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About XFRACAS

ReliaSoft XFRACAS by Hottinger Bruel & Kjaer Inc. is a highly configurable, web-based Failure
Reporting, Analysis and Corrective Action System (FRACAS). Depending on how your imple-
mentation is configured, XFRACAS can include tools for incident/failure reporting, failure analysis
on returned parts, part tracking for serialized systems, root cause analysis, team-based problem res-
olution and tracking of assigned actions. The specific features, field names and behaviors that are
accessible to you will depend on the settings for your implementation.

This guide covers features that may be available to all XFRACAS users. If you have administrative
responsibilities for your implementation, you may also need to consult the following guides:

l Implementation Guide - guidance for an IT admin to prepare the database and web server(s)
and install the website. It also provides tips to help an application admin complete the initial
configuration. Online version | PDF version

l Admin Guide - covers features that are available only to users with administrative permissions.
Online version | PDF version

XFRACAS can also be integrated with other ReliaSoft applications, which provides intelligent
integration between reliability program activities and tools while simultaneously facilitating effect-
ive information sharing and cooperation between engineering teams of any size. Other ReliaSoft
software by Hottinger Bruel & Kjaer Inc. includes Weibull++, BlockSim, Lambda Predict,
XFMEA, RCM++, MPC, and SEP.
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Tip: Click the Print icon to save any help topic as a PDF or to print it to a device from your
browser.

Technical Support

The configurable settings for your XFRACAS implementation will be set and maintained by users
with administrative permissions within XFRACAS. If you have questions about these settings, the
About page in XFRACAS (Options > Help > About) displays the name and e-mail address for
your primary administrative contact.

For organizations with an active maintenance agreement, we provide technical support for soft-
ware-related issues via a network of regional offices and partners/distributors throughout the world.
Visit http://www.reliasoft.com/about/contact-us to get contact details for technical support world-
wide.

When Requesting Tech Support

When you contact us to request technical support, please be prepared to provide the following
information:

l Your phone number and e-mail address.

l The build version of your implementation (displayed on the About page).

l The name and version of your web browser.

l What you were doing when the problem occurred and exactly what happened. Please include
the specific wording of any message(s) that appeared.

Note: Technical support representatives are not reliability consultants. Their assistance is lim-
ited to technical issues that you may encounter with the software tools.
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You must access XFRACAS from a computer that has been logged in to the network using a valid
domain\username and password. In addition, you must have been granted access to XFRACAS by
an application admin.

Requesting Account Access

If you do not have permission to access XFRACAS, when you attempt to open a page, you'll see a
message stating that your username is unknown.

l To request access, click Request XFRACAS Account. This opens the New User page, with
your network login pre-populated. Enter additional information as appropriate; fields shown
with red borders are required.

l To request access to multiple entities (business units), hold the CTRL key and click your selec-
tions.

When you choose Options > Request Entity > Send, an e-mail notice will be sent to the admin of
each entity that you request access to. In addition, you will receive a confirmation e-mail.

PAGE 3



XFRACAS USER 2021 GUIDE

Tip: If the XFRACAS Update in Progress error message displays when you attempt to access the
website and you have reason to believe that no update is in progress (e.g., other users can
access XFRACAS), verify that the domain part of your login is present (domain\username).

Conditions for Account Suspension

New in Version 2021, depending on the configurable settings for your XFRACAS imple-
mentation, your account access may be disabled after a period of inactivity (e.g., 30 days). In this
case, you will receive an e-mail notifying you that you must log in within a specified number of
days to maintain access.

If this feature is implemented, you will be required to accept the Terms of Use Agreement each
time you log in.

Optimum Browser Settings

Supported Browsers and Requirements

XFRACAS is compatible with most commonly used browsers — including Google Chrome, Moz-
illa Firefox and Microsoft Internet Explorer (IE) — that support the following doctype:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

However, if you are using IE, version 11 is required; earlier versions are no longer supported.

If necessary, make the following changes to your browser’s security and privacy settings for your
website (e.g., http://xfracas.reliasoft.com) to ensure that XFRACAS functions correctly:

l Allow pop-up windows to display. Since most browsers now block pop-ups by default, you
may need to change this setting. If you have a third-party ad blocker installed, you’ll need to
disable it for your XFRACAS website.

l Allow cookie data to be saved and read.

Additional Settings for Firefox

Follow these instructions to use XFRACAS in Firefox without encountering security warnings and
other messages.
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Note: These instructions were prepared using Firefox 80. If you are using another version of the
browser, the appearance of the windows may vary.

1. In Firefox, type about:config in the address bar and press ENTER. If you see a warning,
click to continue.

2. In the Search field, type ntlm-auth.

3. Double-click network.automatic-ntlm-auth.trusted-uris (you can also click the Edit icon
for this field).

4. Type the URL for the XFRACAS website (e.g., http://xfracas.reliasoft.com) in the text field
and click the Save (check) icon.

5. Close the Advanced Preferences tab.

User Information

Your user information is initially based on what you specify when requesting access to
XFRACAS, or what an application admin enters when giving you access to XFRACAS. You can
view or change this information by choosing Options > Settings > User Information.

Note that your user information is applied system-wide and is not entity specific.
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At a minimum, you must supply a first name, last name and e-mail address. You must also specify
a default entity, which is the entity that is selected by default as the current entity when you first
access XFRACAS. The entity for subsequent screens is based on either the last screen or the entity
of the record that you are viewing.

If desired, you can click the Edit icon, , to add an image that will be associated with your user
account.

To save your changes, choose Options > User Information > Save.
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Entities

XFRACAS can be configured with a single entity (where all users share the same configuration set-
tings and data) or with multiple entities (where each entity has its own separate permissions, set-
tings and data).

If your implementation has more than one entity, your user account specifies which entit(ies) you
can access, and which will be active by default each time you visit XFRACAS. Configurable set-
tings (e.g., field names) and your personal permissions may differ in each entity that you use. Ana-
lysis data (e.g., system templates, serialized systems, incidents, etc.) is separate for each entity.

Identifying the Entity

When applicable, a drop-down list at the top of the page allows you to select which entity is cur-
rently active. Remember that you cannot change the entity for a new system template, serialized
system or record (e.g., incident, problem, etc.) after it is created.

When you are viewing a record that already belongs to a particular entity, the name of the entity
will be displayed at the top of the page and the entity will also be reflected in the prefix for the
record number.
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Requesting Access to an Entity

To request access to an entity, choose Options > Settings > Request Entity Access.

On the Request Entity Access page, the Entities field will display the entities that you do not
already have access to. To request access to multiple entities, hold the CTRL key and click your
selections.

To send your request to an application admin, choose Options > Request Entity > Send.

Record Types

XFRACAS is highly configurable to fit your organization's needs, processes and terminology. Vari-
ous types of records may be used in your implementation, depending on its configuration. If your
implementation has more than one entity, these records will be managed separately in each.

l Customer support records. If you are tracking serialized systems, a customer support record
(CSI) can be used to capture a detailed history for each piece of equipment, such as customer
contact information, installation details, reported incidents, operating time and the current status
of the system.
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l Incident records. An incident captures information for a single occurrence of an issue (e.g.,
failure, planned downing event, customer request, etc.) and allows you to track how it is
addressed.

l Failure analysis record. If parts were repaired or replaced during an incident, a failure ana-
lysis report can be used to capture the details of failure analysis and remanufacturing activities.

l Problem records. When multiple incidents are attributed to the same underlying issue, a prob-
lem (called "PRR in prior versions of XFRACAS) can be used to link all instances to a single
report and facilitate a team-based approach to understand the root cause and take actions to pre-
vent similar issues from recurring in the future.

l Project records. In much the same way that problems are used to manage related incident
reports, projects can be used to manage related problems.

l Action records. Throughout XFRACAS, you can create actions that must be performed to
address a specific incident, failure analysis report, problem, project or CSI.

Changing Record Numbers

When you create a new record, XFRACAS automatically assigns it a number. This number
includes a prefix that is configured by an admin user and typically corresponds to the entity and
record type (e.g., "ENT-I-" for incidents, "ENT-P-" for problems, etc.).

Users with the "Manage Entities" permission can change this number for an existing record if
needed.

1. Open the record in XFRACAS.

2. If you have the required permission, the record number, which appears near the top-left corner
of the screen, will display as a hyperlink. Click this link.

3. In the Edit Record # dialog box, type the new record number and click Save.

PAGE 10



WORKING IN XFRACAS

The new record number must be unique throughout the database. Although it can be part of the
auto-generated sequence, that's not a requirement.

l If you enter a record number that would be otherwise be used in a future auto-generated
sequence, the sequence will be updated so the next record uses the next value. For example, if
the last auto-generated record number was ENT-I-305 and you change an existing record to
ENT-I-307, then the next auto-generated record number would be ENT-I-308.

l Likewise, if there is a gap in the auto-generated sequence, you can use this feature to assign
unused record numbers. For example, in the scenario described above, you could change
another record to ENT-I-306.

Tip: Note that changing the record number may also change the name of the folder where your
uploaded file attachments are stored. This applies if your implementation is configured to store
attachments on a server rather than in the database. In this case, changing the record number
will also change the name of the folder where the files that are attached to the record are
stored.

Fields and Lists

Your XFRACAS implementation has been customized by an application admin to capture inform-
ation that is relevant to your organization’s specific needs. Therefore, this guide may refer to fields
and features that differ from those you’ll see when working in a given entity. The fields that are
available for each record type will depend on several factors:

l The configurable settings for the entity, which determine which fields are enabled, how they
are named and how your organization uses them. For example, your organization may refer to
problems as “corrective actions.”

l Whether the record is new or existing.
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Drop-down lists are one type of field that may be customized by an application admin. If an option
within a drop-down list is enclosed within brackets [], it has been “retired,” indicating that it was in
use at one time but has been discontinued. Retired list options may appear in existing records
because XFRACAS stores the data associated with them; however, they will not be available
when creating new records.

Brackets are also used in the Owner drop-down list in problems and projects to indicate that a user
no longer has the "owner" designation.

Security Levels

New in Version 2021, XFRACAS now supports the use of security levels to restrict specified
users from accessing certain incident, problem, project and CSI records within an entity. These
levels are defined by an application admin based on your organization’s security policies.

If this feature has been implemented for a given record type, then all records of that type will con-
tain one or more “security level” drop-down lists. An application admin defines the names of these
lists and determines where they appear in the record — e.g., in an incident, they may appear in the
System/Component Information, Incident Disposition, Incident Repair and/or Incident
Details sections.

l To assign a security level to a new or existing record, select it from the drop-down list. Once
the record is saved, it can only be accessed by users who have been assigned this security
level.

l To allow users to retain their access to an existing record, simply leave the security level unse-
lected (this is the default behavior).

Note that action and failure analysis records inherit the security level of the parent record (e.g., an
incident action can only be accessed by those who can view the parent incident).
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EXAMPLE
Let’s assume that security levels have been defined for your company’s three major geographic
divisions — Eastern, Western and Central — for use in incidents. These levels appear in a drop-
down list named Regions. In this case, selecting the Eastern option from the Regions drop-down
will ensure that users from the other two divisions cannot access this record, nor can they access
any actions or failure analysis records associated with the record.

How Security Levels Affect What’s Displayed

In most cases, you’ll only see links to records that you can access based on your personal security
settings. Clicking a link to a record that you cannot access will trigger an error message.

l Reports only include links to records that you can access (applies to standard reports as well as
custom reports that are based on standard reports).

Note: Reports are generated based on each user’s security settings; therefore, two users
running the same report will see a different set of records if their security settings differ.

l Charts may include data for records that you cannot access, depending on the record type:

l Incident, problem, project, and CSI charts are filtered to exclude any data you cannot
access, but action and failure analysis charts will display aggregated data that includes
records you do not have permission to view.

l In either case, any records that you cannot access are always excluded from results when
you drill down.

l E-mail alerts and the tasks list in the XFRACAS portalmay contain links to records that you
cannot access. Clicking one of these links .

In addition, certain fields will not be displayed if security levels are defined in the entity:

l TheMake Public option, when you are saving reports and charts.

l The Enter E-mail Address Manually field in the Send E-mail utility.

Associated Files

Security settings also determine which records can be linked to another record via the Attachments
utility. The following restrictions apply when you select XFRACAS ID from the Data Source
Type drop-down list in the Associated Files dialog:
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l You can only associate records that you have permission to view; if you try to link to a record
that you cannot access, an error message will appear.

l The Incident Search dialog will only display records that you can access.

Home Tab

The Home tab of the ribbon contains the following commands:

Portal

XFRACAS opens the XFRACAS Portal page.

SEP opens the SEP web portal, if it has been implemented.

View

Reports opens the Reports page, which allows you to generate results for a variety of pre-
defined reports.

Charts opens the Charts page, which allows you to generate results for a variety of pre-
defined chart reports.

Dashboard opens the XFRACAS Dashboard page, which displays a predefined set of
reports and charts.

Create

Incident opens the Incident page to create a new incident.

Problem opens the Problem page to create a new problem.

Project opens the Project page to create a new project.

Customer Support opens the CSI page to create a record that keeps track of information for
a particular serialized system.
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Record Groups

When you are working with a record (e.g., incident, problem, etc.), the Home tab will also contain
a group of commands appropriate to the record type.

When you are creating a record, the following commands may appear:

Create saves the new record once you have entered all required information. For incidents
and CSIs, this command is available only when you are working with a single form, not when
you are using the Wizard.

Use Incident Wizard switches to the Incident Wizard to guide you through the steps of cre-
ating the incident report. This command is available depending on the settings chosen by an
application admin, and only when creating a new incident report.

Use CSI Wizard switches to the CSI Wizard to guide you through the steps of creating the
CSI record. This command is available depending on the settings chosen by an application
admin, and only when creating a new CSI record.

Use Single Form switches to the single form view of the Incident page. This command is
available only when creating a new incident report.

Use Single Form switches to the single form view of the CSI page. This command is avail-
able only when creating a new CSI record.

When you are working with an existing record, the following commands may appear:

Save saves the current record.

Completed marks the current action as completed and saves it. This command is available
only for actions.

Reopen opens a currently closed record. This command is available for incidents, problems,
projects and actions, depending upon your permissions.

Print Preview allows you to view how the current record will appear on the printed page.

Duplicate creates a copy of the current record. This command is available only for incidents
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and CSI records. Note that the copy is not automatically saved, but you can modify the new
record and then choose Home > [Incident/CSI] > Create to save it.

Export exports the current record to a new *.xml file.

Create Linked Action opens the Create Action utility, allowing you to create a new action
associated with the current action. This command is available only for action records.

E-mail URL opens the Send E-mail utility, allowing you to send an e-mail message, includ-
ing the URL of the current record, to selected system users. This command is available for all
record types except actions.

E-mail Team URL opens the Send E-mail utility, allowing you to send an e-mail message,
including the URL of the current record, to selected system users, with the team members for
the record preselected in the utility. This command is available for incidents, problems and pro-
jects that have team members specified.

Copy URL displays the URL of the current record, allowing you to copy the URL to the clip-
board for use in other locations.

Delete deletes the current record. This command is available for all record types, depending
upon your permissions. There is no undo for delete.

Portal Link

Save/Update saves changes to a new or existing link.

Delete deletes the current link. There is no undo for delete.

Announcement

Save/Update saves changes to a new or existing announcement.

Delete deletes the current announcement. There is no undo for delete.
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Options Tab

The Options tab of the ribbon contains the following commands:

Designers

Report Builder opens the Report Builder page, which allows you to create your own reports
and charts with custom criteria and information.

Dashboard Designer opens the Dashboard Designer page, which allows you to change the
content and arrangement of the reports and charts that appear on the Dashboard page.

Settings

Portal Preferences opens the Portal Preferences page, which allows you configure the
information shown on the XFRACAS Portal page.

User Information opens the User Information page, which allows you to specify the inform-
ation about you used in the system.

Request Entity Access opens the Request Entity Access page, which allows you to request
access to any of the entities within XFRACAS.

Help

Help opens the online help topic for the current page.

Contents opens the online help file to its home page.

Admin Contents opens the administrative help file.

New User Intro opens a page with basic information about accessing the system.

About opens the About XFRACAS page, which provides licensing and version information
for XFRACAS.
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Portal Preferences

If you are working on the XFRACAS Portal page:

Save saves the changes you have made to the Portal preferences.

Load Application Defaults returns to the default Portal preference settings.

User Information

If you are working on the User Information page:

Save saves the changes you have made to user information.

Request Entity

If you are working on the Request Entity Access page:

Send sends your request for entity access to an application admin.

Report

If you are working on the Report Builder page:

Generate generates the results for the Report Builder without saving the settings.

Save saves the current Report Builder settings using the current report name.

Save As saves the current Report Builder settings using a name, description and icon that you
specify.

Part Search allows you to search for a template part by part description.

Serialized Search allows you to search for a serialized part by system serial number or sub-
system serial number and then opens the system configuration in the Serialized page.
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Dashboard

If you are working on the Dashboard Designer page:

Generate generates the reports specified in the Dashboard Designer without saving the layout
settings.

Save saves the current settings using the current layout name.

Save As saves the current settings using a layout name that you specify.

Quick Search

The Quick Search box, located in the top-right corner of a page, provides a quick way to open an
existing incident, problem, action, project, failure analysis report or customer support record.

Select the type of record from the drop-down list and then type the relevant identifier:

l Problem #, Incident #, Customer #, Failure Analysis # or Project # - type the record's dis-
play ID with or without the entity prefix (e.g., ENT-I-301 or 301). If you do not include the
entity prefix, it will search only within the current entity. If you include the prefix, it will search
for an exact match in all entities that you have permission to access.

l Action # - type an action number, which is unique across all entities.
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l Serial Number # - type the serial number of a serialized system that has a customer support
record. If an exact match is not found, XFRACAS displays a list of all CSIs in the current
entity.

l RMA Number - type the RMA number of a part that has a failure analysis record.

XFRACAS Portal

The XFRACAS Portal displays announcements and tasks that are relevant to you. The display
depends on your Portal Preferences. If your implementation has more than one entity, the display
may also depend on which entity is currently selected from the list at the top of the page.

To access the portal, choose Home > Portal > XFRACAS.

Announcements

For each announcement, an icon indicates whether it is public or private  .

Edit Announcements opens a page where you can create, edit or delete announcements that
you have permission to manage. (See Announcements.)

Announcements History displays a list of all your public and private announcements, includ-
ing any that are "expired" (i.e., today's date does not fall in the range of dates when the
announcement was configured to start and stop displaying).

Tasks

The quantity in parentheses indicates the total possible number of items that could be displayed in
your portal for each type of task — e.g., the total number of unclosed incidents or open problems
that you own. Some or all of these items may be displayed in the tables; the actual number depends
on the settings in your Portal Preferences page. To view all records in the Report Results page,
click the quantity link.

Tip: If applicable, a label above the table also indicates how many of those tasks are "due" and
their dates will be highlighted in red. A task is "due" if the date falls within the offset specified
by an application admin for that type of record. For example, if the offset for incidents is 15
days, an incident will be "due" if today's date is => 15 days after the occurrence date.
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l Open ReliaSoft Desktop Actions - ReliaSoft desktop actions that are not completed and that
you are responsible for (i.e., you are the Person Responsible). This type of task is available
only if the database is used with ReliaSoft desktop applications and you have an active user
account.

l Uncompleted Actions - XFRACAS actions that have not been completed and that you own
(i.e., you are the assigned Owner).

l Unclosed Incidents - incidents that have not been closed and that you own.

l TeamMember Unclosed Incidents - incidents that have not been closed and that you have
been assigned to as a Team member.

l Open Problems - problems that have not been closed and that you own.

l TeamMember Open Problems - problems that have not been closed and that you have been
assigned to as a TeamMember.

l Problems to Review - problems in which you are assigned to review and sign off on a step.
(See Failure Review Boards.)

l My Projects - projects that have not been closed and that you own.

l TeamMember Projects - projects that have not been closed and that you have been assigned
to as a TeamMember.

Portal Preferences

Use the Portal Preferences page to customize which items are displayed in your XFRACAS Portal
and Links panel.

If you have permission to edit portal preferences, you can click the icon in the Tasks section of
the portal or choose Options > Settings > Portal Preferences.

Default vs. Saved Preferences

The default portal preferences are managed separately for each entity. If you have not saved
changes to your own personal portal preferences, your portal will use the default settings for the
entity that you are currently viewing, and those settings may differ for each entity.
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Alternatively, if you choose to save your own personal portal preferences, they will be the same for
any entity that you view. To do this, make the desired changes in the Portal Preferences page and
then choose Options > Portal Preferences > Save.

Tip: If you have the "Portal - Set Default Portal Preferences" permission for the entity that you
are currently viewing, Save as application default will display at the top of the page. If this
check box is selected when you click Save, the changes will be saved as the defaults for that
entity and also saved as your own personal preferences for all entities.

To return to using the defaults for each entity, choose Options > Portal Preferences > Load
Application Defaults.

Show All, None or Show Only

For links, announcements and each type of task, you can choose from the following options:

l Show All - displays all items of that type, and they will be sorted from the newest to the oldest
date.

l None - the section will not display, even if there are items of that type.

l Show Only - displays no more than the specified quantity of items (from 1 - 99). You can
choose whether to show items with the Newest orOldest dates.

Display Order

For each type of task, the Display Order sets the order in which that section will display on the
portal page.

To hide sections for task types that do not contain any items, set Display Empty Portal Sections
to "Yes."

Display My Entities

The Display My Entities option is relevant if you have access to more than one entity.
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l Show All - displays items from all entities that you have access to.

l Show Current - displays items only from the entity that is currently selected at the top of the
page.

Display My Report on Load

You have the option to run your own custom report when the XFRACAS Portal page loads. To
enable this feature, set Display My Report On Load to "On" and use the drop-down to select any
of the saved templates from your list of "My Reports."

The Interval field determines how frequently the report runs. If set to 0, the report will run each
time you load the portal page. If the interval is greater than 0, the report will run only if it has been
at least that many hours since the last time the report ran. For example, if you want the report to run
no more than once a day, set the interval to 24 hours.

Links Panel

The Links panel (displayed on the left side of most pages in XFRACAS) provides quick and con-
venient access to selected reports and charts and can include any uniform resource locator (URL)
that can be accessed via a web browser.

This panel may contain personal links that are visible only to you as well as public links that are vis-
ible to all users in a specified entity.

To manage your links, click Edit Links in the upper right corner of the panel.

Creating, Updating or Deleting a Link

l To create a new link, select the blank option in the Select Link to Edit list and then enter at
least the required fields and click Home > Portal Link > Save.

l To edit an existing link, select it from the list, make the desired changes and click Home >
Portal Link > Update.

l To delete an existing link, select it from the list and click Home > Portal Link > Delete.
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Link Properties

l Title - the anchor text that is visible in the page.

l Type - in addition to URL (which is always available), this list also includes any type of report
or chart that you can view in the Reports and Charts pages (e.g., Standard Reports, My
Reports, Public Reports, etc.). After you select the type, enter the URL or select a specific
Saved Report.

l Group - the options depend on the entity's configurable settings. The quantity of links dis-
played in each group depends on the Portal Preferences.

l Display Order - sets the display order within the selected group.

l Start Displaying At and Stop Displaying After - a date range when the link will be visible. If
not specified, the link will be visible immediately and will remain visible unless it is manually
deleted.

l Display to Public - if selected, the link will be visible to all users in the specified entit(ies).
The ability to manage public links is available only to users with the "Portal - Create Public
Links and Announcement" and "Portal - Modify Public Links and Announcements" per-
missions.

l Owner - the user who created the link.

l Entities - the entit(ies) where the link will be visible.

Announcements

The Announcements section in your XFRACAS Portal may contain two types of announcements:

Public announcements are visible to all users in specified entit(ies).

Private announcements are visible only to you.

All XFRACAS users can create and manage their own private announcements. Only users with
specific permissions are able to create and modify public announcements.

Depending on the Portal Preferences, your portal may show some or all of your announcements,
either from the entity that is currently selected or from all entities that you have access to.
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Announcements may be configured to display only within a specified date range. If today's date
does not fall within the specified range, the announcement will not show in your portal, but you
can continue to access "expired" announcements via the Update Announcement and Announce-
ment History pages.

Create, Update or Stop Displaying an Announcement

l To manage your announcements, click Edit Announcements in your portal.

l To create a new announcement, select the blank option in the Select Announcement to Edit
list then enter at least the required fields and click Home > Announcement > Save.

l To edit an existing announcement, select it from the list then make the desired changes and
click Home > Announcement > Update.

l To stop displaying an announcement, select it from the list, specify a date in the Stop Dis-
playing After field (< today's date) and click Home > Announcement > Update.

Tip: For users with the "Portal - Modify Public Links and Announcements" permission, you can
permanently delete an announcement by selecting it from the list and clicking Home >
Announcement > Delete.

Announcement Properties

l Title and Description - text that is visible in the portal.

l Display Order - the sequence among all public and private announcements in your portal.

l Start Displaying At and Stop Displaying After - a date range when the announcement will
be visible in your portal. If not specified, it will be visible immediately and will remain visible
unless it is manually deleted.

l Display to Public - if selected, the announcement will be visible to all users in the specified
entit(ies). Only users with the "Portal - Create Public Links and Announcements" permission
can create public announcements.

l Owner - the user who created the announcement. Only users with the "Portal - Modify Public
Links and Announcements" permission can edit a public announcement that was created by
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another user.

l Entities - the entit(ies) where the announcement will be visible.

Announcement History

To view a list of all your announcements, including those that have "expired," click Announce-
ments History in your portal.

In the Announcement History page:

l If the image in the first column is a solid square, clicking it opens the page where you can view
or edit the properties. If the image is an outline, you do not have permission to edit the prop-
erties.

l To sort by any of the columns, click the column header.

Tracking Record Views and Changes
Tracking Views

New in Version 2021, XFRACAS now allows you to generate reports showing who has viewed
transactional records.

Your Reports page may already include links to reports that have been configured to display
"view" information; if not, you can easily add this info to any standard incident, problem, project,
CSI, action or failure analysis report as follows:

1. Open the Report Builder page (Options > Designers > Report Builder).

2. In the Select Report drop-down, choose Standard Report and one of the following record
types:

l Incident

l Problem

l Project

l CSI
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l Action

l Failure Analysis

3. Configure the report as you normally would and use the Additional Fields drop-down list to
add the Viewed and Viewed By fields. Be sure to enable the Show option for each.

4. Click Generate to build the report. The “Viewed” and “Viewed By” columns should be pop-
ulated for any record that has been opened at least once.

l “Viewed” indicates when the record was viewed, in UTC date-time format.

l “Viewed By” indicates who viewed the record, in last name / first name format.

5. If desired, save the report for future use.

Note that the report may include multiple instances of the same record (one for each view).

Getting Notified when Records Are Updated

New in Version 2021, XFRACAS now allows you to receive a daily e-mail digest containing a list
of incident, problem, project and CSI records that have changed since the last digest was sent. This
feature requires the XFRACAS Data Import Utility to be running (see DIU Service in the Admin
help for more information).

To receive this digest, you’ll need to subscribe to notifications for each individual record you’d like
to “follow.” You can do this by clicking the Subscribe icon in the title bar of the record's summary
area.

The e-mail is sent only when at least one of these records has been updated since the last digest
was sent. It will include links to view and unsubscribe from each record, as well as a link to unsub-
scribe from all records.

You can also unsubscribe directly from within the record by clicking the Unsubscribe icon.

Note: Separate digests are sent for each entity; therefore, if you have subscribed to records in
multiple entities, may receive more than one digest.
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A Note About Time Zones

Depending on the configurable settings for the current entity, date fields may be displayed with
associated time fields. If this is the case, the time fields include a time zone field. All times are
saved in the database using Coordinated Universal Time (UTC), formerly known as Greenwich
Mean Time (GMT) — the current time at 0º longitude. This allows users in various time zones to
log and view events accurately and easily.

For example, if an incident is created in Tucson, Arizona, and later referenced in Kuala Lumpur,
Malaysia, the 15-hour difference could cause confusion. The incident is created at 2:38 PM on
March 9, 2017, in Tucson with an occurrence date of March 8, 2017 - 10:30 PM. These times are
saved into the database as "2017-03-09 21:38" and "2017-03-09 05:30" respectively. Since Tuc-
son is in time zone -7, 7 hours have been added to each date/time to get the UTC time. You can
see that this changed the date as well as the time of the occurrence date. When redisplayed in Tuc-
son, the date/times are adjusted by subtracting 7 hours.

If someone in Tucson ran a search for this incident, they could specify an occurrence date of
March 8, 2017, with times between 10:00 PM and 11:00 PM. However, if someone in Kuala Lum-
pur ran the same search, their results would not include this incident because their local time is in
time zone +8. They could get the desired result by simply setting the occurrence date time zone for
the query to Tucson's -7 time zone. If the user in Kuala Lumpur were then to edit the incident,
because all information is saved as UTC, the information would be just as easy to find again in Tuc-
son.

To change the default time zone for your user account, choose Options > Settings > User Inform-
ation.
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Common Utilities

IN THIS CHAPTER
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XFRACAS features several “utilities” that appear in one or more types of records and/or reports.
Note that some of these utilities may not be visible to you, depending on your user permissions and
the configurable settings for your organization’s XFRACAS implementation. In addition, their
appearance may differ slightly depending on where you access them.
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l Attachments - allows you to link files, text, a URL, or another record to the current record

l Send E-mail Utility - sends an e-mail that includes a link to the current record

l Select Existing Utility - allows you to reuse text from other records

l Assign TeamMembers Utility - allows you to assign users to a team

l Status Fields - allows you to document the progress of an issue or assignment

l Part and Serial Number Selection Utilities - allows you to choose parts for incidents and seri-
alized systems for incident and customer support (CSI) records

l Serialized Page - displays serialized system configurations

Attachments

An Associated Files field (aka "attachments table") enables you to conveniently link supporting
files and references for an XFRACAS record. Depending on the configurable settings for the
entity, this type of field may be available in incidents, problems, failure analysis reports, actions or
customer support records.
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Use the icons on the right side of the table to add , edit or remove associated files. The
properties depend on the Data Source Type. For all types, the Name is required and Description
is optional. The Section drop-down list identifies which attachments table will show the attach-
ment. If there are multiple tables in the same record, you can use this field to move the attachment
to another section.

Uploaded File

If the Uploaded File type is enabled for your implementation, you can use the Associated File field
to browse for and upload a copy of a file. Depending on the configurable settings, the file will
either be saved as a blob in the database or stored in a specified folder on the web server.

Note that if you import or export a record that has an uploaded file attachment, the XML file will
contain the blob ID or the database path.

URL

The URL type is always available. Use the URL field to type a uniform resource locator that can
be opened via a web browser (e.g., http://www.reliasoft.com).

Text

The Text type is always available. Use it to attach text notes or references for the record (similar to
a list of citations in the bibliography of a report).

XFRACAS Record

The XFRACAS Record type is always available. This creates either a one-way link or a two-way
link to another XFRACAS record.

After you have selected the XFRACAS Type (incident, problem, failure analysis, action or cus-
tomer support), you can specify the XFRACAS ID for an existing record of that type. To view a
list of records of that type in the current entity, click Find, .

Reciprocal Section determines whether the link will be one-way or two-way. If None, the attach-
ment will link only from the current record to the other record. If you specify a reciprocal section
(i.e., select the name of an attachments table in the other record), the other record will also link
back to the current record. The name and description will be the same for the links in both records.
If you remove a reciprocal link from either record, it will be removed from both.

The optional Relationship Type field adds a text label in the attachment type column of the table.
The options depend on the configurable settings for the current entity. If it is a reciprocal (two-way)
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link, the current record will display the label you have selected (e.g., "Master") and the other
record will display the corresponding label (e.g., "Sub").

Note that if you import or export a record that has an XFRACAS Record attachment, the XML file
will contain the ID for the other record (one-way link) but it will not contain the reciprocal section
(two-way link).

Send E-mail Utility

The Send E-mail utility allows you to send an e-mail that includes a link to the current record.

Open the Utility

To open this utility when you are working with an incident, failure analysis report, problem, pro-
ject or CSI record, choose Home > [Record Type] > E-mail URL or, if team members have been
added for the record, Home > [Record Type] > E-mail Team URL.

Clicking a user name in the TeamMembers field of the Incident, Problem and Project pages will
also open this utility.

Choose E-mail Address(es)

Choose the source for available e-mail addresses from the E-mail Address Source drop-down list.
Options include:

l XFRACAS User List

l Enter E-mail Address Manually - to prevent unauthorized users from accessing the record,
this option will not be available if security levels have been defined for the entity (see Security
Levels)

l TeamMembers - this option will be preselected if you opened the utility using the E-mail
Team URL command; if you opened the utility by clicking a team member name, that name
will be pre-selected

You may also be able to select users from a global address list from an Exchange server, depend-
ing on how the Exchange preferences are set up.
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When you are working with a user list, you can double-click a user in the list on the left to add
them to the To: area on the right, which displays a list of the users who have been selected to
receive the e-mail. At least one user is required in this recipient list in order to send the e-mail. You
can also use the TO >, CC > and BCC > buttons to add the selected user(s) to the corresponding
area on the right. Double-click a user in a recipient list to remove it from the list.
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Enter Your Message

You can enter a message in theMessage field at the bottom of the window. This message will
appear in the body of the e-mail along with the link to the record and/or a printer-friendly view of
the record, depending on your selection in the Include field.

Send the E-mail

Click Send to send the e-mail to the selected users.

Select Existing Utility

The Select Existing utility allows you to find and reuse text from the same field in other existing
records. This can help save time on data entry, ensure consistency and facilitate brainstorming.

This utility may be available if it has been enabled for a particular description or status field and if
you have permission to use this feature for a particular record type.

Searching for Existing Text

1. Use the drop-down list in the Search area to specify how to match the specified keywords,
and then type the keywords into the input box.

l = returns descriptions where the exact string entered matches the whole field.

l Contains returns descriptions that contain the exact string entered.

l Begins With returns descriptions where the exact string entered appears at the start of the
field.

l Ends With returns descriptions where the exact string entered appears at the end of the
field.

2. In the Entities area, select which entities you want to look in for the text.
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3. Click the Search icon, , to display the matching results in the Text area.

4. Select the desired text, then click OK.

Assign Team Members Utility

The Assign TeamMembers Utility will be displayed when you click the Assign/Remove Mem-
bers icon for the TeamMembers field on the Incident, Problem or Project page.

You can assign users to the team individually, or in user groups. User groups can be defined by an
application admin to provide a convenient way to add multiple users who commonly work
together.
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To add an individual user to the team:

1. Select a role that the user will fulfill from the TeamMember Role drop-down list.

2. Select the user from the Users list, which displays users that are not already on the team.

3. Click Add TeamMember.

To add a predefined group of users to the team:

1. Select the user group from the User Groups drop-down list. The members of the group, and
the roles that they fulfill in that group, will be displayed in the Group Members area.

2. Click Add Group Members.

To remove a team member, select the user in the Current TeamMembers list and click
Remove Selected.

3. Click Save to save the changes in the window.

Note that if the incident or problem displays the Audience Restriction field and the drop-down list
is set to "Attorney/Client Privilege," you will not be able to save any changes to the team until a
user is assigned to the legal role. To be eligible for this role, the user's account must be assigned to
the "Legal Expert" category.

Status Fields

A Status field allows users to add notes about the progress made for a particular issue or assign-
ment, and also send e-mail notifications if applicable.

Depending on the configurable settings for an entity, these fields may appear in incidents, failure
analysis reports, problems, actions, projects or CSIs. Within each status field, the notes/updates will
be displayed in order based on the creation date (either ascending or descending, depending on the
configurable preference).

Add creates a new note that will be added to the list.
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Editmodifies the note that is currently selected.

When you create a new status note or edit an existing one, the utility may include E-mail Notify
check boxes that determine which user(s) will receive an e-mail notification when you click Save.

The e-mail options depend on the record type (incident, problem, etc.) and the configurable settings
for the entity. For each record type, an application admin can determine which check boxes are
available, which check boxes are selected by default, and what information is included in the noti-
fication e-mails.

Part and Serial Number Selection Utilities

XFRACAS provides utilities to help you choose serialized systems for incident and customer sup-
port (CSI) records. A similar utility allows you to select parts for part incidents.
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Serialized Incidents and CSI Records

You can choose a system based on its serial number or on a part.

To choose a system from a list of serial numbers:

1. Leave both the SerialNumber and Part Number fields blank and click the Find icon, ,
next to the Serial Number field.

2. In the dialog box that appears, choose a serial number from the Available Parts drop-down
list, which contains all of the serialized systems that have been created for your entity.

3. Click Select to update the record.

To choose a system from a list of parts:

1. Leave both the SerialNumber and Part Number fields blank and click the Find icon, ,
next to the Part Number field.
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2. In the dialog window that appears, choose a part from the Available Parts drop-down list,
which contains all of the system templates (top-level parts) that have been created for your
entity.

l If you select a part that is associated with more than one serialized system, you will be
provided with a list of systems to choose from. In this case, click Select to close the dialog
box and then click Select again to update the record.

l If you select a part that is not associated with a serialized system, XFRACAS will indicate
this. In this case, click Cancel.

To choose a system if you know some or all of a serial or part number:

Type the entire serial or part number, or just a portion of this number, in the appropriate field and
then click the Find button.

l If only one match is found, both the serial and part number will be updated automatically in the
record.

l If multiple matches are found, you will be provided with a list of systems to choose from. In
this case, click Select to update the record.

Part Incidents

To choose a part from a list of all parts in the entity:

1. Leave the Part Number field blank and click the Find icon, .

2. In the dialog box that appears, choose a part number from the Available Part Numbers list.

Note: The Available Part Numbers utility displays the first 1,000 parts in your entity.

3. If necessary, use the Filter tool to find the part:

a. Type the part number or name, or a portion of either, in the Part field, to search all available
parts.

b. Click the Filter button or press Enter.

c. Choose one of the matching parts from the list.

4. Click Select to update the record.
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To choose a part if you know some or all of its name or number:

Type the part name or number, or a portion of either, in the Part Number field and then click the
Find icon, .

l If only one match is found, the part number and name will be updated automatically.

l If multiple matches are found, you will be provided with a list of parts to choose from. In this
case, choose the appropriate part and click Select to update the record.

Serialized Page

The Serialized page allows you to view serialized system configurations. You can open the Seri-
alized page in several ways:

l Click the System Configuration link in the summary area at the top of the Incident page for a
serialized incident.

l Click the System Configuration link in the summary area at the top of the CSI page.

l Choose Options > Report > Serialized Search when working with the Report Builder then
choose the system that you want to view.

System Configuration

The configuration for the selected system appears in the left panel. The part number, part descrip-
tion, version and serial number for each part in the configuration are displayed.
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l To hide or display the parts below a part in the hierarchy, click plus (+) or minus (-).

l To locate a specific part, click the Find part on system link at the top of the hierarchy to
search by part number, part description or serial number.

l If a part in the system configuration has been replaced, it will appear at the bottom of the
hierarchy, with the retired date next to it.

l Retired parts are indicated by .

l To view another serialized system, choose Home > Serialized > Serialized Search. In the
Find System utility that appears, you can search by the system serial number or subsystem
serial number.

Part Details

When you select a part, its details appear in the Information panel on the right side of the page.

New in Version 2021, these details now include accumulated hours and other key information for
parts that have been repaired or replaced. This is especially helpful for tracking these parts across
systems when reusing them. The following information appears for each repair/replace occurrence:

l The part disposition

l Up to three time metrics — e.g., run hours, number of starts, kW run hours, etc. — depending
on the configurable settings for the entity

l A link to the incident where the part was repaired or replaced
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Incidents
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Use the Incident page to record and view information for a single occurrence of an issue (e.g., fail-
ure, planned downing event, customer request, etc.).

If you have permissions to create a new incident, choose Home > Create > Incident.

If the incident wizard is enabled for the current entity, the page will either display all fields in a
single form or a wizard that prompts you to enter data one step at a time. To toggle the display,
choose Use Incident Wizard, , or Use Single Form, .

After you have entered all required fields (highlighted with red boxes), choose Home > Incident >
Create to save the new record.

Note: New in Version 2021, you can subscribe to receive e-mail notifications whenever an incid-
ent, problem, project or CSI record is updated. See Getting Notified when Records Are Updated
for more information.

Entity

If your implementation has more than one entity, the fields and options may be configured dif-
ferently in each. When applicable, a drop-down list at the top of the page allows you to select
which entity is currently active before you create a new record.

Incident Type

Depending on the settings for the current entity, you may choose from up to three incident types.
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l Serialized Incident - an incident for a specific serialized system.

l Part Incident - an incident that is tied only to a part number, not a specific serialized system.

l Simple Incident - an incident that is not tied to any particular serialized system or part number.

Areas and Fields

The fields in the page depend on the incident type and the configurable settings for the entity. The
following topics discuss some types of fields that may be used in each area of the page.

l Incident Summary area - a summary of key details for an existing incident.

l System/Component Information area - in a serialized incident or part incident, information
about the system or part that the incident applies to. (The area will also appear if there are cus-
tom details within this section.)

l Incident Disposition area - information about the incident that occurred or the issue that may
need to be addressed.

l Incident Repair Information area - information about what was done to resolve the issue,
including details for any parts that were repaired, replaced, removed and/or found to be failed.

If an application admin has configured additional fields to meet your organization's specific needs,
they may be integrated into the areas mentioned above or grouped together in a separate Incident
Details area at the bottom of the page.

Serial Number and/or Part Number

In a serialized incident or part incident, there are multiple ways to specify the system or part that the
incident pertains to. (See Part and Serial Number Selection Utilities.)

If the incident is not related to a specific system or part, you can leave the fields blank. Altern-
atively, you can hide the "System/Component Information" area by selecting "Simple Incident" for
the incident type.

If you choose to specify this info, it cannot be changed after the incident is saved.
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Responsible Part(s)

The Responsible Part field identifies the part(s) that caused the incident to occur. This field uses
the system template(s) defined for the current entity.

If the settings for the current entity allow you to select multiple parts, click the Edit icon, , to
view the tree. If the entity is configured to require a single responsible part, you will just see a
drop-down list of parts that have an owner.

Click the History icon, , to view a list of any changes to the responsible part that have been
saved for the incident. (This field is required and cannot be disabled or hidden.)

Incident Owner and Creator

Users who have the required permission can set or modify the incident owner and creator fields
using the drop-down list.

If you create a new incident without selecting the owner or creator, these fields will be set auto-
matically when you save the record:

l Owner will be set to the owner of the first responsible part that has a part owner.

l Creator will be set to the user who created the incident.

Depending on the configurable settings for the entity, the incident owner may receive e-mail noti-
fications when the incident is created, when actions are created for the incident, etc.

Team Members

If enabled for the current entity, the TeamMembers field identifies the users who will be working
on the issue, and their roles on the team. This field is not displayed until the record is created. (See
Assign TeamMembers Utility.)

You can click the link for any team member's name to send an e-mail regarding the record. (See
Send E-Mail Utility.) Depending on the configurable settings for the entity, team members may
also receive e-mails when a status update is added or modified. (See "Status Updates.")
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Tip: If the Audience Restriction field is enabled for the entity and you select "Attorney/Client
Privilege," the record will be visible only to the owner and team members. You will also be
prompted to select a user for the "Legal" role on the team.

Actions

An Actions field contains a list of specific assignments that need to be tracked and completed. If
enabled for the entity, this type of field is not displayed until the record is created.

Click Create New Action, , to add a new assignment for the current incident. (See Actions.)

The table displays the actions that have already been assigned. Click the action number link to
open the action window, or click the expand icon, , to show more of the details in the table. Click

to view the list of actions in a report grid that you can filter, sort, export to Excel, etc.

Status Updates

If enabled for the current entity, a Status field allows users to add notes about the progress made
for the incident, and also send e-mail notifications if applicable. This type of field is not displayed
until the record is created. (See Status Fields.)

Associated Files or Links

If enabled for the current entity, an Associated Files field allows users to upload file attachments,
links to files in another location (e.g., a document management website) or link to another record in
XFRACAS. This type of field is not displayed until the record is created. (See Attachments.)
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Repairing or Replacing Parts

The Repair or Replace Parts feature allows you to list all the parts that were repaired, replaced,
removed or found to be failed due to the incident (if any). If you are extracting data to Weibull++,
this is used to obtain failure and suspension times based on part number. (See Repair or Replace
Parts Utility.)

Assigning an Incident to a Problem

The Assigned to Problem # field in the incident summary links to any problems that the incident
is associated with.
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New Problems

Click Create New Problem, , to create a new problem record and automatically assign the incid-
ent at the same time.

Depending on the configurable settings for the entity, certain fields from the incident may be used
to automatically populate fields in the new problem. These fields include:

l The responsible part, which may be transferred to the problem's Part Category Code field.
Note that this field can only contain a single part; therefore, if the incident has multiple respons-
ible parts, only the first one will be transferred.

l The incident's title, which may be transferred to the problem's Title field.

Existing Problems

Click Assign/Remove Problem, , to assign the incident to an existing problem or change the
problem(s) that the incident is currently assigned to.

Note: New in Version 2021, you can now assign large groups of incidents to a new or existing
problem via an incident report or chart. See Associating Multiple Incidents to Problems from
Reports and Charts to learn more about this feature.

Adding or Editing a Failure Analysis Report (if Applicable)

You can use the Initial Failure Analysis field in the incident to record a summary of the analysis
that was performed in the field to determine which parts to repair or replace. In addition, if you
want to create a more detailed failure analysis report for a particular part after it is returned, click
the New link in the table in the Incident page. If a report already exists for a part, the link will dis-
play the record ID instead.

Closing an Incident

Depending on the settings for the current entity, the incident's State field may contain one or mul-
tiple options to indicate that an incident is closed (e.g., "Closed," "Closed - Insufficient Data," etc.).
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l Only users who have certain permissions can close an incident.

l You may not be able to close an incident until all associated actions are completed and/or all
associated failure analysis reports are closed.

l The incident may be "read-only" after it is closed. When that preference is enabled, only users
with specific permissions will be able to re-open a closed incident.

Tip: If the incident pertains to a serialized system that you are also tracking via the Customer
Support page, we recommend to update the System Status (e.g., "Running," "Down - Waiting
on Part," etc.) before you close the incident. The system status displayed in the CSI page will be
based on all incidents reported for that serialized system.

Incident Summary Area

The Incident Summary area of the Incident page provides a quick at-a-glance summary of key
details for an existing incident. This area is not displayed until the record is created.

l Assign to Problem # - links to the problem(s), if any, that the incident is assigned to. (See
"Assigning an Incident to a Problem.")

l State - the current state of the incident (e.g., "Open," "Closed," etc.).

l Occurrence Date and Reporting Date - the date when the incident occurred and the date
when the record was created.

l Owner - the user who has primary responsibility for the incident.

l Creator, Reporting Org - the user who created the incident and the organization specified in
that person's user account (e.g., "Engineering," "Product Safety," etc.).

l Category - the category assigned to the incident.

l Responsible Part - the generic template part(s) that the incident pertains to.

l Last Updated By and Last Updated - the user who saved the last change for the incident,
and the date/time (if the preference is enabled for the current entity).

If the incident was reported for a specific serialized system:

l System Configuration - links to the full record of assemblies and parts that may be tracked for
the system. (See Serialized page.)
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l System Status - the current operational status of the system (e.g., "Running," "Down - Wait-
ing on Part," etc.)

l Time Metrics - (e.g., "Run Hrs / Starts / kW Hours) - up to three time/usage metrics that were
reported for the system at the time of the incident. Click the link to view a history of all saved
time/usage reports for that system.

l Customer Support # - links to the customer support information (CSI) for the system, if
applicable.

l Unit Location - the location of the system at the time of the incident.

l Distributor and ASP - the distributor and authorized service provider that are currently
assigned in the CSI record for the system, if applicable. Click the links to view the contact
details.

l ASP Field Service Tech - the technician assigned to the incident. Click the link to view the
contact details.

l Response Time - the number of hours between the Occurrence Date and the Service
Response Date. This is only displayed if the Service Response Date is enabled for the entity.

l Downtime - the number of hours between the Occurrence Date and the Completed Date.

System/Component Information Area

The System/Component Information area of the Incident page is displayed only if the incident
type is "Serialized Incident" or "Part Incident" or if there are details within this section.

Serial Number, Part Number and Version - the specific serialized system or part that the incid-
ent pertains to. (See Part and Serial Number Selection Utilities.)

If you choose to specify this info, it cannot be changed after the incident is saved.

l System Status - the current operational status of the system (e.g., "Running," "Down - Wait-
ing on Parts," etc.). This may change over time as you take steps to address the incident. Click
the History icon, , to view a list of all system statuses saved for the incident. This field is
always shown for serialized incidents. An application admin can choose whether to show it for
part incidents.

l Time Metrics - (e.g., "System Hours," "Number of Starts" and "kW Run Hours"). You can
report up to three time/usage metrics for the system at the time of the incident. Depending on
the settings for the current entity, these may be populated or calculated automatically based on
other available information.
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l Unit Location - the location of the system at the time of the incident.

l If this field is enabled for the current entity and you have permission, you can select from a
list of locations predefined by an application admin.

l If you don't specify a location and a customer support information (CSI) record is available
for the system, the same location for the CSI will be assigned to the incident upon save. In
addition, the Incident Occurrence Date must be after the commission date on the CSI and
before the decommission date.

l Under Warranty - if a CSI record is available for the system, this field specifies whether the
system was under warranty at the time of the incident. If you have permission to override the
automatic warranty determination, this will be a radio button that you can change if appro-
priate.

l System Down Event - whether the incident caused system downtime. If a CSI record is avail-
able for the system, this will be used to calculate the estimated hours (i.e., total possible usage
minus the downtime).

Incident Disposition Area

The Incident Disposition area of the Incident page contains information about the incident that
occurred or the issue that may need to be addressed.

l Title and Description - a description of the incident is always required. If enabled for the cur-
rent entity, you can also specify a short title.

l Occurrence Date - the date/time when the incident occurred. (This field is required and can-
not be disabled or hidden.)

l State - the current state of the incident (e.g., "Open," "Under Review," "Closed," etc.). This
may change over time as you proceed to review and address the incident. Click the History
icon, , to view a list of all states that have been saved for the incident. (This field is required
and cannot be disabled or hidden.)

Depending on the configurable settings for the entity, there may be special conditions for the
state(s) that indicate the incident is closed. (See "Closing an Incident.")

l Report Type - how the incident was observed or reported (e.g., "Internal Testing," "Planned
Field Event," etc.). (This field is required and cannot be disabled or hidden.)

l Incident Category - for the purpose of reliability data analysis, some categories may be
"chargeable" (e.g., "Component Failure," "Production Error," etc.) and others may be "non-
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chargeable" (e.g., "Customer Information Request"). (See Repair or Replace Parts Utility.)
(This field is required and cannot be disabled or hidden.)

l Responsible Part - generic template part(s) that the incident pertains to. (See "Responsible
Part(s).") This field is required and cannot be disabled or hidden.

Click the History icon, , to view a list of any changes to the responsible part that have been
saved for the incident.

l Owner and Creator - if you do not specify the owner and creator, they will be set auto-
matically upon save. (See "Incident Owner and Creator.")

l TeamMembers - the users who will be working on the incident, and their roles on the team.
(See "TeamMembers.")

l Actions - the specific assignments that need to be tracked and completed in order to address
the incident. (See "Actions.")

l Failure Mode - if enabled for the current entity, the failure mode and root cause responsible
for the incident.

l Potential Criticality and Actual Criticality - if enabled for the current entity, criticality met-
rics are calculated based on the selections in the drop-down lists (e.g., schedule, cost, etc.) and
the formulas specified by a system administrator. (See Configuring Criticality Metrics in the
admin documentation.)

Incident Repair Information Area

The Incident Repair Information area of the Incident page contains information about what was
done to resolve the issue, including details for any parts that were repaired, replaced, removed
and/or found to be failed.

l Service Response Date - the date/time when someone first responded to the incident.

l ASP Field Service Tech - the technician who performed the repairs. If this field is enabled for
the entity, you can select from a list of contacts predefined by an application admin.

l Status of Troubleshooting - notes about the progress made to address the incident. (See
Status Fields.)

l Resolution - describes how the incident was addressed.

l Completed Date - the date/time when the incident was resolved.
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l Repair Duration - the time (in hours) to complete the repair. If you are extracting data to
Weibull++, this field will be extracted to the StateTimeRestore column and can be used to fit a
distribution for the time-to-repair.

l Repair or Replace Parts - identifies the parts that were repaired, replaced, removed or found
to be failed due to the incident (if any). If you are extracting data to Weibull++, this is used to
obtain failure and suspension times based on part number.

l Click Repair or Replace Parts to add a part to the list. (See Repair or Replace Parts
Utility.)

l For serialized incidents, and only if you have permission to edit serialized part information,
click Add/Modify Parts to view or modify the full serialized configuration for the system.
Please consult the admin help for more information.

l Click the links in the table to edit the return type, part disposition, sales order number (SO
number), etc.

l If you want to add a detailed failure analysis report for the part, click the New link in the
Failure Analysis Report column. If a report already exists, click the record ID to view or
edit it.

l If you have permission to delete a repair/replace part row, click Delete, , to remove the
row.

l For simple and part incidents— and only if you have permission to duplicate a repair/re-
place part row — click Duplicate, , to create a new row in the table that is identical to
the existing one.

Note: New in Version 2021, you can now edit time/usage data (e.g., “Run Hours,” “Number of
Starts” or “kw Run Hours”) by clicking the links within the Repair or Replace Parts table. This
feature allows you to update both calculated or manually entered values; you can also delete a
previously entered manual value so that XFRACAS will calculate time/usage for the part based
on the values for the system.
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l Incident Failure Analysis - describes any failure analysis that was performed.

l Associated Files - if enabled for the current entity, any links or file attachments associated with
the incident. (See "Associated Files or Links.")

Associating Multiple Incidents to Problems from Reports and
Charts

New in Version 2021, XFRACAS now allows you to assign large groups of incidents to new or
existing problem(s).

Note: The instructions for doing this in individual records are covered in “Assigning an Incident
to a Problem” and “Associated Incidents and Projects.”

l To use these features, you’ll need the Incident/Problem - Allow Incident/Problem Asso-
ciation user permission.

l In addition, to create a new problem using incidents in a report, you’ll also need the Problem -
Create Problems user permission.

Incident Reports

To create a new problem from an incident report:
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1. Generate a standard incident report (or a report that is based on a standard incident report) that
contains the incidents you wish to assign to a problem. (See Reports and Report Builder.)

2. Click the Create Problem icon, , in the ribbon area of the report. This opens a new Problem
page.

3. Complete the first section (first step) of the problem and click Create.

All of the incidents in the report will now be associated to this new problem.

Note: Applying filters in the report view will not affect the number of incidents that are
assigned to the problem.

To associate incidents to one or more existing problems from an incident report:

1. Generate a report that contains the incidents you wish to associate to one or more problems.

2. Click the Assign/Remove Problems icon, . This opens the Assign Problems to Incidents
dialog, which lists all of the problems that the incidents can be assigned to.

3. Select any or all of the problems and click Save.

All of the incidents from the report will now be associated to the selected problems.

Incident Charts

You can also use charts as a source for creating new problems or associating groups of incidents to
one or more existing problems.

1. In an incident chart, drill down by clicking on a bar, data point or pie slice.

2. In the Custom Chart Drill Down dialog, select the Data Table option to display a report that
contains the records used in the bar, data point or pie slice.

3. Follow the steps for creating a new problem or associating incidents to existing problem(s).
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Repair or Replace Parts Utility
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Using the Repair or Replace Parts Utility

The Repair or Replace Parts utility allows you to record information about a part that was repaired,
replaced, removed or found to be failed due to the incident. The information that it captures can be
used for reliability analysis in Weibull++.

The utility can be used for both serialized and non-serialized systems. For serialized incidents, it
implements and tracks changes to the system configuration. For part and simple incidents, its applic-
ations are limited since it cannot capture information about a non-serialized part’s history.
However, it is useful in manufacturing environments, before serial numbers have been assigned, as
well as in cases where tracking individual parts is impractical due to the large number of units in
the field. In these cases, the utility allows you to record run times for parts that failed during testing
and/or investigate failure modes for a particular lot.

PAGE 57



XFRACAS USER 2021 GUIDE

Selecting a Part and Viewing Its Details

To open the Repair or Replace Parts utility, click the Repair or Replace Parts link that appears in
the Incident Repair Information Area after you create an incident.

Note: This link will only be available if enabled for the entity.

Next, find and select the part you want to repair, replace, remove or mark as failed. The inform-
ation displayed in the utility’s left panel depends on the type of incident.

Serialized incidents

The Repair or Replace Parts utility shows the current system configuration — all parts that reside
on the system, along with parts that have been removed. Removal dates are enclosed in brackets
(e.g., [04/11/2017]).

New in Version 2021, the utility now shows accumulated hours and other details that allow you to
track repaired/replaced parts across systems. The following information appears for each repair/re-
place occurrence of the selected part:

l The part disposition

l Up to three time metrics — e.g., run hours, number of starts, kW run hours, etc. — depending
on the configurable settings for the entity

l A link to the incident where the part was repaired or replaced

Part Incidents

For part incidents, the display depends on what has been specified in the incident’s Part Number
field (System/Component Information Area):

l If the Part Number is for a system template (i.e., a top-level part), the left panel shows this
template. In this case, you can only repair / replace parts from that template.

l If it is for a lower-level part, the left panel is blank. In this case, you must click the Find Tem-
plate icon to select a template that contains the part.
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Simple Incidents

For simple incidents, you must click the Find Template icon to select the template that contains
the part. Once you select a part, the right panel shows details for that part.

EXAMPLE
In the image below, Part A (SN:555555) was replaced on April 11th with a new part of the same
type (SN:888888). The right panel shows the details for the selected part, Part C (SN:777777).

Replacing a Part

The Replace Part Utility allows you to replace one part with another.

Open the Replace Part Utility

1. Click the Repair or Replace Parts link.

2. In the Repair or Replace Parts utility, select the part you wish to replace.

3. Click the Replace Part icon to open the Replace Part Utility, where you’ll enter details for
both the “old” part (the one you are replacing) and the “new” (replacement) part.

PAGE 59



XFRACAS USER 2021 GUIDE

Assign a Failure Type and Disposition

The part's failure type, together with the incident category, determines how data will be extracted
for use in reliability analyses. Like an incident category, a failure type may be “chargeable” (e.g., a
Primary Failure) or “non-chargeable” (e.g., a Primary Suspension or Collateral Failure). The com-
bination of the incident category and failure type determines whether the incident is treated as a fail-
ure (F) or suspension (S) for that specific part number.

l If both the incident category and failure type are chargeable, it is considered a failure.

l If either or both incident category and failure type are non-chargeable, it is considered a sus-
pension

An application admin determines which failure types are available for your XFRACAS imple-
mentation and whether these types are chargeable or non-chargeable. The following options are
some examples of how your organization may define failure types:

l Primary Failure - applies when the part fails and must be repaired, replaced or removed.

l Primary Suspension - applies if you removed the part before it failed (for an upgrade, main-
tenance, use in a different system, etc.)

l Collateral Failure - indicates that the part failed as a direct result of the primary failure — e.g.,
a hose breaks (primary failure) and leaks fluid on a circuit board (collateral failure).

l Collateral Suspension - indicates that the part was removed due to the removal or repair of a
part that did not fail — e.g., in the course of upgrading a circuit board (primary suspension),
you strip a screw (collateral suspension).

Disposition indicates what you did with the part that was removed from the system (e.g., “Send to
Engineering,” “Scrap,” “Return to Supplier,” etc.).

Specify a Replacement Part

You can specify a brand new replacement part or, if you are working in a serialized system, a used
part that already exists in the entity.

New Parts

If you specify a new replacement part that is not in the current template (i.e., you’re providing a
new part number), it will be added to the template; otherwise, the current template remains unaf-
fected. In either case, if you are replacing a serialized part, it will be inserted into the current seri-
alized system.
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Used Parts (Serialized Systems Only)

You can also specify a used part — one that was previously removed from another serialized sys-
tem— as the replacement. This inserts the used part into the current system. When you extract data
to Weibull++ for reliability analysis, the part's time/usage history will be calculated based on its
prior accumulated (starting) age, plus any additional run time before the next failure. (See "If
Applicable, Record Time/Usage.")

In addition, you have the option of replacing a part (e.g., a part on "System A") with one that you
are simultaneously removing from another serialized system (e.g., "System B") by specifying its
name, part number and serial number. However, this will not record time/usage for the replacement
part on System B at the time of its removal. Instead, we recommend removing the part with the
Remove Part Utility before using it as a replacement in another system. This two-step process will
ensure that the part's entire time/usage history can be captured from System B for reliability ana-
lyses.

Note: To use a replacement part that’s not already on the current template, you’ll need the
“Incident - Allow Serialized System Modifications” user permission.

Indicate Whether to Include Child Parts (Serialized Systems Only)

On a serialized system, if you are replacing an assembly that contains child parts, you may be able
to save time by using the Copy all children of replaced part option.

Note: This option applies to new replacement parts only (see "Specify a Replacement Part"). If
you are replacing a part with an existing (used) part, its children will be included (with their
serial numbers, if applicable) regardless of whether you enable this option.

l Enable Copy all children of replaced part when you want the new assembly to match the
configuration of the old one, with the same part number and children. You can only enter a
serial number for the entire assembly; to enter serial numbers for child parts, use the
Add/Modify Parts link (this requires the “Incident - Edit Serialized Part Information” user per-
mission).

l Do not enable this option if the replacement part has different children; instead, use
Add/Modify Parts to manually add them. (This may apply if the template contains more than
one instance of the same part — e.g., three power supplies with different designs or options.)
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If Applicable, Record Time/Usage

If the time/usage data (e.g., “Run Hours,” “Number of Starts” or “kw Run Hours”) for the part you
are replacing differs from the time/usage data for the system, you can enter it here; otherwise, this
will be set automatically based on the part’s starting age on the system and the time/usage metric(s)
specified in the System/Component Information area of the Incident page.

If the replacement part is used (and therefore has already accumulated age), you can enter its Start-
ing Age (“Run Hours,” “Number of Starts” or “kw Run Hours”).

If you extract data for a used part to Weibull++ for reliability analysis, its time/usage will be cal-
culated as follows:

100 hours (starting age) + 200 hours (additional run time on system before the next failure) =
300 hours

Repairing, Removing or Marking a Part as Failed

Repairing a Part

Use Repair Part to indicate that the part was restored and remains in the system.

The Repair Part Utility only requires you to specify a failure type, but you can also record time/us-
age data (“Run Hours”). (See "If Applicable, Record Time/Usage.")

XFRACAS assumes that parts are repaired to “good as new” condition (0 run time hours).

Removing a Part

Use Remove Part to indicate that a part, either failed or functional, was removed from the system.

This utility is useful for non-repairable systems and cases where repairing or replacing the part is
not required or not feasible. If the part is serialized, it can be removed for use in another system.
(See Repair or Replace Parts Utility.)

In addition to the failure type (required), you also have the option of entering time/usage data if it
differs from that of the system. (See "If Applicable, Record Time/Usage.")
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Note: To remove a part because a configuration was entered incorrectly, use the System > Seri-
alized page — not this utility.

Marking a Part as Failed

For serialized incidents, you can useMark Part as Failed to indicate that the part was found to be
failed but you don’t yet know how to record it.

Marking a part as failed prohibits others from using it in another incident until it is repaired,
replaced or removed. If another user attempts to do so, a warning appears indicating that the system
configuration must first be updated. When information becomes available, you can remove this
restriction as follows:

1. Click the Repair or Replace Parts link.

2. Find the part in the system configuration (left pane) and select it. In the right pane, “Part Failed
- Waiting for Replacement” will appear in red.

3. Click the appropriate icon to replace, repair or remove the part and update the system con-
figuration.
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Failure Analysis Reports
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Use the Failure Analysis page to record the findings from a detailed failure analysis on a part that
has been repaired or replaced during an incident.

To create a new failure analysis report, click the New link in the Replaced/Repaired Part(s) table in
the Incident Repair Information area of the Incident page.

After you have entered the required fields (highlighted with red boxes), choose Home > Failure
Analysis > Create to create the new record.

The fields that appear on this page may differ from those described below (see Fields and Lists),
which are used in typical XFRACAS implementations.
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Failure Type

The Failure Type drop-down list contains the same options that were available in the incident's
Repair or Replace Parts window. Together with the incident category, this field determines
whether the failure will be treated as "chargeable" or "non-chargeable" in reliability analysis.

If you change the failure type in the failure analysis page for a repaired/replaced part, it will also be
updated in the incident. (See "Assign a Failure Type and Disposition.")

Associated Problem

A failure analysis report is always linked to the incident in which the part was repaired or replaced.
In addition, that incident may be associated to one or multiple problems, and each of those prob-
lems can be associated to a project.

Failure analysis reports are not automatically associated to all the problems that the linked incident
is associated to. Use the Associated Problem field if you wish to create an association to one of
those problems. If a failure analysis report is directly associated to a problem, it can be tracked in
the project(s) that the problem is associated to.

Status Updates

A Status field allows users to add notes about the progress made, and also send e-mail noti-
fications if applicable. If enabled for the entity, this field is not displayed until the record is created.
(See Status Fields.)

Associated Files or Links

An Associated Files field allows users to upload file attachments, link to files in another location
(e.g., a document management website) or link to another record in XFRACAS. If enabled for the
entity, this type of field is not displayed until the record is created. (See Attachments.)

Actions

An Actions field contains a list of specific assignments that need to be tracked and completed. If
enabled for the entity, this type of field is not displayed until the record is created.

Click Create New Action, , to add a new assignment. (See Actions.)
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Technician Name

The Technician Name fields allow you to specify the user(s) who performed various tasks in the
failure analysis. These drop-down lists show users who have the "FA Engineer" category for the
current entity.

Test Duration

In the ATP/Burn-in Area, the Test Duration fields allow you to specify the length of the test in
hours or portions of an hour (e.g., 1 indicates 1 hour and .25 indicates 15 minutes).

Closing a Failure Analysis Report

A failure analysis report is considered closed when the FA Status field has been set to “Closed.”
This may be a requirement before closing the associated incident.

l Any user who can edit the failure analysis can also close it.

l The record remains editable after it is closed.
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Problems
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Use the Problem page (called "PRR" in previous versions) to record and view information for an
issue that requires a team-based approach to understand the root cause and take actions to prevent
similar issues from occurring again in the future.

If you have permissions to create a new problem, choose Home > Create > Problem.
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After you have entered the required fields (highlighted with red boxes), choose Home > Problem
> Create to save the new record.

Note: New in Version 2021, you can subscribe to receive e-mail notifications whenever an incid-
ent, problem, project or CSI record is updated. See Getting Notified when Records Are Updated
for more information.

Entity

If your implementation has more than one entity, the fields and options may be configured dif-
ferently in each. A drop-down list at the top of the page allows you to select which entity is cur-
rently active before you create a new record.

4 to 8 Steps

XFRACAS can be configured to support any problem resolution methodology from 4 to 8 steps
(e.g., 8D, Six Sigma DMAIC, etc.). The areas and fields depend on the configurable settings for
the entity. Some or all of the following steps may be enabled for your implementation.

l Establish the Team (required)

l Describe the Problem (required)

l Implement and Verify Containment Actions

l Identify and Verify Root Cause

l Choose and Verify Permanent Corrective Actions (required)

l Implement Permanent Corrective Actions

l Prevent Recurrence (required)

l Congratulate the Team

Completing Each Problem Step

The bar(s) for completed steps are green. The bar for the current step is red.
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To complete a given step, the Completed By and the Completed Date fields must be filled out,
and the record must be saved.

Depending on the configurable settings, you may also be required to complete all actions asso-
ciated with the step (Closure Restriction Level 3).

In addition, any of the steps 2 through 8 may allow or require review and sign-off by a Failure
Review Board (FRB). (See Failure Review Boards.)

Owner and Creator

Owner

If you have the required permission, you can use the Owner drop-down list to set or change a prob-
lem’s owner. The contents of this list depend on the settings for users in the entity:

l For new problems, the list will only contain you (the problem creator) plus any users who have
been designated as a “Problem Owner” by an application admin.

l If you are not a designated “Problem Owner,” your name will appear in brackets.

l If you don’t have permission to set or change the owner, XFRACAS will automatically
assign you as the owner for any problems that you create.

l For existing problems, the owner’s name will appear in brackets if they no longer have the
“Problem Owner” designation. In this case, if another user is ever assigned as owner, the ori-
ginal owner’s name will be removed from the list.

Depending on the configurable settings for the entity, the owner may receive e-mail notifications
when actions are created for the record.

Creator

By default, XFRACAS automatically assigns you (the logged-in user) as creator. If you have the
required permission, you can select a different creator from the Creator drop-down list.

Team Members

A TeamMembers field identifies the users who will be working on the issue, and their roles on
the team. If enabled for the entity, this field is not displayed until the record is created. (See Assign
TeamMembers Utility.)
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You can click the link for any team member's name to send an e-mail regarding the record. Depend-
ing on the configurable settings, team members may also receive e-mails when a status update is
added or modified.

Tip: If the Audience Restriction field is enabled for the entity and you select "Attorney/Client
Privilege," the record will be visible only to the owner and team members. You will also be
prompted to select a user for the "Legal" role on the team.

Associated Incidents and Projects

Sometimes multiple incident reports can be attributed to the same underlying problem. If enabled
for the current entity, Associated Incident Reports shows a list of chargeable and non-chargeable
incidents that are associated with the problem.

To update this list, click Assign/Remove Incidents. In the Assign Incidents to Problem window,
click Filter to display a list of incidents that match the specified criteria. There is a check box in the
row for each incident. If the check box is selected when you click Save, the incident will be asso-
ciated with the problem.

Tip: You can also assign groups of incidents to a problem directly from reports and charts. See
Associating Multiple Incidents to Problems from Reports and Charts.

Actions

An Actions field contains a list of specific assignments that need to be tracked and completed.
Depending on the configurable settings, there may be separate actions tables in different areas of
the page. This type of field is not displayed until the record is created.

Click Create New Action, , to create a new assignment. (See Actions.)
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Status Updates

A Status field allows users to add notes about the progress, and also send e-mail notifications if
applicable. Depending on the configurable settings, there may be zero, one or multiple status fields
in different areas. This type of field is not displayed until the record is created. (See Status Fields.)

Associated Files or Links

An Associated Files field allows users to upload file attachments, link to files in another location
(e.g., a document management website) or link to another record in XFRACAS. Depending on the
configurable settings, there may be zero, one or multiple attachment fields in different areas. This
type of field is not displayed until the record is created. (See Attachments.)

Closing a Problem

Before you can close a problem, all of the steps must be completed first. In addition, you'll need the
"Problem - Close Problem" permission, along with the ability to edit the problem. Depending on
the settings for the entity, you may not be able to close the record until all of the incidents asso-
ciated with the problem have been closed and/or all of the actions for the problem have been com-
pleted.

Once you complete the final step of the problem and save the record, the Set Close Status and
Close Date fields will appear, assuming you have the required permissions.

To close the problem:

l Select an option from the Set Close Status drop-down list. The available options will depend
on the configurable settings for the entity.

l Specify a closure date. If you select a close status without specifying a date, the current date
will be applied. If you have the "Problem - Open a Closed Problem" permission, you can
change this date if needed.
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Failure Review Boards

Depending on the configurable settings for the entity, any of the steps 2 through 8 in the Problem
page may allow or require review and sign-off by a Failure Review Board (FRB).

Review a Step Assigned to You

If your name is in the list, you can select the Yes or No option to indicate your approval or dis-
approval of the decision to close the current step.

If you reject closure, you will be prompted to specify the reason and a "Rejected" label will be dis-
played. Any user can point to or click this label to see the reason specified.

Assign Reviewers to a Step

If you have permission to assign or remove members of the FRB, click the Edit Reviewer List
link.

Tip: If FRB approval is configured to display for a step, the link will become active immediately
after you complete the Completed By and Completed Date fields. If you assign at least one
reviewer at that point (before saving the record), the link will remain active until all assigned
reviewers have signed off.

l The Available Reviewers List (left) shows XFRACAS users who belong to the approver cat-
egory for this step. In addition, you can use the drop-down list to select users who belong to
other user categories that are eligible to be FRB reviewers.

l The Selected Reviewers List (right) shows the users who are assigned to the FRB for this step
of this problem. If they have been assigned to both the "Default Problem Reviewer" category
and the approver category for this step, they appear in this list by default.

You can double-click a name in one list to move it to the other list or use the arrow buttons. To
select multiple users, hold down the CTRL key and click the names.

Depending on the configurable settings, reviewers may be required to sign off in the order in
which they are listed. To move a reviewer up or down in the list, select the name and click (+) or
(-).
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If you remove a reviewer who has already been saved for the step, you will be prompted to provide
a reason. Click View Reviewer History to see a list of all reviewers who have been removed.

PAGE 75





PROJECTS

Projects
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You can use the Projects page to manage related problems in much the same way that you use the
Problem page to manage related incidents. 

If you have permission to create a new project, choose Home > Create > Project.

After you have entered the required fields (highlighted with red boxes), choose Home > Project >
Create to save the new record.
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Note: New in Version 2021, you can subscribe to receive e-mail notifications whenever an incid-
ent, problem, project or CSI record is updated. See Getting Notified when Records Are Updated
for more information.

Entity

If your implementation has more than one entity, the fields and options may be configured dif-
ferently in each. A drop-down list at the top of the page allows you to select which entity is cur-
rently active before you create a new record.

Owner and Creator

Owner

XFRACAS automatically assigns you as the owner for any projects that you create. The contents
of the Owner drop-down list depend on the settings for each user in the entity:

l For new projects, the list will only contain you (the project creator) plus any users who have
been designated as a “Project Owner” by an application admin. If you are not a designated
“Project Owner,” your name will appear in brackets.

l For existing projects, the owner’s name will appear in brackets if they no longer have the “Pro-
ject Owner” designation. In this case, if another user is ever assigned as owner, the original
owner’s name will be removed from the list.

Depending on the configurable settings for the entity, the owner may receive e-mail notifications
when actions are created for the record.

Creator

For new projects, XFRACAS automatically assigns you (the logged-in user) as creator. If you
have the required permission, you can use the Creator drop-down list (in new and existing pro-
jects) to set or change the project’s creator. This list contains:

l Users who currently have the “Project Owner” designation.

l Users who have been assigned as creator but no longer have the “Project Owner” designation.
In this case, their names will be enclosed in brackets.
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Assigning a Team

A TeamMembers field identifies the users who will be working on the issue and their roles on the
team. If enabled for the entity, this field is not displayed until the record is created. (See Assign
TeamMembers Utility.)

You can click the link for any team member's name to send an e-mail regarding the record. Depend-
ing on the configurable settings, team members may also receive e-mails when a status update is
added or modified.

Associated Problems

The Associated Data area links to the problem reports that are relevant for this project. To add or
remove problems, click Create New Problem or Assign/Remove Problems.

In the list of problems:

l Status showsthe problem step (e.g., Describe the Problem, Prevent Recurrence, etc.) that
needs to be completed next.

l # of IRs shows the quantity of incidents associated to the problem. Click the link to see a list of
those incidents.

l Last Occurrence shows the occurrence date for the most recent incident associated to the prob-
lem.

l Cpt. Date shows the closure date for the problem.

If applicable, this area also displays:

l Incidents that are associated to a problem that is associated to the project. Click Hide/Display
Associated Incidents to toggle between showing either the quantity of open and closed incid-
ents or a full list of the incidents.

l Failure analysis reports that are associated to a problem that is associated to the project. Note
that XFRACAS does not assume that all failure analysis reports linked to an incident that is
associated to a problem are also associated with that problem. Rather, in order to specifically
associate a failure analysis report to a problem, you must use the Associated Problem field in
the Failure Analysis page.
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Associated Files or Links

An Associated Files field allows users to upload file attachments, link to files in another location
(e.g., a document management website) or link to another record in XFRACAS. If enabled for the
entity, this type of field is not displayed until the record is created. (See Attachments.)

Actions

An Actions field contains a list of specific assignments that need to be tracked and completed for
the project. If enabled for the entity, this type of field is not displayed until the record is created.

Click Create New Action, , to add a new assignment. (See Actions.)

Status Updates

A Status field allows users to add notes about the progress made, and also send e-mail noti-
fications if applicable. If enabled for the entity, this field is not displayed until the record is created.
(See Status Fields.)

Closing a Project

A project is considered closed when the Actual Completion Date field has been filled in. Depend-
ing on the settings chosen by an application admin, a project may not be able to be closed until all
problems associated with the project are closed and/or all actions for the project completed.
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Throughout XFRACAS, an Actions field contains a list of specific assignments that need to be
tracked and completed. For incidents, failure analysis reports, CSIs and projects, there can be a
single actions field in each type of record. For problems, there can be separate actions fields for dif-
ferent aspects of the problem resolution process (description, containment, root cause analysis,
etc.).

Actions Fields

For all fields of this type, the table shows actions that have been assigned for the current record.
Click the action number link to open the action window, or click the Expand icon, , to show
more of the details in the table. Click to view the list of actions in a report grid that you can fil-
ter, sort, export to Excel, etc.

To add a new assignment, click Create New Action .
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Action Properties

The fields and features depend on the type of action and the configurable settings for the entity.
Some of the properties in a typical implementation include:

l Associated [Incident/Problem/Project/CSI/Failure Analysis] - the display ID of the record
that the action is associated with (e.g., ENT-I-101 or ENT-PB-15). If you replace this with the
identifier for another record of the same type, it will move the action to the other record. For
example, you can move an incident action from one incident to another; but you cannot move
an incident action to a problem, project, CSI or failure analysis report.

l Owner - the user who is assigned to perform the action. If the entity is configured to send e-
mail notifications to action owners, changing the owner will send an e-mail to the new owner
and to the previous owner.

l Category - this drop-down will always have a main category. Depending on the configurable
settings, it may also have sub-categories.

l The main category indicates the field where the action is displayed (e.g., in an incident, in
the Description step for a problem, etc.). For incidents, failure analysis reports, CSIs and
projects, this can't be changed. For problems, changing the main category moves the action
into table in another section of the page.

l If sub-categories are used for your implementation, you can select from any of the pre-
defined options.

l Due Date - the date when the action is due.

l Completed - selecting the check box marks the action as closed, with today's date as the Com-
pleted Date.

l Result - a description of the results from the action performed. This field must be populated in
order to mark the action as completed.

Create a Linked Action

Depending on how you opened the record, the action properties may be displayed in a popup win-
dow or in a page. If you are viewing the action in a page, and if the action properties include an
Associated Files field (see Attachments), the Home > Action > Create Linked Action command
will be available.
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This command creates a new action that has a reciprocal (two-way) link to the current action. Both
actions will be associated with the current record (i.e., they will appear in the same Actions field)
and both actions will have a link to the other action.

Closing an Action

Any user who can edit an action can also close it.

To close an action, make sure a Description and Result have been entered (at a minimum) and
select the Completed check box. The Completion Date is populated automatically.

The action is “read-only” after it is closed. Only users with certain permissions can re-open a
closed action.
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Customer Support
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If you are tracking particular serialized systems, use the Customer Support (CSI) page to capture a
detailed history for each piece of equipment. This history may include customer contact inform-
ation, installation details, reported incidents, operating time and the current status of the system.

Creating CSI Records

If you have permissions to create a new customer support record, choose Home > Create > Cus-
tomer Support.

If the CSI wizard is enabled, the page will either display all fields in a single form or a wizard that
prompts you to enter data one step at a time. To toggle the display, choose Use CSI Wizard or
Use Single Form .
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After you have entered all required fields (highlighted with red boxes), choose Home > CSI >
Create to save the new record.

Note: New in Version 2021, you can subscribe to receive e-mail notifications whenever an incid-
ent, problem, project or CSI record is updated. See Getting Notified when Records Are Updated
for more information.

CSI Records and Entities

If your implementation has more than one entity, the fields and options may be configured dif-
ferently in each. When applicable, a drop-down list at the top of the page allows you to select
which entity is currently active before you create a new record.

Areas and Fields

The fields that are displayed on the CSI page depend on the configurable settings for the entity.
They are organized as follows:

l Customer Support Summary - unit commissioning information that has been defined for the
current CSI. This summary is displayed after the CSI record has been created. (See Customer
Support Summary Area.)

l Customer/Location Information - information about the customer who owns the unit and the
location where it is installed. (See Customer/Location Information Area.)

l Warranty Information - initial and extended warranty information for the unit. (See War-
ranty Information Area.)

l Incident History - table listing the incidents, if any, that have been reported for the serialized
system. Click Create Incident to create a new record, or click a record ID to view the full
details for that incident.

l Installation Details - information about the specific installation of the serialized unit. (See
Installation Details Area.)
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l Replaced Parts - table showing the parts that were replaced in the last 90 days (or another
time frame, depending on the configurable settings). The Replaced Parts table will only be vis-
ible if parts have been replaced.

l Accessories - If enabled for the current entity, an Accessories field allows you to specify addi-
tional parts that were installed with this particular serialized system. The drop-down list shows
the accessory parts that have been defined in all the customer support records in the current
entity. To define a new accessory part, click Add .

Closing a CSI Record

A CSI record is effectively "closed" when its Decommission Date is set.

Customer Support Summary Area

The Customer Support Summary area of the CSI page displays the unit commissioning inform-
ation that has been defined for the customer support record. This area is not displayed until the
record is created.

Note: The fields that are available in this area may differ from those described below. See
Fields and Lists for more information.

l Time Metrics Field displays up to three types of time measurements that have been reported
for the unit at the time of the incident. Note that an application admin maintains the time metric
field names. Therefore, the name of the Time Metrics field used in your implementation may
be different and, depending on the configurable settings for the current entity, this field may dis-
play one, two or three time metrics. The default is Run Hrs/Starts, which displays the total sys-
tem hours and the number of starts that have been reported for the unit at the time of the
incident. You can click the Add icon, , to add a report on system hours and/or starts. You
can click the link to display the System Run Hours utility, which displays a summary of all sys-
tem hours and number of starts reports that have been made for the unit. System hours reports
that were made manually (i.e., that are not from an incident) can be deleted from this table.

l System Status displays the current operational status of the unit based on the highest status
code for all the incidents associated with the serialized system. The rankings of the status codes
are determined by an application admin. If multiple incident reports apply to the system, the
overall system status is determined by the system status with the highest precedence. For
example, let us say that the list of available statuses contains (in order of increasing pre-
cedence):
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l Available

l Idle

l Running - Needs Service

l Down - Waiting on Service

If two incident reports apply to the system— one with a status of Running - Needs Service
and one with a status of Down - Waiting on Service — the overall system status would be
Down - Waiting on Service. Once the service is applied to that incident, the system status
would change to Running - Needs Service.

l System Configuration provides a link to the Serialized page for the unit.

l MTBF/MTBFE displays the mean time between failures (based on reported hours and based
on estimated system hours) for the system, assuming a constant failure rate.

l MTBCF/MTBCFE displays the mean time between chargeable incidents, or failures (based
on reported hours and based on estimated system hours), for the system, assuming a constant
failure rate.

l MTBNCF/MTBNCFE displays the mean time between non-chargeable incidents, or sus-
pensions (based on reported hours and based on estimated system hours), for the system,
assuming a constant failure rate.

l MTBI/MTBIE displays the mean time between incidents (based on reported hours and based
on estimated system hours) for the system, assuming a constant failure rate.

l Chargeable Incidents displays the total number of chargeable incidents (failures) for the sys-
tem.

l Non Chargeable Incidents displays the total number of non-chargeable incidents (sus-
pensions) for the system.

l Under Warranty displays an indication of whether or not the unit is currently under warranty
and, if applicable, the expiration date of the warranty period.

l Operational Availability displays the percentage of total time during which the system was
not down. Total time is the time from when the unit was commissioned, shipped or built.
Downtime is the time between occurrence dates and repair dates for all incidents on the sys-
tem. If the System Down Event incident detail is available in the current entity, only incidents
for which that detail is checked count toward downtime; otherwise, all incidents are con-
sidered. Note that if no repair date is given for an incident, the system is considered to be down
from the occurrence date on.
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Customer/Location Information Area

The Customer/Location Information area of the CSI page allows you to view and maintain
information about the customer who owns the unit and the location where it is installed.

Note: The fields that are available in this area may differ from those described below. See
Fields and Lists for more information.

l Unit Owner displays the owner of the unit. You can choose an existing company from the
drop-down list. Users with specific permissions can add a new unit owner to the list by click-
ing the Add icon, . In the Company page that appears, type the name and information for
the new unit owner and click Save. The Company page will close and the Unit Owner field
will display the new unit owner. Authorized users can also click the Edit icon, , to edit the
selected unit owner in the Company page.

The available options for the Category field will vary and are maintained by an application
admin.

l Location displays the location of the unit. You can choose an existing location from the drop-
down list; the available locations are based on the selected unit owner. The address, city, state,
zip code and country associated with the location will be displayed in the corresponding fields.
Users with specific permissions can add a new location to the list or edit the selected location in
the Location page.

The City, State and Country fields are drop-down lists that you can choose from. You can
also add, edit or delete cities, states or countries in these lists using the Add, Edit or Delete
icons.

l Contact Name displays the name of the primary customer contact to communicate with regard-
ing the unit. You can choose an existing contact from the drop-down list. The e-mail, phone
and fax associated with the contact will be displayed in the corresponding fields. Users with
specific permissions can add a new contact to the list or edit the selected contact in the Contact
page.

l Contact Area

l In the Company field, you can choose a company or click the Add icon to add a new com-
pany to the list. The Company page will appear. Once you have entered the company
information, click Save to save it and return to the Contact page.
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l In the Location field, you can choose a location from the list, click the Add icon or choose
a location from the list and edit it by clicking the Edit icon. The Location page will appear.
Once you have entered the location information, click Save to save it and return to the
Contact page.

l The available options for the Category field will vary and are maintained by an application
admin.

l The Associated Systems link runs a report showing the CSI records associated with the cur-
rently selected contact. This link will appear only when you are editing an existing contact
and when the contact is associated with commissioned serialized systems.

Note: The Company and Contact pages are also available by double-clicking a company or con-
tact record from within report results.

Warranty Information Area

TheWarranty Information area of the CSI page allows you to view and maintain the initial and
extended warranty information for the unit. This area is not displayed until the record is created.

Note: The fields that are available in this area may differ from those described below. See
Fields and Lists for more information.

l Initial Warranty allows you to enter the warranty period (in months) from the date of ship-
ment or delivery (depending on your selection from theWarranty Type drop-down menu)
and from the date of commission for the current serialized unit. Select a warranty type of To
End User to specify the warranty period from the date of delivery or select To Distributor to
specify the warranty period from the date of shipment.

l Months from Shipment/Delivery displays the default number of months for the warranty
period from the date of shipment or date of delivery (depending on the selected initial war-
ranty months) as specified in the administrative preferences. In cases of extended warranty
or other non-typical situations, you can change these quantities as applicable.

l Months from Commission displays the default number of months for the warranty period
from the date of commissioning, as specified in the administrative preferences. In cases of
extended warranty or other non-typical situations, you can change these quantities as applic-
able.

l To save Extended Warranty information, you must provide a purchase date.
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Installation Details Area

The Installation Details area of the CSI page allows you to maintain information about the spe-
cific installation of the serialized unit.

Note: The fields that are available in this area may differ from those described below. See
Fields and Lists for more information.

l Distributor displays the name of the distributor for the unit. This field is available only when
you are viewing an existing customer support record. Users with specific permissions can add
a distributor to the list by clicking the Add icon, . In the Company page that appears, type
the name and information for the new distributor and click Save. The Company page will close
and the Distributor field will display the new distributor. Authorized users can also click the
Edit icon, , to edit the selected distributor in the Company page.

l ASP displays the company name of the authorized service provider who performed the install-
ation/commissioning. Users with specific permissions can add an ASP company to the list or
edit the selected ASP company in the Company page. Please note that if an ASP company is
not selected, the ASP Field Service Tech drop-down list will be empty since the available
ASP technicians are dependent upon the selected ASP company.

l ASP Field Service Tech displays the name of the authorized service provider's technician
who performed the installation/commissioning. Users with specific permissions can edit the
selected ASP technician in the Contacts page. Please note that this drop-down list may not dis-
play all ASP technicians, depending on the settings chosen by an application admin. In addi-
tion, if an ASP company is not selected, this list will be empty since the available ASP
technicians are dependent upon the selected ASP company.

l Status displays the status of the actions taken to resolve the issue. To create a new status, click
the Add icon, . The Status utility will appear, allowing you to enter comments about the
troubleshooting process.
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Reports

To access XFRACAS reports, choose Home > View > Reports.

Note: Reports only contain links to records that you have permission to view based on your
security settings. If another user who has different security settings runs the same report, it will
yield different results. See Security Levels for more information.

Watched Reports are reports of any type (standard, public, etc.) that you have selected to
"watch." (See Watched Reports and Charts.)

Standard Reports are included by default with XFRACAS.

My Reports have been customized and saved via the Report Builder for your personal use.
This may include reports that you saved for yourself or reports that another user saved for you
or for a security group that you belong to.

Public Reports have been customized and saved via the Report Builder for all users to view.

Custom Reports are created by ReliaSoft for use in the current entity.

Administrator Reports provide information that is of interest to application admins.Please
consult the admin help for more information.
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Grouping Results

To group results, click the column name and drag it into the grouping bar at the top of the results
table. You can drag multiple columns into the grouping bar; their order determines how the records
are sorted. For example, this picture shows grouped by responsible part and then by state.

Filtering Results

When filters are applied, the current criteria will appear at the bottom of the results table. Clear the
check box to remove the filter. There are two ways to apply filters:

l Type in the search field(s) directly below the column name(s).

l Click the Create Filter link at the bottom of the results to open the Filter Builder. In this utility,
each group is headed by a logical operator in red (and, or, not or, not and) that applies to the
conditions under it. Click the red link to select the operator, add a sub-group, add a condition
or remove the operator. Each condition is made up of a property in blue, a relational operator in
green (equals, contains, is not blank, etc.) and a value in gray.
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Click the blue or green link to select the property or operator. Click the gray link to type the
value.

Report Results Toolbar

Show Field Chooser allows you to hide or display columns by dragging the column header
into or out of the pop-up.

Export sends the current report to the file format specified in the drop-down list (*.pdf, *.xls,
*.xlsx, *.rtf or *.csv).

Watch adds the report to your personal list of watched reports.

E-mail Report sends the results in an e-mail message. You must have the appropriate per-
mission in the entity to use this feature.

Show SQL Statement displays the SQL statement that was used to generate the results. You
must have the appropriate permission in the entity to use this feature.

Print Preview is available for reports containing incident, problem, project, CSI or failure ana-
lysis records. This convenient feature saves time by eliminating the need to open each record
within a report to create a printer-friendly view. Instead, it generates a single-page view of the
first 500 records that you have permission to access and renders the same content, in the same
format, as the Print Preview for individual records. In printed report output, each record
starts on a new page. (See the note below.)

Create New Problem is available for incident reports. It allows you to create a new problem
with all of the incidents in the report associated to that problem.
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Assign / Remove Problems is available for incident reports. It allows you to associate all of
the incidents in the report with one or more existing problems.

Note: Some print previews may take a long time to generate, depending on your available
browser, computer and server resources, among other factors. In certain cases, you may exper-
ience time-outs. If you encounter issues when generating a print preview, try reducing the num-
ber of records by modifying the criteria specified in the Report Builder.

Report Builder

Use the Report Builder to design the reports and charts that will be available in the Reports page
and the Charts page. You can save reports that are visible only to you or shared with a specific user
or group. If you have the required permissions, you can also modify the built-in "Standard" reports
or save new "Public" reports that are visible to all users in the entity.

To access the page, choose Options > Designers > Report Builder.

Use the Select Report drop-down lists to select a report/chart to create or modify. For example:

l To create a new report, select an existing one that is similar. Apply your changes and click
Save As. You will be prompted to specify a name, description and other details. (See Saving
Reports and Charts.)

l To modify a report that already exists, select that report. Apply your changes and click Save
(or Save As if you want to be prompted to change the name, description or other details).

To preview the results, save the report and then choose Options > Report > Generate.

Note: Reports only contain links to records that you have permission to view based on your
security settings. If another user who has different security settings runs the same report, it will
yield different results. See Security Levels for more information.
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Reloading Defaults and Deleting Saved Reports

For predefined report types (Standard Reports, Chart Reports, Administrator Reports), you can
click to reload the last saved settings. If the saved settings differ from the default for that type of
report, you can also click to restore the application defaults.

Note: The default Standard and Chart Reports can be modified by users with the "Report
Builder - Set Application Default" permission.

For reports that were created by users (My Reports, My Chart Reports, Public Reports, Public
Chart Reports, Custom SQL Statements), you can click to reload the last saved settings or to
delete the report.

Filter Criteria and Fields to Display

The table contains a row for each field that will be displayed in the results and/or used as a filter.

l To add a field, choose it from the Additional Fields drop-down list and click Add Field .

Note: The maximum number of columns that a report can include is determined by an
application admin.
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l To remove a field, click the Remove Field icon, , in that row.

l When building a report, use the check box in the Show column to show or hide the field in the
results. If the field is shown, enter a value in the Order column to specify the location of the
column in the results. Numbers that are skipped are ignored.

l In the Criterion columns, click Add Filter Criteria, , to specify the operator and argument
(s) for each field. (Alternatively, you can click the operator icon on the left to open the same
window.) If more than one criterion is specified for the same field, click inside the&/Or
column to toggle between AND ( ) and OR ( ). To clear all filter criteria for a field, click
Clear Values, .

l To apply the criteria in groups (e.g., results can match criteria 1 and 2 OR criteria 3 and 4), use
the Filter Group column to define the groups, and then use the Filter Groups Criteria sec-
tion to define the operator that will be applied between groups. (See the recommendations
under "Filter Criteria Groups" below).

These are based on standard SQL operators and commands. Note that not all operators apply to all
data types.

OPERATOR FILTERS BY FIELDS THAT…

Equals Are an exact match to the specified value

Greater than Are greater than (but not equal to) the specified value

Contains Match the specified value (word or phrase), which may be preceded
and/or followed by other values

Does not con-
tain

Do not a match the specified value, which may be preceded and/or
followed by other values

Begins with Begin with the specified value

Ends with End with the specified value

Greater than or
equal to

Are greater than or equal to the specified value

Less than Are less than (but not equal to) the specified value

Less than or
equal to

Are less than or equal to the specified value
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Not equal to Are not an exact match to the specified value

Empty Do not contain a value (i.e., are null)

Not empty Contain a value (i.e., are not null)

IN Match any of multiple specified values (shorthand for multiple OR
conditions, frequently used for lists)

Not IN Do not match any of multiple specified values

Creating Date Filters

If you are building a report or chart and using date fields, you can define filter criteria based on the
current day, a specific date, or a standard period — week, month, quarter or year (this or next). In
addition, you can define filter criteria based on a specified number of days in the past or future with
records for the current day included, if desired.

In the Report Builder’s Filter pop-up window:

1. Choose the Number of Days option from the Specify Date drop-down list.

2. Choose Last or Next from the new drop-down list that appears and enter the number of days.

3. If applicable, enable the Include today check box.

Note: New in Version 2021, if history logging is enabled for your XFRACAS implementation, you
can use the Historical Reporting Date field to generate a report that shows a historical “snap-
shot” of your data at a specified point in time. (See Viewing Historical Data for more inform-
ation.)

Part Details and Serialized Details

When applicable, report results can include information about the particular template part or seri-
alized system that each incident or problem pertains to:

l For incidents, the report can include fields from the System/Component Information Area as
well as any configurable fields for the template part or serialized system.

l For problems, the report can include the "Part Category" as well as any configurable fields for
the specified part.
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In the Report Builder's Additional Fields list, these fields are identified with the prefix "Part
Detail" (for template parts) or "Serialized Detail" (for serialized systems).

Print Preview Links

A Print Preview field is a link to a customized presentation of the data for a particular record. If an
administrator has configured this type of field in the page for a given record type, you can include
those links in your report. The report results will show the same link that is displayed in the record.
Since every record will have the same link, the criterion columns will not be available for this type
of field.

Filter Criteria Groups

If you have specified more than one Filter Group in the table, you can toggle between AND ( )
and OR ( ) to specify the operator that will be applied between groups.

In the following example, the results will include records that match all of the criteria in the first
group (AND operators for all fields in Group 1) or the single criterion in the second group (OR
operator between Groups 1 and 2).

Sorting

When you are building a report, this area specifies how the results will be sorted when they are gen-
erated. The results will be sorted by each field in the Selected list, successively.
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Select a field and click or to move it from one list to the other. Double-click a field in the
Selected list to toggle between ascending (ASC) and descending (DESC) order.

Users can also change the sort order after the report is generated. (See Reports.)

Output

When you are building a report, you can choose whether the results will be displayed in HTML,
XML or XSLT.

l HTML Table - If you choose this default, the results will be displayed in a tabular format and
you can specify the number of records shown per page.

l XSLT - If you choose XSLT, you can either specify an *.xslt style sheet (Extensible
Stylesheet Language Transformation) or leave the XSLT File field blank.

l If you specify an *.xslt style sheet, it will be used to customize the presentation of your res-
ults. (See Working with XSLT Files.)

l If you do not specify a style sheet, the XSLT option will generate XML data for external
use in your own custom XSLT output, in a custom application or in a tool such as Power BI
or Excel. (See Using Reports as Web Data Sources.) This feature allows you to extend the
reporting capabilities of XFRACAS.
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Charts

To access XFRACAS chart reports, choose Home > View > Charts.

Note: Reports only contain links to records that you have permission to view based on your
security settings. If another user who has different security settings runs the same report, it will
yield different results. See Security Levels for more information.

Watched Chart are charts of any type (standard, public, etc.) that you have selected to
"watch." (See Watched Reports and Charts.)

Chart Reports are included by default with XFRACAS.

My Chart Reports have been customized and saved via the Report Builder for your personal
use. This may include reports that you saved for yourself or reports that another user saved for
you personally or a security group that you belong to.

Public Chart Reports have been customized and saved via the Report Builder for all users to
view.

Chart Results Toolbar

Report Builder opens the Report Builder where you can define a new chart.

Data Table displays a tabular report of the data.

Export sends the current chart to the file format specified in the drop-down list (*.xls, *.xlsx,
*.png, *.jpeg, *.bmp, *.tiff or *.gif).

Watch adds the chart to your personal list of watched charts.

Refresh reloads the last saved settings.
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Drilling Down

To drill down in a chart, simply double-click the bar, slice or point of interest then use the Custom
Chart Drill Down window to specify your preference.

For example, this pareto chart displays a count of failure analysis reports broken down by failure
type:
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Double-clicking the Primary Failure bar provides the following options:
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Selecting an option opens a chart in a new window. For example:

Chart Control and Appearance

Chart Control

When you are building a chart, the following settings on the Report Builder page specify how the
data will be presented.

l Analysis Type - you can select Pareto (e.g., bar chart, pie chart, scatter chart, etc.) or Trend
Analysis (e.g. line chart).

l X-Axis and Y-Axis specify the data displayed in the chart. This is always a count of the num-
ber of records that have the same value for the field selected as the Y-axis (e.g., incidents by
responsible part, actions by type, etc.).

Tip: The Y-Axis list excludes some types of fields that are not relevant for this type of chart
(e.g., descriptions, check boxes, accessories, companies, trees, part details, etc.).

In addition, it is not recommended to select fields that show counts obtained from the
query (e.g., Action Count, Status Count, Chargeable Incident Count, etc.). In such cases, the
chart will show a separate bar or slice for each record and increment any duplicate counts
(e.g., 2, 2 [1], 2[2], etc.).
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l Number of Records to Display

l For pareto analyses, you can display the records that either have the most number of
matches to the criteria or the least number of matches to the criteria.

l For trend analyses, you can display the records that either have the most recent dates that
match the criteria or the oldest dates that match the criteria.

l Chart Options

l For pareto analyses, you can show the Average Line.

l For trend analyses, you can show the Average Line or the Trend Line. The Trend Line
shows a smoothed-out curve that follows the data. This an Exponentially Weighted Moving
Average (EWMA) line, which is calculated using a cubic B-spline (CBS) process to
smooth out the line, with a correction factor of 0.5.

Chart Appearance

These settings are applied when the chart is first generated and can be changed later.

l Chart Type - for Pareto analysis, select bar, line, area, step, pie or scatter. Trend charts can
only display as a line chart.

l Kind - 2-dimensional or 3-dimensional

l Appearance - the background color scheme

l Palette - the colors used for chart elements

In the following example, these settings will generate a horizontal bar chart that shows the 20 dates
on which the greatest number of incidents were created along with a line showing the average num-
ber of incidents created daily.
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Saving Reports and Charts

When applicable, you can use the Save Report window on the Report Builder page to enter or
change the Report Name, Report Description and Report Icon.

Depending on your permissions, you may also be able to select:

l Save report for another user or Save report for a security group - makes the report avail-
able to a selected user or to all users in a selected security group. Only the specified user(s) will
be able to view and edit the report, and it will show under "My Reports" or "My Charts."

Tip: If you create a report for another user, or for a security group that you don't belong to,
you will not be able to access it again after the save. If you need to be able to edit the
report again in the future, it is recommended to make sure you belong to the security
group or save your own personal copy that you can modify and share again if needed.

l Save as application default - saves the current settings as the application default for this type
of report, replacing the prior default. You cannot undo this action.

l Make Public - makes the report available to all users in the current entity. Any user in the
entity will be able to view and edit the report, and it will show under "Public Reports" or
"Public Chart Reports."

Note: This option will not appear if security levels have been implemented for the entity
(see Security Levels).

l Add RDW Data Source - makes the report available to the Reliability Data Warehouse
(RDW) in Weibull++.

l You can then use the RDW to create custom dashboards for the data that will be visible in
ReliaSoft desktop applications and the SEP web portal. (See "Connect to XFRACAS
Report" in the Weibull++ documentation.)

l Within XFRACAS, these reports are not visible in the Reports page, but they can be
accessed for subsequent editing under "RDW Data Sources" in the Report Builder.
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Working with XSLT Files

The Display Format drop-down in the Report Builder contains an XSLT option that allows you
to apply your own custom formatting to your XML output. If you choose this option, you can spe-
cify an existing style sheet or upload a new one.

When creating a new *.xslt style sheet, you may be able to save time by downloading the fol-
lowing example file and adapting it to suit your needs:

XFRACASXSLT_simpleIncident_example.xslt

This example file generates a simple table and contains the following code, which illustrates how to
apply a green background and bold text to any cells containing a value of "Open":

<xsl:for-each select="Incidents/Incident">

<tr>

<xsl:for-each select="*[not(local-name() = '' or local-
name() = 'NULL')]">

<xsl:if test="(current()='Open')"> <td class="pfvvalue"
align="middle" style="background-color:#c4df9b; font-
weight: bold;"><xsl:value-of select ="current()"/></t-
d></xsl:if>

<xsl:if test="not(current()='Open')"> <td class-
s="pfvvalue" align="middle"><xsl:value-of select ="cu-
rrent()"/></td></xsl:if>

</xsl:for-each>

</tr>

</xsl:for-each>

Note that this example can be adapted to other types of records, such as problems.

Using Reports as Web Data Sources

If you have specialized reporting requirements that are not directly supported in XFRACAS, you
can create a data link for use in external applications such as Power BI and Excel.

You’ll need the following permission for this task: Report Builder - Access Report Builder
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1. In Options > Report Builder, create a custom report with XSLT selected as the display
format in the Output section.

2. In Home > Reports, click the link to the report you just created. This should open a new tab
that displays the report data in XML format.

3. In the address bar of the new tab, copy the URL.

To use the data in Power BI, Excel, etc., choose theWeb option when specifying a data source
and paste the URL into the application.

Viewing Historical Data

Note: This feature is only available if history logging has been enabled for your XFRACAS imple-
mentation. Contact your application admin for more information.

New in Version 2021, XFRACAS now allows you to view a historical “snapshot” of your data at
a specified point in time. This feature is available for the following predefined Standard Reports
and Chart Reports that ship with XFRACAS, as well as any saved reports that are based on these
report types:

l Incident

l Problem

l Project

l CSI

l Action

l Failure Analysis

l Repaired/Replaced Part

To create a historical report,

1. Use the Report Builder to create a predefined standard report.

2. Add the Historical Reporting Date field to your report.

3. When you configure your filter criteria for this field, use the Equals operator ( ). In the Fil-
ter: Historical Reporting Date dialog, select Specific Date and specify a date and time. The
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generated report will show data as it appeared on that date / time.

4. Save the report, if desired, for future use.

Watched Reports and Charts

The watch feature provides a quick and convenient way to access the reports and charts that you
frequently use. If you are watching at least one report, aWatched Reports group will display at
the top of the Reports page. Likewise, if you are watching at least one chart, aWatched Charts
group will display at the top of the Charts page.

Watch

To start watching a report or chart, open the results page and click theWatch icon on the toolbar.
The icon will be disabled if you are already watching that report/chart. The icon will not display if
it is not possible to generate the exact same report again in the future (e.g., because the query cri-
teria are not saved with a template).

Delete Watch

To stop watching a report, go to the Watched Reports/Watched Charts group and click the Delete
watch icon next to the report.
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Note: If you have a SEP web portal that is linked to XFRACAS, a watch will be created auto-
matically in SEP for any reports or charts that you choose to watch in XFRACAS. However, the
watches are not synchronized after the original creation. If you later delete the watch in
XFRACAS, it will not change the watch in SEP. Likewise, if you later delete or rename the watch
in SEP, it will not change the original watch in XFRACAS.

Dashboard and Designer

Use the Dashboard to view multiple reports and charts simultaneously in a side-by-side format.

To access the Dashboard, choose Home > View > Dashboard.

Use the Select Layout list at the top of the page to select which saved dashboard to view. Click
to refresh the layout.

Click the Zoom icon, , at the upper right corner of the report to open a new browser with all cap-
abilities of that report type (e.g., chart reports have drill-down functionality; text reports can be sor-
ted, grouped, etc.).

Using the Dashboard Designer

If you have the required permission, you can use the Dashboard Designer to create and save dash-
board layouts. To access the Dashboard Designer, choose Options > Designers > Dashboard
Designer.

Use the Select a Dashboard Layout list to specify which type of layout you want to create or
modify. For example:

l To create a new layout, select an existing one that is similar. Apply your changes and click
Save As. You will be prompted to specify the name and other details. (See "Save Dashboard
Layout Window" below.)

l To modify an existing layout, select it, apply your changes and Save (or click Save As if you
also want to be prompted to change the name or other details).

l If you have made changes to your personal default layout, you can click to restore the
application default.
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Note: The application default dashboard can be modified by users with the "Dashboard
Designer - Set Application Default" permission.

If you want to preview the results based on the current settings, choose Options > Dashboard >
Generate.

Save Dashboard Layout Window

When applicable, you can use the Save Dashboard Layout window to enter or change the Dash-
board Layout Name.

Depending on your permissions, you may also be able to select:

l Save report for another user or Save report for a security group - makes the layout avail-
able to a selected user or to all users in a selected security group. Only the specified user(s) will
be able to view and edit the layout.

l Save as application default - saves the current settings as the application default dashboard,
replacing the prior default. You cannot undo this action.

l Make Public - makes the layout available to all users in the current entity. Any user in the
entity will be able to view and edit the layout.

Note: This option will not appear if security levels have been implemented for the entity
(see Security Levels).

Text Search Tips

Keep the following hints in mind to improve the effectiveness of your searches.

l Searches return items that contain any of the words that you type in the text search field.
Search for a few words (keywords) specifically related to what you are trying to find. Avoid
searching for common words like "and", "the", "with", etc.

l Search for more specific or less common words. For example, instead of searching for "veget-
able", you might want to search for "tomato".
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l Searches are not sensitive to case. If you search for "fuel processor", the utility will return
items that contain either "Fuel" or "Processor" or any capitalized variant.

l Words with hyphens such as "e-mail" or "e-commerce" differ from words without hyphens
("email" or "ecommerce) and must be searched separately.

l The following "wildcard" characters can help you refine your text search:

l Use a space before and after a word if you only want the search to return that exact match.
For example, if you enter " fault " (with a space before and after the word), the search will
only return the word "fault" and not "faulty" or "faults", etc.

l Use an underscore "_" to search for words that contain any letter in addition to the entered
letters. For example, if you enter "_ean, the search will return any words that contain four
letters with the last letters being

l Use an underscore alone in any text field to search for records in which that field is not
blank.

l Use brackets "[]" to search for words that contain any letters within a specified range or set.
For example, if you enter a range of letters, such as "[a-p]

l Use brackets with a caret "[^]" to search for words that contain any letters except those
within a specified range or set. For example, if you enter a range of letters, such as "[^a-p]
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End User License Agreement
Click Wrap Agreement at time of product installation

BY INSTALLING THIS SOFTWARE OR BY CLICKING THE “I ACCEPT” BUTTON
AND ACCEPTING THIS LICENSE IN ACCORDANCE WITH SECTION D (LICENSE
ACCEPTANCE PROCEDURES) YOU AGREE TO THE TERMS OF THIS LICENSE
WHICH WILL BIND YOU, THE COMPANY ON WHOSE BEHALF YOU ARE
ENTERING INTO THIS LICENSE AGREEMENT, AND ITS EMPLOYEES, AS
APPLICABLE.

THIS LICENSE AGREEMENT IS A LEGAL AGREEMENT BETWEEN HOTTINGER
BRUEL & KJAER UK LTD, A COMPANY INCORPORATED IN THE UNITED
KINGDOM, WHOSE REGISTERED NUMBER IS 1589921 AND WHOSE REGISTERED
OFFICE IS AT TECHNOLOGY CENTRE, ADVANCED MANUFACTURING PARK,
BRUNEL WAY, CATCLIFFE, ROTHERHAM S60 5WG (THE "LICENSOR") AND THE
END USER LICENSEE OR ITS REPRESENTATIVE/AGENT AUTHORISED TO BIND
THE END USER LICENSEE (REFERENCED HEREIN AS "YOU" OR "YOUR").

PLEASE READ THIS CAREFULLY BEFORE USING THE SOFTWARE PRODUCT

A: BACKGROUND

THIS LICENSE AGREEMENT SHALL BE BETWEEN YOU AND THE LICENSOR
REGARDLESS OF WHETHER YOU HAVE PURCHASED THE SOFTWARE PRODUCT
DIRECTLY FROM THE LICENSOR OR AN AUTHORISED RESELLER AS SET OUT
BELOW.

THE LICENSOR APPOINTS EXPERIENCED PROVIDERS OF SOFTWARE RESALE
SERVICES WHO DISTRIBUTE THE SOFTWARE PRODUCT TO END USERS
("AUTHORISED RESELLER"). IF YOU HAVE PURCHASED THE SOFTWARE
PRODUCT AND ANY ASSOCIATED SUPPORT AND MAINTENANCE SERVICES
FROM AN AUTHORISED RESELLER, SUCH PRODUCTS AND SERVICES WILL BE
PROVIDED DIRECTLY TO YOU BY THE RELEVANT AUTHORISED RESELLER AND
ALL PAYMENTS SHALL BE MADE TO THE AUTHORISED RESELLER ON THE
AUTHORISED RESELLER’S TERMS AND PRICES.

IF YOU HAVE PURCHASED THE SOFTWARE PRODUCT AND SUPPORT AND
MAINTENANCE SERVICES DIRECTLY FROM THE LICENSOR, SUCH SUPPORT AND
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MAINTENANCE SERVICES WILL BE DEALT WITH IN A SEPARATE AGREEMENT
BETWEEN YOU AND THE LICENSOR AND ALL PAYMENTS WILL BE MADE TO
THE LICENSOR AND GOVERNED BY THE LICENSOR’S TERMS OF SALE.

B: PROPERTY OF LICENSOR

THE LICENSOR, OR, WHERE APPLICABLE, THE RELEVANT MEMBER OF THE
LICENSOR’S CORPORATE GROUP, IS THE ENTIRE LEGAL AND BENEFICIAL
OWNER OF CERTAIN SOFTWARE PRODUCT(S) (THE "SOFTWARE PRODUCT") AS
SET OUT IN THE QUOTATION OF INFORMATION, WHICH SHALL ALSO INCLUDE
YOUR LICENSE KEY, SENT TO YOU BY EMAIL EITHER BY THE LICENSOR OR, IF
YOU HAVE PURCHASED THE SOFTWARE PRODUCT FROM AN AUTHORISED
RESELLER, BY THE AUTHORISED RESELLER ("QUOTATION").THE LICENSOR IS
WILLING TO GRANT YOU A LICENSE TO USE THE SOFTWARE PRODUCT ONLY IF
YOU ACCEPT ALL THE TERMS AND CONDITIONS SET OUT BELOW.

C: LICENSE TO BE GRANTED

THE LICENSOR IS PROPOSING TO GRANT YOU ONE OF THE FOUR FORMS OF
LICENSES IN RESPECT OF THE SOFTWARE PRODUCT. THE DETAILS OF EACH
FORM OF LICENSE ARE SET OUT IN CLAUSES 2.1 AND 3 BELOW. THE FORM OF
LICENSE THAT IS PROPOSED TO BE GRANTED TO YOU IS SET OUT IN THE
QUOTATION. THE QUOTATION FORMS PART OF THE LICENSE AGREEMENT AND
BY ACCEPTING THE TERMS OF THE LICENSE YOU ARE ACCEPTING THOSE
TERMS IN THE QUOTATION. IF YOU HAVE NOT RECEIVED THE QUOTATION
FROM EITHER THE LICENSOR OR FROM THE AUTHORISED RESELLER (IF YOU
HAVE PURCHASED THE SOFTWARE PRODUCT FROM AN AUTHORISED
RESELLER) AT THE DATE HEREOF OR IF ANY DETAILS WITHIN THE QUOTATION
ARE INCORRECT THEN YOU SHOULD FOLLOW THE "LICENSE REJECTION
PROCEDURES" SET OUT AT PARAGRAPH E BELOW AND IMMEDIATELY
CONTACT THE LICENSOR OR THE AUTHORISED RESELLER (AS APPLICABLE).

D: LICENSE ACCEPTANCE PROCEDURES

BY CLICKING ON THE ACCEPTANCE BUTTON WHICH FOLLOWS THIS LICENSE
AGREEMENT (MARKED "I ACCEPT") IN THE UI, YOU INDICATE ACCEPTANCE OF
THIS LICENSE AGREEMENT AND THE LIMITED WARRANTY AND LIMITATION OF
LIABILITY SET OUT IN THIS LICENSE AGREEMENT. SUCH ACCEPTANCE IS ON
YOUR OWN BEHALF, IF YOU ARE AN INDIVIDUAL, AND ON BEHALF OF ANY
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CORPORATE ENTITY WHICH EMPLOYS YOU OR WHICH YOU REPRESENT
("CORPORATE LICENSEE") IN ENTERING INTO THIS LICENSE AND YOU
WARRANT THAT YOU HAVE THE NECESSARY AUTHORITY TO BIND THE
CORPORATE ENTITY IN THIS RESPECT OR THAT THE AUTHORISED
REPRESENTATIVES OF THE CORPORATE ENTITY ARE AWARE OF YOUR
ACCEPTANCE OF THIS AGREEMENT ON ITS BEHALF. IN THIS LICENSE
AGREEMENT, "YOU" REFERS TO THE LICENSEE, ANY SUCH CORPORATE
LICENSEE, OR BOTH, AS A COMMON SENSE INTERPRETATION OF THE
RELEVANT SECTION DICTATES.

E: LICENSE REJECTION PROCEDURES

IF YOU DO NOT ACCEPT THESE TERMS AND CONDITIONS, YOU SHOULD CLICK
ON THE "I DO NOT ACCEPT" BUTTON IN THE UI, DELETE THE SOFTWARE
PRODUCT FROM YOUR COMPUTER AND PROMPTLY (AND IN ANY EVENT,
WITHIN 14 DAYS OF RECEIPT) RETURN TO THE RESELLER (A) ANY MEDIA; AND
(B) ANY OTHER ITEMS PROVIDED, THAT ARE PART OF THIS PRODUCT.

F: OTHER AGREEMENTS

IF THE LICENSOR HAS EXPRESSLY AGREED WITH YOU IN WRITING THAT YOUR
USE OF THE SOFTWARE PRODUCT IS GOVERNED BY A PRIOR EXECUTED
LICENSE AGREEMENT WITH THE LICENSOR, SUCH AGREEMENT SHALL APPLY
INSTEAD OF THE FOLLOWING TERMS AND CONDITIONS TO THE EXTENT THAT
THEY CONFLICT.

YOU SHOULD PRINT A COPY OF THIS LICENSE AGREEMENT FOR FUTURE
REFERENCE.

LICENSE AGREEMENT

1. Ownership of Software Product and Copies

1.1 The Software Product and any printed materials or electronic documentation accompanying the
Software Product ("Documentation") are copyrighted works of authorship, and are also protected
under applicable database laws. The Licensor, or, where applicable, the relevant member of the
Licensor’s corporate group, retains ownership of the Software Product and all subsequent copies of
the Software Product, regardless of the form in which the copies may exist. This License Agree-
ment is not a sale of the original Software Product or any copies.
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2. Commercial License

2.1 In consideration of You agreeing to abide by the terms of this License Agreement and payment
of the applicable License fees either to the Licensor or, if You have purchased the Software
Product from an Authorised Reseller, to the Authorised Reseller (as specified in the Quotation), the
Licensor hereby grants to You a personal, non-exclusive, and (unless expressly agreed otherwise
by the Licensor in accordance with clause 5.1) non-transferable License to use the Software
Product and the Documentation on the terms of this License Agreement. The License shall take
one of the following forms, and shall be set out in the Quotation:

(a) Annual License:

(i) Duration – this License shall continue for a period of 12 months ("Initial Period") from
the date of delivery of the Quotation (“the Delivery Date”) and, provided that You have
paid all applicable renewal fees, from year to year thereafter unless terminated in accordance
with any provision of clause 10 below or any other clause of this License Agreement.

(ii) Termination – You must give the Licensor 90 days' written notice prior to the
anniversary of the Delivery Date, such notice not to expire before such anniversary date.

(b) Perpetual License:

(i) Duration – this License shall continue for a period of 25 years from the Delivery Date
unless terminated in accordance with any provision of clause 10 below or any other clause
of this License Agreement.

(ii) Conversion – this License may be converted to a Token Based Annual License, upon
application to either the Licensor or the Authorised Reseller (if You have purchased the Soft-
ware Product from an Authorised Reseller), and payment of an additional fee to the
Licensor or the Authorised Reseller(as applicable), which shall be additional to the fees paid
or payable in respect of any maintenance and support services provided by either by the
Licensor or the Authorised Reseller (if You have purchased the Software Product from an
Authorised Reseller). You may reverse this conversion to the same terms as agreed in the
Perpetual License at the anniversary of the conversion by giving the Licensor 90 days' writ-
ten notice prior to the anniversary of the Delivery Date, such notice not to expire before the
anniversary of the Delivery Date.

(c) Token Based Annual License (referenced in the Quotation as a Prenscia Access Sys-
tem, CDS, CRS, or CDRS License):

(i) Subject to the terms and conditions of this License Agreement, You may access any of
the Software Product in the Quotation at any one time and in any combination up to the
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number of subscriptions granting You access to the Software Product for simultaneous use
by You and purchased by You pursuant to this Agreement ("Access Credits"). You may
add additional Access Credits which shall be charged in accordance with either the
Licensor’s prices or the Authorised Reseller’s prices (if You have purchased the Software
Product from an Authorised Reseller). Such increase in Access Credits shall apply to the fol-
lowing 12 month period, unless You give the Licensor or the Authorised Reseller (as applic-
able) written notice at least 90 days in advance of the expiration of the Initial Period, that
You do not wish to sustain such increase in Access Credits. You may opt to reduce the num-
ber of Access Credits with 90 days' written notice in advance of the 12 month period fol-
lowing from the anniversary of the Delivery Date, provided that the total number of Access
Credits does not fall below the minimum threshold set by the Licensor or the Authorised
Reseller (as applicable) or below the initial number of Access Credits calculated at the time
of conversion of any Perpetual License.

(ii) Duration – this License shall continue for the Initial Period and, provided that You have
paid for the applicable Access Credits, from year to year thereafter unless terminated in
accordance with any provision of clause 10 below or any other clause of this License Agree-
ment.

(iii) Reporting – in order to serve the Licensor's customers better, the Licensor needs to be
able to understand how its customers use the Token Based Annual License. As a condition
of Your continued access to the system, You are asked to provide to the Licensor on a
quarterly basis, the log file. You will be provided with easy-to-follow instructions on how to
do this.

(iv) Termination – You must give the Licensor 90 days' written notice in advance of the
expiration of the Initial Period of Your intention to discontinue the Token Based Annual
License, such notice not to expire before the anniversary of the Delivery Date, and You
must have submitted all reports required of You in clause 2.1(c)(iii) above. Failure to
provide such notice and reports will mean that the License shall automatically continue on
the same terms until terminated in accordance with this clause.

2.2 As an end user licensee of the Software Product, You may, subject to the following conditions
and any conditions specified in the Quotation:

(a) use and copy the Software Product only for use on any computer system that is detailed in
the release notes of the respective Software Product and which is licensed, leased and/or con-
trolled by You (the Corporate Licensee) or any member of Your corporate group, which
expression includes the Corporate Licensee's majority-owned subsidiaries, any parent company
having a majority-owned interest in the Corporate Licensee, and such parent's majority-owned
subsidiaries;
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(b) load the Software Product into and use it only on computers at the locations specified in the
Quotation and which are under Your control; and

(c) copy the Software Product only for back-up and archival purposes and make up to three
copies of the Documentation, provided that the original and each copy is kept in Your pos-
session and that Your installation and use of the Software Product does not exceed any restric-
tions contained in the Quotation.

3. Demonstration License

3.1 If the Licensor has provided You with the Software Product free of charge for evaluation pur-
poses, this clause 3 shall apply to Your use of the Software Product.

3.2 You may use the Software Product on a computer solely for the purposes of evaluating the Soft-
ware Product.

3.3 The Software Product is provided to You free of charge and on an “AS IS” basis, without any
technical support or warranty of any kind from the Licensor including, without limitation, a war-
ranty of satisfactory quality, fitness for purpose and non-infringement.

3.4 This License shall continue for a period of 30 days from the Delivery Date unless terminated in
accordance with any provision of clause 10 below or any other applicable clause of this License
Agreement or until such License is converted into an Annual License, Perpetual License or Token
Based Annual License, if earlier.

3.5 As part of the Licensor’s testing and evaluation of the Software Product, You shall share with
the Licensor the input and views received and any reports and analysis produced promptly upon
receipt of such feedback.

3.6 Clauses 4, 5.1(a), 6.1(b), 6.1(f), 8.1, 8.2, 8.5, 10.1(a) of this License Agreement shall not apply
to a Demonstration License.

4. Delivery and Risk

4.1 The Software Product shall consist of one copy of the object code of the Software Product on
machine-readable form only, on the disk, dongle or other media on which the Software Product is
delivered as described in the Quotation (the “Media”). Risk in the Media shall pass to You on deliv-
ery. If any part of the Media shall thereafter be lost, damaged or destroyed, You must contact either
the Licensor or the Authorised Reseller from whom You have purchased the Software Product
who will arrange for a repair or replacement of such Media at a cost (if any) determined by the
Licensor or the Authorised Reseller (as applicable).
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5. License Restrictions

5.1 You may not nor permit others to:

(a) transfer the Software Product from one location to another, without the express written con-
sent of the Licensor and provided such transfers do not exceed two in any twelve month
period. It will be a condition of the grant of any such consent that the Software Product held on
hard drives at the current location must be erased and You must enter into a new License agree-
ment with the Licensor before a Software Product License key is provided to You. The admin-
istration charge (currently US $1,500) will be payable by You in respect of such transfer. This
charge is only applicable to end user licensees who do not have a support and maintenance ser-
vices agreement with the Licensor or Authorised Reseller;

(b) exceed the number of concurrent users specified in the Quotation, if any;

(c) sub-License, sell, assign, rent, pledge, lease, transfer or otherwise dispose of the Software
Product, on a temporary or permanent basis, without the prior written consent of the Licensor;

(d) translate, reverse engineer, decompile, disassemble, modify or create derivative works
based on the Software Product except as permitted by law;

(e) make copies of the Software Product, in whole or part, except for back-up or archival pur-
poses as permitted in this License Agreement;

(f) use any back-up copy of the Software Product for any purpose other than to replace the ori-
ginal copy in the event that it is destroyed or becomes defective;

(g) copy the Documentation (except as provided by this License Agreement);

(h) adapt, modify, delete or translate the Documentation in any way for any purpose what-
soever;

(i) vary, delete or obscure any notices of proprietary rights or any product identification or
restrictions on or in the Software Product.

6. Open Source

Notwithstanding the foregoing provisions, You acknowledge that certain components of the Soft-
ware Product may be covered by so-called open source software licenses (“Open Source Com-
ponents”), which means any software licenses approved as open source licenses by the Open
Source Initiative or any substantially similar licenses, including without limitation any license that,
as a condition of distribution of the software licensed under such license, requires that the
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distributor make the software available in source code format. To the extent required by the
licenses covering Open Source Components, the terms of such licenses will apply to such Open
Source Components in lieu of the terms of this Agreement. To the extent the terms of the licenses
applicable to Open Source Components prohibit any of the restriction in this License Agreement
with respect to such Open Source Components, such restrictions will not apply to such Open
Source Components. To the extent the terms of the licenses applicable to Open Source Com-
ponents require Licensor to make an offer to provide source code or related information in con-
nection with the Software Product, such offer is hereby made. Any request for source code or
related information should be directed only to Customer Support, Hottinger Bruel & Kjaer UK
LTD, AMP Technology Centre, Brunel Way, Catcliffe, Rotherham, South Yorkshire, S60 5WG,
United Kingdom. You acknowledge receipt of notices for the Open Source Components for the ini-
tial delivery of the Software Product

7. Undertakings

7.1 You undertake:

(a) to ensure that, prior to use of the Software Product by Your employees or agents, all such
parties are notified of this License and the terms of this License Agreement and that any such
use as aforesaid is in accordance with the terms of this License Agreement;

(b) to replace the current version of the Software Product with any updated or upgraded ver-
sion or new release provided by the Licensor or the Authorised Reseller (if applicable) under
the terms of this License Agreement immediately on receipt of such version or release;

(c) to use the Software Product only as described in the Documentation and subject to the
restrictions as set out in clause 5 (License Restrictions above);

(d) to reproduce and include the Licensor’s copyright notice (or such other party’s copyright
notice as specified on the Software Product) on all and any copies of the Software Product,
including any partial copies of the Software Product as permitted to be made under the terms of
this License Agreement;

(e) to hold all drawings, specifications, data (including object and source codes), Software
Product listings and all other information relating to the Software Product confidential and not
at any time, during this License or after its expiration, disclose the same, whether directly or
indirectly, to any third party without the Licensor’s consent and

(f) to effect and maintain adequate security measures to safeguard the Software Product from
access or use by any unauthorised person and indemnify the Licensor for losses flowing from
Your failure to do so.
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8. Intellectual Property Rights

8.1 You acknowledge that all intellectual property rights in the Software Product and the Docu-
mentation throughout the world belong to the Licensor, that rights in the Software Product are
licensed (not sold) to You, and that You have no rights in, or to, the Software Product or the Docu-
mentation other than the right to use them in accordance with the terms of this License Agreement.

8.2 You acknowledge that You have no right to have access to the Software Product in source
code form or in unlocked coding or with comments.

8.3 The integrity of this Software Product is protected by technical protection measures (“TPM”)
so that the intellectual property rights, including copyright, in the software of the Licensor are not
misappropriated. You must not attempt in any way to remove or circumvent any such TPM, nor to
apply, manufacture for sale, hire, import, distribute, sell, nor let, offer, advertise or expose for sale
or hire, nor have in Your possession for private or commercial purposes, any means whose sole
intended purpose is to facilitate the unauthorised removal or circumvention of such TPM.

9. Limited Warranty

9.1 Subject to the limitations and exclusions of liability below and providing the Software is used
in accordance with the Documentation and on an operating system or computer for which it was
designed, the Licensor warrants that (a) the Media on which the Software Product is furnished will
be free from material defects under normal use for a period of 90 days from the date of delivery
(the “Warranty Period”); and that (b) during the Warranty Period, the Software Product will, when
properly used, perform substantially in accordance with the functions described in the Docu-
mentation; and (c) that the Documentation correctly describes the operation of the Software
Product in all material respects.

9.2 If, within the Warranty Period, You notify the Licensor in writing of any defect or fault in the
Software Product in consequence of which it fails to perform substantially in accordance with the
Documentation, and such defect or fault does not result from You having amended the Software
Product or used it in contravention of the terms of this License Agreement, the Licensor will, at its
sole option, i) repair or replace the Software Product, provided that You make available all inform-
ation that may be necessary to assist the Licensor in resolving the defect or fault, including suf-
ficient information to enable the Licensor to recreate the defect or fault, or ii) terminate this License
Agreement immediately by notice in writing to You and the Licensor will refund or if the Software
Product has been purchased from an Authorised Reseller will procure that the Authorised Reseller
shall refund; any of the fees paid as at the date of termination (less a reasonable sum in respect of
Your use of the Software Product to the date of termination) on return of the Software Product and
all copies thereof. The Licensor’s obligation under this clause 8.2 is subject to Your compliance
with clause 6.1(b).
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9.3 You acknowledge that the Software Product has not been developed to meet Your individual
requirements and that it is therefore Your responsibility to ensure that the facilities and functions of
the Software Product as described in the Documentation meet Your requirements.

9.4 You acknowledge that the Software Product may not be free of bugs or errors and You agree
that the existence of any minor errors shall not constitute a breach of this License Agreement.

9.5 The Licensor shall not be liable under the said warranty above if the Software Product fails to
operate in accordance with the said warranty as a result of any modification, variation or addition
to the Software Product not performed by the Licensor or caused by any abuse, corruption or incor-
rect use of the Software Product, including use of the Software Product with equipment or other
software which is incompatible.

9.6 All other conditions, warranties or other terms which might have effect or be implied or incor-
porated into this License Agreement or any collateral contract, whether by statute, common law or
otherwise, are hereby excluded, including, without limitation, the implied conditions, warranties or
other terms as to satisfactory quality, fitness for purpose or the use of reasonable skill and care.

10. Exclusion of Liability

10.1 Nothing in this License Agreement shall limit or exclude the liability of either party for death
or personal injury resulting from negligence, for fraud or for fraudulent misrepresentation.

10.2 Subject to clause 9.1, the Licensor shall have no liability for any losses or damages which
may be suffered by You (or any person claiming under or through You), whether the same are
suffered directly or indirectly or are immediate or consequential, and whether the same arise in con-
tract, tort (including negligence) or otherwise howsoever, which fall within any of the following:

(a) loss of income;

(b) loss of business profits or contracts;

(c) business interruption;

(d) loss of the use of money or anticipated savings;

(e) loss of information;

(f) loss of opportunity, goodwill or reputation;

(g) loss of, damage to or corruption of data; or
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(h) any indirect or consequential loss or damage of any kind howsoever arising and whether
caused by tort (including negligence), breach of contract or otherwise;

provided that this clause 9.2 shall not prevent claims for loss of or damage to Your tangible prop-
erty that fall within the terms of clause 8 or a claim for a refund of the License fees paid to the
Licensor or the Authorised Reseller (as applicable) for the License of the Software Product.

10.3 Subject to clause 9.1 and clause 9.2, the Licensor's maximum aggregate liability under or in
connection with this License Agreement, or any collateral contract, whether in contract, tort (includ-
ing negligence) or otherwise, shall be limited to a sum equal to the fees paid by You to the
Licensor or the Authorised Reseller (as applicable) for the License of the Software Product.

10.4 Subject to clause 9.1, clause 9.2 and clause 9.3, the Licensor's liability for infringement of
third party intellectual property rights shall be limited to breaches of third party rights subsisting in
the UK and USA.

10.5 This License Agreement sets out the full extent of the Licensor's obligations and liabilities in
respect of the supply of the Software and Documentation. In particular, there are no conditions,
warranties, representations or other terms, express or implied, that are binding on the Licensor
except as specifically stated in this License Agreement. Any condition, warranty, representation or
other term concerning the supply of the Software and Documentation which might otherwise be
implied into, or incorporated in, this License Agreement, or any collateral contract, whether by stat-
ute, common law or otherwise, is hereby excluded to the fullest extent permitted by law.

11. Term and Termination

11.1 This License Agreement is effective for the period referred to in clause 2.1 or until otherwise
terminated in accordance with that clause. The Licensor may terminate this License Agreement
immediately by written notice to You if:

(a) save in respect of a Perpetual License, if You purchase the Software Product directly from
the Licensor, You fail to pay any renewal or other fees due by You to the Licensor in respect
of this License Agreement;

(b) You fail to comply with any provisions of this License Agreement;

(c) You commit a material or persistent breach of this License Agreement which You fail to
remedy (if remediable) within 14 days after the service on You of written notice requiring You
to do so;

(d) a petition for a bankruptcy order to be made against You has been presented to the court; or
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(e) where You, as the Corporate Licensee, become insolvent or unable to pay its (the com-
pany's) debts, enters into liquidation, whether voluntary or compulsory (other than for reasons
of bona fide amalgamation or reconstruction), passes a resolution for its winding-up, has a
receiver or Administrator manager, trustee, liquidator or similar officer appointed over the
whole or any part of its assets, makes any composition or arrangement with its creditors or
takes or suffers any similar action in consequence of its debt, or becomes unable to pay its
debts or ceases to trade.

11.2 In the event of termination in accordance with clause 10.1, You must immediately pay to the
Licensor any sums due to the Licensor under the License Agreement and (at the Licensor’s sole
option) You must return, destroy or delete all copies of the Software Product from all storage
media in Your control and, in the case of destruction, certify to the Licensor that You have done
so.

12. Export

12.1 You will comply with all applicable laws, rules, and regulations governing export of goods
and information, including the laws of the countries in which the Software Product was created. In
particular, You will not export or re-export, directly or indirectly, separately or as a part of a sys-
tem, the Software Product or other information relating thereto to any country for which an export
License or other approval is required, without first obtaining such License or other approval.

13. General

13.1 You agree that the Licensor shall have the right, after supplying undertakings as to con-
fidentiality, to audit any computer system on which the Software Product are installed in order to
verify compliance with this License Agreement.

13.2 You agree that the Licensor may use Your company name in Licensor’s customer lists and
other promotional materials describing Your company as a customer or user of Licensor’s software
or services, as applicable, unless it receives written notice from You objecting to such use.

13.3 This License Agreement, its subject matter or its formation (including non-contractual dis-
putes or claims) shall be governed by and construed in accordance with English law and submitted
to the non-exclusive jurisdiction of the English courts.

13.4 This License Agreement constitutes the complete and exclusive statement of the agreement
between the Licensor and You with respect to the subject matter of this License and supersedes all
proposals, representations, understandings and prior agreements, whether oral or written, and all
other communications between the parties relating to that subject matter except for those expressly
referred to in this License Agreement.
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13.5 Any clause in this License Agreement that is found to be invalid or unenforceable shall be
deemed deleted and the remainder of this License Agreement shall not be affected by that deletion.

13.6 Failure or neglect by either party to exercise any of its rights or remedies under this License
Agreement will not be construed as a waiver of that party’s rights nor in any way affect the validity
of the whole or part of this License Agreement nor prejudice that party’s right to take subsequent
action.

13.7 This License Agreement is personal to You and You may not assign, transfer, sub-contract or
otherwise part with this License or any right or obligation under it without the Licensor’s prior writ-
ten consent.
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