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Chapter 1: Getting Started 
ReliaSoft Weibull++ by HBM Prenscia is the industry standard in life data analysis (Weibull 
analysis) for thousands of companies worldwide. Accelerated Life Testing (ALTA) provides an 
intuitive and user-friendly way to utilize tremendously complex and powerful mathematical 
models for quantitative accelerated life testing data analysis. Reliability Growth (RGA) is a 
powerful software tool that allows you to apply reliability growth models to analyze data from 
both developmental testing and fielded repairable systems. In the development stage, the 
software allows you to quantify the reliability growth achieved with each successive design 
prototype and also provides advanced methods for reliability growth projections, planning and 
management. For systems operating in the field, RGA allows you to calculate optimum overhaul 
times and other results without the detailed data sets that normally would be required for 
repairable system analysis. 

What's Changed? Starting in Version 2020, ALTA and RGA are now part of Weibull++. ALTA is 
now referred to as "Accelerated Life Testing" and RGA is now referred to as "Reliability 
Growth". 

This application is part of the suite of ReliaSoft desktop applications, which offers intelligent 
integration between reliability program activities and tools, while simultaneously facilitating 
effective information sharing and cooperation between engineering teams of any size. For 
information about features that are shared by all (or most) of the ReliaSoft desktop 
applications, see the Databases and Projects, Desktop Application Interfaces and ReliaSoft 
Common Tools chapters. 

Other ReliaSoft software by HBM Prenscia includes: BlockSim, Lambda Predict, XFMEA, RCM++, 
RBI, MPC, SEP web portal and XFRACAS. 

Quick Tour 

Weibull++ offers the most comprehensive toolset available for reliability life data analysis, 
with support for all life data types and all commonly used product lifetime distributions. 

Accelerated Life Testing (ALTA) and Accelerated Life Testing PRO (ALTA PRO) utilize powerful 
life-stress relationship models to design and analyze data from accelerated life tests. 

Reliability Growth (RGA) supports all of the major reliability growth models and can analyze 
data from both developmental testing and fielded repairable systems. It also includes a 
comprehensive toolset for advanced reliability growth projections, planning and management. 

https://www.reliasoft.com/products/reliability-analysis/blocksim
https://www.reliasoft.com/products/reliability-analysis/lambda-predict
https://www.reliasoft.com/products/reliability-management/xfmea
https://www.reliasoft.com/products/reliability-management/rcm
https://www.reliasoft.com/products/reliability-management/rbi
https://www.reliasoft.com/products/reliability-management/mpc
https://www.reliasoft.com/products/reliability-management/synthesis-enterprise-portal
https://www.reliasoft.com/products/reliability-management/xfracas
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These applications are also packed with tools for related reliability analysis such as degradation 
data analysis, stress-strength comparison, reliability test design and design of experiments 
(DOE). In addition, Weibull++ also supports warranty data analysis, non-parametric data 
analysis and recurrent event data analysis. 

For life data and life-stress data analysis, you can use this application to answer a wide variety 
of questions such as: 

• How many units do you need to test? How much test time? At which stress levels? 

• Will the product meet the reliability requirement? 

• What is the influence of different failure modes? How does accelerated stress affect life? 

• Which design (or supplier) will be more cost-effective over time? 

• How many units are likely to be returned under warranty? 

• Is there an emerging reliability problem in the field? With a particular supplier? In a 
particular region? 

• When will a crack, wear, etc. degrade to the point of failure? 

• What is the typical time to repair? How effective are the repairs? 

For growth data analysis, you can use this application to answer a wide variety of questions, 
such as: 

• Will the product meet the MTBF goal? How much test time is required? 

• How does the product perform across different test phases? At which phase will the 
product meet the reliability requirement? What is the initial MTBF? 

• How do the test data compare to the reliability growth test plan? 

• What failure modes should be fixed and when? 

• What is the optimum growth maintenance strategy? When is the best time to schedule 
maintenance/overhauls? 



Chapter 1: Getting Started 

Weibull++ 2020 User's Guide 3 

 

 

USING DATABASES AND PROJECTS 

File Menu 

Use commands on the File menu (New, Recent or Open Database) to create or open a 
database). (See Database Types.) 

Each database supports simultaneous access by multiple users. If you have admin permissions, 
use File > Manage Database to control user access and manage configurable settings that apply 
throughout the database. (See Security Options and Backstage View.) 

Use File > Help to access online help and shipped examples. 
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Project List 

Each database can contain multiple projects. Use the project list to create or open a project. 
(See Project Manager.) 

If you have a lot of projects: 

• Use the project filter to limit what’s displayed. 

• Use the project category to group projects within the list. 
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Current Project Explorer 

Use the current project explorer to create or open analyses and reports. (See Current Project 
Explorer.) 

You can open the same project in any ReliaSoft desktop application. Analyses and reports are 
visible only in the application(s) that can edit them: 

• Life data folios are only visible in Weibull++ 

• Fault trees are only visible in BlockSim 

• FMEAs are only visible in XFMEA, RCM++ or RBI 

• Etc. 
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Common features such as project plans, resources and project attachments are visible in all 
ReliaSoft desktop applications. 

USING LIFE DATA FOLIOS 

Weibull++'s life data folio allows you to fit a statistical distribution to failure time data in order 
to understand the reliability performance of a product over time or to make projections about 
future behavior. From the analysis, you can obtain reliability information about a product such 
as probability of failure, reliability, mean life or failure rate. 

The basic steps for using a life data folio are: 

1. Add life data folio 

Right-click the Life Data folder in the current project explorer and choose Add Life Data. 

 

In the setup window, select the desired data type and the units for time/usage values 
(hours, cycles, etc.). (See Weibull++ Data Types.) 



Chapter 1: Getting Started 

Weibull++ 2020 User's Guide 7 

 

 

2. Enter data 

Enter the data and use the control panel to specify the life distribution and analysis 
settings. (See Life-Data Folio Control Panel for descriptions of all available settings.) 
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3. Analyze data 

Click the Calculate icon on the control panel. 

 

The Analysis Summary area displays the parameters of the distribution. Click the Detailed 
Summary icon  to view more information. 
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4. View plots 

Click the Plot icon on the control panel to open the plot sheet. (See Life Data Analysis Plots 
for available plot types.) 

 

To show the confidence bounds, click the Confidence Bounds link on the plot's control 
panel, and then set the desired type of bounds and confidence level. 
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5. Calculate metrics 

Click the QCP icon on the control panel to open the Quick Calculation Pad.  (See QCP 
Calculations for Life Data Analysis for available calculations.) 

 

The following example shows the estimates for the reliability and the lower one-sided 90% 
confidence bound. 
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6. Create report 

Right-click the Reports folder in the current project explorer and choose Add ReliaSoft 
Workbook. 
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In the ReliaSoft Workbook wizard, select the folio as the default data source. If desired, you 
can also select a standard or user-defined report template (e.g., the "Weibull Summary 
Style 1 Template" is shown below). (See ReliaSoft Workbooks.) 
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USING LIFE-STRESS DATA FOLIOS 

Weibull++'s life-stress data folio allows you to perform quantitative accelerated life testing data 
analysis. In this analysis, you extrapolate a product’s failure behavior at normal conditions from 
life data obtained at accelerated stress levels. Since products fail more quickly at accelerated 
stress levels, the analysis allows you to obtain reliability information about a product (e.g., 
mean life, probability of failure at a specific time, etc.) in a shorter time. 

The basic steps for using a life-stress data folio are: 

1. Add life-stress data folio 

Right-click the Life-Stress Data folder in the current project explorer and choose Add Life-
Stress Data. 
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In the setup window, select the desired censoring type and units for time/usage values 
(hours, cycles, etc.). (See Accelerated Life Testing Life-Stress Data Folio Setup.) 

 

In the next page, define the stress type(s) to use in the analysis and the use stress level. 
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2. Enter data 

Enter the data and use the control panel to specify the life-stress model. (See Life-Stress 
Data Folio Control Panel for available models.) 
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3. Analyze data 

Click the Calculate icon on the control panel. 

 

The Analysis Summary area displays the parameters of the distribution. Click the Detailed 
Summary icon  to view more information. 
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4. View plots 

Click the Plot icon on the control panel to open the plot sheet. (See Accelerated Life Testing 
Plots for available plot types.) 

 

To show the confidence bounds, click the Confidence Bounds link on the plot's control 
panel, and then set the desired type of bounds and confidence level. 
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5. Calculate metrics 

Click the QCP icon on the control panel to open the Quick Calculation Pad.  (See QCP 
Calculations for Accelerated Life Testing Analysis for available calculations.) 

 

The following example shows the estimates for reliability and the lower one-sided 90% 
confidence bound. 
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USING GROWTH DATA FOLIOS 

Weibull++’s growth data folio supports traditional reliability growth analysis, repairable systems 
analysis and reliability growth projections. The data type you select determines the type of 
analysis you can perform. 

The basic steps for using a growth data folio are: 

1. Add growth data folio 

Right-click the Growth Data folder in the current project explorer and choose Add Growth 
Data. 
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In the setup window, select the desired data type. (See Reliability Growth Data Types.) 
Then click Next to set the units for values (hours, cycles, etc.) and other preferences. (See 
Creating a Growth Data Folio.) 

 

2. Enter data 

Enter the data and use the control panel to specify the growth model and analysis settings. 
(See Growth Data Folio Control Panel for descriptions of all available settings.) 
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3. Analyze data 

Click the Calculate icon on the control panel. 

 

The Analysis Summary area displays the parameters of the growth model. Click the 
Detailed Summary icon   to view more information. 
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4. View plots 

Click the Plot icon on the control panel to open the plot sheet. (See QCP Calculations and 
Plots for Traditional RGA.) 

 

To show the confidence bounds, right-click the plot, choose Show Confidence Bounds, and 
then set the desired type of bounds and confidence level. 
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5. Calculate metrics 

Click the QCP icon on the control panel to open the Quick Calculation Pad. (See QCP 
Calculations and Plots for Traditional RGA.) 

 

The following example shows the instantaneous MTBF with the lower one-sided 90% 
confidence bound. 
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MORE ANALYSES AND TOOLS 

Warranty Data Analysis 

For life data analysis, the Warranty folio offers a choice of 4 data entry formats that use sales 
and returns data to predict future returns under warranty: Nevada, Times-to-Failure, Dates of 
Failure and Usage. 
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Degradation 

For life data and life-stress analyses, the Degradation folio extrapolates expected failure times 
based on how a performance measure (e.g., crack propagation, tread depth, vibration) has 
degraded over time. 
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Recurrent Event Data Analysis 

For life data analysis, the non-parametric RDA folio uses the Mean Cumulative Function to plot 
the average number of recurring failures over a given period of time. The parametric RDA folio 
uses the General Renewal Process (GRP) model, which considers the effectiveness of repairs, to 
model the cumulative number of failures over time. 
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Design of Experiments 

A set of Design folios provide techniques for DOE analyses such as identifying key factors that 
affect performance (standard design), minimizing a system’s sensitivity to noise (robust design) 
and determining the best proportion of components in a mixture (mixture design). 
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Monte Carlo Data Generation and SimuMatic 

For life data and life-stress data analyses, the Monte Carlo utility generates a data set based on 
a specified probability distribution. SimuMatic performs analyses on a large number of 
simulated data sets, based on a specified probability distribution. For growth data analysis, the 
Monte Carlo utility generates a data set based on the Crow-AMSAA model, with specified beta 
and lambda parameters while SimuMatic performs analyses on a large number of simulated 
data sets, based on the Crow-AMSAA model. 

The life data versions look like this: 
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Comparison Folios 

The Life Comparison folio determines the probability that the life of one population will be 
greater or less than that of the second. The Stress-Strength analysis folio determines the 
probability of failure based on the probability of stress exceeding strength. 
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Test Design 

For life data analysis, Weibull++ offers a choice of tools to assist with reliability test design: 
Reliability Demonstration Test (Parametric Binomial, Non-Parametric Binomial, Exponential Chi-
Squared or Non-Parametric Bayesian), Expected Failure Times Plot and Difference Detection 
Matrix. For growth data analysis, the Test Design folio uses the non-homogeneous Poisson 
process (NHPP) to design a demonstration test for repairable systems by solving for either the 
test time required per system or the number of systems that must be tested. 
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Target Reliability Planner 

For life data analysis, the Target Reliability folio finds the optimum cost and reliability of a 
product, given estimates for various factors involved in the product’s production and sale. 
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Maintenance Planning 

For life data analysis, the Maintenance Planning folio uses the optimum replacement age model 
to determine the most cost-effective time to replace aged components. 
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Growth Planning 

For growth data analysis, the Growth Planning folio helps you to create a multi-phase reliability 
growth testing program that is designed to achieve a specific MTBF or reliability goal. 
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Multi-Phase plot 

For growth data analysis, the Multi-Phase plot displays actual test results (e.g., demonstrated, 
projected and growth potential MTBF or failure intensity) across multiple analysis points and/or 
test phases. It can be linked to a growth planning folio to compare actual test results against 
the test plan. 
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Mission Profiles 

For growth data analysis, Mission profiles help to create a balanced operational test plan and 
track the actual testing against the plan to make sure the data will be suitable for reliability 
growth analysis. 
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Technical Support 
ReliaSoft reliability software products are renowned for their ease of use and unparalleled after 
sale support. For users with an active maintenance agreement, we provide technical support 
for software-related issues via a network of regional offices and partners/distributors 
throughout the world. 

You can request assistance directly from within the software by choosing File > Help > E-mail 
Support. This creates an e-mail message that is pre-populated with information about your 
license and operating system, which the technical support representative will need for 
troubleshooting the issue. 

To get contact details for technical support worldwide, choose File > Help > Contact Technical 
Support or visit https://support.hbmprenscia.com. 

WHEN REQUESTING SUPPORT 

When you contact us to request technical support, please be prepared to provide the following 
information: 

• Your phone number and e-mail address. 

https://support.hbmprenscia.com/
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• The product name and the Compile Release Version number of your application. To 
determine the Compile Release Version (CRV) of the application on your computer, choose 
File > Help. The CRV is displayed in the About area. Note that the CRV will also indicate 
whether you are running the 32-Bit version or the 64-Bit version of the software. 

• Your product license key. 

• To determine the license for the application on your computer, you can choose File > 
Application Setup and click any of the main headings in the Application Setup window. 

• The operating system (e.g., Windows 7), RAM and hard disk space on your computer. 

• Describe what you were doing when the problem occurred and exactly what happened. 
Please include the specific wording of any message(s) that appeared. 

Note: Technical support representatives are not reliability consultants, and their assistance is 
limited to technical issues that you may encounter with the software tools. To get assistance 
with your analysis from a subject matter expert, please contact Reliability Consulting Services. 
HBM Prenscia also offers a comprehensive selection of training courses that cover both the 
underlying principles and theory, as well as the applicable software tools. For details, visit 
https://www.reliasoft.com/services/training-courses. 

Reliability Consulting 
If your organization does not have sufficient time, expertise or objectivity in-house to 
accomplish specific reliability goals, turning to our expert reliability consultants can prove to be 
the most effective and economical solution. Whether you need a quick statistical analysis, a 
complete assessment of your reliability program plan or something in between, Reliability 
Consulting Services (RCS) is ready to help. 

• Our reliability consulting services team has combined expertise in almost all areas of 
reliability and quality engineering with experience that spans a broad spectrum of product 
types, from micro-electronics and appliances to advanced weapons systems and off-shore 
oil well drilling equipment. 

• Unlike engaging a consultant who works independently, RCS consultants have direct access 
to all of ReliaSoft global resources, expertise and contacts. 

• Our team-based approach to consulting, combined with ReliaSoft global reliability 
engineering organization, allows us to provide you with reliability consultants who 
understand your culture and speak your language while ensuring that the appropriate 
reliability expertise can be applied to each and every project. 

https://www.reliasoft.com/services/training-courses
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• RCS is structured to accommodate requests of any size or complexity, from short 
telephone consultations to multiple experts at a client's site for an extended time period. 

Please visit https://www.reliasoft.com/services/consulting for more information. 

Install and License 

SYSTEM REQUIREMENTS 

In addition to the information below, we provide an automated tool that determines whether 
your computer and Internet connection meet the requirements for running and activating 
ReliaSoft desktop applications. It will also determine whether you could install the 64-bit 
version of these applications, if desired. [Download Requirements and Compatibility Test 
Tool...] 

Operating Systems 

64-bit versions are supported, except where noted. [See our 32-bit vs. 64-bit FAQ...] 

• Microsoft Windows® 7 with Service Pack 1 (with the Version 2020.0.1 release ONLY) or 
Windows 10. 

• Microsoft Windows Server 2008 R2 SP1 (64-bit version) or newer. (Requires a license that 
specifically allows server installations/deployments.) 

Note: Upgrading your operating system after your ReliaSoft software has already been installed 
can cause issues with the activation. To prevent this, it is recommended to uninstall ReliaSoft 
2020 prior to upgrading your operating system and then reinstall it after the upgrade. For other 
options, and for information about how to handle the "activated license is corrupt" message 
that may appear if you upgrade your operating system with live activations, please refer to 
https://www.reliasoft.com/windows10-reactivation. 

Minimum Hardware Requirements 

• RAM: 2 GB or more 

• Hard disk space: 1 GB (minimum) free space available 

• Screen resolution: 1024 x 768 or higher 

https://www.reliasoft.com/services/consulting
https://www.reliasoft.com/check-requirements
https://www.reliasoft.com/check-requirements
https://www.reliasoft.com/32-or-64-bit
https://www.reliasoft.com/windows10-reactivation
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Additional Software Requirements 

• .NET Framework 4.6.1 

• Microsoft Office (Excel®, Word and Outlook®) 2010 or higher (non-subscription-based)  for 
automated exports, report generation and e-mail/calendar integration. 

Enterprise Database Platforms 

32- and 64-bit versions are supported. 

• SQL Server® 2012 - 2017 

• SQL Server Express Edition 2012 - 2017 

• Oracle® 10g - 12c 

Although the enterprise database platform (Microsoft SQL Server or Oracle) could be installed 
on the same computer where the ReliaSoft applications reside, most organizations will choose 
to set up a separate server to host the database. Both the 32-bit and 64-bit versions of the 
applications will work with either the 32-bit or 64-bit versions of a back-end database/server. 
The minimum hardware/software requirements for each server hosting the database should be 
obtained directly from the selected database vendor (i.e., Microsoft or Oracle). In general, we 
recommend a minimum CPU speed of 2 GHz and 4 GB of RAM. 

INSTALLATION AND LICENSING 

There are two alternative ways that ReliaSoft desktop applications may be licensed on your 
computer: 

• If you received a license file (*.lic) and/or a license settings file (*.prnrsl), see Locally Hosted 
Licensing 

• If you received only a license key (a 32-digit alphanumeric code), see ReliaSoft-Hosted 
Licensing 

One or both methods can be used on the same computer. For example, if you have your own 
single-user license for BlockSim and will share your department’s new multi-user (floating) 
license for Weibull++, you will receive a license key for BlockSim and a license file for Weibull++. 

If you will use both types of licensing on the same computer, use the installation instructions 
for locally hosted licenses. When you launch any application that isn't included in your locally 
hosted license or that you have specified as using ReliaSoft-hosted licensing via the License 
Settings Tool (see https://www.reliasoft.com/license-settings-tool), the ReliaSoft License 

https://www.reliasoft.com/license-settings-tool
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Manager will allow you to perform the activation of your ReliaSoft-hosted license(s) using a 
product license key. 

Requirements for All Installations 

• Before running the installation program, make sure your computer meets the system 
requirements for ReliaSoft desktop applications. 

• You must be logged in with a user account that has administrative rights. 

• It is strongly recommended that you close all other applications during the installation. 

Locally Hosted Licensing 

If you received a license file (*.lic) or license settings file (*.prnrsl), you will be using locally 
hosted licensing. This allows you to manage available license seats or CRS units in-house 
without the requirement to connect to the ReliaSoft external license server. 

The first step is for a license administrator to configure your organization’s license server and 
provide each individual user with the path to the license server/host (e.g., 6220@servername) 
and, in some cases, a license settings file (*.prnrsl) that specifies which ReliaSoft applications on 
your computer will use locally hosted licensing. (For detailed instructions, see 
https://www.reliasoft.com/locally-hosted-licensing.) 

Once the license server has been set up, perform the following steps for each client installation. 
If you have previously connected the client computer to the appropriate license server, you can 
start at step 4. 

1. Open the ReliaSoft ePack and decompress the *.zip archive in the Locally Hosted Licensing 
Utility folder 

2. Install the HBM Prenscia Licensing Administration utility by double-clicking licinst.exe and 
following the prompts. The utility will start as soon as installation is complete. 

3. On the Client tab of the license admin utility, click Set Client License Path and then click 
Add Network Host or enter the license path directly in the window (use the network host 
format; e.g., port@serverhostname). 
 
The client computer will check for available license seats in the specified order (i.e., it will 
go to the top server listed and if no license seat is available there, it will check the next 
server down, and so on). 
 
Note that you can delete a license location by highlighting the line and deleting it. 

https://www.reliasoft.com/locally-hosted-licensing
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4. Install the ReliaSoft desktop applications by double-clicking the installation program from 
the ePack (e.g., ReliaSoft2020.exe) and following the prompts. 

5. For versions prior to Version 2020: If you were provided with a *.prnrsl file, open the 
Import/Export License Settings utility by choosing ReliaSoft [Version] > ReliaSoft [Version] 
License Settings Import-Export (Windows 10) or ReliaSoft [Version] > Additional Tools > 
ReliaSoft [Version] License Settings Import-Export (Windows 7) in the Windows Start 
menu. Follow the on-screen instructions to import the *.prnrsl file. 

The first time you launch an application, you may be asked to provide your name and basic 
contact information. This is required to be eligible for technical support. 

Note: Applications using locally hosted licensing must have an active connection to the license 
server unless you have borrowed a license. If you see a message that indicates that a license 
could not be obtained, this could be for a variety of reasons (e.g., you are not connected to the 
license server, the license server is down or there are no seats or CRS units available for the 
license). In addition, if you lose connection to the license server while you are using an 
application, you will see a message warning you to save your work before the application 
closes. 

ReliaSoft-Hosted Licensing 

If you are requesting a demo or have already received a license key (a 32-digit alphanumeric 
code), you will be using ReliaSoft-hosted licensing. 

If your computer has an active Internet connection and your firewall allows the software to 
access the ReliaSoft secure external license server at https://validate.reliasoft.org, only a few 
simple steps are required for activation: 

1. Install the ReliaSoft desktop applications by double-clicking the installation program from 
the ePack (e.g., ReliaSoft2020.exe) and following the prompts. 

2. The first time you launch an application, the activation wizard will appear. On the first page, 
select whether you want to activate a license or request a free demo license. 

3. On the next page, enter a valid e-mail address to serve as your ReliaSoft ID. This is the e-
mail address where you will receive confirmation e-mails from the ReliaSoft License Server. 
This must be your company e-mail address — not gmail, hotmail, etc. 

• Name and Contact Info: If this is the first time that you have registered a ReliaSoft 
desktop application on this computer with this e-mail address, the next page will 
request your name and basic contact information. 
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• Demo License: If you need a demo license, most requests will be addressed 
immediately during normal business hours; for some locations, please allow up to 2 
business days. 

4. On the next page, enter the product license key provided to you. Tip: If you are able to copy 
the key from a product delivery e-mail, the Paste icon saves time by automatically entering 
each section into the appropriate input box. 

 

• Confirmation Keys: If your license type requires a confirmation key, the next page 
requires you to copy/paste a key that you will receive via e-mail. Tip: If the e-mail does 
not appear in your Inbox within a few minutes, check your Junk mail or SPAM folders. 

• Activate Multiple Applications: If your license key includes other ReliaSoft desktop 
applications that have not yet been activated on this computer, the next page gives you 
the opportunity to activate any or all of them at the same time. 

5. When you see the "Your product has been activated” message, click Finish to start using 
the software. 

If the computer does not have an active Internet connection, or if you encounter issues with 
the firewall, there are other ways to complete the activation. Please visit 
https://www.reliasoft.com/reliasoft-hosted-licensing for details. And, of course, you can always 
contact us for assistance (https://support.hbmprenscia.com). 

Uninstalling ReliaSoft Applications 

If you wish to stop using all of the ReliaSoft desktop applications on this computer, you can 
perform the following steps: 

1. Make sure you do not have any ReliaSoft desktop applications currently open. 

2. For locally hosted licenses prior to Version 2020, if you are uninstalling permanently (i.e., if 
you are not doing this as part of an uninstall/reinstall), open the Import/Export License 
Settings utility by choosing ReliaSoft [Version] > ReliaSoft [Version] License Settings 
Import-Export (Windows 10) or ReliaSoft [Version] > Additional Tools > ReliaSoft [Version] 
License Settings Import-Export (Windows 7) in the Windows Start menu. Follow the on-
screen instructions to delete the license settings file. 

https://www.reliasoft.com/reliasoft-hosted-licensing
https://support.hbmprenscia.com/
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3. Open the Windows Control Panel and click Programs and Features (or use the search box in 
the Windows Start menu to find and select Add or Remove Programs). 

4. In the Uninstall or change a program window, double-click ReliaSoft [Version] and follow 
the prompts. 

5. If you have installed the HBM Prenscia Licensing Administration tool, you can follow similar 
steps to uninstall it. 

Tip: If you are using ReliaSoft-hosted licensing (i.e., if you received a license key and activated 
specific application(s) on your computer), you also have the option to deactivate one or more 
applications without performing a complete uninstall. For instructions, see 
https://www.reliasoft.com/deactivating-applications. 

LICENSE MANAGER 

The License Manager allows you to view and manage license-related details for the ReliaSoft 
desktop applications that are currently activated on your computer. You can use this interface 
to: 

• View and, for ReliaSoft-hosted licenses, edit the contact information that is on file with us 
or change the password associated with your ReliaSoft ID. [Learn more…] 

• For ReliaSoft-hosted licenses, deactivate the current application (if you don't plan to 
continue to use it on this computer or for this user). [Learn more…] 

• For ReliaSoft-hosted floating licenses, check out or check in a license. [Learn more...] 

To open the License Manager, choose File > Help and click the License Manager link in the 
Licensing section. 

You may be prompted to enter the password that was sent via e-mail when you first registered 
your ReliaSoft ID. This password is required if you want to modify your contact information. For 
everything else, you can click Cancel to proceed without it. (If you forgot your password, you 
can request to have the information sent to the e-mail address on file for your registration by 
clicking E-mail my password to me.) 

Contact Information and Password 

The Contact Information page displays the name, phone number and other details that are on 
file with ReliaSoft. For locally hosted licenses, this information is read-only and can only be 
edited by uninstalling and reinstalling the software. For ReliaSoft-hosted licenses: 

https://www.reliasoft.com/deactivating-applications
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• If you need to download the latest information from the license server, click Synchronize. 

• If you want to change your password or any of the current contact information, type the 
new information into the fields on this page and then click Update Information on Server. 

Both actions require authentication. If you have not already entered the current password 
that's associated with your ReliaSoft ID, you will be prompted again to enter it. 

Deactivate the Current Application 

For ReliaSoft-hosted licenses, if you don't plan to continue to use the current ReliaSoft 
application on a particular computer (or for a particular user), you can use the License Manager 
to deactivate it. This does not require authentication; you can proceed with the deactivation 
even if you have not entered your password. 

Click the Deactivate button in the current product area on the Products page. 

 

The application will shut down immediately after you deactivate, so you will be prompted to 
confirm that you're ready to continue. If you later try to access this application again for this 
computer/user, you will be prompted to repeat the activation process. 

BORROWING LICENSES 

For certain license types, your computer must be able to connect to a license server to 
determine whether shared license seats (or, for token-based licenses, the required number of 
CRS units) are available when you attempt to launch a ReliaSoft application. 

If you need to use the application(s) when your computer is not connected to the license 
server, you can either "borrow" or "check out" the licenses (depending on the license type). 
This reduces the number of seats (or CRS units) available to other users until the licenses are 
returned. (For ReliaSoft-hosted licenses, you can also use this feature to make sure a license 
seat will be available when you need it.) 
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Borrowing Locally Hosted Licenses 

If you have a locally hosted license, you can use the ReliaSoft License Borrowing utility to 
borrow licenses for selected product(s) for a specified duration. 

IMPORTANT: If at least one ReliaSoft product with a locally hosted license is borrowed, you will 
only be able to start the product(s) that are borrowed. All desired products must be borrowed 
or returned at the same time. Note that in versions prior to 18.0.3, you must also be 
disconnected from the license server to use the borrowed product(s). 
 
If any of the ReliaSoft applications on your computer use a ReliaSoft-hosted license (i.e., a 
license key rather than a license settings file), they will be unaffected by locally hosted license 
borrowing. For those products, see Checking Out ReliaSoft-Hosted Licenses below. 

Borrow License(s) 

Before attempting to borrow licenses, first make sure that your computer is connected to the 
license server and shut down all ReliaSoft desktop applications. 

1. To open the ReliaSoft License Borrowing utility, navigate to the ReliaSoft 2020 > Additional 
Tools folder in the Windows Start menu and click ReliaSoft 2020 License Borrowing. 

2. The window shows all of the ReliaSoft desktop applications on your computer that use 
locally hosted licensing. Specify the borrow duration and select which product(s) you want 
to borrow. (Remember that all desired products must be borrowed or returned at the same 
time.) 
 
Starting in Version 2020, this list also includes any licensed features (e.g., Accelerated Life 
testing [ALTA] in Weibull++, Process Flow Simulation in BlockSim, etc.). When you select a 
feature, the parent application is automatically selected; clearing the parent application will 
also clear the feature. 

3. Click Borrow Selected Licenses. 

4. Close the window. 

You will only be able to use the product(s) that are borrowed. Additionally, for versions prior to 
18.0.3, you can use the borrowed products only when the computer is not connected to the 
license server. If you need to change which products are borrowed, you can reconnect to the 
license server (if necessary) and repeat the same steps again (this will restart the borrow 
duration for all selected products). If you need to be able to use other (unborrowed) 
applications, you can return the licenses as described below. 
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What's Changed? Starting in version 18.0.3, you can use the products you have borrowed while 
you are connected to the license server. 

Return License(s) 

Before attempting to return licenses, shut down all ReliaSoft desktop applications and make 
sure your computer is connected to the license server. 

1. Open the ReliaSoft License Borrowing utility. 

2. Click Return All Licenses. 

3. Close the window. 

Note: Failure to shut down all ReliaSoft desktop applications prior to borrowing or returning 
licenses may result in unexpected behavior, such as inability to borrow, applications quitting 
unexpectedly or double use of license credits. 

You can borrow licenses only while your license is valid (e.g., if the annual expiration date of 
your locally hosted license is 2 days from now, you cannot borrow a license for a duration of 3 
days). In addition, you cannot borrow licenses during the 24 hours prior to annual license 
expiration. 

Checking Out ReliaSoft-Hosted Licenses 

If you have a ReliaSoft-hosted floating license, you can use the ReliaSoft License Manager to 
reserve a license. 

1. Open the ReliaSoft application. 

2. Open the License Manager by choosing File > Help and clicking the License Manager link in 
the Licensing section. 

3. In the current product area on the Products page, click Check Out or Check In. 
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Chapter 2: Databases and Projects 
The ReliaSoft desktop applications use a multi-user, database-driven approach. This offers 
enormous potential to integrate reliability program activities and tools, while simultaneously 
facilitating effective information sharing and cooperation between engineering teams of any 
size. 

Your organization (or team) will need to choose the most appropriate database type and 
security, implement shared settings that will effectively facilitate project management, and 
establish adequate backups and database maintenance to protect against data loss. In addition, 
individual users must be aware that changes are saved automatically as they work, and become 
familiar with the features that facilitate simultaneous access by multiple users. 

This chapter discusses some of the basic requirements for using ReliaSoft applications and 
projects. For information about other features, see ReliaSoft Common Tools. 

What's Changed? In versions prior to Version 2020, "databases" were known as "repositories". 

ReliaSoft Databases 

DATABASE TYPES 

ReliaSoft desktop applications offer two types of databases for storing projects and analysis 
data. The type of database you choose will depend on the requirements of your organization. 

  Standard databases (*.rsr20) are basic database files for single- or multi-user 
environments. Implementation of a database server is not required; however, there are 
limits on the amount of data and the number of simultaneous users. 

  Enterprise databases require implementation and support of Oracle or Microsoft SQL 
Server, but they are a more robust platform that can store much more analysis information 
in the same database and support access by many more simultaneous users. ReliaSoft 
applications are compatible with Microsoft SQL Server 2008 or later and Oracle 10g or later 
(including the free Express editions of all of these). They can be accessed via an enterprise 
database connection file with the extension *.rserp. 

What's Changed? Starting in Version 2019, Synthesis files (*.rsf) can no longer be created but 
you can still open Synthesis files created in prior versions. Such files will be converted to 
standard databases upon opening. 
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STANDARD DATABASES 

A standard database is a basic database file for single- or multi-user environments. 
Implementation of a database server is not required; however, there are limits on the amount 
of data and the number of simultaneous users. (If you prefer to use a more robust Oracle or 
SQL Server database, see Enterprise Databases.) 

Creating a New Standard Database 

To create a new standard database, choose File > New > Standard Database. 

 

In the Database name field, specify the filename for the new *.rsr20 file. The path where the 
file will be saved is shown below this field; to change the location, click the browse icon in the 
field. 

The following options are available when you create a new standard database: 

• Apply login security configures the new database to be login secure. You can then select 
the Open security window upon creation check box if you want to add user accounts as 
part of the database creation process. Note that you cannot automatically remove security 
from a database once it has been enabled. However, you can create a new non-secure 
database and use the Import from existing database check box to automatically import all 
of the data from the secure database to the non-secure one. 

• Import from existing database imports entire projects and other data from an existing 
database, after the new database is created. 

Opening an Existing Standard Database 

If you have opened the file recently, choose File > Recent and then select the file in the Recent 
Databases list. 

Otherwise, choose File > Open Database and then browse for the *.rsr20 file. 

If the database has login security enabled and you are unable to connect, you may be 
encountering one of the following issues: 

• No access to the database. If you have not been given access to the database, you will see 
a message stating that your account in the database is not active or not assigned to at least 
one security group. You will need assistance from someone who can create and update 
user accounts (see Managing User Accounts).  



Chapter 2: Databases and Projects 

Weibull++ 2020 User's Guide 49 

 

• Windows authentication failed. If your Windows login (domain and username) is different 
from what was specified for your user account, you will see a message to connect using 
alternative credentials. You will need assistance from someone who can enable the use of 
alternative credentials for your user account.  

Upgrading a Standard Repository from a Previous Version 

If you have a standard repository that was created in a previous version of the software, you 
can simply open it like any other standard database (File > Open Database). An upgraded copy 
will be created, with "_V20" appended to the filename. For example, if you open 
"MyDatabase.rsr10," the Version 2020 database that is created will be called 
"MyDatabase_V20.rsr20." 

It is important to remember that upgrading a standard repository will not automatically 
upgrade any library or template files that you may have been using in conjunction with that 
database, as these file types are stored separately. Please refer to the documentation on those 
files for information on upgrading them. 

IMPORTANT: For best results, the standard repository should NOT be open in the prior version. 
This ensures that all information in the repository will be converted to the new database. 

Enterprise Databases 

Unlike standard databases, enterprise databases require an established database server with 
Oracle or Microsoft SQL Server. This allows you to store more analysis information in the same 
database and support access by many more simultaneous users. ReliaSoft applications are 
compatible with Microsoft SQL Server 2008 or later and Oracle 10g or later (including the free 
Express editions of all of these). 

To establish a database server, you will need to purchase an appropriate license package from 
Oracle or Microsoft. The license, as well the IT maintenance and support needed to establish 
the database server, is separate from the license agreement for ReliaSoft software and must be 
negotiated directly with Oracle or Microsoft. 

As an alternative, you may choose to use the free versions of Oracle or SQL Server if the 
expected load for the database fits within the limited capabilities of the Express edition (as 
specified by Oracle/Microsoft). With the free editions, you can establish a functioning 
enterprise database on your own without making a large investment of time and resources. If 
your organization's needs grow beyond the capabilities of the Express edition, you can then 
upgrade to a more robust version with the appropriate IT infrastructure and support. 
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Tip: Although we cannot provide full documentation and support for third-party database 
platforms, we do provide a limited number of resources as a convenience for users who wish to 
explore the possibilities of an enterprise database implementation. For resources on SQL Server 
(including instructions for configuring the Express edition), see 
https://www.reliasoft.com/using-sql-enterprise-databases. For resources on Oracle, see 
https://www.reliasoft.com/using-oracle-enterprise-databases. 

The following topics will be of interest to database administrators: 

• Creating a New Enterprise Database 

• SQL Server Logins or Impersonation 

• Upgrading an Enterprise Database from a Previous Version 

• ReliaSoft Admin Tool 

The following topics will be of interest to all enterprise database users: 

• Creating an Enterprise Database Connection File (*.rserp) 

• Monitoring Connection Speed 

Creating a New Enterprise Database 

If your organization already has established a database server with Oracle or Microsoft SQL 
Server and you have the permissions necessary to create databases on the server, you can 
create a new enterprise database by choosing File > Manage Database > New Enterprise 
Database. 

 

Tip: If you need to be able to create an enterprise database without using a ReliaSoft desktop 
application (i.e., without taking up one of the available license seats), you can access this same 
feature from the ReliaSoft Admin tool. 

You can choose to create the new database in either Oracle or Microsoft SQL Server. 

If you choose SQL Server, you will be required to enter: 

• Server Name: The name of the Microsoft SQL Server implementation where the new 
database will be created. Note that if you are using SQL Server Express, the server name is 

https://www.reliasoft.com/using-sql-enterprise-databases
https://www.reliasoft.com/using-oracle-enterprise-databases
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usually your login for that computer followed by \SQLEXPRESS (e.g., 
Username\SQLEXPRESS). 

• Database Name: The name of the new database that will be created. 

• Options: 

• Encrypt communication secures the connection information between the ReliaSoft 
application and the enterprise database. 

• Trust server certificate. Select this option if the server has a self-signed certificate. 

If you choose Oracle, you will be required to enter: 

• Port, Host and Service identifiers for the Oracle server where the new database will be 
created. 

• The Schema of the new Enterprise database. 

• The Password for the new enterprise database schema. If you are including special 
characters in the password, you must include quotes around each special character when 
entering the password. 

• The administrative username and password for the Oracle server (entered in the Admin 
Information area). 

For either server type, select the Import from existing database check box if you want to 
import entire projects and other data from an existing database. 

Click OK to create the database. The database will not open automatically; you must connect to 
it. (See Connecting to an Existing Enterprise Database.) 

Connecting to an Existing Enterprise Database 

If your organization has already created an enterprise database on Oracle or SQL Server and 
you have an active user account, you can use an enterprise database connection file (*.rserp) to 
connect with the database. You can create this file yourself or use a file that has been created 
by someone else. 

Creating a Connection File 

To create a connection file, choose File > New > Enterprise Database Connection File. 
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This command creates an enterprise database connection file (*.rserp) that is stored locally on 
your computer; the file contains all of the necessary information for connecting to the 
enterprise database. 

Enter a name for the connection file, then choose the database type and version. 

• For a SQL Server database: 

• Select Encrypt communication if you want to encrypt the connection between the 
application and the database 

• Select Trust server certificate if the server has a self-signed certificate. 

• Select Use impersonation if you want the connection file to impersonate a Windows 
user account with a SQL Server login that can be shared by multiple users. This 
connection file can then be distributed to any user who does not have his/her own 
individual SQL Server login and is not part of a Microsoft Active Directory® group that 
has a login. (See SQL Server Logins or Using Windows Impersonation.) 

• For an Oracle database, enter the port, host and service identifiers, the database schema 
and the password for the enterprise database schema. 

• If you are including special characters in the password, you must include quotes around 
each special character when entering the password. 

Note: If you want to encrypt the connection for an Oracle implementation, you must set 
the encryption type to either "requested" or "required" for the Oracle database. For more 
information, please consult the Oracle documentation (e.g., 
https://docs.oracle.com/cd/B19306_01/network.102/b14268/asoconfg.htm#i1007808). 

Using an *.rserp File to Connect to an Enterprise Database 

If you have used the connection file recently, choose File > Recent and then select the file in the 
Recent Databases list. 

Otherwise, choose File > Open Database and then browse for the *.rserp file. 

If you are unable to connect to an enterprise database, you may be encountering any of the 
following issues: 

• No access to the database. If you have not been given access to the database, you will see 
a message stating that your account in the database is not active or not assigned to at least 
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one security group. You will need assistance from someone who can create and update 
user accounts (see Managing User Accounts).  

• Windows authentication failed. If your Windows login (domain and username) is different 
from what was specified for your user account, you will see a message to connect using 
alternative credentials. You will need assistance from someone who can enable the use of 
alternative credentials for your user account.  

• Cannot connect to the server or login failed. Server-related issues may occur for several 
reasons, and you may see various messages pertaining to the situation. Common issues are: 

• You do not have a network connection or you may have entered the incorrect database 
name or server name in the connection file. 

• The SQL Server database resides in a different domain than the one you have used to 
log in to Windows and your network cannot recognize the domain name you have 
entered. Depending on your network configuration, you may be able to connect using 
either the "fully qualified domain name" (FQDN) or the IP address for the server. 

• In SQL Server databases, a login issue may occur if your username is not associated 
with a SQL Server Login. (See SQL Server Logins or Using Windows Impersonation.) 

• The server is not configured to allow remote connections, has certain firewall settings 
or is experiencing other issues. 

Note: If you get an "error occurred when reading the connection file" message, the connection 
file may be corrupted or is using old encryption. You can create a new connection file by 
choosing File > New > Enterprise Database Connection File. 

 

SQL Server Logins or Using Windows Impersonation 

Connecting with a SQL Server database via Windows authentication requires a "SQL Server 
login" that allows the database platform to recognize the user and gives access to the ReliaSoft 
database. There are three ways that a user account may be recognized by SQL Server: 

• Individual Login: The user has an individual SQL Server login that is associated directly with 
his/her Windows username. 

• Group Login: The user belongs to an Active Directory group that has a SQL Server login 
shared by all members of the group. 
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• Use Impersonation for Connection File: The user does not have an individual or group login 
but he/she connects to the database with an enterprise connection file (*.rserp) that 
impersonates another Windows user account that does have a SQL Server login. 

Your organization may choose to use any or all of these methods for your implementation (e.g., 
some users may have their own individual logins, while other users connect using Windows 
identity impersonation). This document provides an overview of all three options. 

Option 1: Creating Individual SQL Server Logins 

If you choose to create individual SQL Server logins for some or all of the user accounts, you 
have two options. (For details and instructions on performing these tasks in SQL Server, see 
https://www.reliasoft.com/using-sql-enterprise-databases.) 

1. A database administrator for SQL Server can create SQL Server logins in advance for every 
potential user and give the logins access to the application database (at least the 
db_datareader and db_datawriter roles are required). This would be performed directly in 
SQL Server (not via one of the ReliaSoft applications). 

2. A database administrator for SQL Server can grant the appropriate level of database 
authority for creating SQL Server logins and database roles (e.g., securityadmin or 
sysadmin) to any user who has the ability to create user accounts in the ReliaSoft database. 
The additional authority would be added directly in SQL Server. Then, when any of these 
administrative users creates a new user account via the ReliaSoft application, the required 
SQL Server login can be created and the application database roles can be assigned 
automatically at the same time. 

If you are using the first approach, clear the Create SQL Server login check box that is displayed 
when you are adding or importing a user account. If you are using the second approach, you 
must select this check box. 

https://www.reliasoft.com/using-sql-enterprise-databases
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Tip: If the user already has a SQL Server login and access to the application database, it does 
not matter whether you select or clear the Create SQL Server login check box because the 
application attempts to create the login only if one does not already exist. 
 
Furthermore, if the user who is creating the user account does not have the necessary level of 
database authority in SQL Server, the login will not be created even if the check box is selected. 
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Option 2: Using a Group Login 

If the user belongs to an Active Directory group that has a SQL Server login shared by all 
members of the group and that group has access to the application database, you can clear the 
Create SQL Server login check box that is displayed when you are adding or importing a user 
account. 

For example, base installations of Microsoft SQL Server Express 2008 include the "Builtin\Users" 
Active Directory group as a SQL Server login by default. This means all users with a Windows 
account for that domain will be able to log in to the enterprise database with no need to create 
individual SQL Server logins in SQL Server Express. However, it will still be necessary to grant 
access for this group login to the application database (at least the db_datareader and 
db_datawriter roles are required). 

Option 3: Using Windows Impersonation for the Connection File  

If you choose to have some (or all) users connect to the SQL Server database with a connection 
file that impersonates a shared Windows user account that has a SQL Server login, you must do 
the following: 

• A Windows network administrator must establish the shared user account on Windows. 

• A database administrator for SQL Server must create a SQL Server login for the shared 
Windows user account and grant this login access to the application database (at least the 
db_datareader and db_datawriter roles are required). 

• A user must create an enterprise database connection file that impersonates the shared 
Windows user account: 

1. Choose File > New then click Enterprise Database Connection File. 

2. Under Database Connection Settings, select Microsoft SQL Server (2008 or later) from 
the drop-down list and then select the Use impersonation check box. 

3. Enter the server and database name for the SQL Server database, then enter the 
domain, username and password for the shared Windows account that users will need 
to impersonate. 

4. Click OK to create the connection file (*.rserp). It will be stored in the location specified 
under Connection File Name. Note that the default filename will be "SQL_(Server 
Name)_(Database Name)," but you can assign any name that fits the process your 
organization will use for distributing the file to users. (Note that while the window 
shown next is for Weibull++, the settings are the same for all ReliaSoft applications.) 
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Once you have created a connection file that impersonates the shared Windows user account, 
you can distribute the file to any user who needs it. To connect to the database using this file, 
the user can: 

1. Choose File > Open Database and browse for the connection file. 

2. Click Open to connect with the database. 

After the first connection, this *.rserp file will be saved in the list of recent databases, which can 
be accessed by choosing File > Recent. 
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Note: For the purpose of being recognized by SQL Server and accessing the application 
database, the user will be impersonating the shared Windows login. For the purpose of 
performing actions via the ReliaSoft applications, the user’s actions will be governed by his/her 
own user account in the ReliaSoft applications. In other words, multiple users can connect with 
the database using the same enterprise connection file, but their activities within the ReliaSoft 
applications will be governed by the permissions established in their own individual user 
accounts, and any changes made to the analysis data will be recorded in the application under 
their own usernames. 

Enterprise Database Connection Speed 

If the ReliaSoft desktop application is exhibiting slow performance when you’re connected to an 
enterprise database, the issue may be related to your network connection. The MDI status bar 
displays a connection speed indicator on the lower right side of the window. 

 

The following icons are used to indicate the connection speed. In cases of poor network 
performance, you will need to request assistance from the IT support group responsible for the 
server. 

< 30 ms: Good (acceptable performance) 

30 - 70 ms: OK (may exhibit some delays in operations, opening/closing windows, etc.) 

70 - 110 ms: Slow (will exhibit some delays in operations, opening/closing windows, etc.) 

110 - 150 ms: Very slow (will exhibit significant delays in operations, opening/closing 
windows, etc.) 

> 150 ms: Extremely slow (will result in unacceptable performance and usability) 

If a connection error occurs, the tooltip that is displayed when you point to the error message 
will show the associated IPStatus value. 

Upgrading an Enterprise Database from a Previous Version 

If you have an existing enterprise repository that was created in Version 8 or later of the 
ReliaSoft applications, you can transfer or convert all of the existing data into a new database 
that is compatible with the latest version. 

All of the same requirements for creating a new enterprise database apply here (e.g., you must 
have an established database server and the necessary permissions to create a database on the 
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server). In addition, you must be a member of the Admin group in the database to perform the 
task. 

Upgrading an enterprise repository will also upgrade any library files and/or templates that are 
stored within that database. 

Tip: If you need to be able to upgrade an enterprise database without using a ReliaSoft desktop 
application (i.e., without taking up one of the available license seats), you can access this same 
feature from the ReliaSoft Admin tool. 

Upgrading from Version 9 or Above 

It is strongly recommended that you create a backup of the enterprise repository to be 
upgraded. The upgrade process converts the database itself to the latest version. This change 
cannot be undone. 

To upgrade the database, choose File > Manage Database > Upgrade Enterprise Repository. 

 

In the window, specify the enterprise database that you wish to upgrade. Click OK to start the 
process. 

Upgrading from Version 8 

You do not need to create a backup before upgrading a Version 8 enterprise repository. The 
upgrade process does not involve a direct conversion of data, but rather copies over all existing 
data into a new database. This complete switch to a new database is required in order to 
support the exclusive features in the latest version. 

To upgrade the database, open the latest version of the ReliaSoft application and choose File > 
Manage Database > Upgrade Version 8 Repository. 

 

Use the left side of the window to specify the Version 8 enterprise database that you wish to 
upgrade. Use the right side of the window to define the new Version 2020 enterprise database 
that the existing data will be copied into. Click OK to start the upgrade. 
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ReliaSoft Admin Tool 

ReliaSoft desktop applications include an admin tool that allows a database administrator to set 
up and manage enterprise databases without requiring a software user license or an activated 
ReliaSoft desktop application. 

To use the ReliaSoft Admin tool, your organization must have already established a database 
server with Oracle or Microsoft SQL Server, and you must have the permissions necessary to 
create databases on the server. 

To access the tool, open the Windows Start menu and choose ReliaSoft 2020 > Additional Tools 
> ReliaSoft 2020 Admin from the programs list. Alternatively, you can open the Windows Start 
menu and type ReliaSoft 2020 Admin in the search bar. 

The following features from the ReliaSoft desktop applications are available in the admin tool. 

• Creating a new enterprise database 

• Upgrading an enterprise database from a previous version 

• Manage user accounts: 

• Adding and editing user accounts 

• Importing users from Active Directory 

• Creating alternative credentials 

• Editing user login and contact info 

• Managing security groups 

• Configuring the XFRACAS or SEP applications on a web server. For details, please consult 
the implementation guides for those web applications. 

Projects 

In ReliaSoft databases, projects serve as a way to keep related analyses together. Each project 
can contain analyses (e.g., folios, diagrams, plots, FMEAs, etc.), a Project Planner, resources 
that can be shared between analyses (e.g., models, tasks, actions, etc.) and attachments. 

Any project can be opened in any ReliaSoft application; however, application-specific analyses 
(e.g., folios in Weibull++, diagrams in BlockSim, etc.) are visible only in the application(s) that 
can edit them. 
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CREATING AND MANAGING PROJECTS 

This topic describes how to create and manage the projects that are accessible to you via the 
project list (View > Project Manager > Show Project Manager). This depends on your 
permissions in the database and any security that has been defined at the project level. 

There are three types of projects: private, public or reference. In addition, a project may be 
locked or checked out at any given time. Each type of project is displayed under the appropriate 
heading in the project list: 

 

Tip: The Manage Projects window (Project > Management > Manage Projects) allows you to 
perform administrative tasks for multiple projects all at once, and to manage the private 
projects of other users. (See Manage Projects Window.) 



Chapter 2: Databases and Projects 

62 https://www.reliasoft.com/weibull 

 

Creating a New Project 

When you create a new project, you must specify whether it will be public, private or reference. 
Select or right-click the appropriate heading in the project list and (i.e., Private, Public or 
Reference), and then choose Project > Management > Create Project. 

 

The selected project type will be displayed at the bottom of the Project Properties window. If 
desired, you can change the selection before clicking OK to create the project.  

 

Tip: If you later need to change the project type, select the project and choose Project > 
Security > [Make Private, Make Public, or Make Reference]. The same commands are also 
available in the Manage Projects window. 

Duplicating Projects 

To duplicate an existing project, select it and choose Project > Management > Duplicate 
Project. 

 

This command will create an exact duplicate of the original project with a name that contains 
an increment number (e.g., Project_1, Project_2, etc.). Note that duplicate projects do not 
retain the security settings of the original project. 

Deleting Projects 

To delete a project, select it and press DELETE or choose Project > Management > Delete 
Project. 

 

To make sure that your analysis information is not deleted by mistake, you will always be 
prompted to confirm before proceeding. By default, the project will be moved to the recycle 
bin, which will give you a chance to recover it later if needed. If you want to permanently delete 
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the project now (no way to undo unless you have a backup or restore point), clear the Send 
project to recycle bin check box in the confirmation window. 

Note: You cannot delete a reference project if any of its resources are in use, including by 
projects in the recycle bin. 

PROJECT PROPERTIES 

The Project Properties window will be displayed when you create a new project or when you 
choose Project > Management > Edit Project Properties. 

 

The options available in this window will vary depending on which application you are using and 
whether the database has login security enabled. For MPC, see MPC's Project Properties 
(below). For all other ReliaSoft desktop applications, this may include: 

• General Tab 

• Security Tab (available only for public/reference projects in secure databases) 

• Configurable Settings Tab (only in XFMEA/RCM++/RBI) 

In addition, the status bar at the bottom of the window always displays the following 
information: 

Project Owner: The user who has been identified as the project owner. In a secure database, 
the ability to edit the project properties is restricted to the project owner and to users with the 
relevant "manage all projects" permissions.) 

Last Update: The time and date the project was last changed/updated, and the user who made 
the change. This considers any change to any of the analysis data in the project (not just the 
project properties). 

General Tab 

The General tab contains the following options: 

• Name is the identifier for the project that will appear in the current project explorer and in 
many other windows and reports throughout the software. This field is required and cannot 
contain any of the following characters: \ / : " * ? < > |. 
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• Description and Remarks can contain more detailed notes or information about the 
project. 

• Proprietary Label can contain a copyright or distribution statement, if desired. This label 
may appear in the footer of some reports generated in XFMEA/RCM++/RBI or MPC. 

• Project Category allows you to assign a project category that can be used to filter the 
projects displayed in the project list and in many other windows throughout the software. 

In XFMEA/RCM++/RBI, this tab also contains: 

• FMEA Structure determines how the software will display the effect and cause records in 
the FMEA hierarchy. This is applicable only in XFMEA/RCM++/RBI. (See Choosing the FMEA 
Structure in the XFMEA/RCM++/RBI documentation.) 

• Select Profile from Library displays a list of all profiles that have been defined in the active 
library. When you choose a profile from the list, all of the configurable settings for the 
project will be set/reset based on the settings that have been predefined for that profile. If 
you are editing a project, the current profile is shown in brackets. (In a secure database, the 
ability to add and edit a profile is available only for users with the "Manage profiles and 
templates in XFMEA/RCM++/RBI" permission.) 

 

Security Tab 

The Security tab is available only when you are working with a public or reference project in a 
secure database. For a full discussion on how to use these settings, see Planning Your Security 
Approach. 

For quick access to the Security tab, you can select the project in the project list and choose 
Project > Security > Project Security. 

 

Configurable Settings Tab 

The Configurable Settings tab is available for XFMEA/RCM++/RBI only. It provides access to all 
of the configurable settings that have been defined for the current project, based on the profile 
that was selected on the General tab. 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=choosing_the_right_fmea_structural_view_type_for_your_analysis.htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=choosing_the_right_fmea_structural_view_type_for_your_analysis.htm
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This tab allows you to make specific changes that will apply to the current project only. For 
example, if you are using a predefined profile but want to make a change to the interface style 
for this particular project only, you could click the Edit icon associated with the Interface Style 
drop-down list in the Interface Settings area. 

 

It is important to note that any change to the Configurable Settings page will update the 
settings for the current project, but it will not alter the original profile. If you want the project’s 
current settings to be available as a new profile in the active library, click the Send Settings to 
Library button and then type the name and description for the new profile that will be created. 

In the Enable Legacy Analyses section, you can choose whether to allow users to create and 
use DVP&R or DRBFM analyses in the project. These settings are not part of the profile and may 
be different for each project. (See Design Verification Plans (DVP&Rs) and Design Reviews 
Based on Failure Mode (DRBFMs) in the XFMEA/RCM++/RBI documentation.) 

MPC’s Project Properties 

For users of MPC, the interface has been customized to display only the information that is 
directly relevant for MSG-3 analyses. This includes the Name, Description, Remarks and Project 
Category. In addition, you will be able to define the following: 

• Short Description appears in the header of the Standard report template. It is not 
applicable for Dassault or Sukhoi reports. 

• Proprietary Label appears in the footer of the Standard report template. It is not applicable 
for Dassault or Sukhoi reports. 

• MSG-3 Guidelines displays a list of the available MSG-3 guidelines that can be used for the 
systems and powerplant analysis. 

• In most cases, the version that you select will not have any impact on the MSG-3 logic 
displayed in the interface and print-ready reports. 

• The only substantive difference occurs when you select MSG-3 Revision 2002.1 because 
this older version of the guideline uses slightly different titles for two of the 
maintenance significant item (MSI) questions, and lists the questions in a different 
order. 

• Model/Equipment/Effectivity allows you to enter the information that will appear on the 
title page of the Dassault and Sukhoi templates. 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=design_verification_plans_dvprs.htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=design_reviews_based_on_failure_mode_(drbfms).htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=design_reviews_based_on_failure_mode_(drbfms).htm
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PROJECT OWNER 

For each project in a ReliaSoft desktop application, one user will be assigned as the project 
owner. By default, the owner will be the user who created the project, but this can be changed 
when needed. 

In a secure database, being the project owner means that you have full permissions over the 
project. This includes the ability to edit the project properties, add/edit/delete project items 
and resources, lock and unlock, set security settings, create restore points and delete the 
project. These permissions are always in effect regardless of the project security settings or 
item permissions that may be in place. 

Changing the Project Owner 

To change the owner, select the project in the project list and choose Project > Security > 
Change Owner. 

 

In a secure database, this is available only for users with the applicable "Manage all projects" 
permissions. 

Identifying the Project Owner 

There are three ways to identify the current owner of a project: 

• Use the filters in the project list to filter and/or group projects based on the project owner. 
For example: 

 

• The Project Properties window (Project > Management > Edit Project Properties) displays 
the name of the current owner in the status bar at the bottom of the window. 
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• The Manage Projects window (Project > Management > Manage Projects) displays a list of 
all projects and their owners in a table format. You can use custom filters to filter, sort 
and/or group the list based on the project owner. 

 

PUBLIC, PRIVATE AND REFERENCE PROJECTS 

In ReliaSoft databases, there are three types of projects you can create: 

• A public project may be accessible to any user who has access to the database, depending 
on the security settings that have been implemented. 

• A private project can be viewed and edited only by the project owner. The project list 
shows only your own private projects, while the Manage Projects window provides the 
ability to manage all users’ private projects (including delete, lock/unlock or changing the 
project type). 

• A reference project is like any regular public project, except that you can share its resources 
and FMEAs with other projects in the database. This gives you a pool of resources that can 
be used throughout the database by specified users (based on the security settings for the 
reference project), while allowing you to maintain fully functional analyses within the 
reference project itself. (For more information, see Local, Global and Reference Resources, 
and Linked FMEAs in the XFMEA/RCM++/RBI documentation.) 

In the project list, each type of project is displayed under the appropriate heading, as shown in 
the following example. 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=linked_fmeas.htm
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Note: In MPC, the Reference heading will appear only if reference projects already exist in the 
database (created by another ReliaSoft desktop application). You cannot create a new 
reference project or convert an existing project into a reference project in MPC. 

Setting the Initial Project Type 

When you create a new project, you must specify whether it will be public, private or reference. 
Select or right-click the appropriate heading in the project list and (i.e., Private, Public or 
Reference), and then choose Project > Management > Create Project. 

 

The selected project type will be displayed at the bottom of the Project Properties window. If 
desired, you can change the selection before clicking OK to create the project.  
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Changing the Project Type 

To change the project type for one project, select it in the project list and choose Project > 
Security and then one of the following options: 

 Make Private 

 Make Public 

 Make Reference 

To change the project type for multiple projects simultaneously, use the Manage Projects 
window instead. 

LOCKED AND UNLOCKED PROJECTS 

In all ReliaSoft databases, a project can be locked to prevent users from editing the data. If a 
project is locked, it will be moved to the Locked heading in the project list and it cannot be 
edited by any database user unless it is unlocked again. 

In a secure database, locking and unlocking a project are available only if the user a) is the 
project owner, b) has the "Lock or check out project" permission for the project or c) has the 
applicable "Manage all projects" permissions.) 
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Locking a Project 

To lock a project, select it in the project list and choose Project > Security > Lock Project. 

 

When a project is locked, all database users (including the user who locked the project) will 
have read-only access to the project. In addition, a locked project cannot be deleted or have its 
properties and public/private/reference status edited. 

Unlocking a Project 

To unlock a project, select it in the project list and choose Project > Security > Unlock Project. 

 

Tip: The Manage Projects window allows you to select multiple projects and lock or unlock 
them all at once. 

CHECK IN AND CHECK OUT PROJECTS 

In all ReliaSoft databases, both private and public projects can be checked out to temporarily 
allow one particular user to work on a project independently for a period of time and/or to 
work on a computer that is not connected to the network where the shared database resides 
(e.g., if you need to work on the project while you’re out of the office). When a project is 
checked out, two things happen: 

• An editable copy of the project will be saved into a standard database (*.rsr20) in the 
specified "Checked Out" folder on your local computer. This database will have the same 
name as the project. 

• The original project will be set to read-only and moved under the Checked Out heading in 
the project list. This allows other users who would normally be able to access the project to 
see that it is currently being edited exclusively by one particular user. It also provides read-
only access to the latest version of the project at the time it was checked out so those users 
can query, copy data, etc. while you’re editing the project "offline." 
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You can then edit the project as needed in the standard database and check the project back in 
when you’re finished. 

IMPORTANT: If the project uses resources or FMEAs from a reference project (e.g., linked 
FMEAs, models, URDs) the links won't be maintained when you check out the project. Any 
linked resources/FMEAs will be replaced with local copies of the resources/FMEAs and stored 
directly within the project. See also Local, Global and Reference Resources. 

Specifying the "Checked Out" Folder 

By default, projects will be checked out to the default Documents folder on your computer 
(e.g., My Documents\ReliaSoft\Files\Checked Out). 

To change this location, open the Backup/Check Out Options page of the Application Setup 
window and browse for a new default path under Check In/Out. Keep in mind that anyone who 
has access to the folder will have full access to the checked out project; however, only the user 
who has the project checked out will have the ability to check in the project. 

 

Tip: If you need to work on the project from a different computer after it has been checked out 
to the local folder, you will simply need to make sure that the latest copy of the standard 
database file is saved back to the exact same check-out location and filename before you check 
the project back in. 

Checking Out a Project 

To check out a project, select it in the project list then choose Project > Management > Check 
In/Out > Check Out. 

 

In a secure database, this is available only if the user a) is the project owner, b) has the "Lock or 
check out project" permission for the project or c) has the applicable "Manage all projects" 
permissions. 

Checking in a Project 

To check in a project, select it under the Checked Out heading in the project list and choose 
Project > Management > Check In/Out > Check In. 
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Note that when you check in a project, the software creates a restore point, which is an exact 
replica (i.e., a backup) of the project before it was checked out. This allows you to restore the 
project to its prior state when and if needed. The restore point will include a description of the 
user who checked out the project, as well as the date and time of the check out. (See Restore 
Points.) 

Undo Check Out 

To discard changes and restore the project to the state it was in before it was checked out, 
select the project under the Checked Out heading in the project list and choose Project > 
Management > Check In/Out > Undo Check Out. 

 

In a secure database, this is available only if the user a) is the user who checked out the project, 
b) is the project owner or c) has the applicable “Manage all projects” permissions. 

MANAGE PROJECTS WINDOW 

The Manage Project window displays a list of all the projects that currently exist for the 
database and allows you to perform administrative tasks for multiple projects all at once. If you 
have created custom project filters, you can apply those same filters in this window. 

To open the Manage Projects window, choose Project > Management > Manage Projects. 

 

In a secure database, this is available only to users with the applicable "manage all projects" 
permissions. Only the type of project that you have permissions for will be displayed. Projects 
that are under the Locked, Checked Out and Recycle Bin headings will be visible only if you have 
permissions for all three project types. 

Tasks You Can Perform 

Some of the tasks you can perform in this window include: 

• See a list of private projects created by other users (and perform any administrative tasks 
that may be needed for those projects). 

• Change multiple public projects to private all at once, and vice versa. 
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• Change the owner for multiple projects all at once. 

• Apply the same changes to the project properties for multiple projects all at once. 

• Review and edit the security settings (if applicable) for multiple projects all at once. 

• Delete, restore, lock and unlock, or undo check out for multiple projects all at once. 

• Review and sort projects based on the user who made the last change to a project, the 
date/time of the last change and the last application that was used to make the change. 

Tip: The Manage Projects window allows you to edit the properties of a project that is currently 
open or in use. When you make a change, the user who has the project open will see the 
change you have made when the database refreshes (the refresh happens automatically 
whenever the user makes a change, such as closing a window, selecting a different item, etc.). 

Tools 

The Manage Project window contains the following commands: 

Project 

  Close closes the Manage Projects window. 

  Edit Project Properties allows you to view and edit the properties of the selected 
project(s). 

  Delete Project permanently deletes the selected project(s) and bypasses the recycle 
bin. There is no undo for delete unless you have a stored backup or restore point. 

  Restore Project is available only when you have selected project(s) under the Recycle 
Bin heading. Each selected project will be recovered from the recycle bin and restored to its 
original location in the project list. 

Security 

  Change Owner assigns a different database user to be the owner for the selected 
project(s). (See Project Owner.) 

  Project Security is available only for public and reference projects in secure databases. 
It opens the Project Properties window with the Security tab active, where you can specify 
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the user accounts that can view/modify the selected project. (See Planning Your Security 
Approach.) 

  Lock Project moves the selected project(s) into the Locked heading of the project list. 
When a project is locked, all database users (including the user who locked the project) will 
have read-only access to the project. In addition, a locked project cannot be deleted or 
have its properties and public/private/reference status edited. To unlock project(s), choose 
Unlock Project. (See Locked and Unlocked Projects.) 

  Make Private moves the selected project(s) into the Private heading of the project list. 
To move private project(s) to the Public heading, choose Make Public. (See Public, Private 
and Reference Projects.) 

  Make Reference moves the selected project(s) into the Reference heading of the 
project list. To move reference project(s) to the Public heading, choose Make Public. 

Check Out 

  Undo Check Out discards all changes made to a checked out project and restores it to 
the state it was in at the time it was checked out. (See Check In and Check Out Projects.) 

Excel 

  Send to Excel exports the data currently displayed in the Manage Projects window to 
an Excel spreadsheet.   

RECYCLE BIN 

The recycle bin is a temporary storage location for projects that have been deleted. It gives you 
a chance to restore the deleted project to its original location, if needed. Projects in the recycle 
bin are stored until you either empty the recycle bin or delete each individual project from the 
recycle bin. 

Sending Projects to the Recycle Bin 

Whenever you delete a project from a database, a confirmation window like the one shown 
next will appear. 
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If you want to move the project to the recycle bin, make sure the Send project to recycle bin 
check box is selected. If you want to immediately and permanently delete the project, clear the 
check box. Remember that once you empty or delete a particular project from the recycle bin, 
there will be no way to get it back unless you have previously created a backup or restore point. 

Restoring and Deleting Projects from the Recycle Bin 

In a secure database, the ability to restore and delete projects from the recycle bin is available 
only if the user a) is the project owner, b) has the "Delete project" permission, or c) has the 
applicable "manage all projects" permissions). 

To restore a project from the recycle bin, select it and choose Project > Management > Recycle 
Bin > Restore Project. 

 

To permanently delete a project in the recycle bin (no way to undo unless you have a backup or 
restore point), select it in the recycle bin and choose Project > Management > Recycle Bin > 
Delete Project. 

 

To permanently delete all projects currently in the recycle bin (no way to undo unless you have 
a backup or restore point), select the Recycle Bin heading in the project list and choose Project 
> Management > Recycle Bin > Empty Recycle Bin. 
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Security 

All enterprise databases use login security, meaning that the ReliaSoft applications use 
Windows authentication (or alternative credentials) to identify each user and control the user’s 
access via security groups. For a standard database, you can choose whether to apply login 
security; if you don’t, any user who has read/write access to the file will have full permissions 
throughout the database. 

By default, each user in a secure database will have the same set of permissions for every 
public/reference project in the database (e.g., Jane Engineer has read-write access to all 
projects, Bill User has read-only access to all projects, and so on). Alternatively, you can 
configure the database to provide different permissions for different public/reference projects, 
if desired (e.g., Jane Engineer has read-write access to all of Department A’s projects, but she 
has read-only access to other projects). With either approach, you also have the option to 
further limit access for specific project items (e.g., folios, diagrams, system hierarchy items, 
etc.) if needed. There are many different ways these options can be configured depending on 
your organization’s particular needs. 

Tip: If you need to be able to manage an enterprise database without using a ReliaSoft desktop 
application (i.e., without taking up one of the available license seats), you can access the same 
security features from the ReliaSoft Admin tool. 

APPLYING LOGIN SECURITY 

All enterprise databases use login security. For standard databases, there are two ways to apply 
login security if desired: 

• Upon creating a new standard database (File > New), you can make it login secure by 
selecting the Apply login security check box. 

 

• For an existing standard database, you can apply login security at any time by choosing File 
> Manage Database > Users and Security and then clicking the Apply Login Security button 
at the lower left corner of the window. 
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When you create an enterprise database or apply login security to a standard database, you will 
automatically be a member of the Admin security group, which has full permissions throughout 
the database. You can then use the Users and Security window to add/edit/delete other user 
accounts and assign them to appropriate security groups. 

Note: You cannot automatically remove security from a database once it has been enabled. 
However, you can create a new non-secure database and use the Import from existing 
database check box to automatically import all of the data from the secure database to the 
non-secure one. 

PLANNING YOUR SECURITY APPROACH 

In secure databases, there are two basic factors that determine what a typical user can see and 
do in the database: the security group(s) that the user account belongs to and the 
public/reference project security settings. 

This topic discusses two general approaches you can use to configure the security groups and 
project security settings to fit your organization’s specific needs: 

• Same permissions for all public/reference projects 

• Different permissions for different public/reference projects 

Tip: In addition to these considerations, it is also important to note the following: a) Users with 
the applicable "manage all projects" permissions (in any of the security groups that they belong 
to) will always have full project-level permissions for all public or reference projects in the 
database; b) The project owner will always have full project-level permissions within that 
particular project; and c) The item permissions can be used to further limit access to specific 
items within a project (e.g., folios, diagrams, system hierarchy items, etc.). 
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Same Permissions for All Public/Reference Projects 

If you want each user to have the same set of permissions for all public/reference projects in 
the database (e.g., Jane Engineer has read-write access to all projects, Bill User has read-only 
access to all projects, and so on), follow these steps: 

1. User Accounts and Security Groups: Assign each user account to an appropriate security 
group. This can be one of the four security groups that are created by default in each new 
ReliaSoft database — Admin, Power, User (Read/Write) or View (Read-Only) — or you can 
configure new or existing security groups to meet your particular needs. 
 
Select or clear the Allow access to projects with database-level security check box. If some 
of the projects in the database will continue to use database-level security, this allows you 
to specify whether each user will be able to access those projects. 

• If the option is selected (default), the user will be able to access any public/reference 
project that is set to use database-level security, with the combined permissions from 
any of the assigned security groups. 

• If the option is cleared, the user will only be able to access a project if it is specifically 
assigned to a security group that he/she belongs to, or if the user account is specifically 
assigned to the project. 
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2. Project Security: Accept the default option on the Security tab of the Project Properties for 
all public and reference projects (Project > Security > Project Security). Note that if a user 
belongs to more than one security group (and the Allow access to projects with database-
level security check box is selected for his/her user account), that user will have the 
combined permissions of those groups in any project that is set to database-level security. 
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Different Permissions for Different Public/Reference Projects 

If you want the same user to have different permissions for different public/reference projects 
(e.g., Jane Engineer has read-write access to all of Department A’s projects, but she has read-
only access to other projects), follow these steps: 

1. Security Groups: Create a security group for each distinct type of access that users might 
need in any particular public/reference project. Here’s a simple example: 
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2. User Accounts: Assign the appropriate security group(s) to each user account. For the 
example shown below, the user will have read/write permissions in projects that are 
assigned to "Department A," and read-only access in projects that are assigned to "Read-
Only." 

 

If some of the projects in the database will continue to use database-level security, the 
Allow access to projects with database-level security check box gives you the option to 
decide whether each user will be able to access those projects. 

• If the option is selected (default), the user will be able to access any public/reference 
project that is set to use database-level security, with the combined permissions from 
any of the assigned security groups. 
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• If the option is cleared, the user will only be able to access a project if it is specifically 
assigned to a security group that he/she belongs to, or if the user account is specifically 
assigned to the project. 

3. Project Security: Assign the appropriate security group(s) and/or specific user(s) for every 
public/reference project in the database. 

• When you assign a security group, every user who belongs to that group will be able to 
access the project with the permissions that are specified in the group. 

• When you assign a specific user, the combined permissions from all of the security 
groups that the user belongs to will be displayed. Use the check boxes to select which 
of those permissions will be in effect for that user in this particular project. 

4. For the example shown below, users from Department A will have read/write access 
(because they belong to the "Department A" security group), users from Departments B 
and C will have read-only access (because they belong to the "Read-Only" security group) 
and Fred Consultant will have read/write access (because he belongs to the "Consultants" 
security group and has been specifically assigned to have those permissions in this project). 
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User Accounts 

Every person who will access a ReliaSoft database, be assigned to some role in an assigned 
action, and/or receive alerts via e-mail or SMS message must have a personalized user account 
in the database. 

• In non-secure databases, the software automatically creates an account for anyone who 
opens the file. Every user has full permissions throughout the database, including the ability 
to create, edit or delete other user accounts (e.g., so you can modify contact information or 
send alerts to someone who has not yet had an account created automatically). 

• In secure databases, the accounts must be created and managed by users with the 
"Manage users and logins" permission. The security group(s) assigned to each account 
determines what the user can see and do in the database. 

To view and manage the user accounts in a database, choose File > Manage Database > Users 
and Security. 
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This topic describes how to use the Users and Security window to create, edit or 
delete/deactivate user accounts. The same window can also be used to enable login security for 
a standard database, and to manage security groups (permissions) for a secure database. 

Starting in Version 2020, in enterprise databases, you can click the Report button at the bottom 
of the Users and Security window to generate an Excel spreadsheet that includes: 

• All security groups and the permissions assigned to them. 

• All users and the security groups they belong to. 

Built-in Find/Filter, Configuration and Grouping Tools 

The Users tab of the Users and Security window offers the same filter, column configuration 
and grouping tools that are built in to other utilities that use a similar grid (e.g., the Analysis 
Explorer, Actions Explorer, etc.). For details about how to use each feature, see: 

• Finding and Filtering Records 

• Configuring Columns 

• Grouping Panel 

Creating and Editing User Accounts 

The Users tab of the Users and Security window displays a table of all user accounts that have 
been created in the database. You can use the Add or Edit buttons below the table to create or 
modify individual accounts. 

You can also import user accounts from Microsoft Active Directory by clicking the Active 
Directory button. (See Importing Users from Active Directory.) 

Keep in mind the following requirements when creating new user accounts for a secure 
database: 

• In order to use Windows authentication, the user must be logged in to a computer with the 
same domain/username that is defined in the user account. If a user needs to connect to a 
database from a different domain, you can set up alternative credentials that will allow 
access without domain authentication. (See Creating Alternative Credentials.) 
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• In order to access the database, the user account must be assigned to at least one security 
group. (If you simply wish to send e-mail alerts to the user, a security group is not 
required.) 

• For SQL Server databases, the username must be associated with a "SQL Server Login" that 
allows the database platform to recognize the user and give access to the application 
database. This can be accomplished with an individual login, a group login or Windows 
impersonation. (See SQL Server Logins or Using Windows Impersonation.) 

The Run As button below the table allows you to change your current connection to run as the 
user currently selected in the table. This allows you to test that user's permissions to be sure 
that they are set as you intended. Depending on the permissions that user has, you may have to 
close the database and reconnect to it in order to change back to your own account. 

Deleting or Deactivating User Accounts 

If an account has never been used and you want to permanently remove it, select the account 
name from the list and click Delete. 

If an account has already been logged in at least once (the Last Login column shows this 
information), attempting to delete the account will deactivate it instead. A deactivated account 
will not have access to the database. 

You can manually deactivate an account by clearing the check box in the Active column for the 
account. To reactivate the account and give the user access to the database again, select the 
check box in the Active column. 
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User Login and Contact Information 

The User Login and Contact Information window contains the contact information, alerts 
preferences and action resource details for an individual user. In a secure database, it also 
includes access settings (security groups and alternative credentials). 

To view or edit your own user account, double-click your name in the MDI status bar or choose 
My Portal > Users > My Profile. 

 or   

To view or edit any user account in the database, choose File > Manage Database > Users and 
Security, then double-click any row in the Users table. (In a secure database, this is available 
only for users with the "Manage users and logins permission.") 

All of the user account options are described below. Some of these settings cannot be modified 
when you are editing your own profile. 

User Info Tab 

• Domain and Username contain the credentials used by Windows authentication to identify 
the user and give him/her access to the database. 

• Contact Details. Each user can update his/her own contact details, if desired. Note that the 
Display Name will appear in all projects, analyses and plots you create or modify in the 
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database. Click the Active Directory button to update the contact details based on 
information stored in Active Directory. 

• User Image. Each user can save a profile photo, which will appear in locations such as the 
User Page of My Portal. Saved images are resized to 100 x 100 pixels. 

• Security Groups control the user's access to the database. (See Managing Security Groups.) 

• Allow access to projects with database-level security 

• If the option is selected (default), the user will be able to access any public/reference 
project that is set to use database-level security, with the combined permissions from 
any of the assigned security groups. 

• If the option is cleared, the user will only be able to access a project if it is specifically 
assigned to a security group that he/she belongs to, or if the user account is specifically 
assigned to the project. 

For more information, see Planning Your Security Approach. 

• Update security groups upon login (if associated with Active Directory) 

• If the option is selected (default), the user's security groups will be assigned 
automatically based on his/her security group in Active Directory. (See Associating 
Security Groups with Active Directory.) 

• If the option is cleared, the user can be manually assigned to any of the available 
security groups. 

• Active. Clear or select the check box to deactivate or activate the account. A deactivated 
account will not have access to the database. 

Alerts/Actions Tab 

• Receive automated alerts. Each user can choose to receive alerts via e-mail, SMS text 
message or ReliaSoft portal messages. (See Watches and Alerts and What is Your SMS 
Address?) Note that alerts via e-mail and SMS text are available only if a valid SMTP server 
has been defined for the database and the user account has an e-mail address/SMS contact 
defined. 

• When assigned to actions. When a user account is assigned to an action (either as the 
Person Responsible or as part of the Team resource), the Cost Category and Hours per Day 
are used to calculate resource utilization and costs. (See Costs and Man Hours.) 
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Alternative Credentials Tab 

The Alternative Credentials tab is available only for secure databases. Select the check box to 
allow the user to bypass Windows authentication and connect to the database using an 
alternative username and password. (See Creating Alternative Credentials.) 

Importing Users from Active Directory 

If your organization uses Microsoft Active Directory, this topic explains how to import 
username and contact information from the directory to create new user accounts in the 
ReliaSoft database. (If you also wish to use Active Directory to manage the membership in 
security groups, see Associating Security Groups with Active Directory.) 

To import users from Active Directory, choose File > Manage Database > Users and Security, 
click the Active Directory button, and then follow these steps: 

1. Enter or select the domain name in the Domains field. If your organization’s directory is 
large, you may also choose to limit the search to specific groups by clicking Load Groups 
and then choosing an option from the drop-down list. You can also use the Filter By field to 
further limit the search. When you have specified the desired filters, click Load Users to 
update the table. 

 

2. In the table of user accounts that match the filter criteria, select the check box for each 
user you want to create a account for. (The names of users who already have an account in 
the current database will appear grayed out.) 

3. For secure databases only, use the Import as Members Of field to select the security 
group(s) that will be assigned to the new user account(s). If you skip this option now, you 
can assign security groups later for each individual account. (See Managing Security 
Groups.) 
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4. For SQL Server databases only, select the Create SQL Server login check box if you want to 
create an individual SQL Server login for each new user account. (See SQL Server Logins or 
Using Windows Impersonation.) 

 

5. Click Import to create the account(s). After the process completes, the window will remain 
open to allow you to import additional users, if desired. 

Creating Alternative Credentials 

Secure databases use Windows authentication by default. This means that users must be 
logged in to a computer using the same domain and username specified for their user accounts. 
You can, however, allow specific users to bypass Windows authentication as needed. This may 
be useful for situations where: 

• A user needs to work on a copy of a secure standard database on a computer that is not 
connected to the company's network. 

• A user needs to connect to an enterprise database from a different domain. 

For these situations, you can set up alternative credentials for a user’s account that will allow 
that user to access the database without domain authentication. These credentials must be set 
up in advance, before the user attempts the connection. 

If you have the "Manage users and logins" permission, you can create alternative credentials 
for a user account by following these steps: 

1. Open the Users and Security window (File > Manage Database > Users and Security). On 
the Users tab, select the account name from the list and click Edit. 

2. In the User Login and Contact Information window, click the Alternative Credentials tab 
and then select the check box to enable alternative credentials. 

3. With the setting enabled, create an alternative username and password for the account. 
The username and password must be unique within the database, and the password is CaSe 
SeNsiTiVe. 
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Once you have created the credentials, instruct the user to enter this login whenever the 
database prompts for it. The database will ask for the alternative credentials whenever the user 
account cannot be matched based on domain authentication.   

Tip: The first time you connect to a database using alternative credentials, the application will 
automatically remember the login information on your computer. If you wish to clear the saved 
login, you can click the Clear Alternative Credentials link on the Other Common  Settings page 
of the Application Setup. 

User Groups 

The User Groups window (formerly called "Notification Groups") allows you to create and 
manage groups of users that can be assigned throughout the current database for: 

• Recipients for portal messages 

• Monitors for assigned actions 

• Team members in the Project Planning Resources 

To access the window, choose File > Manage Database > User Groups. 

 

In a secure database, this is available only for users with the "Manage users and logins" 
permission. 

Adding or Editing a Group 

The table displays a list of the user groups that have already been defined in the current 
database. 

To add a new group, click Add. 

To view or edit an existing group, double-click the row or select the row and click Edit. 
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The Available Users list shows all of the user accounts in the current database that are not yet 
assigned to the group. Double-click or use the buttons to move at least one user into the 
Selected Users list. 

Deleting a Group 

To delete an existing group, select a row and click Delete or press the DELETE key. 

If the user group has been assigned to any existing actions, messages or project planning teams, 
the group will be removed automatically and those users will no longer be assigned in the 
affected records. There is no undo for delete. 

MANAGING SECURITY GROUPS 

In a secure database, security groups control what users can see and do in the database. By 
default, the software includes four predefined security groups: Admin, Power, User and View. 
The Admin group, which has full permissions throughout the database, can neither be deleted 
nor have its permissions modified. For the other predefined groups, you can edit their 
permissions or replace them with new groups that fit the specific way the database will be 
used. 

As discussed in Planning Your Security Approach, there are two basic approaches you can use: 

• Same permissions for all public/reference projects – each user account is assigned to one 
security group and all public/reference projects use the default security option (database-
level security). 

• Different permissions for different public/reference projects – each user account may be 
assigned to multiple security groups and each public/reference project may be accessed 
only by specific security groups and/or users. 
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Note: If your organization has implemented an SEP web portal for an enterprise database and 
the site is configured to enable access by nCode Aqira users, a special "Aqira" security group 
will be created. This security group cannot be deleted, but you can modify the permissions that 
will be available to Aqira users. 

Creating, Editing or Deleting Security Groups 

You can manage the security groups by choosing File > Manage Database > Users and Security. 
(In a secure database, this is available only to users with the "Manage users and logins" 
permission.) 

 

In the Users and Security window, click the Security Groups tab to see all the security groups 
that have been created in the database. Use the Add, Edit or Delete buttons below the table to 
manage the groups. 

When you edit a security group, the left side of the Security Group window allows you to 
choose the permissions, while the right side shows all the users currently assigned to the group. 

If you have selected to Associate this security group with an Active Directory group, the list of 
assigned users can be updated automatically, or you will only be able to manually import/assign 
users who belong to the designated Active Directory group. (See Associating Security Groups 
with Active Directory.) 
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Starting in Version 2020, in enterprise databases, you can click the Report button at the bottom 
of the Users and Security window to generate an Excel spreadsheet that includes: 

• All security groups and the permissions assigned to them. 

• All users and the security groups they belong to. 

Permissions 

Here is a summary of all the permissions that can be granted to a particular security group. 
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Basic permissions throughout database 

These permissions apply throughout the database if they are in any of the security groups that 
the user belongs to. These permissions do not depend on the security settings for a particular 
project. 

Create and own 
private projects 

You can create and own private projects in the database that are 
accessible only to you. (Users with the "Manage all private projects" 
permission can still perform administrative tasks on all private 
projects, such as editing their properties, locking them, converting 
them to public projects, etc.) 

Create and own 
public projects 

You can create and own public projects that other users can view and 
edit (depending on the project security settings). 

Create and own 
reference projects 

You can create and own reference projects for sharing resources and 
FMEAs with other projects in the database (depending on the project 
security settings). 

Create portal 
messages 

You can create new messages and edit or delete the messages you 
have personally created via the Messages page in My Portal. 

Publish to SEP web 
portal 

You can publish your progress, results and analyses from a given 
project to the SEP web portal, making the information accessible 
from any web-enabled device. 

Open desktop apps 
from SEP web portal 

You can use the Open buttons on the FMEAs and analysis summary 
pages in the SEP web portal to open those applications using Remote 
ReliaSoft. 

Create/edit/delete 
RDW data 
collections 

You can create, edit and delete data collections in the Reliability Data 
Warehouse (RDW). This includes data extraction from XFRACAS as 
well as custom connections, and confers the ability to create 
dashboard layouts for custom connections. See Reliability Data 
Warehouse (RDW) in the Weibull++ documentation. 

http://help.reliasoft.com/weibull20/index.htm#t=reliability_data_warehouse_rdw.htm
http://help.reliasoft.com/weibull20/index.htm#t=reliability_data_warehouse_rdw.htm
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Basic and advanced permissions at project level 

A user can have these permissions in some projects but not others, depending on the project 
security settings. Regardless of the project security settings, these permissions are always 
automatically granted to the current project owner and anyone else that can manage the 
project. 

Read You can perform tasks that do not modify the data in the project 
(e.g., view the analysis, calculate metrics in a Quick Calculation Pad, 
export data, etc.). 

Create/edit project 
items 

You can create and edit items in a given project such as folios in 
Weibull++, diagrams in BlockSim, etc., as well as update the item 
properties. Starting in Version 2020, in order to create and edit 
system hierarchy items in XFMEA/RCM++/RBI, you must also have 
the "Add/insert new system hierarchy items in XFMEA/RCM++/RBI" 
permission. 

Create/edit/delete 
own resources 

You can create resources (e.g., URDs, models, etc.) and edit or delete 
any existing resources you have created. 

Delete project items You can delete any item in a given project (e.g., folios in Weibull++, 
diagrams in BlockSim, etc.). Starting in Version 2020, in order to 
delete system hierarchy items in XFMEA/RCM++/RBI, you must also 
have the "Delete system hierarchy items in XFMEA/RCM++/RBI" 
permission. 

This permission cannot be assigned unless you also have the 
"Create/edit project items" permission. 

Create/edit project 
plans 

You can create and edit project plans for a given project. 

Create/edit/delete 
local resources 

You can create, edit and delete any local resources in the project (not 
just the ones that you created). 

Set project security You can control who can view and edit a given project. This 
permission allows you to configure both project security settings and 
item permissions. 

Edit project 
properties 

You can use the Project Properties window to edit the name, 
description, category and other settings of a given project. 
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Lock or check out 
project 

You can: 

• Lock and unlock a given project. 

• Check in and check out a given project. 

Create restore 
points 

You can utilize restore points for a given project, which are exact 
replicas of the project at a particular point in time (i.e., backups). 

Delete project You can delete a given project. 
Add/insert new 
system hierarchy 
items in 
XFMEA/RCM++/RBI 

You can add/insert new items into the system hierarchy in XFMEA, 
RCM++ and RBI. See Building the System Hierarchy in the 
XFMEA/RCM++/RBI documentation. 

This permission cannot be assigned unless you also have the 
"Create/edit project items" permission. 

Edit system 
hierarchy items 
properties in 
XFMEA/RCM++/RBI 

You can edit the item properties for system hierarchy items in 
XFMEA, RCM++ and RBI. See Item Properties in the 
XFMEA/RCM++/RBI documentation. 

This permission cannot be assigned unless you also have the 
"Create/edit project items" permission. 

Add new analyses to 
system hierarchy 
items in 
XFMEA/RCM++/RBI 

You can create new analyses for system hierarchy items in XFMEA, 
RCM++ and RBI. See Associated Analyses and Diagrams in the 
XFMEA/RCM++/RBI documentation. 

This permission cannot be assigned unless you also have the 
"Create/edit project items" permission. 

Move system 
hierarchy items in 
XFMEA/RCM++/RBI 

You can move system hierarchy items (move up, move down, 
promote, demote) in XFMEA, RCM++ and RBI. See Building the 
System Hierarchy in the XFMEA/RCM++/RBI documentation. 

This permission cannot be assigned unless you also have the 
"Create/edit project items" permission. 

Delete system 
hierarchy items in 
XFMEA/RCM++/RBI 

You can delete items from the system hierarchy in XFMEA, RCM++ 
and RBI. 

This permission cannot be assigned unless you also have the "Delete 
project items" permission. 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=adding_and_deleting_items.htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=item_properties.htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=associated_analyses_and_diagrams.htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=adding_and_deleting_items.htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=adding_and_deleting_items.htm
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Activate/Manage 
change logs in 
XFMEA/RCM++/RBI 

You can enable and manage change logs within a given project. 
Change logs can be created for FMEAs, DVP&R, Control Plan and P-
Diagram analyses in XFMEA, RCM++ and RBI. See Change Logs in the 
XFMEA/RCM++/RBI documentation. 

Deactivate change 
logs in 
XFMEA/RCM++/RBI 

You can deactivate change logs within a given project. 

Review change logs 
in 
XFMEA/RCM++/RBI 

You can implement electronic approval tracking for change logs 
within a given project. See Electronic Approval Tracking in the 
XFMEA/RCM++/RBI documentation. 

  

Administrative permissions throughout database 

These permissions apply throughout the database if they are in any of the security groups that 
the user belongs to. These permissions do not depend on the security settings for a particular 
project. 

Manage users and 
logins 

You can: 

• Use the Users and Security window to add user accounts to 
the database and define security groups, as well as create 
alternative credentials for user accounts. 

• Use the User Groups window to add and manage distribution 
groups for e-mail alerts, portal messages, action alerts and 
projecting planning resources. 

• Use the Database Logins window to view and export a 
history of database logins. 

• Use the Reset "In Use" Flags window to clear the "in use" 
status for selected database users (not just your own). 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=change_logs.htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=electronic_approval_tracking.htm
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Manage project 
planning resources 
and working days 

You can: 

• Use the Project Planning Resources window to manage the 
cost categories, teams, materials and facilities that are used 
for tracking resource utilization in Project Planner gates and 
actions. 

• Use the Working Days/Holidays window to specify the 
business days that will be used for Project Planner gates and 
actions. 

Manage 
project/item 
categories 

You can use the Project/Item Categories window to define the 
project and item categories that can be used for grouping and 
filtering projects and items in the database. 
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Manage other 
database settings 

You can: 
1.  

• Use the Unit Settings window to define the unit and 
measurement settings available for use in any project within 
the database. 

• Use the Default Name Formats window to specify how 
default names for resources and blocks are created. 

• Use the Task Types window in RCM++, RBI and MPC. 

• In RCM++ and RBI, you can map the task types that are 
used only in RCM++/RBI to the task classes in the 
universal reliability definition (URD). See Task Types in 
RCM++/RBI in the RCM++/RBI documentation. 

• In MPC, you can modify the abbreviations used for MSG-
3 task types. See Task Type Abbreviations in MPC in the 
MPC documentation. 

• Use the Database Settings window to set some default 
settings for existing and new databases. This includes 
enabling e-mail alerts for the database, activating history 
logs, etc. 

• Set up XFRACAS connection settings that allow ReliaSoft 
desktop applications to access the XFRACAS data stored in 
the database. This is available only for standard databases 
(*.rsr20). 

Create/edit/delete 
global resources 

You can create, edit and delete any global resources in the project 
(not just the ones that you created). In addition, you can transfer 
data from XFRACAS to the RDW. See Extracting Data from XFRACAS 
in the Weibull++ documentation. 

Approve actions You can review and approve actions, which are resources that allow 
you to track progress made in a project. 

Manage all portal 
messages 

You can edit or delete any messages that are visible to you via the 
Messages page in My Portal. This includes any messages for which 
you are the creator or one of the recipients. 

Manage dashboard 
layouts 

You can create and save layouts for use in the Dashboard Viewer in 
Weibull++ and BlockSim. 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=task_types.htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=task_types.htm
http://help.reliasoft.com/mpc20/index.htm#t=defining_task_type_abbreviations.htm
http://help.reliasoft.com/weibull20/index.htm#t=extracting_data_from_xfracas.htm
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Manage profiles and 
templates in 
XFMEA/RCM++/RBI 

This permission is available only in enterprise databases. You can: 

• Use the Profiles/Library Manager window in 
XFMEA/RCM++/RBI to configure the predefined settings 
stored in the active library of the enterprise database. See 
Profiles/Library Manager in the XFMEA/RCM++/RBI 
documentation. 

• Use the Templates Manager window in XFMEA/RCM++/RBI 
to configure report templates stored in the enterprise 
database. See Templates Manager in the XFMEA/RCM++/RBI 
documentation. 

Manage Lambda 
Predict database 
settings 

You can: 

• Use the FIDES Settings Manager window in Lambda Predict 
to configure the FIDES-related settings stored in the 
database. This applies to the FIDES prediction standard only 
(see FIDES Settings Manager in the Lambda Predict 
documentation). 

• Use the Custom Derating Standards Manager window in 
Lambda Predict to create, edit or delete user-defined 
derating standards stored in the database. See Creating 
Custom Derating Standards in the Lambda Predict 
documentation. 

• Use the MIL-217 Custom Connections window in Lambda 
Predict to define failure rates for user-defined connectors 
stored in the database. This applies to the MIL-217 
prediction standard only. See MIL-217 Custom Connection 
Types in the Lambda Predict documentation. 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=profiles_libraries_manager_window.htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=templates_manager.htm
http://help.reliasoft.com/lp20/index.htm#t=manage_fides_settings.htm
http://help.reliasoft.com/lp20/index.htm#t=custom_derating_standards.htm
http://help.reliasoft.com/lp20/index.htm#t=custom_derating_standards.htm
http://help.reliasoft.com/lp20/index.htm#t=custom_connection_types.htm
http://help.reliasoft.com/lp20/index.htm#t=custom_connection_types.htm
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Manage MPC 
Settings 

You can: 

• Use the Manage ATA Chapters window in MPC to define the 
systems and subsystems that are available for use in the 
database. See Managing ATA Chapters in the MPC 
documentation. 

• Use the Manage Major Zones window in MPC to define the 
zones and major sub-zones that are available for use in the 
database. See Managing Major Zones in the MPC 
documentation. 

• Use the Configurable Options for Systems and Powerplant 
Analysis window in MPC to enable or disable the display of 
some item properties and task properties fields. See 
Configurable Options for Systems and Powerplant Analysis in 
the MPC documentation. 

• Use the Configurable Options for Structural Analysis window 
in MPC to customize the settings for environmental 
deterioration (ED) and accidental damage (AD) analyses that 
can be performed for any structural item in MPC Plus. See 
Configurable Options for Structural Analysis in the MPC 
documentation. 

• Use the Configurable Options for Zonal and L/HIRF Analysis 
window in MPC to customize the settings for the standard 
zonal, enhanced zonal and L/HIRF analyses that can be 
performed for any zonal item in MPC Plus. See Configurable 
Options for Zonal and L/HIRF Analysis in the MPC 
documentation. 

Manage all public 
projects 

You have all the basic and advanced project-level permissions for 
public projects in the database. You can also change the project 
owner for any public project in the database. 

Manage all 
reference projects 

You have all the basic and advanced project-level permissions for 
reference projects in the database. You can also change the project 
owner for any reference project in the database. 

Manage all private 
projects 

You have all the basic and advanced project-level permissions for 
private projects in the database. You can also change the project 
owner for any private project in the database. 

 

http://help.reliasoft.com/mpc20/index.htm#t=managing_ata_chapters.htm
http://help.reliasoft.com/mpc20/index.htm#t=managing_major_zones.htm
http://help.reliasoft.com/mpc20/index.htm#t=show_hide_optional_properties_window.htm
http://help.reliasoft.com/mpc20/index.htm#t=structural_analysis_configurable_ratings.htm
http://help.reliasoft.com/mpc20/index.htm#t=zonal_analysis_configurable_settings.htm
http://help.reliasoft.com/mpc20/index.htm#t=zonal_analysis_configurable_settings.htm
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ASSOCIATING SECURITY GROUPS WITH ACTIVE DIRECTORY 

If your organization uses Microsoft Active Directory (AD), you can give an AD group a specific 
set of permissions in the ReliaSoft database. The members of the AD group can then access the 
database based on the set of permissions associated with the group. 

In addition, the software offers the option to automatically update the permissions of a user 
whenever that user is added or removed from an AD group. For example, if a user is moved 
from AD group A to AD group B, his/her user account can be automatically updated with the 
permissions associated with AD group B. The changes will take effect the next time the user 
connects to the database via any of the ReliaSoft desktop applications. (Note that for users who 
will connect only via the SEP web portal, you’ll need to update their permissions manually 
either via a desktop application or the ReliaSoft Admin tool on the web server.) 

Tip: Multiple security groups can be assigned to the same user account, if appropriate. For 
example, a user can be assigned to the "ABC Team" group (which is associated with Active 
Directory) and the "Read-Only" group (which is not). (See Planning Your Security Approach.) 

Assigning Permissions to an Active Directory Group 

To associate a security group with an Active Directory group, choose File > Manage Database > 
Users and Security and click the Security Groups tab. Then double-click the security group you 
want to edit. 

In the Edit Security Group window, select the Associate this security group with Active 
Directory check box, and then specify the domain name and Active Directory group to use. 
There are two additional options, which apply only when users log in from a ReliaSoft desktop 
application: 

• Automatically update this security group's members. If a user is added to the AD group, 
his/her user account will automatically have this set of permissions the next time the user 
logs in to the database via any of the ReliaSoft desktop applications. Likewise, if the user 
leaves the AD group, his/her user account will no longer have this set of permissions. 

If you do not want the changes in Active Directory to be automatically applied to a 
particular user, clear the Update security groups upon login check box in that user's 
account in the ReliaSoft database. 

• Automatically create new user accounts on first login. If a member of the AD group does 
not already have a user account, it will be created automatically (and assigned to this 
security group) the first time he/she tries to connect via any of the ReliaSoft desktop 
applications. 
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Creating/Updating Accounts Now 

If you don’t want to wait for all users to log in before creating/updating their user accounts, 
click the Assign button at the bottom of the window. 

• To create new accounts, choose Import users who are members of this Active Directory 
group. This opens the Import Users from Active Directory window, but you can only choose 
users from the associated Active Directory group. 

• To update the security groups for existing accounts, choose Assign existing database users 
who are members of this Active Directory group. This shows a list of existing users who 
also belong to the associated Active Directory group; you can select to update any or all of 
their accounts. 

SETTING ITEM PERMISSIONS 

In a secure database, all project items (e.g., folios, diagrams, system hierarchy items, etc.) are, 
by default, set to inherit their permissions from the project. This means that if a user has the 
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"Create/edit items" permission for the project, he or she will be able to edit all of the items by 
default. If you want to prevent some or all of those users from editing a particular item (i.e., 
lock or limit access to the item), you can use the Item Permissions window. 

The window functions a little differently depending on whether you’re working with items in a 
project explorer (e.g., folios, diagrams, etc.) or items in a system hierarchy. 

Project Explorer Items 

In Weibull++, BlockSim or Lambda Predict, select the item in the current project explorer and 
choose Project > Current Item > Item Properties. (In a secure database, this is available only if 
the user a) is the project owner, b) has the "Set project security" permission, or c) has the 
applicable "Manage all projects" permissions.) 

 

The settings are displayed on the Permissions tab of the properties window. 

In the Item Permissions window, select the Restrict editing to selected project users option 
and then select which specific users will be able to edit this particular item. All others can view, 
but not edit, the item. Only users with editing rights to the project will appear in the list. 

To remove item permissions and change the security settings back to the defaults, select the 
Inherit from project option. 

System Hierarchy Items 

In XFMEA, RCM++ or RBI, select the item and choose System Hierarchy > Current Item > Item 
Permissions. In MPC, select an item and choose Security > Item Permissions on the relevant 
ribbon tab. (In a secure database, this is available only if the user a) is the project owner, b) has 
the "Set project security" permission, or c) has the applicable "Manage all projects" 
permissions.) 

 

In the Item Permissions window, you can choose to: 

• Define the permissions for the item by selecting the Restrict editing to selected project 
users option and then selecting which specific users will be able to edit this particular item. 
All others can view, but not edit, the item. Only users with editing rights to the project will 
appear in the list. 
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• Set the item to inherit the same permissions as the next item above it in the system 
hierarchy by selecting the Inherit from parent item option. 

• Remove item permissions and change the security settings back to the defaults by selecting 
the Inherit from project option. 

If you select the Apply to all dependents check box, the software will automatically set the 
permissions for all next-level items in this branch of the hierarchy to match the item you are 
currently editing. For example, consider a case where each item in an XFMEA system hierarchy 
has different permissions, as shown next. 

 

For a quick way to reset all of the item permissions to the defaults, you can open the Item 
Permissions window for SubSystem 1, set to Inherit from parent item and select the Apply to 
all dependents check box. The resulting system hierarchy is shown next. 
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STATUS INDICATORS 

ReliaSoft desktop applications include status indicators that tell you which project items (e.g., 
folios, diagrams, system hierarchy items, etc.) are in use or restricted. 

When you encounter an item that is read-only (e.g., OK button is disabled in the window or you 
are unable to type in the cells of a worksheet or table), you can check the status of the item to 
see if it is currently in use  (i.e., you can’t edit the item until the user closes the folio/diagram 
or selects a different item in the hierarchy) or restricted  (i.e., you don’t have permissions to 
edit the item). If the item is in use, move the pointer over the icon to identify the user. 

The location of these status icons will vary depending on which ReliaSoft application you are 
using: 

• In projects that use a current project explorer to manage analysis data, the status icons are 
displayed next to the item’s name in the current project explorer, as in the example shown 
next. 

 

• In projects that use hierarchical trees to manage analysis data (as seen in the XFMEA, 
RCM++, RBI and MPC applications), the status icons are displayed in the User Access 
column of the system hierarchy. (To hide or display columns, right-click the column 
headings, then click Customize Columns to select which columns you want to display.) 
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Tip: The application interface refreshes automatically whenever you make a change (e.g., close 
a project, create a resource, select a different item, etc.). If your computer will not let you edit 
an item that is in fact not currently being edited by another user, it could be because your 
computer has not been recently refreshed with the latest changes made by other database 
users. You can initiate the refresh manually by choosing View > Refresh. 
 
In addition, the software employs "in use" flags within the database to record when an analysis 
is currently being edited by a particular user. If the refresh still does not show that the item has 
been released, then something might have occurred to prevent the flags from being reset 
correctly (e.g., a network interruption or if the software closes unexpectedly). Refer to the 
Reset "In Use" Flags topic for instructions on how to reset the flags throughout the database if 
this problem occurs. 

RESET "IN USE" FLAGS 

Because ReliaSoft databases allow simultaneous access by multiple users, it is necessary to 
store "in use" flags within the database to indicate when a particular portion of the analysis is 
currently being edited by a particular user. There are some circumstances when these flags 
might not be reset correctly when a user stops editing an analysis (e.g., if there is a network 
interruption or if the software closes unexpectedly). If that occurs, then the analysis will be 
locked for editing because the software receives an erroneous indication that it is still in use by 
another user. 

To correct the problem, it is necessary to reset some or all of the "in use" flags within the 
database. To reset the flags, choose File > Manage Database > Reset ‘In Use’ Flags. 
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(In a secure database, this is available only for users with the "Manage users and logins" 
permission.) 

This opens the Reset 'In Use' Flags window, which shows all users who have an account in the 
database. (If you are working in a non-secure database, any user who has ever opened the 
database will have an account created automatically and will be shown in this list.) A status light 
is displayed for each user; if it is "lit up" (i.e., green), the user is currently logged in to the 
database. In addition, the Connections column shows the ReliaSoft application(s) that the user 
currently has connected to the database. You can select the check box for each user for whom 
you want to reset "in use" flags, then click OK to reset the flags. 

IMPORTANT: It is important to make sure that no selected user is currently logged in to the 
database when you use this command. Users currently logged into the database can be viewed 
on the Users Page of My Portal. 

DATABASE LOGINS 

The Database Logins window displays a record of the date and time the users in the database 
logged in. To open the Database Logins window, choose File > Manage Database > Database 
Logins. (In a secure database, this is available only for users with the "Manage users and logins" 
permission.) 

 

The following options are available: 

• Use the Most Recent filter to display in the table the last 10; 100; 10,00 or 10,000 users 
who logged in to the database. 

• Use the User filter to specify whether the table will display the logs for all users or display 
only the logs for a selected database user. 

• Click the Send to Excel button to export the data currently displayed in the table to an Excel 
spreadsheet. 

• Click the Clear Logins button to clear the entire history of users who logged in to the 
database. Since this action cannot be undone, you will be prompted to confirm that you 
want to proceed before the records are erased. 

Users currently logged into the database can be viewed on the Users page of My Portal. 
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Database Settings 

The Database Settings window contains settings that are shared by all users and analysis 
projects in the database. To access this window, choose File > Manage Database > Database 
Settings. (In a secure database, this is available only for users with the "Manage other database 
settings" permission.) 

 

In a standard database, you can save the current settings as the default for each new standard 
database that you create from this computer by clicking the Set as Default button at the 
bottom of the window. 

E-MAIL SETTINGS PAGE 

• Enable Alerts via E-mail or SMS configures the database to enable alerts via e-mail or SMS 
text message. (See Enable Alerts via E-mail or SMS.) 

• Action Alerts apply to action resources. The database can be configured to auto-subscribe a 
"watch" for users based on their role(s) for a particular action. You can also specify the 
default text that will be used at the beginning of each action alert. (See Action Alert 
Preferences.) 

ACTIONS PAGE 

New in Version 2020, this page allows you to automatically set the person who created an 
action to be the person responsible for it (see Person Responsible and Resources) and to hide 
the action start and completion dates in the FMEA worksheet view. 

FMEA CHANGE LOGS PAGE 

New in Version 2020, this page allows you to restrict the version labels used for FMEA change 
log revisions in XFMEA/RCM++/RBI (see Change Logs in the XFMEA/RCM++/RBI documentation) 
so that users must select labels from a predefined list. If you select this option, you can define 
the list of labels on this page. 

OTHER SETTINGS PAGE 

• FMEA Structure (XFMEA/RCM++/RBI) allows you to select the default FMEA structure for 
new projects created in the database, which determines how the software will display the 
effect and cause records in the FMEAs.  If you don't specify a default, users will be 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=change_logs.htm
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prompted to select the structure for each new project they create in XFMEA/RCM++/RBI. 
(See Choosing the FMEA Structure in the XFMEA/RCM++/RBI documentation.) 

• History Logs allows you to turn the log on (or off) for all active projects, and stores a 
preference for whether the log should be activated by default for each new project. (See 
History Logs.) 

• Project Planner allows you to enable the Project Planner for use in all projects in the 
database. Starting in Version 2020, the Project Planner is disabled by default. 

• Enable publish to SEP web portal is available only in enterprise databases. If your 
organization has established an SEP web portal for the current database, select this check 
box to enable users to publish analysis summaries, ReliaSoft Workbooks and other 
information to the portal. 

• Delete All Portal Messages deletes all portal messages for all users in the database. There 
is no undo for deleting portal messages. 

UNIT SETTINGS 

ReliaSoft databases are pre-configured with a set of units for use with any analysis in any 
project within the database. The conversion factors are predefined, allowing you to easily 
express results in terms of other units. For example, you can enter data into a Weibull++ data 
sheet in terms of hours and then obtain results from the QCP in terms of years. Similarly, in 
RCM++, RBI or BlockSim, you can define the duration of a maintenance task in terms of hours 
and specify the total operating time of a system in terms of months. In MPC, the units can be 
used to define task intervals. 

IMPORTANT: Making changes to the existing units can have implications for all analyses 
throughout the database; therefore, it is best to set up units once, upon creation of the 
database. 

To define units, choose File > Manage Database > Unit Settings. (In a secure database, this is 
available only to users with the "Manage other database settings" permission.) 

 

If you're working in Weibull++, the Warranty Units tab will be available. It allows you to specify 
which of the configurable database units are equivalent to the built-in (not configurable) 
"warranty time units" used in some warranty folio formats. For details, see Manage Warranty 
Units in the Weibull++ documentation. 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=choosing_the_right_fmea_structural_view_type_for_your_analysis.htm
http://help.reliasoft.com/weibull20/index.htm#t=manage_warranty_units_in_weibull.htm
http://help.reliasoft.com/weibull20/index.htm#t=manage_warranty_units_in_weibull.htm
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Setting SBU Equivalencies 

The conversion factor of a unit is defined in relation to a system base unit (SBU). A base unit is a 
standard unit of measurement upon which other units can be based. Base units always have a 
conversion factor of 1. All other related units are converted back to the base unit. 

For example, say that we choose kilograms (kg) as our SBU for mass. The conversion factor of 
related units, such as pounds (lb) and metric tons (T), must be entered in terms of the SBU: 

Unit SBU Equivalency 
(using kg as the 
base unit) 

1 kg 1 kg 

1 lb 0.4536 kg 

1 T 1000 kg 

  

Similarly, if we change the base unit to pounds (lb), the conversion factors must reflect the 
change: 

Unit SBU Equivalency 
(using lb as the 
base unit) 

1 kg 2.2046 lb 

1 lb 1 lb 

1 T 2204.62 lb 

  

By default, ReliaSoft databases use hours (hr) as the SBU for time, and miles (mi) as the SBU for 
length. To ensure that you obtain correct results when converting units, it is recommended that 
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you set an SBU for each type of measurement (e.g., time, length, frequency, force, etc.) and 
define the conversion factors of all other units in terms of the relevant SBU. 

Changing the Default Unit 

You can set any unit as the default by selecting it in the Use as Default column. The software 
will automatically use the new default unit when you create a new analysis or resource in any 
project in the database. The change will not affect existing analyses and resources. 

Creating and Deleting Units 

To add a new unit, click the Add button below the table and follow the on-screen prompts to 
create the unit. The wizard will automatically calculate and apply the appropriate SBU 
equivalency based on your inputs. 

To delete a unit, click the Delete button below the table. There is no undo for delete. 

Editing Existing Units 

Click a cell to edit a unit’s name, abbreviation, SBU equivalency and category. To apply your 
changes, click the Save button at the bottom of the window. 

Note that if you will be using the usage format of the Weibull++ warranty folio, only the units 
assigned to the Usage category will be available for those analyses; units assigned in the Time 
category are not available in the warranty usage format. 

Built-in Find/Filter, Configuration and Grouping Tools 

You can move a unit up or down its current position by dragging the row to the desired 
position, or by selecting it and using the Move Up or Move Down buttons. 

To show more tools, right-click any column heading. The window offers the same filter, column 
configuration and grouping tools that are built in to other utilities that use a similar grid (e.g., 
the Resource Manager). For details about each feature, see: 

• Finding and Filtering Records 

• Configuring Columns 

• Grouping Panel 
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DEFAULT NAME FORMATS 

In all ReliaSoft desktop applications except MPC, the Default Name Formats window specifies 
the default names for new resources, as well as new blocks in BlockSim RBDs, fault trees, phase 
diagrams and PFS diagrams. For example, when you create a new model, the default name will 
be the word "Model" plus an increment to make the name unique (e.g., "Model," "Model_1," 
etc.). You can configure the database to use a different default name format if desired. 

To open the window, choose File > Manage Database > Default Name Formats. (In a secure 
database, this is available only for users with the "Manage other database settings" 
permission.) 

 

The Item Name column displays the basic name label for each type of resource or block. This 
will be represented by the \N code in the name format. 

The Name Format column allows you to use any of the following elements to define the default 
name format for each type of resource or block: 

• \N returns the label from the Resource Name column plus an increment to make the name 
unique (e.g., "Model," "Model_1," etc.). 

• \U returns the name of the user who created the resource or block. 

• \D returns the date when the resource or block was created. 

• \S adds a sequential number that reflects the order in which the resource/block was added 
to the database. 

• \T returns the ReliaSoft application ("tool") used to create the resource or block. 

• \F returns the contents of all of the identifier fields except the category and comments 
fields. 

• \G returns a summary of the properties of the resource or block. For example, for a node in 
a BlockSim diagram, \G returns the "k out of n" paths that are required. 

• \I is only applicable for resources. It functions the same as \N unless there is another 
window, resource or analysis that it can "inherit" part of the name from. Some examples: 

• If you create a URD from BlockSim’s block properties window, the default name will be 
"[Block Name]_URD." 
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• If you create a metric based on a model, the default name will be "[Model 
Name]_Metric." 

• If you push a metric from a Project Planner gate, the default name will be "[Gate 
Name]_[Property Name]_Metric." 

Tip: In BlockSim diagrams, you can use an asterisk (*) to insert the default block name. For 
example, if you enter  *System  for the block name, the diagram will display the default name 
for the block followed by the word "System." The asterisk also allows the block name to be 
updated dynamically when relevant properties change. 

PROJECT PLANNING RESOURCES 

In all ReliaSoft desktop applications except MPC, project planning resources can be assigned to 
actions in order to track the required costs and time in the Project Planner and anywhere else 
that actions are used. Because project planning resources are shared throughout the database, 
any change made to one is automatically applied to all actions in the database that use it. 

• Cost Categories specify direct and/or per instance costs that can be assigned to any team 
member, facility or material. 

• Teams identify groups of users who will work together on any given action. 

• Facilities specify the cost and maximum utilization for facilities (e.g., test lab) or other 
resources for which the cost depends on the duration of use (e.g., rented test equipment). 

• Materials specify the cost and quantity for materials (e.g., test units) or other resources for 
which the cost depends on the amount used rather than the duration (e.g., purchased 
usage data). 

To open the Project Planning Resources window, choose File > Manage Database > Project 
Planning Resources. (In a secure database, only users with the "Manage project planning 
resources and working days" permission will be able to create and edit these resources; other 
users can select from the resources that have already been predefined.) 

 

Cost Categories 

Cost categories can be created from the Project Planning Resources window, or when you are 
creating/editing a facility, material or individual user account. Enter the Currency Symbol to use 
for displayed costs at the bottom of the window. 
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• The Direct Cost per Hour or Unit is the per-hour cost when assigned to a team member or 
facility, or the per-unit cost when assigned to a material (e.g., the cost of a single light 
bulb). 

• The Cost per Instance is a one-time cost that applies every time a team, facility or material 
is used. 

Teams 

Teams can be created from the Project Planning Resources window, or when you are defining 
an action. A team can include: 

• Individual Users who have active user accounts in the database. 

• Groups of active user accounts that have been predefined in the database. 

Note that you cannot assign a cost category directly to a team. Instead, the team's 
cost/utilization is based on the cost category and maximum hours per day for each team 
member. Both of these properties are set on the Alerts/Actions tab of the User Login and 
Contact Information window. 

Facilities 

Facilities can be created from the Project Planning Resources window, or when you are defining 
an action. 

• The Cost Category specifies the facility's hourly and/or per-use costs. 

• The Max Hours Per Day is the number of hours of use if the facility is set to be 100% 
utilized for a given action (as specified in the action properties). 

Materials 

Materials can be created from the Project Planning Resources window, or when you are 
defining an action. 

• The Cost Category specifies the cost per unit (e.g., the cost for each test prototype), as well 
as any additional fixed cost (e.g., the cost for manufacturing a sufficient number of test 
prototypes). 

• The Quantity that will be used (e.g., 100 light bulbs). 
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WORKING DAYS/HOLIDAYS 

In all ReliaSoft desktop applications except MPC, actions and Project Planner gates contain 
important dates like start dates and due dates. You can specify which dates will be considered 
working days for all actions and gates in the database. This way, an action's cost/time 
estimates, as well as its duration, will be based solely on working days. 

To define the working days for the database, choose File > Manage Database > Working 
Days/Holidays. (In a secure database, this is available only for users with the "Manage project 
planning resources and working days" permission.) 

 

In the window that appears, use the Define Work Week area on the left side to specify which 
days of the week will be considered regular working days (e.g., Monday-Friday). 

Define Holidays 

On the Define Holidays tab, you can define three different types of holidays. 

• Fixed Date - Recurring holidays occur every year on the same calendar date (e.g., New 
Year's Day is always January 1). 

• Variable Date - Recurring holidays occur every year, but not always on the same date (e.g., 
Thanksgiving is always the fourth Thursday of November). 

• Fixed Date - Non-recurring holidays occur once and do not happen again. For example, a 
specific Monday could become a non-working day due to weather conditions. 

In the Holiday Properties window, select Move to adjacent working day if necessary to make 
sure the holiday will be observed when a) it occurs outside the work week, but b) there is a 
regular working day immediately before/after it. In this case, the holiday is observed on the 
nearest working day. (If there is a working day immediately before and after the holiday, it is 
observed on the following day.) 

View Observed Holidays 

The View Observed Holidays tab allows you to easily examine the names and dates of all 
holidays that will be observed during the work week, and can also help you make sure your 
working days/holidays settings are correct. Specify the years you want to view in the Displayed 
Range in Years area. 
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XFRACAS CONNECTION 

XFRACAS is a web-based, closed-loop, incident (failure) reporting, analysis and corrective action 
system designed for the acquisition, management and analysis of product quality and reliability 
data from multiple sources. There are several ways in which you might wish to share data 
between XFRACAS and the analyses that you perform in ReliaSoft desktop applications: 

• Use the Reliability Data Warehouse in Weibull++ to extract data from XFRACAS incidents. 
(See Reliability Data Warehouse in the Weibull++ documentation.) 

• Share system configuration and failure mode data between XFRACAS and 
XFMEA/RCM++/RBI. (See Import or Sync from XFRACAS in the XFMEA/RCM++/RBI 
documentation.) 

When you are working with an enterprise database, the data from XFRACAS and ReliaSoft 
desktop applications can be stored in the same SQL Server or Oracle database. 

When you are working with a standard database (*.rsr20), you will need to establish a 
connection to an enterprise database that contains XFRACAS data. To do this, choose File > 
Manage Database > XFRACAS Connection. (In a secure database, this is available only for users 
with the "Manage other database settings" permission.) 

 

In the XFRACAS Connection Settings Window, select Connect to an enterprise database with 
XFRACAS data then choose Microsoft SQL Server or Oracle. 

• For a SQL Server database, enter the server name and database name. 

• Encrypt communication. Secures the connection information between the ReliaSoft 
application and the enterprise database. 

• Trust server certificate. Select this option if the server has a self-signed certificate. 

• Use impersonation. Configures the connection setting to impersonate a Windows user 
account with a SQL Server login that is shared by multiple users. (See SQL Server Logins 
or Using Windows Impersonation.) If you do not use impersonation, then each user 
who uses the features that utilize XFRACAS must have an account in the external 
database that contains the XFRACAS data. 

• For an Oracle database, enter the port, host and service identifiers and the database 
schema. Your Windows login credentials are used for access to the database; enter your 
Windows password. 

http://help.reliasoft.com/weibull20/index.htm#t=reliability_data_warehouse_rdw.htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=import_from_xfracas.htm
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Managing and Restoring Data 

Since each database may contain a large amount of valuable information that would be difficult 
to re-create, it is essential to make sure that you are diligent about storing adequate backups 
and performing the necessary maintenance activities to keep the database operating smoothly. 
The necessary procedures vary depending on the type of database. 

ENTERPRISE DATABASE MAINTENANCE 

When you choose to store analysis information in an enterprise database, a database 
administrator must perform backups and database maintenance activities using the data 
management tools that are packaged with and/or designed for the database platform (e.g., SQL 
Server Enterprise Manager for SQL Server). Each individual organization typically establishes its 
own procedures for protecting the data stored in the Oracle or SQL Server databases. As a 
convenience for users who wish to explore the possibilities of an enterprise database 
implementation without making a large investment of time and resources, instructions on how 
to perform the minimum database maintenance recommendations are posted on the ReliaSoft 
website: 

See https://www.reliasoft.com/using-sql-enterprise-databases for SQL Server. 

See https://www.reliasoft.com/using-oracle-enterprise-databases for Oracle. 

STANDARD DATABASE MAINTENANCE 

When you choose to store analysis information in a standard database, it will be subject to the 
same limitations and vulnerabilities as any other file that uses the Microsoft Access® database 
file format. For example, the maximum file size is ~ 2GB, maximum number of concurrent users 
is 255, etc. In addition, some specific database vulnerabilities are discussed in a Microsoft 
publication at http://support.microsoft.com/kb/283849/EN-US/. As this publication states: 

"Microsoft Jet, the database engine that is used in Microsoft Access, is a file sharing 
database system. When Microsoft Jet is used in a multi-user environment, multiple client 
processes are using file read, write, and locking operations on a shared database. Because 
multiple client processes are reading and writing to the same database and because Jet 
does not use a transaction log (as do the more advanced database systems, such as SQL 
Server), it is not possible to reliably prevent any and all database corruption." [emphasis 
added] 

https://www.reliasoft.com/using-sql-enterprise-databases
https://www.reliasoft.com/using-oracle-enterprise-databases
http://support.microsoft.com/kb/283849/EN-US/
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Although our developers have made every effort to reduce or eliminate the possibility that the 
software will induce a database error, there is no way to absolutely prevent corruption that 
might be caused by other factors, such as faulty network hardware, an unexpected "crash" on 
your computer or a network interruption. Therefore, this section provides some 
recommendations for standard precautions that all users can take to protect the data in their 
standard databases from this type of corruption and reduce the impact of the data loss if 
corruption is unavoidable. 

1. Create backups regularly. As with any resource that contains a large amount of valuable 
information that would be difficult to re-create, it is essential to make sure that you are 
diligent about creating and storing backup files. There are a number of ways this can be 
accomplished: 

• If you select Automatically back up database upon closing from the Backup/Check Out 
Options page of the Application Setup, the ReliaSoft desktop application that you use 
to open the database will back up the database every time you close the file. 

• If you have a database open and choose File > Save As, the application will create a 
copy of the database to a pathname/filename of your choosing. 

• If you browse to the database file (*.rsr20) in one of the Windows file management 
tools (such as My Computer or Windows Explorer), you can copy and paste the 
database file as needed. 

2. Compact and repair regularly. Using the "Compact and Repair" feature will help to reduce 
the size of the database file and help to protect against problems with the operation of the 
database. If you have the database open and it is not currently in use by another user, you 
can initiate the process by at any time by choosing File > Manage Database > Compact and 
Repair. 

 

3. Do not store the database in a shared network location if you suspect that your network 
connection and/or hardware may be unreliable. According to Microsoft, faulty network 
hardware is one of the main reasons why a file that uses the Microsoft Access database file 
format may become corrupted. As the Microsoft publication at 
http://support.microsoft.com/kb/283849/EN-US/ states: 

"The cause can be one or more links in the hardware chain between the computer that 
the database resides on and the computer that has the database open. This list 
includes, but is not limited to, network interface cards, network cabling, routers, and 
hubs. 

http://support.microsoft.com/kb/283849/EN-US/


Chapter 2: Databases and Projects 

120 https://www.reliasoft.com/weibull 

 

Hardware-based corruption is typically indicated by .mdb files that cannot be restored 
through the use of compacting, repairing, or Jetcomp. Hardware corruption will 
typically recur until the responsible hardware is repaired or replaced." [emphasis 
added] 

If you have experienced this type of corruption for a standard database file, it is 
recommended that you take steps to correct the network problem or refrain from 
accessing database files over the network. In such cases, you may choose to use an 
enterprise database instead (i.e., Oracle or SQL Server), which would be less vulnerable to 
network interruptions. Alternatively, you could keep multiple analysis projects together in a 
single shared standard database file but ask users to export the analysis to a separate 
"working" database on their own computers when there is a need to make substantial 
modifications. Users could then import the data back into the shared database after the 
modifications have been completed. 

4. Do not allow the file size of the database to grow too large. Performance will be affected 
by the size of the database and the number of simultaneous users. Therefore, it is 
important for users to monitor the sizes of their database files and take steps to export the 
data into several smaller and more manageable files if they become too large. Please be 
aware of the following factors, which can lead to very large database files: 

• Failure to compact and repair the database on a regular basis. 

• Using a very large number of attached documents. In some cases, using a link instead of 
an attachment may provide equivalent functionality with a much smaller impact on the 
size of the database file. 

If you try to open a standard database via the software and receive a message that says 
"Unable to open the database," this is an indication that the database file may have become 
corrupted. Please contact Technical Support and provide as much information as possible about 
exactly what you were doing when the corruption occurred. Whenever possible, please provide 
a copy of the corrupted file. In some cases, we may be able to provide assistance with salvaging 
some or all of the affected data. However, in many cases, the best recourse may be to restore 
the latest backup from before the corruption occurred. 

RESTORE POINTS 

In all ReliaSoft desktop applications, you can create and manage restore points for any analysis 
project. Within the context of these applications, the phrase "restore point" refers to an exact 
replica of the project at a particular point in time (i.e., a backup) that can be restored when and 
if it is needed. A restore point will include all the data that the project contained at the time the 
restore point was created, including information about the project properties, security settings 
and project owner. 
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There are a variety of ways that this functionality could be used, depending on your particular 
analysis process and data management requirements. For example, if you are about to begin a 
major revision to an existing project, you could choose to archive the original version as a 
restore point and then proceed with updating the project. This would ensure that the active 
projects in the database contain only the most recent information but also provide easy access 
to a fully editable copy of the previous version of the analysis if it is ever needed. 

Create a Restore Point 

You can create a restore point for a project at any time by choosing Project > Management > 
Restore Point > Create Restore Point or by right-clicking the name of the project in the project 
list and choosing the command on the shortcut menu. 

 

In a secure database, this is available only if the user is the project owner or has the "Create 
restore points" permission. 

IMPORTANT: When you create a restore point, any global, reference and FMEA resources used 
in the project are converted to local resources and stored with the backup. This ensures that 
you will have access to these resources upon restoration, regardless of what may have 
happened to those resources in the interim. 

Restore a Project 

To restore all data from an existing restore point, use the Restore Project command. This opens 
the Restore Project window, which displays a list of all existing restore points for the project, if 
any. You have two options: 

• Overwrite existing project uses the restore point to roll back the current project to the 
earlier state. The restore process will complete as long as the project is not currently in use 
by another user. There is no undo for project overwrites. Therefore, it would be prudent to 
create a new restore point for the project before you overwrite it with one of the older 
restore points. 

• Create new project uses the restore point to create a new project. You may enter a unique 
name for the new project. When the restore process completes, the new project will be 
accessible from the project list. 
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Manage all Restore Points in the Database 

To manage all the restore points that have been created in the database, choose File > Manage 
Database > Restore Points. (In a secure database, this is available only for users who have all 
three "Manage all projects" permissions.) 

 

This opens the Restore Points window, which displays the details for each of the restore points. 

• To create a new restore point, click the Create button then select the project you want to 
back up. Enter any notes that are appropriate to describe the purpose or the circumstances 
of the restore point and click OK. 

• To delete an existing restore point, select the row and click the Delete button or press 
DELETE. There is no undo for delete. 

• To create a new project that restores all of the data from an existing restore point, select 
the row and click the Restore Project button. You will be prompted to specify a unique 
name for the new project. 
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Chapter 3: Desktop Application Interfaces 
Most ReliaSoft desktop applications have their own Multiple Document Interfaces (MDIs) that 
provide full-featured support for the relevant analysis methods. 

When you are using multiple ReliaSoft applications simultaneously, different applications will 
open in separate MDIs but they can all connect to the same database, and even to the same 
analysis project. 

All ReliaSoft MDIs share a common structure, which includes the following elements. 

Ribbon and Backstage View 
The ribbon at the top of the MDI is divided into tabs that organize commands into logical 
groups. Some tabs will always be available (such as File, Home, etc.) while others are contextual 
and will appear only when you are working on a particular task. 

The first tab , the File tab, provides access to a special type of interface called the Backstage 
view. This is where you will create and open databases, manage settings that apply to the 
entire database, access the Help Center, etc. 

Project Manager and My Portal 
The Project Manager allows you to manage the projects within the current database and, for 
many ReliaSoft applications, it also allows you to manage all of the folios, diagrams, reports, 
attachments, etc. in the currently open project(s). This panel is docked on the left side of the 
MDI and pinned by default. ("Pinned" means that the entire panel is always visible unless you 
decide to hide or "unpin" it.) 

My Portal provides quick access to messages, assigned actions and other information that may 
be of personal interest to you while working in the ReliaSoft applications. This panel is docked 
on the right side of the MDI and unpinned by default. ("Unpinned" means that only a small tab 
will be visible in the interface unless you move the pointer over the tab to make the entire 
panel visible.) 

For both of these MDI features, you can decide whether the panel will be visible and how it will 
be positioned in the interface. (See Show, Tile, Dock and Pin Panels.) 
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Tip: If desired, you can change the overall color scheme used in the MDIs for all ReliaSoft 
desktop applications on your computer. Use the Skins drop-down list on the Common Settings 
page of the Application Setup to select the style you prefer. 

Status Bar 
As an example, the following picture shows the status bar at the bottom of the MDI for an 
enterprise database: 

 

For more information about the connection speed indicator, see Enterprise Database 
Connection Speed. 

Show, Tile, Dock and Pin Panels 
In all ReliaSoft desktop applications, the MDI includes a Project Manager panel and a My Portal 
panel. You can decide whether each panel will be displayed and how it will be positioned in the 
interface at any given time.  

SHOW OR HIDE 

To show or hide the Project Manager panel, choose View > Project Manager and toggle the 
Show Project Manager command on or off. 

For My Portal, toggle the View > My Portal > Show My Portal command. 

You can also hide either panel by clicking the X at the top of the window. 

 

TILE OR VIEW ONE PAGE AT A TIME 

In all ReliaSoft desktop applications, My Portal consists of four pages. You have the option to 
view one page at a time (and use large buttons or small icons at the bottom of the panel to 
switch between pages) or tile the pages so that more than one page can be visible at the same 
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time. To specify your preference, choose View > My Portal and toggle the Tile My Portal 
command on or off. 

When applicable, these same options are available for the Project Manager panel. Choose View 
> Project Manager and toggle the Tile Project Manager command on or off. (This command is 
not available in applications such as XFMEA, RCM++, RBI and MPC, which have only a single 
page in the Project Manager.) 

As an example, the first picture shows the My Portal panel when it is not tiled. The second 
picture shows the tiled panel, with two of the four pages expanded to be visible at the same 
time. 

 

When the panel is not tiled, you can drag the horizontal splitter bar up to display large buttons 
or down to display small icons. 
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When the panel is tiled, you can use the handle buttons to expand or collapse each page. 

 

DOCK OR FLOAT 

For both panels, you have the option to dock the panel on the left, right, top or bottom side of 
the MDI. When the panel is docked, it cannot be moved but you can change the width (if 
docked left or right) or height (if docked top or bottom) by dragging the edge to the desired 
position. 

Alternatively, you can choose to float the panel as a window that can be resized and dragged to 
any location on the desktop. 

There are several ways to set the docking position: 

• Choose View > Project Manager > Dock Project Manager and then choose the desired 
option. 

 

The same options are available when you choose View > My Portal > Dock My Portal. 
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• If the panel is currently floating: 

• Double-click the window's title bar to return it to the most recent docked position. 
 
or 

• Click the window's title bar and drag it onto one of the location icons that become 
visible while you are moving the window. When the window is correctly positioned, 
blue shading will show where the window will be docked when you release the mouse 
button. (Note that the window's title bar must be exactly positioned above one of 
these location icons before the blue shading appears. If you don't see blue shading, the 
panel will not be docked when you release the mouse button.) 

 

If you prefer to float the window, you can: 

• Choose either: 

• View > Project Manager > Dock Project Manager > Floating Project Manager 
 
or 

• View > My Portal > Dock My Portal > Floating My Portal 

• Double-click the title bar of the docked panel. 
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PINNED OR UNPINNED 

When docked, both panels can also be toggled between pinned and unpinned states by clicking 
the pushpin icon in the panel's title bar. When the pushpin in the icon is vertical , the panel is 
pinned and will be displayed at all times. 

When the pushpin is horizontal , the panel is unpinned. A tab will be displayed at the docking 
location for each unpinned panel. 

The behavior for unpinned panels is as follows: 

• If you point to the tab, the panel displays only until you point to something else. 

• If you click the tab, the panel stays displayed until you click something else. 

• When a panel is unpinned, it cannot be undocked or moved. 

As an example, the following picture shows the Project Manager panel docked on the left side 
of the MDI, unpinned and hidden, while the My Portal panel is docked on the right side of the 
MDI, unpinned and visible (either because the user moved the pointer over or clicked the tab). 
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Project Manager 

The Project Manager provides the tools you need to browse or search for a particular project or 
analysis folio in a ReliaSoft database. Depending on the application, the Project Manager 
consists of either one or two pages: 

• In all ReliaSoft desktop applications, the project list displays all the projects in the current 
database. (For XFMEA, RCM++, RBI and MPC, this is the only page available in the Project 
Manager). 

• In Weibull++, BlockSim and Lambda Predict, the Open Project(s) page of the Project 
Manager (i.e., the current project explorer) displays all the analysis folios, reports and other 
items in the current project(s) that apply to the software you are using. 

There may be up to five nodes in the project list, indicating the sharing status of the projects: 
Private, Public or Reference projects, Locked projects and Checked Out projects. Additionally, 
the Recycle Bin is shown in the project list. 

Each node may be further broken down by project category and/or by project owner. This 
ensures that projects will be organized in a logical, manageable way within the project list. 

OPENING A PROJECT 

To open an existing project, double-click the project name or select the project and choose 
Project > Management > Open Project. 

 

Note: Remember that each project may contain items from any ReliaSoft application but you 
will see only the items that are relevant for the application you are currently working with (e.g., 
Weibull++ analysis folios are visible only when the project is opened in Weibull++). Common 
items, such as project attachments, are visible from all applications. 

FILTERING THE LIST OF PROJECTS 

The project list can utilize the same project filters that are available in many other locations 
throughout ReliaSoft desktop applications. For example, with the filter shown below, the 
project list will show only projects belonging to Department B. 
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This feature might be particularly useful for an enterprise database that may be used to store 
analysis projects for the entire organization in a single centralized location. In such cases, the 
number of projects displayed in the project list could become overwhelming and these filters 
provide the ability to display only those projects that are of interest to you at any given time. 

To remove the filter, select Show All from the drop-down list. 

SEARCHING FOR A PARTICULAR PROJECT 

You can also search for projects by entering text in the Find field. The project list updates 
dynamically to show only the projects with names that contain the text that you have entered. 
As an example, the following picture shows a quick way to find all of the projects for a 
particular product line by using the project names instead of predefined categories or other 
filter criteria. 

 

CURRENT PROJECT EXPLORER 

In all ReliaSoft desktop applications except XFMEA, RCM++, RBI and MPC (which use the system 
hierarchy to manage all of the different analyses in a given project), the Open Project(s) page of 
the Project Manager allows you to manage all of the relevant project items (e.g., folios, 
diagrams, etc.) in the project(s) that are currently open. 

Applications that use the current project explorer can have multiple projects open at the same 
time. (See Working with Multiple Projects.) 
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Note: Remember that each project may contain items from any ReliaSoft desktop application 
but you will see only the items that are relevant for the application you are currently working 
with (e.g., Weibull++ analysis folios are visible only when the project is opened in Weibull++). 
Common items, such as project attachments, are visible from all applications. 

Filtering the Project Items 

The current project explorer can utilize the same item filters that are now available in many 
other locations throughout ReliaSoft desktop applications. (This provides more flexibility than 
the Filter based on creator feature in prior versions.) 

For example, with the filter shown below, the current project explorer will show only items 
created by Joe User and updated within the current month. 

 

To remove the filter, select Show All from the drop-down list. 

Opening Items 

Double-click an item to open that item in the MDI or to bring that item to the front of the MDI if 
it is already open. (Note that if you double-click an attachment that appears in the current 
project explorer, it will open in its corresponding application, as long as that application is 
installed on your computer.) 

Tip: In all ReliaSoft applications, projects can be shared by multiple users and the current 
project explorer may display an "in-use" icon to indicate the status of an item that can't be 
edited because it is currently locked or being edited by another user. (See Status Indicators.) 
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Adding Items 

You can add items to the project by right-clicking the relevant folder and choose an appropriate 
command on the shortcut menu that appears. 

Editing, Renaming, Duplicating or Deleting Items 

To manage existing items within the project (i.e., Edit Item, Rename Item, Duplicate Item and 
Delete Item), right-click the item and choose a command from the shortcut menu or select the 
item and use the commands in the Current Item group on the Project tab of the ribbon. 

Sub-Folders and Drag and Drop 

In addition to the top-level folders that are fixed for each application, you also have the ability 
to create your own custom sub-folders to organize project items (the exception being the 
Attachments folder, which you cannot add sub-folders to). To add a custom sub-folder, right 
click any existing folder and choose Add Folder on the shortcut menu. 

You can also arrange custom sub-folders and project items by dragging them to the desired 
location. Dragging a folder or project item onto a folder will place it into the bottom of that 
folder. Dragging a folder or project item onto a project item will place it in the same level above 
that item. 

WORKING WITH MULTIPLE PROJECTS 

ReliaSoft desktop applications that use the current project explorer (i.e., Weibull++, BlockSim 
and Lambda Predict) can have multiple projects open at the same time. To enable this 
functionality, select the Allow multiple projects (project explorer) check box on the Common 
Settings page of the Application Setup. 

Tip: There is a separate setting that controls the ability to have multiple projects open in 
XFMEA/RCM++/RBI. 
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When you have more than one project open, the projects will be shown in the current project 
explorer with the most recently opened project at the top. Note that the icon shown beside 
each project indicates whether it is a public, private or reference project and, when applicable, 
whether it is locked or checked out. 

  Unlocked, Not 
Checked Out 

Locked Checked Out 

Public Project 
   

Private Project 
   

Reference Project 
 

 

N/A 

  

In addition to the convenience of being able to view analyses from multiple projects, having 
multiple projects open allows you to transfer data between the projects quickly and easily. 
Specifically: 

• For any item that can be imported/exported between projects, you can simply drag the 
item (analysis, multiplot, report, etc.) from the source project to the appropriate folder in 
the destination project. This opens the Export window, where you can just click Export to 
finish the export, or add more items to export before you finish the process. 

• In Weibull++, data can be copied from an analysis in one project and pasted to an analysis 
in another project. 

• In BlockSim, blocks can be copied from a diagram in one project and pasted to a diagram in 
another project, according to the following rules: 

• If the block uses resources that are local to the source project, they will also be copied 
and added to the destination project. 

• If a resource of the same name exists in the destination project, the name of the 
copy will be incremented (e.g., if "Model1" already exists, the new copy might be 
renamed to "Model1_1"). 

• If a model is associated with a data source (e.g., a model published from a 
Weibull++ folio), the model is copied into the destination project as a model with 
the association removed. 

• If the block uses resources that are global or in a reference project, they will not be 
duplicated. They will retain their original reference to that global/reference resource. 
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• Subdiagram blocks cannot be copied and pasted across projects. 

Note: The FMRA view is not available in BlockSim when you have multiple projects open. 

My Portal 

In all ReliaSoft desktop applications, My Portal provides quick access to messages, assigned 
actions and other information that may be of personal interest to you while working in the 
ReliaSoft application. (When you first activate the software, My Portal will be "docked" on the 
right side of the MDI and "unpinned." Move your mouse pointer over the tab to make the panel 
visible at any time. For other options, see Show, Tile, Dock and Pin Panels.) 

If your organization chooses to implement a web-based SEP portal for an enterprise database, 
you can also access many of these same features — as well as selected metrics, reports and 
other details from specific analyses — from any web-enabled device. 

PORTAL MESSAGES 

The ReliaSoft desktop application’s messages feature provides a convenient way to 
communicate with other database users. Messages are displayed in a "timeline" format similar 
to social media websites like Facebook®. 

These messages are displayed both in My Portal (in any ReliaSoft desktop application) and in 
the SEP web portal (if it is implemented for your database). 

All database users will be able to view their own messages. In a secure database, the following 
permissions are required to create, edit or delete messages: 

• Create portal messages allows you to create new messages, and edit or delete the 
messages you have personally created. 

• Manage all portal messages allows you to edit or delete any messages that are visible to 
you. This includes any message for which you are the creator or one of the recipients. 

Message Display Options 

The messages timeline will display all messages that were created by or addressed to you. You 
can sort the message threads in two ways: 

• Newest Active considers the dates/times of both the main messages and the replies. 

• Newest Message considers only the dates/times of the main messages. 
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Create, Edit, Delete or Reply to Messages 

In ReliaSoft desktop applications, you can access the message commands from the My Portal 
tab of the ribbon, and by right-clicking inside the Messages page of the panel. 

 

Note that the purpose of the Refresh Messages command is to update the display with any 
new messages that were recently added or changed by another database user. 

Message Recipients 

You can specify whether a message will be visible to all database users or only to specific users 
or groups. If you select Selected Groups/Users, you can choose from two lists: user groups that 
have been predefined in the database and/or individual user accounts. 

 

If a valid SMTP server has been defined for the database, you can select the Also send this via 
e-mail check box to send an e-mail copy of the message to the recipient(s). (See Enable Alerts 
via E-mail or SMS.) 
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ACTIONS IN MY PORTAL 

Your team can use actions to track specific assignments that need to be performed. These 
versatile resources can be used multiple times in different locations, if appropriate. This may 
include actions in Project Plans, FMEAs or Test Plans, as well as actions that are independent of 
any particular analysis or plan. 

This topic discusses how to view and manage actions via My Portal in any ReliaSoft desktop 
application. If you want to view/manage all action records, see Actions Explorer or Resource 
Manager. For information about the action properties and other general considerations that 
apply wherever the action may be used, see Action Resources. 

Actions Displayed in My Portal 

The Actions page in My Portal (and in the SEP web portal) display action records that: 

• Need to be reviewed by you. 

• Are relevant to you in some way and are: 

• Past Due – the completion date has passed. 

• Due Next 7 Days – the completion date occurs within the next 7 days. 

• Past Start Date – the start date has passed. 

• Start Today – the start date is today. 

• Start Tomorrow – the start date is tomorrow. 

• Start Next 7 Days – the start date occurs within the next 7 days. 

• In Progress – the actual start date has been entered and the action is not yet "Past 
Due" or "Due Next 7 Days." 

If the action is not used in the Project Planner, this will be based on the planned 
start/completion dates. But if the action is used in a plan, it’s based on the expected dates 
(which can shift automatically if there are recorded delays in prior gates/actions). 

Also note that if an action fits under more than one heading, it will display under the more 
urgent one. For example, if the action is both due in the next 7 days and past the planned start 
date, it will show under "Due Next 7 Days." 
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Create, Edit or Delete Actions from My Portal 

In ReliaSoft desktop applications, you can access the portal actions commands from the My 
Portal tab of the ribbon, and by right-clicking inside the Actions page of the panel. 

 

Tip: If an action doesn’t fit the My Portal display criteria for your computer/username (see 
details below), the new record won’t be displayed in your portal after you create or edit it. In 
such cases, you can use the Actions Explorer or Resource Manager to access the record. 

Add to Outlook Calendar 

The Add to Outlook Calendar command will be enabled if Microsoft Outlook is installed on 
your computer. 

 

It launches Outlook’s interface for creating a new calendar event and automatically populates 
the subject and date. You can modify the details as needed before saving the new event to your 
calendar. 

Note that you may need to give focus to the Outlook application in order to see the window.   
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Refresh Actions 

The Refresh Actions command updates the display with any new actions that were recently 
added or changed by another database user. 

 

Action Display Settings 

To specify your personal preferences for displaying actions in My Portal (stored per 
computer/username), right-click inside the panel and choose Action Display Settings. 

 

An action may be relevant to you in one or more of the following ways. Use Show Actions to 
specify which actions to display. 

• I am responsible for  

• You are assigned in the Person Responsible field. 

• I am a team member in  

• You belong to the team assigned in the Team field. 

• I need to review/approve  

• You are assigned in the Reviewer field. 

• I am monitoring  

• You are assigned in the Action Monitors window, or you have personally subscribed to 
“watch” the action.  

• I am the creator  

• You are listed in the Created By field. 

If you select Display ‘Show Actions’ labels in portal, the panel will also include headings that 
indicate how the action is relevant to you. 
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Finally, you can choose to Sort by Start Date or Sort by Due Date within each node of the 
display. 

Tip: If an action is relevant to you in more than one way, it will display if any applicable 
relevance check box is selected. If you are using relevance headings, the action will display 
under the first selected heading that fits. For example, if you are both the person responsible 
and the creator, and all relevance options are selected, the action will display under "I am 
responsible for." Alternatively, if only the creator relevance is selected, it will display under "I 
am the creator." 

Action Explorer 

The Actions Explorer command opens a flexible utility that allows you to explore all of the 
action resources that are stored in the current database. You can use it to filter, sort, add, edit 
or delete actions. (See Actions Explorer.) 

 

Note that when you return to the Actions page in My Portal, you will need to use the Refresh 
Actions command to view any changes. 

DATABASE USERS LIST 

The database users list shows all active user accounts in the database, and identifies which of 
those users are currently connected to the database with any of the ReliaSoft applications. 

This list is displayed both in My Portal (in any ReliaSoft desktop application) and in the SEP web 
portal (if it is implemented for your database). 

In ReliaSoft desktop applications, you can access the users list commands from the My Portal 
tab of the ribbon, and by right-clicking inside the Users page of the panel. Similar commands 
are available in the SEP web portal, if applicable. 
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My Profile opens the User Login and Contact Information window, which allows you to edit the 
contact information associated with your user account. 

Refresh Users updates the list to reflect any recent changes in user activity. 

PROJECT PLAN SUMMARY IN MY PORTAL 

In all ReliaSoft desktop applications except MPC, the Project Plan Summary page in My Portal 
provides a summary of the plan for the current project, if applicable. 

The summary in My Portal always reflects the entire plan for the current project, based on the 
actual date/time from your computer. If you want to see the summary for a particular gate or 
action, or to estimate what the statuses would be for a different date, you must use the Project 
Planner window. 

• Choose Project > Management > Project Planner. 

 

• Click the link in the project name bar at the top of the summary in My Portal. 
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How to Read the Summary 

The plan summary in My Portal provides the following information at-a-glance. (For details, see 
Project Plan Summary Panel.) 

 

By default, this shows the current date, 
which is used to determine the status (e.g., 
"Missed Start Date"), resource usage to date, 
etc. 

Use Refresh to obtain the latest information 
from the Project Planner. 

 

The top bar displays name of the project that 
the summary applies to. Click the link to 
open the project in the Project Planner. 

The next two rows show the expected dates 
and any actual dates, and the last row shows 
the status. 

 

This is the percentage of the total duration of 
dependent actions/gates that is complete. For 
example, if Action 1 (duration = 3 days) is 
complete and Action 2 (duration = 1 day) is 
incomplete, the progress is 75%. 
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For resource usage, the black bars show the 
planned man hours and costs. The colored 
bars show either the expected usage to date 
(estimated based on the number of days in 
progress), or the actual usage if complete. 
(See Costs and Man Hours.)   

• Yellow = In progress and usage to 
date is still within plan 

• Orange = In progress and usage to 
date has exceeded plan 

• Green = Complete and actual usage 
was within plan 

• Red = Complete and actual usage 
exceeded plan 

 

Displays only if actions have been assigned to 
the project or gate (either directly or via 
dependent gates). 

• Not Started = Actions that have not 
started and can complete on time 

• In Progress = Actions that are in 
progress and can complete on time 

• Completed = Completed actions that 
have been approved, or don't 
require approval 

• Past Due = Actions that have not 
completed and can no longer 
complete on time 
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Folios 

DATA SHEETS 

The  following picture shows the basic components of a data sheet using one particular format 
as an example. 

 

• Caption shows the name of the folio and the name of the sheet that is currently displayed. 

• Name Box shows the location of the currently selected cell by listing the column letter and 
row number that intersect at the cell's location. 

• Data Entry Bar shows the contents of the selected cell, which may be text, a numerical 
value or a formula. For text or numerical values, you can enter/edit the information directly 
inside the cell or inside the data entry bar. For a formula, you must use the data entry bar 
for editing; the cell will display only the calculated value. 

• Row Headings identify the row numbers. Each data sheet contains up to 65,536 rows. The 
application's speed of execution is inversely proportional to the number of data rows in the 
current data set. 
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• Column Headings indicate the titles of the columns. To rename a heading, right-click it and 
choose Rename Column. When applicable, you can save the column titles and use them as 
the default headings for all new data sheets of the current type. (See Default Column 
Headings.) 

• Sheet Tabs represent the different sheets within the folio. To rename a sheet, double-click 
the tab. The number of folios that can be opened at once depends on the amount of 
memory of your system (up to a maximum of 256 for some folio types). 

Default Column Headings 

In life data, life-stress and growth data folios, creating a new data sheet automatically applies 
default column headings that are generally appropriate for the analysis. If there are certain 
types of data that you frequently use (e.g., miles-to-failure, cycles-to-failure, etc.), you can 
customize the column headings to always use your preferred column titles. 

To modify the defaults for a particular data type, first rename the column headings in an 
existing data sheet. Right-click the heading and choose Rename Column on the shortcut menu. 
Then save the new titles as the defaults. For a life data folio, choose Life Data > Format and 
View > Set Headers as Default. (For a life-stress folio, the command is in the Life-Stress Data 
tab; for a growth data folio, it's in the Growth tab.) 

 

These preferences are saved for the current computer/username, and will be applied the next 
time you create a new data sheet for that particular data type. 

To apply the new default headings to an existing analysis, open the data sheet and choose [Life 
Data/Life-Stress Data/Growth Data] > Format and View > Apply Default Headers. 

 

If you ever need to restore the default column headings back to the shipped settings, choose 
File >Application Setup, then click Reset Application Settings or Reset All Settings on the Reset 
Settings page. 

Resizing Columns 

Column widths are set to span evenly by default. If you want to resize and have the changes 
saved with the folio, right-click a column heading and choose Column Width Style > Default. 

To resize a column, drag the edge of the heading to the desired position, or right-click it and 
choose Column Width. 
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Entering Formulas in the Data Sheet 

Data sheets in Weibull++ allow you to enter formulas in columns that do not require entries to 
be dates, times or text (e.g., you cannot use formulas in the State F or S column in a life data 
folio, or in the Classification column in a growth data folio). For example, in a life data folio, if 
you have a data set where the units were inspected every 24 hours, you can speed up data 
entry by creating a formula to add 24 hours to the previous inspection time, as shown next. 

 

There are two types of cell references (locations) when inputting a formula: absolute and 
relative. By default, the cell reference is relative, meaning that as a formula is copied and 
pasted to other cells, the cell references in the formula will be adjusted to reflect the new 
relative location. In the previous figure, the formula in cell C2 is copied and pasted into cell C4. 
This changes the cell reference in the formula from "=C1+24" to "=C3+24"; therefore, the time 
value in C4 is 72+24 = 96. 

In contrast, an absolute reference does not change when the formula is copied to other cells. 
Absolute references are designated by placing a dollar sign ($) in front of the row and/or 
column to be made absolute. If the formula in the example were rewritten to "=$C$1+24", then 
copying the formula to cell C4 would retain the cell reference to C1 and the time value in C4 
would be 24+24 = 48. 

CHANGE UNITS 

In Weibull++, you have the ability to define the units used for the data set and calculations. For 
example, if your data set contains failure times in hours, you now have the option to perform 
calculations using different time units such as years, months, days, etc. The software performs 
the unit conversion automatically. Authorized users can define the units that will be available 
for use in any project within the database and set up the conversion factors. 
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The units are displayed in the heading of the relevant column in the data sheet. If you wish to 
change the units of an existing data sheet, click the Change Units icon on the Main page of the 
control panel. 

 

In the Change Units window, the units that are currently being used in the data sheet will be 
displayed at the top of the window. In the Change Units To field, you can choose any other 
defined unit to be used in the data sheet. In the Conversion Options area, specify what will 
happen when the units are changed: 

• You can convert the existing data to the new units. For example, if you had a time of 10 in a 
data sheet that was using hours, that time would become 600 if you converted the data to 
minutes (10 hours x 60 minutes per hour = 600 minutes). For life data, life-stress data and 
growth data folios, when this option is selected, you can select whether you want to copy 
the data to a new sheet in the folio and then perform the conversion, leaving the original 
data sheet unchanged, or convert the data in the current sheet. 

• You can leave the data unchanged and just apply the new units. This would be appropriate 
if, for example, you had entered all of your data and then realized that the data sheet was 
using different units from the original units in which the times were measured. 

GENERAL SPREADSHEETS 

General Spreadsheets can be inserted into a Weibull++ life data folio, life-stress data folio or 
growth data folio. They provide the same spreadsheet capabilities that are available in the 
spreadsheet module in ReliaSoft Workbooks, but are stored together with an analysis folio. You 
may prefer to use this reporting tool if you are performing custom calculations based on the 
data sheets in the same folio and you wish to keep the analyses together with their source data. 

To add a General Spreadsheet to a folio, right-click the data sheet tab area (the area at the 
bottom of the window that shows the name of the data sheets in the folio) and choose Insert 
General Spreadsheet on the shortcut menu. This command also appears on the ribbon tab for 
the particular type of data folio. For example, to insert a general spreadsheet into a Weibull++ 
life data folio, you can choose Life Data > Folio Sheets > Insert General Spreadsheet. 

 

Inserting Data Source Functions 

To build and insert functions that utilize a referenced analysis (data source), click a cell in the 
general spreadsheet and choose Sheet > Sheet Actions > Function Wizard. 
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The following picture shows the most complex configuration as an example: 

 

For the function arguments: 

• Brackets [ ] indicate that the input is optional. 

• You can use cell references as inputs. For example, instead of entering 1000 for the Age 
input, you could specify to use whatever time is currently entered into cell A10, using either 
the relative reference (A10) or the absolute reference ($A$10). (See Cell References.) 

• You can also use variable names as inputs. (See Defined Names.) 

For the data source: 

• Click the Select button and then select which data sheet in the folio to use as the data 
source. 

• Any time you make changes to the data source, the general spreadsheet will need to be 
recalculated to reflect the most current results. Choose Sheet > Format and View > More 
Settings > Recalculate Formulas. The general spreadsheet may return "N/C" if the data 
source needs to be recalculated. 
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Inserting Math Functions 

To add math, date, logic and other functions, click a cell in the general spreadsheet and choose 
Sheet > Sheet Actions > Insert Function. 

 

Select a function from the drop-down list and click OK. You can enter inputs for the function 
arguments by either selecting the cells in the sheet or typing them directly into the appropriate 
field. 

Referencing a Data Source 

Some functions (e.g., AMEAN, D_COUNT, etc.) require you to reference a particular data 
source. 

To reference a data source, use the following syntax, with the quotes and exclamation marks 
(!). You can only reference sheets in the same folio. 

"Application!Folio!DataSheet" 

In the following example, the data source is a data sheet called "Data1" in the Weibull++ folio 
called "Folio1". 

 

Control Panels 
Many of the analysis folios, diagram sheets and other interfaces in ReliaSoft desktop 
applications utilize a control panel that allows you to make required inputs, initiate the desired 
analysis or simulation and view/access applicable results. This topic describes some features 
that are common to most control panels. (For XFMEA, RCM++, RBI, MPC and Lambda Predict, 
see System Panel and Analysis panel instead.) 
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SWITCHING BETWEEN PAGES 

Many control panels and navigation panels contain multiple pages that vary depending on the 
type of analysis. You can switch between pages by clicking either the large buttons or the small 
icons at the bottom of the panel. 

If you drag the horizontal splitter bar to the bottom of the control panel, all of the pages will be 
accessed by small icons. If you drag it as far up as it will go, all of the pages will be accessed by 
large buttons. 

 

HIDING OR DISPLAYING A CONTROL PANEL 

The control panel can be toggled between hidden and displayed states by clicking the Hide or 
Show icon in its title bar. 

When the control panel is hidden, only the title bar and page icons will be visible on the right 
side of the window (as shown next using a Weibull++ folio as an example). When you click the 
bar, the active page will be displayed temporarily. When you click anywhere outside of the 
control panel page, it will be automatically hidden again. 
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IDENTIFIERS PAGE 

The Identifiers page of the control panel allows you to enter identifying details (e.g., category, 
name, part number, etc.) that will be associated with the analysis and any models or SEP 
summaries that are published from the analysis. This will help you to find, filter and group 
analyses and resources throughout the database. 

In folios that can have multiple data sheets, the Folio Identifiers are edited via the Item 
Properties window, and the Data Sheet Identifiers can be entered directly in the control panel. 
Use an asterisk (*) if you want the data sheet’s identifiers to be the same as the folio's (see 
Identifiers). 

PUBLISHING PAGE 

The Publishing page allows you to view and manage information from the current analysis that 
is shared throughout the ReliaSoft desktop applications. 
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• Model/Fitted Model – publishes a model based on the current analysis. See Publishing 
Models. 

• SEP Summary – publishes a summary of the current analysis to the SEP web portal. This is 
visible only if the enterprise database is configured for SEP and you have the "Publish to 
SEP web portal" permission. See Publishing to SEP. 

• Metrics – shows all of the metric resources that are associated with the current analysis. 
See Showing Metrics in Folios/Diagrams. 

NOTIFICATIONS PAGE 

When applicable, the Notifications page provides information on the Current Status of the 
analysis, along with any warnings or errors. A green light indicates that the folio has been 
analyzed, and a red light indicates that the folio has not been analyzed since changes were last 
made. The Latest Notifications area displays any warnings and errors generated during 
analysis. 

 

UTILIZED RESOURCES PAGE 

In BlockSim only, the Utilized Resources page displays a grouped list of all of the resources that 
are used directly by blocks in the diagram (i.e., not applied via any other resource or tool). 

For example, a URD that is assigned to a block will be displayed in this list, but the model 
assigned to the URD will not be shown, nor will any tasks assigned to the URD. Similarly, if a 
block belongs to a maintenance group, that maintenance group will be shown in the list. 
However, if a block has a state change trigger, the maintenance group(s) used for that trigger 
will not be shown unless some block in the diagram belongs to them. 

This list is not updated automatically; if you have made changes to the diagram, click the 
Refresh icon to update the list. 
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Double-click a resource in the list to open its properties window for viewing or editing. Click the 
Resource Manager icon to view/manage all of the resources available in the project. 

 

System Panel and Analysis Panel 
Some ReliaSoft applications use two convenient panels to manage all of the analysis 
information in a particular project (XFMEA, RCM++, RBI and MPC) or in a particular prediction 
folio within the project (Lambda Predict). 

The first panel (called the System panel or the System Hierarchy panel) allows you to build 
simple or complex multi-level configurations that contain the items you plan to analyze. The 
second panel (called the Analysis panel or the Properties panel) contains all of the properties 
and analyses for the item that is currently selected. 

This topic discusses the ways in which you can configure the layout of these two panels to fit 
your particular workspace preferences. 

CHANGE ORIENTATION 

You can display the panels side-by-side or with one panel above the other. 

 

To switch between layouts, choose View > Workspace Layout > Change Orientation. 

 

RESIZE A PANEL 

You can resize the panels by dragging and dropping the vertical (or horizontal) separator into 
the desired position. 
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HIDE A PANEL 

You can also completely hide either panel so that the other can fill the available space. Choose 
View > Workspace Layout > Hide [System Panel/System Hierarchy] or [Analysis 
Panel/Properties]. 

 or   

When you wish to return to the two-panel layout, choose the Split Panels command. 

 or   

EXPAND OR COLLAPSE NODES 

When the panel presents data in a hierarchical tree configuration (e.g., the system hierarchy, 
FMEA hierarchy, etc.), the View tab provides several flexible options for expanding and 
collapsing the nodes (branches) that are currently displayed. 

To expand or collapse all branches at the same time, choose Expand Tree or Collapse Tree. 

 or  

To expand or collapse a specific branch, you can click the + or - icons, or select the item and 
choose Expand Node or Collapse Node. 

 or  

To collapse all branches in the tree to a specific level, select any item at the desired level and 
choose Collapse to Level. 

 

As an example, the following pictures show how the hierarchy collapses to the second 
(subsystem) level. 
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SELECTING WHICH COLUMNS TO DISPLAY 

When applicable, you can hide, display or reorder the columns shown in a particular type of 
hierarchy by right-clicking any column heading and choosing Customize Columns. These 
settings are stored per computer/username, and different users may have different display 
preferences without affecting the stored data. The same preferences can also be managed from 
the relevant page of the Application Setup. 

Printing 

ReliaSoft desktop applications offer different printing utilities for data sheets, diagrams, plots 
and ReliaSpft Workbooks. 

DATA SHEETS AND DIAGRAMS 

To print a data sheet or diagram, choose File > Print or press CTRL+P on the keyboard. You will 
see a preview of the printed page, and can choose to print or to access page setup options. 

When printing an RBD or fault tree in BlockSim, clicking the Print button on this page will open 
the Print Diagrams window, where you will be able to choose whether to print only the Current 
diagram (and possibly its subdiagrams on separate pages) or to Choose multiple diagrams from 
the current project to print. If you choose to print the current diagram and its subdiagrams, you 
can select Print subdiagram page number to include the starting page number for each 
subdiagram in the caption of the relevant subdiagram block. 

To print an XFMEA, RCM++ or RBI diagram (e.g., FMEA block diagrams, etc.), choose Home > 
Print > Print. 
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PLOTS 

To print a plot, choose File > Print or press CTRL+P on the keyboard. 

To print a plot displayed in the Plot Viewer (as seen in XFMEA, RCM++, RBI and Lambda 
Predict), click the Print icon  on the plot control panel. 

RELIASOFT WORKBOOKS 

To print ReliaSoft Workbooks, choose View > Print > Print Preview. For more printing options, 
you can send the report to Microsoft Word or Excel and use the print utilities in those 
applications. Choose Home > Report > Send to Excel or Send to Word. 

REPORTS GENERATED IN WORD OR EXCEL 

In XFMEA, RCM++, RBI, MPC and Lambda Predict, reports are generated in Microsoft Word or 
Excel. You will need to use the print utilities built in to those applications. 

OTHER FEATURES 

For other features that offer the print functionality (e.g., RS Draw, Resource Manager, etc.), the 
Print icon  will be displayed in the window itself. 

PAGE SETUP - PLOTS AND DIAGRAMS 

The Page Setup for plots and diagrams is accessible via the print window (see Printing). 

Maximize Printing Space 

The following options are available on the Page tab or Margins tab of the Page Setup. 

• Orientation. The Portrait orientation works best for small charts and diagrams. If the image 
is wider than it is tall (which is the case for most plots), select the Landscape orientation. 

• Keep aspect ratio (available for plots). Select this option to maintain the proportional 
relationship between the width and height of the image. Clear the check box if you want to 
stretch the image to fill the paper. 

• Scaling (available for diagrams) allows you to shrink or enlarge a diagram to fit a specified 
number of pages. For example, to print a diagram to four pages in a rectangle, you would 
enter the values 2 by 2 pages. The software will automatically adjust the size of the diagram 
image to fit to the specified pages.   
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• Print without interior margins is used for printing images that span multiple pages, so 
that the pages can be assembled into a whole picture. It removes as much margin 
space as possible from the interior edges of each page, where it meets the other pages. 

• Print empty pages prints any blank pages within the print area; otherwise, the blank 
pages are omitted from the printout. 

• Margins. By default, the margins will be printed based on the System’s default option, 
which is the measurement system specified in your computer’s region and language 
settings. You can change the unit to inches or centimeters as desired.   

Headers/Footers 

To add custom headers/footers for printing, click the Header/Footer tab of the Page Setup. 

To insert variable information such as date, time, number of pages, etc., use the command 
icons in the window to insert the appropriate field codes (or use the codes shown in the table 
below). 

Field Code Description 

&A Inserts the sheet name. (Does not apply to plots in XFMEA, RCM++, RBI 
and Lambda Predict.) 

&D Inserts the current date. 

&T Inserts the current time. 

&P Inserts the page number. 

&N Inserts the total number of pages. 

&ZA Inserts the name of the application (e.g., Weibull++). 

&ZC Inserts the company name. 

&ZU Inserts the user name. 

&ZP Inserts the project name. 

&ZI Inserts the name of the item. (Does not apply to plots in XFMEA, RCM++, 
RBI and Lambda Predict.) 

&ZL Inserts the path to the current database. 

PAGE SETUP - DATA SHEETS 

The Page Setup for data sheets is accessible via the print window (see Printing). For the 
spreadsheet module in ReliaSoft Workbooks, choose View > Print > Page Setup. 
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Maximize Printing Space 

The following options are available on the Page tab or Margins tab of the Page Setup. 

• Orientation. The Portrait orientation works best when the data has more rows than 
columns. If the data sheet is wider than it is tall, select the Landscape orientation. 

• Scaling allows you to shrink the font size by a certain percentage to fit the data sheet into 
one page, or enlarge it to span the data sheet across multiple pages. 

• Paper size and Print quality. The options depend on the type of printer you use. 

• First page number allows you to specify any number to be the starting page number. 

• Margins adjusts the widths of the margins on the paper. 

• Center on page allows you to center the data sheet in the printout horizontally, vertically or 
both. 

Print Order and Other Options 

The Sheet tab of the Page Setup provides more printing options: 

• Print area allows to specify a range of cells to print. Recommended if you want to print only 
a specific selection of data and not the entire data sheet. For example, you could enter the 
range A1:B10 to print only cells A1 through B10. To print the entire data sheet, clear this 
field. 

• Print titles. If your data sheet is more than one page long, you can repeat row or column 
titles on each printed page to make it easier to read your data. For example, to repeat the 
column titles of a data table that has several rows spanning multiple pages, you could enter 
the range $1:$1 into the Rows to repeat at top field, where $1:$1 is the location of the 
column title in the table. 

• Gridlines prints the gridlines of a data sheet. 

• Draft quality prints the data sheet at a lower quality for faster printing. 

• Row and column headings prints the row numbers and column headings of the data sheet. 

• Comments. If you’ve added comments to the data sheet, you can choose to print them 
along with the data sheet. Choose whether to print the comments at the end of the sheet 
or as they are displayed in the sheet. 
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• Cell errors as allows you to specify how any cell errors in the data sheet should be 
displayed in the printouts. Choose whether to print them as displayed, <blank>, dashes (--) 
or as #/NA 

• Page order. If your data sheet spans multiple pages, you can specify the order in which the 
pages are numbered and printed. 

• Down, then over prints from the top down, then left to right. 

• Over, then down prints from left to right, then from the top down. 

Headers/Footers 

The Header/Footer tab of the Page Setup provides several options for adding custom 
headers/footers to the printed page. 

• Header and Footer drop-down lists allow you to select a predefined header/footer format. 
The software includes several predefined formats to choose from. 

• Different odd and even pages and Different first page gives you the option to apply 
different headers/footers for odd and even pages, or choose to apply a different 
header/footer to the first page only. Select the check box for the desired option and then 
click the Custom Header/Footer button to edit the headers (see the section below). To 
apply the same header/footer to all pages in the document, clear the check boxes for both 
options. 

• Scale with document auto-adjusts the font size to scale with the data sheet. 

• Align with page margins auto-adjust the position of the header/footer to be consistent 
with the page margins. 

Edit the Headers/Footers 

You can edit the headers/footers for the current printing session. Note that the edits are 
discarded when you switch to different header/footer format or when you exit the print 
preview. 

To edit an existing header/footer, choose it from the drop-down list and click the Custom 
Header/Footer button. Alternatively, you can select none from the drop-down list and then 
click the button. 

To insert variable information such as date, time, number of pages, etc., use the command 
icons in the window to insert the appropriate field codes (or use the codes shown in the table 
below). 
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Format Code Description 

&[Page] Inserts the page number. 

&[Pages] Inserts the number of pages. 

&[Date] Inserts date. 

&[Time] Inserts time. 

&[Path]&[File] Inserts the file path. 

&[File] Inserts the file name. 

&[Tab] Inserts the sheet name. 

&[Picture] Inserts a selected picture. Click the Format Picture icon on the 
Header/Footer window to set the image size and other properties. 

PAGE SETUP - WORD PROCESSING MODULE 

To access the Page Setup for the word processing module in ReliaSoft Workbooks, choose View 
> Print > Page Setup. 

Maximize Printing Space 

The following options are available on the Margins tab or Paper tab of the Page Setup. 

• Margins adjusts the widths of the margins on the paper. 

• Orientation. The Portrait orientation works best when the data has more rows than 
columns. If the data sheet is wider than it is tall, select the Landscape orientation. 

• Paper size. The options depend on the type of printer you use. 

Layout 

The Layout tab of the Print Setup provides more printing options: 

• Section divides the report into several sections, where each section can have different 
formatting elements such as the page orientation, margins, headers/footers, etc. The 
easiest way to insert section breaks is to exit the Page Setup and choose Page Layout > 
Page Setup > Breaks. 

• Headers and footers. You can choose to apply different headers/footers for odd and even 
pages, or choose to apply a different header/footer to the first page only. To apply the 
same header/footer to all pages in the document, clear the check boxes for both options. 
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To configure and save header/footer information into the report, exit the Page Setup and 
choose Document > Header & Footer > Header or Footer. 

To set up a header/footer that applies only to the current printing session (i.e., the 
information will be lost when you exit the preview), exit the Page Setup and choose View > 
Print > Print Preview. In the preview window, click the Header/Footer icon on the ribbon. 
To insert variable information such as date, time, number of pages, etc., use the command 
icons in the window to insert the appropriate field codes (or use the codes shown in the 
table below). 

Format Code Description 

[Page #] Inserts the page number. 

[Pages #] Inserts the number of pages. 

[Page # of Pages#] Inserts date. 

[Date Printed] Inserts the current date. 

[Time Printed] Inserts the current time. 

[User Name] Inserts the username of the current user. 
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Chapter 4: Weibull++ Ribbon 
In ReliaSoft desktop applications, the ribbon is divided into tabs that relate to a task or activity, 
such as managing the projects in a database or performing a specific type of analysis. 
Depending on the current activity, some commands may appear dimmed or will not appear at 
all. 

Note that many features in the application also have a shortcut menu (accessed by right-
clicking) that gives access to commands that are commonly used for that feature. All commands 
available in the shortcut menus are also available on the ribbon. 

To minimize the ribbon and maximize your workspace, click the arrow on the right-side of the 
ribbon (labeled "Minimize Ribbon" in the picture below). The ribbon will be expanded when 
you click a tab and then minimized after you click a command. 

 

Quick Access Toolbar 
The Quick Access Toolbar is a customizable feature of the ribbon that allows you to access 
frequently used commands without changing tabs. 

To add your favorite ribbon commands to the Quick Access Toolbar, right-click the command 
and select Add to Quick Access Toolbar. 

To remove a command from the Quick Access Toolbar, right-click the command and select 
Remove from Quick Access Toolbar, or click the Customize Quick Access Toolbar icon  and 
clear the check box for the command. 

To reposition the Quick Access Toolbar, click the Customize Quick Access Toolbar icon  and 
select to show it either below the ribbon or above the ribbon. 
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To reset the Quick Access Toolbar to default settings, click the Reset All Settings button in the 
Application Setup (File > Application Setup). 

Backstage View (File Tab) 
The Backstage view (File tab) is the first view you will see when you start a ReliaSoft desktop 
application. 

  Save As (available only when a standard database is currently open) saves a copy of 
the standard database to another pathname/filename and/or file type. You can save the 
file as a new standard database (*.rsr20) or compressed standard database (*.rsgz20). 

  Pack and E-mail (available only when a standard database is currently open) sends a 
compressed version of the standard database via e-mail.  

  Open Database opens an existing standard database, enterprise database or 
compressed standard database, from the current version or any previous version. You can 
also open even earlier file types, depending on the application you are currently using. 

  Close Database closes the database. You also can close the database by opening 
another database or by exiting the application. 

Recent shows a list of recently opened database files (*.rsr20 and *.rserp) and a list of 
recently accessed locations. Clicking a database will open it, and clicking a location will 
allow you to browse for databases in that location. The number of items in these lists is set 
in the Common Settings page of the Application Setup. You can pin items to a list by clicking 
the pushpin icon associated with the item; when the pin is vertical, the item will not roll off 
the list. 

New allows you to create a new standard database (*.rsr20) or connection file for access to 
an enterprise database (*.rserp). 

Manage Database provides a variety of tools and configurable settings for the database. 
The settings are shared by all users and all analysis projects in a database. 

Print (available only in Weibull++ and BlockSim) generates a print preview of the current 
data sheet, diagram or plot, and sends it to the printer. 

Help provides a variety of resources to help you use the application more effectively. In 
addition, it displays information about the application, including the Compile Release 
Version (CRV) and License information. 
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  Application Setup allows you to set your personal preferences for working with 
analyses, such as the math precision, default plot settings and the like. The settings apply 
only to the current computer/username, and they do not affect the results of the analyses. 

 Exit closes the current database (if any) and shuts down the application. 

MANAGE DATABASE 

The Manage Database section of the Backstage View contains the following commands. The 
available commands depend on the current application and the database type. 

Users 

  Users and Security controls which users can access the database and their 
permissions. 

  User Groups create and manage groups of users that can be assigned to actions, 
messages, etc. throughout the current database. 

  Database Logins displays a list of users who have connected to the database and 
allows you to export this information to Excel. 

  Reset "In Use" Flags allows you to reset the flags that indicate the "in use" status of 
projects or items within a project. 

Lambda Predict Database Settings 

Available only in Lambda Predict: 

  FIDES Settings Manager defines the settings related to the FIDES prediction standard 
such as process audits, pi factors, categories, etc. (See FIDES Settings Manager in the 
Lambda Predict documentation.) 

  Custom Derating Standards Manager allows you to add, edit, delete or import/export 
custom derating standards. (See Creating Custom Derating Standards in the Lambda Predict 
documentation.) 

  MIL-217 Custom Connections defines custom connection types for use with the MIL-
HDBK-217F prediction standard. (See MIL-217 Custom Connection Types in the Lambda 
Predict documentation.) 

http://help.reliasoft.com/lp20/index.htm#t=manage_fides_settings.htm
http://help.reliasoft.com/lp20/index.htm#t=custom_derating_standards.htm
http://help.reliasoft.com/lp20/index.htm#t=custom_connection_types.htm
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XFMEA/RCM++/RBI Libraries 

Available only in XFMEA, RCM++ and RBI: 

  Profiles/Library Manager configures the predefined settings of the profiles stored in 
the software library. Profiles allow you to customize the look, drop-down lists, rating scales 
and other settings of a particular project in order to fit the needs of the analysis. (See 
Profiles/Library Manager in the XFMEA/RCM++/RBI documentation.) 

  Templates Manager allows you to manage the configurable templates that can be 
used for customized reports, saved queries or importing/exporting data via Excel. (See 
Templates Manager in the XFMEA/RCM++/RBI documentation.) 

Settings and Predefined Options 

 Database Settings allows you to enable alerts via e-mail or SMS, activate history logs, 
and other settings. 

  Unit Settings defines the unit and measurement settings that will be available for use 
in any project within the database. 

  Project/Item Categories defines the categories that can be used to filter and group 
data throughout the database. 

  Default Name Formats (not applicable for MPC) specifies the default names for new 
resources, as well as new blocks in BlockSim RBDs, fault trees and phase diagrams. 

 Project Planning Resources (not applicable for MPC) defines the cost categories, 
teams, materials and facilities that are used for tracking costs, man hours and resource 
utilization in actions and Project Planner gates. 

 Working Days/Holidays (not applicable for MPC) specifies the business days when 
project planning resources can be utilized. 

 Dashboard Layout Manager (not applicable for MPC) shows all of the predefined 
dashboard layouts that will be available for any user to view for a particular data set. 

 Task Types (applicable only in RCM++, RBI and MPC) maps the task types used in 
RCM++ and RBI (e.g., Restoration, Failure Finding, etc.) to the corresponding task classes in 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=profiles_libraries_manager_window.htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=templates_manager.htm
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the universal reliability definition (e.g., Preventive, Inspection, etc.) so that simulation and 
cost calculation results are accurate. (See Task Types in RCM++/RBI in the 
XFMEA/RCM++/RBI documentation.) In MPC, it allows you to modify the abbreviations 
used for the MSG-3 task types. (See Task Type Abbreviations in MPC in the MPC 
documentation.) 

 XFRACAS Connection is available only for standard databases (*.rsr20) in Weibull++ 
and XFMEA/RCM++/RBI. It allows you to define connection settings for an enterprise 
database. 

Database Tools 

  New Enterprise Database opens a wizard that leads you through the steps to create a 
new enterprise database (SQL Server or Oracle database). To use this option, you must 
have access to a server with a supported version of SQL Server or Oracle and you must have 
the appropriate permissions to create a new database on the server. 

  Upgrade Enterprise Repository converts an existing Version 9 or later enterprise 
database to a Version 2020 enterprise database. This cannot be undone. It is 
recommended that you create a backup of the database before performing the upgrade. 

  Upgrade Version 8 Repository copies all of the existing data from a Version 8 
enterprise database to a new Version 2020 enterprise database. 

 Restore Points manages all of the project backups that are stored in the current 
database. 

 Compact and Repair is available only in a standard database (*.rsr20). It helps to 
reduce the size of the database and protect against data loss and corruption. (See Backups 
and Database Maintenance.) 

  Import from Version 5 is available only in XFMEA, RCM++ and RBI. It allows you to 
import data from a Version 5 XFMEA/RCM++ database. This command is available only 
when you are connected to an enterprise database and have the "Manage users and logins" 
permission and the applicable "Manage all projects" permissions. 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=task_types.htm
http://help.reliasoft.com/mpc20/index.htm#t=defining_task_type_abbreviations.htm
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Help Center 
The Help Center, which is part of the Backstage view, is intended to help you use the 
application more effectively by providing quick access to a variety of support tools. To access 
the Help Center, choose File > Help. 

USING THIS APPLICATION 

  Help File opens the application's help file. If you have an active Internet connection, 
the help topics that you see will always be the most up-to-date versions available. If you do 
not have an active Internet connection, the help topics that you see will be the local copy 
that was installed on your computer. 

  Quick Tour opens the Quick Tour within the application's help file. The Quick Tour 
provides a brief overview of the application's features, including basic steps for performing 
the most common analysis types. This command is available only if the current application 
offers a Quick Tour. 

ONLINE RESOURCES 

  reliasoft.com opens the main page of the reliasoft.com website. 

  weibull.com opens the weibull.com website, which is devoted entirely to the topic of 
reliability engineering, reliability theory and reliability data analysis and modeling. 

  reliawiki.org opens the ReliaWiki website, which is both a resource portal and a wiki 
for professionals in reliability engineering and related fields. 

EXAMPLES 

  Open Examples Folder provides access to a set of example projects that are designed 
to help you explore various software features. 

TECHNICAL SUPPORT 

  E-mail Support generates an e-mail to request technical support. The e-mail is pre-
populated with information about your license and operating system, which the technical 
support representative will need for troubleshooting the issue. 

https://www.reliasoft.com/
http://www.weibull.com/
http://www.reliawiki.org/index.php/Main_Page
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  Contact Technical Support provides the contact information you will need to obtain 
technical support. 

  Check for Update allows you to download the latest free service release for the 
software. 

• Licensing displays your license and registration details. To view or edit additional 
information, click License Manager. The License Manager displays additional information 
about which products you have currently registered and/or your contact information on file 
with us. 

• About displays the application's Compile Release Version (CRV) (sometimes called a "build 
number"), which allows you to determine whether you have the latest version of the 
software. 

Home Tab 
The Home tab contains the following commands: 

CLIPBOARD 

  Paste 

• Paste pastes the contents of the Clipboard to the current folio or spreadsheet. 

• Paste Special opens the Paste Special window, which allows you to paste specific cell 
contents or attributes (such as formulas, formats, or comments) from the Clipboard. 

  Cut cuts the selected text to the Clipboard. Data stored in the Clipboard can be pasted 
into this and other applications. 

  Copy copies the selected text to the Clipboard. Data stored on the Clipboard can be 
pasted into this and other applications. If you are copying a plot, the way the plot is copied 
will depend on your selection in the Copy Plot Graphic setting in the Application Setup 
window. 

  Format Painter copies the format properties of text in a sheet and applies it to other 
text. To use the Format Painter, first select the text with the format properties that are to 
be copied, then choose Format Painter and click the text to which the format properties 
are to be applied. 
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EDIT 

  Delete deletes the selected text. 

  Clear 

• Clear All deletes the contents and format of the selected cell(s), but does not delete 
the actual cell(s). 

• Clear Values deletes only the contents of the selected cell(s). The format will be 
retained. 

• Clear Formats deletes only the format of the selected cell(s). The contents will be 
retained. 

  Select All selects all of the cells in the currently active sheet. 

  Find searches the active data sheet for specified text/values and, if desired, replace 
the original with new text/values. You can specify the order in which to search (either By 
Rows or By Columns), and whether to look in equations (Formulas) or within the results of 
equations (Values). Select the Match Case check box to limit the results to text that have 
the same case. Select the Find Entire Cells Only check box to limit the results to 
text/numbers that are identical to the search term. 

To replace every instance of a text string, click Replace and in the Replace With field, type 
the text that will replace the original (if you don't type anything, the tool will delete the 
original). Click Find Next to search for the text. When a match is found, you can either click 
Replace to replace the original with the new text, or click Find Next to leave the original as-
is and find the next occurrence. To replace all instances without review, click Replace All. 

  Spelling activates the Spell Check utility, which allows you to check the spelling within 
the current sheet. 

INSERT 

  Project Item Wizard opens the Project Item Wizard, which provides information about 
all the analyses that you could add to the project and guides you through any steps 
required to configure the analysis that you have selected. 

Insert Gallery displays icons of the analyses, plots and diagrams that you could add to the 
project. Click the More  arrow to view the full gallery. 
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Life Data 

  Life Data adds a life data folio for life data analysis. It allows you to capture life 
data (e.g., failure times) from a sample of units and analyze the data based on an 
underlying life distribution. From the analysis, you can measure the reliability 
performance of a product over time or make projections about future behavior. 

  Non-Parametric LDA adds a non-parametric life data analysis (LDA) folio. It allows 
you to analyze life data without assuming an underlying life distribution. This analysis is 
useful when dealing with unknown failure modes, when there is not enough data to 
assume a life distribution or when the data set does not fit any life distribution in a 
satisfactory way. The folio also allows you to perform a standard (parametric) life data 
analysis on the data set in order to compare the results obtained from both methods 
and perform further analysis. 

Life-Stress Data 

  Life-Stress Data adds an Accelerated Life Testing life-stress data folio for 
accelerated life testing data analysis. It allows you to capture life data from a sample of 
units that are subjected to elevated stress conditions (the elevated stress conditions 
cause the units to fail more quickly, reducing the test time required to obtain data for a 
product). You can then analyze the data based on a life-stress relationship model in 
order to extrapolate a use level pdf, which allows you to obtain reliability predictions 
about the product at normal operating conditions. 

Growth Data 

   Growth Data adds a Reliability Growth data folio for growth data analysis. 

Designs 

  Standard Design adds a DOE standard design folio for identifying important factors 
(i.e., "screening") and determining the best settings for these factors (i.e., 
"optimization"). 

  Robust Design adds a DOE robust design folio that includes all the functionality of 
the standard design folio, with the addition of some features specific to the robust 
design methodology. 
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  Mixture Design adds a DOE mixture design folio for when the factors in an 
experiment are components in a mixture, and when you wish to determine the best 
proportions to use for each component. 

  Free Form adds a free form folio that allows you to analyze data from an 
experiment by manually entering the factor level combination and observed response 
for each test run. 

  Optimization opens the Select Optimization Tool window, which provides tools 
that allow you to examine factor level combinations and evaluate how well they meet 
your response goal(s). 

Warranty 

  Warranty adds a warranty data analysis folio for capturing and analyzing failure 
data from fielded products, in order to predict future warranty returns (product 
failures) and plan for warranty fulfillment needs such as the number of spares to stock. 

Degradation 

  Degradation adds a degradation analysis folio. If you have Accelerated Life Testing 
on your computer, all four options will be available: 

• Nondestructive Degradation folio allows you to estimate the point at which a 
product is expected to fail based on the level of degradation of a physical or 
performance characteristic (e.g., depth of tire tread, voltage of battery, 
propagation of crack size) over time. Multiple measurements are taken per test 
unit over time, and the folio analyzes the extrapolated failure times using standard 
life data analysis to obtain reliability predictions about the product. 

• Destructive Degradation folio is used in cases where measuring the level of 
degradation of a specimen is not possible without invasive techniques or 
destroying the specimen (e.g., corrosion in a chemical container, strength 
measurement of adhesive bond). Unlike the nondestructive degradation analysis 
folio, only one measurement is taken per test unit and multiple samples are 
required at different points in time. 

• Accelerated Nondestructive Degradation folio is used for cases where the 
specimen is subjected to elevated stress conditions. The elevated stress conditions 
accelerate the degradation of the product, reducing the test time required to 
obtain the measurements. The folio analyzes the extrapolated failure times using 
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accelerated life testing data analysis to obtain reliability predictions about the 
product at normal operating conditions. 

• Accelerated Destructive Degradation is similar to the Weibull++ destructive 
degradation folio except that accelerated stress levels are used during testing to 
further reduce the test time required to obtain the predicted failure times. 

Repairable Systems 

  Non-Parametric RDA adds a non-parametric recurrent event data analysis (RDA) 
folio. The folio is similar to a parametric RDA folio, except that it uses the mean 
cumulative function (MCF) to model the reliability performance of a system over time 
and obtain estimates such as the cumulative number of failures. 

  Parametric RDA adds a parametric recurrent event data analysis (RDA) folio for 
capturing and analyzing data obtained from recurring events, as in the case of a 
repairable system that may fail or be repaired multiple times during its operation life. 
The folio uses the General Renewal Process (GRP) model to describe the failure 
behavior of a system over time and obtain estimates such as the cumulative number of 
failures, mean time between failures (MTBF) and failure intensity. 

  Event Log adds an event log folio, which allows you to capture data in an event log 
format (commonly used in the Machine Tools and other industries) and analyze the 
information in order to create a reliability model for a piece of equipment. The 
reliability model can be used to help you understand the performance of the 
equipment, such as the total system uptime/downtime, or obtain reliability predictions 
about its future behavior. 

Test and Planning 

  Test Design opens the Test Design Assistant, which provides tools that help you 
design, evaluate and compare reliability demonstration tests based on the number of 
failures (pass/fail tests) or the time of failure. 

  Target Reliability adds a target reliability estimator folio, which generates plots to 
help you select a reliability goal that will minimize cost, maximize profit and maximize 
the return on an investment. 

  Linearity and Bias adds a linearity & bias folio that is used to estimate a measuring 
device's accuracy (i.e., the extent to which the device underestimate or overestimates, 
across the device's expecting operating range). 
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  Gage R&R adds a gage R&R folio that is used to estimate a measurement system's 
precision (i.e., the variation in measurements that can be expected when the same part 
is measured repeatedly). 

  Gage Agreement adds a gage agreement folio that is used to compare the 
accuracy and precision of two systems. 

  ALTA Test Plan adds an ALTA test plan folio, which helps you design a test plan for 
accelerated life data testing analysis. Based on information you provide, the test plan 
will include recommendations for stress levels and the number of units to be tested at 
each stress level. 

  Maintenance Planning adds a maintenance planning folio, which generates a cost 
vs. time plot that helps you determine the cost-effective time to replace aged 
components. 

  Continuous Growth Planning adds a continuous growth planning folio to the 
project. 

  Discrete Growth Planning adds a discrete growth planning folio to the project. 

   Repairable Systems Test Design opens the Repairable Systems Test Design folio 
that can assist you in designing a demonstration test. 

Comparison 

  Stress-Strength Comparison adds a stress-strength comparison folio for 
comparing two data sets to determine the probability of failure based on the 
probability of stress exceeding strength. 

  Life Comparison adds a life comparison folio for comparing two data sets to 
determine whether the lives of the units in the first data set will outlast the lives of the 
units in the second. 

  One-Way ANOVA adds a DOE one-way ANOVA folio that offers a simple way to 
evaluate the effect of a single factor on a single response. 

Mission Profile 
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  Mission Profile adds a mission profile folio to the project. 

Regression Tools 

  Multiple Linear Regression adds a multiple linear regression folio, which allows 
you to enter and analyze your own experimental data without using one of the DOE 
design types provided in available in Weibull++. 

  Equation Fit Solver adds a non-linear equation fit solver folio, which allows you to 
estimate the parameters of any user-defined non-linear equation. This gives you the 
flexibility to perform simple parameter estimation on statistical models other than the 
life distributions and life-stress relationship models available in Weibull++. 

Diagram 

  Diagram adds a reliability block diagram (RBD). In Weibull++, RBD diagrams are 
used to graphically represent the failure modes of a product and analyze how each 
mode contributes to the overall reliability performance of the product. 

Simulation 

  Monte Carlo opens the Monte Carlo utility, which allows you to generate a data 
set that fits a specified life distribution or model. The generated data set can then be 
analyzed like any other data set and used in a variety of applications, such as in the 
analysis of probabilistic design models, or to compare the data generated from 
simulation with actual field data. 

• Monte Carlo generates a data set for life data analysis. 

• Stress-Dependent Monte Carlo generates a data set for accelerated life testing 
data analysis. 

• Repairable Systems Monte Carlo generates a single data set containing values that 
are distributed according to the Crow-AMSAA (NHPP) model with specified beta 
and lambda parameters. 

  SimuMatic opens the SimuMatic utility, which allows you to generate several data 
sets all at once and automatically perform an analysis on each of the generated data 
sets. The simulated data could be used in a number of applications such as in the 
analysis of probabilistic models, risk analysis and in designing reliability tests. 
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• SimuMatic performs basic life data analysis on each of the generated data sets. 

• Stress-dependent SimuMatic performs accelerated life testing data analysis on 
each of the generated data sets. 

• Repairable Systems SimuMatic generates several sets of data at once and 
automatically perform a large number of reliability analyses on them. 

   Simulation Worksheet adds a simulation worksheet that allow you to vary values 
that are used in simulating a BlockSim simulation RBD or an event analysis flowchart. 
This allows you to investigate the effect of one or more settings on the simulation 
results. 

Reports and Plots 

  ReliaSoft Workbook adds a ReliaSoft Workbook, which is a custom reporting tool 
that contains both spreadsheet and word processing modules. 

  Overlay Plot adds an overlay plot that allows you to display in a single plot results 
from multiple data sheets. This provides an easy visual method to compare analyses. 
For example, you may wish to show the reliability plots of two product designs in the 
same plot or compare a simulation-based data set with actual data obtained from 
fielded products. 

  Side-By-Side Plot adds a side-by-side plot that allows you to display different plots 
of a single data set all in a single window for easy comparison. For life data analysis, 
you can select to plot the data set using multiple distributions or plot types. For 
Accelerated Life Testing, you get a third option to plot the data set using multiple life-
stress relationship models. 

  Multi-Phase Plot adds a new Multi-Phase Plot to the project. This allows you to 
plot data from multiple test phases together, along with data from a growth planning 
folio, if desired. 

  3D Plot adds a 3D plot that allows you to graph functions with three variables such 
as the reliability at a given time and stress level. 

  3D Overlay Plot adds a 3D overlay plot. This type of plot is similar to regular 
overlay plots but displayed in 3D space. 

Attachments 

https://www.reliasoft.com/products/reliability-analysis/blocksim
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  Attachment adds linked or attached files to the project. 

RELIASOFT 

  Quick Tools 

  Non-Linear Equation Root Finder opens the Non-Linear Equation Root Finder 
utility, which allows you to solve for the root of any user-defined non-linear equation. 
This helps you eliminate some of the guesswork of solving for the value of the unknown 
variable that brings the function as close to zero as possible. 

  Quick Statistical Reference opens the Quick Statistical Reference utility, which 
allows you to calculate common statistical values such as median ranks, chi-squared 
values and student's t values. It also includes a polynomial interpolation/extrapolation 
function, which allows you to obtain new data points from a set of known data points 
that you provide. 

  Quick Parameter Estimator (W++) opens the life data version of the QPE, which 
allows you to estimate the parameters of a distribution based on information you have 
about the reliability of a product, the probability of an event occurring or the typical 
duration of a task. 

  Quick Parameter Estimator (ALTA) opens the Accelerated Life Testing version of 
the QPE, which allows you to estimate the parameters of a model based on information 
you have about the reliability of a product at normal and accelerated stress levels. 

  Resource Manager opens the Resource Manager window, which allows you to view 
and edit all of the resources (URDs, models, tasks, etc.) available to the selected project. 
This command is not available in MPC. 

  Batch Properties Editor opens the Batch Properties Editor, which allows you to 
perform batch editing of most types of local resources in the current project. In BlockSim, it 
also allows you to edit the blocks used in the diagrams. This command is not available in 
MPC. 

  Actions Explorer allows you to explore all of the action resources that are stored in the 
current database. You can filter and sort by date, status, person responsible, relevancy to 
you, etc. (See Actions Explorer.) 
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  Analysis Explorer allows you to explore all of the different analyses that are stored in 
the current database. You can filter, group and sort the analyses in a flexible grid, and also 
present the information in a wide variety of dashboard charts. (See Analysis Explorer.) 

  Reliability Data Warehouse allows you to access data from ReliaSoft’s XFRACAS or 
other external data sources for life data analysis. (See Reliability Data Warehouse (RDW).) 

  Launch Application provides a drop-down list of the other ReliaSoft applications that 
are installed on your computer. When you click an icon, the same database will be opened 
automatically in the new application. 

My Portal Tab 
The My Portal tab contains commands related to using the My Portal feature. 

MESSAGES 

  Create Message opens the Message window, which allows you to compose and send 
messages within the database. 

  Edit Message opens the Message window, which allows you to view and edit all of the 
properties of the message. 

  Reply to Message opens Message Reply window, which allows you to respond to a 
message sent to you. 

  Delete Message deletes the current message. 

ACTIONS 

  Create Action opens the Action window and adds an action to the project. 

  Edit Action opens the Action window, which allows you to view and edit all of the 
properties of the action record. 

  Delete Action deletes the current action record. 
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  Add to Outlook Calendar adds an event, on the Action's due date, to your Outlook 
calendar. 

USERS 

  My Profile opens the User Login and Contact Information window where you change 
your contact details for your user account in the current database. 

Project Tab 
Unless otherwise indicated, these commands apply to the project that is currently selected in 
the project list. There are three ways to select a project and apply a command: 

• By right-clicking the project in the project list and choosing the command from the shortcut 
menu. 

• By selecting the project in the project list and then clicking the command on the ribbon. 

• By clicking anywhere inside the project that is currently open/visible and then clicking the 
command on the ribbon. 

Note: For secure databases, access to the commands on this tab may be restricted based on the 
permissions assigned to the user account. 

MANAGEMENT 

  Create Project adds a new project to the current database. At a minimum, you must 
specify the project name. 

  Open Project opens the selected project. 

  Close Project closes the project that is currently open/visible and all of the analyses it 
contains. 

  Edit Project Properties allows you to view and edit the properties of the selected 
project. 
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  Duplicate Project creates a copy of the selected project. The new project will have the 
same name as the original with an increment number added to the end (e.g., Project_1, 
Project_2, etc.). 

  Delete Project moves the selected project to the recycle bin. 

  Transfer Project is available only in XFMEA/RCM++/RBI. It allows you to create a new 
project with data transferred from the selected project. (See Transfer Projects in the 
XFMEA/RCM++/RBI documentation.) 

  Task Numbering is available only in MPC. It allows you to specify whether or not you 
want to reuse task numbers within the project. (See Task Numbering in MPC in the MPC 
documentation.) 

  Manage Projects opens the Manage Projects window, which allows you to edit the 
security settings and properties of all projects in the database in one location. 

  Import/Export gives you the option to open either the Import or Export wizard. The 
Import wizard allows you to import projects, resources or items from an existing database 
into the current database, while the Export wizard allows you to export to a new or existing 
database. (See Import, Export and Data Conversion.) 

  Configurable Settings is available only in XFMEA/RCM++/RBI. It allows you to 
view/modify the configurable settings for the current project. (See About Configurable 
Settings in the XFMEA/RCM++/RBI documentation.) 

  Restore Point gives you the option to utilize restore points, which are exact replicas of 
the project at a particular point in time (i.e., backups). To create a restore point for the 
selected project, use the Create Restore Point command. To restore all data from an 
existing restore point, use the Restore Project command. 

  Check In/Out allows you to check out the selected project and make it available for 
editing only to you, while all other users in the database have read-only access to the 
project. No other user can edit the project unless you check in the project or undo the 
check out. 

  Recycle Bin 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=transfer_projects.htm
http://help.reliasoft.com/mpc20/index.htm#t=task_numbering_in_mpc.htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=about_configurable_settings_xfmea.htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=about_configurable_settings_xfmea.htm
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  Empty Recycle Bin permanently deletes all projects under the Recycle Bin heading 
in the project list. There is no undo for emptying the recycle bin. 

  Restore Project is available only when you have selected a project under the 
Recycle Bin heading. The selected project will be recovered from the recycle bin and 
restored to its original location in the project list. 

  Delete Project permanently deletes the selected project. There is no undo for 
delete unless you have a stored backup or restore point. 

  History Log is available only if you are the project owner or have the applicable 
"manage all projects" permissions. It opens the Project History Log window, which allows 
you to activate and deactivate the history log for the project and, if the history log is 
currently activated, to view changes that have been performed throughout the entire 
project, with any ReliaSoft application. 

  Project Planner opens the Project Planner, which provides full project planning and 
management capabilities for the current project. This command is not available in MPC. 

  Attachments is available only in XFMEA/RCM++/RBI and MPC. It adds linked or 
attached files to the selected project. In other ReliaSoft desktop applications, attachments 
commands are available in the current project explorer. 

E-MAIL PROJECT 

  Pack and E-mail compresses a copy of the selected project to a *.rsgz20 file and 
attaches it to a new e-mail message. If no e-mail program is installed or no default e-mail 
program is defined on the computer, a message notifying you of this will be shown. 

SECURITY 

  Project Security is available only for public projects in secure databases. It opens the 
Project Properties window with the Security tab active, where you can specify the user 
accounts that can view/modify the selected project. 

  Change Owner allows you to assign a different database user to be the owner for the 
selected project. 
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  Lock Project moves the project into the Locked heading of the project list. When a 
project is locked, all database users (including the user who locked the project) will have 
read-only access to the project. In addition, a locked project cannot be deleted or have its 
properties and public/private status edited. To unlock a project, choose Unlock Project. 
(See Locked and Unlocked Projects.) 

  Make Private moves the selected public project into the Private heading of the project 
list. (See Public, Private and Reference Projects.) 

  Make Public moves the selected private or reference project into the Public heading of 
the project list. 

  Make Reference moves the selected public project into the Reference heading of the 
project list. This command is not available in MPC. 

CURRENT ITEM 

The following commands are available when you select a specific item (a diagram, report, 
multiplot, etc.) in the current project explorer. This group is not available in XFMEA/RCM++/RBI 
or in MPC. 

  Edit brings the selected item to the front of the windows and activates it as the current 
control. If an attachment is selected, the command opens the attachment in the 
appropriate application, if that application is installed on your computer. 

  Rename allows you to rename the selected item. 

  Duplicate creates a copy of the selected item within the project. The duplicate will 
have the same name as the original with an increment number added to the end (e.g., 
RBD1_1, RBD1_2, etc.). In BlockSim, you can choose to Duplicate With Resources, which 
also creates duplicate resources in the Resource Manager window. 

  Delete deletes the selected item. There is no undo for delete. 

  Item Properties is available only for project explorer items (e.g., folios, diagrams, plots, 
etc.). It opens the Item Properties window, which allows you to view and edit the item's 
Identifiers, item settings (if applicable) and item permissions (in secure databases).   
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  Save Locator Link is a link file (similar to a Windows shortcut) that provides quick 
access to the specific analysis. In an enterprise database, you can choose to Save or E-mail 
the file. In a standard database, the only option is to save the file. In XFMEA/RCM++/RBI, 
these commands are available in the System Hierarchy tab. In MPC, they are in the 
Systems, Structures, Zones or L/HIRF tab. 

DATA MANAGEMENT 

The following commands are available only in BlockSim. 

  Mirror Group Manager opens the Mirror Group Manager window, which allows you to 
add, view and edit groups of mirrored blocks within the project that is currently 
open/visible. (See Mirroring (Using Blocks in Multiple Locations) in the BlockSim 
documentation.) 

  Maintenance Group Manager opens the Maintenance Group Manager window, which 
allows you to add, view and edit the maintenance task groups available to the project that 
is currently open/visible. (See Maintenance Groups.) 

  Flow Group Manager opens the Flow Group Manager window, which allows you to 
add, view and edit the flow groups available to the project that is currently open/visible. 
(See Flow Groups in the BlockSim documentation.) 

REPORTS 

  MRBR is available only in MPC. It allows you to generate a maintenance review board 
report in Microsoft Word. (See Maintenance Review Board Reports in the MPC 
documentation.) 

View Tab 
The View tab contains commands related to configuring the layout of the application's 
interface. 

REFRESH 

  Refresh refreshes the display in the Project window. If multiple users are accessing the 
same project simultaneously, this command will refresh your screen with any changes 
made by other users. When you make a change to the project, your window will be 
refreshed automatically. 

http://help.reliasoft.com/blocksim20/index.htm#t=mirroring_using_blocks_in_multiple_locations.htm
http://help.reliasoft.com/blocksim20/index.htm#t=flow_groups.htm
http://help.reliasoft.com/mpc20/index.htm#t=maintenance_review_board_reports.htm
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PROJECT MANAGER 

  Show Project Manager brings the Project Manager into focus. If the Project Manager 
is unpinned and hidden, choosing this command will display it. 

  Tile Project Manager tiles the project list and current project explorer so they are both 
displayed simultaneously in the Project Manager panel. This command is not available in 
XFMEA, RCM++, RBI or MPC. 

  Dock Project Manager opens a submenu that allows you to choose the desired 
position for the Project Manager: Dock Left, Dock Right, Dock Top, Dock Bottom or Floating. 

MY PORTAL 

  Show My Portal opens the My Portal window, which provides information relevant to 
your work within the database, such as messages from other users, recommended actions 
for a particular project item, status of other users logged in to the database and other 
information.   

  Tile My Portal tiles the Messages, Actions and Users pages so they are all displayed 
simultaneously within the My Portal panel. 

  Dock My Portal opens a submenu that allows you to choose the desired position for 
the Portal: Dock Left, Dock Right, Dock Top, Dock Bottom or Floating. 

WORKSPACE LAYOUT 

The commands in this group are available only in XFMEA, RCM++, RBI, MPC and Lambda 
Predict. 

  Change Orientation toggles between the two possible orientations for the System 
panel and the Analysis/Properties panel. These panels can be side-by-side or one on top of 
the other. 

  Hide System [Panel/Hierarchy] hides the System panel in the Project window. When 
you want to show the panel again, choose View > Workspace Layout > Split Panels. 
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   Hide [Analysis Panel/Properties] hides the Analysis/Properties panel in the Project 
window. When you want to show the panel again, choose View > Workspace Layout > Split 
Panels. 

   Split Panels splits the Project window into two equal panels, with 50% of the available 
space used for the System panel and 50% of the available space used for the 
Analysis/Properties panel. 

   Properties View is available only in Lambda Predict. 

  Tree View organizes the properties depending on whether they are physical 
properties (e.g., part quality level, case type, etc.) or application properties (e.g., 
ambient temperature, applied voltage, etc.). Depending on the prediction standard and 
component you are working with, the properties may also be organized according to 
failure mechanisms or type of data. 

  Pi Factor View organizes the item properties based on the pi factors that they 
contribute to so you can see how the values affect the failure rate calculations. The 
relevant pi factors will vary depending on the item's failure rate model. (See the Tree 
View and Pi Factor View topic in the Lambda Predict documentation.) 

EXPAND/COLLAPSE 

The commands in this group apply to the hierarchical view that currently has focus. Depending 
on the application, this can be the project list, the current project explorer, the System panel, 
the Properties panel (Lambda Predict only) or the Analysis panel if it is using a hierarchical view. 

   Expand Tree expands the entire tree in the hierarchical view. 

  Collapse Tree collapses the entire tree in the hierarchical view. 

   Expand Node expands the selected branch in the hierarchical view. 

   Collapse Node collapses the selected branch in the hierarchical view. 

  Collapse to Level collapses the hierarchical view to the level of the item that is 
currently selected. For example, if you have selected a cause in the FMEA hierarchy view 
and choose this command, all branches in the FMEA hierarchy view will be collapsed to the 
cause level and the nodes for controls and actions will be hidden. 

http://help.reliasoft.com/lp20/index.htm#t=tree_view_vs_pi_factor_view.htm
http://help.reliasoft.com/lp20/index.htm#t=tree_view_vs_pi_factor_view.htm
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ZOOM 

  Normal Zoom sets the degree of magnification to 100%. 

  Zoom In increases the degree of magnification. 

  Zoom Out decreases the degree of magnification. 

  Custom Zoom allows you to specify the degree of magnification. 

WINDOW 

  Use Tabbed MDI maximizes the windows to fill the full space available in the MDI and 
shows a tab for each open window. If you clear this command, the open windows will be 
displayed as separate windows that can be resized and moved around within the MDI. 

  Window 

  Cascade cascades all open project windows inside the MDI. 

  Tile Horizontally horizontally tiles all open project windows inside the MDI. 

  Tile Vertically vertically tiles all open project windows inside the MDI. 

  Arrange Icons automatically organizes the icons for all open, minimized project 
windows inside the MDI, sending them to the bottom left corner. 

  The Windows drop-down list displays a list of all project windows currently open 
inside the MDI. You can make any of the open project windows active by clicking its 
name in this ribbon. 

  Close All Windows closes all open project windows inside the MDI, leaving only 
the Project Manager and My Portal panels open (if they were selected to be shown). 

FMRA 

The commands in this group are available only in BlockSim. (See Failure Modes and Reliability 
Analysis (FMRA) in the BlockSim documentation.) 

http://help.reliasoft.com/blocksim20/index.htm#t=fmra_view.htm
http://help.reliasoft.com/blocksim20/index.htm#t=fmra_view.htm
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  Show FMRA opens the FMRA view, which displays the FMRA (failures modes and 
reliability analysis) hierarchy that is associated with the project. 

  Disassociate FMRA deletes all of the diagrams and blocks associated with the current 
FMRA hierarchy and closes the FMRA view. 

SHOW 

The commands in this group are available only in XFMEA, RCM++ and RBI. 

  Show FMRA enables/disables the FMRA tab in the System panel. 

Application-Specific Tabs 

3D PLOT TAB 

The 3D Plot tab is visible when you view a 3D plot sheet. 

Plot 

  Redraw Plot updates the plot to reflect any changes that have been made. 

  Select Data Sheet opens a window that allows you to select the data sheet to plot. 

Actions 

  Copy Plot Graphic copies the current plot to the Clipboard as a bitmap (*.bmp) 
graphic. 

  3D Plot Setup opens the 3D Plot Setup, which offers several options for customizing 
the 3D plot such as editing axis titles, line styles, grid lines, etc. 

  Export Plot Graphic opens the Save As window, which allows you to save the current 
plot graphic as a *.jpg, *.gif, or *.png. 

Display 

  Show Legend displays information about the objects shown on the plot. 
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  Center on Canvas centers the 3D plot horizontally and vertically on the plot sheet. 

  Auto Spin auto-rotates the plot horizontally. 

  Normal Zoom sets the degree of magnification to 100%. 

  Zoom In and    Zoom Out increase or decrease the degree of magnification. 

  Custom Zoom allows you to specify the degree of magnification. 

DATA TAB 

The Data tab is visible when you view a DOE design folio. Depending on which type of design 
folio you view, the following commands may be available. 

Analysis 

  Calculate analyzes the data for each response that is selected to be included in the 
analysis. To exclude a response from the analysis, clear the check box in its column heading. 

  Plot creates a plot based on the analysis. If you click this icon before the current data 
set has been analyzed, an analysis will be performed automatically. 

  Prediction opens the Prediction window, which allows you to enter values for each 
factor and see predicted results for the selected response. 

  Optimization adds an optimal solution plot to the optimization folio that is linked to 
the design folio. If no linked optimization folio exists, the software will create one. 

  Overlaid Contour Plot adds an overlaid contour plot to the optimization folio that is 
linked to the folio. If no linked optimization folio exists, the software will create one. 

Design 

  Select Terms opens the Select Terms window, which allows you to specify the terms 
(i.e., factors, factorial interactions, blocks and quadratic effects) to be considered for each 
response. 



Chapter 4: Weibull++ Ribbon 

Weibull++ 2020 User's Guide 187 

 

  Alter Data Type is available only for designs that are configured to accept life data. It 
opens the Alter Data Type window, which is used to specify the type of life data response 
(e.g., right censored data) that is used in the current experiment. 

  Select Transformation opens the Select Transformation window, which allows you to 
select a transformation to apply to each response. 

  Variability Analysis is available only for two level factorial and Plackett-Burman 
designs with standard life data. It opens the Variability Analysis window, which allows you 
to select the response column(s) that you want to see variability analysis for and which 
factors to consider. 

  Fold Design is available only for designs that require two-level factors (i.e., two level 
factorial and Plackett-Burman designs). It opens the Fold Design window, which allows you 
to replicate the design with runs that use the opposite levels for that factor. 

  Optimal Design opens the Optimal Design window, which allows you to optimize a 
built design by taking into account a) the specific effects that are under investigation, b) 
limitations on the number runs that can be performed and c) constraints on the factor level 
combinations that can be used during the experiment. 

  Augment Design presents options where you can augment the design by adding 
individual runs or replicates. See Augmenting Designs. 

  Set Shape Parameter applies to reliability DOE designs only. If you already have a 
reliable estimate for the life distribution's shape parameter, you can enter it here. This can 
reduce the uncertainty in your results, since the analysis will solve for fewer variables. 

Simulation Worksheets 

  Transfer to Simulation Worksheet transfers the factor settings to a new simulation 
worksheet. 

Folio Sheets 

  Select Sheet allows you to select which sheet in the current folio you want to be 
active. 

  Delete Sheet deletes the current sheet within the folio. 
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Format and View 

  Visible Columns opens the Visible Columns window that allows you to choose which 
columns to hide/show in the Data tab. 

Display 

  Actual Values displays the actual values for the factors. 

  Coded Values displays the coded values for the factors. Which coded values are used 
(e.g., whether 0 or -1 represents the low level) is dependent on the design type. 

  Amount applies to mixture designs only. 

  Amount displays the component factor values as amounts (e.g., 2 pounds). 

  Proportion applies to mixture designs only. It displays the component factor 
values as proportions (e.g., 0.2 = 20% of the total mixture used in the run). 

  Pseudovalue applies to mixture designs only. It displays the component factor 
values as scaled values between 0 and 1, where 0 is the minimum possible value for 
the factor (given the design settings) and 1 is the maximum possible value. 

ReliaSoft 

  Publish Model allows you to use the results of the growth analysis as a resource object 
and make it available for unlimited use elsewhere within the project, in any ReliaSoft 
application that has a need for that type of object. 

  Publish SEP Summary publishes a summary of the current analysis to the SEP web 
portal. This is visible only if the enterprise database is configured for SEP and you have the 
"Publish to SEP web portal" permission (see Publishing to SEP). 

DEGRADATION TAB 

The Degradation tab is visible when you view a nondestructive degradation analysis folio data 
sheet for degradation analysis. 
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Analysis 

  Calculate extrapolates the times at which the degradation will reach the critical 
degradation level (i.e., the times at which the degradation is serious enough that the unit is 
considered to be failed), and then performs life data analysis or accelerated life testing 
analysis on the extrapolated times. 

  Plot creates a new sheet in the folio that provides a choice of applicable plot types. 
This includes the degradation vs. time plot, which displays the degradation of each unit 
over time. 

  Quick Calculation Pad opens the Quick Calculation Pad, which allows you to calculate 
results identical to the calculations you can perform in a life data folio QCP or a life-stress 
data folio QCP. 

  Model Wizard opens the Degradation Model Wizard, which helps you select the 
degradation model that best fits your data. 

  Distribution Wizard helps you select a distribution that best fits a data set. See the life 
data version or life-stress data version of the Distribution Wizard. 

Transfer Life Data 

Note: If you are using the Accelerated Life Testing degradation folio, the icons show the 
Accelerated Life Testing version, and the extrapolated data are transferred to a life-stress data 
folio. 

  Transfer Life Data to New Folio transfers the extrapolated failure and suspension 
times to a new life data folio. 

  Transfer Life Data to Selected Folio transfers the extrapolated failure and suspension 
times to an existing life data folio. 

ReliaSoft 

  Publish Model publishes the chosen distribution as a model for use throughout the 
project, in any ReliaSoft application where models are used. See Publishing Models. 
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Format and View 

  Override Plot Color opens the Override Plot Color window, which allows you to ignore 
the default colors of the plotted line and points, and apply a color that you specify. This 
setting is activated in the source data sheet of the plot. This means that when you enable 
the setting for a particular data sheet, it applies only to the plots that you create for that 
data sheet and not the plots for all other data sheets that may be within the same folio. 
Note that only the colors of the lines and points are affected. Other settings such as the line 
style and thickness, or the point size and shape are based on the settings that you have 
specified in the Plot Items page of the Plot Setup window. 

  Switch to Unit View/Switch to Inspection View toggles between the views for a 
nondestructive data sheet. The Unit View displays the information about each 
measurement in separate rows for each unit and inspection time. The Inspection View 
displays measurements for multiple units at each inspection time. 

  Add/Remove Columns 

• For life data nondestructive folio data sheets, this allows you to add or remove subset 
ID columns when using the Inspection View. 

• For Accelerated Life Testing nondestructive data sheets, this allows you to add or 
remove columns for stress levels and, when using the Inspection View, add or remove 
subset ID columns. 

DESIGN TAB 

The Design tab is visible is available when creating an experiment design in a design folio. 

Responses 

  Add Response adds a new response to the design. 

  Remove Response removes the currently selected response from the design. 

Factors 

  Add Factor adds a new factor to the design. 

  Remove Factor removes the currently selected factor from the design. 
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Import/Export 

  Import Template allows you to load the settings from a design that was previously 
saved. 

  Export Template allows you to save all your current design settings for use in future 
designs. 

General 

  Build Design builds the experiment based on the current settings. 

   Clear Settings resets all the settings on the Design tab. 

  Undo Changes reverts to the settings that were originally used. 

  Change Orientation allows you to display the navigation and input panels side-by-side 
or with one panel above the other. 

DESTRUCTIVE DEGRADATION TAB 

The Destructive Degradation tab is visible when you view a destructive degradation folio data 
sheet for degradation analysis. 

Analysis 

  Calculate fits the degradation measurements directly to the chosen degradation 
model and life distribution. 

  Plot creates a new sheet in the folio that provides a choice of applicable plot types. 
This includes the degradation vs. time plot, which displays the degradation of each unit 
over time. 

  Quick Calculation Pad opens the Quick Calculation Pad, which allows you to calculate 
results identical to the calculations you can perform in a life data folio QCP or a life-stress 
data folio QCP. 

  Model Wizard opens the Degradation Model Wizard, which helps you select the 
degradation model that best fits your data. 
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  Distribution Wizard helps you select a distribution that best fits a data set. See the life 
data version or life-stress data version of the Distribution Wizard. 

ReliaSoft 

  Publish Model publishes the chosen distribution as a model for use throughout the 
project, in any ReliaSoft application where models are used. See Publishing Models. 

Format and View 

  Override Plot Color opens the Override Plot Color window, which allows you to ignore 
the default colors of the plotted line and points, and apply a color that you specify. This 
setting is activated in the source data sheet of the plot. This means that when you enable 
the setting for a particular data sheet, it applies only to the plots that you create for that 
data sheet and not the plots for all other data sheets that may be within the same folio. 
Note that only the colors of the lines and points are affected. Other settings such as the line 
style and thickness, or the point size and shape are based on the settings that you have 
specified in the Plot Items page of the Plot Setup window. 

DIAGRAM TAB 

The Diagram tab is visible when you view a reliability block diagram (RBD). 

Analysis 

  Analyze analyzes the relationships of the components in the diagram and puts the 
reliability-wise configuration into a mathematical formula. 

  Plot creates a plot based on the analysis results. Clicking the Plot icon before the 
diagram has been analyzed will automatically perform the analysis and then plot the data. 

  QCP opens the Weibull++ Quick Calculation Pad (QCP), which allows you to obtain 
reliability results based on the algebraic solution for the diagram. Clicking the QCP icon 
before the diagram has been analyzed will automatically perform the analysis and then 
open the QCP. 

  Transfer to BlockSim is available only if BlockSim is activated on your computer. It 
exports the blocks into a new BlockSim simulation diagram. All the blocks must be 
associated with a published model before they can be exported. 

https://www.reliasoft.com/products/reliability-analysis/blocksim
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Blocks 

  Add Block adds a new standard block to the current diagram. The block represents a 
data sheet in a life data or life-stress data folio. 

  Add Node adds a new node (k-out-of-n switch) to the current diagram. 

   Add Junction adds a non-failing block to the diagram. Because diagrams must flow 
from a single starting point to a single ending point, you may need to use junction blocks as 
starting and/or ending blocks (see Diagram Analysis Constraints). They can also be used 
anywhere within the diagram that you need a block that does not fail (i.e., does not affect 
the system reliability). This type of block does not have properties. 

  Auto Arrange automatically arranges the blocks in the diagram so that all blocks are 
evenly spaced and centered. 

Settings 

  Connect Blocks allows you to create connectors between blocks in the current 
diagram. When this command is selected, click the source block, hold down the left mouse 
button and drag a line from the source block to the destination block. When the crosshairs 
are located above the destination block, release the mouse button to create a connector. 
To stop adding connectors and return to the normal mode, click the diagram or clear the 
Connect Blocks option (i.e., by choosing the command again). 

  Save Diagram The application always saves the diagram upon calculate or close. This 
command provides the option to manually save the diagram at any time while you're 
editing. This can be useful if you're working across a network in an enterprise database. 

  Copy Diagram as Graphic copies the current diagram to the Clipboard. The diagram 
can then be pasted into other documents as an enhanced metafile (*.emf) graphic. 

  Copy Selected Graphic copies the current block to the Clipboard. The block can then 
be pasted into other documents as an *.emf graphic. 

  Export Graphic saves the diagram as a graphic in *.wmf, *.png, *.gif or *.jpg format. 
You will be able to use the exported graphic in any application, provided that the 
application supports the file format. 
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  Add Annotation adds a new annotation to the current diagram. You can edit the text 
that appears in the annotation by double-clicking it to open the Edit Annotation window. 

Properties 

  Block Properties opens the data sheet that is associated with the block. 

  Line Bend alters the bend style of the selected connectors. If a custom style is used, 
the options for removing bend points will become available. 

EQUATION FIT SOLVER TAB 

The Equation Fit Solver tab is visible when you view the Non-Linear Equation Fit Solver utility. 

Analysis 

  Calculate estimates the parameters of the user-defined equation and calculates other 
results you could use to evaluate how well the function fits the data. 

  Plot creates a plot demonstrating the function fit for each known data point that you 
have defined. 

  Initialize Parameters automatically copies all the unknown variables in your equation 
(except the random variable x) to the Function Parameters area. This also resets the 
minimum, maximum and initial guess values to their default values. 

Solver Templates 

  Select from Templates allows you create, edit, and select equation templates for use 
in the analysis. 

  Add to Templates allows you to save user-defined equations as templates for future 
use. 

EVENT LOG TAB 

The Event Log tab is visible when you view an event log data folio data sheet. 
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Analysis 

  Calculate converts the log entries into failure/repair times and then fits distributions 
to the converted data. It then calculates the total uptime and downtime of the 
components. 

Actions and Settings 

  Set Shift Pattern opens the Shift Pattern window, which allows you specify the days 
and times when the system is operating. 

Transfer Life Data 

  Transfer Life Data to New Folio transfers all of the analyzed time-to-failure and time-
to-repair data sets to separate data sheets in a new Weibull++ life data folio. 

  Transfer Life Data to Selected Folio opens the Transfer Life Data window, which allows 
you to choose specific data set(s) to transfer to either new or existing folio(s). 

  Transfer to BlockSim is available only if BlockSim is activated on your computer. The 
Transfer to BlockSim window allows you to export the analysis results as blocks in a new 
simulation diagram. 

FORMAT TAB 

The Format tab is visible when you are working with a reliability block diagram (RBD). 

Format 

  Select Font sets the font properties for the selected blocks. 

  Font Color sets the font color for the selected text. 

  Fill Color sets the fill color for the selected text. 

Styles 

  Diagram Style opens the Diagram Style window, which allows you to customize the 
appearance of the current diagram and set the default properties for connectors and new 
blocks that are added to the diagram. 

https://www.reliasoft.com/products/reliability-analysis/blocksim
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  Block Style opens the Block Style window, which allows you to customize the 
appearance of the selected block or annotation. 

  Connector Style opens the Connector Style window where you can customize the 
appearance of the selected connectors. 

Alignment and Spacing 

  Align Blocks allows you to easily adjust the position of multiple blocks. The selected 
blocks will be aligned with the first block selected, except for Align to Grid, which moves 
each selected block to its nearest point on the grid. (See Arranging and Resizing Blocks.) 

  Make Spacing Equal allows you to easily adjust the spacing between multiple blocks. 
The selected blocks will be moved so that they are equally spaced over the original size of 
horizontal and/or vertical area. (See Arranging and Resizing Blocks.) 

  Make Same Size allows you to resize multiple blocks of different sizes. The selected 
blocks will be resized to match the height and/or width of the first block selected. See 
Arranging and Resizing Blocks. 

  Bring to Front moves the currently selected block(s) or connector(s) in front of other 
objects on the diagram. 

  Send to Back moves the currently selected block(s) or connector(s) behind other 
objects on the diagram. 

GROWTH DATA TAB 

The Growth Data tab is visible when you view a growth data folio data sheet. 

Analysis 

  Calculate estimates the parameters of the selected model and analysis method, based 
on the current data set and the specified analysis settings. 

  Plot creates a new sheet in the folio that provides a choice of applicable plot types. 
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  Quick Calculation Pad opens the Quick Calculation Pad, which allows you to calculate 
results, such as the cumulative MTBF and the expected number of failures, based on the 
analyzed data sheet. 

  Statistical Tests Report performs statistical tests on the active data set and displays 
the results in the Results Panel. These tests may include the Chi-Squared, Cramér-von 
Mises, Laplace Trend and Common Beta Hypothesis tests, depending on the data type. 

  Event Report opens an Event Report for the current analysis in the Results Window. 
The Event Report gives information on individual failure modes. Event Reports are available 
for all multi-phase data types and for the Multiple Systems with Event Codes data type. 

Crow Extended 

  Effectiveness Factors is available only if the data sheet contains Projections columns. It 
opens the Effectiveness Factors window, which allows you to define the effectiveness 
factors for each BD mode to estimate the fractional decrease in failure intensity. 

   Convert Modes opens the Convert Modes window, which allows you to convert any 
classification and mode in the data set to another classification and mode. 

  Mode Processing opens the Mode Processing window where you can extract the first 
failure time for each unique BC mode and/or unique BD mode in a data set. 

  Test for Fix Effectiveness opens the Test for Fix Effectiveness utility, which allows you 
to assess whether or not corrective actions have been effective across phases. This 
command is available for all multi-phase data types, for the Multiple Systems with Event 
Codes data type and for any data set analyzed using Change of Slope calculations. 

Advanced Systems 

The following commands are visible when you view the data sheet in Advanced Systems View. 

  Edit Systems 

• Copy System copies the selected system in the Advanced Systems View Explorer. 

• Paste System pastes the copied system as a new system in the Advanced Systems View 
Explorer. The copied system will be named as "Copy of (name of copied system) 
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[increment]." Thus, if you create a single copy of a system named "System A," the copy 
will be named "Copy of System A 1." 

• Add System adds a system to the Advanced Systems View Explorer. 

• Delete System deletes the selected system from the Advanced Systems View Explorer. 

• Select All selects all systems in the Advanced Systems View Explorer for inclusion in the 
analysis. 

• Clear All clears the check boxes for all systems in the Advanced Systems View Explorer 
so that none are selected for inclusion in the analysis. 

• Expand All expands the hierarchy in the Advanced Systems View Explorer to show the 
start and end times for each system. 

• Collapse All collapses the hierarchy in the Advanced Systems View Explorer to hide the 
start and end times for each system. 

• Move Up moves the selected system up one place in the Advanced Systems View 
Explorer. 

• Move Down moves the selected system down one place in the Advanced Systems View 
Explorer. 

• Rename allows you to change the name of the selected system in the Advanced 
Systems View Explorer. When selected, edit the name in the text box that appears and 
press ENTER. 

  System Results 

• Current System displays the calculated results for the currently selected system. 

• All Systems displays the calculated results for all systems. 

Options 

  Alter Parameters opens the Alter Parameters window, which allows you to alter the 
values of the corresponding calculated parameters. No recalculation is performed. This 
command is available for any data set calculated using any model except the Crow 
Extended and Crow Extended - Continuous Evaluation. Furthermore, for data sets 
calculated with the Crow-AMSAA (NHPP) model, this functionality is not available for 
Change of Slope calculations. 
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  Auto Group Data opens the Auto Group Data window, which allows you to specify 
intervals to group the data in the current data sheet. This command is available only for the 
Failure Times, Multi-Phase Failure Times and Fleet data types. 

  Interval GOF opens the Interval Goodness-of-Fit Test window, which allows you to 
evaluate the model's fit to the combined equivalent system (for developmental data) or 
superposition system (for fielded systems data) and, if necessary, omit individual systems 
from the combined analysis. This command is available for the following data types: 
Multiple Systems - Concurrent Operating Times, Multiple Systems with Dates, Multiple 
Systems with Event Codes, Repairable Systems and Fleet. 

  Batch Auto Run opens the Batch Auto Run window, which allows you to quickly 
extract data subset(s) from an existing data set. This command is available only for the 
Multiple Systems - Concurrent Operating Times, Multiple Systems with Dates, Multiple 
Systems with Event Codes, Repairable Systems, Fleet, Multi-Phase Failure Times, Multi-
Phase Mixed Data and Multi-Phase Grouped Failure Times data types. 

   Link Mission Profile allows you to select a Mission Profile in the project that you want 
to group the data sheet by. The data in the data sheet will be transferred to a new data 
sheet in the folio and grouped according to the specified Mission Profile. This command is 
available only for the Failure Times data type. 

Folio Sheets 

  Insert Data Sheet inserts a new blank data sheet into the currently active folio and 
opens the Reliability Growth Folio Data Sheet Setup window, which allows you to select 
what types of data to include in the new data sheet. 

  Insert Additional Plot Sheet inserts an overlay plot in the currently active folio. This 
allows you to display in a single plot results from multiple data sheets within the folio. This 
provides an easy visual method to compare analyses. For example, you may wish to show 
the reliability plots of two product designs in the same plot. 

  Insert General Spreadsheet inserts a new blank general spreadsheet into the currently 
active folio. 

   Delete Sheet deletes the current sheet within the folio. 
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  Move or Copy Sheet allows you to move or copy any of the sheets within the currently 
active folio. Select the sheet that you wish to move and then click (move to end) to move 
the selected sheet to the end of all the sheets in the folio. Select Create a Copy to create a 
copy of the selected sheet. 

   Select Sheet allows you to select which sheet in the current folio you want to be 
active. 

Format and View 

   Insert Columns allows you to insert additional columns into a growth data folio data 
sheet. The types of columns available for insertion vary depending on the data type. 

   Delete Columns allows you to delete columns from a growth data folio data sheet. 
The types of columns that can be deleted vary depending on the data type. 

  Set Headers as Default saves the current column headings as the defaults for new data 
sheets of the same type. To reset the default headings, click Reset Application Settings in 
the Application Setup. 

  Apply Default Headers applies the currently saved defaults to the column headings of 
the active data sheet. 

   Switch to Normal View/Switch to Advanced Systems View toggles between systems 
views for data types with multiple systems. The Advanced Systems View displays the data 
one system at a time and provides a navigation panel to select which system you wish to 
view. This view allows you to view the calculated results for each system individually and 
for the "equivalent" system (for reliability growth analyses) or the "superposition" system 
(for fielded systems analyses). In addition, this view gives you the ability to remove 
individual systems from consideration in a particular analysis. The Normal View displays the 
data for multiple systems all together in the same data sheet. 

Transfer Data 

   Transfer to New Data Type opens the Transfer to New Data Type window, which 
allows you to select a data type into which you would like to transfer the data. This 
command is available only for the Multiple Systems - Concurrent Operating Times, Multiple 
Systems with Dates, Multiple Systems with Event Codes, Repairable Systems and Fleet data 
types. 
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   Transfer to Life Data folio opens the Transfer to Life Data folio  window, which allows 
you to transfer the current Reliability Growth data set to a life data folio. Please note that 
you can transfer data only after the parameters have been calculated. 

ReliaSoft 

  Publish Model allows you to use the results of the growth analysis as a resource object 
and make it available for unlimited use elsewhere within the project, in any ReliaSoft 
application that has a need for that type of object. 

  Publish SEP Summary publishes a summary of the current analysis to the SEP web 
portal. This is visible only if the enterprise database is configured for SEP and you have the 
"Publish to SEP web portal" permission (see Publishing to SEP). 

LIFE-STRESS DATA TAB 

The Life-Stress Data tab is visible when you view an Accelerated Life Testing life-stress data folio 
data sheet for accelerated life testing analysis. 

Analysis 

  Calculate estimates the parameters of the chosen model, based on the current data 
set and the specified analysis settings. 

  Plot creates a new sheet in the folio that provides a choice of applicable plot types. For 
life-stress data folios, this includes plots such as use level probability, reliability vs. time, life 
vs. stress, etc. 

  Quick Calculation Pad opens the Accelerated Life Testing Quick Calculation Pad, which 
allows you to calculate results, such as the mean life and the probability of failure, based on 
the currently active data sheet. 

  Distribution Wizard opens the Distribution Wizard, which helps you select the life 
distribution that will best fit your data. 

  3D Plot creates a 3D plot in the project, allowing you to graph functions with three 
variables such as the reliability at a given time and stress level. The 3D plot is saved under 
the Multiplots heading in the current project explorer. 
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Folio Sheets 

  Insert Data Sheet inserts a new blank data sheet into the currently active folio and 
opens the Accelerated Life Testing Folio Data Sheet Setup window, which allows you to 
select what types of data to include in the new data sheet. 

  Insert Additional Plot inserts an overlay plot in the currently active folio, allowing you 
to display in a single plot results from multiple data sheets within the folio. This provides an 
easy visual method to compare analyses. For example, you may wish to show the reliability 
plots of two product designs in the same plot. 

  Insert General Spreadsheet inserts a new blank General Spreadsheet into the 
currently active folio. 

  Select Sheet allows you to select which sheet in the current folio you want to be 
active. 

  Move/Copy Sheet allows you to move or copy any of the sheets within the currently 
active folio. In the Move/Copy window, select the sheet you wish to move and click (move 
to end) to move the selected sheet to the end of all the sheets in the folio. Select Create a 
Copy to create a copy of the selected sheet. 

  Delete Sheet deletes the current sheet within the folio. There is no undo for delete. 

Options 

  Set Use Stress opens the Use Stress Level window, which allows you to define the use 
stress values for the selected stress type(s) in the current folio. 

  Select Stress Columns opens the Select Stress Columns window, which allows you to 
select which stress type(s) in the current folio to consider when calculating the parameters 
of the model (i.e., the life-stress relationship and distribution combination). 

  Alter Parameters provides two options for manually editing the value of the calculated 
parameters. Alter Parameters (w/o Recalculation) allows you to alter the value of one (or 
more) parameters, while Alter One Parameter (and Recalculate) allows you to alter one of 
the parameter values and have the software estimate the other parameter values that 
would result in a good fit for the model. See also Alter Parameters. 
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  Stress Transformation opens the Stress Transformation window, which allows you to 
specify a transformation equation for each stress that will be used in the analysis. 

  Likelihood Ratio Test opens the Likelihood Ratio Test window, which allows you 
evaluate the discrepancy between the estimates of the shape parameter at the various 
accelerated stress levels. The test helps you to determine whether the units in the sample 
will fail in the same manner across different stress levels. 

  Convert Stress Values allows you to convert all the values entered in one of the stress 
columns to another value or to another stress unit (e.g., Celsius to Kelvin). 

Format and View 

  Alter Data Type opens the Accelerated Life Testing Folio Data Sheet Setup window, 
which allows you to change the data entry columns in the current data sheet. Note that 
when you change the setup, you may lose information already entered in the data sheet. 
For example, switching the data sheet from one that supports interval data to one that 
supports only right censored data will remove all the inspection times. 

  Override Plot Color opens the Override Plot Color window, which allows you to ignore 
the default colors of the plotted line and points, and apply a color that you specify. This 
setting is activated in the source data sheet of the plot. This means that when you enable 
the setting for a particular data sheet, it applies only to the plots that you create for that 
data sheet and not the plots for all other data sheets that may be within the same folio. 
Note that only the colors of the lines and points are affected. Other settings such as the line 
style and thickness, or the point size and shape are based on the settings that you have 
specified in the Plot Items page of the Plot Setup window. 

  Set Headers as Default saves the current column headings as the defaults for new data 
sheets of this type. To reset the default headings, click Reset Application Settings in the 
Application Setup. 

  Apply Default Headers applies the currently saved defaults to the column headings of 
the active data sheet. 

  Add/Remove Columns opens the Add or Remove Columns window, which allows you 
to add/remove stress columns or subset ID columns in the currently active data sheet. 
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  Auto Group Data opens the Auto Group Data window, which allows you to group 
together identical data points. Grouping data significantly speeds up calculations when you 
have a very large data set. 

ReliaSoft 

  Publish Model publishes the chosen distribution as a model for use throughout the 
project, in any ReliaSoft application where models are used. See Publishing Models. 

  Publish SEP Summary publishes a summary of the current analysis to the SEP web 
portal. This is visible only if the enterprise database is configured for SEP and you have the 
"Publish to SEP web portal" permission (see Publishing to SEP). 

LIFE COMPARISON TAB 

The Life Comparison tab is visible when you view a life comparison folio. 

Analysis 

  Calculate estimates the probability that the times-to-failure of the first population will 
be better or worse than the times-to-failure of the second population. 

  Select Data Sheets allows you to select the data sheets to compare. 

  Parameter Estimator opens the Target Reliability Parameter Estimator window, which 
allows you to explore how you could attempt to change one of the distribution parameters 
in order to meet a specified target reliability. The plot and reliability estimate will be based 
on the altered distributions and therefore may be appropriate only within the context of 
your specific scenario. 

LIFE DATA TAB 

The Life Data tab is visible when you view a life data folio data sheet for life data analysis. 

Analysis 

  Calculate estimates the parameters of the chosen distribution, based on the current 
data set and the specified analysis settings. 
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  Plot creates a new sheet in the folio that provides a choice of applicable plot types. For 
life data folios, this includes plots such as reliability vs. time, failure rate vs. time, 
probability plot, etc. 

  Quick Calculation Pad opens the Weibull++ Quick Calculation Pad, which allows you to 
calculate results, such as the mean life and the probability of failure, based on the analyzed 
data sheet. 

  Distribution Wizard opens the Distribution Wizard, which helps you select the 
distribution that best fits your data based on the selected parameter estimation method 
(i.e., RRX, RRY or MLE). 

  3D Plot creates a 3D plot in the project, allowing you to graph functions with three 
variables such as the reliability at a given time and stress level. The 3D plot is saved under 
the Multiplots heading in the current project explorer. 

Options 

  Batch Auto Run opens the Batch Auto Run window, which allows you to easily extract 
data from an existing data set based on their subset ID. 

  Specify Points opens the Specify Points window, which allows you to adjust the way 
that the line is fitted to the points for a rank regression analysis. The ranks will be 
calculated based on all of the data points but the regression line will be fitted only to the 
points you have specified. 

  Alter Parameters provides two options for manually editing the value of the calculated 
parameters. Alter Parameters (w/o Recalculation) allows you to alter the value of one (or 
more) parameters, while Alter One Parameter (and Recalculate) allows you to alter one of 
the parameter values and have the software estimate the other parameter values that 
would result in a good fit for the model. See also Alter Parameters. 

   Fill Median Ranks is available only if the data type is free-form. It allows you to 
experiment with median ranks and see how they affect the solution of the analysis. Enter 
the time-to-failure values in the "X-Axis value" column, then choose this command. The "Y-
Axis value" column will be filled with the corresponding median ranks. 
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  Auto Group Data opens the Auto Group Data window, which allows you to group 
together identical data points. Grouping data significantly speeds up calculations when you 
have a very large data set. 

  Goodness of Fit Results opens the Goodness of Fit Results utility, which uses different 
tests to determine how well the parameters of the distribution fit the data. 

Folio Sheets 

  Insert Data Sheet inserts a new blank data sheet into the currently active folio and 
opens the Weibull++ Folio Data Sheet Setup window, which allows you to select what types 
of data to include in the new data sheet. 

  Insert Additional Plot inserts an overlay plot in the currently active folio, allowing you 
to display results from multiple data sheets within the folio. This provides an easy visual 
method to compare analyses. For example, you may wish to show the reliability plots of 
two product designs in the same plot. 

  Insert General Spreadsheet inserts a new, blank General Spreadsheet into the 
currently active folio. 

  Select Sheet allows you to select which sheet in the current folio you want to be 
active. 

  Move or Copy Sheet allows you to move or copy any of the sheets within the currently 
active folio. In the Move/Copy window, select the sheet you wish to move and click (move 
to end) to move the selected sheet to the end of all the sheets in the folio. Select Create a 
Copy to create a copy of the selected sheet. 

  Delete Sheet deletes the current sheet within the folio. There is no undo for delete. 

Format and View 

  Alter Data Type opens the Weibull++ Folio Data Sheet Setup window, which allows 
you to change the data entry columns in the current data sheet. Note that when you 
change the setup, you may lose information already entered in the data sheet. For 
example, switching the data sheet from one that supports interval data to one that 
supports only right censored data will remove all the inspection times. 
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  Override Plot Color opens the Override Plot Color window, which allows you to ignore 
the default colors of the plotted line and points, and apply a color that you specify. This 
setting is activated in the source data sheet of the plot. This means that when you enable 
the setting for a particular data sheet, it applies only to the plots that you create for that 
data sheet and not the plots for all other data sheets that may be within the same folio. 
Note that only the colors of the lines and points are affected. Other settings such as the line 
style and thickness, or the point size and shape are based on the settings that you have 
specified in the Plot Items page of the Plot Setup window. 

  Set Headers as Default saves the current column headings as the defaults for new data 
sheets of the same type. To reset the default headings, click Reset Application Settings in 
the Application Setup. 

  Apply Default Headers applies the currently saved defaults to the column headings of 
the active data sheet. 

  Add/Remove Columns allows you to add or remove subset ID columns in the currently 
active data sheet. 

   Color Data Values allows you to apply different font colors to the entries in the data 
sheet for easy visualization. Note that whenever you edit or add new data to the data 
sheet, you must choose one of the Color Data Values commands again in order to apply the 
font colors. 

• Default Color applies a black font color to all the entries in the data sheet. 

• Based on Data Type applies different font colors based on the type of censoring. The 
colors are: red for failure data (no censoring), green for suspension data, magenta for 
left-censored data and blue for interval data. 

• Based on Subset ID 1 applies different font colors based on unique subset IDs in the 
Subset ID 1 column. If a data point has no entry in the Subset ID 1 column, then the 
font color is black. 

• Based on Subset ID 2 applies different font colors based on unique subset IDs in the 
Subset ID 2 column. If a data point has no entry in the Subset ID 2 column, then the 
font color is black. 

• Based on Subset ID Combination applies font colors based on unique combinations of 
subset IDs in the Subset ID 1 and Subset ID 2 columns. If a data point has no subset IDs, 
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the font color is black, but if a data point has at least one subset ID, then it is treated as 
having a unique combination of subset IDs. 

ReliaSoft 

  Publish Model publishes the chosen life distribution as a model for use throughout the 
project, in any ReliaSoft application where models are used. See Publishing Models. 

  Publish SEP Summary publishes a summary of the current analysis to the SEP web 
portal. This is visible only if the enterprise database is configured for SEP and you have the 
"Publish to SEP web portal" permission (see Publishing to SEP). 

MAINTENANCE PLANNING TAB 

The Maintenance Planning tab is visible when you view the Maintenance Planning folio. 

Analysis 

  Plot updates the plot to reflect any changes that have been made, and recalculates the 
estimates for the minimal cost and optimal time. 

  Select Data Sheet opens a window that allows you to select the data sheet to analyze. 

  Create Task opens the Maintenance Task window, which allows you to create a 
preventive and/or inspection task for use in BlockSim simulation diagrams. 

MISSION PROFILE TAB 

The Mission Profile tab is visible when you view a mission profile data sheet. 

Mission Profile 

  Insert Profile Sheet adds a new profile sheet to the current mission profile. 

  Delete Profile Sheet deletes the current profile sheet from the mission profile. 

  Validate Mission Profiles sorts each profile sheet by the Cumulative Time column and 
checks that all necessary data have been entered. 

https://www.reliasoft.com/products/reliability-analysis/blocksim
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  Plot Mission Profiles creates a Mission Profile plot for all profile sheets in the current 
folio. 

  Transfer Convergence Points to Profile Sheets adds all convergence points entered on 
the convergence points sheet to each profile sheet in the mission profile. 

NON-PARAMETRIC LDA TAB 

The Non-Parametric LDA tab is visible when you view a non-parametric life data analysis (LDA) 
folio data sheet. 

Analysis 

  Calculate obtains the reliability estimates based on the chosen non-parametric 
method. It then converts the results to free-form data and performs a parametric analysis 
based on the chosen life distribution. 

  Plot creates a Reliability vs. Time plot of the non-parametric analysis. 

  Quick Calculation Pad opens the Quick Calculation Pad, which allows you to calculate 
results such as mean life and probability of failure based on the results of the standard life 
data analysis. It uses the same calculations that you can perform in a Weibull++ life data 
folio QCP. 

  Distribution Wizard opens the Distribution Wizard, which helps you select the 
distribution that best fits the data set based on the chosen parameter estimation method 
(i.e., RRX or RRY). In the non-parametric LDA folio, the ranking in the Distribution Wizard is 
based on the life data model. 

Transfer Life Data 

  Transfer Life Data to New Folio allows you to transfer the values from the Life Data 
Model area of the control panel to a fee-form data sheet in a new Weibull++ life data folio. 
The selected failure time values (start time, end time or average time) will be copied to the 
"X-Axis value" column, and the reliability values will be converted to their inverse values 
(i.e., unreliability) and then transferred to the "Y-Axis value" column. 

  Transfer Life Data to Selected Folio allows you to transfer the values from the Life 
Data Model area of the control panel to a free-form data sheet in an existing Weibull++ life 
data folio. 
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ReliaSoft 

  Publish Model publishes the chosen life distribution as a model for use throughout the 
project, in any ReliaSoft application where models are used. See Publishing Models. 

OPTIMIZATION TAB 

The Optimization tab is visible when working with an optimization folio. 

Actions 

  Calculate allows you to specify new optimization settings. 

  Plot is available only for dynamic overlaid contour plots. It updates the current plot to 
reflect the changes that have been made. 

  Plot Setup opens the Plot Setup window, which allows you to customize most aspects 
of the plot appearance including the titles, axis numbers and line styles. 

  Select Responses & Factors is available only for optimal solution plots. It allows you to 
choose the factors (i.e., columns) and responses (i.e., rows) to be displayed in the plot. 

  Select Data Source allows you to select the source data sheet for the optimization 
folio. 

Solutions 

The following commands are available only for the optimal solution plot. 

  Duplicate Solution creates a copy of the currently selected solution and adds it to the 
Solutions list. You can then modify the solution as needed. 

  Create Solution allows you to enter a name for the solution and specify the factor 
values to be used for the solution. Your new solution will be added to the solutions list. 

  Edit Solution allows you to manually adjust the factor values for the currently selected 
solution. Note that if you edit an optimal solution generated by the software, your changes 
will be used to create a new custom solution and the original solution will remain 
unchanged. 
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  Delete Solution removes the currently selected solution from the Solutions list. 

  View Solutions opens the Solutions window, which shows each solution, including 
factor settings, the associated block (if any) and the predicted response(s) at those settings. 

Tools 

  Add Optimization Tool opens the Select Optimization Tool window, which allows you 
to add an additional optimization tool of a type that is not already present in the folio to 
the folio. Note that each optimization folio can have only one optimization tool of each 
type and this command is unavailable if the folio already contains each type of tool. 

PLOT TAB 

The Plot tab is visible when you view a plot sheet. 

Plot 

  Redraw Plot updates the plot to reflect the changes that have been made. 

  Quick Calculation Pad is available only for applicable plots. It opens the Quick 
Calculation Pad (QCP), which allows you to obtain reliability results based on the currently 
active folio or diagram. 

  3D Plot creates a 3D plot in the project, allowing you to graph functions with three 
variables such as the reliability at a given time and stress level. The 3D plot is saved under 
the Multiplots heading in the current project explorer. This option is not available for 
reliability growth data folios. 

Actions 

  Copy Plot Graphic copies the plot to the Clipboard as a graphic. If you will be pasting 
copied plots into any one of the spreadsheets built in to ReliaSoft applications (e.g., 
ReliaSoft Workbooks or General Spreadsheets), choose Metafile Optimized for ReliaSoft 
Spreadsheet. If you will be pasting them into external applications, choose Bitmap or 
Metafile Optimized for External Use. 

  Copy Plot Data exports the plot data to the Clipboard. You can then paste that data 
into another application. The exact information depends on the plot type. 
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  Plot Setup opens the Plot Setup window, which offers several options for customizing 
a plot such as editing axis titles, line styles, grid lines, etc. 

  RS Draw launches ReliaSoft Draw, which is a graphics editor that offers advanced 
options for annotating, inserting images, drawing images on a plot, and more. 

  Export Plot Graphic opens the Save As window, which allows you to save the current 
plot graphic as a *.wmf, *.png, *.gif, or *.jpg file. 

  Show/Hide Plot Items provides options for displaying or hiding from view certain plot 
items such as data points, lines, probability scales, etc. 

Confidence Bounds 

  Confidence Bounds are available if the associated analysis includes calculations for 
confidence bounds. It opens the Confidence Bounds Setup window, which provides options 
for defining the properties of the bounds that will be displayed on the plot. 

  Hide Confidence Bounds removes the line(s) depicting the confidence bounds from 
the current plot. 

Display 

The following commands are available only for DOE design folios. 

  Actual Values displays the actual values for the factors. 

  Coded Values displays the coded values for the factors. Which coded values are used 
(e.g., whether 0 or -1 represents the low level) is dependent on the design type. 

  Amount applies to mixture designs only. 

  Amount displays the component factor values as amounts (e.g., 2 pounds). 

  Proportion applies to mixture designs only. It displays the component factor 
values as proportions (e.g., 0.2 = 20% of the total mixture used in the run). 
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  Pseudovalue applies to mixture designs only. It displays the component factor 
values as scaled values between 0 and 1, where 0 is the minimum possible value for 
the factor (given the design settings) and 1 is the maximum possible value. 

Options 

The following commands are available only for reliability growth data folios. 

  Plot Modes applies to Individual Mode MTBF/FI/Reliability plots. See Plot Modes 
window. 

  Plot Systems applies to System Operation plots for multiple systems. See Select 
Systems to Plot window. 

  Plot Beta Bounds applies to Beta Bounds plots. See Beta Bounds window. 

RECURRENT EVENT DATA TAB 

The Recurrent Event Data tab is visible when you view either a parametric or a non-parametric 
recurrent event data analysis (RDA) folio data sheet. 

Analysis 

  Calculate estimates the cumulative number of failures (in non-parametric RDA folios) 
or the parameters of the GRP model (in parametric RDA folios) based on the current data 
set. 

  Plot creates a new plot sheet in the folio. In non-parametric RDA folios, there is only 
one type of plot, the mean cumulative function (MCF). In parametric RDA folios, it provides 
a choice of applicable plot types such the cumulative failures vs. time, failure intensity vs. 
time, etc. 

  Quick Calculation Pad applies to parametric RDA folios only. It opens the Parametric 
RDA Quick Calculation Pad, which allows you to calculate results based on the analyzed 
data sheet such as the number of failures and mean time between failures (MTBF). 

SHEET TAB 

The Sheet tab is visible when you view data sheets, general spreadsheets or DOE simulation 
worksheets. 
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Format and View 

  Format Cells opens the Format Cells window, which provides several ways to change 
the way data are displayed in a cell or range of cells: 

• Number tab sets the numbering format of a cell. Anything you type in the cell will be 
automatically formatted based on your selection. For example, if you select the number 
format and specify 3 decimal places, typing the value 1.2 in the cell will automatically 
display it as 1.200. 

• Alignment tab sets the horizontal, vertical alignment and indentation text in a cell. 
Includes text control options such as wrap text, shrink to fit, merge cells and text 
direction. 

• Font tab sets the font, style, color, size and effects of the selected text. 

• Border tab applies borders around the selected cell(s) and controls the line style, 
thickness and color of the border lines. 

• Fill tab sets the background color of the selected cell(s). You can also apply a pattern 
style and choose a pattern color. 

  Recalculate Formulas forces a recalculation of all formulas in the spreadsheet. 

  Defined Names applies only to general spreadsheets. It allows you to create and 
manage variable names that can be referenced in any function. You can define a name for 
any spreadsheet cell or data sheet or function. Names can help make formulas in the 
spreadsheet easier to understand and maintain. 

Sheet Actions 

The following commands apply only to general spreadsheets. 

   Function Wizard opens a function wizard that helps you to build functions that utilize 
a referenced analysis (data source). 

   Insert Function opens a function wizard that helps you to build functions that return 
results from mathematical values (e.g., sine, pi or averages). 
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  Chart Wizard allows you to create new plots and charts based on the current 
spreadsheet. To use, select a range of cells for which you would like to create a chart, then 
click Chart Wizard and select the area where you want to place the chart. 

  AutoSum allows you to compute the sum of the values in a range of selected cells. If a 
cell range is not selected, the command computes the sum of the values in the cells directly 
above the current cursor location. 

  Sort allows you to reorder the selected data either in ascending or descending order. 
Note that you may need to be careful when sorting certain types of data in order to prevent 
errors in analysis. 

• If your analysis takes into account the order position of a data point (1st, 2nd, 3rd, etc. 
position), sorting may result in an inaccurate analysis. 

• If the range of cells that you wish to sort contains blank cells, the blank cells may be put 
in the first position (ascending order) or the last position (descending order). 

Rows/Columns 

  Delete deletes the selected cells and moves the remaining cells based on the specified 
direction. Note that when the cells are deleted, the information inside the cells is also 
deleted. 

   Insert inserts new cells at the current cursor location and moves the existing cells 
based on the specified direction. If a range of cells is selected in the sheet, then the same 
number of cells will be inserted. 

Transfer Data 

  Send to Excel exports all sheets to an Excel file. 

  Send to Word exports the current sheet to a Word file. 

SIMUMATIC(A) TAB 

The SimuMatic(A) tab is visible when you view a Life-Stress Data SimuMatic results folio. 
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SimuMatic 

  Stress-Dependent SimuMatic allows you to change your simulation settings and 
replace your current simulated data sets with new ones. 

  Plot creates a probability plot of all the data sets. 

SIMUMATIC(R) TAB 

The SimuMatic(R) tab is visible when you view a Repairable Systems SimuMatic results folio. 

SimuMatic 

  Repairable Systems SimuMatic allows you to change your simulation settings and 
replace your current simulated data sets with new ones. 

  Plot creates a probability plot of all the data sets. 

SIMUMATIC(W) TAB 

The SimuMatic(W) tab is visible when you view a Life Data SimuMatic results folio. 

SimuMatic 

  SimuMatic allows you to change your simulation settings and replace your current 
simulated data sets with new ones. 

  Plot creates a probability plot of all the data sets. 

  Transfer Life Data to Selected Folio transfers the simulated data set to an existing 
Weibull++ life data folio, with one data sheet for each parameter of the model that was 
used to generate the data. 

  Transfer Life Data to New Folio transfers the simulated data set to a new Weibull++ 
life data folio, with one data sheet for each parameter of the model that was used to 
generate the data. 

STRESS-STRENGTH TAB 

The Stress-Strength tab is visible when you view a stress-strength comparison folio. 
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Analysis 

  Calculate estimates the probability of stress exceeding the strength of a given product. 

  Select Data Sheets allows you to select the data sheets to compare. 

  Parameter Estimator opens the Target Reliability Parameter Estimator window, which 
allows you to explore how you could attempt to change one of the distribution parameters 
in order to meet a specified target reliability. The plot and reliability estimate will be based 
on the altered distributions and therefore may be appropriate only within the context of 
your specific scenario. 

TEST AND PLANNING TAB 

The Test and Planning tab is visible when you view a growth planning folio. 

Analysis 

  Calculate calculates the inputs and generates the growth planning results. 

  Plot creates a new sheet in the folio that provides a choice of applicable plot types 
that show the results that are expected if you implement the plan. 

  Quick Calculation Pad opens the Quick Calculation Pad, which allows you to calculate a 
variety of results that are expected if you implement the plan. 

  Show Results allows you to see a summary of the inputs and results in the Results 
window. 

TEST DESIGN TAB 

The Test Design tab is visible when you view any of the Test Design tools. Depending on which 
utility you view, the following commands may be available. 

Reliability Demonstration Test 

  Calculate implements the selected test design method based on the specified inputs. 

  Get Distribution updates the shape parameter and demonstrated time in the RDT 
sheet based on data from an existing Weibull++ life data folio in the current project. 
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  Show RDT Table is available only for the Parametric Binomial test design method and 
for Reliability Growth test design folios. For life data analysis, this command creates a 
parametric binomial table and plot based on the target metric and life distribution that you 
specified on the RDT sheet. For growth analysis, this creates an RDT table and plot that 
allows you to compare different test scenarios. 

  Show Bayesian Systems is available when you choose the Non-Parametric Bayesian 
test design method and the source of prior information is from "Prior tests at the 
subsystem level." This command opens the Edit Bayesian Subsystems window, which allows 
you to edit the number of units and number of failures for each subsystem for which you 
have prior information. 

  Send to Excel exports the table to a new Excel spreadsheet. 

RDT Table 

  Calculate generates the RDT table based on the sample size and number of failures 
that you specify on the control panel. 

  Plot creates a plot in the folio that depicts how the allowed number of failures 
influences the test time and the required sample size. 

  Send to Excel exports the table to a new Excel spreadsheet. 

Expected Failure Time 

  Get Failure Model updates the expected failure model (i.e., parameters and time) 
based on data from an existing Weibull++ life data folio in the current project. 

Detection Matrix 

  Calculate validates your inputs and generates the matrix. 

  Send to Excel exports the matrix to a new Excel spreadsheet. 

  Change Matrix Color allows you to choose a new base color for the matrix. The 
selected color will be used to indicate the shortest test time and darker values of the color 
will be used to indicate longer test times. 
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TEST PLAN TAB 

The Test Plan tab is visible when you view an ALTA test plans folio. 

Analysis 

  Generate Test Plan generates test plan recommendations for what stress levels should 
be used in the test and how many units should be tested at each stress level. 

WARRANTY TAB 

The Warranty tab is visible when you view a warranty folio data sheet for warranty analysis. 

Analysis 

  Calculate converts the warranty claims data to failure/suspension times and then 
estimates the parameters of the chosen life distribution based on the converted data. If 
you select the Use Subsets option on the Main page of the control panel, the parameters of 
the distribution of each subset ID will be calculated separately. 

  Plot creates a new sheet in the folio that provides a choice of applicable plot types. In 
warranty analysis folios, this includes plots such as expected failures vs. period, reliability 
vs. time, probability plot, etc. You can plot the data in the warranty analysis folio with or 
without a forecast. 

  Quick Calculation Pad opens the Weibull++ Quick Calculation Pad, which allows you to 
calculate life data analysis metrics. It uses the same calculations that you can perform in a 
Weibull++ life data folio QCP. 

  Distribution Wizard opens the Distribution Wizard, which helps you select the 
distribution that best fits your data based on the selected parameter estimation method 
(i.e., RRX, RRY or MLE). In warranty analysis folios, the ranking in the Distribution Wizard is 
based on the converted failure/suspension times. 

Tools 

  Forecast opens the Forecast Setup window, which allows you to specify the time 
periods at which to estimate the number of expected warranty returns. Clicking Forecast 
before the parameters have been calculated will automatically calculate the parameters 
and open the Forecast Setup window. 
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  Restore Guide Colors applies only if you have manually changed the colors of cells in 
the Returns sheet of a Nevada chart format warranty folio. It returns the cells to their 
original colors, which are used in the Statistical Process Control feature of the Nevada chart 
format to indicate the following: 

• Green represents the number of product returns that are within the expected range. 

• Yellow represents the number of product returns that are between the caution and 
critical levels. 

• Red represents the number of product returns that are above the critical range. 

  Data Sheet Setup is available only for the Nevada chart format. It opens the Warranty 
Setup window, which allows you to change the time periods of the warranty claims data in 
the current data sheet. 

  Convert Data converts the format of the currently active warranty analysis folio to a 
new format. Converting formats creates a new folio and does not overwrite the contents of 
the existing folio. It is an automatic process, except when converting from the Dates of 
Failure format to Nevada chart format. In that case, you will be prompted to define the 
time unit of each period (e.g., dates, month or years) in order to proceed with the 
conversion. The following table shows the data conversion options. 

From Convert To 

Nevada Chart Format Dates of Failure Format 

Times-to-Failure Format 

Dates of Failure Format Nevada Chart Format 

Times-to-Failure Format 

Times-to-Failure Format N/A 

Usage Format Times-to-Failure Format 

Transfer Life Data 

  Transfer Life Data to New Folio allows you to transfer the failure/suspension times to 
a new Weibull++ life data folio in order to perform life data analysis. 

  Transfer Life Data to Selected Folio allows you to transfer the failure/suspension times 
to an existing Weibull++ life data folio in order to perform life data analysis. 
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Chapter 5: Life Data Analysis Folios 
Weibull++ Life Data Folios 

WEIBULL++ LIFE DATA FOLIO 

The Weibull++ life data folio for life data analysis is the most basic folio in the application. The 
objective of life data analysis is to fit a statistical distribution to failure time data in order to 
understand the reliability performance of a product over time or to make projections about 
future behavior. From the analysis, you can estimate metrics such as probability of failure, 
reliability, mean life or failure rate. The ReliaWiki resource portal has more information on the 
basics of life data analysis at 
http://www.reliawiki.org/index.php/Life_Data_Analysis_Reference_Book. 

WEIBULL++ LIFE DATA FOLIO SETUP 

To add a Weibull++ life data folio to a project, choose Home > Insert > Life Data or right-click 
the Life Data folder in the current project explorer and choose Add Life Data on the shortcut 
menu. 

 

A setup window will prompt you to select a data type to use in the folio and a unit appropriate 
for your data (the unit may be measured in mileage, distance, weight, etc.; see Unit Settings). 

There are two types of data available: times-to-failure data or free-form data. In addition, 
times-to-failure data may contain three forms of censoring: suspensions (right censored), 
interval censored or left censored data. (See Weibull++ Data Types.) 

Any of the times-to-failure data types can also be entered as grouped data. The ReliaWiki 
resources portal has more information on grouped data analysis at: 
http://www.reliawiki.org/index.php/Grouped_Data_Parameter_Estimation. 

The data type you select determines the data entry columns that will appear in the data sheet. 
When you select a data option, the preview area at the bottom of the setup window shows you 
the names of the data entry columns that will appear in the data sheet, as shown in the 
following example. 

http://www.reliawiki.org/index.php/Life_Data_Analysis_Reference_Book
http://www.reliawiki.org/index.php/Grouped_Data_Parameter_Estimation
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WEIBULL++ DATA TYPES 

In Weibull++, there are two types of life data: times-to-failure data and free-form data. In 
addition, times-to-failure data may contain three forms of censoring: suspensions, interval 
censored or left censored data. 

In a Weibull++ life data folio, the data type you select determines the data entry columns that 
appear in the data sheet. The following sections describe each data type and demonstrate how 
to enter data in a Weibull++ life data folio data sheet. 

Tip: You can change the data entry columns for an existing Weibull++ data sheet anytime by 
choosing Life Data > Format and View > Alter Data Type. 

Times-to-Failure Data 

Times-to-failure data sets, also known as complete data, are obtained by recording the exact 
times when the units failed. For example, if we tested five units and they all failed, and we 
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recorded the time when each failure occurred, we would then have complete information as to 
the time of each failure in the sample. 

To use this data type, select the Times-to-failure data check box on the setup window. Your 
data sheet will have a Time Failed column for recording the times-to-failure. The example 
shown next displays a life data folio data sheet where all the units in the sample failed. The 
exact time of each failure is recorded. 

 

Note: In this example and in the rest that follow, the Subset ID column is used for explanatory 
purposes and is not intended to demonstrate how the column would normally be used. 

If multiple units failed at the same time, you can choose to enter the data in groups. To do this, 
select the I want to enter data in groups check box in the setup window. This adds a third 
column to the data sheet, as shown next. In this example, the units that failed at the same time 
are grouped together. The Number in State column indicates the number of failed units in that 
group (the software will automatically enter a 1 if you leave this cell blank) and the State End 
Time column indicates the exact time the units in each group failed. 

 

Times-to-Failure with Suspensions (Right Censored Data) 

The term suspension describes the units that did not fail during the observation period. Such 
units are also known as right censored data. For example, if we tested five units and only three 
had failed by the end of the test, the observed operating time of the two units that did not fail 
would be referred to as right censored data. The term right censored means that the event of 
interest (i.e., the time-to-failure) is to the right of our data point on the time scale. 
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To use this data type, select the Times-to-failure data check box and the My data contains 
suspensions (right censored data) check box in the setup window. Your data sheet will have a 
State F or S column for recording whether the data point is a failure (F) or suspension (S). In the 
example shown next, a test was conducted and the first five units in the sample failed but the 
sixth unit was still operational when the test terminated at 190 hours. 

 

Tip: If you enter the time as a negative number (e.g., -190), Weibull++ will automatically assign 
it as a suspension. This time-saving feature applies only to data sheets that have been 
configured to support right censored data. 

When entering this type of data in groups, units that have the same state (i.e., failed or 
suspended) and have the same value in the State End Time column can be grouped together, as 
shown next. 

 

Times-to-Failure with Interval and Left Censored Data 

The term interval censored data describes the uncertainty as to the exact time the unit failed 
within an interval. This type of data frequently comes from tests or situations where the units 
are not constantly monitored. For example, if we are running a test on five units and inspecting 
them every 100 hours, we only know that a unit failed or did not fail between inspections. 
Specifically, if we inspect a certain unit at 100 hours and find it operating, and then perform 
another inspection at 200 hours to find that the unit is no longer operating, then the only 
information we have is that the unit failed at some point in the interval between 100 and 200 
hours. 
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Left censored data is a special case of interval censored data. In left censored data, the interval 
is between time = 0 and some inspection time. 

To use this data type, select the Times-to-failure data check box and the My data set contains 
interval and/or left censored data check box in the setup window. In the example shown next, 
the first unit was observed at 150 hours and found to be failed. The second unit was still 
operating at 150 hours but failed at some point prior to the next observation at 300 hours, and 
so on. 

 

Note: Although this example shows a scenario in which the inspections occur at regularly 
scheduled intervals, Weibull++ does not require the start time of the interval to be equal to the 
end time of the previous interval. 

When entering this type of data in groups, all units that failed within the same interval are 
considered to be part of the same group. 

 

Times-to-Failure with All Types of Censored Data 

Times-to-failure data with different types of censoring can be added to a single data sheet. The 
data may be entered in groups or ungrouped. The following is an example of a grouped data set 
with complete, suspended, interval and left censored data. 
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The next illustration summarizes the differences between complete data and the different 
types of censored data. 

 

Free-Form (Probit) Data 

The free-form data type is used to analyze the relationship between an independent variable 
(x-axis data) and the percentage of failures (y-axis data) in response to the variable. The y-axis 
data are treated as probability units, or probits, and they show how the percentage of failures 
increase in response to a variable (e.g., time, distance, stress level, etc.). For example, you could 
use the free-form data type to record the Y percentage of automobiles that will need repair 
after X number of miles, or record the Y percentage of product failures at X degrees of 
temperature. 

To use this data type, select the Free-form (probit) data check box in the setup window. In the 
data sheet, enter the values for the independent variable in the X-Axis value column and enter 
the cumulative percentage of failures in the Y-Axis value column. The following is an example of 
a data set that shows the effect of time (x-axis data) on the probability of failure (y-axis data) of 
a product. 
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SUBSET IDS 

By default, Weibull++ life data folio data sheets include a Subset ID column for logging any 
pertinent information or comments about the data. The column can contain values or text up 
to 30 characters, including spaces. 

The information in the subset ID column do not affect the calculations in the folio unless you 
select to use analysis methods that categorize data based on their subset IDs. The following is a 
list of analysis methods in Weibull++ that are affected by subset IDs: 

• Competing failure modes (CFM) Analysis 

• Batch Auto Run 

• Auto Group Data 

• Specify Points 

To insert additional subset ID columns to a data sheet, choose Life Data > Format and View > 
Add/Remove Columns. 

 

In the window, click the Add Subset ID Column button. To remove a subset ID column from the 
list, clear the check box next to the column's name. 

LIFE DATA FOLIO CONTROL PANEL  

The life data folio control panel allows you to configure the analysis settings for the data sheet 
and view/access the results. It consists of multiple pages, each containing options for 
performing particular tasks. This topic focuses on the Main page of the life data folio control 
panel, which contains most of the tools you will need to perform life data analysis. For more 
information about the control panel in general, see Control Panels. 
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Control Panel Main Page 

• The Distribution drop-down list allows you to select a life distribution to model the failure 
behavior of the data. There are nine distributions and three special analysis methods to 
choose from. 

• The nine distributions are: Weibull, exponential, lognormal, normal, generalized 
gamma, gamma, logistic, loglogistic and Gumbel. The ReliaWiki resource portal has 
information on the statistical characteristics of each distribution at: 
http://www.reliawiki.org/index.php/Life_Distributions. 

Tip: If you are not certain which distribution would provide the best fit for your data, 
you can use the Distribution Wizard to guide you through the selection process. 

• The special analysis methods are: 

• Mixed Weibull analysis is used for analyzing data sets that reflect different trends 
in the failure behavior. This method may be useful when dealing with failure modes 
that cannot be assumed to be independent (i.e., the occurrence of one failure 
mode affects the probability of occurrence of the other mode) and/or when it is 
not possible to identify the failure mode responsible for each individual data point. 
To use mixed Weibull analysis, you will need to specify how many subpopulations 
exist in the data set (2, 3 or 4). The software will determine the proportion of units 
that fall under each subpopulation, and then calculate the Weibull parameters of 
those subpopulations. The overall reliability of the full data set is then computed by 
obtaining the sum of the proportional reliability contributions of each 
subpopulation. 

• Bayesian-Weibull analysis is based on the concepts of Bayesian statistics. It is 
typically used in situations when you have a small sample size and a strong prior 
knowledge of what the failure behavior is likely to be. 

• Competing Failure Modes (CFM) analysis is used for analyzing data sets that 
contain failures due to different types of failure modes. The occurrence of one 
failure mode results in a failure for the product; hence, the failure modes are said 
to “compete” to cause the failure. This analysis can be used when the failure 
modes are assumed to be statistically independent (i.e., the occurrence of one 
failure mode does not affect the probability of occurrence of the other mode) and 
the failure mode responsible for each failure can be clearly identified. To use CFM 
analysis, you will need to categorize the times in the data set according to failure 
modes and then choose one type of life distribution to model the failure behavior 
of each mode separately. The overall reliability is computed by obtaining the 

http://www.reliawiki.org/index.php/Life_Distributions
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reliability due to each failure mode and then multiplying together the reliability 
values. 

• The Analysis Settings area provides a summary of the settings that will be used to fit the 
distribution. Click the options displayed in blue text to toggle between the available 
options. 

 

The following table serves as a guide to the abbreviations. These settings are also available 
on the Analysis page of the control panel (see Life Data Folio Analysis Settings for a 
description of these settings). Note that the available options will vary depending on the 
data type, distribution and analysis method you have selected. 

Analysis Method Rank Method 

Rank Regression on X (RRX) Standard Ranking Method (SRM) 

Rank Regression Y (RRY) ReliaSoft Regression Method (RRM) 

Non-Linear Rank Regression (NLRR)   

Maximum Likelihood Estimation (MLE)   

Confidence Bounds Method Rank Method 

Fisher Matrix Confidence Bounds (FM) Median Ranks (MED) 

Likelihood Ratio Confidence Bounds (LRB) Kaplan-Meier Estimator (K-M) 

Bayesian Confidence Bounds (BSN)   

Beta-Binomial Confidence Bounds (BB)   

1. The Analysis Summary area displays the calculated parameters and other results that may 
be used to evaluate how well the chosen distribution or analysis method fits the data set. 
As an example, the following picture shows the analysis results for a particular data set. 
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Depending on your application settings, additional information may also be displayed: 

• The Rho value (correlation coefficient) is automatically calculated and displayed in the 
results if the parameters were estimated using rank regression. Rho is a measure of 
how well the regression line falls onto a straight line on a probability plot. The closer 
the value of rho is to +/-1, the better the linear fit. A value of zero would indicate that 
the data points are randomly scattered and have no pattern or correlation to the 
regression line model. 

• The LK Value (likelihood function value) compares how well different models fit the 
same data set. The model with the highest LK value is considered to have the best fit 
statistically for that data. However, because this value is influenced by the sample size 
and the variability of the data set, it varies across different data sets and cannot be 
used by itself to evaluate a particular model. 

• The Pnz (percent non-zero) is automatically calculated and displayed in the results if 
the data set contains failures at t = 0. Pnz represents the proportion of the population 
with non-zero failure times. A value of 1 indicates that there are no zero failure times in 
the data set (which is the most common scenario in life data analysis); a decimal value 
indicates that the data set includes zero failure times (such as out-of-the-box failures, 
for example). The model parameters are calculated based on non-zero failure times, 
and the PNZ value is used as a multiplier when calculating certain metrics (e.g., 
reliability, unreliability) based on the model. 

• The number of failures and suspensions. This includes failures at t = 0 but excludes 
suspensions at t = 0. 

• The model status (as shown in the previous picture) is displayed if the result of the 
analysis is associated with a published model. The status "Synchronized" indicates that 
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the published model reflects the latest results from the analysis. If the analysis has 
been modified since the model was last published (e.g., if more data has been added, 
an analysis setting has changed, etc.), the status will display as "Out of Sync." (See 
Publishing Models.) 

Tip: If you use the 3-parameter Weibull distribution, you have the option to display the theta 
parameter, which is the sum of the values of the eta and gamma parameters. To include the 
theta parameter in the results, select the Show Theta check box on the Weibull++ Folios page 
of the Application Setup. Note that for the 1-parameter and 2-parameter Weibull distributions, 
the value of gamma is zero; therefore, if you select to display theta for these distributions, the 
value of theta will be identical to the value of eta. As an alternative, you can select to always 
display the theta parameter instead of eta. To do this, click the Calculations page of the 
Application Setup and select the Use Theta parameter scheme on Weibull check box. 

Additional Results 

The following tools may also be used in conjunction with your own engineering knowledge 
about the model in order to further evaluate the fit of the distribution to the data set. 

• For a rank regression analysis, the Probability Plot shows you how well the solution line 
tracks the plotted data points. This allows you to visually assess the fit of a distribution. This 
method can be used only when the parameters have been calculated using rank regression. 

• Confidence Bounds allow you to quantify the amount of uncertainty in the parameter 
estimates and in the reliability predictions due to sampling error. The narrower the 
confidence bounds, the closer the estimates are to the true value of the parameters and 
the better the precision on the reliability predictions. You can visualize the confidence 
bounds by using plots or obtain point calculations on the confidence bounds by using the 
Quick Calculation Pad. 

• The Goodness of Fit Results utility uses three different tests to determine how well the 
parameters of the distribution fit the data. Note that it can only be used to evaluate data 
sets that do not contain censored data. 

Folio Tools 

The folio tools are arranged on the left side of the Main page of the control panel. Use these 
tools to manage data and experiment with the results of your analysis. 

  Calculate estimates the parameters of the chosen distribution, based on the current 
data set and the specified analysis settings. This tool is also available by choosing Life Data 
> Analysis > Calculate. 
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  Plot creates a new sheet in the folio that provides a choice of applicable plot types. For 
life data folios, this includes plots such as reliability vs. time, failure rate vs. time, 
probability plot, etc. This tool is also available by choosing Life Data > Analysis > Plot. 

  QCP opens the Weibull++ Quick Calculation Pad, which allows you to calculate results 
based on the analyzed data sheet, such as the probability of failure, mean life, etc. This tool 
is also available by choosing Life Data > Analysis > Quick Calculation Pad. 

  Distribution Wizard opens the Distribution Wizard, which helps you select the 
distribution that best fits your data based on the selected parameter estimation method 
(i.e., RRX, RRY or MLE). This tool is also available by choosing Life Data > Analysis > 
Distribution Wizard. 

  Alter Data Type opens the Weibull++ Folio Data Sheet Setup window, which allows 
you to change the data entry columns in the current data sheet. Note that when you 
change the setup, you may lose information already entered in the data sheet. For 
example, switching the data sheet from one that supports interval data to one that 
supports only right censored data will remove all the inspection times. This tool is also 
available by choosing Life Data > Format and View > Alter Data Type. 

  Change Units opens the Change Units window, which allows you to change the units 
for the values in the current data sheet. 

  Auto Group Data opens the Auto Group Data window, which allows you to group 
together identical data points. Grouping data significantly speeds up calculations when you 
have a very large data set. This tool is also available by choosing Life Data > Options > Auto 
Group Data. 

  Alter Parameters (also called Alter Parameters w/o Recalculation) allows you to 
manually alter the value of one (or more) parameters, while keeping the original values of 
the rest of the parameters and the variance/covariance matrix the same. The LK value, the 
solution line on plots and all subsequent analyses will be based on the modified set of 
parameters.  

  Specify Points opens the Specify Points window, which allows you to adjust the way 
that the line is fitted to the points for a rank regression analysis. The ranks will be 
calculated based on all of the data points but the regression line will be fitted only to the 
points you have specified. This tool is also available by choosing Life Data > Options > 
Specify Points. 
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  Color Data Values applies different font colors to the entries in the data sheet for easy 
visualization. Note that whenever you edit or add new data to the data sheet, you must 
choose one of the Color Data Values commands again in order to apply the font colors. 

• Default Color applies a black font color to all the entries in the data sheet. 

• Based on Data Type applies different font colors based on the type of censoring: 
red for failure data (no censoring), green for suspension data, magenta for left-
censored data and blue for interval data. 

• Based on Subset ID 1 applies different font colors based on unique subset IDs in 
the Subset ID 1 column. If a data point has no entry in the Subset ID 1 column, then 
the font color is black. 

• Based on Subset ID 2 applies different font colors based on unique subset IDs in 
the Subset ID 2 column. If a data point has no entry in the Subset ID 2 column, then 
the font color is black. 

• Based on Subset ID Combination applies font colors based on unique combinations 
of subset IDs in the Subset ID 1 and Subset ID 2 columns. If a data point has no 
subset IDs, the font color is black, but if a data point has at least one subset ID, 
then it is treated as having a unique combination of subset IDs. 

  Batch Auto Run opens the Batch Auto Run window, which allows you to extract data 
from an existing data set based on the subset ID. This tool is also available by choosing Life 
Data > Options > Batch Auto Run. 

 
WEIBULL++ LIFE DATA FOLIO ANALYSIS SETTINGS 

The Analysis page of the Weibull++ life data folio control panel includes the settings that are 
also displayed on the Main page, along with any additional settings that may be applicable for 
the current data sheet. This topic provides a brief description of all the settings. For the 
background theory of each analysis method, the ReliaWiki resource portal provides more 
information at: http://www.reliawiki.org/index.php/Parameter Estimation. 

The Analysis page of the Weibull++ life data folio control panel contains the following settings: 

• Analysis Method sets the method for estimating the parameters of your chosen 
distribution. There are four options to choose from: rank regression on X (RRX), rank 
regression on Y (RRY), non-linear rank regression (NLRR) and maximum likelihood 
estimation (MLE). Note that: 

http://www.reliawiki.org/index.php/Parameter%20Estimation
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• For free-form data, the only analysis methods available are RRX and RRY. 

• The NLRR method is available only when you choose the 3-parameter Weibull 
distribution. 
 
As a rule of thumb, data sets with small sample sizes and mostly complete data may be 
best analyzed with rank regression, while MLE may be more appropriate for data sets 
with a high proportion of suspensions, interval data or many observed failures. This is 
because the MLE method is based on the likelihood function, which considers each 
time-to-suspension in the estimate of the parameters, unlike in rank regression where 
the solution is based on the plotting positions of the times-to-failure data. However, 
the MLE solution tends to be badly biased (statistically distorted) when performed on 
small sample sizes. As the sample size gets larger, the difference between the two 
methods become less important. To determine whether your sample size is large 
enough for MLE, you will need to take into account factors such as the amount of 
variability in your data set and the acceptable level of risk or margin of error in your 
calculations. 
 
When choosing between rank regression on X (RRX) and rank regression on Y (RRY), 
note that data are best analyzed when regressed in the direction of uncertainty. For 
example, in reliability tests, the times-to-failure (x-axis) vary from test to test but the 
probabilities of failure (y-axis) remain consistent. Therefore, if the uncertainty is on the 
times-to-failure data, RRX may be the preferred analysis method. 
 
On the other hand, in situations where the time value (x-axis) is known but the 
probability of failure (y-axis) varies for each time value, the RRY method may be the 
appropriate choice because the uncertainty is on the unreliability estimates. 

• Rank Method sets the method for calculating the unreliability estimates of the times-to-
failure data. There are two options available: median ranks and the Kaplan-Meier 
estimator. 
 
The median ranks method assigns unreliability estimates based on the failure order number 
and the cumulative binomial distribution. Alternatively, the Kaplan-Meier estimator uses 
the product of the surviving fractions, producing a modified empirical distribution. In 
general, the median ranks method is preferable and more widely used for unreliability 
estimation. Thus, it is a good idea to use the median ranks method unless one has a specific 
reason to use the Kaplan-Meier methodology. 

• Use RS Regression Method uses ReliaSoft's ranking method (RRM). This option is 
automatically selected when you have interval censored data in the data sheet; otherwise, 
the software will use the default standard ranking method (SRM). The RRM method 
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provides a more accurate estimate of the time the failure occurred in the interval by 
iteratively recomputing the failure times and the ranks until the parameter values 
converge. For non-interval data (exact times-to-failure data) there is no difference in the 
results between the SRM and RRM methods. The ReliaWiki resource portal provides more 
information on the RRM method at: http://www.reliawiki.org/index.php/ReliaSoft's 
Alternate Ranking Method. 

• Confidence Bounds Method sets the method for calculating the confidence bounds. The 
methods available depend on your chosen distribution method or analysis method. (Note 
that confidence bounds calculations are not available for free-form data.) The ReliaWiki 
resource portal provides more information on the background theory of confidence bounds 
at: http://www.reliawiki.org/index.php/Confidence Bounds. 

• The Fisher Matrix method is the standard way of calculating confidence bounds and it is 
the default method in the software. For data sets with a large number of data points, 
there is no significant difference in the results between the Fisher Matrix method and 
the likelihood ratio method; however, when working with very small sample sizes, the 
Likelihood Ratio method may be more accurate. 

• The Bayesian method calculates the confidence bounds by analyzing prior information 
about the assumed distribution’s parameters, along with sample data in order to 
evaluate the amount of uncertainty in the estimated values. 

• The Beta-Binomial method is a non-parametric approach to confidence bounds 
calculations, meaning that no underlying distribution is assumed. This method can be 
used only with the mixed Weibull distribution. 

• Sort before calculation sorts the failure/suspension times in the data sheet in ascending 
order. This will not affect the results of the calculation because, in life data folios, all data 
points are assumed to be independent and identically distributed (i.i.d.). 

• Grouped Data Settings affect how the unreliability estimates (median ranks or Kaplan-
Meier estimates) are plotted on the probability plot. These settings are available only when 
working with grouped data. 

 

When using rank regression with grouped data, the software will plot only the data points 
that correspond to the highest median rank position in each group. For example, for two 
groups of data with 10 units each, the software will plot only two data points: the 10th rank 

http://www.reliawiki.org/index.php/ReliaSoft%27s_Alternate_Ranking_Method
http://www.reliawiki.org/index.php/ReliaSoft%27s_Alternate_Ranking_Method
http://www.reliawiki.org/index.php/Confidence_Bounds
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position out of 20 and the 20th rank position out of 20. The regression line is then fitted to 
these two points. When you select the Ungroup on regression check box, the software will 
plot each individual data point in the group. The regression line is then fitted to all the data 
points. In general, grouped data analysis provides parameter estimates that have wider 
confidence bounds, while ungrouped data analysis provides parameter estimates with 
much narrower confidence bounds. The ReliaWiki resource portal provides more 
information about using rank regression with grouped data at: 
http://www.reliawiki.org/index.php/Grouped Data Parameter Estimation. 

When using MLE analysis, the Ungroup on MLE check box ungroups the data during 
calculations and then plots all the data points in each group on the probability plot; 
however, the solution of the line is obtained from the likelihood function and not by the 
plotting positions of the data points. Therefore, the line is not expected to track the points 
on the plot. This option is useful for adjusting the way the grouped data points are 
displayed on the MLE probability plot. 

Note: When working with grouped failure data, you have to be cautious about ungrouping 
the data. In grouped data, it is assumed that the failures occur at some time in the interval 
between the previous and the current time-to-failure. For example, for a group of 10 units 
with a failure time of 100 the software will assume that the 10 units failed between 0 and 
100 hours. If you select the Ungroup on regression check box, the software will treat the 10 
units as failures that occur at exactly 100 hours. 

• Biasing is available when you select the 2-parameter Weibull distribution with MLE 
analysis, and only if the Bayesian confidence bounds method is not selected. 

 

The MLE method is known to obtain biased (statistically distorted) estimates when 
performed on small sample sizes. The Unbias parameters check box corrects the biased 
estimate of the Weibull beta parameter due to the MLE sampling error. Weibull++ uses the 
correction factor proposed by Ross and Hirose to unbias both censored and non-censored 
data. The ReliaWiki resource portal provides more information about the correction factors 
at: http://www.reliawiki.org/index.php/The_Weibull_Distribution#Unbiased_MLE. 

LIFE DATA ANALYSIS PLOTS 

To create a plot in a Weibull++ life data folio, choose Life Data > Analysis > Plot or click the icon 
on the Main page of the control panel. 

http://www.reliawiki.org/index.php/Grouped_Data_Parameter_Estimation
http://www.reliawiki.org/index.php/The_Weibull_Distribution#Unbiased_MLE
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Tip: You can add additional plot sheets to the folio by choosing Life Data > Folio Sheets > Insert 
Additional Plot. The additional sheets can function as overlay plots to display results from 
multiple data sheets in the current folio on a single plot. 

The following is a description of the different types of plots that can be created in a Weibull++ 
life data folio. (For general information on working with plots, see Plot Utilities.) 

• The Probability plot shows the trend in the probability of failure over time. The plotting 
positions of the data points are determined by the failure/suspension times in the data set 
(x-axis) and their corresponding unreliability estimates (y-axis). 

Note: Unlike the probability plots for other distributions, the y-axis in an exponential 
probability plot always indicates the reliability instead of the unreliability. This tradition 
arose from the time when probability plotting was performed "by hand." The exponential 
reliability model starts with R = 1 at T = 0 (or gamma). Thus, if the unreliability were plotted, 
the axis would start at Q = 1 - R = 0, which is not possible, given that the y-axis scale is 
logarithmic. 

When the parameters have been calculated using rank regression analysis, the regression 
line is fitted to the data points on the plot in order to obtain the distribution parameters. 
Therefore, the plot can also be used to compare how different distributions fit a particular 
data set. The closer the regression line tracks the points on the plots, the better the fit. 

In contrast, the maximum likelihood estimation (MLE) method obtains the solution of the 
line from the likelihood function, not by the plotting positions of the data points. Therefore, 
the line is not expected to track the points on the plot, and the plot should not be used to 
evaluate the fit of a distribution when using MLE. 

The following examples show the rank regression analysis of single data set using a Weibull 
distribution and a lognormal distribution. As you can see, the probability plot shows that 
the Weibull distribution presents the better fit to this particular data set. 
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• The Reliability vs. Time plot shows the reliability values over time, capturing trends in the 
product’s failure behavior. 

• The Unreliability vs. Time plot shows the probability of failure of the product over time. 

• The pdf plot shows the probability density function of the data over time, allowing you to 
visualize the distribution of the data set. 

• The Failure Rate vs. Time plot shows the failure rate function of the product over time. 

• The Contour Plot shows a 3D surface on a 2D plot. The plot represents the 3D surface by 
plotting constant z slices, called contours, on a 2D format. The shape of a contour is 
determined by plotting the parameters of the data set (x- and y-axis) at the position where 
a given confidence level occurs (z-axis). In Weibull++, contour plots are typically used to 
compare data sets. (See Contour Plots.) 
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• The Failures/Suspensions (F/S) Histogram is a bar chart that shows the number of 
failures/suspensions that fall into different time intervals. This allows you to evaluate the 
frequency distribution of the failures and suspensions in the data set. Use the Time Interval 
field in the control panel to define the length of the interval, then choose any of the 
following display options: 

• Probability Density Values displays a chart where the height of each bar is proportional 
to the frequency of occurrence of failures in each interval. Select the Superimpose pdf 
check box on the control panel to show the pdf line on the same chart. 

• Failures displays a chart where the height of each bar is proportional to the number of 
failures in each interval. Select the Show suspensions check box to show a bar chart of 
the number of suspensions in each interval. 

• The Failures/Suspensions Pie chart displays the ratio and proportion of failures and 
suspensions to the whole data set. 

• The Failures/Suspensions Timeline plot is similar to a horizontal bar chart. The values of 
the failures and suspensions are plotted on the y-axis and the time periods are on the x-
axis. All the lines are anchored to the y-axis, giving a common point of measurement. 

CONTOUR PLOTS 

In Weibull++, contour plots are available only for the 2- and 3-parameter Weibull, normal and 
lognormal distributions. The first time you select a contour plot from the Plot Type drop-down 
list, the Contours Setup window will appear. This window allows you to select: a) the number of 
contour lines to be shown, b) the confidence level represented by each selected line, and c) the 
resolution used to draw the lines. 

For existing contour plots, you can access the Contours Setup window by clicking the Contours 
Setup link on the control panel of the plot sheet. 

To change the level of detail at which the contours are plotted (and the smoothness of the 
lines), adjust the Resolution slider. You can click and drag the slider or, for fine adjustments, 
click the slider and then use the arrow keys. The number of points plotted to create the lines is 
displayed beside the field name. Note that higher resolutions will take longer to plot. 

Comparing Data Sets 

In Weibull++, contour plots are typically used to compare data sets. For two contour plots that 
are superimposed in an overlay plot, the Plot Critical Level check box will be available, as 
shown next. This allows you to calculate and display the minimum confidence level at which the 
two contour plots intersect. At any confidence level below the critical level, the contour plots 
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will not overlap and there will be a statistically significant difference between the data sets at 
those levels. 

 

The following example shows two contour plots in an overlay plot. The solid contour lines 
represent the 90% confidence level while the dashed contour lines represent the critical 
confidence level, which is calculated to be 93.6%. (The appearance of the lines in the example 
were modified via the Plot Setup to make the plot easier to interpret.) Note that due to the 
calculation resolution and plot precision, the contour lines at the calculated critical level may 
appear to overlap or have a gap. 
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QUICK CALCULATION PAD (QCP) 

The Quick Calculation Pad (QCP) provides a convenient way of calculating a variety of useful 
metrics. To access the tool, click the QCP icon on the Main page of the control panel. 

 

This topic provides a general description of the QCP and how to use it in most analyses. For 
more focused information about the types of calculations that can be performed for a 
particular analysis, you can go directly to the topic of interest. 

• Life Data Analysis 

• Accelerated Life Testing Data Analysis 

• Recurrent Event Data Analysis 
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How to Use the QCP 

1. Choose a metric in the Calculate area. (Note: To calculate the Parameter Bounds, you must 
first select a type from the Bounds drop-down list.) 

2. If applicable, use the Units drop-down list to specify the units for values that are entered as 
inputs and/or displayed as results. The units in the QCP can be different from the units that 
were used for the data sheet. For example, in a life data folio, you could enter the 
failure/suspension times in hours but then calculate the reliability for 1 year of operation — 
the application will convert the times automatically based on the conversion factors 
specified for the database. 

3. If applicable, use the Bounds drop-down list to specify what type of confidence bounds to 
calculate. The following graphics illustrate the types. The ReliaWiki resource portal provides 
more information on the background theory of confidence bounds at: 
http://www.reliawiki.org/index.php/Confidence Bounds. 

 

If you select Both One-Sided, the QCP will calculate both the lower one-sided bound and 
the upper one-sided bound. 

Note: Confidence bounds calculation options are disabled when the underlying data type is 
free-form data. 

4. Make any required inputs in the Input area. 

5. Click Calculate. The calculated value(s) will always be displayed in the results area at the 
top of the window, and clicking the Report button displays a summary of the current 
calculation input/output in the Results window.  You can also use the Options drop-down 
list to configure other settings, including: 

• Precision sets the number of decimal places displayed in the results. 

http://www.reliawiki.org/index.php/Confidence_Bounds
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• Scientific Notation sets the point at which numbers will be converted to normalized 
scientific notation. For example, setting this to 3 means that all numbers with a value of 
1,000 or more will be converted to normalized scientific notation (e.g., 1.0E+3). 

• Set Display Font allows you to change the font style and size that is used to display the 
calculated value(s) in the results. 

• Select Captions if you want additional information to be displayed in the results area 
along with the values (a green light in the button indicates that this option is selected). 
For example, if you have selected to calculate the reliability for a given time with 2-
sided confidence bounds at the 90% confidence level, the first picture shows the 
display with captions and the second picture shows without. 

 
QCP window with captions on. 

 
QCP window with captions off. 

• Select Show Calculation Log if you want to display a log on the right side of the window 
that records some or all of the calculations performed during this QCP session (a green 
light in the button indicates that this option is selected). 

• If Auto Print Results is selected under Options, all results will be automatically 
printed to the log each time you perform a calculation. 

• Otherwise, you can choose which results to add to the log by using the Print button 
at the bottom of the log display. 
 
Under the log display, you can also click Feed to "advance the tape" or Clear to 
delete all data from the current log. If you click inside the log, you can copy some 
or all of the text to the Clipboard. 
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• Select Non-Modal QCP to lock the QCP in a top window position so it can remain open 
while you have access to all folios and data sheets. The calculations performed in the 
QCP will be based on the currently active data sheet. If this option is not selected, you 
will need to close the QCP to access any data sheet or folio. This setting can also be 
changed using the While QCP is open, have access to all folios option on the Other 
page of the Application Setup. 

QCP CALCULATIONS FOR LIFE DATA ANALYSIS 

Weibull++ includes a Quick Calculation Pad (QCP) for computing useful life data analysis 
metrics. You can access the QCP by clicking its icon on the Main page of the control panel. 

 

To perform a calculation, select the appropriate option and enter any required inputs in the 
Input area, then click Calculate. For more detailed information on how to use the QCP in 
general, see Quick Calculation Pad (QCP). 

The following calculations are available for life data analyses: 

Probability 

Reliability 

Calculates the probability that a new product will operate without failure for a given period 
of time. Enter the time at which you wish to calculate the reliability in the Mission End 
Time field. The mission is assumed to start at time = 0. 

For example, a reliability of 90% for a mission end time of 3 years means that if 100 
identical units are fielded, then 90 of them will still be operating at the end of 3 years. 

Probability of Failure 

Calculates the probability that a new product will be failed in a given period of time. Enter 
the time at which you wish to calculate the probability of failure in the Mission End Time 
field. The mission is assumed to start at time = 0. 

Probability of failure is also known as unreliability, and it is the inverse of the reliability. For 
example, a probability of failure of 10% for a mission end time of 3 years is equivalent to a 
90% reliability. 

Conditional Reliability 
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Calculates the probability that a product will successfully operate at a specific time interval 
given that it has operated successfully up to a specified time. Enter the start time of the 
interval in the Mission Start Time field and enter the duration of the interval in the Mission 
Additional Time field. 

For example, a product may have a reliability of 90% for 3 years. If the product has 
operated for 2 years without failure, the conditional reliability for an additional year (for a 
total of 3 years of operation) may be 95%. 

Conditional Probability of Failure 

Calculates the probability that a product will be failed at a specific time interval given that it 
has not failed up to a specified time. Enter the start time of the interval in the Mission Start 
Time field and enter the duration of the interval in the Mission Additional Time field. 

For example, a product may have a 10% probability of failure for 3 years. If the product has 
operated for 2 years without failure, the conditional probability of failure for an additional 
year (for a total of 3 years of operation) may be 5%. 

Life 

Reliable Life 

Calculates the estimated time at which a specified reliability value will be achieved. Enter 
the reliability goal in the Required Reliability field. For example, a goal of 90% reliability 
with a reliable life of 4 years means that if 100 identical units are fielded, then 90 of them 
will be still be operating at the end of 4 years. 

BX% Life 

Calculates the estimated time at which a specified probability of failure will be achieved. 
Enter the probability of failure in the BX% Life At field. For example, a B10 life of 4 years 
means that 10% of the fielded units are expected to be failed at the end of 4 years of 
operation (note that this is equivalent to a 90% reliability with a reliable life of 4 years). 

Note: In the early days of reliability engineering, bearing manufacturers used the term "B10 
life" to refer to the time by which 10% of the components would fail. Keeping with 
tradition, ReliaSoft retained this nomenclature but replaced "10" with "X," since the 
software allows you to get this information at any percentage point and not just at 10% 
(e.g., B1, B5, etc.). 

Mean Life 
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Calculates the average time at which a product is expected to operate before failure. In the 
Weibull++ life data folio, the mean life is the mean time to failure (MTTF) based on the 
fitted model. 

Note: The term mean time to failure (MTTF) is used as a metric for the analysis of non-
repairable components. In the Weibull++ life data folio, all data are assumed to come from 
non-repairable components that are independent and identically distributed (i.i.d.). On the 
other hand, the term mean time between failures (MTBF) is used as a metric in repairable 
systems analysis, where the same system may fail and be repaired multiple times. To 
analyze simple repairable system data in Weibull++, use the recurrent event data analysis 
(RDA) folios. 
 
For more complex repairable system analyses, see ReliaSoft’s BlockSim software. 

Mean Remaining Life 

Calculates the expected remaining life given that the product, component or system has 
survived to time t. Enter the time at which you wish to calculate the mean remaining life in 
the Mission End Time field. 

Rate 

Failure Rate 

Calculates the instantaneous number of failures per unit time that can be expected at a 
certain time given that a unit survives to that age. Enter the time at which you wish to 
calculate the failure rate in the Mission End Time field. 

For example, a failure rate of 0.01 at 100 hours means that each unit that survives to 100 
hours has approximately a 1% probability of failure in the next hour. 

Bounds 

Parameter Bounds 

Calculates the specified bounds on the parameter estimates, allowing you to quantify the 
amount of uncertainty in those estimates. This option is available only when you have 
specified the type of confidence bounds to use from the Bounds drop-down list. When you 
click Calculate, the Results Window will open to display the estimated parameters and their 
bounds. 

https://www.reliasoft.com/products/reliability-analysis/blocksim


Chapter 5: Life Data Analysis Folios 

248 https://www.reliasoft.com/weibull 

 

LIFE DATA ANALYSIS EXAMPLE 

Ten identical units of a prototype device were reliability tested at the same application and 
operation stress levels. Six of the units failed during testing after operating for the following 
times: 16, 34, 53, 75, 93, 120 hours. Four other units were still operating after 120 hours. 

The objective is to obtain the reliability of the prototype device at 60 hours, at the lower 1-
sided 90% confidence bound. 

Create a Life Data Folio 

1. Choose Home > Insert > Life Data. In the setup window, select Times-to-failure data for the 
data type and then select My data sheet contains suspensions (right censored data). For 
the time units, select Hour. Click OK to create the folio. 

2. Enter the given data in the data sheet, and then on the Main page of the control panel, 
choose the 2P-Weibull distribution and the MLE parameter estimation method, as shown 
next. (You may also choose the parameter estimation method on the Analysis page of the 
control panel.) 
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Analyze the Data Set 

3. Choose Life Data > Analysis > Calculate or click the icon on the Main page of the control 
panel. 

 

The parameters of the distribution will be automatically computed and displayed in the 
Analysis Summary area of the control panel. The parameters are beta = 1.5070 and eta = 
128.6414. 

4. To estimate the reliability of the device, open the QCP by choosing Life Data > Analysis > 
Quick Calculation Pad or by clicking the icon on the Main page of the control panel. 

 

5. In the QCP, choose to calculate the Reliability with lower 1-sided confidence bounds. 
Select Hour for the time units and then make the following inputs: 

• Mission End Time = 60 

• Confidence Level = 0.9 

6. Click Calculate to obtain the results, as shown next. The result shows that the reliability of 
the prototype device at 60 hours is 72.84%. The lower one-sided 90% confidence bound is 
estimated to be 54.32%. This means that there is 90% probability that the reliability of the 
device will be at least 54.32% at the end of 60 hours of operation. 
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Create a Reliability vs. Time Plot 

7. To visualize the reliability of the device over time, close the QCP and then create a plot by 
choosing Life Data > Analysis > Plot, or by clicking the icon on the Main page of the control 
panel. 

 

8. Show the confidence bounds on the plot by choosing Plots > Confidence Bounds > 
Confidence Bounds or by right-clicking the plot sheet and then choosing Confidence 
Bounds on the shortcut menu. In the Confidence Bounds Setup window, make the 
following selections: 

• Sides: One-Sided; Show Bottom 

• Type: Reliability (Type II) 
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• Confidence Level %: 90 

9. Click OK. On the control panel of the plot sheet, choose the Reliability vs. Time plot type. 
The following picture shows the resulting plot (with annotations added). As you can see, 
the line representing the confidence bound is fairly far from the reliability line, indicating a 
significant amount of uncertainty in the results. Based on this result, you may choose to 
perform further analysis on the data, such as testing those 4 suspended units to failure to 
see whether the uncertainty is due to the small number of failures in the data set or due to 
the variability inherent in the device itself. 

 

Tools 

Distribution Wizard 

The Distribution Wizard performs multiple goodness of fit tests to determine the best 
distribution for a data set based on the chosen parameter estimation method. Note that the 
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Distribution Wizard only serves as a guide. You should compare its suggestion with your own 
engineering knowledge about the product being modeled before making the final decision on 
which distribution to use for your data set. 

Comparing Distributions 

To use the Distribution Wizard, you must have at least two failure data points in the current 
data sheet. 

The first step is to choose a parameter estimation method from the control panel. Then open 
the Distribution Wizard by choosing Life Data > Analysis > Distribution Wizard or by clicking the 
icon on the Main page of the control panel. 

 

On the Main tab of the Distribution Wizard, select the distributions you would like to consider. 
(The available distributions will vary depending on which folio you opened the tool from.) Then 
click Analyze to start the evaluation. The distributions will be ranked according to how well they 
fit the data, with rank 1 being the best fit. 

In the example shown next, the 3P-Weibull distribution is the suggested distribution for the 
data set. The parameter estimation method selected in the data sheet (in this case, MLE) is 
displayed at the bottom of the window. 
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To calculate the parameters of the distribution in the rank 1 position, click the Implement 
button. This closes the Distribution Wizard, and the results will appear in the Analysis Summary 
area of the control panel. 

Note: You may find that the Distribution Wizard often recommends either the 3-parameter 
Weibull distribution or the generalized gamma (G-Gamma) distribution. This is because these 
distributions have the ability to mimic the attributes of other distributions based on the values 
of the distribution's parameters. In such cases, if you have reason to believe that the 
recommended distribution is not applicable, you may prefer to select the distribution with the 
next highest ranking. 

Goodness of Fit Tests 

To see the calculations behind the ranking, click the Analysis Details tab. The Distribution 
Wizard performs three goodness of fit tests to determine the rank of the distributions: 

• The Kolmogorov-Smirnov test (GOF) tests for statistical difference (the difference between 
the expected and obtained results). 
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• The Correlation coefficient test (PLOT) measures how well the plotted points fit a straight 
line. 

• The Likelihood value test (LKV) computes the value of the log-likelihood function, given the 
parameters of the distribution. 

The Initial sheet contains the values computed from the three tests. The AVGOF column 
contains the average values from the GOF test, the AVPLOT column contains the average values 
from the PLOT test and the LKV column contains the average values from the LKV test, as 
shown next. 

 

The Intermediate sheet displays the ranking of the distributions based on the values from the 
Initial sheet. The RAVGOF column contains the ranking of the GOF test, the RAVPLOT column 
contains the ranking of the PLOT test and the RLKV column contains the ranking of the LKV test. 

The values from the Initial sheet are first weighted (e.g., AVGOF * weight) and then summed 
into one overall DESV value (i.e., weighted decision variable). The distribution with the lowest 
DESV value is considered to be the best fit for the data. The weights assigned to each test are 
based on the parameter estimation method. For example, by default, a higher weight is given 
to the LKV test if the parameter estimation is MLE; whereas in rank regression, higher weights 
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are given to the K-S and Rho tests. The weights can be adjusted in the Setup window of the 
Distribution Wizard. 

The Final Report sheet displays all the distributions in their final ranking order and the 
calculated parameters for each distribution. 

Distribution Wizard Setup Window 

When you open the Distribution wizard from the Weibull++ life data folio, you have the option 
to change the weights that are used to determine the ranking of the distributions. Click the 
Setup button at the lower right corner of the Distribution Wizard to view the settings, as shown 
next. 

 

You can use different weights for the rank regression method and the MLE method. The sum of 
the three weights for each parameter estimation method must equal 100%. The weights are: 

• Goodness of Fit represents the weight percentage for the GOF test. 

• Plot Fit represents the weight percentage for the PLOT test. 

• Likelihood Ratio represents the weight percentage for the LKV test. 

The settings in the Other Options area specifically affect the Weibull and exponential 
distributions: 
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• Discard if location parameter is less than zero will exclude the Weibull and exponential 
distributions from the ranking if their location parameters are negative. A negative location 
parameter indicates that failures occurred before time = 0, or before a product operated 
for the first time. 

• Discard 3-parameter Weibull if location parameter is less than (_)% of min. time will 
exclude the Weibull distribution from the ranking if the value of the location parameter is 
smaller than the first time-to-failure. The default setting is for a value that is less than 1% of 
the first time-to-failure, which is a value close to zero. 

• Discard Weibull if shape parameter is greater than (_) will exclude the Weibull distribution 
from the ranking if the shape (beta) parameter is greater than a specified value. The default 
setting is to discard the distribution if the beta value is greater than 15. 

Goodness of Fit Results 

The Goodness of Fit Results utility performs statistical tests to determine how well the 
parameters of the distribution fit the data. Note that this utility can only be used to evaluate 
data sets that do not contain censored data. 

To use the utility, first calculate the parameters of the distribution of your data set, and then 
choose Life Data > Options > Goodness of Fit Results. 

 

The following picture shows sample results for a particular data set. 
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• Both the Modified Kolmogorov-Smirnov (K-S) test and the Chi-Squared test return the 
probability that the respective critical value (D_Crit for K-S and χ^2_Crit for chi-squared) is 
less than the calculated statistic value (D statistic for K-S and χ^2 statistic for chi-squared). 
The calculated statistic value is the difference between the observed probability and the 
predicted probability. High probability values, close to 1, indicate that there is a significant 
difference between the theoretical distribution and the data set. In other words, it is an 
indication that the model may not be a good fit for the data. Note that the chi-squared test 
may not produce valid results for smaller sample sizes (e.g., minimum of 35). 

• The P-Value shows the probability that the calculated statistic value is greater than a 
random variable. If the p-value is smaller than your specified level of significance, then the 
model may not be a good fit for the data. 

• The Correlation Coefficient test determines how well the plotted points fit a straight line. 
This test is only available if the parameters were estimated using rank regression. The 
closer the value of rho (ρ) is to 1, the better the linear fit. A value closer to zero would 
indicate that the data points are randomly scattered and have no pattern or correlation to 
the regression line model. 
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Specify Points 

The Specify Points feature enables you to experiment with possible alternative scenarios by 
allowing you to adjust the way that the line is fitted to the points for a rank regression analysis. 
The ranks will be calculated based on all of the data points, but the regression line (which 
determines the parameter estimates) will be fitted only to the points you have specified. Any 
plots or QCP results will be based on the adjusted line, and therefore may be appropriate only 
within the context of your specific "what if" analysis. 

To use the Specify Points feature, first identify the data points that you wish to include in the 
regression line/parameter estimation. In the Weibull++ life data folio data sheet, assign the 
selected data points to a specific subset ID, as shown in the following example. 

 

Note: The subset ID can be any text up to 30 characters, including spaces. For example, "A _ _ 
X" is not the same as "A _ X" where " _ " is used to designate a space. 

Choose Life Data > Options > Specify Points or click the icon on the Main page of the control 
panel. 

 

You will be presented with a list of all the subset IDs in your data sheet as shown next. If you 
have more than one subset ID column in your data sheet, a drop-down list will be available to 
allow you to choose which column to use in the analysis. 
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Double-click the subset ID of the data points you wish to include in the analysis (in this case, it is 
subset ID "Include"). You can also drag the subset ID to the Selected Subset ID column. Click 
OK. 

Next, choose an appropriate distribution for the data set and calculate the parameters. The 
control panel will display the parameters of the regression model and also display a status to 
indicate that the standard analysis method has been altered and the parameters were 
calculated based on a regression line fitted only through the specified data points. 

The overlay plot shown next illustrates the changes to the estimates of the parameters 
between the cases where the three data points are either included or excluded from the 
regression analysis. 
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Fill Median Ranks 

The Fill Median Ranks feature is available only for data sheets that have been configured to 
support free-form data. It enables you to obtain the median ranks for a given set of failure 
times, allowing you to experiment with the unreliability estimates for each failure and see how 
they affect the solution of an analysis. 

To generate median ranks, enter the times-to-failure data in the "X-Axis value" column of the 
data sheet, then choose Life Data > Options > Fill Median Ranks. 

 

For each time-to-failure value in the "X-Axis value" column, the "Y-Axis value" column is filled 
with the corresponding median ranks value. On the control panel, choose a distribution and 
then choose Life Data > Analysis > Calculate or click the icon on the Main page of the control 
panel. 



Chapter 5: Life Data Analysis Folios 

Weibull++ 2020 User's Guide 261 

 

 

The software will compute the parameters of the distribution based on the data set. You can 
use the plots and the QCP to obtain results based on the calculated parameters; however, 
calculations involving confidence bounds are not available. 

The ReliaWiki resource portal has more information on median ranks at: 
http://www.reliawiki.org/index.php/Parameter Estimation. 

Special Analysis Methods 

Mixed Weibull Analysis 

Mixed Weibull analysis (also call multimodal Weibull) is a method that can be used in situations 
when dealing with failure modes that cannot be assumed to be independent (i.e., the 
occurrence of one failure mode affects the probability of occurrence of the other mode) and/or 
when it is not possible to identify the failure mode responsible for each individual data point. 

To use mixed Weibull analysis, you will need to specify how many subpopulations exist in the 
data set (2, 3 or 4). The software will then determine the proportion of units that fall under 
each subpopulation and calculate the Weibull parameters of those subpopulations. The overall 
reliability of the full data set is then calculated by taking the sum of the proportional reliability 
contributions of each subpopulation. 

The ReliaWiki resource portal provides more information about the mixed Weibull distribution 
at http://www.reliawiki.org/index.php/The_Mixed_Weibull_Distribution. 

Tip: If the failure modes are assumed to be statistically independent and the data set can be 
directly categorized into distinct subpopulations, competing failure modes (CFM) analysis may 
be more appropriate. 

Example 

Data sets with mixed populations are often recognized by the "dogleg" or S-shaped curve 
pattern of the data points on a probability plot. For example, consider the following data set. 

Failure Times (in Hours) for 20 Test 
Units 

5.2 140.1 

http://www.reliawiki.org/index.php/Parameter_Estimation
http://www.reliawiki.org/index.php/The_Mixed_Weibull_Distribution
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11.3 150.5 

16.6 166.0 

35.9 186.7 

38.2 188.8 

55.7 191.3 

71.8 198.8 

72 206.7 

116.4 234.3 

135.8 249.8 

When the data set is analyzed with a 2-parameter Weibull distribution and plotted on a 
probability plot, as shown next, the pattern of the data points looks as if it could be modeled by 
two straight lines of different slopes. This indicates the possible existence of subpopulations in 
the data set. 
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Based on the pattern observed on the probability plot, let us assume that there are two 
subpopulations in the data set. To use the mixed Weibull distribution, follow the steps below: 

1. Enter the data from the table into a Weibull++ life data folio. 

2. On the Main page of the control panel, click the Distribution drop-down list. Choose Mixed 
Weibull and then choose the number of subpopulations to consider (for this example, 
choose 2 Subpop-Mixed Weibull). Click Calculate. 

Weibull++ will automatically fit a 2 subpopulation mixture model with Weibull parameters 
and portion values. In the results shown next, Beta[1] and Eta[1] are the parameters that 
were calculated for the first subpopulation. The result showing Portion[1] = 0.6245 means 
that subpopulation 1 comprises 62.45% of the data points. 
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Note: The subpopulation numbers are ordered based on the value of the scale parameter 
(eta). The order is used only to identify the subpopulation and does not affect the analysis. 

3. To view the probability plot of the data set, click the Plot icon on the control panel. The plot 
shows that the 2-subpopulation mixed Weibull distribution provides a better fit to the 
pattern of the data points compared to the 2P- Weibull distribution. You can use the Quick 
Calculation Pad (QCP) to make reliability predictions within the range of the observations; 
however, care must be taken when making projections outside the range of the observed 
failure times (i.e., extrapolation). 
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To visualize the mixed Weibull distribution, choose Pdf Plot in the Plot Type drop-down list. 
The plot shows that from time = 0 to approximately time = 100, the pdf exhibits the 
“decreasing with time” trend characteristic of a Weibull distribution with a beta value less 
than or equal to 1. This region characterizes the contribution of subpopulation 1. From time 
= 100 onward, the pdf exhibits the bell-shaped curve typical of a Weibull distribution with a 
beta value in the vicinity of 5. This region characterizes the contribution of subpopulation 2. 

Note that the mixed Weibull analysis method does not specify which data point belongs to 
which subpopulation. If reliability predictions are needed at the subpopulation level, you 
will need to gather additional information in order to identify which data point belongs to 
which subpopulation. 
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Bayesian-Weibull Analysis 

In Weibull++, the Bayesian-Weibull analysis method combines the concept of Bayesian statistics 
with the properties of the Weibull distribution to make predictions about the life characteristics 
of a product. This type of analysis is particularly useful when there is limited life data for a given 
product or failure mode but there is a strong prior understanding of the failure rate behavior. 

The prior information in the analysis is in the form of a distribution fitted to a range of likely 
beta values. In the context of life data analysis, the beta parameter is used to define the shape 
of the Weibull distribution, which reflects the failure behavior of a product (i.e., whether the 
failure rate increases, decreases or remains constant over time). The range of beta values could 
be obtained from data for a similar product design or from engineering knowledge. When a 
distribution is fitted to the range of beta values, the distribution is called the prior distribution 
of beta and it serves to model the most likely failure behavior of the product. 

The ReliaWiki resource portal provides more information about Bayesian-Weibull analysis at: 
http://www.reliawiki.org/index.php/Bayesian-Weibull Analysis. 

http://www.reliawiki.org/index.php/Bayesian-Weibull_Analysis
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Example 

Take for example a device that was redesigned for improved reliability. A test performed on the 
new design produced only a few failures; however, the same failure modes as the original 
design were observed. To use the Bayesian-Weibull approach, you first need to obtain the prior 
distribution of beta in order to describe the failure behavior observed for the original design. In 
Weibull++, there are four distributions available: normal, lognormal, exponential and uniform. 

The following example shows a range of known beta values obtained from prior analyses of the 
original design. The prior distribution of beta is determined to be a lognormal distribution with 
a log-mean of 0.9064 and a log-standard deviation of 0.3325, as shown next. 

 

Next, collect the current times-to-failure data of the new design and enter the information in a 
new data sheet, as shown next. On the Main page of the control panel, click the Distribution 
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drop-down list and choose Bayesian-Weibull > B-W Lognormal Prior. Click Calculate. A window 
similar to the one shown in the inset will be displayed. 

 

Enter the calculated parameter values of the prior distribution of beta: LogMean = 0.9064 and 
LogStd = 0.3325. Click OK. 

The following figure shows the results of the analysis. 
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Note that instead of a single calculated value for each of the parameters, the parameters of the 
Bayesian-Weibull distribution are distributed. This result is known as a posterior distribution. In 
the example, the result showing that Beta (Median) = 2.3612 means that the median value of 
the posterior distribution of the beta parameter is 2.3612. For convenience, this is used as the 
single point estimate for the beta parameter. 

By default, Weibull++ calculates the point estimates from the median value of the posterior 
distribution. This is because the median value always corresponds to the 50th percentile of a 
distribution. You have the option to change this setting and calculate the mean value of the 
posterior distribution instead; however, note that the mean is not a fixed percentile and this 
could cause issues when comparing results across different data sets. The option to change this 
setting is available on the Analysis page of the control panel when you choose the Bayesian-
Weibull analysis, as shown next. 
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To obtain point estimates of a metric, such as the probability of failure or the reliability at a 
given point in time, use the Quick Calculation Pad (QCP). The QCP will automatically compute 
the metric of interest using the median value of the posterior distribution (or the mean, if you 
switch the setting on the Analysis page of the control panel). 

The following plots show the confidence bounds for the Bayesian-Weibull analysis that 
incorporates the prior information compared to the confidence bounds of a 2-parameter 
Weibull analysis of the new design data only. As you can see, the confidence bounds of the 
Bayesian-Weibull analysis are tighter, which may lead to a more precise analysis of whether the 
redesign improved the life of the device. 
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Confidence bounds of the Bayesian-Weibull analysis 
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Confidence bounds of the 2-parameter Weibull analysis 

Competing Failure Modes (CFM) Analysis 

Often, a product could fail due to any of several possible causes of failure. For a non-repairable 
component, each unit can only fail once; hence, if the occurrence of any one failure mode 
results in a failure of the component, then the failure modes are said to "compete" to cause the 
failure. This can be viewed as a series reliability model, where the overall reliability is equal to 
the product of the reliability equations for all of the failure modes, or: 

 

(1) 

where n is the number of failure modes considered. Note that competing failure modes (CFM) 
analysis can be performed only when the product is non-repairable and when it can be 
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assumed that the failure modes are statistically independent (i.e., the occurrence of one failure 
mode does not affect the probability of occurrence for the other failure modes). Furthermore, 
the Competing Failure Modes option that is built-in to the Weibull++ life data folio supports the 
analysis of up to four competing failure modes and applies the same distribution to analyze all 
of the modes. If your analysis does not fit these conditions, it may be more appropriate to use a 
reliability block diagram (RBD) analysis approach. 

The ReliaWiki resource portal provides more information about competing failure modes 
analysis at: http://www.reliawiki.org/index.php/Competing_Failure_Modes_Analysis. 

Tip: When it is not possible to categorize your data set into distinct modes, mixed Weibull 
analysis may be more appropriate. 

Example 

Consider a water pump that is considered failed when either its gasket or its valve fails. To use 
CFM analysis in a Weibull++ life data folio, you must categorize each failure time into distinct 
subset IDs. The following data sheet shows the categorized failure times. 

 

Note: The subset ID can be any text up to 30 characters, including spaces. For example, "A _ _ 
X" is not the same as "A _ X" where " _ " is used to designate a space. 

On the Main page of the control panel, choose Competing Failure Modes and then choose a 
distribution that is appropriate to analyze the data for each failure mode (for this example, 
choose CFM-Weibull). Next, select MLE as the parameter estimation method and click 
Calculate. You will be presented with a list of all the subset IDs in your data sheet, as in the 
figure shown next. If you have more than one subset ID column in your data sheet, a drop-
down list will be available to allow you to choose which column to use in the analysis. 

http://www.reliawiki.org/index.php/Competing_Failure_Modes_Analysis
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You can define up to four modes to include in the CFM analysis, and each mode can be 
associated with one or more subset IDs. (For example, consider a product with components A, 
B and C, where components B and C are identical, used in two places in the product and 
subjected to identical stresses. In this case, components B and C are expected to exhibit 
identical failure modes; therefore, they can be analyzed together and grouped under a single 
mode for CFM analysis.) 

First, select the subset ID(s) in the Available Subsets column. Then select a mode from the 
Modes column and click the arrow buttons to assign the selected subset ID(s) to the selected 
mode. You can also double-click or drag a subset ID to assign it to a mode. 

Assign "Gasket failure" to "Mode 1" and "Valve failure" to "Mode 2," and then click OK. 
Weibull++ will automatically calculate the parameters for each mode separately. 
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To visualize how each failure mode contributes to the water pump’s overall probability of 
failure, click the Plot icon on the control panel. The solution of the probability line is based on 
Eqn. (1). All other plots and the calculations you perform via the Quick Calculation Pad (QCP) 
are also based on the same equation. 

 

Using Reliability Block Diagrams (RBDs) for Failure Modes Analysis 

As mentioned above, the competing failure modes (CFM) analysis options that are built into the 
Weibull++ life data folio (e.g., CFM-Weibull, CFM-lognormal, etc.) assume a simple series 
reliability model and use only one type of distribution to analyze all the modes. When your 
analysis is more complicated, Weibull++ offers a different method for failure modes analysis. 
The method described next applies in any or all of the following circumstances: 

• The analysis involves more than four failure modes. 

• The failure modes are described by different life distributions. 
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• The relationship between the failure modes does not follow a series configuration. For 
example, if more than one failure mode must occur together in order for the component to 
fail, a parallel configuration must be used for the analysis and this is referred to as 
"complex failure modes analysis" rather than "competing failure modes analysis." 

Example 

Using the same water pump system in the previous example, we'll create an RBD that illustrates 
the relationship between the failure modes. 

The first step is to analyze separately the data due to each mode. When you analyze the data 
set of a particular mode, the failure times for all other competing modes are considered to be 
suspensions. This captures the fact that those units operated for a period of time without 
experiencing the failure mode of interest before they were removed from observation when 
they failed due to another mode. You can easily perform this step via the Batch Auto Run utility. 
To do this, follow the steps below: 

1. In the data sheet that contains the failure times for the gasket and valve, open the Batch 
Auto Run utility by choosing Life Data > Options > Batch Auto Run or by clicking the icon on 
the Main page of the control panel. 

 

2. In the Batch Auto Run window, click the Select All Available button at the bottom of the 
window to automatically include all the modes in the batch auto run process. 

3. Click the Processing Preferences tab and select the option shown next. 
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4. Click OK. The data set for each mode will be extracted to separate data sheets in the folio. 
Select an appropriate distribution for each failure mode and estimate the parameters for 
each separate data sheet. (For this example, use the 2P-Weibull distribution and the MLE 
parameter estimation method for both data sheets). 

5. The next step is to describe the relationships between the failure modes. Add an RBD to the 
project by right-clicking the RBD folder in the current project explorer and choosing Add 
Diagram on the shortcut menu. 

 

This creates a reliability block diagram (RBD) folio, which gives you the ability to create 
blocks that represent the failure modes. You can use arrows to connect the blocks in an 
appropriate configuration to describe the relationship between the failure modes and show 
how each mode can result in a failure for the product. The following RBD shows that the 
water pump will fail if either the gasket or valve fails. 
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Following are brief descriptions on how to build the diagram shown here. For complete 
instructions, see Building Diagrams in Weibull++. 

1. Add a junction block by choosing Diagram > Blocks > Add Junction. The junction block 
serves as a unique starting point for the diagram. 

2. Add blocks by choosing Diagram > Blocks > Add Block. You will be asked to select the data 
sheet of the failure mode that the block will represent. 

3. Add nodes by choosing Diagram > Blocks > Add Node. The nodes act as switches that the 
diagram paths move through. 

4. Add arrows by choosing Diagram > Settings > Connect Blocks. 

5. To analyze the diagram, choose Diagram > Analysis > Analyze or click the icon on the 
control panel of the RBD folio. 

 

All reliability calculations performed via the QCP tool of the RBD folio will be based on the 
resulting reliability equation of the diagram. 
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Tip: ReliaSoft's advanced reliability block diagram software, BlockSim, can handle advanced 
configurations and analyses such as dependent failure modes (i.e., the occurrence of one failure 
mode affects the probability of occurrence of the other modes). 

Fractional Failure Analysis 

You can use fractional failure analysis in Weibull++ life data folios to account for the 
effectiveness of an assumed corrective action or product redesign in your analyses. For 
example, if the fix for a failure is expected to be 70% effective, you can enter the failure count 
as 0.3 (30%) in the data sheet. This allows you to analyze a product's reliability, B10 life or other 
metrics, assuming an implemented fix. 

Example 

The data set used in this example is available in the example database installed with the 
Weibull++ software (called "Weibull20_Examples.rsgz20"). To access this database file, choose 
File > Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder.  

The name of the project is "Standard - Fractional Failures." 

A product underwent a reliability test. The following picture shows the data set as it was 
entered in Weibull++. 

https://www.reliasoft.com/products/reliability-analysis/blocksim
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The analysts believe that the planned design improvements will yield 50% effectiveness. To 
estimate the reliability of the product based on the assumptions about the repair effectiveness, 
they enter the data in groups, counting a 0.5 failure for each group, as shown next. 



Chapter 5: Life Data Analysis Folios 

Weibull++ 2020 User's Guide 281 

 

 

The overlay plot, shown next, compares the changes to the estimates in the parameters 
between the original data set and the data set that includes the repair effectiveness. 
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Non-Parametric Life Data Analysis (LDA) Folios 

NON-PARAMETRIC LDA FOLIO 

Non-parametric life data analysis (LDA) allows you to analyze data sets without assuming an 
underlying life distribution. This technique is useful when dealing with unknown failure modes, 
when there is not enough data to assume a life distribution or when the data set does not fit 
any life distribution in a satisfactory way. Non-parametric methods can give the "big picture" of 
how products are behaving without the level of technical detail that standard (parametric) life 
data analysis provides, and without the risk of errors brought about by making incorrect 
assumptions about the distribution; however, the non-parametric analysis does not provide 
reliability predictions outside of the points of observation (e.g., if failures occurred at 100 and 
200 hours, the analysis will calculate the reliability at those two times, but it cannot be used to 
calculate the reliability at 150 hours). 
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In cases where you might want to estimate (i.e., interpolate) the reliability of a product 
between the points of observation, the non-parametric LDA folio gives you the ability to create 
a parametric model that is based on the analysis. This means that you convert the reliability 
values obtained by the non-parametric analysis into unreliability values, and then fit a 
distribution to the free-form data set (x = time and y = unreliability). The parametric analysis 
allows you to interpolate (and to some extent, extrapolate) the life characteristics of the 
product using the Quick Calculation Pad and a wider variety of plots. 

For more information on non-parametric vs. parametric analysis, please read "Data Analysis 
and Reporting" at: http://www.weibull.com/hotwire/issue44/hottopics44.htm. 

Non-Parametric LDA Folio Data Sheet 

To create a non-parametric LDA folio, choose Home > Insert > Non-Parametric LDA, or right-
click the Life Data folder in the current project explorer and choose Add Non-Parametric LDA 
on the shortcut menu. 

 

Once the folio is created, select a non-parametric analysis method from the Data Type area of 
the control panel. The method you select will determine the columns that appear in the data 
sheet. 

There are three non-parametric analysis methods available: Kaplan-Meier, Actuarial-Simple and 
Actuarial-Standard. In general, the Kaplan-Meier method is recommended for data sets with 
few suspensions, while the Actuarial-Standard and Actuarial-Simple methods are best for cases 
where the data set is mostly suspensions or when working with interval data, provided that 
none of the intervals are overlapping. There are no significant differences in the results 
between the two actuarial methods; however, in some cases, the approximation method of the 
Actuarial-Simple analysis may provide more conservative estimates. The ReliaWiki resource 
portal has more information on these analysis methods at: 
http://www.reliawiki.org/index.php/Non-Parametric Life Data Analysis. 

Kaplan-Meier Analysis 

The following example shows the data sheet for the Kaplan-Meier analysis. The Number in 
State column indicates the number of units in a group, the State F or S column indicates 
whether the units in the group are failures (F) or suspensions (S), and the State End Time 
column records the end time of the interval. 

http://www.weibull.com/hotwire/issue44/hottopics44.htm
http://www.reliawiki.org/index.php/Non-Parametric_Life_Data_Analysis
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Actuarial-Simple Analysis 

The following example shows the data sheet for the Actuarial-Simple analysis. The data sheet 
contains information about the start time and end time of each interval, as well as the number 
of units in each interval that are either failures or suspensions. The Available Units column 
shows the number of units at the start of each interval. The information in this column is 
automatically calculated by the software based on all of the entries in the Number Failed and 
Number Suspended columns. 

 

Actuarial-Standard Analysis 

The following example shows the data sheet for the Actuarial-Standard analysis. The 
calculations are similar to the Actuarial-Simple analysis except that the number of units at the 
start of an interval is reduced by half of the number of suspensions in that interval. This results 
in reliability estimates that may be lower (i.e., more conservative) when compared to the 
results obtained by the Actuarial-Simple method. 

The data sheet contains information about the start time and end time of each interval, as well 
as the number of units in each interval that are either failures or suspensions. The Available 
Units column shows the number of units at the start of the interval and the Adjusted Units 
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column shows the value reduced by half of the number of suspensions. The data in these two 
columns are automatically calculated by the software based on all of the entries in the Number 
Failed and Number Suspended columns. 

 

Control Panel Settings 

The non-parametric LDA folio control panel allows you to configure the analysis settings for the 
data sheet and view/access the results. It consists of multiple pages, each containing options 
for performing particular tasks. This topic focuses on the Main page of the non-parametric LDA 
control panel, which contains the tools you will need to analyze the data set. For more 
information about control panels in general, see Control Panels. 

• The Data Type area allows you to select the non-parametric method for approximating the 
reliability. The method you select will determine the columns that appear in the data sheet. 

• The Calculate Confidence check box allows you to calculate the lower and the upper one-
sided confidence bounds of the reliability estimates at a specified confidence level. Specify 
the desired confidence level in the Level field. Selecting this option also allows you to 
automatically include the confidence bounds in the plot of the analysis. 

• The Life Data Model area contains the settings for creating a parametric model that is 
based on the data set obtained from the non-parametric analysis. These settings have no 
effect on the non-parametric analysis. The options in this area are identical to the ones on 
the control panel of a Weibull++ life data folio, except for the two drop-down lists shown 
next: 
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The two options allow you to choose which values will be fitted with the chosen life 
distribution. 

• Failure time: If you use the Kaplan-Meier analysis, the failure times are the end times 
of the intervals. If you use either the Actuarial-Simple or Actuarial-Standard analysis, 
each failure time may be the start time of the interval, end time of the interval, or the 
average between the start time and end time. 

• Unreliability value: If you select to include confidence bounds for the non-parametric 
analysis, you will have the option to select either the unreliability estimates calculated 
by the non-parametric analysis, or the upper confidence bounds or lower confidence 
bounds of the unreliability estimate. 

When you click the Calculate icon on the control panel, the software analyzes the data set 
based on the chosen non-parametric method. It then automatically performs a separate 
standard life data analysis based on the settings you have specified in the Life Data Model 
area on the control panel. 

• The Non-Parametric Results area allows you to view the reliability estimates calculated by 
the non-parametric analysis and the free-form data set that will be used for parametric 
analysis. Click the Non-Parametric Results (...) button to open the Results window, which 
allows you to view, edit and print the report. 

• The Life Data Results area allows you to view the parameters of the life data model. Click 
the Life Data Results (...) button to open the Results window. You can also click the Quick 
Calculation Pad (QCP) icon on the control panel to obtain results based on the life data 
model, such as the probability of failure or mean life. 

Folio Tools 

The folio tools are arranged on the left side of the Main page of the control panel. Use these 
tools to manage data and experiment with the results of your analysis. 
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  Calculate calculates the reliability estimates based on the chosen non-parametric 
method (i.e., Kaplan-Meier, Actuarial-Simple or Actuarial-Standard). It then performs a 
separate standard (parametric) life data analysis based on the settings in the Life Data 
Model area of the control panel. This tool is also available by choosing Non-Parametric LDA 
> Analysis > Calculate. 

  Plot creates a Reliability vs. Time plot of the non-parametric analysis. The scaling, 
setup, exporting and other features are similar to the options available for other Weibull++ 
plot sheets. Features that are not applicable to this plot will be hidden or disabled. Clicking 
the Plot icon before the folio has been calculated will automatically calculate the folio and 
then plot the data. This tool is also available by choosing Non-Parametric LDA > Analysis > 
Plot. 

  QCP opens the Weibull++ Quick Calculation Pad, which allows you to calculate results, 
such as mean life and probability of failure, based on the results of the standard life data 
analysis. It uses the same calculations that you can perform in a Weibull++ life data folio 
QCP. This tool is also available by choosing Non-Parametric LDA > Analysis > Quick 
Calculation Pad. 

  Distribution Wizard opens the Distribution Wizard, which helps you select the 
distribution that best fits the data set based on the chosen parameter estimation method 
(i.e., RRX or RRY). In the non-parametric LDA folio, the ranking in the Distribution Wizard is 
based on the life data model. This tool is also available by choosing Non-Parametric LDA > 
Analysis > Distribution Wizard. 

  Change Units opens the Change Units window, which allows you to change the units 
for the values in the current data sheet. 

Transferring Data to a Weibull++ Life Data Folio 

The Life Data Model area of the non-parametric LDA control panel gives you the ability to 
create a parametric model that is based on the analysis. In order to assess whether the 
parametric model provides a good fit to the results of the analysis, you can transfer the data to 
a Weibull++ life data folio. Choose Non-Parametric LDA > Transfer Life Data > Transfer Life 
Data to New Folio. 

 

The data will be transferred to a free-form data sheet, where the failure time values will be 
copied to the "X-Axis value" column and the unreliability values will be copied to the "Y-Axis 
value" column. In the life data folio, you could use the plots and other results to evaluate the fit 
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of the distribution to the values from the non-parametric analysis. If the distribution does not 
provide a good fit, you could experiment with other distributions to see which one would 
provide a better fit. Once you have selected an appropriate parametric model, you can use it to 
obtain calculations from the life data folio’s QCP, or to generate other graphical plots in the life 
data folio’s plot sheet. If you use the same analysis settings in both the life data folio and non-
parametric LDA folio, then you will obtain the same results from the QCPs in both folios. 

NON-PARAMETRIC LIFE DATA ANALYSIS EXAMPLE 

The data set used in this example is available in the example database installed with the 
Weibull++ software (called "Weibull20_Examples.rsgz20"). To access this database file, choose 
File > Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder.  

The name of the project is "Non-Parametric LDA - Three Methods" and the folio that contains 
the data is called "Kaplan-Meier." 

An analyst is performing a field test for a prototype product. A group of 21 participants agreed 
to test the product and all participants are to return after appointed periods of time to report 
their experience with the product. 

Units that are reported to have malfunctioned during the test period are marked as failed (F), 
while units that did not exhibit any problems are marked as suspensions (S). At the end of the 
41-week test, the analyst's log shows the following information. The objective is to create a 
Reliability vs. Time plot in order to predict the failure rate behavior of the product. 

Number of Units State (F or S) Test Period (Weeks) 

3 F 9 

1 S 9 

1 F 11 

1 S 12 

1 F 13 

1 S 13 

1 S 15 

1 F 17 

1 F 21 

1 S 22 

1 S 24 
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1 S 26 

1 F 28 

1 F 30 

1 S 32 

2 S 35 

1 S 39 

1 S 41 

Create a Non-Parametric LDA Folio 

1. On the Home tab, click the Non-Parametric LDA icon in the Insert gallery. 

 

2. On the Main page of the control panel, choose the Kaplan-Meier analysis. This will format 
the data sheet correctly for the non-parametric analysis. Select the Calculate Confidence 
check box and enter 0.95 for the confidence level. 

3. Click the Change Units icon. 

 

In the Change Units window, change the time unit to Week. Click OK. 

4. Enter the information from the table into the data sheet. 

5. The non-parametric LDA folio will obtain the reliability estimates only for the failure times 
that were entered in the data sheet (in this example, it is for weeks 9, 11, 13, 17, 21, 28 and 
30). In order to estimate the reliability of the product at other times, you will need to 
create a parametric model. To do this, make the following selections in the Life Data Model 
area of the control panel: 

• 2P-Weibull. 

• RRY (Rank Regression on Y). 

• Use Unreliability. This means that the free-form data set will be based on the 
unreliability estimates calculated from the non-parametric analysis, rather than the 
upper or lower confidence bound. 

The following picture shows the completed setup. 
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Analyze the Data Set 

6. Choose Non-Parametric LDA > Analysis > Calculate or click the icon on the control panel. 

 

The software will perform a non-parametric analysis on the data set, and then 
automatically perform a separate standard life data analysis based on the settings specified 
in the Life Data Model area. 

7. To create the Reliability vs. Time plot, choose Non-Parametric LDA > Analysis > Plot or click 
the icon on the control panel. 

 

In the following example, the dots on the plot show the reliability estimates at each point 
of failure, the triangles show the lower 1-sided confidence bounds of the estimates, and the 
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inverted triangles show the upper 1-sided confidence bounds. The pattern of the data 
points shows that the product exhibits a sharp decline in reliability over the course of a few 
weeks. 

 

8. Click the Non-Parametric Results (...) button on the control panel to open the Results 
window, as shown next. The results show that the reliability of the product at 9 weeks of 
operation is estimated to be 85.71%; however, by 30 weeks, the reliability estimate is 
44.81% and may be as low as 24.91%. 
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Evaluate the Life Data Model 

To assess whether the assumed distribution (that was chosen in the Life Data Model area of the 
control panel) provides a good fit, transfer the results of the non-parametric analysis to a 
Weibull++ life data folio. 

9. Choose Non-Parametric LDA > Transfer Life Data > Transfer Life Data to New Folio. 

 

The data will be transferred to a free-form data sheet, where the failure time values will be 
copied to the “X-Axis value” column and the unreliability values will be copied to the "Y-
Axis value" column. 

In the life data folio, select the same analysis settings that you chose in the non-parametric 
LDA folio (i.e., 2P-Weibull and RRY), and then click the Calculate icon on the control panel. 
The following picture shows the completed analysis. 
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10. Click the Plot icon on the control panel. The following probability plot shows the probability 
line with respect to the values obtained from the non-parametric analysis. As you can see, 
the 2P-Weibull provides a good fit to the values. If the distribution did not provide a good 
fit, you could experiment with other distributions to see which one would provide a better 
fit. Once you have selected an appropriate parametric model, you can use it to obtain 
calculations from the Quick Calculation Pad (QCP). 
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Obtain Results for Other Points in Time 

To obtain a reliability estimate at a time that was not calculated in the non-parametric analysis, 
say, 25 weeks, use the Quick Calculation Pad (QCP). You can use the QCP either from the life 
data folio with the transferred data or from the non-parametric LDA folio. If you use the same 
analysis settings (i.e., distribution, parameter estimation method) in both the life data folio and 
non-parametric LDA folio, then you will obtain the same results from the QCPs in both folios. 

1. Click the QCP icon on the control panel. 

 

2. In the QCP, choose to calculate the Reliability. Select Week for the time units and then 
enter 25 for the mission end time. Click Calculate to display the results. The reliability is 
estimated to be 55.2436%, as shown next. 
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Note: Confidence bounds calculations are not available for free-form data. 

 

Warranty Analysis Folios 

WARRANTY ANALYSIS FOLIOS 

Warranty claims data typically consist of quantities of units sold and quantities returned within 
a specified warranty period. The Weibull++ warranty analysis folio is designed to convert your 
existing warranty claims data sets into failure/suspension data sets, so that they can be easily 
analyzed with traditional life data analysis methods. In addition, the folio gives you the ability to 
predict future warranty returns in order to detect and correct potential product quality 
problems in the field, as well as plan for warranty fulfillment needs such as repair costs and the 
number of spares to stock. 
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The ReliaWiki resource portal has more information on warranty analysis at: 
http://www.reliawiki.org/index.php/Warranty_Data_Analysis. 

WARRANTY ANALYSIS FOLIO SETUP 

  

To add a warranty analysis folio to a project, choose Home > Insert > Warranty, or right-click 
the Warranty folder in the current project explorer and choose Add Warranty on the shortcut 
menu. 

 

In the setup window, select a format to use with the folio. You must select the format that is 
appropriate for the type of warranty claims data you have available. If you select the Nevada 
chart format, click Next to go to the next step to configure your analysis; otherwise, click OK to 
immediately create the folio. 

Converting Formats 

You can convert the format of an existing warranty analysis folio to a another format. To do so, 
open the existing folio and choose Warranty > Tools > Convert Data, and then choose the 
format to convert to. (The data in the existing folio must already be analyzed in order for the 
command to become available.) 

Converting formats creates a new folio and does not overwrite the contents of the existing 
folio. It is an automatic process, except when converting from the dates of failure format to the 
Nevada chart format, and vice versa. In that case, you will be prompted to define the time unit 
of each period (e.g., dates, month or years) in order to proceed with the conversion. 

Below is a summary of the data conversion options: 

From Convert To 

Nevada Chart Format Dates of Failure Format 

Times-to-Failure Format 

Dates of Failure Format Nevada Chart Format 

Times-to-Failure Format 

Times-to-Failure Format N/A 

Usage Format Times-to-Failure Format 

http://www.reliawiki.org/index.php/Warranty_Data_Analysis
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Control Panel Settings 

This section focuses on the warranty folio control panel, which contains most of the tools you 
need to perform a warranty analysis. For more information about control panels in general, see 
Control Panels. 

The warranty control panel consists of the following pages: 

• The Main page contains all the tools you will need to perform a warranty analysis. These 
tools are described in the next section below. 

• The Analysis page contains the settings that are also displayed on the Main page of the 
control panel. 

• The Comments page allows you to enter notes or other text that will be saved with the 
folio. 

• The Statistical Process Control page is available only for the Nevada chart format. It 
contains optional tools for monitoring warranty returns data. 

• The Suspensions page is available only for the usage format. It contains the settings for 
estimating the amount of usage for fielded units. 

Control Panel Main Page 

• The Life Data Model area contains the options for performing life data analysis. When you 
click Calculate, Weibull++ converts the warranty claims data into failure/suspension data 
and then performs a life data analysis based on the settings you specified in this area. 

• Use Subsets gives you the option to analyze multi-population data sets. To use this 
setting, you must first assign each subpopulation group in your data sheet to a specific 
subset ID. Select the Use Subsets check box, and then use the drop-down list to switch 
between the subset IDs and alter the analysis settings (i.e., distribution and parameter 
estimation method) for each one. When you click Calculate, the software will 
separately analyze each subset of data. You can view the parameters of each subset ID 
by choosing the subset ID from the drop-down list or by clicking the Results Report icon 

 in the Analysis Summary area. 

• The Suspend After check box allows you to specify a period beyond which the data are 
considered incomplete. For example, consider a shipment that has been in the field for 14 
months. If the warranty period is 12 months, then the failures entered in the data sheet for 
months 13 and 14 are taken into account, but all remaining units in that shipment period 
are suspended at 12 months. Note that: 
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• In the Nevada chart format, the warranty period uses the same time units used in the 
Nevada chart data sheets. 

• In the dates of failure format, you can specify the warranty period to be in days, 
months or years. 

• In the usage format, you have two options: a) specify the warranty period to be in days, 
month or years, or b) consider a warranty period based on usage (e.g., 100K miles or 10 
years, whichever comes first). 

• This option is not available for the times-to-failure format. 

• The Analysis Summary area displays the results of the life data analysis. This includes the 
parameters of the selected distribution, the rho and/or LK value (when applicable), and the 
number of failures and suspensions in the converted data set (includes failures at t = 0, but 
excludes suspensions at t = 0). Click the Results Report icon   to open the Results 
window, which shows the results in a worksheet that you can copy or print. 

• The End of Observation Period setting is available only in the dates of failure format and 
usage format. It is used to determine the time in service for each unit that had not yet been 
returned by the end of the observation period (i.e., the suspensions). The date is typically 
set to the last day the warranty data was collected. 

• The Suspensions Estimation Method area is available only in the usage format. It displays 
information about how the product usage is defined. Clicking the link will take you to the 
Suspensions page of the control panel, which contains the options for estimating the 
amount of usage accumulated by suspensions. 

Folio Tools 

The folio tools are arranged on the left side of the Main page of the control panel. Use these 
tools to manage data and experiment with the results of your analysis. 

  Calculate converts the warranty claims data to failure/suspension times and then 
estimates the parameters of the chosen life distribution based on the converted data. If 
you select the Use Subsets option on the Main page of the control panel, the parameters of 
the distribution of each subset ID will be calculated. This tool is also available by choosing 
Warranty > Analysis > Calculate. 

  Plot creates a new sheet in the folio that provides a choice of applicable plot types. In 
warranty analysis folios, this includes plots such as expected failures vs. period, reliability 
vs. time, probability plot, etc. You can plot the data in the warranty analysis folio either 
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with or without generating a forecast. This tool is also available by choosing Warranty > 
Analysis > Plot. 

  Distribution Wizard opens the Distribution Wizard, which helps you select the 
distribution that best fits your data based on the selected parameter estimation method 
(i.e., RRX, RRY or MLE). In warranty analysis folios, the ranking in the Distribution Wizard is 
based on the converted failure/suspension times. This tool is also available by choosing 
Warranty > Analysis > Distribution Wizard. 

  QCP opens the Quick Calculation Pad, which allows you to calculate life data analysis 
metrics. It uses the same calculations that you can perform in a Weibull++ life data folio 
QCP. This tool is also available by choosing Warranty > Analysis > Quick Calculation Pad. 

  Forecast opens the Forecast Setup window, which allows you to specify the time 
periods at which you wish to estimate the number of expected warranty returns. Clicking 
Forecast before the parameters have been calculated will automatically calculate the 
parameters and open the Forecast Setup window. This tool is also available by choosing 
Warranty > Tools > Forecast. 

  Folio Setup is available only for the Nevada chart format. It opens the Nevada Chart 
Setup window, which allows you to change the time periods of the warranty claims data in 
the current data sheet. 

  Change Units opens the Change Units window, which allows you to select the units to 
use in the data sheet. This tool is not available in the dates of failure format. The units that 
are available in the drop-down list are defined at the database level. Note that: 

• In the Nevada chart format, this tool is available only when you choose to label the 
sales and returns periods in terms of numbers during the setup process. See Nevada 
Chart Setup. 

• In the usage format, only the units that are related to usage (e.g., cycles, miles, etc.) are 
available in the drop-down list. 

• In the times-to-failure format, all the time units that were defined at the database level 
are available in the drop-down list. 
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Warranty Data Formats 

Nevada Chart Format 

If you keep track of the period in which each returned unit was sold and the period in which it 
was returned, you can use the Nevada chart format to convert your warranty claims data into 
failure/suspension data. 

Nevada Chart Setup 

The setup window of the Nevada chart format allows you to define the time periods of interest. 
The time unit may be measured in days, months, years, or by using a unit-less number. 

• The Sales and Failures/Returns areas allows you to define the number of sales and return 
periods. The Increment field indicates the length of the time period. In the following 
picture, the time unit is in terms of months; therefore, an increment of 1 would mean that 
1 period is equivalent to 1 month, while an increment of 2 would mean that 1 period is 
equivalent to 2 months. 

• The Future Sales area allows you to define the number of future sales periods. This setting 
will include additional rows in the Sales data sheet for entering the projected sales figures. 
Information regarding future sales is used only in the forecast analysis. 

• The Allow Returns at Time = 0 check box allows you to include zero-time failures in the 
analysis, which are failures that occurred before the units made it to the field. These 
failures may be due to manufacturing defects, insufficient quality control or shipping 
damages. 
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Time Units 

In the Nevada chart format, you can change the time periods for an existing Nevada chart data 
sheet at any time. Note, however, that changing the time period only changes the name of the 
unit; the data set is not converted to the new unit. 

There are two ways to change the time periods: 

• If the periods are labeled in terms of days, months or years, choose Warranty > Tools > 
Data Sheet Setup or click the icon on the control panel. This opens the Warranty Folio 
Setup window, which allows you to edit the time periods. Note that when you change the 
existing setup, you may lose information already entered in the data sheet. 

 

• If the periods are labeled in terms of numbers, click the Change Units icon on the Main 
page of the control panel of the data sheet. This opens the Change Units window, which 
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gives you a selection of units to use. The units that are available in the drop-down list are 
defined at the database level. 

 

Data Sheets 

The Nevada chart folio consists of two data sheets: Sales and Returns. 

In the Sales data sheet: 

• The Period column shows the time periods that were defined during setup. 

• The Quantity In-Service column indicates the number of units that are assumed to have 
started operating during each period. The general term in-service represents the closest 
estimate of the time at which each unit started operating in the field. For example, if you 
have access to both the manufacturing date and the shipping date for a group of parts, you 
may choose to perform the analysis based on the shipping date because it is a closer 
indicator of the time the product started operating in the field. 

• The Subset ID column is for logging any pertinent information or comments about the data. 
You can also use the Subset ID column to categorize subpopulations in your data set. You 
will be able to choose a distribution appropriate for each subset of data by selecting the 
Use Subsets option on the Main page of the control panel. 

Note: The subset ID can be any text up to 30 characters, including spaces. For example, "A _ 
_ X" is not the same as "A _ X" where "_ " is used to designate a space. 

• If you entered future sales periods during setup, yellow rows will be added in the data 
sheet to identify the future sales data. The projected sales figures will be used in the 
forecast analysis. 

 

In the Returns data sheet: 

• The column headings represent the warranty periods 
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• The row headings represent the sales periods 

In the example shown here, there were 3 returns in February from the batch that was in-service 
in January. In March, 5 more units from the batch that was in-service in January were returned 
and 2 units from the batch that was in-service in February were also returned. The rest of the 
chart can be read in a similar manner. 

 

Zero-Time Failures 

In many cases, it is possible for failures to occur immediately at the beginning of the life of the 
unit. These types of failures are known as out-of-the-box failures or zero-time failures. 
Examples are products that failed quality inspections prior to shipping or were damaged during 
shipping and then returned within the same period they were sold. 

To include zero-time failures in the Nevada chart warranty analysis, select the check box during 
setup and set the return start date to be the same as the sales start date, as shown in the 
following example. 

 

When you enable this setting and click OK, the Returns sheet will allow you to enter returns for 
the same month in which the units were in-service, as shown next. In this example, 5 units from 
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the January sales were damaged during shipping and were returned within the January sales 
period. These 5 failures will be treated as zero-time failures. In February, 3 units were also 
returned within the February sales period. These 3 failures are also zero-time failures. The rest 
of the chart can be read in a similar manner. 

 

When you calculate the parameters and view the results report, the converted data set will 
contain a certain number of data points with failures at time = 0, as shown in the next example. 
Pnz represents the proportion of the population with non-zero failure times. In this sample 
report, the percentage of the population with non-zero failure times is approximately 
95.3871%. The Fail/Susp field shows the total number of failures and suspensions in the data 
set (including failures at t = 0 but excluding suspensions at t = 0). 
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The distribution parameters are calculated without the zero-time failures, but any subsequent 
reliability calculations for the full data set will be multiplied by the Pnz value, such that: 

 

where R’(t) is the reliability function for the entire data set and R(t) is the reliability function for 
the data set without the zero-time failures. Therefore, when Pnz is equal to 1, all the failures 
are assumed to occur after time = 0. 

The following overlay plot illustrates the effect of the Pnz value on the reliability function. The 
straight line is the unreliability function for the set of non-zero failure and suspension times. 
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The inclusion of the zero-time failures causes the unreliability function to curve towards the 
value of unreliability at time = 0, which is 1-Pnz. 

When you use the Quick Calculation Pad (QCP), the reliability, unreliability and probability 
density calculations of the entire data set are influenced by the value of Pnz, while the 
conditional reliability and failure rate functions are not affected. 

 

Statistical Process Control 

The Nevada chart format includes a statistical process control (SPC) method for analyzing 
warranty returns data. The SPC method evaluates the discrepancy between the actual number 
of failures and the number of failures predicted by the distribution parameters. It uses a chi-
squared test to help you detect unusually high or low return rates for any given period, alerting 
you to any possible deviations in manufacturing, quality control or any other factors that may 
adversely affect the reliability of the product in the field. This enables you to intervene 
immediately and avoid increased warranty costs or more serious repercussions. The SPC 
application is available only for the Nevada chart format. 
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Note: The SPC feature applies only to homogeneous data sets and is therefore unavailable 
when you select the Use Subsets option on the Main page of the control panel. 

To use SPC, click the Statistical Process Control page icon on the control panel. 

 

1. Select the Calculate chi-squared values check box, and then enter the desired control 
values into the Critical and Caution fields in decimal form. 

The control values are the upper probability levels of the chi-squared distribution below 
which the sales or return periods will be flagged as outliers. The values must be greater 
than zero and less than one. By default, the critical value is 1% and the caution value is 
10%. 

2. Select the Color-code Returns sheet check box to highlight the results. You can select to 
evaluate the results By sales period (results are color-coded by rows) or By returns period 
(results are color-coded by columns). 

• Green indicates that the number of product returns is within the expected range. 

• Yellow indicates that the number of product returns is between the caution and critical 
levels. 

• Red indicates that the number of product returns is outside the expected range. 

3. If you have manually changed the colors of any cells, click the Restore Guide Colors button 
to return the cells to their original colors. 

Tip: If you wish to perform a manual evaluation of the table of chi-squared values, you can use 
Weibull++’s Quick Statistical Reference (QSR) tool to look up chi-squared values for different 
control values and degrees of freedom. You can access the QSR by choosing Home > ReliaSoft > 
Quick Tools > Quick Statistical Reference. 

Example of a Nevada Chart Warranty Analysis 

The data set used in this example is available in the example database installed with the 
Weibull++ software (called "Weibull20_Examples.rsgz20"). To access this database file, choose 
File > Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder.  

The name of the project is "Warranty - Nevada Chart Format with Statistical Process Control." 
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An electronics manufacturer wants to study the expected number of returns for a product they 
created using materials obtained from two suppliers. The sales and returns data for the product 
are collected and entered into a Nevada chart warranty analysis folio, as shown next. 
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Analyze the Data Set Using the Statistical Process Control (SPC) Method 

1. On the Main page of the control panel, choose the 2P-Weibull distribution and the MLE 
parameter estimation method. 

2. On the Statistical Process Control page of the control panel, select the Calculate chi-
squared values check box. Make sure that the critical value is 0.01 and that the caution 
value is 0.1. 

3. Select the Color-code Returns sheet check box and select the By sales period option. 

4. Choose Warranty > Analysis > Calculate or click the Calculate icon on the Main page of the 
control panel. 

The parameters are estimated to be: beta = 2.3181 and eta = 25.0719. Notice that in the 
Returns sheet, the March and July sales periods are in yellow. This means that the number 
of returns for those sales periods is between the caution and critical levels. 

5. Click the Plot icon. From the Plot Type drop-down list, choose Chi-Squared - Sales. The plot 
shows that the data points for March and July are between the caution and critical levels. 
This implies that the population is not homogeneous and that different subpopulations may 
exist in the data. One suspected reason for the deviation may be the type of material used 
by the suppliers. The manufacturer concludes that the data set needs to be analyzed based 
on their material supplier. 
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Analyze the Data Set Based on Suppliers 

6. Return to the Sales or Returns data sheet. On the Main page of the control panel, select the 
Use Subsets check box. Note that selecting this option will make the SPC feature 
unavailable. For each subset ID, select the 2P-Weibull distribution and the MLE parameter 
estimation method. 

7. Click the Calculate icon to recalculate the parameters. The results show that for Supplier 1, 
the parameters are beta = 2.3819 and eta = 25.3976; for Supplier 2, the parameters are 
beta = 2.3207 and eta = 21.2829. 

8. Click the Plot icon. The following plot shows the probability of failure of the two subsets. 
The plot shows that the material from Supplier 2 tends to have a higher probability of 
failure compared to the material from Supplier 1. 
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9. To determine the statistical difference between the two data sets, create a contour plot. 
Click the Plot Type drop-down list on the control panel and choose Contour Plot. In the 
Contour Setup window, select to plot the contours at the 90% confidence level and click 
OK. 

The resulting plot shows that the two subsets do not overlap at the 90% confidence level. 
This confirms that the two data sets are significantly different at the 90% confidence level. 
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Generate a Warranty Forecast 

The next step is to generate a warranty forecast to obtain the expected number of product 
returns within a specified warranty period. 

10. Return to the Sales or Returns data sheet. Choose Warranty > Tools > Forecast or click the 
icon on the control panel. 

 

11. In the Forecast Setup window, set the forecast range to start in October and end after 4 
forecast periods, as shown next. Set the Increment to 1 and click OK. 
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The following figure shows the Forecast sheet with the warranty period starting in October 
2019 and ending in January 2020. The results show that the highest number of product 
returns is expected to come from the batch that was in-service in March. 

 

12. Click the Plot icon on the control panel of the Forecast sheet. On the Plot Type drop-down 
list, choose Expected Failures. The following plot shows the expected number of returned 
units over the warranty period. 

Earlier, we found out that the material from Supplier 2 tends to have a higher probability of 
failure when compared to the material from Supplier 1. However, the current plot shows 
that Supplier 1 is expected to have a higher number of total returns within the specified 
warranty period. Looking back at the Sales sheet, we can see that the manufacturer sold 
three times more units made with materials from Supplier 1 compared to the number of 
sold units using materials from Supplier 2. Therefore, more units made with the materials 
from Supplier 1 will be returned each month due to the high sales volume of those units. 



Chapter 5: Life Data Analysis Folios 

314 https://www.reliasoft.com/weibull 

 

This forecast analysis can help the manufacturer plan for warranty costs and service, as well 
as plan for the number of units to produce using materials from each supplier and decide 
whether it would be worthwhile to have Supplier 2 increase the reliability of its materials. 

 

Times-to-Failure Format 

If your warranty claims data are already in terms of failure/suspension times, you can use the 
times-to-failure format to forecast future warranty returns. 

Time Units 

In the times-to-failure format, you can use any time units appropriate for your data by clicking 
the Change Units icon on the Main page of the folio's control panel. 
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This opens the Change Units window, which gives you a selection of units to use. The units that 
are available in the drop-down list are defined at the database level. When you select new 
units, the appropriate columns in the data sheet will be automatically configured for the units 
you selected, and the new unit will be displayed next to the results in the control panel. 

Data Sheets 

The times-to-failure format consists of two data sheets: Data and Future Sales. 

In the data sheet: 

• Data entry is similar to entering data in a Weibull++ life data folio. 

• The Subset ID column is for logging any pertinent information or comments about the data. 
You can also use the Subset ID column to categorize subpopulations in your data set. You 
will be able to choose a distribution appropriate for each subset of data by selecting the 
Use Subsets option on the Main page of the control panel. 

Note: The subset ID can be any text up to 30 characters, including spaces. For example, "A _ 
_ X" is not the same as "A _ X" where "_ " is used to designate a space. 

 

In the Future Sales sheet: 

• The Quantity In-Service column is for recording the projected number of units to be sold. 
This information is used in the forecast analysis. 

• The Time column is for logging the anticipated manufacturing/sales/shipment period. 
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Example of a Times-to-Failure Warranty Analysis 

A manufacturer sold two versions of a product. In addition, they plan to sell more of the 
product in the next few months. The objective is to analyze the data for both product versions 
and provide a return forecast for the next 10 months. 

The following data sheet shows the data for the product. The return period (State End Time) is 
measured in months. The manufacturer logs the number of failures and suspensions for each 
product version at the end of each month. 

 

In the Future Sales data sheet, they enter the number of units they plan to ship to stores in the 
next 9th and 10th months, as shown next. 
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Analyze the Data for Each Product Version 

1. On the Main page of the control panel, select the Use Subsets option. Then for each subset 
ID, choose the 2P-Weibull distribution and the MLE analysis method. Click Calculate. 

• The parameters for V1 are estimated to be: beta = 2.3819 and eta = 25.3976. 

• The parameters for V2 are estimated to be: beta = 2.3207 and eta = 21.2829. 

2. On the control panel, click the Plot icon. The following plot shows the probability of failure 
of the two product versions. It shows that V2 has a higher probability of failure compared 
to V1. 
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Generate a Warranty Forecast 

The next step is to generate a warranty forecast to predict the expected number of product 
returns. 

3. Return to the data sheet and choose Warranty > Tools > Forecast or click the icon on the 
control panel. 

 

4. In the Forecast Setup window, set the increment to 1 and set the forecast length to 10 
periods, as shown next. Click OK. 
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5. On the control panel of the Forecast sheet, select the Show Subset ID check box. The 
following figure shows the results (showing only the first 8 columns). 

 

The intervals in the warranty period are indicated by the Current Age plus the increment 
that was specified in the Forecast Setup window. In the sheet shown above, the first row in 
the data sheet tells us that 1108 (Number in State) units were operating in the field when 
the warranty period started and that these unit will have survived at least 1 month (Current 
Age) of operation. In the 2nd month of operation (Current Age+1), 2 units from that batch 
are expected to fail. After 4 months of operation (Current Age+3), 7 more units from the 
batch are expected to fail, and so on. Note that the last 4 rows of the Forecast sheet will 
show the expected number of returns from the future sales. (In this example, the returns 
are expected to start at Current Age+10.) 
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6. Click the Plot icon on the control panel of the Forecast sheet. In the Plot Type drop-down 
field, choose Expected Failures. The following plot shows the trend in the expected number 
of failures over the next 10 periods. This forecast analysis can help the manufacturer 
predict the failure behavior of each product version in the field, as well as plan for the 
warranty costs and service for each product version. 

 

Dates of Failure Format 

If you keep track of the exact calendar dates for sales and returns, you can use the Dates of 
Failure format to convert your warranty claims data into failure/suspension data. 
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Time Units 

In the dates of failure format, the inputs and results are in terms of days, where 1 day = 24 
hours; however, you have the option to obtain the results based on a different ratio, such as 1 
day = 8 hours. The new ratio for the day unit will need to be defined at the database level. 

Data Sheets 

The dates of failure format consists of three data sheets: Sales, Returns and Future Sales. 

Note: For the column headings in this sheet, the general term in-service represents the closest 
estimate of the time at which each unit started operating in the field. For example, if you have 
access to both the manufacturing date and the shipping date for a group of parts, you may 
choose to perform the analysis based on the shipping date because it is a closer indicator of the 
time the product started operating in the field. 

In the Sales sheet: 

• The Quantity In-Service column indicates the number of units that are assumed to have 
started operating during each period. 

• The Date In-Service column is for entering the calendar date on which the units are 
assumed to have started operating. 

• The Subset ID column is for logging any pertinent information or comments about the data. 
You can also use the Subset ID column to categorize subpopulations in your data sets. You 
will be able to choose a distribution appropriate for each subset of data by selecting the 
Use Subsets option on the Main page of the control panel. 

Note: The subset ID can be any text up to 30 characters, including spaces. For example, "A _ 
_ X" is not the same as "A _ X" where "_ " is used to designate a space. 

 

In the Returns sheet: 
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• The Quantity Returned column indicates the number of units that were returned. 

• The Date of Return column indicates the date the units were returned. 

• The Date In-Service column indicates how long the units were in service before they were 
returned. Each entry in the Date In-Service column in the Returns sheet must have a 
matching entry in the Date In-Service column in the Sales sheet. 

 

In the Future Sales sheet: 

• The Quantity In-Service column is for recording the projected number of units to be sold. 
This information is used in the forecast analysis. 

• The Date In-Service column is for logging the anticipated manufacturing/sales/shipment 
period. 

 

End of Observation Period 

In the dates-of-failure format, the End of Observation Period setting on the Main page of the 
control panel is used to convert the sales/return data to failures/suspensions. The date is 
typically set to the last day the warranty data was collected. It is used to determine the time in 
service for each unit that had not yet been returned by the end of the observation period. The 
time in service for a particular suspension unit is equal to the End of Observation Period date 
minus the Date In-Service of the unit. 
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To automatically set the end date to the last day the warranty data were collected, click Auto 
Set, as shown next. This may be the latest date that appears on the Sales sheet or the latest 
date that appears on the Returns sheet, whichever is more recent. 

 

Example of a Dates of Failure Warranty Analysis 

A manufacturer sold two versions of a product. In addition, a new version is planned for future 
release. The objective is to analyze the data for all versions and provide a return forecast for 
the next 20 months. 

The following data sheet shows the sales data. 

 

The following data sheet shows the returns data. 
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The future shipments are expected to be as follows. 

 

Analyze the Data for Each Product Version 

1. The information in the Returns sheet is current as of January 31, 2019. Therefore, on the 
Main page of the control panel, set the End of Observation Period date to 1/31/2019 to 
indicate that the warranty data collection period ended on that date. 

2. To analyze each product, select the Use Subsets option on the Main page of the control 
panel. For all subset IDs, choose the Lognormal distribution and the MLE analysis method. 

3. Click Calculate. You will be prompted to enter the parameters of Design C. Because Design 
C is a future product and no returns have been experienced yet, you will need to define its 
failure behavior. Information from the company’s test data indicate that Design C follows a 
lognormal distribution with a log-mean = 11 and log-std = 2.2 days. Enter these values in 
the input window, as shown next. 



Chapter 5: Life Data Analysis Folios 

Weibull++ 2020 User's Guide 325 

 

 

Note: Because the unit of time in the dates of failure format is in days, the parameters that 
are assigned to a data set must also be in terms of days. 

4. Click OK. The results show that for Design A, the parameters are: log-mean = 8.4394 and 
log-std = 2.2311; for Design B, the parameters are: log-mean = 10.0772 and log-std = 
2.2973. 

Generate a Warranty Forecast 

The next step is to generate a warranty forecast to predict the expected number of product 
returns. 

5. Choose Warranty > Tools > Forecast or click the icon on the control panel. 

 

6. In the Forecast Setup window, enter a Start date of 3/1/2019 and obtain forecasts for 20 
periods, as shown next. Set the increment to once per month, and then click OK. 
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7. On the control panel of the Forecast sheet, select the Show Subset ID check box. The 
following figure shows the Forecast sheet with the first 4 months of expected product 
returns. The first row of the Forecast sheet tells us that 200 units of Design A were sold on 
1/1/2018 and that 1 of those sold units is expected to fail between February 1, 2018 (the 
day after the End of Observation Period date) and March 1, 2018. 
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8. On the control panel of the Forecast sheet, click the Plot icon. In the Plot Type field, choose 
Expected Failures. The following plot shows the total number of expected failures from 
each design version over the next 20 months. This forecast analysis can help the 
manufacturer predict the failure behavior of each product version in the field, as well as 
plan for the warranty costs and service for each product version. 
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Usage Format 

In the usage format, the analysis is based on the amount of usage the unit accumulated rather 
than the amount of time the unit was in the field. There are many applications where usage, 
not time, affects a product’s reliability. In the automotive industry, for example, the majority of 
failure behavior is based on mileage rather than product age. This approach could also be used 
in other situations, such as the number of pages for a printer, number of cycles for a washing 
machine, etc. 

What’s Changed? Starting in Version 2019, when forecasting warranty returns, you can predict 
the number of failures based on the time and usage as well as the time. For example, for a 
vehicle with a 3-year/30,000 mile warranty, you can forecast the total number of warranty 
returns based on both values. 
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Units 

In the usage format, you can use any usage units (e.g., miles, cycles, etc.) appropriate for your 
data by clicking the Change Units icon on the Main page of the folio's control panel. 

 

This opens the Change Units window, which gives you a selection of units to use. The units that 
are available in the drop-down list are defined at the database level. Note that in the usage 
format, selecting a new unit only changes the name of the unit; the data set is not converted to 
the new unit. The appropriate columns in the data sheet will be automatically configured for 
the units you selected, and the new unit will be displayed next to the results in the control 
panel. 

Data Sheets 

The usage format consists of three data sheets: Sales, Returns and Future Sales. 

Note: For the column headings in this sheet, the general term in-service represents the closest 
estimate of the time at which each unit started operating in the field. For example, if you have 
access to both the manufacturing date and the shipping date for a group of parts, you may 
choose to perform the analysis based on the shipping date because it is a closer indicator of the 
time the product started operating in the field. 

In the Sales sheet: 

• The Quantity In-Service column is for entering the number of units that are assumed to 
have started operating during each period. 

• The Date In-Service column is for entering the calendar date on which the units are 
assumed to have started operating. 

• The Subset ID column is for logging any pertinent information or comments about the data. 
You can also use the Subset ID column to categorize subpopulations in your data sets. You 
will be able to choose a distribution appropriate for each subset of data by selecting the 
Use Subsets option on the Main page of the control panel. 

Note: The subset ID can be any text up to 30 characters, including spaces. For example, "A _ 
_ X" is not the same as "A _ X" where "_ " is used to designate a space. 
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In the Returns sheet: 

• The Quantity Returned column is for entering the number of units returned. 

• The Usage at Return Date column indicates the amount usage the units accumulated 
before they were returned. In the following example, the usage unit is in terms of cycles. 

• The Date-In-Service column indicates how long the units were in service before they were 
returned. Each entry in the Date In-Service column in the Returns sheet must have a 
matching entry in the Date In-Service column in the Sales sheet. 

 

In the Future Sales sheet: 

• The Quantity In-Service column is for recording the projected number of units to be sold. 
This information is used in the forecast analysis. 

• The Date In-Service column is for logging the anticipated manufacturing/sales/shipment 
period. 
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Other Analysis Settings 

• The End of Observation Period setting on the Main page of the control panel is used to 
convert the sales/return data to failures/suspensions. The date is typically set to the last 
day the warranty data was collected. It is used to determine the time in service for each 
unit that had not yet been returned by the end of the observation period. Click Today if you 
wish to set the end date to the current date, as shown next. 

 

• The Suspension Estimation Method setting on the Main page of the control panel allows 
you to specify how Weibull++ will estimate the amount of usage for units still in the field 
(suspensions). See Estimating Usage. 

To view or change the settings, click the  icon or click the Suspensions page icon at the 
bottom of the control panel. 

 

Estimating Usage 

Like any other warranty analysis folio in Weibull++, the usage format must convert the 
sales/returns data to failures/suspensions that can be analyzed with life data analysis 
techniques. Since the returns information is entered in terms of accumulated usage (e.g., miles, 
cycles, etc.) rather than time, the failure "times" will be the usage values recorded when the 
units were returned. However, an additional step is required to estimate the amount of usage 
accumulated by the units still operating in the field at the end of the observation period (i.e., 
the suspensions). Two methods are available for you to provide the information required for 
these calculations: 

• You can define the average amount of usage that any given unit will typically accumulate 
over a specified period of time (e.g., 500 miles per month, 1,000 cycles per year, etc.). 

• You can define a statistical distribution that reflects the variation in usage patterns among 
different customers. The information for the usage distribution could come from customer 
surveys, repair records, built-in devices that record usage data, etc. 
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To select a method, click the link in the Suspension Estimation Method area of the Main page 
or click the Suspensions page icon at the bottom of the control panel, as shown next. 

 

Both methods are described next. 

To perform the estimates based on average usage 

When you choose Average Usage on the Suspensions page of the control panel, you will be 
required to enter the average amount of usage that any given unit typically accumulates over a 
specified period of time (in days, months or years). As an alternative, you could have the 
software calculate the average usage based on the unit conversion factors. For example, the 
settings shown in the following picture might indicate that the average amount of usage 
typically accumulated by a washing machine during 1 year of operation is 100 cycles. 
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When you click the Calculate icon on the Main page of the control panel, Weibull++ will 
perform the following calculations for each group of units that have the same date in-service: 

1. Calculate the number of units from the sales group that were still operating at the end of 
the observation period: 
 
Number of Units Sold – Number of Units Returned = Number of Suspensions 

2. Calculate the amount of time (in days) that those units had been in service by the end of 
the observation period: 
 
End of Observation Period date – Date In-Service = Days in Service 

3. If necessary, convert the average usage to the daily rate for calculation purposes (e.g., if the 
average usage is 10,000 miles per year, then the daily rate would be approximately 27.3973 
miles per day). 

4. Estimate the amount of usage the suspension units may have accumulated by the end of 
the observation period: 
 
Days in Service * Average Usage per Day = Estimated Usage at Time of Suspension 

For example, suppose that the Sales sheet records that 50 cars entered service on January 1st 
while the Returns sheet records the mileage for the 20 units from this sales group that have 
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been returned. If you enter July 1st for the End of Observation Period date and 1000 miles/per 
year for the Average Usage, the software will calculate the suspensions from the January 1st 
sales group as follows (where the daily rate has been rounded to 4 decimal places for the sake 
of simplicity, and therefore the estimated usage will not exactly match the value calculated by 
the software): 

• 50 Units Sold – 20 Units Returned = 30 Suspensions 

• July 1 – January 1 = 181 Days in Service 

• 181 Days in Service * 2.7397 Miles per Day = 495.8857 Miles approximately 

When you click the Show Analysis Summary button on the Main page of the control panel, the 
life data analysis data set will include one row with 30 suspensions at "End Time" = 495.8857. 

To perform the estimates based on a usage distribution 

If you have more specific information about variations in usage patterns between different 
customers, you may prefer to describe the estimated usage in terms of a statistical distribution 
instead of an average. There are several different ways that you could obtain a usage 
distribution. For example, if you have information about the amount of usage accumulated by 
many different users over a specified period of time, you could analyze the data in a Weibull++ 
life data folio with a time-to-failure data sheet. Alternatively, if you can define typical usage 
patterns and estimate the percentage of users who are likely to belong to each group (e.g., 18% 
of customers use 100 cycles or less, 25% of customers use 300 cycles or less, and so on), you 
could analyze the data in a Weibull++ life data folio with a free-form (probit) data sheet, as 
shown next. 
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• When you choose Usage Distribution on the Suspensions page of the control panel, you 
will be required to define a distribution that reflects the usage amounts that different 
customers may accumulate during a specified period of time (called the Usage Distribution 
Period). 

• If you choose Weibull, Normal, Lognormal, Exponential, Generalized Gamma, Gamma, 
Logistic, Loglogistic or Gumbel from the drop-down list, you can simply enter the 
appropriate parameter(s) for the selected distribution. 
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• If you choose Mixed Weibull, you can use the Subpopulation drop-down list to define 
parameters and the portion (percentage of the population) represented by each 
subpopulation. 

• If the estimated values of the distribution parameters are not available, you can use the 
Quick Parameter Estimator (QPE) to solve for them. 

• If you choose the User-Defined distribution, you can manually enter any equation that 
describes how customers use your product. You will need to use the variable t to 
represent time or usage, as in the example shown next. 

 

You can also use distributions calculated in life data folios from your current project as 
data sources for your equation. To insert a data source, click the Insert Data Source 
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button and select a calculated life data folio. The software will enter that source into 
the Equation area. You can insert multiple data sources and combine them (with 
operators such as + and *) to form new distributions. 

To save the equation, click the Set as Default button. To automatically re-enter the 
saved equation in the Equations area, click Load Default. 

• You will also be required to enter the Interval Width. This value is used to divide the usage 
distribution pdf into segments so the software can obtain the probability that any given 
unit will have accumulated usage at the rate represented by that segment. For example, if 
the usage distribution represents the number of pages printed per year and you enter 500 
for the interval, the software will break the distribution into segments of 0 to 500 pages per 
year, 501 to 1000 pages per year, 1001 to 1500 pages per year, and so on. 

The appropriate value for this field will depend upon your knowledge of typical product 
usage levels. The interval width should be selected such that when the warranty data are 
converted into failure/suspension times, the resulting times-to-suspension will neither be 
too close together (too few suspension units per interval) or too far apart (too many 
suspension units per interval). If you find that the failure/suspension data set is not 
acceptable, you can adjust the interval width and perform the calculation again. To help 
eliminate some of the guesswork, you can also use the Interval Width Estimator, which 
provides an approximation of the interval width based on the number of intervals and 
suspensions you specify. You can access the tool by clicking the icon in the Interval Width 
area of the control panel. 

• When you click the Calculate icon on the Main page of the control panel, Weibull++ will 
perform the following calculations for each group of units that have the same date in-
service: 

1. Calculate the number of units from the sales group that were still operating at the end 
of the observation period: 
 
Number of Units Sold – Number of Units Returned = Number of Suspensions 

2. Calculate the amount of time (in days) that those units had been in service by the end 
of the observation period: 
 
End of Observation Period date – Date In-Service = Days in Service 

3. Use the Interval Width to split the usage distribution into segments and calculate the 
probability that any given unit will fall into each segment: 
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where Q( ) is the cumulative distribution function (cdf) of the usage distribution and x 
represents the intervals used in apportioning the suspensions. 

4. For each segment, calculate the number of suspensions that are expected to have 
accumulated usage at the rate represented by that segment. (Note that the software 
applies a correction factor in order to get a whole number of units for each interval.) 
 
Number of Suspensions x Percentage for the Segment 

5. If necessary, convert the usage value from the end of each segment to the daily rate for 
calculation purposes (e.g., if the segment represents users who typically print 201 - 400 
pages per month, then the daily rate would be 400/30 or approximately 13.333 pages 
per day). 

6. For each segment, estimate the amount of usage the suspensions may have 
accumulated by the end of the observation period: 
 
Days in Service * Usage per Day = Estimated Usage at Time of Suspension 

For example, suppose that the Sales sheet records that 100 printers entered service on January 
1st while the Returns sheet records the number of pages printed for the 20 units from this sales 
group that have been returned. If you enter December 31st for the End of Observation Period 
date and the usage distribution indicates that 25% of users are likely to print 50 -100 pages per 
month, the software will calculate the usage for this segment of the January 1st sales group as 
follows: 

• 100 Units Sold – 20 Units Returned = 80 Suspensions 

• December 31st – January 1st = 365 Days in Service 

• 80 Suspensions x 25% = 20 Units printing 50 - 100 pages per month (or ~3.33 pages per day) 

• 365 Days in Service * 3.33 Pages per Day = 1215.45 Pages approximately 

When you click the Show Analysis Summary button on the Main page of the control panel, the 
life data analysis data set will include one row with 20 suspensions at "End Time" = 1215.45. 
There will be additional rows for the remaining 60 suspensions from the January 1st sales 
group, which will reflect the different usage amounts calculated based on the other segments 
of the usage distribution. 
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Interval Width Estimator 

The usage format of the warranty analysis folio converts the amount of usage accumulated by a 
fielded product into failures/suspensions data so you can perform life data analysis and/or 
forecast future warranty returns. When you use a statistical distribution to take into account 
the variations in the amount of product usage, the conversion process becomes more involved. 
In order to convert the usage data to failures/suspensions data, the software must have a way 
to estimate the amount of usage accumulated by units still operating in the field at the end of 
the observation period (i.e., suspensions). 

The software uses the concept of interval width to estimate the amount of usage accumulated 
by the suspensions. The interval width is a value that is used to divide the usage distribution 
into usage rate intervals. For example, if the usage distribution represents the number of pages 
printed per year, and you specify 500 for the interval width, the software will break the 
distribution into usage rate intervals of 0 to 500 pages per year, 501 to 1000 pages per year, 
1001 to 1500 pages per year, and so on. The software uses the intervals to obtain from the 
distribution the percentage of customers who use the product at each of the usage rates. The 
percentages are then used to obtain the probability that any given suspended unit will have 
accumulated usage at the rate represented by those intervals. 

The Interval Width Estimator is a tool that helps you to determine an appropriate interval width 
by providing a pdf graph of the usage distribution and showing you how well the usage values 
assigned to the suspended units track the pdf. Note that this tool only serves as a guide and 
that the appropriate interval width value will depend upon your own knowledge of typical 
product usage levels. 

Estimating the Interval Width 

To use the Interval Width Estimator, you must first define the usage distribution on the 
Suspensions page of the control panel. Next, open the tool by clicking the icon in the Interval 
Width area on the Suspensions page (note that this area will be displayed only when the 
warranty analysis folio has been configured for the usage format and only if you have selected 
to define the usage with a distribution). 

The interval width is estimated based on the following inputs: 

• In the End Usage field, enter the length of the observation period. This sets the maximum 
value for the x-axis. 

• In the Number of Intervals field, set the maximum number of intervals you want to divide 
the usage distribution into. 
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• In the Number of Suspensions field, set the total number of suspensions that are expected 
to continue operating in the field at the end of the observation period. 

Click the Calculate icon to estimate the interval width. 

 

The resulting rate intervals will be plotted in a bar chart and superimposed over the pdf of the 
usage distribution. To show the estimated number of suspensions that accumulate usage at 
each rate represented by each interval, move the pointer over the bars depicting the intervals. 

You can adjust the number of intervals and perform the calculation again to obtain an interval 
width value that provides a good number of intervals for the usage distribution. The following 
plots show some examples of how different interval widths may fit the same usage distribution. 

Figure 1 shows a plot with a narrow interval width, resulting in a pdf that is divided into several 
small segments. This causes the allocated suspensions to track the pdf poorly. When the 
warranty data are converted to failures/suspension data, there may be insufficient accuracy of 
the usage values of the suspensions (i.e., several intervals with few suspended units in each 
interval). 

 
Figure 1: Interval width = 500. 

Figure 2 shows a plot with a wider interval width, resulting in a pdf that is divided into larger 
segments. The allocated suspensions track the usage pdf well. Therefore, this interval width 
would be appropriate for the data set. 
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Figure 2: Interval width = 1,000. 

Figure 3 shows a plot with a very wide interval width. Again, this causes the allocated 
suspensions to track the pdf poorly. When the warranty data are converted to 
failures/suspension data, there may be insufficient granularity of the suspensions (i.e., few 
intervals with a high number of suspended units in each interval). 

 
Figure 3: Interval width = 3,750. 
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Example of a Usage Format Warranty Analysis 

The data set used in this example is available in the example database installed with the 
Weibull++ software (called "Weibull20_Examples.rsgz20"). To access this database file, choose 
File > Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder.  

The name of the project is "Warranty - Usage Format." 

An automotive manufacturer collected warranty returns and sales data for a vehicle part. The 
objective is to obtain the percentage of sold vehicles that will need repair under warranty if this 
particular part has a warranty coverage of 36,000 miles. 

The manufacturer has been documenting the mileage accumulation per year for this type of 
product across the customer base in comparable regions for many years. Based on the data, it 
was determined that the yearly usage follows a lognormal distribution with a mean = 9.38 and a 
standard deviation = 0.085. For the interval width, the manufacturer decided to specify an 
interval of 1,000 miles. 

The following is a table of the warranty information for a single year. The information is current 
as of December 1, 2018. 

Sales Month Units Sold Quantity 
Returned 

Usage at Time of Return 
(miles) 

12/1/2017 9 1 9072 

1/1/2018 13 1 9743 

2/1/2018 15 1 6857 

3/1/2018 20 1 7651 

4/1/2018 15 0 - 

5/1/2018 25 1 

1 

1 

1 

5083 

5990 

7432 

8739 

6/1/2018 19 1 3158 

7/1/2018 16 1 1136 

8/1/2018 20 1 4646 
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9/1/2018 19 1 3965 

10/1/2018 25 1 3117 

11/1/2018 30 1 3250 

The following pictures show the sales and return data in the usage warranty analysis folio. 

 

 

Analyze the Data Set 

1. On the Main page of the control panel, set the End of Observation Period date to 
12/1/2018. 

2. Set up the usage distribution. On the Suspensions page of the control panel, make the 
following inputs/selections: 



Chapter 5: Life Data Analysis Folios 

344 https://www.reliasoft.com/weibull 

 

• Suspension Estimation Method: Usage Distribution 

• Usage Distribution Period: 1 year 

• Distribution: Lognormal 

• Parameters: Log-Mean = 9.38, Log-Std = 0.085 

• Interval Width: 1000 

3. Choose a failure distribution for the vehicle part. On the Main page of the control panel, 
choose the Lognormal distribution and then select MLE for the parameter estimation 
method. 

4. Calculate the parameters by choosing Warranty > Analysis > Calculate or click the icon on 
the Main page of the control panel. 

 

The parameters of the failure distribution are estimated to be log-mean = 10.5281 and log-
std = 1.1352. 

5. Calculate the probability that the vehicle part will fail under warranty. To do this, click the 
QCP icon on the control panel. In the QCP window, choose to calculate the Probability of 
Failure. Select Miles for the time units and enter 36,000 for the mission end time. 

6. Click Calculate to obtain the result. The result shows that the probability of failure when 
under warranty is estimated to be 48.71%. In other words, an estimated 48.71% of sold 
vehicles will return for repair under the current warranty policy. Based on this information, 
the manufacturer may wish to modify the warranty policy and/or work on improving the 
reliability of the part. 
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FORECASTING WARRANTY RETURNS 

Once the warranty data set has been converted to failure/suspension times, the information 
can be used to predict the number of failures, or warranty returns, in subsequent time periods. 
Accurate predictions about the quantity of products that will be returned under warranty can 
provide huge benefits to manufacturing organizations, such as the ability to anticipate 
customer support needs and correct serious product quality problems in the field before other 
problems occur. 

What’s Changed? Starting in Version 2019, for folios that use the usage format, you can predict 
the number of failures based on the time and usage as well as the time. For example, for a 
vehicle with a 3-year/30,000 mile warranty, you can show the total number of warranty returns 
based on both values. 



Chapter 5: Life Data Analysis Folios 

346 https://www.reliasoft.com/weibull 

 

Forecast Setup 

To generate a forecast, choose Warranty > Tools > Forecast or click the icon on the control 
panel. 

 

Then in the Forecast Setup window: 

1. Enter the Start date for the forecast, the number of forecasts (Number of Periods field) and 
the length of each forecast (Increment field). In the example shown below, the time unit is 
in terms of years; therefore, an increment of 1 would mean that 1 forecast period is 
equivalent to 1 year, while an increment of 2 would mean that 1 forecast period is 
equivalent to 2 years. Note that: 

• In the Nevada chart format, the forecast period uses the same time units used in the 
data sheets. 

• In the times-to-failure format, the unit of time is not defined; however, it is consistent 
with the unit of time used in the data sheet. 

• In the dates of failure format and the usage format, you can specify the forecast period 
to be in days, months or years. 

2. Select whether you want the forecast sheet to display the Forecast (i.e., projected returns) 
or the Upper Bounds or Lower Bounds of the forecast. 

3. For a usage format folio, select whether you want to generate the returns based on the 
Time only or on the combined Time and Usage estimates. 

4. Finally, enter the desired confidence level and select whether to calculate One-Sided or 
Two-Sided confidence bounds. 
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Forecast Sheet 

The example shown next is a Forecast sheet for the Nevada chart format. The column 
headings represent the warranty periods and the row headings represent the sales periods. 
Forecasts for the future sales periods are in the yellow cells. 
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The Forecast sheet includes a control panel that contains the following settings: 

1. In the Show area, you can select to view the results as the Forecast, as the Upper 
Bounds of the forecast or as the Lower Bounds of the forecast. 

2. Round Results rounds the estimates to the nearest integer. Note that the column totals 
are calculated based on the non-rounded results. 

3. Show Subset ID adds a column in the Forecast sheet that displays the corresponding 
subset ID of the data in the Forecast sheet. 

4. The Use Warranty Length check box limits the length of the warranty period. By 
default, the software assumes an infinite warranty period. Limiting the warranty period 
allows you to disregard the number of returns that are outside the warranty period. For 
example, a warranty length of 12 months would mean that any units that fail after 12 
months of operation are out of warranty, and are therefore not counted in the total 
number of returns. This is useful when planning for warranty costs, spare parts and 
other fulfillment needs that fall within a specified period. 
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For the usage format, if selected in the Forecast Setup window, you can also specify the 
maximum Usage Length value. Limiting the usage length allows you to disregard the 
number of returns that had more usage than the warranty allows. For example, a usage 
length of 30,000 miles would mean that any units that fail after having been operated 
for 30,000 miles are out of warranty and are therefore not counted in the total number 
of returns. 

In the forecast sheet, the values shown include the number of failures for both time 
and usage. 

Enter the length of the warranty period in the Time Length field and, if applicable, the 
Usage Length fields and click Update. These options use the same units you selected 
for the period increments in the Forecast Setup window and the usage units used in the 
Returns data sheet. 

WARRANTY ANALYSIS PLOTS 

The features on the plot sheet of warranty analysis folios are similar to the options available for 
all other Weibull++ plots. Features that are not applicable to warranty analysis will be hidden or 
disabled. 

In addition to the standard plots in Weibull++, the following plot types are available for 
warranty analysis: 

• Expected Failures plot is available only when you've generated forecast data. It shows the 
expected number of failures over a period of time. Four additional options in the control 
panel are associated with this plot: 

• Cumulative Failures shows the cumulative percentage of failures for each time period. 
For example, consider 10 units that had failed within a period of 6 months. If 2 units 
failed during the 1st month, then the percentage of failures is 2/10 = 20%. If 3 more 
units failed during the 2nd month, then the cumulative percentage of failures is 
(2+3)/10 = 50%, and so on. 

• Failures in Percents shows the percentage of failures for each time period, with respect 
to the number of units that are still out in the field operating at the beginning of each 
period. 

• Show Confidence Bounds shows the upper and lower confidence bounds on the plot. 

• Include Total Data is available only when the Use Subsets check box was selected on 
the Main page of the control panel. It shows a plot of the entire data set, along with the 
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selected subsets. This allows you to view the overall trend of the entire data set in 
addition to the trends exhibited by each subset of data. 

• Chi-Squared Sales and Chi-Squared Returns plot types are available only when using the 
statistical process control (SPC) feature of the Nevada chart format. These plots give a 
visual indication of whether the expected number of warranty returns for a certain period 
is within or outside an expected range. 

MANAGE WARRANTY UNITS IN WEIBULL++ 

You can specify which of the configurable "database time units" are equivalent to the built-in 
(not configurable) "warranty time units" used in some warranty folio formats. To set the 
equivalencies, choose File > Manage Database > Unit Settings, and then click the Warranty 
Units tab. (In secure databases, this is available only if the user has the "Manage other 
database settings" permission.) 

The affected warranty folio formats include: 

• The Nevada chart format when the periods are labeled in terms of days, months or years. 

• The dates of failure format where the software calculates the number of days between the 
specified calendar dates. 

• The usage format where the software can calculate the amount of usage typically 
accumulated per day, month or year in order to estimate the usage for units still operating 
in the field. 

It is not applicable for the Nevada chart format when the periods are labeled with numbers or 
the times-to-failure format. In those cases, you will be prompted to select one of the "database 
time units" for all time inputs and calculated results in the folio. 

What does this mean? 

For each ReliaSoft database, you can configure which units will be available for inputs and 
results, and you can define conversion factors that allow the software to automatically convert 
data from one unit to another (see Unit Settings). 

However, it is important to be aware that some warranty folio formats use built-in (not 
configurable) "warranty time units" for entering sales/returns data and calculating the 
failure/suspension times. For example, in the dates of failure format, if 100 units were shipped 
on January 1st and 2 units from that shipment were returned on January 15th, the failure times 
for those returns will be recorded as 14 calendar days. Likewise in the Nevada chart format, if 
you label the periods in terms of months and report that 10 of the 1,000 units shipped in 
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January were returned in July, the failure times will be recorded as 6 calendar months. (Note 
that the usage format is affected differently because the failure/suspension values represent 
usage rather than time. See below for specific details.) 

When you calculate the life data model for the Nevada/dates of failure folios (or when you 
transfer the data to a Weibull++ life data folio), the software must apply the equivalent 
"database time units" so that a) the results will be consistent with other analyses in the same 
database and b) any tools that utilize unit conversions (such as the QCP) will be able to perform 
the conversions properly. 

For example, in the following picture, the failure/suspension data in the Results window (which 
is displayed when you click the Detailed Summary icon  in the Analysis Summary area of the 
control panel) has been calculated in terms of the "warranty time units" that are appropriate 
for the sales/returns data entered into the folio (calendar months), while the life data model 
parameters and QCP results are reported in the equivalent "database time units" (abbreviated 
as "Mon" under the default settings). 
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By default, each new database is created with "database time units" and conversion factors 
that are equivalent to the built-in "warranty time units" (where a day = 24 hours, a month = 730 
hours and a year = 8760 hours), as shown below. 

 

If you choose to modify the configurable time units for any database (and you expect that 
database users will utilize any of the affected warranty folio formats), you must take this 
equivalency into account. For example, if you want to give users the choice of working with 
time inputs/results in terms of a full 24-hour day or an 8-hour work day, you must decide which 
type of day is appropriate to describe the operating times for warranty returns. Will you 
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assume that a unit shipped on January 1st and returned on January 15th will have accumulated 
336 hours of operation (14 days x 24 hours) or 112 hours of operation (14 days x 8 hours)? If 
the former, then you could simply add the new 8-hour "Work Day" time unit to the database 
settings but keep the "warranty time unit" mapped to the original 24-hour "Day." If the latter, 
then you could change the “warranty time unit” mapping as shown next. 

 

Remember that the failure/suspension data generated by the Nevada chart and dates of failure 
warranty folios do not get converted based on this mapping. The software simply assigns an 
appropriate "database time unit" to the times that were calculated in "warranty time units." 
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How are usage format folios affected? 

In a usage format warranty folio, you enter the amount of usage (rather than operating time) 
for the failed units and the software must estimate the amount of usage accumulated by the 
units that have not failed (suspensions). 

• On the Main page of the usage format warranty folio's control panel, you can use the 
Change Units icon to select which of the "database time units" the usage data will be 
entered in. The options include any of the units that have been assigned to the Usage 
category in the Unit Settings window. The default settings are shown next. 

 

• On the Suspensions page of the control panel, you must specify the amount of usage that 
units typically accumulate per "Day," "Month" or "Year." This refers to the built-in (not 
configurable) "warranty time units." If you have selected to specify the Average Usage 
(rather than a Usage Distribution), you can enter the value directly (e.g., 1000 miles per 
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month) or click the Set Usage icon to have the software automatically calculate the value 
based on the conversion factors that have been defined for the equivalent "database time 
units." 

For example, suppose that the warranty data has been entered in miles and the "Unit 
Settings" window indicates that typical usage is 1 Mile = .73 Hour. 

 

If you choose Days from the drop-down list on the Suspensions page of the control panel, 
and then click the Set Usage icon (circled in the picture below), the software will use the 
Manage Warranty Units window to determine which of the "database time units" is 
equivalent to Days in a warranty folio and then it will use the specified conversion factors 
to calculate the number of miles. For this example, the calculation would be as follows: 
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24 hours / .73 hour per mile = 32.8767 'miles 

Another way to think about this is: 

• 1 mile / .73 hour = 1.3699 miles per hour 

• 24 hours x 1.3699 miles per hour = 32.8767 miles 

For Months, the calculation would be: 

• 730 hours / .73 hours per mile = 1000 miles 

For Years, the calculation would be: 

• 8760 hours / .73 hours per mile = 12000 miles 

Repairable Systems Analysis Folios 

Recurrent Event Data Analysis (RDA) Folios 

Recurrent Event Data Analysis 

In life data analysis, it is assumed that the components being analyzed are non-repairable; that 
is, they are either discarded or replaced upon failure. When analyzing the failure behavior of 
non-repairable components, the data points are typically either times-to-failure or times-to-
suspension. For a group of non-repairable units coming from a single population, the time-to-
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failure of one unit in the sample does not affect the time-to-failure of other units in the sample. 
Therefore, the lifetimes of non-repairable systems are considered to be independent and 
identically distributed (i.i.d). 

On the other hand, for complex systems such as automobiles, computers, aircraft, etc., it is 
likely that the system will be repaired (not discarded) upon failure. Failures are recurring events 
in the life of a repairable system, and data from such a system are obtained by recording the 
age of the system at the time when each failure occurred. This type of data is known as 
recurrent event data. 

The failure behavior of a repairable system is dependent on that system’s history of repairs; 
therefore, traditional life data analysis methods, such as the Weibull distribution, are not 
appropriate because those methods treat every failure event as identical and independent from 
the previous one. In order to analyze recurrent event data, Weibull++ includes a choice of two 
methods: non-parametric and parametric analysis. 

The ReliaWiki resource portal has more information on recurrent event data analysis at 
http://www.reliawiki.org/index.php/Recurrent Event Data Analysis. 

Non-Parametric RDA Folios 

Non-Parametric RDA Folio 

The non-parametric RDA folio is based on the mean cumulative function (MCF). This analysis 
provides a plot of the MCF to illustrate the average number of recurring failures of a system, or 
a group of systems, over a given period of time (or distance, cycles, etc.). The MCF can be used 
to evaluate whether the number of failures increases or decreases over time, to predict the 
future number of failures or to compare different data sets from different designs, operating 
conditions, production periods, etc. The ReliaWiki resource portal has more information on the 
MCF at: http://www.reliawiki.org/index.php/Non-Parametric_Recurrent_Event_Data_Analysis. 

Non-Parametric RDA Data Sheet 

To create a non-parametric RDA folio, choose Home > Insert > Non-Parametric RDA, or right-
click the Repairable Systems folder in the current project explorer and choose Add Non-
Parametric RDA on the shortcut menu. 

 

The following picture shows an example of the non-parametric RDA folio data sheet. 

http://www.reliawiki.org/index.php/Recurrent_Event_Data_Analysis
http://www.reliawiki.org/index.php/Non-Parametric_Recurrent_Event_Data_Analysis
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• The System ID column identifies the system that experienced an event. In the sample data 
sheet, two units of the same type of motor are being tracked. The resulting mean 
cumulative function (MCF) will depict the average behavior of the motors. 

• The Event column describes the type of event. An F indicates a failure and an E indicates 
that the observation period for the unit has ended. Each unique system in the data sheet 
must have a single end event. If you do not enter an end event for a system, then the end 
event is assumed to be equal to the last failure time for that system. 

• The Time to Event column indicates the age of the system when the event occurred. For 
each unique system, the time of the end event (E) must be equal to or greater than the last 
failure time of that system. The time of the end event is also known as the censoring age, 
because the product’s failure or repair history beyond that time is unknown. 

• The Calculate Confidence option on the control panel calculates the upper 1-sided and 
lower 1-sided confidence bounds of the MCF at a specified confidence level. Specify the 
desired confidence level in the Level input field. Selecting this option also automatically 
includes the confidence bounds in the plot of the analysis. 

Evaluating Results 

To analyze the data set, choose Recurrent Event Data > Analysis > Calculate or click the icon on 
the control panel. 
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Note that this will also sort the data set by system ID and then by time to event. 

To view the results, click the Show Results (...) button to open the Results window, as shown 
next. 

 

The Time column displays the system ages, sorted in chronological order, that were entered for 
the failure events. The Sample MCF column shows the average number of failures at each 
particular age. 

The Variance column indicates the amount of uncertainty in the MCF value. This is also used to 
obtain the 1-sided confidence bounds that are displayed in the Lower Limit and Upper Limit 
columns. These three columns are available only if you have selected the Calculate Confidence 
check box in the control panel and specified a confidence level. 
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The MCF values and the confidence bounds can also be displayed in an MCF plot in order to 
visualize the behavior of the recurring failures. To view the MCF plot, choose Recurrent Event 
Data > Analysis > Plot, or click the icon on the control panel. 

 

The following plots show some examples of the different MCF shapes. 

 

• Constant Recurrence Rate indicates that the units are exhibiting what is usually referred to 
as useful life, which is a stable period during which the failures occur at a rate that is 
neither increasing or decreasing with time. 

• Increasing Recurrence Rate is a curve that is concave up and the recurrence rate of the 
failures increases (the data points are becoming horizontally closer) as the population ages. 
This is typical of units with wearout problems. It could also indicate that the system 
maintenance is degrading with time. 

• Decreasing Recurrence Rate is a curve that is concave down and the recurrence rate of the 
failures decreases (the data points are becoming horizontally farther apart) as the 
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population ages. This is typical of units exhibiting a period of infant mortality problems. It 
could also indicate that the system maintenance is improving with time. 

• Bathtub Recurrence Rate is a curve that starts as concave down, and then becomes 
concave up. This behavior is typical of units that first experience infant mortality problems 
and then exhibit a useful life period. As the age increases, the units start to enter the 
wearout stage. 

Non-Parametric RDA Example 

A car manufacturer wants to make projections about the expected cumulative number of 
transmission repairs by 24,000 miles for 100 cars of the same model. The manufacturer 
conducted a preproduction road test and tracked the transmission repairs in a sample of 14 
cars. The following table shows the data. (Adapted from the example that appears on page 4 in 
Recurrent Events Data Analysis for Products Repairs, Disease Recurrences, and Other 
Applications, by Wayne B. Nelson, 2003.) 

Car ID Mileage at 1st 
Repair 

Mileage at 2nd Repair Last Observed Mileage 

1 - - 27099 

2 - - 21999 

3 11891 - 27583 

4 - - 19966 

5 - - 26146 

6 3648 13957 23193 

7 - - 19823 

8 2890 - 22707 

9 2714 - 19275 

10 - - 19803 

11 - - 19630 

12 - - 22056 

13 - - 22940 

14 3240 7690 18965 

Analyze the Data Set 

1. Enter the given data into a non-parametric RDA folio data sheet, as shown next. 
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2. Select to calculate the confidence bounds, enter a confidence level of 0.95 and click 
Calculate. 

3. Click the Show Results (...) button to open the Results window. The results indicate that for 
the period between 2,714 and 2,890 miles, the estimated mean cumulative number of 
repairs per car is 0.0714. For the period between 2,890 and 3,240 miles, the estimate is 
0.1429, and so on. 
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4. To view a plot of the MCF results, close the Results window and click the Plot icon on the 
control panel. The following plot shows the MCF and the confidence bounds. The system 
ages are on the x-axis and the values for the mean cumulative number of repairs per car are 
on the y-axis. 
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The Xs in the plot represent the system ages that were entered for the failure events. As 
you can see, the MCF value of 0.5 applies to the period that is between 13,957 to 27,583 
miles (the latest system age entered for failure event F and the latest observed censoring 
age entered for end event E). Therefore, for a fleet of 100 cars, the expected number of 
transmission repairs by 24,000 miles is 50 (i.e., 0.5 x 100). This estimate can be useful for 
predicting the future number of failures, estimating repair cost and planning for spare 
parts. 

Notice that the MCF data points on the plot grow horizontally farther apart as the 
population ages. If a smooth curve were drawn through the Xs on the plot, the curve would 
be concave down, indicating a decreasing recurrence rate. This means that the rate of 
repairs decreases as the cars accumulate more miles. This could also mean that the cars 
have a manufacturing defect and the recurrence rate will continue to decrease until all 
defects have been repaired. 
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Parametric RDA Folios 

Parametric RDA Folio 

The parametric RDA folio uses the General Renewal Process (GRP) model to analyze the failure 
behavior of a repairable system. The GRP analysis method takes into account the effectiveness 
of repairs on the condition of the system. For example, a repair may bring the system to an as-
good-as-new condition, to an as-bad-as-old condition or to some stage in between. If the 
system is only partially rejuvenated after the repair, then this may affect how the system fails in 
the future. Over time, the recurrence rate of failures may remain constant, increase or 
decrease. The GRP model allows you to analyze the failure behavior of a partially restored 
system over time so you can obtain estimates such as the cumulative number of failures, mean 
time between failures (MTBF) and failure intensity. The ReliaWiki resource portal has more 
information on the GRP model at: 
http://www.reliawiki.org/index.php/Parametric_Recurrent_Event_Data_Analysis. 

Parametric RDA Data Sheet 

To create a parametric RDA folio, choose Home > Insert > Parametric RDA, or right-click the 
Repairable Systems folder in the current project explorer and choose Add Parametric RDA on 
the shortcut menu. 

 

The following picture shows an example of a parametric RDA folio data sheet. 

http://www.reliawiki.org/index.php/Parametric_Recurrent_Event_Data_Analysis
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• The System ID column identifies the system that experienced an event. In the sample data 
sheet, two units of the same type of motor are being tracked. The results, such as the mean 
time between failures (MTBF) and failure intensity, will depict the average behavior of the 
motors. 

• The Event column describes the type of event. An F indicates a failure event and an E 
indicates that the observation period for the unit has ended. Each unique system in the 
data sheet must have a single end event. If you do not enter an end event for a system, 
then the end event is assumed to be equal to the last failure time for that system. In 
addition, the data set must have at least three failures in order for the software to perform 
the calculations. 

Notice that the repair times of the motors are not recorded in the data sheet. This is 
because the GRP model assumes that the repair times are negligible and only the effects of 
the repairs on the condition of the system are of concern. Therefore, each data point in the 
data sheet can be treated as a single fail-and-repair process. 

• The Time to Event column indicates the age of the system when the event occurred. For 
each unique system, the time of the end event (E) must be equal to or greater than the last 
failure time of that system. The time of the end event is also known as the censoring age, 
because the product’s failure or repair history beyond that time is unknown. 
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Parametric RDA Folio Control Panel Settings 

The parametric RDA folio control panel allows you to configure the analysis settings for the data 
sheet and view/access the results. This topic focuses on the Main page and Analysis page of the 
parametric RDA folio control panel, which contain most of the tools you will need to perform 
the analysis. For more information about the control panel in general, see Control Panels. 

Control Panel Main Page 

The GRP model uses the concept of virtual age to mathematically capture the effect of the 
repairs on the subsequent rate of occurrence of failure (i.e., failure intensity). The rate of 
occurrence of failure over time is modeled by the power law function. This means that the GRP 
analysis method has three parameters, two of which are used to describe the power law 
function and a third for estimating the virtual age of a system. 

• The Parameters area allows you to select how you want to calculate the parameters of the 
GRP model. If you select 2 parameters, you will be prompted to specify a value for the 
virtual age parameter based on your own knowledge about the effectiveness of the repairs 
(this may be the q or RF parameter, depending on your default setting). If you select 3 
parameters, the software will calculate the virtual age parameter based on the data, giving 
you an indication of the effectiveness of the repairs as reflected by the data set. 

• The Settings area displays "Power Law" to indicate that the power law function will be used 
in the analysis. This setting cannot be changed; however, you have the option to select 
which virtual age model will be used in the analysis. Click the option displayed in blue text 
on the control panel to toggle between the available virtual age models. 

 

• The Analysis Summary area displays the calculated results. The following example shows 
the calculated values of the parameters and the likelihood (LK) value of the GRP model for a 
particular data set. You can click the Detailed Summary icon  to open the Results 
window, which shows the results in a worksheet that you can copy or print. 
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Folio Tools 

The folio tools are arranged on the left side of the Main page of the control panel: 

  Calculate estimates the parameters of the GRP model, based on the current data set. 
This tool is also available by choosing Recurrent Event Data > Analysis > Calculate. 

  Plot creates a new sheet in the folio that provides a choice of applicable plot types. In 
parametric RDA folios, this includes cumulative failures vs. time, failure intensity vs. time, 
etc. This tool is also available by choosing Recurrent Event Data > Analysis > Plot. 

  QCP opens the Quick Calculation Pad, which allows you to calculate results based on 
the analyzed data sheet, such as the number of failures and mean time between failures 
(MTBF). This tool is also available by choosing Recurrent Event Data > Analysis > Quick 
Calculation Pad. 

  Change Units opens the Change Units window, which allows you to change the units 
for the values in the current data sheet. 

Control Panel Analysis Page 

The following settings are available on the Analysis page of the parametric RDA control panel: 

• The Virtual Age Model area allows you to select one of two ways that the GRP model can 
calculate the virtual age after each repair: 

• Only since last repair (Type I) assumes that the repairs will remove some portion of the 
damage that has accumulated since the last repair. 

• From the beginning (Type II) assumes that the repairs will remove a portion of all the 
damage that has accumulated since the system was new. 

The ReliaWiki resource portal explains the mathematical concept behind these two models 
at: http://www.reliawiki.org/index.php/Imperfect Repairs. (Note that the article is written 
for ReliaSoft's BlockSim software, but the theory remains the same.) 

http://www.reliawiki.org/index.php/Imperfect_Repairs
https://www.reliasoft.com/products/reliability-analysis/blocksim
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Since it may not be feasible to classify real-world repair situations into one of these two 
abstract categories, the virtual age type is usually selected based on what provides a better 
statistical fit for the data. The model fit can be assessed by using the likelihood (LK) value 
that is displayed in the Analysis Summary area on the control panel, where the higher 
value indicates the better fit. 

• The Simulation Settings are for the Monte Carlo simulation. In general, the application uses 
the failure times supplied by the data set in order to calculate virtual age. However, when 
extrapolating for results that are outside of the range of observations, the failure times are 
unknown. Therefore, unless the virtual age parameter q = 1, there are no analytical 
solutions available for metrics such as total failure number and failure intensity. In this 
case, the solution can be obtained only through Monte Carlo simulation. 

• The Number of Simulations specifies the number of data points to generate in the 
simulation. 

• The Use a Fixed Seed checkbox is an optional setting that allows you to specify a 
starting point from which random numbers are generated in the simulation. The same 
random numbers and, therefore, the same simulation results will be generated when 
the same seed value and number of data points are used. 

• The Parameterization option allows you to select how you want the parameters to be 
calculated. By default, the software calculates for the beta, lambda and q parameters. 
However, if you want to publish the model and use it in BlockSim, then you need to express 
the power law parameter (lambda) in terms of the Weibull parameter (eta) and express the 
virtual age parameter (q) in terms of the RF parameter (which users of BlockSim will 
recognize as the restoration factor of a maintenance action). To do this, select the check 
box in the Parameterization area, as shown next. 

https://www.reliasoft.com/products/reliability-analysis/blocksim
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The relationship between the power law parameter, lambda (λ), and the Weibull 
parameter, eta (η), is described as: 

 

The relationship between the q and RF parameters is described as: 

 

The RF parameter indicates the degree to which the condition of a system will be restored 
after each repair. Parameter q indicates the opposite. A value between 0 and 1 indicates 
the extent of the repair, where: 

• An RF = 1 indicates that the system will be "as good as new" after the repair. This is also 
called perfect repair. 
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• An RF value between 0 and 1 indicates that the system will be "better than old but 
worse than new" after the repair. This is also called imperfect repair. 

• An RF = 0 indicates that the system will be "as bad as old" (i.e., no improvement) after 
the repair. This is also called minimal repair. 

QCP Calculations for Parametric RDA 

The parametric RDA folio includes a Quick Calculation Pad (QCP) for computing useful metrics. 
You can access the QCP by choosing Recurrent Event Data > Analysis > Quick Calculation Pad 
or by clicking its icon on the Main page of the control panel. 

 

To perform a calculation, select the appropriate option and enter any required inputs in the 
Input area, then click Calculate. For more detailed information on how to use the QCP in 
general, see Quick Calculation Pad (QCP). 

Failure Intensity 

Cumulative Failure Intensity 

Calculates the average rate of occurrence of failures from time = 0 up to a specified end 
time. Enter the end time in the Time field. For example, a cumulative failure intensity of 
0.15 for a time period of 100 hours means that, on average, 0.15 failures occurred every 
hour over the 100-hour period. 

Instantaneous Failure Intensity 

Calculates the rate of occurrence of failures over a small interval dt that begins at a 
specified time. Enter the time in the Time field. For example, an instantaneous failure 
intensity of 0.15 at 100 hours means that, over the next small interval dt that begins at 100 
hours, the rate of occurrence of failures is 0.15 failures per hour. 

MTBF (Mean Time Between Failures) 

Cumulative MTBF   

Calculates the average MTBF from time = 0 up to a specified end time. Enter the end time 
in the Time field. For example, a cumulative MTBF of 5 hours from 0 to 100 hours means 
that, on average, the time between failures was 5 hours over the 100-hour period. 

Instantaneous MTBF 
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Calculates the average MTBF over a small interval dt that begins at a specified time. Enter 
the time in the Time field. For example, an instantaneous MTBF of 5 hours at 100 hours 
means that, over the next small interval dt that begins at 100 hours, the average MTBF will 
be 5 hours. 

Note: MTBF is used as a metric for the analysis of repairable components. On the other 
hand, the term mean time to failure (MTTF) is used as a metric for non-repairable systems, 
where components are discarded or replaced upon failure. To analyze non-repairable 
system data in Weibull++, use the Weibull++ life data folio. 

Failures 

Cumulative Number of Failures 

Calculates the cumulative number of failures to be expected for a specified interval of time. 
Enter the start time of the interval in the Mission Start Time field and enter the duration of 
the interval in the Mission Additional Time field. For example, a system may be estimated 
to fail 10 times between 100 and 500 operating hours. 

Failures by System 

Calculates the cumulative number of failures to be expected for each system for a specified 
interval. The start time of the interval is equivalent to the time when the observation 
period for the system ended (indicated by an E in the folio data sheet). If you did not enter 
an end time for a system, then the start time of the interval is assumed to be equal to the 
last failure time for that system. Enter the duration of the interval in the Mission Additional 
Time field and then click Calculate to open the Results window, which shows the 
cumulative number of failures for each system, as well as the overall number of failures. 

Probability 

Conditional Reliability 

Calculates the probability of the system successfully completing a mission, given that it may 
or may not have successfully completed a previous mission. Enter the start time of the new 
mission in the Mission Start Time field and enter the duration of the new mission in the 
Mission Additional Time field. 

For example, a system failed three times during its first three years of operation. The 
probability that the system will operate for an additional six months without failure, or the 
conditional reliability for one half of a year given that the system is three years old, may be 
30%. 
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Conditional Probability of Failure 

Calculates the probability that the system will fail a mission, given that it may or may not 
have successfully completed a previous mission. Enter the start time of the new mission in 
the Mission Start Time field and enter the duration of the new mission in the Mission 
Additional Time field. 

For example, a system failed three times during its first three years of operation. The 
probability that the system will fail in the next six months, or the conditional probability of 
failure for one half of a year given that the system is three years old, may be 70%. 

Parametric RDA Folio Plots 

Weibull++ includes several plot types you can use to visualize the results of your parametric 
RDA analysis. You can create plots by choosing Recurrent Event Data > Analysis > Plots or by 
clicking the icon on the Main page of the control panel. 

 

The following is a description of the different types of plots that can be created in a parametric 
RDA folio. (For general information on working with plots, see Plot Utilities.) 

• Cumulative Number of Failures plots the failure times in the x-axis and the cumulative 
number of failures in the y-axis. The points represent the actual failure times in the data set 
and the line represents the expected cumulative number of failures based on a simulation 
using the calculated model parameters. This gives you an indication of how the number of 
failures is increasing over time. 

• Cumulative Failure Intensity vs. Time plots the average rate of occurrence of failures over 
a period of time. The points represent the cumulative failure intensity calculated at each 
failure time in the data set and the line represents the cumulative failure intensity based on 
a simulation using the calculated model parameters. This shows how the rate of occurrence 
of failures increases, decreases or remains constant for that period of time. 

• Instantaneous Failure Intensity vs. Time plots the rate of occurrence of failures over 
several instances of time. The line represents the instantaneous failure intensity based on a 
simulation using the calculated model parameters. This plot may be used to show how the 
rate of occurrence of failures has changed at a particular point in time. 

• Conditional Reliability vs. Time and Conditional Unreliability vs. Time shows the reliability 
or probability of failure over intervals of time. There are two options: 
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• Vary Mission Time shows how the reliability or probability of failure would vary over 
different mission times if the system operated at a specific Start Time. The start time is 
an assumed value for the system age at the beginning of the mission. For example, a 
start time = 100 hours means that the origin of the plot corresponds to a system with a 
total age of 100 hours after a mission of 0 hours. Therefore, an x-axis value of 500 
mission hours on that plot would correspond to a system with a total age of 600 hours 
after a mission of 500 hours. 

• Vary Start Time shows how the reliability or probability of failure would vary over 
different start times if the system operated within a specific Mission Time. The mission 
time is an assumed value for additional age a system will accumulate during the 
mission. For example, a mission time = 100 hours means that the origin of the plot 
corresponds to a system with a total age of 100 hours after a mission of 100 hours. 
Therefore, an x-axis value of 500 hours on that plot would correspond to a system with 
a total age of 600 hours after a mission of 100 hours. 

Parametric RDA Example 

The data set used in this example is available in the example database installed with the 
Weibull++ software (called "Weibull20_Examples.rsgz20"). To access this database file, choose 
File > Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder.  

The name of the project is "Parametric RDA - Airplane AC Repair." 

An analyst recorded the successive failures of the air-condition unit of an aircraft. The objective 
is to obtain the expected number of failures that may occur by 1,800 hours. The following data 
sheet shows the failure logs of the unit between 0 to 1,539 hours of observation. The 
observation period ended at the time of the last failure. 
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Analyze the Data Set 

1. The first step is to determine which virtual age model provides the best statistical fit for the 
given data. On the Main page of the control panel, select 3 for the parameters settings and 
then calculate the results for each of the virtual age models. Use the default settings for the 
simulation. 

The LK value for the Type I model is -123.6347 while the LK value for the Type II model is -
123.5964. Therefore, for this data set, the Type II model may provide the best fit (i.e., have 
a slightly larger LK value). The parameters of the Type II GRP model are estimated to be 
beta = 0.8276, lambda = 0.0389 and q = 0.2758.  

2. Click the Plot icon to visualize how the number of failures increases over time, as shown 
next. 
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3. To estimate the number of failures expected to occur by 1,800 hours, click the QCP icon on 
the control panel. In the QCP, choose to calculate the Cumulative Number of Failures with 
two-sided confidence bounds. Select Hour for the time units and then make the following 
inputs: 

• Mission Start Time: 0 

• Mission Additional Time: 1800 

• Confidence Level: 0.9 

4. Click Calculate. The results show that the cumulative number of failures in 1,800 hours is 
28.4740 or about 28 failures, and the number may be as high as about 39 failures. 
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Event Log Data Folio 

Event Log Data Folio 

Event logs, or maintenance logs, store information about a piece of equipment's failures and 
repairs. They provide useful information that can help companies achieve their productivity 
goals by giving insight about the failure modes, frequency of outages, repair duration, 
uptime/downtime and availability of the equipment. 

Some event logs contain more information than others, but essentially event logs capture data 
in a format that includes the type of event, the date/time when the event occurred and the 
date/time when the system was restored to operation. The volume of this type of data can 
become very large and the task of extracting useful and concise information can also be 
cumbersome. To facilitate the processing of the data, the Weibull++ event log folio is designed 
to convert your log entries into failure/repair data and perform basic life data analysis. In 
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addition, the folio calculates additional information such as the total uptime/downtime of the 
equipment and the total number of repair actions performed. 

Event Log Folio Data Sheet 

To create an event log folio, choose Home > Insert > Event Log, or right-click the Repairable 
Systems folder in the current project explorer and choose Add Event Log on the shortcut menu. 

 

The following is an example of an event log folio data sheet. In this example, the events are 
from two cutting machine systems in two parallel production lines. 

 

• The System column identifies the system that experienced an event. In the sample data 
sheet, the machines are identified by the labels M-1 and M-2. 

The System column is optional, and it can be displayed by selecting the Use System column 
check box on the Other page of the folio’s control panel. If the System column is not used, 
all events are assumed to have occurred for the same system. 

All occurrence dates in the log must be within the defined observation period for the 
system. You will enter the start/end dates of the observation period for the system in the 
System area of the control panel. 

• The F=Failure/E=Event column indicates whether the occurrence was a failure event (F) or 
a general event (E). A general event represents an activity that brings the system down, but 
is not directly relevant to the reliability of the equipment such as preventive maintenance, 
routine inspections and the like. 

If you choose to include general events (E) in the analysis, you will have the option on the 
control panel to select whether you want to obtain the failure/repair distributions of the F 
and E occurrences separately or combined. 

• Date Occurred and Time Occurred indicate the exact date and time of the event. 
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• Date Restored and Time Restored indicate the exact date and time the system was 
restored to operating mode. 

• Levels 1, 2, 3 and 4 indicate the subsystem or component that was responsible for the 
event. This gives you the flexibility to analyze the failure and repair data by certain levels 
within the system. For example, in row 1 of the sample data sheet, the failure event was 
caused by the motor of the electric saw of machine M-1. By entering this level of 
information in the data sheet, you will have the option to obtain individual failure and 
repair distributions for the motor (2nd level) and the electric saw (1st level). Note that in 
order to perform an analysis, you must at least specify a 1st level component for every 
entry in the log. 

• OTSF (Operates Through System Failures) allows you to specify whether the component will 
continue to accumulate age when any failures other than the component’s own failure 
occur. Enter a Y in this column to indicate that the component continues to operate 
through other failures or enter an N to indicate that the component is assumed to be failed 
when the system is failed. 

Note that the entry in this column for a particular component must be consistent with all 
other events in the data set associated with the component. For example, there are two 
rows in the sample data sheet with events associated with the electric saw blade (rows 4 
and 10), both of those rows must contain the same value (Y or N) in the OTSF column 
because the blade either does or does not continue to operate when the system fails due 
to another type of event. 

The OTSF column is optional, and it can be displayed by selecting the Use OTSF column 
check box on the Other page of the folio’s control panel. If this column is not used, all 
components are assumed to be failed when the system is failed. 

• The Description column is for logging any other pertinent information or comments about 
the event. The information has no effect on the analysis. 

If your system does not operate on a 24/7 basis, you may want to define the shift schedule of 
the system so that you obtain accurate calculations for the failure and repair times. See Set 
Shift Pattern. 

Event Log Control Panel Settings 

The event log folio control panel allows you to configure the analysis settings for the data sheet 
and view/access the results. It consists of a Main page, Analysis page, Other page and 
Comments page. 
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Control Panel Main Page 

The Main page of the event log folio control panel contains most of the tools you will need to 
perform an analysis. 

• The Levels to Analyze area allows you to specify the component level to include in the 
analysis. At least one level must be selected in order to perform an analysis. For instance, 
suppose you have a cutting system with an electric saw as the level 1 component and the 
saw blade as the level 2 component. If you select to analyze both levels 1 and 2, then the 
software will compute for the total uptime and downtime at each level. In addition: 

• The software will obtain the failure and repair distributions of the electric saw. The 
analysis of the level 1 component considers the events that affect the electric saw and 
any other components of the electric saw assembly, including the saw blade. 

• The software will also obtain separate failure and repair distributions for the saw blade. 
The analysis of the level 2 component considers the events that affect the saw blade 
and events for any other components of the saw blade (level 3 and 4 components of 
the saw blade, if any). 

Note that when you select the Use OTSF column check box on the Other page of the 
control panel, the software can analyze only one level at a time. 

• The Analyze Failures and Events area allows you to select whether you want to obtain the 
failure/repair distributions of the F and E occurrences jointly or separately. When you select 
a joint analysis, all general events in the data set will be treated as failures. This affects the 
calculation for the total uptime/downtime of the component, as well as the failure/repair 
distributions. 

• The System area is for specifying the dates/times when you started and stopped collecting 
the event log data. Note that if you select the Use System column check box on the Other 
page of the control panel, the drop-down list will be enabled. This allows you to select the 
system name from the drop-down list and enter the start date/time and the end date/time 
of the observation period of that system. If the Use System column check box is not 
selected, the software assumes that all events are assumed to have occurred for the same 
system and the drop-down list will be disabled. 

The System is new on start date check box indicates that the system has never been used 
before and that the start date you entered is also the same calendar date that the system 
started operating. This setting affects how the software classifies data when it converts the 
log entries to failure/suspension data. If the system is new, then the times to first 
occurrence of every event are considered to be complete data (F) because the exact time-
to-event is known. If the system is not new, then the times to first occurrence of every 
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event are considered to be right censored data (S) because the amount of time that the 
system operated before the observation period began is not known. 

Tip: As an alternative, you can enter the start date/time and end date/time of the 
observation period for each system in a separate window by clicking the Systems Setup 
icon    on the Main page of the control panel. The larger window makes it easier to enter 
information for several systems all at once. This option is available only if you have selected 
the Use System column check box on the Other page of the folio’s control panel. 

If your system does not operate on a 24/7 basis, you may also want to define the shift 
schedule of the system so that you obtain accurate calculations for the failure and repair 
times. (See Set Shift Pattern.) 

• The Results area provides the results: 

• To view the failure/repair distributions of each component, click the Show Analysis 
Summary (...) button. The resulting failure/repair distributions are based on the 
settings you have defined on the Analysis page of the control panel and on the log data 
in your data sheet. 

• To view a report on the number of repair actions performed, the OTSF settings of each 
component and other results, click the Show Report (...) button. 

Folio Tools 

The folio tools are arranged on the left side of the Main page of the control panel. These tools 
are also available from the Event Log tab on the ribbon. 

  Calculate converts the log entries into failure/repair times and then fits distributions 
to the converted data. In addition, it calculates the total uptime and downtime of the 
components. 

  Set Shift Pattern opens the Shift Pattern window, which allows you to specify the days 
and times when the system is operating. 

  Systems Setup is available only if you have selected the Use System column check box 
on the Other page of the folio’s control panel. It opens the Systems Setup window, which 
allows you to record the dates/times when you started and stopped collecting event log 
data for each system and whether it was new at the specified start date. 

After the folio has been calculated, three transfer options become available: 
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  Transfer Life Data to New Folio transfers all of the analyzed time-to-failure and time-
to-repair data sets to separate data sheets in a new Weibull++ life data folio. 

  Transfer Life Data to Selected Folio opens the Transfer Life Data window, which allows 
you to choose specific data set(s) to transfer to either new or existing folio(s). 

  Transfer to BlockSim is available only if BlockSim is activated on your computer. The 
Transfer to BlockSim window allows you to export the analysis results as blocks in a new 
simulation diagram. 

Control Panel Analysis Page 

The Analysis page of the event log folio control panel allows you to specify how the software 
will fit a distribution to the failure data and the repair data. 

• If you select the Use quick defaults check box, all the other options will be unavailable and 
one of the following actions will be applied: 

• When the failure/repair data set contains at least two unique failure times, the 
software uses the 2-parameter Weibull distribution and the MLE parameter estimation 
method to analyze the data. 

• When the failure/repair data set contains one failure time, the software uses the 1-
parameter exponential distribution and the MLE parameter estimation method to 
analyze the data. 

• If you select the Prefer RRX if sufficient data option, the software uses the RRX parameter 
estimation method when the failure/repair data set has at least two unique failure times; 
otherwise, the MLE method is used. 

• If you select the Always use MLE option, the software always uses the MLE parameter 
estimation method. 

• The Distributions to Consider area allows you to select one or more of the listed 
distributions to be considered for the data. The software evaluates the fit of each selected 
distribution to the data set and displays in the results the one that provides the best fit. 

Control Panel Other Page 

The Other page of the event log folio control panel contains optional settings that allow you to 
format the event log data sheet. 

https://www.reliasoft.com/products/reliability-analysis/blocksim
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• The Times to Failure/Repair In area allows you to select the unit of time to be used when 
the software converts the log entries to failure/repair data. 

• The Time Format and Date Format areas allows you to select the formatting options for 
displaying the date and time information in the data sheet and in the results. 

• The Other area allows you to include either an OTSF (Operates Through System Failures) 
column or a System column in the data sheet, or both. 

• If the Use OTSF column check box is selected, you will have the option to specify in the 
data sheet whether a component continues to accumulate age when any failures other 
than that component’s own failure occurs. If the check box is not selected, all 
components are assumed to be failed when the system is failed. 

• If the Use System column check box is selected, you will have the option to enter 
events for multiple systems in the data sheet. If the check box is not selected, all events 
are assumed to have occurred for the same system. 

To save your current settings for all new event log folios, click the Set as Default button. To 
automatically apply the saved settings to any existing event log folio, click Load Default. 

Control Panel Comments Page 

The Comments page allows you to enter notes or other text that will be saved with the folio. 

Event Log Data Analysis Example 

Consider a simple system comprising two components of interest for analysis purposes: a 
motor and a pump. When the motor fails, the pump also stops operating and the entire system 
is shut down for repairs. However, when the pump fails, the motor continues to run. The 
system operates from 8 AM to 5 PM seven days a week. 

The following table shows the maintenance log. System monitoring started on January 1, 2018 
at 12 PM and stopped on March 18, 2018 at 1 PM. The system had been in operation for some 
time before the log began, but information for events prior to January 1 is not available. 

The objective is to analyze each component and obtain the failure and repair distributions for 
all recorded events. 

  Event Type System Failed System Restored Component 

Date Time Date Time 

1 Failure Jan-02-18 4:00 PM Jan-02-18 7:49 PM Pump 
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2 Maintenance Jan-09-18 8:30 AM Jan-09-18 10:43 AM Motor 

3 Failure Jan-10-18 9:13 AM Jan-10-18 7:48 PM Motor 

4 Inspection Jan-12-18 3:26 PM Jan-12-18 6:46 PM Pump 

5 Failure Jan-13-18 4:56 PM Jan-13-18 5:21 PM Pump 

6 Maintenance Jan-15-18 1:16 PM Jan-15-18 4:39 PM Motor 

7 Failure Jan-20-18 1:38 PM Jan-21-18 7:15 PM Pump 

8 Failure Jan-25-18 10:32 AM Jan 27-18 10:47 PM Motor 

9 Cleaning Jan-28-18 11:31 AM Jan-28-18 12:00 PM Pump 

10 Failure Feb-02-18 2:38 PM Feb-02-18 7:11 PM Motor 

11 Inspection Feb-08-18 3:51 PM Feb-08-18 8:22 PM Pump 

12 Failure Feb-12-18 4:42 PM Feb-13-18 9:59 AM Pump 

13 Cleaning Feb-17-18 2:47 PM Feb-17-18 7:13 PM Motor 

14 Maintenance Feb-25-18 4:31 PM Feb-25-18 5:00 PM Pump 

15 Failure Feb-28-18 9:00 AM Feb-28-18 3:10 PM Motor 

16 Failure Mar-01-18 10:16 AM Mar-01-18 10:43 AM Pump 

17 Inspection Mar-02-18 3:14 PM Mar-02-18 9:11 PM Pump 

18 Failure Mar-12-18 8:46 AM Mar-12-18 9:20 PM Motor 

19 Failure Mar-13-18 4:45 PM Mar-13-18 5:13 PM Pump 

20 Maintenance Mar-15-18 9:36 AM Mar-15-18 10:02 PM Motor 

Select the Analysis Settings 

The first step is to set up the event log folio for data entry: 

• On the Other page of the control panel: 

• Select Hours for the time units. 

• Select your preferred format for the date and time. 

• Select the Use OTSF column check box and clear the check box for the Use System 
column. 
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• On the Analysis page of the control panel, select the Prefer RRX if sufficient data option 
and select all three distributions for consideration. Do this for both the failure and repair 
distributions. 

Next, enter the given data into the folio: 

• In the "F=Failure/E=Event" column, mark all the events that are not considered to be actual 
failures (i.e., maintenance, cleaning and inspections) with an E. Use F for the failures. 

• In the "OTSF" column, mark all the events attributed to the motor component with a Y 
because it continues to operate despite a failed pump. The pump, however, will stop 
accumulating age if the motor fails. In this case, mark all the events attributed to the pump 
with an N. 

 

Once data entry is complete, go to the Main page of the control panel and make the following 
selections/inputs: 

• In the Levels to Analyze area, select Level 1. 

• In the Failures and Events area, select the Analyze Separately option so that we get 
separate results for the failures and the general events. 

• In the System area, enter the date and time the system monitoring started (January 1, 2018 
at 12 PM), as well as the date and time the system monitoring ended (March 18, 2018 at 1 
PM). Clear the check box for System is new on start date. 

Enter the shift schedule of the system by choosing Event Log > Actions and Settings > Set Shift 
Pattern or by clicking the icon on the control panel. 
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In the Shift Pattern window, specify 8:00 AM to 5:00 PM shifts seven days a week, as shown 
next. Click OK. 

 

Analyze the Data Set 

• Calculate the results by choosing Event Log > Analysis > Calculate or by clicking the icon on 
the control panel. 

 

• To view the failure and repair distributions, click the Show Analysis Summary (...) button 
on the control panel. The following report shows the results. In this example, the first table 
shows the failure and repair distributions for each component due to each type of event. 
The second table shows the total uptime and downtime for each component due to each 
type of event. 

 

Transfer the Results to a Life Data Folio 

You can perform further analysis by transferring the failure/repair data from the event log folio 
to a Weibull++ life data folio. 

Close the Results window and choose Event Log > Transfer Life Data > Transfer Life Data to 
New Folio or click the icon on the control panel. 
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This automatically creates a new Weibull++ life data folio within the project. The folio will 
contain separate data sheets for the failure and repair data. The following data sheet shows the 
failure data for the motor component. 

 

The [F] indicates an analysis of the failures, while [E] indicates an analysis of the general events 
(note that a combined analysis of F and E events would display [C]). The [FD] indicates that the 
data set is for the failure distribution, while [RD] indicates that the data set is for the repair 
distribution. 

You can visually compare the reliability of the components by fitting a distribution to the failure 
data and then generating an overlay plot. For example, the following overlay plot shows the 
failure data for the motor and for the pump, both analyzed using the 2-parameter Weibull 
distribution. 
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Folio Tools 

Set Shift Pattern 

One of the functions of the Weibull++ event log folio is to convert your log entries into 
failure/repair times. The failure times are obtained by calculating the date/time between the 
last repair and the date/time the new failure occurred. The repair times are obtained by 
calculating the difference between the date/time of occurrence and the date/time of 
restoration. In the case of a piece of equipment that does not run on a 24/7 basis, the Shift 
Pattern feature allows the analysis to take into consideration the periods when your system is 
not in use. This ensures accurate calculations for the failure and repair times. 

To create a shift pattern, choose Event Log > Action and Settings > Set Shift Pattern or click the 
icon on the Main page of the control panel. 
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The shift schedule you create applies to all of the systems you have identified in your data 
sheet. In other words, all the systems follow the same shift schedule. The following picture 
shows an example. 

 

The buttons at the lower left side of the window allow you to add or remove shifts. To save the 
current shift pattern as the default for new event log folios, click Save as Default. To load the 
default shift pattern settings for any existing event log folio, click Load Defaults. 

Systems Setup 

The Systems Setup window is available only if you have selected the Use System column check 
box on the Other page of the folio’s control panel. This window allows you to record the 
dates/times when you started and stopped collecting event log data for each system and 
whether it was new at the specified start date. The information you provide is used by the 
software to obtain the time to first occurrence of the failure (F) and general (E) events of every 
unique system. 

To open the Systems Setup window, click the icon on the Main page of the control panel. 

 

The following picture shows an example of a setup for two machines, M-1 and M-2. 
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The System is New column indicates that the system has never been used before and that the 
start date you entered is also the same calendar date that the system started operating. If the 
system is new, then the times to first occurrence of every event are considered to be complete 
data (failures) because the exact time-to-event is known. If the system is not new, then the 
times to first occurrence of every event are considered to be right censored data because the 
amount of time that the system operated before the observation period began is not known. 

Note that the information you provide in the Systems Setup window will be automatically 
copied to the System area on the Main page of the control panel and vice versa. 
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Transfer Life Data 

You can transfer the time-to-failure and time-to-repair data from an event log folio to a new or 
existing Weibull++ life data folio. To do this, choose Event Log > Transfer Life Data > Transfer 
Life Data to Selected Folio or click the icon on the Main page of the control panel. 

 

The following example shows the Transfer Life Data window for a system with three 1st level 
components. The [F] indicates an analysis of the failures, while [E] indicates an analysis of the 
general events (note that a combined analysis of F and E events would display [C]). The [FD] 
indicates that the data set is for the failure distribution, while [RD] indicates that the data set is 
for the repair distribution. 
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Transferring Data Sets 

This utility provides the option to transfer one selected data set, or to transfer all data sets 
together. 

To transfer a single data set: 

1. On the left panel, select a data set. 

2. On the right panel, specify where the data will be transferred. There are three ways to do 
this: 

• If you want to overwrite an existing data sheet with the selected data, select the check 
box for the specific data sheet. 

• If you want to create a new data sheet, select the name of the folio where you want to 
insert the new sheet and click Add Sheet. 

• If you want to create a new folio, select the Folios heading at the top of the panel and 
click Add Folio. 

3. Click Transfer to transfer the data. 
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4. Repeat the steps above for each data set you wish to transfer. 

To transfer all data sets at once: 

1. Select the Transfer all level IDs check box. 

2. On the right panel, select the check box for the folio where the data will be transferred. 
Note that the utility will create new data sheets in the folio for each data set. If the folio 
already contains data sheets that have the same name as the data to be transferred, you 
can choose to overwrite the data in those sheets by selecting the Replace sheets with 
same names check box. 

If you want to create a new folio instead, click Add Folio. 

3. Click Transfer to transfer the data. 

Transfer to BlockSim 

If you have ReliaSoft's system availability and maintainability analysis software, BlockSim, 
activated on your computer, you can export the analysis results as blocks in a new BlockSim 
simulation diagram. Each block represents a 1st level component, where the block's reliability 
model is based on the component's failure distribution and the corrective task is based on the 
component's repair distribution. (See Universal Reliability Definition (URD).) 

To transfer your Weibull++ analysis results, first calculate the parameters of the data set, and 
then choose Event Log > Transfer Life Data > Transfer to BlockSim. 

 

In the Transfer to BlockSim window, select which components you wish to transfer and click 
OK. The selected components will be transferred to BlockSim as blocks that are connected in a 
reliability-wise series configuration, as shown in the following example. You can then edit the 
reliability block diagram in the BlockSim application, if desired. 

https://www.reliasoft.com/products/reliability-analysis/blocksim
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Transfer to BlockSim window in Weibull++ 

  

 
Reliability block diagram in BlockSim 
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Chapter 6: Life-Stress Data Analysis Folios 
Life-Stress Data Folio 
For life-stress data only. 

In basic life data analysis, units are tested under normal use conditions in order to obtain 
information about a product’s failure behavior. In some cases, however, it is desirable to obtain 
this information more quickly than is possible with use level testing. For example, products with 
long lifetimes or short periods between design and release, as well as products that are 
operated continuously, may produce results too slowly with basic life data analysis. 

The Accelerated Life Testing (ALTA) life-stress data folio is used to perform quantitative 
accelerated life testing data analysis. In this analysis, the engineer extrapolates a product’s 
failure behavior at normal conditions from life data obtained at accelerated stress levels. Since 
products fail more quickly at accelerated stress levels, this sort of analysis allows the engineer 
to obtain reliability information about a product (e.g., mean life, probability of failure at a 
specific time, etc.) in a shorter time. The ReliaWiki resource portal has more information on the 
basics of accelerated life testing at: 
http://www.reliawiki.org/index.php/Introduction_to_Accelerated_Life_Testing. 

Note: Life-stress data folios are available only if supported by your license. For more 
information, contact us. 

Life-Stress Data Folio Setup 
For life-stress data only. 

The Accelerated Life Testing (ALTA) life-stress data folio contains the tools for performing an 
accelerated life testing data analysis. 

To add an life-stress data folio to a project, choose Home > Insert > Life-Stress Data, or right-
click the Life-Stress Data folder in the current project explorer and choose Add Life-Stress Data 
on the shortcut menu. 

 

A setup window will prompt you to select a data type to use in the folio, the stresses to use and 
a unit appropriate for your data (the unit may be measured in mileage, distance, weight, etc.; 
see Unit Settings). 

http://www.reliawiki.org/index.php/Introduction_to_Accelerated_Life_Testing
https://www.reliasoft.com/about/contact-us
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There are two types of data available: times-to-failure data or free-form data. In addition, 
times-to-failure data may contain three forms of censoring: suspensions (right censored), 
interval censored or left censored data. (See Accelerated Life Testing Data Types.) 

Any of the times-to-failure data types can also be entered as grouped data. The ReliaWiki 
resources portal has more information on grouped data analysis at: 
http://www.reliawiki.org/index.php/Grouped_Data_Parameter_Estimation. 

The first page of the Data Sheet Setup window is shown next. 

 

Note that when you select a data type, the preview table at the bottom of the setup window 
will show you the names of the data entry columns that will appear in the data sheet. 

If you are creating a new folio, you will also need to specify the time units appropriate for your 
data. Units may be measured in time, distance, weight, etc. The appropriate columns in the 
data sheet will be automatically configured for the units you select. If you later wish to change 
the time units of an existing data sheet, click the Change Units icon on the Main page of the 
control panel of the data sheet. 

http://www.reliawiki.org/index.php/Grouped_Data_Parameter_Estimation
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If you wish to use the same stress column and stress level settings that were used when you 
last set up an Accelerated Life Testing life-stress data folio—or if you are only changing the data 
type of an existing folio—click OK to close the window and view your folio. Otherwise, click 
Next > to display the second page of the window. 

 

You can use this page to do the following: 

• Adjust the number of stress columns to be used in your folio by selecting the appropriate 
check boxes. 

• Every stress column represents a stress type. So, for example, a data sheet with two 
stress columns would be used for data obtained from a two-stress test. In this case, 
each row would contain a failure/suspension time and the two stress values that define 
the stress level at which the data point was obtained (e.g., a unit might have failed at 
100 hours while tested at 343 K and 80% relative humidity). 
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• If you would like to change the number of stress columns in a folio you have already 
created, click the Add or Remove Columns icon on the Main page of the folio's control 
panel. 

 

• Change the labels of each stress column by changing the text under Stress Name or Stress 
Units. These fields are merely for adding text to the headings of the stress columns, so you 
can keep track of which stress type is associated with each stress column. This information 
is not relevant to the software’s calculations. 

• Define the product's normal stress level by entering values under the Use Level heading for 
each stress type (e.g., the product that was tested under accelerated temperature and 
humidity might normally operate at 323 K and 50% humidity). After the folio is created, you 
can change this value in the Use Stress Level window. 

IMPORTANT: Temperature values must always be entered in absolute units (e.g., Kelvin or 
Rankine). To convert temperature values in the data sheet that were entered in Celsius or 
Fahrenheit to absolute units, choose Life-Stress Data > Options > Convert Stress Values. 

Like the first page of the setup window, there is a preview at the bottom of the page that shows 
you how the names of the associated columns will appear in the data sheet. 

Accelerated Life Testing Data Types 
For life-stress data only. 

For Accelerated Life Testing analysis, there are two types of life-stress data: times-to-failure 
data and free-form data. In addition, times-to-failure data may contain three forms of 
censoring: suspensions, interval censored or left censored data. 

In a life-stress data folio, the data type you select determines the data entry columns that 
appear in the data sheet. The following sections describe each data type and demonstrate how 
to enter data in a life-stress data folio data sheet. 

Tip: You can change the data entry columns for an existing data sheet anytime by choosing Life-
Stress  Data > Format and View > Alter Data Type. 
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TIMES-TO-FAILURE DATA 

Times-to-failure data sets, also known as complete data, are obtained by recording the exact 
times when the units failed. For example, if we tested 6 units at two stress levels and they all 
failed, and we recorded the time when each failure occurred, we would then have complete 
information as to the time of each failure in the sample. 

To use this data type, select the Times-to-failure data check box on the setup window. Your 
data sheet will have a Time Failed column for recording the times-to-failure. The example 
shown next displays a life-stress data folio data sheet where all the units in the sample failed. 
The exact time of each failure is recorded. 

 

If multiple units failed at the same time, you can choose to enter the data in groups. To do this, 
select the I want to enter data in groups check box in the setup window. This adds a third 
column to the data sheet, as shown next. In this example, the units that failed at the same time 
are grouped together. The Number in State column indicates the number of failed units in that 
group (the software will automatically enter a 1 if you leave this cell blank) and the State End 
Time column indicates the exact time the units in each group failed. 

 

Times-to-Failure with Suspensions (Right Censored Data) 

The My data set contains suspensions option allows you to record data for units that did not 
fail during the observation period. These data points are known as suspensions. The suspension 
time is the last time the unit was observed as not failed. In the example shown next, a test was 
conducted and five units in the sample failed, but one unit (marked with an "S" in the first 
column) was still operational when the test terminated at 7,500 hours. 
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Times-to-Failure with Interval and Left Censored Data 

The My data set contains interval and/or left censored data option allows you to record data 
when there is uncertainty as to the exact time when a unit fails. This type of data frequently 
comes from situations where the units are not constantly monitored. For example, if you are 
running a test on five units and inspecting them every 100 hours, you only know that a unit 
failed or did not fail between inspections. (If you select to enter both suspensions and interval 
data, you can enter suspensions as intervals.) Left censored data is a special case of interval 
censored data. With left censored data, the interval is between time = 0 and some inspection 
time. 

In the example shown next, the first unit was operational at the start of the test but found 
failed at 150 hours (thus, it is a left censored data point). The second unit was still operating at 
150 hours, but it failed at some point prior to the next observation at 300 hours, and so on. 

 

FREE-FORM (PROBIT) DATA 

Starting in Version 2019, the free-form data type is used to analyze the relationship between an 
independent variable (x-axis data) and the percentage of failures (y-axis data) in response to 
the variable. The y-axis data are treated as probability units, or probits, and they show how the 
percentage of failures increase in response to a variable (e.g., time, distance, stress level, etc.). 
For example, you could use the free-form data type to record the Y percentage of items that 
failed after X number of hours at a given stress. 

To use this data type, select the Free-form (probit) data check box in the setup window. In the 
data sheet, enter the values for the independent variable in the X-Axis value column and enter 



Chapter 6: Life-Stress Data Analysis Folios 

Weibull++ 2020 User's Guide 401 

 

the cumulative percentage of failures in the Y-Axis value column. The following is an example of 
a data set that shows the effect of time (x-axis data) on the probability of failure (y-axis data) at 
specified stress levels of a product. 

 

Life-Stress Data Folio Control Panel 
For life-stress data only. 

The Accelerated Life Testing (ALTA) life-stress data folio control panel allows you to configure 
the analysis settings for the data sheet and view/access the results. It consists of multiple 
pages, each containing options for performing particular tasks. This topic focuses on the Main 
page of the life-stress data folio control panel, which contains most of the tools you will need to 
perform accelerated life testing analysis. For more information about the control panel in 
general, see Control Panels. 

CONTROL PANEL MAIN PAGE 

The Main page of the life-stress data folio control panel includes the following settings: 

• The Model drop-down list allows you to select the life-stress relationship and life 
distribution that will be used to extrapolate failure behavior at normal operating 
conditions. The selected life distribution is fitted to the data obtained at each accelerated 
stress level used in the test, and then the selected life-stress relationship is used to 
extrapolate the probability density function (pdf) at the use stress level from the pdfs at the 
accelerated levels. 

There are five life-stress relationships to choose from in Accelerated Life Testing Standard 
and four additional relationships in Accelerated Life Testing PRO. For both versions of 
Accelerated Life Testing, there are three life distributions to choose from. The choice of the 
life-stress relationship depends on various factors, including the types and number of 
stresses used in the test. The ReliaWiki resource portal has more information on the 
distributions and life-stress relationships at: 
http://www.reliawiki.org/index.php/Accelerated_Life_Testing_Data_Analysis_Reference. 

http://www.reliawiki.org/index.php/Accelerated_Life_Testing_Data_Analysis_Reference


Chapter 6: Life-Stress Data Analysis Folios 

402 https://www.reliasoft.com/weibull 

 

• Tip: If you are not certain which life distribution would provide the best fit for your data, 
you can use the Accelerated Life Testing Distribution Wizard to guide you through the 
selection process. 

• Life distributions: 2-parameter Weibull, lognormal (not available with the proportional 
hazards relationship) and 1-parameter exponential. 

• Life-stress relationships in Accelerated Life Testing Standard: 

• Arrhenius: a single-stress model typically used when temperature is the accelerated 
stress. 

• Eyring: a single-stress model typically used when temperature or humidity is the 
accelerated stress. 

• Inverse power law (IPL): a single-stress model typically used with a non-thermal stress 
such as vibration, voltage or temperature cycling. 

• Temperature-humidity (TH): a double-Arrhenius model that is typically used when 
temperature and humidity are the acceleration variables. 

• Temperature-nonthermal (TNT): a combination of the Arrhenius and IPL relationships 
that is typically used when one stress is temperature and the other is non-thermal (e.g., 
voltage). 

• Additional life-stress relationships in Accelerated Life Testing PRO: 

• Generalized Eyring (GER): a variation of the Eyring relationship that is typically used 
when both temperature and humidity are accelerated. 

• Proportional hazards (PPH): analyzes data with up to 8 simultaneous stress types using 
the exponential relationship for each stress. It also allows the use of zero as a stress 
value, which enables the analysis of data with indicator variables (e.g., 0 = on/off and 1 
= continuous operation). 

• General log-linear (GLL): supports the analysis of data with up to 8 simultaneous stress 
types and provides the flexibility of specifying the life-stress relationship (Arrhenius, IPL 
or exponential) for each stress. Like the PPH model, this model also allows for the 
analysis of data with indicator variables. 

• Cumulative damage (CD): analyzes data with up to 8 stress types and/or situations 
where the stress varies with time. This model is not available for free-form data. 
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• Directly underneath the Model drop-down list are options for selecting the stress columns 
and, when applicable, the stress transformations that will be used in the analysis, and 
defining the use stress level for every stress that is selected to be used in the analysis. 

 

• The Analysis Summary area displays the calculated parameter values and other values for 
your selected model. As an example, the following picture shows the analysis results for a 
particular data set. 

 

Depending on your application settings, additional information may also be displayed: 

• The Ea (activation energy) value is displayed when temperature-related models, such 
as Arrhenius, Eyring, generalized Eyring, temperature-humidity or temperature-
nonthermal, are used. It represents the effect of temperature; a large value means 
temperature has a large effect on the life of the product. 

• The Scale Parameter value represents the product's characteristic life. 
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• For the Weibull distribution, the characteristic life is equal to the value of the eta 
parameter (i.e., the time at which unreliability = 63.2%). 

• For the lognormal distribution, it is equal to Exp(Log-mean) (i.e., the time at which 
unreliability = 50%). 

• For the exponential distribution, it is equal to the mean life. 

• The LK Value (likelihood function value) is the logarithm of the likelihood value for the 
model parameters. It can help you compare how well different models fit the same 
data set. The model with the highest LK value is considered to have the best fit 
statistically for that data. However, because this value is influenced by the sample size 
and the variability of the data set, it varies across different data sets and cannot be 
used by itself to evaluate a particular model. 

• The use stress level of every stress that was used in the analysis. 

• The number of failures and suspensions in the data set. 

• The model status (as shown in the previous picture) is displayed if the result of the 
analysis is associated with a published model. The status "Synchronized" indicates that 
the published model reflects the latest results from the analysis. If the analysis has 
been modified since the model was last published (e.g., if more data has been added, 
an analysis setting has changed, etc.), the status will display as "Out of Sync." (See 
Publishing Models.) 

Additional Results 

The following tools may also be used in conjunction with your own engineering knowledge 
about the model in order to further evaluate the fit of the model to the data set. 

• The Use Level Probability and Standardized Residuals plots show you how well the 
solution line tracks the plotted data points. This allows you to visually assess the fit of the 
selected model. 

• The Likelihood Ratio Test is used to confirm the assumption of a common shape parameter 
among the data obtained at the various accelerated stress levels. This assumption underlies 
the use of any model that includes the Weibull or lognormal life distribution. 

• Confidence Bounds allow you to quantify the amount of uncertainty in the parameter 
estimates and other functions, such as reliability predictions, due to sampling error. The 
narrower the confidence bounds at a given confidence level, the closer the estimates are to 
the true value of the parameters and the better the precision on the reliability predictions. 
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You can visualize the confidence bounds by using plots, or you can view the calculated 
values of the confidence bounds by using the Quick Calculation Pad. 

FOLIO TOOLS 

The folio tools are arranged on the left side of the Main page of the control panel. Use these 
tools to manage data and experiment with the results of your analysis. 

  Calculate estimates the parameters of the chosen model, based on the current data 
set and the specified analysis settings. This tool is also available by choosing Life-Stress 
Data > Analysis > Calculate. 

  Plot creates a new sheet in the folio that provides a choice of applicable plot types. For 
life-stress data folios, this includes plots such as Use Level Probability, Reliability vs. Time, 
Life vs. Stress, etc. You can also create a Plot sheet by choosing Life-Stress Data > Analysis > 
Plot. 

  QCP opens the Accelerated Life Testing Quick Calculation Pad, which allows you to 
calculate results, such as the mean life and the probability of failure, based on the currently 
active data sheet. This tool is also available by choosing Life-Stress Data > Analysis > Quick 
Calculation Pad. 

  Distribution Wizard opens the Accelerated Life Testing Distribution Wizard, which 
helps you select the life distribution that will best fit your data. This tool is also available by 
choosing Life-Stress Data > Analysis > Distribution Wizard. 

  Alter Data Type opens the Data Sheet Setup window, which allows you to change the 
data entry columns in the current data sheet. Note that when you change the setup, you 
may lose information already entered in the data sheet. For example, switching the data 
sheet from one that supports interval data to one that supports only right censored data 
will remove all the inspection times. This tool is also available by choosing Life-Stress Data 
> Format and View > Alter Data Type. 

  Add or Remove Columns allows you to add/remove columns for stress levels and unit 
IDs. 

  Change Units opens the Change Units window, which allows you to change the units 
for the values in the current data sheet. 
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  Auto Group Data opens the Auto Group Data window, which allows you to group 
together identical data points. Grouping data significantly speeds up calculations when you 
have a very large data set. This tool is also available by choosing Life-Stress Data > Format 
and View > Auto Group Data. 

  Alter Parameters (also called Alter Parameters w/o Recalculation) allows you to 
manually alter the value of one (or more) parameters, while keeping the original values of 
the rest of the parameters and the variance/covariance matrix the same. The LK value, the 
solution line on plots and all subsequent analyses will be based on the modified set of 
parameters.  

  Likelihood Ratio Test opens the Likelihood Ratio Test tool, which allows you to assess 
the assumption of a common shape parameter across all the stress levels used in the test. 
This assumption underlies the use of any model that includes the Weibull or lognormal life 
distribution. You can also open this tool by choosing Life-Stress Data > Options > Likelihood 
Ratio Test. 

  Transfer Data to Life Data Folio allows you to transfer data from the life-stress data 
folio to a life data folio. 

Accelerated Life Testing Plots 
For life-stress data only. 

To create a plot in a life-stress data folio, choose Life-Stress Data > Analysis > Plot or click the 
icon on the Main page of the control panel. 

 

Tip: You can add additional plot sheets to the folio by choosing Life-Stress Data > Folio Sheets > 
Insert Additional Plot. The additional sheets can function as overlay plots to display results 
from multiple data sheets in the current folio on a single plot. 

The following is a description of the different types of plots that can be created in a life-stress 
data folio. (For general information on working with plots, see Plot Utilities.) 

Note that the use stress level for plots is by default the level you entered on the Main page of 
the control panel. However, you may adjust the level for plots by clicking Set Use Stress directly 
underneath the Analysis Summary area of the Plot page. This will not change the use stress 
level specified on the Main page. 
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• The Use Level Probability plot shows the trend in the probability of failure over time at the 
specified use stress level. The plot also shows data points from the test that are 
transformed from the accelerated stress levels to the use stress level. The relationship 
between unreliability and time is linearized wherever possible, which results in non-linear 
axis scales. Like the standardized residuals plot, this plot is useful for comparing models 
that use the same life-stress relationship. 

• The Probability plot shows the probability of failure (i.e., unreliability) as a function of time 
at every stress level used in the test. The plot also displays the extrapolated line for 
unreliability at the specified use stress level. 

Note: Unlike the probability plots for other distributions, the y-axis in an exponential 
probability plot always indicates the reliability instead of the unreliability. This tradition 
arose from the time when probability plotting was performed "by hand." The exponential 
reliability model starts with R = 1 at T = 0 (or gamma). Thus, if the unreliability were plotted, 
the axis would start at Q = 1 - R = 0, which is not possible, given that the y-axis scale is 
logarithmic. 

• The Reliability vs. Time plot shows the reliability values over time at the specified use 
stress level, capturing trends in the product’s failure behavior. The plot also shows data 
points from the test that are transformed from the accelerated stress level to the use stress 
level. 

• The Unreliability vs. Time plot shows the probability of failure of the product over time at 
the specified use stress level. Unlike the Use Level Probability plot, the axis scales are linear. 

• The pdf Plot shows the probability density function of data over time at the specified use 
stress level. This allows you to visualize the distribution of the data set. 

• The Failure Rate vs. Time plot shows the failure rate of the product over time at the 
specified use stress level. 

• The Mean Remaining Life plot show the expected survival time of a product given the 
current age of the product. 

• The Stress Profile plot is available only when the analysis uses stress profiles. The plot 
shows how the stress values for each profile changed over time. The plot also shows the 
data points from the test and the stress level at which they were obtained. If the test 
includes multiple stresses, click Set Use Stress to select which use stress values to show in 
the plot. 
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The following plots show the relationship between stress level and another reliability metric. In 
multi-stress situations, one stress is varied and the remaining stresses are fixed. Click Set Use 
Stress on the Plot page of the control panel to select the varied stress. 

• The Life vs. Stress plot shows the effect of a stress on the life of the product. Multiple pdfs, 
each at a different stress level used in the test, are displayed on the plot. The failure times 
obtained at each stress level are shown at the base of the associated pdf. Note that the 
lines and pdfs are mapped to the use stress level, but the failure times are plotted at the 
tested conditions. 
 
If a model that uses the Weibull distribution is selected, an eta line will be displayed as well. 
The eta line estimates the time by which 63.2% of units in the population are expected to 
fail. The plot may also include other life lines that show the relationship between stress 
level and the time by which other specified percentages of a population are expected to fail 
(see Specifying Life Lines.) The life-stress relationship is linearized whenever possible. 
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• The Std vs. Stress plot shows the standard deviation of failure time as a function of stress 
level, thus providing information about the spread of data at every given stress level on the 
x-axis. 

• The AF vs. Stress plot shows the acceleration factor as a function of stress level. The 
acceleration factor is determined by dividing the product’s life under normal operating 
conditions by its life at an accelerated stress level. For example, if the acceleration factor is 
2 at an accelerated stress level of 350 K, then the product’s life at 350 K is expected to be 
half of its life at the specified use stress level. 

The following plots are residual plots. In these plots, a residual value for each data point is 
displayed. As a result, these plots are useful for assessing model assumptions, revealing 
inadequacies in the model and revealing any extreme observations. The ReliaWiki resource 
portal has more information on residual plots at: 
http://www.reliawiki.org/index.php/Accelerated_Life_Testing_and_ALTA#Residual_Plots. 

• The Standardized Residuals plot is useful for determining the adequacy of the selected 
model for the data. The appropriate probability transformation is given on the y-axis and 
the values of the residuals are given on the x-axis. The residual values for each data point 
are color-coded to indicate which accelerated stress level the associated data point was 
obtained from. If the model adequately fits the data, the points should track the plot line. 
 
For example, the next figures show the results of an Arrhenius-Weibull model and an 
Arrhenius-lognormal model using the same data set. As you can see, the plot shows that 
the lognormal distribution presents the better fit to this particular data set. 

 

• The Cox-Snell Residuals plot is similar to the standardized residuals plot, except the line is 
plotted on an exponential probability plotting paper and is on the positive domain. 

http://www.reliawiki.org/index.php/Accelerated_Life_Testing_and_ALTA#Residual_Plots


Chapter 6: Life-Stress Data Analysis Folios 

410 https://www.reliasoft.com/weibull 

 

• The Standard vs. Fitted Value plot helps to detect behavior that isn’t modeled in the 
underlying relationship. It plots the standardized residuals versus the scale parameter of 
the underlying life distribution (which is a function of stress) on log-linear paper (linear on 
the y-axis). Note that when heavy censoring is present, the plot is more difficult to 
interpret. 

Specifying Life Lines 
For life-stress data only. 

You can specify additional life lines to be plotted on life vs. stress plots in Accelerated Life 
Testing by clicking the Life Lines link on the plot sheet control panel. The Specify Life Lines 
window will open. 

This window allows you to define up to ten additional life lines to be shown on life vs. stress 
plots. For each life line, enter the unreliability value. You can enter values manually or use the 
up and down arrows beside each field to increase/decrease the value. You can keep previously 
entered values without plotting them by simply clearing the appropriate check boxes. You can 
select to show or hide confidence bounds for each life line. 

To use your current settings by default on life vs. stress plots, click the Set As Default button. 
You can reset these settings by clicking Reset Application Settings on the Reset Settings page of 
the Application Setup. 

Select Stress Columns 
For life-stress data only. 

The Select Stress Columns window is used to select which of the stress columns in your data 
sheet will be used in the analysis. When applicable, this window also includes drop-down lists 
that allow you to categorize the selected stresses. To access the window, click Select Stress 
Columns directly underneath the Model area of the Main page of the control panel. 

All of the stress columns in your data sheet are listed in the Available Stress Columns area. To 
use a column in the analysis, select the corresponding check box. Note that the text directly 
above the Available Stress Columns area provides information on how many stresses are 
required and how many can be used with the selected model. 

If you chose a temperature-nonthermal (TNT) or generalized Eyring (GER) model on the control 
panel, you will be required to categorize each stress as thermal or nonthermal. To use either of 
these models, you must select exactly two stress columns: one for a thermal stress and one for 
a nonthermal stress. 
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Tip: You can also choose which stress columns to include in the analysis by selecting the check 
boxes in the column headings of the data sheet. 

Stress Transformation 
For life-stress data only. 

When you select a general log-linear (GLL) or cumulative damage (CD) model, you must use the 
Stress Transformation window to choose one transformation for each stress that is selected to 
be used in the analysis. To access this window, click Stress Transformation directly underneath 
the Model area of the Main page of the control panel. 

The Transformation drop-down list provides three options for how the stress will be 
transformed within the model: 

• Use the None X=V transformation for stress types associated with the exponential life-
stress relationship (LSR). This transformation is commonly used for indicator variables (e.g., 
0 = on/off and 1 = continuous operation). 

• Use the Reciprocal X=1/V transformation for stress types associated with the Arrhenius 
LSR. This transformation is commonly used for thermal stresses. 

• Use the Logarithmic X=ln[V] transformation for stress types associated with the inverse 
power law LSR. This transformation is commonly used for non-thermal stresses. 

Use Stress Level 
For life-stress data only. 

The Use Stress Level window is used to define the normal stress levels for every stress that is 
selected to be used in the analysis. This value can also be defined during the setup of the life-
stress data folio. To access the window, click Set Use Stress directly underneath the Model area 
of the Main page of the control panel. 

The Stress area of the window lists every stress that will be used in the calculation. In the Use 
Stress Level area, enter the stress level that the product will experience under normal 
conditions. For example, to specify that the normal operating temperature for a product is 328 
K and the normal operating voltage is 2 V, you would enter the following into the window: 
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If the analysis is for a cumulative damage (CD) model, you will also be able to use profiles to 
describe time-dependent stress conditions that the product will experience during normal use. 

QCP Calculations for Accelerated Life Testing 
For life-stress data only. 

Accelerated Life Testing includes a Quick Calculation Pad (QCP) for computing useful metrics. 
You can access the QCP by clicking its icon on the Main page of the control panel. 

 

To perform a calculation, select the appropriate option and enter any required inputs in the 
Input area, then click Calculate. For more detailed information on how to use the QCP in 
general, see Quick Calculation Pad (QCP). 

The following calculations are available for accelerated life testing data analysis: 

PROBABILITY 

Reliability 

Calculates the probability that a new product will operate without failure for a given period 
of time at the stress level specified in the Stress field. Enter the time at which you wish to 
calculate the reliability in the Mission End Time field. The mission is assumed to start at 
time = 0. 

For example, a reliability of 90% for a mission end time of 3 years means that if 100 
identical units are fielded, then 90 of them will still be operating at the end of 3 years. 

Probability of Failure 
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Calculates the probability that a new product will be failed in a given period of time at the 
stress level specified in the Stress field. Enter the time at which you wish to calculate the 
probability of failure in the Mission End Time field. The mission is assumed to start at time 
= 0. 

Probability of failure is also known as unreliability, and it is the inverse of the reliability. For 
example, a probability of failure of 10% for a mission end time of 3 years is equivalent to a 
90% reliability. 

Conditional Reliability 

Calculates the probability that a product will successfully operate at a specific time interval 
given that it has operated successfully up to a specified time and at the stress level 
specified in the Stress field. Enter the start time of the interval in the Mission Start Time 
field and enter the duration of the interval in the Mission Additional Time field. 

For example, a product may have a reliability of 90% for 3 years if it operates at a stress 
level of 10 volts. If the product has operated for 2 years without failure, the conditional 
reliability for an additional year (for a total of 3 years of operation) may be 95%. 

Conditional Probability of Failure 

Calculates the probability that a product will be failed at a specific time interval given that it 
has not failed up to a specified time and at the stress level specified in the Stress field. 
Enter the start time of the interval in the Mission Start Time field and enter the duration of 
the interval in the Mission Additional Time field. 

For example, a product may have a 10% probability of failure for 3 years if it operates at a 
stress level of 10 volts. If the product has operated for 2 years without failure, the 
conditional probability of failure for an additional year (for a total of 3 years of operation) 
may be 5%. 

LIFE 

Reliable Life 

Calculates the estimated time at which a specified reliability value will be achieved at the 
stress level specified in the Stress field. Enter the reliability goal in the Required Reliability 
field. For example, a goal of 90% reliability with a reliable life of 4 years means that if 100 
identical units are fielded, then 90 of them will be still be operating at the end of 4 years. 

BX% Life 
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Calculates the estimated time at which a specified probability of failure will be achieved at 
the stress level specified in the Stress field. Enter the probability of failure in the BX% Life 
At field. For example, a B10 life of 4 years means 10% of the fielded units are expected to 
be failed at the end of 4 years of operation (note that this is equivalent to a 90% reliability 
with a reliable life of 4 years). 

Note: In the early days of reliability engineering, bearing manufacturers used the term "B10 
life" to refer to the time by which 10% of the components would fail. Keeping with 
tradition, ReliaSoft retained this nomenclature but replaced "10" with "X%," since the 
software allows you to get this information at any percentage point and not just at 10% 
(e.g., B1 life, B5 life, etc.). 

Mean Life 

Calculates the average time at which a product is expected to operate before failure at the 
stress level specified in the Stress field. In the life-stress data folio, the mean life is the 
mean time to failure (MTTF) based on the fitted model. 

Note: The term mean time to failure (MTTF) is used as a metric for the analysis of non-
repairable components. In the Accelerated Life Testing life-stress data folio, all data are 
assumed to come from non-repairable components that are independent and identically 
distributed (i.i.d.). On the other hand, the term mean time between failures (MTBF) is used 
as a metric in repairable systems analysis, where the same system may fail and be repaired 
multiple times. Simple repairable system data can be analyzed in Weibull++ using the 
Recurrent Event Data Analysis (RDA) folio. 
 
For more complex repairable system analyses, see ReliaSoft’s BlockSim. 

Mean Remaining Life 

Calculates the expected remaining life given that the product, component or system has 
survived to time t at the stress level specified in the Stress field. Enter the time at which 
you wish to calculate the mean remaining life in the Mission End Time field. 

RATE 

Failure Rate 

Calculates the instantaneous number of failures per unit time that can be expected at a 
certain time and at the stress level specified in the Stress field, given that a unit survives to 
that age. Enter the time at which you wish to calculate the failure rate in the Mission End 
Time field. 

https://www.reliasoft.com/products/reliability-analysis/blocksim


Chapter 6: Life-Stress Data Analysis Folios 

Weibull++ 2020 User's Guide 415 

 

For example, a failure rate of 0.01 at 100 hours and at a stress level of 10 volts means that 
each unit that survives to 100 hours has approximately a 1% probability of failure in the 
next hour. 

ACCELERATION 

Acceleration Factor 

Calculates the ratio of the product's use level life to its life at an accelerated stress level. For 
example, if the product has a life of 100 hours at the use stress level, and it has a life of 50 
hours at an accelerated level, then the acceleration factor at the specified stress levels 
would be 2. Click the arrow in the Stress field to enter the use level stress values for every 
stress that was used to calculate the data sheet. Click the arrow in the Accelerated Stress 
field to enter the accelerated stress values. 

BOUNDS 

Parameter Bounds 

Calculates the specified bounds on the parameter estimates, allowing you to quantify the 
amount of uncertainty in those estimates. This option is available only when you have 
specified the type of confidence bounds to use from the Bounds drop-down list. When you 
click Calculate, the Results Window will open to display the estimated parameters and their 
bounds. 

Single-Stress Example 
For life-stress data only. 

A manufacturer asks a team of engineers to determine, with a confidence level of 90%, whether 
a prototype device has a reliability of at least 90% at 6,000 hours. Since the life of the product 
under normal operating conditions is expected to be more than 15,000 hours, it is not feasible 
to test under these conditions and obtain results in an acceptable timeframe. So the engineers 
decide to run an accelerated test with a duration of 7,500 hours, by which time they expect 
that the majority of units will have failed. The normal operating temperature for this product is 
323 K (50°C), and temperature is the only acceleration variable. 

The data collected from the test for three different accelerated stress levels are shown next. 

Stress Level (K) 393 408 423 

Failure Time (Hr) 3850 3300 2750 

4340 3720 3100 
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4760 4080 3400 

5320 4560 3800 

5740 4920 4100 

6160 5280 4400 

6580 5640 4700 

7140 6120 5100 

Did not fail 6840 5700 

Did not fail Did not fail 6400 

CREATE A LIFE-STRESS DATA FOLIO 

1. Choose Home > Insert > Life-Stress Data. On the first page of the setup window, make sure 
only the My data set contains suspensions check box is selected. Then, select Hour (hr) 
from the Units drop-down list and click Next. 

2. On the second page of the setup window, select Temperature as the stress type. Set the 
use level temperature to 323 with K as the unit. Click OK to create the folio. 

3. Enter the given data in the data sheet. The first fifteen rows of the data sheet are shown 
next. 
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ANALYZE THE DATA SET 

4. On the Main page of the folio’s control panel, select the Arrhenius-Weibull model and click 
the Calculate icon. The parameters of the model will be automatically computed and 
displayed in the Analysis Summary area of the control panel. 

 

5. To estimate the reliability of the device at 6,000 hours, click the Quick Calculation Pad icon 
on the control panel. 

 

6. In the QCP, choose to calculate the Reliability with Lower One-Sided confidence bounds. 
Select Hour for the time units and then make the following inputs: 

• Stress = 323 

• Mission End Time = 6000 

• Confidence Level = 0.90 

7. Click Calculate to display the results, as shown next. The results show that the device’s 
estimated reliability at 6,000 hours is 99.09%. The lower one-sided 90% confidence bound 
is shown to be 90.61%. In other words, the test shows with 90% confidence that the 
device’s reliability a 6,000 hours is at least 90.61%, thus meeting the demands of the 
manufacturer. 
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Two-Stress Example 
For life-stress data only. 

A team of reliability engineers is instructed to perform an accelerated life test and use the 
accelerated test data to extrapolate a product's use level failure behavior. They are asked to 
estimate, with 90% confidence, the time at which the product will have an unreliability of 10% 
(i.e., the B10 life). 

The normal operating temperature for this product is 328 K, and the normal operating voltage 
is 2 V. It was decided to accelerate both stresses in the test. The following table shows the data 
from the test. 
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Time Failed  (Hr) Temperature (K) Voltage (V) 

620 348 3 

632 348 3 

658 348 3 

822 348 3 

216 378 3 

246 378 3 

332 378 3 

400 378 3 

380 378 5 

416 378 5 

460 378 5 

596 378 5 

CREATE A LIFE-STRESS DATA FOLIO 

1. Choose Home > Insert > Life-Stress Data. Since the data set contains only exact failure 
times, do not select any of the check boxes in the Options for the Times-to-Failure Data 
Type area. Select Hour (hr) from the Units drop-down list and click Next. 

2. On the second page of the setup window, select Temperature and Voltage as the stress 
types. Set the use level temperature to 328 with K as the unit, and set the use level voltage 
to 2 with V as the unit. Click OK to create the folio. 

3. In the data sheet of your new folio, select the check boxes inside the Temperature and 
Voltage column headings. Both stresses will now be used in the calculation for the selected 
model. 

4. Enter the given data into the data sheet. 

ANALYZE THE DATA SET 

5. On the Main page of the folio’s control panel, select the TNT-Weibull model (i.e., the 
temperature-nonthermal life-stress relationship combined with the Weibull life 
distribution) and click the Calculate icon. The parameters of the model will be automatically 
computed and displayed in the Analysis Summary area of the control panel. 
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6. To obtain the two-sided 90% confidence bounds on the product's B10 life, click the Quick 
Calculation Pad icon on the control panel. 

 

7. In the QCP, choose to calculate the BX% Life with Two-Sided Bounds. Select Hour for the 
time units and then make the following inputs: 

• Stress = 328; 2 

• BX% Life At = 10 

• Confidence Level = 0.9 

8. Click Calculate to display the results, as shown next. The results show, with 90% 
confidence, that the time at which the product will have an unreliability of 10% is between 
459.7681 and 853.1253 hours. 
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9. To view a plot of the result, click the Plot icon on the Main page of the control panel. 

 

10. On the Plot page, select Unreliability vs. Time from the Plot Type drop-down list. 
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Time-Dependent Stress Profiles 

TIME-DEPENDENT STRESS PROFILES 

For life-stress data only. 

Stress levels under test conditions and/or during normal use may vary with time. For example, 
an engineer may decide that each unit in a sample will be tested at 310 K for the first 10 hours 
of a test, 320 K for the next 10 hours, and 330 K for the remainder of the test. 

You can create profiles, which are resources that allow you to represent how stress levels will 
vary with time. Profiles are designed to be used with the cumulative damage model, which is 
available only in Accelerated Life Testing PRO. When you select a cumulative damage model in 



Chapter 6: Life-Stress Data Analysis Folios 

Weibull++ 2020 User's Guide 423 

 

the life-stress data folio, all of the profiles validated in your project become available to 
describe use level stress conditions and stress conditions during testing. 

Note: If you are an Accelerated Life Testing Standard user who needs to use time-dependent 
stress profiles in your analysis, please contact ReliaSoft for information about upgrading to 
Accelerated Life Testing PRO. 

Stress Profiles in the Life-Stress Data Folio 

There are two ways you can use profiles in a life-stress data folio. Note that: 

• Because stress and time units are not defined in a profile, it is important to apply profiles 
only to folios that are intended to use the same stress and time units. 

• If you update a profile that is associated with a life-stress data folio, the calculations in the 
folio will not be updated automatically. To update the calculations, click the Calculate icon 
on the folio's control panel. 

Use Profiles to Describe Stress Conditions 

Select the cumulative damage life-stress model on the folio's control panel. To assign a stress 
profile to a data point, double-click a cell in the stress column, then open the drop-down list to 
see all validated stress profiles in the current project. The control panel will show a list of stress 
profiles used in the data sheet. 

https://www.reliasoft.com/about/contact-us
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Use Profiles to Describe the Use Stress Condition 

Select the cumulative damage life-stress model on the control panel, then click the Set Use 
Stress link. In the Use Stress Level window, select the Profile check box for all applicable 
stresses. A drop-down list containing all the validated stress profiles in the project appears. 
Note that when you use a stress profile in this way, some plots (e.g., the use level probability 
plot) will not be available. 
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STRESS PROFILE EXAMPLE 

For life-stress data only. 

A reliability engineer is asked to determine, with a confidence level of 90%, whether an 
electronic component has a B10 life of at least 350 hours under ordinary conditions. 

To simplify the analysis, the engineer will assume that the ordinary stress conditions for the 
component consist of a constant stress level of 2 V. However, because the ordinary stress 
conditions are known to involve escalating stress values, the component will be subjected to a 
time-dependent voltage stress during testing. The following table describes the stress values 
that will be applied during the test. 

Starting Time (Hr) Ending Time (Hr) Stress Level (V) 

0 250 2 
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250 350 3 

350 370 4 

370 380 5 

380 390 6 

390 400 7 

All eleven units were tested to failure using the same stress profile. The following failure times 
were observed in the test. 

Failure Time (Hr) Stress Level 

280 Time-dependent 

310 Time-dependent 

330 Time-dependent 

352 Time-dependent 

360 Time-dependent 

366 Time-dependent 

371 Time-dependent 

374 Time-dependent 

378 Time-dependent 

381 Time-dependent 

385 Time-dependent 

Create a Life-Stress Data Folio and Stress Profile 

1. Choose Home > Insert > Life-Stress Data. Since all the data are exact failure times, clear all 
of the check boxes in the Options for the Times-to-Failure Data Type area. Then, select 
Hour (hr) from the Units drop-down list and click Next. 

2. On the second page of the setup window, select Voltage as the stress types. Set the use 
stress level to 2 with V as the unit. Click OK to close the setup window and create the new 
life-stress data folio. 

3. Enter the failure times into the data sheet. 

4. On the control panel of the data sheet, select CD-Weibull. Click Stress Transformation and 
apply the Logarithmic transformation to the stress. 
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5. To create a stress profile: 

a. Click the   icon on the control panel. 

b. In the Profile window, rename the profile to "Voltage Step." Enter the segment end 
times and stress values into the data sheet, as shown next. 
 

 

c. On the control panel, select Continue with last value. Click the Validate Stress Profile 
icon to validate the information in your new profile. Finally, click the Plot icon to view a 
stress vs. time plot of the profile. 

d. Click OK to save the profile with the project and close the window. 

6. To assign the stress profile to a failure time, double-click the corresponding cell in the 
Voltage column of the data sheet, then click the drop-down arrow and choose Voltage Step 
from the list. After you have filled out the data sheet, it should appear as shown next. 
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Analyze the Data Set 

1. Click the Calculate icon on the folio's control panel. The parameters of the model will be 
automatically computed and displayed in the Analysis Summary area of the control panel. 

2. To estimate the B10 life of the device, choose Life-Stress Data > Analysis > Quick 
Calculation Pad or click the icon on the control panel. 

 

3. In the QCP, choose to calculate the BX% Life with Lower One-Sided confidence bounds. 
Select Hour for the time units and then make the following inputs: 

• Stress = 2 

• BX% Life At = 10 

• Confidence Level = 0.9 

4. Click Calculate to display the results. The results show that the component's estimated B10 
life is 507.9438 hours. The lower one-sided 90% confidence bound is shown to be 300.4821 
hours. Thus, the test's results do not show with 90% confidence that the component's B10 
life is at least 350 hours. 
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Tools 

ACCELERATED LIFE TESTING DISTRIBUTION WIZARD 

For life-stress data only. 

The Distribution Wizard for Accelerated Life Testing life-stress data folios performs a Likelihood 
Value (LKV) test. The test computes the value of the log-likelihood function given the calculated 
parameters of the distribution in order to determine the best distribution for a data set. Note 
that the Distribution Wizard only serves as a guide for you to decide which distribution to use in 
your selected model, and it assumes the life-stress relationship you selected on the control 
panel. You should compare its suggestion with your own engineering knowledge about the 
product being modeled before making the final decision. 
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Open the Distribution Wizard by choosing Life-Stress Data > Analysis > Distribution Wizard or 
by clicking its icon in the Main page of the control panel. 

 

On the Main tab of the Distribution Wizard, select the distributions you would like to consider 
and then click Analyze to compare them. The distributions will be ranked according to how well 
they fit the data, with rank 1 being the best fit. The highest ranked distribution will also be 
highlighted with blue text. 

Click the Implement button to close the Distribution Wizard and automatically calculate the 
parameters for the highest ranked distribution. 

The data sheet on the Analysis Details tab summarizes the ranking results and displays the 
value of the log-likelihood function for each distribution given the calculated parameters. The 
calculated parameters for each considered distribution are also shown. 

LIKELIHOOD RATIO TEST 

For life-stress data only. 

The Likelihood Ratio Test tool is used to assess the assumption of a common shape parameter 
among the data obtained at the various accelerated stress levels. This assumption underlies the 
use of any model that includes a life distribution with a shape parameter. By confirming this 
assumption, you confirm that units will fail in the same manner across different stress levels. 
The tool is available for all models in Accelerated Life Testing that include the Weibull or 
lognormal distribution, except the cumulative damage models in Accelerated Life Testing PRO. 

To use the Likelihood Ratio Test tool, first calculate the parameters in your life-stress data folio. 
After the shape parameter is calculated in the folio, open the tool by choosing Life-Stress Data 
> Options > Likelihood Ratio Test or clicking its icon on the Main page of the folio's control 
panel. 

 

Next, enter a significance level in the Input area. The tool uses your specified significance level 
to determine whether there is a statistically significant difference in the shape parameter 
estimates at each stress level. For example, if you enter 0.1, then the tool will determine 
whether the estimated shape parameters are statistically the same at a confidence level of 0.9. 

Finally, click Calculate to view the results of the test. The Results area of the window displays 
the calculated likelihood ratio test statistic, T, and chi-squared value. If T is not greater than the 
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chi-squared value, then the estimated shape parameters do not differ significantly at the 
specified level. A written report of the results also appears in this area. 

The Likelihood Values tab of the window displays the likelihood values obtained by two 
methods. The values in the Accelerated Stress Levels area are calculated by fitting a separate 
distribution to the data from each of the test stress levels (with two or more exact failure 
times). The likelihood value in the Use Stress Level area is calculated by fitting a single model 
with a common shape parameter and a separate scale parameter for each of the stress levels, 
where the stress levels are represented by indicator variables. 

ADD OR REMOVE COLUMNS 

For life-stress data only. 

To add or remove additional stress columns and Subset ID columns to a data sheet, choose Life-
Stress Data > Format and View > Add/Remove Columns. 

 

• Add Subset ID Column adds a new Subset ID column. 

• Add Stress Column adds a new stress column. You can add up to 8 stress columns to the 
data sheet. 

To remove a stress or subset ID column from the list, clear the check box next to the column's 
name. 

Tip: If you wish to later change the heading of any stress or subset ID column, simply right-click 
the column heading and choose Rename Stress/Rename Column. 

CONVERT STRESS VALUES 

For life-stress data only. 

In life-stress data folios, you can easily convert all the values in a specified stress column to 
another value. 

First, select the stress column that contains the values you want to convert by clicking the 
heading of that column or selecting any cell in that column. All of the values in the selected 
column will be converted. For example, if you select one cell and convert the contained value, 
all the other values in that column will be converted as well. 

Then choose Life-Stress Data > Options > Convert Stress Values. 
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Select how you want to convert the values: 

• Multiply or divide the values in the column by a specified value. Use the input field to enter 
the value that you wish to have each stress value multiplied or divided by. 

• Celsius to Kelvin 

• Fahrenheit to Kelvin 

• Celsius to Rankine 

• Fahrenheit to Rankine 

If you want to move the original, unconverted values into a subset ID column in the data sheet 
for future reference, select the Put current values in Subset ID check box and then use the 
drop-down list to choose the subset ID column to move the values into. If there is already 
information in the selected subset ID column, the software will overwrite that information. 

Tip: If you only have one subset ID column, and you want to move its information to a column 
that will not be overwritten when you select the Put current values in Subset ID check box, first 
use the Add or Remove Columns window to add a second subset ID column. The second subset 
ID column will be available in the drop-down list when you next open the Convert Stress Values 
window. 

CALCULATIONS WITH INSUFFICIENT DATA ENTERED 

For life-stress data only. 

The Parameter Input window will appear when you attempt to calculate a life-stress data sheet 
that does not contain enough data to fit a model. 

No Data Entered 

If you attempt to calculate a data sheet in a life-stress data folio with no data entered, the 
Parameter Input window will appear, as shown next, and allow you to either enter the 
parameters for the selected Accelerated Life Testing model directly or use the Quick Parameter 
Estimator (QPE) to estimate the model's parameters based on information you have about the 
reliability of the product at normal and accelerated stress levels. 
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After you enter the parameters and click OK, the data sheet will be updated automatically with 
the specified model. Any plots or QCP results you produce from this data sheet will be based on 
this model. 

Note: If you have more than one stress column selected to be used in the analysis and you 
attempt to calculate an empty data sheet using a proportional hazards or general log-linear 
model, the Columns drop-down list will be enabled in the Parameter Input window. With this 
drop-down list, you can select how many stresses to include in the model. You cannot choose 
to use more stresses than are selected to be used in the analysis. 

Not Enough Stress Levels 

To perform an accelerated life testing data analysis, you need information about how the 
product behaves at more than one stress level. If you select to use an Arrhenius, Eyring or 
inverse power law (IPL) model and attempt to calculate the data sheet with data for only one 
stress level, the Parameter Input will appear, as shown next, and ask you to specify an 
acceleration factor that allows the software to calculate how the product behaves at other 
stress levels. 
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The acceleration factor is obtained by dividing the product’s life at the use stress level by its life 
at the accelerated stress level used in the test. For example, if the product has a life of 100 
hours at the use stress level, and it was tested at an accelerated stress level which reduces its 
life to 50 hours, then you would enter 2 in the Acceleration Factor field. 

Note: This method of calculating the data sheet does not support confidence bounds. 

TRANSFER DATA TO LIFE DATA FOLIO 

For life-stress data only. 

You can transfer data in a life-stress data folio to a life data folio in order to perform life data 
analysis on your accelerated test data. 

To transfer the data, click the Transfer Data to Life Data Folio icon on the control panel. 

 

Then select how you want to transfer the data: 

• Transfer all data to a single data sheet copies the values from the stress columns to the 
subset ID column of the new life data folio data sheet. In multiple-stress situations, a stress 
level is a combination of stress values. (If desired, you can later use the Batch Auto Run tool 
to extract data subsets from the data sheet.) 
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• Transfer use level data creates a free-form data sheet within the new life data folio and 
copies the probability of failure over time values (Y-Axis Values) at the specified use stress 
levels (X-Axis values) into it. 

• Transfer data for each stress to a separate data sheet groups the accelerated data set 
according to stress level and then places each group into its own data sheet in the new 
Weibull++ life data folio. In multiple-stress situations, a stress level is a combination of 
stress values. There are two additional options: 

• Calculate parameters after transfer automatically calculates each data sheet using the 
life distribution from your selected model. 

• Add contour plot creates a contour plot that compares the calculated parameters for 
each data sheet, allowing you to determine, for example, whether the shape parameter 
estimates for the data obtained at different stress levels differ significantly at a 
specified confidence level. (This option is not available for free-form data.) 

• Create and transfer a stress distribution data set calculates the product's unreliability at 
the specified time and at different stress intervals. The stress intervals will range from the 
use stress level to the maximum stress level used in the test, with equal increments in 
between. This information will then be exported to a free-form data sheet in a new life data 
folio. In multi-stress situations, you can click the Select Stress to Vary icon to select which 
stress type will be varied in the software's unreliability calculations. The remaining stress 
types will be fixed at their specified use stress values. 
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In the free-form data sheet, the X-axis represents the stress intervals and the Y-axis 
represents the unreliability (as a percentage ) for each interval, as shown in the following 
example. The product's use stress level is 356 K, and the maximum stress level used in the 
test is 426 K. Thus, the X-axis values range from 356 to 426. If the specified time was 1,000 
hours, then, according to the first row of this data sheet, the product has a probability of 
failure of 31.57% at 1,000 hours at a stress level of 356 K. If you wish, you can calculate this 
data to further analyze the relationship between stress level and unreliability. 
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Chapter 7: Life Data and Life-Stress Data 
Analysis Folios 
Degradation Analysis Folios 

Degradation analysis is a technique that uses the performance (degradation) measurements of 
a product over time to predict the point at which each unit in the sample is expected to fail. 
This analysis is useful for tests performed on products with very high reliability, where it is not 
possible to test the units to failure under normal conditions. 

Weibull++ offers two types of degradation analysis folios: 

• Nondestructive degradation analysis folios are for cases where it is possible to directly 
measure the degradation of a physical or performance characteristic over time (e.g., depth 
of tire tread, voltage of battery, propagation of crack size, etc.). In this case, you take 
multiple measurements per test unit over time. The folio extrapolates the times at which 
the amount or level of degradation is serious enough that the unit is considered to be 
failed, and then automatically performs life data analysis on the extrapolated failure times. 

• Destructive degradation analysis folios are for cases where it might not be possible to 
measure the degradation without invasive or destructive techniques that would directly 
affect the subsequent performance of a product (e.g., corrosion in a chemical container, 
strength measurement of adhesive bond, etc.). Only one measurement is taken per test 
unit and multiple samples are required at different points in time. Unlike the 
nondestructive degradation folio, which extrapolates the failures times, the destructive 
degradation analysis folio fits the measurements directly to the chosen degradation model 
and life distribution, and then uses the result to predict future failure behavior. 

The ReliaWiki resources portal has more information on degradation analysis at: 
http://www.reliawiki.org/index.php/Degradation_Data_Analysis. 

What's Changed? Starting in Version 2019, you can now use the Inspection View with 
nondestructive folio data sheets. 

DEGRADATION ANALYSIS FOLIO SETUP 

To add a degradation analysis folio, choose Home > Insert > Degradation, or right-click the 
Degradation folder in the current project explorer and choose Add Degradation on the 
shortcut menu. 

http://www.reliawiki.org/index.php/Degradation_Data_Analysis
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In the setup window, select the type of degradation analysis folio to create. If you have 
Accelerated Life Testing activated on your computer, all four options will be available. The 
Accelerated Life Testing degradation analysis folios are similar to life data except that 
accelerated stress levels are used during testing to further reduce the test time required to 
obtain the predicted failure times. 

Weibull++  

  Nondestructive Degradation 

  Destructive Degradation 

Accelerated Life Testing  

  Accelerated Nondestructive Degradation 

  Accelerated Destructive Degradation 

DEGRADATION FOLIO DATA SHEET 

There are two options for displaying data in degradation analysis folio data sheets: 

• The Unit View is available for all analysis folio data sheets. This corresponds to the view 
that is used in earlier versions of the software. 

• The Inspection View is available only for nondestructive folio data sheets. 

For nondestructive degradation analysis folios, there are two options for the data sheet view: 
the Unit View (which corresponds to the view used in all older versions of the software) and the 
Inspection View (new in Version 2019). When you create the folio, you will be able to choose 
which view to use. 

For destructive degradation analysis folios, only the Unit View is available. 

Unit View 

When using this view, you enter measurements on a separate row for each unit and inspection 
time: 
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• Inspection Time - the time at which the degradation was measured. Time may also be 
measured as the amount of usage the unit accumulates or as the factor that degrades the 
unit. In nondestructive degradation analyses, the level of degradation may be measured 
either continuously or at predetermined intervals of time. 

• Degradation - the degradation measurement. 

• Unit ID - the test unit being measured. 

• Stress - for Accelerated Life Testing degradation analysis folios, the stress type and stress 
level. 

The following example shows a Weibull++ nondestructive degradation analysis for two 
automobile tires, A and B. The inspection time is in mileage because of its direct relation to the 
wear on the tires. 

  

The following example shows an accelerated nondestructive degradation analysis for two LED 
units, A1 and A2. The light intensity is inspected every 50 hours and measured in milliamperes. 

 

Inspection View 

When using this view, you enter measurements for multiple units at each inspection time. 
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• Inspection Time - the time at which the degradation was measured. Time may also be 
measured as the amount of usage the unit accumulates or as the factor that degrades the 
unit. 

• Unit ID(s) - the specific test unit being measured, with separate columns for each test unit. 
(You can rename a column by right-clicking the column heading and choosing Rename 
Column on the shortcut menu.) 

The following example shows a Weibull++ nondestructive degradation analysis for two 
automobile tires. 

 

The following example shows a nondestructive degradation analysis for four LED units. 

 

You can add additional unit IDs to the data sheet by clicking the Add/Remove Columns icon on 
the Main page of the control panel. 

 

To switch between the views, choose Degradation > Format and View > [Switch to Unit 
View/Switch to Inspection View]. 

 

Conditions 

If you are switching from the Inspection View to the Unit View: 

• For nondestructive degradation folios with life data analysis: 
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• Any unit ID column that does not have a measurement value associated with it will 
become its own line in the Unit View. 

• Any inspection time that does not have a measurement value associated with it will 
become its own line in the Unit View. 

• For nondestructive degradation folios with Accelerated Life Testing: 

• Any unit ID column that does not have a measurement value associated with it will 
become its own line in the Unit View. 

• Any unique combination of inspection time and stress column that does not have a 
measurement value associated with it will become its own line in the Unit View. 

CONTROL PANEL SETTINGS 

The degradation folio control panel contains most of the tools you need to perform a 
degradation analysis. For more information about control panels in general, see Control Panels. 

• Degradation Model allows you select the mathematical model that best describes the 
product's degradation over time. The available degradation models are: linear, exponential, 
power, logarithmic, Gompertz and Lloyd-Lipow. In Weibull++ nondestructive degradation 
analyses,you can also choose User-Defined. See User-Defined Degradation Models. 

Tip: If you are not certain which degradation model would provide the best fit for your 
data, you can use the Degradation Model Wizard to guide you through the selection 
process. 

• Critical Degradation is the level of degradation that is considered a failure. For example, 
you might wish to define failure as the time when the depth of the tire tread is less than 2 
millimeters. 

• Suspend After is available for nondestructive degradation analyses only. It allows you to 
define a censoring time past which no failure times are extrapolated. In practice, there is 
usually a rather narrow band in which the censoring time has any practical meaning. If the 
censoring time is relatively low, no failure times will be extrapolated, which defeats the 
purpose of the degradation analysis. On the other hand, a relatively high censoring time 
would occur after all of the theoretical failure times, thus rendering the censored data 
meaningless. Nevertheless, certain situations may arise in which it is beneficial to censor 
the degradation data. For example, if your product has a maximum warranty life of 10,000 
hours, then you may want to treat all failures beyond that time as suspensions. 
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Nondestructive Degradation 

• Life Data Model/ALTA Model contains the settings for performing life data/life-stress data 
analysis on the extrapolated failure times. These settings have no effect on the degradation 
analysis calculations; they affect only the life data/life-stress data analysis calculations. 

The settings in this area are identical to the settings on the control panel of a life data folio 
or life-stress data folio except for the Use extrapolated intervals check box, which allows 
you to extrapolate the failure/suspension times as interval censored data. Selecting this 
option calculates the intervals as bounds around the extrapolated data points. 

Note: If the distribution and parameters are associated with a published model, then the 
model's name will appear as a link at the bottom of the Life Data Results area. Click the link 
to view the model's properties. See Publishing Models. 

• Degradation Results displays the parameters of the chosen degradation model and the 
extrapolated failure/suspension times. Click the button to view the results in a worksheet. 

• Life Data/ALTA Results displays the parameters of the life data/life-stress data model. Click 
the button to view the results in a worksheet. 

Destructive Degradation 

• Measurement Distribution allows you to select a distribution that represents the variability 
of a degradation measurement at a given time. The maximum likelihood estimation (MLE) 
method is used to estimate the distribution's parameters, and the Fisher matrix (FM) 
method is used to solve for the confidence bounds. 

• Analysis Summary displays the calculated parameters and other values for the selected 
distribution. Click anywhere within the area to view the results in a worksheet. 

Folio Tools 

The folio tools are arranged on the left side of the Main page of the control panel. Use these 
tools to manage data and experiment with the results of your analysis. 

  Calculate analyzes the data set. This command is also available by choosing 
Degradation > Analysis > Calculate. 

  Plot creates a new sheet in the folio that provides a choice of applicable plot types. 
This tool is also available by choosing Degradation > Analysis > Plot. 
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  QCP opens the Quick Calculation Pad, which allows you to calculate life data/life-stress 
data analysis metrics, identical to the calculations you can perform in a life data/life-stress 
data folio. This tool is also available by choosing Degradation > Analysis > QCP. 

  Degradation Model Wizard opens the Degradation Model Wizard, which helps you 
select the degradation model that best fits your data. This tool is also available by choosing 
Degradation > Analysis > Model Wizard. 

  Distribution Wizard opens the Distribution Wizard, which helps you select the 
distribution that best fits the data set. This tool is also available by choosing Degradation > 
Analysis > Distribution Wizard. 

  Add/Remove Columns 

• For life data nondestructive folio data sheets, this allows you to add or remove subset 
ID columns when using the Inspection View. 

• For Accelerated Life Testing nondestructive data sheets, this allows you to add or 
remove columns for stress levels and, when using the Inspection View, add or remove 
subset ID columns. 

This tool is also available by choosing Degradation > Format and View > Add/Remove 
Columns. 

  Change Units opens the Change Units window, which allows you to change the units 
for the values in the current data sheet. 

USER-DEFINED DEGRADATION MODELS 

The life data nondestructive degradation analysis folio includes the option to predict failure times 
based on a user-defined degradation model. To use this option, you must provide the equation 
that defines the model, as well as specify ranges and initial guesses for the software to use when 
fitting the model. 

Entering User-Defined Equations 

To define a new degradation model, choose User-Defined from the drop-down list in the 
Degradation Model area. Then enter the model's Name and a Formula that represents the 
degradation over time. The formula can include parameters with any name (e.g., b or beta), but 
it should include x as the random variable for time. 



Chapter 7: Life Data and Life-Stress Data Analysis Folios 

444 https://www.reliasoft.com/weibull 

 

As an example, the linear degradation model is defined next. 

 

To save the equation in the project for later use, click the Add to Templates link. 

To select an equation that was previously saved, click the Select from Templates icon . This 
opens the Existing Equation Templates window, which shows a list of all the saved templates. 
The buttons at the lower left side of the window allow you to add, edit or delete templates. 

Entering Ranges and Guesses for Parameter Estimation 

After specifying the user-defined degradation model, click the Function Parameters icon  to 
provide a starting point for estimating the parameters. The following example shows the 
parameter estimates for each unit ID in a particular data set. 

 

For each Unit ID, enter the following values: 
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• In the Is greater than and Is less than columns, set an estimate for the minimum and 
maximum values for each parameter in the equation. If the iteration does not converge at 
the specified range, you will need to edit the range values until a solution can be obtained. 

• In the Initial Guess column, set a value from which the approximation for the 
corresponding parameter will start. If the iteration cannot arrive at a solution, you will need 
to edit the initial guess values until a solution can be obtained. 

To reset all your inputs in this window to the defaults, click the Initialize Parameters icon . 

DEGRADATION PLOT SHEET 

After you analyze the degradation data, you can create plots of your results by choosing 
Degradation > Analysis > Plot or by clicking the Plot icon on the Main page of the control panel. 

 

The Plot Type area on the plot sheet of the control panel allows you to select the type of plot 
you wish to view and the units of measurement you want the x-axis of the plot to be displayed 
in. 

Nondestructive Degradation Folio Plots 

In addition to the standard life data/life-stress data analysis plots, you can view the following 
plots, which pertain specifically to the extrapolation of failure times from the degradation 
measurements. 

• Degradation vs. Time (Linear) plots the degradation of each test unit over time, using a 
linear scale for time and degradation. A thick horizontal line marks the critical degradation 
level (i.e., the level at which a unit is considered failed) that was specified on the Main page 
of the control panel. You can use this plot to visualize how failure times were extrapolated 
for each unit. 

• Degradation vs. Time (Log) plots the same information as the Degradation vs. Time (Linear) 
plot, but using logarithmic axes for time and degradation. 

The Unit IDs area of the control panel will display the unit IDs you entered in the data sheet of 
the folio. To remove a test unit from the plot, clear the associated check box. 
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Destructive Degradation Folio Plots 

The following plots are available for the destructive degradation folios. The last two 
degradation plots pertain specifically to the degradation model based on the fitted 
measurement distribution. 

• Reliability vs. Time 

• Unreliability vs. Time 

• Pdf Plot 

• Failure Rate vs. Time 

• Degradation vs. Time (Linear) shows the effect of time on the degradation measurements, 
using a linear scale for time and degradation. Multiple pdfs, each at a different inspection 
time, are displayed on the plot. The measurements obtained at each time are shown at the 
base of the associated pdf. 

A degradation line will be displayed over the pdfs, which shows how the measurement 
distribution's location parameter changes over time. And a thick horizontal line marks the 
critical degradation level (i.e., the level at which a unit is considered failed) that was 
specified on the Main page of the control panel. 

• Degradation vs. Time (Log) plots the same information as the Degradation vs. Time (Linear) 
plot, but using logarithmic axes for time and degradation. 

DEGRADATION MODEL WIZARD 

The Degradation Model Wizard performs a goodness of fit test to determine the best 
degradation model for your data. Note that the degradation model wizard only serves as a 
guide. You should compare its suggestion with information about the product being modeled 
before making the final decision. 

You can access the wizard by choosing [Degradation/Destructive Degradation] > Analysis > 
Model Wizard or by clicking its icon on the Main page of the control panel. 

 

Evaluating and Using Degradation Models 

1. On the Main tab of the Degradation Model wizard, select the models you would like to 
consider. The available models will vary depending on which degradation analysis folio you 
are working with. 
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2. Click Analyze to start the evaluation. The results of the evaluation will be presented as in 
the example shown next. 

 

The models will be ranked according to how well they fit the data, with rank 1 being the 
best fit. In the example shown above, the exponential model is the suggested model for the 
data set. Click Implement to extrapolate failure times using the suggested model. 

Viewing the Analysis Details 

The wizard uses the Sum of Square Error (SSE) to evaluate the fit of the data. The calculations 
behind the ranking can be viewed on the Analysis Details tab, which contains two data sheets: 

• The Ranks sheet displays the overall ranking as well as the ranking for each model and unit 
ID based on the SSE evaluation. Due to the randomness of materials, a model that is good 
for one unit may not be the best for the other units. In the example shown next, the 
exponential model is the best model for analyzing the data collected for all devices, while 
the Gompertz model is the second best fit for all devices. 
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• The SSE sheet shows the sum of square error for each model and unit ID. The values are 
obtained by first calculating the distance (the error) vertically from each data point to its 
corresponding value on the fitted model. The error value is squared, and then all the 
squared values are added up. The SSE column shows the calculated sum of squared errors 
for each model. The highest rank is given to the model with the lowest SSE value. 

 

LIFE DATA DEGRADATION ANALYSIS EXAMPLE 

The data set used in this example is available in the example database installed with the 
Weibull++ software (called "Weibull20_Examples.rsgz20"). To access this database file, choose 
File > Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder.  
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The name of the project is "Degradation - Crack Propagation." 

An analyst needs to determine the time when 10% of the turbine blades in a sample are 
expected to fail (i.e., B10 life). To determine performance, the blades are tested for crack 
propagation. The units are cyclically stressed and inspected every 100,000 cycles for crack 
length. Failure is defined as a crack length of 30mm or greater. 

The data sheet in the "Crack Propagation" folio displays the results of the inspections for the 
five units, A through E. 

Using degradation analysis, project the failure times for the blades using an exponential model 
for the extrapolation, and then calculate the reliability of the blades at a 90% confidence level. 

Analyze the Data Set 

1. The first step is set up the data sheet for the analysis. Click the Change Units icon on the 
Main page of the control panel 

 

2. In the Change Units window, select to change the time units to Cycles. 

3. On the control panel, select the Exponential degradation model and enter a value of 30 for 
the Critical Degradation. 

4. For the life data model, select the 2P Weibull distribution and the MLE analysis method. 
Use the default settings for all other options, as shown next. 
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5. Click Calculate and then click the Plot icon on the Main page of the control panel. 

The Degradation vs. Time (Linear) plot shows that unit C is expected to reach the critical 
degradation level first, compared to the other units. (Plot shown with annotations to make 
the information easier to read.) 
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6. To view the times when the units will reach the critical degradation level, return to the data 
sheet of the folio. On the control panel, click the Degradation Results (...) button. In the 
Results window, select the second data sheet. The report shows that Unit C will reach 
critical degradation at about 428.74 cycles. 

7. To view the results of the life data analysis, close the Results window and click the Life Data 
Results (...) button on the control panel. The parameters of the life data model are 
estimated to be beta = 8.055074 and eta = 519.555393. 

Estimate the B10 Life 

8. The next step is to estimate the time when 10% of the blades in the sample are expected to 
fail. Close the Results window and click the QCP icon on the control panel. 

9. In the QCP, choose to calculate the BX% Life with lower 1-sided confidence bounds. Select 
Cycles for the units and then make the following inputs: 
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• BX% Life At = 10 

• Confidence Level = 0.9 

10. Click Calculate to obtain the results. The results indicate that 10% of the turbine blades will 
have failed (i.e., B10 life) at approximately 392.92 cycles of operation, and the 90% lower 
one-sided confidence bound on the B10 life is 334.95 cycles. 

 

ACCELERATED LIFE TESTING DEGRADATION ANALYSIS EXAMPLE 

For life-stress data only. 

A manufacturer of LEDs wants to determine, with 90% confidence, whether the B10 life of the 
LED is at least 700 hours. During operation, the light intensity of the LED diminishes over time, 
and for present purposes the level at which an LED can be considered failed (i.e., the critical 
degradation level) is 50 mcd. The LEDs normally operate at a stress level of 28 mA, but it would 
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take too long for units tested at this stress level to decrease to a light intensity of 50 mcd. So it 
is decided to perform an Accelerated Life Testing degradation analysis. 

5 units were tested at 35 mA, and 5 were tested at 40 mA. The light intensity of each unit was 
recorded five times, at 50 hour intervals, as shown next. 

Light Intensity (mcd) of Units Tested at 35 mA 

Inspection Time (Hr) Unit A1 Unit A2 Unit A3 Unit A4 Unit A5 

50 95.1 93.3 98.3 96.6 95.8 

100 86.0 87.1 92.4 88.2 89.0 

150 77.6 79.7 89.0 85.1 84.0 

200 70.0 74.3 84.3 81.4 81.0 

250 66.7 73.0 83.0 78.6 80.0 

Light Intensity (mcd) of Units Tested at 40 mA 

Inspection Time (Hr) Unit B1 Unit B2 Unit B3 Unit B4 Unit B5 

50 86.6 82.1 82.7 79.8 75.1 

100 78.7 71.4 70.3 68.3 66.7 

150 76.0 65.4 64.0 62.3 62.8 

200 71.6 61.7 61.3 60.0 59.0 

250 68.0 58.0 59.3 59.0 54.0 

Create an Accelerated Nondestructive Degradation Analysis Folio 

1. Choose Home > Insert > Degradation. In the Add Degradation window, select the 
Accelerated Nondestructive Degradation option and click Next. 

2. In the setup window, select the first check box in the Stress Name column and rename the 
stress to "Amps," then enter mA in the Stress Units column and 28 in the Use Level column. 
Click OK to create the folio. 
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3. Enter the given data into the data sheet. As an example, the data for units A1 and A2 are 
entered as shown next. 

 

Analyze the Data Set 

4. In the Degradation Model area of the control panel, select Exponential from the drop-
down list and enter 50 in the Critical Degradation area. In the Model area, select the IPL-
Weibull model (i.e., the inverse power law life-stress relationship combined with the 
Weibull life distribution) from the drop-down list. 

5. Click the Calculate icon. The software will predict the failure time for each unit under the 
specified accelerated stress conditions, and it will perform an accelerated life testing data 
analysis on those failure times in order to extrapolate to normal use conditions. To view a 
plot of the results click the Plot icon. 

The Degradation vs. Time plot shows how the performance of each unit ID degrades over 
time. You can select to plot the data points on a linear or logarithmic scale. The following 
example shows the linear scale plot. The pink line at the bottom of the plot marks the 
critical degradation level that was specified on the control panel. 
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6. To view the parameters of the chosen degradation model and the extrapolated 
failure/suspension times, return to the data sheet. On the control panel, click Degradation 
Results (...). The parameters of the degradation model for each unit ID are displayed in the 
first data sheet of the Results window while the extrapolated failure times for all units are 
displayed in the second sheet. 

7. To view the results of the accelerated life testing data analysis, close the Results window 
and click ALTA Results (...) on the control panel. 

Estimate the B10 Life 

8. To estimate the time at which 10% of units are expected to fail under normal conditions, 
open the QCP by choosing Life-Stress Data > Analysis > Quick Calculation Pad or by clicking 
the icon on the Main page of the control panel. 
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9. In the QCP, choose to calculate the BX% Life with Lower One-Sided confidence bounds. 
Select Hour for the time units and then make the following inputs: 

• BX% Life At = 10 

• Confidence Level = 0.9 

10. Click Calculate to obtain the results. The results show that the B10 life of the LED is 
estimated to be 1109.9328 hours. The lower one-sided 90% confidence bound is estimated 
to be 737.7939 hours. Thus, the LED meets the manufacturer's requirement. 
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Comparison Folios 

Tests of Comparison 

Weibull++ provides two tools designed for statistical comparison of data sets: 

• The Life Comparison tool calculates the probability that the times-to-failure of one 
population will be greater or less than the times-to-failure of the second. This allows you to 
compare life distributions from two alternate designs, manufacturers, lots, assembly lines, 
etc. in order determine whether the units in the first group will outlast the units in the 
second. 

• The Stress-Strength comparison tool allows you to determine the probability of failure 
based on the probability of stress exceeding strength. The strength data set could be actual 
data that represents the strength of the material (i.e., minimum applied stress to cause 
failure) and the stress data set could be the actual stress levels that the material will 
experience under use conditions. 

Both tools are based on the same underlying probability equation, and both folios function in a 
similar way. Both tools are described in the following sections. 

Folio Setup 

To add a life comparison or stress-strength folio to a project, right-click the Comparison folder 
in the current project explorer and choose the folio type. 

 Life Comparison 

 Stress-Strength Comparison 

When you add the folio to a project, you will be asked to select two data sheets to compare. 
Note that the data sheets must have already been analyzed (i.e., the parameters of the 
distribution have been calculated) in order for you to select them. 

After you select the data sheets, the software will automatically plot the distributions of the 
data sets and estimate the probability value. You can then use the control panel settings in the 
folio to perform additional analyses or change how you want the probability value to be 
calculated. 
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Probability Equation 

The life comparison test uses the following equation to evaluate the probability of failure based 
on the probability that the life of the second data set is greater than or equal to the life of the 
first data set [Brown, Gerald G. and Rutemiller, Herbert C. "Evaluation of P[X>=Y] When Both X 
and Y are from Three-Parameter Weibull Distributions." IEEE Transactions in Reliability, R-22, 
no. 2 (1973).]: 

 

(1) 

where f(t) is the pdf of data set 1 and R(t) is the reliability function of data set 2. The evaluation 
is based on whether this probability is less than or greater than 0.5. The result is interpreted as 
follows: 

• If P = 0.5, then the lives of both data sets are equal. 

• If P > 0.5, then the life of data set 2 exceeds the life of data set 1. For example, if P = 0.8, 
then data set 2 is better than data set 1 with an 80% probability. 

• If P < 0.5, then the life of data set 1 exceeds the life of data set 2. For example, if P = 0.10, 
then data set 1 is better than data set 2 with a 90% probability (1 - 0.10 = 0.9). 

For the stress-strength test, Eqn. (1) may be expressed as: 

 

(2) 

The expected reliability is calculated as: 

 

(3) 
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For cases where the limits of one of the distributions are truncated to a specified range, Eqn. (3) 
is adjusted as: 

 

(4) 

where: L ≤ X1 ≤ U, and X1 = Stress, X2 = Strength. 

For data sets that are calculated in an Accelerated Life Testing life-stress data folio, the 
comparison is performed at the given use stress levels of both data sets; therefore, Eqn. (1) can 
also be expressed as: 

 

(5) 

 

Tests of Comparison Control Panel 

The life comparison and stress-strength folios share the same control panel settings. The icons 
arranged vertically on the left side of the panel allow you to perform a variety of tasks related 
to the comparison (e.g., calculate the folio, select different data sheets, etc.), while the icons 
arranged horizontally perform tasks for each data set. 

The control panel consists of two pages: the Analysis page, which contains most of the tools 
you will need to perform the analysis and view/access the results, and the Setup page, which 
contains options for setting how you want the probability value to be computed. 

Note: Information from the source data sheets are copied, not linked to the analysis. This 
means that if changes were made to the data sheets, you must re-select the data sheets to 
copy the new information to the analysis. To re-select data sheets, click the   icon on the 
control panel. 

Control Panel Analysis Page 

The Analysis page of the control panel contains the following settings: 
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• The Results area shows the calculated probability value. Click the Show Results (...) button 
to display a report of the results. 

• In the life comparison folio, the value represents the probability that the life of the 
second data set exceeds the life of the first data set (Probability X1<X2). 

• In the stress-strength folio, the value represents the Reliability of the product (i.e., the 
probability that the product can withstand the applied stress). This can also be 
displayed as the Probability of Failure if you select the check box on the Setup page of 
the control panel. 

• The Calculate Confidence check box provides the option to compute the two-sided 
confidence bounds of the probability value. Enter the desired confidence level (in decimal) 
in the Level field, and then click the Calculate icon on the control panel to display the 
results in the Upper Bound and Lower Bound fields. 

 

• The following settings affect how the plot is displayed: 

• The Units drop-down list allows you to choose the unit for the plot's time scale. 

• The Auto Refresh check box automatically refreshes the plot if any of the data sets, 
inputs or settings are modified. 

• The Keep Aspect Ratio check box maintains the ratio of the horizontal size to the 
vertical size of the plot graphic when you resize the plot sheet. 

• The Scaling area shows the minimum and maximum values for the X and Y axes. You 
can change these values if the Auto Scale check box beside the value range is cleared. If 
it is selected, the application will automatically choose appropriate values for the range 
based on the current data. 
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• The control panel also displays the values of the parameters of the distribution for each 
data set. For the stress-strength comparison test (as shown in the picture below), the first 
data set represents the Stress and the second data set represents the Strength. For the life 
comparison test, these are displayed as Set 1 and Set 2. 

  

To see a summary report of the analysis for a data set, click anywhere within the 
parameters table. To open the folio, click the blue link that displays the name of the folio 
and data sheet. 

Folio Tools 

The folio tools are arranged on the left side of the Analysis page of the control panel and in the 
areas dedicated to the selected data sheets (e.g., the Stress area on the control panel, as shown 
in the previous picture). Use these tools to manage data and experiment with the results of 
your analysis. 

  Calculate calculates the probability value. 

• In the life comparison folio, the value represents the probability that the life of the 
second data set exceeds the life of the first data set. 
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• In the stress-strength folio, the value represents the reliability of the product (i.e., the 
probability that the product can withstand the applied stress). This can also be 
displayed as the probability of failure if you select the check box on the Setup page of 
the control panel. 

  Redraw Plot updates the plot to reflect any changes that have been made. 

  Plot Setup opens the Plot Setup window, which allows you to customize most aspects 
of the plot including the titles, line styles and point styles. 

  RS Draw launches ReliaSoft Draw, which allows you to annotate your plot and view 
your plot in greater detail. 

  Export Plot Graphic opens the Save As window, which allows you to save the current 
plot graphic in one of the following formats: *.jpg, *.gif, *.png or *.wmf. 

  Select Data Sheet opens a window that allows you to select the data sheets to 
compare. 

  Target Reliability Parameter Estimator opens the Target Reliability Parameter 
Estimator window, which allows you to explore how you could attempt to change one of 
the distribution parameters in order to meet a specified target reliability. The plot and 
probability value will be based on the altered distributions and therefore may be 
appropriate only within the context of your specific scenario. 

  Reliability Demonstration Test opens the Reliability Demonstration Test window, 
which allows you to solve for values associated with a specified test design such as required 
test time, required sample size, demonstrated reliability and confidence level. 

  Alter Parameters (also called Alter Parameters w/o Recalculation) allows you to 
manually alter the value of one (or more) parameters, while keeping the original values of 
the rest of the parameters and the variance/covariance matrix the same. The LK value, the 
solution line on plots and all subsequent analyses will be based on the modified set of 
parameters.  

  Refresh Parameters if  you have manually modified the parameters of the data set, 
this option allows you to revert to the parameters calculated from the original data source. 
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  Transfer Parameters allows you to transfer those modified parameters to the original 
data source. All subsequent analysis made on the data source, such as calculations made 
via the QCP and other tools, will be based on the modified parameter values; therefore, the 
analysis may be appropriate only within the context of your specific scenario. 

Control Panel Setup Page 

The Setup page of the control panel contains options for setting how you want the probability 
value to be computed. The following picture shows the Setup page of a stress-strength folio. 

 

• The limits of the integral in the probability equation are from zero to infinity. You can 
change the limits by selecting the Override auto-calculated limits check box. If you select 
this option, the equation shown on the control panel (as shown in the picture above) will 
be used to obtain the result. 

The ability to change the upper and lower limits of the integral gives you the option to limit 
your analysis to specific areas of interest. When you use a finite upper limit, the test 
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excludes the outcomes where both products are expected to operate longer than the time 
specified by the upper limit. When you specify a lower limit, the test excludes the outcomes 
where both products are expected to fail before the time specified by the lower limit. For 
example, you might wish to set the lower limit to a time other than zero in order to exclude 
the burn-in period from the comparison. Likewise, you could set a specific time for the 
upper limit if you want to consider only the behavior that occurs while the product is under 
warranty. 

The Quadrature Points field allows you to set the number of intervals (evaluation points) 
that the integral is divided into. Increasing the quadrature points increases the accuracy of 
the approximation but at the expense of increased calculation time. 

• The comparison tools provide two methods for calculating the confidence bounds, 
depending on whether the parameters of the distributions were estimated from actual 
data, or based on engineering knowledge or existing references. A brief description of each 
method is provided next. For an in-depth discussion on both calculation methods, the 
ReliaWiki resource portal provides more information at: 
http://www.reliawiki.org/index.php/Stress-Strength_Analysis. 
 
Note that confidence bounds calculations are not possible when one or both data sheets is 
an Accelerated Life Testing life-stress data folio that uses stress profiles. 

• Variation in Model Parameters. Select this option if the parameters of both 
distributions are estimated from actual data. Parameters that are estimated from 
actual data sets have associated uncertainties that the software can use to calculate 
the variance and confidence bounds on the estimated probability. Note that this 
method is not supported if one or both of the data sets meets any of the following 
conditions: 

• The data sheet has no data set (i.e., has fixed parameters). 

• The data set is from a free-form data sheet. 

• The data set is from an Accelerated Life Testing life-stress data folio that uses the 
cumulative damage model. 

• The data set was not analyzed using Fisher Matrix confidence bounds. 

• The distribution has parameters that were modified via the Alter Parameters tool 
or Target Reliability Parameter Estimator. 

http://www.reliawiki.org/index.php/Stress-Strength_Analysis
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• Variation in Probability Values. Select this method if the parameters of either 
distribution are fixed values. The software will use the variations in the estimated 
probability values to obtain the variance and confidence bounds. 

• The Result as probability of failure check box is available only in stress-strength folios. It 
allows you to display the probability of failure instead of the reliability. 

Life Comparison Example 

A product is being redesigned to improve its reliability. The following tables show the times-to-
failure data of each design. The objective is to determine whether the redesign improved the 
product's reliability. 

Table 1: Times-to-Failure of the Old Product Design 

2 2 3 4 6 9 

9 11 17 17 19 21 

23 28 33 34 34 37 

38 40 45 55 56 57 

67 76 90 115 126 197 

Table 2: Times-to-Failure of the New Product Design 

15 32 61 67 75 

116 148 178 181 183 

Create a Life Comparison Folio 

1. Enter the given data into two separate Weibull++ life data folio data sheets. Calculate the 
parameters for both data sheets by using the 2P-Weibull distribution and the RRX analysis 
method. 

2. Next, add a life comparison folio to the project. On the Home tab, click the Life Comparison 
icon in the Insert gallery. 
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3. Select the data sheets for the two designs, as shown next. Click OK. 

 

The result shows the following plot (with an area shaded to show the region where the life 
of the new design exceeds the life of the old design). 
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The result on the control panel indicates that the new design will last longer with a 
probability of 79.4675%, as shown next. 
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Stress-Strength Test Example 

Steel rods with a diameter of 0.5 +/- 0.015 inches are to be used in an application where the 
load is purely tensile. Investigations of the application reveal that the load is not constant in 
magnitude. The following tables show the typical load values and the strength data for 50 
specimens. 

The objective is to estimate the reliability of the steel rods against fractures. 

Table I: Typical Load Values (lbs) 

10455 12372 16559 19703 

16961 10595 10898 5814 

17279 12849 11661 6795 

7821 13017 11263 17934 

6821 15426 14656 17703 

Table II: Ultimate Tensile Strength Data of 50 specimens (psi) 

103779 103633 103779 103633 103799 

102906 102616 101162 107848 103488 

104796 106831 102470 99563 102906 

103197 102325 105232 105813 101017 

100872 104651 103924 108430 104651 

97383 105087 102325 106540 103197 

101162 106399 105377 101744 105337 

98110 100872 104796 101598 101744 
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104651 104360 106831 103799 106104 

102906 101453 105087 100145 100726 

Note: The data sets in this example use units that are not shipped with the software (inches, 
pounds, and pounds per square inch). If you have the  "Manage other database settings" 
permission, you could add these units to the database, define their conversion factors and have 
them available for use for any analysis performed within the database. For the purpose of this 
example, it is not necessary for the software to able to convert these units to some other units, 
so we will use the simpler approach of setting up all the units to be in hours. 

Obtain the Stress Distribution 

In this example, stress is defined as: 

 

(S.1) 

  

where F is the tensile load on the rod and d is the rod’s diameter. These variables are 
distributed; therefore, in order to obtain the stress data set, we will first need to obtain the 
distributions for these two variables. 

1. Let us assume that the diameters of the rods are normally distributed. The parameters of 
the distribution can then be determined from the given base dimension and tolerance 
value of the rods. Therefore, the mean of the assumed normal distribution, which is taken 
to be the base dimension, is 0.5 inches. The standard deviation, which is taken to be a sixth 
of the total tolerance value, is 0.005 inches. 
 
To use this information, create a new Weibull++ life data folio in the project. Rename the 
data sheet to "Diameter." On the control panel, choose the Normal distribution and the 
RRX parameter estimation method. Click the Calculate icon on the Main page of the control 
panel, then in the input window, enter 0.5 for the mean and 0.005 for the standard 
deviation, as shown next. 
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2. Click OK. The data sheet will be empty but the parameters of the distribution will be visible 
in the Analysis Summary area of the control panel. 

3. For the distribution of the tensile load, we can use the data from Table I. Create a new data 
sheet in the same folio by right clicking the data sheet tab area (the area at the bottom of 
the window that shows the name of the data sheets) and choosing Insert Data Sheet on 
the shortcut menu. Rename the data sheet to "Load." 

4. Enter the data from Table I and calculate the parameters using the 2P-Weibull distribution 
and the RRX parameter estimation method. The parameters of the distribution for the 
tensile load F are beta = 3.3435 and eta = 14278.1579 lbs, as shown next. 
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5. Now that the distributions of the variables governing Eqn. (S.1) are available, we can now 
obtain the stress data set. There are several conventional methods for synthesizing 
distributions. For this example, we will use a Monte Carlo simulation: 

a. Open the Monte Carlo utility by choosing Home > Insert > Monte Carlo. (If you have 
Accelerated Life Testing or Reliability Growth activated on your computer, you will be 
given a choice between "Monte Carlo," "Stress-Dependent Monte Carlo" or "Repairable 
Systems Monte Carlo." Choose Monte Carlo.) 

 

b. In the distribution drop-down list, choose User-Defined. Enter Eqn. (S.1) in the 
Equation field and click the Insert Data Source button to insert the distributions of the 
variables in the equation, as shown next. 
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c. Click the Settings tab. In the Data Points area, enter 1,000 and then click Generate to 
generate the stress data set. This creates a new folio in the project. Rename the new 
folio to "Stress Values." 

7. Fit a distribution to the data set in the "Stress Values" folio. For this example, the 
distribution that best fits the stress data is a generalized gamma distribution with a mu = 
11.2127 psi, sigma = 0.2856 psi and lambda = 1.0632 psi. Note that your results may vary 
because the data were obtained through simulation. 

Obtain the Strength Distribution 

7. To obtain the strength distribution, use the tensile strength data from Table II. Create a 
new Weibull++ life data folio and rename it to "Tensile Strength." 

8. Enter the data from the table in the data sheet and calculate the parameters using the 
Normal distribution and the RRX parameter estimation method, as shown next (showing 
only the first 19 rows of data). The parameters for the normal distribution of the tensile 
strength are mean = 103421.0800 psi and standard deviation = 2395.1061psi. 
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Estimate the Reliability 

9. Finally, use the stress-strength folio to calculate the reliability of the steel rods. Add the 
folio to the project by choosing Home > Insert > Stress-Strength Comparison. 

 

• Select the data sheets containing the stress and strength data, as shown next. Click OK. 
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• The stress-strength test shows the following plot (with the scaling adjusted and an area 
of the plot shaded to show the region where the strength exceeds the stress). 



Chapter 7: Life Data and Life-Stress Data Analysis Folios 

Weibull++ 2020 User's Guide 475 

 

 

• The result on the control panel indicates that the reliability of the steel rods against 
fractures is estimated to be 96.2171%, as shown next. 
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Target Reliability Parameter Estimator 

The life comparison and stress-strength tools include the Target Reliability Parameter 
Estimator, which allows you to explore how you could attempt to change one of the 
parameters in order to meet a specified target reliability. The plot and reliability estimate will 
be based on the altered distributions, and therefore may be appropriate only within the 
context of your specific "what-if" analysis. 

To open the Target Reliability Parameter Estimator window, choose [Life Comparison/Stress-
Strength] > Analysis > Parameter Estimator or click the icon on the control panel. 

 

You can use the Target Reliability Parameter Estimator with any combination of distributions. 
The life data and life-stress versions of the tool are similar, except for one setting: The Solve 
Parameters based on Coefficient of Variation (CV) check box is available only in the life data 
version of the tool and when the distributions are either both normal or both lognormal. Select 
the parameters to estimate and then enter the CV value. The tool will then estimate the 
parameters that would result in the target reliability. 

The example shown next displays the life data version of the tool. In this example, the first data 
set shows the parameters of a Weibull distribution, while the second data set shows the 
parameters of a lognormal distribution. If we are trying to achieve a target reliability of 90% and 
select to estimate the beta of the first data set, then the tool will hold the rest of the 
parameters constant and estimate a beta value that would result in the 90% target reliability. 
For this example, the result is a beta estimate of 4.0899. 
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To see how the change in the parameter value affects the plot, click Update. The Target 
Reliability Parameter Estimator window will close and the plot will refresh. The control panel 
will display the new probability value or reliability estimate, as well as a status that indicates 
that the parameters have been altered. 

For a practical example on how you might use the Target Reliability Parameter Estimator tool, 
see: http://www.reliawiki.org/index.php/Stress-Strength Analysis in Design for Reliability. 

One-Way ANOVA Folio 

The one-way ANOVA folio offers a simple way to evaluate the effect of a single factor on a 
single response. Like a one factor design, it allows you to take a detailed look at the effect of 
the factor (using up to 255 levels), and it helps you determine whether a change in output is 
due to a change in the input (level) instead of random error. 

The factor in a one-way ANOVA folio is always a qualitative factor. For this reason, predictions 
cannot be made for factor levels that are not tested, nor can optimization be performed. 

Note: In general, one-way ANOVA is a statistical method that is well suited to examining 
existing data, rather than planning an experiment. For planning an experiment involving a single 
factor, the one factor design in the design folio is the appropriate tool. 

http://www.reliawiki.org/index.php/Stress-Strength_Analysis_in_Design_for_Reliability
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To add a one-way ANOVA folio to your project, choose Home > Insert > One-Way ANOVA. 

 

One-Way ANOVA Control Panel 

The one-way ANOVA folio control panel allows you to control the settings for analyzing 
response data and displays the results of the analysis. This topic focuses on the Main page and 
Analysis page of the one-way ANOVA folio control panel, which contains most of the tools you 
will need to perform the analysis. For more information about the control panel in general, see 
Control Panels. 

Control Panel Main Page 

• The Settings area is used to view the settings and status of the analysis. 

 

In this example: 

• The specified risk level is 10%. To configure this setting, click the text. The Analysis 
Settings page of the control panel will be displayed, allowing you to set the risk level. 

• No transformation is used (i.e., the "transformed" response, Y', is equal to the non-
transformed response, Y). To configure this setting, you can click the text or the Select 
Transformation icon in the folio tools. 

• "Analyzed" is shown in green, which indicates that the response data has been 
analyzed using the current settings. Otherwise, this would show "Modified" in red. 

• The last row indicates that the analyzed data consists of 9 observations. 

• The Analysis Summary area is shown when the current response data has been analyzed 
using the current settings. This area displays the p value for the factor and a statement 
regarding whether or not the factor levels affect the response. Click the View Analysis 
Summary icon in this area to view the details of the analysis results. 
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Folio Tools 

The folio tools are arranged on the left side of the control panel. Use these tools to configure 
your analysis and experiment with the analysis results. Depending on the type of design you are 
working with, the control panel may contain some or all of the following tools: 

  Calculate analyzes the data for each response that is selected to be included in the 
analysis. To exclude a response from the analysis, clear the check box in its column heading. 

  Plot creates a plot based on the analysis. If you click this icon before the current data 
set has been analyzed, an analysis will be performed automatically. 

  Design - View Analysis Summary opens a window that contains detailed information 
about current and past analysis results. 

  Select Transformation opens a window that allows you to select a transformation to 
apply to each response. 

Control Panel Analysis Settings Page 

The Analysis Settings page of the one-way ANOVA folio control panel allows you to set the Risk 
Level, or alpha value. This is a measure of the risk that the analysis results are incorrect (i.e., 
alpha = 1 - confidence level). 

One-Way ANOVA Data Tab 

The Data tab in the one-way ANOVA folio offers a column for each level of the factor (up to 256 
levels). Enter the response values observed for each level of the factor in the appropriate 
column. An example is shown next. 

 

You can rename columns in the one-way ANOVA folio data tab by right-clicking the column 
heading and choosing Rename Column on the shortcut menu. 
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One-Way ANOVA Analysis Results 

When accessed from a one-way ANOVA folio, the Analysis Summary window will contain 
detailed information about analysis results, including information that describes how the factor 
levels affect the response. 

If the current response data has been analyzed, you can open the window by clicking the View 
Analysis Summary icon on the control panel. 

 

If the current response data has not been analyzed, the icon will still be available so you can 
view the folio's analysis history. 

Select an item in the Available Report Items panel to display it on the spreadsheet. Each item is 
described next. 

Analysis Results 

The ANOVA table provides general information about the effects of the factor levels on the 
selected response. 

ANOVA Table Columns 

• Source of Variation is the source that caused the difference in the observed output 
values. This can be a factor, factorial interaction, curvature, block, error, etc. If your 
design includes more than one factor and you have selected to use grouped terms in 
the analysis (specified on the Analysis Settings page of the control panel), the effects 
will be grouped by order (i.e., main effects, two-way interactions, etc.). Sources 
displayed in red are considered to be significant.  

• The number of Degrees of Freedom for the Model is the number of regression 
coefficients for the effects included in the analysis (e.g., two coefficients might be 
included in the regression table for a given main effect). The number of degrees of 
freedom for the Residual is the total number of observations minus the number of 
parameters being estimated.  

• Sum of Squares is the amount of difference in observed output values caused by this 
source of variation.  

• Mean Squares is the average amount of difference caused by this source of variation. 
This is equal to Sum of Squares/Degrees of Freedom.  
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• F Ratio is the ratio of Mean Squares of this source of variation and Mean Squares of 
pure error. A large value in this column indicates that the difference in the output 
caused by this source of variation is greater than the difference caused by noise (i.e., 
this source affects the output).  

• P Value (alpha error or type I error) is the probability that an equal amount of variation 
in the output would be observed in the case that this source does not affect the output. 
This value is compared to the risk level (alpha) that you specify on the Analysis Settings 
page of the control panel. If the p value is less than alpha, this source of variation is 
considered to have a significant effect on the output. In this case, the term and its p 
value will be displayed in red.  

• The following values are shown underneath the ANOVA table, and they indicate how 
well the model fits the data:  

• S is the standard error of the noise. It represents the magnitude of the response 
variation that is caused by noise. Lower values indicate better fit. 

• R-sq is the percentage of total difference that is attributable to the factors under 
consideration. It is equal to Sum of Squares(factor)/Total Sum of Squares. Higher 
values usually indicate better fit. 

• R-sq(adj) is an R-sq value that is adjusted for the number of parameters in the 
model. Higher values indicate better fit. 

The Data Summary table gives the mean and standard deviation of the output at each level of 
the factor.  

Data Summary Table Columns 

• Factor Level is the name of the qualitative level. 

• Number in Level is the number of data points obtained at the factor level. 

• Estimated Mean is the average of the data points obtained at the level. 

• Standard Deviation is the standard deviation of the data points obtained at the level. 

The Mean Comparisons table provides information on comparisons between levels of the 
factor. 

Mean Comparisons Table Columns 
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• Contrast gives the paired comparison of any two levels. Level 1 - Level 2 means the 
difference between Level 1 and Level 2. Contrasts displayed in red are considered to be 
significant. 

• Mean Difference is the mean value of the difference in output between the two levels. 

• Pooled Standard Error is the standard error of the mean difference in output between 
the two levels. 

• Low Confidence and High Confidence ares the confidence bounds on the mean 
difference. 

• T Value is the normalized difference, which is equal to Mean Difference/Pooled 
Standard Error. 

• P Value is the probability that an equal amount of variation in the output would be 
observed in the case that there is no significant difference between the levels. This 
value is compared to the risk level (alpha) that you specify on the Analysis Settings page 
of the control panel. If the p value is less than alpha, there is considered to be a 
significant difference between the levels. In this case, the contrast and its p value will 
be displayed in red. 

The Regression Equation information is presented using two tables.  

Regression Equation Tables 

• The Response table displays the response that the regression equation applies to and 
the units of measurement that were entered for the response (if any). 

• The Additional Settings table shows the transformation and risk level you entered for 
the response. 

One-Way ANOVA Plots 

The following plots are available for one-way ANOVA folios. For general information on working 
with plots, see Plot Utilities. 

Level Plots 

Level plots allow you to compare the visually evaluate the effects of different factor levels on 
the selected response. 

• The Comparison Chart shows the standardized difference for each paired comparison of 
factor levels. 
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• The Response vs. Level plot shows the observed output, or response, as well as the 
calculated mean output, at each level of the factor. 

• The Level Mean plot shows the mean output at each level of the factor. The center point of 
each level line is the calculated mean and the end points represent the high and low 
confidence bounds on the mean based on the alpha (risk) value specified on the Analysis 
Settings page of the control panel. 

• The Box Plot shows the output at each level of the factor. The height of each box 
represents the spread of output values at that level. 

• The Mean PDFs plot shows the pdf of the mean response at each level of the factor. 

Residual Plots 

Residuals are the differences between the observed response values and the response values 
predicted by the model at each combination of factor values. Residual plots help to determine 
the validity of the model for the currently selected response. When applicable, a residual plot 
allows the user to select the type of residual to be used: 

• Regular Residual is the difference between the observed Y and the predicted Y. 

• Standardized Residual is the regular residual divided by the constant standard deviation. 

• Studentized Residual is the regular residual divided by an estimate of its standard 
deviation. 

• External Studentized Residual is the regular residual divided by an estimate of its standard 
deviation, where the observation in question is omitted from the estimation. 

The plots are described next. 

• The Residual Probability* plot is the normal probability plot of the residuals. If all points fall 
on the line, the model fits the data well (i.e., the residuals follow a normal distribution). 
Some scatter is to be expected, but noticeable patterns may indicate that a transformation 
should be used for further analysis. Two additional measures of how well the normal 
distribution fits the data are provided by default in the lower title of this plot. Smaller 
values for the Anderson-Darling test indicate a better fit. Smaller p values indicate a worse 
fit. 

• The Residual vs. Fitted* plot shows the residuals plotted against the fitted, or predicted, 
values of the selected response. If the points are randomly distributed around the "0" line 
in the plot, the model fits the data well. If a pattern or trend is apparent, it can mean either 
that the model does not provide a good fit or that Y is not normally distributed, in which 
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case a transformation should be used for further analysis. Points outside the critical value 
lines, which are calculated based on the specified alpha (risk) value, may be outliers and 
should be examined to determine the cause of their variation. 

• The Residual Histogram* is used to demonstrate whether the residual is normally 
distributed by dividing the residuals into equally spaced groups and plotting the frequency 
of the groups. The Residual Histogram Settings area allows you to: 

• Select Custom Bins to specify the number of groups, or bins, into which the residuals 
will be divided. Otherwise, the software will automatically select a default number of 
bins based on the number of observations. 

• Select Superimpose pdf to display the probability density function line on top of the 
bins. 

Diagnostic Plots 

• The Box-Cox Transformation* plot can help determine, for the currently selected response 
and model, what transformation, if any, should be applied. The plot shows the sum of 
squares of the residuals plotted against lambda. The value of lambda at the minimum point 
of this curve is considered the "best value" of lambda, and indicates the appropriate 
transformation, which is also noted by default in the lower title of the plot. 

* These plots are available only when there is error in the design, indicated by a positive value 
for sum of squares for Residual in the ANOVA table of the analysis results. 

One-Way ANOVA Example 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 

The name of the example project is "One Factor - Operators in Pulp Mill." 

Consider the following experiment, which was performed at a pulp mill. Plant performance is 
based on pulp brightness, as measured by a reflectance meter. Each of the four shift operators 
(denoted by A, B, C and D) made five pulp handsheets from unbleached pulp. Reflectance was 
read for each of the handsheets using a brightness tester. The data set is shown next. 

Operator A Operator B Operator C Operator D 

59.88 59.87 60.83 61.01 

60.12 60.32 60.87 60.87 
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60.88 60.42 60.56 60.69 

60.98 59.99 61 60.53 

59.9 60.12 60.5 60.63 

A goal of the experiment is to determine whether there are significant differences between the 
operators in making the handsheets and reading their brightness. If there are such differences, 
then the operators may not be creating the handsheets or recording their observations in a 
consistent manner. 

Creating the Folio 

To determine whether there are differences between the operators, the experimenters create 
a one-way ANOVA folio. Then they enter the response values for analysis. The design matrix 
and the response data are given in the "Operator Study - One-Way ANOVA" folio. The following 
steps describe how to create this folio on your own. 

1. On the Home tab, click the One-Way ANOVA icon in the Insert gallery. 

 

2. Right-click the Level 1 column heading and choose Rename Column on the shortcut menu. 
Change the column name to "Operator A" and click OK. 

3. Rename the second, third and fourth column to "Operator B," "Operator C" and "Operator 
D," respectively. 

Analysis and Results 

The data set for this example is given in the "Operator Study - One-Way ANOVA" folio of the 
example project. After you enter the data from the example folio, you can perform the analysis 
by doing the following: 

• Click the Calculate icon on the Data tab control panel. 

 

• The result in the Analysis Summary area show that the p value is 0.0210. In other words, 
there is a 2.1% chance that the variation would be observed in the case when there is no 
significant difference between the response levels. Since the p value is less than the risk 
level (10%) entered on the Analysis Settings tab of the control panel, the conclusion is that 
the different factor levels (i.e., operators) do affect the response. 
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• To see more detailed comparisons of the responses at different factor levels, click the View 
Analysis Summary icon and view the Mean Comparisons table. 

 

The compared factor levels are listed in the Contrast column (e.g., "Operator A - Operator 
B" is the comparison of those two operators). When a p value is red, the compared levels 
are significantly different. For example, there is a significant difference between Operator 
A and Operator C, but there is no significant difference between Operator A and Operator 
B. 

• To see a plot that also allows you to compare the different factor levels, click the Plot icon. 

 

Then view the box plot. In this plot, you can see that see that operators C and D are 
nearly the same. 
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Conclusions 

The results show that there is a significant difference between operators A and C, between A 
and D, and so forth. As a result, the operators receive further training to insure that they create 
the handsheets and record their observations consistently. 

RBDs 

The diagrams in Weibull++ allow you to build reliability block diagrams (RBDs) using blocks that 
are linked to calculated data sheets from life data and life-stress data folios. 

One typical application for this tool is for performing complex failure modes analysis. As 
explained in the Competing Failure Modes (CFM) Analysis topic, the CFM analysis method that 
is built-in to the Weibull++ life data folio assumes a series reliability model and uses only one 
type of distribution to analyze all the modes. If the situation is more complex, an RBD analysis 
method must be used instead (see Using RBDs for Failure Modes Analysis). 
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Building the Diagram 

To add a diagram in Weibull++, choose Home > Insert > Diagram, or right-click the RBDs folder 
in the current project explorer and choose Add Diagram on the shortcut menu. 

 

To add blocks to a diagram, choose Diagram > Blocks and then select the type of block you wish 
to add. 

  Add Block adds a standard block that represents a data sheet in a life data or life-
stress data folio. You can also add a standard block by dragging the data sheet of interest 
from the Data Sheets page of the control panel into the diagram. You can use any data 
sheet in any life data or life-stress data folio, as long as it has been calculated and is not 
using one of the competing failure modes distributions. (A red flag over a block indicates 
that the associated data sheet in the folio has either been deleted or needs to be 
calculated.) 

By default, standard blocks are named after the data sheets they represent. If you want to 
use a different name, right-click the block and choose Rename Block. 

  Add Node adds a node block that functions like a switch that diagram paths move 
through. A node block models an alternative form of redundancy known as k-out-of-n 
redundancy. A k-out-of-n node block can have n paths leading into it and requires that k out 
of n paths must function for the system to function. There must be at least one path 
leading into a node; therefore, a node block cannot be placed as the starting block for a 
diagram. 

Double-click the node block to specify the number of paths that must reach the node in 
order for the system to succeed. 

  Add Junction adds a junction block, which is a non-failing block. Because diagrams 
must flow from a single starting point to a single ending point, you may need to use 
junction blocks as starting and/or ending blocks (see Diagram Analysis Constraints). They 
can also be used anywhere within the diagram that you need a block that does not fail (i.e., 
does not affect the system reliability). 

Once you have added blocks to the diagram, you can then use connectors to connect the blocks 
and build the RBD. From the RBD, you can calculate the exact system reliability equation for the 
system, and obtain plots and results based on that equation. 
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Examples of RBD Configurations 

In a basic series configuration, all items must work for the system to work. The following 
example shows standard blocks connected in series. The system fails if Block A, Block B or Block 
C fails. 

 

In a basic parallel configuration, items are considered to be redundant. In the RBDs shown 
next, the system will continue to function if either Block B or Block C fails. (The second RBD 
shows an example of a junction block used as a starting block.) 

 

The following example shows a k-out-of-n configuration where Block B, Block C or Block D can 
fail without causing system failure, but if two of the blocks fail, the system will fail. 
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The following example shows a complex diagram with a node configuration. If more than three 
of the five blocks (blocks C, E, F, G and H) leading to the node block fail, the system will fail. 

 

Diagram Analysis Constraints 

In order to permit analysis, all RBDs created in the software must conform to the following 
constraints: 

• A diagram must contain at least one block. 

• If a diagram contains more than one block, all blocks in the diagram must be connected. 

• Diagrams must contain a single starting block and a single ending block, as shown next. 
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If a diagram consists of only one block, that block represents both the starting and ending 
block. Junction blocks can be used as starting and/or ending blocks that possess no 
reliability characteristics. 

• Circular references, as shown below, are not allowed. There must be a clear path towards 
the end of the RBD and the RBD cannot loop back on itself. 

 

Connecting Blocks 

Connectors represent the flow of the process or system being diagrammed, and the lines 
contain information about the relationship between the specific source and destination blocks 
that they connect. In process flow simulation (PFS) diagrams, connectors are considered to 
represent pipes. Each pipe carries a specific type of throughput flow, and there may be multiple 
flow types in a diagram.  

Adding Connectors 

To add a connector between blocks, you can: 

• Right-click the diagram (not blocks) and choose Connect Blocks or choose the command in 
the ribbon. 
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• Hold down the ALT key. 

In PFS diagrams, use the down arrow on the Connect Blocks ribbon command to specify which 
flow type you are currently adding before using either of these methods. 

In both methods, the pointer will change to display small crosshairs. Click the source block, hold 
down the left mouse button and drag a line from the source block to the destination block. 
When the crosshairs are located over the connection point box, release the mouse button to 
create a connector. 

 

Note that existing connectors can be dragged to different destination blocks, if needed. Also 
note that the curved, custom curve and custom angled connector types give you the option to 
connect to the top or bottom of a block, if desired. When this option is available, the blocks will 
show additional connection point boxes when you create or move a connector. 

 

In BlockSim RBDs, you can add multiple connectors at once by selecting either multiple source 
blocks or multiple destination blocks and then adding a connector. By default, you will see a 
message allowing you to choose to add the connections for all of the blocks in the selection. If 
desired, you can select to stop showing the message in the future and to always perform the 
action you select going forward. This can be changed in the future by reselecting the Ask for 
confirmation when connecting multiple blocks option on the Other Settings page of the 
BlockSim Application Setup. Note that if you clear this option manually within the Application 
Setup, the default behavior (adding the connection only to the block you actually placed the 
connector on) will be used. 
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Starting in Version 20.0.2, you can also connect multiple blocks in fault trees. This adheres to 
the same constraints that apply to all fault trees; please refer to the topics on each block type 
(listed here) and to Fault Tree Analysis Constraints for details. No error message is shown for 
invalid connections when connecting multiple blocks, but only valid connections will be added. 
The Application Setup option mentioned also above applies in this case. 

In fault trees, you will normally connect multiple source blocks to one destination block. If you 
attempt to reverse this, the software will connect the blocks in the direction that makes logical 
sense (in much the same way that when you connect a single OR gate to a single OR gate, the 
gate on top will always be the destination). 

Stop Adding Connectors 

To stop adding connectors and return the pointer to its normal mode, release the ALT key or 
click inside the diagram. 

Tip: If you do not click the diagram or clear the Connect Blocks option to return the pointer to 
its normal mode, you will not be able to perform certain other activities, such as moving or 
deleting blocks. If you are experiencing difficulties with the application, make sure that the 
pointer is in its normal mode. 

Inserting Blocks/Splitting Connectors 

RBDs, PFS diagrams, Markov diagrams and event analysis flowcharts allow you to insert a block 
into the flow of the diagram without having to delete and add connectors. Simply drag an 
unconnected block onto an existing connector. When the pointer changes to a double-headed 
arrow, drop the block to split the existing connector and insert the block. 

 

http://help.reliasoft.com/blocksim20/index.htm#t=fault_tree_block_types.htm
http://help.reliasoft.com/blocksim20/index.htm#t=fault_tree_analysis_constraints.htm
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Connector Types 

There are several types of connector that can be used in a diagram. The simplest is a straight 
line but there are options for adding line bends to create curved or angled lines. For details 
about available connector styles and defining preferences, see Connector Style Settings. 

Using Curved, Custom Curve or Angle Connectors 

When using curved, custom curve or custom angle connectors, you can choose the location 
where they connect to the blocks (top, middle or bottom) and add one or more bends to the 
line. These options can be used separately or in combination. 

To add or modify line bends: 

• Curved connectors have a single bend point in the center of the connector. To change the 
angle, click and drag the point to the desired location. 

 

• For custom curve and custom angle connectors, add line bend(s) by clicking anywhere on 
the connector and dragging the selected point to the desired location. 

  

These custom bends can be removed by right-clicking the connector and choosing Remove 
all Bend Points or, to remove a single bend point, by right-clicking the bend point and 
choosing Remove Bend Point. 

Arranging and Resizing Blocks 

There are a number of commands that can be used to arrange and resize the blocks in a 
diagram. They can be used separately or in combination. 

• To select multiple blocks, select the first block and then hold down the CTRL key while 
clicking each of the other blocks. 
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• If you apply a command and don’t like the result, you can use CTRL+Z to return to the 
original layout. 

Align Blocks 

To align the blocks (align by center, top, bottom, left, etc.), select the block you want to use as 
the reference alignment position then select the other blocks. Right-click inside one of the 
blocks and choose Align Blocks then the desired alignment style. 

The selected blocks will be aligned with the first block selected. For example, if you choose 
Align Middles, the blocks will be aligned to the vertical center of the first selected block, as 
shown next. 

 

Resize 

Select the block then click one of the sizing handles and drag it to the desired size. 

 

Make Same Size 

To make the blocks the same size, select the block that has the desired dimension(s) then select 
the other blocks that you want to resize. Right-click inside one of the blocks and choose Make 
Same Size then choose to match the width and/or height of the first selected block. 

For example, if you choose Height, the blocks will be resized to the same height as the first 
selected block. 
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Make Spacing Equal 

To adjust the spacing between blocks, select the blocks that will be affected (the selection 
order does not matter). Right-click inside one of the blocks and choose Make Spacing Equal 
then the desired direction. 

The selected blocks will be moved so that they are equally spaced over the original size of 
horizontal and/or vertical area. 

  

Auto Arrange 

To automatically arrange the blocks in the diagram so that all blocks are placed in logical order 
depending on their connections, right-click the diagram (not blocks) and choose Auto Arrange. 

Note that for Markov diagrams in BlockSim, you also need to select the starting block that is 
going to be the top left block in the diagram. 

The space between blocks depends on the settings specified in the Background and Grid page 
of the Diagram Style window. 
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Auto Fit Width 

In some BlockSim diagrams, you can also choose Auto Fit Width to automatically arrange the 
blocks in the diagram to fit evenly spaced within the width of the diagram window. 

 

Adding Annotations 

Annotations are blocks that can be added to a diagram and can contain notes, comments or any 
other information that you want to appear with your diagram. Annotations are not taken into 
consideration when the diagram is analyzed but will be saved with the project. 

To add an annotation, right-click the diagram (not blocks) and choose Add Annotation. 

The annotation block will appear in the diagram. 

By default, the text "Annotation" will appear in the block. You can change this text in the Edit 
Annotation window, which is accessed by double-clicking the annotation block. 
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In BlockSim diagrams, you can click the Function Wizard icon to insert a function that provides 
information about the diagram. 

  

If you are working with an analytical diagram, you can insert: 

• General Functions, which return basic information about the database and project, such as 
the project name or the current date. 

• Data Source Functions, which return information based on the model used with the 
specified data source, such as the acceleration factor or the reliability at given time. 

If you are working with a simulation diagram, you can insert: 

• General Functions, which return basic information about the database and project, such as 
the project name or the current date. 

• Simulation Functions, which return information about the simulation results and settings. 

Note that if you want to add additional functions to the same annotation box, click the Function 
Wizard icon, again. 

Keyboard and Mouse Combinations 

This topic describes the various keyboard and mouse key combinations that you can use while 
working with diagrams. 

Note the following: 

• A unit is equal to either 1 millimeter or 0.1 inches, depending on the system setting. 

• When selecting multiple objects, you can select either blocks or connectors. A selection 
cannot include both blocks and connectors. Note that while you can include Standby 
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Containers and Load Sharing Containers in a selection, any changes you make, such as 
resizing the containers, do not apply to the blocks or connectors in the containers. If you 
start a selection inside a container, that selection can include only those blocks and 
connectors within that container. 

Selecting Objects 

Select a block or connector Click the block or connector. 

Select multiple blocks or 
connectors 

Press CTRL and click the blocks or connectors. 

Select a group of blocks Click within the diagram and drag the selection to include 
the desired blocks. 

Add additional blocks or 
connectors to the currently 
selected group 

With a group of blocks or connectors selected, press CTRL 
and then make another selection. The new selection will be 
merged with the existing selection. 

Select all blocks in the diagram Press CTRL+A. 

Clear all selections in the 
diagram 

Press ESC. 

Switch the status of a block or 
connector from selected to 
not selected or from not 
selected to selected. 

Press SHIFT and click the block or connector. 

Moving Objects 

Move a block Click the block and drag to the desired location. 

Move multiple blocks Select the blocks then click any block within the selection 
and drag the selection to the desired location. 

Move block(s) by 1-unit 
increments 

Select the block(s) then press the desired arrow key. 

Move block(s) the distance of 
1 grid line 

Select the block(s) then press CTRL + the desired arrow key. 
If only one block is selected, this shortcut will first align the 
block to the grid and then each subsequent use of the 
shortcut will move the block by one grid line. 

Resizing Objects 

Resize a block Select the block then click one of 
the sizing handles and drag it to 
the desired size. 
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Resize block(s) by 1-unit 
increments 

Select the block(s) then press SHIFT and the desired arrow 
key. The up and down arrow keys move the bottom edge of 
each selected block by a single unit; the right and left arrow 
keys move the right edge of each selected block by a single 
unit. 

Resize block(s) by 5-unit 
increments 

Select the block(s) then press CTRL + SHIFT + the desired 
arrow key. The up and down arrow keys move the bottom 
edge of each selected block by 5 units; the right and left 
arrow keys move the right edge of each selected block by 5 
units. 

Connectors 

Add a new connector Press ALT and drag the connector from the source block to 
the destination block. 

Change a connector's source 
or destination 

Select the connector then drag 
the appropriate connection 
handle to the new source or 
destination block. 

Add a bending point to a 
connector. 

Note that the connector must 
use the Custom style. To set 
the style, refer to the 
Connector Style Settings topic. 

Click the connector and drag 
the bending point to the 
desired location. 

Scrolling 

Scroll vertically Rotate the mouse wheel. 

Scroll horizontally Press SHIFT and rotate the mouse wheel. 

Scroll in any direction With nothing selected, press the desired arrow key. 

Scroll horizontally to the far 
left 

Press HOME. 

Scroll horizontally to the far 
right 

Press END. 

Scroll to the upper left corner 
of the diagram 

Press CTRL+HOME or CTRL+PAGE UP. 

Scroll to the lower right corner 
of the diagram 

Press CTRL+END or CTRL+PAGE DOWN. 
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Scroll by the size of the visible 
area of the diagram 

With nothing selected, press CTRL + the desired arrow key. 
For vertical scrolling, you can also press PAGE UP and PAGE 
DOWN. 

Move the diagram in any 
direction (pan) 

Press SHIFT, click the diagram and drag. This is like dragging 
the diagram sheet itself (e.g., to see objects lower in the 
diagram, you would drag the diagram upward). 

Other 

Zoom in or out Press CTRL and rotate the mouse wheel. 

Exit the Format Painter or 
Connect Blocks modes 

Press ESC. 

Create a copy of a block and 
move the copy to the desired 
location 

Press CTRL+SHIFT and click the block then drag to the 
desired location, either within the diagram or in another 
diagram of the same type. 

Add blocks to the mirror group 
currently shown in the Mirror 
Group Manager window 

Press CTRL+SHIFT and drag the block from the diagram into 
the Mirrored Blocks area of the Mirror Group Manager. 

Analyzing Diagrams 

Weibull++ Diagram Control Panel 

The diagram control panel in Weibull++ contains the following options. 

Main Page 

  Analyze analyzes the relationships of the components in the diagram and puts the 
reliability-wise configuration into a mathematical formula. 

  Plot creates a plot based on the analysis results. Clicking the Plot icon before the 
diagram has been analyzed will automatically perform the analysis and then plot the data. 
(See Plot Utilities.) 

  QCP opens the Quick Calculation Pad (QCP), which allows you to obtain reliability 
results based on the algebraic solution for the diagram. 

  Transfer to BlockSim is available only if BlockSim is activated on your computer. It 
exports the blocks into a new BlockSim simulation diagram. All the blocks must be 
associated with a published model before they can be exported. 

https://www.reliasoft.com/products/reliability-analysis/blocksim
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• The Analytical area displays the status and results of the analysis. If the light is green, as 
shown below, then the diagram has been analyzed. If the light is red, then the diagram has 
not been analyzed. An analyzed diagram will remain in the analyzed state unless a change is 
made to the structure of the diagram (e.g., a block is added or changed, a connector is 
removed, etc.). 

You can click the (...) button to display the algebraic solution for the diagram in the 
Equation Viewer. 

 

• The Information area displays information for the diagram (if a block is not currently 
selected) or for the selected block. 

        

Data Sheets Page 

The Data Sheets page contains a list of all of the data sheets in the project that are available for 
use in the diagram. 

You can drag a data sheet into the diagram to create a standard block. You can use any data 
sheet in any life data or life-stress data folio, as long as it has been calculated and is not using 
one of the competing failure modes distributions. 
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Equation Viewer 

In Weibull++ diagrams, the Equation Viewer shows the algebraic equation for the system 
reliability, pdf and failure rate as a function of the block reliabilities. 

To open the Equation Viewer, click the Show Algebraic Solution (...) icon on the control panel. 

 

There are two ways to view the system reliability equation: as a symbolic equation or as the 
complete equation. With either view, you can: 

• Select Show Legend to display the failure distribution for each block in the diagram. 

• Select Show Colors to use color-coding in the window to make the equations easier to 
view. 

If you have made changes to these settings, click Refresh to update the contents of the 
window. 

You can click Add Equation to Attachments to save the equation to the project attachments as 
an embedded *.rtf file. 

Symbolic Equation View 

The symbolic equation view uses tokens to represent portions of the equation. You can read 
the solution from the bottom up, replacing any occurrences of a particular token with its 
definition. For example, consider the RBD shown next. 

 

When this diagram is analyzed, the symbolic reliability equation is: 
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This would be read as follows: 

 

(1) 

 

(2) 

 

(3) 

  

We begin with Eqn. (3). This equation contains the token D1, which is defined in Eqn. (2). This is 
then substituted into Eqn. (3), yielding: 

 

(4) 
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Now Eqn. (4) contains the token ID, which is defined in Eqn. (1). Substituting this into Eqn. (4) 
yields: 

 

(5
) 

  

Complete Equation View 

When you use the complete equation view, the software automatically performs all token 
substitutions. You should be aware that in some cases, the software may not be able to render 
the complete equation in the Equation Viewer even though it has internally computed it. This 
could happen if the memory available on your computer is insufficient and is therefore unable 
to construct the equation algebraically. This usually does not happen unless there are over one 
million terms. 

 

Diagram Skins and Appearance Settings 

Most of the appearance settings in a diagram can be customized to meet your particular 
preferences. 

Diagram Skin – sets (or resets) all of the settings in the Diagram Style for a particular diagram. 

Diagram Style – contains all of the style settings for the current diagram (e.g., background 
color and grid style) as well as default settings for the blocks and connectors within this 
diagram. 
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Block Style and Connector Style – allow you to override the default settings for specific 
blocks or connectors, if desired. 

For consistency and ease of use, the simplest option is to choose a preferred skin and set it as 
the default for your computer. Each new diagram you create will have the preferred settings 
applied automatically. If desired, you also have the option to change settings for a particular 
diagram, and/or for particular blocks or connectors. 

Tip: If you use the Block Style or Connector Style windows to modify the settings for specific 
blocks or connectors, those settings will no longer be linked to the default settings in the 
Diagram Style and they won’t be updated if you change the skin. If you want the 
block/connector settings to be determined by the diagram style/skin, make sure they are set to 
"Diagram Default." 

Using Diagram Skins 

A diagram skin provides a quick and easy way to set (or reset) all of the settings in the Diagram 
Style window for a particular diagram. 

Diagram skins are universal across all ReliaSoft applications. This means that a single skin can 
contain the appearance settings for all types of diagrams in BlockSim, Weibull++ and 
XFMEA/RCM++/RBI. However, you will only be able to see/modify the settings for the type of 
diagram that you are currently working with. 

The universal skins are stored with a *.dskin extension at C:\Users\Public\Public 
Documents\ReliaSoft\Skins. If you have already customized skins from a prior version, see 
Converting Version 9 Skins.   

In order to create, modify or manage the skins on your computer, you must first open a 
diagram then right-click and choose Diagram Style. 

The commands that you will use are located in the lower-left corner of the window. 

 

What's Changed? Starting in Version 18, you cannot modify the skins that are installed with the 
software. Any changes that you make must be saved as new skins with their own names. 
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Select Skin 

To apply an existing skin to the current diagram: 

1. Click the Select Skin (✓) icon. 

2. Choose a skin from the list and click OK. The name of the selected skin will be displayed in 
Skin field. 

3. Click OK to close the Diagram Style window and apply the relevant settings to the diagram. 

If you don’t like the result, you can undo the action by pressing CTRL+Z, or simply return to the 
Diagram Style window and select a different skin. 

Modifying or Creating a Skin 

1. Open a diagram that has the settings you want to reuse or create the diagram. Open the 
Diagram Style window. 

2. Make your changes. For details on the settings that can be changed, see the Diagram Style 
Settings. 

3. Click the Save as Skin (+) icon. Enter a name for the skin and click OK. If you specify a name 
that already exists, you’ll be asked to confirm that you want to replace the settings for this 
particular diagram type. 

Note: Skin names cannot contain the following characters: < > | / \ ; ? : * or quotes. The 
names are not case sensitive. 

Skins are stored with a *.dskin extension in the Skins folder (C:\Users\Public\Public 
Documents\ReliaSoft\Skins). 

Save as Skin 

To use the settings in the current diagram to create a new skin, or to update an existing skin: 

1. Click the Save as Skin (+) icon. 

2. Enter a name for the skin and click OK. If you specify a name that already exists, you’ll be 
asked to confirm that you want to replace the settings in the existing skin for this particular 
diagram type. (The settings that are specific to other diagram types will remain unchanged.) 

Note: Skin names cannot contain the following characters: < > | / \ ; ? : * or quotes. 
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Manage Skins 

To view or manage the skins that are available to use on your computer, click the Manage Skins 
(…) icon. From here you can: 

• Click Import to browse for *.dskin files in another location (e.g., skins that were created by 
another user or on a different computer) and copy them into the designated folder for your 
computer. 

Tip: You can also copy/paste *.dskin files directly into the C:\Users\Public\Public 
Documents\ReliaSoft\Skins folder. However, they won’t appear in the skins list until you 
restart the application. 

• Select a skin and click Rename, then specify a new name. This will change the name of the 
*.dskin file in the designated folder for your computer. 

• Select a skin and click Delete. This will remove the *.dskin file from the designated folder 
on your computer and cannot be undone. 

• Click Set Defaults and then specify which skin will be used by default for each new diagram 
you create. 

Converting Version 9 Skins 

Starting in Version 10, diagram skins are universal to all ReliaSoft applications that use 
diagrams. This means that a single skin can contain the appearance settings for all types of 
diagrams in BlockSim (and, for versions prior to 2020, RENO), Weibull++ and 
XFMEA/RCM++/RBI. 

Many of the predefined skins installed with Version 9 applications have already been merged 
and converted into universal skins that are ready to use in any diagram type in later versions. 
For example, the new White.dskin replaces the old RBDWhite.dskinrbd, FTDWhite.dskinftd, etc. 

If you created your own customized skins in Version 9, this topic explains how to convert them 
for use in later versions. 

Preparing the Version 9 Skins Folders 

The conversion utility considers the old Version 9 skins that are stored in the following 
locations: 

• C:\Users\Public\Public Documents\ReliaSoft\Skins\BlockSim9 
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• C:\Users\Public\Public Documents\ReliaSoft\Skins\Xfmea9 

• C:\Users\Public\Public Documents\ReliaSoft\Skins\RCM9 

• C:\Users\Public\Public Documents\ReliaSoft\Skins\Weibull9 

Before running the utility, you can: 

1. Delete any Version 9 skins that you don’t wish to use or convert. (This is not required but it 
may help to avoid confusion when you run the conversion utility.) 

2. For any Version 9 skins that you wish to combine into the same universal skin, rename 
them to the same filename (while still retaining the different file extensions). 

For example, if you want to combine RBDCustom.dskinrbd and FTDCustom.dskinftd into the 
same universal skin, you could rename the files to Custom.dskinrbd and Custom.dskinftd. 

Running the Conversion Utility 

After you have prepared the Version 9 skins folders as described above: 

1. Choose File > Application Setup. 

2. On the Common Settings > Other page, click Convert. 

  

3. The Convert Skins window will display all of the unique filenames that remain in the Version 
9 skins folders. (If you want to combine multiple skins into the same new universal skin, 
make sure you have already renamed the files as described above.) Select the skins you 
want to use in later versions and click Convert. 

4. Close the application so the skin(s) will be added to the Skins folder. 

The new file(s) are stored at C:\Users\Public\Public Documents\ReliaSoft\Skins with a *.dskin 
extension and “_V9” appended to the name. 

A Note about Diagram Backgrounds 

Universal skins contain appearance settings for diagram background and grid, and connector 
and block handles that are applied to all diagram types. When you create a universal skin from 
individual skins with different background/grid/handle settings, only one set of these 
appearance settings will be stored in the skin. The settings that are saved into the universal skin 
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are from the last skin that was merged. If these are not the settings you desire, you can use the 
Diagram Style window to change them. 

Diagram Style Settings 

In the Diagram Style window, you can define diagram-level appearance settings, and default 
settings for the blocks and connectors within the diagram. These settings can be saved in a 
diagram skin and reused with other diagrams. 

To open the Diagram Style window, right-click the diagram (not blocks) and choose Diagram 
Style. 

This window consists of multiple pages. The number and type of pages depend on the type of 
diagram that you are working with. Settings that can be defined are divided into two groups: 
Diagram and Defaults. 

• At the diagram level, you can define the appearance of the diagram sheet and those 
aspects of the appearance of diagram components (i.e., blocks and connectors) that cannot 
be configured at the individual component level. 

• You can define the default appearance settings for diagram components (i.e., connectors, 
blocks and annotations). See Defaults for Blocks and Connectors. 

Background and Grid 

You can customize the background and grid appearance of the diagram. 

• Grid Style: Whether to display grid lines and, if so, the style of the lines (e.g., solid, dash, 
etc.). 

• Grid Spacing: The size (width and height) of the grid squares, in inches. 

• Shadow: The size and color of the shadow "cast" by blocks in the diagram. Note that this 
applies to all block types, but the shadow will be shown only if the Show Shadow check box 
is selected on the Defaults > General page for that block type. 

• Colors: The colors used for the background, grid lines and page separator lines. 

• Auto Arrange: The horizontal and vertical spacing between blocks, in inches, that will be 
used if you choose the Auto Arrange ribbon command. 

For fault trees in BlockSim, you can also select the Always Auto Arrange check box to turn 
on Auto Arrange by default. 
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• Block Caption ID: Whether to display the block ID, which is an internal ID number assigned 
to each block when it is created. You can choose not to display the ID or to display it in 
decimal or hexadecimal format. If it is displayed, it will appear directly below the block 
name (i.e., its location, alignment and font will be dictated by the properties that are 
specified for the block caption). 

Connector Handles and Indicators 

You can customize the following diagram-level connector properties. These settings apply to all 
connectors of all types within the diagram and cannot be overridden at the connector level. 

• If you select Show Connectors Over Blocks, any connectors that cross blocks will be shown 
over (i.e., in front of) those blocks. Otherwise, the blocks will be displayed on top. 

• Where connectors attach to blocks if the blocks are not in direct horizontal or vertical 
alignment. If the Automatic Connection Preference field is set to Left-Right, the connector 
will attach to the sides of the blocks; if it is set to Top-Bottom, the connector will attach to 
the top and bottom of the blocks. If No Preference is chosen, the connector will attach to 
the closest edges. 

• The colors used for: 

• All connector handles and selected connectors. 

• Connectors to/from highlighted blocks (i.e., blocks that are part of a multiple selection). 

• Connectors leading to or from a selected block. This can be helpful in visualizing how a 
block is connected within a complex diagram. 

• The size of the arrow head, in inches. 

• The thickness of connectors in a traced path. 

Block Handles and General Indicators 

You can customize the following diagram-level block properties. These settings apply to all 
blocks of all types within the diagram and cannot be overridden at the block level. 

• The properties for a highlighted block, including: 

• The colors used for the handles that appear when you are resizing a block or 
connecting blocks. 

• The colors used for the caption, border and fill (i.e., the area background). 
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• The fill style (i.e., how the color is applied to the area). 

• Flag settings: 

In BlockSim, can be used to indicate anything you want. For example, each flag could 
represent a level of analysis that has been completed. These flags are not used by BlockSim 
for analyses or simulations. 

In Weibull++, the block flags are used to mark blocks that represent a data sheet that has 
been changed and has not been calculated or a data sheet that has since been deleted. 

• Block flag size: Block flags, which are added by selecting one or more blocks, right-
clicking one of the blocks and choosing Set Block Flag. 

• Block flag borders: The style (e.g., solid, dash, etc.), color and thickness of the border 
for block flags. 

• Cross out lines for blocks: In BlockSim diagrams, the style, color and thickness of the line 
that is used to cross out blocks that are set as failed. Blocks can be set as failed by selecting 
the Set block as failed option in the Block Properties window. You can also set this option 
by right-clicking the block and choosing Set Block as Failed.   

Block Corner Indicators (BlockSim Only) 

The Block Corner Indicators pages allow you to customize the appearance of status indicators 
that are displayed at the corners of blocks. Such indicators include the colored shapes that are 
used to indicate certain block and text labels that may appear independently or in conjunction 
with a shape. The available Block Corner Indicators pages will vary depending on the type of 
diagram that you are working with. 

Defaults for Blocks and Connectors 

Default appearance settings can be defined for diagram components (i.e., connectors, blocks 
and annotations. A diagram skin can hold the appearance settings for all diagram types (e.g., 
RBD, fault tree, process flow, etc.); however, you can only modify the settings for the diagram 
type you are working with. To define these settings, see: 

• Block style settings 

• Connector style settings 
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Block Style Settings 

The block style settings can be defined at the diagram level in the Diagram Style window or at 
the block level in the Block Style window. The block-specific settings defined in the Block Style 
window have priority over the default settings defined in the Diagram Style window for the 
diagram you are working with. For details on how the diagram-level and connector-level 
settings relate to each other, see Appearance Settings. 

Diagram Level 

To open the Diagram Style window, right-click the diagram (not blocks) and choose Diagram 
Style. 

Block Level 

To open the Block Style window, select one or more blocks, right-click one of the blocks then 
choose Block Style. 

Note that if you are using the this window, you must clear the various Use Default check boxes 
in order to modify some settings. 

General Properties 

Block Properties 

• Shape and shadow: The options available in the Shape drop-down list depend on the block 
type. You can change the shape of standard blocks in RBDs, events in fault trees and all 
blocks in process flow and cause/effect diagrams; all other block types have permanently 
assigned shapes. You can add a shadow to any available shape. 

• Size: Unlike the other options on this page, changes to this setting made at the diagram 
level will apply only to blocks subsequently added to the diagram. 

• Color and style: The background color is the underlying color applied to the block; the fill 
color is applied over the background color in the pattern specified by the fill style. 

Caption Properties 

The caption text comes from a block name in BlockSim, folio name in Weibull++ or property 
name in XFMEA/RCM++/RBI. 

• Location and Horizontal Alignment: Specify where the caption will be displayed (e.g., under 
the block, inside the block, etc.) and whether it will be left aligned, center aligned or right 
aligned. 
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• If you choose to place the caption to the left, right or inside the block, you can also 
specify the Vertical Alignment (i.e., at the top, center or bottom of the block). 

• If you choose to hide the caption, the Alignment fields will not be available. 

• The width and height of the area used for the text. You can enter a fixed value for either or 
both of these. If Block Width is selected in the Width field, the caption text will wrap, if 
necessary, up to the vertical limit set in the Height field. If Auto Height is selected in the 
Height field, no limit is placed on the height of the text area. 

• The color and font used for the text. 

Description Box Properties 

These properties are available for BlockSim blocks only. 

The description box displays the text entered in the Description field of the Block Properties 
window. 

 

Description Box Properties 

• Box width and height: You can enter a fixed value for either or both of these or you can set 
them to be the same as the settings used for the caption area. 

• If Block Width is selected in the Width field, the description text will wrap, if necessary, 
up to the vertical limit set in the Height field. 

• If Auto Height is selected in the Height field, no limit is placed on the height of the text 
area. 

• Box color and style: The background color is the underlying color applied to the description 
box; the fill color is applied over the background color in the pattern specified by the fill 
style. 
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Description Text Properties 

• Text Location and Horizontal Alignment allow you to specify where the description area 
will be displayed (i.e., above the block, inside the block or hidden) and whether it will be 
left aligned, center aligned or right aligned. 

• If you choose to place the caption inside the block, you can also specify the Vertical 
Alignment (i.e., at the top, center or bottom of the block). 

• If you choose to hide the description area, the Alignment fields will not be available. 

Note that if you place the description inside the block, only the description text will be 
shown. The settings for the surrounding area (i.e., background color, fill color and 
border properties) will not be used. The properties for the background color fill color 
and fill style of the block will be used instead. 

• The color and font used for the text. 

Using the Same Location Settings for Captions and Descriptions 

Block captions and descriptions both have the option to place the text above or inside the block 
(and other locations, for captions). If you choose the same location for both, the description 
text will display under the caption text. 

 

Images 

To load an image: 

1. Clear Use default image, if applicable. 

2. Click Load, and browse for and select the desired image file. 

3. Use the Position drop-down list to specify how the image will be placed on the block (e.g., 
stretched to fit inside the block's current dimensions, centered, etc.). If you select 
stretched, you can also define the margins you want. 

4. Select the Transparency Mask Color check box to choose a color that will be shown as 
transparent when the image is displayed on the block. 
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Note: If you choose to use an image that is larger than 800x600 pixels, you will be given the 
option to down sample the image in order to reduce its size and alleviate possible delays 
related to database size. 

5. Click the Clear button to remove the loaded image and use no image at all. 

Returning Block-Level Settings to Diagram Defaults 

To use the diagram style settings again, in the Block Style window, choose Diagram Default 
from the drop-down lists and select the Use Default check boxes. 

Connector Style Settings 

The connector style settings can be defined at the diagram level in the Diagram Style window or 
the connector level in the Connector Style window. The connector-specific settings defined in 
the Connector Style window have priority over the default settings defined in the Diagram Style 
window for the diagram you are working with. For details on how the diagram-level and 
connector-level settings relate to each other, see Diagram Skins and Appearance Settings. 

Note:  In BlockSim process flow simulation (PFS) diagrams, connectors are considered to 
represent pipes. Each pipe carries a specific type of throughput flow, and there may be multiple 
flow types in a diagram. For these diagrams, flow types (connector styles) can also be defined at 
the diagram level via the Flow Types window (right-click the diagram and choose Flow Types). 
This window works similarly to the Diagram Style window, and connector-specific settings also 
have priority over settings defined in the Flow Types window. 

Diagram Level 

To open the Diagram Style window, right-click the diagram (not blocks) and choose Diagram 
Style. 

Connector Level 

To open the Connector Style window, select one or more connectors, right-click one of the 
connectors then choose Connector Style. 

Note that if you are using the this window, you must clear the Use Default check boxes in order 
to modify some settings. 

Line Settings 

• Line Settings: Specify the connector's line style (e.g., solid, dash, etc.), thickness and color. 
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• Line Bend and Arrows: Use the Line Bend drop-down list to specify the kind of bend that 
you want in the lines. Note that if you select Angle or Right Angle, the Line Bend % field will 
be enabled. This field allows you to specify the point, in percent, at which the line will bend. 
For example, if you enter 0.5 (50%), an angle (bend) will appear in the line at the horizontal 
halfway point. 

  

The available bend styles are shown next. 

 

Caption Settings 

Specify the location, text color and font used for the caption. The caption text for a connector is 
entered in the Connector Style window. 
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Note that in BlockSim, you cannot enter caption text for connectors used in phase diagrams, 
event analysis flowcharts and Markov diagrams. 

Flow Type 

When you are working with a BlockSim PFS diagram, the Diagram Style window and the Flow 
Types window also require you to specify a name (for future reference) and an abbreviation 
(used in the diagram, plots and results) for each flow type. 

Returning Connector-Level Settings to Diagram Defaults 

To use the diagram style settings again, in the Connector Style window, choose Diagram 
Default from the drop-down lists and select the Use Default check boxes. 

Non-Linear Equation Root Finder 

NON-LINEAR EQUATION ROOT FINDER 

Many engineering math problems result in a need to solve non-linear equations. Solving these 
equations can be complex, tedious and in some situations, no solution may exist at all. The 
Non-Linear Equation Root Finder is a utility that allows you to quickly solve for the root of any 
user-defined non-linear equation. This helps you eliminate some of the guesswork of solving for 
the value of the unknown variable that brings the function as close to zero as possible. 

You can access the utility by choosing Home > ReliaSoft > Quick Tools > Non-Linear Equation 
Root Finder. 

 

The following is an example of a calculation for the root of an equation. 
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To use the utility, follow the steps below: 

1. Enter the user-defined equation in the Function field. Use the variable x for the unknown 
variable. 

2. In the Root Minimum and Root Maximum fields, enter the initial guess estimates of the 
root. 

3. In the Algorithm Order field, enter the variable order which is to be improved in every 
iteration. Note that the algorithm order must be greater than or equal to 2. 

4. In the Convergence field, set a tolerance value at which the root of the equation should 
converge (i.e., f(x) = 0). 

5. In the Max Iterations field, set the maximum number of iterations the algorithm will 
perform in order to solve for the root of the equation. 

6. Click Calculate to solve for the root of the equation. You may need to edit the inputs in 
order to obtain the best possible solution for the equation. The Results area will return the 
following: 
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• Real Root returns the root of the equation. If the root is not within the initial specified 
range, you will need to edit the values in the Root Minimum and Root Maximum fields 
until the root is within range of those values. 

• Function Value shows the value of the user-defined equation at the root value. You 
may need to edit the tolerance value in the Convergence field in order to obtain a 
solution that is as close as possible to zero. 

• Iterations returns the number of iterations that were performed in order to obtain the 
solution. 
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Chapter 8: Analysis Tools 
Batch Auto Run 
The Batch Auto Run utility allows you to extract data subsets from an existing data set in a life 
data folio or a reliability growth data folio. The options depend on the folio type. 

LIFE DATA FOLIOS 

For life data folios, consider a data sheet that contains the failure times for a product 
manufactured in two different plants. By using Batch Auto Run, you can filter the data by 
manufacturing plant and then analyze the failures from each plant separately. 

Batch Auto Run Setup 

To use the tool, you must first define a subset ID for each data point you want to extract, 
making sure that the data points you wish to group together all have the same subset ID. 

Note: The subset ID can be any text up to 30 characters, including spaces. For example, "A _ _ 
X" is not the same as "A _ X" where " _ " is used to designate a space. 

Open the utility by choosing Life Data > Options > Batch Auto Run or by clicking the icon on the 
Main page of the control panel. 

 

You will be presented with a list of all the subset IDs in your data sheet, as shown in the 
following example. 
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Double-click an available subset ID to include it in the batch auto run process or drag the subset 
ID to the Selected Subset IDs column. If you have more than one subset ID column in your data 
sheet, a drop-down list will be available to allow you to choose which column to use in the 
analysis. 

You can also click the Select All Available button to automatically include all subset IDs in the 
column in the batch auto run process. Each selected subset ID will be extracted to its own 
separate data sheet at the end of the batch auto run process. 

Processing Preferences 

You can set your preferences for how the data will be processed on the Processing Preferences 
tab. When you change the settings and click OK, your preferences will be saved as the default 
settings for the next time you apply the batch auto run process for any Weibull++ life data folio. 
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• Extraction Options set how the data of the selected subset IDs will be extracted. The first 
option simply extracts the data points for each subset ID into separate data sheets so that 
you can analyze the data separately. 

The second option extracts the data sets that are required to perform a competing failure 
modes (CFM) analysis. For example, consider a device that has three competing failure 
modes A, B and C. When you extract the data points of mode A, the Batch Auto Run utility 
will retain all the data points due to mode A but mark all other data points due to modes B 
and C as suspensions. In CFM analysis, the data points of modes B and C are considered to 
be suspensions because if they did not exist, all the units will have failed at some point in 
the future due to mode A. For an example on how to use this setting, see Competing 
Failure Modes (CFM) Analysis. 

• Calculation Options allow you select whether to automatically analyze the extracted data 
sheets and create a probability plot. The parameters of the extracted data sheet will be 
calculated using the same analysis settings specified for the original data sheet. 
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• Sheet Names Options specifies where to put the extracted data. The first time you run the 
batch auto run process, the utility will extract the data points into new data sheets with the 
same names as the subset IDs. If you run the process again for the same subset IDs, you will 
have the option to either replace the data in the existing sheets or to always extract the 
data to new sheets. 

If you select the Always place data in a new sheet option, the data will be extracted to 
another new data sheet with the same name as the subset ID plus an increment to reflect 
the number of additional data sheets that have been created for the same subset ID. The 
increments can be separated by parentheses, a dash or a space. The following example 
shows the increment number separated by parentheses. 

 

RELIABILITY GROWTH DATA (RGA) FOLIOS 

For fielded data or with some of the multiple systems data types (Concurrent Operating Times, 
with Dates and with Event Codes), you can use Batch Auto Run to extract all the data that 
relates to a particular system ID. 

For multi-phase data, you can use Batch Auto Run to extract all the events (i.e., failures, time of 
implemented fixes, etc.) that occurred within a particular phase or analysis point. 

To use Batch Auto Run, choose Growth Data > Options > Batch Auto Run or click the icon on 
the Main page of the control panel. 

 

You will be presented with a list of all the available subsets in your data sheet, similar to the 
examples shown next. 
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Double-click an available subset to include it in the batch auto run process or drag the subset to 
the Selected column. You can also click the Select All Available button to automatically include 
all subsets in the process. 

If you are extracting data based on the system ID, you can choose to extract the selected 
subsets into individual data sheets by clicking the Processing Preferences tab and selecting the 
Place each system in an individual sheet check box. Otherwise, clear the option if you prefer to 
have the selected subsets appear all together in one data sheet. 

Tip: If you wish to extract the first times-to-failure of all unique BC modes or unique BD modes 
in a data set, use the Mode Processing window. 

Alter Parameters 
The Alter Parameters feature is available for life data folios, life-stress data folios and reliability 
growth data folios. It enables you to experiment with possible alternative scenarios by altering 
the estimated parameters of the fitted model. 

LIFE DATA AND LIFE-STRESS DATA FOLIOS 

For life data and life-stress data folios, after you calculate the parameters for your data set, you 
can access the tool by choosing [Life Data/Life-Stress Data] > Options > Alter Parameters and 
then selecting one of the following options: 

• Alter Parameters (w/o Recalculation) allows you to alter the value of one (or more) 
parameters, while keeping the original values of the rest of the parameters and the 
variance/covariance matrix the same. 
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• Alter One Parameter (and Recalculate) allows you to alter one of the parameter values, 
and then have the software estimate the other parameter values that would result in a 
good fit for the model. In Weibull++ life data folios, this option is available only for data sets 
that were analyzed with the MLE analysis method and either the 2P- or 3P-Weibull 
distribution. 

If you wish to modify the value of the gamma parameter of the 3P-Weibull distribution, you 
must first select the Use true 3-P MLE on Weibull check box in the Calculations page of the 
Application Setup, and then estimate all three parameters using MLE. Note that the pure 
MLE solution is not always stable, and may fail for some data sets. 

For both options, the LK values, solution line on plots and all subsequent analyses will be based 
on the modified set of parameters. To go back to the true parameters, click the Calculate icon 
on the folio's control panel. 

RELIABILITY GROWTH DATA (RGA) FOLIOS 

For reliability growth data folios, the feature is available for any data set calculated using any 
model except the Crow Extended and Crow Extended - Continuous Evaluation. Furthermore, for 
data sets calculated with the Crow-AMSAA (NHPP) model, this functionality is not available for 
Change of Slope calculations. 

This feature assumes that the likelihood function and the Fisher Matrix (evaluated at the 
original parameter estimates) remain the same. In plots, the position of the data points remain 
the same but the solution line and all subsequent analyses made via the Quick Calculation Pad 
and other tools are based on the modified parameter values. Therefore, the analysis may be 
appropriate only within the context of your specific "what-if" analysis. 

To use this feature, choose Growth Data > Options > Alter Parameters or click the icon on the 
Main page of the control panel. 

 

The Alter Parameters window appears. Type the new value for the parameter(s) you wish to 
change. The new value of the parameters will appear in the Results area of the growth data 
folio control panel with the label "User Modified Results"displaying in the analysis settings area, 
as shown in the following example. 
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Calculations with No Data Entered 
Weibull++ gives you the flexibility to generate plots and calculate metrics for reliability models 
without entering the data that the reliability model is based upon. To do this, create a life data 
folio data sheet or a growth data folio sheet and, without entering any data, choose a 
distribution and click the Calculate icon on the Main page of the control panel. 

 

With no data specified, this opens an input window that allows you to enter the parameters for 
a model. After you enter the parameters and click OK, the parameters of the specified model 
will be displayed in the Analysis Summary area of the control panel. Any plots or QCP results 
you produce from this data sheet will be based on this model. 
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Options for a life data folio 

 

Options for a reliability growth data folio 

Tip: If you don't know the model parameters, you have the option to use the Quick Parameter 
Estimator (QPE) to estimate them based on what you know about the behavior over time. 

GENERATING A DATA SET BASED ON THE SPECIFIED RELIABILITY MODEL 

For life data folios, you can generate a data set based on a specified model. To do this, click the 
Options tab in the input window and then select the Add data and calculate check box, as 
shown next. 
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With this setting enabled, Weibull++ will generate a data set that is based on the specified 
model and your desired sample size, number of failures and probability. The probability value is 
the chance that the ith failure will occur after the generated failure time Ti. For example, the 
following picture shows the generated failure times for a 2-parameter Weibull distribution 
using the following settings: 

• Beta = 1.5 

• Eta = 100 

• Sample size = 10 

• Number of failures = 6 

• Probability = 50% 
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In this case, the 1st failure time (T1) is estimated to be about 16.874 hours. This means that 
when you conduct a test on a product using the same sample size and reliability model, there is 
a 50% chance that the 1st failure will occur after 16.874 hours. Therefore, 16.874 can also be 
thought of as the one-sided lower bounds for the 1st failure time at a confidence level of 50%. 
The rest of the failure times in the data set can be read in a similar manner. 

Create Random Data 
The Create Random Data tool allows you to create randomly generated data for an analysis. 
This tool is available for life data folios, life-stress data folios, DOE design folios and reliability 
growth data folios. 

To use the tool, select the range of cells for which you would like to fill with random data, then 
right-click any of the selected cells and choose Random Data on the shortcut menu. This 
launches the Create Random Data window, which provides the following options: 
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• Columns to Fill and Rows to Fill areas, select which columns/rows in the data sheet to 
populate with random data. If you had selected a range of cells before accessing the tool, 
the fields will be populated automatically. 

• Generated Data area, choose the method for generating the random data: 

• Random data allows you to specify a range of numerical values from which the tool will 
randomly select data points. The range is specified using a starting point and a 
variability value (in decimals) that describe how far the values can vary from the 
starting point. For example, if you specified a starting point of 100 and a percent 
variability of 0.2, the data points would be randomly selected from a set of values that 
ranges from 80 to 120. 

If you clear the check boxes, the tool will use a randomly selected starting point and/or 
variability for each column of data. 

• Random values in a range allows you to specify a minimum and maximum range of 
numerical values from which the tool will randomly select data points. 

• Random points from a set of values allows you to manually define a set of values from 
which the randomly selected data points will be chosen. These can be quantitative or 
qualitative values, each separated by a comma (with or without a space). For example, 
if you are randomly entering values for a column that only accepts the values "F" and 
"S," you would enter F, S in this field. 

When you select one of the first two options in the Generated Data area, the Decimal places 
field will be enabled, which allows you to specify the number of decimal places that will be used 
for each randomly generated data point. 

Note: Generating large numbers of stress levels in Accelerated Life Testing may affect software 
performance. 

Auto Group Data 
The Auto Group Data tool is available for life data folios, life-stress data folios and for reliability 
growth data folios. 

LIFE DATA AND LIFE-STRESS DATA FOLIOS 

The Auto Group Data tool allows you to automatically group together identical data points. This 
helps to speed up calculations when you have a large data set. 
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• For life data folios, two data points are considered identical if their failure/suspension times 
AND the value/text in their Subset IDs columns are identical. 

• For life-stress data folios, two data points are considered identical if their 
failure/suspension times AND stress levels AND the value/text in their Subset IDs columns 
are identical. 

Note: The subset ID can be any text up to 30 characters, including spaces. For example, "A _ _ 
X" is not the same as "A _ X" where " _" is used to designate a space. 

To group your data, click the Auto Group Data icon on the Main page of the control panel. 

 

You can choose to group exactly identical values, or to first round the failure/suspension times 
to the nearest whole number or multiple of 10, and then group the identical data. 

 

RELIABILITY GROWTH DATA (RGA) FOLIOS 

The Auto Group Data tool is available for data types where the exact failure times have been 
recorded (i.e., Failure Times and Multi-Phase Failure Times) and for the Fleet data type. 

Times-to-Failure and Multi-Phase Data 

For the Failure Times and Multi-Phase Failure Times data types, you might use the Auto Group 
Data tool to smooth out the analysis of a data set that failed the goodness-of-fit test. Grouping 
the data can also be used to organize the failure times into specified intervals that show the 
trend in the data rather than the individual failures. 

To group data, choose Growth Data > Options > Auto Group Data or click the icon on the Main 
page of the control panel. 
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A new data sheet using the corresponding grouped data type (i.e., either Grouped Failure Times 
or Multi-Phase Grouped Failure Times) will be added to the same folio and populated with the 
grouped data. 

Fleet Data 

For the Fleet data type, the Auto Group Data tool appears automatically when you calculate the 
data sheet. In this case, the analysis stacks the failure times of each system in the data set into 
a cumulative timeline, and then converts it to grouped data based on the intervals that you 
specify. The parameters of the Crow-AMSAA (NHPP) or Crow Extended models are then 
calculated from the grouped data. 

Grouping the Data 

The following picture shows the Auto Group Data window. You can choose to specify intervals 
that are all the same width (constant) or intervals of different widths (user-defined). In both 
cases, the final interval is defined by the test termination time. The intervals must be 
representative of the data. The appropriate intervals will depend upon your knowledge and 
assumptions about the systems under test. 
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• Select Constant if you want to specify the same width for all intervals. For example, 
suppose the failure times are 10, 20 and 30 hours, and the test terminates at 40 hours. If 
you group the data by a constant width of 20 hours, the grouping will show two failures 
between 0 to 20 hours and one failure between 20 to 40 hours. 

• Select User Defined if you want to use intervals of different widths in order to group the 
data by some qualitative characteristic or other meaningful interpretation of the data. Use 
the spreadsheet below the option to specify the end time of each interval. The values in the 
spreadsheet must increase in each subsequent row, but the intervals do not have to be of 
equal length. For the same example discussed above (failure times at 10, 20 and 30 hours 
and the test terminates at 40 hours), if you specify the intervals as 5 and 10, the grouping 
will show no failures between 0 to 5 hours, one failure between 5 to 10 hours and two 
failures between 10 to 40 hours. 
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Chapter 9: Reliability Growth Analysis Folios 
RGA Growth Data Folio 

For reliability growth data analysis only. 

The Reliability Growth data folio (RGA) is the most commonly used folio for reliability growth 
analysis. Depending on the data type selected, the folio can be used for several different types 
of analysis. This chapter describes general information about growth data folios that apply to 
most analyses. 

Note: Reliability Growth data folios are available only if supported by your license. For more 
information, contact us. 

For more focused information about performing a particular type of analysis, you can go 
directly to the topic of interest, which provides information about the applicable data types and 
models, analysis assumptions, available results, application examples, etc. 

• Traditional Reliability Growth Analysis: This type of analysis is used for data from in-house 
reliability growth testing that was conducted during the developmental stages for a 
product. The analysis assumes that all fixes (i.e., permanent design improvements) are 
applied immediately after failure and before testing resumes, and that a reliability growth 
model can be fitted to the data in order to track how the reliability changes over time. The 
metrics of interest may include the reliability, MTBF, failure intensity, expected number of 
failures for a given time, and the amount of testing that will be required to demonstrate a 
specified reliability. Depending on the data type, the following statistical models can be 
used in the analysis: Crow-AMSAA (NHPP), Standard Gompertz, Modified Gompertz, Lloyd-
Lipow, Duane or Logistic. 

• Reliability Growth Projections, Planning and Management: This type of analysis focuses on 
how the reliability growth management strategy (i.e., which modes are fixed and when) 
affects the reliability growth potential of the product. Instead of assuming that all fixes are 
applied immediately after failure and before the observational period resumes, you can use 
classifications to account for different fix strategies employed for different failure modes. 

• The Crow Extended model is designed for a single test phase, and it classifies failure 
modes as A = no fix, BC = fixed at some time during the test or BD = fix delayed until 
after the end of the test. 

• The Crow Extended – Continuous Evaluation model can be used for single or multiple 
test phases, and it classifies failure modes as A = no fix, BC = fixed immediately before 

https://www.reliasoft.com/about/contact-us
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testing resumes or BD = fixed at some point after testing resumes (i.e., later in the 
same test phase, between test phases, in a subsequent test phase or after all test 
phases). 

• The growth planning folio and multi-phase plot can be used to develop an effective 
reliability growth test plan, and visualize the test results across multiple phases. 

• Repairable Systems Analysis: This type of analysis is used for data from repairable systems 
operating in the field under typical customer usage conditions. Such data might be 
obtained from a warranty system, repair depot, operational testing, etc. You can use the 
power law or Crow-AMSAA (NHPP) models for repairable system analysis based on the 
assumption of minimal repair (i.e., the system is "as bad as old" after each repair) to 
calculate metrics such as the expected number of failures, rate of wearout or the optimum 
time to replace or overhaul a system to minimize life cycle costs. 

CREATING A GROWTH DATA FOLIO 

For reliability growth data analysis only. 

To add a growth data folio to a project, choose Home > Insert > Growth Data or right-click the 
Growth Data folder in the current project explorer and choose Add Growth Data. 

 

A setup window will prompt you to select a data type to use with the folio. The data type you 
select determines the data entry columns that appear in the data sheet and the type of analysis 
you can perform (see Reliability Growth Data Types). Click Next to go to the next step to 
configure your data sheet; otherwise, click OK to immediately create the folio. 

Data Sheet Configuration Options 

The configuration options that are available in the setup window will depend on your chosen 
data type: 

• The Units drop-down list is available for all data types except the discrete and Multi-Phase 
Mixed data types. Use this list to select the units appropriate for your data. Units may be 
measured in mileage, distance, weight, etc. The appropriate columns in the data sheet will 
be automatically configured for the units you select. If you later wish to change the units of 
an existing data sheet, click the Change Units icon on the Main page of the control panel of 
the data sheet. 
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This opens the Change Units window, which gives you several options for converting the 
units of the existing data. Authorized users can define the units that will be available for use 
in any project within the database and set up the conversion factors. 

• The Use advanced systems view check box is available for fielded/developmental multiple 
systems data types. (See Normal and Advanced Systems View.) 

• The Number of systems field is available for fielded/developmental multiple systems data 
types. If you are working with the Multiple Systems - Known Operating Times data type, 
this field allows you to specify the number of "Time System" columns that will appear in the 
new data sheet. For all other multiple systems data types, this field allows you to specify 
the number of systems that will appear in the navigation panel of the Advanced Systems 
View (see Normal and Advanced Systems View ). 

• The Number of comment columns field is available for all data types. Use this field to 
specify the number of "Comments" columns that will appear in the new data sheet. The 
information in those columns will not affect the calculations in the folio. 

Data Types 

Reliability Growth Data Types 

For reliability growth data analysis only. 

There are many different ways that data for reliability growth analysis (RGA) may be collected. 
The type of data you collect determines which types of analyses you can perform and which 
statistical models you can use. This chapter describes all of the different types of data 
supported by the software. For more focused information about performing a particular type of 
analysis, you can go directly to the topic of interest. (See Traditional Reliability Growth Analysis; 
Reliability Growth Projections, Planning and Management (Crow Extended Model); or 
Repairable Systems Analysis.) 

There are two general types of data that can be analyzed with the software: developmental and 
fielded data. Developmental data are obtained from reliability growth testing conducted in-
house, during the stages of development for a particular product. Fielded data, on the other 
hand, are obtained from repairable systems operating in the field under typical customer usage 
conditions. To provide a reference of all your options, the following table shows the three 
different (but related) types of analysis you can perform in Weibull++, the statistical models 
that are available for each, and the data types that can be used. 
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Times-to-Failure Data 

For reliability growth data analysis only. 

The times-to-failure data types are used for analyzing failure times recorded from in-house 
reliability growth testing. Different data sheets are available depending on how the testing was 
conducted and what information is available: 

• If you will be analyzing failure times from a single system (or the combined times from 
multiple systems), there is a choice of two data sheets depending on whether you will enter 
exact failure times or grouped (interval) data: 

• Failure Times 

• Grouped Failure Times 

• If you will be analyzing failure times from multiple identical systems (where the data from 
each system is identified by the specific System ID), there is a choice of four data sheets 
depending on how the operating times of the systems are determined. (See Times-to-
Failure Data from Multiple Systems for more information about these data sheets.) 

• Multiple Systems - Known Operating Times 

• Multiple Systems - Concurrent Operating Times 
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• Multiple Systems with Dates 

• Multiple Systems with Event Codes 

If you will assume that all fixes are applied immediately after failure and before testing resumes 
(traditional reliability growth analysis), then you can use the Crow-AMSAA (NHPP) or Duane 
models. If you want to account for different fix strategies used for different failure modes 
(growth projections analysis), choose the Crow Extended model. 

When you select the Crow Extended model, the Classification and Mode columns will be 
inserted into the data sheet. You can also manually insert or remove these columns by choosing 
Growth Data > Format and View > [Insert Columns/Delete Columns] > Projections. The Crow 
Extended model and mode classifications are discussed in Failure Mode Classifications. 

By default, all data sheets include a Comments column for logging any pertinent information 
about each row of data. You can add a second comments column or delete the columns by 
choosing Growth Data > Format and View > [Insert Columns/Delete Columns] > Comments. 
The information in these columns does not affect the calculations in the folio. 

See also Minimum Data Requirements for Times-to-Failure Data. 

Failure Times 

The Failure Times data type is used for situations where the exact failure times have been 
recorded. This data type can be used to analyze the data from a single system or for the 
combined times from multiple systems. For example, if three identical systems are tested and 
one fails at 10 hours, the recorded failure time is 30 hours. 

The failure times are recorded in the Time to Event column in the data sheet. The times can be 
cumulative (where each row shows the total amount of test time when the failure occurred) or 
non-cumulative (where each row shows the incremental test time from when the last failure 
occurred). (See Cumulative vs. Non-Cumulative Data.) 

The following example shows a data set in which the times are cumulative. The first failure (row 
1) occurred at 10 hours. The second failure (row 2) occurred 5 hours later at 15 hours of total 
test time. The rest of the data can be read in a similar manner. 
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Failure Times Data Sheet for Traditional Reliability Growth Analysis (Cumulative) 

The next example shows the same data set, but where the times are non-cumulative. 

 
Failure Times Data Sheet for Traditional Reliability Growth Analysis (Non-Cumulative) 

When you use the Crow-AMSAA (NHPP) or Duane model, the assumption is that fixes are 
applied when failures are found; therefore, each row in the data sheet will represent a different 
design configuration. Alternatively, when you use the Crow Extended model, you assume that 
different fix strategies are used for different failure modes (i.e., A = no fix, BC = fixed during test 
or BD = delayed fix). You will be required to identify and classify the failure mode responsible 
for each failure, as well as specify the effectiveness factor for each delayed fix (see Failure 
Mode Classifications). 

Tip: If your data set failed the goodness-of-fit test, you can smooth out the analysis by 
organizing the data into groups and transferring them into a Grouped Failure Times data sheet. 
To do this, choose Growth Data > Options > Auto Group Data. For more information on how to 
use the tool, see Auto Group Data. 

Grouped Failure Times 

The Grouped Failure Times data type is used for cases where the failures occurred within 
specified time intervals, but the exact times are not known (i.e., interval data). This data type 
can be used to analyze the data from a single system or for the combined times from multiple 
systems (e.g., if three identical systems are tested and one fails between 10 and 20 hours, the 
recorded interval is 30 to 60 hours). 
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This data sheet can also be used for situations when the exact failure times are available, but it 
is useful to group the data into intervals for analysis purposes. For example, you could use this 
data sheet to smooth out the analysis of a Failure Times data set that failed the goodness-of-fit 
test. (See Auto Group Data.) 

The Interval End Time column is for recording the times that an interval ended. The times are 
cumulative (where each row shows the total amount of test time accumulated by the end of 
each interval). The Failures in Interval column is for recording the number of failures that 
occurred in each interval. The failure numbers are non-cumulative (where each row shows the 
number of failures that occurred in that interval only). (See Cumulative vs. Non-Cumulative 
Data.) 

When you use the Crow-AMSAA (NHPP) or Duane model, the assumption is that fixes are 
applied at the end of each interval; therefore, each row in the data sheet will represent a 
different design configuration. The following example shows a data set where five identical 
systems are inspected every week. The systems accumulate a total of 250 hours of test time 
each week. In the first week (row 1), the total number of system failures that occurred in that 
week is 3. In the second week (row 2), the total number of system failures that occurred in that 
week is 8. The rest of the data sheet can be read in a similar manner. 

 
Grouped Failure Times Data Sheet for Traditional Reliability Growth Analysis 

When you use the Crow Extended model, you assume that different fix strategies are used for 
different failure modes (i.e., A = no fix, BC = fixed during test or BD = delayed fix). You will be 
required to identify and classify the failure mode responsible for each failure, as well as specify 
the effectiveness factor for each delayed fix, if any (see Failure Mode Classifications). 

For example, the following data set shows that in the first week (rows 1 to 2), the total number 
of system failures that occurred in that week is 3. Two of these failures are identified as BC100 
(row 1) and one failure is identified as BD1 (row 2). In the second week (rows 3 to 8), the total 
number of system failures that occurred in that week is 8, and the failures are identified as BD1, 
BC150, BC4, BC60 (with 3 occurrences), BD23, BC3 and A75. 
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Grouped Failure Times Data Sheet with the Crow Extended Model. 

Times-to-Failure Data from Multiple Systems 

For reliability growth data analysis only. 

The multiple systems data types are for analyzing failure times from multiple identical systems 
(where the data set from each system is identified by the specific System ID). In multiple 
systems analysis, Weibull++ combines the operating hours of the systems to create a single 
equivalent system, which allows you to evaluate all the failures and fixes that occurred during 
testing. The parameters of the equivalent system, along with the results of the goodness-of-fit 
tests for that system, are calculated automatically when you analyze the data sheet. Any plots 
generated for the data set and analyses via the Quick Calculation Pad will be also based on the 
equivalent system. 

There is a choice of four data sheets depending on how the operating times of the systems are 
determined: 

• Multiple Systems - Known Operating Times 

• Multiple Systems - Concurrent Operating Times 

• Multiple Systems with Dates 

• Multiple Systems with Event Codes 

In all these data sheets, the operating time of the failed system is recorded for each failure. The 
following table summarizes how these data sheets obtain or estimate the operating times of 
the other non-failed systems. 
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Data Type Operating Times of Non-Failed Systems All systems 
must 

operate at 
same rate? 

All systems 
must start 
the test at 
the same 

time? 

Known Operating 
Times 

User provides the exact operating times 
for both failed system and all other non-
failed systems. 

No 

Concurrent 
Operating Times 

Weibull++ uses the failure time of the 
failed system as the operating times of 
the non-failed systems. 

Yes 

Multiple Systems 
with Dates 

Weibull++ uses calendar dates to 
estimate the operating times of non-
failed systems based on their average 
daily usage rate for the relevant time 
period. 

No 

Multiple Systems 
with Event Codes 

Same as "Concurrent Operating Times." Yes 

If you will assume that when failures are found the same set of fixes is applied to all of the 
systems at the same time (traditional reliability growth analysis), then you can use the Crow-
AMSAA (NHPP) or Duane models. Once the fix has been implemented for all systems, the test 
is resumed; therefore, each row in the data sheet will represent a different design 
configuration. 

If you want to account for different fix strategies used for different failure modes (growth 
projections analysis), choose the Crow Extended model. You will be required to identify and 
classify the failure mode responsible for each failure (i.e., A = no fix, BC = fixed during test or BD 
= delayed fix), as well as specify the effectiveness factor for each delayed fix. 

When you select the Crow Extended model, the Classification and Mode columns will be 
inserted into the data sheet. You can also manually insert or remove these columns by choosing 
Growth Data > Format and View > [Insert Columns/Delete Columns] > Projections. The Crow 
Extended model and mode classifications are discussed in Failure Mode Classifications. 

By default, all data sheets include a Comments column for logging any pertinent information 
about each row of data. You can add a second comments column or delete the columns by 
choosing Growth Data > Format and View > [Insert Columns/Delete Columns] > Comments. 
The information in these columns does not affect the calculations in the folio. 

See also Minimum Data Requirements for Times-to-Failure Data. 
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Multiple Systems - Known Operating Times 

The Known Operating Times data type is used for situations when multiple identical systems are 
tested and the exact operating times for all systems are known. When a failure occurs in any of 
the systems, the exact operating times for all systems (both failed and non-failed) are recorded. 
The analysis assumes that the fixes are applied to all of the systems at the same time so they 
continue to have the same configuration. 

The Time System [x] columns are for recording the failure times/operating times of the units. 
The times can be cumulative (where each row shows the total amount of time when the failure 
occurred) or non-cumulative (where each row shows the incremental time from when the last 
failure occurred). (See Cumulative vs. Non-Cumulative Data.) By default, the data sheet is 
configured for two systems. To insert or remove additional columns, choose Growth Data > 
Format and View > [Insert Columns/Delete Columns] > System/Unit. 

The Failed System ID column is for recording the ID number of the system that failed. It must 
be represented by a positive integer. 

The following data sheet shows an example in which the times are cumulative. The first failure 
occurred for System 1 (indicated by a 1 in the first column for row 1). At that point, the 
operating times for both systems were recorded — 7 hours for System 1 and 10 hours for 
System 2 — and the same fix was applied on both systems. The next failure occurred for System 
2 (indicated by a 2 in the first column for row 2). Once again, the operating times for both 
systems were recorded — 15 hours for System 1 (8 since the last event) and 17 hours for 
System 2 (7 since the last event). The rest of the data can be interpreted in a similar manner. 

 
Multiple Systems - Known Operating Times Data Sheet for 

Traditional Reliability Growth Analysis (Cumulative) 

The next example shows the same data set, but the times are non-cumulative. 
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Multiple Systems - Known Operating Times Data Sheet for 
Traditional Reliability Growth Analysis (Non-Cumulative) 

Multiple Systems - Concurrent Operating Times 

The Concurrent Operating Times data type is used for situations when multiple identical 
systems are tested but a system’s exact operating time can be known only when it fails. The 
analysis assumes that the systems all began with the same configuration, they operate 
concurrently, they accumulate usage at the same rate and they receive fixes at the same time. 
Therefore, when a failure occurs in any of the systems, the exact operating time for the failed 
system is recorded and this time is also used as the operating times for the other non-failed 
systems. 

With this data type, you can enter the data in the Normal View or Advanced Systems View. The 
following example shows the Normal View. The System ID column is for recording the ID of the 
system that the data point relates to. The Event column specifies whether the row represents 
the start time (S), failure time (F) or end time (E) of the system. The Time to Event column is for 
recording the total cumulative test time when the specified event occurred. 

 
Multiple Systems - Concurrent Operating Times Data Sheet (Normal View) 

for Traditional Reliability Growth Analysis 

The following plot shows the failure times of both systems in the example, along with the 
timeline for their equivalent system. When the first failure occurred at 21 hours (System A), the 
total operating time for the test (represented by the equivalent system) is 42 hours because 
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there are two systems running concurrently. In other words, the analysis multiplies the failure 
time of the failed system by the total number of systems in the test to obtain the equivalent 
operating time. Similarly, the first failure of System B (at 83 hours) is shown in the equivalent 
system as occurring at 166 hours. 

 

Multiple Systems with Dates 

Like the Concurrent Operating Times data type, the Multiple Systems with Dates data type is 
used for situations when multiple identical systems are tested but a system’s exact operating 
time can be known only when it fails. However, this data type can be used when the systems 
did not all begin with the same configuration and/or they are not operated concurrently 
(although it still assumes that the fixes are applied to all of the systems at the same time). 
When a failure occurs in any of the systems, the exact operating time for the failed system is 
recorded and the software estimates the operating times for the other non-failed systems using 
the exact calendar dates recorded for all events. Specifically, the software uses the dates to 
calculate the average daily usage rate of each non-failed system over the relevant time period. 
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The data sheet is the same as the Concurrent Operating Times data sheet but with a Date 
column for recording the calendar date of the events. You can enter the data in the Normal 
View or Advanced Systems View. The following example shows a data set in the Normal View. 

 
Multiple Systems with Dates Data Sheet (Normal View) 

for Traditional Reliability Growth Analysis 

The following plot shows the failure times of both systems in the example, along with the 
timeline for their equivalent system. For example, the plot shows that when System A failed on 
1/18/2019, it had accumulated 66 hours of operating time, but we don’t know the exact 
operating time for System B at that point. 

We do know that when System B failed on 1/15/2019 it had accumulated 169 hours of test time 
and then when it failed again on 2/1/2019, it had accumulated 213 hours. The total 
accumulated test time of System B between these two periods is 213-169=44 hours. 

If we divide this result by the number of days (17), we obtain the average daily usage rate of 
System B during that period (2.588235 hours/day). 

This can then be used to estimate the number of hours System B accumulated in the 2 days 
between the first failure of System B on 1/15/2019 and the first failure of System A on 
1/18/2019 (2 x 2.5882 = 5.176470 hours). 

Therefore, the analysis assumes that the operating time of System B was 174.176470 hours 
when System A failed on 1/18/2019. 

For the equivalent system, the estimated operating time on 1/18/2019 is the summation of the 
observed operating time for System A and the estimated operating time for System B, which is 
240.176470 hours. 
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Multiple Systems with Event Codes 

The Multiple Systems with Event Codes data type is similar to the Concurrent Operating Times 
data type except that it always requires you to identify and classify the failure mode responsible 
for each failure (see Failure Mode Classifications). It also allows you to use codes to identify 
other types of events besides failures (e.g., the time when a fix was implemented for a 
particular failure mode, performance or quality issues that can be included or excluded from 
the analysis, etc.). This data type can be used when fixes are not implemented simultaneously 
for all systems. The Crow Extended model is used for the analysis. 

With this data type, you can enter the data in the Normal View or Advanced Systems View. The 
following example shows the Normal View. The Classification and Mode columns are for 
identifying and classifying the failure mode responsible for each failure. The Event column 
specifies the type of event the data point represents. See Event Codes for Crow Extended for 
information on all five possible event types. In the following data sheet, S = start time, F = 
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failure time, I = the time when the fix for a particular failure mode was implemented, P = 
performance failure, Q = quality failure and E = end time. 

 
Multiple Systems with Event Codes Data Sheet (Normal View) 

for Reliability Growth Projections Analysis 

In this case, the process of combining the data set for the equivalent system is the same as 
described above for the Concurrent Operating Times data sheet, but with the addition of taking 
into account the time of implemented fixes across different systems. The implemented fix time 
is obtained by computing for the total time that the system spent in the same design 
configuration for a particular mode before the implemented fix took place. For these plots, the 
different types of events are shown in different colors: failure (red circle), implemented fix 
(yellow triangle), performance failure (blue circle) and quality failure (green diamond). 
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The ReliaWiki resource portal provides an example that demonstrates how the software builds 
the equivalent system for this data type at 
http://www.reliawiki.org/index.php/Equivalent_System_Example. 

Discrete Data 

For reliability growth data analysis only. 

Discrete data are obtained from one-shot devices with only two possible outcomes from the 
test: success or failure. An example is a missile that gets fired once and it either succeeds or 
fails. This type of data is also referred to as success/failure or attribute data. Different data 
sheets are available depending on how the testing was conducted and what information is 
available. This also determines what kind of analysis can be performed. 

With the first three discrete data types, you can use the Crow-AMSAA (NHPP), Standard 
Gompertz, Modified Gompertz, Lloyd-Lipow, Duane or Logistic models to track how the 
reliability of the system changes over time (traditional reliability growth analysis): 

http://www.reliawiki.org/index.php/Equivalent_System_Example
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• Sequential 

• Sequential with Mode 

• Grouped per Configuration 

The fourth discrete data type can be used for either traditional reliability growth analysis or 
projections (growth projections analysis): 

• Mixed Data 

For the Mixed data type, if you will assume that all fixes are applied immediately after failure 
and before testing resumes (traditional reliability growth analysis), you can use the Crow-
AMSAA (NHPP) model. If you want to account for different fix strategies used for different 
failure modes (growth projections analysis), choose the Crow Extended model. 

When you select the Crow Extended model, the Classification and Mode columns will be 
inserted into the data sheet. You can also manually insert or remove these columns by choosing 
Growth Data > Format and View > [Insert Columns/Delete Columns] > Projections. The Crow 
Extended model and mode classifications are discussed in Failure Mode Classifications. 

By default, all data sheets include a Comments column for logging any pertinent information 
about each row of data. You can add a second comments column or delete the columns by 
choosing Growth Data > Format and View > [Insert Columns/Delete Columns] > Comments. 
The information in these columns does not affect the calculations in the folio. 

See also Minimum Data Requirements Discrete Data. 

Sequential 

The Sequential data type is used for one-shot devices where a single trial is performed for each 
system configuration and improvements are made before the next trial. Only the outcome 
(success/failure) is recorded for each trial. 

The device is inspected after each trial, and then fixes are applied before the next trial begins; 
therefore, each row number in the data sheet represents a particular design configuration. In 
the following example, the device succeeded (S) for the first configuration (row 1), but failed (F) 
for the second configuration (row 2). The rest of the data can be read in a similar manner. 



Chapter 9: Reliability Growth Analysis Folios 

552 https://www.reliasoft.com/weibull 

 

 

Sequential with Mode 

The Sequential with Mode data type is used for one-shot devices where a single trial is 
performed for each system configuration and improvements are made before the next trial 
occurs. In addition to the outcome (success/failure) for each trial, the specific failure modes are 
also recorded. 

The data sheet is the same as the Sequential data sheet, but with the addition of a Failure 
Mode column for recording the mode responsible for each failure. This allows you to track the 
possible recurrence of a failure mode after the fixes have been applied. If the mode does not 
appear again in the later trials, then the probability of failure is reduced. This is known as failure 
discounting.  If you do not enter any failure modes, then no failures are discounted in the 
analysis (and the results will be the same as in the Sequential data type if you use the same 
growth model). The following figure shows an example of the data sheet. 

 

Grouped per Configuration 

The Grouped per Configuration data type is used for one-shot devices where multiple trials are 
performed for each design configuration (e.g., testing 5 missiles of the same design equals 5 
trials). Improvements are made after all the devices within the group have been tested. 
Therefore, each row in the data sheet represents a particular design configuration. For each 
stage of testing, both the number of trials and the number of failures are recorded (e.g., 3 
failures out of 10 trials for configuration A, 2 failures out of 10 trials for configuration B, etc.). 

The Number of Trials column is for recording the number of devices that were tested for each 
design configuration. The Number of Failures column is for recording the number of failed units 
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in the specified configuration. The values in these columns can be cumulative (where each row 
shows the total number of trials and failures since the beginning of the test) or non-cumulative 
(where each row shows the incremental number of trials and failures from the last 
configuration). (See Cumulative vs. Non-Cumulative Data.) 

The following example shows a data set where the values are cumulative. In the first 
configuration (row 1), there were 5 failures out of 10 trials. In the second configuration (row 2), 
there were 3 more failures (for a total of 8) out of 8 more trials (for a total of 18). The rest of 
the data can be read in a similar manner. 

 
Grouped per Configuration Data Sheet (Cumulative) 

The next example shows the same data set, but the values are non-cumulative. 

 
Grouped per Configuration Data Sheet (Non-Cumulative) 

Mixed Data 

The Mixed data type is used for one-shot devices where some test stages (i.e., design 
configurations) may have only one trial while other stages may have multiple trials. For each 
stage of testing, both the number of trials and the number of failures are recorded (e.g., 1 
failure out of 1 trial for configuration A, 2 failures out of 5 trials for configuration B, etc.). This 
data type may be used in cases when you have a different number of samples available from 
each design configuration. For example, you might test one device initially then later start 
testing more samples of each design. 
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The Failures in Interval column is for recording the number of failures in a stage. The 
Cumulative Trials column is for recording the total number of trials that were performed since 
the beginning of the test. 

When you use the Crow-AMSAA (NHPP) model for this data type, the assumption is that fixes 
are applied at the end of each interval; therefore, each row in the data sheet will represent a 
different design configuration, where each configuration can have any number of trials. For 
example, the following data set shows that in the first stage (row 1), 4 units were tested and 3 
failed. In the second stage (row 2), 1 more unit was tested (for a total of 5) and it did not fail. In 
the third stage (row 3), 4 more units were tested (for a total of 9) and all 4 failed. The rest of 
the data can be read in a similar manner. 

 
Mixed Data Sheet with the Crow-AMSAA (NHPP) Model 

When you use the Crow Extended model, you assume that some of the fixes may be delayed 
until the end of the test and that some of the failure modes may not be fixed (i.e., A = no fix or 
BD = delayed fix). This is useful for situations when you need to perform the test in stages due 
to logistic reasons (e.g., cannot launch 10 missiles at the same time), or the purpose of the test 
is only to uncover failure modes. You will be required to identify and classify the failure mode 
responsible for each failure, and specify the effectiveness factor for each delayed fix, if any (see 
Failure Mode Classifications). 

For example, the following data set shows that in the first stage (rows 1 to 3), 4 units were 
tested and 3 failed. The failures are identified as BD125 (row 1), A10 (row 2) and BC230 (row 3). 
In the second stage (row 4), 1 more unit was tested (for a total of 5) and it did not fail. The rest 
of the data can be read in a similar manner. 

 
Mixed Data Sheet with the Crow-Extended Model 
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 Tip: If you will assume that some fixes are implemented at the end of an interval while some 
are implemented at the end of the observed test time, then the Multi-Phase Mixed data type 
may be more appropriate. 

Multi-Phase Data 

For reliability growth data analysis only. 

Multi-phase data types are designed for practical testing situations where failures can be 
corrected at the time of failure, delayed until a later time during the current phase, fixed during 
another phase or fixed at the end of a phase. This data type implements the Crow Extended - 
Continuous Evaluation model. 

When used in conjunction with the growth planning folio, these data sheets allow you to 
compare the reliability performance of the system at each phase against the goals that were 
developed in the reliability growth plan. 

Different data sheets are available depending on how the testing was conducted and what 
information is available: 

• Multi-Phase Failure Times 

• Multi-Phase Grouped Failure Times 

• Multi-Phase Mixed Data 

By default, all data sheets include a Comments column for logging any pertinent information 
about each row of data. You can add a second comments column or delete the columns by 
choosing Growth Data > Format and View > [Insert Columns/Delete Columns] > Comments. 
The information in these columns does not affect the calculations in the folio. 

See also Minimum Data Requirements for Multi-Phase Data. 

Multi-Phase Failure Times 

The Multi-Phase Failure Times data type is used for multi-phase data analysis with the Crow 
Extended - Continuous Evaluation model when the exact time is recorded for each event. It is 
the same as the Failure Times data type, but with the addition of the Event, Classification and 
Mode columns for recording the information required to use the continuous evaluation model. 

The following example shows the failure times of a single system, entered cumulatively. The 
Event column specifies the type of event the data point represents. See Event Codes for Multi-
Phase Data for information on all seven possible event types. In the following data sheet, F = 
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failure time, AP = analysis point (i.e., a designated time at which calculations will be performed 
and results obtained), and I = the time when the fix for a particular failure mode was 
implemented. The Classification and Mode columns are for identifying and classifying the 
failure mode that is responsible for the failure (for F, P or Q events) or the mode that received a 
fix (for I events). 

 

Multi-Phase Grouped Failure Times 

The Multi-Phase Grouped Failure Times data type is used for multi-phase data analysis with the 
Crow Extended - Continuous Evaluation model when the time of each event falls somewhere 
within a specified interval. It is the same as the Grouped Failure Times data type, but with the 
addition of the Event, Classification and Mode columns for recording the information required 
to use the continuous evaluation model. 

The following example shows the total test time at the end of each interval and the number of 
failures that occurred in each interval. The Event column specifies the type of event the data 
point represents. See Event Codes for Multi-Phase Data for information on all seven possible 
event types. In the following data sheet, F = failure time, Q = quality-related issue and P = 
performance-related issue. The Classification and Mode columns are for identifying and 
classifying the failure mode that is responsible for the failure (for F, P or Q events) or the mode 
that received a fix (for I events). 

 

Multi-Phase Mixed Data 

The Multi-Phase Mixed data type is used for multi-phase data analysis with the Crow Extended - 
Continuous Evaluation model for one-shot devices, and where some test stages (i.e., design 
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configurations) may have only one trial and other stages may have multiple trials. For each 
stage of testing, both the number of trials and the number of failures are recorded (e.g., 1 
failure out of 1 trial for configuration A, 2 failures out of 5 trials for configuration B, etc.). This 
data sheet is the same as Discrete Mixed data type, but with the addition of the Event, 
Classification and Mode columns for recording the information required to use the continuous 
evaluation model. 

The following example shows the number of trials and failures in each test interval. The Event 
column specifies the type of event the data point represents. See Event Codes for Multi-Phase 
Data for information on all seven possible event types. In the following data sheet, F = failure 
time and PH = end of phase. The Classification and Mode columns are for identifying and 
classifying the failure mode that is responsible for the failure (for F, P or Q events) or the mode 
that received a fix (for I events). 

 

Reliability Data 

For reliability growth data analysis only. 

The Reliability data type is used for modeling the relationship between time and reliability. You 
can use the Standard Gompertz, Modified Gompertz, Lloyd-Lipow or Logistic models to track 
how the reliability changes over time. 

The Reliability column is for recording the reliability values. The reliability can be computed by 
dividing the number of systems still operating by the total number of systems, or by performing 
life data analysis (e.g., Weibull analysis) or other related methods. The Time/Stage column is 
for recording the cumulative test "time" when the reliability was computed. This can be 
measured in terms of test stages, design configurations, development time, and the like. 

In this data sheet, reliability values are entered as decimals; however, you can configure the 
data sheet to accept percent values. You can change the setting by selecting or clearing the Use 
percents (not decimals) for reliability check box on the RGA Growth Data Folios page of the 
Application Setup. 

In the following example, the "Numerical" label on the control panel indicates that the 
reliability values are decimal values. 
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The next example shows the "Percentage" label on the control panel and the same data set as 
above, but entered as percent values. 

 

By default, all data sheets include a Comments column for logging any pertinent information 
about each row of data. You can add a second comments column or delete the columns by 
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choosing Growth Data > Format and View > [Insert Columns/Delete Columns] > Comments. 
The information in these columns does not affect the calculations in the folio. 

See also Minimum Data Requirements for Reliability Data. 

Fielded Data 

For reliability growth data analysis only. 

The fielded data types are used for analyzing data from repairable systems operating in the 
field under typical customer usage conditions. Such data might be obtained from a warranty 
system, repair depot, operational testing, etc. 

Although fielded systems analysis applies some of the same statistical models that are used to 
analyze data from developmental testing, it should be noted that there is a difference in the 
underlying analysis assumptions. For developmental testing data, the analysis assumes that 
permanent fixes are being applied to improve the inherent reliability of the design; whereas for 
fielded system data the analysis assumes that systems may fail and be repaired many times, 
and that each system will always be "as bad as old" after a repair (i.e., the concept of minimal 
repair). The fielded systems analysis assumes that permanent design improvements, if any, are 
delayed until a later time. 

Tip: If you assume that each repair partially renews the system (i.e., "better than old but worse 
than new") or restores the system to "as good as new," then the General Renewal Process 
(GRP) may be a more appropriate model. This model is available using a Parametric RDA folio. 

There is a choice of two data sheets for analyzing data from fielded systems. In general: 

• Use the Repairable data type for analyzing the individual failure times for multiple 
repairable systems operating in the field. The analysis models the number of individual 
system failures vs. system time. 

• Use the Fleet data type for analyzing the failure times for multiple repairable systems from 
a fleet (rather than individual system) perspective. The analysis groups the data and models 
the number of fleet failures vs. fleet time. 

These data sheets can be used for two kinds of analysis. In general: 

• If you wish to perform repairable systems analysis based on the assumption of minimal 
repair (i.e., the system is "as bad as old" after each repair), use the Power Law model in a 
Repairable data sheet. If the power law model does not provide a good fit, you can transfer 
the data to a Fleet data sheet and use the Crow-AMSAA (NHPP) instead. 
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• If you wish to estimate the jump in reliability that can be expected from rolling out the 
same set of permanent design fixes to all systems in the field, use the Crow Extended 
model. 

• In a Repairable data sheet, the Crow Extended analysis method is intended to be used 
specifically for "Operational Testing" situations when there is careful control of the test 
conditions and the failure intensity observed in the field is constant (i.e., beta = 1). Only 
two of the three failure mode classifications are applicable for such scenarios (A = no fix 
or BD = delayed fix). 

• In a Fleet data sheet, the Crow Extended analysis method does not require the 
assumption that the failure intensity observed in the field is constant (i.e., beta does 
not have to equal 1). All three of the failure mode classifications are available (A = no 
fix, BC = fixed during test and BD = delayed fix). 

Note: Weibull++ displays a warning in the growth data folio when the beta = 1 hypothesis is 
invalid (i.e., when the 90% two-sided confidence bounds on beta do not include 1). You can 
choose whether to display this warning by using the Beta = 1 hypothesis is Invalid option 
on the RGA Growth Data Folios page of the Application Setup.] 

When you select the Crow Extended model, the Classification and Mode columns will be 
inserted into the data sheet. (See Failure Mode Classifications.) When this model is applied 
to a Repairable data sheet, the analysis assumes that all permanent design fixes are 
delayed until a later time and therefore only two of the three failure mode classifications 
are available: A = no fix and BD = delayed fix. 

By default, all data sheets include a Comments column for logging any pertinent information 
about each row of data. You can add a second comments column or delete the columns by 
choosing Growth Data > Format and View > [Insert Columns/Delete Columns] > Comments. 
The information in these columns does not affect the calculations in the folio. 

(See Minimum Data Requirements for Fielded Data.) 

Repairable Systems 

The Repairable data type is used for analyzing the individual failure times for multiple 
repairable systems operating in the field. It models the number of individual system failures vs. 
the system time. 

You can enter the data in the Normal View or Advanced Systems View. The following example 
shows the Normal View. The System ID column is for recording the ID of the system. The Event 
column specifies whether the row represents the start time (S), failure time (F) or end time (E) 
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of the system. The Time to Event column is for recording the total operating time when the 
specified event occurred. 

 
Repairable Systems Data Sheet (Normal View) for Fielded Systems Analysis 

In repairable systems analysis, Weibull++ places the failure times of the systems on a single 
timeline to create a superposition system, which shows the order in which all the failures in the 
data set occurred. For example, the following plot shows the failure times of both systems in 
the example, along with the timeline for their superposition system. The timeline shows that 
the first failure occurred at 1.2 hours (System A) and that the second failure occurred at 10 
hours (System B). The termination time in the superposition system is equal to the age of the 
oldest system. 

The parameters of the superposition system, along with the results of the goodness-of-fit tests 
for that system, are calculated automatically when you analyze the data sheet. Any plots and 
QCP results will be also based on the superposition system. 
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Fleet 

The Fleet data type is used for analyzing the failure times for multiple repairable systems from a 
fleet (rather than individual system) perspective. It groups the data and models the number of 
fleet failures vs. the total operating times of all systems in the fleet. 

Data entry in the Fleet data sheet is the same as described above for the Repairable Systems 
data sheet. However, in fleet data analysis, the failure times of each system are stacked into a 
cumulative timeline. This allows Weibull++ to model the failures in the population over the 
cumulative fleet operating time. The termination time in the cumulative timeline is equal to the 
sum of the ages of all the systems in the analysis. For example, the following plot shows that 
System A operated for a total of 1,268 hours. The first failure of System B (at 682 hours) is 
added to System A's end time to obtain a failure time of 1,950 hours for the cumulative 
timeline. 
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As the example demonstrates, the data sets of all the systems are stacked one after another 
based on the order in which the systems were entered into the data sheet; if we had entered 
the data set of System B first, then the first failure time of System A would have been added to 
the end time of System B. The ReliaWiki resource portal has more information about how the 
order of the systems may affect the fleet analysis at 
http://www.reliawiki.org/index.php/Fleet_Data_Analysis. 

Tip: For any given observation period, the Fleet data sheet requires a complete record of the 
failure times of all the systems in the fleet. If your data set is limited to a record of the total 
amount of operating time for the fleet per observation interval (where the intervals may be 
measured in weeks, months, etc.) and the total number of system failures in those intervals, 
then you can use the Grouped Failure Times data type instead. 

http://www.reliawiki.org/index.php/Fleet_Data_Analysis
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Cumulative vs. Non-Cumulative Data 

For reliability growth data analysis only. 

In Weibull++, some data sheets may be configured to have the data input as cumulative or non-
cumulative.  The following data sheets have this option: 

• Times-to-failure data: 

• Failure Times 

• Multiple Systems - Known Operating Times 

• Discrete data: 

• Grouped per Configuration 

• Multi-phase data: 

• Failure Times 

If the data sheet is configured for cumulative data entry, each failure time represents the total 
amount of operating time until the failure. If the data sheet is configured for non-cumulative 
data entry, each failure time represents the incremental amount of operating time since the 
last failure. 

For example, suppose a system fails at 10 hours and then fails again 10 hours later (at 20 hours 
of test total time) and then fails again 10 hours later (at 30 hours of total test time). If the data 
sheet is configured for cumulative data entry, the times are 10, 20 and 30. If the data sheet is 
configured for non-cumulative data entry, the times are 10, 10 and 10, as shown next. 

  

When applicable, this option also applies to the data entry for number of trials and number of 
failures. For example, in the following data sheets (Discrete Data: Grouped per Configuration), 
the left picture shows the cumulative data entry and the right picture shows the non-
cumulative. 
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You can specify whether the values are cumulative or non-cumulative by clicking the blue text 
on the Main page of the control panel, or by selecting the Data input is cumulative check box 
on the Analysis page of the control panel. As an example, the following pictures show these 
two options for the Failure Times data type. 

 

You can configure Weibull++ to always use a particular format each time you create any of the 
data sheets mentioned above. You can change this setting by selecting or clearing the Data 
input is cumulative check box on the RGA Growth Data Folios page of the Application Setup. 
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Normal View and Advanced Systems View 

For reliability growth data analysis only. 

When you are analyzing data from multiple systems, Weibull++ combines the data into a single 
representative system that allows you to evaluate all the failures that occurred during the 
observation period. 

• In the following times-to-failure data types, the data sets are combined to form an 
equivalent system: 

• Multiple Systems - Concurrent Operating Times 

• Multiple Systems with Dates 

• Multiple Systems with Event Codes 

• In the Repairable Systems data type, the failure times are placed on a single timeline to 
form a superposition system. 

• In the Fleet data type, the failure times are stacked into a cumulative timeline. 

For more information about how the software combines the data for analysis, click one of the 
links above. This topic focuses on the two different ways that you can view and enter data for 
all of these data types, regardless of how the analysis is performed. 

The Normal View displays the data for multiple systems all together in the same data sheet, 
while the Advanced Systems View displays the data one system at a time and provides a 
navigation panel to select which system you wish to view. Any changes that you make to the 
data while in one view will be reflected if you switch to the other view; however, only the 
Advanced System View allows you to select specific systems to be excluded from the analysis 
(e.g., you may choose to exclude a specific system if that data set is not representative of the 
entire population). 

To switch between the two views, choose Growth Data > Format and View > Switch Systems 
View or click the icon on the Main page of the control panel. 

 

Regardless of which view you choose, the System Operation plot shows the failure times of the 
systems that were included in the analysis, as well as the timeline for the representative 
system. 
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Normal View 

In the Normal View, the System ID column is for recording the identifier of the system (e.g., 
System A, SN#1234, etc.). All events entered for this system must have the same ID. The Event 
column specifies whether the row represents the start time (S), failure time (F) or end time (E) 
of the system. The Time to Event column is for recording the time of the event. 

When you calculate the data sheet, the analysis results of the representative system (i.e., the 
equivalent system, superposition system or cumulative timeline) are displayed in the Results 
area of the control panel, as shown next. If you wish to see the results for an individual system, 
you must switch to the Advanced Systems View. 
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Advanced Systems View 

In the Advanced Systems View, the left side of the data sheet shows all the systems that have 
been defined along with their start times (marked with green bullets) and end times (marked 
with red bullets). The check box to the left of each system name allows you to select whether to 
include that system in the representative system for analysis (i.e., the equivalent system, 
superposition system or cumulative timeline). By default, all systems are selected to be 
included in the analysis; however, you can clear the check box to remove the system from the 
combined analysis. You can also edit a system name by right-clicking it and choosing Rename 
on the shortcut menu. 

The following example shows the Advanced Systems View with the data for System A visible. In 
the Time to Event column, the start time of the system is entered in row 1, while the end time 
is entered in row 2 (these rows are reserved for this information). The failure times are entered 
into the subsequent rows, starting with row 3. 

When you calculate the data sheet, the analysis results for the representative system (i.e., the 
equivalent system, superposition system or cumulative timeline) are shown in the Results area 
of the control panel. In addition, the analysis results for the individual system that is currently 
selected will be displayed in an Individual System Results, as shown next. 
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Transfer to New Data Type 

For reliability growth data analysis only. 

In some cases, you can transfer your data from one type of data sheet to another. This option is 
available only for fielded data and some of the multiple systems data types (Concurrent 
Operating Times, with Dates and with Event Codes). 



Chapter 9: Reliability Growth Analysis Folios 

570 https://www.reliasoft.com/weibull 

 

To transfer your data, choose Growth Data > Transfer Data > Transfer to New Data Type or 
click the icon on the Main page of the control panel. 

 

You can choose to transfer data between any of the specified data types. A new data sheet with 
the transferred data will be added to the current folio. In other words, the original data sheet 
remains unchanged and a new data sheet is created in the same folio. 

In addition, the following data sheets give you the option to transfer the data to an equivalent 
system, which is a single system that represents the combined operating time of all the systems 
in the data set. Note that this option is available only when the parameters of the data set have 
been calculated. 

• For the Concurrent Operating Times and Multiple Systems with Dates data types, the 
equivalent system will be transferred into a Failure Times data sheet, which allows you 
perform gap analysis or link the data set to a mission profile, if desired. 

• For the Multiple Systems with Event Codes data type, the equivalent system will be 
transferred into a Multi-Phase Failure Times data sheet, which allows you to use the Crow 
Extended - Continuous Evaluation model to analyze the data set. 

Transfer Data to a Life Data Folio 

For reliability growth data analysis only. 

You can transfer data from a reliability growth analysis (RGA) folio to a life data folio. This 
option is available for time-to-failure data (except Multiple Systems – Known Operating Times), 
multi-phase data (except Mixed Data) and fielded data. 

To transfer your reliability growth analysis data, first calculate the parameters of the data set, 
and then choose Growth Data > Transfer Data > Transfer to Life Data folio or click the icon on 
the Main page of the control panel. 

 

The Transfer to Life Data folio window appears, as shown next. The options that are available 
will depend on the type of reliability growth analysis data sheet and model you are using. 
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• What to Transfer? specifies how your reliability growth analysis data will be handled in the 
life data folio. 

• First failure for each system transfers only the first failure time of each system in the 
reliability growth analysis data sheet. Choose this option if you wish to use the life data 
folio to fit a life distribution to the first times to failure and calculate the reliability (i.e., 
probability of operating without failure for a period of time) of the system. 

• Time between failures in individual systems transfers all the failure times of each 
system in the reliability growth analysis data sheet. Although it is generally not 
recommended to fit a life distribution to repairable systems data, you might choose 
this option if you wish to use the life data folio to fit a distribution to the data set for 
simulation in BlockSim, ReliaSoft's system reliability and maintainability analysis 
software. 
 
If the failure times in the data sheet are cumulative, then the process converts the 
times into their equivalent non-cumulative failure times (because data entry in the life 
data folio is always non-cumulative). If the data in the reliability growth analysis data 
sheet are already non-cumulative, then no conversion will occur and the failure times 
that are transferred will appear as they do in the reliability growth analysis data sheet. 

• Time between failure IDs across systems transfers all the failure times in the reliability 
growth analysis data sheet based on the unique failure modes in each system (you will 
need to select one of the options in the Apply Failure ID area to serve as the identifier 
for the failure modes). Choose this option if you wish to use the life data folio to fit a 
distribution to each failure mode (assuming that the systems are the lowest repairable 

https://www.reliasoft.com/products/reliability-analysis/blocksim
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units). 
 
If a failure mode did not occur in a particular system, then it will be treated as a 
suspension for that system. Similar to the previous option, if the failure times are 
cumulative, the process converts the data into their equivalent non-cumulative failure 
times; if the data are already non-cumulative, then no data conversion will occur. 

• Apply Failure ID? specifies how each data point in the life data sheet will be grouped into 
subsets: 

• The None option does not group the data points in the life data sheet. 

• The Use the "Mode" column option is available only when using the Crow Extended or 
Crow Extended - Continuous Evaluation models. It transfers the combined information 
from the Classification and Mode columns in the reliability growth analysis data sheet 
to the Subset ID column in the life data folio. For example, for a reliability growth 
analysis data point that has the classification "BD" for mode "100," that data point will 
be categorized as part of subset "BD100" in the life data folio. 

• The Use the "Comment" column option uses any text/values that were entered in the 
Comments column of the reliability growth analysis data sheet to group the data points 
in the life data folio. 

A Note About Suspension Times in the Transferred Data 

When you select to apply a failure ID, all subsets are assumed to end at the same time. For 
example, if you have two systems where the observation period for System 1 ended at 100 
hours and for System 2 at 150 hours, then the transferred data for System 1 will automatically 
include a suspension time that covers the difference between the end times of the two 
systems. 

Note that if the data were cumulative, then the suspension time would be the difference 
between the last failure time for System 1 and the last failure time for System 2 (e.g., 150 - 100 
= 50 hours), but if the reliability growth analysis data were non-cumulative, then the suspension 
time would be the difference between the last failure time for system 1 and the total test 
duration (e.g., if the observation period ended at 250 hours, then the suspension time would be 
250 - 100 = 150 hours). 

Examples 

The following examples show pictures of how data from a cumulative Failure Times data sheet 
may be transferred to a life data folio. Here is the original reliability growth analysis data. 
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Reliability Growth Failure Times data sheet (cumulative) 

Example 1: Here is the data set transferred using the "Time between failures in individual 
systems" option with no failure ID applied. The cumulative times have been converted to non-
cumulative. All failure times are transferred, but the failure mode is not identified. 

 

Example 2: Here is the data set transferred using the "Time between failures in individual 
systems" option and the "Use the Mode column" option. The cumulative times have been 
converted to non-cumulative. The failure times are grouped into subsets based on the 
combined information from the Classification and Mode columns in the growth data sheet. The 
suspension data are added automatically to ensure that all the subsets have the same 
termination time. 
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Example 3: Here is the data set transferred using the "Time between failures in individual 
systems" option and the "Use the Comment column" option. The results are the same as 
example 2, except that the failure IDs came from the Comments column in the growth data 
sheet. 

 

GROWTH DATA FOLIO CONTROL PANEL 

For reliability growth data analysis only. 

The growth data folio control panel allows you to configure the analysis settings for the data 
sheet and view/access the results. This topic provides general information that applies to most 
analyses. For more focused information about performing a particular type of analysis, you can 
go directly to the topic of interest. (See Traditional Reliability Growth Analysis, Growth 
Projections, Planning and Management (Crow Extended Model) or Repairable Systems 
Analysis.) 

Control Panel Main Page 

• The Model area allows you to choose a statistical model to use in analyzing the data set. 
The list of models available will depend on the data type. See the Reliability Growth Data 
Types topic for a complete list. 

 

• The Calculation Options area allows you to choose the Change of Slope analysis method for 
situations where there has been a significant change in the failure intensity of the system. 
(See Change of Slope Analysis.) 
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• The available analysis settings may vary depending on the data type. The following picture 
shows an example of the settings that are available for the Failure Times data type. In this 
example, the settings show the type of data (Developmental – Failure Times), parameter 
estimation method (MLE),  confidence bounds method (Crow), whether a gap interval has 
been defined in the analysis (No Gap) and whether the failure times are entered as 
cumulative or non-cumulative (Cumulative). 

 

If a setting is displayed in blue text, you can click the label to switch between the available 
options. These settings are also available on the Analysis page of the control panel. See 
Control Panel Analysis Page for a description of all available settings. 

• The Termination Time field is available when you use the Crow-AMSAA (NHPP) or Crow 
Extended models with any of the following times-to-failure data types: 

• Failure Times 

• Grouped Failure Times 

• Multiple Systems - Known Operating Times 

This setting allows you to specify the time when the observation period ended, if 
applicable. Click the (...) button to open the Termination Time window, as shown next. 
Select the Time Terminated option to enter the actual observation time, or select the 
Failure Terminated option to indicate that the observation period ended with the last 
failure time recorded in the data sheet. 
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• The Results area displays the calculated parameters and other results. The information 
shown in this area depends on the current data type and model, as well as your selections 
on the RGA Growth Data Folios page and Calculations page of the Application Setup. If you 
are analyzing data from multiple systems, this area may show two sets of results (see 
Normal and Advanced Systems View). 

As an example, the following picture shows the analysis results for one particular data set 
and model. Click the Results Report icon   to open the Results window, which shows the 
results in a worksheet that you can copy or print. 

 

Folio Tools 

The folio tools are arranged on the left side of the Main page. Depending on the data type or 
model used in the analysis, the growth data folio control panel may contain some or all of the 
following tools: 

 Calculate estimates the parameters based on the selected model and analysis settings. 
Once the parameters have been calculated, the Results area will show the current results. 
This command is also available by choosing Growth Data > Analysis > Calculate. 



Chapter 9: Reliability Growth Analysis Folios 

Weibull++ 2020 User's Guide 577 

 

 Plot creates a new sheet in the folio that provides a choice of applicable plot types. This 
includes plots such as MTBF vs. time, cumulative number of failures, failure intensity vs. 
time, etc. This command is also available by choosing Growth Data > Analysis > Plot. 

 QCP opens the Quick Calculation Pad, which allows you to obtain calculated results 
based on the analyzed data sheet, such as the cumulative MTBF and the expected number 
of failures. This command is also available by choosing Growth Data > Analysis > QCP. 

 Effectiveness Factors is available only when you use the Crow Extended or Crow 
Extended - Continuous Evaluation models. It opens the Effectiveness Factors window, 
which allows you to define the effectiveness factors for each BD mode to estimate the 
fractional decrease in failure intensity that can be expected after the delayed fix is applied. 
This command is also available by choosing Growth Data > Crow Extended > Effectiveness 
Factors. 

 Alter Parameters opens a tool that allows you to alter the values of the calculated 
parameters, assuming that the likelihood function and Fisher Matrix (evaluated at the 
original parameter estimates) remain the same. In plots, the position of the data points 
remain the same, but the solution line and all subsequent analyses made via the QCP and 
other tools are based on the modified parameter values. Therefore, the analysis may be 
appropriate only within the context of your specific scenario. This command is also 
available by choosing Growth Data > Options > Alter Parameters. 

 Switch System View is available only for fielded data and some of the multiple systems 
data types (Concurrent Operating Times, with Dates and with Event Codes). It allows you to 
switch between the two complementary views that are available for some multiple systems 
data types (see Normal and Advanced Systems View). This command is also available by 
choosing Growth Data > Format and  View > Switch Systems View. 

 Change Units is available for all data types except discrete data. It opens the Change 
Units window, which allows you to change the units of an existing data sheet. 

 Auto Group Data is available for data types where the exact failure times have been 
recorded (i.e., Failure Times and Multi-Phase Failure Times) and for the Fleet data type. It 
opens the Auto Group Data window, which allows you to specify the intervals that will be 
used to group the data. This command is also available by choosing Growth Data > Options 
> Auto Group Data. 
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 Link Mission Profile is available only for the Failure Times data sheet. It applies to cases 
where testing involves multiple test profiles. This command allows you to select a mission 
profile in the project that you want to use to analyze the data set. The data in the current 
data sheet will be transferred to a new data sheet in the same folio, and then grouped 
according to the "convergence points" in the specified mission profile. (See Mission 
Profiles.) 

 Mode Processing is available for data sets analyzed with the Crow Extended or Crow 
Extended - Continuous Evaluation  models. This utility allows you to extract the first failure 
time for each unique BC mode and/or unique BD mode in a data set. This allows you to 
automatically copy the failure times for a particular failure mode classification into a new 
data sheet for separate analysis. 

 Event Report is available for all multi-phase data types and for the Multiple Systems 
with Event Codes data type. It opens a report about the failure modes in the current 
analysis, such as the classification of the modes, their first times to failure and effectiveness 
factors. This command is also available by choosing Growth Data > Analysis > Event 
Report. (See Event Reports.) 

 Batch Auto Run is available only for multi-phase data, fielded data and some of the 
multiple systems data types (Concurrent Operating Times, with Dates and with Event 
Codes). It opens the Batch Auto Run window, which allows you to quickly extract data from 
an existing data sheet based on the system ID, phase or analysis point. This command is 
also available by choosing Growth Data > Options > Batch Auto Run. 

 Transfer to New Data Type is available only for fielded data and some of the multiple 
systems data types (Concurrent Operating Times, with Dates and with Event Codes). It 
opens the Transfer to New Data Type window, which allows you to select the data type into 
which you would like to transfer the data. This command is also available by choosing 
Growth Data > Transfer Life Data > Transfer to New Data Type. 

 Transfer to Life Data folio  is available for time-to-failure data (except Multiple Systems 
– Known Operating Times), multi-phase data (except Mixed Data) and fielded data. It opens 
the Transfer to Life Data folio  window, which allows you to transfer the current reliability 
growth data set to a new life data folio data sheet. This command is also available by 
choosing Growth Data > Transfer Life Data > Transfer to Life Data folio. 
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GROWTH DATA FOLIO ANALYSIS SETTINGS 

For reliability growth data analysis only. 

The Analysis page of the growth data folio control panel may contain some or all of the 
following options (and some of these settings can also be changed on the Main page of the 
control panel): 

• The Analysis Type area allows you to choose the method for estimating the parameters of 
your chosen model. 

• The Maximum Likelihood parameter estimation method is available for the Crow-
AMSAA, Crow Extended, Crow Extended - Continuous Evaluation, Power Law and Lloyd-
Lipow models. 

• The Least Squares method is available for the Lloyd-Lipow, Standard Gompertz, 
Modified Gompertz, Duane and Logistic models. 

• The Confidence Interval Method area allows you to choose a method for calculating the 
confidence bounds. The methods that are available depend on the data type and model. 

• Fisher Matrix and Crow confidence bounds are available for the Crow-AMSAA (NHPP), 
Crow Extended, Crow Extended - Continuous Evaluation and Power Law models. There 
are two exceptions: 

• If you use the Crow-AMSAA model with the Discrete Grouped per Configuration 
data type, then Least Squares is the only available confidence bounds method. 

• Fisher Matrix is the only available confidence bounds method for the Lloyd-Lipow 
model. 

• The Least Squares method is available for the Standard Gompertz, Modified Gompertz, 
Duane and Logistic models. 

• The Gap Interval setting is available only when you use the Failure Times data type with the 
Crow-AMSAA (NHPP) model. When a gap is defined in the data set, the application assumes 
that reliable information for that time period is unknown and ignores any entries that have 
been made for the specified time interval. (See Gap Analysis.) 
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• The Data input is cumulative check box allows you to specify whether the data will be 
entered cumulatively (where each row shows the total amount of operating time when the 
failure occurred) or non-cumulatively (where each row shows the incremental operating 
time from when the last failure occurred). When applicable, this setting also applies to the 
data entry for number of trials and number of failures in discrete data sheets. (See 
Cumulative vs. Non-Cumulative Data.) This check box is available for the following data 
sheets: 

• Times-to-failure data: 

• Failure Times 

• Multiple Systems - Known Operating Times 

• Discrete data: 

• Grouped per Configuration 

• Multi-phase data: 

• Failure Times 

• The Failure Discounting setting is available only for the Discrete Sequential with Mode data 
type. It allows you to specify the confidence level that will be used to define the fractional 
decrease in failure value. (See Failure Discounting.) 

 

• The Event Code Options area is available only for the Multiple Systems with Event Codes 
data type and all multi-phase data types. It allows you to select whether or not to include Q 
(quality failure) and/or P (performance failure) events in the reliability growth projections 
analysis. 

 

• The Statistical Tests area is available only for the Crow-AMSAA (NHPP) or Crow Extended 
models. It allows you to specify the significance level used in the statistical tests. (See 
Statistical Tests.) 
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QUICK CALCULATION PAD (QCP) 

For reliability growth data analysis only. 

The Quick Calculation Pad (QCP) provides a convenient way of calculating a variety of useful 
metrics. To access the tool, click the QCP icon on the Main page of the control panel. 

 

This topic provides a general description of the QCP and how to use it in most analyses. For 
more focused information about the types of calculations that can be performed for a 
particular type of analysis/model, you can go directly to the topic of interest: 

• Traditional reliability growth analysis (Crow-AMSAA, Duane and discrete models). 

• Crow Extended model. 

• Crow Extended - Continuous Evaluation model. 

• Repairable systems analysis (Crow-AMSAA and Power Law models). 

How to Use the QCP 

To use the QCP, do the following: 

1. Choose a metric in the Calculate area. The metrics available depend on the data type and, 
in the case of the Crow Extended model, which fix strategies were implemented (i.e., BC = 
fixed during test or BD = delayed fix). 

2. If applicable, use the Units drop-down list to specify the units for any time values that are 
entered as inputs and/or displayed as results. The units in the QCP can be different from 
the units that were used for the data sheet. For example, you could enter the failure times 
in hours but then calculate the cumulative number of failures for 1 month of operation — 
the application will convert the times automatically based on the conversion factors 
specified for the database. 

3. If applicable, use the Bounds drop-down list to specify what type of confidence bounds to 
calculate. The following graphics illustrate the types. The ReliaWiki resource portal provides 
more information on the background theory of confidence bounds at: 
http://www.reliawiki.org/index.php/Confidence Bounds. 

http://www.reliawiki.org/index.php/Confidence%20Bounds
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If you select Both One-Sided, the QCP will calculate both the lower one-sided bound and 
the upper one-sided bound. 

4. Make any required inputs in the Input area. 

5. Click Calculate. The calculated value(s) will always be displayed in the results area at the 
top of the window. 

Other Options 

1. Click the Report button at the bottom of the window to display a summary of the current 
calculation input/output in the Results window. 

2. Use the Options drop-down list to configure other settings, including: 

• Precision sets the number of decimal places displayed in the results. 

• Scientific Notation sets the point at which numbers will be converted to normalized 
scientific notation. For example, setting this to 3 means that all numbers with a value of 
1,000 or more will be converted to normalized scientific notation (e.g., 1.0E+3). 

• Set Display Font allows you to change the font style and size that is used to display the 
calculated value(s). 

• Select Captions if you want additional information to be displayed in the results area 
along with the values (a green light in the button indicates that this option is selected). 
For example, if you have selected to calculate the cumulative MTBF for a given time 
with 2-sided confidence bounds at the 90% confidence level, the first picture shows the 
display with captions and the second picture shows without. 
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QCP window with captions on 

 
QCP window with captions off 

• Select Show Calculation Log if you want to display a log on the right side of the window 
that records some or all of the calculations performed during this QCP session (a green 
light in the button indicates that this option is selected). 

• If Auto Print Results is selected under Options, all results will be automatically 
printed to the log each time you perform a calculation. 

• Otherwise, you can choose which results to add to the log by using the Print button 
at the bottom of the log display. 
 
Under the log display, you can also click Feed to "advance the tape" or Clear to 
delete all data from the current log. If you click inside the log, you can copy some 
or all of the text to the Clipboard. 

• Select Non-Modal QCP to lock the QCP in a top window position so it can remain open 
while you have access to all folios data sheets (a green light in the button indicates that 
this option is selected). The calculations performed in the QCP will be based on the 
currently active data sheet. If this option is not selected, you will need to close the QCP 
to access any data sheet. This setting can also be changed by using the While QCP is 
open, have access to all folios option on the Other page of the Application Setup. 
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RELIABILITY GROWTH PLOTS 

For reliability growth data analysis only. 

Reliability Growth Data folios (RGA) offer a variety of plots to show a visual representation of 
your analysis results; the available plots depend of what kind of analysis you are performing. To 
create or view a plot for an analysis, click the Plot icon on the Main page of the control panel. 

 

For information about how to use the plot utilities, refer to Plot Utilities. 

For focused information on the types of plots that can be generated for a particular analysis, 
you can go directly to the topic of interest: 

• QCP Calculations and Plots for Traditional RGA 

• QCP Calculations and Plots for Crow Extended 

• QCP Calculations and Plots for Multi-Phase Data 

• QCP Results and Plots for Repairable Systems Analysis 

PUBLISHING MODELS FROM ANALYSIS RESULTS 

For reliability growth data analysis only. 

Once a data sheet has been analyzed, you can publish the results as a model. To publish a 
model based on the analysis results, click the Publish to Model icon on the Publishing page of 
the control panel. 

 

The type of model that will be published depends on the data type and growth model that you 
are working with: 

• For discrete data types (Multi-Phase Mixed data sheet and Discrete data sheets), the results 
are in terms of the demonstrated reliability, so the published model will be a fixed 
reliability value. 

• For all other developmental data, the results are based on the reliability growth process; 
therefore, the published model will be a 1-parameter exponential distribution with a mean 
time equal to the demonstrated MTBF. 
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• For fielded data analyzed with the Power Law model, the published model will be a 2-
parameter Weibull distribution, where the beta parameter indicates whether the system is 
exhibiting wearout, infant mortality or a constant failure rate (beta = 1). If the data are 
analyzed with the Crow Extended model, the published model will be a 1-parameter 
exponential distribution with a mean time equal to the instantaneous MTBF at the 
termination time. 

All other tools for working with the published model, such as displaying its properties and 
tracing its usage, are on the Publishing page of the growth data folio's control panel. 

STATISTICAL TESTS 

For reliability growth data analysis only. 

When you use the Crow-AMSAA (NHPP) or Crow Extended models, Weibull++ automatically 
performs statistical tests on the calculated data set. The results of the tests help you to 
evaluate how well the model fits the data. Only the test that applies to the data type and model 
you are using will appear in the results. The results are displayed on the growth data folio 
control panel, and can also be displayed in a report by choosing Growth Data > Analysis > 
Statistical Tests Report. 

 

The following tests evaluate the hypothesis that the failure times follow a non-homogeneous 
Poisson process (NHPP). The ReliaWiki resource portal provides more information about these 
tests at http://www.reliawiki.org/index.php/Crow-AMSAA_(NHPP). 

• The Chi-squared goodness-of-fit test is applied to grouped failure times. 

• The Cramér-von Mises (CVM) goodness-of-fit test is applied to non-grouped failure times 
where there are no gaps in the data. 

The following tests apply to multiple systems analysis only. The ReliaWiki resource portal has 
more information about these tests at http://www.reliawiki.org/index.php/Hypothesis_Tests. 

• The Common Beta Hypothesis (CBH) test indicates whether all the systems in the data set 
have similar beta values so you can evaluate whether the systems should be combined into 
a single representative system (i.e., the equivalent system, superposition system or 
cumulative timeline). 

• The Laplace Trend test evaluates the hypothesis that a trend does not exist in the data. It 
can determine whether the system reliability is improving, deteriorating or staying the 

http://www.reliawiki.org/index.php/Crow-AMSAA_(NHPP)
http://www.reliawiki.org/index.php/Hypothesis_Tests
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same. When the Crow Extended model is used without BC failures modes, it is assumed 
that there is no trend (i.e., the system is neither improving nor deteriorating). 

Tip: You can set the default significance level for the statistical tests by entering a value in the 
RGA Growth Data Folios page of the Application Setup, or by changing the value on-the-fly from 
the Analysis page of the growth data folio control panel. 

The following tools are also available in Weibull++, but are not automatically performed when 
you calculate the data set: 

• The Interval Goodness-of-Fit Test tool helps you to determine which intervals should be 
used to group the data so that the goodness-of-fit test passes. This option is available only 
for fielded data and some of the multiple systems data types (Concurrent Operating Times, 
with Dates and with Event Codes). 

• The Test for Fix Effectiveness tool helps you to assess whether or not applied fixes have 
been effective across test phases. It is available only for the multi-phase data types. 

INTERVAL GOODNESS-OF-FIT TEST 

For reliability growth data analysis only. 

The Interval Goodness-of-Fit Test window helps you to group failure times into intervals so that 
the chi-squared goodness-of-fit test will pass when you analyze the grouped data. You specify 
the intervals that you are considering and the tool automatically determines the actual number 
of failures that were observed at the specified intervals and the number of expected failures 
based on the Crow AMSAA (NHPP) model. It then compares the observed vs. expected number 
of failures in order to evaluate how well the Crow-AMSAA (NHPP) model will fit the data when 
grouped into the proposed intervals. 

If the model fits the data, the result will indicate that the data set passed the test; but if there is 
a large difference between the observed and expected number of failures, the test may fail. In 
this case, the model may not be representative of the data and you will need to adjust the 
specified intervals such that the test passes. 

The ReliaWiki resource portal provides more information about the chi-squared analysis at 
http://www.reliawiki.org/index.php/Crow-AMSAA_(NHPP). 

This tool is available only for fielded data and some of the multiple systems data types 
(Concurrent Operating Times, with Dates and with Event Codes). 

To use the tool, first calculate the parameters of the data set, and then choose Growth Data > 
Options > Interval GOF. 

http://www.reliawiki.org/index.php/Crow-AMSAA_(NHPP)
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The following picture shows an example of how to use the utility. The End Time column displays 
the interval end times that you want to consider. The Observed Failures column displays the 
observed failures at the specified interval end time. The Expected Failures column shows the 
number of failures that would be expected for that interval based on the Crow-AMSAA (NHPP) 
model. Note that the termination time of the test is automatically entered for you (in this 
example, the termination time is 2,909 hours). 

 

• To add an interval to be considered, enter a value in the Interval end time field and click 
Add. 

• To change an interval, select the row, enter a new value in the Interval end time field and 
click Update. 

• To remove an interval, select the row and click Delete. Alternatively, you can remove all the 
intervals that were entered by clicking Reset. 
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Once you have specified all of the intervals that you want to consider for grouping the data, 
click Calculate to perform the test. The Result field displays whether the test passed or failed. 

You can click Report to open a summary of the analysis in the Results window. If you want to 
proceed with the grouped data analysis, you can copy the "End Time" and "Observed Failures" 
values into a new Grouped Failure Times data sheet. 

SELECT SYSTEMS TO PLOT 

For reliability growth data analysis only. 

When you are analyzing data from multiple systems, Weibull++ combines the data into a single 
representative system that allows you to evaluate all the failures that occurred during the 
observation period. You can view the resulting timeline via the System Operation plot, which 
also shows the failure times of each available system in the data sheet. 

In the Systems Operation plot, you can select to display or hide a system on the plot by 
choosing Plot > Options > Plot Systems or by right-clicking the plot and choosing the option on 
the shortcut menu. 

 

The Select System to Plot window shows all the systems that were analyzed, including the end 
time, total operating time and number of recorded failures in each system. To add or remove a 
system on the plot, select or clear the corresponding check box. Click the column heading 
above the check boxes to select or clear all check boxes. 

To change the order in which the systems appear in the plot, click any of the column headings 
to sort the values. For example, clicking the Failures column heading will sort the systems from 
the lowest to the highest number of failures. Clicking the heading again reverses the sort order. 
Clicking one more time returns the order to its original state (i.e., sorted by system). 

To show or hide the timeline of the representative system, select or clear the Plot System 
Timeline check box. 

To export all the data shown in the window to an Excel file, click the Send to Excel button. 
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UPDATING RGA SPREADSHEETS AND REPORTS FROM PRIOR VERSIONS 

For reliability growth data analysis only. 

In versions prior to Version 2020, RGA was a separate desktop application that included both 
specialized functions for reliability growth analyses as well as modified versions of functions 
that are also used in Weibull++. While most of the functions in Version 2020 work the same, 
there are some changes that you will need to make before using a general spreadsheet or 
ReliaSoft Workbook that you created in an earlier version. 

New Functions 

The following RGA-specific functions have new names in Version 2020 as the names used in 
older versions are now specific for life data and life-stress data folios. 

Old Name New Name 

Spreadsheet Functions 

FCOUNT FCOUNT_G 

PROBFAIL PROFAIL_G 

RELIABILITY RELIABILITY_G 
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TIMEATR TIMEATR_G 

Word Processing Functions 

Number of Failures Number of Failures_G 

Probability of Failure Probability of Failure_G 

Reliability Reliability_G 

Time at Reliability Time at Reliability_G 

Data Sheet References 

In prior versions, data sheet references looked like this: 

=MODEL("Folio1!Data1") 

In Version 2020, you must update the data sheet references to include the folder name, like 
this: 

=MODEL("RGA!Folio1!Data1") 

Data sources that are associated with ReliaSoft Workbooks do not have to be manually 
updated. 

Plots 

All reliability growth plots created in the Word Processing Module must be recreated. 

  

Traditional Reliability Growth Analysis 

For reliability growth data analysis only. 

Depending on the data type and the model selected, the reliability growth data folio can be 
used to perform several different types of analysis. The Growth Data Folios topic provides 
general information that is applicable for any type of analysis (e.g., choosing a data type, 
specifying the time units, using the control panel, etc.). This topic provides more focused 
information about using the reliability growth data folio specifically for traditional reliability 
growth analysis. 

This type of analysis is performed with data from in-house reliability growth testing that was 
conducted during the developmental stages for a product. The analysis assumes that all fixes 
(i.e., permanent design improvements) are applied immediately after failure and before testing 
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resumes, and that a reliability growth model can be fitted to the data in order to track how the 
reliability changes over time. The metrics of interest may include the reliability, MTBF, failure 
intensity, expected number of failures for a given time or the amount of testing that will be 
required to demonstrate a specified reliability. 

DATA TYPES AND MODELS FOR TRADITIONAL RGA 

For reliability growth data analysis only. 

The following information provides a summary of the data types and models that are applicable 
for traditional reliability growth analysis (i.e., the analysis of developmental testing data with 
the assumption that fixes are applied immediately after a failure and before testing resumes). 

Data Types 

You can perform traditional reliability growth analysis with any of the following data types: 

• All times-to-failure data types (except for Multiple Systems with Event Codes, which is 
intended only for growth projections analysis) 

• All discrete data types 

• Reliability data 

Reliability Growth Models 

Weibull++ includes six reliability growth models that can be used to track how the reliability 
changes over time during developmental testing. The models available will depend on the data 
type. The following list provides links to the ReliaWiki resource portal that discusses in detail 
the assumptions behind each model. 

• Crow-AMSAA (NHPP) -  http://www.reliawiki.org/index.php/Crow-AMSAA_-_NHPP 

• Duane - http://www.reliawiki.org/index.php/Duane_Model 

• Standard and Modified Gompertz - http://www.reliawiki.org/index.php/Gompertz_Models 

• Lloyd-Lipow - http://www.reliawiki.org/index.php/Lloyd-Lipow 

• Logistic - http://www.reliawiki.org/index.php/Logistic 

http://www.reliawiki.org/index.php/Crow-AMSAA_-_NHPP
http://www.reliawiki.org/index.php/Duane_Model
http://www.reliawiki.org/index.php/Gompertz_Models
http://www.reliawiki.org/index.php/Lloyd-Lipow
http://www.reliawiki.org/index.php/Logistic
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ANALYSIS RESULTS FOR TRADITIONAL RGA 

For reliability growth data analysis only. 

When you calculate a data set, the analysis results will be displayed in the Results area on the 
control panel. The following pictures show some examples of analysis results. 

 

The available results will vary depending on the data type and model you are working with. The 
results may include the following: 

• The estimated parameters of the model are always displayed. For example, this will be a, b 
and c for Standard Gompertz; A and Alpha for Duane; Beta and Lambda for Crow-AMSAA; 
etc. 
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• The estimated Growth Rate. A larger growth rate means faster MTBF growth. 

• The instantaneous MTBF and failure intensity at the end of the observation period. An 
option on the Calculations page of the Application Setup window determines whether you 
prefer to call these values "demonstrated" (DMTBF and DFI) or "achieved" (AMTBF and 
AFI) for all new folios. For existing folios, you can change the option in the Settings tab of 
the Item Properties window (Project > Current Item > Item Properties). 

• The demonstrated reliability (DRel) and demonstrated failure probability (DFP), which is 1 - 
DRel. 

• Whether the test was Failure Terminated or has a specified Termination Time for the 
calculations. (See Termination Time window.) 

• Whether the data set passed or failed the applicable goodness-of-fit tests that are 
performed automatically when you calculate the parameters (applies to the Crow-AMSAA 
model only). Only the test(s) that apply to the data type you are using will appear in the 
results. (See Statistical Tests.) 

• For data sheets that support the Advanced Systems View, the following information will 
also be displayed. 

• The number of systems that were included in the analysis (e.g., 4/6 means four out of 
six systems were analyzed). You can omit a system from the analysis by clearing its 
check box on the Systems panel while the data sheet is in Advanced Systems View. 

• The control panel will show two sets of results: the larger table at the top shows the 
results for the equivalent system (which represents the combined operating hours of 
the systems), and the smaller table at the bottom show the results for the individual 
system that is currently selected in the data sheet. The specific system name is shown 
in the heading of this table. 

Note: If the result of the analysis is associated with a published model, then the model's name 
will appear as a link at the bottom of the Results area. Click the link to view the model's 
properties. For details on how to publish the results as a model, see Publishing Models. 

QCP CALCULATIONS AND PLOTS FOR TRADITIONAL RGA 

For reliability growth data analysis only. 

Weibull++ includes a Quick Calculation Pad (QCP) for computing useful metrics, as well as 
multiple plots that allow you to visualize the results of your analyses. This topic describes the 
calculations and plots you can obtain from traditional reliability growth analysis (i.e., the 
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analysis of developmental testing data with the assumption that fixes are applied immediately 
after a failure and before testing resumes). 

Note: When you analyze data from multiple systems, Weibull++ combines the data to create a 
single equivalent system. Any plots generated for the combined data set and analyses via the 
Quick Calculation Pad will be based on the equivalent system. See Times-to-Failure Data from 
Multiple Systems for more information about how the software combines the data for analysis. 

QCP Calculations 

You can open the Quick Calculation Pad (QCP) by choosing Growth Data > Analysis > Quick 
Calculation Pad or by clicking the icon on the control panel. 

 

To perform a calculation, select the appropriate option and enter any required inputs in the 
Inputs area, then click Calculate. For more detailed information about all the options available 
in the QCP, see Quick Calculation Pad (QCP). 

The types of calculations available depend on the selected data type. 

Times-to-failure data types 

Two values can be calculated for either the MTBF or Failure Intensity: 

• The Instantaneous value is the MTBF/FI over a small interval dt that begins at a specified 
time. For example, an instantaneous MTBF of 5 hours after 100 hours of operation means 
that, over the next small interval dt that begins at 100 hours, the average time between 
failures will be 5 hours. 

• The Cumulative value is the MTBF/FI from time = 0 up to a specified end time. For example, 
a cumulative MTBF of 5 hours from 0 to 100 hours means that the average time between 
failures was 5 hours over the 100-hour period. 

The Time Given option allows you to calculate the mission duration given any of the following 
metrics: 

• Cumulative MTBF 

• Instantaneous MTBF 

• Cumulative failure intensity (FI) 
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• Instantaneous failure intensity (FI) 

Number of Failures is the cumulative number of failures that are expected to occur by a 
specified time, based on the fitted model. 

Discrete data types 

For the Discrete-Sequential data sheet with the Crow-AMSAA (NHPP) or Duane models, the 
following calculations are available: 

• Two values can be calculated for either the Reliability or Probability of Failure: 

• The Cumulative value is the reliability/prob. of failure from time = 0 up to a specified 
end time. For example, a reliability of 0.85 from 0 to 100 hours means that, on average, 
the reliability was 0.85 over the 100-hour period. 

• The Instantaneous value is the reliability/prob. of failure over a small interval dt that 
begins at a specified time. For example, an instantaneous reliability of 0.85 at 100 
hours duration means that, over the next small interval dt that begins at 100 hours, the 
average reliability will be 0.85. 

• The Stage Given option allows you to calculate at which stage a specific metric will be 
achieved. You can specify the following metrics: 

• Cumulative reliability 

• Cumulative probability of failure 

• Instantaneous reliability 

• Instantaneous probability of failure 

• Number of Failures is the cumulative number of failures that are expected to occur by a 
specified time, based on the fitted model. 

For the Discrete-Mixed data sheet with the Crow-AMSAA or Crow Extended models, the 
following calculations are available: 

• Two values can be calculated for either the Reliability or Probability of Failure: 

• The Average value is the reliability/prob. of failure from time = 0 up to a specified end 
time. 

• The Instantaneous value is the reliability/prob. of failure over a small interval dt that 
begins at a specified time. 
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• Number of Failures is the cumulative number of failures that are expected to occur by a 
specified time, based on the fitted model. 

For all other discrete data sheets and models, the following calculations are available: 

• Reliability is the probability of the system operating without failure for a period of time. 

• Probability of Failure is also known as unreliability, and it is the inverse of the reliability. 

• The Stage Given option allows you to calculate at which stage the reliability will be 
achieved. 

Reliability data type 

• Reliability is the probability of the system operating without failure for a period of time. 

• Probability of Failure is also known as unreliability, and it is the inverse of the reliability. 

• Time Given Reliability is the mission duration for a specified reliability value. 

Plots 

You can create plots by choosing Growth Data > Analysis > Plot or by clicking the icon on the 
control panel. 

 

This section describes the types of plots you can create for traditional reliability growth 
analysis. The scaling, setup, exporting and confidence bounds settings are similar to the options 
available for all other reliability growth plot sheets. For more information on these common 
options, see Plots. 

The types of plots you can create depend on the selected data type. 

Times-to-failure data types 

• Cumulative Number of Failures shows how the number of failures is increasing over time. 
It plots the failure times on the x-axis and the cumulative number of failures on the y-axis. 
The points represent the actual failure times in the data set and the solution line represents 
the expected number of failures. The vertical line represents the test termination time. 

• MTBF vs. Time shows how the time between consecutive failures increases, decreases or 
remains constant over time. It plots the cumulative MTBF curve and the corresponding 
instantaneous MTBF curve on the same plot. The points represent the actual failure times 
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in the data set, while the vertical line represents the test termination time. The horizontal 
lines represent the instantaneous MTBF over the marked interval, which is obtained by 
dividing the length of the interval with the number of failures in that interval. You can 
specify the length of the intervals by right-clicking the plot and choosing Show/Hide Items 
on the shortcut menu. In the window, enter the desired interval length in the Time Interval 
field. 

• Failure Intensity vs. Time shows how the rate of occurrence of failures increases, decreases 
or remains constant over time. It plots both the cumulative and instantaneous failure 
intensity curves on the same plot. The points represent the actual failure times in the data 
set, while the vertical line represents the failure time. The horizontal lines represent the 
instantaneous failure intensity over the marked interval, which is obtained by dividing the 
number of failures in that interval with the length of the interval. You can specify the length 
of the intervals by right-clicking the plot and choosing Show/Hide Items on the shortcut 
menu. In the window, enter the desired interval length in the Time Interval field. 

• System Operation is available only for multiple systems analysis. It shows the failure times 
of each system in the data set, along with the timeline for their equivalent system that is 
used for calculating analysis results. See Times-to-Failure Data from Multiple Systems for 
more information on how the software combines the data to build the equivalent system. 

Discrete data types 

The following plots are available when you use the Crow-AMSAA or Duane model with the 
Discrete-Sequential data sheet, or the Crow-AMSAA or Crow Extended model with the Discrete-
Mixed data sheet: 

• Cumulative Number of Failures shows how the number of failures is increasing over time. 
It plots the failure times on the x-axis and the cumulative number of failures on the y-axis. 
The points represent the actual failure times in the data set and the solution line represents 
the expected number of failures. The vertical line represents the test termination time. 

• Reliability vs. Time shows how the reliability increases, decreases or remains constant over 
time. It plots both the cumulative and instantaneous reliability curves on the same plot. 

• Unreliability vs. Time shows how the probability of failure increases, decreases or remains 
constant over time. It plots both the cumulative and instantaneous probability of failure 
curves on the same plot. 

For all other models and/or discrete data sheets, the following plots are available: 

• Reliability vs. Time shows the reliability values over time, capturing trends in the system’s 
failure behavior. 
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• Unreliability vs. Time shows the probability of failure of the system over time. 

Reliability data type 

• Reliability vs. Time shows the reliability values over time, capturing trends in the 
system’s failure behavior. 

• Unreliability vs. Time shows the probability of failure of the system over time. 

Tip: Weibull++ includes two additional plot utilities you can use across all types of data: the 
overlay plot, which allows you to compare different data sets or models; and the side-by-side 
plot, which allows you to display different plots of a single data set all in a single window for 
easy comparison. 

EXAMPLE: FAILURE TIMES DATA 

For reliability growth data analysis only. 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_ReliabilityGrowth_RGA_Examples.rsgz20"). To access this database 
file, choose File > Help, click Open Examples Folder, then browse for the file in the Weibull sub-
folder. 

The name of the project is "Failure Times - Duane and Crow-AMSAA," and the folio that contains 
the data is called "Crow-AMSAA (NHPP)." 

A prototype of a system is tested at the end of one of its design stages. When a failure occurs in 
the system, the time of failure is recorded and then a fix is applied before testing resumes. A 
total of 40 failures were observed during this period. The prototype has a design specification 
of an MTBF = 135 hours with a 90% confidence level. The goal is to determine whether the 
prototype meets the specified MTBF goal. 

The data from the test are recorded in a Failure Times data sheet configured for cumulative 
failure times, as shown next. To specify the time when the test ended, click the (...) button on 
the control panel to open the Termination Time window. Select Failure Terminated and click 
OK. 
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On the control panel, choose the Crow-AMSAA (NHPP) model, and then analyze the data by 
choosing Growth Data > Analysis > Calculate or by clicking the icon on the Main page of the 
control panel. 

 

The results show a demonstrated MTBF (DMTBF) = 166.2217 hours at the end of the test, as 
shown next. 
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You can use the Quick Calculation Pad (QCP) to obtain the 90% confidence bounds on the 
demonstrated MTBF. To access the QCP, choose Growth Data > Analysis > Quick Calculation 
Pad or click the icon on the Main page of the control panel. 

 

In the QCP, select to calculate the instantaneous MTBF with lower one-sided confidence 
bounds. Select Hour for the time units and then make the following inputs: 

• Time = 3256.3 

• Confidence Level = 0.9 

Click Calculate to obtain the results. It shows that the lower limit on the MTBF at the specified 
time with a 90% confidence level is 131.2122 hours. Therefore, the prototype has met the 
specified goal. 
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To create a plot of the result, close the QCP, and then choose Growth Data > Analysis > Plot or 
click the icon on the Main page of the control panel. 

 

On the plot's control panel, click the Plot Type drop-down list and choose MTBF vs. Time. The 
following plot shows the cumulative MTBF and the corresponding instantaneous MTBF on a 
logarithmic plot. (Note that you can switch to a linear scale by clearing the Use Logarithmic 
Axes check box on the plot's control panel). 
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The points represent the actual failure times in the data set, while the vertical line represents 
the test termination time. The horizontal lines on the plot are the instantaneous intervals, 
which show the MTBF over a specified interval length. The MTBF over an interval is obtained by 
dividing the length of the interval with the number of failures in that interval. The intervals can 
be used to observe a general MTBF trend, whether the MTBF increases, decreases or stays the 
same over time. 

You can specify the length of the intervals by choosing Plot > Actions > Show/Hide Items or by 
right-clicking the plot and choosing Show/Hide Items on the shortcut menu. 

 

In the window, make sure that the Show Intervals check box is selected, and then specify the 
length of the interval in the Time Interval field, as shown next. Click OK and the plot will refresh 
to show the new results. 
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EXAMPLE: DISCRETE (SUCCESS/FAILURE) DATA 

For reliability growth data analysis only. 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_ReliabilityGrowth_RGA_Examples.rsgz20"). To access this database 
file, choose File > Help, click Open Examples Folder, then browse for the file in the Weibull sub-
folder. 

The name of the project is "Discrete Data- Sequential." 

A cartridge device is required to have a reliability of 95% at the end of a reliability growth 
testing program. The device is designed for emergency use and its casing is destroyed when it 
releases its charge; therefore, the design can be tested and improved only through sequential 
pass/fail tests. The result of each trial (whether the device passed or failed) is recorded in a 
Discrete Sequential data sheet. 

Choose the Logistic model, and then analyze the data set by choosing Growth Data > Analysis > 
Calculate or by clicking the icon on the Main page of the control panel. 

 

The following picture shows the data set and the calculated parameters of the logistic model. 
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To create a plot of the results, choose Growth Data > Analysis > Plot or click the icon on the 
Main page of the control panel. 

 

The following reliability vs. time plot shows how the reliability of the device changes with each 
new improvement in the design. The vertical line represents the stage when the test was 
terminated. This plot shows that the reliability after 20 trials is 75%. 
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You can use the Quick Calculation Pad (QCP) to predict when the reliability will reach 95%. To 
access the QCP, choose Growth Data > Analysis > Quick Calculation Pad or click the icon on the 
Main page of the control panel. 

 

In the QCP, select to calculate the Stage Given Reliability, and then enter 0.95. Select Hour for 
the time units and click Calculate to obtain the result. The result indicates that if the reliability 
keeps its trend, it is expected to reach 95% at the 42nd stage of testing, as shown next. 
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CHANGE OF SLOPE ANALYSIS 

For reliability growth data analysis only. 

Change of Slope analysis can be applied to situations where a major change in the system 
design or operational environment causes a significant change in the failure intensity of the 
system. In this case, a single model may not provide a good fit for the data set. 

To analyze this type of data set, the Change of Slope analysis splits the data set into two 
segments, based on the time that the change took place, and then applies a separate Crow-
AMSAA (NHPP) model to each segment. The time that the change took place can be estimated 
from the data or based on your own knowledge about the specific change that was applied to 
the system. Note that although two separate models are applied to the segments, the 
information collected in the first segment are considered when creating the model for the 
second segment. 
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This analysis is available when you use the Crow-AMSAA (NHPP) model with any times-to-
failure data type (except Multiple Systems with Event Codes) or with Discrete – Mixed data. 

Note: The Change of Slope analysis requires at least three failures up to the break point and 
two failures after the break point (in the case of grouped data, this would be the number of 
intervals before and after the break point). 

The ReliaWiki resource portal provides more information about the analysis at 
http://www.reliawiki.org/index.php/Change_of_Slope_Analysis. 

Example 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_ReliabilityGrowth_RGA_Examples.rsgz20"). To access this database 
file, choose File > Help, click Open Examples Folder, then browse for the file in the Weibull sub-
folder. 

The name of the project is "Failure Times - Change of Slope." 

A system is put through a reliability growth testing program. A total of 58 failures are observed 
during the 660 hours of testing. The data are recorded in a Failure Times data sheet and 
analyzed with the Crow-AMSAA (NHPP) model, as shown next. 

http://www.reliawiki.org/index.php/Change_of_Slope_Analysis
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The results show that the data set failed the Cramér-von-Mises (CVM) goodness-of-fit test. This 
indicates that the model is not a good fit for the data. In addition, the following plot shows that 
there appears to be a significant change in the slope of the points at around 400 hours. As it 
turns out, a major design change was implemented at this point in time. Given this scenario, we 
can repeat the analysis using the Change of Slope methodology with the break point set to 400. 
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Return to the data sheet. In the Calculations Options area of the control panel, select the 
Change of Slope option, and then click the Calculate icon. This opens the Change of Slope - 
Break Point window, which allows you to specify the point at which the data set should be 
divided. Enter a value of 400, as shown next. 
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Weibull++ automatically splits the data into two segments and fits a separate Crow-AMSAA 
(NHPP) model to each segment. For the first segment, the data points up to 400 hours are used 
to calculate its parameters. For the second segment, the data points after 400 hours plus 
information from the first segment are used to calculate its parameters. 

The following results show the estimated parameters for Segment 2. Based on this model, the 
demonstrated MTBF (DMTBF) of the system at the end of the test is 38.3063 hours. (The 
Segment 1 model can be used to calculate the MTBF for times up to 400 hours only.) The 
results also show that the data set has passed the chi-squared goodness of fit test. 

 

The following plot shows that the model provides a much better fit to the data. If you choose to 
display the confidence bounds on the plot, only the bounds on Segment 2 (which is the model 
of interest) will be plotted, as shown next. 
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GAP ANALYSIS 

For reliability growth data analysis only. 

Gap analysis is used in situations where issues such as oversight, biases, human error, technical 
difficulties, etc. cause some portion of the data to be erroneous or completely missing. This 
causes the analysis to return distorted estimates of the growth rate and actual system 
reliability. In this type of situation, you can use the Gap Analysis feature in Weibull++ to analyze 
the data set. 

Gap analysis assumes that the information within the problematic time interval is unavailable 
or unreliable and does not use any entries that have been made for that time period. Instead, 
the number of failures for that interval is assumed to be unknown, but the rest of the data 
follow the Crow-AMSAA model. The analysis retains the contribution of the interval to the total 
test time, but no assumptions are made regarding the actual number of failures over the 
interval. 
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This analysis is available when you use the Failure Times data type with the Crow-AMSAA 
(NHPP) model using standard calculations (gap intervals are not compatible with Change of 
Slope calculations). You can define one gap interval per data set. Each gap is a time range that 
exists within the data, and it has a defined start time and end time. There must be at least one 
failure before and after the specified gap interval. 

The ReliaWiki resource portal provides more information about the analysis at 
http://www.reliawiki.org/index.php/Gap_Analysis. 

Example 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_ReliabilityGrowth_RGA_Examples.rsgz20"). To access this database 
file, choose File > Help, click Open Examples Folder, then browse for the file in the Weibull sub-
folder. 

The name of the project is "Failure Times - Gap Analysis." 

A system is put through a reliability growth testing program. The test is terminated after 1,000 
hours of testing, and a total of 86 failures were observed during that period. The data are 
recorded in a Failure Times data sheet and analyzed with the Crow-AMSAA (NHPP) model, as 
shown next. 

http://www.reliawiki.org/index.php/Gap_Analysis
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The results show that the data set failed the Cramér-von-Mises (CVM) goodness-of-fit test. This 
indicates that the model is not a good fit for the data. 

The following plot shows that the number of failures from 500 to 625 hours is abnormally high. 
A quick investigation found that new data collectors were assigned to the project at around 
that time and that extensive design changes involving the removal of several parts were also 
made within that period. It is possible that the parts that were removed were incorrectly 
reported as failed parts. Based on their knowledge of the system and the test program, the 
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analysts agree that such a large number of failures were extremely unlikely. They decide to 
repeat the analysis using gap analysis. 

 

 

Return to the data sheet. On the Analysis page of the control panel, select the Specify a gap 
interval check box and then enter 500 to 625 for the gap interval, as shown next. 

 

Return to the Main page of the control panel and analyze the data set by choosing Growth Data 
> Analysis > Calculate or by clicking the icon on the Main page of the control panel. 
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This time, the analysis will ignore the failure times observed between 500 and 625 hours. The 
resulting plot now shows that the model provides a much better fit to the data. 

 

FAILURE DISCOUNTING 

For reliability growth data analysis only. 

Failure discounting applies to the analysis of discrete data (also known as success/failure or 
attribute data), in which the data set records the success or failure of each one-shot trial (e.g., 
of a missile or other type of device that either succeeds or fails). In Weibull++, you can perform 
failure discounting by using the Discrete Sequential with Mode data type. 

This analysis is used to track the possible recurrence of a failure mode after a fix has been 
applied. If the mode does not appear again in the later trials, then the probability of failure due 
to that mode is reduced. The amount of reduction is related to the consecutive number of 
successful tests after the fix was applied. The following equation describes this relationship: 
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where f is the failure value due to the mode, CL is the confidence level and Sn is the number of 
additional successful tests after the first success following the fix. 

For example: 

• In trial#1, failure mode A occurred. The failure value due to this mode is 1 (i.e., counted as 
one failure). A permanent fix is then applied for mode A. 

• In trial#2, mode A did not recur. This marks the first success after the fix was applied. The 
failure value due to this mode is still counted as 1. 

• In trial#3, mode A did not recur; therefore, Sn = 1, and the failure value due to mode A is 
reduced to 0.9, based on a 90% confidence level. 

• In trial#4, mode A did not recur; therefore, Sn = 2, and the failure value due to mode A is 
further reduced to 0.684, based on a 90% confidence level. 

• In trial#5, mode A occurs again, and because a second fix now needs to be applied, the 
failure value due to this mode resets back to 1. 

Failure discounting has the effect of reducing the total number of failures in the analysis, which 
results in a higher reliability estimate. The following example illustrates this effect. 

Example 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_ReliabilityGrowth_RGA_Examples.rsgz20"). To access this database 
file, choose File > Help, click Open Examples Folder, then browse for the file in the Weibull sub-
folder. 

The name of the project is "Discrete Data - Sequential with Mode." 

The ReliaWiki resource portal provides the mathematical calculations behind this example at 
http://www.reliawiki.org/index.php/Failure_Discounting. 

A device under development undergoes a reliability growth program. A total of 22 trials are 
performed and the result of each trial is recorded in the Discrete Sequential with Mode data 
sheet. Whenever a failure occurs, a fix is applied to the device and the failure mode that caused 
the failure is recorded. 

http://www.reliawiki.org/index.php/Failure_Discounting
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On the Analysis page of the control panel, enter 0.9 for the confidence level in the Failure 
Discounting area, as shown next. 

 

Select the Standard Gompertz model and then analyze the data set by choosing Growth Data > 
Analysis > Calculate or by clicking the icon on the Main page of the control panel. 

 

The following picture shows the data set and the parameters of the model. 
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To compare how failure discounting affects the reliability estimates, copy the Success/Failure 
data and paste them into a Discrete Sequential data sheet. Analyze that data sheet using the 
Standard Gompertz model. 

The following picture shows the copied data set and the parameters of the Standard Gompertz 
model, this time, without failure discounting. 

 

To create an overlay plot that compares the results of the two analyses, choose Home > Insert 
> Overlay Plot. 

 

When prompted to select which data sheets to plot, select the two data sheets you have been 
working with. The following picture shows the resulting overlay plot (with annotations added 
via RS Draw to make the plot easier to interpret). It shows that the reliability estimates are 
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higher when failure discounting is used because of its effect of reducing the total number of 
failures in the analysis. 

 

Crow Extended Model 

For reliability growth data analysis only. 

Traditional reliability growth analysis is used to analyze data from tests where design fixes are 
incorporated during the observation period (the test-fix-test strategy). However, in actual 
practice, fixes may be delayed until after the end of the observation period (test-find-test), or 
you may implement some fixes during the observation period while delaying others (test-fix-
find-test). 

With the Crow Extended model, you can perform reliability growth projections, planning and 
analysis—which allows you to analyze test data from any or all of these strategies by providing 
additional information about the failure modes and the reliability growth management strategy 
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(i.e., which modes are fixed and how effectively the design improvements reduce failure 
intensity). You can also use this model for data from fielded repairable systems in order to 
evaluate the improvement (i.e., the jump in MTBF) that could be achieved by rolling out a set of 
fixes for all systems operating in the field. 

DATA TYPES FOR CROW EXTENDED MODEL 

For reliability growth data analysis only. 

You can apply the Crow Extended model to any of the following data types. 

• All times-to-failure data types 

• Discrete Mixed data 

• All fielded data types 

When the Crow Extended model is selected in any of these data sheets, additional Classification 
and Mode columns will appear in the data sheet. These columns are used to classify and 
identify the failure mode responsible for each observed failure. To learn how to use these two 
columns in an analysis, see Failure Mode Classifications. For the background theory behind the 
Crow-Extended model, the ReliaWiki resource portal provides more information at: 
http://www.reliawiki.org/index.php/Crow_Extended. 

Mode Classifications 

For reliability growth data analysis only. 

To use the Crow Extended model, you must classify and identify the failure mode responsible 
for each observed failure. This information is entered in the Classification and Mode columns in 
the data sheet. These columns are inserted automatically when you choose the Crow Extended 
model from the Model drop-down list on the growth data folio control panel. 

Tip: If the Crow Extended model is not selected but still available for the current data type, you 
can manually add the Classifications and Mode columns to the data sheet by choosing Growth 
Data > Format and  View > Insert Columns > Projections. This will allow you to record 
projections data in case you decide to change the model to Crow Extended later. When Crow 
Extended is not selected, the projections data will not affect the calculations. 

The Classification column records the code that describes how the failure mode is treated. The 
possible codes are described next. 

http://www.reliawiki.org/index.php/Crow_Extended
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• A indicates that no fix will be applied (i.e., management chooses not to address the failure 
mode because of technical, financial or other reasons). 

• BC indicates that a fix was applied during the observation period. The analysis assumes that 
the effect of the design improvement was experienced during the observation period and 
will be reflected in the data. 

• BD indicates that the fix will be delayed until after the observation period. You will be 
required to define the effectiveness factor for each BD mode to estimate the fractional 
decrease in failure intensity that is expected to occur after the fix has been implemented. 

Tip: BC modes are not available for data sheets configured for fielded data or Discrete Mixed 
data because these data types assume that all design improvements are delayed (i.e., no 
reliability growth during the observation period). If you are using Discrete Mixed data (i.e., 
success/failure data from a series of trials on one-shot devices) and you want to account for 
fixes that were implemented during the test, you can use a data sheet configured for Multi-
Phase Mixed data instead. In this sheet, you can enter a BD failure event and its implemented 
fix event (i.e., "I" event). Such a failure will, in effect, be treated as a BC mode. 

The Mode column records the specific failure mode identification, which is optional for A 
modes but required for all BC and BD modes. This can be entered as either a name or a 
numerical code (e.g. "seal leak," "1," "BD1," etc.). 

The next picture shows the first ten rows of a Failure Times data sheet with failure mode 
identification and mode classification information. 

 

Tip: If you discover that a certain failure mode was classified incorrectly (e.g., if every "operator 
error" mode in the above data sheet should have been classified as an A classification instead of 
BD), or if you want to change a particular mode identifier (e.g., you want to change every 
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instance of a particular number in the Mode column to a name), you can use the Convert 
Modes window to apply the update automatically. 

Convert Modes Window 

For reliability growth data analysis only. 

The Convert Modes window allows you to convert any failure mode classification and mode in 
the current data set to another classification and mode. For example, suppose a particular 
failure mode occurs several times during the observation period and is currently classified as BD 
in the data sheet. If it is later decided to ignore this mode rather than addressing it after the 
observation period, you could convert every instance of it in the data sheet to an A 
classification. 

To access this window, choose Growth Data > Crow Extended > Convert Modes. 

 

Two drop-down lists appear next to Failure Mode. Choose the failure mode classification in the 
first list and the failure mode identifier in the second. Then, in the Convert To drop-down list, 
choose the classification that you want the selected failure mode to be changed to, and if 
desired, enter a new identifier in the input field. 

Click Convert to apply the specified changes. The Classification and Mode columns in the data 
sheet will be updated accordingly, and a message will appear specifying the number of changes 
that were made. When you are finished converting failure modes, click the Close button. 

Mode Processing Window 

For reliability growth data analysis only. 

The Mode Processing utility allows you to extract the first failure time for each unique BC mode 
and/or unique BD mode in a data set. This allows you to automatically copy the failure times for 
a particular failure mode classification into a new data sheet for separate analysis. This tool 
applies only to data sets analyzed with the Crow Extended or Crow Extended - Continuous 
Evaluation models. 

To use the tool, you must first analyze the data sheet (by clicking the Calculate icon on the 
control panel), and then choose Growth Data > Crow Extended > Mode Processing. 
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In the window that appears, select the check box next to each mode classification you wish to 
extract. If the data set does not contain a particular mode classification, the corresponding 
check box will be unavailable. 

For example, if you select to extract BC modes, the failure times for all BC modes will appear in 
a new data sheet. (If a particular failure mode (e.g., BC 100) has more than one failure time, 
only the first time will be extracted.) The new data sheet will have the same name as the source 
data sheet plus the name of the mode classification and an increment to reflect the number of 
data sheets that have been created for the same classification. 

 

You can then analyze the extracted data set using traditional reliability growth analysis 
techniques. 

Tip: If you wish to extract subsets of data based on either the system ID recorded in multiple 
systems data sheets or the phases/analysis points recorded in multi-phase data sheets, use the 
Batch Auto Run utility. 

EFFECTIVENESS FACTORS FOR CROW EXTENDED 

For reliability growth data analysis only. 

If you are using the Crow Extended model and have classified some failure modes as BD modes 
(i.e., the modes will not be addressed until after the current observation period), you will need 
to specify the expected effectiveness of the delayed fixes. This information is used to estimate 
the fractional decrease in failure intensity that will occur after the design fixes are 
implemented. For example, you could indicate that 60% of a BD mode's failure intensity will be 
removed from the system after the delayed fix has been implemented (i.e., 40% of the failure 
intensity will remain because the fix is not perfectly effective). This information is used to 
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estimate the fractional decrease in failure intensity that will occur after corrective action is 
taken. 

To specify the effectiveness factors for the BD modes, choose Growth Data > Crow Extended > 
Effectiveness Factors or click the icon on the control panel. 

 

In the spreadsheet area of the window that appears, all BD modes are pre-populated in the BD 
Mode column. There are two ways to specify the effectiveness of delayed fixes for these 
modes. 

1. You can use the Effectiveness Factor column to set a different effectiveness factor (entered 
as a decimal) for each unique mode. 
 
or 

2. You can set one general factor that applies to all modes by clicking the Use Fixed 
Effectiveness Factor button on the toolbar and entering the fixed value in the input box, as 
shown next. Any values entered in the Effectiveness Factor column will then be ignored. 

 

The average of all effectiveness factors will appear in the status bar in the bottom left corner of 
the window. This value can be used as an input to the growth planning folio, and it can also be 
useful as a point of reference for estimating the effectiveness factor of a BD mode in a future 
analysis. 

You can enter any additional information about the effectiveness factors in the Comments 
column. The information in this column does not affect calculations. 

If you want to save a record of how the effectiveness factors are currently defined, you can click 
the Transfer to Folio icon . This will add to the folio a general spreadsheet that contains the 
effectiveness factors you've selected to use, as well as the comments you've entered. 

EVENT CODES FOR CROW EXTENDED 

For reliability growth data analysis only. 

The Event column that appears in the Multiple Systems with Event Codes data type allows you 
to specify the type of event that each row in the data sheet represents, so it can be handled 
appropriately in the calculations. The drop-down list in the column contains the following 
options: 
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• F - Failure is the default event type. Any event left unspecified will be treated as a normal 
failure. 

• I - Implemented Fix indicates the time when the fix for a specified BC failure mode was 
implemented. This type of event must be preceded by an observed instance of the BC 
mode in question. 

• P – Performance and Q - Quality indicate failures due to performance or quality issues. You 
can choose whether or not to consider these events in the analysis. 

• Events marked with X - Exclude will always be excluded from the analysis. This event code 
can be used to add comments or a timestamp within the data set. Note that an "X" can be 
placed in front of any existing event code or entered by itself. For example, "XF" indicates a 
failure in the data set that should be excluded from the analysis. 

The Event Code Options area on the Analysis page of the control panel allows you to choose 
whether performance (P) and quality (Q) failures will be included in the analysis. By default, 
both check boxes will be selected. 

 

CROW EXTENDED ANALYSIS RESULTS 

For reliability growth data analysis only. 

When you calculate a data sheet using the Crow Extended model, the analysis results will be 
displayed in the Results area on the control panel. The results that apply to all failure modes 
are displayed first. Use the scroll bar to see results that only apply to failure modes with a 
particular classification (i.e., A Modes = not fixed, BC Modes = fixed during observation period 
or BD Modes = fixed after observation period), as shown next. 
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When you use the Crow Extended model, the results may include the following: 

• Beta and Lambda are the two parameters of the Crow Extended model. 

• If beta < 1, the reliability improved during the observation period. If beta > 1, the 
reliability deteriorated. In addition: 

• If the data set does not include BC modes, Beta (hyp) will indicate that the model 
assumes beta = 1 (i.e., the reliability neither improved nor deteriorated). If this 
value is shown in red, then the 90% two-sided confidence bounds on beta do not 
include 1, which means this assumption may not be valid. 

• When working with times-to-failure data, Beta (Unb) indicates that the unbiased 
MLE estimate of the beta parameter was calculated. 
 
Note that the preference to display Beta (hyp) and/or calculate Beta (Unb) is set on 
the Calculations page of the Application Setup window for all new folios or in the 
Settings tab of the Items Properties window for existing folios. 

• If the data set includes BC failure modes, the Growth Rate will also be displayed, which is 
equal to 1 - beta. A positive value means the MTBF is improving, and larger values mean 
faster growth. 

• The metrics used to describe the reliability at the end of the observation period will vary 
depending on the data type you are working with. 
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• If you're working with times-to-failure or fielded data, the results will show the mean 
time between failures and the failure intensity at the end of the observation period. An 
option on the Calculations page of the Application Setup window (for all new folios) or 
in the Settings tab of the Items Properties window (for existing folios) determines 
whether you prefer to call these values "demonstrated" (DMTBF and DFI) or "achieved" 
(AMTBF and AFI). 

• If you're working with Discrete Mixed data, the results will show the demonstrated 
reliability (DRel) and demonstrated failure probability (DFP), which is 1 - DRel. 

• The Statistical Tests area shows whether the data set passed or failed the applicable 
goodness-of-fit tests that are performed automatically when you calculate the parameters. 

• For failure times and grouped failure times, this will be the Cramer-von Mises test 
(CVM). 

• For mixed data, it will be the chi-squared test (Ch-Sq). 

• For data from multiple systems, this area may also show the results from the common 
beta hypothesis (CBH) and/or the Laplace Trend test. 

See Statistical Tests for more information. 

• Depending on the data type, the Other area may display the Termination Time: 

• If you are using the Failure Times, Grouped Failure Times or Multiple Systems - Known 
Operating Times data types, you can use the Termination Time window to specify 
whether this is the time of the last observed failure, or a specific time that you enter. 

• For all other data types that can be analyzed with the Crow Extended model, the 
termination time is the end of the observation period. 

• Finally, if you are working in a data sheet that supports the Advanced Systems View, the 
following information will also be displayed. 

• The Other area will show the number of systems that were included in the analysis 
(e.g., 4/6 means four out of six systems were analyzed). You can omit a system from 
the analysis by clearing its check box on the Systems panel while the data sheet is in 
Advanced Systems View. 

• The control panel will show two sets of results: the larger table at the top shows the 
results for the equivalent system (which represents the combined operating hours of 
the systems), and the smaller table at the bottom show the results for the individual 
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system that is currently selected in the data sheet. The specific system name is shown 
in the heading of this table. 

Note: If the result of the analysis is associated with a published model, then the model's name 
will appear as a link at the bottom of the Results area. Click the link to view the model's 
properties. For details on how to publish the results as a model, see Publishing Models. 

Calculations and Plots 

For reliability growth data analysis only. 

Weibull++ includes a Quick Calculation Pad (QCP) for computing useful metrics, as well as 
multiple plots that allow you to visualize the results of your analyses. This topic describes the 
calculations and plots you can obtain from data sheets analyzed with the Crow Extended 
model. 

Note: When you analyze data from multiple systems, Weibull++ combines the data to create a 
single representative system (i.e., equivalent system, superposition system or cumulative 
timeline, depending on the data type). Any plots generated for the combined data set and 
subsequent analyses via the Quick Calculation Pad will be based on the resulting representative 
system. See Times-to-Failure Data from Multiple Systems and Fielded Data for more 
information about how the software combines the data for analysis. 

QCP Calculations 

You can open the Quick Calculation Pad (QCP) by choosing Growth Data > Analysis > Quick 
Calculation Pad or by clicking the icon on the control panel. 

 

To perform a calculation, select the appropriate option and enter any required inputs in the 
Input area, then click Calculate. For more detailed information about all the options available in 
the QCP, see Quick Calculation Pad (QCP). 

The Basic Calculations tab of the QCP includes the typical calculations for traditional reliability 
growth analysis (e.g., cumulative/instantaneous MTBF and expected number of failures). These 
calculations are applicable only when your data set includes BC failure modes. (See QCP 
Calculations and Plots for Traditional RGA.) 

On the Extended Calculations tab, the available calculations will vary depending on whether 
you’re analyzing failure times or mixed (discrete) data. For failure times, the calculated values 
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will be mean time between failures (MTBF) and failure intensity (FI). For mixed data, the values 
will be reliability and probability of failure. Most of these calculations are applicable only when 
your data set includes BD failure modes. 

• Three values can be calculated for either the mean time between failures (MTBF), failure 
intensity (FI). 

• The Demonstrated/Achieved values reflect the reliability at the end of the observation 
period, before any delayed fixes have been implemented. 

• The Projected values reflect the reliability that will be achieved after the delayed fixes 
have been implemented. 

• The Growth Potential values are the best values that could be achieved by applying the 
current reliability growth management strategy. In other words, this estimates the 
maximum reliability growth that you can expect if you continue to find new failure 
modes at the same rate and make the same types of decisions about which failure 
modes to fix. 

• Discovery Rate is the rate at which new BD failure modes are being discovered (i.e., the 
failure intensity of unseen BD modes) at a specified time. For example, if the discovery rate 
at 400 hours is 0.02, then 0.02 new BD modes are being discovered every hour 
(equivalently, 2 new BD modes are discovered every 100 hours). 

• MTBF BD Unseen is the mean time between failures due to unseen failure modes at a 
specified time (i.e., BD modes that did not appear during the observation period but are 
estimated from the analysis). 

• Number of Failures is the cumulative number of failures that are expected to occur by a 
specified time, based on the fitted model. 

• If the data set includes BC failure modes, then this value is calculated on the 
assumption that the reliability changed during the observation period. The option will 
thus be on the Basic Calculation tab with the other typical calculations for traditional 
reliability growth analysis (e.g., cumulative/instantaneous MTBF). 

• Otherwise, the calculation assumes that the reliability neither deteriorated nor 
improved during the observation period (i.e., beta = 1). 

• Expected Fleet Failures is the number of failures that are expected to occur for all systems 
by a specified time. This option is available only for fielded repairable data and for fielded 
fleet data. 
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Plots 

You can create plots by choosing Growth Data > Analysis > Plot or by clicking the icon on the 
control panel. 

 

This section describes the types of plots you can create for the Crow Extended model. The 
scaling, setup, exporting and confidence bounds settings are similar to the options available for 
all other reliability growth analysis plot sheets. (See Plots.) 

Once again, the available calculations will vary depending on whether you’re analyzing failure 
times or mixed (discrete) data. For failure times, the calculated values will be mean time 
between failures (MTBF) and failure intensity (FI). For mixed data, the values will be reliability 
and probability of failure. 

The plots described next apply to data sets that include at least some BD modes. Some of these 
plots apply specifically to data sets that consist entirely of A/BD modes (e.g., when you use the 
Crow Extended model to analyze fielded data), where the analysis assumes that there is no 
reliability growth during the observation. 

• Cumulative Number of Failures shows the total number of failures versus time. Data points 
on the plot represent the cumulative number of failures that have been reported by a given 
time (e.g., the second point marks the time at which the second failure was observed). The 
lines that can be included will vary depending on whether there are BC modes in the data 
set. 

• If both BC and BD modes are included, the plot can include the Expected Failures line, 
which serves as an empirical goodness-of-fit test for the Crow Extended model. It is 
fitted using the beta that was calculated from the data points. 

• If only A/BD modes are included, the plot can include the Assumed Parameters line 
based on the assumption that beta = 1 (i.e., no reliability growth was experienced 
during the observation period) and the Estimated Parameters line based on the beta 
calculated from the data points. You can then compare the two lines to evaluate 
whether the beta = 1 assumption is valid. 

• The [Value] vs. Time plots show how the value increases, decreases or remains constant 
over time. The points represent the actual failure times in the data set and the plot includes 
one line for the instantaneous value and one line for the cumulative value. These plots are 
available when your data set includes BC failure modes. 
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• Beta Bounds is available when only A/BD modes are included in the data set. This plot is 
used to assess the validity of the assumption that beta = 1. For example, if the two-sided 
95% confidence bounds on beta do not include 1, then you can (with 95% confidence) 
reject the hypothesis that beta = 1. The following lines can be shown in the plot: 

• The Beta Hypothesis line marks beta = 1. 

• The Beta Bounds lines show the confidence bounds for beta at five different confidence 
levels. You can configure these lines using the Beta Bounds window. 

• System Operation is available only for multiple systems analysis. It shows the failure times 
of each system in the data set, along with the timeline for their representative system (i.e., 
equivalent system, superposition system or cumulative timeline), which is used to evaluate 
all the failures and fixes that occurred during the observation period. Each type of event is 
color coded on the plot: failure (red circle), implemented fix (yellow triangle), performance 
failure (blue circle) and quality failure (green diamond). 
 
To learn more about how the failure times are combined, see the following topics: 

• For multiple systems times-to-failure data types, see Times-to-Failure Data from 
Multiple Systems. 

• For fielded data types, see Fielded Data. 

• The Growth Potential plots are applicable only when the data set includes BD failure 
modes. The plots can include these items: 

• The Demonstrated/Achieved point represents the value at the end of the test, before 
any delayed fixes have been implemented. 

• The Projected point represents the expected value after the delayed fixes have been 
implemented. 

• The Growth Potential line represents the best value that could be achieved by applying 
the current reliability growth management strategy (i.e., the portion of the system's 
failure intensity that will be addressed by design fixes). 

• If desired, you can use the Show/Hide Plot Items window to show the Instantaneous 
line, which shows how the value changes over time during the test. The instantaneous 
value is calculated over a small interval dt that begins at a given time. For example, an 
instantaneous MTBF of 5 hours at 100 hours duration means that, over the next small 
interval dt that begins at 100 hours, the average MTBF will be 5 hours. 
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• If desired, you can estimate the projected MTBF or failure intensity with a specified 
amount of further testing. This option is applicable only for developmental testing 
when BD failure modes are included in the data. To enable this option and specify a 
time greater than the termination time, click the [...] button. 

 

• The Final bar charts provide the same information as the Growth Potential plots, but using 
bars instead of lines.  

• Cumulative Number of BD Modes shows the total number of unique observed BD modes 
versus time. This plot can include these items: 

• Data points on the plot represent the cumulative number of BD modes that have been 
discovered by a given time. For example, the second point marks the time at which the 
second unique BD mode (e.g., BD2) was observed. 

• The Cumulative Number of BD Modes line is fitted to the data points and shows how 
the cumulative number of discovered BD modes changes with time. 

• MTBF BD Unseen and Discovery Rate show the rate at which new unique BD failure modes 
are being discovered at any given time. For example, if the MTBF for unseen BD modes is 
50 hours, then 2 more unique BD modes are expected to be observed over the next 100 
hours. The discovery rate is the failure intensity of the unseen BD modes (i.e., the inverse of 
the MTBF). In a successful reliability growth test, the MTBF for unseen BD modes will 
increase over time and the discovery rate will decrease. 

• The Individual Mode bar charts show two bars for each failure mode. Use the Plot Modes 
window to choose which failure modes to include in the chart. 

• The Before bars represents the value at the end of the test, before any delayed fixes 
have been implemented. 
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• The After bars are available only for BD modes and represents the value after the 
delayed fixes have been implemented. 

• The Failure Mode Strategy pie chart breaks down the overall failure intensity (FI) into six 
possible categories: 

• The Type A slice represents the FI that is due to failure modes that are ignored (i.e., no 
fixes will be implemented).  

• The Type BC - Seen slice represents the FI that is due to BC modes that were observed 
and for which fixes were implemented. 

• The Type BC - Unseen and Type BD - Unseen slices represents the FI that is due to BC 
and BD modes that were not observed but are estimated from the analysis. If they 
were observed (e.g., through future testing), fixes would be implemented. 

• The Type BD - Remained and Type BD - Removed slices represent the FI that is due to 
BD modes that were observed (i.e., they represent the FI due to seen BD modes). The 
Remained slice represents the portion of FI that is expected to stay in the system 
because the fixes are not 100% effective, while the Removed slice represents the FI 
that is expected to be eliminated. 

• Conditional Reliability/Unreliability is available only when you are using the Repairable 
data sheet. These plots show the reliability/unreliability versus system age or mission time. 

• If you choose to hold the system age constant, the plots will show the 
reliability/unreliability for different mission times. For example, assuming that the 
system has already operated for 100 hours, the plot can show the reliability for the 
next 10 hours, 20 hours, 30 hours, etc. 

• If you choose to hold mission time constant, the plots will show the 
reliability/unreliability for different system ages. For example, assuming that the 
mission will be 100 hours, the plot can show the reliability for a system that has already 
operated for 10 hours, 20 hours, 30 hours, etc. 

To specify which value will be held constant, click the [...] button on the control panel. In 
the window that appears, select the type of metric that will be held constant, as shown 
next. Then enter the constant value in the input field. 
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Tip: Weibull++ includes two additional plot utilities you can use across all types of data: the 
overlay plot, which allows you to compare different data sets or models; and the side-by-side 
plot, which allows you to display different plots of a single data set all in a single window for 
easy comparison. 

Plot Modes Window 

For reliability growth data analysis only. 

When you're viewing an Individual Mode MTBF/FI/Reliability plot, you can select which of the 
failure modes in the current data sheet will appear by choosing Plot > Options > Plot Modes or 
by right-clicking the plot and choosing the option from the shortcut menu. 

 

To show/hide all of the modes, click the column headings above the check boxes. 

To select all modes of a given classification (i.e., all A modes, all BC modes or all BD modes), 
choose the desired classification in the Select by Mode field at the bottom of the window. 

To export all the data shown in the window to an Excel file, click the Send to Excel button. 

Changing the Order of the Failure Modes 

The order of failure modes in this window reflects the order of modes in the plot. By default, 
the modes are shown in the same order that they occurred during the observational period. To 
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change the order, you can sort the modes by clicking the column heading that you wish to sort 
by. Click the heading again to reverse the order of the sort, and click it one more time to return 
the order to its original state. 

• Classification displays the mode classifications. 

• Mode displays the failure mode identifiers. 

• Effectiveness Factor displays the corresponding effectiveness factor for each BD mode, if 
any factor was specified. 

• Time to First Failure displays the first time at which the failure mode was observed. 

• Before MTBF displays the mode's MTBF at the end of the observation period and before 
any delayed fixes are implemented. 

• After MTBF displays the mode's MTBF after any delayed fixes are implemented. For BD 
modes, the "before" and "after" values will be different. For A and BC modes, they will be 
the same. 

• Change in MTBF displays the difference between the "before" and "after" values for BD 
modes. 

Beta Bounds Window 

For reliability growth data analysis only. 

When you're viewing the Beta Bounds plot, you can specify which confidence levels to show by 
choosing Plot > Options > Plot Beta Bounds or by right-clicking plot and choosing the option 
from the shortcut menu. Beta Bounds is available when only A/BD modes are included in the 
data set analyzed with the Crow Extended model. 

 

• In the window that appears, you can select to show up to five confidence levels. 

• For each beta bound line you have selected to show, enter the confidence level as a 
percentage in the input field. 

• You can click the color field to define the line color for the beta bound. To add a new color 
to the Custom tab, right-click one of the color boxes in the bottom two rows. 
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• The drop-down list in the lower left corner of the window allows you to select which type 
of confidence bounds (one-sided or two-sided) to display in the plot. For example, if you 
use 90% one-sided bounds, then the upper and lower one-sided 90% bounds will be used 
(which is the same as using two-sided 80% bounds). The following graphics illustrate the 
difference between one- and two-sided bounds. 

 

Crow Extended Examples 

For reliability growth data analysis only. 

The Crow Extended model can be used with data obtained from developmental testing or from 
systems operating in the field. The following topics provide examples of using the model with 
these different types of data: 
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• The developmental testing example uses data obtained from a single system during a 
developmental test. In this scenario, design fixes are applied during the test. Thus, 
reliability growth is expected to be observed during the test, and additional growth can be 
projected for fixes that will be applied after the test. 

• The operational testing example uses data obtained from two fielded repairable systems 
that were tested under customer use conditions. In this scenario, any repairs performed 
during the test are assumed to be minimal repairs (i.e., they do not improve the system 
reliability). All permanent design fixes are delayed until after the test. Thus, reliability 
growth is not expected to be observed during the test, but the model will project the 
growth due to fixes that will be applied after the test. 

Example Using the Crow Extended Model for Developmental Test Data 

For reliability growth data analysis only. 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_ReliabilityGrowth_RGA_Examples.rsgz20"). To access this database 
file, choose File > Help, click Open Examples Folder, then browse for the file in the Weibull sub-
folder. 

The name of the project is "Crow Extended - Failure Times," and the folio that contains the data 
is called "Corrective and Delayed Fixes." 

Failure times for a single system undergoing developmental testing were recorded. Some of the 
observed failure modes were not addressed, some were addressed during the test and some 
were delayed until after the test. The test ended at 400 hours, and the goal is to estimate the 
following values: 

• The MTBF demonstrated at the end of the test. 

• The MTBF that can be expected after the BD failure modes are addressed. 

• The maximum MTBF that can be achieved if all BD modes that exist in the system were 
discovered and fixed according to the current maintenance strategy (i.e., given the portion 
of the system's failure intensity that will be addressed by corrective actions). 

The data from the test are recorded in a Failure Times data sheet configured for cumulative 
failure times and with the Crow Extended model selected, as shown next. Modes classified as 
"A" are not addressed. "BC" modes are addressed during the test, and "BD" modes are 
addressed after the test. Numerical codes were used to identify the modes in the order in 
which they appeared (e.g., 100 and 200 are the first and second BC modes, 1 and 2 are the first 
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and second BD modes, etc.). To specify that the test is time terminated at 400 hours, click the 
(...) button on the control panel to open the Termination Time window. 

 

Next, enter an effectiveness factor for each BD mode to specify the effectiveness of each 
delayed fix (e.g., a factor of 0.7 means the fix will reduce the mode's failure intensity by 70%). 
To do this, choose Growth Data > Crow Extended > Effectiveness Factors or click the icon on 
the control panel. 

 

Enter the factors shown next. You can see that the average effectiveness factor for all the 
delayed fixes—displayed in the status bar—is 0.7250. Click OK to save the changes and close 
the window. 
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Click the Calculate icon on the folio's control panel to analyze the data. 

 

Note: This model uses the maximum likelihood estimation (MLE) method to calculate the 
parameters, which is known to produce a biased value for beta. This bias is more evident when 
working with small sample sizes. If the folio is not configured to remove this bias, you will be 
prompted to change the option in the Settings tab of the Item Properties window (Project > 
Current Item > Item Properties). To ensure the unbiased beta is always calculated for all new 
folios, use the RGA Growth Data Folios page of the Application Setup window to select the 
option. This example assumes that the unbiased beta is calculated. 

The results for all failure modes will appear as shown next. 
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The beta, lambda and growth rate (1 - beta) parameters are shown in the table. In addition to 
these values, the table provides this information: 

• The demonstrated/achieved mean time between failures (DMTBF/AMTBF) at the end of 
the test is 7.8471 hours. 

• The demonstrated/achieved failure intensity (DFI/AFI) at the end of the test is 0.1274. 

• The data is shown to have passed the Cramér-von Mises statistical test (CVM), which 
means we can accept the hypothesis that the failure times follow a non-homogeneous 
Poisson process (NHPP). This hypothesis is assumed by the Crow Extended model. 

Next, to view all the desired values in a plot, click the Plot icon on the control panel. 
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Then choose Growth Potential MTBF from the Plot Type drop-down list. The plot appears as 
shown next. 

 

The following information is shown in the plot: 

• The blue Demonstrated point shows the MTBF at the end of the test (before the BD failure 
modes are addressed) is 7.8471 hours. 

• The red Projected point shows that, after the BD failure modes are addressed, the MTBF is 
expected to be 11.3182 hours. 

• The green Growth Potential line shows that the maximum achievable MTBF given the 
current management strategy is 14.9957 hours. 
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Example Using the Crow Extended Model for Operational Test Data 

For reliability growth data analysis only. 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_ReliabilityGrowth_RGA_Examples.rsgz20"). To access this database 
file, choose File > Help, click Open Examples Folder, then browse for the file in the Weibull sub-
folder. 

The name of the project is "Crow Extended - Operational Test Data for Two Systems," and the 
folio that contains the data is called "Operational Test Data." 

Operational testing for two systems is performed towards the end of a new product 
development program. The systems are pilot builds and are subjected to representative 
customer use conditions during testing. When a system fails, a minimal repair is performed to 
bring the system back to operating condition (i.e., repairs are only enough to bring the system 
back to operation). Therefore, the configuration of each system during the test is assumed to 
not change and the reliability is assumed to neither deteriorate nor improve during the test 
(i.e., beta = 1). In addition, for each failure time, the associated failure mode is identified and 
classified. 

The analysts have the following goals: 

• Determine the MTBF that would be attained at the end of the basic reliability tasks if all the 
problem failure modes were uncovered in early design and corrected in accordance with 
the management strategy. 

• Create a plot to determine whether new BD modes are being discovered at a decreasing 
rate throughout the test. If so, this would indicate that the number of remaining unseen BD 
modes is decreasing with time. 

The data from the test are recorded in a Repairable data sheet with the Crow Extended model 
selected. Modes classified as "A" are not addressed, and "BD" modes are addressed after the 
test. Numerical codes were used to identify each specific failure mode. Some of the data for 
System 1 (selected in the Systems panel on the left) are shown next. 
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Before you can analyze the data, you must enter an effectiveness factor for each BD mode to 
specify the effectiveness of each corrective action that will be performed after the test (e.g., a 
factor of 0.7 means the corrective action will reduce the mode's failure intensity by 70%). To do 
this, choose Growth Data > Crow Extended > Effectiveness Factors or click the icon on the 
control panel. 

 

In the window that appears, select the Use Fixed Effectiveness Factors option and then enter 
0.6 in the input field. Click OK to save the factors and return to the folio. 

Click the Calculate icon on the folio's control panel to analyze the data. 

 

The results for all failure modes will appear as shown next. 
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• The Parameters values include estimated parameters for the fitted model and other 
calculations based on those parameters. 

• The beta hypothesis, Beta (hyp), is the assumed beta value for the analysis. If this value 
is shown in red, then the beta = 1 assumption may not be valid. 

• The calculated Beta and Lambda parameters are 0.8685 and 0.0676. The calculated 
beta value is used to determine whether the beta = 1 assumption is valid. (If 0.8685 
were significantly different from 1, then the assumption would be invalid.) 

• The demonstrated/achieved mean time between failures (DMTBF/AMTBF) at the end 
of the test is 33.7097 hours. 

• The demonstrated/achieved failure intensity (DFI/AFI) at the end of the test is 0.0297. 
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• The Statistical Tests values indicate whether the data meet various assumptions underlying 
the analysis. 

• The data is shown to have passed the Cramér-von Mises test (CVM), which means we 
can accept the hypothesis that the failure times follow a non-homogeneous Poisson 
process (NHPP). 

• The data also passed the Common Beta Hypothesis (CBH) test, which means the data 
sets from both systems can be assumed to have the same beta value. 

To calculate the maximum attainable MTBF based on the current management strategy, click 
the Quick Calculation Pad icon on the control panel. 

 

In the window that appears, select the MTBF option in the Projected area. After you click 
Calculate, the QCP will appear as shown next. 
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This result means the MTBF demonstrated at the end of the test (the DMTBF of 33.7097 shown 
on the control panel) is expected to increase to 42.3824 hours after all the BD modes have been 
fixed. 

The next goal is to create a plot to examine how the failure intensity due to unseen BD modes 
changes over time. To do this, click the Plot icon on the control panel. 

 

Then choose Discovery Rate from the Plot Type drop-down list and clear the Use Logarithmic 
Axes option on the control. The plot will appear as shown next. 

 

As unique BD modes are being discovered during the test, the unseen failure intensity 
decreases. This indicates that unique BD modes are being discovered at a decreasing rate, 
which is the desired outcome for a reliability growth test. 
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Continuous Evaluation Model 

For reliability growth data analysis only. 

While the Crow Extended model facilitates reliability growth projections, planning and analysis 
for a single test phase, the Crow Extended – Continuous Evaluation model is designed for 
analyzing data across up to 10 test phases. 

This model provides increased flexibility to analyze data from practical testing situations in 
which the failure modes may be addressed a) at the time of the failure, b) later in the same test 
phase, c) between test phases d) during a subsequent test phase or e) after the completion of 
all test phases. 

The continuous evaluation model is available in three Multi-Phase data types: Multi-Phase 
Failure Times, Multi-Phase Grouped Failure Times and Multi-Phase Mixed data. 

Two related features will be discussed in the next chapter. You can use the growth planning 
folio to develop the plan for a multi-phase test. Then after you’ve begun to enter the test data 
into a multi-phase data sheet, you can use a multi-phase plot to link the plan with your test 
data. The plot provides a visual way to track the progress toward meeting your MTBF goal and 
determine whether you will need to make adjustments in the remaining test. 

For an example that demonstrates how these three tools can be used together, see Example: 
Multi-Phase Test Planning and Analysis. 

EVENT CODES FOR MULTI-PHASE DATA 

For reliability growth data analysis only. 

The Event column that appears with all three Multi-Phase data types allows you to specify the 
type of event that each row in the data sheet represents, so it can be handled appropriately in 
the calculations. 

The drop-down list in the Event contains the following options: 

• F - Failure is the default event type. Any event left unspecified will be treated as a normal 
failure. 

• I - Implemented Fix indicates the time when the fix for a specified BD (delayed fix) failure 
mode was implemented. This type of event must be preceded by an observed instance of 
the BD mode in question. 
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• P - Performance and Q - Quality indicate failures due to performance or quality issues. You 
can choose whether or not to consider these events in the analysis. 

• Events marked with X - Exclude will always be excluded from the analysis. This event code 
can be used to add comments or a timestamp within the data set. Note that an "X" can be 
placed in front of any existing event code or entered by itself. For example, "XF" indicates a 
failure in the data set that should be excluded from the analysis. 

• AP - Analysis Point indicates a point at which the demonstrated, projected and growth 
potential MTBF/FI values can be displayed on a multi-phase plot in order to track the 
progress up to that point. 

• PH - End of Phase indicates the end of a test phase. 

The Event Code Options area on the Analysis page of the control panel allows you to choose 
whether performance (P) and quality (Q) failures will be included in the analysis. By default, 
both check boxes will be selected. 

 

FAILURE MODE CLASSIFICATIONS FOR MULTI-PHASE DATA 

For reliability growth data analysis only. 

Like the failure mode classifications for the Crow Extended model, analysis with the Crow 
Extended – Continuous Evaluation model will also require you to identify and classify the 
specific mode responsible for each failure. 

For both models, the Mode column records the specific failure mode identification, which is 
optional for A modes but required for all BC and BD modes. This can be entered as either a 
name or a numerical code (e.g., "seal leak," "1," "BD1," etc.). 

However, the classifications are applied a bit differently for the continuous evaluation model in 
order to support a wider array of possible management strategies. Specifically, for the 
Classification column in a multi-phase data sheet: 

• A indicates that no fix will be applied. Management chooses not to address the failure 
mode because of technical, financial or other reasons. (This is the same as in Crow 
Extended.) 
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• BC indicates that the fix will be applied at the time of failure and before the testing 
continues. (Whereas, in Crow Extended, BC indicates that the fix is applied at any time 
during the test.) 

• BD indicates that the fix will be delayed until a later time, either in the same test phase, 
between test phases, in a subsequent test phase or after all test phases are completed. 
(Whereas, in Crow Extended, BD indicates that the fix is delayed until after the completion 
of the test.) 

The increased flexibility for the treatment of BD failure modes means that the data set can also 
contain the exact times when the delayed fixes are implemented. Use the I – Implemented Fix 
event code to indicate the time of a delayed fix. The I event must have the exact same 
classification and mode as the prior failure event (F, P or Q). For example, the following picture 
shows a highly simplified data set where Mode 1 occurs at 100 hours but the fix is delayed. The 
first test phase ends at 200 hours and then the fix for Mode 1 is implemented during the 
second phase, at 250 hours of total test time. 

 

If the fix is implemented between test phases or after all test phases are completed, you will 
not be able to enter a specific I event time in the data sheet. In such cases, you will use the 
Effectiveness Factors window to indicate when the fix was (or will be) implemented, and supply 
the estimated effectiveness factor to be used during data analysis. (See Effectiveness Factors 
for Multi-Phase Data.) 

EFFECTIVENESS FACTORS FOR MULTI-PHASE DATA 

For reliability growth data analysis only. 

Like the effectiveness factors for the Crow Extended model, analysis with the Crow Extended – 
Continuous Evaluation model may also require you to specify the decrease in failure intensity 
for some delayed fixes. However, in the continuous evaluation model, a specified effectiveness 
factor is required only if the delayed fix time (I event) is not recorded in the data set. (If the fix 
time is provided, the model can use the data to evaluate the effectiveness of those fixes.) 

To specify the required effectiveness factors, choose Growth Data > Crow Extended > 
Effectiveness Factors or click the icon on the control panel. 
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In a multi-phase data sheet, the Effectiveness Factors window will display one or both of the 
following sheets. 

BD Modes Sheet 

The BD Modes sheet is always displayed and it shows a list of any BD failure modes in the 
current data set that do not have a specific fix time (I event) recorded in the data set. For each 
failure mode in the list: 

• Use the Implemented at End of Phase # column to specify when the delayed fix was (or 
will) be applied. 

• If the fix was applied after a specific test phase, select that phase from the drop-down 
list. For example, if the fix was applied between Phase 1 and Phase 2, select 1 – Phase 
1. 

• If the fix is not yet implemented, select Not Implemented. 

• Specify the effectiveness factor, entered as a decimal. For example, 0.6 indicates that 60% 
of the failure intensity will be removed after the fix is applied but 40% will remain. There 
are two options: 

• If you want to assign different effectiveness factors for different failure modes, use the 
Effectiveness Factor column to specify the factor for each mode. 

• If you prefer to assume the same effectiveness factor for all failure modes shown in the 
list, click the Use Fixed Effectiveness Factor button on the toolbar. This will disable the 
column in the spreadsheet and you can enter a single value in the input box next to the 
button, as shown next. 

 

Implemented Fixes Sheet 

If you have selected the Allow EF values for BD modes with implemented fixes option on the 
Calculations page of the Application Setup, the Implemented Fixes sheet will show a list of the 
BD failure modes in the current data set that do have a specific fix time (I event) recorded. This 
sheet is for your information only. Any inputs you provide here will not affect the calculations. 
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ANALYSIS RESULTS FOR MULTI-PHASE DATA 

For reliability growth data analysis only. 

When you calculate a multi-phase data sheet with the Crow Extended – Continuous Evaluation 
model, the following results will be displayed on the Main page of the control panel. By default, 
the Results area displays the results from all failure mode classifications first. Use the scroll bar 
to see results that only apply to failure modes with a particular classification (A, BC and BD), as 
shown next. 

 

• Beta, Lambda and p are the three parameters of the Crow Extended - Continuous 
Evaluation model. 

• If beta < 1, the reliability improved during the observation period. If beta > 1, the 
reliability deteriorated. In addition: 

• If the data set does not include any failure modes that were fixed before the end of 
the last test phase (such as BC modes), Beta (hyp) will indicate that the model 
assumes beta = 1 (i.e., the reliability neither improved nor deteriorated). If this 
value is shown in red, then the 90% two-sided confidence bounds on beta do not 
include 1, which means this assumption may not be valid. 

• When working with times-to-failure data, Beta (UnB) indicates that the unbiased 
MLE estimate of the beta parameter was calculated. 
 
Note that the preference to display Beta (hyp) and/or calculate Beta (UnB) is set on 
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the RGA Growth Data Folios page of the Application Setup window for all new 
folios or in the Settings tab of the Items Properties window for existing folios. 

• The p value is the probability that the corrective action for an observed BD failure 
mode will occur after the end of the last test phase. In other words, for every new BD 
mode that is discovered during the test, p is the probability that its corrective action 
will be delayed until after the test. 

• The Growth Rate is equal to 1 - beta. A positive value means the MTBF is improving, and 
larger values mean faster growth. 

• The metrics used to describe the reliability at the end of the observation period will vary 
depending on the data type. 

• For failure times and grouped failure times, the results will show the mean time 
between failures and the failure intensity at the end of the observation period. An 
option on the Calculations page of the Application Setup window (for all new folios) or 
in the Settings tab of the Items Properties window (for existing folios) determines 
whether you prefer to call these values "demonstrated" (DMTBF and DFI) or "achieved" 
(AMTBF and AFI). 

• For mixed data, the results will show the demonstrated reliability (DRel) and 
demonstrated failure probability (DFP), which is 1 - DRel. 

• The Statistical Tests area shows whether the data set passed or failed the applicable 
goodness-of-fit test that is performed automatically when you calculate the parameters. 
For failure times and grouped failure times, this will be the Cramer-von Mises test (CVM). 
For mixed data, it will be the chi-squared test (Ch-Sq). (See Statistical Tests.) 

• For failure times and grouped failure times data sheets, the Termination Time is the time of 
the last data point that is not excluded from the analysis. If this is the end of a phase (PH) or 
an analysis point (AP), the folio performs a time-terminated calculation. If this is a failure 
time (F, P or Q), it will be failure-terminated. This is not applicable for mixed data sheets. 

Note: If the result of the analysis is associated with a published model, then the model's name 
will appear as a link at the bottom of the Results area. Click the link to view the model's 
properties. For details on how to publish the results as a model, see Publishing Models. 
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QCP CALCULATIONS AND PLOTS FOR MULTI-PHASE DATA 

For reliability growth data analysis only. 

Weibull++ includes a Quick Calculation Pad (QCP) for computing useful metrics, as well as 
multiple plots that allow you to visualize the results of your analyses. This topic describes the 
calculations and plots you can obtain from multi-phase data sheets analyzed with the Crow 
Extended – Continuous Evaluation model. 

QCP Calculations 

You can open the Quick Calculation Pad (QCP) by choosing Growth Data > Analysis > Quick 
Calculation Pad or by clicking the icon on the control panel. 

 

To perform a calculation, select the appropriate option and enter any required inputs in the 
Input area, then click Calculate. For more detailed information about all the options available in 
the QCP, see Quick Calculation Pad (QCP). 

The Basic Calculations tab of the QCP includes the typical calculations for traditional reliability 
growth analysis (e.g., cumulative/instantaneous MTBF and expected number of failures). These 
calculations are applicable only when your data set includes failure modes that were fixed 
before the end of the last test phase. (See QCP Calculations and Plots for Traditional RGA.) 

On the Multi-Phase Calculations tab, the available calculations will vary depending on whether 
you’re analyzing failure times or mixed (discrete) data. For failure times, the calculated values 
will be mean time between failures (MTBF) and failure intensity (FI). For mixed data, the values 
will be reliability and probability of failure. Most of these calculations are applicable only when 
your data set includes BD failure modes. The projected and growth potential calculations apply 
only when the data set includes BD modes that will be fixed after the end of the last test phase 
(as specified in the Effectiveness Factors window). 

• The Demonstrated values reflect the reliability at the end of the last test phase, before any 
delayed fixes are implemented. 

• The Nominal values represent the best case scenario in which a fix is applied to every BD 
failure mode, even if the fix has not yet been implemented or planned. These calculations 
consider the implemented fix times (I events) and all of the effectiveness factors (even if 
the fix is marked "Not Implemented"). 

• Nominal Projected are the expected values after the delayed fixes for all seen BD 
failure modes. 
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• Nominal Growth Potential are the best possible values that could be achieved if all 
delayed fixes are implemented for all seen and unseen BD failure modes. 

• The Actual values take into account which delayed fixes have actually been implemented in 
the current management strategy. These calculations consider the implemented fix times (I 
events) and the effectiveness factors for the fixes that were marked to be implemented 
after a specific test phase. However, any BD failure mode that is marked as "Not 
Implemented" in the Effectiveness Factors window is given an EF=0. 

• Actual Projected are the expected values after the delayed fixes that are actually 
implemented for seen BD failure modes. 

• Actual Growth Potential are the best possible values that could be attainable by 
applying the current management strategy for both seen and unseen BD failure modes. 

• Discovery Rate is the rate at which new BD failure modes are being discovered (i.e., the 
failure intensity of unseen BD modes) at a specified time. For example, if the discovery rate 
at 400 hours is 0.02, then 0.02 new BD modes are being discovered every hour 
(equivalently, 2 new BD modes are discovered every 100 hours). 

• MTBF BD Unseen is the mean time between failures due to unseen failure modes at a 
specified time (i.e., BD modes that did not appear during the observation period but are 
estimated from the analysis). 

• Number of Failures is the cumulative number of failures that are expected to occur by a 
specified time, based on the fitted model. 

• If the data set includes some failure modes that were fixed before the end of the last 
test phase, then this value is calculated on the assumption that the reliability changed 
during the test. The option will thus be on the Basic Calculations tab with the other 
typical calculations for traditional reliability growth analysis (e.g., 
cumulative/instantaneous MTBF). 

• Otherwise, the calculation assumes that the reliability neither deteriorated nor 
improved during the observation period (i.e., beta = 1). 

Plots 

You can create plots by choosing Growth Data > Analysis > Plot or by clicking the icon on the 
control panel. 
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This section describes the types of plots you can create for the Crow Extended – Continuous 
Evaluation model. The scaling, setup, exporting and confidence bounds settings are similar to 
the options available for all other reliability growth analysis plot sheets. (See Plots.) 

Once again, the available calculations will vary depending on whether you’re analyzing failure 
times or mixed (discrete) data. For failure times, the calculated values will be mean time 
between failures (MTBF) and failure intensity (FI). For mixed data, the values will be reliability 
and probability of failure. 

Also note that all projected and growth potential values displayed in the plots are based on the 
"actual" (not "nominal") calculations. 

• Cumulative Number of Failures shows the total number of failures versus time. Data points 
on the plot represent the cumulative number of failures that have been reported by a given 
time (e.g., the second point marks the time at which the second failure was observed). The 
lines that can be included will vary depending on whether there the data set includes 
failures modes that will be fixed before the end of the last test phase. 

• If some failure modes will be fixed before the end of the last test phase, the plot can 
include the Expected Failures line, which serves as an empirical goodness-of-fit test for 
the Crow Extended model. It is fitted using the beta that was calculated from the data 
points. 

• If no failure modes will be fixed before the end of the last test phase, the plot can 
include the Assumed Parameters line based on the assumption that beta = 1 (i.e., no 
reliability growth was experienced during the observation period) and the Estimated 
Parameters line based on the beta calculated from the data points. You can then 
compare the two lines to evaluate whether the beta = 1 assumption is valid. 

• The [Value] vs. Time plots show how the value increases, decreases or remains constant 
over time. The points represent the actual failure times in the data set and the plot includes 
one line for the instantaneous value and one line for the cumulative value. These plots are 
available when your data set includes failure modes that were fixed before the end of the 
last test phase. 

• The Growth Potential plots are applicable only when the data set includes failure modes 
that will be fixed after the end of the last test phase (as specified in the Effectiveness 
Factors window). The plots can include these items: 

• The Demonstrated/Achieved point represents the value at the end of the test, before 
any delayed fixes have been implemented. 



Chapter 9: Reliability Growth Analysis Folios 

656 https://www.reliasoft.com/weibull 

 

• The Projected point represents the expected value after the delayed fixes have been 
implemented. 

• The Growth Potential line represents the best value that could be achieved by applying 
the current reliability growth management strategy (i.e., the portion of the system's 
failure intensity that will be addressed by design fixes). 

• If desired, you can use the Show/Hide Plot Items window to show the Instantaneous 
line, which shows how the value changes over time during the test. The instantaneous 
value is calculated over a small interval dt that begins at a given time. For example, an 
instantaneous MTBF of 5 hours at 100 hours duration means that, over the next small 
interval dt that begins at 100 hours, the average MTBF will be 5 hours. 

• If desired, you can estimate the projected MTBF or failure intensity with a specified 
amount of further testing. This option is applicable only for developmental testing 
when BD failure modes are included in the data. To enable this option and specify a 
time greater than the termination time, click the [...] button. 

 

• The Final bar charts provide the same information as the Growth Potential plots, but using 
bars instead of lines.  

• Cumulative Number of BD Modes shows the total number of unique observed BD modes 
versus time. This plot can include these items: 

• Data points on the plot represent the cumulative number of BD modes that have been 
discovered by a given time. For example, the second point marks the time at which the 
second unique BD mode (e.g., BD2) was observed. 

• The Cumulative Number of BD Modes line is fitted to the data points and shows how 
the cumulative number of discovered BD modes changes with time. 
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• MTBF BD Unseen and Discovery Rate show the rate at which new unique BD failure modes 
are being discovered at any given time. For example, if the MTBF for unseen BD modes is 
50 hours, then 2 more unique BD modes are expected to be observed over the next 100 
hours. The discovery rate is the failure intensity of the unseen BD modes (i.e., the inverse of 
the MTBF). In a successful reliability growth test, the MTBF for unseen BD modes will 
increase over time and the discovery rate will decrease. 

• The Individual Mode bar charts show two bars for each failure mode. Use the Plot Modes 
window to choose which failure modes to include in the chart. 

• The Before bars represents the value at the end of the test, before any delayed fixes 
have been implemented. 

• The After bars are available only for BD modes and represents the value after the 
delayed fixes have been implemented. 

• The Failure Mode Strategy pie chart breaks down the overall failure intensity (FI) into six 
possible categories: 

• The Type A slice represents the FI that is due to failure modes that are ignored (i.e., no 
fixes will be implemented).  

• The Type BC - Seen slice represents the FI that is due to BC modes that were observed 
and for which fixes were implemented. 

• The Type BC - Unseen and Type BD - Unseen slices represents the FI that is due to BC 
and BD modes that were not observed but are estimated from the analysis. If they 
were observed (e.g., through future testing), fixes would be implemented. 

• The Type BD - Remained and Type BD - Removed slices represent the FI that is due to 
BD modes that were observed (i.e., they represent the FI due to seen BD modes). The 
Remained slice represents the portion of FI that is expected to stay in the system 
because the fixes are not 100% effective, while the Removed slice represents the FI 
that is expected to be eliminated. 

Tip: Weibull++ includes two additional plot utilities you can use across all types of data: the 
overlay plot, which allows you to compare different data sets or models; and the side-by-side 
plot, which allows you to display different plots of a single data set all in a single window for 
easy comparison. 
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EVENT REPORTS 

For reliability growth data analysis only. 

Once you have calculated the parameters for the Multiple Systems with Event Codes data type 
or any multi-phase data type, you can choose Growth Data > Analysis > Event Report to view a 
special report in the Results window. The Event Report can consist of up to five tabs, depending 
on the types of events defined in the data set. The tabs are described next. 

Mode Summary Tab 

The Mode Summary tab is always displayed and it provides the following information for each 
unique failure mode in the data sheet: 

• Mode and Classification: The unique identifier and classification (A, BC or BD) for the 
failure mode. 

• First Failure: The time of the first failure due to that mode. 

• Total Failures: The total number of failures due to that mode. 

For the Multiple Systems with Event Codes data type, there is one additional column. 

• Effectiveness Factor: The effectiveness factor assigned for each BD failure mode. 

For multi-phase data types, there are three additional columns. These columns are applicable 
only for BD failure modes that do not have an implemented fix time (I event) in the data set. For 
these failure modes, the Effectiveness Factors window records the phase after which the fix will 
be applied, if any, along with the estimated effectiveness factor. Therefore, the report displays: 

• Nominal EF: The effectiveness factor that will be used for "nominal" calculations (e.g., 
nominal projected MTBF, etc.). These calculations represent the best case scenario in which 
a fix is applied to every BD failure mode, even if the fix is marked "Not Implemented." 

• Phase Fixed: A number indicates the phase after which the fix was applied (e.g., the 
number 2 indicates that the fix was applied after the end of Phase 2 but before the start of 
Phase 3). "Not Implemented" indicates that the fix has not been applied. 

• Actual EF: The effectiveness factor that will be used for "actual" calculations (e.g., actual 
projected MTBF, etc.). These calculations take into account which delayed fixes have 
actually been implemented in the current management strategy. Therefore, if the fix is 
"Not Implemented," the actual EF will be zero. 
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Implemented Fixes Tab 

The Implemented Fixes tab is present only if the Multiple Systems with Event Codes data set 
contains BC failure modes, or if the multi-phase data set contains BD failure modes that have an 
implemented fix time (I event) in the data set. For each applicable failure mode, this tab 
provides the following information: 

• Mode and Classification: The unique identifier and classification (A, BC or BD) for the 
failure mode. 

• First Failure: The time of the first failure due to that mode. 

• Total Failures: The total number of failures due to that mode. 

• Before Fix Failures and After Fix Failures: The number of failures due to the mode that 
occurred before and after the fix was implemented. 

• Before Fix Runtime and After Fix Runtime: The amount of operating time before and after 
the fix was implemented. In a Multiple Systems with Event Codes data sheet, this is the sum 
of the operating times for all affected systems. 

For the Multiple Systems with Event Codes data type, there is one additional column: 

• Systems With Fixes: The number of systems for which the fix was implemented. 

For multi-phase data types, if the Allow EF values for BD modes with implemented fixes option 
is selected on the on the Calculations page of the Application Setup, there are two additional 
columns: 

• Effectiveness Factor and Comments display any additional information that you have 
entered on the Implemented Fixes tab in the Effectiveness Factors window. This 
information is for your information only and is not considered in the data analysis. 

Quality Events and Performance Events Tabs 

The Quality Events tab and the Performance Events tabs are present only if the data set 
contains events of these types. These tabs provide summaries for the events that have been 
marked with the Q and P event types. 

Mode Fix List Tab 

The Mode Fix List tab is present only if fixes have been implemented to Multiple Systems with 
Event Codes data. The tab provides a summary of all systems that have a fix recorded for each 
failure mode. 
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TEST FOR FIX EFFECTIVENESS 

For reliability growth data analysis only. 

The Test for Fix Effectiveness window allows you to apply Dr. Crow's "Statistical Test for 
Effectiveness of Corrective Actions" test for an applicable data set. This test helps you to 
determine whether the fixes applied during or at the end of a phase have effectively reduced a 
system's failure intensity. 

The utility is available for: 

• Any of the multi-phase data types (as long as the parameters have been calculated and the 
data set contains at least two phases). 

• Any data sheet that has been analyzed with the Change of Slope calculation option. 

To access the window, choose Growth Data > Crow Extended > Test for Fix Effectiveness. 

 

If you are working with a multi-phase data sheet, use the Phase 1 and Phase 2 drop-down lists 
to choose the two phases you want to compare. If you are working with a Change of Slope 
analysis, Segment 1 is the data before the specified Break Point, while Segment 2 is the data 
after. 

Specify the Significance Level (a decimal between 0 and 1) and click Test. The utility gives two 
results: 

• The first result compares the average failure intensities of the two phases (or segments). If 
the average failure intensity during the second is less than during the first (at the specified 
significance level), the utility displays "Passed." If not, it displays "Failed." 

• The second result compares the average failure intensity during the second phase (or 
segment) with the instantaneous failure intensity at the end of the first. If the average 
failure intensity during the second is less than the instantaneous failure intensity at the end 
of the first (at the specified significance level), the utility displays "Passed." If not, it displays 
"Failed." 

Click the Report button to see a more detailed summary of the analysis in the Results window. 
This includes the failure intensities that are calculated for both phases. 
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Growth Planning Folio and Multi-Phase Plot 

Growth Planning Folio 

For reliability growth data analysis only. 

Weibull++'s growth planning folio helps you to plan a single- or multi-phase reliability growth 
test program that is designed to achieve a specific MTBF or reliability goal. For the most 
advanced functionality, this typically uses the Crow Extended growth planning model. Starting 
in Version 2019, the MIL-HDBK 189 planning model is also available in the Continuous Growth 
Planning folio, allowing you to compare the results between the two models. 

Creating a Growth Testing Plan 

To create a growth planning folio, right-click the Test and Planning folder in the current project 
explorer and choose either Add Continuous Growth Planning (if working with times-to-failure 
data) or Add Discrete Growth Planning (if working with one-shot devices). 

Important: Starting in Version 2019, when you add a Continuous Growth Planning folio, you 
need to select the model that you will be using on the control panel. Your choice will determine 
the required inputs. 

In the data sheet of the folio: 

1. Do you know how the test time will be accumulated across each test phase? Choose Yes if 
you want to specify the end time (and other details) for each phase of testing. Choose No if 
you want to create a plan for a single test phase with no specific end time. 

2. Planned test phases is available at the bottom of the data sheet only if you chose Yes to 
the question in step 1 above. Specify the number of phases and then define each phase: 

• Phase Name can be any alphanumeric identifier, up to 50 characters. 

• Cumulative Time is the amount of cumulative test time at the end of each phase. 
Because this represents cumulative test time across all test phases, the number must 
be higher for each subsequent phase. 

• Average Fix Delay is the amount of test time from when a failure mode is discovered 
until a fix is likely to be implemented. (Not available when using the MIL-HDBK 189 
model.) 
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As an example, the following picture shows the inputs for a multi-phase test with 5 test 
phases that last 1,000 hours each. In the first phase, the planners estimate that delayed 
fixes (for BD failure modes) will, on average, take 500 hours each. The fix time is expected 
to increase in later phases. 

 

If there are a lot of test phases and/or if you have this information available in an external 
data file, you can click the Edit Phase Data icon   to open a more flexible spreadsheet for 
entering/editing these details. The Import icon  at the bottom of this window allows you 
to import data from an Excel spreadsheet (*.xls or *.xlsx). Note that if you import from 
Excel, it will overwrite anything that you may have already entered (i.e., the data from Excel 
replaces entries rather than being appended). 

3. Each growth planning model considers a set of variables; you will select to solve for one of 
them (i.e., Which value would you like to calculate?) based on your inputs for the rest of 
them (i.e., Assumed inputs for the reliability growth test plan.) 
 
For the Crow-Extended model, the following variables are considered. (Note that the 
calculations in the continuous growth planning folio are in terms of MTBF, while the 
calculations in the discrete growth planning folio are in terms of reliability.) 

• Initial MTBF/Reliability is the value before the test program begins. It can be 
determined by some initial testing or through historical information, engineering 
expertise and/or reliability predictions. 

• Goal MTBF/Reliability is the requirement that you need to achieve by the end of the 
test program. 

• Growth Potential Design Margin estimates the amount by which the growth potential 
value (i.e., the value that would be achieved if you continued testing until all failure 
modes are observed and corrected according to the current maintenance strategy) 
exceeds the goal. This value provides a "safety factor" to ensure that the requirement is 
met. A higher GP design margin means there's a smaller risk that the reliability 
observed in the field will not meet the requirement, but it also means a more rigorous 
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reliability growth program will be required. Typically, the GP design margin is between 
1.2 and 1.5. 

• Average EF (where EF = effectiveness factor) estimates the fractional decrease in 
failure intensity you expect to achieve by implementing design fixes. Typically, about 
30% of the failure intensity for the failure modes that are addressed will remain in the 
system after implementing all of the design fixes; therefore, in many reliability growth 
programs, the average effectiveness factor is 0.7. The value must be greater than 0, 
and less than 1. 

• Management Strategy Ratio determines the percentage of the unique failure modes 
discovered during the test that will be fixed. This is an important variable in reliability 
growth planning because the management strategy can be changed to address a larger 
percentage of the discovered failure modes if the goal cannot be reached with the 
current strategy. Generally, the management strategy is recommended to be above 
90%. 

• Discovery Beta is the rate at which new, unique B failure modes are being discovered 
during testing. These are the failure modes that will be fixed. In growth planning, it is 
assumed that most failures will be identified early on, and that new failure modes will 
be discovered at a decreasing rate as the test proceeds. Therefore, this value must be 
greater than 0 and less than 1. This input is always required; you cannot solve for the 
discovery beta. 

• Average Fix Delay is used only for single-phase plans with no specific end time (i.e., you 
chose No to the question in step 1 above). This value is the amount of test time from 
when a failure mode is discovered until a fix is likely to be implemented. If this value is 
considered, it is required as an input; you cannot solve for the average fix delay. 

For the MIL-HDBK 189 model, the following variables are considered: 

• Average MTBF over the First Test Phase is the value before the test program begins. It 
can be determined by some initial testing or through historical information, 
engineering expertise and/or reliability predictions. 

• Growth Parameter is how fast the rate is expected to grow. 

• Final MTBF is the requirement that you need to achieve by the end of the test 
program. 

• Test Time for First Phase is used only for single phase plans with no specific end time 
(i.e., you chose No to the question in step 1 above). This value is the time it will take for 
the first phase to be completed. 
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• Total Test Time is used only for single phase plans with no specific end time (i.e., you 
chose No to the question in step 1 above). This value is the total time the test will take. 

Analysis Results 

Once you have entered all of the required inputs, calculate the results by choosing Test and 
Planning > Analysis > Calculate or clicking the icon in the control panel. 

 

The result shows the estimated value for the metric you have selected to solve and other 
results that may be used to evaluate the test plan. You can then use the Plot sheet to visualize 
the results expected if you implement the test plan, and the QCP to calculate a variety of 
metrics based on the test plan. 

• Additional results in continuous growth planning folios when using the Crow Extended 
model: 

• Time at which growth begins is the estimated time when the first B failure mode (i.e., 
the first failure mode that will be fixed) is expected to occur. Reliability growth is 
expected to begin after this time. 

• Final MTBF is the expected MTBF at the end of the test, taking into account the 
average fix delay. 

• Time to reach goal is the test time at which the goal MTBF is expected to be reached. 
The Actual value takes into account the average fix delay, and the Nominal value does 
not. If the current test plan will not meet the goal, this field displays "Goal not met." 

• Additional results in discrete growth planning folios: 

• Trial at which growth begins is the estimated number of trials when the first B failure 
mode (i.e., the first failure mode that will be fixed) is expected to occur. Reliability 
growth is expected to begin after this time. 

• Initial MTrBF (where MTrBF = mean trials before failure) is the initial estimated system 
MTrBF. 

• Growth Potential MTrBF is the expected MTrBF that could be reached if you continued 
testing until all B failure modes are observed and fixed according to the management 
strategy. 

• Final MTrBF is the expected MTrBF at the end of the test. 
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• Num. trials to reach goal is the number of trials at which the goal reliability is expected 
to be reached. The Actual value takes into account the average fix delay, and the 
Nominal value does not. If the current test plan will not meet the goal, this field 
displays "Goal not met." 

Growth Planning Folio Plots 

For reliability growth data analysis only. 

The Plot sheet in the growth planning folio shows a variety of plots that display the results that 
are expected if you implement the plan. To view the growth planning folio plots, choose Test 
and Planning > Analysis > Plot or click the icon on the control panel. 

 

The following is a description of the different types of plots you can create for growth planning. 
For general information on working with plots, see Plot Utilities. 

Plot Types 

The following plots show the expected value of the specified metric across all planned test 
phases: 

• MTBF vs. Time (available only for the continuous growth planning folio) 

• Reliability vs. Time (available only for the discrete growth planning folio) 

• MTrBF vs. Time (available only for the discrete growth planning folio) 

• Failure Intensity vs. Time 

For the plots above, you can use the check boxes in the control panel to select which of the 
following elements will be displayed in the plot: 

For the Crow Extended model, the options are: 

• Nominal Idealized and Actual Idealized lines (also called idealized growth curves) show 
the overall characteristic pattern for the reliability growth across all phases of testing. 
The nominal curve is the best case scenario, which assumes that the average fix delay is 
zero. The actual curve takes into account the average fix delay. If fixes are not 
incorporated instantaneously, the actual line will show slower growth compared to the 
nominal line. 
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• Planned Growth lines display information for each phase of testing (and thus are 
available only when you have provided information for each phase). These horizontal 
lines mark the time when each phase will begin and end, while the vertical position of 
each line shows the expected value of the metric at the beginning of the phase. You 
can point to the line to see the specific values. (Note that in the continuous growth 
planning folio, you can show confidence bounds on the planned growth lines, but only 
when you have at least 3 test phases specified on the folio's data sheet.) 

 

• The Termination Line shows the end time of the final test phase. 

• The Goal line shows the target value that you hope to achieve by the last phase of 
testing. 

For the MIL-HDBK 189 model, the options are: 

• The Idealized Growth Curve line shows the overall characteristic pattern for the 
reliability growth across all phases of testing. 

• If the test phase settings are specified, the Average per Test Phase line shows either 
the average MTBF for each test phase on the MTBF vs. Time plot or the average failure 
rate for each test phase on the Failure Intensity vs, Time plot. 

For the Crow Extended model, the following plots are also available: 

• Cumulative Number of B Modes shows the cumulative number of observed unique B 
failure modes versus time. These are failure modes that have been discovered and will be 
fixed. 

• MTBF B Unseen shows the mean time between failures due to B failure modes that have 
not yet appeared in testing. These are failure modes that are anticipated based on the 
analysis and will be fixed when/if they are discovered. 

• Discovery Rate shows the rate at which unique B failure modes are being discovered. In 
other words, it is the failure intensity of the unseen B failure modes. 
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Growth Planning Folio QCP 

For reliability growth data analysis only. 

After you have used the data sheet in the growth planning folio to create a reliability growth 
program test plan, you can use the Quick Calculation Pad (QCP) to calculate a variety of results 
that are expected if you implement the plan. 

To open the QCP for growth planning folio calculations, choose Test and Planning > Analysis > 
Quick Calculation Pad or click the icon on the control panel. 

 

To perform a calculation, click one of the buttons on the left side of the window and enter any 
required inputs in the Input area, then click Calculate. For more detailed information about all 
the options available in the QCP, see Quick Calculation Pad (QCP). 

Continuous Growth Planning Folio 

For the Crow Extended model, the options are: 

• Nominal MTBF and Nominal Failure Intensity calculations reflect the best case scenario. 
They assume that the average fix delay is zero. 

• Actual MTBF and Actual Failure Intensity take into account the average fix delay. If fixes 
are not incorporated instantaneously, the actual value will show slower growth compared 
to the nominal value. 

• Planned MTBF and Planned Failure Intensity return the expected MTBF or failure intensity 
at the beginning of each test phase. To perform this calculation, you must select the phase 
from a drop-down list. Note that, unlike the other calculations, you can calculate 
confidence bounds on the planned growth values, but only when you have at least 3 test 
phases specified on the folio's data sheet. 

• Discovery Rate is the rate at which new BD failure modes are being discovered at the 
specified time. 

• MTBF B Unseen is the mean time between failures due to B failure modes that have not yet 
appeared in testing but are estimated from the analysis. These are failure modes that 
would be fixed if they were discovered. 

• Cum. Num. B Modes is the cumulative number of B failure modes that are expected to 
have been seen during testing by the specified time (i.e., failure modes that will be fixed). 
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For the MIL-HDBK 189 model, the options are: 

• Idealized Growth MTBF and Idealized Growth Failure Intensity calculations reflect the best 
case scenario. 

• Average MTBF and Average Failure Intensity return the expected MTBF or failure intensity 
at the beginning of each test phase. To perform this calculation, you must select the phase 
from a drop-down list. These options are available only if the accumulated test time is 
known. 

Discrete Growth Planning Folio 

• Nominal Reliability, Nominal MTrBF and Nominal Failure Intensity calculations reflect the 
best case scenario. They assume that the average fix delay is zero. 

• Actual Reliability, Actual MTrBF and Actual Failure Intensity take into account the average 
fix delay. 

• Planned Reliability, Planned MTrBF and Planned Failure Intensity return the expected 
value of the metric at the beginning of each test phase. To perform this calculation, you 
must select the phase from a drop-down list. 

• Discovery Rate is the rate at which new B failure modes are being discovered at the 
specified time. 

• MTBF B Unseen is the mean time between failures due to B failure modes that have not yet 
appeared in testing but are estimated from the analysis. These are failure modes that 
would be fixed if they were discovered. 

• Cum. Num. B Modes is the cumulative number of B failure modes that are expected to 
have been seen during testing by the specified time (i.e., failure modes that will be fixed). 

Multi-Phase Plot 

For reliability growth data analysis only. 

The multi-phase plot displays key analysis results from data analyzed with the Crow Extended 
model or Crow Extended – Continuous Evaluation model so you can see how the demonstrated, 
projected and growth potential MTBF or failure intensity changes across multiple analysis 
points and/or test phases. 

If desired, you can also link the plot to a growth planning folio so you can see how the actual 
test results compare to the plan, and determine if it’s necessary to make adjustments in 
subsequent test phases in order to meet your reliability growth goals. 
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To create a multi-phase plot, choose Home > Insert > Multi-Phase Plot. 

 

Multi-Phase Plot Wizard 

For reliability growth data analysis only. 

When you create a new multi-phase plot or click the Multi-Phase Plot Setup button in an 
existing plot, the Multi-Phase Plot Wizard allows you to specify the data source(s) for the plot. 
The test data displayed in the plot can come from: 

• One Multi-Phase data sheet that includes all of the analysis points and phase data defined 
together in a single data source. [See details below.] 

or 

• Multiple Data Sheets that each contain the data from one particular analysis point or 
phase. This requires you to assign a specific data sheet to each analysis point and phase you 
want to display in the plot. [See details below.] 

After you have defined the test data source(s), the wizard also allows you to select an 
applicable growth planning folio, if desired. Use this option if you want to use the plot to 
compare the test results against what was expected based on the reliability growth program 
plan. 

 

Click Finish when you’re ready to save the changes and create or return to the Multi-Phase Plot 
window. 

Option 1: Getting the Test Data from One Multi-Phase Data Sheet 

If you select Multi-Phase and proceed to the next page in the wizard, you will be prompted to 
select a single analyzed multi-phase data sheet that contains all of the test phases and analysis 
points already defined in a single data sheet. 
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Option 2: Getting the Test Data from Multiple Data Sheets 

If you select Multiple Data Sheets and proceed to the next page in the wizard, you will be 
prompted to select the separate data sheets that contain the data for each analysis point and 
phase you wish to display in the plot. The data sheets must be calculated with either the Crow 
Extended or Crow Extended – Continuous Evaluation model, and each sheet can be used only 
once in the same plot. 

One Sheet per Phase 

If you don’t wish to include analysis points in the plot, you can simply specify the number of 
phases at the top of the window and then select one data sheet on the tab for each phase. 

 

Separate Sheets for Analysis Points 

If you want to include analysis points, there must be a separate data sheet that contains the 
data for each analysis point, in addition to the data sheets that contains all of the data for each 
entire test phase. 

For example, in the following picture, the data from the first week of testing were recorded and 
analyzed in four separate data sheets (in which each sheet contains all of the data up to a 
specific point in time). 
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In other words: 

• "Monday (Wk1)" contains the data from Sunday and Monday. 

• "Wednesday (Wk1)" contains all of the data from Monday's data sheet, plus the additional 
data collected on Tuesday and Wednesday. 

• "Friday (Wk1)" contains all of the data from Wednesday's data sheet, plus the additional 
data collected on Thursday and Friday. 

• "Full (Wk1)" contains all of the data from Friday's data sheet, plus the additional data 
collected on Saturday. This data sheet contains all of the data from phase 1. 

To select the data sheets for the analysis points, click the (...) button in the Analysis Points bar. 
In the Select Data Sheets window that opens, select the check box for all the data sheets that 
contains analysis point data for the current phase. 

To remove a data sheet from the Analysis points list, you can return to the Select Data Sheets 
window and clear the check box, or simply double-click the data sheet name in the list. 

Multi-Phase Plot Control Panel 

For reliability growth data analysis only. 

In the Multi-Phase Plot window’s control panel, the Plot Type drop-down list allows you to 
select whether the plot will display the mean time between failures (MTBF) or failure intensity, 
while the Units drop-down list allows you to select the units, which are defined at the database 
level. 
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The Multi-Phase Plot Setup button opens the Multi-Phase Plot Wizard, which allows you to 
view or change the data source(s) that are displayed in the plot. 

The Show area at the bottom of the control panel allows you to select which results and other 
elements will be shown in the plot. 

• The options under the Phases and Analysis Points headings are based on the test data from 
each phase. 

• The Demonstrated values reflect the reliability before any delayed fixes are 
implemented. 

• The Projected values reflect the expected jump in reliability after delayed fixes are 
implemented. 

• The Growth Potential values are the maximum system reliability that can be attained 
with the current system design and reliability growth management strategy (i.e., all B 
failure modes have been found and fixed). 

• The Estimated Parameters Line is applicable only for the test phases (not analysis 
points). It shows MTBF or failure intensity vs. time within each individual test phase. 

• The Phase Termination Line is applicable only for the test phases (not analysis points). 
It provides a long vertical line to more clearly mark the end of each test phase. 

• The options under the Planning heading are based on the growth planning folio that’s been 
linked to the plot, if any, and on the planning model used with the planning folio. 
 
These options are available if the planning folio uses the Crow Extended model. 

• The Nominal Idealized and Actual Idealized lines (also called idealized growth curves) 
show the overall characteristic pattern for the reliability growth across all phases of 
testing. The nominal MTBF/FI is the best case scenario, which assumes that the average 
fix delay is zero. The actual MTBF/FI takes into account the average fix delay. 

• The Planned Growth lines mark the time when each phase will begin and end, while 
the vertical position of each line shows the expected MTBF or failure intensity at the 
beginning of the phase. 

• The Goal Value line shows the target MTBF or failure intensity that you hope to achieve 
by the last phase of testing. 

These options are available if the planning folio uses the MIL-HDBK 189 model. 
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• The Idealized Growth Curve line shows the overall characteristic pattern for the 
reliability growth across all phases. 

• If the test phase settings are specified, the Average per Test Phase line shows the 
calculated MTBF at each phase. 

If you want to hide/display confidence bounds, choose Plot > Confidence Bounds > 
[Show/Hide] Confidence Bounds. 

  

The remaining options in the control panel are similar to other plot sheets throughout the 
application. Specifically: 

The folio tools are arranged on the left side of the control panel. 

 Redraw Plot updates the plot to reflect any changes that have been made. 

 Plot Setup opens the Plot Setup window, which allows you to customize most aspects 
of the plot including the titles, colors, sizes, etc. 

 RS Draw launches ReliaSoft Draw, which allows you to view the plot in greater detail, 
add annotations and modify selected plot elements. 

 Export Plot Graphic saves the plot as a graphic in one of the following formats: *.wmf, 
*.png, *.gif or *.jpg. You will be able to use the exported graphic in any application, 
provided that the application supports the file format. 

The Options area provides: 

• Auto Refresh automatically updates the plot to reflect any changes that have been made. If 
not selected, you must click the Redraw Plot icon to refresh the display. 

• Keep Aspect Ratio maintains the ratio of the horizontal size to the vertical size of the plot 
graphic when you resize the plot sheet. 

In the Scaling area: 

• The X and Y Scaling boxes show the minimum and maximum values for the x- and y-axes. 
You can change these values if the check box beside the value range is not selected. If it is 
selected, the application will automatically choose appropriate values for the range. 
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EXAMPLE: MULTI-PHASE TEST PLANNING AND MANAGEMENT 

For reliability growth data analysis only. 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_ReliabilityGrowth_RGA_Examples.rsgz20"). To access this database 
file, choose File > Help, click Open Examples Folder, then browse for the file in the Weibull sub-
folder. 

The name of the project is "Multi-Phase Test Planning and Management." 

A manufacturer is developing a small electric vehicle for indoor use, such as airports. The goal 
MTBF for the vehicle is 300 operating hours. 20 developmental prototypes are going to be 
tested for 3,000 hours each, for a total of 60,000 hours. The first phase of testing is planned to 
end at 5,000 hours of cumulative test time; the second phase will end at 15,000 hours; the third 
phase will end at 25,000 hours; the fourth will end at 35,000 hours; the fifth will end at 45,000 
hours and the sixth will end at 60,000 hours. 

The analysts wish to: 

• Create a test plan that will achieve the desired MTBF goal. 

• Use the Crow Extended - Continuous Evaluation model to analyze the data at the end of 
each phase of testing. 

• Use the multi-phase plot to track the actual progress against the original test plan. 

Continuous Growth Planning Folio 

The first step of creating an overall reliability growth program plan is to set an idealized growth 
curve and planned MTBF goal at each stage of the program. This will help determine the 
management strategy that may be needed to achieve the final MTBF goal. (The reliability 
growth program plan for this example is located in the growth planning folio called "Test Plan.") 
The inputs on the data sheet are shown next. 
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You can see that the cumulative test time at the end of each test phase has been defined under 
the Planned test phases heading, along with the average fix delay for failure modes that are 
discovered in each phase. In this case, the team expects that it will be easier to implement fixes 
earlier in the process; therefore, the estimated fix delay increases in each phase. For example, 
the fix for a failure mode discovered during Phase 1 is expected to be implemented 
approximately 3,000 test hours later; whereas a failure mode discovered during Phase 5 might 
not be able to be fixed until approximately 8,000 test hours later because the design is more 
mature at that point. 

The growth planning folio also shows the inputs for the Crow Extended growth planning model. 
In this case, the analysts have selected to calculate for the Initial MTBF that the product must 
have before reliability growth testing begins in order to achieve the Goal MTBF of 300 hours by 
the end of the test program, given the following growth management strategy: 

• A GP Design Margin of 1.3, which indicates that the growth potential MTBF (i.e., the 
maximum achievable MTBF if you continue until all modes are observed and corrected 
according to the current maintenance strategy) must equal 130% of the goal MTBF. This 
value provides a "safety factor" to ensure that the reliability requirement is met. 
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• An Average EF of 0.7, which indicates that the team expects that the fixes applied to failure 
modes discovered during testing will remove about 70% of the failure intensity due to 
those modes. 

• A Management Strategy of 0.95, which indicates that the team plans to fix about 95% of 
the failure modes that are discovered during testing (while about 5% may be classified as A 
modes, which are not fixed due to technical, financial or other reasons). 

• A Discovery Beta of 0.71, which indicates that the inter-arrival times between unique 
failure modes discovered during testing will become larger as the test progresses. 

As shown next, the results indicate that the initial MTBF must be about 131 hours when the 
first test phase begins. Furthermore, the plan estimates that the MTBF goal will be achieved 
after about 58,000 hours of test time. 

 

Click the Plot icon to see a visual representation of the results that are expected in each phase 
of testing. The following picture contains annotations to help you identify the following: 

• The Actual Idealized and Nominal Idealized lines show the overall characteristic pattern for 
the reliability growth across all phases of testing. 

• The actual MTBF takes into account the average fix delay. If fixes are not incorporated 
instantaneously, the actual line will show slower growth compared to the nominal line. 

• The nominal MTBF is the best case scenario, which assumes that the average fix delay is 
zero. 

• The horizontal Planned Growth lines mark the duration of each test phase, as well as the 
MTBF that is expected to be achieved by the beginning of the phase. For example, the 
planned growth line for Phase 4 begins at 25,000 hours, ends at 35,000 hours and shows 
that the MTBF is planned to be about 280 hours by the beginning of that phase. 

• The Goal line marks the MTBF the analysts plan to achieve. 

• The Termination line marks the end of the last test phase at 60,000 hours of cumulative 
test time. 
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Analyze the Test Data with the Continuous Evaluation Model 

When the testing began, the team used the Multi-Phase Failure Times data type in Weibull++ to 
record the data. For demonstration purposes, the sample project contains separate folios with 
the data up to the end of each individual test phase. As an example, you can open the "Test 
Data - Through Phase 2" folio, which contains all of the data through the end of the second 
phase. The last twenty data points from this folio are shown next. 
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As you can see, in addition to recording the time and mode classification for each failure event 
(F)—where A = no fix, BC = immediate fix before testing resumes and BD = delayed fix—this 
data type also allows the team to identify: 

• PH: The end time of each phase, which allows for the data from multiple test phases to be 
entered and analyzed together in the same data sheet. 

• I: The specific time when delayed fixes are implemented during testing. For example, on 
row 84 in this picture, you can see that a fix was applied at 12,935 hours for mode 5001. 

• AP: Specific analysis points at which the team wants to calculate results in order to track 
the progress of the test plan. 

(Although they are not shown in this picture, this data type also allows you to mark events as 
performance (P) or quality (Q) issues that can be excluded from the analysis if desired, You can 
also mark any event with an X to exclude it from the analysis.) 

For the BD (delayed fix) failure modes that do not have a specific fix time (I event) recorded in 
the data set, the Effectiveness Factors window allows the team to specify when the fix was (or 
will be) implemented. To open the window, choose Growth Data > Crow Extended > 
Effectiveness Factors. 
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As you can see, the fix for mode 5017 was implemented at the end of the second phase, and it's 
expected to have an effectiveness factor of 0.79 (i.e., only 79% of the mode's failure intensity is 
expected to be removed because the fix is not perfectly effective). The remaining modes have 
not yet been fixed before the start of Phase 3; they may be fixed during or between later test 
phases. 

 

Multi-Phase Plot 

As the testing progressed, the team used Weibull++’s multi-phase plot to track the progress 
against the original test plan. As an example, you can open the "Through Phase 2" multi-phase 
plot. This plot shows that the MTBF expected after the delayed fixes are implemented after 
Phase 2 (194.0895 hours) is less than the MTBF planned for the beginning of Phase 3 (264.2011 
hours). The team can use this information to determine whether the growth management 
strategy needs to be adjusted in subsequent phases. 

Note: The multi-phase plots in this example are based on analyses that use the maximum 
likelihood estimation (MLE) method to calculate the parameters, which is known to produce a 
biased value for beta. In this example, all these plots are based on unbiased estimates of beta. 
If the folio is not configured to remove this bias, you will be prompted to change the option in 
the Settings tab of the Item Properties window (Project > Current Item >  Item Properties). To 
ensure the unbiased beta is always calculated for all new folios, use the RGA Growth Data 
Folios page of the Application Setup window to select the option. 



Chapter 9: Reliability Growth Analysis Folios 

680 https://www.reliasoft.com/weibull 

 

 

Finally, if you open the "All Test Phases" multi-phase plot, you can see that the demonstrated 
MTBF eventually exceeded the goal, indicating a successful reliability growth plan. 
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RGA Repairable Systems Analysis 

For reliability growth data analysis only. 

Some of the models in Weibull++ can be used to analyze data from repairable systems 
operating in the field under typical customer usage conditions. Such data might be obtained 
from a warranty system, repair depot, operational testing, etc. 

Specifically, you can use the power law or Crow-AMSAA (NHPP) models for repairable system 
analysis based on the assumption of minimal repair (i.e., the system is "as bad as old" after 
each repair) to calculate metrics such as the expected number of failures, rate of wearout or 
the optimum time to replace or overhaul a system to minimize life cycle costs. 

The ReliaWiki resource portal has more information on repairable systems analysis at 
http://www.reliawiki.org/index.php/RGA_Models_for_Repairable_Systems_Analysis. 

http://www.reliawiki.org/index.php/RGA_Models_for_Repairable_Systems_Analysis


Chapter 9: Reliability Growth Analysis Folios 

682 https://www.reliasoft.com/weibull 

 

Tip: For even more advanced repairable systems analysis capabilities, you may wish to use 
ReliaSoft's BlockSim software. With BlockSim, you can use discrete event simulation to perform 
a wide variety of reliability, availability, maintainability and supportability (RAMS) analyses for 
repairable systems. 

DATA TYPES AND MODELS FOR REPAIRABLE SYSTEMS ANALYSIS 

For reliability growth data analysis only. 

There is a choice of two data sheets for analyzing data from repairable systems. In general: 

• Use the Repairable data type for analyzing the individual failure times for multiple 
repairable systems operating in the field. The analysis models the number of individual 
system failures vs. system time. 

• Use the Fleet data type for analyzing the failure times for multiple repairable systems from 
a fleet (rather than individual system) perspective. The analysis groups the data and models 
the number of fleet failures vs. fleet time. 

If you wish to perform repairable systems analysis based on the assumption of minimal repair 
(i.e., the system is "as bad as old" after each repair), use the Power Law model in a Repairable 
data sheet. If the power law model does not provide a good fit, you can transfer the data to a 
Fleet data sheet and use the Crow-AMSAA (NHPP) instead. 

For information about using the Crow Extended model for fielded systems, see Crow Extended. 

QCP RESULTS AND PLOTS FOR REPAIRABLE SYSTEMS ANALYSIS 

For reliability growth data analysis only. 

Weibull++ includes a Quick Calculation Pad (QCP) for computing useful metrics, and multiple 
plots that allow you to visualize the results of your analyses. The following calculations and 
plots are available when you are performing repairable systems analysis with the power law or 
Crow-AMSAA (NHPP) model. 

Note: When you analyze data from fielded systems, Weibull++ combines the data to create a 
single superposition system or cumulative timeline. Any plots generated for the combined data 
set and subsequent analyses via the Quick Calculation Pad will be based on the resulting 
system/timeline. See Fielded Data for more information about how the software combines the 
data for analysis. 

https://www.reliasoft.com/products/reliability-analysis/blocksim
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QCP Calculations 

To open the Quick Calculation Pad (QCP), choose Growth Data > Analysis > Quick Calculation 
Pad or click the icon on the control panel. 

 

This section describes the types of calculations you can perform in the QCP for repairable 
systems analysis. For general information on how to use the QCP, see Quick Calculation Pad 
(QCP). For information about the metrics and plots available for other types of analyses that 
you can perform in Weibull++, see QCP Calculations and Plots for Traditional RGA and QCP 
Calculations and Plots for Crow Extended. 

When you are performing repairable systems analysis with a Repairable or Fleet data sheet, the 
following calculations will be available: 

• Two values can be calculated for either the MTBF or Failure Intensity: 

• The Instantaneous value is the MTBF/FI over a small interval dt that begins at a 
specified time. For example, an instantaneous MTBF of 5 hours after 100 hours of 
operation means that, over the next small interval dt that begins at 100 hours, the 
average time between failures will be 5 hours. 

• The Cumulative value is the MTBF/FI from time = 0 up to a specified end time. For 
example, a cumulative MTBF of 5 hours from 0 to 100 hours means that the average 
time between failures was 5 hours over the 100-hour period. 

• The Time Given option allows you to calculate the mission duration given any of the 
following metrics: 

• Cumulative MTBF 

• Instantaneous MTBF 

• Cumulative failure intensity (FI) 

• Instantaneous failure intensity (FI) 

• Number of Failures is the cumulative number of failures that are expected to occur by a 
specified time, based on the fitted model. 

• Expected Fleet Failures is the number of failures that are expected to occur for all systems 
by a specified time. This option is available only for fielded repairable data and for fielded 
fleet data. 
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The following calculations are available only for the Repairable data sheet (which models the 
number of individual system failures vs. system time, rather than the number of fleet failures 
vs. fleet time). 

• Reliability is the probability that a system that has already operated for a certain amount of 
time will successfully complete a mission of a certain duration. Enter the amount of time 
that the system has already operated for in the System Age field, and enter the duration of 
the mission in the Mission Time field. For example, if the system age = 2 years and mission 
time = 1 year, the QCP will calculate the reliability for one additional year of operation after 
the system has already operated for two years (i.e., conditional reliability). To calculate the 
standard (i.e., non-conditional) reliability, enter 0 for the system age. 

• Prob. of Failure is similar to reliability, except that it is the probability that the system will 
not complete the mission. Thus, it is equal to 1 - Reliability. 

• Mission Time is the duration of a mission that a system can complete while still maintaining 
a certain reliability. Enter the required reliability in the Reliability field, and if you will 
assume that the system has already operated for a certain time prior to the mission, enter 
the prior operating time in the System Age field. For example, if system age = 1 year and 
reliability = 0.9, then the QCP will calculate the longest mission that the system can 
complete while maintaining a reliability of at least 90%, under the assumption that the 
system that has already operated for one year. 

• Optimum Overhaul is the best time to use between regularly scheduled renewals of the 
system. By overhauling the system at the right times, you can minimize the total life cycle 
cost. The optimum overhaul time is calculated using the average Repair Cost and the 
Overhaul Cost. For example, if it costs $1,000 to repair the system and $3,000 to overhaul 
it, the QCP can calculate the optimum time to overhaul the system (e.g., every 5 years). 

Plots 

You can create plots by choosing Growth Data > Analysis > Plot or by clicking the icon on the 
control panel. 

 

This section describes the types of plots you can create for repairable systems analysis. The 
scaling, setup, exporting and confidence bounds settings are similar to the options available for 
all other reliability growth analysis plot sheets. For more information on these common 
options, see Plot Utilities. 

When you are performing repairable systems analysis with a Repairable or Fleet data sheet, the 
following plots may be available. 
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• Cumulative Number of Failures shows the total number of failures versus time. Data points 
on the plot represent the cumulative number of failures that have been reported by a given 
time (e.g., the second point marks the time at which the second failure was observed). The 
Expected Failures line is fitted to the data points and serves as an empirical goodness-of-fit 
test for the model. 

• The [Value] vs. Time plots show how the value increases, decreases or remains constant 
over time. The points represent the actual failure times in the data set and the plot includes 
one line for the instantaneous value and one line for the cumulative value. 

• System Operation shows the failure times of each system plotted on separate lines. The 
last line is the timeline for the representative system (i.e., superposition system or 
cumulative timeline), which is used to evaluate all the failures that occurred during the 
observation period. To learn more about how the failure times are combined, see Fielded 
Data. 

• Conditional Reliability/Unreliability is available only when you are using the Repairable 
data sheet. These plots show the reliability/unreliability versus system age or mission time. 

• If you choose to hold the system age constant, the plots will show the 
reliability/unreliability for different mission times. For example, assuming that the 
system has already operated for 100 hours, the plot can show the reliability for the 
next 10 hours, 20 hours, 30 hours, etc. 

• If you choose to hold mission time constant, the plots will show the 
reliability/unreliability for different system ages. For example, assuming that the 
mission will be 100 hours, the plot can show the reliability for a system that has already 
operated for 10 hours, 20 hours, 30 hours, etc. 

To specify which value will be held constant, click the [...] button on the control panel. In 
the window that appears, select the type of metric that will be held constant, as shown 
next. Then enter the constant value in the input field. 
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• Optimum Overhaul plots are only available when Beta > 1 and only when you are using the 
Repairable data sheet. These plots show two values; economic life and useful life. Economic 
life is the overhaul time that minimizes cost (same as the QCP calculation). Useful life takes 
into account the reliability requirement for the given mission duration. Click Overhaul 
Settings on the plot control panel to change the parameters. 

 

Tip: Weibull++ includes two additional plot utilities you can use across all types of data: the 
overlay plot, which allows you to compare different data sets or models; and the side-by-side 
plot, which allows you to display different plots of a single data set all in a single window for 
easy comparison. 
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EXAMPLE USING POWER LAW MODEL FOR REPAIRABLE SYSTEMS ANALYSIS 

For reliability growth data analysis only. 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_ReliabilityGrowth_RGA_Examples.rsgz20"). To access this database 
file, choose File > Help, click Open Examples Folder, then browse for the file in the Weibull sub-
folder. 

The name of the project is "Repairable Systems - Race Car Analysis." 

Failure times were recorded for three Formula 1 race cars operating in the field. Each car failed 
multiple times during the observation period. When a failure occurred, the failure time was 
recorded, along with the name of the failed component that was replaced. For example, the 
data set for the first car is shown next using the Advanced Systems View. 

 

According to this data set, the first car was observed during its first 2,500 kilometers of 
operation. The engine was replaced when the car failed after 249.8 kilometers, the front 
suspension was replaced after 584.2 kilometers, and so on. Similar data sets are available for 
two others cars. 

The goals of the analysis are to analyze the combined data from all three repairable systems in 
order to: 
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• Estimate the total number of failures that you could expect for a car that competes in ten 
200-kilometer races. 

• Determine the probability that a car that has finished two races will complete a third 
without any failures. 

• Determine if it would be feasible to overhaul the entire car at regular intervals in order to 
minimize its total life cycle cost. If it is feasible, calculate the overhaul time, assuming an 
average repair cost of $192,000 and an overhaul cost of $500,000. 

On the control panel, choose the Power Law model, and then analyze the data by choosing 
Growth Data > Analysis > Calculate or by clicking the icon on the Main page. 

 

A summary of the calculation results will then be shown on the control panel. 

 

You can see in the results that the data passed the Cramér-von Mises (CVM) test, which 
indicates that the power law model provides a good fit for the data. (If the power law model did 
not provide a good fit, you could transfer the data to a Fleet data sheet and use the Crow-
AMSAA model instead. The Fleet data sheet allows you to group the data and combine them 
into a cumulative timeline for analysis.) 

To estimate the total number of failures expected for one car over the period of ten 200-
kilometer races, open the QCP by choosing Growth Data > Analysis > Quick Calculation Pad or 
by clicking the icon on the Main page of the control panel. 

 

In the QCP, choose to calculate the Number of Failures with None for the confidence bounds. 
Select km for the time units and then enter 2000 (i.e., the equivalent of ten 200-kilometer 
races) in the Time field. 



Chapter 9: Reliability Growth Analysis Folios 

Weibull++ 2020 User's Guide 689 

 

Click Calculate to obtain the result, as shown next. This analysis estimates about 5 failures for a 
car that competes in ten races. 

 

You can also use the QCP to determine the probability that a car that has finished two 200-
kilometer races will complete a third race. Choose to calculate Reliability and make the 
following inputs: 

• System Age = 400 (i.e., two races, each 200 kilometers) 

• Mission Time = 200 (i.e., a third 200-kilometer race) 

According to this result, the reliability of the car for the third race is estimated to be 69.88%. 
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Finally, to calculate an optimum overhaul time, first make sure the beta value of the fitted 
power law model is greater than 1 (indicating wearout). If the system has a constant failure rate 
(beta = 1) or a decreasing rate (beta < 1), then it will not be cost-effective to implement an 
overhaul policy. 
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Since beta is greater than 1, you can use the QCP to solve for the optimum overhaul time. In the 
QCP, choose to calculate Optimum Overhaul, and then make the following inputs: 

• Repair Cost = 192000 

• Overhaul Cost = 500000 

According to this result, the total life cycle cost of the car can be minimized by overhauling it 
every 1,619 kilometers. 

 

Mission Profile Folios 

For reliability growth data analysis only. 

Mission Profiles can help you to ensure that your testing is representative of the expected 
conditions of actual use by checking, at defined "convergence" points, whether expected usage 
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and actual usage are acceptably close. The ReliaWiki resource portal provides more information 
about operational mission profile testing at: 
http://www.reliawiki.org/index.php/Operational_Mission_Profile_Testing. 

To add a mission profile folio to a project, choose Home > Insert > Mission Profile or right-click 
the Mission Profile folder in the current project explorer and choose Add Mission Profile. 

 

To use a mission profile folio in Weibull++, do the following: 

• Set the convergence points 

• Define the profile for each separate characteristic that will be tested 

• Validate the mission profiles 

• Create a plot that allows you to visually compare the actual vs. expected usage in any or all 
of the defined profiles 

If desired, you can also link a profile with a data sheet in order to group the data. 

CONVERGENCE POINTS SHEET 

On the Convergence Points sheet, enter the times at which you want to check that the 
expected usage and the actual usage either meet their expected averages or fall within an 
accepted range(i.e., the amount that the usage can vary from the expected value, while still 
being acceptable. For example, if the expected number of miles traveled is 1,000 and the 
allowed variance is 100, then usages of 1,051 and 913 are acceptable, while usages of 1,103 
and 879 are not). You must include a minimum of three convergence points in the analysis. The 
test times between the convergence points do not have to be the same. 

The following example shows a convergence points sheet with four times defined. 

 

http://www.reliawiki.org/index.php/Operational_Mission_Profile_Testing
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All of the defined convergence points must be included in all of the profile sheets that you add 
to the folio. To automatically add the defined convergence points to each profile sheet, choose 
Mission Profile > Mission Profile > Transfer Convergence Points to Profile Sheets or click the 
icon on the control panel. 

 

PROFILE SHEET 

Each profile sheet represents a different part of testing (e.g., a different task that the system 
performs, etc.). By default, each new mission profile folio starts with one profile sheet. You can 
add additional profile sheets to the folio by choosing Mission Profile > Mission Profile > Insert 
Profile Sheet. 

 

At a minimum, each profile sheet must contain the times that you entered on the convergence 
points sheet. It may also contain any additional times at which usage is observed and recorded. 

The profile sheet contains the following information: 

• The Cumulative Time column indicates the time at which the usage is measured. The input 
is cumulative, which means that the times must be increasing and each row represents the 
total test time up to that point. 

• The Expected Usage column is the usage value that you expect at that time (e.g., the 
distance that the system should have traveled, the number of hours it should have 
operated or the number of times it should have performed a certain action). These inputs 
are also cumulative, which means that the values must be increasing and each row 
represents the total distance, hours operated, times used, etc. up to that point in time. 

• The Actual Usage column is the usage value recording during the testing. These inputs are 
also cumulative. 

• In the Plus/Minus Range field, specify the accepted variance from the expected usage 
values. 

The following example shows part of the data in a profile sheet. 
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VALIDATING THE MISSION PROFILE 

After you have entered all of the data, you can validate the profile to make sure that all 
necessary data points have been entered. To do so, choose Mission Profile > Mission Profile > 
Validate Mission Profiles or click the icon on the control panel. 

 

This feature checks that all convergence points are in all the profile sheets and sorts the data by 
the Cumulative Time column. 

Note: Validation also occurs when you generate a plot of the mission profile. If all of the data 
points have been entered, all of the profile sheets are marked as being verified. 
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MISSION PROFILE PLOTS 

For reliability growth data analysis only. 

You can visually compare the expected usage and the actual usage in any or all of the mission 
profiles defined in the folio by choosing Mission Profile > Mission Profile > Plot Mission 
Profiles or clicking the icon on the control panel. A plot sheet will be added to the folio. 

 

An example of a mission profile plot is shown next: 

 

The plot sheet control panel includes the following options: 

  Redraw Plot updates the plot to reflect any changes that have been made. 
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  Plot Setup opens the Plot Setup window, which allows you to customize most aspects 
of the plot including the titles, colors, sizes, etc. 

  RS Draw launches ReliaSoft Draw, which allows you to view the plot in greater detail, 
add annotations and modify selected plot elements. 

  Export Graphic allows you to save the current plot graphic in one of the following 
formats: *.jpg, *.gif, *.png or *.wmf. 

• Auto Refresh automatically redraws the plot when something changes. If not selected, you 
must click the Redraw Plot icon to refresh the display. 

• Keep Aspect Ratio maintains the ratio of the horizontal size to the vertical size of the plot 
graphic when you resize the plot sheet. 

• Units allows you to choose which units you want the plot to show from the drop-down 
menu. 

• In the Scaling area, the X and Y Scaling boxes show the minimum and maximum values for 
the x- and y-axes. You can change these values if the check box beside the value range is 
not selected. If it is selected, the application will automatically choose appropriate values 
for the range. 

• Show 

• Select Show Plus/Minus Range if you want to display lines that show the allowed 
accepted variance from the expected average usage values on the plot. (Accepted 
variance is the amount that the usage can vary from the expected value, while still 
being acceptable. For example, if the expected number of miles traveled is 1,000 and 
the allowed variance is 100, then usages of 1,051 and 913 are acceptable, while usages 
of 1,103 and 879 are not.) 

• Select Intervals if you want to display the convergence points on the plot. 

• Available Profiles allows you to select which of the profile sheets in the folio will be 
included in the plot. 

LINKING A MISSION PROFILE TO A DATA SHEET 

For reliability growth data analysis only. 

If your actual testing follows the balanced test plan that you established in a Weibull++ mission 
profile folio, then it is likely that you will get valid results from analyzing the test data directly 
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with one of the reliability growth models in a Failure Times data sheet. However, if there is a 
possibility that the test data might not be appropriate for direct analysis, you can use the 
mission profile folio to group the data based on the specified convergence points so it is 
suitable for reliability growth analysis. 

To use this feature, first enter the test data in a Failure Times data sheet, then click the Link 
Mission Profile icon on the growth data folio control panel. 

 

After you select one of the mission profiles in the current project, the application will 
automatically transfer the data to a new Grouped Failure Times data sheet in the folio. The data 
will we grouped according to the times in the specified mission profile. 

EXAMPLE: USING THE MISSION PROFILE FOLIO 

For reliability growth data analysis only. 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_ReliabilityGrowth_RGA_Examples.rsgz20"). To access this database 
file, choose File > Help, click Open Examples Folder, then browse for the file in the Weibull sub-
folder. 

The name of the example is "Mission Profiles," and the folio that contains the data is called 
"Tank Testing Profile." 

A team is working on a military system that must perform three tasks: 

• firing a gun 

• moving under environment 1 

• moving under environment 2 

They use a mission profile to create a test plan that defines the expected accumulated usage 
values for each task, and includes the same four convergence points (100, 250, 320 and 400 
hours) in each task's profile. The purpose of these convergence points is to make sure that the 
usage levels for all three tasks match up at those specific times (even if there is some variation 
from the test plan in between convergence points). 

When the team performs the test, they record the actual usage values in the mission profile 
folio, and they record the failure times data in a reliability growth data folio. 
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The mission profile folio called "Tank Testing Profile" shows the actual and expected usage for 
all three tasks. As shown next, the plot shows all three planned mission profiles together with 
the actual usage during the test. For example, the straight blue line shows the planned usage 
for the gun firing task and the jagged black line shows the actual usage during the test. You can 
see that the actual usage tends to fluctuate around the plan (due to normal variations under 
actual test conditions), but always meet the target at each of the four convergence points. The 
same applies for the actual usage on the environment 1 and environment 2 tasks. 

 

The plot can be used to track whether the test is proceeding according to plan. In addition, the 
mission profile folio can also assist with data analysis by automatically grouping the data based 
on the specified convergence points. 

If there has been significant variation from the test plan in between the convergence points, 
this means that the usage values for the three tasks may not have been properly balanced at 
certain points in time, and an analysis of the exact failure times may give misleading results. For 
this example, the team decides to group the data at the convergence points so they can be sure 
that the usage of all three tasks has been synchronized according to the plan. 
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The "Tank Data" growth data folio contains the failure times observed during the test. The first 
data sheet (called "Original Data") contains the exact failure times. To create the second sheet 
(called "Grouped Data"), the analyst simply opened the original data sheet and clicked the Link 
Mission Profile icon on the control panel. 

 

When prompted, he selected the applicable mission profile and the application automatically 
grouped the data. The following picture shows the grouped data analysis, which is based on 
balanced usage values for the three different tasks. 

 

The following plot shows some useful planning metrics obtained from the grouped data analysis 
with the Crow Extended model: the demonstrated, projected and growth potential MTBFs. 
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Chapter 10: DOE Design Folios 
DOE Background 
In order to develop the best possible products and processes in the most cost-effective way, it 
is necessary to plan the testing process carefully so that all relevant factors and potential 
interactions of factors are considered without wasting time, effort or money. Design of 
Experiments (DOE) is widely used across the natural and social sciences to develop 
experimentation strategies that maximize learning using a minimum of resources. 

Designed experiments are usually carried out in five stages: planning, screening, optimization, 
robustness testing and verification. These stages are described next. 

PLANNING STAGE 

Careful and thorough planning prior to embarking upon the process of testing and data 
collection can save time and resources by eliminating unnecessary work and by helping the 
analyst to avoid making costly mistakes. Well-planned experiments are easy to execute and 
analyze, whereas experiments that are poorly planned may result in data sets that are difficult 
or impossible to analyze with even the most sophisticated statistical tools or, if they can be 
analyzed, give inconclusive results. Essential points to consider during the planning stage 
include:  

• Objective: What do you hope to learn through the experiment? 

• Team: Individuals from different disciplines related to the product or process should be 
chosen, in order to incorporate the broadest possible range of knowledge. 

• Factors and Responses: The team should identify a pool of factors that will be investigated 
and the response(s) that will be measured. For each response, the team should identify a 
goal. This might be to minimize or maximize the response, to bring it as close as possible to 
a target value, to minimize variability or some combination of these. 

SCREENING STAGE 

The goal of the screening stage is to determine which factors out of the pool of potential 
factors identified during the planning stage are important enough to examine in greater detail 
(i.e., to extract the "vital few" from the "trivial many"). To this end, screening experiments are 
carried out to identify factors with a significant effect on the measured response(s). Typically, 
these experiments are efficient designs that require only a few executions and focus on the 
main effects of factors rather than on interactions between the factors. These experiments, in 
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conjunction with prior knowledge of the process, help in eliminating unimportant factors and 
focusing attention on the factors that require more detailed analysis. 

In DOE, factorial designs are well suited for use in the screening stage. 

OPTIMIZATION STAGE 

Once the important factors have been identified, the objective is to determine the settings of 
these factors that, taken together, will yield the desired outcome. The analyst will need to 
consider the goal set for each response and, in cases where multiple responses are measured, 
may need to consider the relative importance of each response when determining optimal 
solutions. 

Response surface method design types are often used in the optimization stage, when the 
focus is on the nature of the relationship between the response and the factors rather than on 
the identification of important factors. The purpose of response surface methods is to examine 
this relationship, or "surface." 

In DOE, after analyzing data from an experiment with at least two factors (one of which must be 
quantitative), the optimization folio can be used to optimize the factor settings. 

ROBUSTNESS TESTING STAGE 

While the experimental environment can be carefully controlled, it is likely that there will be 
factors that affect the product or process in the application environment and are beyond the 
control of the analyst. Such factors, referred to as noise or uncontrollable factors, may include 
humidity, ambient temperature, variation in material, etc. The goal of robustness testing is to 
identify these factors and ensure that the product or process is made as insensitive, or robust, 
as possible to them. 

In DOE, you can use robust parameter designs for robustness testing. In addition, response 
variability analysis is available for two level factorial and Plackett-Burman designs. 

VERIFICATION STAGE 

In the verification stage, the analyst confirms the results drawn from the previous phases by 
performing a few follow-up experimental runs to see if the observed response values are close 
to the predicted value(s). The goal is to validate the best settings that have been determined, 
making sure that the product or process functions as desired and that all objectives are met. 

The ReliaWiki resource portal provides more information about Design of Experiments at 
http://www.reliawiki.org/index.php/DOE_Overview. 

http://www.reliawiki.org/index.php/DOE_Overview
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Design Folio 

Weibull++ includes three kinds of folios for design of experiments: 

• Standard design folios are used for identifying important factors (i.e., "screening") and 
determining the best settings for these factors (i.e., "optimization"). They can also be used 
for simple one factor designs that allow you to compare the response at different factor 
levels. 

• Robust design folios are used to minimize the system's sensitivity to noise factors (i.e., 
"robustness testing"). Robust design folios include all the functionality of the standard 
design folio, with the addition of some features specific to the robust design methodology. 

• Mixture design folios are used when the factors in an experiment are components in a 
mixture, and when you wish to determine the best proportions to use for each component. 

To create a DOE folio, right-click the DOE folder in the current project explorer and choose the 
folio type. 

  Standard Design 

  Robust Design 

  Mixture Design 

When the folio first appears, only the Design tab will be displayed, which allows you to 
configure an experiment design. After you have specified all of the settings on the Design tab, 
choose Design > General > Build Design or click the icon on the control panel. 

 

This will create a second tab called Data that a) shows a "plan" for how the experiment needs 
to be performed and b) allows you to enter and analyze response data from an experiment that 
follows that plan. (If you want to change the experiment design settings after the Data tab has 
already been created, see Changing Design Settings.) After you analyze the data, a summary of 
results (including the factors that were found to be significant) will appear on the control panel. 

Tip: This documentation assumes that you will first design an experiment, then perform it, and 
then enter and analyze the resulting data. However, if you already have data available from a 
prior experiment, you can also use the Design tab to build a design that reflects the prior 
experiment and then build the design so you can enter and analyze the results on the Data tab. 
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After you have entered the response information in the Data tab, you can choose Data > 
Analysis > Plot or click the icon on the control panel. 

 

This will create a third tab called Analysis Plot that allows you to view all of the graphical plots 
that are relevant to the current analysis of the response data. 

The information presented in the topics that follow describes interfaces and procedures that 
are common to all design types. To learn more about a specific design type, see one of the 
following topics: 

• Factorial Designs 

• Response Surface Method Designs 

• One Factor Designs 

• Robust Parameter Designs 

• Mixture Designs 

• Reliability DOE 

Design Tab 

When you first create a design folio, the Design tab will be shown. After you specify the settings 
on this tab, choose Design > General > Build Design or click the icon on the control panel. 

 

This will create the Data tab, which shows the new "plan" for the experiment and allows you to 
record and analyze response data. 

Design Types 

The following design types are supported: 

Factorial Designs are used for screening vital factors, and they are available in standard design 
folios and robust design folios. The links below explain these designs in the context of standard 
design folios. 
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• Two Level Factorial: You can have 2 to 15 factors; each factor must have exactly two levels. 
This design type can be used to investigate all main effects and their interactions (full 
factorial) or just a subset of them (fractional factorial). 

• Plackett-Burman Factorial: This is a special category of two level fractional factorial design, 
where only a few specifically chosen runs are performed to investigate the main effects 
(i.e., no interactions). You can have 2 to 47 factors; each factor must have exactly two 
levels. 

• General Full Factorial: Different factors can have different numbers of levels. All effects and 
their interactions are investigated. You can have 2 to 7 factors; each factor can have 2 to 20 
levels. 

• Taguchi Orthogonal Array (OA) Factorial: This is a highly fractional design type. It can 
investigate main effects with just a few runs, and different factors can have different 
numbers of levels. 

Response Surface Method Designs are used for system optimization and are available only in 
standard design folios. 

• Central Composite Design Response Surface Method: This is the most commonly used 
response surface methodology design. It is typically used to study the quadratic effects of 
factors. 

• Box-Behnken Response Surface Method: This design type allows you to consider from three 
to nine quantitative factors at three levels each (one level being a center point). If setting 
all factors at the high level at the same time carries a risk of equipment damage or violates 
other constraints, these designs provide a matrix that avoids setting all factors at extreme 
values simultaneously. 

One Factor Designs are used for comparison, and they are available only in standard design 
folios. 

• Only one factor is investigated, and the response is compared at different factor levels. The 
factor levels must be qualitative. (To perform one factor analysis with quantitative levels, 
use the Multiple Linear Regression folio.) 

Mixture Designs are used when the factors in an experiment are components in a mixture, and 
when you wish to determine the best proportions to use for each component. 

• Simplex Designs include: 

• Simplex Lattice: With this design, the blends in the experiment are determined by the 
specified number of levels of each component (i.e., the degree of design + 1). Since it 
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includes all the reasonable combinations of components, this design is useful when the 
number of components is not large, and a higher polynomial equation is needed for 
optimization. 

• Simplex Centroid: By default, this design includes single-component blends (vertices) 
and all centroids up to the dimension g, where g is the number of components. Users 
can specify the degree of design (i.e., the dimension of centroids). Since it usually has 
fewer test runs than a simplex lattice design, this design is useful when the number of 
components is larger, but a lower polynomial equation will suffice for optimization. 

• Simplex Axial: This design includes vertices, blends with an absent component (edge 
points), center points and interior points between the center point and vertices (axial 
points). It is mainly used for screening components. 

• Extreme Vertex Designs: This design allows you to impose additional limits on the 
component values by specifying upper bounds on components and defining linear 
constraints for blends. 

Building a New Design 

The Design tab of the design folio is used to define and then build an experiment design. When 
you build the design, its "plan" will be shown on the Data tab. 

• If you are working with a standard design folio, you will use the Design tab to select a 
design type, define responses/factors and choose additional settings for the whole design. 

• If you are working with a robust design folio, you will make these selections for each of the 
inner and outer arrays of the design. 

• If you are working with a mixture design folio, you will make these selections to specify the 
design for mixture factors and, if applicable, process factors. 

After you create the folio, follow the steps outlined next to build a design from scratch. 

Tip: If you wish to use saved settings instead, choose Design > Import/Export > Import 
Template or click the  icon on the control panel. After you import the settings, you can 
proceed to the last step to review your settings and build the design. (See Importing/Exporting 
Design Settings.) 
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Choose the Design Type(s) 

If you are working with a standard design folio, choose one design type for the experiment by 
clicking the Design Type heading in the navigation panel on the left and choosing an option in 
the input panel on the right.  

If you're using a robust design folio, you need to select two design types (one under the Inner 
Array heading and another under the Outer Array heading). For considerations in choosing the 
design types and additional information about settings used in configuring the robust design, 
see Robust Parameter Designs. 

When you first create a design folio, the current factor settings will change as required 
depending on the design you select. After you directly make changes to the factors, responses 
or additional settings, the factor settings will no longer change automatically, and the design 
types will be color-coded in green or red. 

If a design is red, then one of the current factor settings is incompatible with it. When you 
select a red design type, the factor(s) it is incompatible with will become red as well. To find out 
why the setting is incompatible, read the design type's description. For example, the red text in 
the design description below says, "All factors must have exactly 2 levels," which indicates that 
the Carbonation factor (also shown in red) does not have the required number of levels for a 
Box-Behnken design. 
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Define the Response(s) 

If you are using a standard design folio, you must configure the response(s) that will be 
measured in the experiment by selecting the response in the navigation panel and editing its 
properties in the input panel. (See Adding, Removing and Editing Responses.) To perform 
reliability DOE, select Life Data as the response type for one response. The resulting Data tab 
will be configured for reliability DOE. 

For robust design folios, default response properties will be used to build the design. 

Define the Factor(s) 

You can change the number of factors by clicking the Factors heading in the navigation panel 
and choosing an appropriate number in the input panel. You can then define individual factors 
by selecting the factor in the navigation panel and editing its properties. (See Adding, Deleting 
and Editing Factors.) 

Specify Additional Settings 

The options available when you click the Additional Settings heading will vary depending on 
which design type is currently selected. The following options may be available: 

• General Settings 

• Replicates allows you to specify the number of test samples you want to observe at 
each combination. In other words, the number of replicates is the number of times you 
want to perform the complete set of runs required by the design. Using replicates helps 
to separate error caused by a poor model fit from error caused by natural variation 
(i.e., experimental error). 

• Repeated Measurements allows you to specify the number of measurements to use 
for each test run. The mean and standard deviation of the measurements are 
calculated for each run, and either can be selected as the analyzed response for the 
experiment. This option is not available for R-DOE or designs with multiple responses. 

• Block on Replicates allows you to choose whether you will use each replicate of the 
design as a block. By blocking on replicates, you can account for "nuisance factors" (i.e., 
effects that are not of interest to the investigator) due to conditions that differ from 
one replicate of the design to another. For example, if the first replicate of the design is 
performed on Day 1, and the second is performed on Day 2, you could account for 
variation in the response due to the day. This option is available only if the number of 
replicates in the design is greater than 1. 

• Block Settings 
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• Number of Blocks allows you to specify the total number of blocks that will be used in 
the design. Blocks per Replicate (shown when you choose to block on replicates) allows 
you to specify the number of blocks that will be used per replicate. The more blocks 
you use in the design, the more potential nuisance factors you can account for. Note, 
however, that using blocks requires aliasing them with one or more effects. 
 
Select a number of blocks from the drop-down list; the options available in this list 
depend on the type of design and the number of factors. Using 1 block in the entire 
design is equivalent to not using blocks. 
 
With Taguchi OA designs, you must block on replicates to use blocks, and you can use 
at most 1 block per replicate. 

• Center Points per Block allows you to specify the number of center points that will be 
used per block. Center points are used primarily to help you determine if there is 
curvature in the relationship between the factors and the response. In addition, using 
several center points provides an estimate of pure error. 

• Block Name allows you to enter a name for each block. 

• Design Generators will appear when you have multiple blocks. This field is used to 
specify the factorial interaction effects that will be aliased with that of the nuisance 
factor for which you are blocking the design. (See Specifying Generators.) 

• Factorial Settings 

• Fraction allows you to select the number of base runs you want to use in the 
experiment, based on a fraction of the total number of runs that would be required for 
a full factorial design. For example, if your design includes five factors with two levels 
each, a full factorial design would require 25 = 32 base runs. For a fractional factorial 
design in this case, you can select to use a one-half fraction (16 runs) or a one-fourth 
fraction (8 runs). The total number of runs required for the experiment may be greater 
than the number of base runs (e.g., if you use replicates and/or center points). (See 
Two Level Factorial Designs and Central Composite Designs.) 

• Design Generators will appear when you are using a fractional design, not a full 
factorial. It allows you to specify the factorial interaction effects that will be aliased 
with the main effects of particular factors. (See Specifying Generators.) 

• Plackett-Burman Settings (Plackett-Burman designs only) 
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• Base # of Runs allows you to specify the number of runs you want to use in the 
experiment. The available choices are determined by the number of factors you specify 
and the design matrix developed by Robin L. Plackett and J. P. Burman. 

• Taguchi OA Settings (Taguchi OA designs only) 

• The options available in the Taguchi Design Type drop-down list will depend on the 
numbers of levels for each factor. For example, if all your factors have three levels, 
then you could choose the L9 (3^4) design, which uses nine runs to investigate up to 4 
three-level factors. If some factors have two levels and the rest have four, then you 
could choose the L16 (2^9*4^2) design, which uses 16 runs to investigate up to 9 two-
level factors and up to 2 four-level factors. 

• Click the View Alias Table icon  to see the alias table for the selected Taguchi design 
type. The table shows what aliases result from assigning factors to particular columns 
in the orthogonal array. See Taguchi OA Alias Table. 

• Taguchi Column Indices allows you assign factors to columns of the selected 
orthogonal array. No two factors can have the same index. 

• The Specify Interaction Terms link opens a window that helps you assign factors to 
columns without aliasing any main effects or any interaction terms of interest. (See 
Specify Interaction Terms Window.) 

• Central Composite Settings (Central Composite designs only) 

• Alpha value allows you to specify the alpha value that you want to use to determine 
the axial points in the design. Options include:  

• Rotatable Design: This alpha value ensures that the variation in the response will 
be the same for all points that are the same distance from the design center point. 
This makes the model provide equally precise predictions throughout the region of 
interest, which means that regardless of the direction taken to search for the 
optimum solution, the result is equally accurate.  

• Spherical Design: This alpha value places the axial points on the surface of the 
sphere defined by the factorial design points (i.e. all design points have the same 
distance to the center point).  

• Orthogonal Block: This alpha value ensures that the effect of the blocking is 
unconfounded with other effects. This option is available only if you have selected 
to block the design.  
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• Face Centered Design: In this case, alpha = 1, which means that all design points 
will be in the range from -1 to 1.  

• Custom: Allows you to specify your own alpha value to meet the constraints of 
your experiment.  

• If you select Yes in the Add axial point block drop-down list, an extra block will be 
added to the design and used for the axial points.  

• Center points / axial block allows you to select how many center points will be added 
to the axial block.  

• Mixture Settings (Mixture designs only) 

• Mixture Total allows you to specify the total amount of the mixture used for each test 
run. 

• Degree of Design is available only for simplex lattice designs. With a degree of n, each 
factor will use the values 0, 1/n, 2/n, …, n/n. Therefore, choosing n means each mixture 
factor will have n + 1 factor levels. 

• Degree of Centroid is available only for simplex centroid and extreme vertex designs. 
With a degree of n, the centroid of n-dimensional space will be added to the design. 
(For example, the center point of a line is the centroid of a 2-dimensional space.) 

• Additional Runs (Mixture designs only) 

• Center Points allows you to specify the number of center points to add to the overall 
design. A center point is a test run that uses a blend with all components set to the 
same value. 

• Axial per Component (simplex designs only) allows you to specify the number of axial 
points to add for each component in the design. An axial point is a test run that uses a 
blend between a center point and a vertex (i.e., a blend with one component set to its 
maximum value). 

• Vertex per Component (simplex designs only) allows you to specify the number of 
vertex runs to add for each component in the design. 

• Axial per Vertex (extreme vertex designs only) allows you to specify the number of 
axial points to add for each vertex in the design (i.e., a blend with one component set 
to its maximum value). An axial point is a test run that uses a blend between a center 
point and a vertex. 
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• The Blend Combinations settings (e.g., 2-Blend Combinations) are available if you have 
at least three components in your simplex design. They allow you to specify how many 
combinations of N-blend points to add to the design. For example a 2-blend point is a 
test run that includes two components set to equal values, and any remaining 
components set to zero. 3-, 4- and 5-blend combinations may also be available 
depending on the number of components in the design. 
 
Note that the specified number is the number of combinations of points to add, not 
individual points. Thus, if you have three components and choose 1 for the Double 
Blend, three runs with the following values will be added to the design: (1/2, 1/2, 0), 
(1/2, 0, 1/2) and (0, 1/2, 1/2). 

• Linear Constraints (extreme vertex designs only) allow you to define limits on how the 
components can be combined. See Defining Linear Constraints. 

Design for Process Factors 

For mixture designs, click Design for Process Factors in the navigation panel and specify 
whether process factors (e.g., temperature) will also be included in this design. If you choose 
Yes, more settings become available to specify the design for process factors. The steps for 
defining this part of the design are similar to those for creating a factorial design. 

Rename the Folio 

If you wish to rename the folio, click the heading at the very top of the navigation panel and 
edit the text in the Name field in the input panel. Alternatively, you can right-click the folio in 
the project explorer and choose Rename from the shortcut menu. 

Review Your Settings and Build the Design 

You can review some properties of your new design in the Design Information area of the 
control panel, as shown next. 
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In addition to the Design Type, Responses, Factors  and Replicates you chose for the design, 
the following calculated values are shown: 

• Base Runs is determined by the number of factors, the number of levels for each factor and 
whether you are using a fractional design. For example, if your design is a full factorial 
design with 3 factors that each have 2 levels, then the number of base runs is 23, or 8. If the 
factors/levels are the same but you are using a fractional design that uses 1/2 of the runs 
required for a full design, then the number of base runs is 4 (i.e., 1/2 of the 8 required for 
the full design). 

• Total Runs is the total number of runs that are required for the experiment. This value is 
determined by the number of base runs, replicates, center points per block, axial points per 
block and other settings. For extreme vertex designs, this information will not be available 
until you have validated the constraints. 

If you click any link in the first column of this table, you will be able to edit the relevant setting 
in the input panel. If you wish to see more detailed information about your current design 
settings, click the Detailed Summary link at the bottom of the table. The Design Summary will 
provide further information about the design's properties. 

You can also use the Design Evaluation tool to help you determine whether a design with the 
current settings would, for example, be likely to detect the main effects and factorial 
interactions you are interested in. (See Design Evaluation.) 

When you are ready to build the design, choose Design > General > Build Design or click the 
icon on the control panel. 

 

This will create a new Data tab in the folio that will be used to enter and analyze response data. 

Adding, Removing and Editing Responses 

Before building your design, make sure you have the correct number of responses (i.e., the 
types of output that you want to measure) and that each response is defined appropriately. 
These settings are selected on the Design tab. 

Adding and Removing Responses 

There are three ways to add or remove responses from a design. 

• You can choose Design > Responses > Add Response. 
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If two or more responses are included in the design, you can remove a response by 
selecting it in the navigation panel and choosing Design > Responses > Remove Response. 

 

• You can also add/remove responses by right-clicking a response and choosing the 
appropriate option from the shortcut menu. 

• To quickly add or remove several responses at once, click the Responses heading and then 
change the number in the Number of Responses drop-down list in the input panel, as 
shown next. 

 

Note that when you decrease the number of responses using the drop-down list, the 
responses at the bottom of the list will be deleted first. 

Editing Responses 

You can define the properties of an individual response by selecting it in the navigation panel 
and editing its properties in the input panel, as shown next. 
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Alternatively, you can edit all the responses simultaneously by clicking the Modify Responses 
icon in the navigation panel (  ). 

The following properties are available: 

• Name is the label for the response. 

• Units are the units of measurement that will be used for the response. 

• Response Type specifies whether you will be using life data (e.g., failure times) for the 
response values. If you select Life Data from the drop-down list, the data sheet will be 
configured for reliability DOE. Note that only one response in a given design can contain life 
data. 

• Censoring is applicable only if the response contains life data. The option you select from 
the drop-down list will determine which columns will be added to the Data tab so you can 
enter the selected type of censored data. For example, if you select Intervals, then the Data 
tab will include a Last Inspected column and a Time Failed column. (See Reliability Design 
Data Types.) 

• The Comments field allows you to save notes or other text about the response. This 
information is not used in any calculations, and it can be accessed only via the input panel. 



Chapter 10: DOE Design Folios 

716 https://www.reliasoft.com/weibull 

 

Adding, Removing and Editing Factors 

Before building your design, make sure you have the correct number of factors and that each 
factor is defined appropriately. 

Note that if a factor appears red in the navigation panel (as shown next), then it is incompatible 
with the selected design type. The reason will be displayed in red text next to the selected 
design. 

 

Note: For robust design folios, factors are configured separately for the inner array and the 
outer array. For example, you could use two factors (e.g., pressure and viscosity) for the inner 
array and one factor (e.g., humidity) for the outer array. Similarly, for mixture design folios, 
factors are configured separately for mixture factors and process factors, if applicable. 

Adding and Removing Factors 

There are three ways to add or remove factors from a design. 

• You can choose Design> Factors > Add Factor. 

 

You can remove a factor by selecting it in the navigation panel and choosing Design > 
Factors > Remove Factors. 
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• You can also add/remove factors by right-clicking a factor and choosing the appropriate 
option from the shortcut menu. 

• To quickly add or remove several factors at once, you can click the Factors heading and 
then change the number in the Number of Factors drop-down list in the input panel, as 
shown next. 

 

Note than when you decrease the number of factors using the drop-down list, the factors 
at the bottom of the list will be deleted first. 

Editing Factors 

You can define the properties of an individual factor by selecting it in the navigation panel and 
editing its properties in the input panel, as shown next for a standard design folio. 



Chapter 10: DOE Design Folios 

718 https://www.reliasoft.com/weibull 

 

 

Alternatively, you can edit all the factors simultaneously by clicking the Modify Factors icon in 
the navigation panel (  ). 

The following properties are available for factors in all design folios: 

• Name is a label for the factor. 

• Custom Abbreviation allows you to enter your own abbreviated name for the factor. If you 
clear this check box, the default abbreviation "A" will be used for the first factor, "B" will be 
used for the second factor, and so on. The abbreviated name is used when referring to 
interactions in plots and when specifying generators. 

• Units are the units of measurement that will be used for the factor (e.g., "K" if the applied 
temperature is measured in kelvins). 

• The Comments field allows you to save notes or other text about the factor. This 
information is not used in any calculations, and it can be accessed only via the input panel. 

These properties are available only for factors in standard design and robust design folios. 

• Type specifies whether the factor will be treated as having quantitative or qualitative 
values (e.g., "300" vs. "Small"). Note that predictions are possible only with quantitative 
factors. 

• You can change the Number of Levels for the factor using the drop-down list, or by clicking 
the [-] and [+] icons. 
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• For central composite designs, you can view the factor's Range Based on Alpha Values, 
which shows the full range of values that the factor will have in the experiment. Select 
Define levels using range to set the range directly. 

These properties are available only for factors in mixture design folios. 

• Lower Bound and Upper Bound set the bounds on the amounts of each mixture factor. You 
can change the lower bounds in extreme vertex designs only. 

Specifying Generators 

If you are working with a fractional factorial and/or blocked design, selecting the Additional 
Settings heading in the Design tab's navigation panel will allow you to specify generators for 
the design. 

• Fractional generators are needed when working with a fractional factorial design. These 
generators are factorial interactions whose effects will be aliased (or confounded) with the 
main effects of particular factors. In other words, by specifying a generator, you determine 
which interaction effects will be indistinguishable from the main effects of certain factors. 

• Block generators are needed when working with a blocked design (i.e., a design that divides 
runs into blocks in order to screen out nuisance factors). These generators are factorial 
interactions whose effects will be aliased with that of the nuisance factor. 

This topic will focus on specifying fractional generators, but the underlying principles are the 
same for block generators. 

In the example shown next, the main effect of "Etch Time" is aliased with the interaction of the 
first four factors. Note that the abbreviated names of the factors (e.g., "B" for "Exposure Time") 
are specified when you edit each factor. By default, the first factor is abbreviated as "A," the 
second as "B," and so forth. 
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The software automatically selects the fractional generators that maximize the design's 
resolution given the number of factors included in it. However, if you click inside the field(s) in 
the Design Generators area, you can change the sign of the generator using the first drop-down 
list. You can also use the second drop-down list to change the interaction that is used for the 
generator, as shown next. 

 

As an example, consider an experiment involving three factors (A, B and C) at two levels each (1 
and -1). Running all possible combinations of factor settings without any replication requires 
eight runs, as shown next. 

  Factor A Factor B Factor C 

Run 1 -1 -1 -1 
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Run 2 1 -1 -1 

Run 3 -1 1 -1 

Run 4 1 1 -1 

Run 5 -1 -1 1 

Run 6 1 -1 1 

Run 7 -1 1 1 

Run 8 1 1 1 

To create a half-fraction design (i.e., one with half as many runs), it will be necessary to alias the 
effect of one factor with the interaction of the other two. For example, if you are confident that 
there are no interaction effects between any of the factors, then you can alias C with the 
interaction of A and B, as shown next. With this alias structure, the test design will allow you to 
evaluate all three main effects (but no interactions). 

  Factor A Factor B Factor C = Factor A x Factor B 

Run 1 -1 -1 1 

Run 2 1 -1 -1 

Run 3 -1 1 -1 

Run 4 1 1 1 

The selected generator for this case is shown next. 

 

Alternatively, you could use the rule C = -AB, aliasing the effect of Factor C with the negative (or 
opposite) effect of the interaction of the other two factors, as shown next. 

  Factor A Factor B Factor C = –(Factor A x Factor B) 

Run 1 -1 -1 -1 

Run 2 1 -1 1 

Run 3 -1 1 1 

Run 4 1 1 -1 

To use the negative effect of the factors, change the sign of the generator as shown next: 
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Design Summary 

The Design Summary provides details for the settings currently selected on the Design tab, 
including the design type, response/factor details, blocks, etc. If the folio includes an 
experiment plan (i.e., Data tab) that is no longer in sync with the Design tab settings, a second 
"Prior Settings" summary will provide a record of the design settings that were used to build 
the experiment. 

The Design Summary is accessed by clicking the Design Summary heading in the navigation 
panel of the Design tab or by clicking the Detailed Summary link on the control panel. An 
example summary is shown next. 

 

Note: For extreme vertex designs, information on the number of runs will not be available until 
you have validated the constraints. 
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Alias Structure for Two Level Factorial Designs 

If you are using a two level factorial design with aliased factors (i.e., two level fractional 
factorial design), the summary will consist of two pages, accessed by clicking two tabs. The first 
tab will display the design properties summary and the second tab will display the initial alias 
structure, which describes which effects are indistinguishable from other effects in the current 
design. The alias structure is set automatically, but it can be changed by manually specifying 
generators. 

The initial alias structure of a design is shown next. 

 

Prior Settings Summary 

If the Design tab is out of sync with the Data tab (as indicated at the top of the Design tab 
control panel), two summaries will be available under the Design Summary heading. The 
Current Settings summary provides information about the settings currently selected on the 
Design tab (as described above). The Prior Settings summary provides a record of the design 
settings that were originally used to build the experiment plan. 
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If any changes were made to the experiment plan via the Data tab (e.g., runs were manually 
deleted), the Prior Settings summary will describe the experiment as "customized." In other 
words, the Design tab settings that were originally used to create the experiment may no 
longer accurately represent it. In addition, depending on the change that was made, it may no 
longer be possible to recreate the current experiment using the Design tab settings (e.g., the 
experiment may no longer fit into any of the basic design types). For these reasons, the Design 
tab will be considered permanently out of sync with the current experiment. 

If no changes were made via the Data tab, then you can use the Prior Settings summary as a 
reference while you modify the settings on the Design tab. For example, if you want to undo 
some of the changes you've made to the Design tab settings since the experiment plan was 
built, you can compare the two summaries to see what has changed, or you can choose Design 
> General > Undo Changes to quickly bring the Design tab back in sync with the Data tab (i.e., 
the Design tab settings will once again accurately describe the built experiment). 

 

Changing Design Settings 

After building a design (i.e., creating a Data tab in the design folio), you may wish to change 
some of its settings (e.g., the number of replicates that are used, or the number of factors). 
There are several ways to do this: 

• In most cases, you can return to the Design tab of the folio, change the settings and then 
rebuild the design by choosing Design > General > Build Design. 
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In the window that appears, select whether you wish to create a new folio for the modified 
design, or whether you wish to overwrite the experiment plan on the Data tab. If you select 
the Maintain response data check box, the response data from the prior design will be 
included in the modified design. 

Note that when you modify the experiment using the Design tab, two design summaries 
will become available under the Design Summary heading. The Current Settings summary 
shows the settings that are currently selected on the Design tab. The Prior Settings 
summary shows the settings that were originally used to build the experiment on the Data 
tab. 

• If, after changing the settings on the Design tab, you want to revert to the settings that 
were originally used, choose Design > General > Undo Changes. 

 

• You can also choose Design > General > Clear Settings to put the Design tab in its 
original state (i.e., using default settings that change depending on the design type you 
choose). 

 

• If you wish to make changes that aren't possible with the Design tab settings, you can 
customize the experiment by: 

• Manually changing any of the values (e.g., factor levels) that are shown on the Data 
tab. To do this, simply click inside a cell, change the value and press ENTER. 

• Using one of the following features to modify the experiment automatically. 

• Use the augment design feature to add new blank rows to the Data tab, or to add 
replicates of the entire design. 

• Use the fold design feature to add a replicate to the design with runs that use the 
opposite levels for all the factors you specify. 

• Use the tool for creating an optimal design. The new design will have fewer runs, 
and when creating the design the software can consider the number of runs you 
wish to use, the effects you wish to investigate and which factor level combinations 
you wish to use in the experiment. 
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Importing/Exporting Design Settings 

When the Design tab of a design folio is active, you can choose to save the current design 
settings or load the settings from a design that was previously saved. 

• To save all your current design settings for use in future designs, choose Design > 
Import/Export > Export Template or click the icon on the control panel. 

 

Then specify the name and location of the experiment file (*.dex) that will store all the 
current design settings. 

• To overwrite all the settings of your current design and use the settings from an experiment 
file instead, choose Design > Import/Export > Import Template or click the icon on the 
control panel. 

 

Then select the *.dex file that has all the desired settings. 

Data Tab 

After you build a design with the Design tab, you can use the Data tab to enter response data 
and change settings in the built design. By analyzing the data, you can investigate the 
relationship between factors and responses. Depending on the data you provide and the type 
of design you use, you may then be able to use this information to determine the optimal 
response and/or predict response levels using the analysis results. 

Data Tab Columns 

After you build a design, the Data tab will include a test plan with Response columns for 
entering response data. Each cell in a Response column is used to record the response value 
obtained at the combination of factor settings (green columns) specified in the current row. 
Note that robust parameter designs work differently; for more information on using these 
designs, see Using Robust Parameter Designs. 

The columns shown in the test plan will vary depending on the design type you are working 
with. To hide/show columns, choose Data > Format and View > Visible Columns or click the 
Visible Columns icon on the control panel. 
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The available columns are described below.  

• Standard Order displays the basic order of runs, as specified in the design type, without 
randomization. This pattern is provided as a reference (e.g., textbook examples often use 
the standard order). 

Tip: If you need to use a non-randomized order in an actual experiment, you can sort the 
design by clicking a cell in the column you wish to sort by and choosing Sheet > Sheet 
Actions > Sort > [Order]. For example, if changing levels in a randomized experiment would 
be too expensive, you can sort the design table by factor levels. 

• Run Order displays the randomized order generated by the software. By conducting 
experiments using a randomized order, you can reduce the effect of factors not being 
investigated. 

• Point Type indicates what kind of point the run is. 0 indicates that the run is a center point. 
1 is used for all other points. 

• Block Value displays the block to which the run belongs. If the design is not blocked, all 
rows will display the same default value. 

• Life Data Columns are present only for reliability DOE. The columns that are available 
depend on the type of life data specified when the design was created. These columns take 
the place of the response column(s) in a standard design, and are used to calculate the 
underlying response for the design, which is considered to be time. 

• Time Failed Column allows you to enter the failure time for each unit. This column is 
available only for times-to-failure data with no censoring (complete data). 

• State F or S Column allows you to specify whether the unit is failed (F) or suspended 
(S). This column is available only for data with right censoring. 

• Time to F or S Column allows you to enter the failure time for the unit or, in the case of 
suspended units, the time at which the unit was removed from the test while still 
operating. Note that you can enter a negative number in this column and it will 
automatically be marked as a suspension in the State F or S column. This column is 
available only for data with right censoring. 

• Last Inspected Column allows you to enter the last time the unit was inspected prior to 
the time it failed. This column is available only for data with interval and/or left 
censoring. 
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• State End Time Column allows you to enter the time at which the unit’s state was 
discovered (i.e., the first inspection time after the unit’s failure). This column is 
available only for data with interval and/or left censoring and without right censoring. 

To change the type of life data used in the experiment, use the Alter Data Type 
window. 

• Factor Columns display the settings used for each factor in the run. By default, these 
columns are titled using the format "X: Factor Name," where X is the abbreviated name. If 
you have defined the units for the factor, that will also be displayed in the column heading. 
Factor columns are shown in green by default. 
 
Factor levels can be displayed as the actual values assigned in the factor properties or as 
coded values. When you use coded values for two level factorial or Plackett-Burman 
designs, the low level will be displayed as -1 and the high level will be displayed as 1. When 
you use coded values for general full factorial or Taguchi OA factorial designs, the lowest 
level will be displayed as 1, the next level as 2, and so on. To switch between coded and 
actual values, choose Data > Display > [Value Type]. 

• Ignore / Include allows you to specify whether the run will be included in the analysis. You 
can also enter an asterisk (*) in a response column to ignore that data point. 

• Comments allows you to enter notes or other text for each run. This information is not 
used in any calculations. 

If your design includes only one observation per test run, the following columns may be 
available: 

• Response Columns allow you to enter the response(s) for each test run. A response column 
heading will include the response name and (if specified) units you have defined on the 
Design tab. 
 
Each column contains a check box in the column heading that specifies whether the 
response will be included in the analysis. If a column is selected, the color of the check box 
border will indicate the status of that response's analysis. A green border indicates that the 
response has been analyzed using the current analysis settings; a red border indicates that 
it has not. Note that if you clear the check box, you will not be able to specify analysis 
settings for the response, nor will you be able to display it in plots or use it in optimization. 

• Response Standard Deviation Columns are available only when you select to perform 
variability analysis. These columns are populated by the software when the data set is 
analyzed, and they show the standard deviation of the selected response at each factor 
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level combination. (Asterisks indicate that the standard deviation was shown in a previous 
row.) 

If your design includes multiple measurements per test run, the following columns will be 
available:  

• Repeated Measurements Columns are available if you chose to include repeated 
measurements under the Additional Settings on the Design tab. The measurements for 
each test run are used to generate an average and standard deviation value for that run, 
either of which can be selected as the analyzed response for the experiment. 

• The Y Mean and Y Standard Deviation Columns are populated by the software when the 
data set is analyzed. They show the mean and standard deviation of the measurements 
taken during each test run. 

Data Tab Control Panel 

The design folio control panel allows you to control the settings for analyzing response data and 
evaluating an experiment design. It also displays the results of the analysis/evaluation. The 
panel is composed of the following pages: 

• The Main Page contains most of the tools you will need to analyze response data. 

• The Analysis Settings Page contains the analysis settings that are also displayed on the 
Main page. 

• The Evaluation Settings Page contains the settings that are used when you perform a 
design evaluation. 

• The Comments Page allows you to enter notes or other text that will be saved with the 
folio. 

• If your design includes a life data response, the Identifiers and Publishing pages will also be 
available. These pages allow you to publish the results as a model. 

Main Page 

The Main page of the control panel includes the following tools and areas. 

Folio Tools 

The folio tools are arranged on the left side of the control panel. Use these tools to configure 
your analysis and experiment with the analysis results. Depending on the type of design you are 
working with, the control panel may contain some or all of the following tools: 
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  Calculate analyzes the data for each response that is selected to be included in the 
analysis. To exclude a response from the analysis, clear the check box in its column heading. 

  Plot creates a plot based on the analysis. If you click this icon before the current data 
set has been analyzed, an analysis will be performed automatically. 

  Select Terms opens a window that allows you to specify the terms (i.e., factors, 
factorial interactions, blocks and quadratic effects) to be considered for each response. 

  View Analysis Summary opens a window that contains detailed information about 
current and past analysis results. 

  Optimization adds an optimal solution plot to the Optimization folio that is linked to 
the design folio. If no linked Optimization folio exists, the software will create one. 

  Overlaid Contour Plot adds an overlaid contour plot to the Optimization folio that is 
linked to the folio. If no linked Optimization folio exists, the software will create one. 

  Select Transformation opens a window that allows you to select a transformation to 
apply to each response. 

  Prediction opens a window that allows you to enter values for each factor and see 
predicted results for the selected response. 

  Transfer to Simulation Worksheet transfers the factor settings to a new simulation 
worksheet. 

  Visible Columns opens a window that allows you to choose which columns to 
hide/show in the Data tab. 

  Transfer Data to Life Data Folio is available only for reliability designs. It transfers the 
data from the design folio to a new life data folio. The factor settings are noted in a subset 
ID column in the new folio. 

  Transfer Data to Life-Stress Folio is available only for reliability designs. It transfers 
data from the design folio to a new life-stress folio. The factor settings are entered in stress 
columns; each factor is considered a separate stress. 
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Settings Area 

The Main page of the control panel may also contain some or all of the following settings. 
Information and examples on how to use these settings for particular designs are available in 
the documentation for the various design types. 

• The Response drop-down list is used to select the response that all the displayed settings 
and analysis results will apply to. 

 

• The Distribution area is used to select a life distribution for reliability DOE. 

 

If you already have a reliable estimate for the selected distribution's shape parameter, you 
can fix the parameter at that value by choosing Data > Design > Set Shape Parameter. 

 

Setting this parameter can reduce the uncertainty in your results, since the analysis will 
solve for fewer variables. 

• The Settings area is used to view the available analysis settings, which vary depending on 
the design type. The following picture shows an example of the settings that are available 
in a two level factorial design. 

  

In this example: 



Chapter 10: DOE Design Folios 

732 https://www.reliasoft.com/weibull 

 

• The partial sum of squares ("Partial SS") and grouped terms are used. 

• The specified risk level is 10%. 

• No transformation is used (i.e., the "transformed" response, Y', is equal to the non-
transformed response, Y). 

• "Analyzed" is shown in green, which indicates that the current response data has been 
analyzed using the current settings. Otherwise, this would show "Modified" in red. 

• The last row indicates that the analyzed data consists of 12 observations. 

To configure the settings used in the analysis, click the blue text. These settings are also 
accessible on the Analysis Settings page of the control panel. See the Design Folio Control 
Panel Analysis Settings Page section for a description of all available settings. 

Note: If you are using a robust parameter design and the selected response is signal noise 
ratio, this area will also include a row to indicate which kind of signal noise ratio is being 
analyzed (i.e., nominal, smaller or larger). 

Analysis Summary Area 

The Analysis Summary area is shown when the current response data has been analyzed using 
the current settings. This area displays the terms that were found to be significant, as well as 
their associated regression coefficients. Click the View Analysis Summary icon in this area to 
view the details of the analysis results (including an ANOVA table). 

 

Design Evaluation Area 

The Design Evaluation area is used to help you determine the efficiency of the current design. 
In the picture shown next, the main effect that is the least likely to be detected by design has a 
45.02% of being detected. Click the Detailed Results link in this area to view details of the 
evaluation results (including the probability of detection, or power, for individual effects and 
interactions). 



Chapter 10: DOE Design Folios 

Weibull++ 2020 User's Guide 733 

 

 

Analysis Settings Page 

The Analysis page of the design folio control panel includes additional settings that may be 
applicable for the current analysis. It may contain some or all of the following options (which 
can also be changed on the Main page of the control panel). 

 

• The Response Settings drop-down list is used to choose the response that all the visible 
settings and analysis results will apply to. When you choose a response here, it will 
automatically be chosen when you return to the Main page. 

• The Risk Level, or alpha value, is a measure of the risk that the analysis results are incorrect 
(i.e., alpha = 1 - confidence level). 

• The next area allows you to specify the Type of Sum of Squares to use in the analysis. 
Select the Partial Sum of Squares option to test if a term is significant given that all other 
terms are considered in the model. Select the Sequential Sum of Squares option to test if 
an additional term is significant given that the terms before it are already in the model. This 
area is not applicable to R-DOE. 

• The Test Terms area specifies what the information in the ANOVA table in the Design Folio 
Analysis Results applies to. If you select Individual Terms, the software will separately 
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examine the effects of each individual factor and/or factorial interaction. If you select 
Grouped Terms, it will examine groups of effect types, such as main effects, two-way 
interactions, etc. 

You can also analyze the selected response or open the Select Transformation window by 
clicking the icon to the left of the Response Settings area. 

Design Folio Analysis Results 

When accessed from a design folio, the Analysis Summary window will contain detailed 
information about analysis results, including information that describes how each factor and 
factorial interaction affects the variation of the response that is currently selected in the Data 
tab control panel. 

If the current response data has been analyzed, you can open the window by clicking the View 
Analysis Summary icon on the control panel. 

 

If the current response data have not been analyzed, the icon will still be available so you can 
view the folio's analysis history. 

Analysis Results 

Depending on the type of design you are working with, the analysis results may contain some or 
all of the following: 

The Analysis of Variance (ANOVA) table provides general information about the effects of the 
factor(s) and factorial interactions on the selected response. For designs with multiple factors, 
this information may be presented for individual factors and interactions or for groups of 
factors and interactions, depending on your analysis setting on the control panel.  

ANOVA Table Columns 

• Source of Variation is the source that caused the difference in the observed output 
values. This can be a factor, factorial interaction, curvature, block, error, etc. If your 
design includes more than one factor and you have selected to use grouped terms in 
the analysis (specified on the Analysis Settings page of the control panel), the effects 
will be grouped by order (i.e., main effects, two-way interactions, etc.). Sources 
displayed in red are considered to be significant.  

• The number of Degrees of Freedom for the Model is the number of regression 
coefficients for the effects included in the analysis (e.g., two coefficients might be 
included in the regression table for a given main effect). The number of degrees of 
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freedom for the Residual is the total number of observations minus the number of 
parameters being estimated.  

• Sum of Squares is the amount of difference in observed output values caused by this 
source of variation.  

• Mean Squares is the average amount of difference caused by this source of variation. 
This is equal to Sum of Squares/Degrees of Freedom.  

• F Ratio is the ratio of Mean Squares of this source of variation and Mean Squares of 
pure error. A large value in this column indicates that the difference in the output 
caused by this source of variation is greater than the difference caused by noise (i.e., 
this source affects the output).  

• P Value (alpha error or type I error) is the probability that an equal amount of variation 
in the output would be observed in the case that this source does not affect the output. 
This value is compared to the risk level (alpha) that you specify on the Analysis Settings 
page of the control panel. If the p value is less than alpha, this source of variation is 
considered to have a significant effect on the output. In this case, the term and its p 
value will be displayed in red.  

• The following values are shown underneath the ANOVA table, and they indicate how 
well the model fits the data:  

• S is the standard error of the noise. It represents the magnitude of the response 
variation that is caused by noise. Lower values indicate better fit. 

• R-sq is the percentage of total difference that is attributable to the factors under 
consideration. It is equal to Sum of Squares(factor)/Total Sum of Squares. Higher 
values usually indicate better fit. 

• R-sq(adj) is an R-sq value that is adjusted for the number of parameters in the 
model. Higher values indicate better fit. 

The Data Summary table is available only for one factor designs. It gives the mean and standard 
deviation of the output at each level of the factor.  

Data Summary Table Columns 

• Factor Level is the name of the qualitative level. 

• Number in Level is the number of data points obtained at the factor level. 

• Estimated Mean is the average of the data points obtained at the level. 
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• Standard Deviation is the standard deviation of the data points obtained at the level. 

The Mean Comparisons table is available only for one factor designs. It provides information on 
comparisons between factor levels. The table includes the following columns: 

Mean Comparisons Table Columns 

• Contrast gives the paired comparison of any two levels. Level 1 - Level 2 means the 
difference between Level 1 and Level 2. Contrasts displayed in red are considered to be 
significant. 

• Mean Difference is the mean value of the difference in output between the two levels. 

• Pooled Standard Error is the standard error of the mean difference in output between 
the two levels. 

• Low Confidence is the lower confidence bound of the mean difference. 

• High Confidence is the upper confidence bound of the mean difference. 

• T Value is the normalized difference, which is equal to Mean Difference/Pooled 
Standard Error. 

• P Value is the probability that an equal amount of variation in the output would be 
observed in the case that there is no significant difference between the levels. This 
value is compared to the risk level (alpha) that you specify on the Analysis Settings page 
of the control panel. If the p value is less than alpha, there is considered to be a 
significant difference between the levels. In this case, the contrast and its p value will 
be displayed in red. 

The Regression table provides specific information on the contribution of each factor or 
factorial interaction to the variation in the response and an analysis of the significance of this 
contribution. 

Note: For each factor with n levels, n-1 effects are estimated (e.g., one effect is estimated for a 
two level factor, four effects are estimated for a five level factor). For a two level factor, the 
effect is the difference of the average response at the two levels. For factors with more levels, 
the average response at one level is considered to be a baseline and the average responses at 
other levels are compared with that baseline. If more than one effect exists for a factor, the 
effects are differentiated with a number along with the factor’s letter designation (e.g., A[1], 
A[2]). 

Regression Table Columns 
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• Term is the factor, factorial interaction, curvature, block, etc. under consideration. 
Terms displayed in red are considered to be significant. In cases where there is no error 
in the model, significant effects are determined according to Lenth’s method and the 
term names are displayed in red and followed by an asterisk (*). 

• Effect is a measure of how much the response value (Y) changes when the value of the 
corresponding term in the model changes from the low level to the high level. 

• Coefficient is the regression coefficient of the term, which represents the contribution 
of the term to the variation in the response. 

• Standard Error is the standard deviation of the regression coefficient. 

• Low Confidence and High Confidence are the lower and upper confidence bounds on 
the regression coefficient. 

• T Value is the normalized regression coefficient, which is equal to Coefficient/Standard 
Error. 

• P Value (alpha error or type I error) is the probability that an equal amount of variation 
in the output would be observed in the case that this term does not affect the output. 
This value is compared to the risk level (alpha) that you specify on the Anaysis Settings 
page of the control panel. If the p value is less than alpha, this source of variation is 
considered to have a significant effect on the output. In this case, the term and its p 
value will be displayed in red. 

The Likelihood table is available only for reliability designs. It provides general information 
about the factor's effects on the times-to-failure.  

Likelihood Table Columns 

• Model displays the model for which the results apply. 

• Reduced assumes that the product life is the same at different levels of the factor. 

• Full assumes that the product life is different at different levels of the factor. 

• Degrees of Freedom is the degrees of freedom of this source of variation. This is also 
the number of parameters in the model for this source. 

• Ln(Likelihood Value) is the logarithm transformation of the likelihood value for this 
source of variation. 

• Likelihood Ratio is the likelihood ratio value for this source of variation. 
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• P Value is the probability that LR is from a chi-squared distribution, which would 
indicate that the factor has no effect on product life. This value is compared to the risk 
level (alpha) that you specify on the Analysis Settings page of the control panel. If the p 
value is less than alpha, then the factor is considered to have a significant effect on 
product life. In this case, the effect and its p value will be displayed in red. 

The MLE Information table is available only for reliability designs. It provides specific 
information on the contribution of each factor or factorial interaction to the variation in the 
times to failure and an analysis of the significance of this contribution.  

MLE Information Table Columns 

• Term is the factor, factorial interaction, etc. under consideration. Terms displayed in 
red are considered to be significant. 

• Effect is a measure of how much the response value (Y) changes when the value of the 
corresponding term in the model (using coded values) changes from -1 to 1. 

• Coefficient is the regression coefficient of the term, which represents the contribution 
of the term to the variation in the response. 

• Standard Error is the standard deviation of the regression coefficient. 

• Low Confidence and High Confidence are the confidence bounds on the regression 
coefficient, using Fisher bounds. 

• Z Value is the normalized regression coefficient, which is equal to Coefficient/Standard 
Error. 

• P Value is the probability that an equal amount of variation in the output would be 
observed in the case that this source does not affect the output. This value is compared 
to the risk level (alpha) that you specify on the Analysis Settings page of the control 
panel. If the p value is less than alpha, this source of variation is considered to have a 
significant effect on the output. In this case, the term and its p value will be displayed in 
red. 

The Life Characteristic Summary table is available only for one factor reliability designs. It gives 
the characteristic life and standard deviation for the product at each factor level, along with 
lower and upper confidence bounds. 

Life Characteristic Summary Table Columns 

• Factor Level is the name of the level. 
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• Number in Level gives the number of failures (F) and suspensions (S) in the level. 

• The next column is the characteristic life at that level. 

• Eta is shown for the Weibull distribution, and it is equal to the time at which 
unreliability = 63.2%. 

• Ln-Mean is shown for the lognormal distribution, and it is equal to the time at 
which unreliability = 50%. 

• MTTF (i.e., the mean time to failure) is shown for the exponential distribution. 

• The Standard Deviation is also shown for the characteristic life. 

• Low Confidence and High Confidence give the two-sided confidence bounds on the 
characteristic life, based on the risk level entered on the Analysis Settings page of the 
control panel (e.g., if the risk level is 0.1, then 90% two-sided bounds will be shown). 

The Life Comparisons table is available only for one factor reliability designs. It provides 
information on comparisons between levels of the factor, allowing you to determine whether 
one particular level is significantly different from another. 

Life Comparisons Table Columns 

• Contrast gives the paired comparison of any two levels. Level 1 - Level 2 means the 
difference between Level 1 and Level 2. Contrasts displayed in red are considered to be 
significant. 

• Mean Difference is the mean value of the difference in output between the two levels. 

• Pooled Standard Error is the standard error of the mean difference in output between 
the two levels. 

• Low Confidence is the lower confidence bound of the mean difference. 

• High Confidence is the upper confidence bound of the mean difference. 

• T Value is the normalized difference, which is equal to Mean Difference/Pooled 
Standard Error. 

• P Value is the probability that an equal amount of variation in the output would be 
observed in the case that there is no significant difference between the levels. This 
value is compared to the risk level (alpha) that you specify on the Analysis Settings page 
of the control panel. If the p value is less than alpha, there is considered to be a 
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significant difference between the levels. In this case, the contrast and its p value will 
be displayed in red. 

The Regression Equation information is presented using multiple tables. The available tables 
will vary depending on the design type you are working with. The results that could be available 
include: 

Regression Equation Tables 

• The Response table displays the response that the regression equation applies to and 
the units of measurement that were entered for the response (if any). 

• The Additional Settings table shows the transformation and risk level you entered for 
the response. 

• The Significant Terms table is applicable only when at least one term was found to be 
significant. It shows the significant terms in the Name column and the associated 
regression coefficients in the Coefficient column. 

• The Equation tables show the regression coefficients for the model of the selected 
response. For example, consider this table: 

 

The corresponding model for this table is y = 9.3903 - 0.8467x1 + 1.2813x2 + 0.7303x1x2. 

• The first Equation table shows the coefficients for a model that uses coded values 
for the factors. 

• The second Equation table shows the coefficients for a model that uses the actual 
factor values. 

Additional Results 

All of the following tables provide information that was generated from the main calculations. 
The available tables will vary depending on the design type you are working with. The results 
that could be available include: 

Alias Structure 
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This item is available for all designs with at least two factors. It describes the alias structure 
for the design, taking into account only the terms you've selected to include in the analysis. 
Together with your engineering knowledge, you can use this information to help determine 
whether any important interaction information was lost due to aliasing. When aliased 
terms exist, the following areas will be shown: 

• Terms selected to be in the model lists all the terms that are considered for inclusion in 
the regression model (i.e., the selections in the Select Terms window). 

• Terms included in the model lists all the selected terms that are included in the model. 
The alias structure determines which terms are excluded. 

• Alias Structure lists the aliased effects based on the selected terms. For example, A • B 
= A • B + C • D means the interaction effect A • B is aliased because it is 
indistinguishable from effect C • D. Therefore, the model cannot include both 
interaction terms; it will include only one (e.g., A • B). 

Alias Summary 

The terms in the first column of this table are aliased with the terms shown in the second 
column. Only the terms in the first column are included in the model. 

Var/Cov Matrix 

This shows the variance/covariance matrix, which is available for one factor R-DOE designs 
and all other designs with two or more factors. The diagonal elements in this matrix are 
used to calculate the coefficients in the MLE or Regression Information table. 

Diagnostic Information 

This table is available for one factor R-DOE designs and all other designs with two or more 
factors. It displays various analysis results for each run and highlights significant values. The 
following columns are included: 

• Run Order is the randomized order, generated by the software, in which it is 
recommended to perform the runs to avoid biased results. Note that any changes 
made to the Run Order column on the Data tab will be reflected here. 

• Standard Order is the basic order of runs, as specified in the design type, without 
randomization. Note that any changes made to the Standard Order column on the Data 
tab will be reflected here. 

• Actual Value (Y) is the observed response value for the run, as entered in the response 
column on the Data tab. 
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• Predicted Value (YF) is the response value predicted by the model given the factor 
settings used in the run. 

• Residual (or "regular residual") is the difference between the actual value (Y) and the 
predicted value (YF) for the run. 

• Standardized Residual is the regular residual for the run divided by the constant 
standard deviation across all runs. 

• Studentized Residual is the regular residual for the run divided by an estimate of its 
standard deviation. 

• External Studentized Residual is the regular residual for the run divided by an estimate 
of its standard deviation, where the run in question is omitted from the estimation. 

• Leverage is a measure of how much the run influences the predicted values of the 
model, stated as a value between 0 and 1, where 1 indicates that the actual response 
value of the run is exactly equal to the predicted value (i.e. the predicted value is 
completely dependent upon the observed value). 

• Cook’s Distance is a measure of how much the output is predicted to change if the run 
is deleted from the analysis. 

Values that are considered to be significant, or outliers, are displayed in red. For the 
residual columns, significant or critical values are those that fall outside the residual’s upper 
or lower bounds, calculated based on the specified alpha (risk) value.  

The ReliaWiki resource portal has more information on how significant values are 
determined for the Leverage and Cook's Distance columns at: 
http://www.reliawiki.org/index.php/Multiple_Linear_Regression_Analysis. 

Least Squares Means 

This table shows the predicted response values for the given factor levels. It includes the 
following columns: 

• Effect is the main effect or interaction used to predict the response. The coefficients for 
effects not used in the prediction are set to zero. 

• Level is the combination of factor levels used to predict the response. 

• Mean is the predicted response value. 

Regressor 

http://www.reliawiki.org/index.php/Multiple_Linear_Regression_Analysis
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This table is available only for mixture designs. It shows the values of each term used in the 
regression equation (whereas the Regression Equation table shows the coefficients). 

Analysis Summary Window 

The Analysis Summary window allows you to display a detailed summary of current and past 
analysis results. This window is available from any of the following folios: 

• The standard, robust or mixture design folios 

• The free form folio 

• The multiple linear regression folio 

• The one-way ANOVA folio 

• All of the measurement system analysis folios 

To access the window, click the View Analysis Summary icon. 

 

In addition to a spreadsheet that displays analysis information, the window includes two panels 
and a ribbon, as described next. 

Available Report Items Panel 

The Available Report Items panel is used to determine which analysis results will display in the 
spreadsheet. The items you see in this panel will vary depending on the design type and/or folio 
that you are working with. If desired, you can edit the results anywhere in the spreadsheet by 
clicking a cell. These changes can then be copied to the Windows Clipboard or exported to an 
Excel spreadsheet using the ribbon. 

Analysis History Panel 

The Analysis History panel includes a history of all the results for all analyses that have been 
performed in the folio. To display the results of a prior analysis, click the date and time of that 
analysis in the list. 
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You can switch between the panel's hidden and displayed states by clicking the Hide/Show icon 
in its title bar. 

 

When the panel is in its hidden state, a bar containing the analysis history will be displayed on 
the left side of the window, and the list of results will be hidden until you click the bar, as 
shown next. To hide the results again, click outside the list. 

 

The Ribbon 

The ribbon of the Analysis Summary window allows you to cut, copy, paste and print the 
displayed analysis results, as well as save them in an Excel spreadsheet. 

If you choose Settings > Apply Settings from the ribbon, the analysis settings that were used to 
obtain the displayed results will be applied to the current analysis. For example, if you used the 
Analysis History panel to view results that were obtained using a risk level of 0.5, and if you 
wanted to use that risk level and all the other settings from that prior analysis, you would 
choose this command and then recalculate the folio. 
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Note that you can apply the settings from a prior analysis only if it is based on the same design 
and response data as the current analysis. If this isn't the case for the displayed analysis results, 
then the results will include red text that says, "The design has been modified since this history 
was created. These settings can no longer be applied to this response." 

Select Terms Window 

The Select Terms window allows you to specify, for each response, which main effects and 
interaction effects you want to include in the analysis of each response and in the evaluation of 
the design for each response. It is accessed by choosing Data > Design > Select Terms or 
clicking the icon on the Data tab control panel. 

 

The window will appear as shown next. If the response data has been analyzed already, any 
terms that were found to be significant will be highlighted in red. 

 

• The Response drop-down list allows you to select the response you want to select 
regression terms for. 

• If you are working with a mixture design that includes process factors, the Include process 
factors up to drop-down list will be available. Use this drop-down to automatically select 
only those process factor terms that are required to fit a model of the order you choose. 
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After the terms are automatically selected, you can add/remove individual terms as 
desired. 

• The check boxes in the Desired Terms area allow you to select which terms you want to 
include in the analysis/evaluation. Note that if you select an interaction term, you must also 
select the interacting effects under the Main Effects heading (e.g., if you select interaction 
AC, then you must select the main effects A and C individually). 

• The Block check box directly underneath the All Terms heading allows you to specify 
whether you want to include blocks in the model. This option is available only if the 
design you are working with is blocked. 

• Quadratic Effects check boxes are available only for factors with three or more unique 
values. They are used to determine whether the factors have curvature effects. 

• The following terms are available for mixture designs only: 

• Mixture Factors includes all the terms for fitting different types of models (linear, 
quadratic, etc.). By default, the terms required to fit a quadratic model are 
selected. 

• Process Factors include all the terms for investigating the effects of mixture factors 
under the influence of the process factors. Instead of selecting process factors 
individually, you can use the Include Process Variables up to order drop-down list 
at the top of the window to automatically select the process variables needed to 
investigate effects up to a given order. 

• The Select Significant Terms icon (   ) automatically selects all terms that were found to 
be significant when you last analyzed the data. All other terms will be cleared. 

• The Apply to All Responses icon (  )applies the current selections to all other responses 
(if any) instead of just to the response you selected. 

• The Reset Defaults icon (  ) selects all terms for all responses. 

After you select the desired terms, click OK and recalculate the folio to update the analysis or 
evaluation. 

Select Transformation Window 

Analysis of variance is based on two assumptions: 

1. The response in question is normally distributed. 
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2. The error variance of each observation is constant (i.e., it does not change with either the 
observation time or the observed response value). 

If either of these assumptions is violated, applying a transformation to the response may be 
useful. 

The Select Transformation window allows you to select a transformation to apply to each 
response. It is accessed by choosing Data > Design > Select Transformation or clicking the icon 
on the Data tab control panel. 

 

To use the window, first choose the response you want to work with from the Response drop-
down list. 

Next, select a transformation from the Transformation drop-down list. 

 

The equation for the transformation will be displayed and input areas for any required inputs 
will be available under the Transformation heading. In the example shown next, 0 was entered 
for the A parameter in the equation . 
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If you are not certain what transformation, if any, to apply to the selected response, you can 
calculate the data in the folio and then obtain information on the Box-Cox transformation 
results for the selected response, which helps in selecting an appropriate transformation. The 
Box-Cox Results area will display the best lambda value for the response, including the two-
sided confidence bounds at the level determined by the risk level (alpha) you have specified. 
The recommended transformation will be displayed in the Recommended Transformation 
area, as shown next. 

 

Click the link to automatically choose it in the Transformation drop-down list. 

Repeat the process for any other responses you want to apply a transformation to, and then 
click OK to return to the folio, where you can recalculate using the selected transformation(s). 



Chapter 10: DOE Design Folios 

Weibull++ 2020 User's Guide 749 

 

Available Transformations and Requirements 

The following table displays the transformations that can be applied to responses in DOE folios 
and specifies any requirements for using the transformations. 

Transformation Name Transformation Equation Data Requirements 

None 
 

None 

Square Root 
 

 

Natural Log 
 

 

Base 10 Log 
 

 

Inverse Square Root 
 

 

Inverse 
 

 

Power 
 

 
 
 
 

Logit 
  

ArcSin Square Root 
 

 

Augmenting Designs 

After building an experiment design, you may wish to augment the design by adding individual 
runs or replicates. For example, after performing all the runs for a design and entering the 
response data, you may decide to perform one more replicate of the entire design to get more 
precise results. Or you may decide to add rows to the data sheet for additional runs that 
include center points, etc. 

To augment a built design, choose Data > Design > Augment Design or right-click a cell in the 
design and choose Augment Design from the shortcut menu. 

 

The following options will appear: 
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• To add a specific number of blank rows to the design, enter a number in Append Rows field 
and click OK. The new rows will be added at the bottom of the table. 

• The Add Replicates field is used to add replicates of the entire current design. For example, 
if there are 20 rows in the current design, then adding 1 replicate will add 20 new rows that 
use the same factor combinations as the original design. 

Note: After you augment a design, the selected options on the Design tab will no longer fully 
reflect the experiment described on the Data tab. In other words, rebuilding the design from 
the Design tab will remove the appended rows/replicates. 

Fold Design Window 

When you fold a factor over in a design, you replicate the design with runs that use the 
opposite levels for that factor. For example, if you fold over Factor A, the design will be 
replicated, and in each new row the value of Factor A will be opposite of what it was in the 
original row that was copied (i.e., the -1 values will be replaced with the 1 values and vice 
versa). The ability to fold the design is available only for designs that require two-level factors 
(i.e., two level factorial and Plackett-Burman designs). 

To fold a design, choose Data > Design > Fold Design. 

 

The Fold Design window will appear as shown next. 
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The first area in the window allows you to select the Factors to Fold Over. 

The Fold Factors In area allows you to select whether you would like to add the new rows to a 
new block or to the existing blocks. 

Design Folio Plots 

The Analysis Plot tab is added to a design folio the first time you choose Data > Analysis > Plot 
or click the icon on the Data tab control panel. 

 

The options available on the Analysis Plot control panel vary depending on the selected plot. 
For general information on working with plots, see Plot Utilities. 

The available plots will vary depending on the design type you are working with. The following 
plots may be available. 

Level Plots (One Factor Designs Only) 

Level plots allow you to visually evaluate the effects of different factor levels on the selected 
response. 
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• The Comparison Chart shows the standardized difference for each paired comparison of 
factor levels. Use the Contrasts area of the control panel to select which pair of levels to 
show on the plot. 

• The Response vs. Level plot shows the observed output, or response, as well as the 
calculated mean output, at each level of the factor. 

• The Level Mean plot shows the mean output at each level of the factor. The center point of 
each level line is the calculated mean and the end points represent the high and low 
confidence bounds on the mean based on the alpha (risk) value specified on the Analysis 
Settings page of the control panel. 

• The Box Plot shows the output at each level of the factor. The top and bottom points at 
each level represent the highest and lowest responses. The points within the box represent 
the responses at the 25th, 50th and 75th percentile. 

• The Mean PDFs plot shows the pdf of the mean response at the selected factor levels. 

• The Life Characteristic plot (reliability DOE only) shows the calculated life characteristic at 
each factor level. The top and bottom tick marks on the vertical lines mark the two-sided 
confidence bounds on the life characteristic. The confidence level for the bounds is 
determined by the risk level specified on the Analysis Settings page of the Data tab control 
panel (e.g., if the risk level is 0.1, then 90% two-sided bounds would be shown).The value of 
the characteristic life depends on the selected distribution. 

• Eta is used for the Weibull distribution, and it is equal to the time at which unreliability 
= 63.2%. 

• Ln-Mean is used for the lognormal distribution, and it is equal to the time at which 
unreliability = 50%. 

• MTTF (i.e., the mean time to failure) is used for the exponential distribution. 

Effect Plots 

Effect plots allow you to visually evaluate the effects of factors and factorial interactions on the 
selected response. 

• The Pareto Chart - Regression plot shows the standardized effects of the selected terms 
(i.e., factor or combination of factors). The vertical blue line is the threshold value. If a bar 
is beyond the blue line, it will be red, indicating that the effect is significant. 
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• The Pareto Chart - ANOVA* plot shows the inverse p value (1 - p) of each selected term. 
The vertical blue line is the threshold value. If a bar is beyond the blue line, it will be red, 
indicating that the term is significant. 

• The Pareto Chart - LRT (reliability DOE only) shows the inverse p value for the reduced 
model in the likelihood table. The vertical blue line is the threshold value. If the bar is 
beyond the blue line, it will be red, indicating that the factor has a significant effect on 
reliability. 

• The Effect Probability plot is a linear representation of probability versus the standardized 
effect (i.e., the probability that any term’s standardized effect will be lower than the given 
value). The points on this plot represent the values for each term in the T Value column of 
the Regression Table in the detailed analysis results. If there is no error in the design, then 
the probability versus the effect is shown and the points on this plot represent the values 
for each term in the Effect column of the Regression Table in the analysis results.  

• Select Normal in the Scale Type area to display the negative and positive values of the 
effects (coefficients). The negative effects will appear to the left of the probability line. 

• Select Half-normal to display the absolute values of all the effects, which allows you to 
compare the size of each effect. All the effects will appear to the right of the probability 
line. 

• The Main Effects plot shows the mean effect of the selected factor(s). The points are the 
observed Y values at the low and high level for each factor. The line connects the mean 
value at each factor level, and you can specify how the means are calculated in the 
Calculation Options area. Note that if you are using actual factor values in the plot, you can 
plot only one factor at a time. If you are using coded values, you can plot multiple factors 
simultaneously. For mixture designs, this plot applies only to process factors (i.e., process 
variables). 

• The Interactions plot shows the mean effect of a selected factor versus another selected 
factor at each level. If the green and red mean effect lines are parallel, there is no 
interaction between the two factors. You can specify how the means are calculated in the 
Calculation Options area. For mixture designs, this plot applies only to process factors (i.e., 
process variables). 

• The Interaction Matrix shows multiple Interactions plots. The plots shown depends on the 
factors you select. For example, if you select factors A and B, then two interactions plots 
will be shown: one showing A versus B and another showing B versus A. 
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• The Term Effect Plot shows the fitted means for all combinations of all factor levels for 
each selected term. You can specify how the means are calculated in the Calculation 
Options area. 

• The Cube Plot shows the mean values of the selected response for the combinations of the 
low and high levels of three selected factors. You can specify how the means are calculated 
in the Calculation Options area. Note that you have the option of selecting "none" for the 
third factor, generating a square (2-dimensional) plot. Only two level factors can be 
included in the Cube plot, and at least two quantitative factors (each run at two levels) 
must be included in the model for the Cube plot to be available. 

• The Scatter Plot shows the observed values of the currently selected response plotted 
against the levels of the selected factor. A 3-dimensional version of this plot is available in 
the 3D plot folio. 

• The Contour Plot shows how varying two selected factors affects the predicted response 
values, which are represented as colors. See Contour Plots. A 3-dimensional version of this 
plot ("Surface Plot") is available in the 3D plot folio. For mixture designs, this plot applies 
only to process factors (i.e., process variables). 

Note that for mixture designs, main effects cannot be shown in the Pareto Chart - Regression 
and Effect Probability plots. This is because the T value (or standardized effect) is based on a 
comparison with 0, which is not appropriate for the coefficients of main effects in mixture 
designs. 

The following effect plots are available only for mixture designs and apply only to mixture 
factors (i.e., components): 

• The Simplex Design Plot is available only when there are at least three components in the 
experiment, and it shows the different blends that were included in the experiment. 

• The Response Trace Plot is used to see the effect of each component. By default, the 
center of the design is set as the reference point (which you can change by clicking Set 
Factor Levels on the control panel). As one component’s proportion moves away from the 
reference point, the relative ratios of other components are kept constant. The x-axis is the 
amount of change of each component, and the y-axis displays the corresponding response 
values when x is changed. Each component has its own curve on the plot. 

• The Mixture Contour Plot shows how varying the three selected components affects the 
predicted response values, which are represented as colors. See Contour Plots. This plot 
uses the same principles as the simplex design plot to represent different mixtures (e.g., 
the center of the plot represents a blend with all three components in equal proportions). A 
3-dimensional version of this plot ("Mixture Surface Plot") is available in the 3D plot folio. 
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Residual Plots 

Residuals are the differences between the observed response values and the response values 
predicted by the model at each combination of factor values. Residual plots help to determine 
the validity of the model for the currently selected response. When applicable, a residual plot 
allows the user to select the type of residual to be used: 

• Regular Residual is the difference between the observed Y and the predicted Y. 

• Standardized Residual is the regular residual divided by the constant standard deviation. 

• Studentized Residual is the regular residual divided by an estimate of its standard 
deviation. 

• External Studentized Residual is the regular residual divided by an estimate of its standard 
deviation, where the observation in question is omitted from the estimation. 

The plots are described next. 

• The Residual Probability* plot is the normal probability plot of the residuals. If all points fall 
on the line, the model fits the data well (i.e., the residuals follow a normal distribution). 
Some scatter is to be expected, but noticeable patterns may indicate that a transformation 
should be used for further analysis. Two additional measures of how well the normal 
distribution fits the data are provided by default in the lower title of this plot. Smaller 
values for the Anderson-Darling test indicate a better fit. Smaller p values indicate a worse 
fit. 

• The Residual vs. Fitted* plot shows the residuals plotted against the fitted, or predicted, 
values of the selected response. If the points are randomly distributed around the "0" line 
in the plot, the model fits the data well. If a pattern or trend is apparent, it can mean either 
that the model does not provide a good fit or that Y is not normally distributed, in which 
case a transformation should be used for further analysis. Points outside the critical value 
lines, which are calculated based on the specified alpha (risk) value, may be outliers and 
should be examined to determine the cause of their variation. 

• The Residual vs. Order* plot shows the residuals plotted against the order of runs used in 
the design. If the points are randomly distributed in the plot, it means that the test 
sequence of the experiment has no effect. If a pattern or trend is apparent, this indicates 
that a time-related variable may be affecting the experiment and should be addressed by 
randomization and/or blocking. Points outside the critical value lines, which are calculated 
based on the specified alpha (risk) value, may be outliers and should be examined to 
determine the cause of their variation. 
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• The Residual vs. Factor* plot shows the residuals plotted against values of the factor 
selected in the Residual Factor area. It is used to determine whether the residuals are 
equally distributed around the "0" value line and whether the spread and pattern of the 
points are the same at different levels. If the size of the residuals changes as a function of 
the factor’s settings (i.e., the plot displays a noticeable curvature), the model does not 
appropriately account for the contribution of the selected factor. Points outside the critical 
value lines, which are calculated based on the specified alpha (risk) value, may be outliers 
and should be examined to determine the cause of their variation. 

• The Residual Histogram* is used to demonstrate whether the residual is normally 
distributed by dividing the residuals into equally spaced groups and plotting the frequency 
of the groups. The Residual Histogram Settings area allows you to: 

• Select Custom Bins to specify the number of groups, or bins, into which the residuals 
will be divided. Otherwise, the software will automatically select a default number of 
bins based on the number of observations. 

• Select Superimpose pdf to display the probability density function line on top of the 
bins. 

• The Residual Autocorrelation* plot shows a measure of the correlation between the 
residual values for the series of runs (sorted by run order) and one or more lagged versions 
of the series of runs. The default number of lags is the number of observations, n, divided 
by 4. If you select Custom Lags in the Auto-Correlation Options area, you can specify up to 
n -1 lags. The correlation is calculated as follows: 

 

where: 

• k is the lag. 

• is the mean value of the original series of runs. 

For example, lag 1 shows the autocorrelation of the residuals when run 1 is compared with 
run 2, run 2 is compared with run 3 and so on. Lag 3 shows the autocorrelation of the 
residuals when run 1 is compared with run 4, run 2 is compared with run 5 and so on. Any 
lag that is displayed in red is considered to be significant; in other words, there is a 
correlation within the data set at that lag. This could be caused by a factor that is not 
included in the model or design, and may warrant further investigation. 
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• The Fitted vs. Actual plot shows the fitted, or predicted, values of the currently selected 
response plotted against the observed values of the response. If the model fits the data 
well, the points will cluster around the line. 

Diagnostic Plots 

• The Leverage vs. Order plot shows leverage plotted against the order of runs used in the 
design. Leverage is a measure (between 0 and 1) of how much a given run influences the 
predicted values of the model, where 1 indicates that the actual response value of the run 
is exactly equal to the predicted value (i.e. the predicted value is completely dependent 
upon the observed value). Points that differ greatly from the rest of the runs are considered 
outliers and may distort the analysis. 

• The Cook’s Distance* plot can show Cook’s distance (i.e., a measure of how much the 
output is predicted to change if each run is deleted from the analysis) plotted against either 
the run order or the standard order for the currently selected response. Points that differ 
greatly from the rest of the runs are considered outliers and may distort the analysis. 

• The Box-Cox Transformation* plot can help determine, for the currently selected response 
and model, what transformation, if any, should be applied. The plot shows the sum of 
squares of the residuals plotted against lambda. The value of lambda at the minimum point 
of this curve is considered the "best value" of lambda, and indicates the appropriate 
transformation, which is also noted by default in the lower title of the plot. 

* These plots are available only when there is error in the design, indicated by a positive value 
for sum of squares for Residual in the ANOVA table of the analysis results. 

Contour Plots 

To view the contour plot, create the Plot tab in your design folio, then choose Contour Plot. 
You can specify how the means are calculated in the Calculation Options area. 

When you are working with this type of plot, the control panel includes an Additional Settings 
page with the following options: 

• The Contour Options area lets you specify the color gradient for the contour bands and the 
resolution of the lines. The colors for low, medium and high response values can be 
modified by clicking the colored Low, Mid and High icons. You can also change the 
Resolution of the contour lines (higher resolution means smoother curves, but the plot may 
take longer to generate). 

• The Band Settings area lets you choose how many contour bands will be used and what 
response values they will represent. Three options are available: 
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• Select Count to enter the number of contour bands directly in the Contour Count field. 
More bands means more fine-grained results (i.e., more colors for marking response 
ranges). The minimum and maximum response values are set by the software 
automatically. 

• Select Range to manually set the minimum and maximum response values to be shown 
in the plot. Then enter the Increment that will be used to create the contours. A lower 
increment means more fine-grained results. 

• Select Values to define each contour manually. For example, if you enter the values 2 
and 3, then the plot will have three contours: one for values less than 2, another for 
values between 2 and 3, and another for values greater than 3. Use the [+] and [-] icons 
in the Contour Values area to add a new value or remove a selected one. 

Effect Plot Calculation Options 

For effect plots that show mean response values, the Response drop-down list in the 
Calculation Options area allows you to specify how the means will be calculated at the different 
factor levels. 

Use the drop-down list in this area to select the type of mean value that is used. Note that, for 
some effect plots, only fitted means will be available. 

 

• Fitted Means uses mean values based on the fitted regression model. When you use this 
option, you can click Set Factor Values to specify how factors will be treated in the 
calculation. 
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• Select Use Least Squares Means to set all non-varied factors to 0 (i.e., remove them 
from the response calculation). 

• For some plots created in the mixture design folio, you can select Use Centroid to set 
the plot's reference point to the center of the design for the response trace plot, or to 
set the values of any non-varied mixture components. 

• Clear the option if you want to manually specify the values of non-varied factors. 

• Data Means uses the mean values from the observed data entered on the Data tab. (If a 
transformation has been applied to the response during analysis, data means will be based 
on the transformed values.) 

• When this option is used for response surface method designs, the mean values will 
not include curvature because only a fitted regression model can account for quadratic 
effects. 

Variability Analysis 

Variability analysis is available only for two level factorial and Plackett-Burman designs with 
standard response data, and it is used to identify the experimental run that results in the least 
amount of variation in the response. To perform this analysis, the design must have 2 or more 
runs that use the same factor level combinations for the factors that you choose to consider in 
the analysis. 

The Variability Analysis window allows you to select the response column(s) that you want to 
see variability analysis for and which factors to consider. To open the window, choose Data > 
Design > Variability Analysis or click the icon on the Data tab control panel. 
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The Variability Analysis window is shown next. 

 

For each response that you select in this window, a standard deviation column will be inserted 
beside it on the Data tab, displaying the standard deviation of the observations taken for each 
factor setting combination across replicates. Such columns can be selected for inclusion in the 
analysis (i.e., used as responses). 

The Factors area allows you to specify which factors are considered in the variability analysis. If, 
for example, only Factor A is selected, there will be only two rows of data in the Response 
Standard Deviation column: one for the runs that used A's low level and one for the runs that 
used the high level. The remaining rows would include an asterisk to indicate the standard 
deviation was displayed in a previous row, as shown next. 

 

If the design includes blocks, the Factors area will include a Block check box that allows you to 
consider them in the variability analysis. 
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Variability Analysis Example 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 

The name of the example project is "Factorial - Two Level Full Factorial Design." 

In a separate example, two optimal solutions were found for the factor level combination that 
optimize the process of growing epitaxial layers on polished silicon wafers. The two solutions 
are shown next. 

 

Although both solutions give the same predicted thickness (14.5 µm), it is important to identify 
which solution is better in terms of variability. To do this, you need to perform a variability 
analysis, where the analyzed response is the standard deviation of the thickness at each factor 
level combination. 

The data and results for the variability analysis are given in the "Variability Analysis" folio of the 
example file. On the Design tab, you can see the various settings that were used to generate 
the experiment design. 

Each row on the Data tab shows the factor level combination and recorded thickness for a 
single run. In addition, the yellow Thickness Standard Deviation column, which was added using 
the Variability Analysis window, shows the standard deviation of the thickness at the given 
factor level combination. (If a cell in this column does not display a value, that's because the 
variation in response for that factor level combination is already shown in a previous cell.) The 
Thickness column was removed from the analysis by clearing the check box in the column 
heading. 
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To transform the standard deviation values, choose Data > Design > Select Transformation, or 
click the icon on the Data tab's control panel. 

 

Then choose the natural log transformation (which is typically used when studying variability) in 
the window that appears. 
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The results for the variability analysis are shown in the Analysis Summary area on the control 
panel. 

 

The values of the regression coefficients show that nozzle position and deposition temperature 
have a negative effect on the variation in thickness. 

Conclusion 

Since the significant factors have a negative effect on variability, higher values will produce 
lower standard deviation. Therefore, of the two optimal solutions, the second solution is better 
in terms of variability. 



Chapter 10: DOE Design Folios 

764 https://www.reliasoft.com/weibull 

 

Nozzle Position Deposition 
Temperature 

Deposition 
Time 

Predicted 
Thickness 

Predicted 
Thickness Std 

Position 2 1210.7392 High 14.5 0.512 

Position 6 1214.8235 High 14.5 0.472 

Optimal Design 

The many DOE design types in Weibull++ are sufficient for most applications. However, 
sometimes limitations on resources and factor level combinations will require you to build a 
custom design that is based on one of the included design types. 

You can use the Optimal Design tool to build a custom design that is optimized for a selected 
regression model (i.e., the design will minimize the uncertainty of the regression coefficients) or 
optimized to cover as large of a design space as possible (i.e., the distance between design 
points is maximized). For example, if you only have 11 units available to test using a two level 
factorial design with five factors, you could build a two level full factorial design (which would 
require 32 runs), and then use this tool to build a modified version of the design that uses 11 
runs and takes into account only the effects you want to investigate, as well as any restrictions 
on the factor level combinations that can be used in the experiment. 

Optimal Design Window 

The Optimal Design window is used to select test runs from a design table in order to minimize 
the estimation uncertainty of the coefficients in a given regression model. It takes into account 
a) the specific effects that are under investigation, b) limitations on the number runs that can 
be performed and c) constraints on the factor level combinations that can be used during the 
experiment. The ReliaWiki resource portal provides more information on optimal custom 
designs at: http://www.reliawiki.org/index.php/Optimal_Custom_Designs. 

To access the Optimal Design window, build a design and then choose Data > Design > Optimal 
Design. 

 

The window includes two tabs discussed next. 

Design Settings Tab 

This tab is used to specify the method that will be used to create the design. Follow the steps 
outlined below to enter the settings. 

http://www.reliawiki.org/index.php/Optimal_Custom_Designs
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• If you wish to optimize the design for a regression model, select the Regression Model-
Based Optimal Design option at the top of the window. 

• In the Desired Model Terms area, select which terms will be included in the regression 
model. 

• In the Number of Runs in the Optimal Design area, specify the number of runs that will 
be used in the optimal design. The minimum and recommended numbers of runs are 
calculated automatically by the software. If you want to use a different number of runs, 
select the Custom number of runs option and then enter a number in the input field. 

• If desired, you can modify the method for creating the design in the Algorithm Settings 
area. 
 
The first section in this area concerns the random elements that are used in the 
generation of the design. 

• Select the Use Seed check box if you would like to set a consistent starting point 
from which the random numbers will be generated. Using the same seed value and 
keeping all other settings the same will allow you to replicate the resulting design. 

• Specify the Number of random initial runs that will be used. The software uses 
each random initial run to generate a design (using the algorithm you specify next), 
and then returns the best design that was found. Using more initial runs may 
produce a better design, but it will also increase the time required to generate the 
final design. 

The second section is used to select the algorithm that will be used to generate the 
design. Three algorithms are available. 

  How likely to produce the 
optimal design? 

How fast? 

Federov's Method Most likely Slowest 

Modified Federov's Method Somewhat likely Somewhat fast 

K-Exchange Method Least likely Fastest 

  

• If you want the design points (i.e., runs) in the design to cover as large of a design space as 
possible, select the Distance-Based Optimal Design option. 
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• Then use the Number of Runs in the Optimal Design area to specify the number of 
runs that will be used in the optimal design. The minimum and recommended numbers 
of runs are calculated automatically by the software. If you want to use a different 
number of runs, select the Custom number of runs option and then enter a number in 
the input field. 

Candidate Runs Tab 

This tab is used to select which runs will be considered in the final design. By default, the table 
on the Candidate Runs tab shows all the runs used in the current design. If desired, you can 
modify the factor levels in any of the runs. 

Follow the steps outlined next to choose the runs to consider and, if desired, add/remove runs. 

• In the Included in optimal design? column, make sure the appropriate option is chosen for 
each run: 

• Choose Consider if you are not sure whether the combination should be included in the 
optimal design. The software will use the settings you specified on the Design Settings 
tab to determine whether the combination will be included. 

• Choose Include if want that combination to be used in the optimal design (e.g., you 
might be interested in examining the response at a particular combination). 

• Choose Exclude if you do not want to include the combination (e.g., there might be 
safety concerns with setting all factor levels to the highest level). 

• If you want to add a new run to the table, click the Add button at the bottom of the 
window. The software will create a new row in the table with center points for all the factor 
values. If you do not wish to use center points, you can enter new factor values. To remove 
an added row, select it and click the Delete button. 

Optimal Design Example 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 

The name of the example project is "Optimal Custom Design." 

In this example, a full factorial design is created that requires 24 unique factor combinations. 
Then, the Optimal Design utility is used to optimize the experiment so only 15 factor 
combinations are required. Finally, the optimized design is evaluated and modified to meet the 
experimenter’s goals. 
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An experimenter wants to conduct some tests to study the effects of 4 factors. The main effects 
and the interaction effects AB, BC and CD will be investigated. The factors and factor levels that 
will be used in the experiment are shown next. 

Factor Level 1 Level 2 Level 3 

A: Material Type M1 M2 M3 

B: Curing Curing No Curing - 

C: Temperature 120°C 150°C - 

D: Pressure 4 bars 5 bars - 

If a full factorial design is used, the number of required factor combinations is 24. However, due 
to the constraints of the test facility, only 15 unique factor combinations can be used. 
Moreover, because of safety concerns, the combination A = M2, B = Curing, C = 150°C and D = 5 
bars cannot be used. 

Based on the above information, the experimenters need to choose 15 runs from the 24 unique 
runs in the general full factorial design. The resulting design will then be evaluated and further 
modified if necessary. 

Creating a Preliminary Design 

To begin, the experimenter creates a preliminary full factorial design. This will serve as a 
starting point for the optimal design. The design matrix is given in the "Preliminary Design" 
folio. The following steps describe how to create this folio on your own. 

• Choose Home > Insert > Standard Design to add a standard design folio to the current 
project. 

 

• Click Design Type in the folio's navigation panel, and then select General Full Factorial in 
the input panel. 
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• Specify the number of factors by clicking the Factors heading in the navigation panel and 
choosing 4 from the Number of Factors drop-down list. 

• Define each factor by clicking it in the navigation panel and editing its properties in the 
input panel. The properties are given in the table above. The first factor is defined as shown 
next. (Note that the third and fourth factors are quantitative.) 

 

• Rename the folio by clicking the Experiment1 heading in the navigation panel and entering 
Preliminary Design for the Name in the input panel. 

• Next, click the Build icon on the control panel to create a Data tab that allows you to view 
the preliminary plan. 
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• Finally, sort the test runs in the preliminary design using the standard, non-randomized 
order. Sorting the test runs in this way will make it easier to find the factor level 
combination that you will later exclude from the design. 

• Choose Data > Format and View > Visible Columns and select to view the Standard 
Order column in the Visible Columns window. 

• Click a cell in the Standard Order column, and then choose Sheet > Sheet Actions > Sort 
> Sort Ascending. 

Optimizing the Design 

The preliminary design requires 24 factor combinations. To optimize the design so it only 
requires 15 unique factor combinations, view the experiment plan on the Data tab of the 
"Preliminary Design" folio. Then choose Data > Design > Optimal Design. 

 

On the Design Settings tab of the window that appears, specify the terms that you are 
interested in investigating in the Desired Model Terms area. Also, in the Number of Runs in the 
Optimal Design area, specify how many runs you want to include in the design. 
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On the Candidate Runs tab, make sure the unsafe factor level combination (A = M2, B = Curing, 
C = 150°C and D = 5 bars) is not used by selecting Exclude in the second column for that 
combination. 
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After you click OK, the resulting optimized design is given in the "Optimal Design" folio, as 
shown next. (Since the standard order is no longer relevant, you can open the Visible Columns 
window again to hide that column.) 
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Note: To minimize the effect of unknown nuisance factors, the run order is randomly generated 
whenever you create a design. Therefore, if you followed these steps to create your own folio, 
the order of runs in your folio may be different from that of the folio in the example file. This 
will not affect the design evaluation results described next. 

Evaluating the Design 

The experimenter wants to evaluate the power of the design (i.e., the probability that it will 
detect an active effect). The settings for the evaluation are specified on the Evaluation Settings 
page of the Data tab control panel. 
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Click the Calculate icon to return to the Main page of the control panel. A summary of the 
evaluation results will be shown in the Design Evaluation area. Click the Detailed Results link in 
that area to view the calculated power values for each term that was included in the 
evaluation. 

 

The power values for effect A and interaction AB are relatively small, which means the 
experiment is not likely to detect these effects if they are active. To increase the power, more 
runs need to be added to the experiment. 
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Augmenting the Design 

Two more replicates are added to the optimal design using the Augment Design tool. To use 
this tool, view the experiment on the Data tab and then choose Data > Design > Augment 
Design. 

 

In the window that appears, specify that 2 replicates will be added and click OK. 

 

The new design is given in the "Optimal Design - Replicates" folio. 

The power values for this design are: 

 

The experimenter considers these values high enough. Therefore, this design is used as the final 
one. 

Design Evaluation 

The design folio control panel includes a tool that allows you to evaluate your design and 
compare it to other designs. By evaluating a design before you implement it, you can avoid 
using time or resources on an inefficient experiment. For example, if the tool shows that a 
design is unlikely to detect any main effects, you can increase the numbers of replicates and re-
evaluate before performing the experiment. If you have already implemented a design, you can 
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enter the response data and calculate it before performing the evaluation, which will produce 
more accurate results. 

Specifically, the design evaluation tool allows you to: 

• Calculate the design's power given a specified amount of effect. The power is the 
probability of detecting a specified amount of effect. 

• Calculate the amount of effect given a specified power. The amount of effect is the largest 
difference between the response means obtained at each factor or effect level. 

• Inspect the design's alias structure. This shows which effects are aliased with each other, 
and thus it helps you make sure you aren't losing any important information about 
interaction effects due to aliasing. 

• Determine whether the design is orthogonal (i.e., the analysis of an effect does not depend 
on what other effects are included in the model). Orthogonal designs are ideal because 
they have minimal variance for the estimated model coefficients. 

• If the design is not orthogonal, you can compare the design's optimality to other proposed 
designs to see which one is more similar to an orthogonal design. 

IMPORTANT: This tool assumes that the response values obtained from the experiment will 
follow a normal distribution. Thus, it is not applicable to R-DOE, which is intended for life data 
that is not normally distributed. 

For an example of how you can use this feature to compare two designs, see Design Evaluation 
Example. 

Selecting the Settings for the Evaluation 

The Design Evaluation tool is available on both the Design tab and the Data tab. 

• If you evaluate a design from the Design tab, the tool will evaluate the overall design 
without considering any response-specific settings. 

• If you evaluate a design from the Data tab, the tool will evaluate the design for a specific 
response and take into account all relevant settings (and data, if entered and calculated) 
specific to that response. 

Use the Evaluation Settings page of the control panel to configure the evaluation. The page will 
differ slightly depending on which tab you access it from, as shown next. 
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Follow the steps below to define the evaluation settings. 

• If you accessed the tool from the Data tab, choose a response from the Response Settings 
drop-down list. The settings you choose will apply to that response only. When accessed 
from the Design tab, the tool will assume all responses have the same settings. 

• Choose a metric to solve for. 

• If you choose to Solve for Power, you will be required to specify the amount of effect in 
the Effect per Std Dev field. 

• The effect per standard deviation defines how much the effect exceeds the 
response variation due to noise (i.e., standard deviation). For example, if you want 
to know the probability of detecting an effect that is 1.5 times greater than the 
response's standard deviation, you'd enter 1.5. 

• If you choose to Solve for Effect Value, the software will calculate an amount of effect 
given the Value of Power that you provide (e.g., if the probability of detecting an active 
effect is 90%, enter 0.9). 

• Enter a Risk Level, which is a measure of the risk that the results of analyzing the response 
data are incorrect (i.e., alpha = 1 - confidence level). 
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• The Standard Deviation represents the response variation that is due to noise. The default 
value is 1, but if you access the tool from the Data tab and then enter and calculate the 
response data, the default value will become the calculated standard deviation for the 
selected response. 

 

Note that the detection power is calculated in terms of the effect per standard deviation 
(i.e., the amount by which the effect exceeds the standard deviation, whatever it is), so the 
standard deviation itself does not affect the calculation when you solve for power. 
However, in this case, the total effect (Effect per Std Dev * Standard Deviation) will be 
shown in the Power Study table in the detailed results. 

• If you access the tool from the Design tab, the area at the bottom of the page will allow you 
to select the terms that will be used in the evaluation. For example, if you were not 
interested in investigating the interaction between factors A and B, then you would you 
clear the A · B check box. When accessed from the Data tab, the tool will use the same 
terms you selected in the Select Terms window. 

Performing the Evaluation and Interpreting the Results 

After you select the desired settings, go to the Main page of the control panel and click the 
Calculate icon in the Design Evaluation area. 

 

The value you selected to solve for (i.e., power or effect) will appear in the area as shown 
above. In this example, the probability of detecting the given amount of effect is 79.96% for 
main effects and 51.64% for 2-way interactions. Note that when there are multiple effects, this 
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value refers to the effect that is the least likely to be detected. (For example, if there are two 
main effects A and B, and the probability of detecting A is 50% and for B it's 60%, then the Main 
Effects row will show 0.5000.) 

To see more details concerning the evaluation (including the powers calculated for individual 
effects of interest), click the Detailed Results link at the bottom of the area to view the 
Evaluation Results window. 

Design Evaluation Results Window 

The Design Evaluation Results window shows the detailed results of the design evaluation. It is 
accessed by clicking the Detailed Results link in the control panel's Design Evaluation area. 

All available information and tables are presented next. To view or hide any of these results in 
the spreadsheet, use the check boxes in the Available Report Items panel. 

• The Power Study table shows the calculated power/effect values for each term that you 
selected to include in the evaluation. 

• The Degrees of Freedom is the number of coefficients that represent the effect of each 
term in the model. For qualitative factors, this is the number of levels - 1 for each term. 
For quantitative factors, it is always 1. 

• The last column will vary depending on whether you selected to solve for power or 
effect. 

• The Power for Effect Value is the calculated power for each term (i.e., the 
probability of detecting the specified amount of effect for each term). The column 
heading displays the total effect, which is equal to the effect per standard deviation 
multiplied by the standard deviation (also shown in the heading). 

• The Effect for Power Value is the calculated total effect for the each term (i.e., the 
largest difference between the response means obtained at each factor level). The 
column heading displays the power value that was used to calculate the effect. 

• The Alias Structure shows which effects are aliased with each other. It takes into account 
only the terms you've selected to include in the evaluation. Together with your engineering 
knowledge, you can use this table to help determine whether any important interaction 
information will be lost due to aliasing. If there are no aliased effects, the sentence "All 
selected terms are alias free" will appear. This table is not available for one factor designs. 

• The D-Optimal Information table shows the following values. 
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• The Determinate of X'X is the determinant calculated for the information matrix. This 
value is used to compare the design to other designs and determine which is closer to 
being orthogonal. Larger determinant values mean you can get more information about 
the factors you are studying compared to a design with the same model but a smaller 
determinant. 

• The D-Efficiency is used to measure the orthogonality of a design. A value close to 1 
means the design is close to being orthogonal. A value of 1 means the design is 
orthogonal. 

• The Trace of X'X^-1 is the calculated trace of the variance-covariance matrix (i.e., the 
sum of all its diagonal elements). Like the determinate of X'X, this value is used to 
compare different designs. Smaller trace values mean less uncertainty for the 
estimated model coefficients. 

• The Regressor table displays the regressors that were used to calculate the X'X and X'X^-1 
matrices described next. 

• X'X is the information matrix of the design. It is used to calculate the first and second 
values in the D-Optimal Information table. 

• X'X^-1 is the normalized variance-covariance matrix of the design. It is multiplied by the 
estimated variance of the error to obtain the variance-covariance matrix of the 
estimated model parameters. 

The ReliaWiki resource portal has more information on design evaluation at: 
http://www.reliawiki.org/index.php/Design_Evaluation_and_Power_Study. 

Design Evaluation Example 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 

The name of the example project is "Design Evaluation - Taguchi OA vs. Two Level Full 
Factorial." 

Experimenters often need to decide between different experiment designs. For example, a half 
fractional factorial design with 2 replicates will allow you to estimate the error variance more 
accurately than a full factorial design which uses the same number of runs, but at the cost of 
aliasing some effects. A full factorial design will not alias any effects, but it may be more time- 
and resource-intensive since it requires more factor level combinations. 

http://www.reliawiki.org/index.php/Design_Evaluation_and_Power_Study
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In this example, the Design Evaluation tool will be used to compare a Taguchi OA design to a 
two level full factorial design. The designs will be compared in terms of alias structure, 
detection power and resource constraints. Assume a group of engineers want to investigate the 
main effects and 2-way interaction effects of 4 factors run at 2 levels each. One option is to use 
the first 4 columns of the Taguchi L8 (2^7) with 2 replicates; the other option is to use a full 
factorial design. Both designs require 16 test samples. In the steps that follow, both designs will 
be evaluated, and the better design will be improved before the engineers agree to use it. 

Creating/Evaluating the Taguchi OA Design 

The Taguchi OA design is given in the "Taguchi L8 (2^7)" folio. The four factors were assigned to 
the first 4 columns under the Additional Settings header on the Design tab. 

 

On the Evaluation Settings page of the control panel, specify that you will solve for power (i.e., 
the probability that the design will detect an active effect) and select to include all main effects 
and 2-way interactions in the evaluation. 
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Then click the Calculate icon to return to the Main page of the control panel and view a 
summary of the evaluation results in the Design Evaluation area. 

Click the Detailed Results link in this area to view the calculated power values for each included 
term, as shown next. 
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According to this table, if any of the displayed main effects or interaction effects is active, there 
is a 57.27% chance that the design will detect it. 

Notice that some of the interactions that were selected to be included are not shown in the 
Power Study table. That's because they are aliased with main effects, as shown in the Alias 
Structure table. 

 

For example, according to this table, the main effect of factor A is aliased with the interaction 
BC. Thus, BC is not shown in the Power Study table. 

Creating/Evaluating the Two Level Full Factorial Design 

The full factorial design is given in the "2^4 Full Factorial Design - 1 Replicate" folio. On the 
Evaluation Settings page of the control panel, select to solve for power and include all the main 
effects and 2-way interaction effects. 

The calculated power values for the included terms are shown next. 
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Underneath this table is an indication that "All selected terms are alias free." This means the 
full factorial design can be used to investigate all the main effects and 2-way interaction effects. 

Comparing the Two Designs 

• Compare the alias structure 

The Taguchi OA design cannot be used to investigate all the 2-way interaction effects. For 
example, it cannot distinguish the main effect A and the interaction effect BC. The two level 
full factorial design, however, does not alias any effects. Thus, the full factorial design is 
better in terms of aliasing. 

• Compare the detection power 

The design evaluation shows that the power for the Taguchi OA design is 0.5727, while the 
power for the two level full factorial design is 0.5318. The Taguchi OA design might thereby 
appear better in terms of detection power. However, the two level full factorial design has 
more terms included in the model (because of its lack of aliasing). If we omit the terms that 
are aliased in the Taguchi OA design from the full factorial design as well, the power of the 
full factorial design will also be 0.5727. So in terms of the detection power, both designs are 
the same. 

• Consider other factors such as resource constraints 

Since there are two replicates in the Taguchi OA design, the error variance can be 
estimated more accurately. In the two level full factorial design, the error variance is 
estimated by pooling high order interactions. If some of the interactions are active, the 
estimated error variance may not be accurate. 
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Choosing the Right Design 

The experimenters decided that the most important goal is to estimate all the main effects and 
2-way interactions clearly. Therefore the two level full factorial design is used. Since the power 
for all the main effects and 2-way interactions is only 0.5318, however, they need to increase 
the sample size to increase the probability of detecting active effects. So they increase the 
replicates and recalculate the power values. The effect of the number of replicates on the 
number of runs and power value is shown in the table below. 

Replicates Number of Runs Power 

1 16 0.5318 

2 32 0.8623 

3 48 0.9604 

The experimenters decided to accept any power value above 85%, so they use 2 replicates for 
this experiment, as shown in the "2^4 Full Factorial Design - 2 Replicates" folio. 

 

Factorial Designs 

Factorial designs are typically used for screening factors/interactions. In other words, they help 
you determine which factors have a significant effect on the response and identify interactions 
between those factors. The following four types of factorial designs are available: 

• Two Level Factorial: Use this design to investigate the main effects and/or interaction 
effects of a few factors run at two levels each. You can investigate all factors/interactions 
(full factorial) or only a subset of them (fractional factorial). 
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• Placket-Burman Factorial: This is a special category of two level fractional factorial design. 
Use this design to investigate the main effects of multiple factors run at two levels each, 
using few runs. 

• General Full Factorial: Use this design to investigate the main effects and interaction 
effects of multiple factors run at different numbers of levels (for example, two factors at 
two levels each and two factors at three levels each). 

• Taguchi OA Factorial: Use this design to investigate to investigate the main effects of 
multiple factors run at different numbers of levels, using few runs. This design can be 
thought of as a general fractional factorial design. 

When selecting a factorial design type, it is important to keep these considerations in mind: 

• Full factorial designs test all possible combinations of factors at each level. While such 
designs yield comprehensive data, they may not be feasible due to constraints on time, 
money and/or number of samples available for testing. 

• Fractional factorial designs test a subset of the possible combinations of factors at the 
levels in question. This allows for the screening of larger numbers of factors/levels with less 
investment of time, money and/or samples. However, it also results in some loss of data for 
analysis, as eliminating runs naturally reduces the ability of the design to fully examine all 
possible effects. 

More specifically, fractionality results in some level of aliasing (or confounding), where the 
effect of a certain factor or factorial interaction cannot be separated from another effect. 
Designs in which main effects are aliased with lower-order interactions are said to be low 
resolution and are appropriate for screening (e.g., a resolution III design, in which main 
effects may be aliased with second-order interactions, which are interactions of two 
factors). Fractional factorial designs of higher resolution, along with full factorial designs, 
may also be useful for studying factorial effects and interactions in depth and/or for 
optimization. Resolution is presented in more detail in Two Level Factorial Designs. 

• Using two levels per factor is generally sufficient for screening experiments. However, to 
test for curvature (thereby identifying factors and interaction that merit in-depth analysis) 
either center points or additional levels must be used. If factors have a significant curvature 
effect on the response, you should investigate their quadratic effects using response 
surface methodology. 

For more information about how to use the design types, please consult the documentation on 
design folios. 
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Two Level Factorial Designs 

With two level factorial designs, you can consider all combinations (for a full factorial design) or 
a subset of combinations (for a fractional factorial design) of up to 15 factors at 2 levels each. 
To design an experiment that includes factors with multiple levels and tests all factor-level 
combinations, use a general full factorial design instead. 

Available Two Level Factorial Designs 

The available two level factorial designs are shown next. This information is applicable to 
designs with standard response data, as well as robust parameter designs and reliability DOE. 

 

 
This table provides information about the available combinations of the number of factors and 
the number of runs. The two level full factorial designs are displayed in white cells, and the 
information shown in the cells is (number of levels)^(number of factors), which yields the 
number of runs. 

The two level fractional factorial designs are displayed in green, yellow and red cells, where: 

• The information shown in the cells is the design in 2k-p form. k represents the number of 
factors used in the design. The fractionality of the design is equal to 1/2p, or 2-p. Thus, the 
design is represented by 2k(2-p), or 2k-p. Note that in such designs, the number of generators 
(i.e., the factorial interactions whose effects will be aliased with the main effects of 
particular factors) is also equal to p. 
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Two Level Factorial Designs: Example 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 

The name of the example project is "Factorial - Two Level Full Factorial Design." 

One of the initial steps in fabricating integrated circuit (IC) devices is to grow an epitaxial layer 
on polished silicon wafers. The wafers are mounted on a six-faceted cylinder (two wafers per 
facet) called a susceptor, which is spun inside a metal bell jar. The jar is injected with chemical 
vapors through nozzles at the top of the jar and heated. The process continues until the 
epitaxial layer grows to a desired thickness. The nominal value for thickness is 14.5 µm with 
specification limits of 14.5 ± 0.5 µm. 

The current settings caused variations that exceeded the specification by 1.0 µm. Thus, the 
experimenters first need to find the factors that affect the process. Then further experiments 
will be conducted to optimize the process. 96 units are available for testing, and the factors and 
levels shown next will be used. 

Factor Name Low Level High Level 

A Susceptor-Rotation Method Continuous Oscillating 

B Nozzle Position 2 6 

C Deposition Temperature 1210 1220 

D Deposition Time Low High 

Designing the Experiment 

To find the important factors, the experimenters create a two level full factorial design folio, 
perform the experiment according to the design, and then enter the response values into the 
folio for analysis. The design matrix and the response data are given in the "Two Level Full 
Factorial Design" folio. The following steps describe how to create this folio on your own. 

• Choose Home > Insert > Standard Design to add a standard design folio to the current 
project. 

 

• Click Design Type in the folio's navigation panel, and then select Two Level Factorial in the 
input panel. 
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• Rename the response by clicking Response 1 in the navigation panel and entering 
Thickness in the input panel. 

• Specify the number of factors by clicking the Factors heading in the navigation panel and 
choosing 4 from the Number of Factors drop-down list. 

• Define each factor by clicking it in the navigation panel and editing its properties in the 
input panel. The properties are given in the table above. Note that factors A and D use 
Qualitative levels; this is specified in the Factor Type drop-down list. 

• Rename the folio by clicking the Experiment1 heading in the navigation panel and entering 
Two Level Factorial Design for the Name in the input panel. 

• Click the Additional Settings heading. In the input panel, set the number of Replicates to 6. 
Note that by leaving Full selected under the Factorial Settings heading, you are indicating 
that this will be a full factorial design. 

• Finally, click the Build icon on the control panel to create a Data tab that allows you to view 
the test plan and enter response data. 

 

Analysis and Results 

The data set for this example is given in the "Two Level Full Factorial" folio of the example 
project. After you enter the data from the folio, you can perform the analysis by doing the 
following: 

Note: To minimize the effect of unknown nuisance factors, the run order is randomly generated 
when you create the design. Therefore, if you followed these steps to create your own folio, the 
order of runs on the Data tab may be different from that of the folio in the example file. This 
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can lead to different results. To ensure that you get the very same results described next, show 
the Standard Order column in your folio, then click a cell in that column and choose Sheet > 
Sheet Actions > Sort > Sort Ascending. This will make the order of runs in your folio the same as 
that of the example file. Then copy the response data from the example file and paste it into 
the Data tab of your folio. 

• Make sure all main effects and interactions will be considered. To do this, click the Select 
Terms icon on the control panel. 

 

In the window that appears, select the All Terms check box. Then click OK. 

• Click the Calculate icon. 

 

• The results in the Analysis Summary area on the control panel show that the nozzle 
position and deposition time have significant effects on the thickness, as well as the 
interaction of terms C and D (i.e., deposition temperature and deposition time). 

 

• To view a plot comparing the standardized effect of each term, click the Plot icon. 

 

Then choose Pareto Charts - Regression from the Plot Type drop-down list. The following 
plot appears. The blue line in the plot marks the critical value determined by the risk level 
specified on the Analysis Settings page of the control panel. If the bar goes past the blue 
line, then the effect is considered significant. 
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Optimization 

To optimize the response, you should work with a model that only includes the significant 
terms. The results for the reduced model of the analysis are given in the "Reduced Model" folio 
of the example project. The following steps describe how to create this folio on your own. 

• Right-click the "Two Level Full Factorial Design" folio in the current project explorer. Then 
choose Duplicate from the shortcut menu. 

• Right-click the new, duplicated folio in the current project explorer and choose Rename 
from the shortcut menu. Change the name to "Reduced Model." 

• Open the new folio. Then click the Select Terms icon on the control panel. 
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To automatically select only those terms that were found to be significant, click the Select 
Significant Terms icon. Since the interaction of factors C and D is significant, C must also be 
included in the model. So select the C:Deposition Temperature check box as well. Then 
click OK. 

• Click the Calculate icon to create a reduced model using the current data. 

The factor level combinations that will produce the optimum response value are given in the 
"Optimal Solution Plot" folio. The following steps describe how to create this folio on your own. 

• To find the best settings of the significant factors, click the Design - Optimization icon on 
the control panel of the "Reduce Mode" folio. 

 

• In the window that appears, use the settings shown next and click OK. According to these 
settings, the ideal thickness for the epitaxial layer is 14.5 µm, but thicknesses between 14 
µm and 15 µm are still acceptable. 

 

• An Optimization folio will appear with an optimal solution plot showing the first solution, 
displayed next. (The Solutions area on the control panel shows all the solutions that were 
found, and you can click them to view the plot representing the solution.) 
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This plot shows one combination of factor settings that will produce the target response 
value (marked with a horizontal dotted line). Factors B and D are qualitative, so the plot 
uses dots (i.e., a discrete function) to show what the response level would be given either 
one of the two factor levels used in the experiment. Factor C is quantitative, so a 
continuous function is used to calculate the optimal temperature. 

• You can choose Optimization > Solutions > View Solutions or click the icon on the control 
panel to see all the optimal solutions in numerical format. 

 

Two optimal solutions for factors B, C and D were found, and they are shown next. 
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Conclusion 

Two optimum solutions were found that give the same predicted thickness. In choosing 
between these two combinations of factor levels, it is important to identify which is better in 
terms of variability. To do this, you can perform a variability analysis, where the response is the 
standard deviation of the observations at each setting. (See Variability Analysis Example.) 

Plackett-Burman Designs 

Plackett-Burman designs are highly fractional designs that allow you to consider a subset of 
combinations of up to 47 factors at two levels each. Unlike two level fractional factorial designs, 
the number of runs in Placket-Burman designs is a multiple of four (rather than only a power of 
2), and the number of factors can be up to one less than the number of runs (e.g., an 
experiment with 16 runs can screen up to 15 factors). Because this design is highly fractional, it 
is not appropriate for studying interaction effects. The design matrix was developed by Robin L. 
Plackett and J. P. Burman in 1946. 

Available Plackett-Burman Designs 

The available Plackett-Burman designs are shown next. This information is applicable to designs 
with standard response data, as well as robust parameter designs and reliability DOE. 
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This table provides information about the available combinations of the number of factors and 
the number of runs. The number of runs in a Plackett-Burman design is always a multiple of 
four. The number of factors can be up to one less than the number of runs. For example, this 
table shows that a design using 20 runs may use up to 19 factors. 

Plackett-Burman Designs: Example 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 

The name of the example project is "Factorial - Plackett-Burman Design." 

Plackett-Burman design is a "screening design." Such designs are traditionally used for 
investigating a large number of factors to see which have a significant effect on the response. In 
the analysis of these designs, usually only main effects are estimated. 

Consider a life test of weld-repaired castings (as described in Wu, Jeff and Hamada, Michael, 
Experiments: Planning, Analysis, And Parameter Design Optimization, John Wiley & Sons, New 
York, 2000). The objective of the test is to identify the important factors that affect the life and 
estimate the factor levels that will improve the product life. There are seven factors under 
investigation. A two level full factorial design would require 27 = 128 runs, and thus would be 
too time-consuming and costly. Therefore, an eight-run Plackett-Burman experiment will be 
conducted instead. 
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For this example, the seven factors and associated levels are shown next. The response is the 
logged failure time of each test unit. 

Factor Low Level High Level 

Initial Structure As Received Beta Treat 

Bead Size Small Large 

Pressure Treat None HIP 

Heat Treat Anneal Solution Treat/Age 

Cooling Rate Slow Rapid 

Polish Chemical Mechanical 

Final Treat None Peen 

Design the Experiment 

The experimenters create a Plackett-Burman design folio, perform the experiment according to 
the design, and enter the response values for further analysis. The design matrix and the 
response data are given in the "Cast Fatigue Experiment" folio of the example project. The 
following steps describe how to create this folio on your own. 

• Choose Home > Insert > Standard Design to add a standard design folio to the current 
project. 

 

• Click Design Type on the folio's navigation panel, and then select Plackett-Burman Factorial 
in the input panel. 
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• Rename the response by clicking Response 1 in the navigation panel and entering Time in 
the input panel. 

• Specify the number of factors by clicking the Factors heading in the navigation panel and 
choosing 7 from the Number of Factors drop-down list. 

• Define each factor by clicking it in the navigation panel and editing its properties in the 
input panel. The properties are given in the table above. Note that all factors use 
Qualitative levels; this is specified in the Factor Type drop-down list. The first factor is 
defined as shown next. 

 

• Rename the folio by clicking the Experiment1 heading in the navigation panel and entering 
Cast Fatigue Experiment for the Name in the input panel. 

• Click the Additional Settings heading. On the input panel, set the number of Replicates to 
1. Note that by leaving 8 selected for the Number of Runs, you are indicating that this 
design will use the minimum number of runs required for a Plackett-Burman design with 7 
factors. 

• Finally, click the Build icon on the control panel to create a Data tab that allows you to view 
the test plan and enter response data. 
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Analysis and Results 

The data set for this example is given in the "Cast Fatigue Experiment" folio of the example 
project. After you enter the data from the example folio, you can perform the analysis by doing 
the following: 

Note: To minimize the effect of unknown nuisance factors, the run order is randomly generated 
when you create the design. Therefore, if you followed these steps to create your own folio, the 
order of runs on the Data tab may be different from that of the folio in the example file. This 
can lead to different results. To ensure that you get the very same results described next, show 
the Standard Order column in your folio, then click a cell in that column and choose Sheet > 
Sheet Actions > Sort > Sort Ascending. This will make the order of runs in your folio the same as 
that of the example file. Then copy the response data from the example file and paste it into 
the Data tab of your folio. 

• On the Analysis Settings page of the control panel, select to use Individual Terms in the 
analysis. 

• Return to the Main page of the control panel and click the Calculate icon. 

 

The ANOVA table and the Regression Information table for the model are available in the 
Analysis Summary window after you click the View Analysis Summary icon on the control 
panel. 

• Click the Plot icon to add the Analysis Plot tab to the folio. 

 

Choose the Effect Probability plot from the Plot Type drop-down list, where you can see 
that effect F is significant. 
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Conclusions 

Click the View Analysis Summary icon on the control panel and select to the view the 
Regression Table. The effect values for each factor are contained in the table and shown next 
(some values were not calculated because the design does not use replicates): 
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Factors A through E have negative effect values. F and G have positive effect values. Thus, 
assuming there are no interaction effects, a higher product life can be achieved by setting A, B, 
C, D and E at their low levels, and setting F and G at their high levels. If desired, further 
experiments can be conducted to study the interaction effects of these factors. 

Moreover, since factor F's effect was great enough to be considered significant, it was found to 
be the most important factor. 

General Full Factorial Designs 

General full factorial designs allow you to consider all combinations of up to 7 factors at up to 
20 levels each. It is not required that all factors have the same number of levels. If there are 
many factors with more than two levels, the number of runs for a general full factorial design 
may be prohibitively large. In such cases, Taguchi orthogonal array (OA) design should be used. 

Available General Full Factorial Designs 

The limitations on general full factorial designs are shown next. This information is applicable to 
designs with standard response data, R-DOE and robust parameter designs. 

  Maximum Allowed 

Factors 7 

Levels per Factor 20 

Rows per Design 65,000 

This table provides information about the maximum number of factors, levels and rows 
possible in a general full factorial design. 
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General Full Factorial Designs: Example 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 

The name of the example project is "Factorial - General Full Factorial Design." 

In this example, a soft drink bottler is interested in obtaining more uniform fill heights in the 
bottles (as described in Montgomery, D. C. Design and Analysis of Experiments, 5th edition, 
John Wiley & Sons, New York, 2001). The filling machine is designed to fill each bottle to the 
correct target height, but in practice, there is variation around this target, and the bottler 
would like to examine the sources of this variability so she can reduce it. There are three 
control factors. The factors and associated levels that will be used in the experiment are shown 
next. 

Factor Unit Level 1 Level 2 Level 3 

Percent Carbonation % 10 12 14 

Operating Pressure psi 25 30 - 

Line Speed bpm 200 250 - 

There are two replicates at each factor setting, making a total of 24 runs. The response is the 
average deviation from the target fill height observed in a production run of bottles. Positive 
deviations are fill heights above the target. 

Design the Experiment 

The experimenters create a general full factorial design, perform the experiment according to 
the design, and then enter the response values into the folio for analysis. The design matrix and 
the response data are given in the "Soft Drink Bottling Experiment" folio. The following steps 
describe how to create this folio on your own. 

• Choose Home > Insert > Standard Design to add a standard design folio to the current 
project. 

 

• Click Design Type in the folio's navigation panel, and then select General Full Factorial in 
the input panel. 
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• Rename the response by clicking Response 1 in the navigation panel and entering Height 
Deviation in the input panel. 

• Specify the number of factors by clicking the Factors heading in the navigation panel and 
choosing 3 from the Number of Factors drop-down list. 

• Define each factor by clicking it in the navigation panel and editing its properties in the 
input panel. The properties are given in the table above. The first factor is defined as shown 
next. 

 

• Rename the folio clicking the Experiment1 heading in the navigation panel and entering 
Soft Drink Bottling Experiment for the Name in the input panel. 

• Click the Additional Settings heading. In the input panel, set the number of Replicates to 2. 

• Finally, click the Build icon on the control panel to create a Data tab that allows you to view 
the test plan and enter response data. 
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Analysis and Results - Part 1 

The data set for this example is given in the "Soft Drink Bottling Experiment" folio of the 
example project. After you enter the data from the example folio, you can perform the analysis 
by doing the following: 

Note: To minimize the effect of unknown nuisance factors, the run order is randomly generated 
when you create the design. Therefore, if you followed these steps to create your own folio, the 
order of runs on the Data tab may be different from that of the folio in the example file. This 
can lead to different results. To ensure that you get the very same results described next, show 
the Standard Order column in your folio, then click a cell in that column and choose Sheet > 
Sheet Actions > Sort > Sort Ascending. This will make the order of runs in your folio the same as 
that of the example file. Then copy the response data from the example file and paste it into 
the Data tab of your folio. 

• On the Analysis Settings page of the control panel, select to use Individual Terms in the 
analysis. 

• Return to the Main page of the control panel and click the Calculate icon. 

 

Click the View Analysis Summary icon on the control panel and select to the view the ANOVA 
Table. 
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From this table, you can see that effects A, B, C and AB are significant. To simplify the analysis, 
the next step is to recreate the model using only the significant terms. 

Analysis and Results - Part 2 

The results for the reduced model are given in the "Reduced Model" folio of the example 
project. The following steps describe how to create this folio on your own and then use the 
results to find the factor settings that provide the smallest deviation in height. 

• Right-click the design folio in the current project explorer and select Duplicate Item from 
the shortcut menu. Rename the new folio with an appropriate name. 

• Click the Select Terms icon on the new folio's control panel. 

 

• In the Select Terms window that appears, click the Select Significant Effects button to 
select only the significant effects to calculate the new model, as shown next, then click OK. 

 

• Click the Calculate icon in the new folio's control panel. 

• Click the View Analysis Summary icon on the control panel. In the Analysis Summary 
window that appears, view the Diagnostic Information table. The table is shown next. In 
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order to identify which factor settings can provide the smallest height deviation, look for 
the runs in the table with the Fitted Value (YF) closest to zero (highlighted). 

 

Conclusions 

You can see that the 9th and 10th runs in the standard order are at the best combination of 
settings. The settings for these particular runs on the Data tab are shown to be A = 12, B = 25, C 
= 200. Under these settings, the expected deviation is lowest. 

Note that the best factor settings in this case are limited to those settings actually used in the 
experiment. This limitation can be avoided using response surface methodology, which may 
allow you to find the optimal settings for the manufacturing process. 

Taguchi Orthogonal Array (OA) Designs 

Taguchi orthogonal array (OA) factorial designs are highly fractional designs that allow you to 
consider a selected subset of combinations of multiple factors run at different numbers of 
levels. The number of factors that can be considered is dependent on the factor levels used. 
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Orthogonal arrays are balanced to ensure that all levels of all factors are considered equally. 
For this reason, the factors can be evaluated independently of each other despite the 
fractionality of the design. The available designs are based on the design matrix created by 
Genichi Taguchi. 

Available Taguchi OA Designs 

The available single level and mixed level Taguchi OA designs are shown next. This information 
is applicable to designs with standard response data, as well as robust parameter designs and 
reliability DOE. 

Single Level Designs  
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Mixed Level Designs  

 

These tables provide information about the available combinations of the number of factor 
levels and the number of runs. In the design notation, the value immediately following L 
represents the number of runs used in the design. Within the parentheses, each base value 
represents a number of levels and each exponent represents a number of factors. For example: 

• The L8(27) design uses eight experimental runs to investigate up to 7 two-level factors. 

• The L8(24 x 41) design uses eight experimental runs to investigate up to 4 two-level factors 
and 1 four-level factor. 

The ReliaWiki resource portal provides the design tables for all of these Taguchi OA designs at: 
http://www.reliawiki.org/index.php/Taguchi_Orthogonal_Arrays. 

The alias relations are given at: 
http://www.reliawiki.org/index.php/Alias_Relations_for_Taguchi_Orthogonal_Arrays. 

http://www.reliawiki.org/index.php/Taguchi_Orthogonal_Arrays
http://www.reliawiki.org/index.php/Alias_Relations_for_Taguchi_Orthogonal_Arrays
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Taguchi OA Alias Table 

The alias table for a Taguchi orthogonal array (OA) factorial design shows the aliased effects 
that would result from assigning certain factors to certain columns in the orthogonal array of 
the selected Taguchi design type (such as an L8 (2^7) design). 

The table can be accessed from the Design tab of the standard design folio while configuring a 
Taguchi OA factorial design. To open it, click the Additional Settings heading in the navigation 
panel and then click the View Alias Table icon in the input panel. 

 

As an example, the L16 (2^6 * 4^3) design uses 16 runs to investigate the main effects of up to 
6 two-level factors and up to 3 four-level factors. The alias table for this design is shown next. 
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The numbers in Taguchi OA alias tables represent factors that are assigned to columns in the 
array. For instance, "1" represents the factor assigned to the first column in the array (if any). 
"2x3" represents the interaction effect of the factors assigned to the second and third columns. 
Each column in an alias table lists the 2-way interaction effects that are aliased with the main 
effect of the factor listed in the column heading. 

For example, suppose your design includes 2 two-level factors (A and B) and one four-level 
factor (C). Furthermore, suppose you used the drop-down lists under the Taguchi Column 
Indices heading of the Additional Settings to assign factor A to the first column in the 
orthogonal array (A = 1), B to the second column (B = 2) and C to the seventh column (C = 7). 
According to the above alias table, the main effect of A (1) will be aliased with the interaction 
effect BC (2x7). 

The ReliWiki resource portal has more information on Taguchi OA alias tables at: 
http://www.reliawiki.org/index.php/Highly_Fractional_Factorial_Designs. 

http://www.reliawiki.org/index.php/Highly_Fractional_Factorial_Designs#Preferred_Columns_in_Taguchi_OA
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Specify Interaction Terms Window 

The Specify Interaction Terms window helps you assign factors to columns in the orthogonal 
array in a way that will not alias main effects or any of the selected interaction terms with any 
other terms. In other words, it helps you configure a design that you can use to determine 
whether any of the main effects or selected interaction effects are significant. 

The window can be accessed from the Design tab of the standard design folio while configuring 
a Taguchi OA factorial design. To open it, click the Additional Settings heading in the navigation 
panel and then click the Specify Interaction Terms link in the input panel. 

 

To enter an interaction effect that you wish to investigate, click the first row in the Selected 
Interactions table. Then specify the interaction using the drop-down lists in that row. For 
example, if you wish to include the interaction term AC, select factor A in the first drop-down 
list and factor C in the second, as shown next. 
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Once you click outside the row, the interaction term (e.g., "A·C") will appear. To remove the 
term, click inside its row and then click the red X. 

After you click OK, the software will attempt to assign factors to the appropriate columns in the 
orthogonal array. In the example shown next, Factor 1 is now assigned to column 1, Factor 2 to 
column 3, and Factor 3 to column 7. 

 

To ensure that you will be able to investigate the main effects and the interactions you entered, 
do not change the new factor assignments. 

The ReliWiki resource portal has more information on assigning array columns to factors at: 
http://www.reliawiki.org/index.php/Highly_Fractional_Factorial_Designs. 

http://www.reliawiki.org/index.php/Highly_Fractional_Factorial_Designs#Preferred_Columns_in_Taguchi_OA


Chapter 10: DOE Design Folios 

Weibull++ 2020 User's Guide 811 

 

Taguchi OA Designs: Example 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 

The name of the example project is "Factorial - Taguchi OA Design Example." 

Taguchi orthogonal array (OA) designs are often used in design experiments with factors that 
include more than two levels. Taguchi OA can be thought of as a general fractional factorial 
design. 

Consider an experiment to study the effect of four three-level factors on a fine gold wire 
bonding process in an IC chip-package. Taguchi OA L27 (3^13) is applied to identify the critical 
parameters in the wire bonding process. The response is the ball size. The smaller the ball size, 
the better the process. 

For this example, the four factors and their associated levels are: 

Factor Level 1 Level 2 Level 3 

Force 5 10 15 

Power 40 50 60 

Time 15 20 25 

Temperature 155 160 165 

Design the Experiment 

The experimenters create a Taguchi OA design folio, perform the experiment according to the 
design, and then enter the response values for further analysis. The design matrix and the 
response data are given in the "Taguchi OA L27(3^13)" folio. The following steps describe how 
to create this folio on your own. 

• Choose Home > Insert > Standard Design to add a standard design folio to the current 
project. 

 

• Click Design Type in the folio's navigation panel, and then select Taguchi OA Factorial in 
the input panel. 
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• Rename the response by clicking Response 1 in the navigation panel and entering Ball Size 
for the Name in the input panel. 

• Specify the number of factors by clicking the Factors heading in the navigation panel and 
choosing 4 from the Number of Factors drop-down list. 

• Define each factor by clicking it in the navigation panel and editing its properties in the 
input panel. The properties are given in the table above. The first factor is defined as shown 
next. (Note that every factor must be configured to have three levels.) 

 

• Rename the folio by clicking the Experiment1 heading in the navigation panel and entering 
Taguchi OA L27 (3^13) for the Name in the input panel. 

• Click the Additional Settings heading to choose an orthogonal array and assign factors to 
columns in the array. 
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• In the input panel, choose L27 (3^13) from the Taguchi Design Type drop-down list. 
This specifies the orthogonal array that will be used to generate the design. 

• To have the software determine which columns in the array will be assigned to the 
factors, click the Specify Interaction Terms link. In the window that appears, enter all 
possible two-way interactions between the factors being investigated. The easiest way 
to do this is by repeatedly clicking the row that says "Click here to add a new 
interaction" until the row disappears. 

 

• Click OK to close the window. Force is now assigned to column 1 of the array, Power to 
2, Time to 5 and Temperature to 9, as shown next. 

 

These column assignments will be used to generate a design that does not alias any of 
the two-way interactions you entered in the Specify Interaction Terms window with 
any main effects. 

• Finally, click the Build icon on the control panel to create a Data tab that allows you to view 
the test plan and enter response data. 



Chapter 10: DOE Design Folios 

814 https://www.reliasoft.com/weibull 

 

 

Analysis and Results - Part 1 

The data set for this example is given in the "Taguchi OA L27 (3^13)" folio of the example 
project. After you enter the data from the example folio, you can perform the analysis by doing 
the following: 

Note: To minimize the effect of unknown nuisance factors, the run order is randomly generated 
when you create the design. Therefore, if you followed these steps to create your own folio, the 
order of runs on the Data tab may be different from that of the folio in the example file. This 
can lead to different results. To ensure that you get the very same results described next, show 
the Standard Order column in your folio, then click a cell in that column and choose Sheet > 
Sheet Actions > Sort > Sort Ascending. This will make the order of runs in your folio the same as 
that of the example file. Then copy the response data from the example file and paste it into 
the Data tab of your folio. 

• On the Analysis Settings page of the control panel, select to use Individual Terms in the 
analysis. 

• Return to the Main page of the control panel and click the Calculate icon. 

 

Click the View Analysis Summary icon on the control panel and select to the view the ANOVA 
Table. 
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From this table, you can see that effects A, B, C are significant. To simply the analysis, the next 
step is to recreate the model using only the significant terms. 

Analysis and Results - Part 2 

The results for the reduced model are given in the "Reduced Model" folio of the example 
project. The following steps describe how to create this folio on your own and then use the 
results to find the factor settings that provide the smallest deviation in height. 

• Right-click the design folio in the current project explorer and select Duplicate Item from 
the shortcut menu. Rename the new folio with an appropriate name. 

• Click the Select Terms icon on the new folio's control panel. 

 

• In the Select Terms window that appears, click the Select Significant Effects button to 
select only the significant effects to calculate the new model, as shown next, then click OK. 

 

• Click the Calculate icon in the new folio's control panel. 
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• Click the View Analysis Summary icon on the control panel. In the Analysis Summary 
window that appears, view the Diagnostic Information table. The table is shown next. In 
order to identify which factor settings can provide the smallest ball size (and hence the best 
process), look for the runs in the table with the Fitted Value (YF) closest to zero 
(highlighted). 

 

Conclusions 

You can see that the first run in the standard order (8th run in the run order) is at the best 
combination of settings. The settings for this particular run on the Data tab is shown to be A = 
5, B = 40, C = 15. Under these settings, the expected ball size is lowest. 

Note that the best factor settings in this case are limited to those settings actually used in the 
experiment. This limitation can be avoided using response surface methodology, which may 
allow you to find the optimal settings for the manufacturing process. 



Chapter 10: DOE Design Folios 

Weibull++ 2020 User's Guide 817 

 

Response Surface Method Designs 

In factorial design, only the linear effects of the quantitative factors are studied. Response 
surface methodology allows you to study the quadratic effects of the factors (i.e., effects that 
differ depending on the level of the factors), making it well-suited to predictive modeling and 
optimization. The following types of response surface method designs are available: 

• Central Composite: A two level full or fractional factorial design is embedded in the central 
composite design, and additional center and axial points are also used in order to estimate 
curvature. This is the most commonly used response surface methodology design. 

• Box-Behnken: Each factor must have three levels, with one level being the center point 
between the high and low levels. This design type is useful in cases where setting all factors 
at extreme values simultaneously is undesirable (e.g., if setting all factors at the high level 
carries a risk of equipment damage or otherwise violates constraints). 

For more information about how to use the design types, please consult the documentation on 
design folios. 

Central Composite Designs 

In central composite designs, there are three kinds of points involved: 

• Factorial points: A two level full or fractional factorial design, using up to nine factors, is 
embedded in the central composite design. The points associated with this embedded 
design are also called "corner points," and are indicated by a 1 in the Point Type column on 
the Data tab. 

• Axial points: For each factor, two axial points are calculated as follows: all other factors are 
set to their coded 0 value (i.e., midway between the low and high —  or coded -1 and 1 
—  values) and the factor in question is set to -alpha and +alpha, where alpha is a value 
specified by the user. Axial points, sometimes called "star" points, allow estimation of 
curvature. These points are indicated by a -1 in the Point Type column on the Data tab. 

• Center point: All factors are set to the coded 0 value. These points are indicated by a 0 in 
the Point Type column on the Data tab. 

Thus, for each factor, five values are used: -alpha, -1, 0, 1, +alpha. 

Available Central Composite Designs 

The available central composite designs are shown next. This information is applicable to 
designs with standard response data, as well as robust parameter designs and reliability DOE. 
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This table provides information about how many corner point (i.e., factorial) runs will be used 
in the design, based on the number of factors and the selected fractionality of the design, as 
well as how many center points will be used by default when a single block is used. For 
example, if you are using 5 factors and have selected a full factorial design, the design will use 
32 corner point runs and will use 10 center points by default, provided that only a single block is 
used. If you are using 5 factors and have selected a half fraction design, the design will use 16 
corner point runs and will use 6 center points by default, provided that only a single block is 
used. 

Central Composite Designs: Example 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 

The name of the example project is "Response Surface Method - Central Composite Design." 

A chemical engineer is interested in determining the operating conditions that maximize the 
yield of a process. Two controllable variables influence process yield: reaction time and reaction 
temperature. 
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A central composite design with five center points and alpha = 1.414 is used to conduct the 
experiment. A full quadratic model is fitted to the data. 

Designing the Experiment 

The engineer creates a central composite design folio, performs the experiment according to 
the design, and then enters the response values into the folio for further analysis. The design 
matrix and the response data are given in the "Central Composite Design" folio. The following 
steps describe how to create this folio on your own. 

• Choose Home > Insert > Standard Design to add a standard design folio to the current 
project. 

 

• Click Design Type in the folio's navigation panel, and then select Central Composite 
Response Surface Method in the input panel. 

 

• Rename the folio by clicking the Experiment1 heading in the navigation panel and entering 
Central Composite Design for the Name in the input panel. 

• Rename the response by clicking Response 1 in the navigation panel and entering Yield in 
the input panel. 

• Specify the number of factors by clicking the Factors heading in the navigation panel and 
choosing 2 from the Number of Factors drop-down list in the input panel. 
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• Define each factor by clicking it in the navigation panel and editing its properties in the 
input panel. 

• First factor: 

• Name: Time 

• Units: min 

• Factor Type: Quantitative 

• Level 1 (Low): 80 

• Level 2 (High): 90 

• Second factor: 

• Name: Temperature 

• Units: F 

• Factor Type: Quantitative 

• Level 1 (Low): 170 

• Level 2 (High): 180 

• Click the Additional Settings heading. In the input panel, set the following properties: 



Chapter 10: DOE Design Folios 

Weibull++ 2020 User's Guide 821 

 

 

• Click the Design Summary heading to make sure that you have entered all settings 
correctly. The complete Design Summary is shown next. 
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• Finally, click the Build icon on the control panel to create a Data tab that allows you to view 
the test plan and enter response data. 

 

Analysis and Results 

The data set for this example is given in the "Central Composite Design" folio of the example 
project. After you enter the data from the folio, you can specify the settings for the analysis by 
doing the following: 

Note: To minimize the effect of unknown nuisance factors, the run order is randomly generated 
when you create the design. Therefore, if you followed these steps to create your own folio, the 
order of runs on the Data tab may be different from that of the folio in the example file. This 
can lead to different results. To ensure that you get the very same results described next, show 
the Standard Order column in your folio, then click a cell in that column and choose Sheet > 
Sheet Actions > Sort > Sort Ascending. This will make the order of runs in your folio the same as 
that of the example file. Then copy the response data from the example file and paste it into 
the Data tab of your folio. 

• Make sure all main effects and interactions will be considered. To do this, click the Select 
Terms icon on the control panel. 

 

In the window that appears, select the All Terms check box then click OK. 

• On the Analysis Settings page of the Control Panel, select to use Individual Terms in the 
analysis. 

• Click the Calculate icon. 

 

• The results in the Analysis Summary area on the main effects A and B, as well as the 
quadratic effects AA and BB, are significant. 

• To view a plot comparing the standardized effect of each term, click the Plot icon. 

 

Then choose Pareto Charts - Regression from the Plot Type drop-down list. The following 
plot appears. 
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The vertical blue line in the plot marks the critical value determined by the risk level 
specified on the Analysis Settings page of the control panel. If the bar goes past the blue 
line, then the effect is considered significant. 

From these results, effects A, B and AA and BB will be included in the reduced model. In 
fact, you could also include term AB in the model. From the Pareto chart, you can see that 
AB is only slightly below the critical value. The inclusion or exclusion of AB is a personal 
decision that should be made based on the knowledge of the experiment and the statistical 
results. For this example, only A, B, AA and BB will be included in the model. 

Optimization 

The results for the reduced model (which only includes the terms that were found to be 
significant) are given in the "Reduced Model" folio. The following steps describe how to create 
this folio on your own. 
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• Right-click the "Central Composite Design" folio in the current project explorer. Then 
choose Duplicate from the shortcut menu. 

• Right-click the new, duplicated folio in the current project explorer and choose Rename 
from the shortcut menu. Change the name to "Reduced Model." 

• Open the "Reduced Model" folio. Then click the Select Terms icon on the control panel. 

• In the Select Terms window that appears, click the Select Significant Effects icon to select 
only the significant effects to calculate the new model, as shown next, then click OK. 

 

• Click the Calculate icon. 

• In the Analysis Summary area on the control panel, click the View Analysis Summary icon 
to view detailed results from the analysis. 

• In the Analysis Summary window, select the Regression Table check box on the Available 
Report Items panel. The coefficients for the model will appear in the Regression Table as 
shown next. 
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• Click the Design - Optimization icon on the control panel. 

 

• In the Response Settings window that appears, use the settings shown next and click OK. 
These settings indicate that you want to maximize the Yield response, with values above 80 
being considered 100% desirable and values below 75 being undesirable. 

 

• An Optimization folio will appear with a plot showing the single solution that is found. 
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• You can choose Optimization > Solutions > View Solutions or click the icon on the control 
panel to see the solution in numerical format. 

 

The optimum settings for factors A and B are shown next. 
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• You also can use the surface plot to visually identify the optimal settings for factors A and B. 
Return to the Analysis Plot tab of the "Reduced Model" folio and click the 3D Plot icon in 
the control panel. 

 

The 3D Plot folio will open and display the surface plot, as shown next. 

 

Conclusions 

From the surface plot, you can see that the maximum yield occurs at Time = 86.8 and 
Temperature = 176.3° F, which is the same as the result from the optimization. The predicted 
maximum yield is 80.1861. Keep in mind that it is necessary to conduct an experiment using 
these settings to confirm this conclusion. 

Box-Behnken Designs 

Box-Behnken designs allow you to consider from three to nine quantitative factors at three 
levels each (one level being the center point between the high and low levels, which are the 
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only levels you define when you are creating the design). The designs are spherical and 
rotatable or nearly rotatable. If setting all factors at the high level at the same time carries a risk 
of equipment damage or otherwise violates constraints, these designs provide a matrix that 
avoids setting all factors at extreme values simultaneously. 

Available Box-Behnken Designs 

The available Box-Behnken designs are shown next. This information is applicable to designs 
with standard response data, as well as robust parameter designs and reliability DOE. 

 

This table provides information about how many non-center point runs will be used in the 
design, based on the number of factors, as well as how many center points will be used by 
default. For example, if you are using 5 factors, the design will use 40 non-center point runs and 
will use 6 center points by default. 

Box-Behnken Designs: Example 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 

The name of the example project is "Response Surface Method - Box-Behnken Design." 

Consider a UV-light system that is used to inactivate fungal spores of Aspergillus niger in corn 
meal.* Fungal contamination of grains during the post-harvest period has been a recurring 
health hazard. 
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The response is the log10 reduction of the fungal spores. Therefore, the goal is to maximize the 
reduction (response). 

Three process parameters in the UV-light system will affect the inactivation results. They are: A) 
treatment time (number of pulses), B) the distance from the UV strobe and C) input voltage for 
the UV lamp. 

 

A 15 run Box-Behnken design with three center points is conducted. A full quadratic model is 
fitted to the data. Using this model, the optimal setting that gives the largest reduction of 
fungal spores is found. 

Designing the Experiment 

The experimenters create a Box-Behnken design folio, perform the experiment according to the 
design, and then enter the response values in the folio for further analysis. The design matrix 
and the data are given in the "UV-light Treatment" folio. The following steps describe how to 
create this folio on your own. 

• Choose Home > Insert > Standard Design to add a standard design folio to the current 
project. 

 

• Click Design Type in the folio's navigation panel, and then select Box-Behnken Response 
Surface Method in the input panel. 
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• Rename the folio by clicking the Experiment1 heading in the navigation panel and entering 
UV-light Treatment for the Name in the input panel. 

• Specify the number of factors by clicking the Factors heading in the navigation panel and 
choosing 3 from the Number of Factors drop-down list. 

• Define each factor by clicking it in the navigation panel and editing its properties in the 
input panel. 

• First factor: 

• Name: Time 

• Units: sec 

• Factor Type: Quantitative 

• Level 1 (Low): 20 

• Level 2 (High): 100 

• Second factor: 

• Name: Distance 

• Units: cm 
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• Factor Type: Quantitative 

• Level 1 (Low): 3 

• Level 2 (High): 13 

• Third factor: 

• Name: Voltage 

• Units: V 

• Factor Type: Quantitative 

• Level 1 (Low): 2,000 

• Level 2 (High): 3,800 

• Click the Additional Settings heading. In the input panel, set the following properties: 

 

• Click the Design Summary heading to make sure that you have entered all settings 
correctly. The complete Design Summary is shown next. 
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• Finally, click the Build icon on the control panel to create a Data tab that allows you to view 
the test plan and enter response data. 

 

Analysis and Results 

The data set for this example is given in the "UV-light Treatment" folio of the example project. 
After you enter the data from the folio, you can specify the settings for the analysis by doing 
the following: 

Note: To minimize the effect of unknown nuisance factors, the run order is randomly generated 
when you create the design. Therefore, if you followed these steps to create your own folio, the 
order of runs on the Data tab may be different from that of the folio in the example file. This 
can lead to different results. To ensure that you get the very same results described next, show 
the Standard Order column in your folio, then click a cell in that column and choose Sheet > 
Sheet Actions > Sort > Sort Ascending. This will make the order of runs in your folio the same as 
that of the example file. Then copy the response data from the example file and paste it into 
the Data tab of your folio. 

• Make sure all main effects and interactions will be considered. To do this, click the Select 
Terms icon on the control panel. 
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In the window that appears, select the All Terms check box. Then click OK. 

• On the Analysis Settings page of the Control Panel, select to use Individual Terms in the 
analysis. 

• Click the Calculate icon. 

 

The results in the Analysis Summary area on the control panel show that time (A) and voltage 
(C) have significant effects on the reduction of the fungal spores, as well as AA (the quadratic 
effect of A) and the interaction of AC. 

• In the Analysis Summary area on the control panel, click the View Analysis Summary icon 
to view detailed results from the analysis. 

In the ANOVA table, you can see that effects A, C, AC and AA are significant. The p value for 
factor B is 0.1481, which is close to the risk level of 0.1. Therefore, you decide to include it 
in the final model. 
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Optimization 

The results for the reduced model (which only includes the terms that were found to be 
significant) are given in the "Reduced Model" folio. The following steps describe how to create 
this folio on your own. 

• Right-click the "UV-light Treatment" folio in the current project explorer. Then choose 
Duplicate from the shortcut menu. 

• Right-click the new, duplicated folio in the current project explorer and choose Rename 
from the shortcut menu. Change the name to "Reduced Model." 

• Open the "Reduced Model" folio. Then click the Select Terms icon on the control panel. 

• In the Select Terms window that appears, click the Select Significant Effects icon to select 
only the significant effects to calculate the new model, and also select the check box for 
term B, as shown next, then click OK. 

 

• Click the Calculate icon in the new folio's control panel. 
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• In the Analysis Summary area on the control panel, click the View Analysis Summary icon 
to view detailed results from the analysis. 

The coefficients for the model will appear in the Regression Table, as shown next. 

 

• Click the Design - Optimization icon on the control panel. 

 

• In the Response Settings window that appears, use the settings shown next and click OK. 
These settings indicate that you want to maximize Response 1, with values above 4.89975 
being considered 100% desirable and values below 2 being undesirable. 

 

• An Optimization folio will appear with a plot showing the single solution that is found. 
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• You can choose Optimization > Solutions > View Solutions or click the icon on the control 
panel to see the solution in numerical format. 

 

The optimum settings for factors A and B are shown next. 
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Conclusions 

The optimal solution is found to be A = 100 s, B = 3 cm and C = 3800 v. Under this setting, the 
expected logarithmic transformation of the reduction is 4.9. Keep in mind that it is necessary to 
conduct an experiment using this setting to confirm this conclusion. 

* S. Jun, J. Irudayaraj, A. Demirci and D. Geiser, "Pulsed UV-light treatment of corn meal for 
inactivation of Aspergillus niger spores," International Journal of Food Science and Technology, 
2003, 38, 883-888. 

One Factor Designs 

One factor designs, also called "one factor at a time" (OFAT) or one-way analysis of variance 
(ANOVA), are used to determine if a particular factor has an effect on an output or response. 
This approach allows you to take a detailed look at the effect of the factor (using up to 255 
levels), and it helps you determine whether a change in output is due to a change in the input 
(level) instead of random error. 

The factor in a one factor design must be configured as a qualitative factor. For this reason, 
predictions cannot be made for factor levels that are not tested, nor can one factor designs be 
used for optimization. 

Note: A one factor design is appropriate for planning an experiment involving a single factor. If 
you already have existing data that you want to examine, the one-way ANOVA folio offers this 
capability.  

For more information about how to use the design types, please consult the documentation on 
design folios. 

ONE FACTOR DESIGNS: EXAMPLE 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 

The name of the example project is "One Factor - Operators in Pulp Mill." 

Consider the following experiment, which was performed at a pulp mill. Plant performance is 
based on pulp brightness, as measured by a reflectance meter. Each of the four shift operators 
(denoted by A, B, C and D) made five pulp handsheets from unbleached pulp. Reflectance was 
read for each of the handsheets using a brightness tester. The data set is shown next. 
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Operator A Operator B Operator C Operator D 

59.88 59.87 60.83 61.01 

60.12 60.32 60.87 60.87 

60.88 60.42 60.56 60.69 

60.98 59.99 61 60.53 

59.9 60.12 60.5 60.63 

A goal of the experiment is to determine whether there are significant differences between the 
operators in making the handsheets and reading their brightness. If there are such differences, 
then the operators may not be creating the handsheets or recording their observations in a 
consistent manner. 

Designing the Experiment 

To determine whether there are differences between the operators, the experimenters create 
a one factor design folio and enter the response values into the folio for analysis. The design 
matrix and the response data are given in the "Operator Study" folio. The following steps 
describe how to create this folio on your own. 

• Choose Home > Insert > Standard Design to add a standard design folio to the current 
project. 

 

• Click Design Type in the folio's navigation panel, and then select One Factor in the input 
panel. 
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• Rename the response by clicking Response 1 in the navigation panel and entering 
Reflectance in the input panel. 

• Define the factor by clicking Factor 1 in the navigation panel and editing its properties in 
the input panel. 

• Factor name: Operator 

• Factor type: Qualitative 

• Number of levels: 4 

• Level 1: Operator A 

• Level 2: Operator B 

• Level 3: Operator C 

• Level 4: Operator D 

• Rename the folio by clicking the Experiment1 heading in the navigation panel and entering 
Operator Study for the Name in the input panel. 
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• Click the Additional Settings heading. In the input panel, set the number of Replicates to 5 
(since there are 5 measurements from each operator). 

• Finally, click the Build icon on the control panel to create a Data tab that allows you to view 
the test plan and enter response data. 

 

Analysis and Results 

The data set for this example is given in the "Operator Study" folio of the example project. After 
you enter the data from the example folio, you can perform the analysis by doing the following: 

Note: To minimize the effect of unknown nuisance factors, the run order is randomly generated 
when you create the design. Therefore, if you followed these steps to create your own folio, the 
order of runs on the Data tab may be different from that of the folio in the example file. This 
can lead to different results. To ensure that you get the very same results described next, show 
the Standard Order column in your folio, then click a cell in that column and choose Sheet > 
Sheet Actions > Sort > Sort Ascending. This will make the order of runs in your folio the same as 
that of the example file. Then copy the response data from the example file and paste it into 
the Data tab of your folio. 

• Click the Calculate icon on the Data tab control panel. 

 

• The result in the Analysis Summary area show that the p value is 0.0210. In other words, 
there is a 2.1% chance that the variation would be observed in the case when there is no 
significant difference between the response levels. Since the p value is less than the risk 
level (10%) entered on the Analysis Settings tab of the control panel, the conclusion is that 
the different factor levels (i.e., operators) do affect the response. 

 

• To see more detailed comparisons of the responses at different factor levels, click the View 
Analysis Summary icon and view the Mean Comparisons table. 
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The compared factor levels are listed in the Contrast column (e.g., "Operator A - Operator 
B" is the comparison of those two operators). When a p value is red, the compared levels 
are significantly different. For example, there is a significant difference between Operator 
A and Operator C, but there is no significant difference between Operator A and Operator 
B. 

• To see a plot that also allows you to compare the different factor levels, click the Plot icon. 

 

Then view the box plot. In this plot, you can see that see that operators C and D are 
nearly the same. 
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Conclusions 

The results show that there is a significant difference between operators A and C, between A 
and D, and so forth. As a result, the operators receive further training to insure that they create 
the handsheets and record their observations consistently. 

Robust Parameter Designs 

Robust parameter designs are based on the work of Genichi Taguchi. The purpose of robust 
designs is to find the settings of controllable factors that will minimize variation in the response 
due to uncontrollable noise factors. This is done by combining an inner array of control factors 
with an outer array of noise factors. All control factor setting combinations specified in the 
inner array are tested at each noise factor settings combination specified in the outer array. 
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AVAILABLE ROBUST PARAMETER DESIGNS 

The available designs for the inner and outer arrays of a robust parameter design depend on 
the design type selected for each array. 

For the inner array, the following design types may be used. Click a design type to view the 
available designs. 

• Two level factorial designs 

• Plackett-Burman designs 

• General full factorial designs 

• Taguchi OA designs 

Note that most Taguchi orthogonal arrays are saturated and therefore not effective for 
examining factorial interactions. If interactions of the control factors are likely, using a two level 
factorial design for the inner array may be desirable. 

For the outer array, all of the above design types are available except Taguchi OA designs. 
When configuring the outer array, note the following: 

• You can use a two level factorial design, a Placket-Burman design or a general full factorial 
design. 

• Each of these design types can have 1 to 15 factors when used for the outer array. 

• In addition to the settings described for configuring the inner array, you can also specify a 
number of replicates in the Additional Settings for the outer array. 

• You cannot define blocks, center points, responses or repeated measurements for the 
outer array, regardless of the design type. 

For more information about how to use the design types, please consult the documentation on 
design folios. 

USING ROBUST PARAMETER DESIGNS 

The Data tab for robust parameter designs works differently from that for other design types. 

In each cell in the noise condition columns, enter the response value obtained at the control 
factor settings specified in the current row and at the current noise condition. The noise factor 
settings represented by each noise condition column are available in the Noise Condition 
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Matrix in the Design Summary on the Design tab. For example, consider the Noise Condition 
Matrix and Data tab shown next. 

 

 

In the first row of the Data tab, you would enter the response values that were measured with 
the control factors set as follows: 

• Flow Rate: 2 

• Pressure: 2 

• Viscosity: 2 

• Cure Temperature: 120 

In the Noise Condition 1 column, you would enter the value measured at those control factor 
settings when Air Temperature = 15 and Humidity = 50. In the Noise Condition 2 column, you 
would enter the value measured when Air Temperature = 30 and Humidity = 50, and so on. 

In analyzing the data set, the software can calculate results for the Y Mean, Y Standard 
Deviation and Signal Noise Ratio columns. You will select one or more of these columns to be 
used as the "responses" for the analysis by selecting the check boxes in the column headings. 

• Each value in the Y Mean column is the average measured response at the specified 
combination of control factor settings, across all noise conditions. 

• The Y Standard Deviation column provides the standard deviation of the response at the 
given control settings across all noise conditions. This column has the natural log 
transformation applied by default 
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• The values in the Signal Noise Ratio column indicate how robust the response is to the 
noise factors at the specified combination of control factor settings, where a greater value 
indicates that the measured response is less affected by the noise factors. This is the main 
point of robust parameter design, so you will almost always have this column selected. 

For each column selected for inclusion in the analysis, you can specify settings on the Analysis 
Settings page of the control panel. For the Signal Noise Ratio column, you must specify the 
equation to be used in calculating the ratio. Your selection for this option is determined by the 
purpose of your analysis: 

• Nominal (or "nominal-the-best") should be used if you have a specific target value for the 
measured response. 

• Larger (or "larger-the-better") should be used if you want to maximize the value of the 
measured response. 

• Smaller (or "smaller-the-better") should be used if you want to minimize the value of the 
measured response. 

ROBUST PARAMETER DESIGNS: EXAMPLE 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 

The name of the example project is "Robust Parameter Design - Method Settings." 

Robust parameter design is used to find the appropriate control factor levels in the design to 
make the system less sensitive to variations in uncontrollable noise factors (i.e., to make the 
system robust). 

Consider an experiment that seeks to determine a method to assemble an elastomeric 
connector to a nylon tube while delivering the requisite pull-off performance suitable for an 
automotive engineering application. 

The primary design objective is to maximize the pull-off force, while secondary considerations 
are to minimize assembly effort and reduce the cost of the connector and assembly. 

The controllable and noise factors are: 
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For the inner (control) array, Taguchi OA L9 (3^4) is used. For the outer (noise) array, a two 
level full factorial design is applied. 

The measured response is the pull-off force. 

Design the Experiment 

The experimenters create a robust parameter design folio, perform the experiment according 
to the design, and then enter the response values into the folio for further analysis. The design 
matrix and the response data are given in the "Method Settings" folio. The following steps 
describe how to create this folio on your own. 

• Choose Home > Insert > Robust Design to add a robust parameter design folio to the 
current project. 

 

• Click Design Type under the Inner Array heading in the navigation panel, and then select 
Taguchi OA Factorial in the input panel. 
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• Rename the folio by clicking the Robust1 heading in the navigation panel and entering 
Method Settings for the Name in the input panel. 

• Specify the number of factors by clicking Factors under the Inner Array heading in the 
navigation panel and choosing 4 from the Number of Factors drop-down list. 

• Define each factor by clicking it in the navigation panel and editing its properties in the 
input panel. The properties are given in the first table above. The first factor is defined as 
shown next. 

 

• Click Design Type under the Outer Array heading in the navigation panel, and then select 
Two Level Factorial in the input panel. 
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• Specify the number of factors by clicking Factors under the Outer Array heading in the 
navigation panel and choosing 3 from the Number of Factors drop-down list. 

• Define each factor by clicking it in the navigation panel and editing its properties in the 
input panel. The properties are given in the second table above. 

• Click the Design Summary heading to make sure that you have entered all settings correctly 
and to view the Noise Condition Matrix. The complete Design Summary is shown next. 
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• Finally, click the Build icon on the control panel to create a Data tab that allows you to view 
the test plan and enter response data. 

 

Analysis and Results 

The data set for this example is given in the "Method Settings" folio of the example project. 
After you enter the data from the folio, you can perform the analysis by doing the following: 

Note: To minimize the effect of unknown nuisance factors, the run order is randomly generated 
when you create the design. Therefore, if you followed these steps to create your own folio, the 
order of runs on the Data tab may be different from that of the folio in the example file. This 
can lead to different results. To ensure that you get the very same results described next, show 
the Standard Order column in your folio, then click a cell in that column and choose Sheet > 
Sheet Actions > Sort > Sort Ascending. This will make the order of runs in your folio the same as 
that of the example file. Then copy the response data from the example file and paste it into 
the Data tab of your folio. 
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• On the Analysis Settings page of the control panel, select to use Individual Terms for the Y 
Mean response, which is currently chosen in the Response drop-down list. 

• Choose the Y Std response from the Response drop-down list and select to use Individual 
Terms for it. 

• Choose the Signal Noise Ratio response and select Larger in the Signal Noise Ratio area, as 
you are aiming to maximize the pull-off force response. Select to use Individual Terms for 
this response as well. 

• Click the Calculate icon. 

 

The three responses—Y Mean, Y Standard Deviation and Signal Noise Ratio—are automatically 
calculated and are used as the responses in the analysis. Note that the logarithmic 
transformation is automatically applied to the Y Standard Deviation response. To view the 
transformation, you can click the Transformation icon. 

 

In the Select Transformation window, choose the Y Standard Deviation response from the 
Response drop-down list to see the transformation that has been applied. When you are 
finished viewing the transformation, click OK to close the window. 

In robust design, you can use the effect plots to find proper factor settings to meet both mean 
and standard deviation requirements for the response. 

• Click the Plot icon. 

 

• Choose Main Effects from the Plot Type drop-down list. 

• Choose Data Means from the drop-down list in the Response Values area. This allows you 
to view the response values based on values in the original data rather than fitted values. 
The main effect plot for the Y Mean (pull-off force) response is shown next. 
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• To view the main effect plot for the Y Standard Deviation response, choose Y Std in the 
Response drop-down list. 



Chapter 10: DOE Design Folios 

852 https://www.reliasoft.com/weibull 

 

 

• To view the main effect plot for the Signal Noise Ratio response, choose Signal Noise Ratio 
in the Response drop-down list. 
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Conclusion 

Since the goal is to maximize both signal-to-noise ratio and the pull-off force, some trade-off 
may need to be made in the selecting of factor settings. Examining the main effect plots for Y 
Mean and Signal Noise Ratio shows that the medium level for A is clearly the best choice for 
maximizing signal-to-noise ratio (robustness) and the average pull-off force (Y Mean). It also has 
a relatively low standard deviation value. For the wall thickness, B, the medium and high level 
are slightly better than the low level for signal-to-noise ratio; however, the medium is preferred 
to high level in order to maximize the average pull-off force. From the main effect plot, the 
better settings for factors C and D can also be determined. In the final analysis, the best settings 
to maximize signal-to-noise ratio are A (medium), B (medium), C (deep) and D (low), based on 
the experimental results for maximizing pull-off force. 
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Mixture Designs 

Mixture designs are used when the factors in an experiment are components in a mixture, and 
when you wish to determine the best proportions to use for each component. Since the 
proportions of all the components in a mixture must always sum to one, mixture designs 
assume that all the component factors are dependent (i.e., changing one component's value in 
an experiment will necessarily change others). 

Mixture designs can also include process variables as factors. For example, if the components in 
a mixture are different metals that are combined to produce steel, the experimenter can 
choose to consider process variables like temperature and pressure in order to determine the 
best way to process the mixture (in addition to estimating the best proportions of the metals). 

Specific mixture design types include: 

• Simplex designs, which assume that there are either no bounds or only lower bounds on 
the component amounts. 

• Extreme vertex designs are more complicated designs that allow you to add linear 
constraints on the design and/or upper bounds on individual components. 

For more information about how to use the design types, please consult the documentation on 
design folios. 

Simplex Designs 

The factor levels for components in simplex designs are subject to the following constraints: 

• The proportions of all the components must sum to one. 

• The amounts of each component must be at least the specified lower bound and no greater 
than the specified total amount. 

If you want to further constrain the factor levels by adding upper bounds to components, or by 
adding linear constraints (i.e., bounds on combinations of components), use an extreme vertex 
design. 

Available Simplex Designs 

There are three types of simplex designs: 

• Simplex Lattice: With this design, the blends in the experiment are determined by the 
specified number of levels of each component (i.e., the degree of design + 1). Since it 



Chapter 10: DOE Design Folios 

Weibull++ 2020 User's Guide 855 

 

includes all the reasonable combinations of components, this design is useful when the 
number of components is not large, and a higher polynomial equation is needed for 
optimization. 

• Simplex Centroid: By default, this design includes single-component blends (vertices) and 
all centroids up to the dimension g, where g is the number of components. Users can 
specify the degree of design (i.e., the dimension of centroids). Since it usually has fewer test 
runs than a simplex lattice design, this design is useful when the number of components is 
larger, but a lower polynomial equation will suffice for optimization. 

• Simplex Axial: This design includes vertices, blends with an absent component (edge 
points), center points and interior points between the center point and vertices (axial 
points). It is mainly used for screening components. 

Simplex Designs: Example 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 

The name of the example project is "Mixture Design - Design with Process Variables." 

A type of vinyl is used for seat covers. Several components are used to make it. A preliminary 
experiment is set up to study three plasticizers (X1, X2 and X3), where the percentage of their 
total formulation contribution is 40%. The percentage of the remaining components is to be 
held fixed in all blends studied, where the sum of their parts by weight make up 60% of the 
total. A {3, 2} simplex lattice design is used. 

Two process variables, rate of extrusion (Z1) and temperature of drying (Z2), are very important 
to make good vinyl. A two level factorial design is used for them. The low and high for Z1 are 10 
and 20; the low and high for temperature are 30 and 50. No units for them are provided. 

A complete {3, 2} simplex lattice design for the components is conducted under each of the 4 
combinations of Z1 and Z2. 

The measured response is the vinyl thickness value. The ideal thickness is 10. The acceptable 
range is 9 to 11. 

Designing the Experiment 

The experimenters create a simplex lattice design folio, perform the experiment according to 
the design, and then enter the response values into the folio for analysis. The design matrix and 
the response data are given in the "Design with Process Variables" folio. The following steps 
describe how to create this folio on your own. 
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• Choose Home > Insert > Mixture Design to add a mixture design folio to the current 
project. 

 

• In the folio's navigation panel, under the Design for Mixture Factors heading, click Design 
Type and then select Simplex Lattice in the input panel. 

 

• Rename the folio by clicking the Mixture1 heading in the navigation panel and entering 
Design with Process Variables for the Name in the input panel. 

• Rename the response by clicking Response 1 in the navigation panel and entering 
Thickness in the input panel. 

• Specify the number of mixture factors by clicking the Mixture Factors heading in the 
navigation panel and choosing 3 from the Number of Factors drop-down list. 

• Rename each factor by clicking it in the navigation panel and editing its properties in the 
input panel. 

• Click the Additional Settings heading to specify the sum of the components and the degree 
of the lattice. 

• Set the Mixture Total to 0.4. 

• Set the Degree of Design to 2. 
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• Click the Design for Process Factors heading in the navigation panel and choose Yes in the 
Include process factors? field. 

• Click Design Type and then select Two Level Factorial in the input panel. 

 

• Specify the number of process factors by clicking the Process Factors heading in the 
navigation panel and choosing 2 from the Number of Factors drop-down list. 

• Define each factor by clicking it in the navigation panel and editing its properties in the 
input panel. 

• First factor: 

• Name: Rate of Extrusion 

• Type: Quantitative 

• Level 1 (Low): 10 

• Level 2 (High): 20 

• Second factor: 
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• Name: Temperature 

• Type: Quantitative 

• Level 1 (Low): 30 

• Level 2 (High): 50 

• Click the Design Summary heading to make sure that you have entered all settings 
correctly. The complete Design Summary is shown next. 
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• Finally, click the Build icon on the control panel to create a Data tab that allows you to view 
the test plan and enter response data. 
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Analysis and Results 

The data set for this example is given in the "Design with Process Variables" folio of the 
example project. After you enter the data from the folio, you can perform the analysis by doing 
the following: 

Note: To minimize the effect of unknown nuisance factors, the run order is randomly generated 
when you create the design. Therefore, if you followed these steps to create your own folio, the 
order of runs on the Data tab may be different from that of the folio in the example file. This 
can lead to different results. To ensure that you get the very same results described next, show 
the Standard Order column in your folio, then click a cell in that column and choose Sheet > 
Sheet Actions > Sort > Sort Ascending. This will make the order of runs in your folio the same as 
that of the example file. Then copy the response data from the example file and paste it into 
the Data tab of your folio. 

• Select terms for the model by clicking the Select Terms icon on the control panel. 

 

In the window that appears, select the linear effects and 2-way interaction effects of the 
mixture factors in the model. The linear effects and 2-way interaction effects of the process 
factors are crossed with each term of the mixture factors. Click OK. 

• On the control panel, click the Calculate icon. 

 

Click the View Analysis Summary icon on the control panel and select to the view the 
Regression Information table. Note that the results from this step are not visible in the example 
folio, which shows the reduced model results that are obtained later in this example. 
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Terms with an asterisk (*) are significant terms selected by Lenth’s method. Terms with 
coefficients (absolute value) less or equal to 1 can be removed, and coefficients close to 0 can 
be considered insignificant. These terms are: 

• Z1*A 

• Z1*B 

• Z2*A 

• Z2*B 

• Z1*Z2*B 

• Z1*Z2*C 
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Return to the Select Terms window and remove these terms, then recalculate the folio. The 
results are shown next. Note that the results from this step are not visible in the example folio, 
which shows the reduced model results that are obtained later in this example. 

 

Some of the terms in the above model should be removed again since their p values are 
relatively high (i.e., at least 0.1). These terms are: 

• A*C 

• B*C 

• Z1*A*B 

• Z1*A*C 

• Z1*B*C 

• Z2*A*B 

• Z2*A*C 

• Z2*B*C 

• Z1*Z2*A*C 
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• Z1*Z2*B*C 

The results with these terms removed are shown next. 

 

Optimization 

• Click the Design - Optimization icon on the control panel. 

 

• In the Response Settings window that appears, use the settings shown next and click OK. 
These settings indicate that you want to reach a target thickness of 10, with values less 
than 9 or greater than 11 being undesirable. 
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• An Optimization folio will appear with an optimal solution plot showing the fourth solution, 
displayed next. (The Solutions area on the control panel shows all the solutions that were 
found, and you can click them to view the plot representing the solution.) 
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• You can choose Optimization > Solutions > View Solutions or click the icon on the control 
panel to see all the optimal solutions in numerical format. 

 

Four optimum settings were found, and they are shown next. 
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Conclusions 

The optimal solution is found to be X1 = 0.349, X2 = 0 and X3 = 0.051 with process factors Rate 
of Extrusion = 10.000 and Temperature = 50.000. Under this setting, the expected thickness of 
the vinyl is 10.00. Keep in mind that it is necessary to conduct an experiment using this setting 
to confirm this conclusion. 

Extreme Vertex Designs 

While simplex designs provide allow you to place lower bounds on individual mixture factors, 
there may be situations where more complicated constraints are appropriate. Extreme vertex 
designs allow you to impose additional limits on the component values by specifying upper 
bounds on components and defining linear constraints for blends. 

Defining Linear Constraints 

Unlike component bounds, which put limits on individual component amounts, linear 
constraints allow you to place limits on combinations of components. As an example, if you 
have three components in your experiment (C1, C2 and C3), the following two limits would be 
linear constraints: 

• The combined amount of C1 and C2 in any blend must be at least 0.5 grams. 

• In any blend, the amount of C3 must be at least twice the amount of C2. 

When you're creating an extreme vertex design, constraints like these are defined by opening 
the Linear Constraints window. To do this, click the Additional Settings heading on the 
navigation panel, and then click the [+] icon under Linear Constraints. To remove a constraint, 
click the [-] icon next to it. 

Defining Constraints 

Each row in the Linear Constraints window represents an equation that defines a single 
constraint. The first and last columns represent lower/upper bounds of the constraint, and the 
middle columns represent the coefficients of each component in the blend (the column headers 
show the abbreviated factor names). If a constraint lacks a lower or upper bound, or if there 
certain components that are not considered, you can leave those cells blank. 

Consider the two example constraints above. These constraints could be defined as shown 
next. 
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• According to the first constraint, the combined amount of C1 and C2 must be at least 0.5. In 
other words: 

0.5 <= C1 + C2 

So 0.5 is entered for the lower bound, and 1 is entered for the coefficients of C1 and C2. 

• The second constraint can be expressed as follows. 

2*C2 <=  C3 

In other words, C3 must be at least double the amount of C2. This is equivalent to the 
following: 

2*C2 - C3 <= 0 

So 2 and -1 are entered for the coefficients of C2 and C3, and 0 is entered for the upper 
bound. 

After you click OK, the constraints are displayed in the folio as shown next. To edit a constraint, 
just click the blue equation to re-open the Linear Constraints window. 
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Validating Constraints 

To determine whether you have entered any incompatible or unnecessary linear constraints 
(i.e., constraints that rule out all blends, or which do not impose any new limits beyond those 
already defined), click the Validate Constraints icon in the additional settings. 

Colored dots will appear next to any problematic constraints. Red dots represent incompatible 
constraints, and orange dots represent unnecessary ones. For example, Constraint 1 below is 
unnecessary because it is identical to the default constraint. And Constraint 2 is incompatible 
with Constraint 1 because no blend can have an amount that is both at most 1 (Constraint 1) 
and at least 6 (Constraint 2). 

 

Note: Information on the number of runs in the Design Information area of the control panel 
and in the Design Summary will not be available until you have validated the constraints. 

Extreme Vertex Designs: Example 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 

The name of the example project is "Mixture Design - Extreme Vertex Design." 

Four components, A, B, C and D, are used to make a polymer material. Their proportions are 
restricted by lower and upper bounds, and two linear constraints: 

Bounds: 

• 0.20 ≤ A ≤ 0.65 

• 0.10 ≤ B ≤ 0.55 

• 0.10 ≤ C ≤ 0.20 

• 0.15 ≤ D ≤ 0.35 

Linear constraints: 



Chapter 10: DOE Design Folios 

Weibull++ 2020 User's Guide 869 

 

• 0.25 ≤ A + C ≤ 0.70 

• 0.25 ≤ C + D ≤ 0.45 

The objective of the experiment is to find the best settings of each component in order to 
maximize the strength of the material. An experiment within the feasible region defined by the 
above constraints should be conducted. The experimenters want some experiment runs to be 
placed at the boundary of the feasible region and some to be inside the region. 

Designing the Experiment 

The experimenters create an extreme vertex design folio, perform the experiment according to 
the design, and then enter the response values into the folio for analysis. The design matrix and 
the response data are given in the "Extreme Vertex Design" folio. The following steps describe 
how to create this folio on your own. 

• Choose Home > Insert > Mixture Design to add a mixture design folio to the current 
project. 

 

• In the folio's navigation panel, under the Design for Mixture Factors heading, click Design 
Type and then select Extreme Vertex in the input panel. 

 

• Specify the number of mixture factors by clicking the Mixture Factors heading in the 
navigation panel and choosing 4 from the Number of Factors drop-down list. 
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• Define each factor by clicking it in the navigation panel and editing its properties in the 
input panel. The bounds for each factor are given above. The first factor is defined as 
shown next. 

 

• Rename the folio by clicking the Mixture1 heading in the navigation panel and entering 
Extreme Vertex Design for the Name in the input panel. 

• Click the Additional Settings heading to choose the number of center points and axial 
points per vertex, and to specify the linear constraints. 

• Set the number of Center Points to 1. 

• Set the Axial per Vertex field to 1. 

• Click the [+] icon under Linear Constraints and enter the linear constraints as shown 
next. 
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After you click OK, the constraints are displayed in the folio as shown next. 

 

• To determine whether you have entered any incompatible or unnecessary linear 
constraints, click the Validate Constraints icon next to the Linear Constraints heading. 

  

No constraints are marked as problematic, so you can proceed. 

• Finally, click the Build icon on the control panel to create a Data tab that allows you to view 
the test plan and enter response data. 

 

Analysis and Results 

The data set for this example is given in the "Extreme Vertex Design" folio of the example 
project. After you enter the data from the folio, you can perform the analysis by doing the 
following: 

Note: To minimize the effect of unknown nuisance factors, the run order is randomly generated 
when you create the design. Therefore, if you followed these steps to create your own folio, the 
order of runs on the Data tab may be different from that of the folio in the example file. This 
can lead to different results. To ensure that you get the very same results described next, show 
the Standard Order column in your folio, then click a cell in that column and choose Sheet > 
Sheet Actions > Sort > Sort Ascending. This will make the order of runs in your folio the same as 
that of the example file. Then copy the response data from the example file and paste it into 
the Data tab of your folio. 

• Make sure all terms up to 2-way interactions will be considered. To do this, click the Select 
Terms icon on the control panel. 

 

In the window that appears, select the Linear and Quadratic check boxes. Then click OK. 
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• On the Analysis Settings page of the Control Panel, select to use Individual Terms in the 
analysis. 

• Click the Calculate icon. 

 

• In the Analysis Summary area on the control panel, click the View Analysis Summary icon 
to view detailed results from the analysis. Note that the results from this step are not 
visible in the example folio, which shows the reduced model results that are obtained later 
in this example. 

In the ANOVA table, you can see that effects AD, BD and CD are significant. The p value for 
effect BC is also relatively close to the risk level of 0.1. Therefore, you decide to include it in 
the final model. 
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Optimization 

The reduced model includes only the terms that were found to be significant. The following 
steps describe how to obtain this model on your own. 

• Click the Select Terms icon on the control panel. 

• In the Select Terms window that appears, click the Select Significant Effects icon to select 
only the significant effects to calculate the new model, and also select the check box for 
effect BC, as shown next, then click OK. 
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• Click the Calculate icon in the control panel. 

• In the Analysis Summary area on the control panel, click the View Analysis Summary icon 
to view detailed results from the analysis. 
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• Click the Design - Optimization icon on the control panel. 

 

• In the Response Settings window that appears, use the settings shown next and click OK. 
These settings indicate that you want to maximize Response 1, with values above 3.5 being 
considered 100% desirable and values below 3.0 being undesirable. 

 

• An Optimization folio will appear with a plot showing the single solution that is found. 
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• You can choose Optimization > Solutions > View Solutions or click the icon on the control 
panel to see the solution in numerical format. 

 

The optimum settings are shown next. 
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Conclusions 

The optimal solution is found to be A = 0.2, B = 0.35, C = 0.2 and D = 0.25. Under this setting, 
the expected strength of the material is 3.75. Keep in mind that it is necessary to conduct an 
experiment using this setting to confirm this conclusion. 

Reliability DOE 

Unlike other design types, reliability designs are specifically intended to handle life data. Only 
one response (typically failure time) is measured, but the designs can accommodate data sets 
that include suspensions (right censoring) and/or uncertainty as to when the units failed 
(interval and/or left censoring), in addition to complete data sets in which all of the units under 
test failed and the failure time for each unit is known. 

In contrast to traditional DOE techniques, which assume that response values at any treatment 
level are normally distributed, reliability DOE (R-DOE) uses the Weibull, lognormal or 
exponential distribution to analyze data. You can publish the fitted distribution as a model for 
use in other applications, if desired. In addition, the kinds of results and plots available may 
differ from those that are available with DOE using standard response data. 

Tip: To perform R-DOE, select any design type in a standard design folio and set the Response 
Type for one of the responses to Life Data. (See Adding, Removing and Editing Responses.) 

This section explains how to perform reliability DOE, including: 

The ReliaWiki resource portal provides more information about R-DOE at 
http://www.reliawiki.org/index.php/Reliability_DOE_for_Life_Tests. 

Tip: If you wish to analyze life data from a prior experiment, considering using the free form 
folio, which does not require that you create an experiment design. 

AVAILABLE RELIABILITY DESIGNS 

The available designs for reliability DOE are: 

• One factor reliability designs allow you to test a single factor using from 2 to 20 levels to 
determine if the factor has an effect on the product's reliability. Note that the factor in a 
one factor design is treated as a qualitative factor. Therefore, predictions cannot be made 
for factor levels that are not tested, and the designs cannot be optimized. 

http://www.reliawiki.org/index.php/Reliability_DOE_for_Life_Tests
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• Factorial reliability designs allow you to test multiple factors at two levels each to 
investigate the effect of the factors on the product's reliability. 

• In factorial reliability design, only the linear effects of the quantitative factors are studied. 
Response surface method (RSM) reliability designs allow you to study the quadratic effects 
of the factors (i.e., effects that differ depending on the level of the factors), making them 
well-suited to predictive modeling and optimization. For example, RSM reliability designs 
can be used to determine the factor settings that will optimize the reliability of a 
component. 

For more information about how to use the design types, please consult the documentation on 
design folios. 

RELIABILITY DESIGN DATA TYPES 

Reliability designs allow you to enter life data (i.e., times-to-failure data) as the response. 
Depending on the censoring type you select, other information may also be included. When you 
are selecting the design settings in a design folio, you can select Life Data as the response type 
and then choose an option from the Censoring drop-down list on the Design tab. (See Adding, 
Removing and Editing Responses.) 

 

The censoring option you choose will determine which of the following data types is used in the 
design: 

• Life Data with No Censoring (Complete Data): Complete data are obtained by recording 
the exact times when the units failed. For example, if we tested five units and they all 
failed, and we recorded the time when each failure occurred, we would then have 
complete information as to the time of each failure in the sample. Complete data are 
shown next in the context of a one factor reliability design. 
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• Life Data with Suspensions (Right Censored Data): The data points for units that did not 
fail during the observation period are known as suspensions or right censored data, which 
means that the event of interest (i.e., the failure time) is to the right of our data point on 
the time scale. For example, if we tested six units and only four had failed by the end of the 
test, the observed operating time of the two units that did not fail would be referred to as 
right censored data. Failure times with right censored data are shown next in the context of 
a one factor reliability design (e.g., the last data point is a suspension at time = 500). 

 

• Life Data with Intervals: Interval censored data sets contain uncertainty as to when the 
units actually failed. For example, if five units under test are inspected every 100 hours, 
then the status of each unit (failed or still running) is known only at the time of each 
inspection. If a unit fails, it is known only that it failed between inspections and the exact 
time of failure is not known. Instead of an exact failure time, an interval of time (e.g., 
between 0 and 100 hours, or 100 and 200 hours) would be recorded. Interval data are 
shown next in the context of a factorial reliability design (e.g., the first data point indicates 
that a failure occurred at some time between 140 and 160 hours). 
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• Life Data with Both Suspensions and Intervals: This is the most general data type, as it 
includes all of the possible censoring types. Failure times with interval and right censored 
data type are shown next in the context of a factorial reliability design. (Note that the first 
data point is actually an exact failure time since it has an interval with identical start and 
end times.) 

 

ALTER DATA TYPE WINDOW 

The Alter Data Type window is used to specify the type of life data response (e.g., right 
censored data) that is used in the current experiment. It is available only for designs that are 
configured to accept life data. To open the window, choose Data > Design > Alter Data Type or 
by click the icon on the Data tab control panel. 

 

The following options are available in the Life Data Response Type area of the Alter Data Type 
window. 

• Select My data set contains suspensions (right censored data) if the response data 
includes times at which some test units were observed as not being failed. 

• Select My data set contains interval and/or left censored data if the response data 
includes intervals during which a failure/suspension is known to have occurred. 

The area at the bottom of window shows the response columns that will be included on the 
Data tab, given the selections in the Life Data Response Type area. 

PUBLISHING MODELS FROM R-DOE RESULTS 

You can publish reliability DOE (R-DOE) results as a model resource for use throughout the 
project. To publish a model based on R-DOE results, click the Publish Model icon on the 
Publishing page of the design folio or free form folio control panel. (Note that the Publishing 
page is available only when the selected response is configured as life data.) 
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At this point, you need to provide the factor settings that will be used to solve for the scale 
parameter of the published model. In the window that appears, choose the tool that will solve 
for the scale parameter. Two tools are available: 

• The Prediction window lets you directly enter the factor level combination. Just enter the 
factor values in the green factor columns, perform the prediction and click the Publish 
Model button on the control panel. The resulting model will be based on the factor level 
combination you selected in the table. (To select a combination, click any cell in the row 
that contains that combination.) 

• The Optimal Solution Plot helps you find the factor level combination that produces the 
best response value(s). After you perform the optimization, select the solution you wish to 
use in the Solutions area on the control panel, then click the Publish Model button on the 
control panel. 

After you choose to publish the prediction or optimal solution, the Publish Model window will 
appear, allowing you to specify the model name and the model category. Click OK to publish 
the model. 

All other tools for working with the published model, such as displaying its properties and 
tracing its usage, are on the Publishing page of the control panel for the R-DOE analysis. 

ONE FACTOR RELIABILITY DESIGNS: EXAMPLE 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 

The name of the example project is "Reliability DOE - One Factor Reliability DOE." 

In this example, one factor reliability DOE is used to determine if there is a difference in three 
different materials that can be used in a product and, if there is, to determine which material is 
the best in terms of the product life. 10 units were tested for each material, and the test 
stopped at 500 hours. The product's life is assumed to follow the Weibull distribution. 

Designing the Experiment 

The design matrix and the response data are given in the "3 Levels One Factor" folio. The 
following steps describe how to create this folio on your own. 

• Choose Home > Insert > Standard Design to add a standard design folio to the current 
project. 
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• Click Design Type in the folio's navigation panel, and then select One Factor in the input 
panel. 

 

• Specify that you will be performing reliability DOE by clicking Response 1 in the navigation 
panel and choosing Life Data from the Response Type drop-down list. Then choose 
Suspensions from the Censoring drop-down list to specify that some of the data points will 
be suspensions (i.e., times at which the unit was found not failed). 

• Define the factor by clicking Factor 1 in the navigation panel and editing its properties in 
the input panel. 

• Factor type: Qualitative 

• Number of levels: 3 

• Level 1: Type A 

• Level 2: Type B 

• Level 3: Type C 
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• Rename the folio by clicking the Experiment1 heading in the navigation panel and entering 
3 Levels One Factor for the Name in the input panel. 

• Click the Additional Settings heading. In the input panel, set the number of Replicates to 10 
(since there are ten units tested for each material). 

• Finally, click the Build icon on the control panel to create a Data tab that allows you to view 
the test plan and enter response data. 

 

Analysis and Results 

The data set for this example is given in the "3 Levels One factor" folio of the example project. 
After you enter the data from the example folio, you can perform the analysis by doing the 
following: 

Note: To minimize the effect of unknown nuisance factors, the run order is randomly generated 
when you create the design. Therefore, if you followed these steps to create your own folio, the 
order of runs on the Data tab may be different from that of the folio in the example file. This 
can lead to different results. To ensure that you get the very same results described next, show 
the Standard Order column in your folio, then click a cell in that column and choose Sheet > 
Sheet Actions > Sort > Sort Ascending. This will make the order of runs in your folio the same as 
that of the example file. Then copy the response data from the example file and paste it into 
the Data tab of your folio. 

• In the Distribution drop-down list on the Data tab control panel, select to use the Weibull 
distribution for the analysis. 

• Click the Calculate icon on the Data tab control panel. 

 

• The result in the Analysis Summary area show that the p value is 0.032. In other words, 
there is a 3.2% chance that the variation would be observed in the case when there is no 
significant difference between the response levels. Since the p value is less than the risk 
level (10%) entered on the Analysis Settings tab of the control panel, the conclusion is that 
the different factor levels (i.e., materials) do affect the response. 
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• To see more detailed comparisons of the responses at different factor levels, click the View 
Analysis Summary icon and view the Life Comparisons table. 

 

The compared factor levels are listed in the Contrast column (e.g., "Type A - Type B" is the 
comparison of those two materials). When a p value is red, the compared levels are 
significantly different. For example, there is a significant difference between the Type A and 
Type B materials, but there is no significant difference between Type B and Type C. 

• To see a plot that shows how the product life differs for each material, click the Plot icon. 

 

Then view the life characteristic plot. 
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This plot shows the calculated life characteristic for each type of material. The tick marks at 
the top and bottom of the vertical lines mark the two-sided confidence bounds on the life 
characteristic. Since the Weibull distribution was used to calculate the data, the life 
characteristic is eta (i.e., the time at which unreliability = 63.2%). 

Conclusions 

The analysis showed that the type of material used does affect the product life. From the life 
characteristic plot, you can see that the Type C material has the largest eta value and therefore 
the longest expected life. 

FACTORIAL RELIABILITY DESIGNS: EXAMPLE 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 
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The name of the example project is "Reliability DOE - Life Time Test of Fluorescent Lights." 

In this example, two level factorial reliability DOE is used to determine the best factor settings 
to improve the reliability of fluorescent light bulbs. Five two-level factors were used in a 
fractional design to investigate the main effects of the factors and the interaction effect of the 
first two factors. It is assumed that none of the other interaction effects are significant and that 
the life of the bulb follows a lognormal distribution. 

Each treatment in the design has two replicates (i.e., two bulbs were tested at each factor level 
combination), and the experiment was conducted over 20 days with inspections every two 
days. (The failure times were short because the lights were subjected to an accelerating factor 
that stressed the lights at higher than normal conditions.) Some of the units were still not failed 
at the end of the 20-day test. 

Designing the Experiment 

The design matrix and the response data are given in the "Fluorescent Light Life Test" folio. The 
following steps describe how to create this folio on your own. 

• Choose Home > Insert > Standard Design to add a standard design folio to the current 
project. 

 

• Click Design Type in the folio's navigation panel, and then select Two Level Factorial in the 
input panel. 

 

• Specify that you will be performing reliability DOE by clicking Response 1 in the navigation 
panel and choosing Life Data from the Response Type drop-down list. Then choose Both 
Suspensions and Intervals from the Censoring drop-down list to specify that some of the 
data points will be suspensions (i.e., times at which the unit was found not failed) and all of 
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the times-to-failure data will be entered as intervals (since the units are inspected only 
once every two days). 

• Specify the number of factors by clicking the Factors heading in the navigation panel and 
choosing 5 from the Number of Factors drop-down list. 

• Define each factor by clicking it in the navigation panel and editing its properties in the 
input panel. In this example, the default labels are used for all the factors. (See Adding, 
Removing and Editing Factors.) 

• Rename the folio by clicking the Experiment1 heading in the navigation panel and entering 
Fluorescent Night Life Test for the Name in the input panel. 

• Click the Additional Settings heading to choose the number of replicates, specify the kind 
of fractional design that will be used and define the generators (i.e., aliased effects). 

• Set the number of Replicates to 2 (since there are 2 units tested for each factor level 
combination). 

• Under the Factorial Settings heading, choose 1/4: 8 runs from the Fraction drop-down 
list. This means 8 runs will be used for each replicate of the design, instead of the 32 
runs that would be required for a full factorial design. 

• Since a fractional design is being used, you must choose Design Generators for the last 
two factors. Since it is assumed that the interaction effects AC and BC are not 
significant, you choose to alias the main effect of D with the interaction effect AC, and 
the main effect of E with the interaction effect BC, as shown next. 

 

• Finally, click the Build icon on the control panel to create a Data tab that allows you to view 
the test plan and enter response data. 
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Analysis and Results 

The data set for this example is given in the "Fluorescent Light Life Test" folio of the example 
project. After you enter the data from the folio, you can perform the analysis by doing the 
following: 

Note: To minimize the effect of unknown nuisance factors, the run order is randomly generated 
when you create the design. Therefore, if you followed these steps to create your own folio, the 
order of runs on the Data tab may be different from that of the folio in the example file. This 
can lead to different results. To ensure that you get the very same results described next, show 
the Standard Order column in your folio, then click a cell in that column and choose Sheet > 
Sheet Actions > Sort > Sort Ascending. This will make the order of runs in your folio the same as 
that of the example file. Then copy the response data from the example file and paste it into 
the Data tab of your folio. 

• In the Distribution drop-down list on the Data tab control panel, select to use the 
Lognormal distribution for the analysis. 

• Make sure all main effects and the interaction effect AB will be considered. To do this, click 
the Select Terms icon on the control panel. 

 

In the window that appears, select the Main Effects and A·B check boxes. Then click OK. 

• On the Analysis Settings page of the control panel, enter a Risk Level of 0.5 and choose to 
analyze Individual Terms. 

• Return to the Main page of the control panel and click the Calculate icon. 

 

• The results in the Analysis Summary area show that second, fourth and fifth factors have a 
significant effect on the bulb's life. 
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• To see the coefficients for all the terms in the regression model, click the View Analysis 
Summary icon and view the MLE Information table. 

 

From the MLE Information table, you can see the model for the ln-mean or the scale 
parameter in the lognormal distribution is: 

μ = 2.9392 + 0.1168A - 0.2015B - 0.051C - 0.2729D + 0.1527E - 0.0488AB 

• To view a plot comparing the standardized effect of each term, click the Plot icon. 

 

Then choose Pareto Charts - Regression from the Plot Type drop-down list. The following 
plot appears. 
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The horizontal blue line in the plot marks the critical value determined by the risk level 
specified on the Analysis Settings page of the control panel. If the bar goes past the blue 
line, then the effect is considered significant. 

Conclusion 

From the regression model, we can determine that in order to improve the reliability, factors B, 
C and D should be set to their low (-1) level, indicated by their negative coefficients, while A and 
E should be set at their high (+1) level, indicated by their positive coefficients. Under this 
setting, the predicted scale parameter in the lognormal distribution is 3.7829. Therefore, the 
life distribution under this factor setting is a lognormal distribution with a standard deviation of 
0.1589 and ln-mean of 3.7829. 

To do more advanced analysis, you can enter the data into an Accelerated Life Testing folio for 
accelerated life data analysis to further investigate the life stress relationship. Since factors A 
and C are not shown to be significant, they can be removed in further analysis. 
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RESPONSE SURFACE METHOD RELIABILITY DESIGNS: EXAMPLE 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 

The name of the example project is "Reliability DOE - Optimization for a Single Response." 

In this example, two factors in a manufacturing process, curing temperature and curing time, 
have a significant effect on the life of a component. A central composite design is used to 
investigate the relationship between these factors and the life of the component. Life is defined 
as cycles-to-failure under normal use conditions. The warranty period is 1,000 cycles. 

5 units are available for testing, and the factors and levels shown next will be used. 

Factor Low Level High Level 

Temperature (degrees C) 80 100 

Time (min) 300 500 

  

A reasonable reliability should be achieved for the warranty period. If the reliability is too low, 
the warranty cost will be high. If the product is overdesigned or too reliable, then customers 
will not replace their old components, which will negatively affect sales. The target reliability is 
decided to be 0.95 and values below 0.92 or above 0.98 are considered unacceptable. The goal 
of the experiment is to find the optimal settings of temperature and time. 

Design the Experiment 

The design matrix and the response data are given in the "Central Composite R-DOE" folio. The 
following steps describe how to create this folio on your own. 

• Choose Home > Insert > Standard Design to add a standard design folio to the current 
project. 

 

• Click Design Type in the folio's navigation panel, and then select Central Composite 
Response Surface Method in the input panel. 
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• Rename the folio by clicking the Experiment1 heading in the navigation panel and entering 
Central Composite R-DOE for the Name in the input panel. 

• Specify that you will be performing reliability DOE by clicking Response 1 in the navigation 
panel and choosing Life Data from the Response Type drop-down list. Then choose 
Suspensions from the Censoring drop-down list to specify that some of the data points will 
be suspensions (i.e., times at which the unit was found not failed). Rename the response to 
Cycle to Failure. 

• Define each factor by clicking it in the navigation panel and editing its properties in the 
input panel. The first factor is shown next. 
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See Adding, Removing and Editing Factors. 

• Click the Additional Settings heading to choose the number of replicates, specify the kind 
of fractional design that will be used and define the generators (i.e., aliased effects). 

• Set the number of Replicates to 5 (since there are 5 units tested for each factor level 
combination). 

• Choose Yes from the Block on Replicates drop-down list. This specifies that each 
replicate will be assigned its own block in the design. 

• Finally, click the Build icon on the control panel to create a Data tab that allows you to view 
the test plan and enter response data. 

 

Analysis and Results - Part 1 

The data set for this example is given in the "Central Composite R-DOE" folio of the example 
project. After you enter the data from the folio, you can perform the analysis by doing the 
following: 

Note: To minimize the effect of unknown nuisance factors, the run order is randomly generated 
when you create the design. Therefore, if you followed these steps to create your own folio, the 
order of runs on the Data tab may be different from that of the folio in the example file. This 
can lead to different results. To ensure that you get the very same results described next, show 
the Standard Order column in your folio, then click a cell in that column and choose Sheet > 
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Sheet Actions > Sort > Sort Ascending. This will make the order of runs in your folio the same as 
that of the example file. Then copy the response data from the example file and paste it into 
the Data tab of your folio. 

• On the Analysis Settings page of the control panel, select to use Individual Terms in the 
analysis. 

• Return to the Main page of the control panel and click the Calculate icon. 

 

Click the View Analysis Summary icon on the control panel and select to the view the MLE 
Information table. 

 

From this table, you can see that effects A and B, as well as the quadratic effect of B (i.e., B·B), 
are significant. To simply the analysis, the next step is to recreate the model using only the 
significant terms. 

Analysis and Results - Part 2 

The results for the reduced model are given in the "Reduced Model" folio of the example 
project. The following steps describe how to create this folio on your own in order to generate 
the regression model that will be used for the optimization. 

• Right-click the design folio in the current project explorer and select Duplicate Item from 
the shortcut menu. Rename the new folio with an appropriate name. 

• Click the Select Terms icon on the new folio's control panel. 

 



Chapter 10: DOE Design Folios 

Weibull++ 2020 User's Guide 895 

 

• In the Select Terms window that appears, click the Select Significant Effects button to 
select only the significant effects to calculate the new model, as shown next, then click OK. 

 

• Click the Calculate icon in the new folio's control panel. 

• To see the details of the reduced model, view the MLE Information table. 

 

Optimization 

The optimal factor settings are available in the "Optimization" folio of the example project. 
Follow the steps outlined below to create the folio from scratch and solve for the optimal 
settings. 

• On the control panel of the "Reduced Model" standard design folio, click the Optimization 
icon. 
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• The Optimization Settings window will appear. Click the cell in the Goal column and choose 
Target from the drop-down list. Then, enter the target response value, as well as the lower 
and upper limits on the value. 

When you enter target values to optimize a life data response, the values must be entered 
in terms of ln(eta) for the Weibull distribution. From the MLE Information table, we know 
that beta = 2.0203. If you assume that beta is the same under different factor values and 
that only the scale parameter is affected by the factor values, then you can use the 
required reliability value to calculate the required eta. 

The reliability function for a Weibull distribution is: 

 

Therefore, since the target reliability is 0.95, the target eta is 4,350. Similarly, the lower 
(0.92) and upper (0.98) limits on the reliability are equivalent to eta values of 3,420 and 
6,900, respectively. 

In the software, we assume the logarithmic transform of eta is a linear function of all the 
effects. For this example, it is: 

 

So the logarithmic transform is used in the optimization. In this case the lower limit is 
8.1374, the target value is 8.3779 and the upper limit is 8.8393. After entering the values, 
the window will appear as shown next. 
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• Click OK to calculate the optimal solutions. The second solution will be shown in the plot. 
To view all the numerical solutions at once, click the View Solutions icon (  ) at the 
bottom of the control panel. Two optimal solutions will be shown. 

 

In this example, optimal solution 2 uses the shortest curing time and lowest temperature 
among both solutions. Therefore, it can be used as the final recommended factor setting. 

Free Form Folio 

The free form folio allows you to analyze data for traditional and reliability DOE by manually 
entering the factor level combinations and observed response values from a prior experiment. 
After you designate columns for factors and responses, you can then analyze the data in much 
the same way that it is analyzed on the Data tab of a design folio. You can also use this folio to 
perform predictions and optimize responses. 
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Note: In general, the free form folio is useful for analyzing existing data, rather than planning an 
experiment. To plan an experiment, use the design folio. 

To add a free form folio to your project, choose Home > Insert > Free Form, or right-click the 
DOE folder on the current project explorer and choose Add Free Form on the shortcut menu. 

 

FREE FORM FOLIO: CONTROL PANEL 

The free form folio control panel allows you to control the settings for analyzing response data 
and displays the results of the analysis. The panel includes the following pages: 

• The Main Page contains most of the tools you will need to analyze response data. 

• The Analysis Settings Page allows you to set the risk level for the analysis. 

• The Comments Page allows you to enter notes or other text that will be saved with the 
folio. 

• If you selected to analyze a life data response, the Identifiers and Publishing pages will also 
be available. These pages allow you to publish the results as a model. 

Main Page 

The Main page of the control panel includes the following tools and areas. 

Folio Tools 

The folio tools are arranged on the left side of the control panel. Use these tools to configure 
your analysis and experiment with the analysis results. Depending on the type of design you are 
working with, the control panel may contain some or all of the following tools: 

  Calculate analyzes the data for each response that is selected to be included in the 
analysis. To exclude a response from the analysis, clear the check box in its column heading. 

  Plot creates a plot based on the analysis. If you click this icon before the current data 
set has been analyzed, an analysis will be performed automatically. 

  Modify Design opens a window that allows you to specify the properties for the 
factors and responses in the analysis. 
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  Select Terms opens a window that allows you to specify the terms (i.e., factors, 
factorial interactions, blocks and quadratic effects) to be considered for each response. 

  View Analysis Summary opens a window that contains detailed information about 
analysis results. 

  Optimization adds an optimal solution plot to the Optimization folio that is linked to 
the design folio. If no linked Optimization folio exists, the software will create one. 

  Overlaid Contour Plot adds an overlaid contour plot to the Optimization folio that is 
linked to the folio. If no linked Optimization folio exists, the software will create one. 

  Select Transformation opens a window that allows you to select a transformation to 
apply to each response. 

  Prediction opens a window that allows you to enter values for each factor and see 
predicted results for the selected response. 

Settings Area 

The Main page of the control panel may also contain some or all of the following settings. 

• The Response drop-down list is used to select the response that all the displayed settings 
and analysis results will apply to. 

 

• The Distribution area is used to select a life distribution for reliability DOE. It is available 
when the selected response is configured as life data on the Data tab. 

 

• The Settings area is used to view the available analysis settings. An example is shown next. 
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In this example: 

• The partial sum of squares ("Partial SS") and grouped terms are used. 

• The specified risk level is 10%. 

• No transformation is used (i.e., the "transformed" response, Y', is equal to the non-
transformed response, Y). To configure this setting, you can click the text or the Select 
Transformation icon in the folio tools. 

• "Analyzed" is shown in green, which indicates that the current response data has been 
analyzed using the current settings. Otherwise, this would show "Modified" in red. 

• The last row indicates that the analyzed data consists of 12 observations. 

To configure the settings used in the analysis, click the blue text. These settings are also 
accessible on the Analysis Settings page of the control panel. 

Analysis Summary Area 

The Analysis Summary area is shown when the current response data has been analyzed using 
the current settings. This area displays the terms that were found to be significant, as well as 
their associated regression coefficients. 

 

Click the View Analysis Summary icon in this area to view the details of the analysis results 
(including an ANOVA table). 



Chapter 10: DOE Design Folios 

Weibull++ 2020 User's Guide 901 

 

Analysis Settings Page 

The Analysis Settings page of the free form folio control panel includes additional settings that 
may be applicable for the current analysis. It may contain some or all of the following options 
(which can also be changed on the Main page of the control panel). 

 

• The Response Settings drop-down list is used to choose the response that all the visible 
settings and analysis results will apply to. When you choose a response here, it will 
automatically be chosen when you return to the Main page. 

• The Risk Level, or alpha value, is a measure of the risk that the analysis results are incorrect 
(i.e., alpha = 1 - confidence level). 

• The next area allows you to specify the Type of Sum of Squares to use in the analysis. 
Select the Partial Sum of Squares option to test if a term is significant given that all other 
terms are considered in the model. Select the Sequential Sum of Squares option to test if 
an additional term is significant given that the terms before it are already in the model. 

• The Test Terms area specifies what the information in the ANOVA table in the free form 
folio analysis results applies to. If you select Individual Terms, the software will separately 
examine the effect of each individual predictor. If you select Grouped Terms, it will treat all 
the predictors as a single group. 

FREE FORM FOLIO: DATA TAB 

The Data tab in the free form folio includes columns that can be configured to record different 
kinds of information. To configure a column, click the arrow in the column heading and choose 
an option from the menu that appears. 
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The following kinds of information can be recorded in each column. To calculate, there must be 
at least one Factor column and at least one Response or Failure Time column. All the possible 
columns are described next. 

• Run Order columns are used to record the order in which each test run is performed. 

• Factor columns are used to record the factor levels for each factor used in the test. 

• Response columns are used to record the response values obtained during each test run. 
These columns are used for standard response data (i.e., they are not used for the purposes 
of reliability DOE). 

• Block columns are used to identify the block that each test run belongs to. 

• Point Type columns are used to identify the kind of data point that is obtained at the given 
test run. Enter 0 if the data point is a center point and 1 if it is not. 

• Failure Time columns are used for reliability DOE. This column records the test unit's exact 
failure/suspension time or, when a Last Inspected column is included, the time at which a 
unit was found to be failed/suspended since its last inspection. 

• State F or S columns are used for reliability DOE, when the times in the Failure Time column 
include suspensions. Enter F if the time is a failure and S if it is a suspension. 

• Last Inspected columns are used when the test runs include interval data for reliability 
DOE. The Last Inspected time is the beginning of the interval and the Failure Time column is 
used for the observation time. For example, if a test unit was found failed at 100 hours and 
was last inspected at 80 hours, then you'd enter 80 in the Last Inspected column and 100 in 
the Failure Time column. 



Chapter 10: DOE Design Folios 

Weibull++ 2020 User's Guide 903 

 

FREE FORM FOLIO: ANALYSIS RESULTS 

When accessed from a free form folio, the Analysis Summary window will contain detailed 
information about analysis results, including information that describes how each factor and 
factorial interaction affects the response that is currently selected on the control panel. 

If the current response data has been analyzed, you can open the window by clicking the View 
Analysis Summary icon on the control panel. 

 

If the current response data has not been analyzed, the icon will still be available so you can 
view the folio's analysis history. 

Select an item in the Available Report Items panel to display it on the spreadsheet. Each item is 
described next. 

Analysis Results 

The Analysis of Variance (ANOVA) table and the Likelihood table provide general information 
about the effects of the factors and factorial interactions on the selected response. This 
information may be presented for individual factors and interactions or for groups of factors 
and interactions, depending on your analysis setting on the control panel. 

ANOVA Table Columns 

• Source of Variation is the source that caused the difference in the observed output 
values. This can be a factor, factorial interaction, curvature, block, error, etc. If your 
design includes more than one factor and you have selected to use grouped terms in 
the analysis (specified on the Analysis Settings page of the control panel), the effects 
will be grouped by order (i.e., main effects, two-way interactions, etc.). Sources 
displayed in red are considered to be significant.  

• The number of Degrees of Freedom for the Model is the number of regression 
coefficients for the effects included in the analysis (e.g., two coefficients might be 
included in the regression table for a given main effect). The number of degrees of 
freedom for the Residual is the total number of observations minus the number of 
parameters being estimated.  

• Sum of Squares is the amount of difference in observed output values caused by this 
source of variation.  
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• Mean Squares is the average amount of difference caused by this source of variation. 
This is equal to Sum of Squares/Degrees of Freedom.  

• F Ratio is the ratio of Mean Squares of this source of variation and Mean Squares of 
pure error. A large value in this column indicates that the difference in the output 
caused by this source of variation is greater than the difference caused by noise (i.e., 
this source affects the output).  

• P Value (alpha error or type I error) is the probability that an equal amount of variation 
in the output would be observed in the case that this source does not affect the output. 
This value is compared to the risk level (alpha) that you specify on the Analysis Settings 
page of the control panel. If the p value is less than alpha, this source of variation is 
considered to have a significant effect on the output. In this case, the term and its p 
value will be displayed in red.  

• The following values are shown underneath the ANOVA table, and they indicate how 
well the model fits the data:  

• S is the standard error of the noise. It represents the magnitude of the response 
variation that is caused by noise. Lower values indicate better fit. 

• R-sq is the percentage of total difference that is attributable to the factors under 
consideration. It is equal to Sum of Squares(factor)/Total Sum of Squares. Higher 
values usually indicate better fit. 

• R-sq(adj) is an R-sq value that is adjusted for the number of parameters in the 
model. Higher values indicate better fit. 

• PRESS is the prediction error sum of squares, which provides a measure of the 
model’s validity. The lower the PRESS value, the better the model’s predictive 
ability. 

• R-sq(pred) is a measure of how well the model predicts new observations. It is 
equal to 1-PRESS/Total Sum of Squares. The larger the value, the more accurate the 
model’s predictions are likely to be. 

Likelihood Table Columns (for reliability DOE) 

• Model displays the model for which the results apply. 

• Reduced assumes that the product life is the same at different levels of the factor. 

• Full assumes that the product life is different at different levels of the factor. 
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• Degrees of Freedom is the degrees of freedom of this source of variation. This is also 
the number of parameters in the model for this source. 

• Ln(Likelihood Value) is the logarithm transformation of the likelihood value for this 
source of variation. 

• Likelihood Ratio is the likelihood ratio value for this source of variation. 

• P Value is the probability that LR is from a chi-squared distribution, which would 
indicate that the factor has no effect on product life. This value is compared to the risk 
level (alpha) that you specify on the Analysis Settings page of the control panel. If the p 
value is less than alpha, then the factor is considered to have a significant effect on 
product life. In this case, the effect and its p value will be displayed in red. 

The Regression table and the MLE Information table provide specific information on the 
contribution of each predictor to the variation in the response and an analysis of the 
significance of this contribution. 

Regression Table Columns 

• Term is the factor, factorial interaction, curvature, block, etc. under consideration. 
Terms displayed in red are considered to be significant. In cases where there is no error 
in the model, significant effects are determined according to Lenth’s method and the 
term names are displayed in red and followed by an asterisk (*). 

• Coefficient is the regression coefficient of the term, which represents the contribution 
of the term to the variation in the response. 

• Standard Error is the standard deviation of the regression coefficient. 

• Low Confidence and High Confidence are the lower and upper confidence bounds on 
the regression coefficient. 

• T Value is the normalized regression coefficient, which is equal to Coefficient/Standard 
Error. 

• P Value (alpha error or type I error) is the probability that an equal amount of variation 
in the output would be observed in the case that this term does not affect the output. 
This value is compared to the risk level (alpha) that you specify on the Anaysis Settings 
page of the control panel. If the p value is less than alpha, this source of variation is 
considered to have a significant effect on the output. In this case, the term and its p 
value will be displayed in red. 

MLE Information Table Columns (for reliability DOE) 
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• Term is the factor, factorial interaction, etc. under consideration. Terms displayed in 
red are considered to be significant. 

• Effect is a measure of how much the response value (Y) changes when the value of the 
corresponding term in the model (using coded values) changes from -1 to 1. 

• Coefficient is the regression coefficient of the term, which represents the contribution 
of the term to the variation in the response. 

• Standard Error is the standard deviation of the regression coefficient. 

• Low Confidence is the lower confidence bound of the regression coefficient, using 
Fisher bounds. 

• High Confidence is the upper confidence bound of the regression coefficient, using 
Fisher bounds. 

• Z Value is the normalized regression coefficient, which is equal to Coefficient/Standard 
Error. 

• P Value is the probability that an equal amount of variation in the output would be 
observed in the case that this source does not affect the output. This value is compared 
to the risk level (alpha) that you specify on the Analysis Settings page of the control 
panel. If the p value is less than alpha, this source of variation is considered to have a 
significant effect on the output. In this case, the term and its p value will be displayed in 
red. 

The Regression Equation information is presented using multiple tables.  

Regression Equation 

• The Response table displays the response that the regression equation applies to and 
the units of measurement that were entered for the response (if any). 

• The Additional Settings table shows the transformation and risk level you entered for 
the response. 

• The Significant Terms table is applicable only when at least one term was found to be 
significant. It shows the significant terms in the Name column and the associated 
regression coefficients in the Coefficient column. 

• The Equation tables show the regression coefficients for the model of the selected 
response. For example, consider this table: 
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The corresponding model for this table is y = 9.3903 - 0.8467x1 + 1.2813x2 + 0.7303x1x2. 

• The first Equation table shows the coefficients for a model that uses coded values 
for the factors. 

• The second Equation table shows the coefficients for a model that uses the actual 
factor values. 

Additional Results 

All of the following tables provide information that was generated from the main calculations. 
The available tables will vary depending on the design type you are working with. The results 
that could be available include: 

Alias Structure 

This item is available for all designs with at least two factors. It describes the alias structure 
for the design, taking into account only the terms you've selected to include in the analysis. 
Together with your engineering knowledge, you can use this information to help determine 
whether any important interaction information was lost due to aliasing. When aliased 
terms exist, the following areas will be shown: 

• Terms selected to be in the model lists all the terms that are considered for inclusion in 
the regression model (i.e., the selections in the Select Terms window). 

• Terms included in the model lists all the selected terms that are included in the model. 
The alias structure determines which terms are excluded. 

• Alias Structure lists the aliased effects based on the selected terms. For example, A • B 
= A • B + C • D means the interaction effect A • B is aliased because it is 
indistinguishable from effect C • D. Therefore, the model cannot include both 
interaction terms; it will include only one (e.g., A • B). 

Alias Summary 

The terms in the first column of this table are aliased with the terms shown in the second 
column. Only the terms in the first column are included in the model. 
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Var/Cov Matrix 

This shows the variance/covariance matrix, which is available for one factor R-DOE designs 
and all other designs with two or more factors. The diagonal elements in this matrix are 
used to calculate the coefficients in the MLE or Regression Information table. 

Diagnostic Information 

This table is available for one factor R-DOE designs and all other designs with two or more 
factors. It displays various analysis results for each run and highlights significant values. The 
following columns are included: 

• Run Order is the randomized order, generated by the software, in which it is 
recommended to perform the runs to avoid biased results. Note that any changes 
made to the Run Order column on the Data tab will be reflected here. 

• Standard Order is the basic order of runs, as specified in the design type, without 
randomization. Note that any changes made to the Standard Order column on the Data 
tab will be reflected here. 

• Actual Value (Y) is the observed response value for the run, as entered in the response 
column on the Data tab. 

• Predicted Value (YF) is the response value predicted by the model given the factor 
settings used in the run. 

• Residual (or "regular residual") is the difference between the actual value (Y) and the 
predicted value (YF) for the run. 

• Standardized Residual is the regular residual for the run divided by the constant 
standard deviation across all runs. 

• Studentized Residual is the regular residual for the run divided by an estimate of its 
standard deviation. 

• External Studentized Residual is the regular residual for the run divided by an estimate 
of its standard deviation, where the run in question is omitted from the estimation. 

• Leverage is a measure of how much the run influences the predicted values of the 
model, stated as a value between 0 and 1, where 1 indicates that the actual response 
value of the run is exactly equal to the predicted value (i.e. the predicted value is 
completely dependent upon the observed value). 



Chapter 10: DOE Design Folios 

Weibull++ 2020 User's Guide 909 

 

• Cook’s Distance is a measure of how much the output is predicted to change if the run 
is deleted from the analysis. 

Values that are considered to be significant, or outliers, are displayed in red. For the 
residual columns, significant or critical values are those that fall outside the residual’s upper 
or lower bounds, calculated based on the specified alpha (risk) value.  

The ReliaWiki resource portal has more information on how significant values are 
determined for the Leverage and Cook's Distance columns at: 
http://www.reliawiki.org/index.php/Multiple_Linear_Regression_Analysis. 

Least Squares Means 

This table shows the predicted response values for the given factor levels. It includes the 
following columns: 

• Effect is the main effect or interaction used to predict the response. The coefficients for 
effects not used in the prediction are set to zero. 

• Level is the combination of factor levels used to predict the response. 

• Mean is the predicted response value. 

FREE FORM FOLIO: PLOTS 

The following plots may be available for free form folios, depending on the type of data you 
analyzed. For general information on working with plots, see Plot Utilities. 

Effect Plots 

Effect plots allow you to visually evaluate the effects of factors and factorial interactions on the 
selected response. 

• The Pareto Chart - Regression plot shows the standardized effects of the selected terms 
(i.e., factor or combination of factors). The vertical blue line is the threshold value. If a bar 
is beyond the blue line, it will be red, indicating that the effect is significant. 

• The Pareto Chart - ANOVA* plot shows the inverse p value (1 - p) of each selected term. 
The vertical blue line is the threshold value. If a bar is beyond the blue line, it will be red, 
indicating that the term is significant. 

• The Pareto Chart - LRT shows the inverse p value for the reduced model in the likelihood 
table. The vertical blue line is the threshold value. If the bar is beyond the blue line, it will 
be red, indicating that the factor has a significant effect on reliability. 

http://www.reliawiki.org/index.php/Multiple_Linear_Regression_Analysis
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• The Effect Probability plot is a linear representation of probability versus the standardized 
effect (i.e., the probability that any term’s standardized effect will be lower than the given 
value). The points on this plot represent the values for each term in the T Value column of 
the Regression Table in the detailed analysis results. If there is no error in the design, then 
the probability versus the effect is shown and the points on this plot represent the values 
for each term in the Effect column of the Regression Table in the analysis results.  

• Select Normal in the Scale Type area to display the negative and positive values of the 
effects (coefficients). The negative effects will appear to the left of the probability line. 

• Select Half-normal to display the absolute values of all the effects, which allows you to 
compare the size of each effect. All the effects will appear to the right of the probability 
line. 

• The Main Effects plot shows the mean effect of the selected factor(s). The points are the 
observed Y values at the low and high level for each factor. The line connects the mean 
value at each factor level, and you can specify how the means are calculated in the 
Calculation Options area. Note that if you are using actual factor values in the plot, you can 
plot only one factor at a time. If you are using coded values, you can plot multiple factors 
simultaneously. For mixture designs, this plot applies only to process factors (i.e., process 
variables). 

• The Interactions plot shows the mean effect of a selected factor versus another selected 
factor at each level. If the green and red mean effect lines are parallel, there is no 
interaction between the two factors. You can specify how the means are calculated in the 
Calculation Options area. For mixture designs, this plot applies only to process factors (i.e., 
process variables). 

• The Interaction Matrix shows multiple Interactions plots. The plots shown depends on the 
factors you select. For example, if you select factors A and B, then two interactions plots 
will be shown: one showing A versus B and another showing B versus A. 

• The Term Effect Plot shows the fitted means for all combinations of all factor levels for 
each selected term. You can specify how the means are calculated in the Calculation 
Options area. 

• The Cube Plot shows the mean values of the selected response for the combinations of the 
low and high levels of three selected factors. You can specify how the means are calculated 
in the Calculation Options area. Note that you have the option of selecting "none" for the 
third factor, generating a square (2-dimensional) plot. Only two level factors can be 
included in the Cube plot, and at least two quantitative factors (each run at two levels) 
must be included in the model for the Cube plot to be available. 
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• The Scatter Plot shows the observed values of the currently selected response plotted 
against the levels of the selected factor. A 3-dimensional version of this plot is available in 
the 3D plot folio. 

• The Contour Plot shows how varying two selected factors affects the predicted response 
values, which are represented as colors. See Contour Plots. A 3-dimensional version of this 
plot ("Surface Plot") is available in the 3D plot folio. For mixture designs, this plot applies 
only to process factors (i.e., process variables). 

Residual Plots 

Residuals are the differences between the observed response values and the response values 
predicted by the model at each combination of factor values. Residual plots help to determine 
the validity of the model for the currently selected response. When applicable, a residual plot 
allows the user to select the type of residual to be used: 

• Regular Residual is the difference between the observed Y and the predicted Y. 

• Standardized Residual is the regular residual divided by the constant standard deviation. 

• Studentized Residual is the regular residual divided by an estimate of its standard 
deviation. 

• External Studentized Residual is the regular residual divided by an estimate of its standard 
deviation, where the observation in question is omitted from the estimation. 

The plots are described next. 

• The Residual Probability* plot is the normal probability plot of the residuals. If all points fall 
on the line, the model fits the data well (i.e., the residuals follow a normal distribution). 
Some scatter is to be expected, but noticeable patterns may indicate that a transformation 
should be used for further analysis. Two additional measures of how well the normal 
distribution fits the data are provided by default in the lower title of this plot. Smaller 
values for the Anderson-Darling test indicate a better fit. Smaller p values indicate a worse 
fit. 

• The Residual vs. Fitted* plot shows the residuals plotted against the fitted, or predicted, 
values of the selected response. If the points are randomly distributed around the "0" line 
in the plot, the model fits the data well. If a pattern or trend is apparent, it can mean either 
that the model does not provide a good fit or that Y is not normally distributed, in which 
case a transformation should be used for further analysis. Points outside the critical value 
lines, which are calculated based on the specified alpha (risk) value, may be outliers and 
should be examined to determine the cause of their variation. 
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• The Residual vs. Order* plot shows the residuals plotted against the order of runs used in 
the design. If the points are randomly distributed in the plot, it means that the test 
sequence of the experiment has no effect. If a pattern or trend is apparent, this indicates 
that a time-related variable may be affecting the experiment and should be addressed by 
randomization and/or blocking. Points outside the critical value lines, which are calculated 
based on the specified alpha (risk) value, may be outliers and should be examined to 
determine the cause of their variation. 

• The Residual vs. Factor* plot shows the residuals plotted against values of the factor 
selected in the Residual Factor area. It is used to determine whether the residuals are 
equally distributed around the "0" value line and whether the spread and pattern of the 
points are the same at different levels. If the size of the residuals changes as a function of 
the factor’s settings (i.e., the plot displays a noticeable curvature), the model does not 
appropriately account for the contribution of the selected factor. Points outside the critical 
value lines, which are calculated based on the specified alpha (risk) value, may be outliers 
and should be examined to determine the cause of their variation. 

• The Residual Histogram* is used to demonstrate whether the residual is normally 
distributed by dividing the residuals into equally spaced groups and plotting the frequency 
of the groups. The Residual Histogram Settings area allows you to: 

• Select Custom Bins to specify the number of groups, or bins, into which the residuals 
will be divided. Otherwise, the software will automatically select a default number of 
bins based on the number of observations. 

• Select Superimpose pdf to display the probability density function line on top of the 
bins. 

• The Residual Autocorrelation* plot shows a measure of the correlation between the 
residual values for the series of runs (sorted by run order) and one or more lagged versions 
of the series of runs. The default number of lags is the number of observations, n, divided 
by 4. If you select Custom Lags in the Auto-Correlation Options area, you can specify up to 
n -1 lags. The correlation is calculated as follows: 

 

where: 

• k is the lag. 
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• is the mean value of the original series of runs. 

For example, lag 1 shows the autocorrelation of the residuals when run 1 is compared with 
run 2, run 2 is compared with run 3 and so on. Lag 3 shows the autocorrelation of the 
residuals when run 1 is compared with run 4, run 2 is compared with run 5 and so on. Any 
lag that is displayed in red is considered to be significant; in other words, there is a 
correlation within the data set at that lag. This could be caused by a factor that is not 
included in the model or design, and may warrant further investigation. 

•  The Fitted vs. Actual plot shows the fitted, or predicted, values of the currently selected 
response plotted against the observed values of the response. If the model fits the data well, 
the points will cluster around the line. 

Diagnostic Plots 

• The Leverage vs. Order plot shows leverage plotted against the order of runs used in the 
design. Leverage is a measure (between 0 and 1) of how much a given run influences the 
predicted values of the model, where 1 indicates that the actual response value of the run 
is exactly equal to the predicted value (i.e. the predicted value is completely dependent 
upon the observed value). Points that differ greatly from the rest of the runs are considered 
outliers and may distort the analysis. 

• The Cook’s Distance* plot can show Cook’s distance (i.e., a measure of how much the 
output is predicted to change if each run is deleted from the analysis) plotted against either 
the run order or the standard order for the currently selected response. Points that differ 
greatly from the rest of the runs are considered outliers and may distort the analysis. 

• The Box-Cox Transformation* plot can help determine, for the currently selected response 
and model, what transformation, if any, should be applied. The plot shows the sum of 
squares of the residuals plotted against lambda. The value of lambda at the minimum point 
of this curve is considered the "best value" of lambda, and indicates the appropriate 
transformation, which is also noted by default in the lower title of the plot. 

* These plots are available only when there is error in the design, indicated by a positive value 
for sum of squares for Residual in the ANOVA table of the analysis results. 

FREE FORM FOLIO: EXAMPLE 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 

The name of the example project is "Free Form Folio - Optimization." 
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A chemical engineering experiment involving heat transfer was performed several weeks ago. 
There were some difficulties during the experiment (the factor values were difficult to control 
because of the testing equipment), and some of the test runs had to be discarded. While the 
testing facility will not be used for future experiments, the engineers would still like to analyze 
the old data and find the possible optimal values for each factor. They could then use the 
optimal values as a starting point for future experiments. The factors are: 

• Fluidizing gas flow rate (lb/hr) 

• Supernatant gas flow rate (lb/hr) 

• Nozzle opening (mm) 

• Gas temperature (F) 

There are two responses: heat transfer efficiency and thermal efficiency. The objective of the 
analysis is to maximize both responses. 

Data Entry 

The data set (without the discarded test runs) is shown in the "Historical Data" free form folio. 
Each column of data was defined as a factor or response column by clicking the arrow in the 
column heading. 

 

The factors and responses were then defined (e.g., the engineers named the factors/responses 
and specified that all the factors are quantitative) by clicking the Modify Design icon on the 
control panel. 
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Analysis and Results 

For terms to be included in the analysis of the heat transfer efficiency response were selected 
by clicking the Select Terms icon. 

 

The Heat Transfer Efficiency was chosen from the drop-down list at the top of the window, and 
the following terms were selected. 

 

For the second response, the main effects of factors A, B and D were selected; the interaction 
effects AB and BD were selected; and the quadratic effects AA and DD were selected. Click the 
Calculate icon to analyze both responses. 

 

The regression table for heat transfer efficiency is shown next: 
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Next is the regression table for thermal efficiency: 

 

Now that models have been created for both responses, you can use the optimization folio to 
investigate how different factor level combinations affect the response values. (See 
Optimization Example.) 

Optimization Folio 

The optimization folio provides three tools that allow you to examine factor level combinations 
and evaluate how well they meet your response goal(s). These tools can be accessed by 
choosing Home > Insert > Optimization. 

 

The Select Optimization Tool window will appear. In this window, you will select a folio to 
optimize and then select one of the following: 

• The optimal solution plot helps you determine the factor level combination that will 
produce the user-specified optimum value for one or more responses. This plot is available 
for all designs with at least two factors. 

• The overlaid contour plot displays all of the factor level combinations for two quantitative 
factors that will produce response values that fall within the user-specified goal. This plot is 
available for all designs with at least two quantitative factors. 

• The dynamic overlaid contour plot displays a series of overlaid contour plots side by side. 
The x- and y-axes represent two of the quantitative factors. The level of one or more 
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additional factors is varied across the plots. This plot is available for all designs with at least 
three factors, where at least two of the factors are quantitative. 

Note that each optimization folio can have only one optimization tool of each type. 

OPTIMAL SOLUTION PLOT 

The optimal solution plot provides a graphical analysis of the factor settings that will produce 
the user-specified optimum value for one or more responses. This plot is available for all 
designs with at least two factors. 

Creating the Optimal Solution Plot 

There are three different ways to create an optimal solution plot: 

• On the Home tab, click the Optimization icon in the Insert gallery. 

 

In the Select Optimization Tool window that appears, select a folio to optimize and then 
select to create an optimal solution plot. 

• You can create an optimal solution plot directly from a calculated design folio by clicking 
the Optimization icon on the control panel. An optimization folio containing an optimal 
solution plot for the folio will be added to the DOE folder in the current project explorer. If 
there is an optimization folio already associated with the design folio, clicking the 
Optimization icon on the control panel for the design folio will add the optimal solution 
plot as a sheet within that folio. 

• Open an existing optimization folio and add additional optimization tools based on the 
same design folio by choosing Optimization > Tools > Add Optimization Tool. 

Note that each optimization folio can have only one optimization tool of each type. 

When you first create an optimal solution plot, you will need to specify the settings that the 
plot is based on. The Optimization Settings window will appear automatically. The navigation 
panel on the left of this window lists all of the settings pages. 

• The pages listed under the Responses heading allow you to select which response(s) you 
want to optimize, and to specify the optimal settings for each response. The settings on 
these pages are required in order to create the plot. 

Click each response in the navigation panel and use the Include in optimization drop-down 
list to specify whether the response will be optimized. Note that if a response is missing all 
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data at a given level for a qualitative factor or a block (which is essentially a type of 
qualitative factor), that level cannot be included in the optimization of the response. 
Therefore, any optimal solutions found will not use factor levels that do not have data for 
all selected responses. 

The options under the Goal Settings heading allow you to specify whether you want to 
minimize the response, maximize it or bring it as close as possible to a particular target 
value. You will then specify a target value for the response, as well as a lower limit and/or 
an upper limit, depending on the type of goal. These settings affect the desirability rankings 
of the solutions as follows: 

• Target 

• Lower Limit: Responses below this value will not be considered desirable at all. 

• Target: The closer to this value the response is, the more desirable it is. 

• Upper Limit: Responses above this value will not be considered desirable at all. 

• Minimize 

• Target: Responses below this value will be considered 100% desirable. 

• Upper Limit: Responses above this value will not be considered desirable at all. 

• Maximize 

• Lower Limit: Responses below this value will not be considered desirable at all. 

• Target: Responses above this value will be considered 100% desirable. 

Note that if a transformation has been applied to any response that you are optimizing, the 
transformed response values are used in optimization. For this reason, the values that you 
enter for Lower Limit, Target and/or Upper Limit must also be transformed values. For 
example, life data responses always have the lognormal transformation applied; therefore, 
if you are maximizing a life data response, the Lower Limit and Target values should be in 
terms of Ln(failure time). 

If you are including more than one response in the optimization, the Desirability fields will 
be available. These are used in determining how desirable each optimal solution is. 

• Use the Weight field to specify how much the target influences the local desirability of 
solutions (i.e., how well each solution optimizes that particular response).   
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• Use the Importance field to specify, on a scale of 0.1 to 10, how much the local 
desirability of the solution for a given response influences the global desirability of the 
solution (i.e., how well each solution meets the optimization requirements for all 
selected responses). This is a way of specifying which response(s) it is most important 
to optimize (e.g., if one solution does a better job of optimizing Response 1 and 
another solution does a better job of optimizing Response 2, your inputs in this column 
will determine which is the more desirable solution). 

Inputs for the Weight and Importance are on a scale from 0.1 to 10, where 0.1 is least 
important and 10 is most important. In other words, if you specify a Weight value of 0.1, 
response values that are relatively far from the target could still be highly desirable, 
whereas if you specify a Weight value of 10, only response values extremely close to the 
target would be highly desirable. 

• The pages listed under the Factors heading allow you to select which factors will be varied 
in the optimization, and to specify boundaries or constraints on any quantitative factors to 
be used in the optimization process, thereby excluding solutions that call for factor settings 
outside the range(s) you specify. The factor values are expressed in terms of actual or 
coded values. To change the setting, close the Optimization Settings window and choose 
Plot > Display > [Value Type]. 

Click each factor in the navigation panel and use the Treatment in Plot drop-down list to 
specify whether the factor's value will be varied or held constant during the optimization. 

Then use the Lower Limit and Upper Limit fields to specify the bounds for each quantitative 
factor. 

• The pages listed under the Algorithm heading allow you to specify how the optimization 
calculations are performed. 

The General Settings page includes the following settings. 

• Design Runs specifies the number of runs in the design that will be checked for optimal 
solutions. 

• Random Runs specifies the number of random start points that will be analyzed. 

• Epsilon is the convergence criterion that controls how long the software attempts to 
find optimal solutions. This is for informational purposes and cannot be changed. 

• Fractions determines the width of the range from each start point that will be checked 
for optimal solutions. This is for informational purposes and cannot be changed. 
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• Use Seed allows the user to specify a start point for the random number generation 
used in the optimization process, providing repeatability of results. 

The Initial Guess page allows you to enter your own estimates of the value for each factor 
as a starting point for the optimization process. If you do not specify a starting point, 
random values between the limits specified under the factor settings will be used or, in the 
case of qualitative factors, every level specified for the qualitative factor is tried for each of 
the random values of the other factor(s) tried. 

To enter a starting point, choose Yes from the Use Initial Guess drop-down list, then enter 
a value for each factor. For quantitative factors, this will be a numeric value. For qualitative 
factors and blocks, click inside the field and select the desired option from the drop-down 
list. If you are supplying initial guesses, you must specify a value for each row. 

Note: If optimization does not yield any solutions with a desirability (either global or local) 
greater than zero, a plot displaying the initial guess value for each factor will be displayed. 
This not an optimal solution; rather, it is intended to be used as a starting point for manual 
editing. 

• The Summary page allows you to review all your optimization settings. 

Once you have specified and reviewed the settings, click OK. The software will compute up to 
five optimal solutions (i.e., the combinations of factor settings that will produce the most 
desirable response values, based on your specifications in the Optimization Settings window) 
and will create a plot of the first optimal solution. Other solutions will be displayed in the 
Solutions area of the control panel; click a solution to view its plot. Note that the order in which 
the solutions are displayed is random and does not indicate their desirability. 

Note: You can specify new settings and re-compute the optimal solutions at any time by clicking 

the Calculate icon (  ) to re-open the Optimization Settings window. You can also change the 

folio that the optimal solution plot is based on by clicking the Select Data Source icon (  ). 

Viewing an Optimal Solution Plot 

In the plot of a solution, each response selected for inclusion is presented in a separate row and 
each factor selected for inclusion is presented in a separate column. In addition, a column can 
be displayed for blocks. By default, the response value is marked with a blue dashed line and 
the factor settings that yield that response value are marked with red dashed lines. For 
example, in the plot shown next, the response is being maximized, with a target value of 4.5 or 
greater. Three factors are included in the optimization. In this solution, the actual response 
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value of 4.826 is achieved by setting factor A (a qualitative factor) to "copper," factor C (a 
quantitative factor) to 36.000 and factor E (a qualitative factor) to "new." 

 

As you can see, possible settings for qualitative factors (and blocks) are displayed as points, 
while possible settings for quantitative factors are displayed as lines. To change the responses 
and/or factors that are shown in the plot, click the Select Responses & Factors icon. 

 

In addition, you can choose to display the feasible region for the factor settings (i.e., the region 
between the limits specified in the Optimization Settings window) by selecting the Display 
Feasible Region check box on the control panel. In the plot shown here, the feasible region is 
indicated by green shading, where reduced desirability is indicated by lighter shading. 
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Working with Solutions 

You can create your own custom solutions by clicking the Create Solution icon (  ) in the 
Solutions area on the control panel. In the window that appears, enter a name for the solution 
and specify the factor values to be used for the solution. Your new solution will be added to the 
solutions list. 

Custom solutions can be edited by selecting the solution in the list and clicking the Edit Solution 
icon (  ) or by dragging the factor lines directly on the plot. Note that if you edit an optimal 
solution generated by the software, your changes will be used to create a new custom solution 
and the original solution will remain unchanged. You can also duplicate a solution by selecting 
the solution and clicking the Duplicate Solution icon (  ). 

To remove a solution from the solutions list, select the solution and click the Delete Solution 
icon (  ). This cannot be undone. 

You can view all of the optimal and custom solutions in a numeric format by clicking the View 
Solutions icon (  ). The Solutions window shows each solution, including factor settings, the 
associated block (if any) and the predicted response(s) at those settings. The response 
desirability columns rate the desirability of each solution from the perspective of optimizing 
each response. If more than one solution has been optimized, the global desirability column 
rates the overall desirability of each solution (i.e., how well its relative optimization of each 
response meets the requirements specified by the Weight and Importance settings on the 
Response Settings tab of the Optimization Settings window). 

The Transfer Solution to Overlaid icon (  ) creates an overlaid contour plot using the factor 
values in the currently selected solution. 

OVERLAID CONTOUR PLOT 

The overlaid contour plot displays all of the factor level combinations for two quantitative 
factors that will produce response values that fall within the user-specified goal. This plot is 
available for all designs with at least two quantitative factors. 

Creating the Overlaid Contour Plot 

There are three different ways to create an overlaid contour plot: 

• On the Home tab, click the Optimization icon in the Insert gallery. 
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In the Select Optimization Tool window that appears, select a folio to optimize and then 
select to create an overlaid contour plot. 

• You can create an overlaid contour plot directly from a calculated design folio by clicking 
the Overlaid Contour Plot icon on the control panel. 

 

An optimization folio containing an overlaid contour plot for the folio will be added to the 
DOE folder in the current project explorer. If there is an optimization folio already 
associated with the design folio, clicking the Overlaid Contour Plot icon on the control 
panel for the design folio will add the overlaid contour plot as a sheet within that folio. 

• Open an existing optimization folio and add additional optimization tools based on the 
same design folio by choosing Optimization > Tools > Add Optimization Tool. 

Note that each optimization folio can have only one optimization tool of each type. 

When you first create an overlaid contour plot, you will need to specify the settings that the 
plot is based on. The Overlaid Contour Plot Settings window will appear automatically. Click 
each response under the Responses heading and use the Include in optimization drop-down to 
specify whether the response will be optimized. 

Then use the Goal field to specify whether you want to minimize the response, maximize it or 
get it within a range of values. You will then specify a lower limit and/or an upper limit for the 
response, depending on which action you have selected. 

Note that if a transformation has been applied to any response that you are optimizing, the 
transformed response values are used in optimization. For this reason, the values that you 
enter for Lower Limit and/or Upper Limit must also be transformed values. For example, life 
data responses always have the lognormal transformation applied; therefore, if you are 
maximizing a life data response, the Lower Limit value should be in terms of Ln(failure time). 

Once you have specified the settings, click OK. The overlaid contour plot will be created. 

Note: You can specify new settings at any time by clicking the Calculate icon (  ) to re-open 
the Overlaid Contour Plot Settings window. You can also change the folio that the overlaid 

contour plot is based on by clicking the Select Data Source icon (  ). 
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Viewing the Overlaid Contour Plot 

For each response that is included in the plot, a shaded region shows the combinations of 
factor settings that result in the response values that you specified in the Overlaid Contour Plot 
Settings window. For example, consider the settings and plot shown next. 
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In the plot, the area shown in blue represents all of the combinations of factor settings for the 
time and temperature factors that will cause the yield to be greater than 70. The areas shown 
in purple represent the factor setting combinations that will result in a viscosity between 62 
and 68. The area in beige represents the factor setting combinations that will give a weight of 
less than 3,400. Where all three of these areas overlap (i.e., the areas shown in green), the 
factor settings will give desirable values for all three results. 

You can specify which factor is shown on each axis using the drop-down lists in the Factors area 
on the control panel. 

The overlaid contour plot looks at the interaction between two factors. If there are more than 
two factors used in the experiment, the factors that are not shown on the plot axes will be held 
at a constant value. In the Factor Values area on the control panel, you can choose to use least 
squares means to determine the value used for each factor or to specify your own custom 
values. If you select Use Custom Values, then click Set to open the Set Custom Factor Values 
window and specify the custom values that you want to use. Note that these values will be used 
only when the factors are not shown on the plot axes. Note that if a response is missing all data 
at a given level for a qualitative factor or a block (which is essentially a type of qualitative 
factor), that level cannot be included in the optimization of the response. Therefore, any level 
you specify that does not have data for a given response will instead be treated as equal to 0 in 
the optimization of that response. 

DYNAMIC OVERLAID CONTOUR PLOT 

The dynamic overlaid contour plot displays a series of overlaid contour plots side by side. The x- 
and y-axes represent two of the quantitative factors. The level of one or more additional factors 
is varied across the plots. This plot is available for all designs with at least three factors, where 
at least two of the factors are quantitative. 

Creating the Dynamic Overlaid Contour Plot 

There are two ways to create a dynamic overlaid contour plot: 

• On the Home tab, click the Optimization icon in the Insert gallery. 

 

In the Select Optimization Tool window that appears, select a folio to optimize and then 
select to create a dynamic overlaid contour plot. 

• Open an existing optimization folio and add additional optimization tools based on the 
same design folio by choosing Optimization > Tools > Add Optimization Tool. 
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Note that each optimization folio can have only one optimization tool of each type. 

When you first create a dynamic overlaid contour plot, you will need to specify the settings that 
the plot is based on. The Dynamic Overlaid Contour Plot Settings window will appear 
automatically. The navigation panel on the left of this windows lists all of the settings pages. 

• The pages listed under the Responses heading allow you to select which response(s) you 
want to optimize, and to specify the optimal settings for each response. 

Click each response under the Responses heading and use the Include in optimization 
drop-down to specify whether the response will be optimized. 

Then use the Goal field to specify whether you want to minimize the response, maximize it 
or get it within a range of values. You will then specify a lower limit and/or an upper limit 
for the response, depending on which action you have selected. 

Note that if a transformation has been applied to any response that you are optimizing, the 
transformed response values are used in optimization. For this reason, the values that you 
enter for Lower Limit and/or Upper Limit must also be transformed values. For example, life 
data responses always have the lognormal transformation applied; therefore, if you are 
maximizing a life data response, the Lower Limit value should be in terms of Ln(failure 
time). 

• The pages listed under the Factor heading allows you to specify which factors will be shown 
on the x- and y-axes and whether to vary or hold constant each factor not shown on the 
axes, as well as the value ranges to use for the factors. The factor values are expressed in 
terms of actual or coded values. To change the setting, close the Optimization Settings 
window and choose Plot > Display > [Value Type]. 

Click each factor and use the Treatment in Plot field to specify how it should be used in the 
plot. You should set one quantitative factor to be displayed on the x-axis and another 
quantitative factor to be displayed on the y-axis. The remaining factors may each be either 
held constant or varied.    

For factors displayed on the axes, use the Lower Limit and Upper Limit fields to specify the 
bounds for each factor. 

For factors that are held constant, specify the setting used for the factor in the Constant 
Value field. If the factor is qualitative, a drop-down list of the available factor settings will 
be provided. 

For quantitative factors that are varied, use the Lower Limit and Upper Limit fields to 
specify the bounds for each factor. Then enter the number of different settings within that 
range to use for the factor in the Number of Intervals field. Qualitative factors will be 
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varied across all possible settings. Note that if a response is missing all data at a given level 
for a qualitative factor or a block (which is essentially a type of qualitative factor), that level 
cannot be included in the optimization of the response. Therefore, any level that does not 
have data for a given response will instead be treated as equal to 0 in the optimization of 
that response. 

The settings that you specify for the factors that are varied determine the number of 
possible solutions (i.e., plots) that will be generated and evaluated to determine if they 
contain a feasible region. 

• The Summary page allows you to review all your optimization settings. 

Once you have specified and reviewed the settings, click OK. The dynamic overlaid contour plot 
will be created. As the range of solutions are examined, the plots for the solutions are 
displayed. Once all solutions have been considered, the first overlaid contour plot is displayed. 
Additional solutions will be displayed in the Sorted Solutions area on the control panel. 

Note: You can specify new settings at any time by clicking the Calculate icon (  ) to re-open 
the Dynamic Overlaid Contour Plot Settings window. You can also change the folio that the 

dynamic overlaid contour plot is based on by clicking the Select Data Source icon (  ). 

Viewing the Dynamic Overlaid Contour Plot 

When the dynamic overlaid contour plot is created, all of the factor setting combinations that 
are possible based on your settings in the Dynamic Overlaid Contour Plot Settings window are 
generated and examined to determine whether they contain a feasible region (i.e., a region 
where response values fall within the specified range). All factor setting combinations that 
contain a feasible region are listed in the Sorted Solutions area on the control panel. You can 
select multiple solutions to be displayed side by side; up to 99 overlaid contour plots can be 
displayed simultaneously. 

To facilitate finding and displaying solutions of interest to you, the order in which the solutions 
are sorted can be changed. Click the drop-down in the Solutions area to view a list of the 
factors that are either varied or held constant. Use the Priority Up and Priority Down arrows 
that appear when you click a priority number in the first column to move the factors up and 
down the list. In the example shown next, the solutions are being sorted first by the Nozzle 
Opening factor setting, then by the Gas Temperature factor setting. 
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This results in the following sorted list, where solutions are sorted by Gas Temperature within 
Nozzle Opening settings: 

 

You can then select or clear entire groups of solutions for display. 

OPTIMIZATION EXAMPLE 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 

The name of the example project is "Free Form Folio - Optimization." 
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In a previous example, data from a chemical engineering experiment was analyzed using the 
free form folio, with the goal of maximizing both response values. The results of the analysis are 
given in the "Historical Data" folio. 

The next step is to find the best factor level combination using the models created in the free 
form folio. The "Optimal Solution Plot" in the example project provides a graphical analysis of 
the factor settings that will produce optimum values for the responses. 

Click the Calculate icon to see the optimum settings for the responses. In this case, any values 
less than 60 for the heat transfer efficiency and less than 200 for the thermal efficiency are 
considered unacceptable. The Target values are the highest values that are expected given the 
process requirements. 
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The plot is shown next. You can see the optimal solution in a numeric format by clicking the 
View Solutions icon (   ) on the control panel. 

 

The overlaid contour plots of these two responses are shown in the "Overlaid Contour Plot" 
folio. This folio shows the ranges of values for two factors (selected on the control panel) that 
produce the desired response values. 
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The green "feasible" area is the region where factors A and B produce the desired response 
values. In this example, factors C and D are fixed at custom values specified by clicking the Set 
link on the control panel. 
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Are there any other feasible regions if we vary the values of C and D, or if we only hold C 
constant but vary the value of D? The "Dynamic Overlaid Contour Plot" folio includes a tool that 
can help you answer this question. 

The engineers decided to make factor C (nozzle opening) constant, but vary factor D (gas 
temperature) along with A (fluidizing gas flow rate) and B (supernatant gas flow rate). This is 
specified on the Factor pages of the window that appears when you click the Calculate icon. A 
summary of the settings is shown next. 

 

With these settings, the tool creates multiple overlaid contour plots where A and B are varied 
along the x- and y-axes. In each plot, C is held constant at its lowest factor value. To vary D, ten 
plots are created, and each uses a different value for factor D. For example, the first plot uses 
D’s lowest value, and the last plot uses its highest value. 

The plots are shown next, and each is identified in the Sorted Solutions area using the value for 
gas temperature that it uses. Double-click a plot to zoom in on it, and double-click it again to 
zoom out and view all the plots. 
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Conclusion 

In this example, we obtained useful results from historical data. Different optimization tools 
were used to explore different factor level combinations. The easiest method is to use the 
optimal solution plot to quickly find the optimal solution. However, the overlaid contour plot 
can also be used to display the feasible region of two factors for multiple responses, while all 
other factors are held constant. And the dynamic overlaid plot can show the feasible region of 
two selected factors under different values for all other factors. 

Prediction Window 

The Prediction window is available after you analyze response data with at least one 
quantitative factor. The window allows you to enter values for each factor and see predicted 
results for the selected response. 

The tool can be accessed from design folios, free form folios and multiple linear regression 
folios. To open it choose Data > Analysis > Prediction or click the icon on the control panel. 
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The values available for prediction in the Prediction window vary depending on whether your 
response values contain standard or life data. The Prediction window for standard data is 
shown next. The window for R-DOE looks similar, except it lacks the Bounds Options area. 

 

Note: If the prediction is based on a reliability DOE analysis, the Publish Model button will be 
available on the control panel. When you click this button, the selected prediction will be used 
to publish the analysis results as a model. (See Publishing Models from R-DOE.) 

To use the Prediction window, follow the steps outlined next: 

• First, in the green factor columns, enter the factor values that will be used to generate the 
prediction. 

• If the design uses blocks, choose values in the Block column as well. 

• You can choose to use either actual or coded values by choosing Display > [Data Type]. 

  

• For mixture designs, you can display the component factor values as amounts (e.g., 2 
pounds), proportions (e.g., 0.2 = 20% of the total mixture used in the run) or 
pseudovalues (scaled values between 0 and 1, where 0 is the minimum possible value 
for the factor and 1 is the maximum possible value) by choosing Display > [Value Type]. 

    

• Note that any factors that you omit from the analysis will be hidden in this window. 
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• Choose the response you wish to generate predictions for in the Response drop-down list. 

• In the Confidence Level field enter the level (as a decimal) that will be used to generate 
two-sided confidence bounds on the prediction. 

• If you're working with standard response data, use the Bounds Options area to specify the 
type of bounds to be displayed for the predicted value. If you are working with R-DOE, this 
tool will always use confidence intervals. 

• If you select Confidence Interval, the value in the Mean Predicted column will be 
treated as a predicted mean value and bounds will be calculated accordingly. 

• If you select Prediction Interval, the value in the Mean Predicted column will be 
treated as a predicted new observation and bounds will be calculated accordingly. The 
prediction interval is wider than the confidence interval because the uncertainly of the 
error is considered in addition to the uncertainty of the parameter(s). 

• Once you have specified all required values, click Calculate. The software will use the 
existing model to predict results for the currently selected response. The following columns 
will be populated: 

• The first column shows the predicted value. The name of this columns depends on the 
type of design you are working with. 

• For a standard design, this is the Mean Predicted column. It may be treated as a 
predicted mean value or a predicted new observation value, depending on the type 
of bounds selected in the control panel. 

• For R-DOE, the first column will represent the characteristic life of the selected 
distribution: 

• For Weibull, it is the Eta Predicted column. This is the predicted time at which 
unreliability = 63.2%. 

• For lognormal, it is the Ln-Mean Predicted column. This is the predicted time at 
which unreliability = 50%. 

• For exponential, it is the MTTF Predicted columns. This is the predicted mean 
life. 

• Standard Error is the standard error of the predicted value (i.e., the value in the 
preceding column). 
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• The last two columns will vary depending on the design type and/or the selected 
bounds option. 

• The Low Confidence Interval and High Confidence Interval columns are always 
used for R-DOE. They are optional for other designs. 

• The Low Prediction Interval and High Prediction Interval columns are not available 
for R-DOE. They are optional for other designs. 

All entered and calculated values are retained in the Prediction window after you close it; the 
next time you open the window, your inputs and results will appear. To clear the entire 
window, click the Clear icon in the window toolbar. 

The Prediction window can be sorted by any column. Select a cell in the column you wish to 
sort by and then choose Sort > Sort [Ascending/Descending]. 

  

The information in the Prediction window can be transferred to a spreadsheet by choosing 
Transfer > Send to Spreadsheet. 

 

The information can also be saved as a Microsoft Excel® file (*.xls or *.xlsx) by choosing 
Transfer > Send to Excel. 
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Chapter 11: Tests and Planning Folios 
Test Design Folios 

TEST DESIGN ASSISTANT 

Weibull++ includes test design tools that provide ways to design reliability tests as well as 
evaluate and compare proposed test designs. Three of these tools can be accessed by choosing 
Home > Insert > Test Design. 

 

The Test Design Assistant will appear and ask you to select one of the following: 

• Reliability Demonstration Test solves for values associated with a specified test design 
such as required test time, required sample size, demonstrated reliability and confidence 
level. 

• Expected Failure Time Plot determines what failure times you can expect in a test with a 
given sample size. Because you can display actual failure times on the plot, it is especially 
useful for determining whether a test is proceeding as expected. 

• Difference Detection Matrix shows how much test time is needed to detect a statistically 
significant difference in life between two product designs when the data are obtained from 
reliability life tests and then analyzed with a  life data or life-stress data folio. 

Note that in addition to the tools discussed in these topics, the software includes two other 
tools that can assist you in designing reliability life tests: 

• ALTA Test Plan recommends a test plan for accelerated life testing data analysis. The 
recommended plan will include information about what stress levels to use in the test, as 
well as what sample sizes to use for each stress level. 

• SimuMatic allows you to use simulation-based methods to experiment with various testing 
scenarios. For example, you could try to improve a given test plan by running a simulation 
of the test with a smaller sample size and seeing whether the more conservative plan 
would still allow you to meet your test goals. (See Designing Reliability Tests with 
SimuMatic.) 
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Reliability Demonstration Test Design 

In a zero-failure reliability demonstration test (RDT), the engineer aims to demonstrate a 
specified target metric (e.g., reliability at a specific time with a given confidence level) by 
testing a specified number of units for a predetermined time. If no failures occur, then the 
target metric is demonstrated. This method has been adapted for scenarios where the target 
metric can be demonstrated even if some failures occur, as long as a specified number of 
allowable failures is not exceeded. For example, in a demonstration test where the number of 
allowable failures is 2, the target metric is demonstrated if no more than 2 failures occur during 
the test. (If more than the number of allowable failures occurs, then the reliability 
demonstration test failed and the target metric was not demonstrated. The engineers may 
choose to continue the test as a reliability life test, recording the exact failure/suspension times 
and then analyzing the data with standard life data analysis methods. Note that although 
mathematically it is possible to design a new test with more allowable failures and a longer 
duration to demonstrate the same target metric, it is unlikely that the metric will be 
demonstrated by the new test if the original demonstration test failed.) 

ReliaSoft's RDT tool can assist the user in designing a demonstration test by solving for various 
values related to the test, such as sample size, required test time, the demonstrated reliability 
and the confidence level at which the target reliability will be demonstrated. 

Tip: This tool could determine, for example, that if you assume your units follow a Weibull 
distribution with a shape parameter of 2 and you tested 10 units for 150 hours and none failed 
during the test, then you would demonstrate a 90% reliability at 100 hours with 90% 
confidence. It does not, however, calculate the probability that one or more units might 
actually fail during the test. If you wish to estimate whether a failure is likely to occur, one 
option is to use the Expected Failure Time Plot to estimate the first failure time based on the 
assumed distribution and parameters. 

Control Panel 

• Test Design Method allows you select a test design option. The method you select will 
determine the required inputs on the RDT sheet. 

• Parametric Binomial determines what test duration or sample size will be required to 
demonstrate either reliability at a specific time or a specified mean time to failure. To 
use this option, you must provide an estimate of the underlying life distribution's shape 
parameter. 

Note: You can get the parameters and time units from a calculated data sheet in the 
current project by clicking the Get Distribution icon  on the control panel. 



Chapter 11: Tests and Planning Folios 

Weibull++ 2020 User's Guide 939 

 

• If you are demonstrating the reliability at a specified time, enter the time in the At 
this Time field. If you used the Get Distribution option, this value will initially be set 
to the time at which a product with the calculated life distribution would have the 
reliability that you specified. 

• If you are demonstrating the mean time to failure, enter the mean time in the 
Demonstrate this MTTF field. If you used the Get Distribution option, this value 
will initially be set to the MTTF that a product with the calculated life distribution 
would have. 

• You can also create a table that displays a range of test duration values as a 
function of sample size and number of allowable failures. The table can also display 
a range of required sample size values as a function of test time and number of 
allowable failures. After you create this table, you can also create a plot displaying 
the same information. This provides a quick way to consider many possible test 
plan scenarios without having to perform each calculation individually. 

• Non-Parametric Binomial solves for the demonstrated reliability, confidence level or 
sample size that is associated with a specified test design. It does not require a life 
distribution. The use of this option assumes that the time at which the reliability is 
demonstrated is equal to the specified test time multiplied by the specified 
acceleration factor. For example, if the acceleration factor is 1, then the time at which 
reliability is demonstrated equals the test duration. If the acceleration factor is 2, then 
the time at which the reliability is demonstrated is double the test duration, and so on. 

• Exponential Chi-Squared determines the total accumulated test time that will be 
required to demonstrate a specified metric. The total accumulated test time is equal to 
the total amount of time experienced by all of the units on test. For example, if the 
total accumulated time is 100 hours, then you could test 1 unit for 100 hours, or you 
could test 2 units for 50 hours each, or you could test 5 units for 1 hour each and 1 unit 
for 95 hours. 

This option is based on the chi-squared distribution, and it is only for products that 
have an assumed exponential life distribution (i.e., products with a constant failure 
rate). 

• Non-Parametric Bayesian solves for the demonstrated reliability or confidence level 
that can be expected from a specified test design. It can also solve for the sample size 
needed to demonstrate a target reliability at a specified confidence level. To use this 
option, you must have some prior information with which you can estimate the 
product’s reliability. 
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In the RDT data sheet, you will need to specify whether the source of prior information 
is expert opinion (i.e., engineering experience) about the reliability of the entire system 
or prior testing at the subsystem level: 

• If you have experience regarding the system as a whole, choose Expert opinion on 
reliability. Then, enter worst case, expected and best case estimates of the 
product's reliability. 

• If you have prior test data for subsystems that compose your system, choose Prior 
tests at the subsystem level, and then specify the number of subsystems that you 
will enter data for. You can enter the information for each subsystem in the RDT 
sheet or click the Edit Bayesian Subsystems icon to open a window you can use to 
enter the prior test data. 

 

Like the non-parametric binomial option, the use of the non-parametric Bayesian 
option assumes that the time at which the reliability is demonstrated is equal to 
the specified test time multiplied by the specified acceleration factor. 

The following chart shows the information that each method can provide. The ReliaWiki 
resource portal has more information on these methods at: 
http://www.reliawiki.org/index.php/Reliability_Test_Design. 

  Metric to demonstrate: Can solve for: 

Parametric 
Binomial 

The reliability at a specific time 
or 

Mean time to failure (MTTF) 

The test time for a specified sample 
size 
or 

The sample size for a specified test 
time 

Non-Parametric 
Binomial 

Reliability at test time 
(if acceleration factor = 1) 

The demonstrated reliability 
or 

The associated confidence level 
or 

The necessary sample size 

http://www.reliawiki.org/index.php/Reliability_Test_Design
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Exponential Chi-
Squared 

The reliability at a specific time 
or 

Mean time to failure (MTTF) 

The total accumulated test time 

Non-Parametric 
Bayesian 

Reliability at test time 
(if acceleration factor = 1) 

The demonstrated reliability 
or 

The associated confidence level 
or 

The necessary sample size 

• Units in the control panel allows you to define the units of time that will be used in the test. 

• Display Options is available when you select to solve for sample size. Select the check box 
to display the sample sizes as integers. 

• Acceleration Factor allows you to enter the acceleration factor associated with the stress 
level that will be used in the test, if applicable. The acceleration factor is obtained by 
dividing the product’s life at the use stress level by its life at the accelerated stress level to 
be used in the test, if applicable. For example, if the product has a life of 100 hours at the 
use stress level and it is being tested at an accelerated stress level which reduces its life to 
50 hours, then the acceleration factor is 2. If you are testing units under normal operating 
conditions, then the acceleration factor is 1. 

Edit Bayesian Subsystems 

The Edit Bayesian Subsystems window is used to enter prior test data for subsystems that 
compose your system. When you select to use the non-parametric Bayesian test design method 
with the Reliability Demonstration Test (RDT) tool, this prior data is used to estimate the 
demonstrated reliability or confidence level that you can expect from a test's results, or the 
sample size that must be used in a test. 

To open the window from the RDT tool, select Non-Parametric Bayesian from the Test Design 
Method drop-down list on the control panel. Then click the Edit Bayesian Subsystems icon. The 
window will appear as shown next. 
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• Subsystem Name is the name or description of the subsystem that was tested. 

• Sample Size indicates how many units were used in the subsystem's test. 

• Number of Failures indicates how many units failed during the test. 

• Import from Excel command allows you to import the first three columns of an Excel sheet 
into the table. 

The software assumes a series configuration of these subsystems (i.e., the failure of any one 
subsystem is sufficient for the whole system to fail) and uses this subsystem-level information 
to estimate the expected value and variance of the reliability of the entire system. 

Parametric Binomial Table and Plot 

When you use the parametric binomial option of the RDT tool, you can create a table and plot 
based on the target metric and life distribution that you specified on the RDT sheet. Depending 
on what you select to solve for, the table will display a range of test duration values as a 
function of sample size and number of allowable failures, or it will display a range of required 
sample size values as a function of test time and number of allowable failures. The table and 
plot provide quick ways to consider many possible test plan scenarios without having to 
perform each calculation individually. 

Follow the steps outlined below to create the table. 

• Open the RDT tool and solve for required test time or sample size using the parametric 
binomial test design option. The table will use the target reliability and life distribution that 
you specified to produce its results. 

• Click the Show RDT Table icon (shown next) on the control panel. 
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• The Test Design Table page will appear with an empty data sheet. In the Solve for area, 
select which value you wish to solve for. 

• Test time for given sample size solves for the test time given a range of sample sizes. 
When you select this option, the Sample Size Range area will require that you enter a 
starting sample size, an ending sample size and an increment value by which the 
sample will increase in the table. 

• Sample size for given test time solves for sample size given a range of test times. When 
you select this option, the Test Time Range area will require that you enter a starting 
test time, an ending test time and an increment value by which the test time will 
increase. 

• For either option, you must enter starting, ending and increment values for the number 
of allowable failures in the Number of Failures Range area. A demonstration test will 
fail to demonstrate the target reliability if the number of failures exceeds this number. 
Thus, if you are designing a zero-failure test, then the test will demonstrate the target 
reliability only if no failures occur. 

• Click Calculate to create the table. 

The data sheet shown next displays a parametric binomial table. For example, the second cell in 
the table tells us that if you used a test time of about 621 hours and no more than one failure 
occurred during the test, then you would need a sample size of 3 to demonstrate the target 
metric. 

 

To view a plot of the table results, click Redraw Plot. Each colored line in the plot corresponds 
to a specific number of failures; this depicts how the allowed number of failures influences the 
test time and the required sample size. 
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Reliability Demonstration Test Design Example 

The following example demonstrates how to use the Reliability Demonstration Test (RDT) tool 
to calculate the test time needed to show a specified reliability at a specified confidence level in 
a zero-failure demonstration test. A parametric binomial table will also be created which 
displays a range of test duration values as a function of sample size and number of allowable 
failures. 

A reliability engineer is asked to plan a test for a component whose failure behavior is governed 
by a Weibull distribution, where beta = 1.5. The goal of the test is to show, with 90% 
confidence, that the component has a reliability of at least 90% at 100 hours. The component 
will be tested at normal use conditions. 10 units are available for testing. Due to resource 
constraints, it is decided that the target metric will be demonstrated in a zero-failure test. The 
engineer’s task is to determine the minimum test time needed to demonstrate this reliability in 
such a test. 
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Design a Zero-Failure Test 

1. Open the tool by choosing Home > Insert > Test Design. In the Test Design Assistant, select 
Reliability Demonstration Test Design and click OK. 

2. Select Parametric Binomial from the Test Design Method area of the control panel. 

3. In the Input area of the control panel, select Hour (hr) for the units to be used for all time 
inputs and results (e.g., hours, days, miles, etc.). Since the component will be tested at the 
use stress level, enter 1 for the acceleration factor. 

4. Provide the required inputs for the RDT sheet, as shown next. 

 

5. Click the Calculate icon to solve for the required test time. The result shows that a test time 
of at least 168.4064 hours is required for the specified test plan. In other words, if 10 units 
are tested for 168.4064 hours at normal use conditions and none fail, then the test will 
demonstrate, with 90% confidence, that the component has a reliability of at least 90% at 
100 hours. 

Generate a Table of Possible Test Plan Scenarios 

6. Click the Show RDT Table icon on the control panel. 

 

7. In the Solve for area, select Test time for given sample size so the table shows test 
duration values as a function of sample and number of allowable failures. 
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8. In the Sample Size Range area, enter a range of sample sizes of 1 through 10 with an 
increment of 1. 

9. In the Number of Failure Range area, enter a range of 0 to 5 with an increment of 1. 

10. Click the Calculate icon. A table showing a range of test duration values as a function of 
sample size and number of allowable failures appears, as shown next. 

 

Expected Failure Time Plot 

Expected Failure Time Plot 

The Expected Failure Time plot provides a visual depiction of what failure times you can expect 
to observe when you implement a particular test plan. If you perform the test and enter the 
actual failures as they’re observed, you can use the plot to monitor whether the test is 
proceeding as planned, which could provide an early warning that adjustments may be needed. 
The ReliaWiki resource portal has more information on the Expected Failure Time Plot at: 
http://www.reliawiki.org/index.php/Reliability Test Design. 

Tip: You can also use this plot to determine whether a specified reliability demonstration test 
will exceed the allowable number of failures. For example, if you have designed a zero-failure 
test and wish to determine whether zero failures will occur during the test, you could examine 
the lower confidence bound of the first predicted failure for that test. This information will help 
you determine whether a failure is likely to occur before the end of the test. 

Generating an Expected Failure Time Plot 

Follow the steps outlined below to generate an Expected Failure Time plot. 

http://www.reliawiki.org/index.php/Reliability_Test_Design
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• Enter the sample size, two-sided confidence level and acceleration factor in the Plot Setup 
area of the control panel. 

The acceleration factor is obtained by dividing the product’s life at the use stress level by its 
life at the accelerated stress level to be used in the test, if applicable. For example, if the 
product has a life of 100 hours at the use stress level and it is being tested at an accelerated 
stress level that reduces its life to 50 hours, then the acceleration factor is 2. If you are 
testing units under normal operating conditions, then the acceleration factor is 1. 

• Define the expected life distribution for your product, and then choose the time units to be 
used in the calculations. To enter the parameters, click the arrow in the Expected Failure 
Model area. 

• A window will appear where you can select a life distribution and enter its parameters. 
If the estimated values of the distribution parameters are not available, you can use the 
Quick Parameter Estimator (QPE) to solve for them. 

 

• In the same window, select the time units (e.g., hours) that will be used in the test. 
Then click OK to close the window and generate the plot. 

Note: You can also get the parameters and time units from a calculated data sheet in the 
current project by clicking the Get Failure Model icon on the control panel. After you select 
the data sheet, click the Redraw Plot icon to generate the plot. 

• The plot will show the predicted failures times for each test unit with a margin of error 
corresponding to the confidence level you entered in the Plot Setup area. The three vertical 
tick marks on each line display the lower confidence bound, median value and upper 
confidence bound for the expected failure time of a tested unit. 
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• To display actual failure times as points that can be compared against the estimated 
intervals, click the arrow in the Actual Failures box. A table will appear where you can enter 
the recorded failure times, as shown next. The entered times will be automatically sorted 
from least to greatest. 
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Tip: If you have a column of data copied to the Clipboard (e.g., from a data sheet), you can 
click the Clipboard icon at the top of the Time column to paste the data into the table. 

You can view a calculated value by pointing to the relevant vertical tick mark on the plot. 
Alternatively, click Results (...) in the Expected Failure Time area of the control panel to view all 
calculated values at once. 

Additional Control Panel Options 

The control panel also includes the following options: 

• Plot Options area: 

• Keep Aspect Ratio maintains the ratio of the horizontal size of the plot graphic to the 
vertical size when you resize the plot. 

• Automatically Refresh will automatically update the plot whenever any of the inputs 
change. If this option is cleared, you will have to click the Redraw Plot icon to update 
the plot. 

• X-Axis Scaling area, select the Linear check box to use a linear scale for time. Select the 
Logarithmic check box to use a logarithmic scale. 

• Scaling area, the X and Y boxes show the minimum and maximum values for the x- and y-
axes. To change these values, clear the check box beside the value range. If it is selected, 
the application will automatically choose appropriate values for the range. 
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• Plot Setup icon opens the Plot Setup window, which allows you to customize most aspects 
of the plot including the titles, line styles and point styles. 

• RS Draw icon launches ReliaSoft Draw, which allows you to annotate your plot and view 
your plot in greater detail. 

• Export Plot icon opens the Save As window, which allows you to save the current plot 
graphic in *.jpg, *.gif, *.png or *.wmf format. 

Expected Failure Time Plot Example 

This section presents an example of how to use the Expected Failure Time plot to monitor an in-
progress test. 

A reliability engineer is asked to perform a reliability life test for a component whose underlying 
life distribution is estimated to be a Weibull distribution, where beta = 2.5 and eta = 500 hours. 
This estimation is uncertain, however, and the engineer has been asked to monitor the test and 
report to management if the failure times suggest that the estimated life distribution is 
incorrect. Ten units will be tested under normal operating conditions. 

Follow the steps outlined below to view two-sided 90% confidence bounds for the failure times 
of each unit in the test. 

1. On the Home tab, click the Test Design icon in the Insert gallery. 

 

2. In the Test Design Assistant, select Expected Failure Times Plot and click OK. The Expected 
Failure Time window will appear. 

3. In the Plot Setup area of the control panel, enter 10 for the sample size. Then enter 90 for 
the two-sided confidence level. Because the units will be tested under normal operating 
conditions, enter 1 for the acceleration factor. 

4. Next, enter the life distribution of the product by clicking the arrow in the Expected Failure 
Model area of the control panel. In the window that appears, select 2P-Weibull for the 
distribution. Then enter the distribution’s parameters and select Hour for the time unit. 

5. Then click the Redraw Plot icon to recalculate the expected failure times. The plot will 
show the predicted failure times for the ten units, with 90% two-sided confidence bounds 
on each prediction. 

6. To add actual failure times to the plot, click the arrow in the Actual Failures field to enter 
the failure times (shown next) as they are observed during the test. The entered times will 
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be automatically sorted from least to greatest, and they will be displayed as points on top 
of the lines that represent the expected failure times. 

 

The following plot shows the first five actual failures displayed with the ten expected failure 
times. At this point, the engineer would inform management that the observed failure 
times indicate that the estimated life distribution may be inaccurate. 
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Difference Detection Matrix 

Difference Detection Matrix 

The Difference Detection Matrix calculates how much test time is required before it is possible 
to detect a statistically significant difference in the mean life or BX% life (e.g., B10 life) of two 
product designs by analyzing the data from a reliability life test. You can use this tool to 
evaluate different test plans in order to choose the one that will be most efficient to compare 
the reliability of the two designs. To use the matrix, you must provide various inputs—including 
the sample sizes that will be used to test each design and the life distributions that describe 
each design’s life behavior. 

The ReliaWiki resource portal has more information on the Difference Detection Matrix at: 
http://www.reliawiki.org/index.php/Reliability Test Design. 

http://www.reliawiki.org/index.php/Reliability_Test_Design
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Reading the Detection Matrix 

In this section, we will look at an example detection matrix and discuss how to read it. The next 
section explains how to set up the matrix. We will assume that a sample size of 10 will be used 
to test both product designs. 

 

Because the column title in the above matrix is "Design 1 Mean Life," we know that the metric 
being compared is mean life (rather than BX% life). The column headings represent possible 
mean life values for Design 1, and the row headings represent possible mean life values for 
Design 2. We’ll begin by examining the cell in the second column and the first row of the matrix, 
which corresponds to a Design 1 mean life of 1,000 hours and a Design 2 mean life of 500 
hours. 

The number inside this cell is 4 and the legend below the matrix tells us that a 4 means a 
difference between the two designs can be detected, but only after at least 1,500 hours of 
testing. In other words, one thing the matrix tells us is that if Design 1 has a mean life of 1,000 
hours and Design 2 has a mean life of 500 hours, then the tests we use to compare these 
designs will need a duration of at least 1,500 hours in order for the analysis of collected data to 
show that there is, at the specified confidence level, a statistically significant difference in mean 
life between the two designs. 

Tip: You can click a cell in the matrix to see the difference in the compared metric that was 
calculated for both designs based on the associated test time. For example, if a cell in the 
matrix shows that a difference in mean life can be detected with 2,000 hours of testing, clicking 
the cell will show the mean life calculations (including two-sided confidence intervals) that 
would be obtained for each design if you analyzed the test data after 2,000 hours of testing. (If 
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only one of the designs would produce enough failures to fit to a distribution during the given 
test time, no intervals will be shown.) 

Setting Up the Detection Matrix 

Follow the steps outlined below to set up the detection matrix. All the settings are located on 
the control panel. 

• In the Metric to Compare area, select whether you want to compare Mean Life or BX% 
Life. If you select to compare the BX% life, you must enter a value in the associated input 
field (e.g., a BX% life of 10 indicates that the software will compare the time when 10% of 
units will have failed). Also, specify the confidence level that will define when a difference 
between the specified designs is statistically significant. Then specify the time units (e.g., 
hours) that will be used for the inputs and results. 

The software calculates two-sided confidence intervals (at the level you specified in the 
Confidence (%) field) on the specified life metric for both designs, when possible. A 
difference is considered detected at a given test time when the two calculated confidence 
intervals do not overlap, or when only one of the designs produces enough failures to fit to 
a distribution. 

• In the Design 1 and Design 2 areas, enter the sample sizes of the tests that will be used to 
compare the designs and define the distributions for each design’s failure behavior. 

• In the Reliability Metric Setup area, configure the rows and columns in the table by first 
entering the Max Metric Time value, which is the highest metric value (mean life or BX% 
life, depending on your selected metric) that the software will consider in the comparison. 
Then enter a Metric Increment to specify the difference between the displayed metric 
values in each column and each row. This value is also used as the minimum metric value 
that will be considered in the comparison. 

For example, if you entered 1000 in the Max Metric Value field and 200 in the Metric 
Increment field, then your matrix would have five columns and five rows, each starting with 
a value of 200 and moving up in increments of 200 until reaching the maximum value of 
1000. 
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• The matrix indicates whether a difference in the selected reliability metric will be detected 
after various test times. These are the test times shown in the legend under the matrix. In 
the Test Times Matrix Setup area, specify the test times that will be evaluated. 

• To specify how many test times to evaluate, enter a value in the Number of Test Times 
field. For example, if you enter 4 in this field, then the software will evaluate will 
evaluate 4 different test times. The software cannot evaluate more than 10 test times. 

• If the Calculate Test Times check box is cleared, you will be able to click the arrow 
inside the Test Time field to open a table where you can enter the specific times. For 
example, if you enter 500 as one of the test times, then the matrix will determine 
whether 500 hours (assuming your selected time unit is hours) is sufficient to detect a 
difference in the selected life characteristic. The number of rows available in this table 
is determined by what you entered in the Number of Test Times field. Note that upon 
exiting the table, the times in the table will be sorted in descending order. 

• If the Calculate Test Times check box is selected, the software will automatically enter 
test times from 1,500 to 6,000 in the Test Time field. 

• Click the Calculate icon to validate your settings and generate the matrix. See Reading the 
Detection Matrix for information on how to read the results. 

• If you wish to export the matrix as a Microsoft Excel file, click the Send to Excel icon. 

 

• You can also change the color used in the matrix by clicking the Set Matrix Color icon. 

 

Your selected color will be used to indicate when the shortest test time provided in the 
Test Time Matrix Setup area is sufficient to detect a difference in the specified life 
characteristic. Darker versions of that color will be used to indicate when longer test 
times are required. 

Difference Detection Matrix Example 

This section presents an example of how to use the Difference Detection Matrix to estimate the 
test time required in a reliability life test to demonstrate that a new product design will have a 
higher mean life than an older design. 

A manufacturer plans to implement a new product design that is expected to improve the 
product’s mean life. The current design is expected to have a mean life of 200 hours, and the 
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new design is expected to have a mean life of 300 hours. A reliability engineer is asked to 
determine, with 90% confidence, the minimum amount of test time that would be required to 
determine that there has been an improvement in mean life with the new design. No more 
than 400 hours will be available for testing, and only 10 units of each design will be available for 
testing. 

The engineer also has some information about the life distributions for both designs. They each 
have a Weibull life distribution, and the beta parameter for the original design is 4.2, while the 
beta parameter for the new design is 3. 

Follow the steps outlined below to estimate the test time required to detect a difference in 
mean life. 

1. Choose Home > Insert > Test Design. In the Test Design Assistant, select Difference 
Detection Matrix and click OK. 

2. In the Metric to Compare area of the control panel, select Mean Life and enter 90 for the 
confidence level. 

3. Choose Hour for the units that will be used for all time inputs and results. 

4. In the Design 1 area, enter 10 for the sample size. Design 1 is the original design, so select 
2P-Weibull for the distribution and enter 4.2 for the beta value. 

5. In the Design 2 area, enter 10 for the sample size. Design 2 is the new design, so select 2P-
Weibull for the distribution and enter 3 for the beta value. 

6. The matrix will display a range of possible mean life values for both designs. The range 
begins with 0 and increases by an increment of your choice. In the Reliability Metric Setup 
area, enter 500 for the maximum metric time. Then enter 100 for the metric increment. 
The range of mean life values displayed for both designs will thus be 100, 200, 300, 400 and 
500. 

7. In the Test Time Matrix Setup area, enter 4 for the number of test times that will be 
evaluated. The software will automatically enter default test times. To view them, clear the 
Calculate Test Times check box, then click the arrow in the Test Time (hr) box. A table will 
appear where you can view and modify the test times that will be evaluated. In the table, 
enter 400 for Test Number 1, 350 for Test Number 2, 300 for Test Number 3 and 250 for 
Test Number 4. 

8. Click the Calculate icon to generate the matrix, which will appear as shown next. 
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According to the above matrix, if Design 1 has a mean life of 200 and Design 2 has a mean life of 
300, then a statistically significant improvement in mean life can be detected between the two 
after analyzing the data of a 300-hour reliability life test. 

Target Reliability Tool 

Deciding on a reliability goal/target involves trade-offs. This is because higher reliability 
typically correlates with higher production costs, lower warranty costs and higher market share. 
With Weibull++'s Target Reliability tool, you can generate plots that help you visualize and 
estimate a target reliability that will minimize cost, maximize profit and/or maximize your 
return on an investment in improving the product’s reliability. The ReliaWiki resource portal has 
more information on the Target Reliability tool at: 
http://www.reliawiki.org/index.php/Target_Reliability_Tool. 

The Target Reliability tool is divided into a target estimation sheet and control panel. The top 
part of the sheet is the Target Estimation Inputs area, where you provide the best, most likely 
and worst case estimates for various factors involved in the production and sale of the product. 
The bottom part of the sheet contains the plot that you select to generate from your inputs. 

The control panel contains settings for the type of plot that will be displayed, as well as other 
plot settings and icons. It also contains an input field for the product's maximum market 
potential and, when the R3OI vs. reliability plot is selected, an input field for the expected initial 
investment. 

GENERATING A PLOT 

Follow the steps outlined below to generate a plot. 

• Open the tool by choosing Home > Insert > Target Reliability. 

 

• In the Target Estimation Inputs area, enter the estimated best, worst and most likely 
scenarios. Each scenario includes all of the following factors. 

http://www.reliawiki.org/index.php/Target_Reliability_Tool
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Note: A better scenario involves an improvement in both reliability and ROI. Thus the 
production costs in the best case scenario must be higher than that of the worst case 
scenario. This is because improving reliability requires increasing spending on factors such 
as facilities, higher quality materials, etc. 

• Expected failures/returns per period (as % of sales). The number of failures or returns 
that are expected in a given period, given as a percentage of sales. For example, if the 
best case scenario is one where 1% of the sold units are expected to fail or be returned 
within a year, then you would enter 1 under the Best heading for this factor. 

• % of market share that you expect to capture. The percentage of the market share 
that you expect to capture with your product. For example, if the worst case scenario is 
one where you expect to capture 40% of the market, then you would enter 40 under 
the Worst heading for this factor. 

• Average unit sales price. The average sales price per unit. For example, if the most 
likely scenario is one where the average sales price per unit is $20, then you would 
enter 20 under the Most Likely heading for this factor. 

• Average cost per unit to produce. The average cost of producing a single unit. For 
example, if the best case scenario is one where it costs, on average, $2 to produce a 
single unit, then you would enter 2 under the Best heading for this factor. 

• Other costs per failure (in addition to replacement cost). The average failure cost per 
unit, ignoring the cost of replacing a returned unit. For example, if the worst case 
scenario involves a cost of $5 per failed unit, $3 of which are due to the cost of 
replacing the failed unit, then you would enter 2 (the remaining cost) under the Worst 
heading for this factor. 

• Select the kind of plot you want to generate in the Plot Settings area of the control panel: 

• Cost vs. Reliability displays total cost as a function of target reliability. The total cost is 
the sum of the production cost, which is the cost involved in manufacturing the product 
to achieve a target reliability, and the unreliability cost, which is the cost incurred as a 
result of failures/returns and lost sales. By default, the plot displays curves for the 
production and unreliability costs and displays a vertical line marking the lowest point 
of the total cost curve. 

• Profit vs. Reliability displays profit as a function of target reliability. Profit is calculated 
by subtracting the production cost, warranty cost and other failure-related costs from 
the estimated total sales revenue. By default, the plot displays a vertical line marking 
the highest point of the profit curve. 
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• R3OI vs. Reliability uses ReliaSoft's Reliability Return on Investment (R3OI) equation to 
calculate expected returns on an initial investment that will affect reliability. The R3OI 
is calculated by subtracting the initial investment from the expected increase in sales 
revenue and dividing the result by the initial investment. This plot displays the return 
on investment as a function of the reliability achieved through that investment. By 
default, the plot displays a vertical line marking the highest point of the R3OI curve. 
 
If you choose R3OI vs. Reliability, then you must enter your expected initial investment 
in the Initial Investment field at the bottom of the control panel. 

• Near the bottom of the control panel, enter the maximum number of units that could be 
sold in a given period in the Max. Market Potential (Units) field. 

• The Show Plot Items area will display a list of curves and vertical lines that can be displayed 
for the plot you selected in the Plot Settings area. To remove a line/curve from the current 
plot display, clear the associated check box. 

• Click the Plot icon on the control panel to generate the plot. 

Tip: You can hide the Target Estimation Inputs area and expand the plot to fill the entire sheet 
by double-clicking the plot. To show the area and shrink the plot to its original size, simply 
double-click the plot again. See the descriptions below for other plot commands that are 
available in this control panel. 

CONTROL PANEL 

The Target Reliability Tool control panel contains the following options:  

• The Analysis Details (...) button displays the equations that are used to generate the plots. 
The values of A and B for each equation are calculated from the inputs provided in the 
Target Estimation Inputs area of the target estimation sheet. 

• In the Plot Settings area: 

• Keep Aspect Ratio maintains the ratio of the horizontal size of the plot graphic to the 
vertical size when you resize the plot. 

• Only Show Positive Values will include only positive values for the y-axis when that axis 
has a minimum value of at least zero. 

• In the Scaling area: 
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• The X and Y boxes show the minimum and maximum values for the x- and y-axes. To 
change these values, clear the check box beside the value range. If it is selected, the 
application will automatically choose appropriate values for the range. 

• The Plot Setup icon opens the Plot Setup window, which allows you to customize most 
aspects of the plot including the titles, line styles and point styles. 

• The RS Draw icon launches ReliaSoft Draw, which allows you to annotate your plot and 
view your plot in greater detail. 

• The Export Plot icon opens the Save As window, which allows you to save the current plot 
graphic in *.jpg, *.gif, *.png or *.wmf format. 

ALTA Test Plan Utility 

For life-stress data only. 

The ALTA Test Plan utility is a planning tool that helps you design a one-stress or two-stress 
accelerated life test that will reduce the estimation uncertainty of product life under normal 
operating conditions. It generates a test plan with recommendations for what stress levels 
should be used in the test and how many units should be tested at each stress level. 

Follow the steps outlined below to generate a recommended test plan. 

1. Open the tool by choosing Home > Insert > ALTA Test Plan. 

 

2. From the Number of Simultaneous Stresses drop-down list, choose whether you will be 
designing a test that applies only one type of stress during the test, or a combination of two 
stresses applied simultaneously (e.g., temperature and humidity). 

3. From the Test Plan Type drop-down list, choose an appropriate test plan. The test plan 
level is the number of stress levels that the plan recommends (e.g., a 3 level plan will 
recommend subjecting some units to a low stress level, some to a mid level and the rest to 
a high level). Test plans may also differ according to how they allocate the units to stress 
levels. Your specified test plan will minimize the variance on the value you enter in the BX 
Life Estimate Sought field. See ALTA Test Plan Types for details on each test plan. 

4. In the BX% Life Estimate Sought field, enter (as a percentage) the BX% life (under normal 
operating conditions) that you intend to estimate from the test (e.g., for the B10 life, you 
would enter 10). 
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5. In the Available Test Time field, enter the duration of the accelerated life test you are 
planning. (The duration can be entered in any unit of time, but you must use the same time 
unit throughout the utility.) 

6. From the Unit Allocation drop-down list, choose Show Allocations as % if you do not want 
to specify the total number of units that will be available for testing. In this case, the test 
plan will only display the percentage of the available units that should be allocated to each 
stress level. 
 
If you want the test plan to display both the percentage and the quantity of test units 
allocated to each stress level, choose Show Allocations as Qty and then enter the total 
number of units that will be available in the Number of Units Available field. 

7. From the Lifetime Distribution drop-down list, select the distribution that describes your 
product's life behavior. You can select Weibull and enter the shape parameter in the Beta 
field, or select Lognormal and enter the shape parameter in the Std field. 

Tip: If your product's underlying life distribution is exponential, select Weibull from the Life 
Distribution drop-down list and enter 1 in the Beta field. This is equivalent to using an 
exponential distribution. 

8. Next, in the Stress 1 area, choose the appropriate Life-Stress Relationship from the drop-
down list. Then enter the stress level at normal use conditions in the Use Stress Value field. 
In the Maximum Stress Value field, enter the maximum stress level that could be applied 
during the test without introducing failure modes that would not occur under normal use 
conditions. Repeat these steps for Stress 2 if you selected to design a two-stress test. 

9. In order to provide reasonable recommendations for the stress levels to be used in the test, 
the software must estimate a life-stress relationship for your product. The utility will 
estimate a life-stress relationship using the values you enter in the Probabilities of Failure 
(%) area. Each probability of failure is for the time you entered in the Available Test Time 
field and at the stress level described. 

For example, if you specified a test time of 100 and one of the fields in this area is P(Time, 
Use Stress 1, Maximum Stress 2), then you should enter the estimated probability of 
failure for the product at time = 100, where the product experiences Stress 1 at the 
specified use stress value and Stress 2 at the specified maximum stress value. 

10. Click Calculate to generate the recommended test plan. The Test Plan Results sheet will 
appear. See Test Plan Results Sheet for information on how to read the results and evaluate 
the plan. You can further evaluate the recommended plan by using the utility's control 
panel. 
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ALTA TEST PLAN TYPES 

For life-stress data only. 

The ALTA Test Plan utility allows you to choose a test plan type that will best fit your test goals 
and resource constraints. Which test plans are available will depend on whether you chose to 
design a one-stress or two-stress test in the Number of Simultaneous Stresses drop-down list. 
Each test plan will attempt to minimize the variance on the BX% life you specified in the BX% 
Life Estimate Sought field. 

If you selected to design a single-stress test, the following test plans will be available: 

• 2 Level Statistically Optimum Plan 
Recommends two stress levels: a high stress level, which is the maximum allowable stress 
value that you specified during setup, and a low stress level. The low stress level and the 
proportion of units allocated to each stress level are calculated in order to minimize the 
variance on the BX% life. 

• 3 Level Best Standard Plan 
Recommends three stress levels: a high stress level, which is the maximum allowable stress 
value that you specified during setup, a low stress level and a mid stress level. The low and 
mid levels are calculated in order to minimize the variance on the BX% life. The test units 
are allocated equally to each stress level. 

• 3 Level Best Compromise Plan 
Recommends three stress levels using the same approach described above for the 3 Level 
Best Standard Plan. You define the proportion of test units to allocate to the mid stress 
level during setup in the Proportion of Units at Mid Stress field. The other proportions are 
calculated in order to minimize the variance on the BX% life. 

• 3 Level Best Equal Expected Number Failing Plan 
Recommends three stress levels using the same approach described above for the 3 Level 
Best Standard Plan. The proportion of units allocated to each stress level is calculated such 
that the number of units expected to fail at each stress level is equal. 

• 3 Level 4:2:1 Allocation Plan 
Recommends three stress levels using the same approach described above for the 3 Level 
Best Standard Plan. The proportion of test units tested at the high, mid and low stress 
levels will be calculated to be as close as 4:2:1 as possible (e.g., if you specified that 7 units 
are available in the Total Number of Units field, then this plan will recommend testing 4 
units at the high level, 2 at the mid level and 1 at the low level). 
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When you select this plan, you must also enter a value in the Low Stress Adjustment Factor 
field. The reduction factor must be a decimal between 0 and 1. The lower the value, the 
closer the recommended low stress level will be to the product's specified use stress level. 
Thus, if the reduction factor is 0, then the low stress level will be equal to the use stress 
level. If the reduction factor is 1, then the low stress level will equal the stress value that 
minimizes the variance on the BX% life. 

If you selected to design a two-stress test, the following test plans are available: 

• 3 Level Optimum Plan 
Recommends three stress levels, each consisting of a combination of stress values for the 
two stress types. The combinations are structured such that: 

• The 1st combination has both Stress 1 and Stress 2 at the maximum allowable stress 
values that you specified during setup. 

• The 2nd combination will have Stress 1 at a calculated mid stress level and Stress 2 at 
the use stress level. 

• The 3rd combination will have Stress 1 at the use stress level and Stress 2 at a 
calculated mid stress level. 

The mid stress level is calculated such that the units tested at the 2nd and 3rd stress 
combinations will have the same probability of failure at the end of the test. The proportion 
of units allocated to each stress level is computed in order to minimize the variance on the 
BX% life. 

• 5 Level Best Compromise Plan 
Recommends five stress levels, each consisting of a combination of stress values for the 
two stress types. The combinations are structured such that: 

• The 1st combination will have both Stress 1 and Stress 2 at the maximum stress values 
that you specified during setup. 

• The 2nd combination will have Stress 1 at a calculated mid stress value A and Stress 2 
at the use stress level. 

• The 3rd combination will have Stress 1 at the use stress level and Stress 2 at a 
calculated mid stress value B. 

• The 4th combination will have Stress 1 at the specified maximum stress value and 
Stress 2 at a calculated mid stress value C. 
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• The 5th combination will have Stress 1 at a calculated mid stress value D and Stress 2 at 
the specified maximum stress value. 

The mid stress values A and B are calculated such that the units tested at the 2nd and 3rd 
stress combinations will have the same probability of failure at the end of the test. The mid 
stress values C and D are calculated such that the units tested at the 4th and 5th stress 
combinations will have the same probability of failure at the end of the test. The proportion 
of units allocated to each stress level is computed in order to minimize the variance on the 
BX% life. 

ALTA TEST PLAN RESULTS SHEET 

For life-stress data only. 

The Test Plan Results sheet displays a summary of your inputs, the utility's recommended test 
plan and the time at which unreliability equals the value you entered in the BX% Life Estimate 
Sought field (i.e., Tp). If you entered a number of available test units, it also displays the 
standard deviation of Tp. 

The results sheet is divided into two areas: 

• The Test Plan Inputs area displays a summary of all the inputs that were used to generate 
the test plan. This includes information for each specified stress type and probabilities of 
failure at various stress levels. 

• The Recommended Test Plan area displays the recommended stress levels to be used in 
the test and the recommended allocation of units to each stress level. Each row describes a 
stress level (which, for two-stress tests, will be a combination of stress values) and the 
number of units to be tested at that stress level. For example, consider the following plan. 

 

The row labeled "First Stress Level" recommends that 19.3% of the available units be tested 
at a level of 400 for Stress 1 and 25 for Stress 2. The Unit Allocation (Qty) column is visible 
when the Show Allocations as Qty option was chosen from the Unit Allocation drop-down 
list on the Test Plan Inputs sheet. In this example, it shows that 19.3% of the number of 
available units is 9.65. 
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• Time at Which Unreliability (Tp) = 5% is the time at which unreliability equals the value 
you entered for BX Life Estimate Sought. This value is calculated based on the life 
distribution and probabilities of failure you entered in the Inputs sheet. 

• Standard Deviation of Tp is calculated only if you choose Show Allocations as Qty on 
the Test Plan Inputs sheet. The smaller the standard deviation of Tp, the less variation 
in Tp you can expect in repeated samplings. Thus, smaller values indicate a more robust 
test plan. 

ALTA TEST PLAN CONTROL PANEL 

For life-stress data only. 

The Main page of the Test Plan's control panel gives you options to further evaluate the 
recommended test plan by solving for any one of the criteria in the Solve for drop-down list. 

. 

• The Confidence Level is the confidence level (as a decimal) of the 2-sided bounds on the 
BX% life estimated from data obtained using the recommended plan. The calculated 
confidence level can be increased by increasing the bounds ratio or sample size. 

• The Bounds Ratio is the ratio of the upper confidence bound to the lower confidence 
bound at the specified confidence level. It indicates the relative size of the variance on the 
BX% life estimate. The narrower the confidence bounds, the closer the ratio is to 1, 
indicating less uncertainty. The calculated bounds ratio can be decreased by decreasing the 
confidence level or increasing the sample size. 

• The Sample Size is the number of units that are used in the test. The sample size can be 
decreased by decreasing the confidence level or increasing the bounds ratio. 

To solve for one of these three criteria, you must provide values for the other two. By using the 
Main page of control panel, you can determine whether your goals with respect to these 
criteria are realistic (given factors such as sample size constraints), and you can explore various 
possible trade-offs between the three criteria. 



Chapter 11: Tests and Planning Folios 

966 https://www.reliasoft.com/weibull 

 

Tip: Weibull++ also includes a simulation tool called SimuMatic that you can use to visualize the 
confidence bounds associated with the bounds ratio presented in the test plans utility. The Test 
Plan utility uses an analytical solution that is based on the assumption of a large sample size; 
SimuMatic does not make any assumptions about the sample size and thus may be preferred in 
the case of small sample sizes. 

To solve for one of these criteria, follow the steps outlined below: 

• From the Solve for drop-down list in the control panel, choose the value you wish to solve 
for. The two input fields immediately below the drop-down list will change depending on 
what you choose. For example, if you choose Sample Size, the two input fields will be 
Confidence Level and Bounds Ratio. 

• Enter the appropriate values in the two input fields. 

• Click the Calculate Result icon in the control panel to solve for your selected value. 

The control panel also includes a Comments page that allows you to enter notes or other text 
that will be saved with the folio. 

ALTA TEST PLAN UTILITY EXAMPLE 

For life-stress data only. 

This topic presents an example of how to use the ALTA Test Plan utility to generate a test plan. 
The test plan will recommend the stress levels that should be used in a test and the number of 
units that should be tested at each stress level. 

A reliability group in a semiconductor company is planning an accelerated life test for an 
electronic device. 150 test units will be employed for the test, and the test is planned to last for 
600 hours. Temperature and voltage have been determined to be the main factors affecting the 
reliability of the device, and three chambers are available for testing the units. The goal of the 
test is to estimate the B10 life (i.e., the time at which unreliability = 10%) of the device under 
the normal use conditions of 300 K for temperature and 4 V for voltage. 

The engineers have determined that the maximum stress values that could be applied during 
the accelerated life test are temperature = 360 K and maximum voltage = 10 V. Stresses beyond 
this level would introduce failure modes that do not occur under normal conditions. The 
product follows a Weibull distribution with beta = 3. Based on their knowledge of the life-stress 
relationship, the engineers estimate the following probabilities of failure after the product is 
tested for 600 hours at the different combinations of use level and maximum level stress 
values: 
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• 2% at 300 K and 4 V. 

• 40% at 360 K and 4 V. 

• 90% at 300 K and 10 V. 

Generating a Test Plan 

Follow the steps outlined below to generate a test plan: 

1. On the Home tab, click ALTA Test Plan icon in the Insert gallery. 

 

2. Select to design a two-stress test by choosing 2 from the Number of Simultaneous Stresses 
drop-down list. 

3. Because only three testing chambers are available, three different stress levels will be used 
for each of the two stress types. Choose 3 Level Optimum Plan from the Test Plan Type 
drop-down list. 

4. Enter 10 in the BX% Life Estimate Sought field to specify that the test will be used to 
estimate the B10 life. 

5. Enter 600 in the Available Test Time field. 

6. From the Unit Allocation drop-down list, choose Show Allocations as % and Qty. Then 
enter 150 in the Number of Units Available field. 

7. Choose Weibull from the Lifetime Distribution drop-down list. Then enter 3 in the Beta 
field. 

8. In the Stress 1 area, enter the information for the first stress type (i.e., temperature). 

• Choose Arrhenius from the Life-Stress Relationship drop-down list. This is the life-
stress relationship that is typically used for temperature. 

• Enter 300 in the Use Stress Value field. 

• Enter 360 in the Maximum Stress Value field. 

9. In the Stress 2 area, enter the information for the second stress type (voltage). 

• Choose Power from the Life-Stress Relationship drop-down list. This is the life-stress 
relationship that is typically used for voltage. 
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• Enter 4 in the Use Stress Value field. 

• Enter 10 in the Maximum Stress Value field. 

10. Enter the estimated probabilities of failure at the end of the test, as shown next. 

 

Each probability of failure is a function to time and two stress levels. For example, the value 
entered in the P(Time, Use Stress 1, Maximum Stress 2) field is the probability of failure at 
600 hours (specified in the Available Test Time field), assuming the product experiences 
the specified use stress level for the first stress (300 K) and the specified maximum stress 
level for the second stress (10 V). The stress values were entered in the Stress 1 and Stress 
2 areas. 

11. Click the Generate Test Plan button. The Test Plan Results sheet will appear. 

12. The recommended stress levels and unit allocations are displayed under the 
Recommended Test Plan heading near the bottom of the results sheet. This area of the 
sheet is shown below. For example, according to this recommendation, the first stress level 
of the test should be combination of 360 K and 10 V, and about 29 units (or 19.4% of the 
total number of available units) should be tested at that level. 

 

Evaluating the Plan 

The reliability group may also wish to evaluate the test plan in relationship to other test goals. 
For example, the company may desire a test that will estimate the B10 life with 90% confidence 
and a bounds ratio of 2 or less. The control panel can help you decide whether this can be 
achieved with the given test plan and with the specified sample size. To use the control panel, 
follow the steps outlined below. 

1. From the Solve for drop-down list in the Input area of the control panel, select Bounds 
Ratio. 
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2. In the Confidence Level input field, enter 0.90. 

3. In the Sample Size input field, enter 150, which is the total number of units that will be 
tested, according to the current test plan. 

4. Click the Calculate Result icon inside the control panel to solve for the bounds ratio. 

In this example, the bounds ratio is calculated to be 1.3575, which is better than the company's 
desired ratio of 2. As a result, the engineers may consider using a smaller sample size in order 
to plan a more efficient test. For example, if they entered 40 in the Sample Size field and then 
clicked Calculate Result again, the calculated bounds ratio would be 1.8073, which suggests 
that 40 units may be sufficient for the purposes of the test. 

Repairable Systems Test Design Folio 

For reliability growth data analysis only. 

In a zero-failure reliability demonstration test (RDT), the engineer aims to demonstrate a 
specified target metric (e.g., an MTBF of at least 500 hours with 90% confidence) by testing a 
specified number of systems for a predetermined time. If no failures occur, then the target 
metric is demonstrated. This method has been adapted for scenarios where the target metric 
can be demonstrated even if some failures occur, so long as a specified number of allowable 
failures is not exceeded. For example, in a demonstration test where the number of allowable 
failures is 2, the target metric is demonstrated if no more than 2 failures occur during the test. 

The repairable systems test design folio can assist you in using the NHPP model to design a 
demonstration test for repairable systems by solving for either the test time required per 
system or the number of systems that must be tested. To create a test design folio, choose 
Home > Insert > Repairable Systems Test Design. 

 

IMPORTANT: The repairable systems test design folio in Weibull++ (known as the "Repairable 
Systems - Design of Reliability Tests" tool in prior versions of RGA) is based on the non-
homogeneous Poisson process (NHPP), so it is suitable only for designing tests involving 
repairable systems. For tests involving non-repairable items, use the RDT utility, which provides 
four test design methods that are suitable for non-repairable systems: parametric binomial, 
non-parametric binomial, exponential chi-squared and non-parametric Bayesian. 

Follow the steps outlined next to use the utility: 
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• In the Calculation Options area on the control panel, specify the Units of measurement for 
the calculation. Note that "Assumes Beta = 1" is displayed in this area, which means that 
the utility assumes the failure intensity is constant during the test. 

• Select the Display systems as integers option on the control panel if you will be solving for 
the number of systems to test and want to round the calculation up to the nearest whole 
number (e.g., any number greater than 4 would both be displayed as 5). 

• In the What metric would you like to demonstrate? area on the RDT sheet, specify the 
metric that you intend to demonstrate with the test you are designing. 

• In the Metric drop-down list, specify whether you will demonstrate the system's MTBF 
or failure intensity. 

• The Demonstrate this [metric] field allows you specify the value of the metric you wish 
to demonstrate. For example, if you wish to demonstrate an MTBF of 1,000 hours, you 
would enter 1,000 in this field. 

• The With this confidence level (%) field allows you to specify, as a percentage, the 
confidence level at which the target metric will be demonstrated. For example, if you 
wish to demonstrate with 90% confidence that the MTBF is at least 1,000 hours, enter 
90 in this field. 

• In the Solve for this value area, specify what value you are using the RDT utility to solve for. 
The Value drop-down list allows you to choose whether you are solving for the test time 
(per system) that will be required to demonstrate the target metric, or the number of 
systems that you'll need to test. 

• If you select Required test time, you'll enter the number of systems that will be tested 
in the next input field. 

• If you select Required number of systems, you'll enter the test time in the next input 
field. 

In the last input field, enter the maximum number of failures that you will allow to occur 
during the test. For example, if you want to demonstrate the target metric with 2 failures or 
less (e.g. two systems fail once, but no other failures occur), then you would enter 2 in this 
field. 

After you have made all of the required inputs, click the Calculate icon to solve for the specified 
value. To examine other possible test scenarios, you can also create a table and plot based on 
the inputs. 

See Repairable Systems RDT Example. 
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RDT TABLE AND PLOT 

For reliability growth data analysis only. 

In addition to calculating a single value (i.e., required test time per system or number of 
systems to test), the repairable systems test design folio also allows you to create a table and 
plot that provide quick ways to consider many possible test plan scenarios without having to 
perform each calculation individually. Depending on what you select to solve for, the table will 
display a range of test duration values as a function of sample size and number of allowable 
failures, or it will display a range of required sample size values as a function of test time and 
number of allowable failures. The plot will graphically display the results with one line for each 
number of allowable failures. 

Follow the steps outlined below to create the table. 

• Open the repairable systems test design folio and solve for required test time or number of 
systems. 

• Click the Create RDT Table icon on the control panel. 

 

• The Table of RDT sheet will appear. In the Calculation Options area, select which value you 
wish to have the table solve for. 

• Test time given number of systems solves for the test time given different numbers of 
systems that could be tested. When you select this option, the Number of Systems 
Range area will require that you enter the smallest and largest integer that you want to 
consider, along with an increment to determine how many values in between will also 
be calculated. For example, if you specify 10 to 20 with a increment of 2, the table will 
show results for 10, 12, 14, etc. 

• Number of systems given test time solves for the number of systems that must be 
tested given a different test times. When you select this option, the Test Time Range 
area will require that you enter a starting test time, an ending test time and an 
increment value by which the test time will increase. 

For either option, you must enter starting, ending and increment values for the number of 
allowable failures in the Number of Failures Range area. A demonstration test will fail to 
demonstrate the target metric if the number of failures exceeds this number. Thus, if you 
are designing a zero-failure test, then the test will demonstrate the target metric only if no 
failures occur. 
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• Click Calculate to create the table. 

 

An example table is shown next. 

 

You can use this table (and the plot of the results shown below) to consider different test 
scenarios. For example, according to the fifth cell in the column called "# of Systems for 0 
Failures," if you tested 5 systems (i.e., 4.0236 rounded up to the nearest whole number) for 
4,000 hours each and no failures occurred, then the test would demonstrate the target 
metric. 

• To view a plot of the table results, click the Plot icon. 

 

Each colored line in the plot corresponds to a specific number of failures; this depicts how 
the allowed number of failures influences the test time and the required sample size. To 
choose which lines to display in the plot, use the options in the Select Failures area on the 
control panel. In the following plot, lines for all numbers of allowable failures considered in 
the table (i.e., 0 to 5) are shown. 
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REPAIRABLE SYSTEMS TEST DESIGN FOLIO EXAMPLE 

For reliability growth data analysis only. 

This topic presents an example of how to use the repairable systems test design folio to 
calculate the number of repairable systems needed to show a specified MTBF at a specified 
confidence level in a zero-failure demonstration test. An RDT table and plot will also be created 
in order to examine a variety of different test scenarios.  

At the end of a reliability growth testing program for a repairable system, a manufacturer wants 
to demonstrate that a new product has achieved an MTBF of 10,000 hours with 80% 
confidence. The available time for the demonstration test is 4,000 hours for each system under 
test. Assuming zero failures are allowed, determine the required number of systems to be 
tested in order to demonstrate the desired MTBF. 

Follow the steps outlined next to solve for the required number of systems. 
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• Create a new test design folio by choosing Home > Insert > Repairable Systems Test 
Design. 

 

• On the control panel, specify that time values will be in hours, and select to round up the 
number of systems to the next whole number (e.g., any number above 4 will be displayed 
as 5), as shown next. 

 

• On the input sheet, specify that you wish to demonstrate an MTBF of 10,000 hours with a 
confidence level of 80%, as shown next. 

 

• Then specify that you wish to use the folio to solve for the Required number of systems 
that must be tested to demonstrate this value, given an available test time of 4,000 hours 
and with 0 failures allowed, as shown next. 

 

• After you select the Display systems as integers option on the control panel, click the 
Calculate icon to view the result. 

 

According to the folio, if you test 5 systems for 4,000 hours and no failures occur, then you 
will demonstrate an MTBF of at least 10,000 hours with 80% confidence. 
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• You can use the RDT table to compare the required test times given different numbers of 
systems and different numbers of allowable failures. To generate an RDT table using these 
inputs, click the Create RDT Table icon. 

 

• Use the default settings on the control panel of the Table of RDT sheet. According to these 
settings, the table will calculate the test time required to demonstrate the target metric. 
The tool will consider different numbers of systems that could be tested, from 1 to 10 in 
increments of 1. And the number of allowable failures will range from 0 to 5, also in 
increments of one. 

 

• Click the Calculate icon to recreate the table. 

 

The table appears next. For example, by looking in the second column, you can investigate 
the test times required in a zero-failure demonstration test, given different numbers of 
systems being tested. 
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• To show the table's results in a plot, click the Plot icon. 

 

Like the RDT table, the plot shows the relationship between number of systems and test 
time, given different numbers of allowable failures. To choose which lines to display in the 
plot, use the options in the Select Failures area on the control panel. In the following plot, 
lines for all numbers of allowable failures considered in the table (i.e., 0 to 5) are shown. 



Chapter 11: Tests and Planning Folios 

Weibull++ 2020 User's Guide 977 

 

 

Measurement Systems Analysis 

In order to successfully conduct design of experiments, it is important to use an adequate 
system for recording measurements (where a "measurement system" includes the operators 
who perform the measurements, the measuring device that they used and their method for 
using the device). Weibull++'s DOE feature includes three tools for evaluating and comparing 
measurement systems. You can use these tools to: 

• Help you determine whether you should use a particular measuring device. 

• Compare one measuring device to another. 

• Compare a measuring device's performance before and after a repair. 

• Investigate the sources of variation in the measurement results (e.g., variation could result 
from differences in how operators use a measuring device). 
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The three tools for measurement systems analysis are described next: 

• The linearity and bias folio is used to estimate a measuring device's accuracy (i.e., the 
extent to which the device underestimates or overestimates the measured values, across 
the device's expected operating range). 

• The gage R&R folio is used to estimate a measurement system's precision (i.e., the variation 
in measurements that can be expected when the same part is measured repeatedly using 
the same measuring device). 

• The gage agreement folio is used to compare the accuracy and precision of two systems. 

To add one of these folios to your project, right-click the Test and Planning folder in the current 
project explorer or choose Home > Insert then choose the folio type (Linearity and Bias, Gage 
R&R, or Gage Agreement). 

The ReliaWiki resource portal provides more information on measurement systems analysis at: 
http://www.reliawiki.org/index.php/Measurement_System_Analysis. 

Linearity and Bias Folio 

The linearity and bias folio is used to estimate the accuracy of a measuring device, or gage. 
Accuracy is defined in terms of bias and linearity. 

• Bias is the difference between the "true" value of a measured part and the observed 
average. For example, if the reading of a scale is always much higher than the actual weight 
of the measured object, then the scale has a bias issue. 

• Linearity is the relationship between a gage's bias and the "true" value of the measured 
part. For example, if the bias of a scale increases rapidly as the weight of the measured 
object increases, then the scale has a linearity issue. 

To add a linearity and bias folio to your project, choose Home > Insert > Linearity and Bias, or 
right-click the Test and Planning folder on the current project explorer and choose Add 
Measurement Systems Analysis > Linearity and Bias on the shortcut menu. 

 

Linearity and Bias Folio Control Panel 

The linearity and bias folio control panel allows you to control the settings for analyzing the 
measurements obtained from the gage under investigation. It also displays the results of the 
analysis. This topic focuses on the Main page and Analysis page of the linearity and bias folio 

http://www.reliawiki.org/index.php/Measurement_System_Analysis
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control panel, which contains most of the tools you will need to perform the analysis. For more 
information about the control panel in general, see Control Panels. 

Control Panel Main Page 

1. The Settings area on the control panel is used to view the settings and status of the 
analysis. To configure the settings used in the analysis, click the blue text. The risk level 
setting is accessible on the Analysis Settings page of the control panel. 

  

In this example: 

• The specified risk level is 10%. 

• "Analyzed" is shown in green, which indicates that the current response data has been 
analyzed using the current settings. Otherwise, this would show "Modified" in red. 

• The last row indicates that the analyzed data consists of 10 observations. 

2. The Analysis Summary area is shown when the current measurement data has been 
analyzed using the current settings. This area can display the following values: 

 

• % Linearity is the percentage of increase of the process variation due to gage linearity. 
For example, a % Linearity of 5.3 means that the observed variation in measurements 
will be 5.3% greater than the variation of the parts themselves (i.e., the "true" process 
variation). 

• Linearity represents the variation of the measurements due to the gage linearity. To 
calculate this value, you must specify the process standard deviation on the Analysis 
Settings page of the control panel. 
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• Bias is the difference between the "true" value of a measured part and the observed 
average. A positive bias means the gage overestimates. A negative bias means the gage 
underestimates. 

• % Bias is the ratio of the bias to the process variation. To calculate this value, you must 
specify the process standard deviation on the Analysis Settings page of the control 
panel. 

Click the View Analysis Summary icon in this area to view the details of the analysis results. 

Folio Tools 

The folio tools are arranged on the left side of the control panel. Use these tools to configure 
your analysis and experiment with the analysis results. 

  Calculate analyzes the measurements and displays a summary of the results on the 
control panel. 

  Plot creates a plot based on the analysis. If you click this icon before the current data 
set has been analyzed, an analysis will be performed automatically. (See Linearity and Bias 
Folio Plots.) 

  View Analysis Summary opens a window that contains detailed information about 
current and past analysis results. 

Control Panel Analysis Settings Page 

The Analysis page of the linearity and bias folio control panel includes the risk level and process 
standard deviation (if any) that will be used for the analysis. 

• The Risk Level, or alpha value, is a measure of the risk that the analysis results are incorrect 
(i.e., alpha = 1 - confidence level). 

 

• The Process Standard Deviation area allows you to specify the standard deviation of the 
manufacturing production process (i.e., the standard deviation of the parts). When the 
check box is selected, the software will multiply the value by 6 to obtain the process 
variation (e.g., if the diameter in centimeters is being measured and the standard deviation 
is 1, then the process variation is 6 centimeters). When this value is provided, the analysis 
results will include Linearity and % Bias values. 



Chapter 11: Tests and Planning Folios 

Weibull++ 2020 User's Guide 981 

 

 

Linearity and Bias Folio Data Tab 

The Data tab of the linearity and bias folio contains a control panel and a sheet with the 
following four columns for entering data: 

• Part is the identifier for the part that was measured.  

• Reference is the "true" value of the measured part (also called the master value). If the true 
value is unknown, the reference value can be the average of several measurements 
obtained via the most accurate measuring equipment available. 

• Reading is the measurement obtained from the gage under investigation. 

• Trial is used to help you keep track of multiple trials that are used in a particular study. For 
example, the first measurement of every part would be considered trial #1, the second 
measurement trial #2, and so on (as shown in the example data set below). These values 
are not used in the calculations. 

As an example, suppose a gage was used to measure the diameter of two objects. The first 
object is 2 inches in diameter, and the second is 4 inches. Each object was measured five times. 
The resulting data set is shown next. For example, the first row shows that Part 1 has an actual 
diameter of 2 inches, but the gage produced a measurement of 1.95 inches. 

 

Linearity and Bias Folio Analysis Results 

When accessed from a linearity and bias folio, the Analysis Summary window will contain 
detailed information about the gage's bias and linearity. 
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If the current response data has been analyzed, you can open the window by clicking the View 
Analysis Summary icon on the control panel. 

 

If the current response data has not been analyzed, the icon will still be available so you can 
view the folio's analysis history. 

Select an item in the Available Report Items panel to display it on the spreadsheet. Each item is 
described next. 

Analysis Results 

The Analysis of Variance (ANOVA) table provides general information about the effects of the 
reference value on the bias. 

ANOVA Table Columns 

• Source of Variation is the source that caused the difference in the measurements. 
Sources displayed in red are considered to be significant. 

• The number of Degrees of Freedom for the Reference is the number of regression 
coefficients for the reference value in the model. The number of degrees of freedom 
for the Residual is the total number of observations minus the number of parameters 
being estimated. 

• Sum of Squares is the amount of difference in measurements caused by this source of 
variation. 

• Mean Squares is the average amount of difference caused by this source of variation. 
This is equal to Sum of Squares/Degrees of Freedom. 

• F Ratio is the ratio of Mean Squares of this source of variation and Mean Squares of 
pure error. A large value in this column indicates that the difference in the output 
caused by this source of variation is greater than the difference caused by noise (i.e., 
this source affects the output). 

• P Value (alpha error or type I error) is the probability that an equal amount of variation 
in the measurements would be observed in the case that this source does not affect 
the output. This value is compared to the risk level (alpha) that you specify on the 
Analysis Settings page of the control panel. If the p value is less than alpha, this source 
of variation is considered to have a significant effect on the output (e.g., if Reference 
has a significant effect, then the gage has a linearity issue). In this case, the term and its 
p value will be displayed in red. 



Chapter 11: Tests and Planning Folios 

Weibull++ 2020 User's Guide 983 

 

• The following values are shown underneath the ANOVA table: 

• S is the standard error of the noise. It represents the magnitude of the difference 
caused by noise. 

• R-sq is the percentage of total difference in the measurements that is attributable 
to differences in the reference values. It is equal to Sum of 
Squares(Reference)/Total Sum of Squares. 

• R-sq(adj) is an R-sq value that is adjusted for the number of parameters in the 
model. 

The Linearity Analysis table provides specific information about the linearity of the 
measurement device.  

Linearity Analysis Table Columns 

• Term is the intercept or slope of the fitted regression model. The slope represents the 
measurement device's linearity. Terms displayed in red are considered to be significant 
(e.g., if "Slope" is displayed in red, then the device has a linearity issue). 

• Coefficient is the regression coefficient of the term, which represents the contribution 
of the term to the variation in the response. 

• Standard Error is the standard deviation of the regression coefficient. 

• Low Confidence and High Confidence are the lower and upper confidence bounds on 
the regression coefficient. 

• T Value is the normalized regression coefficient, which is equal to Coefficient/Standard 
Error. 

• P Value (alpha error or type I error) is the probability that an equal amount of variation 
in the output would be observed in the case that this term does not affect the output. 
This value is compared to the risk level (alpha) that you specify on the Anaysis Settings 
page of the control panel. If the p value is less than alpha, this source of variation is 
considered to have a significant effect on the output. In this case, the term and its p 
value will be displayed in red. 

• Additional values will be shown underneath the Linearity Analysis table: 

• If you specified the process standard deviation on the Analysis Settings page of the 
control panel, these values will be shown. 
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• Process Variation is the total variation of the parts' reference values (i.e., the 
"true" process variation). It is equal to the specified process standard deviation 
* 6. 

• Linearity is the variation in measurements due to gage linearity. 

• The % Linearity value is always shown. It is the percentage of the variation in 
measurements that is due to gage linearity. 

The Bias Analysis table provides specific information about the bias of the measurement 
device. 

Bias Analysis Table Columns 

• Reference is the reference value entered in the data sheet. It represents the "true" 
value of the part when it was measured. If a reference value is displayed in red, then 
there is a significant bias for measurement taken at that value. 

• Bias is the average bias for measurements at the given reference value. 

• % Bias is the ratio of the bias to the process variation at the given reference value. This 
column is available only when the process standard deviation is specified on the 
Analysis Settings page of the Data tab control panel. 

• Std. of Mean is the standard deviation of the bias at each reference value. If there are 
multiple parts with the same reference value, it is the pooled standard deviation of all 
the parts. 

• T Value is the ratio of the absolute value of the Bias column and the Std. of Mean 
column. It is used to calculate the p value. 

• P Value is calculated from the T value and the corresponding degree of freedom for 
each reference value. If the p value is smaller than the risk level specified on the 
Analysis Settings page of the control panel, then the corresponding row has significant 
bias. In this case, the p value will be shown in red. 

• Average shows the mean of all the values in the given column. If "Average" is displayed 
in red, then the gage's average bias is significant. 

Linearity and Bias Folio Plots 

The following plots are available in the linearity and bias folio. They allow you to visually assess 
the accuracy of the measurement system. For general information on working with plots, see 
Plot Utilities. 
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• The Process Variation bar chart is available only when you specify the process standard 
deviation on the Settings page of the Data tab control panel. This chart shows the 
percentage of the observed process variation (i.e., total variation in the parts plus variation 
due to linearity/bias) that is due to linearity and the percentage due to bias. 

• The Bias vs. Part plot shows the individual and average bias values sorted by the measured 
parts. Individual bias values (i.e., the differences between the reference values and 
particular measurements) are plotted as blue points, and average values (i.e., the 
differences between the reference values and the observed averages) are plotted as red 
squares. A blue dotted Zero Value Line marks the point at which there is no bias. You can 
use this plot to examine how the bias of the system (and the variation of the observed 
values) varies depending on the part. 

• The Linearity and Bias plot shows the individual and average bias values versus the 
reference values. The blue dotted Zero Value Line marks the point at which there is no bias. 
In addition, a regression line is fitted to the average bias points, showing the relationship 
between bias and reference (i.e., linearity). Confidence bounds are also drawn on the fitted 
line. The confidence level of the bounds is based on the risk level entered on the Settings 
page of the Data tab control panel (e.g., if the risk level is 0.1, then 90% two-sided upper 
and lower bounds are drawn on the line). 

For example, the following plot shows that, as the reference value increases, the bias 
increases (i.e., there is linearity in the gage). In addition, you can see that when the 
reference value is 2, there is almost no bias (i.e., the average bias is almost zero). 
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Linearity and Bias Folio Example 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 

The name of the example project is "Gage Linearity and Bias Study." 

In this example, a gage linearity and bias study was conducted to evaluate a gage that is used to 
measure the diameter of holes. The study will assess the gage's linearity, which represents its 
accuracy across the expected range of measurements, and its bias, which represents the 
difference between the gage's measurements and the actual value of the measured part. This 
will be done by using the gage to measure holes in an NIST standard coupon, where the true 
diameter of each hole is known. If the gage is found to be unacceptable, a new gage will be 
evaluated. 
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The data set or the study is given below and has been entered in the example folio. The first 
thirteen rows of the data sheet are shown next. 

 

In the first row, you can see that the first part (Part 1) has an actual value of 2, and the first 
measurement of the part was 1.95. The Trial column (which is not used in the calculations) was 
used to keep track of how many times each part was measured, and in this case you can see 
that Part 1 was measured a total of 10 times. If you examine all the data points in the example 
project, you will see that a total of five parts were measured, and some were measured fewer 
than 10 times. To avoid any variation in measurement that could be due to different operators, 
all measurements in this study were performed by the same operator. 

On the Analysis Settings page of the control panel, you can see that a risk level of 0.1 (10%) will 
be used to determine whether there is a statistically significant bias or linearity in the gage. In 
addition, you can see that a process standard deviation of 1 was specified. 
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To analyze the data, click the Calculate icon. 

 

The following summary of results will appear on the control panel. 

 

• % Linearity is the percentage of increase of the process variation due to gage linearity. In 
this example, the observed variation in measurements will be 3.5813% greater than the 
variation of the parts themselves (i.e., the "true" process variation). Because this is a 
relatively small value, linearity is not considered a problem for this gage. 

• Linearity represents the variation of the measurements due to the gage linearity. To 
calculate this value, you must specify the process standard deviation on the Analysis 
Settings page of the control panel. 

• Bias is the difference between the "true" value of a measured part and the observed 
average. A positive bias means the gage overestimates. A negative bias means the gage 
underestimates. 
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• % Bias is the ratio of the bias to the process variation. To calculate this value, you must 
specify the process standard deviation. The lower the % Bias, the better the gage. In this 
case, the % Bias is 2.0882%, which is also small enough to consider the bias acceptable. 

The bias values for each reference and the overall study can be seen by clicking the View 
Analysis Summary icon on the control panel. The results of the bias analysis are shown next. 

 

The p values show that some of the biases are significant when compared to the variation of 
the measured standard coupon. This is understandable since the variation of the standard 
coupon is usually very small. However, when compared to process variation, the average bias of 
this gage (i.e., average % bias) is still relatively small, so the gage is considered acceptable. 

Gage R&R Folio 

The gage R&R folio is used to estimate the precision of a measurement system, or the system's 
ability to produce the same value when used to measure the same part multiple times. 
Precision is defined in terms of repeatability and reproducibility (R&R). 

• Repeatability is the variation in measurements when the same operator measures the same 
part multiple times with the same gage. If this variation is too high, then the gage may be 
unacceptable. 

• Reproducibility is the variation in measurements when different operators measure the 
same part multiple times with the same gage. If this variation is too high, then the 
operators are not using the gage in the same way. 

To add a gage R&R folio to your project, choose Home > Insert > Gage R&R, or right-click the 
Test and Planning folder on the current project explorer and choose Add Measurement 
Systems Analysis > Gage R&R on the shortcut menu. 
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Gage R&R Folio Data Tab 

The Data tab of the gage R&R folio contains a control panel and a sheet with the following four 
columns for entering data: 

• Part is the identifier for the part that was measured.  

• Operator is the identifier for the person who performed the measurement. 

• Reading is the measurement obtained from the gage under investigation. 

• Trial is used to help you keep track of multiple trials that are used in a particular study. For 
example, in a crossed gage R&R study, the first measurement of a part by an operator 
would be trial #1, the second measurement by the same operator trial #2, and so on. These 
values are not used in the calculations. 

As an example, suppose a scale used to weigh two parts (in pounds). Part 1 is measured four 
times: twice by Operator A and twice by Operator B. Part 2 is also measured twice by each 
operator. The resulting data is shown next. For example, the first row shows that Part 1 was 
measured by Operator A, who obtained a measurement of 9.856 pounds. 

 

Gage R&R Folio Control Panel 

The gage R&R folio control panel allows you to control the settings for analyzing the 
measurement system data. It also displays the results of the analysis. This topic focuses on the 
Main page and Analysis page of the gage R&R folio control panel, which contains most of the 
tools you will need to perform the analysis. For more information about the control panel in 
general, see Control Panels. 
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Control Panel Main Page 

1. The Settings area of the control panel displays the settings and status of the analysis. To 
configure the settings used in the analysis, click the blue text. The risk level and design type 
settings are accessible on the Analysis Settings page of the control panel. 

  

In this example: 

• The specified risk level is 10%. 

• A crossed (rather than nested) gage R&R design type will be used. This means each 
operator will measure the same part multiple times. 

• "Analyzed" is shown in green, which indicates that the current response data has been 
analyzed using the current settings. Otherwise, this would show "Modified" in red. 

• The last row indicates that the analyzed data consists of 27 observations. 

2. The Analysis Summary area is shown when the current measurement data has been 
analyzed using the current settings. This area breaks down the percentage of measurement 
variance due to repeatability, reproducibility and the measured part. 

 

• Repeatability is the variance due to properties of the gage. 

• Reproducibility is the variance due to the operator or the interaction between the 
operator and the measured parts. It is the sum of these variance values. 
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• Operator is the variance due to the operators' different ways of performing 
measurements on the same parts. 

• Operator * Part is the variance due to the operators' different ways of performing 
measurements on different parts. To calculate this result, you must go to the 
Analysis Settings page of the control panel and select to include it in the analysis. 

• Part is the variance due to differences in the part being measured (i.e., the part-to-part 
variance). 

• Total Gage R&R is the total of repeatability and reproducibility. 

• Total Variation is the total of the part-to-part variance, repeatability and 
reproducibility. 

Click the View Analysis Summary icon in this area to view the details of the analysis results. 

Folio Tools 

The folio tools are arranged on the left side of the control panel. Use these tools to configure 
your analysis and experiment with the analysis results. 

  Calculate analyzes the measurement data and displays a summary of the results on 
the control panel. 

  Plot creates a plot based on the analysis. If you click this icon before the current data 
set has been analyzed, an analysis will be performed automatically. 

  View Analysis Summary opens a window that contains detailed information about 
current and past analysis results. 

Control Panel Analysis Settings Page 

The Analysis Settings page of the gage R&R folio control panel includes the following settings. 

• The Risk Level, or alpha value, is a measure of the risk that the analysis results are incorrect 
(i.e., alpha = 1 - confidence level). 
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• The Gage R&R Design Type area allows you to select which type of gage R&R design you 
will use. 

 

• With the Crossed design type, each operator measures the same part multiple times. 
For example, if Operator A measures Part 1 twice and Part 2 twice, and Operator B 
does the same, then the design is crossed. This design type is preferable when 
individual parts can be measured repeatedly. 

• With the Nested design type, each part is measured multiple times by only one 
operator. For example, if Operator A measures Part 1 twice and Part 2 twice, and 
Operator B measures Part 3 twice and Part 4 twice, then the design is nested. In this 
case of destructive testing, this type of design assumes that all the measured parts of 
the same type (e.g., Part 1) are similar enough to be considered identical. 

• The Gage R&R Model area allows you select whether the analysis model will include terms 
that represent the interaction between operators and parts. This option is available for 
crossed designs only. 

  

• Process Tolerance Specification area allows you to specify the range of values that are 
acceptable for the measured product. For example, if the specification for a part is 14.5 ± 
0.5 µm, then the process tolerance specification is 1 µm. When this value is provided, the 
calculation results will include the ratio of measurement variation to the process tolerance. 

 

Gage R&R Folio Analysis Results 

When accessed from a gage R&R folio, the Analysis Summary window will contain detailed 
information about the gage's precision. 

If the current response data has been analyzed, you can open the window by clicking the View 
Analysis Summary icon on the control panel. 
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If the current response data has not been analyzed, the icon will still be available so you can 
view the folio's analysis history. 

Select an item in the Available Report Items panel to display it on the spreadsheet. Each item is 
described next. 

Analysis Results 

The Analysis of Variance (ANOVA) table provides general information about the effects of the 
operator on the measurements. 

ANOVA Table Columns 

• Source of Variation is the source that caused the difference in the measurements. 
Part(Operator) is the part variation within operators, and it is shown only for nested 
designs. 

• The number of Degrees of Freedom is the number of regression coefficients in the 
regression model for this source of variation. 

• Sum of Squares is the amount of difference in measurements caused by this source of 
variation. 

• Mean Squares is the average amount of difference caused by this source of variation. 
This is equal to Sum of Squares/Degrees of Freedom. 

• F Ratio is the ratio of Mean Squares of this source of variation and Mean Squares of 
pure error. A large value in this column indicates that the difference in the output 
caused by this source of variation is greater than the difference caused by noise (i.e., 
this source affects the output). 

• P Value (alpha error or type I error) is the probability that an equal amount of variation 
in the measurements would be observed in the case that this source does not affect 
the output. This value is compared to the risk level (alpha) that you specify on the 
Analysis Settings page of the control panel. If the p value is less than alpha, this source 
of variation is considered to have a significant effect on the output. In this case, the 
term and its p value will be displayed in red. 

The Gage Variance Results table shows the variance and standard deviation of variance 
components.  

Gage Variance Results Table Columns 
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• Source is the source of variation in the measurements. Total Gage R&R is the sum of 
Repeatability and Reproducibility, and Total Variation is the sum of Total Gage R&R and 
Part. Part(Operator) is the part variation within operators and is shown for nested 
designs. 

• The Variance Results section includes these columns: 

• Variance is a measure of how far the measurements are spread out due to this 
source of variation. 

• Variance Contribution is the percentage of variance that is due to this source of 
variation. 

• The Standard Deviation section includes these columns: 

• Standard Deviation is the standard deviation that is due to this source. 

• Standard Deviation Ratio (%) is the percentage of the total standard deviation that 
is due to this source. 

• Study Variation represents the spread of values that could result from this source 
of variation. It is equal to 6 * the standard deviation. 

• Study Variation to Tolerance Ratio is the Study Variation divided by the process 
tolerance specification entered on the Analysis Settings page of the control panel. 
Thus, a ratio of 100% means the variation in measurements is equal to the 
acceptable range of part values. 

Gage R&R Folio Plots 

The following plots are available in gage R&R folios, depending on whether you are using a 
crossed or nested design. They allow you to visually display the data and examine the precision 
of the measurement system. For general information on working with plots, see Plot Utilities. 

• The Variation Pie includes several pie charts that allow you to visually examine the sources 
of variation in the measurements. 

• The Total Variation Component chart displays the ratio of each source of variance to 
the total variance. 

• The Gage and Part Variation chart displays the ratio of the total gage variance 
(reproducibility + repeatability) to the total variance, and the ratio of the part variance 
to the total variance. 
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• The Gage R&R Variation chart displays the percentage of repeatability and 
reproducibility to the total gage variance. 

• The Gage Reproducibility chart is available only for crossed designs with the operator * 
part interaction included in the model. It further decomposes reproducibility to 
operator variance and operator-part interaction variance. 

• The Run Chart is available only for crossed designs. Each column shows the measurements 
that were taken of one part, and the measurements are grouped and color-coded 
according to the operator who performed the measurements. The blue dotted Mean line is 
the mean of all the measurements. You can use this plot to look for trends that depend on 
the operators. For example, this chart could show you that one operator's average 
measurement is biased to low, or that one part was measured in inconsistent ways. 

• The Variation Components bar chart shows the contribution of different sources of 
variation to the total measurement variation. You can use this chart to compare the Part 
variation to variation that is due to the gage (Repeatability), the operators (Reproducibility) 
or the sum of both (Total Gage R&R). 

• The Measurement by Part plot displays the measurements grouped by part. (With nested 
designs, the x-axis label "Part(Operator)" indicates that one operator measured each part.) 
The connected red dots in each group are the mean measurements for each part. You can 
use this plot to study how the variation and mean values depend on the parts. For example, 
you might conclude from this plot that measurements for one part have less variation than 
that of the other parts. 

• The Measurement by Operator plot displays the measurements grouped by operator. The 
connected red dots in each group are the mean measurements from each operator. You 
can use this plot to study how the variation and mean values depend on the operator. For 
example, you might conclude from this plot that one operator tends to record higher values 
than the others. 

• The following charts are used to assess the system's reproducibility. The control limits are 
marked with red dotted lines near the top and bottom of the chart. If one operator is 
outside the control limits, then that operator's method differs from the others. If all the 
operators have at least one measurement outside the limits, then the measurement system 
is overly sensitive to operator technique and has a reproducibility issue. 

• The R-Chart by Operator ("R" stands for "Range") is available when 10 or fewer 
measurements for each part are included. The blue dotted Mean line is the average 
range of measurements for all operators. Each blue dot represents the range of 
measurements for a particular part when measured by a particular operator. 
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• The S-Chart by Operator ("S" stands for "Standard Deviation") is available when more 
than 10 measurements of each part per operator are included. The horizontal blue line 
is the average standard deviation of measurements for all operators. Each blue dot 
represents the standard deviation of measurements for a particular part when 
measured by a particular operator. 

• The X-Bar by Operator plot shows how the mean reading changes across the parts. The 
mean readings are grouped by operator. The blue dotted Mean line is the overall mean of 
all the measurements. Red dotted lines mark the control limits. Since the control limits are 
calculated using the repeatability variation, most data points should fall outside the control 
limits. If they do not, then the system has a repeatability issue. 

• The Operator * Part Interaction plot is similar to the X-bar by operator plot, except the 
lines for each operator are color-coded and placed on top of each other. This plot is useful 
for assessing whether the operator * part interaction has a significant effect on the 
measurements. If the operator lines are the same shape (i.e., the segments are parallel to 
each other), the effect is not significant. 

Gage R&R Folio Example 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 

The name of the example project is "Gage R and R Study." 

A gage R&R study was conducted using a crossed experiment, where each operator measures 
each part multiple times. The goal of the study is to determine whether the operators are using 
the gage in a consistent manner, and whether the gage itself is sufficiently precise. The data set 
is given in the "Gage R and R Crossed Design" folio. The product tolerance is 2,000 (i.e., the 
range of acceptable values for the product is 2,000). We want to evaluate the precision of this 
gage using the following three ratios: 

• The precision-to-tolerance ratio (or P/T ratio) is the variation due to the measuring system 
(i.e., the operators and the gage) divided by the product tolerance. 

• The gage-to-part variation ratio is the variation due to the measuring system divided by the 
variation in the parts themselves (i.e., part-to-part variation). 

• The gage-to-total variation ratio is the variation due to the measuring system divided by 
the total variation in measurements. 
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The data set for this example has been entered on the Data tab of the folio. There are 3 parts 
and 3 operators in the experiment. Each operator measured each part 3 times. The first 15 rows 
are shown next. 

 

For example, you can see that Operator A measured Part 1 three times and measured Part 2 
three times. Each measurement is shown in the Reading column. 

On the Analysis Settings page of the control panel, the risk level and design type are specified. 
In addition, the operator * part interaction is selected to be included in the analysis, and the 
process tolerance specification is specified. 
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Click the Calculate icon to analyze the data. 

 

A summary of the results will appear on the Main page of the control panel. It shows a 
breakdown of the variance for different sources of measurement variation. 
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Click the View Analysis Summary icon to view the results in detail. The ANOVA table indicates 
that both the part and operator have a significant influence on the measurement variation. 

 

The P/T ratio in the Gage Variance Results table is in the last column in the Total Gage R&R 
row. The calculated value is 47.85%, which is much higher than the recommended 10% 
maximum. 

 

The gage-to-part variation ratio is the standard deviation for the Total Gage R&R (i.e., total 
variation due to the measurement system) divided by the standard deviation for the Part (i.e., 
part-to-part variation). 

159.488/68.6006 = 232.49% 

The gage-to-total-variation-ratio is the standard deviation for Total Gage R&R divided by the 
standard deviation for Total Variation. 

159.488/173.6159 = 91.86% 

Clearly, all these ratios are too large. As a result, the experiments concluded that the operators 
should be trained so they perform measurements more consistently, and a better gage may 
need to be used. 
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To further examine the breakdown of difference sources of measurement variation, click the 
Plot icon and view the variation pie charts to see the contribution of each variance component. 
The charts are shown next. 

 

Gage Agreement Folio 

The gage agreement folio is used to compare the accuracy and precision of two measuring 
devices (i.e., gages). For example, this folio could be useful if you wish to determine whether 
replacing an old gage with a new one is possible without sacrificing the accuracy and precision 
of the measurements. (To perform a detailed analysis of the accuracy of a gage, use the 
linearity & bias folio. For precision, use the gage R&R folio.) 

Note: When comparing the precision of two systems, only the repeatability (i.e., variation due 
to properties of the gage) is compared. To eliminate variation due to properties of the 
operators (i.e., reproducibility), make sure all the measurements used in the study are 
performed by the same operator. 
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To add a gage agreement folio to your project, choose Home > Insert > Gage Agreement, or 
right-click the Test and Planning folder on the current project explorer and choose Add 
Measurement Systems Analysis > Gage Agreement on the shortcut menu. 

 

Gage Agreement Folio Data Tab 

The Data tab of the gage agreement folio contains a control panel and a sheet with the 
following four columns for entering data: 

• Part is the identifier for the part that was measured.  

• Measuring Device is the identifier for the gage that was used to obtain the measurement. 

• Reading is the measurement obtained from the gage under investigation. 

• Trial is used to help you keep track of multiple trials that are used in a particular study. For 
example, the first measurements of a part by a particular gage would be the first trial, the 
second measurement of the same part by the same gage the second trial, and so on. 

As an example, suppose two scales are being compared for accuracy and precision. To compare 
them, three parts are weighed (in pounds) by both scales. Part 1 is measured four times: twice 
using the first scale and twice using a second scale. Part 2 and Part 3 are measured similarly. 
The same operator performs all the measurements. The resulting data is shown next. For 
example, the first row shows that Part 1 was measured by Gage 1 (the first scale), which 
produced a measurement of 66.32 pounds. 
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Gage Agreement Folio Control Panel 

The gage agreement folio control panel allows you to control the settings for analyzing the 
measurement system data. It also displays the results of the analysis. This topic focuses on the 
Main page and Analysis page of the gage agreement folio control panel, which contains most of 
the tools you will need to perform the analysis. For more information about the control panel in 
general, see Control Panels. 

Control Panel Main Page 

• The Settings area on the control panel is used to view the settings and status of the 
analysis. 

  

In this example: 

• The specified risk level is 10%. This is also known as the alpha value, which is a measure 
of the risk that the analysis results are incorrect (i.e., alpha = 1 - confidence level). To 
configure the risk level used in the analysis, click the blue text, which will take you to 
the Settings page of the control panel. 

 

• "Analyzed" is shown in green, which indicates that the current response data has been 
analyzed using the current settings. Otherwise, this would show "Modified" in red. 

• The last row indicates that the analyzed data consists of 17 observations. 

• The Analysis Summary area is shown when the current measurement data has been 
analyzed using the current settings. This area displays the following values. 
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• The Accuracy area displays the difference between the average observation of the first 
gage and that of the second gage. If the difference is significant according to the paired 
T-test that is performed on the data, then the accuracy of the gages is not the same. 

• The Precision area displays the variance due to repeatability for each gage. If the 
difference is significant, then the precision of the gages is not the same. 

Click the View Analysis Summary icon in this area to view the details of the analysis results. 

Folio Tools 

The folio tools are arranged on the left side of the control panel. Use these tools to configure 
your analysis and experiment with the analysis results. 

  Calculate analyzes the measurement data and displays a summary of the results on 
the control panel. 

  Plot creates a plot based on the analysis. If you click this icon before the current data 
set has been analyzed, an analysis will be performed automatically. 

  View Analysis Summary opens a window that contains detailed information about 
current and past analysis results. 

Control Panel Analysis Settings Page 

The Analysis page of the gage agreement folio is used to enter the Risk Level, or alpha value, 
which is a measure of the risk that the analysis results are incorrect (i.e., alpha = 1 - confidence 
level). 
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Gage Agreement Folio Analysis Results 

When accessed from a gage agreement folio, the Analysis Summary window will contain a 
detailed comparison of the gages' accuracy and precision. 

If the current response data has been analyzed, you can open the window by clicking the View 
Analysis Summary icon on the control panel. 

 

If the current response data has not been analyzed, the icon will still be available so you can 
view the folio's analysis history. 

Select an item in the Available Report Items panel to display it on the spreadsheet. Each item is 
described next. 

Analysis Results 

The Part Summary table compares the average readings from each gage. 

Part Summary Table Columns 

• Subject is the identifier of the measured part. 

• The Number of Readings columns show the number of observations taken of a 
particular part using a particular gage. The name of the gage is shown at the top of the 
table. 

• The Average Reading columns show the average of the measurements that were taken 
of a particular part by a particular gage. 

• Difference is the Average Reading from the first gage minus the Average Reading from 
the second. 

• Grand Average is the average of all measurements taken of a particular part. 

The Difference and Grand Average values in this table are plotted in the difference vs. 
mean plot. 

The Average Reading Comparison table compares the average readings of the two gages in the 
study using a paired T-test. 

Average Reading Comparison Table Columns 
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• The Mean column shows the mean value of the difference between the averages of the 
two gages. 

• Standard Deviation of Mean is the standard deviation of mean value of the difference. 

• The Lower Bound and Upper Bound columns show the confidence bounds of the mean 
value of the difference. The confidence level is determined by the risk level entered on 
the Analysis Settings page of the control panel (e.g., if the risk level is 0.1, then the 95% 
one-sided upper and 95% one-sided lower bounds are calculated). 

• T Value is the ratio of the absolute value of the Mean column and the Standard 
Deviation of Mean column. It is used to calculate the p value. 

• P Value is calculated from the T value. If the p value is less than or equal to the risk 
level specified on the Analysis Settings page of the control panel, then the two gages 
have different average readings in this study. In this case, the p value will be shown in 
red. 

Note: If you suspect that the gages may differ in linearity (e.g., you see a trend in the 
difference vs. mean plot), then you should check the Regression Study table and/or the 
average reading plot to make sure the gages have the same accuracy. 

The Regression Study compares the accuracy (linearity and bias) of the two gages. It includes 
two tables. 

Regression Study Tables 

The Individual Coefficient Test table shows the calculated coefficients for the regression 
line fitted to the average readings of the first vs. second gages (also shown in the Average 
Reading plot). It includes the following columns. 

• Test is the null hypothesis. Two hypotheses are tested individually with this table: that 
b0 of the fitted regression line is 0 (i.e., no difference in bias, assuming there is no 
difference in linearity) and that b1 is 1 (i.e., no difference in linearity). Both of these 
hypotheses are true if the gages have the same accuracy. Note that if there is a 
difference in linearity, then there is also a difference in bias, since linearity describes 
how the bias changes with the size of the measured parts. 

• Coefficient is the coefficient of b0 and b1 in the regression equation. 

• Standard Error is the standard deviation of the regression coefficient. 
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• The Low Confidence and High Confidence are the lower and upper confidence bounds 
on the regression coefficient. For example, if the bounds on b0 include 0, then the b0 = 
0 null hypothesis is not false. 

• T Value is the normalized regression coefficient, which is equal to Coefficient/Standard 
Error. 

• P Value is the probability that the null hypothesis is true. If the p value is less than or 
equal to the risk level specified on the Analysis Settings page of the control panel, then 
the null hypothesis is considered false. In this case, the value is shown in red. 

The Simultaneous Coefficient Test table shows the results of the F-test that is used to 
determine whether the gages have the same accuracy. It includes the following columns. 

• Test is the null hypothesis that b0 = 0 and b1 = 1. If this is true, then the two gages have 
the accuracy. 

• F Value is the critical value of the F-distribution. It is used to calculate the p value. 

• P Value is the probability that the null hypothesis is true. If the p value is less than or 
equal to the risk level, then the two gages do not have the same accuracy. In this case, 
the value is shown in red. The folio's conclusion about whether the accuracy is the 
same is based on this value. 

The Precision Comparison table compares the repeatability of the two gages. 

Precision Comparison Table Columns 

• Gage is the name of the measuring device specified on the Data tab. 

• Repeatability Variance is the repeatability of each gage (i.e., the variation when 
multiple readings for the same part are performed by the same operator). 

• Degrees of Freedom is the number of parts measurement by each individual gage. 

• F Ratio is the ratio of the first Repeatability Variance value to the second value. An F 
ratio of 1 means the gages have the same repeatability. 

• The Lower Bound and Upper Bound columns show the confidence bounds on the F 
ratio. If the bounds include 1, then the two gages have the same repeatability. 

• P Value is the probability that the F ratio is 1. If the p value is less than the risk level/2 
and 1-(risk level/2), then the two gages do not have the same repeatability. (The risk 
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level is specified on the Analysis Settings page of the control panel.) If the gages do not 
have the same repeatability, then this value is shown in red. 

Gage Agreement Folio Plots 

The following plots are available in gage agreement folios. They allow you to visually display the 
data and compare the accuracy and precision of the gages. For general information on working 
with plots, see Plot Utilities. 

• The Difference vs. Mean plot shows the difference between the gage's measurements of 
each part versus the mean measurement of the part. (These are the same values in the 
Difference and Grand Average columns in the Part Summary.) If points seem to follow a 
trend, then the linearity of the gages may be different. The control limits are marked with 
red dotted lines near the top and bottom of the chart. If a point is out of control, then the 
difference (i.e., y-axis value) associated with that point is significantly larger than the 
differences associated with the other points. 

• The Average Reading plot is used to investigate whether the two gages have the same 
accuracy (linearity and bias). If they do, then the average readings from the first vs. second 
gages should follow the black 45-degree reference line that passes through the origin. The 
blue line is a regression line fitted to the data points. The closer the fitted line is to the 
reference line, the more likely it is that the gages have the same accuracy. 

• The Gage Repeatability plot shows the calculated repeatability variance for each gage, as 
well as the upper and lower confidence bounds on the repeatability. The confidence level 
used is determined by the risk level specified on the Analysis Settings page of the Data tab 
control panel. If the confidence bounds for the two gages overlap, then the gages have the 
same repeatability. 

Gage Agreement Folio Example 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 

The name of the example project is "Gage Agreement Study." 

A company needs to investigate if the gages from two different vendors have the same 
accuracy and precision. Experiments were conducted and the resulting measurements were 
entered on the Data tab of the example folio. The first 13 rows of data are shown next. 
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All of the measurements were taken by the same operator (in order to eliminate error due to 
differences between operators). For example, in the first ten rows, you can see that the 
operator measured 10 different parts using the same gage. Each measurement is shown in the 
Reading column. 

The Settings area on the control panel shows that a risk level of 10% was used to determine 
whether a difference in accuracy/precision is considered significant. 

 

The following summary of the results is also shown on the control panel. 

 

According to these results, the gages differ in both accuracy and precision. To see more results, 
click the View Analysis Summary icon. The Average Reading Comparison table is used to 
determine whether the average readings of the gages are different. 
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As you can see, Gage 1 produced measurements that were, on average, 1.218 units greater 
than those of Gage 2, but this difference was not found to be significant. 

The Regression Study tables are used to determine if there are any differences in accuracy (i.e., 
linearity + bias) between the gages. 

 

The Simultaneous Coefficient Test is used to evaluate the hypothesis that the gages have the 
same accuracy. The second row in the Individual Test Table (b1 = 1) specifically tests the 
hypothesis that the gages have the same linearity. Since the p value of that row is less than the 
risk level, and since linearity describes how the bias changes with the size of the measured 
parts, you can conclude that the gages are also different with respect to bias. 

Finally, the Precision Comparison table shows how the precision (i.e., repeatability, or variation 
due to the gage) differs across the gages. 
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The Repeatability Variance column shows that the gages exhibited different variance in 
measurements. Since the p value is higher than 1-(risk level/2), or 0.95, it is concluded that the 
difference in repeatability is significant. 

These results shows that Gage 2 is better in terms of repeatability, and that the gages are 
significantly different with respect to accuracy. Linearity and bias studies should be conducted if 
you wish to determine which gage is the more accurate one. 

Maintenance Planning 

In life data analysis, it is assumed that the components being analyzed are non-repairable; that 
is, they are either discarded or replaced upon failure. When non-repairable components are 
assembled as part of a system, the system's maintenance activities will involve replacing those 
worn or failed components. With the Maintenance Planning tool, you can use the information 
obtained from life data analysis to determine the most cost-effective time to replace an 
individual component. 

The Maintenance Planning tool offers two strategies: 

• Planned replacement is the practice of replacing components before they fail in order to 
promote continuous system operation or to avoid dangerous or costly failures. Cost is 
always a factor with scheduled replacements: replace components too often and you 
increase the maintenance costs; schedule replacements too far apart and you increase the 
risk of failures. The goal, then, is to minimize overall costs by finding the optimal time to 
replace components. 

• Inspections are used to reveal impending failures, such as corrosion or other forms of 
degradation. In general, a component is not replaced during inspection unless it is found 
failed, but if there is evidence that the component is approaching the end of its life, then it 
may be possible to schedule a replacement at the earliest convenience rather than allowing 
the failure to occur and possibly cause severe consequences. The goal, then, is to find the 
optimal time to perform the inspections such that oncoming failures are detected and the 
component can be scheduled for replacement before any failures occur. 

The tool uses the optimum age replacement model to estimate the ideal planned replacement 
and inspection intervals. The model uses the following assumptions: a) the failure rate of the 
component increases with time, implying wearout, and b) the cost of replacing the component 
before failure occurs is significantly less that the cost of replacing the component at the time of 
failure. 
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GENERATING A COST VS. TIME PLOT 

Follow the steps outlined below to generate a cost vs. time plot. 

1. Choose Home> Insert > Maintenance Planning. 

 

Select the data sheet to use for the analysis. Note that the data sheet must have already 
been analyzed (i.e., the parameters of the distribution have been calculated) in order for 
you to select it. 

2. Click the Plot Type drop-down list on the control panel and select which plot to generate. 
You can choose to create a Planned Replacement plot, an Inspection Replacement plot, or 
place both on the same plot. 

3. In the Costs area, enter the required inputs. If you have selected the Planned Replacement 
plot, only the first two inputs are required. For the two other plots, all four inputs are 
required. These are: 

• Planned Replacement is the average cost of replacing the component before failure 
occurs. This includes downtime costs and other associated costs. 

• Unplanned Replacement is the average cost of replacing the component due to failure. 
This includes downtime costs and other costs associated with the risk, such as lawsuits 
over the failure of a safety-critical item, loss of goodwill, etc. 

• Inspection is the average cost of each inspection procedure. 

• Failure Detection is a value between 0 and 1. It indicates the percentage of the 
component's life that must have elapsed in order for the oncoming failure to be 
detected. For example, if the component is estimated to fail in 1,000 days and the 
failure detection threshold value is 0.9, then the oncoming failure can begin to be 
detected at 900 days. 

Note: By default, the planned and unplanned replacement costs are based on the average 
long-term costs, but there may be cases where the average costs change with time, or 
when components are replaced with either costlier or less expensive versions. In this 
situation, you may wish to compute for the optimal time based on the average costs within 
one replacement cycle (defined as the time when a failure occurs or the time of the 
scheduled replacement when no failure occurs). To make this change, select the Plot One 
Cycle Cost/Time option on the Settings page of the control panel. 
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4. To calculate the results and generate the plot, choose Maintenance Planning > Analysis > 
Plot or click the icon on the control panel. 

 

The Parameters area of the control panel shows the parameters of the distribution of the data 
set, while the Results area shows the estimated minimal cost and optimal time for the 
replacement. To see a summary report of the analysis, click anywhere within these two areas. 
To open the life data folio that contains the data set, click the blue link that displays the name 
of the folio and data sheet. 

INTEGRATION WITH BLOCKSIM 

You can use the results from the maintenance plan to create preventive and/or inspection tasks 
for use in BlockSim simulation diagrams. In this case, the tasks represent the maintenance 
activities for non-repairable components (i.e., the tasks are configured to restore the item to as 
good as new condition, and are scheduled at fixed intervals based on item age, equal to the 
optimum replacement time). 

1. To create a task, choose Maintenance Planning > Analysis > Create Task. 

 

This opens a Maintenance Task window that is identical to the interface used in the 
BlockSim application. The Task Scheduling and Restoration properties are pre-configured 
based on the analysis results. You can edit these properties and/or define all the other 
properties of the task, if desired. 

2. Click OK to create the task. The task's name will appear as a link on the control panel, under 
the Results area. You can click the link to view its properties. 

You can also access the task via the Scheduled Tasks page of the Resource Manager (Home 
> ReliaSoft > Resource Manager). 

MAINTENANCE PLANNING CONTROL PANEL 

The Maintenance Planning tool's control panel consists of two pages: Analysis page and 
Settings page. 

Analysis Page 

The Analysis page contains the options for generating a cost vs. time plot (see Maintenance 
Planning). 

https://www.reliasoft.com/products/reliability-analysis/blocksim
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  Plot updates the plot to reflect any changes that have been made, and recalculates the 
estimates for the minimal cost and optimal time. 

  Plot Setup opens the Plot Setup window, which allows you to customize most aspects 
of the plot including the titles, line styles and point styles. 

  RS Draw launches ReliaSoft Draw, which allows you to annotate your plot and view 
your plot in greater detail. 

  Export Plot Graphic opens the Save As window, which allows you to save the current 
plot graphic in *.jpg, *.gif, *.png or *.wmf format. 

  Select Data Sheet opens a window that allows you to select the data sheet to analyze. 

  Create Task opens the Maintenance Task window, which allows you to create a 
preventive and/or inspection task based on the analysis results for use in BlockSim 
simulation diagrams. The name of the last created task will appear as a link on the Main 
page of the control panel, under the Results area. You can click the link to view the task's 
properties. 

The following settings affect how the plot is displayed: 

• Units allows you to choose the unit for the plot's time scale. 

• Auto Refresh automatically refreshes the plot if any of the inputs or settings are modified. 

• Keep Aspect Ratio maintains the ratio of the horizontal size to the vertical size of the plot 
graphic when you resize the plot sheet. 

• Scaling shows the minimum and maximum values for the X and Y axes. To change a value, 
clear the check box beside the value range. If selected, the application will automatically 
choose an appropriate value for the range. 

Settings Page 

The Settings page contains the options for setting how you want the plot to be generated and 
how you want the optimum time to be computed. 

• Iterations specifies the maximum number of iterations that the algorithm will perform in 
order to obtain a solution. 
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• Convergence Criteria specifies the tolerance value that will be used as the convergence 
limit for the iterations. 

• Plot One Cycle Cost/Time computes for the optimum time based on the average costs 
within one replacement cycle, which is defined as the time when a failure occurs or the 
time of the scheduled replacement when no failure occurs. This calculation may be useful 
in cases where the average costs change with time, or when components are replaced with 
either costlier or less expensive versions. 

• Plot Long Term Cost/Cycle computes for the optimum time based on the average long term 
costs. This is the default calculation method. 
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Chapter 12: Reliability Data Warehouse 
The Reliability Data Warehouse (formerly called the "Synthesis Data Warehouse (SDW)") 
enables you to access data from an XFRACAS failure reporting system for the purpose of life 
data analysis or repairable system/reliability growth analysis. You can also set up custom 
connections to obtain reliability-related data from external data sources (including Access, 
Oracle and SQL Server). You can also get data directly from custom reports created in XFRACAS. 

You can then transfer the data to an analysis folio, or use the flexible Dashboard utility to 
explore and present the data in a variety of graphical charts and grids. (See Transferring from 
the RDW to an Analysis Folio or RDW Dashboards.) In addition, if an SEP web portal has been 
implemented for an enterprise database, users can also access RDW dashboards from any web-
enabled device. 

To open the RDW, choose Home > ReliaSoft > Reliability Data Warehouse. 

 

Managing Data Sources 
The available data sources are listed in the data source manager on the left side of the window. 
They may include: 

• Static data collections that were extracted from XFRACAS at a particular point in time (and 
will not change if incidents are later added or updated). (See Extracting Data from 
XFRACAS.) 

• Custom connections that have a live link to a specified external database or to a predefined 
report created in XFRACAS. (See Custom Connections in the RDW.) 

• Static data collections that were extracted from a custom connection at a particular point in 
time (and will not change if the original data source changes). (See Import to a Static Data 
Collection.) 

If you are working with a long list of available data sources, this panel can utilize the same 
categories, identifiers and item filters that are available in many other locations throughout 
ReliaSoft desktop applications.   

To create, delete, rename or edit the properties for these data sources, use the Manage Data 
Sources commands, or right-click inside the panel. 
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The Properties window allows you to enter identifiers for each data source, and to view its 
history. 

Built-in Find/Filter, Configuration and Grouping Tools 
Double-click any data source to display the data in a grid on the right side of the window. The 
RDW offers the same filter, column configuration and grouping tools that are built in to other 
utilities that use a similar grid (e.g., the Analysis Explorer, Actions Explorer, etc.). For details 
about how to use each feature, see: 

• Finding and Filtering Records 

• Configuring Columns 

• Grouping Panel 

Building the Data Set 
The "Include in Analysis?" column shows whether each row will be included in the data set 
when it is transferred to a folio. 

• Include: Data points that will be included in the analysis are shown in green. 

• Invalid: In XFRACAS data collections, incidents with a State Time of less than 0 are 
automatically set to invalid and will not be included in the analysis. These rows are shown 
in red. 

• Ignore: In XFRACAS data collections, incidents with a State Time of 0 that are marked as 
suspensions in the State FS column are automatically set to ignore and will not be included 
in the analysis. These rows are shown in gray. 

• Exclude: Data points that have been manually set to exclude from the analysis are shown in 
blue. 

To view only those rows that will be transferred to a folio, choose View > Show Only Included. 
You can toggle this command off to show all records. 
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To change the status for a specific data point before transferring data to a folio, select the row 
and choose Build Data Set > Include or Build Data Set > Exclude. 

 Include 

 Exclude 

  

Note: Changes to the "Include in Analysis?" indicator will not be saved with the data source. If 
you close the data source and open it again later, and if you view a dashboard in the SEP web 
portal, the data will not reflect changes that were applied manually. 

In XFRACAS data collections, and only if you have permission to view incidents in the XFRACAS 
entity that the data were extracted from, you can select a row and choose Build Data Set > 
View XFRACAS Incident to open the incident in your web browser. 

 

Extracting Data from XFRACAS 
When you are working with an enterprise database that contains XFRACAS data, or a standard 
database that has a connection to external XFRACAS tables, you can use the Reliability Data 
Warehouse to extract static data collections. The collections will not change if incidents are 
later added or updated in XFRACAS. (Alternatively, if you need a live link to a predefined report 
that has already been created in XFRACAS, see Connect to XFRACAS Report.)   

To extract a static data collection from XFRACAS, first open the RDW and then choose Manage 
Data Sources > Get XFRACAS Data. 

 

(In a secure database, this is available only to users with the "Create/edit/delete RDW data 
collections" permission. Additionally, users must have the "ReliaSoft - Read Data" permissions 
for the associated XFRACAS tables.) 
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In the XFRACAS to RDW window, choose an Entity to import from, then select the check box for 
each part that you want to extract the incident (i.e., failure) data. If needed, you can use the 
Auto Filter Row to filter the grid by matching text in one or more columns. (For extremely large 
data sets, this row will be hidden and a Filter window will be available instead.) 

 

Click Next, then specify other settings or fields to import: 

• Time Metric allows you to choose which metric to use with the data. The options are based 
on the metrics that your system administrator has enabled for the XFRACAS entity. 

• Incident Detail Fields allow you to map customized detail fields from the XFRACAS incident 
to one of the user-defined field columns in the RDW collection. The following field types 
can be mapped: 

• StringUDF1-3: Alphanumeric Input Box, Check Box, Company, Contacts, Currency, Date, 
Numeric Input Box, Users, Yes/No Button, or the Select List, Administrative Controlled 
field type 

• NumberUDF1-3: Currency or Numeric Input Box 

• DateUDF1-3: Date 

• For reliability growth analysis (RGA) data, additional options are available: 

• Include non-chargeable extracts incidents that are marked as either chargeable or non-
chargeable in XFRACAS. If you clear the check box, it will extract only chargeable 
incidents. 

• Only system down events extracts only those incidents that brought the system down. 

• Filter by date commissioned extracts only incidents for systems that were 
commissioned between the specified dates. 
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Click Next, then enter a name for the data collection and any Identifiers that you want to use.   

When you click OK, the extraction process will begin. Depending on the amount of data that 
you are extracting, this may take some time. 

You can then use the data collection to transfer data to an analysis folio or explore/present in 
the dashboard utility. For information about the fields that will be available either in the Build 
Data Set tab or in the Dashboard Designer, see Data Fields for XFRACAS Data Collections. 

Data Fields for XFRACAS Data Collections 
The following fields are available for use in dashboard layouts for XFRACAS data collections and 
for data sets created via the ReliaSoft API. These are the same columns available in the Build 
Data Set tab. The fields in custom connections will depend on the data source itself. 

• Address Location: the location of the owner of the system. This corresponds to the 
Location field in the XFRACAS contact. 

• Category: the incident category. This corresponds to the Category field in the XFRACAS 
incident and, in conjunction with the failure type assigned during part repair/replacement, 
determines whether the data row is chargeable (i.e., is considered a failure for reliability 
calculations) or non-chargeable (i.e., is considered a suspension). For more information, see 
the "Incident Disposition Area" topic in the XFRACAS documentation. 

• Chargeable: the chargeable code value (where 0 = non-chargeable, 1 = chargeable): 
equivalent to the Category Chargeable and Category Non-Chargeable lists in the XFRACAS 
Admin List page. This is to be used to calculate the failure state (StateFS). XFRACAS 
categories can also be viewed within an XFRACAS incident. 

• CompanyOwner: the owner of the system. This corresponds to the Company field in the 
XFRACAS contact. 

• DataID: the database ID of the row. 

• DataSetID: the ID of the data set that the row belongs to. This is useful if you are viewing 
multiple data sets at the same time. 

• DateUDF1-3: user-defined fields for dates. You can choose up to 3 detail fields in XFRACAS 
incidents to import to these columns. 

• ExtractedBy, ExtractedDate and ExtractedName: identify the user who extracted the data 
from XFRACAS, the date of extraction and the name of the RDW data collection. 
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• FailureMode: the failure mode associated with the incident. This is chosen or created in the 
Failure Mode field in the XFRACAS incident. 

• IncidentAction: the action taken to address the incident (whether a part was removed or 
installed). This is not related to XFRACAS actions. In XFRACAS data sets, repaired and 
replaced parts will be represented using two rows of data—one will be for removing the 
part, and one for installing it. 

• IncidentEntityDisplayID: the incident number assigned by XFRACAS, which includes the 
prefix for the entity that it is associated with (e.g., E1-201). 

• IncidentID: the database ID of the incident. 

• IncidentOccurrenceDate: the date when the incident happened. This corresponds to the 
Occurrence Date field in the XFRACAS incident. 

• IncidentRepairDate: the date that part repair or replacement was completed. This 
corresponds to the Completed Date field that applies to the XFRACAS incident resolution. 

• IncidentResolution: notes regarding the resolution of the incident. This corresponds to the 
Incident Resolution field in the XFRACAS incident. 

• IsLRU: indicates whether the item is a line replaceable unit (LRU). This does not correspond 
to an XFRACAS field; it can be used when creating data sets via the ReliaSoft API. 

• LastInspectedTime: the last inspected time. For exporting XFRACAS data sets to Weibull++, 
this is equal to the state time for the data row. For exporting XFRACAS data sets for 
Reliability Growth (RGA), it is the amount of time the system has accrued at the last 
reported incident. 

• NumberInState: equivalent to the Number in State column in a Weibull++ life data folio for 
grouped data. In data sets from XFRACAS, this value will always be 1. 

• NumberUDF1-3: user-defined fields for numbers. You can choose up to 3 detail fields in 
XFRACAS incidents to import to these columns. 

• ParentPartID, ParentPartName, ParentPartNumber, ParentPartVersion and 
ParentPartSerialNumber: identifiers for the "parent" of the part that the incident pertains 
to. If the part doesn't have a parent (i.e., it is a top level part), this information will be 
identical to the information for the part itself. 

• PartHID and PartID: the part’s hierarchy identification number and database identification 
number. In XFRACAS, these are assigned by the system and shown in the HID and Part ID 
fields that are displayed for the generic part on the Template page. 
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• PartName, PartNumber and PartVersion: identifiers for the part that the incident pertains 
to. In XFRACAS, this information is specified for the generic part, and serialized parts based 
on the generic part will use the same information. 

• PartOrder: the order in which the part was replaced. This corresponds to the order in the 
repair/replace table in the XFRACAS incident. 

• PartSerialHID, PartSerialMfgCode and PartSerialNumber: relevant only if the incident was 
assigned to a part in a serialized system. They represent the part’s serial hierarchy 
identification number, manufacturing code and serial number. In XFRACAS, the 
PartSerialHID is assigned by the system and shown in the Serial HID field that is displayed 
for the serialized part on the Serialized page. 

• ReportType: how the incident was reported. This corresponds to the type chosen in the 
Report Type field in the XFRACAS incident. 

• RootCause: the root cause of the failure mode. This is chosen or created in the Root Cause 
field in the XFRACAS incident.   

• StateFS: This allows the user to understand if a data row is considered a failure (F) or a 
suspension (S) for the purposes of reliability calculations. In XFRACAS data sets, this is 
based on the incident category assigned in the XFRACAS incident, in conjunction with the 
failure type assigned during part repair/replacement. For more information, see the 
"Incident Disposition Area" topic in the XFRACAS documentation. 

• StateTime: the amount of time accrued on the part. This is based on the run hours 
calculated by XFRACAS. 

• StateTimeRestore: the amount of time required for the repair. This corresponds to the 
Repair Duration field in the XFRACAS incident. 

• StringUDF1-3: user-defined fields for strings. You can choose up to 3 detail fields in 
XFRACAS incidents to import to these columns. 

• TimeMetric: the time metric to use for the data. The options are based on the metrics that 
have been enabled for the XFRACAS entity. 

• TopLevelCommissionDate: the commission date of the top level part in the system. This 
corresponds to the commission date of the associated CSI in XFRACAS. 

• TopLevelPartID, TopLevelPartName, TopLevelPartNumber and TopLevelPartVersion: 
identifiers for the top level part in the system that the incident pertains to. 
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• TopLevelSerialHID and TopLevelSerialNumber: relevant only if the incident was assigned to 
a part in a serialized system. They represent the serial hierarchy identification number and 
serial number of the top level part in the serialized system. This information is used by 
Weibull++ to distinguish the system in which the failure occurred. 

Transferring from the RDW to an Analysis Folio 
Follow the steps below to transfer a data set from the Reliability Data Warehouse (RDW) to an 
analysis folio. 

1. Choose Home > ReliaSoft > Reliability Data Warehouse. 

 

2. In the RDW, double-click the data you want to transfer to an analysis folio. 

3. In the data table, use the Include in Analysis? column to mark any data points that need to 
be excluded from the transfer. You can double-click the cell to toggle the options, or select 
the row and choose Build Data Set > Include or Exclude. 
 
In data collections imported from XFRACAS: 

a. Incidents with StateTime = 0 and StateFS = S (suspension) are automatically marked 
Ignore. 

b. Incidents with StateTime < 0 are automatically marked Invalid. 

 

4. Choose Transfer > Transfer to New Folio. 
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Follow the on-screen prompts to select the data type and map the RDW fields to columns 
in the new analysis folio. 

TIPS FOR MAPPING THE COLUMNS 

• State F or S (for life data and life-stress data analysis) indicates whether a data point 
represents a failure (F) or suspension (S). If the data source field does not use the F and S 
codes, use the Define Values as Failures/Suspension area to specify which value(s) 
represents each state. 

 

• Event (for growth data analysis) indicates whether the data point represents a failure (F) 
that will be transferred for analysis, or some other event that will not be analyzed as a 
failure. When a data point is marked as a suspension (S) for transfer to a growth data 
analysis data set, it will be considered only if it affects the recorded system end time. For 
example, if the System End Time column indicates that the system was last inspected at 
1,000 hours but there is a suspension for that system at 1,100 hours, the later time will be 
used in the folio. 

• Time and quantity columns, such as State End Time and Number in State, can only be 
mapped to fields with a numeric data type (e.g., number, currency, etc.). 

• Classification and Mode columns (for growth data analysis) can be mapped to any RDW 
user-defined field that contains the data. (See Extracting Data from XFRACAS.) 

• Subset ID columns (for life data and life-stress data analysis) or Comment columns (for 
growth data analysis) allow you to choose multiple RDW fields to display in the same folio 
column. The data from the fields will be concatenated and separated by dashes (e.g., 
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"Report Type – Category"). Use the check boxes to select the fields and then use the arrows 
to specify the order. 

 

RDW Dashboards 
This topic describes how to use the Dashboard utility for exploring and presenting data from 
the Reliability Data Warehouse. If an SEP web portal has been implemented for an enterprise 
database, users can also access RDW dashboards from any web-enabled device. 

For static data collections, a variety of dashboard layouts can be predefined. For custom 
connections, there can be only one layout for each connection. 

1. Choose Home > ReliaSoft > Reliability Data Warehouse. 

 

2. Double-click the static data collection or custom connection that contains, or links to, the 
data you want to view in the dashboard. 

3. On the Build Data Set tab, select which rows to include or exclude. (See Building the Data 
Set.) 

4. If an appropriate dashboard layout has already been predefined, switch to the Dashboard 
Viewer tab or choose Dashboard > Dashboard Viewer. If multiple layouts are available, use 
the drop-down list at the top of the viewer to choose what to display. 

5. If you need to create a new layout, choose Dashboard > Dashboard Manager (for a static 
data collection) or Dashboard Designer (for a custom connection). 



Chapter 12: Reliability Data Warehouse 

Weibull++ 2020 User's Guide 1027 

 

   

(In a secure database, the Dashboard Layout Manager and the Dashboard Layout Designer 
are available only for users with the "Manage dashboard layouts" permission.) 

For information on the data fields available for use in dashboard layouts for RDW data 
collections, see Data Fields for XFRACAS Data Collections. 

Tip: For dashboards that are intended to be viewed in both desktop applications and the SEP 
web portal, it is recommended to use the Local Colors option on the Design tab of the 
Dashboard Layout Designer to save your preferred colors with the layout. The global colors 
definition may not be the same in both web and desktop. 

Custom Connections in the RDW 
The Custom Connections feature in the Reliability Data Warehouse allows you to create a live 
link to an external data source (Access, Oracle or SQL Server). This enables you to get data from 
your own custom and third-party databases for transferring to an analysis folio, or for viewing 
in the RDW dashboards. 

You can also get data directly from your own custom reports created in XFRACAS. 

A custom connection data source always shows the latest information from the original 
database or report and you can only create one dashboard layout per connection. You can also 
use these connections to import data into a static data collection, if desired. 

CONNECT TO AN EXTERNAL DATABASE 

To create a live link to an external database: 

1. Choose Manage Data Sources > Add Custom Connection > To External Database. 

 

2. In the Add Custom Connection window: 
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a. Enter the Display Name that will identify this custom connection in the RDW data 
source list. 

b. Enter the connection settings for a Microsoft SQL Server, Oracle or Access database. 
(See Connection Issues below for more information about the Use impersonation 
option for SQL Server.)   

c. After you have specified the database, the Table Name field shows a list of the 
available tables. Select the main one that contains the data you want to use in the 
RDW. 

d. If you want to create aliases for column names, build a query that combines data from 
multiple tables or enter your own SQL, select the Open Query Editor/Builder check 
box. 

e. If you want to create the dashboard layout for this data source immediately after 
defining the connection/query, select the Open Dashboard Designer check box. 

f. Click OK to proceed. 

3. If you selected to customize the query, you can use the Query Editor to type or paste your 
own query, or select a stored procedure. If you need further tools, click the Run Query 
Builder button. The Query Builder can serve three purposes: 

a. The bottom-center panel shows the fields that will be included in the data set. If 
desired, you can use the Alias column to change the names that will be displayed in the 
RDW grid and dashboard layouts. 

b. If the tables are linked by foreign keys, you can use the tool to build a query that 
combines fields from multiple tables. 

c. You can also enter your own SQL in this tool; select the Allow SQL Editing check box 
and type or paste your own query. 

When you are finished in the Query Builder, click OK to return to the Query Editor, where 
you can click Finish to save your changes. 

4. If you selected to open the Dashboard Designer, you can use it to create a single dashboard 
layout for this data source. 

If you want to change the query or create/modify the dashboard layout at a later time, select 
the custom connection in the data source manager and choose Dashboard > Dashboard 
Designer. 
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From within the Dashboard Designer window, choose Home > Query > Edit to customize the 
query. 

 

CONNECTION ISSUES 

There will be a "connection failed" message if the database is not found at the specified 
name/location or if you don’t have permission to access it. 

If your organization has implemented an SEP web portal, the administrator may need to take 
additional steps to make the dashboards visible to all users via the portal. For details, consult 
the print-ready implementation guide (*.pdf). 

• Oracle - the password is stored with the custom connection; therefore, both the desktop 
applications and SEP web portal will attempt to connect in the same way for all users. 

• SQL Server - the Use impersonation option in the custom connection allows you to enter a 
login for a one-time extraction to an RDW data collection, but this login is not saved in 
RDW. 

For subsequent attempts, the desktop applications will connect with the current user’s 
Windows login, whereas SEP will use the login that it uses to connect with the ReliaSoft 
database (if the ReliaSoft database is SQL Server) or with the IIS "application pool identity" 
(if the ReliaSoft database is Oracle). 

• Access - the RDW must have access to the folder where the database is stored. It is 
recommended to use the UNC pathname (e.g., \\servername\foldername rather than 
P:\foldername) when you create the custom connection. 

The desktop applications will attempt to access the file with the current user’s Windows 
login, whereas SEP can only access files stored directly on the web server or in a network 
folder that can be accessed by its IIS "application pool identity." 

Tip: For Access databases with the *.accdb file type, the dashboard can only be displayed if 
the database was created with the same version of Microsoft Office (32-bit vs. 64-bit) that 
is installed on each individual user's computer (for ReliaSoft desktop applications) or on the 
web server (for SEP). 
 

http://help.reliasoft.com/documents/version2020/IG_SEP20.pdf
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To ensure that the dashboard will display regardless of which version of Microsoft Office is 
installed, use the *.mdb file type instead of *.accdb. 

CONNECT TO XFRACAS REPORT 

Creating a custom connection to a predefined XFRACAS report enables you to use the RDW to 
view any type of XFRACAS data (not just data collections extracted for life data or repairable 
systems analysis). If an SEP web portal has been implemented for an enterprise database, users 
can also access the dashboards created for these reports from any web-enabled device. 

Tip: For information about creating RDW reports in XFRACAS, see the "Report Builder" topic in 
the XFRACAS documentation. 

To create a live link to an RDW report that has already been created in XFRACAS: 

1. Choose Manage Data Sources > Add Custom Connection > To XFRACAS Report. 

 

2. In the Select Report window, select any of the XFRACAS RDW reports that have been 
predefined in the database. 

3. Click OK to load the data. 

Import to a Static Data Collection 
In the Reliability Data Warehouse, a custom connection provides a live link to an external 
database or XFRACAS report, while a static data collection stores data that was extracted at a 
particular point in time. 

A static data collection can contain data extracted directly from XFRACAS. If desired, you can 
also create a static data collection by importing data from a custom connection. To do this: 

1. Right-click the custom connection in the data source manager and choose Import. 

2. In the Import Data from Custom Connection window: 

a. The Map Data Source Fields to Columns section specifies which field from the custom 
connection will be mapped to a column that’s available in a data collection. 

http://help.reliasoft.com/xfracas20/help/index.htm#t=report_builder.htm
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b. The Define Values as Failures/Suspensions section displays all of the unique values 
from the field that is currently mapped to the State FS column. Specify whether each 
value should be considered a failure or a suspension. 

c. The Preview tab allows you to see what the data collection will look like based on your 
selections. 

3. Click OK to create the static data collection. 
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Chapter 13: Regression Tools 
Multiple Linear Regression Folio 

The multiple linear regression folio is a general statistical tool intended for performing a simple 
analysis of existing data in order to investigate the effects of predictors on normally distributed 
responses. Only quantitative data can be analyzed. After you designate columns for predictors 
and responses and enter the data, you can perform the analysis in much the same way that it is 
performed on the Data tab of a design folio. You can also use the analysis results to predict 
response values given user-specified levels for the predictors. 

Note: If you are analyzing existing data specifically from a DOE perspective, then the free form 
folio is more appropriate. The free form folio can analyze both quantitative and qualitative 
factors, and it can analyze responses that are not normally distributed (e.g., life data that fits a 
Weibull distribution). In addition, the free form folio can be used to investigate interaction 
effects and optimize factor settings. 
 
Also note that the multiple linear regression and free form folios are typically used for analyzing 
existing data. If you need to plan and implement an experiment to obtain data, use the design 
folio. (See Building a New Design.) 

To add a multiple linear regression folio to your project, choose Home > Insert > Multiple 
Linear Regression. 

 

To use the folio, click the arrows in the column headers to specify which columns will contain 
predictors and which will contain response data. After you enter the data and select the 
appropriate analysis settings on the control panel, click Calculate to analyze the data. 

MULTIPLE LINEAR REGRESSION FOLIO CONTROL PANEL 

The multiple linear regression folio control panel allows you to control the settings for analyzing 
response data and displays the results of the analysis. This topic focuses on the Main page and 
Analysis page of the multiple linear regression folio control panel, which contains most of the 
tools you will need to perform the analysis. For more information about the control panel in 
general, see Control Panels. 



Chapter 13: Regression Tools 

1034 https://www.reliasoft.com/weibull 

 

Control Panel Main Page 

• The Response drop-down list is used to select the response that all the displayed settings 
and analysis results will apply to. 

 

• The Settings area is used to view/edit the settings for analyzing the selected response. An 
example is shown next. To configure the settings, click the blue text. These settings are also 
accessible on the Analysis Settings page of the control panel. 

  

1. In this example: 

• The partial sum of squares ("Partial SS") and grouped terms are used. 

• The specified risk level is 10%. 

• No transformation is used (i.e., the "transformed" response, Y', is equal to the non-
transformed response, Y). To configure this setting, you can click the text or the Select 
Transformation icon in the folio tools. 

• "Analyzed" is shown in green, which indicates that the current response data has been 
analyzed using the current settings. Otherwise, this would show "Modified" in red. 

• The last row indicates that the analyzed data consists of 12 observations. 

• The Analysis Summary area is shown when the current response data has been analyzed 
using the current settings. This area displays the terms that were found to be significant, as 
well as their associated regression coefficients. Click the View Analysis Summary icon in 
this area to view the details of the analysis results (including an ANOVA table). 
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Folio Tools 

The folio tools are arranged on the left side of the control panel. Use these tools to configure 
your analysis and experiment with the analysis results. Depending on the type of design you are 
working with, the control panel may contain some or all of the following tools: 

  Calculate analyzes the data for each response that is selected to be included in the 
analysis. To exclude a response from the analysis, clear the check box in its column heading. 

  Plot creates a plot based on the analysis. If you click this icon before the current data 
set has been analyzed, an analysis will be performed automatically. 

  Select Columns opens a window that allows you to specify which columns will contain 
predictors (i.e., factor level settings) and which will contain response data. 

  View Analysis Summary opens a window that contains detailed information about 
analysis results. 

  Select Transformation opens a window that allows you to select a transformation to 
apply to each response. 

  Prediction opens a window that allows you to enter values for each factor and see 
predicted results for the selected response. 

Control Panel Analysis Settings Page 

The Analysis Settings page of the control panel includes additional settings and appears as 
shown next. 
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• The Response Settings drop-down list is used to choose the response that all the visible 
settings and analysis results will apply to. When you choose a response here, it will 
automatically be chosen when you return to the Main page. 

• The Risk Level, or alpha value, is a measure of the risk that the analysis results are incorrect 
(i.e., alpha = 1 - confidence level). 

• The next area allows you to specify the Type of Sum of Squares to use in the analysis. 
Select the Partial Sum of Squares option to test if a term is significant given that all other 
terms are considered in the model. Select the Sequential Sum of Squares option to test if 
an additional term is significant given that the terms before it are already in the model. 

• The Test Terms area specifies what the information in the ANOVA table in the analysis 
results applies to. If you select Individual Terms, the software will separately examine the 
effects of each individual factor and/or factorial interaction. If you select Grouped Terms, it 
will examine groups of effect types, such as main effects, two-way interactions, etc. 

You can also analyze the selected response or open the Select Transformation window by 
clicking the icons to the left of the Response Settings area. 

MULTIPLE LINEAR REGRESSION FOLIO DATA TAB 

The Data tab of the multiple linear regression folio includes a control panel for specifying 
analysis settings and a spreadsheet for entering data. You must enter numerical data in at least 
two columns (one for predictor data and one for response data) in order to perform the 
analysis. Note that all columns containing non-numerical data will be ignored. 
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For each column containing data, you must specify whether that column contains predictors 
(e.g., factor levels) or response data. To do this, click the arrow inside the column heading and 
choose the appropriate option. 

 

Alternatively, you can click the Select Columns icon on the control panel. 

 

If you wish to rename any of the columns, right-click the column heading and choose Rename 
Column on the shortcut menu. 

SELECT COLUMNS WINDOW 

The Select Columns window allows you to specify, for each column on the Data tab of the 
multiple linear regression folio, whether that column contains response data or predictors (e.g., 
factor levels). It is accessed by clicking the Select Columns icon on the Main page of the Data 
tab control panel. 

 

This window will also appear if you try to calculate the data or generate plots without specified 
response and predictor columns. 
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• The Available Columns area displays the columns on the Data tab that have not been 
specified as containing either response data or factor settings. 

• The Response Columns area displays the columns that have been specified as containing 
response data. 

• The Predictor Columns area displays the columns that have been specified as containing 
values for predictor levels. 

• Select one or more columns in the Available Columns area and then drag them to either of 
the other two areas. To select multiple columns, click the first one and then press and hold 
CTRL while you individually select additional columns. You can also press SHIFT to 
automatically select all the columns in between the first and second column you click. 

• The Include intercept in the model option includes the intercept in the analysis for all 
responses, thereby removing any effects that do not vary. 

Once you have specified the columns you want to use in the analysis, click OK to apply the 
changes to the folio. 
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MULTIPLE LINEAR REGRESSION FOLIO ANALYSIS RESULTS 

When accessed from a multiple linear regression folio, the Analysis Summary window will 
contain detailed information about analysis results, including information that describes how 
each predictor affects response that is currently selected on the control panel. 

If the current response data has been analyzed, you can open the window by clicking the View 
Analysis Summary icon on the control panel. 

 

If the current response data has not been analyzed, the icon will still be available so you can 
view the folio's analysis history. 

Select an item in the Available Report Items panel to display it on the spreadsheet. Each item is 
described next. 

Analysis Results 

The Analysis of Variance (ANOVA) table provides general information about the effects of the 
predictors on the selected response. This information may be presented for individual 
predictors and or for all the predictors treated as a single group, depending on your analysis 
setting on the control panel. 

ANOVA Table Columns 

• Source of Variation is the source that caused the difference in the observed output 
values. The main effects of each predictor will be listed individually or grouped as 
"main effects," depending on whether you selected to use individual or grouped terms 
in the analysis (specified on the Analysis Settings page of the control panel). Sources 
displayed in red are considered to be significant. 

• The number of Degrees of Freedom for the Model is the number of regression 
coefficients for the effects included in the analysis (e.g., two coefficients might be 
included in the regression table for a given main effect). The number of degrees of 
freedom for the Residual is the total number of observations minus the number of 
parameters being estimated. 

• Sum of Squares is the amount of difference in observed output values caused by this 
source of variation. 

• Mean Squares is the average amount of difference caused by this source of variation. 
This is equal to Sum of Squares/Degrees of Freedom. 
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• F Ratio is the ratio of Mean Squares of this source of variation and Mean Squares of 
pure error. A large value in this column indicates that the difference in the output 
caused by this source of variation is greater than the difference caused by noise (i.e., 
this source affects the output). 

• P Value (alpha error or type I error) is the probability that an equal amount of variation 
in the output would be observed in the case that this source does not affect the output. 
This value is compared to the risk level (alpha) that you specify on the Analysis Settings 
page of the control panel. If the p value is less than alpha, this source of variation is 
considered to have a significant effect on the output. In this case, the term and its p 
value will be displayed in red. 

• The following values are shown underneath the ANOVA table: 

• S is the standard error of the noise. It represents the magnitude of the response 
variation caused by noise. 

• R-sq is the percentage of total difference that is attributable to the factors under 
consideration. It is equal to Sum of Squares(factor)/Total Sum of Squares. 

• R-sq(adj) is an R-sq value that is adjusted for the number of parameters in the 
model. 

• PRESS is the prediction error sum of squares, which provides a measure of the 
model’s validity. The lower the PRESS value, the better the model’s predictive 
ability. 

• R-sq(pred) is a measure of how well the model predicts new observations. It is 
equal to 1-PRESS/Total Sum of Squares. The larger the value, the more accurate the 
model’s predictions are likely to be. 

The Regression table provides specific information on the contribution of predictor to the 
variation in the response and an analysis of the significance of this contribution. 

Regression Table Columns 

• Term is the factor under consideration. Terms displayed in red are considered to be 
significant. In cases where there is no error in the model, significant effects are 
determined according to Lenth’s method and the term names are displayed in red and 
followed by an asterisk (*). 

• Coefficient is the regression coefficient of the term, which represents the contribution 
of the term to the variation in the response. 
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• Standard Error is the standard deviation of the regression coefficient. 

• Low Confidence and High Confidence are the lower and upper confidence bounds on 
the regression coefficient. 

• T Value is the normalized regression coefficient, which is equal to Coefficient/Standard 
Error. 

• P Value (alpha error or type I error) is the probability that an equal amount of variation 
in the output would be observed in the case that this term does not affect the output. 
This value is compared to the risk level (alpha) that you specify on the Anaysis Settings 
page of the control panel. If the p value is less than alpha, this source of variation is 
considered to have a significant effect on the output. In this case, the term and its p 
value will be displayed in red. 

• Variance Inflation Factor is a measure of the correlation, if any, between the term 
(predictor) and the other predictors. The lower the value, the less likely it is that the 
predictors are correlated. If the correlation of a predictor with other predictors is 
extremely high, that predictor should be removed from the model. If predictors are 
100% correlated, they are aliased and will automatically be removed from the model. 
This will be noted directly above the Regression Table. 

The Regression Equation information is presented using multiple tables.  

Regression Equation 

• The Response table displays the response that the regression equation applies to and 
the units of measurement that were entered for the response (if any). 

• The Additional Settings table shows the transformation and risk level you entered for 
the response. 

• The Significant Terms table is applicable only when at least one term was found to be 
significant. It shows the significant terms in the Name column and the associated 
regression coefficients in the Coefficient column. 

• The Equation tables show the regression coefficients for the model of the selected 
response. For example, consider this table: 
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The corresponding model for this table is y = -29.8750 - 22.5625x1 + 1.7250x2 - 0.1500x3. 

Additional Results 

All of the following tables provide information that was generated from the main calculations. 
The available tables will vary depending on the design type you are working with. The results 
that could be available include: 

Alias Structure 

This item is available for all designs with at least two factors. It describes the alias structure 
for the design, taking into account only the terms you've selected to include in the analysis. 
Together with your engineering knowledge, you can use this information to help determine 
whether any important interaction information was lost due to aliasing. When aliased 
terms exist, the following areas will be shown: 

• Terms selected to be in the model lists all the terms that are considered for inclusion in 
the regression model (i.e., the selections in the Select Terms window). 

• Terms included in the model lists all the selected terms that are included in the model. 
The alias structure determines which terms are excluded. 

• Alias Structure lists the aliased effects based on the selected terms. For example, A • B 
= A • B + C • D means the interaction effect A • B is aliased because it is 
indistinguishable from effect C • D. Therefore, the model cannot include both 
interaction terms; it will include only one (e.g., A • B). 

Alias Summary 

The terms in the first column of this table are aliased with the terms shown in the second 
column. Only the terms in the first column are included in the model. 

Var/Cov Matrix 

This shows the variance/covariance matrix, which is available for one factor R-DOE designs 
and all other designs with two or more factors. The diagonal elements in this matrix are 
used to calculate the coefficients in the MLE or Regression Information table. 
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Diagnostic Information 

This table is available for one factor R-DOE designs and all other designs with two or more 
factors. It displays various analysis results for each run and highlights significant values. The 
following columns are included: 

• Run Order is the randomized order, generated by the software, in which it is 
recommended to perform the runs to avoid biased results. Note that any changes 
made to the Run Order column on the Data tab will be reflected here. 

• Standard Order is the basic order of runs, as specified in the design type, without 
randomization. Note that any changes made to the Standard Order column on the Data 
tab will be reflected here. 

• Actual Value (Y) is the observed response value for the run, as entered in the response 
column on the Data tab. 

• Predicted Value (YF) is the response value predicted by the model given the factor 
settings used in the run. 

• Residual (or "regular residual") is the difference between the actual value (Y) and the 
predicted value (YF) for the run. 

• Standardized Residual is the regular residual for the run divided by the constant 
standard deviation across all runs. 

• Studentized Residual is the regular residual for the run divided by an estimate of its 
standard deviation. 

• External Studentized Residual is the regular residual for the run divided by an estimate 
of its standard deviation, where the run in question is omitted from the estimation. 

• Leverage is a measure of how much the run influences the predicted values of the 
model, stated as a value between 0 and 1, where 1 indicates that the actual response 
value of the run is exactly equal to the predicted value (i.e. the predicted value is 
completely dependent upon the observed value). 

• Cook’s Distance is a measure of how much the output is predicted to change if the run 
is deleted from the analysis. 

Values that are considered to be significant, or outliers, are displayed in red. For the 
residual columns, significant or critical values are those that fall outside the residual’s upper 
or lower bounds, calculated based on the specified alpha (risk) value.  
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The ReliaWiki resource portal has more information on how significant values are 
determined for the Leverage and Cook's Distance columns at: 
http://www.reliawiki.org/index.php/Multiple_Linear_Regression_Analysis. 

Least Squares Means 

This table shows the predicted response values for the given factor levels. It includes the 
following columns: 

• Effect is the main effect or interaction used to predict the response. The coefficients for 
effects not used in the prediction are set to zero. 

• Level is the combination of factor levels used to predict the response. 

• Mean is the predicted response value. 

MULTIPLE LINEAR REGRESSION FOLIO: PLOTS 

The following plots may be available on the Analysis Plot tab of the multiple linear regression 
folio. Note that the contour plot and residual vs. factor plot are available only when there are at 
least two factors included in the analysis. For general information on working with plots, see 
Plot Utilities. 

Effect Plots 

Effect plots allow you to visually evaluate the effects of factors and factorial interactions on the 
selected response. 

• The Pareto Chart - Regression plot shows the standardized effects of the selected terms 
(i.e., factor or combination of factors). The vertical blue line is the threshold value. If a bar 
is beyond the blue line, it will be red, indicating that the effect is significant. 

• The Pareto Chart - ANOVA* plot shows the inverse p value (1 - p) of each selected term. 
The vertical blue line is the threshold value. If a bar is beyond the blue line, it will be red, 
indicating that the term is significant. 

• The Scatter Plot shows the observed values of the currently selected response plotted 
against the levels of the selected factor. A 3-dimensional version of this plot is available in 
the 3D plot folio. 

• The Contour Plot shows how varying two selected factors affects the predicted response 
values, which are represented as colors. See Contour Plots. A 3-dimensional version of this 
plot ("Surface Plot") is available in the 3D plot folio. For mixture designs, this plot applies 
only to process factors (i.e., process variables). 

http://www.reliawiki.org/index.php/Multiple_Linear_Regression_Analysis
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Residual Plots 

Residuals are the differences between the observed response values and the response values 
predicted by the model at each combination of factor values. Residual plots help to determine 
the validity of the model for the currently selected response. When applicable, a residual plot 
allows the user to select the type of residual to be used: 

• Regular Residual is the difference between the observed Y and the predicted Y. 

• Standardized Residual is the regular residual divided by the constant standard deviation. 

• Studentized Residual is the regular residual divided by an estimate of its standard 
deviation. 

• External Studentized Residual is the regular residual divided by an estimate of its standard 
deviation, where the observation in question is omitted from the estimation. 

The plots are described next. 

• The Residual Probability* plot is the normal probability plot of the residuals. If all points fall 
on the line, the model fits the data well (i.e., the residuals follow a normal distribution). 
Some scatter is to be expected, but noticeable patterns may indicate that a transformation 
should be used for further analysis. Two additional measures of how well the normal 
distribution fits the data are provided by default in the lower title of this plot. Smaller 
values for the Anderson-Darling test indicate a better fit. Smaller p values indicate a worse 
fit. 

• The Residual vs. Fitted* plot shows the residuals plotted against the fitted, or predicted, 
values of the selected response. If the points are randomly distributed around the "0" line 
in the plot, the model fits the data well. If a pattern or trend is apparent, it can mean either 
that the model does not provide a good fit or that Y is not normally distributed, in which 
case a transformation should be used for further analysis. Points outside the critical value 
lines, which are calculated based on the specified alpha (risk) value, may be outliers and 
should be examined to determine the cause of their variation. 

• The Residual vs. Order* plot shows the residuals plotted against the order of runs used in 
the design. If the points are randomly distributed in the plot, it means that the test 
sequence of the experiment has no effect. If a pattern or trend is apparent, this indicates 
that a time-related variable may be affecting the experiment and should be addressed by 
randomization and/or blocking. Points outside the critical value lines, which are calculated 
based on the specified alpha (risk) value, may be outliers and should be examined to 
determine the cause of their variation. 
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• The Residual vs. Factor* plot shows the residuals plotted against values of the factor 
selected in the Residual Factor area. It is used to determine whether the residuals are 
equally distributed around the "0" value line and whether the spread and pattern of the 
points are the same at different levels. If the size of the residuals changes as a function of 
the factor’s settings (i.e., the plot displays a noticeable curvature), the model does not 
appropriately account for the contribution of the selected factor. Points outside the critical 
value lines, which are calculated based on the specified alpha (risk) value, may be outliers 
and should be examined to determine the cause of their variation. 

• The Residual Histogram* is used to demonstrate whether the residual is normally 
distributed by dividing the residuals into equally spaced groups and plotting the frequency 
of the groups. The Residual Histogram Settings area allows you to: 

• Select Custom Bins to specify the number of groups, or bins, into which the residuals 
will be divided. Otherwise, the software will automatically select a default number of 
bins based on the number of observations. 

• Select Superimpose pdf to display the probability density function line on top of the 
bins. 

• The Residual Autocorrelation* plot shows a measure of the correlation between the 
residual values for the series of runs (sorted by run order) and one or more lagged versions 
of the series of runs. The default number of lags is the number of observations, n, divided 
by 4. If you select Custom Lags in the Auto-Correlation Options area, you can specify up to 
n -1 lags. The correlation is calculated as follows: 

 

where: 

• k is the lag. 

• is the mean value of the original series of runs. 

For example, lag 1 shows the autocorrelation of the residuals when run 1 is compared with 
run 2, run 2 is compared with run 3 and so on. Lag 3 shows the autocorrelation of the 
residuals when run 1 is compared with run 4, run 2 is compared with run 5 and so on. Any 
lag that is displayed in red is considered to be significant; in other words, there is a 
correlation within the data set at that lag. This could be caused by a factor that is not 
included in the model or design, and may warrant further investigation. 
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• The Fitted vs. Actual plot shows the fitted, or predicted, values of the currently selected 
response plotted against the observed values of the response. If the model fits the data 
well, the points will cluster around the line. 

Diagnostic Plots 

• The Leverage vs. Order plot shows leverage plotted against the order of runs used in the 
design. Leverage is a measure (between 0 and 1) of how much a given run influences the 
predicted values of the model, where 1 indicates that the actual response value of the run 
is exactly equal to the predicted value (i.e. the predicted value is completely dependent 
upon the observed value). Points that differ greatly from the rest of the runs are considered 
outliers and may distort the analysis. 

• The Cook’s Distance* plot can show Cook’s distance (i.e., a measure of how much the 
output is predicted to change if each run is deleted from the analysis) plotted against either 
the run order or the standard order for the currently selected response. Points that differ 
greatly from the rest of the runs are considered outliers and may distort the analysis. 

• The Box-Cox Transformation* plot can help determine, for the currently selected response 
and model, what transformation, if any, should be applied. The plot shows the sum of 
squares of the residuals plotted against lambda. The value of lambda at the minimum point 
of this curve is considered the "best value" of lambda, and indicates the appropriate 
transformation, which is also noted by default in the lower title of the plot. 

* These plots are available only when there is error in the design, indicated by a positive value 
for sum of squares for Residual in the ANOVA table of the analysis results. 

MULTIPLE LINEAR REGRESSION FOLIO: EXAMPLE 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_DOE_Examples.rsgz20"). To access this database file, choose File > 
Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder. 

The name of the example project is "Multiple Linear Regression - Ice Cream Consumption." 

The multiple linear regression folio provides an easy way to quickly analyze existing data. In this 
example, ice cream consumption per capita was measured in four-week periods from March 
18, 1951 to July 11, 1953 in order to determine whether it depended on the price of ice cream, 
the weekly family income and/or the mean temperature. 
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Creating the Folio 

To investigate the predictors, the analysts create a multiple linear regression folio, and enter 
the predictor and response values on the Data tab. The design matrix and the response data are 
given in the "Ice Cream Consumption" folio. The following steps describe how to create this 
folio on your own. 

1. On the Home tab, click the Multiple Linear Regression icon in the Insert gallery. 

 

2. Right-click the column headings to rename each of the columns. 

3. Click the arrow inside a heading to specify whether the column contains predictor data 
(e.g., mean temperature) or response data (i.e., ice cream consumption). 

 

Analysis and Results 

The data set for this example is given in the "Ice Cream Consumption" folio of the example 
project. After you enter the data from the example folio, you can perform the analysis by 
clicking the Calculate icon. 

 

The ANOVA table and the Regression Information table for the model are available in the 
Analysis Summary window after you click the View Analysis Summary icon on the control 
panel. The R-sq and R-sq(adj) values in the ANOVA table indicate that the model fits the data 
relatively well. 
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The Regression Information table indicates that weekly family income and mean temperature 
are good predictors for ice cream production. 

 

Since the price of ice cream does not seem to predict ice cream consumption, the folio was 
duplicated in the "Reduced Model" folio, where the price column was removed from the 
analysis by clicking the arrow in the heading and clearing all the check boxes. Click the View 
Analysis Summary icon in the new folio to view the final regression model. 

 

Click the Plot icon to view the residual vs. order plot, which you can use to look for outliers in 
the data set. 



Chapter 13: Regression Tools 

1050 https://www.reliasoft.com/weibull 

 

 

Conclusions 

Based on the analysis, weekly family income and mean temperature are found to be the most 
significant factors in ice cream consumption. From the residual vs. order plot, we see that there 
are a few outliers but the majority of our data set fits the model. Thus, if desired, we could use 
the Prediction window to predict future ice cream consumption based on different 
combinations of family income and mean temperature. 

Equation Fit Solver 

The Equation Fit Solver is a tool that allows you to estimate the parameters of any user-defined 
non-linear equation. This gives you the flexibility to perform simple parameter estimation on 
statistical models other than the life distributions available in Weibull++. 
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To add an Equation Fit Solver folio to a project, choose Home > Insert > Equation Fit Solver, or 
right-click the Regression Tools folder in the current project explorer and choose Add Equation 
Fit Solver on the shortcut menu. 

 

EXAMPLE 

Consider a product that has the following mean life for each stress level: 

Table 1: Stress vs. Mean Life 

Stress Level (Temperature K) Mean Life (Hours) 

393 6685.111904 

408 5730.096004 

423 4775.08002 

The relationship between the stress level and mean life can be described by the Eyring 
acceleration model: 

 

where: 

• m is the mean life. 

• T is the operating temperature (i.e., use stress level). 

• A and B are the parameters of the equation. 

In order to estimate the mean life at any given temperature, parameters A and B must be 
determined. To solve for these parameters, follow the steps outlined below: 

1. Write the Eyring acceleration model in the form y = F(x), where x is the random variable. 
For this example, let T = x and m = y. This results in: 
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2. Enter the equation in the Formula field of the control panel, as shown next. 

 

3. Use the Function Parameters area of the folio to provide a starting point for estimating the 
parameters. 

a. In the Is greater than and Is less than columns, set an estimate for the minimum and 
maximum values for each parameter in the equation. If the iteration does not converge 
at the specified range, you will need to edit the range values until a solution can be 
obtained. For this example, use the following values: 

• A is estimated to be greater than -100 and less than 1000. 
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• B is estimated to be greater than -100 and less than 5000. 

b. In the Initial Guess column, set a value from which the approximation for the 
corresponding parameter will start. If the iteration cannot arrive at a solution, you will 
need to edit the initial guess values until a solution can be obtained. For this example, 
the initial guess for A is 0.01 and the initial guess for B is 0.2. 

4. In the Data area, enter the information from Table 1. Enter the stress level values in the X 
column and enter the mean life values in the Y column. 

5. Click the Calculate icon on the control panel to solve for the parameters of the equation. 

The parameter values are found to be A = -11.1465 and B = 1430.2558, as shown next. By 
obtaining the parameters, we can now estimate the mean life (y) for any given stress level 
(x) by using the Calculate Y given X tool. For example, in the picture shown next, the 
estimated mean life for a temperature of 430 K is 4486.81 hours. 

 

The following columns allow you to evaluate the results of the parameter estimation: 

4.  
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• SDEV shows the standard deviation of the values of the parameters, which helps you to 
evaluate the amount of variability in the data set. 

• F(x) shows the calculated mean life (y) at each stress level (x) when the estimated 
values of the parameters are substituted in the user defined equation. 

• Error [Y-F(x)] shows the calculated distance (the error) of the known value in the Y 
column to its corresponding value in the F(x) function. This helps you to evaluate the fit 
of the F(x) function to the data set. 

5. To visually assess how well the function fits the known data points of the equation, click the 
Plot icon on the control panel. The Data and Function Fit plot is shown next (with the 
scaling adjusted). 
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EQUATION FIT SOLVER CONTROL PANEL 

The Equation Fit Solver control panel contains the following settings: 

• The Add to Templates command on the control panel gives you the option to save user-
defined equations as templates for future use. To use this feature, enter the equation in 
the Formula field, type a name for the equation and then click Add to Templates, as shown 
in the following example. 

 

• To use a saved template, choose Equation Fit Solver > Solver Templates > Select from 
Templates or click the icon on the control panel. 

 

This opens the Existing Equation Templates window, which shows a list of all the saved 
templates. The buttons at the lower left side of the window allow you to add, edit or delete 
templates. 

• The Auto fill parameters check box automatically copies all the unknown variables in the 
user-defined equation (except variable x) to the Function Parameters area. If the check box 
is cleared, you can automatically copy the parameters of the equation to the Function 
Parameters area by choosing Equation Fit Solver > Analysis > Initialize Parameters or by 
clicking the icon on the control panel. 

 

• The Calculate Y given X tool uses the user-defined equation and the fitted parameters to 
calculate the value of y given the value of x. This tool is available only when you have 
calculated the parameters. Enter a value for x and click the Analyze button to compute the 
results. 
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Folio Tools 

Additional tools are arranged on the left side of the control panel: 

  Calculate estimates the parameters of the user-defined equation and calculates other 
results you could use to evaluate how well the function fits the data. This tool is also 
available by choosing Equation Fit Solver > Analysis > Calculate. 

  Plot creates a plot demonstrating the fit of the function for each known data point 
that you defined in the Data area. The scaling, setup, exporting and other features of the 
plot are similar to the options available for other Weibull++ plot sheets. Features that are 
not applicable to this plot will be hidden or disabled. This tool is also available by choosing 
Equation Fit Solver > Analysis > Plot. 

  Initialize Parameters automatically copies all the unknown variables in your equation 
(except the random variable x) to the Function Parameters area. This also resets the 
minimum, maximum and initial guess values to their default values. This tool is also 
available by choosing Equation Fit Solver > Analysis > Initialize Parameters. 
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Chapter 14: Simulation 
Monte Carlo and SimuMatic 

In life data analysis and accelerated life testing analysis, the reliability engineer will typically 
select a model to fit data obtained from testing or usage in the field. However, in some 
situations, it is useful to generate simulated data sets containing values that are distributed 
according to a specified life distribution or model. For example, simulated data could be used 
to: 

• Test different warranty and maintenance strategies 

• Perform risk analysis 

• Obtain simulation-based confidence bounds 

• Analyze probabilistic design models 

• Design reliability or reliability growth  tests 

• Compare different parameter estimation methods 

• Evaluate the impact of different censoring schemes 

When using reliability growth analysis, the engineer will typically fit a reliability growth model 
to actual data obtained from developmental testing or fielded repairable systems operating in 
the field. However, in some situations, it may be useful to generate simulated data sets 
containing values that are distributed according to a specified set of parameters. For example, 
simulated data could be used to: 

• Design reliability growth tests. 

• Obtain simulation-based confidence bounds. 

• Experiment with the influences of sample sizes and data types on analysis methods. 

• Evaluate the impact of allocated test time. 

You can use Monte Carlo simulation to produce data sets based on various user inputs, such as 
data type, the beta and lambda parameters of the Crow-AMSAA (NHPP) model and sample size. 
The software will randomly generate input variables that follow a specified probability 
distribution. In the case of reliability growth and repairable system data analysis, the goal is to 
generate failure times for systems that are assumed to have specific characteristics. Therefore, 
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the inter-arrival times of the failures will follow a non-homogeneous Poisson process with a 
Weibull failure intensity (as specified in the Crow-AMSAA model). 

Weibull++ offers the following utilities for generating and analyzing simulated data: 

• The Monte Carlo utility (which comes in a life data version, a life-stress version and a 
reliability growth version) uses Monte Carlo simulation to generate a single data set based 
on various user inputs, such as distribution type, distribution parameters and sample size. 
The data set is then automatically placed in an analysis folio, where it can be analyzed like 
any other data set. For growth analysis, the Repairable Systems Monte Carlo utility uses 
simulation to generate a single data set containing values that are distributed according to 
the Crow-AMSAA model with specified beta and lambda parameters. The data set is then 
automatically placed in a growth data folio, where it can be analyzed like any other data 
set. 

• SimuMatic (which also comes in a life data version, a life-stress version and a reliability 
growth version) generates a large number of data sets using Monte Carlo simulation. It 
then analyzes the group of data sets as a whole. You can use SimuMatic, for example, to 
find the average reliability at a given time for a thousand simulated data sets. For growth 
analysis, the Repairable Systems SimuMatic folio generates a large number of data sets 
using Monte Carlo simulation. It then automatically analyzes the group of data sets as a 
whole in order to explore a variety of questions. For example, you can use SimuMatic to 
calculate the simulation-based confidence bounds on the demonstrated MTBF. 

LIFE DATA AND LIFE-STRESS DATA MONTE CARLO UTILITY 

The Monte Carlo utility uses Monte Carlo simulation to generate a single data set containing 
values that are distributed according to a specified model. The software uses the cdf 
(cumulative distribution function) of the relevant distribution to solve for time given an 
unreliability value chosen from a uniform random distribution. The process is repeated with 
new random unreliability values until the desired number of data points is obtained. The data 
set is then automatically placed in a life data folio or life-stress data folio, where it can be 
analyzed like any other data set. 

To access the Monte Carlo utility, choose Home > Insert > Monte Carlo. If you have Accelerated 
Life Testing activated on your computer, you will be offered a choice between the Monte Carlo 
or Stress-Dependent Monte Carlo utility. 

 

In general, you can produce a data set in just a few steps: 
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• Use the Main tab of the setup window to specify the distribution/model and its parameter 
values. 

• Use the Censoring tab of the setup window to specify the censoring type. 

• Use the Settings tab of the setup window to specify the number of data points to generate. 

• In Accelerated Life Testing, additional steps are required: 

• Use the Stress tab of the setup window to specify an appropriate use level and 
transformation (if applicable) for each stress. 

• Use the data sheet on the right side of the setup window to specify the stress levels 
and the number of data points to generate for each stress level. 

To learn more, the following sections provide complete descriptions of all available options in 
the utility. 

Main Tab 

The Main tab of the setup window allows you to select a distribution/model, enter its required 
parameter values and select the time or usage units (e.g., hours) for the failures/suspensions in 
the data set. 

If the estimated values of the distribution parameters are not available, you can use the Quick 
Parameter Estimator button to solve for them. 

For the life data Monte Carlo utility:  

• If you select the normal, logistic or generalized gamma distributions, the Allow Negative 
Values check box will be available. When generating data to simulate a test, negative 
failure times can be used to simulate failures that occur before a unit's testing period 
begins, such as failures due to manufacturing defects or damage that is incurred during 
shipping. 

• If you select the mixed Weibull distribution, you will need to specify parameters for each 
subpopulation. The Portion field is for the percentage entered as a decimal of the total data 
set represented by the selected subpopulation. Thus, the sum of the portion values for all 
subpopulations must be equal to 1. 

• If you select the User-Defined distribution, you can manually enter an equation that relates 
different random variables. (See User-Defined Equations.) 

• In the Equation area, use R to insert a uniform random variable. 
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• Click the Insert Data Source button if you wish to generate simulated values based on 
distributions calculated from a folio in the project. 

For the Stress-Dependent Monte Carlo utility:  

• If you select the proportional hazards (PPH), general log-linear (GLL) or cumulative damage 
(CD) model, the Number of Stress Columns area will be enabled. It allows you to add stress 
columns to the data sheet on the right side of the window. In the data sheet, specify the 
value of each stress level and how many data points you want generated for each stress 
level. 

 

• If you select the cumulative damage (CD) model, you must assign time-dependent stress 
profiles to the stress columns in the data sheet. 

To create a new profile, choose <Add New> from the Edit Stress Profiles drop-down list 
and then click the Create/View Profile icon . To edit an existing profile, choose it from 
the drop-down list and then click the icon. 
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Stress Tab (Accelerated Life Testing Only) 

The Stress tab of the setup window applies to the Stress-Dependent Monte Carlo utility only. It 
allows you to specify a use level for each stress type. There will be a separate input box for each 
stress column in the data sheet. 

If you have selected the general log-linear (GLL) or cumulative damage (CD) model, you must 
also select an appropriate Transformation for each stress: 

• None X=V is for stress types associated with the exponential life-stress relationship (LSR). 
This transformation is commonly used for indicator variables (e.g., 0 = on/off and 1 = 
continuous operation). 

• Reciprocal X=1/V is for stress types associated with the Arrhenius LSR. This transformation 
is commonly used for thermal stresses. 

• Logarithmic X=ln[V] is for stress types associated with the inverse power law LSR. This 
transformation is commonly used for non-thermal stresses. 

Censoring Tab 

• No censoring: The generated data set will contain only exact failure times (i.e., it will 
contain no right censored, interval or left censored data). 

• Right censoring after specific number of failures: You specify the number of failures, n, 
that the generated data set will contain. After the data are generated, they are sorted. The 
first n data points will be marked as failures while the remaining data points will be marked 
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as suspensions at a time equal to the time of the nth failure. When used with SimuMatic, 
this option allows you to simulate a failure-terminated test (i.e., a test that ends after a 
specified number of failures occur). 

Note: To illustrate how this censoring is performed in the Stress-Dependent Monte Carlo 
utility, suppose you chose to generate 20 data points (e.g., 10 at one stress level and 10 at 
another) and entered 10 in the Number of Failures field. The software would first generate 
20 time values. Then the lowest 10 values across all the stress levels would be marked as 
failure times. The remaining 10 values would be marked as suspensions. 

• Right censoring after a specific time: You specify a duration in the Time field. All simulated 
values that do not exceed this time will be marked as failure times. Values that exceed this 
time will be considered suspensions at the specified time (i.e., units that had not failed by 
the end of the test). When used with SimuMatic, this option allows you to simulate a time-
terminated test (i.e., a test that ends after a specified time). 

• Random censoring (available in for life data only): You provide percentages to specify what 
proportions of your total data points will consist of right censored, interval and left 
censored data. The remaining data points will be exact failure times. Thus, the sum of the 
three percentages entered cannot exceed 100%. This option can be useful for exploring 
how different kinds of uncertainty in your data can influence the results of an analysis. 

For example, the settings in following picture shows that the software will generate a set of 
data points, where 20% of the data are right censored, 20% are interval censored, 20% are 
left censored and the remaining 40% are complete data (i.e., exact failure times). 

 

Note: With random censoring, the software will censor your data using a uniform 
distribution. If this option is used to generate multiple data sets in SimuMatic, the 
percentages you enter will apply to the total number of generated data points, not the 
number of data points within each data set. Thus, if you select to have 50% of your 
generated data consist of suspensions (right censored data), half of all your data points will 
be suspensions, though some data sets may still contain more suspensions than others. 



Chapter 14: Simulation 

Weibull++ 2020 User's Guide 1063 

 

Settings Tab 

The Settings tab of the setup window allows you to specify how you want to generate the data 
set and where you want the data to be stored: 

• Use Seed allows you to set a consistent starting point from which the random numbers will 
be generated. Using the same seed value and keeping all other settings the same will allow 
you to replicate your results. 

• Math Precision allows you to specify the number of decimal places to use for each 
simulated data point. 

• Data Points sets the number of data points you wish to generate. 

• For the life data Monte Carlo utility, use the Number of points field. 

• For the Stress-Dependent Monte Carlo utility, use the data sheet on the right side of 
the window. For example, if you have selected a multi-stress model, the following 
settings would generate 10 data points for Stress 1 = 348 and Stress 2 = 3, 10 data 
points for Stress 1 = 378 and Stress 2 = 3, and 10 data points for Stress 1 = 378 and 
Stress 2 = 5. 

 

• Generate Data in Specified Folio and Data Sheet allows you to choose where to put the 
simulated data. Click the Active button to select the folio and data sheet that were active 
when the utility was opened. If you want the utility to always select the active folio and 
data sheet, select the Select active folio/sheet when loading this window check box. 
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REPAIRABLE SYSTEMS MONTE CARLO UTILITY 

For reliability growth data analysis only. 

Weibull++'s Repairable Systems Monte Carlo utility uses simulation to generate a single data 
set containing values that are distributed according to the Crow-AMSAA (NHPP) model with 
specified beta and lambda parameters. 

To access the Monte Carlo utility, choose Home > Insert > Monte Carlo and choose the 
Repairable Systems Monte Carlo option. 

 

The setup window will appear. Follow the steps outlined below to set up the simulation: 

1. On the Main tab of the window, select a data type and time units in the Data Type area. In 
the Parameters area, enter the beta and lambda values for the Crow-AMSAA model that 
will be used to generate the data set. 

2. In the Data Sets / Points area, enter the following information: 

• Specify the Number of systems for which data will be generated. This value is fixed at 1 
unless you selected a multiple systems data type on the Main tab (i.e., Multiple 
Systems - Concurrent or Repairable Systems). 

• Use the Test termination field to specify what will determine the end of the 
observation period for the simulated data.  

• If the period will end after a specific number of failures have been observed, 
choose Failure Terminated from the drop-down list and enter the number of 
Failures in the next field. 

• If the observation period will end at a specific time, choose Time Terminated from 
the drop-down list and enter a Time in the next field. 

• If you selected to generate Grouped Failure Times data, click the Set Intervals link to 
open a window that allows you to specify the intervals that will contain the failures. 
You need at least three intervals to simulate this type of data. 

3. On the Settings tab, specify how you want to generate the data set and where you want the 
data to be stored. 
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• Select the Use Seed check box if you would like to set a consistent starting point from 
which the random numbers will be generated. Using the same seed value and keeping 
all other settings the same will allow you to replicate your results. 

• In the Math Precision area, enter the number of decimal places that will be used for 
each simulated data point. (This does not affect the precision used in the calculated 
parameters and other results.) 

• Use the Generate Data in Specified Folio drop-down list to specify where to put the 
simulated data. If you select a folio that already exists in the project, the data will be 
placed into a new data sheet at the end of that folio, and any existing data sheets and 
plots will remain unchanged. If you choose <New Folio> the software will create a new 
folio to place the data into. 

4. After the simulation is set up, click Generate to create a new growth data folio data sheet 
populated with a data set that meets your specifications. 

USER-DEFINED EQUATIONS 

The Weibull++ Monte Carlo utility includes the option to generate data sets based on user-
defined equations. This can be used for a wide variety of applications in risk analysis, 
probabilistic design and other areas (see User-Defined Equation Example). 

Entering a User-Defined Equation 

When you select User-Defined in the Distribution area on the Main tab of the Monte Carlo 
utility, the Parameters area will be replaced with an Equation field. 

To use the tool, enter an equation with at least one random variable. There are two ways to do 
that: 

• Use the letter R to indicate a random variable  

If you use the letter R to indicate a random variable in the user-defined equation, the utility 
will generate random values for the variable based on a uniform distribution. For example, 
suppose you want to generate a data set based on the following exponential model, where 
β = 0.5. 

 

Substituting the value of β = 0.5 and using the variable R to represent x, you would enter 
the following equation: 
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Note: A new uniform random variable is chosen for each time R appears in the user-defined 
equation. For example, if you enter R^2, the software will compute the square of one 
uniform random number. But if you enter R*R, the software will compute the product of 
two different uniform random numbers. 

• Draw a random number from a distribution calculated in a life data folio 

If you want to obtain a random number from the distribution in an existing life data folio, 
click the Insert Data Source button and then select the calculated data sheet from the list. 

For example, suppose you want to generate a data set that contains a range of possible 
area measurements (area = length x height), where the length is obtained by drawing a 
random number from the distribution computed in one data sheet (called "Folio1!Length") 
and the height is obtained by drawing a random number from the distribution computed in 
another (called "Folio1!Height"). Your user-defined equation would look like the following: 

 

USER-DEFINED EQUATION EXAMPLE 

The data set used in this example is available in the example database installed with the 
Weibull++ software (called "Weibull20_Examples.rsgz20"). To access this database file, choose 
File > Help, click Open Examples Folder, then browse for the file in the Weibull sub-folder.  

The name of the project is "Monte Carlo Simulation - User-Defined Equation - Hinge." 



Chapter 14: Simulation 

Weibull++ 2020 User's Guide 1067 

 

A company manufactures hinges that are made up of four components A, B, C and D. The next 
figure shows a schematic of the hinge's assembly. 

 

The manufacturer wants to determine the percentage of hinges that would fall out of 
specifications. Specifically, the manufacturer wants to estimate the probability that (A+B+C) will 
be greater than D. 

For that purpose, data sets were collected for the dimensions of each of the manufactured 
components. Of each of the components A, B, C and D, seven units were taken from the 
assembly line and the following measurements were recorded. 

Dimensions for A 
(cm) 

Dimensions for B 
(cm) 

Dimensions for C 
(cm) 

Dimensions for D 
(cm) 

2.0187 1.9795 30.4216 33.6573 

1.9996 2.0288 29.9818 34.5432 

2.0167 1.9883 29.9724 34.6218 

2.0329 2.0327 30.192 34.7538 

2.0233 2.0119 29.9421 35.1508 

2.0273 2.0354 30.1343 35.2666 

1.984 1.9908 30.0423 35.7111 
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Obtain Distributions for the Part Dimensions 

The first step in this analysis is to model the dimensions of each of the parts using the recorded 
data. To do this, create a Weibull++ life data folio configured for times-to-failure. Name this 
folio "Components." Then enter the dimension measurements into the new folio with a 
separate data sheet for each component. 

Next, analyze each data set assuming a normal distribution and RRX as the analysis method. 
Below is the "Components" folio with the analysis results for component D displayed. After the 
parameters for each data set are calculated, Monte Carlo simulation can be performed to 
estimate the probability that (A+B+C) will be greater than D. 
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Use Monte Carlo Simulation to Generate a Data Set 

On the Home tab, click the Monte Carlo icon in the Insert gallery. (If you have Accelerated Life 
Testing activated on your computer, you will be given a choice between "Monte Carlo" or 
"Stress-Dependent Monte Carlo." Choose Monte Carlo.) 

In the Distribution area on the Main tab, choose User-Defined for the distribution and click the 
Insert Data Source button to insert the first data sheet from the "Components" folio. Click the 
button again to insert the second data sheet, and repeat until all four data sheets are entered. 
Edit the user-defined equation so it appears as shown next. 

'Components!A' + 'Components!B' + 'Components!C' - 
'Components!D' 

In the Data Points area on the Settings tab, enter 1000 for the number of data points. Choose 
to generate the data set in a new folio and new sheet, then click Generate to create the 
simulated data. 

Analyze the Data Set 

In the new data sheet that contains the simulated data, calculate the parameters, assuming a 
normal distribution and RRX as the analysis method. 

The following is a pdf plot of the simulated data for (A+B+C-D). 
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The probability that (A+B+C) > D is equal to the probability that (A+B+C-D) > 0. Thus, the area 
under the curve of the above pdf from time = 0 to infinity—where "time" is actually the value of 
(A+B+C-D)—will tell us how likely it is that the product will fall out of specifications (i.e., the 
likelihood that A+B+C will be greater than D). 

Use the QCP to calculate the probability, as shown next. (Note that we will use the Reliability 
option in the QCP, even though we are finding the likelihood of falling out of specifications, 
since the calculation we wish to perform is equivalent to finding the reliability of a randomly 
generated data set at time = 0.) 

The results show that the probability that (A+B+C) will be greater than D is about 16.05%. Note 
that your results may vary because the data were obtained through simulation. 
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SimuMatic 

SimuMatic generates multiple data sets using Monte Carlo simulation. (See Monte Carlo Utility 
for information about how each data set is generated.) It then analyzes each data set 
individually (e.g., to find the reliability at a specified time) and the group of data sets as a whole 
(e.g., to find the average reliability at a specified time across the data sets). 

To create a SimuMatic folio for life data or life-stress data, choose Home > Insert > SimuMatic 
and choose either the SimuMatic or Stress-Dependent SimuMatic option. 
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Main, Censoring and Settings Tabs 

The Main, Censoring and Settings tabs of the SimuMatic setup window are the same as in the 
Monte Carlo Utility. The settings in these tabs determine how each data set is generated. 

On the Settings tab, you must enter the Number of data sets to generate. In most cases, you 
will want this number to be reasonably large (e.g., 1000). 

Analysis Tab 

• Analysis Method and Rank Method (available in for life data only) specifies the methods to 
use for calculating the parameters of the simulated data sets. Select the Use RS Regression 
Method check box to use the ReliaSoft ranking method (RRM) for interval data. If this check 
box is cleared or if there is no interval data, then the software will use the standard ranking 
method (SRM). 

• Confidence Bounds on Plots displays the specified confidence bounds in plots that are 
based on the generated data points. For example, if you enter 90, the plot sheet of the 
SimuMatic folio will display the 90% two-sided confidence bounds on the plots. 

Test Design Tab (Optional) 

The Test Design tab of the setup window allows you to use SimuMatic to design or evaluate a 
reliability test. The software will analyze the data sets in order to estimate the time at which 
the product would have a specified reliability (i.e., the demonstrated life). This value can help 
you determine the combination of test time and sample size that will be adequate to 
demonstrate a required reliability target at a specified confidence level. 

Note: The software calculates the demonstrated time by taking each data set and solving for 
the time at which the specified target reliability would be reached. It then orders these time 
values to find the time value that corresponds to your specified confidence level. For example, 
if you enter 85 for the target reliability and 90 for the confidence level, the software will, for 
each data set, solve for the time at which a product described by that data set's model would 
have a reliability of 85%. It would then order the calculated time values and locate the value in 
the 10th percentile, which is reported as the 90% lower one-sided confidence bound for the 
demonstrated time. 

Reliabilities and Times Tab (Optional) 

The Reliabilities and Times tab of the setup window allows you to calculate the time for every 
given reliability, and/or calculate the reliability for every given time. You can enter up to 10 
reliability values (as decimals less than 1) and up to 10 time values. 
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For example, if you enter 0.5 in the Reliabilities area, the data sheets in the SimuMatic folio will 
display the estimated time when the reliability will be equal to 50%. If you enter 100 in the 
Times area, the reliability at time 100 will be displayed. 

For reliability growth data analysis only. 

Weibull++'s Repairable Systems SimuMatic tool generates multiple data sets using Monte Carlo 
simulation. It then analyzes each data set individually (e.g., to find the instantaneous MTBF at a 
specified time) and also analyzes the group of data sets as a whole (i.e., it shows the average 
and median parameter values for all data sets). 

To create a SimuMatic folio for growth data, choose Home > Insert > SimuMatic and choose 
the Repairable Systems SimuMatic option. 

 

The setup window will appear. Follow the steps outlined below to generate and analyze the 
simulated data sets. 

1. On the Main tab of the window, select a data type and time units in the Data Type area. In 
the Parameters area, enter the beta and lambda values for the Crow-AMSAA model that 
will be used to generate the data set. 
 
In the Data Sets / Points area, enter the following information: 

• Specify the Number of Data Sets that will be generated. 

• Specify the Number of systems for which data will be generated. This value is fixed at 1 
unless you selected a multiple systems data type on the Main tab (i.e., Multiple 
Systems - Concurrent or Repairable Systems). 

• Use the Test termination field to specify what will determine the end of the 
observation period for the simulated data. 

• If the period will end after a specific number of failures have been observed, 
choose Failure Terminated from the drop-down list and enter the number of 
Failures in the next field. 

• If the observation period will end at a specific time, choose Time Terminated from 
the drop-down list and enter a Time in the next field. 

• If you selected to generate Grouped Failure Times data, click the Set Intervals link to 
open a window that allows you to specify the intervals that will contain the failures. 
You need at least three intervals to simulate this type of data. 
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2. On the Settings tab, specify how you want to generate the data set and where you want the 
data to be stored. 

• Select the Use Seed check box if you would like to set a consistent starting point from 
which the random numbers will be generated. Using the same seed value and keeping 
all other settings the same will allow you to replicate your results. 

• In the Math Precision area, enter the number of decimal places that will be used for 
each simulated data point. (This does not affect the precision used in the calculated 
parameters and other results.) 

3. On the Analysis tab, enter the bounds that will be shown in the SimuMatic plots. For 
example, if you enter 90, then the plots will show 90% one-sided upper and 90% one-sided 
lower confidence bounds. 

4. On the Test Design tab, select the Calculate Target Time check box if you wish to a) 
calculate the time at which the demonstrated MTBF reaches a certain value and b) mark 
the lower confidence bound on this value on the instantaneous MTBF vs. time plot. For 
example, if you wanted to know the time for an instantaneous MTBF of 1,000 hours, then 
you would enter 1,000 in the Instantaneous MTBF field. To mark the 90% lower confidence 
bound on this value in the IMTBF vs. time plot, you'd enter 90 in the Lower 1-sided 
Confidence Level field. 

5. On the Results tab, specify the metrics that will be calculated. 

• The first four areas are for instantaneous MTBF calculations (i.e., the MTBF over a small 
interval dt that begins at a specified time) and cumulative MTBF calculations (i.e., the 
MTBF from time = 0 up to a specified end time). Click the arrow to open a drop-down 
table where you can enter the user-specified values. 

• The two areas on the left (e.g., Instantaneous MTBF Given Time) allow you to 
specify up to ten different times and SimuMatic will calculate the MTBF(s). 

• The two areas on the right (e.g., Time Given Instantaneous MTBF) allow you to 
specify up to ten different MTBFs and SimuMatic will calculate the time(s). 

• In the Metrics to Calculate area, select the metrics you wish to calculate for each data 
set. You can then use the results on the Sorted sheet to estimate, for example, the one-
sided 90% lower confidence bound on any of these values at the end of the test. (See 
SimuMatic Example.) 

6. Click the Generate button to create and analyze the data. The results will be displayed in 
the Repairable Systems SimuMatic folio. 
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Life Data and Life-Stress Data SimuMatic Folio 

The SimuMatic folio gives you access to the data sets generated by the SimuMatic utility and to 
the results of analyses on those data sets. 

Simulation Sheet 

The Simulation sheet shows the parameters calculated for each data set. It also contains a 
separate column for each of the calculations that you specified on the Reliabilities and Times 
tab of the setup window. The following example shows the results for the first ten data sets 
created with SimuMatic. 

 

• Beta and Eta (hr) are parameter columns. Parameter columns show the estimated 
parameters for each data set based on your selected distribution and analysis method. For 
parameters with an associated unit of measurement (e.g., the Weibull shape parameter 
eta), the unit will be indicated in the column heading. 

• T(0.9) is a time value column. It displays the time value calculations based on the calculated 
parameters and a reliability value you entered in the Reliabilities and Times tab of the setup 
window. In this example, it shows the time at which the product’s reliability is expected to 
be 0.9, or 90%. 

• R(100) is a reliability value column. It displays the reliability calculations based on the 
calculated parameters and a time value you entered in the Reliabilities and Times tab of the 
setup window. In this example, it shows the reliability value at time = 100. 
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Note: "N/A" will appear in the parameter columns if there was an error in calculating a 
particular data set. This is usually an indication that there were not enough failure times in the 
data set to calculate the parameters. 

Sorted Sheet 

In the Sorted sheet, the calculated values from the Simulation sheet are sorted from least to 
greatest in order to show the confidence bounds. Assuming all the simulated data sets have 
calculated parameters, the Percentage column will display the percentage of data sets that are 
equal to or less than a given data set. So, for example, if you wished to obtain the 90% lower 
one-sided confidence bound of R(100), you would look up the value of R(100) that corresponds 
to 10% (i.e., 100% - 90%). 

 

If you wished to obtain the 90% two-sided confidence bounds of R(100), you would look up the 
values that correspond to 5% (for the lower bound) and 95% (for the upper bound). 

This concept is summarized in the figure shown below. 



Chapter 14: Simulation 

Weibull++ 2020 User's Guide 1077 

 

 

SimuMatic Control Panel 

The SimuMatic control panel and its components are described next. 

• Distribution area displays the type of distribution that was used to generate each data set. 

• Analysis Settings area displays what analysis settings were used to analyze the simulated 
data. 

• Analysis Summary area displays the parameters that were used to generate each data set. 

• Additional Results area: 

• T(i) (...) button opens a report that displays each data set in its own column or group of 
columns. Each calculated data set is separated from the others with an empty data 
sheet column. This report will contain multiple sheets when there are too many data 
points to fit onto one sheet. 

Note: Data sets without enough data points to fit to a model (i.e., those with an "N/A" 
in the parameter columns of the SimuMatic's data sheet) will not be shown in this 
report. 

• Summary (...) button opens a report that displays the settings used to generate the 
data. It also displays information about the variation of the parameter values and, if 
you entered a target reliability on the Test Design tab of the setup window, it will 
display the results as well. 

The following tools are available on the SimuMatic control panel: 



Chapter 14: Simulation 

1078 https://www.reliasoft.com/weibull 

 

  SimuMatic Setup allows you to change your simulation settings and replace your 
current simulated data sets with new ones. 

  Plot generates a probability plot of all the data sets. 

  Transfer Life Data to Selected Folio is available only for life data. It transfers the 
simulated data set to an existing Weibull++ life data folio, with one data sheet for each 
parameter of the model that was used to generate the data. 

  Transfer Life Data to New Folio is available only for life data. It transfers the simulated 
data set to a new Weibull++ life data folio, with one data sheet for each parameter of the 
model that was used to generate the data. 

Plot Sheet 

The following options on the plot sheet are unique to SimuMatic plots. They allow you to 
control which elements will be displayed on the plot. See Plot Utilities for more general 
information on plot sheets. 

• Simulation Lines plots the time vs. unreliability line for every simulated data set. 

• True Parameter Line plots the time vs. unreliability line defined by the parameters of the 
distribution that was used to generated the simulated data. (These parameters are visible 
on the control panel of the Simulation sheet.) 

• Median Line plots the time vs. unreliability line defined by the median parameters of all 
generated data sets. 

• Average Line plots the time vs. unreliability line defined by the average parameters of all 
generated data sets. 

• Bounds on Reliability and Bounds on Time show confidence bounds on the plot. The 
percentile of the confidence bounds is determined by what you entered in the Analysis tab 
of the setup window. For example, if you entered 90% in the setup window and selected 
Bounds on Time, then the displayed confidence bounds would mark the simulated time 
values at the 10th (90% lower bound) and 90th (90% upper bound) percentile for every 
given reliability value. 

• Target is available only if you have specified a target reliability on the Test Design tab of the 
setup window. This option marks the target reliability as a point at the intersection of a 
horizontal line drawn at the target unreliability and a vertical line drawn at the target time. 
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Repairable Systems SimuMatic Folio 

For reliability growth data analysis only. 

The Repairable Systems SimuMatic folio gives you access to the generated data sets and to the 
results of analyses performed automatically for those data sets. 

Simulation Sheet 

The Simulation sheet shows the parameters calculated for each data set. It also contains a 
separate column for each of the calculations that you specified on the Analysis and Results tabs 
of the setup window. The following columns may be included in the Simulation sheet, 
depending on the metrics you chose to calculate in the Repairable Systems SimuMatic Setup 
window. 

• Beta and Lambda of the Crow-AMSAA model are the calculated parameters for each data 
set. 

• The following values are calculated according to the inputs you provided on the Analysis 
tab of the setup window. 

• Target DMTBF is the time required to demonstrate the specified MTBF. 

• DMTBF is the demonstrated MTBF at the end of the test. 

• DFI is the demonstrated failure intensity at the end of the test. 

• Growth Rate is equal to 1 - beta. A larger growth rate means faster MTBF growth. 

• The following values are calculated according to the inputs you provided on the Results tab 
of the setup window. 

• IMTBF(t) and CMTBF(t) are the instantaneous/cumulative MTBF at a specified time, t. 

• T_IMTBF(m) and T_CMTBF(m) are the time given a specified instantaneous/cumulative 
MTBF, m. 

As an example, the following picture shows the results from the first ten data sets for a 
particular simulation. In this case, the analysts chose to display only the Crow-AMSAA model 
parameters (Beta and Lambda), the growth rate, the instantaneous MTBF at 15,000 hours 
(IMTBF(15000) and the lower confidence bound on the time at which the demonstrated MTBF 
reached a specified target value (Target DMTBF). 



Chapter 14: Simulation 

1080 https://www.reliasoft.com/weibull 

 

 

Sorted Sheet 

In the Sorted sheet, the calculated values from the Simulation sheet are sorted from least to 
greatest in order to show the confidence bounds. The Percentage column displays the 
percentage of data sets that are equal to or less than a given data set. So, for example, if you 
wished to obtain the 90% lower one-sided confidence bound on the instantaneous MTBF at 
15,000 hours, you would look up the value of IMTBF(15000) (hr) that corresponds to 10% (i.e., 
100% - 90%), as shown next. 

 

Alternatively, if you wished to obtain the 90% two-sided confidence bounds of IMTBF(15,000), 
you would look up the values that correspond to 5% (for the lower bound) and 95% (for the 
upper bound), as illustrated in the next figure. 
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Control Panel 

The SimuMatic control panel and its components are described next, 

• The Model area always displays "Crow-AMSAA (NHPP)" because this is the only model 
Reliability Growth SimuMatic uses to generate simulated data. 

• The Analysis Settings table shows what settings were used in the analysis of each data set. 
These settings will vary depending on the data type selected. 

As an example, the following picture shows the settings that are used for the Failure Times 
data type. The settings show the type of data (Developmental – Failure Times), parameter 
estimation method (MLE), confidence bounds method (Crow), whether a gap interval has 
been defined in the analysis (No Gap) and whether the failure times are entered as 
cumulative or non-cumulative (Cumulative). 

 

• The Parameters area displays the Crow-AMSAA model parameters that were used to 
generate the data. 

• In the Additional Results area: 

• The T(i) (...) button opens a report that displays each data set in its own column. (Note 
that this report will contain multiple sheets when there are too many data points to fit 
onto one sheet.) 
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• The Summary (...) button opens a report that displays the settings used to generate the 
data. It also displays the average and median parameter values of the data sets. 

The following tools are available on the SimuMatic control panel: 

  SimuMatic Setup allows you to change your simulation settings and replace your 
current simulated data sets with new ones. 

  Plot generates the Plot sheet, which allows you to view the five different plots based 
on the simulated data. 

Plot Sheet 

In the plot sheet, five different kinds of plots are available in the Plot Type drop-down list on 
the control panel. 

• Cumulative Number of Failures gives an indication of how the number of failures is 
increasing over time. It plots the times on the x-axis and the cumulative number of failures 
on the y-axis. The points represent the actual failure times in the data set, and the solution 
line represents the expected cumulative number of failures based on the calculated model 
parameters. The vertical line represents the test termination time. 

• The Cumulative MTBF vs. Time and Instantaneous MTBF vs. Time plots show how the time 
between consecutive failures increases, decreases or remains constant over time. 

• The cumulative MTBF is the MTBF from time = 0 up to a given end time. For example, a 
cumulative MTBF of 5 hours from 0 to 100 hours means that, on average, the time 
between failures was 5 hours over the 100-hour period. 

• The instantaneous MTBF is the MTBF over a small interval dt that begins at a given 
time. For example, an instantaneous MTBF of 5 hours at 100 hours duration means 
that, over the next small interval dt that begins at 100 hours, the average MTBF will be 
5 hours. 

• The Cumulative Failure Intensity and Instantaneous Failure Intensity plots show how the 
failure intensity changes over time. 

• The cumulative failure intensity is the average failure intensity from the beginning of 
the test (i.e., t=0) up to a given time. 

• The instantaneous failure intensity is the failure intensity over a small interval dt that 
begins at a given time. 
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The following options on the plot sheet are unique to SimuMatic plots. They allow you to 
control which elements will be displayed on the plot. See Plot Utilities for more general 
information on plot sheets. 

• Simulation Lines plots the line (e.g., cumulative MTBF vs. time) for every simulated data 
set. 

• True Parameter Line plots the line defined by the parameters of the Crow-AMSAA model. 
(These parameters are visible on the control panel of the Simulation sheet.) 

• Median Line and Average Line plots the lines defined by the median and average 
parameters of all generated data sets. 

• CB on Function and CB on Time plot two-sided confidence bounds on the plot. The 
"Function" is determined by the current plot type (e.g., cumulative MTBF is the function for 
the cumulative MTBF vs. time plot). The percentile of the confidence bounds is determined 
by what you entered for Confidence Bounds on Plot on the Analysis tab of the setup 
window. 

• Target is available when you have selected the Calculate Target Time option on the 
Analysis tab of the setup window. This option marks the target time on the instantaneous 
MTBF/FI vs. time plots. 

Transferring Data to a Life Data Folio 

The Life Data SimuMatic folio allows you to transfer the calculated parameter values for each 
simulated data set to a new or existing life data folio, with one data sheet for each parameter 
of the model that was used to generate the data. Uncalculated data sets (i.e., those showing 
"N/A" in the parameter column of the SimuMatic folio) will be ignored. 

Transferring to a New Folio 

To transfer data to a new folio, choose SimuMatic(W) > SimuMatic > Transfer Life Data to New 
Folio or click the icon on the control panel. 

 

Select whether the data will be transferred to a free-form or times-to-failure data sheet, as 
shown next. After you click OK, a new life data folio will be created containing the simulated 
data in the selected format. 
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Transferring to an Existing Folio 

To transfer data to an existing folio, choose SimuMatic(W) > SimuMatic > Transfer Life Data to 
Selected Folio or click the icon on the control panel. 

 

After you select whether the data will be transferred to a free-form or times-to-failure data 
sheet, the Transfer Life Data window will appear, as shown next. 

 

Select the folio that the data will be transferred to. 

• If the Replace sheets with same names option is selected, the software will replace any 
data sheets that have the same name as the data to be transferred. For example, if a 
selected folio already has a Beta sheet and you will be transferring beta values calculated in 
SimuMatic, then the software will replace the data in the current Beta sheet with the new 
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beta values. If this option not selected, then the software will always create a new sheet in 
the selected folio. 

• Click the Add Folio button to automatically generate a blank life data folio and display it in 
the window. 

Designing Reliability Tests with SimuMatic 

One of the applications of SimuMatic is simulating the outcome from a particular test design 
that is intended to demonstrate a target reliability. You can specify various factors of the 
design, such as the test duration (for a time-terminated test), number of failures (for a failure-
terminated test) and sample size. By running the simulations you can assess whether the 
planned test design can achieve the reliability target. Depending on the results, you can modify 
the design by adjusting these factors and repeating the simulation process—in effect, 
simulating a modified test design—until you arrive at a modified design that is capable of 
demonstrating the target reliability within the available time and sample size constraints. 

Tip: SimuMatic is useful for designing tests where there will be enough failure times observed 
during the test to analyze the data and fit a life distribution (e.g., two or more observed failures 
are required for most 2-parameter distributions). To design a test that demonstrates the target 
reliability with minimal “allowable failures” (e.g., a zero-failure test), use the Reliability 
Demonstration Test Design tool. 

Recommended Settings 

Below are some recommended settings for using SimuMatic to design a reliability life test. The 
options described here can also be used for other types of what-if analyses designed to explore 
the life estimates that can be obtained from different types of data sets. 

On the Settings tab: 

If you are solving for the sample size, start with a large number of data points. You can later 
repeat the simulation with smaller values until you arrive at an acceptable test plan. (In the 
Stress-Dependent Monte Carlo utility, use the data sheet on the right side of the window to 
specify the number of data points for each stress level.) 

Make sure an appropriate number of data sets (e.g., 1,000) has been specified in the Number 
of Data Sets field. Lower numbers may lead to less accurate results. 

On the Censoring tab: 

• If you are designing a test that will end only after all units fail, select No censoring. All 
simulated time values will be considered failure times. 
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• If you are designing a time-terminated test (i.e., a test that will end at a specified time), 
select Right censoring after a specific time and enter an estimated test duration in the 
Time field. All simulated time values that exceed this limit will be considered suspensions at 
the specified time (i.e., units that had not failed by the end of the test). If you are solving 
for the required test duration, enter a large estimate, and then you can repeat the 
simulation with smaller values until you arrive at an acceptable test plan. 

Note: A short censoring time may create many data sets with too few failures to estimate 
an underlying life distribution. These data sets will display "N/A" for the parameters on the 
SimuMatic folio's data sheet. This can be due to an insufficient sample size or a test 
termination time that is too short. As a rule of thumb (and for 2-parameter distributions) 
the combined sample size and test duration should be sufficient to observe three or more 
failures. In other words, if you have a sample size of 10 then the test duration should be 
greater than the product's B30 life (i.e., the time at which unreliability = 30%). 

• If you are designing a failure-terminated test (i.e., a test that will end after a specified 
number of failures occur), select Right censoring after a specific number of failures and 
enter a value in the Number of Failures field. The tool will simulate a test that ends after 
this number of failures, with the surviving units marked as suspensions. If you are solving 
for the number of failures needed, enter a large estimate, and then you can repeat the 
simulation with smaller values until you arrive at an acceptable test plan. 

Tip: In the Life Data SimuMatic utility, you can also choose the Random censoring option if you 
wish to explore the results that can be obtained from data sets that contain certain types of 
uncertainty. In this type of analysis, you can use the T1, T2 and DELTA values to estimate 
whether you'll be able to use the data set to demonstrate a required reliability target and 
evaluate how much the demonstrated life varies from the intrinsic reliability. 

On the Test Design tab: 

Select to Calculate test plan results and enter the Target Reliability you wish to demonstrate 
along with the Lower 1-Sided Confidence Level at which you want to demonstrate it. 

Evaluating the Results 

After generating the simulated data set, click the Summary (...) icon inside the Additional 
Results area of the control panel to view a report of the results. The Test Planning Results area 
of the report displays your test design inputs (reliability requirement, confidence level and 
sample size) along with the following results: 

• Expected Life (T1) is the lower one-sided confidence bound on the reliable life (i.e., the 
time for a given reliability) calculated based on the specified distribution/parameters. This 
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value represents the intrinsic reliability of a product with the specified 
distribution/parameters. So if this value does not meet your reliability goal, then it is not 
possible to demonstrate the desired reliability for a product with your assumed life 
distribution, regardless of the test time or sample size that is employed. 

• Demonstrated Life at Given Confidence (T2) is the lower one-sided confidence bound on 
the reliable life calculated based on the simulated data sets. Specifically, SimuMatic 
calculates the time given reliability for each data set and then sorts the results to obtain the 
value associated with the specified confidence level percentile. You can then compare this 
value to the time for which you want to demonstrate the reliability (e.g., you might want to 
demonstrate that the product will have a reliability of 95% at 1,000 hours, at the 90% 
confidence level). 

• If the demonstrated value is greater than your reliability goal, then SimuMatic predicts 
that the specified test plan would demonstrate the target. For example, if you wish to 
demonstrate that the product has a reliability of 95% at 1,000 hours and T2 = 1,200, 
then SimuMatic predicts that the test plan would demonstrate the target. 

• If the demonstrated value is less than your reliability goal, then SimuMatic does not 
predict that your test plan would demonstrate the target. For example, if you wish to 
demonstrate that the product has a reliability of 95% at 1,000 hours and T2 = 800, then 
SimuMatic does not predict that the test plan would demonstrate the target. 

• Ratio of Expected Life/Demonstrated Life (DELTA) is a measure of the difference between 
the intrinsic reliability of your product (T1) and the life demonstrated by analyzing the 
simulated data (T2). This value is calculated by dividing the expected life by the 
demonstrated life. For example, if your test design would demonstrate a reliability of 90% 
at 50 hours (demonstrated life), and your product has an intrinsic reliability of 90% at 100 
hours (expected life), then DELTA = 2. 

• Expected Test Duration (T3) is the average of the last failure or suspension time from each 
of the simulated data sets. In most contexts, this value provides an indication of how long 
you would need to run a test in order to demonstrate the reliable life calculated in T2. In 
the case of a time-terminated test, you can compare this value against the specified 
censoring time. If the censoring time (i.e., planned test time) is greater than T3, you may 
choose to repeat the simulation with smaller test times to see if it’s feasible to demonstrate 
the target with a less costly test plan. In addition, note that: 

• T3 is an average of all the test runs. 

• T3 is calculated based on the simulated data sets, and therefore it can never be greater 
than the specified censoring (test) time. If you set a test time that is too small, T3 may 
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be identical to the censoring time but the test plan is still not adequate unless the 
demonstrated life (T2) also meets the requirement. 

If the results indicate that you will not be able to demonstrate the target reliability, or if they 
indicate that the current test plan uses more samples or more test time than necessary to 
demonstrate the target, you can keep repeating the simulation with gradual adjustments until 
you arrive at an optimum plan. 

Note that because the results are obtained through Monte Carlo simulation, you may arrive at 
slightly different answers each time you run the analysis. 

See Life-Stress SimuMatic Example for an example of designing a reliability test with SimuMatic. 

Life Data SimuMatic Example 

This example uses the Life Data SimuMatic to compare different parameter estimation methods 
for a sample of 10 units following a Weibull distribution where beta = 2 and eta = 100, with all 
units tested to failure. 

Generate Data Sets 

1. Choose Home > Insert > SimuMatic and choose the SimuMatic option. 

2. On the Main tab of the setup window, select the 2P-Weibull distribution and select Hour 
(hr) for the time unit. Enter 2 in the Beta field and 100 in the Eta field. 

3. On the Censoring tab, select No censoring. 

4. On the Settings tab, enter 1000 in the Number of data sets field and enter 10 in the 
Number of points field. 

5. On the Analysis tab: 

• Choose Maximum Likelihood (MLE) from the Analysis Method drop-down list. This 
method will be used to estimate the parameters of the generated data sets. 

• Choose Median Ranks from the Rank Method drop-down list and clear the Use RS 
Regression Method check box. Enter 90 in the Confidence Level field. 

6. Click Generate to create and analyze the data. A SimuMatic folio will appear. 

7. Click Plot on the control panel. You will be taken to the plot sheet of the folio. In the Show 
area of the control panel, make sure the following options are selected: 

• Simulation Lines 
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• True Parameter Line 

• Median Line 

• Bounds on Reliability 

8. Click Plot again to refresh the plot display all the selected lines. 

To compare RRX to the rank regression on Y (RRY) and maximum likelihood estimation (MLE) 
methods, repeat the steps above, but choose a different option in the Analysis Method drop-
down list on the Analysis tab. Then compare the three plots. 

Compare the Plots 

The plots for the three methods are shown below: 

 
RRX Method 
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RRY Method 
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MLE Method 

The true parameter line (black) shows the time vs. unreliability defined by the parameters of 
the distribution that was used to generated the simulated data. The median line (yellow) shows 
the time vs. unreliability defined by the median parameters of all generated data sets. By 
comparing these two lines, you can estimate how close the estimated parameters would be to 
the product's assumed parameters (which you provided in the setup). The plots above show 
that RRX would provide the least deviation (i.e., "bias") from the truth for this sample size and 
data type. 

The lines marking the lower and upper confidence bounds on reliability (pink) allow you to 
determine how closely grouped together the parameter estimation results are. The plots above 
show that MLE would provide results with less variation than any of the other analysis methods 
for this sample size and data type. 

Thus given our relatively small sample size and uncensored data, RRX is shown to be best in 
terms of bias, while MLE is shown to be best in terms of variation (the median line and true 
parameter line overlap almost perfectly). 
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Life-Stress Data SimuMatic Example 

For life-stress data only. 

This example uses the Stress-Dependent SimuMatic utility to verify whether a proposed test 
plan could be used to demonstrate, with 95% confidence, that a product has a reliability of at 
least 90% at 650 hours at the use stress level of 300 K. 

The engineers have prior experience with a similar design, and as a result they expect the 
product to have an unreliability of 40% at 7,000 hours under normal conditions. At 340 K, they 
expect the product to follow a Weibull distribution, where eta = 500 hours. The life-stress 
relationship is assumed to be Arrhenius, and for all stress levels the life distribution is assumed 
to be Weibull, where beta = 1.5. 

The proposed plan is to test 20 units at 325 K and 15 units at 340 K. All units will be tested to 
failure. The objective is to determine whether this test plan will meet the reliability goal: 

Generate Data Sets 

1. Choose Home > Insert > SimuMatic and choose the Stress-Dependent SimuMatic option. 

2. On the Main tab of the setup window, select the Arrhenius-Weibull model and select Hour 
(hr) for the time unit. Enter 1.5 for the beta parameter. 

3. Because we do not have the values of B and C available, we will use the Quick Parameter 
Estimator to solve for those parameters and transfer them to the setup window. Click the 
Quick Parameter Estimator button to open the utility. The Arrhenius-Weibull model and 
Hour units should be automatically selected in the Model area. 

• In the Quantification Method area, choose Unreliability and a Parameter. 

• In the Point #1 area, enter 7000 for the time and 0.4 for the unreliability. 

• In the Solve for Parameter area, select Eta and then enter 1.5 in the Beta field. 

• In the Use Stress Level area, enter 300 for the use stress level. 

• Click the Next> button to go the second page. Then enter 340 for the accelerated stress 
level and 500 for the characteristic life (i.e., eta). 

• Click Next> to see the calculated values for the B and C parameters, which are shown to 
be 7871.5321 and 4.4093E-08, respectively. Click the Update button to transfer the 
values to the SimuMatic setup window. 
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4. On the Stress tab of the SimuMatic window, enter the use stress level of 300 K. 

5. On the Censoring tab, select No censoring. 

6. On the Settings tab, set the Number of data sets to 1000. Use the default values in the 
other fields. 

7. In the data sheet on the right side of the window, enter the number of units that will be 
tested for each stress level, as shown next. 

 

8. On the Test Design tab, enter 90 in the Target Reliability field and 95 in the Lower 1-Sided 
Confidence Level field. 

9. Click Generate to create and analyze the simulated data sets. A SimuMatic folio will appear. 

View the Results 

In the SimuMatic folio, open the Results window by clicking Summary in the Additional Results 
area of the control panel. 

In the results, T1 confirms that the product's intrinsic reliability is high enough to meet the 
target reliability. Also, because T2 is greater than the time at which the engineers want to 
demonstrate the target reliability, SimuMatic predicts that the given test plan is acceptable. The 
engineers may then choose to decrease the number of points and repeat the simulation to 
determine whether a more efficient plan is possible. Note that your results may vary because 
the data were obtained through Monte Carlo simulation. 
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Repariable Systems SimuMatic Example 

For reliability growth data analysis only. 

The data set used in this example is available in the example database installed with the 
software (called "Weibull20_ReliabilityGrowth_RGA_Examples.rsgz20"). To access this database 
file, choose File > Help, click Open Examples Folder, then browse for the file in the Weibull sub-
folder. 

The name of the project is "RGA SimuMatic." 

A reliability engineer is developing a reliability growth test plan for a new system. The target 
MTBF that she needs to demonstrate at the end of the test is 800 hours with 90% confidence. 
There will be 2,000 hours of test time available. Before she can perform the test, she needs to 
determine the number of prototypes that must be tested in order to demonstrate the target. 
Based on historical data, the expected beta and lambda parameters for the Crow-AMSAA 
model are 0.55 and 0.21, respectively. 

The SimuMatic folio called "Test Design - 10 Systems" contains all the simulated data and 
analysis results based on the assumption that 10 systems will be tested. To recreate this folio 
on your own, follow the steps described next. 

1. Choose Home > Insert > SimuMatic and choose the Repairable Systems SimuMatic option 
to open the SimuMatic Setup window. 

2. On the Main tab of the setup window, select the Multiple Systems - Concurrent data type 
and choose Hour (hr) for the time units. Then, in the Parameters area, enter 0.55 for beta 
and 0.21 for lambda. 

3. In the Data Sets / Points area on the Main tab, specify that you will create 200 data sets in 
order to simulate a time terminated test that ends at 2,000 hours. As a conservative guess, 
enter 10 for the Number of systems that will be tested. The area will appear as shown next. 

 

4. On the Settings tab, select the Use Seed check box and enter a seed value of 1. Then enter 
4 in the Math Precision area. 
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5. On the Analysis tab, enter 90 in the Confidence Bounds on Plot area to specify the bounds 
that will be available to show in all the plots. In this case, lines will be available that show 
the 90% one-sided lower bound and 90% one-sided upper bound. 

6. On the Test Design tab, select the Calculate Target Time option, then specify that you will 
estimate the test time required to demonstrate an instantaneous MTBF of 800 hours. To 
place a target point on the instantaneous MTBF vs. time plot that marks the 90% lower 
one-sided confidence bound on the required test time, enter 90 in the Lower 1-sided 
Confidence Level field. 

 

7. On the Results tab, select the Demonstrated MTBF option and clear all other options and 
inputs. You can use the Clear All icon  to delete any values entered in the first four areas. 

8. Click the Generate button to create and analyze the data. 

The Simulation sheet of the new SimuMatic folio displays the results for each data set in 
separate rows on the Simulation sheet, as shown next (where the parameters and calculated 
results for the first 22 data sets are visible). 
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The Beta and Lambda columns display the parameters that were calculated for each data set. 
The DMTBF (hr) column shows the demonstrated MTBF at the end of the test, and the last 
column shows the test time required to demonstrate the target MTBF (an instantaneous MTBF 
of 800 hours, as specified on the Analysis tab of the setup window). 

The Sorted sheet shows the results for each column sorted from least to greatest. On this sheet, 
you can see the demonstrated MTBF at the 10th percentile of the results (i.e., 90% one-sided 
lower bound), shown next. 
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This shows, with 90% confidence, that the demonstrated MTBF at the end of a 2,000-hour test 
will be at least 647.0804 hours. 

The T(IMTBF=800 hr) column displays the total accumulated test time required to demonstrate 
the MTBF goal of 800 hours. You will use the required test time to calculate the number of 
systems that need to be tested. 

On the Sorted sheet, you can see that the 90% upper one-sided confidence bound on the 
required test time is 29,806 hours, as shown next. 
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Given that each system in the test accumulates 2,000 hours of testing, the current plan of 10 
systems will lead to a total accumulated time of 20,000 hours. Therefore, approximately 10,000 
hours of additional test time are required in order to accumulate 29,535 test hours and reach 
the target MTBF. In other words, an additional 5 systems (each tested for 2,000 hours) will be 
needed to accumulate enough test time. 

To confirm that 5 additional systems will be enough to demonstrate the goal MTBF, return to 
the RGA SimuMatic Setup window and change the Number of systems on the Main tab to 15. 
Then perform the simulation again and check the 90% one-sided lower bound on the 
demonstrated MTBF. The "Test Design – 15 Systems" folio contains all the simulated data and 
analysis results based on the assumption that 15 systems will be tested. The lower bound on 
the demonstrated MTBF with 15 systems is shown next. 

 

According to this result, you know with 90% confidence that testing 15 systems for 2,000 hours 
will demonstrate an MTBF of at least 800.6462 hours at the end of the test. You conclude that 
15 systems will be sufficient to demonstrate the goal MTBF. 

Simulation Worksheets 

Simulation worksheets allow you to vary values that are used when simulating an RBD or an 
event analysis flowchart in BlockSim. This allows you to investigate the effect of one or more 
settings on the simulation results. 

Simulation worksheets consist of columns that can be defined as inputs or outputs. The input 
values are used during simulation, and they can be entered manually or transferred from a DOE 
experiment design. Values in output columns are determined through simulation. For example, 

https://www.reliasoft.com/products/reliability-analysis/blocksim
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you might design an experiment in a Weibull++ design folio and transfer all the factor level 
combinations to the simulation worksheet. Then you could simulate the experiment in BlockSim 
and transfer the output values back to the Weibull++ design folio to analyze the results. If, on 
the other hand, you do not want to test all combinations of all factor settings, you can enter the 
desired combinations of settings by hand. 

In general, using a simulation worksheet will include the following steps: 

• Create the Variables and the Diagram in BlockSim 

• Define the Factor Settings 

• Define the Simulation Worksheet Columns in BlockSim 

• Simulate the Worksheet in BlockSim 

• Analyze the Results in Weibull++ 

• Verify the Results in BlockSim 

Depending on what you are trying to achieve, some of the steps may not be necessary. 

In this topic, we will consider an example in which we explore options for maintaining a spare 
part pool, with a goal of maximizing system availability while minimizing the cost of the pool. 
The factors that we will vary are the number of spare parts initially in the pool, the frequency 
with which the pool is restocked and the number of parts added to the pool at each restock. 

CREATE THE VARIABLES AND THE DIAGRAM IN BLOCKSIM 

Build the diagram for the system in BlockSim. Use variables to represent the factors whose 
settings you want to investigate. Depending on the factors you are studying, you might use the 
variables directly (as field inputs for blocks and resources, or in equations and functions in 
event analysis flowcharts) or via a dynamic model. In RBDs, the following fields can be defined 
using a variable: 

• In standard blocks: 

• Current age 

• Duty cycle 

• Throughput 

• In contained standby blocks and contained load sharing blocks: 
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• Duty cycle 

• In subdiagram blocks: 

• Duty cycle 

• In crews: 

• Number of tasks (visible when there is a limit to the number of tasks the crew can 
perform at the same time) 

• In spare part pools: 

• Initial stock level 

• Capacity if Pool has maximum capacity is selected 

• For scheduled restocks: 

• Restock every 

• Number added per restock 

• For restocking as needed: 

• Restock when stock drops to 

• Number added per restock 

• For emergency spare provisions: 

• Number added per emergency 

• In scheduled tasks performed at fixed or dynamic intervals: 

• Interval value 

Any field that takes a model can use a dynamic model; it is up to you to decide if exploring 
various values for that field will yield useful results. 

IMPORTANT: In event analysis flowcharts, you will need to store the results of interest in 
variables. The When to Reset field for output variables must be set to Never Reset in order for 
the results to be available to the simulation worksheet. This ensures that the results are 
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available to the simulation worksheet, rather than the variables being reset to their initial 
values. 

Example 

The spare part pool that is used by the tasks in our example is configured as shown next. The 
cost per item is specified as a constant model equal to $10 and the holding cost is specified as a 
constant model equal to $10 per month. Since the factors of interest (i.e., the initial stock level, 
the frequency of restocking and the number added per restock) will not be held constant, they 
are assigned to variables. These variables represent factor values that will be specified in the 
simulation worksheet. 

 

DEFINE THE FACTOR SETTINGS 

For the factors of interest, you will decide on the settings to be used in simulation and the 
combinations of factor settings that should be tried (i.e., that will be used as inputs to the 
simulation). 
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• One way to do this is to build an experiment design in a Weibull++ design folio and then 
transfer the factor settings to a new simulation worksheet. After creating the DOE in 
Weibull++, choose Data > Simulation Worksheets > Transfer to Simulation Worksheet. 

 

This will ensure that the factor settings are tested in combinations appropriate to 
determine the effects of each factor and of factorial interactions. 

• In some situations, not all factor setting combinations may be possible. For instance, let's 
say that you are considering two versions of a part, one that costs $100 and has a reliability 
of 0.97 at 1,000 hours and another that costs $85 and has a reliability of 0.92 at 1,000 
hours. You can vary the cost of replacement and the block reliability to account for these 
scenarios. You would not, however, want to run a simulation using a cost of $85 and a 
reliability of 0.97, since that combination does not reflect an available part. In cases like 
this, you can add a new simulation worksheet to the project by choosing Home > Insert > 
Simulation Worksheet. 

 

After adding the new worksheet, you can enter the desired factor values manually, as 
shown next. (Note that the column names were changed by right-clicking each column 
heading and choosing Rename Column on the shortcut menu.) 

 

While you have the simulation worksheet open, it will be read-only in other applications. For 
instance, if you create the simulation worksheet in Weibull++, it will be read-only in BlockSim 
until you do one of the following: 

• Close the simulation worksheet, or 

• Click Commit and Lock on the control panel. This will commit the data in the simulation 
worksheet to the database and lock the simulation worksheet within the current 
application so that it will be available within other applications. 

In either case, if you already have the simulation worksheet open in a read-only state, you will 
need to click Unlock and Edit on the control panel once you have released the lock in the 
original application. 
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Example 

The experiment used in our example is a general full factorial design using the following 
settings: 

 

The first fifteen rows of the simulation worksheet that is created in the transfer process are 
shown next. 

 

DEFINE THE SIMULATION WORKSHEET COLUMNS IN BLOCKSIM 

Once the factor settings have been entered in the simulation worksheet, you will simulate the 
worksheet in BlockSim. The software will perform a set of simulations for each combination of 



Chapter 14: Simulation 

1104 https://www.reliasoft.com/weibull 

 

factor settings in order to obtain response values. In BlockSim, open the simulation worksheet 
and click the Simulate icon on the control panel. 

 

The Select Diagram window will appear, allowing you to select the diagram that will be used to 
simulate the response values (i.e., the data source) for the simulation worksheet. 

Note: You can also click the Associated Data Sources icon to specify or change the source 
diagram. 

The Worksheet Simulation window then appears, allowing you to specify the information 
contained in each column of the simulation worksheet. 

• In the Source of Variable Inputs area, assign the variables representing the factors of 
interest to the appropriate input columns in the worksheet. Available variables will be 
shown in the drop-down list for each column. If a factor of interest is represented by a 
dynamic model, choose the variable upon which the dynamic model is based. 

What's Changed? Starting in Version 11, you can choose to assign the simulation end time 
to one of the input columns. This allows you to obtain results as a function of time. 

• In the Simulation Output area, for each result column, specify the result to be entered: 

• If the associated diagram is a simulation RBD, define the function to calculate from 
each simulation. This is done by clicking the cell associated with the result column to 
open a limited version of the Function Wizard, where only the simulation functions are 
available. 

• If the associated diagram is an event analysis flowchart, select the variable to read for 
the result. 

Example 

The Worksheet Simulation window used in our example is shown next. 
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The output columns were specified as follows: 
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SIMULATE THE WORKSHEET IN BLOCKSIM 

With all columns defined, you can perform the simulation in BlockSim. 

• Click the Edit Simulation Settings button to open the Batch Mode Simulation Settings 
window. This is an abbreviated version of the Maintainability/Availability Simulation 
window or of the Flowchart Simulation window, depending on whether the associated 
diagram is a simulation RBD or an event analysis flowchart. The settings that you specify 
will apply to the simulation performed for each row (i.e., each factor setting combination). 
Specify the desired simulation settings and click OK to return to the Worksheet Simulation 
window. 

• Click Run to perform the simulations. The results will be entered in the simulation 
worksheet. 
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• Commit and lock the simulation worksheet to make it available for analysis in Weibull++. 

Example 

The simulation settings used in our example are shown next. 

 

The first fifteen rows of the simulation worksheet, with results, are shown next. 
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ANALYZE THE RESULTS IN WEIBULL++ 

The results that were derived from the simulation can now be analyzed. To do this: 

• Open the simulation worksheet in Weibull++. (If it was already open, click the Refresh icon 
on the control panel to load the results and unlock the simulation worksheet for use in 
Weibull++.) 

• Transfer the results to a design folio for analysis. You can do either of the following: 

• Transfer to Standard Design Folio transfers the defined input and output columns to 
the factor and response columns in an existing standard design folio. 

 

In the window that appears, select the design folio to transfer to and match up the 
columns in the design folio (factor/response columns) with the columns in the 
simulation worksheet (input/output columns), as shown next. 
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Note that all data will be transferred from the simulation worksheet, so if you have 
made changes to the input/factor columns in the simulation worksheet, those changes 
will be transferred to the design folio. 

• Transfer to Free Form Folio transfers the defined input and results columns to a new 
free form folio. 

 

You can then perform any analysis you choose in Weibull++, including optimization. 

Example 

The results of optimization for our example are shown next. A single optimal solution is found 
with Initial Stock Level = 1, Restock Time = 975.1698 and Number Added per Restock = 5. This 
gives a system availability of .9048 and pool cost of 1183.30. 
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VERIFY THE RESULTS IN BLOCKSIM 

Because BlockSim and Weibull++ rely on different methodologies to arrive at results, 
predictions made by Weibull++ will vary from the simulated results generated by BlockSim. 
Therefore, the optimal settings selected by Weibull++ must be simulated in BlockSim to ensure 
that the predicted results are reliable. To do this, return to BlockSim and, for each of the 
variables, set its initial value to the value given in the optimal solution and then simulate the 
diagram directly (i.e., not via the simulation worksheet) to make sure that the results are close 
to those estimated in Weibull++. 

Example: 

The simulation results from BlockSim are shown next. The results show a mean system 
availability of 0.8924 and a total cost for the pool of $1162.55. These values are very close to 
the estimated values in Weibull++. 
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Chapter 15: Quick Statistical Reference (QSR) 
Quick Statistical Reference 
The Quick Statistical Reference (QSR) tool allows you to easily calculate many common 
statistical values (e.g., median ranks and chi-squared values) and interpolate (or extrapolate) 
values using the polynomial interpolation function. 

To open the QSR, choose Home > ReliaSoft > Quick Tools > Quick Statistical Reference. 

 

The Function Option page of the QSR is for calculating statistical values. The Interpolation page 
is for interpolating (or extrapolating) values using the polynomial interpolation function. 

Calculating Statistical Values 
To calculate a statistical value, select the appropriate function option on left side of the 
Function Option page. Then enter the required inputs and click Calculate. The following options 
are available: 

• Median Ranks 

The Median Ranks option returns the probability of failure based on the sample size and 
order number of the failure. The probability estimates are at a 50% confidence level. 

The median rank is obtained by solving the following equation for Z: 

 

where: 

• N is the sample size. 

• j is the order number. 

• Z is the median rank. 
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• Other Ranks 

The Other Ranks option returns the probability of failure based on the sample size and 
order number of the failure. The probability estimates are at a confidence level percentage 
point that is specified by the user. 

The rank is obtained by solving the following equation for Z: 

 

where: 

• N is the sample size. 

• j is the order number. 

• P is the confidence level. 

• Z is the rank. 

• Standard Nominal Values 

The Standard Normal Tables option returns the probability of observing a value less than or 
equal to x on the standard normal curve, given a value for x. To find the value of x given the 
probability, use the Inverse Standard Normal Values option. 

The probability is obtained by solving the following equation for Z(x): 

 

where Z(x) is the probability of observing a value less than or equal to x. 

• Inverse Standard Normal Values 
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The Inverse Standard Normal Tables option returns a value for x on the standard normal 
curve, given the probability of observing a value less than or equal to x. To find the 
probability given x, use the Standard Normal Tables option. 

The output is obtained by solving the following equation for x: 

 

where Z(x) is the probability of observing a value less than or equal to x. 

• Cumulative Poisson 

The Cumulative Poisson option returns the probability of an event occurring n times during 
a specified interval. The required inputs are n and the average rate of occurrence for the 
event, λ, where λ > 0. 

The probability is obtained by solving for P(n, λ) in the following equation: 

 

where: 

• n is the maximum number of occurrences (and the upper limit of the summation). 

• λ is the average rate of occurrence for the event. 

• Cumulative Binomial Probability 

The Cumulative Binomial Probability option returns the probability of an event occurring k 
or more times in N trials. The required inputs are k, N and the probability (entered as a 
decimal number) of the event occurring per trial. 

The probability is obtained by solving for P in the following equation: 
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where: 

• P is the probability of the event occurring k or more times in N trials. 

• p is the probability of the event occurring per trial. 

• N is the minimum number of trials (and the end of the summation). 

• k is the minimum number of occurrences (and the starting point of the summation). 

• F-Distribution Values 

The F-Distribution option returns Q(F|n1, n2), the significance level at which we can reject 
the hypothesis that one sample has a smaller variance than another. The three inputs 
required are the degrees of freedom for both samples and the ratio of the observed 
dispersion of the first sample to that of the second. To find the ratio of the observed 
dispersion, use the Inverse F-Distribution Values option. 

The output is obtained by solving for Q(F|n1, n2) in the following equation: 

 

where: 

• n1 is the degrees of freedom for the first sample. 

• n2 is the degrees of freedom for the second sample. 

• F is the ratio of the observed dispersion of the first sample to that of the second. 

• B is the beta function. 
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• Inverse F-Distribution Values 

The Inverse F-Distribution option returns F, the ratio of the observed dispersion of one 
sample to that of another. The three inputs required are the degrees of freedom for both 
samples and the significance level at which we can reject the hypothesis that the first 
sample has a smaller variance than the second. To find the significance level at which we 
can reject the hypothesis, use the F-Distribution Values option. 

The output is obtained by solving for F in the following equation: 

 

where: 

• n1 is the degrees of freedom for the first sample. 

• n2 is the degrees of freedom for the second sample. 

• Q(F|n1, n2) is the significance level at which we can reject the hypothesis that the first 
sample has a smaller variance than the second. 

• B is the beta function. 

• Chi-Squared Values 

The Chi-Squared Values option returns the chi-squared value at the (1-d) percentile. The 
required inputs are the area to the right of the critical value and the number of degrees of 
freedom. 

The output is obtained by solving for in the following equation: 
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where: 

• d is the area to the right of the critical value. 

• v is the number of degrees of freedom. 

• X2 is a chi-squared random variable with v degrees of freedom. 

• Incomplete Beta Function 

The Incomplete Beta Function option returns the value of Ix(a,b). The required inputs are 
the values of x, a and b. 

The output is obtained by solving for Ix(a,b) in the following equation: 

 

where 0 < x < 1. 

• Gamma Function 

The Gamma Function option returns the value of Γ(n). The only required input is n. 

The output is obtained by solving for Γ(n) in the following equation: 

 

where n > 0. 

• Student's t Values 

The Student’s t Values option returns the t-value of the Student's t-distribution, given the 
probability of observing a value equal or less than the t-value and the number of degrees of 
freedom. 

The output is obtains by solving for t in the following equation: 
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where: 

• a is the probability of observing a value equal to or less than t. 

• v is the degrees of freedom. 

Interpolating a Value from a Data Set 
The Interpolation page uses the polynomial interpolation function to interpolate (or 
extrapolate) values given a set of known data points that you provide. 

The QSR attempts to fit a polynomial to the given data points. The polynomial is of the (i - 1) 
order, where i is the number of data points. You must enter at least 2 data points, and you 
cannot enter more than 10. 

Note that if the given data points are far from the point of interest, the resulting polynomial can 
oscillate between values, thus yielding erroneous results. Moreover, interpolation based on 
only data points, with no background information on the actual function, can also yield 
erroneous results. For these reasons, an approximate error value is returned with each 
interpolation. 

Follow the steps outlined below to obtain values with the QSR: 

• In the Input area of the Interpolation page, specify the number of data points you wish to 
enter in the Number of x-y Values field. Then click the Update button to create a table on 
the left of the page where you can enter the known data points that you wish to 
interpolate from. 

• In the table on the left side of the page, enter the x- and y-values data points that you wish 
to interpolate from. 

• In the Input area, enter the x-value for which the corresponding y-value will be obtained. 

• Click the Calculate button to obtain the corresponding y-value of the x-value you entered in 
the Input area. The y-value and an approximate error value are displayed in the Output 
area. 
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Chapter 16: Minimum Data Requirements 
Requirements for Weibull++ 

The following sections describe the minimum data requirements for using different folios in 
Weibull++. 

LIFE DATA FOLIOS 

Depending on the data type and the number of failures and/or suspensions present within your 
data, Weibull++ can perform all or some of the available analyses and calculations in a life data 
folio. Note that data sets with 2 or more distinct failure times, with or without suspensions, can 
be calculated with any of the available distributions, except for the mixed Weibull distribution. 

For the mixed Weibull distribution, the following requirements apply: 

• At least 5 unique failure times (i.e., data points with different time values) are required for 
the 2-subpopulation analysis. 

• At least 8 unique failure times are required for the 3-subpopulation analysis. 

• At least 11 unique failure times are required for the 4-subpopulation analysis. 

In addition, Weibull++ allows you to work with data sets that have fewer than 2 distinct failures. 
However, the analysis methods that can be performed will vary depending on the data and 
particular case. 

There are a total of five possible cases as to how data can be entered. For each scenario, a 
description of the available analysis options is provided: 

• Case 1: No Data 

• Case 2: No Failures and 1+ Suspensions 

• Case 3: 1 Failure and No Suspensions 

• Case 4: 1 Failure and 1+ Suspensions 

• Case 5: 2+ Failures 

DEGRADATION ANALYSIS FOLIOS 

The minimum data requirements for degradation analysis folios are as follows: 
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• The unit ID must be entered for all data points. 

• For all models except Gompertz, there must be at least 2 data points for each unique unit 
ID. For the Gompertz model, there must be at least 3 data points for each unique unit ID. 

• The data must produce enough extrapolated failure/suspension times to perform life data 
analysis with the selected life distribution. See the requirements for life data folios. 

NON-PARAMETRIC LIFE DATA ANALYSIS (LDA) FOLIOS 

For non-parametric LDA folios, there must be at least 1 data point entered. 

WARRANTY ANALYSIS FOLIOS 

Weibull++ provides four data formats for warranty analysis. The requirements for each format 
are described next. 

Nevada Chart Format 

The minimum data requirements for warranty analysis folios in the Nevada chart format are as 
follows: 

• The returns quantity cannot exceed the sales quantity. 

• At least one data point must be entered. 

• With only Sales data entered (i.e., a data set with suspensions only), only the 1-parameter 
Weibull or 1-parameter exponential distributions with maximum likelihood estimation 
(MLE) will be available. To use the 1-parameter Weibull, you will be prompted to enter the 
beta value and the lower one-sided confidence bound. Confidence bounds will not be 
available in the QCP or plots. This is similar to Case 2 for life data folios. 

• If the Returns data contains failure(s) for only 1 time period, only MLE analysis is possible. 
In addition, the 3-parameter Weibull, mixed Weibull and generalized gamma distributions 
will not be available. This is similar to Case 4 for life data folios. 

• If the Returns data contains failure(s) for at least 2 time periods, all distributions except 
mixed Weibull will be available. This is similar to Case 5 for life data folios. 

Times-to-Failure Format 

The minimum data requirements for warranty analysis folios in the times-to-failure format are 
the same as those described previously for life data folios, except you cannot calculate with no 
data entered. 
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Dates of Failure Format 

The minimum data requirements for warranty analysis folios in the dates of failure format are 
as follows: 

• The "End of Observation Period" (entered on the Main page of the control panel) is 
required. 

• The "Date In-Service" is required for all Sales and Returns data points. Each date entered in 
the Returns sheet must be identical to a date that has been entered in the Sales sheet. 

• At least one data point must be entered. 

• With only Sales data entered (i.e. a data set with suspensions only), only the 1-parameter 
Weibull or 1-parameter exponential distributions with maximum likelihood estimation 
(MLE) will be available. To use the 1-parameter Weibull, you will be prompted to enter the 
beta value and the lower one-sided confidence bound. Confidence bounds will not be 
available in the QCP or plots. This is similar to Case 2 for life data folios. 

• If the Returns data contains only one unique failure point, only MLE analysis is possible. In 
addition, the 3-parameter Weibull, mixed Weibull and generalized gamma distributions will 
not be available. This is similar to Case 4 for life data folios. 

• If the Returns data contains failure(s) for at least two time periods, all distributions except 
mixed Weibull will be available. This is similar to Case 5 for life data folios. 

Usage Format 

The minimum data requirements for warranty analysis folios in the usage format are the same 
as those described above for warranty folios in the dates of failure format. 

EVENT LOG FOLIOS 

The minimum data requirements for event log folios are as follows: 

• The system start date must be earlier than or the same as the earliest event date. 

• At least one event must be entered. 

PARAMETRIC RECURRENT EVENT DATA ANALYSIS (RDA) FOLIOS 

The minimum data requirements for parametric recurrent RDA folios are as follows: 

• The System ID must be entered for all data points. 
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• There must be at least 3 unique Failure (F) data points entered. 

NON-PARAMETRIC RECURRENT EVENT DATA ANALYSIS (RDA) FOLIOS 

The minimum data requirements for non-parametric RDA folios are as follows: 

• The System ID must be entered for all data points. 

• If confidence bounds are not required, there must be at least 1 Failure (F) data point for 
each unique System ID. 

• If confidence bounds are required, there must be at least 2 unique System IDs with at least 
1 Failure (F) data point each. 

CASE 1: NO DATA 
Data Types: All 
Methods of Analysis None (parameters supplied by user) 
Confidence Bounds 
Calculations? 

No 

Distributions All except 1-parameter Weibull, Weibull-Bayesian and CFM-
Weibull 

Competing Failure Modes? No 

When no data is entered and you click the Calculate icon, Weibull++ will prompt you to enter 
the values of the parameters for the selected model, as shown next for the 2-parameter 
Weibull. The appearance of the Parameter Input window will vary depending on the 
distribution selected. 
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Specify values for the parameters based on the distribution selected and click OK. All options 
and calculations supported by Weibull++ will be available except calculations involving 
confidence bounds. 

CASE 2: NO FAILURES AND 1+ SUSPENSIONS 
Data Types: All except free-form 
Methods of Analysis MLE 
Confidence Bounds Calculations? No 
Distributions 1-parameter Weibull and 1-parameter exponential 
Competing Failure Modes? No 

Since only suspension data has been entered, Weibull++ will only allow you to perform 
calculations involving the 1-parameter Weibull distribution with MLE or the 1-parameter 
exponential distribution with MLE. 
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To use the 1-parameter Weibull distribution, you will be prompted to enter the shape 
parameter, beta, as well as the lower one-sided confidence for the scale parameter, eta. 

 

Once you have supplied the parameters, all options and calculations are supported except for 
calculations involving confidence bounds. The calculated scale parameter, eta, will be the lower 
one-sided value at the confidence level specified by you. 

If using the 1-parameter exponential distribution, the results will be at the 50% confidence 
level. To use the exponential distribution at a higher confidence level, select the Weibull 
distribution, specify a beta equal to 1, and enter the desired confidence level. 
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CASE 3: 1 FAILURE AND NO SUSPENSIONS 

Free-Form Data 

Data Types: Free-form only 
Methods of Analysis MLE 
Confidence Bounds 
Calculations? 

No 

Distributions 2-parameter Weibull, 1-parameter exponential, 2-parameter 
exponential, normal and lognormal 

Competing Failure 
Modes? 

No 

Only rank regression is possible when using free-form data. MLE will be disabled. 

With only one unique data point, only the 2-parameter Weibull, 1-parameter exponential, 2-
parameter exponential, normal and lognormal analyses are possible. If you select a different 
distribution, a message box will appear notifying you that you need to switch analysis types, as 
shown next. 

 

If you select to use a 2-parameter distribution, you will then be prompted to enter a value for 
one of the parameters. Remember that when using free-form data, you are supplying both the 
X and Y position for the entered data point. Given this point and a value for one of the 
parameters, the application will then solve for the other parameter. The parameter that you 
would like to solve for should be left as zero as shown below. 
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Other Data Types 

  

Data Types: All except free-form data 
Methods of Analysis MLE 
Confidence Bounds Calculations? No 
Distributions 1-parameter Weibull and 1-parameter 

exponential 
Competing Failure Modes? No 

With only one unique failure time, the application will notify you that only the 1-parameter 
Weibull and 1-parameter exponential distributions with MLE are available. 
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If you select the 1-parameter Weibull, you will then be prompted to enter the value of the 
known parameter. 

 

CASE 4: 1 FAILURE AND 1+ SUSPENSIONS 
Data Types: All data types with suspensions 
Methods of 
Analysis 

MLE 

Confidence Bounds 
Calculations? 

Yes 

Distributions All except mixed Weibull, 3-parameter Weibull, 2-parameter 
exponential and generalized gamma. However, depending on the 
number of suspensions and their location, a solution may be 
impossible. 

Competing Failure 
Modes? 

No 

If you enter only one unique failure and at least one suspension with any analysis method other 
than MLE, the application will notify you that only MLE is possible. 
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CASE 5: 2+ FAILURES 
Data Types: All 
Methods of Analysis All 
Confidence Bounds Calculations? Yes 
Distributions All except mixed Weibull 
Competing Failure Modes? Yes 

Note that unless sufficient data are present, some distributions of 3 or more parameters may 
not be available, or the application may be unable to converge for a solution. In general, when 
using distributions with 3 or more parameters, you should have at least 5 distinct failure points 
per parameter. 

Requirements for Accelerated Life Testing 
For life-stress data only. 

The following sections describe the minimum data requirements for using different folios in 
Accelerated Life Testing. 

LIFE-STRESS DATA FOLIOS 

The minimum data requirements for life-stress data folios are broken down by model in the 
table below. Note the following: 

• "Number of failures" assumes unique (i.e., different) failure times. 

• "Number of stress levels" assumes unique stress levels. 

• "Stresses" refers to the number of stress columns used in the analysis (this may not 
necessarily equal the number of stress columns in the data sheet). 



Chapter 16: Minimum Data Requirements 

Weibull++ 2020 User's Guide 1131 

 

• If the data set uses the minimum number of stress levels, then each stress level must have 
at least one failure. 

• If you provide the value of the shape parameter (β for the Weibull distribution or σ for the 
lognormal distribution), less data will be required for calculation, as shown in the Give β or 
σ and Solve column of the minimum data requirements table below. If the data set you 
enter meets only these minimum requirements, when you click Calculate, you will be 
prompted to provide the value of the shape parameter in a window. Note that confidence 
bounds calculations are not possible in these situations. 

Life-Stress Model Give β or σ and 
Solve 

Exponential Weibull/Lognormal 

Arrhenius / Eyring / 
Inverse Power Law 

Failures = 2 
Stress Levels = 2 
 
Note: If you provide 
3 or more failures at 
only 1 stress level, 
you can provide the 
acceleration factor 
to calculate. 

Failures ≥ 2 

Stress Levels ≥ 2 

Failures ≥ 3 
Stress Levels ≥ 2. 

Temperature-
Humidity / 
Temperature-
Nonthermal 

Failures = 3 
Stress Levels = 3 

Failures ≥ 3 
Stress Levels ≥ 3 

Failures ≥ 4 
Stress Levels ≥ 3 

Generalized Eyring Failures = 4 
Stress Levels = 4 

Failures ≥ 4 
Stress Levels ≥ 4 

Failures ≥ 5 
Stress Levels ≥ 4 

Proportional 
Hazards / General 
Log-Linear 

Failures = stresses + 
1 
Stress Levels = 
stresses + 1 

Failures ≥ stresses + 
1 
Stress Levels ≥ 
stresses + 1 

Failures ≥ stresses + 2 
Stress Levels ≥ 
stresses + 1 
 
Note: The lognormal 
distribution is not 
available for 
proportional hazards. 
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Cumulative Damage Failures = stresses + 
1 
Stress Levels = 
stresses 

Failures ≥ stresses + 
1 
Stress Levels ≥ 
stresses 

Failures ≥ stresses + 2 
Stress Levels ≥ 
stresses 
 
Note: Only one stress 
column can be used 
with the lognormal 
distribution. 

If you enter no data at all and click the Calculate icon, Weibull++ will prompt you to enter the 
values of the parameters for the selected model, as shown next. The appearance of the 
Parameter Input window will vary depending on the life-stress model and distribution selected. 

 

Specify values for the parameters based on the selected life-stress model and distribution and 
click OK. All options and calculations supported by Accelerated Life Testing will be available 
except calculations involving confidence bounds and plots that require individual stress levels. 

DEGRADATION ANALYSIS FOLIOS 

The minimum data requirements for Accelerated Life Testing degradation analysis folios are as 
follows: 

• The Unit ID must be entered for all data points. 
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• For all models except Gompertz, there must be at least two data points for each unique 
Unit ID. For the Gompertz model, there must be at least three data points for each unique 
Unit ID. 

• Within each unique Unit ID, the inspection times must be increasing. 

• The data must produce enough extrapolated failure/suspension times to perform 
accelerated life testing data analysis with the selected Accelerated Life Testing model. See 
the requirements for life-stress data folios. 

Requirements for Reliability Design 
The minimum data requirements for DOE reliability designs are as follows: 

• For the Weibull and lognormal distributions, the number of unique failures must be greater 
than the number of parameters in the model. 

• For the exponential distribution, the number of unique failures must be greater than or 
equal to the number of parameters in the model. 

Depending on the type of design you are working with, these requirements affect calculations 
in different ways. 

• For two level factorial and Plackett-Burman, if the data set does not meet the requirement, 
the software will automatically reduce the number of parameters in the model until it can 
be calculated. Therefore, the following requirements apply. 

• To use the Weibull or lognormal distribution, you need at least two failures. 

• To use the exponential distribution, you need at least one failure. 

• In one factor reliability designs, you must have more than one factor level regardless of the 
distribution chosen. Therefore, the following requirements apply. 

• To use the Weibull or lognormal distribution, you need at least one failure at each level 
and at least two different failures for at least one level. 

• To use the exponential distribution, you need to have at least one failure at each level. 
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Requirements for Reliability Growth 

MINIMUM DATA REQUIREMENTS - TIMES-TO-FAILURE DATA 

For reliability growth data analysis only. 

The minimum data requirements for analysis of developmental times-to-failure data are 
presented next: 

Data Type Minimum Requirements Models 

Failure Times At least 3 unique failures. Crow-AMSAA, Duane 

Crow Extended: 
BD modes - at least 3 unique 
BD modes - at least 3 unique 

Grouped Failure 
Times 

At least 3 unique failures. Crow-AMSAA, Duane 

Crow Extended: 
BD modes - at least 3 unique 
BD modes - at least 3 unique 

Multiple 
Systems - 
Known 
Operating Times 

At least 3 unique failures for overall 
analysis. 

Crow-AMSAA, Duane 

Crow Extended: 
BD modes - at least 3 unique 
BD modes - at least 3 unique 

Multiple 
Systems - 
Concurrent 
Operating Times 

At least 3 total failures for overall 
analysis. 

Crow-AMSAA, Duane 

At least 3 unique failures on an 
individual system to return 
individual system results. 

Crow Extended: 
BD modes - at least 3 unique 
BD modes - at least 3 unique 

Multiple 
Systems with 
Dates 

At least 3 total failures for overall 
analysis. 

Crow-AMSAA, Duane 

At least 3 unique failures on an 
individual system to return 
individual system results. 

Crow Extended: 
BD modes - at least 3 unique 
BD modes - at least 3 unique 
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Multiple 
Systems with 
Event Codes 

At least 3 total failures for overall 
analysis. 

At least 3 unique failures on an 
individual system to return 
individual system results. 

Crow Extended: 
BD modes - at least 3 unique 
BC modes - at least 3 unique 
I events apply only to BC modes 
and there must be an I event for 
each BC mode 

MINIMUM DATA REQUIREMENTS - DISCRETE DATA 

For reliability growth data analysis only. 

The minimum data requirements for analysis of developmental discrete data are presented 
next: 

Data Type Minimum Requirements Models 

Sequential At least 3 reliability points (this is 
not equal to the number of data 
points or failures). 

Crow-AMSAA, Standard Gompertz, 
Lloyd-Lipow, Duane, Logistic 

At least 4 reliability points Modified Gompertz 

Sequential with 
Mode 

At least 3 reliability points (this is 
not equal to the number of data 
points or failures). 

Standard Gompertz, Lloyd-Lipow, 
Logistic 

At least 4 reliability points Modified Gompertz 

Grouped per 
Configuration 

At least 3 data entries 
(configurations). 

Crow-AMSAA, Standard Gompertz, 
Lloyd-Lipow, Duane, Logistic 

At least 4 reliability points. Modified Gompertz 

Mixed Data At least 3 intervals with at least one 
failure in each. 

Crow-AMSAA 

Number of failures in the first 
interval must be less than the 
number of units in the interval. 

Crow Extended: 
BD modes - at least 3 unique 

 
MINIMUM DATA REQUIREMENTS - MULTI-PHASE DATA 

For reliability growth data analysis only. 

The minimum data requirements for analysis of developmental multi-phase data are presented 
next: 
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Data Type Minimum Requirements Models 

Failure Times At least 3 unique failures. Crow Extended - Continuous 
Evaluation: maximum of 10 phases 

Grouped Failure 
Times 

At least 3 unique failures. Crow Extended - Continuous 
Evaluation: maximum of 10 phases 

Mixed Data At least 3 intervals with at least 1 
failure in each 

BD modes - at least 3 unique 

Crow Extended - Continuous 
Evaluation: maximum of 10 phases 

MINIMUM DATA REQUIREMENTS - RELIABILITY DATA 

For reliability growth data analysis only. 

The minimum data requirements for analysis of developmental reliability data are presented 
next: 

Data Type Minimum 
Requirements 

Models 

Reliability At least 3 unique 
failures. 

Lloyd-Lipow: Initial Time/Stage > 0  

Logistic: Initial Time/State > = 0 

At least 4 unique 
failures. 

Standard Gompertz and Modified Gompertz: 
Initial Time/Stage >= 0 

MINIMUM DATA REQUIREMENTS - CHANGE OF SLOPE CALCULATIONS 

For reliability growth data analysis only. 

The minimum requirements for Change of Slope calculations require at least 3 failures up to the 
break point and at least 2 failures after the break point. Therefore, there must be at least 5 
total failures or intervals (in grouped data) to conduct the analysis. 

Change of Slope calculations are available only for developmental testing data using Crow-
AMSAA, for the following data types: 

• Failure Times 

• Grouped Failure Times 

• Known Operating Times 
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• Concurrent Operating Times 

• Multiple Systems with Dates 

• Mixed 

MINIMUM DATA REQUIREMENTS - FIELDED DATA 

For reliability growth data analysis only. 

The minimum data requirements for analysis of fielded data are presented next: 

Data Type Minimum Requirements Models 

Repairable 
Systems 

At least 3 total failures for overall 
analysis. 

Power Law 

At least 3 unique failures on an 
individual system to return 
individual system results. 

Crow Extended: 
BD modes - at least 3 unique 

Fleet At least 3 total failures for overall 
analysis. 

Crow-AMSAA 

At least 3 unique failures on an 
individual system to return 
individual system results 

Crow Extended: 
BD modes - at least 3 unique 
BC modes - at least 3 unique 
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Chapter 17: Weibull++ Settings 
The Application Setup contains personal preferences that are stored per computer/username. 
These include default settings for new analyses/plots that you create from this computer, as 
well as personal preferences that don’t affect shared analysis data stored in the database.  

In addition, note that the region and language settings will determine how dates, times, 
decimals, currency, etc. are displayed on your computer. 

To open the Application Setup window, choose File > Application Setup. 

 

The settings on the pages listed under Common Settings are the same for all ReliaSoft desktop 
applications; the pages listed under the application name contain settings that apply only to the 
current applications. 

ReliaSoft Settings 

COMMON SETTINGS 

The Common Settings page of the Application Setup can be changed from within any ReliaSoft 
desktop application. 

• Interface sets the language and the skin (color scheme) for the software interface. Selecting 
a skin shows you a preview of the changes in the Application Setup window. The change 
takes effect in the rest of the interface the next time you launch each application. 

Note that a language change will not affect applications that are currently available only in 
English. 

• Open With sets the ReliaSoft application to launch by default when you double-click an 
*.rsr20 or *.rserp file from this computer. If you want to be prompted to choose an 
application each time, select Show the ReliaSoft Launcher. 

• Recent Databases List sets the maximum number of recently saved database files to be 
displayed in the "Recent Databases" list in the Backstage view. 

• Auto Save specifies when folios and diagrams will be saved automatically. The application 
always saves folios/diagrams upon calculate or close. If you want to also save periodically 
while you're editing, specify an interval. This can be useful if you're working across a 
network in an enterprise database. 
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• Other 

• Allow multiple projects (project explorer) applies to ReliaSoft desktop applications 
that use the current project explorer (i.e., Weibull++, BlockSim and Lambda Predict). 
Select the check box if you want to have multiple projects open at the same time. 
There is a separate setting for project windows in XFMEA/RCM++/RBI. (See Working 
with Multiple Projects.) 

• Show project name in opened folios applies to ReliaSoft desktop applications that use 
the current project explorer (i.e., Weibull++, BlockSim and Lambda Predict). It shows 
the project name in [brackets] on the tab or window caption. This may be useful when 
you have multiple projects open at the same time. 

• Use web-based help. Select the check box to always make F1 and other help 
commands open the most up-to-date help file from the Internet when possible. If you 
clear this check box, they open the local help file that was installed with the software. 

• Highlight 'Active' category in ribbon applies a highlight color to the label that shows 
which tabs are currently active. 

• Use non-modal Resource Manager locks the Resource Manager in a top window 
position so it can remain open while you have access to the project. If not selected, you 
must close the Resource Manager to return to the project. 

• Warn when changing metric associations shows a warning when you select an existing 
metric in a situation that will change the metric's associated model. (See Showing 
Metrics in Folios/Diagrams.) 

• Hide unused project folders applies to ReliaSoft desktop applications that use the 
current project explorer (i.e., Weibull++, BlockSim and Lambda Predict). It hides from 
view all folders that do not contain any project items. 

• Highlight colors sets the colors used to color-code values in the following analyses: 

• Results in the FMRA in BlockSim and XFMEA/RCM++/RBI 

• Certain BlockSim plots 

• BlockSim FRED reports 

• BlockSim allocation analysis 

• Spread of failure rate contributions in a prediction folio in Lambda Predict. 

http://help.reliasoft.com/blocksim20/index.htm#t=fmra_view.htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=fmra_view.htm
http://help.reliasoft.com/blocksim20/index.htm#t=fred_reports.htm
http://help.reliasoft.com/blocksim20/index.htm#t=allocation_analysis.htm
http://help.reliasoft.com/lp20/index.htm#t=highlight.htm
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BACKUP/CHECK OUT OPTIONS 

The Backup/Check Out Options page of the Application Setup can be changed from within any 
ReliaSoft desktop application. 

• Standard Database Maintenance applies to standard database files (*.rsr20) only. It allows 
you to automatically save a backup of a database in the location you specify when you close 
the application. The backup file will be named after the database file with the backup date 
appended (e.g., RSDatabase1_2020-01-15.rsr20). 

You can specify how many days of backups can be automatically saved (up to 10), but note 
that only one backup will be saved per day (e.g., if you open and close the same database 
three times in one day, only the final closing of the database will be saved in the backup 
folder). 

Note that you can also create backups manually at any time by choosing File > Save As. For 
more tips on keeping databases running smoothly, see Backups and Database 
Maintenance: Protecting Your Data. 

• Check In/Out specifies the default save location for projects that you check out from a 
database. 

OTHER COMMON SETTINGS 

The Common Settings > Other page of the Application Setup can be changed from within any 
ReliaSoft desktop application. 

• Model, Variable and Workbook Names disallows spaces and special characters in the 
names of models (including those published from any ReliaSoft desktop application) and 
variables, and in the names of workbooks created in BlockSim. This will ensure that all 
models, variables and workbooks can be used in equations in event analysis flowcharts. 

• Display Object IDs. Select the check box to always display the unique object identifier 
(object ID) of each project and resource in the database. The project IDs will be displayed in 
the Manage Projects window and in the Edit Project Properties window, while the resource 
IDs will be displayed in the Resource Manager. In BlockSim, diagram IDs and block IDs will 
be shown in the control panel and in the Block Details simulation results worksheet. 

• Copy Plot Graphic sets the default file type to use when copying a plot to the Clipboard as 
an image. If you will be pasting copied plots into ReliaSoft Workbooks, choose Metafile for 
ReliaSoft use. If you will be pasting them into external applications, choose Bitmap or 
Metafile for external use. 
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• This default setting is used when you copy a plot using Home > Copy or CTRL+C. If you want 
to choose the graphic on the spot, you can do so by right-clicking the plot and choosing the 
Copy Plot Graphic command on the shortcut menu. 

• Hierarchical Trees sets the maximum number of lines for displaying names and descriptions 
in any of the hierarchical tree interfaces used in XFMEA, RCM++, RBI, Lambda Predict and 
MPC. 

• Alternative Credentials applies to secure databases. It allows you to either save your 
alternative credentials (so your account is automatically logged in whenever you open a 
secure database from a different domain) or clear the credentials from this computer. 

• Diagram Skins Utility converts diagram skins created in Version 9 to the latest version. Click 
the Convert link, and in the window that opens, select the name of the skin(s) that you wish 
to convert. You will need to close and re-launch the application to use the converted 
skin(s). (See "Converting Version 9 Skins" in the BlockSim, Weibull++ or XFMEA/RCM++/RBI 
documentation.) 

Application-Specific Settings 

WEIBULL++ LIFE DATA FOLIOS SETTINGS 

The Weibull++ Life Data Folios page of Weibull++'s Application Setup contains default settings 
that will be applied when you create a new life data folio. Note that some of the configurable 
settings that are saved with the folio can still be modified from the control panel and others can 
now be modified via the Item Properties window. 

• Analysis Method sets the default analysis method for time-to-failure data sheets and for 
free-form data sheets. 

• Ranking Method sets the default ranking method for rank regression analyses. 

• Confidence Bounds Method sets the default method used to calculate the confidence 
bounds. 

• Grouped Data Settings affect how individual median rank values are assigned to each data 
point (observation) within each group. 

• Ungroup on regression. Select the check box to fit the regression line to all data points 
in each group. If not selected, only the points with the highest median rank value 
within each group will be considered when fitting the line. 

http://help.reliasoft.com/blocksim20/index.htm#t=converting_version_9_skins.htm
http://help.reliasoft.com/weibull20/index.htm#t=converting_version_9_skins.htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=converting_version_9_skins.htm
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• Ungroup on MLE. Select the check box to plot all of the data points in each group on 
the MLE probability plot. If not selected, only the points with the highest median rank 
value within each group will be plotted. The line is independent of whether data points 
are treated as grouped or ungrouped. 

• Analysis Summary Options. Select which metrics will be shown in the Analysis Summary 
area of the control panel: 

• Show Theta displays the theta parameter when using the Weibull distribution. Theta is 
defined as the sum of the scale and location parameters (eta and gamma): 

 

• Show correlation coefficient (Rho) applies only when using rank regression as the 
analysis method. It displays the correlation coefficient, which may help determine how 
well the parameters of a distribution fit the data. 

• Show likelihood value (LK) displays the likelihood function value, which may be used to 
compare how well different models fit the same data set. 

ALTA LIFE-STRESS FOLIOS SETTINGS 

The ALTA Life-Stress Folios page of Weibull++'s Application Setup contains default settings that 
will be applied when you create a new life-stress folio. Note that some of the configurable 
settings that are saved with the folio can still be modified from the control panel and others can 
now be modified via the Item Properties window. 

• Data Sheet Options for ALTA 

• Show likelihood value (LK) displays the likelihood function value in the Analysis 
Summary area of the control panel. The LK value may be used to compare how well 
different models fit the same data set. 

• Show activation energy applies only to temperature-related models such as Arrhenius, 
Eyring, generalized Eyring, temperature-humidity, and temperature-nonthermal. It 
displays the activation energy (Ea) in the Analysis Summary area of the control panel. A 
large activation energy means temperature has a large effect on the life of the product. 
Click the Units drop-down list to specify which unit to use (Kelvin or Rankine). 

• Indicate stress columns used highlights the borders of the selected stress columns in 
the data sheet. Click the Color drop-down list to select the border color. 
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• Grouped Data Settings affect how individual median rank values are assigned to each data 
point (observation) within each group. Select the check box to plot all of the data points in 
each group on the MLE probability plot. If not selected, only the points with the highest 
median rank value within each group will be plotted. The line is independent of whether 
data points are treated as grouped or ungrouped. 

• Other Options. Select the check box to allow the Use Stress Level window to remain open, 
while you have access to all life-stress folios. If not selected, you must close the Use Stress 
Level window to return to the folios. 

• Default Life Distribution sets the default life distribution for life-stress folios. Note that if 
lognormal is selected as the default and you select a model for which the lognormal 
distribution is not available (i.e., Proportional Hazards or Cumulative Damage in 
Accelerated Life Testing PRO), the life distribution will automatically reset to Weibull. 

• Cumulative Damage Model (ALTA PRO). These options apply to the cumulative damage 
life-stress model in Accelerated Life Testing PRO. 

• Time-dependent stress profiles specifies the time at which the stress will be applied to 
a time-to-failure data point that occurs at the both the End time of one segment and 
the Start time of another segment. Select Implement stress at end of step to apply the 
stress from the later segment, or Implement stress at beginning of step to apply the 
stress from the earlier segment. 
 
For example, suppose that the selected stress profile applies a stress of 300K to failure 
times between 0 and 100 hours and a stress of 350K to failure times between 100 and 
200 hours. If the observed failure time is 100 hours, you must determine whether to 
apply the 300K or 350K stress to that data point. 

• Allow large Beta values displays beta values up to 250. If not selected, the default 
maximum beta value is 100. 

RGA GROWTH DATA FOLIOS SETTINGS 

The RGA Growth Data Folios page of Weibull++'s Application Setup contains default settings 
that will be applied when you create a new growth data folio. Note that some of the 
configurable settings that are saved with the folio can still be modified from the control panel 
and others can now be modified via the Item Properties window. 

• Data Sheet Options 
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• Show Alter Data Type enables the Alter Parameters command in all growth data folios. 
The command enables you to experiment with possible alternative scenarios by 
allowing you to alter the values of the calculated parameters. 

• Use advanced systems view uses the Advanced Systems View by default when you 
create a new data sheet that offers both the Normal View and Advanced Systems View. 
(See Normal and Advanced Systems View.) 

• Warn when transferring data with excluded events displays a message when you 
transfer a data set that has some coded events excluded from the calculations. This 
applies only when you transfer data from a Multiple Systems Event Code data sheet to 
another type of data sheet. 

• Default Number of Systems 

• For 'Multiple Systems - Known Operating Times' data sheets specifies the number of 
"Time System" columns that will appear by default in the data sheet. 

• For all other fielded/developmental multiple systems data types specifies the number 
of systems that appear by default in the navigation panel of the Advanced Systems 
View. (See Normal and Advanced Systems View.) 

• Statistical Tests. When you use the Crow-AMSAA (NHPP) or Crow Extended models, 
Weibull++ automatically performs statistical tests on the calculated data set. Use the check 
boxes to select which test results to display in the Result area of the growth data folio 
control panel. 

• Show Chi-Squared applies to grouped failure times only. The test evaluates the 
hypothesis that the failure times follow a non-homogeneous Poisson process (NHPP). 

• Show Cramér-von Mises (CVM) applies to non-grouped failure times where there are 
no gaps in the data. The test evaluates the hypothesis that the failure times follow a 
non-homogeneous Poisson process (NHPP). 

• Show Laplace Trend applies to multiple systems analysis only. The test evaluates the 
hypothesis that a trend does not exist in the data, and displays in the analysis results 
whether the system reliability is improving, deteriorating or staying the same. 

• Show Common Beta Hypothesis (CBH) applies to multiple systems analysis only. The 
test evaluates whether all the systems in the data set have similar beta values (i.e., 
operated in a similar manner). 

• Default Significance Level specifies the significance level used in the statistical tests. 
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• Failure Discounting applies only to the Discrete Sequential with Mode data type. Specify 
the confidence level that will be used to define the fractional decrease in failure value. (See 
Failure Discounting.) 

• User Warnings 

• Beta = 1 hypothesis is invalid displays a message when the beta = 1 hypothesis fails. 
This warning applies only to the Crow Extended or Crow Extended - Continuous 
Evaluation models. 

• Model parameters out of range displays a message when the value of the k parameter 
(logistic model) or Alpha parameter (Lloyd-Lipow model) is less than or equal to zero. 
Negative values indicate that the analysis results may not be valid. 

• Effectiveness factors of zero displays a message when one or more effectiveness 
factors equal to zero. This warning applies only to the Crow Extended or Crow Extended 
- Continuous Evaluation models. 

• Other Options 

• Use percents (not decimals) for reliability displays reliability values as percentages 
(e.g., 90) rather than decimals (e.g. 0.90). This applies to the Reliability data type only. 

• Data input is cumulative configures the data sheet for cumulative failure times, by 
default, instead of non-cumulative failure times. (See Cumulative vs. Non-Cumulative 
Data.) 

• Calculate unbiased beta removes the bias of the MLE estimate of the beta parameter, 
when applicable. An unbiased estimate will be labeled in the results as "Beta (UnB)" 
instead of "Beta." For more information, the "Unbiasing Beta for the Crow-AMSAA 
(NHPP) Model" article at: 
http://www.weibull.com/hotwire/issue141/hottopics141.htm demonstrates how the 
bias is corrected for Crow-AMSAA (NHPP). This is also applicable to the Crow Extended, 
Crow Extended - Continuous Evaluation and power law models. 

 

http://www.weibull.com/hotwire/issue141/hottopics141.htm
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IMPORTANT: Starting in Version 2020, Weibull++ calculates the ratio to convert the 
MLE beta to the unbiased beta as "(N-2)/(N-1)" instead of the old ratio of "(N-2)/N" 
that was used in RGA Version 2019 and earlier. This change only affects failure 
terminated data. 

DESIGN FOLIOS SETTINGS 

The Design Folios page of Weibull++'s Application Setup contains settings that will be applied 
when you create a new DOE design folio. 

• Formatting Options. Select which colors to use for the applicable columns in the data 
sheet. Click the Color drop-down list to select the border color. 

• Indicate selected response highlights the borders of the cells in every response 
column. 

• Indicate response columns and Indicate factor columns sets the background color of 
every response and factor column. 

• Indicate generated response columns sets the background color of columns that are 
automatically populated based on entered observations (e.g., the Y Mean column in 
robust design folios). 

• Default Analysis Settings set the default options for the settings on the Analysis Settings 
page of the control panel. 

• Analysis History sets the maximum number of historical analysis results to keep in the 
Analysis Summary window. Once the maximum is reached, older results are deleted. 

CALCULATIONS SETTINGS 

The Calculations page of Weibull++'s Application Setup contains default settings that will be 
applied to calculated results when you create a new folio. Note that some of the configurable 
settings that are saved with the folio can still be modified from the control panel and others can 
now be modified via the Item Properties window. 

• Precision to be Displayed on Calculations sets the math precision (number of decimal 
places) and the point at which the software will switch to scientific notation. For example, if 
the scientific notation tolerance is set to 5, then any number that is larger than 105 will be 
displayed using scientific notation. 

• Special Options on Location Parameter applies to analyses in Weibull++ that use the 
location parameter (gamma). 
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• Warn if location parameter is negative generates a warning when the location 
parameter contains a negative value. 

• Discard if location parameter is negative causes the software to behave as follows: 

• If you are using RRX or RRY to calculate the parameters: 

• For the 2-parameter exponential distribution, the negative location parameter 
is discarded and the data set is recalculated using the 1-parameter exponential 
distribution. The location parameter is displayed as zero. 

• For the 3-parameter Weibull distribution, the negative location parameter is 
discarded and the data set is recalculated using the 2-parameter Weibull 
distribution. The location parameter is displayed as zero. 

• If you are using MLE to calculate the parameters: 

• For the 2-parameter exponential distribution, the negative location parameter 
is discarded and the data set is recalculated using the 2-parameter exponential 
distribution with the location parameter constrained between zero and the 
first failure time. 

• If you have not selected the Use true 3-P MLE on Weibull option on this page 
of the Application Setup, the negative location parameter is discarded and the 
data set is recalculated using the 2-parameter Weibull distribution. The 
location parameter is displayed as zero. 

• If you have selected the Use true 3-P MLE on Weibull option, the negative 
location parameter is discarded and the data set is recalculated using the 3-
parameter Weibull distribution with the location parameter constrained 
between zero and the first time-to-failure. 

• Reset if location parameter > T1 on Exponential applies to the exponential distribution 
for both rank regression on X (RRX) and rank regression on Y (RRY). If the location 
parameter is greater than the first failure time, it resets the value of the location 
parameter equal to the first time-to-failure. The parameters will then be recalculated 
based on the new value of the location parameter. 

• Use true 3-P MLE on Weibull applies a true MLE solution to the 3-parameter Weibull 
distribution. The 3-parameter solution is inherently problematic for some beta values 
and can fail to converge for some data sets. When not selected, Weibull++ uses non-
linear regression to compute gamma, and then computes the MLE of beta and eta 
using a transformed T' = (T - γ). 
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• Use Theta parameter scheme on Weibull replaces the Weibull scale parameter eta in 
all results with theta, where theta = eta + gamma. 

• Allow negative location parameter for G-Gamma allows the lambda parameter of the 
generalized gamma distribution to take negative values. 

• Precision for Convergence Criteria sets the tolerance that will be used as the convergence 
limit (degree of accuracy) for mathematical iterations (e.g., a value of 4 indicates 1E-4 
tolerance). 

• Crow/Power Law Models applies only to calculations using the Crow-AMSAA (NHPP), 
Power Law, Crow Extended or Crow Extended - Continuous Evaluation models. Select 
whether to display the value of the power law parameter, Lambda, or the Weibull 
parameter, Eta, in the analysis results. 

• Duane Model applies only to calculations using the Duane model. Select whether to display 
the value of the A parameter (cumulative failure intensity) or the b parameter (cumulative 
MTBF) in the analysis results. 

• Crow Extended Model applies only to calculations using the Crow Extended or Crow 
Extended - Continuous Evaluation models. 

• Show Crow-AMSAA beta for beta = 1 hypothesis displays the value of the beta 
parameter for the Crow-AMSAA (NHPP) model in addition to the hypothetical value of 
beta calculated for the Crow Extended or Crow Extended - Continuous Evaluation 
models, as shown in the following example. 

 

• Allow EF values for BD modes with implemented fixes adds a second tab in the 
Effective Factors window when you are using the Crow Extended - Continuous 
Evaluation model. This allows you to record the effectiveness factors for BD modes that 
were fixed during testing. Note that this functionality is for your information only; it is 
not used in calculations. 
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• Instantaneous MTBF/FI at the End of Development Testing sets whether the 
instantaneous MTBF and failure intensity at the end of the test will be shown in the analysis 
results with the term "demonstrated" (i.e., DMTBF/DFI) or "achieved" (i.e., AMTBF/AFI). 

• Other Options 

• Use mean time for the exponential distribution. By default, lambda is used as the scale 
parameter of the exponential distribution. Select the check box if you prefer to use 
MTTF (1/lambda) instead. 

• Sort before calculation sorts the times in ascending order before calculating the data 
sheet. This does not affect the results of the calculation. 

• Use unbiased Std on Normal data applies to analyses in Weibull++ that use the normal 
distribution with complete data. Select the check box to correct the MLE standard 
deviation (sigma) value for biasedness. 

• Use special sort (place F before S) applies to analyses in Weibull++. The software 
always sorts entries based on failure times, but in special cases where two or more 
failure times are identical to the suspension times, the sort algorithm does not 
distinguish between them and sorts them based on the way they were entered. For 
example, if given a suspension time of 100 hours and a failure time of 100 hours, the 
results will vary depending on the order in which the data were entered and whether 
you are using rank regression. When this check box is selected and two identical times 
are encountered, the software will always put failures before suspensions. This involves 
a double sort routine and might be slightly slower than the standard sort. 

• Use plotted Y points for K-S test applies to the Kolmogorov-Smirnov test, which is used 
by the Goodness of Fit Results and the Distribution Wizard in Weibull++. Select the 
check box to use the plotted points (using median ranks or Kaplan-Meier) to calculate 
the difference between the observed and model-estimated probability. If not selected, 
the non-parametric (empirical) values of the probability of failure are used as the 
observed values for the test. 

PLOT SETTINGS 

The Plot page of Weibull++'s Application Setup contains default settings that will be applied 
when you create a new plot sheet. Note that some of the configurable settings that are saved 
with the plot can still be modified from the control panel and others can be modified via the 
Show/Hide Plot Items window (Plot > Actions > Show/Hide Plot Items). 
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What's Changed? Starting in Version 2019, several options, including those for setting the 
numbers in axis labels and showing the user, date and time on plots, are now specified only 
with the Plot Setup utility. 

• Settings for Plot Sheets 

• Enable auto refresh activates the auto refresh option. 

• Show lines around interval points shows lines around the points for interval censored 
data. The lines represent the starting and ending time for each interval. For example: 

 

• Show parameter scales shows the parameter scales on a probability plot. The 
probability scales allow you to read the parameters directly from the plot. 

• Show parameter bars places a box around the parameter scales on a probability plot. 
For example: 
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• Show left censored points displays the left censored points as triangles on the bottom 
of the plot when plotting interval or left censored data. 

• Show suspensions displays the suspension (right-censored) data points as triangles on 
the bottom of the plot when plotting suspended data. 

• Other Options 

• Enable interactive plot highlights and shows the coordinates/values of a point, line, 
slice or bar on the plot when you move the mouse pointer over it. Note that if you 
change this setting, you must redraw the plot to see the change. 

• Adjust MLE points on plot line. For MLE plots, it adjusts the y-axis positions of the 
plotted points to fit the MLE solution line (instead of plotting the points from rank 
regression). 

• Straighten Gamma line straightens the parameter line on the probability plot for data 
sheets that use the gamma or generalized gamma distributions. Note that if you change 
this setting, you must redraw an affected plot to see the change. 

• Display interval lines (when applicable) applies only to Reliability Growth times-to-
failure data sheets. Select the check box to display the instantaneous interval lines on 
the MTBF vs. time plot or failure intensity vs. time plot. 
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OTHER SETTINGS 

The Other Settings page of Weibull++'s Application Setup contains default settings that will be 
applied when you create a new folio. 

• Preferences 

• Show the Project Item Wizard when creating new projects displays a wizard that helps 
you select the first new folio to create in a project. If not selected, the new project will 
be blank. 

• While QCP is open, have access to all folios locks the QCP in a top window position 
(i.e., non-modal) so it can remain open while you have access to all folios. The 
calculations performed in the QCP will be based on the currently active data sheet. If 
not selected, you must close the QCP in order to return to the folios. This setting can 
also be changed from within the QCP by selecting or clearing the Non-Modal QCP 
option in the Options drop-down list. 

• While Analysis Summary is open, have access to all folios lets you view other folios 
while the DOE Analysis Summary window is still open. If not selected, you must close 
the Analysis Summary window to return to the folios. 

• Show warning when deleting columns with data displays a confirmation message 
when using the Add or Remove Columns window to delete a column that has data. 

• Show warning when deleting data sheets displays a confirmation message when 
deleting a data sheet. 

• Diagram. The following settings apply to diagrams created in Weibull++: 

• Truncate block names when the number of characters exceeds sets the maximum 
number of characters displayed for block names. 

• Ask for confirmation when connecting multiple blocks. By default, when you have 
multiple blocks selected in a diagram and you add a connector to one of the selected 
blocks, the connection goes only to the block you place the connector on. Select the 
check box to be prompted to add connections to all of the selected blocks. 

• Ask to apply changes when using the Format Painter displays a window with the 
Format Painter that allows you to specify which settings will be applied to another 
block. 

• Other Options 
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• Default folio font sets the default font for data sheets in new folios. 

• Show list of distributions on hovering displays the distribution/model drop-down list in 
control panels when you move the pointer over the bar. If not selected, you must click 
the bar to display the list. 

CUSTOMIZE FOLIO TOOLS SETTINGS 

The Customize Folio Tools page of Weibull++'s Application Setup contains default control panel 
settings that will be applied when you create a new life data folio and life-stress data folio. 

In the Customize Weibull++ Folio Tools and Customize ALTA Folio Tools areas, select or clear 
the options that you want displayed in the control panel. Note that these options will still be 
accessible from the applicable ribbons. 

Reset Settings 
The Reset Settings page of the Application Setup allows you to restore some or all of the 
settings to their original configuration. Note that it’s recommended to close all windows before 
resetting settings. If the change does not take effect immediately, restart the application. 

• Reset Common Settings resets the settings under the Common Settings heading in the 
Application Setup. 

• Reset Application Settings resets the settings under the current application's heading in 
the Application Setup. It also clears any saved default column headings in life data, life-
stress data and growth data folios. 

• Reset Application Form Settings resets the form settings for the current application (e.g., 
size and location of windows). 

• Reset Plot Settings resets the Plot Setup settings that are applied by default when you 
create a new plot in the current application. 

• Reset FIDES Settings (Lambda Predict only) resets the predefined FIDES settings (e.g., saved 
pi factors, process audits, etc.) that are applied by default when you create a new database. 
(See FIDES Settings Manager in the Lambda Predict documentation.) 

• Reset Component Defaults (Lambda Predict only) resets the component property values 
that are applied by default when you add a new component to a prediction. (See Default 
Component Properties in the Lambda Predict documentation.) 

http://help.reliasoft.com/lp20/index.htm#t=manage_fides_settings.htm
http://help.reliasoft.com/lp20/index.htm#t=default_component_properties.htm
http://help.reliasoft.com/lp20/index.htm#t=default_component_properties.htm
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• Reset All Settings resets all the saved settings for the current application. This is the same 
as clicking all of the individual "Reset" buttons above. 

Project Item Settings 
ReliaSoft desktop applications offer a variety of configurable settings that are stored per 
computer/username and managed via the Application Setup. 

Your personalized application setup determines the default settings for new folios, diagrams 
and flowcharts that you create in Weibull++ and BlockSim. The relevant settings are also saved 
with each individual folio/diagram and are accessible from the Item Properties window. This 
makes it possible to have different settings for different analyses, and also ensures that any 
given analysis will be the same for all database users. 

To view and edit the configurable settings in the Item Properties window, select the folio, 
diagram or flowchart in the current project explorer and choose Project > Current Item > Item 
Properties. 

 

The settings are displayed on the second tab of the properties window. (In a secure database, 
the settings can be edited only if the user is the project owner or has the "Create/edit project 
items" permission.) 

If you modify the settings for a particular project item, the new preferences will be saved with 
the folio/diagram. The default preferences for new folios/diagrams in the application setup will 
remain unchanged. 

Region and Language Settings 
The Region and Language settings for your particular computer will have some impact on the 
way some information is displayed in ReliaSoft applications. 

Users with different regional and language settings can work together on the same analysis 
projects because, in most cases, the basic information is stored in the database and the 
software simply displays it in the format preferred by each user. For example, if the date 
September 25, 2019 is stored in the database, User A might see it as "9/25/2019" while User B 
might see "25-Sep-19." 

This topic first explains how to view or change the Region and Language settings on your 
computer and then discusses some specific considerations for ReliaSoft applications, including: 

• Which language is selected by default when you install the software 
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• How dates and times will be entered and displayed 

• How decimal values and currency will be entered and displayed 

VIEWING OR CHANGING THE REGION AND LANGUAGE SETTINGS FOR YOUR 
COMPUTER 

To view or change the region and language settings: 

• In Windows 10, move the pointer to the lower left corner of the desktop, then right-click 
and choose Control Panel. Click the Clock and Region option then click the Region link. 

• In Windows 7, choose Start > Control Panel and then click the Region and Language link. 

As an example, the Windows 10 interface is shown here. The Windows 7 version looks different 
but functions similarly. 
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Other relevant settings are managed via the Customize Format window: 

• In Windows 10, click the Additional settings button. 

• In Windows 7, click the Additional settings button. 

As an example, the Windows 10 interface is shown next. 
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Note: To see the changed settings in the ReliaSoft application, you must close the application, 
and then restart it. 

WHICH LANGUAGE IS SELECTED BY DEFAULT WHEN YOU INSTALL THE 
SOFTWARE 

The user interface for ReliaSoft desktop applications is available in several languages. You can 
change this language at any time by choosing an option from the Language drop-down list on 
the Common Settings page of the Application Setup. 
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When you first install the software, it will check your computer's current language as it is set in 
the Format field in the Windows Region and Language window. If that language is supported in 
the ReliaSoft applications, they will use those settings; however, if that language is not 
supported, they will use the default setting of English. 

DEFINING DATE AND TIME FORMATS 

Dates and times appear frequently throughout the ReliaSoft interface, including (but not 
limited to): 

• The dates in the plot legend area of a plot in all ReliaSoft applications. 

• The history provided throughout ReliaSoft applications (e.g., for resources, FMEA records, 
diagrams, in history logs, etc.). 

• The dates in the worksheet view and in the record properties windows in XFMEA, RCM++, 
RBI and MPC. 

• The dates in the "dates of failure" format and "usage" format of the Weibull++ warranty 
folios. 

The Short date field from the Windows Region and Language window determines how dates 
are displayed. You can select any standard format (e.g., M/d/yyyy, dd/MMM/yy, yy/MM/dd) or 
you can create your own format using the available date notations. 

The Short time field determines how times are displayed. You can select any standard format 
(e.g., h:mm tt, HH:mm, HH'h'mm) or you can create your own format using the available time 
notations. 

The Windows settings do not apply to the following items: 

• Dates and times in spreadsheet utilities (e.g., a spreadsheet module in ReliaSoft 
Workbooks, General Spreadsheets, etc.). 

• Dates and times displayed in the Weibull++ event log folio are created by the folio and are 
not affected by the computer's settings. 

CHANGING THE DECIMAL SYMBOL, THE LIST SEPARATOR AND THE CURRENCY 
SYMBOL 

How decimal values are displayed depends on the value of the Decimal symbol field on the 
Numbers page of the Windows Customized Format window, which determines which character 
is used to indicate the decimal portion of a number (e.g., 85.25 or 85,25). In addition, the 
character used to separate the arguments in a list depends on the value of the List separator 
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field. These settings affect how you enter functions in a spreadsheet module in ReliaSoft 
Workbooks or in General Spreadsheets, either manually or by using the Function Wizard. 

For example, if the decimal symbol value is a comma, and the list separator value is a 
semicolon, you would enter a function like this: 
=RELIABILITY("Weibull!Folio1!Data 1";500;100;0,9)).  Whereas, if the 
decimal symbol is a period and the list separator is a comma, it would be 
=RELIABILITY("Weibull!Folio1!Data 1",500,100,0.9)). 

The currency symbol that is displayed in the software depends on the selection in the Currency 
symbol field on the Currency page of the Windows Customized Format window. 
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Chapter 18: ReliaSoft Common Tools 
Categories, Identifiers and Filters 

DEFINING CATEGORIES 

In all ReliaSoft desktop applications, you can use flexible categories and identifiers to filter and 
group analysis data in a way that fits your specific needs. There are two types: 

• Project Categories can be applied to projects in all desktop applications. 

• Item Categories can be applied to project items (e.g., folios, diagrams, system hierarchy 
items) and resources (e.g., models, URDs) in all desktop applications except MPC. 

This topic describes how to define the categories that will be available throughout the current 
database. To learn how to use them to filter and group data, see Project and Item Filters. (For 
additional options related to categories for system hierarchy items, see Item Categories in 
XFMEA/RCM++/RBI in the XFMEA/RCM++/RBI documentation.) 

Accessing the Project/Item Categories Window 

There are two ways to access the Project/Item Categories window and specify which categories 
will be available throughout the current database. (In a secure database, these are available 
only for users with the "Manage project/item categories" permission.) 

To open the window from the backstage view, choose File > Manage Database > Project/Item 
Categories. 

 

Alternatively, you can click inside any Category drop-down list (e.g., in a properties window, 
filter, etc.) and click the Edit Categories icon. 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=item_categories_in_xfmea_rcm_rbi.htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=item_categories_in_xfmea_rcm_rbi.htm
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Adding, Renaming and Deleting Categories 

• To rename an existing category, double-click inside the cell and edit the text. 

• To add a new category in the same level as the one that is currently selected, click Add. 

 

• To add a new category in the level below the one that is currently selected, click Add 
Below. 

 

• To move a selected category up or down within the same level, select the row and click Up 
or Down. 

    

• To move a selected category to a different level, click Promote or Demote. 

         

• To delete a category, select the row and press the Delete key or click the icon. To delete all 
categories at the same time, click Clear All. There is no undo for delete. 
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IDENTIFIERS 

In all ReliaSoft desktop applications, you can use flexible identifiers and categories to filter and 
group analysis data in a way that fits your specific needs. The identifiers are available for project 
explorer items (e.g., folios, diagrams, plots, etc.) and there is one standard set of identifier 
fields for all relevant locations. 

 

This topic describes how to view and edit identifiers for each type of resource or analysis, and 
how existing identifiers will be converted from Version 8 or 9. To learn how to use identifiers to 
filter and group data, see Project and Item Filters. 

For Resources 

To view and edit the identifiers for most types of resources, you can simply open the properties 
window and select the Identifiers node. They can also be edited via the Batch Properties Editor. 
Note that: 

• For published models, the identifiers are obtained from the analysis (e.g., Weibull++ folio, 
BlockSim diagram, etc.). To make a change, you must first edit the identifiers for the 
analysis and then republish the model. 

• Identifiers are not applicable for the following resource types: Variables, Maintenance 
Groups, Mirror Groups, Actions, Controls and Profiles. 

For Project Explorer Items 

To view and edit the identifiers for folios, diagrams, plots and other analyses in Weibull++, 
BlockSim or Lambda Predict, select the item in the current project explorer and choose Project 
> Current Item > Item Properties. 
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The identifiers are always displayed on the first tab of the properties window. 

When applicable, the fields are also visible on the Identifiers page of the control panel. If a folio 
has multiple data sheets, you can use this page to define separate identifiers for each sheet. 
Note that the Folio Identifiers will be used in item filters and in the Analysis Explorer; while the 
Data Sheet Identifiers will be used when publishing a model. 

You can use an asterisk (*) in any or all of the data sheet fields to apply the same text from the 
corresponding folio field. As an example, the following picture shows the identifiers for a 
Weibull++ life data folio that contains multiple data sheets for each design prototype of a new 
chandelier bulb in development. Although most of the data sheet identifiers will be the same as 
the folio (indicated with *), the Version and Comments fields have been modified for each data 
sheet. The data sheet identifiers will be used when you publish a model. 
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For System Hierarchy Items 

To view and edit the identifiers in Lambda Predict, XFMEA, RCM++ and RBI, select an item in the 
system hierarchy and go to the Properties tab in the Analysis panel. 

The fields are grouped together under the Identifiers heading. 

• In Lambda Predict, Name will always be displayed. The remaining identifiers may be hidden 
or displayed via the Application Setup. (See Properties Settings in the Lambda Predict 
documentation.) 

• In XFMEA, RCM++ and RBI, Name, Category and Keywords will always be displayed. The 
remaining identifiers may be hidden or renamed based on the configurable settings for the 

http://help.reliasoft.com/lp20/index.htm#t=application_setup_properties_page.htm
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current project. (See About Configurable Settings in the XFMEA/RCM++/RBI 
documentation.) 

 

In XFMEA, RCM++ and RBI, the same set of identifiers will be used for all analyses associated 
with a given system hierarchy item (e.g., FMEA, control plan, etc.). 

For Diagram Blocks 

To view and edit identifiers for diagram blocks in BlockSim, open the block properties and select 
the Identifiers node. The fields are also visible on the Identifiers page of the control panel when 
the block is selected. 

You can use these identifiers in BlockSim’s Find utility and in the Batch Properties Editor. 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=about_configurable_settings_xfmea.htm
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Conversion from Version 8/9 

The following table shows how the "global identifiers" from previous versions will be mapped 
when you convert existing data in a Version 8/9 database (where “ - “ indicates no change). 

PROJECT AND ITEM FILTERS 

In many locations throughout all ReliaSoft desktop applications, you can use flexible filters to 
limit a list of projects, project items (e.g., folios, diagrams, system hierarchy items, etc.) or 
resources (e.g., models, URDs, etc.). 
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The drop-down list contains the filters you have saved in this database, plus any filters that 
another user has chosen to share with other database users. 

Use the drop-down list to apply an existing filter. To stop filtering the list, select Show All 
(formerly called "Default filter"). 

Sharing Filters with Other Users 

To share a saved filter, open the filter's properties window and select the Show to all database 
users check box. 

In a secure database, a shared filter can be edited or deleted only by a) the user who created 
the filter or b) a user with the "Manage other database settings" permission. 

Project Filters 

Project filters can be applied to lists that contain project names such as the Project Manager 
and Analysis Explorer. The filter can either be a query based on specified criteria, or a selected 
list of projects. 

• Based on Criteria. You can match All Criteria (AND query) or Any Criteria (OR query): 

• Owner (project owner) 

• Category (project category) 

• Analysis/Feature (whether the project contains analyses associated with the specified 
application or feature) 

• Last Updated By 

• Last Updated Date 

• Based on Selected Projects. Click the Add button to select the projects you want to include, 
or the Remove button to remove a selected project from view. 

Clear the Show locked projects check box if you want to exclude locked projects from the 
results, even if they meet the criteria. 

Projects are always grouped based on whether they are public, private or reference. For 
additional grouping, select the Group by category and/or Group by owner check boxes. If you 
select both, the results will be grouped first by project category and then by project owner. For 
example: 
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Item Filters 

Item filters can be applied to lists that contain project items and resources such as the Current 
Project Explorer and Resource Manager. 

Select whether the item must match All Criteria (AND query) or Any Criteria (OR query): 

• Category (item category) 

• Created By 

• Last Updated By 

• Last Updated Date 

• Identifiers (Name, Part Number, Version, Application, Supplier, Description, Comments and 
Keywords) 

Analysis Explorer 

The Analysis Explorer is available in all ReliaSoft desktop applications except MPC. You can use 
this flexible tool to explore all of the different analyses that are stored in the current database. 

What's Changed? In versions prior to Version 2020, the Analysis Explorer was called the 
Synthesis Explorer. 

To access the utility, choose Home > ReliaSoft > Analysis Explorer. 

 

To reduce the amount of time required to populate the grid, first use the project and item 
filters (discussed below) to limit your search, then click Load Data. 
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The analyses shown in the explorer may include: 

• Project items in Weibull++, BlockSim and Lambda Predict (e.g., folios, diagrams, plots, 
ReliaSoft Workbooks, etc.). 

• Analyses that are associated with system hierarchy items in XFMEA, RCM++ or RBI (e.g., 
FMEAs, control plans, risk based inspection analyses, etc.). 

• Project Plans that can be created for any project. 

You can filter/sort/group the analyses based on ReliaSoft application, analysis type, analysis 
creator and many other properties. You can also present the information in a wide variety of 
dashboard charts. 

This topic summarizes the tools you can use to find and organize data in the Analysis Explorer’s 
flexible grid. For information about presenting the data graphically, see Analysis Explorer 
Dashboards. For a list of the properties that can be used in either the grid or the dashboard, see 
Analysis Explorer Properties. 

SAVE AND APPLY VIEWS 

Once you have customized the Analysis Explorer’s grid to suit a particular purpose (using the 
built-in find/filter, column configuration and grouping features described below), you can save 
the preferences as a view that can be used again whenever you need it. A view is saved in the 
database and available only to the user who created it. 

To create a view, first configure the grid to suit your particular needs and then click Save View. 

 

To quickly apply these same preferences again at any time, click Apply View and select one of 
the saved views from the list. 

 

Note: The view does not affect filtering that has been applied from the Project Filter, Item Filter 
or Category Panel. 
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PROJECT AND ITEM FILTERS 

The Analysis Explorer can utilize the same project and item filters that are available in many 
other locations throughout ReliaSoft desktop applications. For example, with the custom filters 
shown below, the Analysis Explorer will show only analyses performed by Department A 
(project filter) that were modified within the last month (item filter). 

 

To remove either filter, select Show All from the drop-down list. To remove both filters at the 
same time, select Clear Filters. 

 

After you clear or change these filters, you must click Load Data again to update the grid. 

 
CATEGORY PANEL 

The category panel provides a quick way to filter the data based only on item category. For 
example, you might use the panel to first view the analyses for Category A and then quickly 
switch to see the analyses for Category B. 

To show or hide the panel, click Show Category Panel. 

 

When there are many categories, the tools at the top of the panel can help you find and select 
the one(s) you need. 
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BUILT-IN FIND/FILTER, CONFIGURATION AND GROUPING TOOLS 

The Analysis Explorer offers the same filter, column configuration and grouping tools that are 
built in to other utilities that use a similar grid (e.g., the Resource Manager). For details about 
how to use each feature, see: 

• Finding and Filtering Records 

• Configuring Columns 

• Grouping Panel 

ANALYSIS EXPLORER DASHBOARDS 

You can use the flexible Dashboard utility for presenting data from the Analysis Explorer. 

As with any other dashboard, you can use the Dashboard Viewer to select any of the layouts 
that have been predefined for this type of data, and you can use the Dashboard Layout 
Manager to create or edit layouts. 

  

(In a secure database, the Dashboard Layout Manager is available only for users with the 
"Manage dashboard layouts" permission.) 

Values and Arguments 

When you’re creating bar charts or pie charts based on Analysis Explorer data, note that the 
argument(s) determine the bars or slices shown in the chart and the value will always be the 
quantity of analyses that fit the specified criteria. 

If you use the default Count option when specifying the value, then any of the Analysis Explorer 
properties will return the same quantities. You may prefer to choose the one that gives the 
most appropriate chart label(s). For example, the following pie chart uses the same property 
(“Application Source”) for both the Value and Argument in order to display the total 
quantity/percentage of analyses for each ReliaSoft application. 
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Tip: Use the Design tab of the ribbon to configure the chart labels and other settings to fit your 
particular preferences. For example, in this chart, the Data Labels are configured to display the 
Argument, Value and Percent (e.g., BlockSim: 648 (23.44%). 

  

If there is ever a situation in which you want to show only the number of distinct values for a 
particular property, you can use the Count Distinct option instead. For example, the following 
pie chart uses User Created By (Count Distinct) for the value in order to show the number of 
users who created analyses with each ReliaSoft application. 
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As you can see from looking at both charts, the "Count" shows that there are 648 total 
BlockSim analyses; while "Count Distinct" shows that only 18 distinct users created BlockSim 
analyses. 

Filtering the Data 

Any filters that are currently applied in the Analysis Explorer grid will not be reflected in the 
dashboard charts. However, you can incorporate filters directly into the dashboard layout. For 
example, if you want to show all of the Weibull++ analyses that were created by a particular 
user, you can create a filter like the one shown next. (See Using the Filter Editor.) 
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In addition (or instead), you can configure the layout with one or more master filters that allow 
individual users to change the filters on-the-fly in the Dashboard Viewer. (See Configuring a 
Master Filter and Using Master Filters.) 

ANALYSIS EXPLORER PROPERTIES 

The following properties will be available when you are using either the grid or dashboard in 
the Analysis Explorer. 

Application 

• Application Source is the primary ReliaSoft application (or product family) for viewing or 
editing the analysis. (Note that Project Planners and Simulation Worksheets are listed 
under ReliaSoft because they can be created/edited from more than one product family.) 

• Application Activated? indicates whether the primary application is activated on your 
computer. 

Project 

• Project Name is the project in which the analysis is stored. 

• Project Type indicates whether it is a public, private or reference project. 

Analysis 

• Analysis Name is the name of the folio, diagram, plot, system hierarchy item, etc. 
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• Analysis Type and Variant indicate the type of analysis. This can include project items (e.g., 
folios, diagrams, plots, etc.) and specific analyses that are associated with a system 
hierarchy item in XFMEA, RCM++ or RBI (e.g., FMEAs, risk based inspection analyses, etc.). 
The variant is used to distinguish: 

• Analytical vs. simulation RBDs and fault trees in BlockSim. 

• Discrete vs. continuous Markov diagrams in BlockSim. 

• The specific prediction standard in Lambda Predict (e.g., MIL-217, Telcordia, etc.). If the 
prediction folio uses more than one standard, this will show as "Multiple." If a standard 
has not yet been added to the prediction folio, the variant field will be blank. 

Categories and Identifiers 

Note that these properties are preceded with "SI" in the Dashboard Layout Designer, so that all 
identifiers can be grouped together in the data source panel. 

• Category is the category assigned to the analysis. 

• Name, Part Number, Version, Supplier, Application, Description, Comments and 
Keywords are the standard identifiers that can be defined for the analysis. Note that 
XFMEA/RCM++/RBI analyses use the identifiers defined for the system hierarchy item they 
are associated with. 

Creation and Last Update 

• User Created and Date Created indicate the database user who originally created the 
analysis, and the associated date/time. 

• User Updated and Date Updated indicate the database user who last modified the analysis, 
and the associated date/time. 

Record Lists 

FINDING AND FILTERING RECORDS 

This topic describes the find and filter tools that are built in to the Resource Manager and other 
utilities that use a similar grid. Each of these tools can be used separately, or in conjunction 
with the others. 
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Find Panel 

The Find panel allows you to search for a word or phrase across all of the available properties. 
To show or hide this panel, toggle the Show Find Panel command on the ribbon or in the 
shortcut menu that appears when you right-click a column heading. 

 

When you enter text into the Find panel, it will return only the fields that contain the text you 
specified, as well as highlight all of the locations where the matching text occurs. 

To stop filtering the data, clear the text box. 

 

  

Auto Filter Row 

The Auto Filter Row allows you to filter the grid based on a selected filter operator. 

To display or hide this row, toggle the Show Auto Filter Row command on the ribbon or in the 
shortcut menu that appears when you right-click a column heading. 

 

Click the selector icon in the auto filer row and then enter the search text or value against 
which column will be filtered, as shown below. The set of filter operators available for a column 
depends on the type of data the column displays. 

For example, the following filter shows only the rows in which the model name contains 
"Component A" and the distribution contains "Weib." 
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Advanced Filters 

The Advanced Filters allow you to choose an automatically generated filter or create a quick 
custom filter. The automatically generated filters are based on the unique values that currently 
exist in the column. 

For example, the following picture is based on a data set that contains models from three 
different categories. If you choose one of the automatically generated filters (e.g., "Reliability"), 
the grid will display only models of that one selected category. 

 

If you want to see models from two of those categories (e.g., either "Reliability" or "Probability 
of Failure"), you can choose [Custom] and create a quick custom filter like this: 
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If a filter has been applied for a particular column, select [All] to remove it.. 

 

Current Query Criteria 

When you are filtering the grid using the Auto Filter Row, Advanced Filters and/or Edit Filter 
window (described below), the current query criteria will be displayed at the bottom of the 
window. For example:    

 

• Click the X to delete the current set of filter criteria. 

• Clear the check box to remove the current set of criteria without deleting it. Select the 
check box if you want to re-apply it. 

• Click  to choose from a list of filter criteria that were recently applied. 

Edit Filter 

The Edit Filter window provides the most flexibility to refine and adjust a filter in either a grid or 
a Dashboard layout. To access the tool, click the Edit Filter button to the right of the current 
query criteria (if applicable), or choose Edit Filter from the shortcut menu. 

As an example, the following filter from the Resource Manager will display only cost per unit 
time models in which the rate equals either $120 per hour or $2 per minute. 
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• Click a red label if you want to: 

• change the logical operator (And, Or, Not And, Not Or) 

• add or remove a group 

• add a condition 

• clear the entire filter 

• Use the  and  icons to add or remove conditions within an existing group. 

• Click a blue label if you want to change the property (e.g., Model Name, Created By, etc.). 

• Click a green label if you want to change the relational operator (e.g., Equals, Contains, 
Begins with, etc.). 

• Click a gray or black label if you want to enter or change the value. 

CONFIGURING COLUMNS 

This topic describes the capabilities for selecting, reordering, resizing and sorting columns that 
are built in to the Resource Manager and other utilities that use a similar grid. 
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Selecting Columns 

To specify which columns will be displayed in the grid, click Select Columns. 

 

In the utility's window or panel for selecting columns, use the check boxes to choose which 
columns will be displayed. As an example, the following pictures show the window and panel 
for model resources in the Resource Manager. 

 

Reordering Columns 

To change the column order, drag the column heading into the desired position. 
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Resizing Columns 

To resize columns, you can do any of the following: 

• Drag the edge of the column heading to the desired position. 

• Double-click the edge of the column heading or right-click it and choose Fit This Column. 
This will resize the column to fit its data. 

• Right-click any column heading and choose Fit All Columns. This will resize all columns to fit 
their own data. 

Sorting Columns 

To sort the grid by one column at a time, you can simply click the column heading to sort in 
ascending order (  ), or click it again to sort in descending order (  ). 

To sort the grid by multiple columns, right-click each column in the desired order and choose 
Sort Ascending or Sort Descending each time. For example, the following picture shows 
Analysis Explorer data sorted first by project (ascending) and then by category (descending). 

 

To stop sorting, right-click any column heading and choose Clear All Sorting. 

GROUPING PANEL 

This topic describes the grouping panel capability that is built in to the Resource Manager and 
other utilities that use a similar grid. 

When you are working with a large amount of data, it may be convenient to group it based on 
one or more properties. For example, the following picture shows resources in the Resource 
Manager grouped first by keyword and then by model category. 
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To group the data without opening the grouping panel, right-click any column heading and 
choose Group By This Column. Alternatively, you can choose Show Grouping Panel to display 
the panel and then drag column headings into or out of the panel to configure the groups. 

 

When the grouping panel is displayed, you can also: 

• Click the column heading to change the sort order between ascending (  ) or descending ( 
 ). 
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• Drag column headings within the panel to change the grouping order. For example, if you 
prefer to group first by model category and then by keyword, drag the column headings as 
shown below. 

 

To stop grouping the data, drag all column headings out of the panel or choose Clear All 
Grouping. 

SEP Web Portal 

If your organization implements an SEP web portal for an enterprise database, the entire team 
— including managers and colleagues who don't have ReliaSoft desktop applications installed 
— can access key analysis and project details from any web-enabled device. 

SEP DASHBOARDS 

The personalized home page provides an intuitive, at-a-glance overview of the information 
you’re tracking via SEP, such as FMEA stats, actions, recent messages, reports, metrics and 
more. You can choose which tiles appear on your dashboard and change their order and 
settings. 

ACTIONS AND PORTAL MESSAGES 

You can use SEP to create, view and edit the same actions and portal messages that are visible 
to you from the desktop applications. SEP also allows colleagues who don't use the desktop 
applications to stay up-to-date on assignments and team communication.) 

PROJECT SUMMARY, ANALYSIS SUMMARIES AND PROJECT PLAN 

For each analysis project that you have permission to view, SEP provides a summary that 
includes metrics, assigned actions, attachments and other project details. It also displays 
summaries, plots and reports for selected analyses published to SEP from Weibull++, BlockSim 
and Lambda Predict. 
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If your team is using the Project Planner in desktop applications, SEP shows a streamlined view 
of the project plan. Users can access this plan in SEP and update their progress for assigned 
actions. 

SYSTEM HIERARCHIES AND FMEAS 

SEP enables users throughout your organization to view FMEAs, queries and reports that were 
created in XFMEA, RCM++ or RBI. This provides managers and others throughout your 
organization with convenient web-based access to the wealth of lessons learned and 
troubleshooting recommendations from your investment in these analyses. 

METRICS (KEY PERFORMANCE INDICATORS) 

SEP shows all of the KPIs (metric resources) that have been created in desktop applications for 
the projects you have permission to view; no publishing is required. Quick visual indicators help 
you monitor performance and support decision making. 

 

MONITORED REPORTS 

SEP can display a variety of custom reports and dashboards created in desktop applications. The 
"Watch" feature makes it easy to manage the specific reports you want to access quickly. 

SEP also shows all of the Analysis Explorer and Reliability Data Warehouse (RDW) dashboards 
that have been predefined in the desktop applications. 

PUBLISHING TO SEP 

SEP does not display all of the analyses that were performed in ReliaSoft desktop applications. 
Instead, your team can decide which analyses to make available and publish selected analysis 
summaries and reports. 

In the desktop applications, these features are only available when: 

• You are connected to an enterprise database that has an SEP web portal implemented and 
the "Enable publish to SEP web portal" option is set to "Yes" for the database. 

• You have the "Publish to SEP web portal" permission. 

http://help.reliasoft.com/weibull20/index.htm#t=rdw_dashboards.htm
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The types of analysis summaries and reports that can be published vary for each ReliaSoft 
desktop application. In addition, some types  of Weibull++ and BlockSim analyses/reports may 
not be available, depending on your organization's licensing. 

Weibull++ 

Life Data 

Non-Parametric LDA 

Life-Stress Data 

Weibull Degradation 

ALTA Degradation 

Parametric RDA 

Standard / Robust / Mixture / Free Form 
Design 

One Way ANOVA 

Linearity & Bias, Gage R&R, Gage Agreement 

Multiple Linear Regression 

Growth Data 

ReliaSoft Workbooks 

XFMEA/RCM++/RBI 

Reports (saved with the project) 

System hierarchy and FMEAs are also visible 
in SEP — no publishing is required. 

BlockSim 

Analytical RBD, Simulation RBD 

Analytical Fault Tree, Simulation RBD 

Phase Diagram 

Event Analysis Flowchart 

Continuous Markov, Discrete Markov 

ReliaSoft Workbooks 

Lambda Predict 

Reports 

Stored Plots 

Note: If you have published analysis summaries and you see a "Link is not properly formatted" 
message when you attempt to open the original analysis from SEP, the link may be corrupted or 
using old encryption. Republish the analysis to refresh the link. 

Data Sheets or Diagrams 

To publish an analysis summary from Weibull++ or BlockSim, open the data sheet or diagram 
and click Publish SEP Summary on the Publishing page of the control panel. (For DOE design 
folios, the Data tab with analyzed response data must be selected.) 
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To publish a data sheet, you must also click Publish SEP Summary again in the preview of the 
spreadsheet summary. 

 

After publishing, the panel displays "Synchronized" if the web version reflects the latest results 
from the analysis. If the analysis has been modified (e.g., if more data has been added, an 
analysis setting has changed, etc.), it displays "Out of Sync" and you will need to recalculate and 
republish to update the web portal. 

To remove the summary from the web portal, click Remove SEP Summary. 

ReliaSoft Workbooks 

To publish a ReliaSoft Workbook from Weibull++ or BlockSim, open the module in the 
workbook that you want to share (spreadsheet or word processing document) and then click 
Home > SEP > Publish Report. 

 

The status bar shows that the spreadsheet or document is visible via SEP and indicates when 
the web version was last updated. 

 

If you subsequently make a change in the desktop application, you will need to republish to 
update the web portal. 

If you want to remove the report from the web portal, open the module and click Home > SEP > 
Remove Report. 
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Prediction Reports and Plots 

To publish a report for a standard item or block in Lambda Predict, select the item/block and 
choose Prediction Tools > Share > Publish SEP Summary. 

 

In the Select Report window, select what to include in the report (e.g., template-based reports, 
default reports or plots) and click OK. (See Lambda Predict Reports in the Lambda Predict 
documentation.) There can be only one published report for each item/block. If you publish 
again for the same item, it will replace the report that was previously published. 

To publish a stored plot from Lambda Predict, open the plot, then click the Publish SEP 
Summary icon on the Publishing page of the plot control panel. 

 

The following example shows two published reports and a published plot. 

 

To remove a report from the web portal, select the standard item or block, then open the 
Publishing tab of the Properties panel and click Remove SEP Summary. 

 

To remove a plot from the web portal, open the plot, then click the Remove SEP Summary icon 
on the Publishing page of the plot control panel. 

 

http://help.reliasoft.com/lp20/index.htm#t=creating_reports.htm
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XFMEA/RCM++/RBI Reports 

To publish a report generated in XFMEA/RCM++/RBI, use the Reports window to build the 
document, select at least one of the Save/Publish file formats on the ribbon (Word, Excel, or 
PDF) and click Generate Report. 

 

To see all of the generated report documents that have been saved with the project (and 
therefore will be visible via SEP), click Published Reports Manager. You can also use the 
manager to edit the name and description that will show in the web portal. 

For more information, see Save/Publish Reports in the XFMEA/RCM++/RBI documentation. 

ReliaSoft Locator Links 
ReliaSoft Locator Links provide quick access to specific analyses in a database (similar to 
Windows shortcuts). You can save these link files anywhere on your computer or network, e-
mail to a colleague, post on the Internet or an intranet, etc. 

When you double-click (open) a ReliaSoft Locator Link file (*.rsllx), it will launch the appropriate 
ReliaSoft application and go directly to a specific project item (e.g., folio, diagram, plot, system 
hierarchy item, etc.) or FMEA record (e.g., function, failure, etc.), as long as the following 
conditions are met: 

• The database still resides in the same location and you have access to the server. 

• You have an active user account in the database. 

• The required ReliaSoft application is activated on your computer. 

Tip: In the case of a standard database, the locator link stores the pathname/filename that was 
open when the *.rsllx file was created. If that was a mapped network drive (e.g., 
P:\ReliaSoft\Database1.rsr20), the link will only work if all other users have that drive mapped 
to the same letter. To make sure the link works for all users, you may need to open the 
database from the UNC pathname (e.g., \\SharedDrive\ReliaSoft\Database1.rsr20) before 
creating a locator link file. 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=publishing_reports.htm
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ReliaSoft Locator Links created in Version 2019 or later do not include the software version 
information as part of the link. When you open a link, the software will attempt to connect to 
the database, regardless of the database’s version. If you attempt to open a standard database 
that was created in an earlier version, the software will automatically convert it to the latest 
version. If you attempt to open an enterprise database that was created in an earlier version, 
the software will display a message; you must then upgrade the enterprise database to the 
later version. 

CREATING A LOCATOR LINK 

In an enterprise database, you can choose to either send the file by e-mail or save it to a 
specified location. In a standard database, the only option is to save the file because it is likely 
that the pathname may only work on your own computer (as discussed above). 

 

• For an item selected in a current project explorer (Weibull++, BlockSim or Lambda Predict), 
choose Project > Current Item > Save Locator Link. 

• For an item selected in an XFMEA/RCM++/RBI system hierarchy, choose System Hierarchy 
> Current Item > Save Locator Link. 

• For an item, structure or zone selected in an MPC hierarchy, choose Tools > Save Locator 
Link on the relevant ribbon tab. 

Note: If you get a "Locator Link is not properly formatted" message, the locator link may be 
corrupted or is using old encryption. Create a new locator link using the methods described 
above. 

POSTING LOCATOR LINKS ON A WEB PAGE 

Remember that ReliaSoft Locator Links are files that must be opened from a computer where 
ReliaSoft desktop applications are installed. If you post the *.rsllx as a standard link on an HTML 
web page, you will need to instruct users to download the file (instead of opening directly from 
the web browser). 



Chapter 18: ReliaSoft Common Tools 

Weibull++ 2020 User's Guide 1191 

 

What's Changed? In prior versions, ReliaSoft Locator Links were version-specific and were not 
compatible with other versions. 

Watches and Alerts 

Automated alerts can be an effective tool to facilitate communication and track the status of 
assigned responsibilities. 

Alerts can be sent via e-mail, SMS text message and/or ReliaSoft portal messages, depending on 
the Receive automated alerts preference specified for your personal user account. 

• Alerts via portal message are always available in any database. 

• Alerts via e-mail or SMS are only available if they are enabled for the database, and a valid 
SMTP server has been defined. (See Enable Alerts via E-mail or SMS.) 

Alerts can be sent for: 

• Any resource that you have personally subscribed to “watch.” (See Subscribing to a Watch.) 

• Action resources, under any of the following conditions: 

• You have personally subscribed to watch the action. 

• You are the action’s creator, person responsible or assigned reviewer/approver and the 
database has been configured to auto-subscribe a watch for that role. (See Action Alert 
Preferences.) 

• You are assigned via the Action Monitors window. (See Action and Gate Monitors.) 

• Project Planner gates, under either of the following conditions: 

• You have personally subscribed to watch the gate. 

• You are assigned via the Gate Monitors window. 

• Change logs you have been assigned to approve in XFMEA/RCM++/RBI. (See Electronic 
Approval Tracking in the XFMEA/RCM++/RBI documentation.) 

ENABLE ALERTS VIA E-MAIL OR SMS 

To configure a database to enable alerts via e-mail and/or SMS text message, choose File > 
Manage Database > Database Settings. 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=electronic_approval_tracking.htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=electronic_approval_tracking.htm
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In a secure database, this is available only for users with the "Manage other database settings" 
permission. 

What’s Changed? In prior versions, similar preferences were defined in the E-mail and Other 
Settings window. 

1. Select the Enable Alerts via E-mail or SMS check box. 

2. Specify a valid SMTP port and SMTP server. (You may need to consult with the IT 
professionals who have configured the e-mail server used within your organization.) 

 

3. Enter your e-mail address (or a valid SMS text messaging address if you prefer) in the 
Recipient address for test message field and then click Send Test Message. 

 

If the test message cannot be sent, an error will be displayed. If that happens, you can 
update the settings and try again until the message is delivered successfully. 

SUBSCRIBING TO A WATCH 

Users can personally subscribe to "watch" specific resources, Project Planner gates and MPC 
tasks that are of particular interest to them. This generates an alert (via e-mail, SMS text 
message and/or ReliaSoft portal message) each time the record is changed. 

Subscribing and Unsubscribing 

To personally subscribe/unsubscribe to a watch, open the resource, Project Planner gate or 
MPC task and select or clear the Alert me on changes to this record check box. The alert types 
shown for this option will depend on your alert preferences, as described in the section below. 

 

Note that the “watch” feature is not applicable for the following types of resources: Variables, 
Profiles, Maintenance Groups, Mirror Groups, Controls, Maintenance Templates (in BlockSim) 
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or resources specific to BlockSim's event analysis flowcharts (Functions, Static Functions, 
Simulation Definitions and Tables). 

Receiving Alerts 

Alerts can be sent via e-mail, SMS text message and/or ReliaSoft portal message, depending on 
the Receive automated alerts preference specified in your personal user account. 

• Alerts via portal message are always available in any database. 

• Alerts via e-mail or SMS are only available if they are enabled for the database, and a valid 
SMTP server has been defined. (See Enable Alerts via E-mail or SMS.) 

No Cascading Alerts 

Alerts are generated only when the record you’re watching is edited directly. For example, if 
you are watching a universal reliability definition (URD): 

• An alert will be sent if someone replaces Model A with Model B in the URD window. 

• An alert will not be sent if there is a change to an existing model, crew, etc. that is already 
assigned to the URD, unless you have also subscribed to watch the dependent resource 
that was changed. 

Special Considerations for Actions and Gates 

For action resources only, there are some additional features designed to maintain continuity 
with prior versions and enhance the actions management functionality. Specifically: 

• Action changes that are applied via the FMEA worksheet in XFMEA/RCM++/RBI will not 
initiate an alert. The change must be saved via the action properties window. 

• The database can be configured to auto-subscribe watches for users with the following 
roles: Action Creator, Person Responsible or Reviewer (aka "approver"). Each user can 
choose to personally unsubscribe later if desired. (See Action Alert Preferences.) 

• The Action Monitors window allows you to specify individual users and/or groups of users 
who will always receive alerts for the action, regardless of whether they have personally 
subscribed to a watch. For example, this allows you to set up an alert for a user who 
doesn’t have access to view or modify the project (and therefore can’t personally subscribe 
to a watch). 

A similar feature, the Gate Monitors window, is available for Project Planner gates. (See 
Action and Gate Monitors.) 
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ACTION ALERT PREFERENCES 

To configure the action alert preferences for the database, choose File > Manage Database > 
Database Settings. 

 

In a secure database, this is available only for users with the "Manage other database settings" 
permission. 

What’s Changed? In prior versions, similar preferences were defined in the E-mail and Other 
Settings window. 

 

• Introduction to each action alert sent via e-mail. This field allows you to specify the default 
text that will be used at the beginning of each action alert e-mail sent from this database. 

• Automatically set 'watch' for. Users can personally subscribe to "watch" specific resources 
and Project Planner gates that are of particular interest to them. For action resources only, 
the database can also be configured to auto-subscribe watches for users that have 
particular roles in a given action, as shown in the picture above. Note that each user can 
choose to personally unsubscribe later if desired (by opening the action record and clearing 
the check box under the Watch heading). 

ACTION AND GATE MONITORS 

The Action Monitors window (for action resources) and the Gate Monitors heading (for Project 
Planner gates) allow you to specify individual users and/or groups of users who will always 
receive alerts for the record, regardless of whether they have personally subscribed to a 
"watch." 

For example, this allows you to set up an alert for a user who doesn’t have access to view or 
modify the project (and therefore can’t personally subscribe to a watch). 



Chapter 18: ReliaSoft Common Tools 

Weibull++ 2020 User's Guide 1195 

 

Action Monitors 

For actions, click the Action Monitors icon in the action’s ribbon. 

 

This replaces the "E-mail Notifications" feature from prior versions, and you can choose any of 
the user groups or individual user accounts defined in the current database. 

The action will also appear under the I am monitoring heading in My Portal, Actions Explorer 
and SEP web portal (along with the actions that the user has personally subscribed to watch). 

  

Gate Monitors 

For Project Planner gates, the assigned users are listed under the Gate Monitors heading. Click 
the Edit icon to select the users you wish to assign. 

 

This replaces the "Team" feature from XFMEA/RCM++/RBI Version 9, and you can choose to 
assign any of the individual user accounts in the database. 

WHAT IS YOUR SMS ADDRESS? 

If you choose to receive alerts via SMS text messaging, the address will usually be your cell 
phone number @ the provider’s e-mail domain. As a courtesy, the table below provides a list of 
domains for popular providers in the United States (as of March 2015). Of course, you may 
need to check with your provider to obtain the most up-to-date information. 

For example, if you use T-Mobile in the US and your cell number is 555-123-4567, your SMS 
address will be 5551234567@tmomail.net. 

Provider   Domain   

Alltel   @message.alltel.com 

Amp'd @vtext.com 

Boost   @myboostmobile.com 
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AT&T @txt.att.net 

Metrocall   @page.metrocall.com 

Nextel   @messaging.nextel.com 

Sprint   @messaging.sprintpcs.com 

T-Mobile @tmomail.net 

US Cellular @mms.uscc.net 

Verizon    @vtext.com 

Virgin (USA)  @vmobl.com   

Windstream   @windstream.net 

History Logs 
By default, all projects and project items automatically show information about when an item 
was created and last updated, and by whom. For example, system hierarchy items in 
XFMEA/RCM++/RBI show this information under the History heading on the Properties tab, 
while folios and diagrams in Weibull++ and BlockSim show the information in the Item 
Properties window (Project > Current Item > Item Properties). 

In addition to the basic information provided, you have the option to activate a full history log 
that shows more detailed information such as the type of change that was made (e.g., add, edit 
or delete), the record that was changed and the specific property, and the value before and 
after the change. 

History logs will increase the size of a database and will cause a slight degradation in 
performance; hence, they must be activated on a per project basis. If desired, you can configure 
the database to automatically activate history logs for each new project by choosing File > 
Manage Database > Database Settings, and then selecting the option under the Other Settings 
tab in the window. (In secure databases, this is available only if the user has the "Manage other 
database settings" permission.) 

Once a history log is activated, the project history log shows the changes for all items in the 
project, and individual record history logs show the changes for selected items only. 

Tip: If you want to monitor and control revisions made to FMEAs, DVP&Rs, control plans, P-
Diagrams or test plans in XFMEA/RCM++/RBI, the use of change logs may be more appropriate. 
See Change Logs in the XFMEA/RCM++/RBI documentation. 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=change_logs.htm
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ACTIVATING A PROJECT HISTORY LOG 

To activate the history log for a project, choose Project > Management > History Log, or right 
click the project in the project list and choose the command on the shortcut menu. (In secure 
databases, this is available only if the user is the project owner, or has the applicable "manage 
all projects" permissions.) 

 

In the Project History Log window that appears, click Activate. 

Once the log has been activated, the database will start keeping records of all changes that are 
performed throughout the entire project for any of the ReliaSoft applications. You can filter the 
records by the last update date, application, user or type of change. For example, you might 
choose to display a list of all changes that were made by Joe User in the last week, or a list of all 
changes that were made by any user in Weibull++ today, and so on. 

You can deactivate the history log at any time from this window. When you do this, the 
recorded data is retained unless you select to clear it in the confirmation message that appears. 

Creating and Managing Archives 

You can limit the amount of information that is visible in the log by archiving older entries that 
are no longer of interest. Entries that have been archived can still be viewed in the Project 
History Log window if you specifically select to view them, but they will no longer be visible in 
the Record History Log windows. 

 

Archives are named based on the date they were created. For example, if you archive entries 
through One week ago, all entries in the history log that are dated as of one week ago or earlier 
will be stored in an archive that is named after the current date. 
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To view the contents of an archive, select the archive of interest from the Archive drop-down 
list in the Filter Based On area. To delete an archive, click the Delete icon that appears in the 
field. 

Note: When a restore point is created for a project or when a project is checked out, all current 
entries in the history log are automatically archived. 

VIEWING RECORD HISTORY LOGS 

In addition to the project history log, you can view a log that shows only the changes made to a 
selected item (archived entries will not be shown). The History Log icon  will be displayed 
whenever the log is available: 

• For folios, diagrams, multiplots (such as overlay plots), reports and worksheets, right-click 
the item in the current project explorer and choose Item Properties, then in the window 
that appears, click the History Log icon in the Identifiers tab. 

• For system hierarchy items in XFMEA/RCM++/RBI and MPC, select the item then click the 
History Log icon in the Properties panel. 

• For FMEAs, DVP&Rs and other analyses in XFMEA/RCM++/RBI, right-click the analysis’s tab 
in the Analysis panel and choose the History Log command on the shortcut menu. 

• For resources (e.g., models, actions, etc.), the History Log icon will be available when you 
edit the item or view its properties. 

Import, Export and Data Conversion 

IMPORTING FROM AN EXISTING DATABASE 

When you are creating a new ReliaSoft database, you have the option to import database 
settings (e.g., user accounts, security groups, project categories, etc.) and/or entire analysis 
projects from another database. 

If the Import from existing database check box is selected when you start to create a new 
database, the Import Data from Existing Database window will be displayed. 

First, use the drop-down list or browse icon  to select the database that you want to import 
from. This can be a standard database (*.rsr20) or an enterprise database connection file 
(*.rserp). 

Then, use the check boxes to select the settings and/or projects you wish to import. 
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Finally, click OK to create the new database with the selected data imported. 

Note: If you are creating a new enterprise database on SQL Server, the Create SQL Server login 
check box will be displayed at the bottom of the window. (See SQL Server Logins or Using 
Windows Impersonation.) 

Importing from Prior Version Files 

There are two ways to convert and import data from project files and standard database files 
that were created in previous versions of the software. 

• Importing to a new standard database (File > Open Database) 

• Importing to an existing database and project (Import > Other file) 

The options depend on which ReliaSoft application you're currently using: 

• For Weibull++ and BlockSim, you can use either method. 

• For Lambda Predict, XFMEA/RCM++ and MPC, you must use the File > Open Database 
method to import the data into a new project in a new standard database. 

Finally, for an enterprise database created in XFMEA/RCM++ 5, there is a dedicated utility that 
you can access from the Backstage View. (See Converting XFMEA/RCM++ 5 Databases.) 

Importing to a New Standard Database (File > Open Database) 

For all ReliaSoft desktop applications, you can use the File > Open Database method to import 
data from a project file or standard database that was created in a previous version of the 
software. This imports the data to a new project in a new standard database. 

1. Choose File > Open Database. 

2. Browse for the file and click Open. 

3. The conversion process will begin immediately for most applications. In BlockSim and MPC 
only, you will be prompted to specify some preferences and then click OK to proceed. 

• See Converting from BlockSim 6 or 7 Files. 

• See Converting MPC 3 Databases. 
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Note that although the conversion of XFMEA/RCM++ 5 databases does not require any user 
input, the process does apply some assumptions to address changes in the functionality and 
data structure between versions. (See Converting XFMEA/RCM++ 5 Databases.) 

When the process completes, the original file will remain unchanged and the new standard 
database will be created in the same folder. 

Tip: Once the new database has been created, you can use the Import/Export Projects feature 
to copy the data into an existing database, if desired. 

Importing to an Existing Database and Project (Import > Other file) 

For the applications and file types shown in the following table, you can use the Import > Other 
file method to import data from a project file that was created in a previous version of the 
software. This imports the data to a selected project in an existing standard database or 
enterprise database. 

Weibull++/ALTA/RGA BlockSim/RENO 

ReliaSoft Office 7 projects (*.rso7) BlockSim 7 projects (*.rbp) 

Weibull++ 7 projects (*.rwp) BlockSim 6 projects (*.rb6) 

ALTA 7 projects (*.ralp) RENO 1 projects (*.rnp) 

Weibull++ 6 projects (*.rw6)   

ALTA 6 projects (*.ra6)   

DOE++ 1 projects (*.rdoe)   

RGA 7 projects (*.rga7)   

RGA 6 projects (*.rga)   

  

Do the following: 

1. Create a new project or open an existing project that you want to import the data into. 

2. Choose Project > Management > Import/Export > Import. 

 

3. In the Import wizard, choose Other file and click OK. 
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4. The conversion process will begin immediately for most applications. In BlockSim only, you 
will be prompted to specify some preferences and then click OK to proceed. (See 
Converting from BlockSim 6 or 7 Files.) 

Note that although the conversion of XFMEA/RCM++ 5 databases does not require any user 
input, the process does apply some assumptions to address changes in the functionality and 
data structure between versions. (See Converting XFMEA/RCM++ 5 Databases.) 

When the process completes, the original file will remain unchanged and the converted data 
will be copied into the selected project. 

Converting from BlockSim 6 or 7 Files 

When you import from a BlockSim 6 (*.rb6) or BlockSim 7 (*.rbp) file, the Conversion Settings 
window allows you to specify: 

• Whether you want the diagrams to be converted to analytical diagrams, simulation 
diagrams, or both. 

• Whether the application will attempt to merge identical records when certain block 
properties are converted to resources. For example, if the old diagram has two blocks with 
the same failure distribution, this can be imported as two separate but identical failure 
models, or as a single failure model that's linked from both blocks. 

Tip: The default preferences for merging identical resources upon conversion are set on the 
Conversion page of BlockSim's Application Setup (File > Application Setup). Note that any 
changes you make in the Conversion Settings window will update your preferences in the 
Application Setup. In other words, the same options will be selected by default the next time 
you attempt to convert a BlockSim 6 or 7 file on this computer. 

Conversion Constraints and Differences 

Numerous improvements have been made to the modeling capabilities and underlying analysis 
and simulation algorithms used in BlockSim. As a result, analysis or simulation of diagrams 
imported from previous versions of BlockSim may yield results that differ from the results 
originally obtained. In particular, results may differ in the following cases and/or for the 
following reasons: 

• Simulation diagrams: 

• When multiple blocks are used in conjunction with subdiagrams, the underlying order 
of block expansion differs between versions, so results may differ. 
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• Starting in Version 8, containers are treated as subdiagrams. The underlying order of 
block expansion differs between versions, so results may differ. However, some special 
cases will produce identical results. These include cases where: 

• The container is the only block in the diagram. 

• The container is at the end of the list in the original diagram (i.e., it was created last 
and has the highest block ID, which is automatically assigned by the software upon 
block creation). 

• The load on contained load sharing blocks is calculated differently. Version 7 required a 
life-stress relationship for such configurations and based the re-calculation of load after 
block failure on that relationship; subsequent versions calculates load using the weight 
proportionality factor as a multiplier. 

• Normal/lognormal distributions have increased precision starting in Version 8. 

• Maintenance tasks that are performed at specified intervals (based on item age or 
calendar time) for multiple blocks are performed in a different order, producing results 
that are not identical, although the difference will not be statistically significant. 

• Indirect cost is calculated differently. In Version 7, the following was calculated at the 
end of the simulation: 

Indirect cost = Average stock level * Holding cost per item * Simulation end time 

In subsequent versions, the indirect cost is calculated for each simulation and then 
averaged at the end to yield the indirect cost that is shown. This is because holding cost 
per item may be a distribution. 

• The order in which random numbers are assigned in general is by block ID. This means 
that if diagrams have the same blocks with the same IDs in both the previous version 
and the current version, the results will be identical. Standby containers represent an 
exception to this. In Version 7, the order of blocks is overwritten by the standby 
priority. Therefore, results may not be identical with standby containers if the block IDs 
do not match the block standby priorities. The difference should not be statistically 
significant. 

• For mirrored blocks, in Version 7, the block that fails is the source and all the other 
mirrors are assigned these failures. In subsequent versions, the failures are assigned to 
the mirrored block with the lowest block ID. If the failure source is not the block with 
the lowest ID, then the results will be different between versions. 
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• Mirrored blocks inside subdiagrams are handled differently. In Version 7, they were 
treated as different groups of mirrors; subsequent versions treat them as the same 
group. This may produce results that are statistically different. 

• Throughput is not available in fault trees starting in Version 8. 

• The throughput property Send units to failed blocks works differently for subdiagrams 
in versions after Version 7, in that it applies to the whole diagram. That is, if the current 
block is set to not send units to failed blocks and the next block is a subdiagram that is 
not operating, then the throughput will be re-routed if possible or the current block will 
accumulate backlog. 

• Phases have different rules on how interrupted events are handled and may give 
different results when re-simulating. 

• Starting in Version 8, containers do not exist in maintenance phases. Thus, the 
availability results for containers in phase simulation may be different than in previous 
versions. 

• Analytical diagrams: 

• The load on contained load sharing blocks is calculated differently. Version 7 required a 
life-stress relationship for such configurations and based the re-calculation of load after 
block failure on that relationship; subsequent versions calculate load using the weight 
proportionality factor as a multiplier. 

• Mirrored blocks inside subdiagrams are handled differently. In Version 7, they were 
treated as different groups of mirrors; subsequent versions treat them as the same 
group. This may produce results that are statistically different. 

• Other issues of interest when opening BlockSim 7 files: 

• Nodes do not have failure/maintenance properties starting in Version 8. Therefore, if a 
node has failure properties in BlockSim 7, it will be imported in the current version as 
two blocks: a node with the k-out-of-n and the throughput properties (if applicable) 
and a block with the failure properties positioned immediately after the node. If the 
node does not have failure properties, a second block will not be imported. 

• The load on contained load sharing blocks is calculated differently. Version 7 required a 
life-stress relationship for such configurations and based the re-calculation of load after 
block failure on that relationship; subsequent versions calculate load using the weight 
proportionality factor as a multiplier. Because of this, if you convert a diagram that uses 
load sharing containers, you will need to manually configure the contained load sharing 
blocks after conversion. 
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• Simulation FRED reports will be imported, but cannot be restarted or have levels 
appended/removed until the diagram is resimulated. 

In addition, certain rules apply when importing maintenance properties from BlockSim 7: 

• Preventive maintenance: 

• For each preventive maintenance setting, a new task will be created. For example, 
if the preventive maintenance policy is set to be performed upon system down and 
upon system age, two tasks will be created. 

• For each task created, the duration, crews, restoration factor, etc. will be identical. 

• Inspections: 

• For each inspection setting, a new task will be created. For example, if the 
inspection policy is set to be performed upon system down and upon system age, 
two tasks will be created. 

• For each task created, the duration, crews, restoration factor, etc. will be identical. 
Note that inspections do not use pools. 

• If a detection threshold is defined in Version 7, an on condition task will be created 
instead of an inspection task in subsequent versions. A threshold is defined in 
Version 7 if a Failure Detection Threshold greater than 0 and less than 1 is specified 
or if a P-F Interval greater than 0 is specified. 

• The inspection properties from Version 7 will be transferred to the inspection 
properties of the on condition task in subsequent versions. 

• The threshold (i.e., detection) information from Version 7 will be transferred to 
the failure detection properties of the on condition task in subsequent 
versions. 

• The preventive maintenance properties from Version 7 will be transferred to 
the on condition task (upon detection) properties of the on condition task in 
subsequent versions. 

• If a detection threshold is defined in Version 7 but no preventive maintenance 
properties are defined, then only an inspection task will be created (i.e., the 
threshold is ignored). 

• PM/Inspection based on group: 
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• A task will be added and assigned to the maintenance group that the block belongs 
to. For example, if Block 1 belongs to Item Group 1 and has an inspection policy 
based on group maintenance in Version 7, then in subsequent versions an 
inspection task will be created and will be set to be performed upon group 
maintenance. Maintenance Group 1 will be checked in the list of groups that will 
trigger a maintenance, and Block 1 will be assigned to Maintenance Group 1. 

• If the block does not belong to a group, a task will not be added. 

• The corrective maintenance properties will be imported as corrective tasks. 

• A preventive maintenance action or an inspection based on maintenance phase and 
associated with a block in a standard phase will not be imported. 

Converting XFMEA/RCM++ 5 Databases 

This topic describes how to convert/import data from an XFMEA/RCM++ 5 database into a 
ReliaSoft database.  

For information about converting and importing data from an XFMEA/RCM++ 5 library, please 
consult the "Configurable Settings" chapter in the XFMEA/RCM++/RBI documentation. 

Standard Databases (*.rx5) 

For XFMEA/RCM++ 5 standard databases, you must convert the entire *.rx5 file to a new 
standard database. (Later, you can use the Import/Export Projects feature to copy specific 
projects into an existing database, if desired.) 

Do the following: 

1. In the current version of XFMEA, RCM++ or RBI, choose File > Open Database. 

2. Select RCM++ 5/XFMEA 5 (*.rx5) from the Files of type drop-down list. 

3. Select the file you wish to convert and click Open. 

The application will create a new standard database file in the same directory with the 
extension *.rsr20; the existing *.rx5 file will remain unchanged. 

Enterprise Databases 

For XFMEA/RCM++ 5 enterprise databases, you can select which analysis projects and settings 
you wish to import into an enterprise database that has already been created. You must be a 
member of the Admin group in the ReliaSoft enterprise database to perform this task. 
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Do the following: 

1. Connect with the enterprise database you want to import into. 

2. Choose File > Manage Database > Import from Version 5. 

 

3. In the area at the top of the Import from Version 5 Enterprise Database window, enter the 
connection information for the Version 5 enterprise database and click Connect. 

4. The table shows all of the data and settings in the original database. Use the check boxes to 
select which data you wish to import and then click OK to start the transfer. 

Note: If you are importing into a SQL Server database, the Create SQL Server login check box 
will be displayed at the bottom of the window. This is applicable only if you are importing user 
accounts. (See SQL Server Logins or Using Windows Impersonation.) 

Conversion Assumptions and Tips 

When you convert data from an XFMEA/RCM++ 5 database, please consider the following 
assumptions and tips: 

Conversion to Resources 

Certain types of information in the Version 5 projects will be converted to resources in the 
current version. This includes reliability information (which will be converted to models), 
controls and actions. In these cases, records that have identical properties will be merged into a 
single resource. For example, if there were two identical actions in the original project, a single 
action would be created as a resource in the project and used in both locations. 

Conversion to Security Groups 

If you are working with secure databases, the access levels and access groups in Version 5 will 
be converted to security groups in the current version. Specifically: 

• Database-level security: User permissions assigned by access level in Version 5 will be 
assigned by the corresponding security group in the current version. For example, if a user 
had the Admin access level in the original database, then that user will be assigned to the 
Admin security group in the current version. If there is no corresponding security group in 
the current version, the user will be imported with no security groups assigned, and a user 
with "Admin" access level permissions will have to manually assign security groups to the 
imported user. 



Chapter 18: ReliaSoft Common Tools 

Weibull++ 2020 User's Guide 1207 

 

• Project-level security: For each access group in the Version 5 database, a security group will 
be created in the ReliaSoft database. Because the Version 5 access groups could have 
different access levels for different users in the same group, it is not possible to 
automatically determine which permissions should be assigned for the new security group 
in the current version. Therefore, these groups will initially be assigned the default 
permissions; you can edit the permissions via the Security Groups tab of the Users and 
Security window. Projects that had access limited by access group in Version 5 will continue 
to have their security set by the appropriate security group(s) at the project level in the 
current version. 

Configurable Settings for Converted Projects 

When you convert an existing project from Version 5, the application will add new configurable 
settings for new features that were added in the current version. For example, the configurable 
PFD Worksheet settings will be added to the interface style, the quantitative values will be 
added to the occurrence rating scale, etc. 

It is important to note that these default settings may need to be modified after the conversion. 
For details, please consult the "Configurable Settings" section in the XFMEA/RCM++/RBI 
documentation. 

Converting MPC 3 Databases 

If you have an existing systems and powerplant analysis that was created in MPC 3, it is easy to 
convert the *.rsm file into a new ReliaSoft database. 

Choose File > Open Database, select MPC 3 (*.rsm) from the Files of type drop-down list, and 
then browse for the desired file. 

When prompted to enter a username and password, enter the administrative login from the old 
*.rsm file. 

Note: By default, a converted Version 3 database is a secure database that transfers any user 
accounts that were defined in the old database. After the new database has been created, the 
administrator should review the automatically created user accounts and update as 
appropriate. See Security Options for more information about database-level security. 

The final step is to use the Tasks Conversion window to review the task records that will be 
imported and make any updates that may be needed (see details below). Once you have 
completed the review, click OK to start the import. 
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When the process completes, there will be a new standard database file in the same folder and 
with the same name as the original *.rsm file. The new file will have the extension *.rsr20 and 
the original *.rsm file will remain unchanged. 

Tasks Conversion Window 

The Tasks Conversion window displays a list of all of the tasks defined in the original database 
and allows you to review how the records will be converted upon import. For any properties 
that are displayed with blue text, you have the option to change the task record data before it 
is imported. 

Some task properties are handled a bit differently than they were in Version 3. Specifically: 

• Some of the Task Types that were combined in Version 3 are now categorized separately 
(e.g., Operational Check (OPC) and Visual Check (VCK) are now separate task types). 

• In Version 3, the task Interval was always stored as a text field. Now, you can choose 
whether each task's interval will be stored as a text field or if it will instead be recorded as a 
number with an associated unit (e.g., 2000 flight hours can now be stored as value=2000 
and unit = FHr). Numbers may be easier to sort and will also make it possible to perform 
simulation-based reliability calculations if you choose to import the analysis project to 
RCM++ or RBI. 

• The Zonal field from Version 3 is called Zonal Candidate in the current version. This is now 
a yes/no field that can be set to Yes only if the failure effect categorization (FEC) is set to 5 
or 8 (i.e., a safety issue) and the task type is "General Visual Inspection (GVI)." Also in the 
current version, the Zone field will be enabled only if Zonal Candidate is set to Yes. 

The following subsections describe the default conversion logic for Task Type, Interval and 
Zone. 

Task Type 

For the Discard and Restoration task types, there is no difference between Version 3 and 
subsequent versions. The text in the Task Type (New Value) column will be displayed in italics to 
indicate that this property cannot be changed via the Tasks Conversion window. 
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For the remaining task types, the software will use the logic specified below to suggest a task 
type, but the property will be displayed in blue text to indicate that it can be edited. If you 
disagree with the default selection, you can choose one of the other eligible task types from the 
drop-down list, as shown in the following example. 

 

• When the task type was set to Inspection/Functional Check (IN) in Version 3, the following 
logic will be applied in the specified order. For example, if the task description contains 
both the word "Visual" and the word "Function," the General Visual Inspection task type 
will be applied by default because the word "Visual" will be matched first. 

If the task description contains: The default option is to import the task as: 

Visual General Visual Inspection 

Special Detail Special Detailed Inspection 

Health Monitor Scheduled Structural Health Monitoring 

Function Functional Check 

none of the words/phrases listed above Detailed Inspection (DET) 

  

• When the task type was set to Lubrication/Servicing (LU) in Version 3, the default option is 
to import the task as Servicing (SVC) if the task description contains "Servic" and as 
Lubrication (LUB) if it does not. 

• When the task type was set to Operational/Visual Check (OP) in Version 3, the default 
option is to import the task as Visual Check (VCK) if the description contains "Visual" and as 
Operational Check (OPC) if it does not. 

Tip: The task types in Version 9 and later of MPC are determined by the requirements of the 
MSG-3 guidelines and cannot be changed. However, the abbreviations can be configured to fit 
your particular preferences. If you want to change the default task type abbreviations (e.g., if 
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you don't want to use DIS for Discard, RST for Restoration, etc.), click the Task Type 
Abbreviations button. The changes that you make in the Define Task Type Abbreviations 
window will automatically apply to all analyses in the current database. This window is also 
accessible from File > Manage Database > Task Types. 

Interval Type and Interval 

Two options are displayed at the top of the Tasks Conversion window to determine how the 
task intervals will be imported: 

• If you choose Transfer all intervals as text, the interval type for all imported task records 
will be set to Based on Events (Text) and the interval will be stored as a text field (just like 
in MPC 3). The Interval (New Value) column will be displayed in blue text to indicate that 
you can change the text if desired before the import. 

 

• If you choose Transfer intervals as numeric if possible, the application will check to see if 
the original task interval begins with a number and is followed by a space and at least one 
text character. If it does (e.g., "2000 flt/hr"), the default option is to import it as a number 
with an associated unit. If not (e.g., "Per Mfg Life Limit"), the default is to import as text. 
Either way, you have the option to change both the interval type and new value before the 
import. For example: 
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Tip: If you want to change the units displayed in the drop-down list, click the Units button. The 
changes that you make in the Unit Settings window will apply immediately to the tasks that you 
are currently importing, and also to all other analyses you may later add to this database. This 
window is also accessible from File > Manage Database > Unit Settings. 

The Tasks Conversion window uses a variety of techniques to try to match the text field from 
Version 3 with one of the specified units in subsequent versions. There will be a match if the 
name or abbreviation of a current version unit either starts with or contains the text in the 
Version 3 field. For some predefined units, the software also recognizes other commonly used 
abbreviations for the unit (e.g., the software will recognize any of the following abbreviations as 
flight hours: Flt/Hr, Flight H, Flt H or Flt/H). 

If your data set contains a task interval that is not recognized, you can do any of the following: 

• Edit the text in the Interval (New Value) column so it will match either the name or the 
abbreviation of a predefined unit. For example, if the Version 3 task record contains a 
misspelling for "2000 fliight hours," you can click inside the cell and remove the extra i. 

• Click the Units button and define a new unit for the database with a name or abbreviation 
that matches the data you want to import. For example, if the Version 3 task record has an 
interval of "5 Weeks," you can open the "Unit Settings" window and create a new unit with 
the name "Weeks." 

• Click Cancel to close the Tasks Conversion window then edit the original tasks in MPC 3 
before starting the import again. 

Zonal Candidate and Zone 

If all of the following conditions are met, the Zonal Candidate (New Value) column will be set 
to Yes by default and any information from the Zone field will be transferred during the import: 

• The failure effect categorization (FEC) is set to 5 or 8 (i.e., it is a safety issue). 

• The Task Type is set to General Visual Inspection (GVI). 

• The Zonal property in the original MPC 3 analysis contains the word "Transfer." 
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If you don't want the task to be considered for zonal analysis even though it meets the 
requirements, you can click inside the Zonal Candidate (New Value) column and choose No 
from the drop-down list. If this column displays No in italics, this indicates that at least one of 
these conditions is not met and the property cannot be changed. 

 

IMPORTING/EXPORTING PROJECTS 

All ReliaSoft desktop applications make it easy to import or export selected projects from one 
database to another. 

Note that when importing/exporting a project between databases, any resources and FMEAs 
used by the project will be automatically imported/exported along with the project as local 
resources, even if they were originally reference resources or global resources. If you do not 
want the reference resources to be converted to local resources, you must import the both the 
project and the reference project at the same time. (See Local, Global and Reference 
Resources.) 

To import a project, first choose Project > Management > Import/Export. 

 or  

In MPC, the Import/Export window opens directly. In all other applications, a wizard displays 
the options that are relevant for the current application. Select Projects and click OK. 

Once the Import Projects or Export Projects window is open, do the following: 

1. Use the drop-down list or browse icon  to select the database that you want to import 
from or export to. 

• This can be any existing standard database (*.rsr20) or enterprise database connection 
file (*.rserp). 
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• If you are exporting, you can also use the add icon  to create a new standard 
database to export into. 

2. The tree displays the projects that are available to be imported or exported. If desired, you 
can use the Filter and Find tools to limit the list of projects displayed. (See Project 
Manager.) 

 

3. Use the check boxes to select which project(s) you want to import/export then click OK to 
copy the data. 

The following considerations apply: 

• The names of projects must be unique within each ReliaSoft database. If you attempt to 
import/export a project with a name that already exists in the destination database, the 
application will automatically increment the name. For example, if "Project1" already exists, 
the new project might be renamed to "Project1_1." 

• If the project has a category, the application will first attempt to match it to an existing 
category in the destination database. If a matching category does not already exist, and you 
have the permission to create project categories in the destination database, it will be 
created automatically. 

• If you select a project of a type that you don’t have permission to create in the destination 
database (private, public or reference), it will be converted to a type that you do have 
permission to create. For example, if you select to import a reference project but you don’t 
have the "Create and own reference projects" permission in the destination database, the 
project will be imported as a public or private project, and any links from other projects will 
be broken. 

IMPORTING/EXPORTING PROJECT ITEMS OR RESOURCES 

When applicable, ReliaSoft applications make it easy to import/export selected project items 
(e.g., folios, diagrams, plot sheets, ReliaSoft Workbooks, etc.) or resources (e.g., models, 
maintenance tasks, etc.) between existing projects. The projects can be in the same database or 
in different databases. 
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First, open the project you want to import to or export from. Then open the import/export 
window, there are two ways: 

• If you have selected the Allow multiple projects option in the Common Settings page of the 
Application Setup, you can open both projects simultaneously and then drag/drop items 
from one project to another. 
 
OR 

• Choose Project > Management > Import/Export. 

 or  

In the wizard, choose Items (not available for XFMEA/RCM++/RBI and MPC) or Resources 
(not available for MPC) and click OK. 

Once the Import window or Export window is open, do the following: 

1. Use the drop-down list or browse icon  to select the database you want to import from 
or export to. 

• This can be any existing standard database (*.rsr20) or enterprise database connection 
file (*.rserp). 

• If you are exporting, you can create a new standard database and project by clicking 
the  icon. 

2. Use the tree in the Source Project or Destination Project area to select the project you 
want to import from or export to. If desired, you can use the Filter and Find tools to limit 
the list of projects displayed. (See Project Manager.) 

 

3. Use the check boxes in the Items to Import or Items to Export area to select which project 
items or resources you want to import/export. 
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• For project items, this area will display the same folders that appear in the current 
project explorer. A +/- icon next to the folder indicates that it contains at least one 
project item that can be imported or exported. 

• For resources, this area will display a folder for each type of resource that exists in the 
selected project. 

4. Click Import or Export to copy the data. 

Note: The names of project items and resources must be unique within each project. If you 
attempt to import/export something with a name that already exists in the destination project, 
the application will automatically increment the name. For example, if "Folio1" already exists, 
the new folio might be renamed to "Folio1_1," "Folio1_2," etc. 

Keeping Associated Items/Resources Together 

The application will automatically copy any item/resource that is linked to the imported or 
exported item, even if you did not specifically select to import/export them. Some examples: 

• A mulitplot, such as an overlay plot, side-by-side plot, or 3D plot, will automatically 
import/export a copy of the folios or diagrams that were used to generate the plot. 

• A BlockSim diagram will automatically import/export a copy of any utilized subdiagrams 
and resources. This includes event analysis flowcharts, which will automatically 
import/export copies of any utilized subcharts, resources and ReliaSoft Workbooks. 

• A ReliaSoft Workbook or special analysis folio/tool (e.g., allocation analysis, stress-
strength analysis, etc.) will automatically import/export a copy of its data sources. 

• A URD will automatically import/export a copy of the models, maintenance tasks, crews, 
etc. that were used to build the URD. The same applies to any resource that is built upon 
another resource. 

Note that when importing/exporting project items between databases, the resources are 
imported/exported as local resources in the destination database, even if they were originally 
reference resources or global resources. For more information on how importing/exporting 
affects a resource, see Local, Global and Reference Resources. 

Tip: If you do not want an event analysis flowchart to import/export an associated resource or 
workbook, you can enclose the resource/workbook name in single quotes to reference it by 
name only. For example, if you export a diagram that contains a block using the expression 
'Model1'(1000), Model1 will not be transferred along with that diagram. If the destination 
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project already contains a model called Model1, that model will be used in simulating the 
transferred diagram. 

IMPORTING FROM EXCEL OR DELIMITED TEXT FILES INTO A FOLIO 

In Weibull++, it is easy to import data from any of the following file types into a folio. 

• Excel files (*.xls, *.xlsx) 

• Tab, comma, space and semicolon delimited files (*.txt, *.csv, *.prn, *.smc) 

Tip: Other ReliaSoft applications use different tools for importing/exporting via Excel (i.e., for 
importing Bill of Materials data in Lambda Predict and failure mode data in XFMEA/RCM++/RBI 
and MPC). For more information about those features, please consult the documentation for 
each particular application. 

First, open the project that you want to import into and choose Project > Management > 
Import/Export. 

 or  

In the wizard, choose Other file and click OK. 

Browse for the file you wish to import from and click Open. Note that: 

• In DOE design folios, the data will be copied into a new free form folio, where you can then 
designate columns for factors and responses and analyze the data. If you are importing 
from an Excel file that has multiple worksheets, the sheet that was active the last time the 
file was opened will be used. 

• In Weibull++, you will need to specify which data will be imported and how it will be 
mapped to the columns in the particular type of data folio. The rest of this topic describes 
how to map the data for import into a Weibull++ data folio.  

Selecting Which Data Sheets Will Be Imported 

The left side of the utility displays the data from the Excel or delimited text file that is currently 
selected. If you wish to open a different source file, click Open. 
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If you are importing from an Excel file that has multiple worksheets, use the tabs at the bottom 
of the window to view and set the import preferences for each sheet. 

Use the options at the top of the control panel for each sheet to specify whether the data will 
be imported. 

• Do not import sheet: The control panel will not contain any other options and the data will 
not be imported. 

• Import sheet: The control panel displays the options you need to either manually map the 
columns or use a template to automatically apply the same mapping that was used for 
another file. 

Using the Control Panel to Map the Columns That Will Be Imported 

If you are not using a template, or if you need to modify the settings after an import template 
has been applied, do the following: 

1. Use the Data Type drop-down list to specify which type of folio to import into. This can be 
different for each sheet, and it determines which options will be available in the rest of the 
control panel. 

2. Click inside each column that you wish to import and then click the corresponding button in 
the control panel to map it to a column in the data folio. This updates the column heading 
and maps the data to a column in the data folio. 

3.  

• If the heading displays a letter, the data in that column will not be imported. 

• If the heading displays a name, the data will be imported to the column associated with 
that name. 

• To remove the column mapping, click inside the column and click the corresponding 
button again. 

As an example, the following picture shows data that will be imported into a Weibull++ life 
data folio. Column A will not be imported. The rest of the data has been assigned to 
columns that are used in the folios. 
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4. If you are importing to an life-stress data folio, use the Number of Stresses field to specify 
how many stress columns will be created in the new folio (maximum = 8). Note that: 

• If you enter a value that is less than the number of columns that were mapped with the 
Stress button, the "extra" stress column data will not be imported. 

• If the number is greater, the additional stress columns will be created in the new folio 
and you can enter the data later. 

5. If the source file contains column headings or other introductory material that should not 
be imported, use the Start from Row field to specify where the actual data begins. For 
example, in the picture above, the first row contains heading labels so the data import 
should begin from Row 2. 

Setting the Import Template Directory 

If you will be importing data from multiple files that have the same structure, you can use saved 
template files (*.waim or *.rgaim in Weibull++) to automatically map the columns for all other 
similar files that you need to import from. 

By default, template files will be stored at 
C:\Users\<username>\AppData\Roaming\ReliaSoft\<application>\Import Templates. This 
directory determines which templates will be displayed in the Import Template drop-down list 
in the control panel. It also sets the default path for saving any new templates you create. 

If you want to access templates from a different location, click the Import Template Directory 
button at the top of the window and select a different folder. 
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Creating a New Import Template 

1. Open a data file and use the control panel buttons to map the columns. 

2. Click the Save icon in the Import Template area on the control panel. 

 

3. Specify a name and click Save. 

Applying a Saved Import Template 

1. Open the data file and select Import sheet to display the rest of the control panel options. 

2. Make sure the Import Template Directory is set to the folder that contains the applicable 
template file(s). 

3. Use the drop-down list in the Import Template area to select the template you want to 
apply. 

 

The utility will automatically assign the column mappings defined in the template. If 
desired, you can use the control panel to make further adjustments before import. 

4. When you are satisfied with the mapping, click Import to create the new folio. 

 

Tip: If you make adjustments after applying the template, you have the option to click Save in 
the Import Template area to either replace the existing template, or create a new template 
with a different name. 
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Importing the Data 

When you are ready to import the data, click the Import button. 

 

By default, the application will import the data into a new folio. The status bar will display 
"Import into New Folio," as shown in the following example. 

 

If you prefer to import into an existing folio instead, click the Import to Existing Folio button 
and choose one of the available folios. When you return to the import window, the status bar 
will now display the name of the selected folio, as shown in the next example. 

 

USING XML IN BLOCKSIM AND LAMBDA PREDICT 

In BlockSim and Lambda Predict, you have the option to use XML (extensible markup language) 
files to import or export system configuration data and item properties. XML files can be used 
to transfer data to/from other applications or database systems. 

In BlockSim, the XML files include the block properties and information about how the blocks 
are connected in a reliability block diagram or fault tree diagram. They do not include visual 
aspects such as diagram style settings, block style settings, etc. BlockSim supports both import 
and export via XML. 

In Lambda Predict, the XML files include the structure of the system hierarchy in a prediction 
folio and some of the item properties. Lambda Predict supports export to XML. 

Exporting to XML 

To create an XML file, first open the project and then choose Project > Management > 
Import/Export > Export. 

 

In the wizard, choose Other file and click OK. 

Specify the desired pathname/filename and click Save. This will export the relevant information 
for all of the diagrams or prediction folios in the current project. Other project items (such as 
event analysis flowcharts, plots, attachments, etc.) are not included. 
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Importing from XML 

There are two ways to import from an XML file. 

If you want to import to a new project in a new standard database: 

1. Choose File > Open Database. 

2. Browse for the file and click Open. 

If you want to import to a selected project in an existing standard database or enterprise 
database: 

1. Create a new project or open an existing project that you want to import into. 

2. Choose Project > Management > Import/Export > Import. 

 

In the wizard, choose Other file and click OK. 

3. Browse for the file and click Open. 

Attachments 
All ReliaSoft desktop applications allow you to attach URLs and/or files that were created in 
other applications. This helps you to keep supporting documentation all together in the same 
place with your analysis. The locations where you can attach files will vary depending on which 
application you are using. 

In all desktop applications, attachments can be either linked or embedded. 

• URL and File Link attachments store the path to a web page or file. This allows you to open 
the resource in its original location (e.g., Internet, intranet or network directory), provided 
that the necessary software is installed on your computer and the link is valid. The files 
themselves are not stored inside the database. When you delete a file link or URL, this 
simply removes the link, leaving the original file untouched. 

Note: If your organization has implemented an SEP web portal for an enterprise database, 
note that file link attachments (i.e., stored paths to local files on your computer or network) 
cannot be created, opened or saved within the SEP due to browser security. 
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• Embedded attachments are always files. For these attachments, the software stores a 
complete copy of the file inside the database. When you delete an embedded file, the 
actual file is deleted from the database and this cannot be undone (unless you happen to 
have a saved backup or restore point that you could roll back to). 

The Attachments window manages all of the URLs/files attached to a particular location (e.g., 
project, resource, hierarchy record or block). 

 

The Add/Edit Attachment window specifies the details of an individual file or URL, and will be 
displayed whenever you choose to create or edit an attachment. 
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If you are attaching a file, the Address field will display a Browse icon (  ) so you can select 
the file to be attached. 

If you are attaching a URL, the Name field will be populated automatically as you type the URL 
into the Address field. This is for your convenience only and you can specify a different name if 
desired. 

ATTACHMENT LOCATIONS 

As mentioned above, the locations where you can attach files will vary depending on which 
application you are using. 

Tip: In most cases, the caption bar in the Attachments window will provide an indication of 
which type of attachment you are working with. For example, when you are working with 
project-level attachments, the caption bar will indicate "Project:" followed by the specific name 
of the project. 

Project Attachments 

All ReliaSoft desktop applications support attachments at the project level. In all applications, 
project attachments can be displayed/managed from the Attachments icon in the Project 
Properties window. 
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For most applications, project attachments can also be displayed/managed from the 
Attachments folder in the current project explorer. 

 

In XFMEA, RCM++, RBI and MPC (which do not have a current project explorer), you can also 
access the project attachments by selecting Project > Management > Attachments. 

Resource Attachments 

All of the applications that utilize resources support attachments at the resource level. For 
example, you can attach a file to a URD, a model, etc. 

To access attachments for an existing resource, you can click the Attachments icon in the 
resource's properties window. 

 

Hierarchy Attachments 

Some applications, including XFMEA, RCM++, RBI, Lambda Predict and MPC, support 
attachments for individual items or records in a system hierarchy or analysis hierarchy. For 
example, in XFMEA, you can create attachments for a particular item, or for a particular record 
in the FMEA for that item. 

To access attachments for items or records in a hierarchy, you can double-click inside the 
Attachments column. (If this column is not displayed on your computer, right-click inside the 
column headings and choose Customize Columns.) You can also choose Tools > Attachments 
on the ribbon tab for the hierarchy that you are currently working with. 
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For records in an analysis hierarchy (such as FMEA or functional failure analysis), the 
attachment icon can also be accessed from within the record properties window. 

 

Block Attachments 

BlockSim supports attachments for individual blocks in a diagram. To access attachments for a 
block, you can click the Attachments icon in the Block Properties window. 

 

Select Existing Text Window 
The Select Existing Text window provides a list of existing descriptions that might apply to the 
current text field or analysis. This can help to save time on data entry, ensure consistency and 
facilitate brainstorming. The utility is used extensively in applications such as XFMEA, RCM++, 
RBI and MPC, and it is also available for certain text fields in other ReliaSoft desktop 
applications. 

There are two ways this utility might be used: 

• Replace or append text in the current field - If you click the  icon inside a text field, you 
can select text and either replace the current text or append the new text to the end. 
Starting in Version 2019, many text fields in XFMEA/RCM++/RBI allow selection of multiple 
descriptions, which will be concatenated in the order in which they were selected using the 
separator specified in the Separator field. Available separators include commas, periods, 
semicolons, dashes and, for multi-line text fields, new lines. 
 
When you are using the utility in this way, the New Text Preview area shows how the 
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selected text will appear, and provides information on how many characters out of the 
character limit are being used (e.g., 45 characters out of a possible 2000 in the example 
below). If you exceed the text field's character limit, your text will be truncated. 

• Create one or multiple new records - If you use one of the ribbon commands in an FMEA or 
P-Diagram (e.g., Functions > Select Existing Text), you can select multiple descriptions and 
the utility will use your selection(s) to create new record(s). 

The options will vary depending on the record/field type, and whether you are updating a single 
description or adding new records. The following example shows how the tool may be used to 
populate the function description in an FMEA. 

 

Tip: The descriptions are sorted alphabetically under each heading. When the table has focus, 
you can type a letter to move to the next description that begins with the letter. 

PROJECT AND ITEM FILTERS 

This window utilizes the same project and item filters that are available in many other locations 
throughout ReliaSoft desktop applications. For example, when searching for text for an item in 
the system hierarchy, you could use a Project Filter to search for analyses performed by 
Department A and then use an Item Filter to show only those analyses that were modified in 
the last month. 

 

In addition, when applicable: 
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• Project Filters: 

• Phrase Sets Only limits the results to data in the selected phrase set(s), with no data 
from any projects. 

• Current Project limits the results to data in the current project. 

• Item Filters: 

• Current Item limits the results to those found in the currently selected system 
hierarchy item. 

• Parent Item limits the results to those found in the immediate parent of the currently 
selected system hierarchy item. 

• Next Lower Level Items limits the results to those found in the immediate dependents 
of the currently selected system hierarchy item. 

• Current Item Branch limits the results to those found in the current branch of the 
system hierarchy. 

• If the currently selected system hierarchy item has a category assigned, Match 
Category limits the results to those found in system hierarchy items that have the same 
category assigned. The scope of this search is limited by your project filter, if any. 

• If the currently selected system hierarchy item has a part number assigned, Match Part 
Number limits the results to those found in system hierarchy items that have the same 
part number assigned. The scope of this search is limited by your project filter, if any. 

RECORD FILTER 

When applicable, the Record Filter shows the possible sources for the current record type and 
field that you can choose to include or exclude. The specific record types vary depending on the 
field. 
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PHRASE SETS 

FMEA records in XFMEA, RCM++ and RBI also have the option to include text from selected 
phrase sets. 

 

FIELD TEXT 

Use the drop-down list in the Field Text area to specify how to match the specified keywords, 
then type the keywords into the input box. 

• Contains returns descriptions that contain the exact string entered. 
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• Contains Any and Contains All allow you to enter multiple keywords (separated by 
commas) and returns descriptions that contain at least one (any) or all of the keywords 
entered. 

• Begins With returns descriptions where the exact string entered appears at the start of the 
field. 

• is returns descriptions where the exact string entered matches the whole field. 

RECORD FILTER OPTIONS 

When the descriptions can be obtained from more than one type of analysis (e.g., when PFMEA 
failures can be copied from FMEA causes, or when control plan operations can be copied from 
PFD Worksheet operations), the headings in the table identify the source. You can use the 
Record Filter to specify which source(s) to include. 

FMEAs 

FMEA Functions FMEA Functions 
Next Higher Level Functions 
Next Lower Level Functions 
FMEA Function Requirements 
System Hierarchy Items 
PFD Worksheet Operations 
P-Diagram Ideal Responses 
P-Diagram Piece-to-Piece 
P-Diagram Change Over Time 
P-Diagram Usage 
P-Diagram Environment 
P-Diagram System Interaction 

FMEA Functions: Requirements FMEA Function Requirements 
FMEA Functions 
Next Higher Level Functions 
Next Lower Level Functions 
P-Diagram Functions 
P-Diagram Functional 
Requirements 
P-Diagram Non-Functional 
Requirements 
P-Diagram Input Signals 
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FMEA Functions: Next Higher Level Functions and Next 
Lower Level Functions 

FMEA Functions 
Next Higher Level Functions 
Next Lower Level Functions 
FMEA Function Requirements 

FMEA Functions: Next Lower Level Item FMEA Function: Next Lower Level 
Items 
System Hierarchy Items 

FMEA Failures FMEA Failures 
P-Diagram Error States 
FMEA Causes 
FMEA Function Requirements 
PFD Worksheet Product 
Characteristics 

FMEA Effects FMEA Effects 
FMEA Failures 
P-Diagram Error States 

FMEA Causes FMEA Causes 
P-Diagram Piece-to-Piece 
P-Diagram Change Over Time 
P-Diagram Usage 
P-Diagram Environment 
P-Diagram System Interaction 
P-Diagram Control Factors 
PFD Worksheet Process 
Characteristics 

FMEA Controls FMEA Controls 
P-Diagram Control Factors 
Control Plan Methods 
DVP&R Test/Specification 
Methods 

FMEA Actions FMEA Actions 
DVP&R Test/Specification 
Methods 

  

P-Diagrams 

P-Diagram Input Signal P-Diagram Input Signal 
System Hierarchy Items 
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P-Diagram Control Factors P-Diagram Control Factors 
FMEA Causes 

P-Diagram Error States P-Diagram Error States 
FMEA Failures 

P-Diagram Ideal Response P-Diagram Ideal Response 
FMEA Functions 

P-Diagram Piece-to-Piece P-Diagram Piece-to-Piece 
FMEA Causes 
PFD Worksheet Product Characteristics 
Analysis Plan Assumptions 

P-Diagram Usage P-Diagram Usage 
Analysis Plan Conditions of Use 

P-Diagram Environment P-Diagram Environment 
Analysis Plan Conditions of Use 

P-Diagram Change Over Time P-Diagram Change Over Time 
FMEA Causes 
Analysis Plan Conditions of Use 

P-Diagram Functions P-Diagram Functions 
FMEA Functions 
FMEA Function Requirements 

P-Diagram Functional Requirements P-Diagram Functional Requirements 
FMEA Functions 
FMEA Function Requirements 

P-Diagram Non-Functional Requirements P-Diagram Non-Functional Requirements 
FMEA Function Requirements 

  

Control Plans, PFD Worksheets and DVP&Rs 

Control Plan Part/Process Numbers Control Plan Part/Process Numbers 
FMEA Function Op Seq Numbers 
PFD Worksheet Op Seq Numbers 

Control Plan Process Name/Operation 
Descriptions 

Control Plan Process Name/Operation 
Description 
FMEA Functions 
PFD Worksheet Operations 
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Control Plan Product Characteristics Control Plan Product Characteristics 
PFD Worksheet Product Characteristics 
FMEA Causes 
FMEA Failures 

Control Plan Process Characteristics Control Plan Process Characteristics 
PFD Worksheet Process Characteristics 
FMEA Causes 

Control Plan Methods Control Plan Methods 
FMEA Controls 

PFD Worksheet Operation Descriptions PFD Worksheet Operation Description 
System Hierarchy Items 

PFD Worksheet Op Seq Numbers PFD Worksheet Op Seq Numbers 
System Hierarchy Item Reference Numbers 

PFD Worksheet Product Characteristics PFD Worksheet Product Characteristics 
P-Diagram Piece-to-Piece 

DVP&R Test/Specification Methods DVP&R Test/Specification Methods 
FMEA Controls 
FMEA Actions 

Check Spelling 
ReliaSoft desktop applications offer the ability to check the spelling of your text. This utility is 
available in different places within the software. For windows that offer the spell check 
functionality (e.g., Project Properties window, etc.), the Check Spelling icon  will be displayed 
within the window itself. For data sheets, spreadsheets and system hierarchies that offer the 
functionality, the Check Spelling icon will be available on the ribbon and you can access it by 
choosing Home > Edit > Spelling. 

Note: In system hierarchies (XFMEA, RCM++, RBI, MPC and Lambda Predict), the utility will 
check the property fields of the selected item only. This means that sub-items and text in 
analysis tabs, such as the FMEA tab in XFMEA, are not checked. 

Whenever text that is not in the application's dictionary is found, the Check Spelling window 
displays the text in question and offers a list of suggestions to verify the error or confirm the 
correction, as shown in the following example. 
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• Ignore Once ignores the current instance of the highlighted word but continues to highlight 
it if the same word appears again. 

• Ignore All ignores all instances of the word in the current form. 

• Add to Dictionary adds the highlighted word to the dictionary on your computer so the 
spell checker will not treat is as a misspelling. The dictionary file is saved in the default 
Documents folder on your computer (e.g., My Documents\ReliaSoft\Dictionaries). 

• Change replaces the current instance of the highlighted word with the word that is 
currently selected in the Suggestions area. If no word is selected, the first one will be used. 
Double-clicking a word in the Suggestions area is another way to change the highlighted 
text. 

• Change All replaces all instances of the highlighted word with the word that is currently 
selected in the Suggestions area. If no word is selected, the first one will be used. 

• Options opens the Spelling Options window, which provides additional settings to how the 
spell checker functions: 

• The General options area provides a list of the types of text that can be ignored by the 
spell checker (e.g., numbers, e-mail addresses, etc.). Select or clear each check box to 
specify how the spell checker will work on your computer. 
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• In the Edit custom dictionary area, the Edit button opens a window that displays all of 
the words that you have added to the custom dictionary on your computer. You can 
edit the custom dictionary by adding or removing words in the list and then clicking OK. 

• International dictionaries allows you to choose the language of the dictionary that will 
be used on your computer. 

• Undo Last reverses the last change that was made. 

Results Window 
The Results window is used in many ReliaSoft applications to show detailed calculation results. 
From this window, you can edit the results, copy the results to the Clipboard or print the 
results. 

• Paste pastes the contents of the Clipboard into the current control. 

• Cut cuts the selected text to the Clipboard. Data stored in the Clipboard can be pasted into 
this and other applications. 

• Copy copies the selected text to the Clipboard. Data stored in the Clipboard can be pasted 
into this and other applications. 

• Paste Special opens the Paste Special window, which allows you to paste specific cell 
contents or attributes (such as formulas, formats, or comments) from the Clipboard. 

• Quick Print sends the current document directly to the default printer without making 
changes. 

• Print opens the Print window, which allows you to specify the printer and the printing 
options. 

• Print Preview allows you to preview the current page before it is sent to the printer. 

• Send to Excel allows you to save the current selection as a Microsoft Excel (*.xls or *.xlsx) 
file and then opens that file in Excel, if it is installed on your computer. 

• Select Columns allows you to specify the columns shown in the spreadsheet. This option is 
available starting in Version 2020, for BlockSim fault trees only. 

Note that the Results window may contain multiple sheets, accessible via the page index tabs at 
the bottom of the window. 
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Quick Parameter Estimator (QPE) 

The Quick Parameter Estimator (QPE) allows you to estimate the parameters of a distribution 
based on information you have about the reliability of a product, the probability of an event 
occurring or the typical duration of a task. In all ReliaSoft desktop applications, you can open 
the QPE from the Model properties window or the Model wizard by clicking the QPE icon.   

 

In Weibull++, it's also accessible from the Home tab of the ribbon and several analysis 
interfaces (including the Weibull++ life data folio, the Monte Carlo and SimuMatic utilities, and 
the Expected Failure Times Plot). 

The QPE includes a Wizard view and an Expert view, described below. You can toggle between 
the different views by clicking the Use Expert or Use Wizard button at the bottom-left corner of 
the window. 

• The Wizard view automatically selects a distribution and estimates that distribution's 
parameters based on your responses to a series of questions. The first page of the Wizard 
view asks you to choose among three different types of models that you can build with the 
QPE. Subsequent pages will ask more specific questions related to your selected model. 

• The Expert view allows you to estimate the parameters of a distribution using either two 
unreliability values at specified times or one unreliability value and the other parameter(s) 
of the distribution. Unlike the Wizard view, you must select a distribution to solve the 
parameter(s) for. 

QUICK PARAMETER ESTIMATOR WIZARD VIEW 

To use the Wizard view of the Quick Parameter Estimator (QPE), simply follow the prompts on 
each page. The first page will present and describe three different types of models that you can 
build with the QPE. Below are the three models and the kind of information you'll need to 
provide in subsequent pages. 

To build a Reliability model you need to provide information about: 

• How age affects the product's reliability. 

• The product's intended design life and the estimated warranty time. 

• Best-case, worst-case and most likely unreliability estimates for the product at the end of 
the design life and warranty time. 
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To build an Event occurrence model you need to provide information about: 

• Whether age affects the probability of the event's occurrence. 

• Best-case, worst-case and most likely estimates for how often the event will occur. 

To build a Task duration model you need to provide information about: 

• Best-case, worst-case and most likely estimates for how long it will take to complete the 
task. 

The last window will display the tool's selected distribution and the calculated parameters. It 
will also provide one of the two options described below. 

• If you opened the QPE from an analysis folio or utility, the Update button will be available 
in case you wish to update that window using the selected distribution, calculated 
parameters and selected units. 

• In Weibull++, if you opened the QPE from the ribbon, the Finish & Copy button will be 
available in case you wish to copy the parameters results to the Windows Clipboard. 

QUICK PARAMETER ESTIMATOR EXPERT VIEW 

Follow the steps below to use the Expert view of the Quick Parameter Estimator (QPE): 

• Choose a distribution from the Distribution drop-down list. This is the distribution that you 
will solve the parameter(s) for. Then choose the appropriate time units from the Units 
drop-down list. 

• If you are not sure which distribution to select, consider using the Wizard view of the 
QPE instead. 

• Your choice of time units applies to all time inputs and applicable parameters of the 
distribution (such as the eta parameter when the Weibull distribution is used). 

• Select an appropriate option in the Quantification Method area. 

• The Unreliability and a Parameter method solves for one parameter of the 
distribution. It requires one unreliability point (i.e., an unreliability value at a specified 
time) and the values of all the parameters of the selected distribution except the 
parameter you will solve for. 

• If you select this method, you must then enter one unreliability point in the Point 
#1 area. For example, if you believe that your product has an unreliability of 10% at 
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100 hours, then you would enter 100 in the Time field and 0.10 in the Unreliability 
field. 

• In the Solve for Parameter area, select the parameter that you wish to solve for. 
The remaining parameters in this area will have input fields enabled. Enter the 
known values of these parameters. 

• The Two Unreliability Points method solves for all the parameters of the distribution. It 
requires two unreliability points that you will provide in the Point #1 and Point #2 
areas. 

Tip: If you are building an event occurrence or task duration model, you can treat an 
"unreliability" point as the probability that an event will occur or that a task will be 
completed by a specified time. For example, if you are modeling the probability of an 
event's occurrence and you believe that there is a probability of 30% that the event will 
occur before 150 hours, then you would enter 0.3 in the Unreliability field and 150 in the 
Time field. 

• Click Calculate to solve for the unknown parameter(s). 

• Click the Update button to update the model using the selected distribution, calculated 
parameters and selected time units. 

QUICK PARAMETER ESTIMATOR (ALTA) 

For life-stress data only, another version of the Quick Parameter Estimator (QPE) allows you to 
estimate the parameters of a model based on information you have about the reliability of a 
product at normal and accelerated stress levels. You can open the QPE from the ribbon by 
choosing Home > ReliaSoft > Quick Tools > Quick Parameter Estimator (ALTA). 

 

You can also open the ALTA QPE from the life-stress data folio (by leaving the folio's data sheet 
empty and clicking Calculate), as well as the stress-dependent Monte Carlo and stress-
dependent SimuMatic utilities. 

Follow the steps below to use the ALTA QPE: 

• The first page of the window will be used to estimate the product's mean life under normal 
stress conditions. 

• Choose a model from the Model drop-down list. This is the model that you will solve 
the parameter(s) for. Then choose the appropriate time units from the Units drop-
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down list. Your choice of time units applies to all time inputs and applicable parameters 
of the model (such as the eta parameter when the Weibull distribution is used). 

• Select an appropriate option in the Quantification Method area: 

• The Unreliability and a Parameter method solves for one parameter of the model. 
It requires one unreliability point (i.e., an unreliability value at a specified time) and 
the values of all the parameters of the selected model except the parameter you 
will solve for. 
 
If you select this method, you must then enter one unreliability point for normal 
use conditions in the Point #1 area. For example, if you believe that your product 
has an unreliability of 10% at 100 hours under normal use conditions, then you 
would enter 100 in the Time field and 0.10 in the Unreliability field. 
 
In the Solve for Parameter area, select the parameter that you wish to solve for. 
The remaining parameters in this area will have input fields enabled. Enter the 
known values of these parameters. 

• The Two Unreliability Points method solves for all the parameters of the model. It 
requires two unreliability points under normal use conditions that you will provide 
in the Point #1 and Point #2 areas. 

• In the Use Stress Level area, you must enter the stress level that the product will 
experience under normal conditions. In multi-stress situations, this stress level will be a 
combination of stress values for each stress type. 

• If the Number of Stresses field is enabled, enter the number of stresses that will be 
used in your model. (Note that different models have different requirements for 
the number of stresses that can be used.) 

• Click the arrow inside the Use Stress Value(s) field. In the table that appears, enter 
a stress value for each stress type. If there are multiple stress values, they will 
appear in the field separated by semicolons. 
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• Click Next > to go to the Life at Each Stress Level page. The Use Stress Level area of the 
page will display the product's mean life at the specified use stress level based on your 
previous inputs. In the Accelerated Level 1 area, you must enter the estimated mean life 
for the product at an accelerated stress level. 

• To enter the accelerated stress level, double-click inside the Stress Value(s) field. In the 
table that appears, enter the stress value for each stress. 
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• In the Characteristic Life field, enter the product's characteristic life at the associated 
accelerated stress level. 

• For the Weibull distribution, the characteristic life is equal to the value of the eta 
parameter (i.e., the time at which unreliability = 63.2%). 

• For the lognormal distribution, it is equal to Exp(Log-mean) (i.e., the time at which 
unreliability = 50%). 

• For the exponential distribution, it is equal to the mean life. 

Note: The number of accelerated stress levels you must provide life estimates for will 
equal the number of stresses that will be used in the selected model. For example, if 
the model uses two stress types, as shown above, then there will be an Accelerated 
Life 2 area in which you must provide a characteristic life estimate for a second 
accelerated stress level. 

• Click Next > again to see the calculated parameters. 

• If you opened the QPE from another utility, such as the Monte Carlo tool, you may click the 
Update button if you wish to update the Monte Carlo tool with the model, parameters and 
time units defined in the QPE. 

• If you opened the QPE from the ribbon, you may click the Finish & Copy button if you wish 
to copy the results to the Windows Clipboard. 
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Chapter 19: Resources 
In ReliaSoft applications except MPC, resources contain various types of information that can be 
shared between analyses. Resources may be created in one application and then shared with 
other ReliaSoft applications where they may be relevant. When the resource is updated with 
new information, the change is reflected in all analyses that rely upon it. 

An example of a resource is a model that represents a product's probability of operating 
successfully over time. The model may be defined manually or published from an application 
such as Weibull++ or Lambda Predict. Then it can be used in applications such as BlockSim, 
XFMEA, RCM++ or RBI as part of the universal reliability definition (URD) of a particular 
component/assembly. 

Note: In a secure database, the ability to create, edit and delete resources is available only if 
the user a) is the project owner, b) has the applicable "resources" permissions, or c) has the 
applicable "manage all projects" permissions. 

Types of Resources 
The following tables describe the types of resources that you can use in different ReliaSoft 
applications. These resources can be created while you're performing an analysis and also from 
the Resource Manager. (In a secure database, the ability to create, edit and delete resources is 
available only if the user a) is the project owner, b) has the applicable "resources" permissions, 
or c) has the applicable "manage all projects" permissions.) 

USED IN MULTIPLE APPLICATIONS 

Resource Used In 

Universal reliability definitions (URDs) describe a set of reliability 
and maintenance characteristics for a particular 
component/assembly. 

BlockSim, RCM++, 
XFMEA, RBI 

Variables store numerical values that can be programmatically varied 
during simulation. 

BlockSim 
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Models can represent probabilities, durations or costs, either fixed or 
time-dependent. They are used by other resources to represent the 
reliability of a component, the duration of a task, the expected cost 
of a repair, etc. 

Can be published 
from analyses in 

Weibull++, BlockSim 
and Lambda Predict, 
or created manually. 

Used in BlockSim, 
XFMEA, RCM++ and 

RBI. 

Tasks represent maintenance activities: 

• Corrective tasks are unplanned maintenance performed 
when a failure occurs. 

• Scheduled tasks can include preventive maintenance, 
inspections and on condition maintenance. 

BlockSim, RCM++, 
RBI 

Task packages represent groups of tasks that are performed 
together at scheduled intervals. 

BlockSim, RCM++, 
RBI 

Crews represent the personnel who will perform a maintenance task. BlockSim, RCM++, 
RBI 

Spare part pools determine whether a spare part will be available, 
how long it will take to obtain and how much it will cost. 

BlockSim, RCM++, 
RBI 

Metrics display any numerical value of interest, and track how it 
changes over time. 

All applications 
except MPC via the 

Project Planner; 
analyses in 

Weibull++, BlockSim, 
XFMEA, RCM++ and 

RBI 

Maintenance groups are used to model situations in which some 
event within the group can trigger maintenance or state changes for 
other components/assemblies. 

BlockSim, RCM++, 
RBI 

Mirror groups are used to represent the exact same 
component/event in more than one location within your analysis. 

BlockSim, RCM++, 
XFMEA, RBI 

Actions describe specific assignments that need to be performed. All applications via 
My Portal; Project 

Planner and FMEAs 
in RCM++, RBI and 

XFMEA 
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Controls may be used in FMEAs and/or control plans to represent 
methods to reduce or eliminate the risk associated with potential 
failures. 

RCM++, XFMEA, RBI 

Profiles represent values that vary with time. They can be used for 
life-stress folios to describe stress levels under test conditions, or in 
process flow simulation diagrams to describe patterns of throughput. 
They can also be used to describe cost and duration in spare part 
pools. 

BlockSim, RCM++, 
RBI 

  

USED ONLY IN BLOCKSIM 

Resource Used In 

Switches describe how the activity transfers between active and 
standby blocks in BlockSim's standby containers/gates. 

BlockSim 

Maintenance templates define the activities that will be performed 
during a maintenance phase in a phase diagram.  

BlockSim 

Flow groups are used to model situations in which meeting a 
particular flow threshold can trigger maintenance tasks. These 
groups are used only in process flow simulation diagrams (if 
supported by your license). 

BlockSim 

Event analysis functions store equations that are evaluated based on 
input values passed to the function during simulation. These 
resources are used only in event analysis flowcharts (if supported by 
your license). 

BlockSim 

Event analysis static functions store equations that are evaluated 
before simulation begins. These resources are used only in event 
analysis flowcharts (if supported by your license). 

BlockSim 

Simulation definitions are used to trigger simulation of a simulation 
RBD or fault tree from within an event analysis flowchart, allowing 
you to use one or more results from the simulation in the 
flowchart. These resources are used only in event analysis flowcharts 
(if supported by your license). 

BlockSim 

Event analysis tables store arrays of values in rows and 
columns. These resources are used only in event analysis flowcharts 
(if supported by your license). 

BlockSim 

http://help.reliasoft.com/blocksim20/index.htm#t=switches.htm
http://help.reliasoft.com/blocksim20/index.htm#t=maintenance_templates.htm
http://help.reliasoft.com/blocksim20/index.htm#t=flow_groups.htm
http://help.reliasoft.com/blocksim20/index.htm#t=event_analysis_functions_and_static_functions.htm
http://help.reliasoft.com/blocksim20/index.htm#t=event_analysis_functions_and_static_functions.htm
http://help.reliasoft.com/blocksim20/index.htm#t=simulation_definitions.htm
http://help.reliasoft.com/blocksim20/index.htm#t=event_analysis_tables.htm
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Local, Global and Reference Resources 
There are three types of resources:   

  Local resources can be used only within the project in which they were created, and are 
therefore available only to users with permissions within that project. 

  Reference resources (which are resources created in a reference project) can be used in 
any project throughout the database. However, in a secure database, they can be created and 
edited only by users who have the "Create/edit/delete local resources" permission within the 
reference project. These resources can be selected by any user who has at least the "Read" 
permission in the reference project. Users without permissions in the reference project can see 
the reference resources wherever they are used, but they will not be able to select or modify 
them. 

  Global resources can be used in any project throughout the database. In a secure 
database, they can only be created and edited by users who have the “Create/edit/delete 
global resources” permission. However, they can be selected by any database user. 

To make a resource global, select it in the Resource Manager and choose Home > Actions > 
Make Global. 

 

Making a resource global cannot be undone and this option is not available for all resource 
types. If you make a resource global, any resources assigned to it will become global as well 
(e.g., if a URD has an assigned model, making that URD global will also make the model global, 
regardless of whether it was originally local or reference). 

PARENT/CHILD RESOURCE RELATIONSHIPS 

Certain resources can have other resources assigned to them (e.g., URDs can have models and 
tasks assigned to them, tasks can have models, crews and spare part pools assigned to them, 
etc.). This can be considered a "parent/child" relationship. 

When you create a resource from within its parent, the child resource will be of the same type 
as its parent. For example, if you are working with a global URD and you add a model to it, the 
model will be global. If you are working with a reference task and you add a crew to it, the crew 
will be added to the reference project that contains the task. 

When you assign existing resources to a parent resource, the following rules apply: 
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• Any resource assigned to a reference resource must be either a reference resource within 
the same project or a global resource (e.g., a local model cannot be assigned to a reference 
URD, nor can a model in "Reference Project 2" be assigned to a URD in "Reference Project 
1"). 

• Any resource assigned to a global resource must be either a reference resource or a global 
resource (e.g., a local model cannot be assigned to a global URD). 

KEEPING RESOURCES TOGETHER 

The application will automatically keep copies of a project's resources and linked FMEAs when 
the project is restored, checked out, imported or exported. 

• When you create a restore point, any reference resources, global resources or linked 
FMEAs used in the project are converted to local resources/FMEAs and stored with the 
backup. 

• When you check out a project for local editing, any reference resources, global resources or 
linked FMEAs used in the project are converted to local resources/FMEAs and stored with 
the project. 

• When importing/exporting a project item that uses reference resources, global resources 
or linked FMEAs: 

• If you import/export within the same database, the references will remain unchanged. 

• If you import/export between databases, the destination project will contain local 
copies of the original resources/FMEAs. 

• When importing/exporting a project: 

• If you import/export a project that uses global resources, the destination project will 
contain local copies of the original resources. 

• If you import/export a project that uses reference resources or linked FMEAs: 

• The references/FMEAs will be maintained if you also import/export the reference 
project at the same time. 

• If you don’t import/export the reference project at the same time, the new project 
will instead contain copies of the original resources/FMEAs. 
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Creating and Selecting Resources 
This topic describes how to use resource wizards to create and edit resources while you’re 
performing an analysis or creating a URD. In addition, you may also need to: 

• Use the Resource Manager to see all of the resources that are available to use in the 
current project. In addition to creating and editing resources, the manager also allows you 
to: 

• Delete resources that are no longer needed. 

• Create global resources that are available to all projects in the database.   

• Publish a model that is linked to an existing analysis. 

(In a secure database, the ability to create, edit and delete resources is available only if the user 
a) is the project owner, b) has the applicable "resources" permissions, or c) has the applicable 
"manage all projects" permissions.) 

OPENING A RESOURCE WIZARD 

Throughout all ReliaSoft desktop applications, the availability of a resource wizard is usually 
indicated by an ellipsis (...) or an arrow in the resource field. Simply click twice in the field to 
open the wizard. 
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Tip: If a resource is already assigned in the field, you can edit it directly without opening the 
wizard by clicking the Edit icon that appears in the field. 

BACK ARROW AND MAIN PAGE 

Each wizard contains multiple pages with different options on each page. If the option you need 
is not immediately visible, you can click the Back arrow to see the Main page, which shows all 
the options that are applicable for the current situation.   

 

As an example, the following pictures show some of the different options that will be available 
on the Main page for specific situations and resource types. 
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If a model hasn't been 
defined... 

 

If a task hasn't been 
defined... 

 

If a task has already been 
defined... 

 

SELECTING AN EXISTING RESOURCE 

The Select page of the wizard displays a list of existing resources that meet the criteria specified 
on the Settings page. You can then further limit the list by typing inside the text box. 

  

As an example, the following pictures show a situation in which the settings are configured to 
display up to 2,000 models (more resources take longer to load) from the current project only 
(called local resources), and the user has selected to see only the ones in which the name 
includes “bulb.” 
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In addition, for model resources only, you must specify whether you want to display the model 
parameters in the list (which also takes longer to load). 

To change the initial criteria for the list, click the Back arrow and then click the Settings button 
on the main page. 

 

Alternatively, if you need more information about the available resources and/or a wider range 
of filtering tools, you can click the icon to open the Select Resource window. 

 

CREATING A RESOURCE 

In most wizards, you can click the Create New button or icon to create a new resource. 

 

In the model wizard, click the button or icon for the type of model you want to create: 

  New Constant 

  New Distribution 

  New Dynamic 
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  New Profile (available only when creating a cost or duration model for use in a spare 
part pool) 

EDITING A RESOURCE 

If a resource has already been assigned, you can view and/or edit its properties by clicking the 
View/Edit button or icon in the field or in the wizard. 

 

Any changes you make will apply everywhere that the resource is used. This includes analyses 
in other ReliaSoft applications. 

REMOVING A RESOURCE 

If a resource has already been assigned, you can remove it from this location by clicking the 
Remove button or icon. 

 

The resource will remain in the database for use in other locations. If you want to completely 
remove a resource from the database, you’ll need to use the Resource Manager or Select 
Resource window. 

Universal Reliability Definitions (URDs) 
A universal reliability definition (URD) describes a set of reliability and maintenance 
characteristics for a particular component/assembly. Like any other resource, you can create or 
edit URDs while you're performing a relevant analysis, and from the Resource Manager. 

Note: Depending on where you are using a URD, only those properties that are relevant are 
applied. For example, if you apply a URD to a block in an analytical diagram in BlockSim, only 
the failure model associated with the URD will be applied to the block. 

For a new resource, a name will be proposed automatically based on the default naming criteria 
established for the current database (see Default Name Formats window). You can replace this 
with your own name, if desired. Remember that the name and identifiers are the primary way 
in which your team will be able to find the resources you need for your analyses. 

When editing the URD's properties, you can choose or create: 
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• A model to describe the behavior associated with the URD. This can be a reliability model, a 
probability of failure model or an event occurrence model. 

• A corrective task that describes the maintenance action taken to restore a failed 
component to operational status. 

• Zero, one or many scheduled tasks that describe the preventive maintenance, inspections 
and/or on condition maintenance tasks. The order in which the tasks are displayed reflects 
the priority with which tasks that are scheduled in the same way (see Task Scheduling) will 
be performed; for example, if there are two tasks scheduled based on interval and they 
conflict, the task higher in the priority list will be performed and the lower priority task will 
be disregarded. You can use the up and down arrows in the cells in this column to move the 
tasks up and down the priority list. 

Additionally, the following are shown: 

• Identifiers contains additional identifying information that can be used to search for this 
resource. 

• History provides information about when the record was created and last updated. If the 
history log has been activated at the project level, you can click the View Item History icon 
to open the Record History Log for the record. 

 

• Watch allows each individual user to subscribe to receive an alert (via e-mail, SMS text 
message or portal message) when the resource is changed. 

TRACE USAGE 

For existing resources, the link at the bottom of the window indicates how many times the 
resource is currently being used. If you need more information, click the link or the icon to open 
the Dependency Viewer. 

 

Models 

In ReliaSoft applications, models can represent probabilities, durations or costs, either fixed or 
time-dependent. They are used by other resources to represent the reliability of a component, 
the duration of a task, the expected cost of a repair and many other characteristics. 
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Like any other resource, you can create or edit models while you’re performing a relevant 
analysis, and from the Resource Manager. In addition, you can publish models that are based 
on an existing analysis (e.g., a life data analysis in Weibull++, a diagram in BlockSim, etc.). 

This topic describes the properties for both types of models. The interface will vary based on 
the particular situation. 

NAMING THE RESOURCE 

For a new resource, a name will be proposed automatically based on the default naming criteria 
established for the current database (see Default Name Formats window). You can replace this 
with your own name, if desired. Remember that the name and identifiers are the primary way 
in which your team will be able to find the resources you need for your analyses. 

ASSOCIATED ANALYSIS 

In published models only, the Associated Analysis area identifies the analysis that the model is 
based on. If the published model reflects the latest analysis results, the status is 
"Synchronized." If the analysis has been modified since the model was last published, the status 
is "Out of Sync." 

Tip: If you have the ability to open the original analysis (i.e., if the required ReliaSoft application 
is activated on your computer and your user account has permissions to access the analysis), 
the Source will be configured as a link and there will also be a Data Source button at the 
bottom of the window. 

MODEL CATEGORY 

The category determines where and how a model can be used. If you are using a resource 
wizard to create a new model, it will be assigned automatically based on what’s relevant for the 
current field. If you are publishing a model or creating it from the Resource Manager, you must 
select the appropriate option. Once a model has been created, you cannot change its category. 

• Reliability, Probability of Failure and Event Occurrence models represent a likelihood of 
occurrence. 

• Duration models represent a length of time. 

• Cost per Unit Time models are used for costs that accrue over time (e.g., the crew charges 
$50 per hour). 

• Cost models are used for costs that don't depend on time (e.g., the part costs $100 or the 
crew charges $50 per service call in addition to their hourly rate). 
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MODEL TYPE 

• A distribution model represents behavior that varies based on factors such as time and/or 
applied stress. For a published model, the inputs and parameters will be specified 
automatically based on the associated analysis. For manually created models, you can: 

• Select a distribution from the drop-down list and then enter the required parameter(s). 

What's Changed? Starting in Version 2020, two new distributions are available for use 
in models: The triangular distribution takes three parameters (lower limit, mode, upper 
limit) defining the shape of the pdf. The uniform distribution takes two parameters 
(lower limit, upper limit) defining the bounds of the pdf. For both distributions: 
 
    - Lower limit >= 0 
    - Upper limit >= 0 
    - Upper limit >= lower limit 
 
For the triangular distribution: 
 
    - Mode >= 0 
    - Mode >= lower limit 
    - Mode <= upper limit 

• Use the Quick Parameter Estimator (QPE) to estimate the parameters of a distribution 
based on what you know about the behavior. 

Tip: A published model includes one additional parameter that is not relevant for manually 
created models. PNZ stands for percent non-zero. A value of 1 indicates that there are no zero 
failure times in the data set (which is the most common scenario in life data analysis). A decimal 
value indicates that the data set does include zero failure times (such as out-of-the-box failures, 
for example). In such cases, the parameters are calculated based on the non-zero failure times, 
and then the PNZ value is used as a multiplier when calculating certain metrics (e.g., reliability, 
unreliability). 

• A constant model represents a fixed probability (e.g., 0.9), duration (e.g., 2 hours) or cost 
(e.g., $10 or $10 per hour). 

• A dynamic model represents a fixed probability, duration or cost, based on a specified 
variable. The variable can then be programmatically varied during simulation in one of two 
ways, thereby changing the value of the model for successive simulation runs. 
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• For event analysis flowcharts, the variable can be varied using the sensitivity 
analysis/multiple analyses features. 

• When simulating a simulation worksheet, the values used by the variable will be 
specified in the worksheet. 

When dynamic models are used outside of these circumstances, they are treated as 
constant models using the defined initial value of the variable. 

• A profile model represents a changing duration or cost over time, based on a specified 
profile. Profile models are available only for the cost and duration model categories. The 
cost or duration of the model will be programatically varied based on an input time 
parameter used in the profile. When creating a profile model, you must specify a time unit; 
this will be used for the profile’s segment times and, if applicable, for the profile’s output 
duration. 
 
Profile models can be used for all direct costs and acquisition times for spare part pools. 
The execution time of the task using the spare part pool will be used as the input time 
parameter for the profile. Profile models are not available for selection anywhere other 
than in the relevant fields within spare part pools. 
 
Note that models that are in use cannot be changed to profile models. 

ADDITIONAL TOOLS 

Additionally, the following are shown: 

• Identifiers contains additional identifying information that can be used to search for this 
resource. 

• History provides information about when the record was created and last updated. If the 
history log has been activated at the project level, you can click the View Item History icon 
to open the Record History Log for the record. 

 

• Trace Usage. For existing resources, the link at the bottom of the window indicates how 
many times the resource is currently being used. If you need more information, click the 
link or the icon to open the Dependency Viewer. 
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PUBLISHING MODELS 

This topic provides general information about how to create and work with published models, 
which are model resources that have been published from and continue to be associated with 
an existing analysis. For information about additional options and requirements in specific 
applications, see: 

• "Publishing Fitted and Analytical Models" in the BlockSim documentation. 

• "Publishing Models from R-DOE Results" in the Weibull++ documentation. 

• "Publishing Models from Analysis Results" in the Weibull++ documentation (for growth 
data folios). 

• "Publishing from Failure Rate Predictions" in the Lambda Predict documentation. 

A ReliaSoft desktop application does not automatically update the published model when 
something changes in the original analysis, but users have the option to republish the model at 
any time. For any other analysis that uses the model, the change will be reflected the next time 
that other analysis is recalculated/resimulated. 

Publishing Tools 

For most ReliaSoft desktop applications, the following model publishing tools are found on the 
Publishing page of the control panel. In Lambda Predict, they are located on the Publishing tab 
of the Properties panel. 

  Publish Model publishes the analysis to a model, making it accessible to all ReliaSoft 
applications. 

• If the analysis has never been published, this will create a new model and you will be 
prompted to specify the name and category. 

• If the analysis has already been published, this will update the existing model and 
change the model's status from "Out of Sync" to "Synchronized." 

  Publish to Existing Model allows you to select an existing model (using the Select 
Resource window) and replace it with an association to the current analysis. 

  Trace Usage opens the Dependency Viewer, which allows you to see where the model 
is used. 

http://help.reliasoft.com/blocksim20/index.htm#t=publishing_fitted_and_analytical_models.htm
http://help.reliasoft.com/weibull20/index.htm#t=publishing_models_from_reliability_doe.htm
http://help.reliasoft.com/weibull20/index.htm#t=publishing_models_from_analysis_results.htm
http://help.reliasoft.com/lp20/index.htm#t=publishing_models_from_failure_rate_predictions.htm
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  View Model displays the properties for the published model. This information will be 
available to any user who is considering whether to use the model in a particular analysis. 

  Remove Association removes the link between the current analysis and the published 
model. The model will continue to be a resource in the database but it can no longer be 
synchronized with the analysis. 

Published Model Summary 

After the model has been published, the summary table in the control panel (or Publishing tab 
in Lambda Predict) will display the model's name, along with the following details: 

• When the Status changes from "Unpublished" to "Published," the label becomes a link that 
opens the model's properties window. 

• Linked? indicates whether the published model has been used. If the model is in use, you 
can click the link in this field to open the Dependency Viewer. 

• Synchronized? displays "Synchronized" if the published model reflects the latest results 
from the associated analysis. If that analysis has been modified since the model was last 
published (e.g., if more data has been added, an analysis setting has changed, etc.), the 
status will display as "Out of Sync." 

• The Created By and Modified By fields display the names of the users who created and last 
updated the model. Click either of the links to see the dates and times. 

Model Basis and Status 

When a model has been published from an existing analysis, its properties window will include 
the following additional information: 

 

• Source is the ReliaSoft analysis that the model was published from. 

• Application is the ReliaSoft application that is required to view/edit the original analysis. 
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• Type is the kind of folio or diagram that the model is based on. For example, this might be a 
life data folio in Weibull++, an analytical diagram in BlockSim, a failure rate prediction in 
Lambda Predict, etc. 

• Status displays "Synchronized" if the published model reflects the latest results from the 
associated analysis. If that analysis has been modified since the model was last published 
(e.g., if more data has been added, an analysis setting has changed, etc.), the status will 
display as "Out of Sync." 

Tip: If you have the ability to view the original analysis (i.e., if the required ReliaSoft application 
is activated on your computer and your user account has permissions to access the analysis), 
the Source will be configured as a link and there will also be a Data Source button at the 
bottom of the window. 

Tasks 

To properly analyze repairable systems, we first need to understand how components in these 
systems are restored (i.e., the maintenance activities that are performed on the components). 
In general, maintenance is defined as any action that restores failed units to an operational 
condition or keeps non-failed units in an operational state. For repairable systems, 
maintenance plays a vital role in the life of a system. It affects the system's overall reliability, 
availability, downtime, cost of operation, etc. 

In ReliaSoft applications, maintenance activities are represented using tasks, which are 
resources that can be shared among analyses and can be managed via the Resource Manager. 
There are two basic kinds of tasks, which comprise four task classes: 

• Corrective tasks are the action(s) taken to restore a failed component to operational status. 
These cannot be scheduled, as the component's exact failure time is not known before it 
happens. 

• Scheduled tasks can be performed on a known schedule, based on time, component 
condition or other factors. These include: 

• Preventive tasks 

• Inspection tasks 

• On condition tasks 

Tasks are assigned to URDs, which are in turn used to represent a set of properties that can be 
applied to standard blocks in RBDs and to events in fault trees. 
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What's Changed? Starting in Version 2019, crews are assigned to tasks as part of teams. This 
allows you to require multiple crews to complete a task (e.g., if a task requires both a mechanic 
and an electrician). 

The Maintenance Task window allows you to create, view and edit all classes of maintenance 
tasks. It can be accessed by clicking the Create New or View/Edit icon in the Task wizard, which 
is accessed from Task fields in properties windows (e.g., the Corrective Maintenance Task field 
in the Universal Reliability Definition window). 

   

It can also be accessed from the Corrective Tasks and Scheduled Tasks pages of the Resource 
Manager by choosing Home > Edit > Add, by selecting a task and choosing Home > Edit > View 
or by double-clicking a task. 

For a new resource, a name will be proposed automatically based on the default naming criteria 
established for the current database (see Default Name Formats window). You can replace this 
with your own name, if desired. Remember that the name and identifiers are the primary way 
in which your team will be able to find the resources you need for your analyses. 

The following options must be configured for all classes of tasks. Configuration options that are 
specific to particular task classes are presented in the corresponding sections. 

• Basic Task Properties 

• Task duration allows you to assign a model, which may represent a fixed time or a 
distribution, to describe the duration of the task. You can choose an existing model or 
create a new one. If no model is assigned, it is assumed that the task has a duration of 
zero (i.e., immediate repair). 

• Teams for task allows you to choose or create one or more teams that can perform the 
task. Each team is made up of one or more crews; all crews assigned to the team are 
considered to be required (i.e., if any one of the crews assigned to a team is 
unavailable, the team is unavailable). You can add, remove or edit the crews assigned 
to any team. You can also remove a team from the task, thereby quickly removing all of 
its crew associations. An empty team is available at the end of the team list, allowing 
you to define a new team. 
 
If multiple teams are assigned to the task and a team is needed, they will be checked 
for availability in the order in which they are displayed in this list. Use the Priority Up 
and Priority Down arrows that appear when you click a team name in the list to move 
it up and down in the list. If a team is needed and all teams are engaged, the team with 
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the shortest wait time (based on the longest wait time of its constituent crews) is 
chosen to perform the task. 
 
If no team is assigned, it is assumed that the work will be done by some undefined 
team that is always available. 

• Restoration These properties allow you to specify the degree to which the block will be 
restored after the performance of the task. In the How much does this task restore the 
item? field, you can specify that the item will be returned to as good as new condition (i.e., 
full repair, equal to a restoration factor of 1), to the same condition it was in when it failed 
(i.e., "as bad as old" or minimal repair, equal to a restoration factor of 0), or you can choose 
Partial restoration. This option provides you with the ability to model maintenance 
involving "used parts" or imperfect maintenance. The Restoration amount field will appear; 
starting in Version 2019, you can specify the amount of restoration achieved by the task by 
entering the value as a decimal from 0 to 1. If you specify anything other than 0 (0%) or 1 
(100%), you will need to specify what the restoration effect applies to (i.e., the restoration 
type). You can select: 

• Only damage accumulated since last repair: Each repair will remove only the damage 
since the last repair (i.e., the nth repair cannot remove the damage incurred before the 
(n-1)th repair). Note that in this context any task is considered a repair and any damage 
that has occurred since the last event (corrective task, preventive task, inspection or on 
condition task) will be reduced. 

• All accumulated damage: Each repair can reduce any damage accumulated up to that 
failure. 

For simulation, the application uses the restoration factor to determine the new age of the 
block after the maintenance action. 

For example, consider an automotive engine that fails after 6 years. If the engine is rebuilt 
and the rebuilding task has a 50% restoration factor: 

• If Only damage accumulated since last repair is selected, the initial rebuild has the 
effect of rejuvenating the engine to a condition as if it were 3 years old. 
 
The engine fails again after 3 years (when it again reaches the effective "age" of 6 
years), but the rebuild this time affects only the age accumulated after the first rebuild. 
Thus the engine has an effective age of 4.5 years after the second rebuild (3 + 3 x (1 - 
0.5) = 4.5). 
 
After the second rebuild, the engine fails again after a period of 1.5 years (when it again 
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reaches the effective age of 6 years) and a third rebuild is required. The effective age of 
the engine after the third rebuild is 5.25 years (4.5 + 1.5 × (1 - 0.5) = 5.25). 

• If All accumulated damage is selected, the initial rebuild has the effect of rejuvenating 
the engine to a condition as if it were 3 years old. 
 
The engine fails again after 3 years (when it again reaches an effective age of 6 years) 
and another rebuild is required. This rebuild also rejuvenates the engine by 50%, thus 
making it effectively 3 years old again. 
 
After the second rebuild, the engine fails again after a period of 3 years (when it again 
reaches the effective age of 6 years) and a third rebuild is required. The effective age of 
the engine after the third rebuild is 3 years. 

Compare the following tables to see how the two options differ. 

Only Damage Accumulated Since Last Repair 

Time Time Since 
Last Repair 

Effective Age 
Before 
Repair 

Effective 
Age After 

Repair 

Start = 0 0 0 0 

6 years 6 6 3 

9 years 3 6 4.5 

10.5 
years 

1.5 6 5.25 

  

All Accumulated Damage 

Time Time Since 
Last Repair 

Effective Age 
Before 
Repair 

Effective 
Age After 

Repair 

Start = 0 0 0 0 

6 years 6 6 3 

9 years 3 6 3 

12 years 3 6 3 



Chapter 19: Resources 

Weibull++ 2020 User's Guide 1261 

 

  

The ReliaWiki resource portal has more information on restoration factors at: 
http://www.reliawiki.org/index.php/Repairable_Systems_Analysis_Through_Simulation. 

What's Changed? In versions prior to 2019, the Restoration amount was specified as a 
percentage rather than a decimal, and was entered either manually or using a slider bar. 

• Additional Costs to Consider allows you to choose or create models to represent costs that 
are always associated with the task. Cost per task uses a cost model, and Downtime rate 
uses a cost per unit time model. If no models are assigned, it is assumed that there are no 
additional costs. 

• Identifiers contains additional identifying information that can be used to search for this 
resource. 

• History provides information about when the record was created and last updated. If the 
history log has been activated at the project level, you can click the View Item History icon 
to open the Record History Log for the record. 

 

• Watch allows each individual user to subscribe to receive an alert (via e-mail, SMS text 
message or portal message) when the resource is changed. 

• Trace Usage. For existing resources, the link at the bottom of the window indicates how 
many times the resource is currently being used. If you need more information, click the 
link or the icon to open the Dependency Viewer. 

 

CORRECTIVE TASKS 

Corrective maintenance consists of the action(s) taken to restore a failed component to 
operational status. Corrective maintenance is performed at unpredictable intervals because a 
component's failure time is not known a priori. 

Corrective tasks: 

• Always bring the block down. 

• May bring the system down. 

http://www.reliawiki.org/index.php/Repairable_Systems_Analysis_Through_Simulation#Imperfect_Repairs
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• Require spare parts. 

In addition to the common task properties, the following options are used to configure 
corrective tasks in the Maintenance Task window: 

• Task Scheduling allows you to specify when the corrective task will be performed. 

• If you choose Upon item failure, the task will be initiated upon failure of the 
component. 

• If you choose When found failed during an inspection, the task will be initiated if the 
component is found to be failed at the next scheduled inspection. This is useful in the 
case of "hidden failures" (i.e., failures that are not apparent until an inspection is 
performed) and in cases where the component is not considered mission critical and 
repair can wait until the next scheduled maintenance. 

• If a preventive task takes place before the next inspection, then preventive 
maintenance (not corrective maintenance) will be performed to restore the block. 
The downtime, etc. will depend on the preventive task properties. 

• If a corrective task is performed upon inspection and an inspection finds the block 
failed, then the total downtime includes the full inspection duration followed by 
the corrective task duration. 

If you have selected to perform a corrective task upon inspection and an inspection or 
preventive task does not occur after the failure, then the block will never be restored. This 
could happen under either of the following circumstances: 

• Neither an inspection nor a preventive task is specified for the block. 
 
and/or 

• The conditions have not been met to perform an inspection or preventive task. 

• Basic Repair Properties > Spare Part Pool allows you to choose or create the spare part 
pool(s) that will be used in performing the task. A spare part pool describes the conditions 
that determine whether a spare part will be available when needed and specifies the time 
and costs associated with obtaining the spare part. If a spare part pool is not assigned, it is 
assumed that unlimited free spares are always immediately available. 
 
Starting in Version 2019, you need to specify a quantity of parts requested from the pool by 
the task. The default value in the Quantity requested by task field is 1. 
 
You can assign multiple spare part pools to a task in Version 2019 and later. In this case, the 
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task is assumed to require all requested parts from all requested pools. In other words, the 
pools are in an AND relationship, not an OR relationship. 
 
For corrective and preventive tasks, the simulation requests a team as soon as a task is 
initiated; however, the team does not begin performing the task unless/until all required 
spare parts are available. 
 
The total time for the task consists of: 

• The time to complete corrective and preventive maintenance (based on the corrective 
task or preventive task properties). 
 
PLUS 

• The longer of the following times: 

• The time to obtain all spare parts (based on the spare part pools). 
 
OR 

• The time to obtain an available crew (based on crew availability) and any logistical 
delay time associated with the crew. 

For example, consider a block that fails at 10 hours (on the system clock). Its corrective task 
will take 5 hours, the time required to obtain all spares will be 48 hours and the team 
consists of a single crew with a logistical delay time of 8 hours. In this case: 

• All spares will arrive by 58 hours (on the system clock). 

• The team will be requested at 10 hours and will arrive at 18 hours (on the system 
clock). 

• The maintenance will be completed at 63 hours (on the system clock). 

• The total time for the corrective maintenance will be 53 hours (48 for the spares plus 5 
for the task). 

• The team's crew will have traveled for 8 hours, waited 40 hours for the spare parts and 
performed the task for 5 hours for a total of 53 hours (including waiting for the spare 
parts). 

If the spare parts are available without delay and all other conditions are the same, then: 
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• The team will be requested at 10 hours and will arrive at 18 hours (on the system 
clock). 

• The maintenance will be completed at 23 hours (on the system clock). 

• The total time for the corrective maintenance will be 13 hours (8 for the team plus 5 for 
the task). 

• The team's crew will have traveled for 8 hours and performed the task for 5 hours, for a 
total of 13 hours. 

• Task Consequences 

• Does this task bring the system down?: By default, corrective tasks will not bring the 
system down unless having the block down brings the system down based on the 
reliability-wise configuration in the diagram. If you answer Yes, the task will bring the 
system down even if the task has a zero duration. This forces the task to be included in 
the count of system downing events, regardless of the task's duration. 

• Does this task bring the item down?: It is assumed that a block will always be down 
when a corrective task is performed, even a task with a zero duration; thus, this option 
cannot be changed. 

PREVENTIVE TASKS 

Preventive maintenance is the practice of repairing or replacing components or subsystems 
before they fail in order to promote continuous system operation or to avoid dangerous or 
inconvenient failures. The schedule for preventive maintenance is based on observation of past 
system behavior, component wearout mechanisms and knowledge of which components are 
vital to continued system operation. In addition, cost is always a factor in the scheduling of 
preventive maintenance. In many circumstances, it is financially more sensible to replace parts 
or components at predetermined intervals rather than to wait for a failure that may result in a 
costly disruption in operations. 

Preventive tasks: 

• Always bring the block down. 

• May bring the system down. 

• Require spare parts. 

There are restrictions on the tasks that can be performed simultaneously on the same block. 
Please refer to Multiple Tasks on the Same Block in the BlockSim documentation. 

http://help.reliasoft.com/blocksim20/index.htm#t=multiple_tasks_on_the_same_block.htm
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In addition to the common task properties, the following options are used to configure 
preventive tasks in the Maintenance Task window: 

• Task Class allows you to specify the kind of maintenance that the task performs: 
preventive, inspection or on condition. The options available in the Maintenance Task 
window will vary depending on your choice in this field. 

• Task Scheduling allows you to specify the circumstances under which the task will be 
performed. (See Task Scheduling.) 

• Basic Task Properties > Spare Part Pool allows you to choose or create the spare part 
pool(s) that will be used in performing the task. A spare part pool describes the conditions 
that determine whether a spare part will be available when needed and specifies the time 
and costs associated with obtaining the spare part. If a spare part pool is not assigned, it is 
assumed that unlimited free spares are always immediately available. 
 
Starting in Version 2019, you need to specify a quantity of parts requested from the pool by 
the task. The default value in the Quantity requested by task field is 1. 
 
You can assign multiple spare part pools to a task in Version 2019 and later. In this case, the 
task is assumed to require all requested parts from all requested pools. In other words, the 
pools are in an AND relationship, not an OR relationship. 
 
For corrective and preventive tasks, the simulation requests a team as soon as a task is 
initiated; however, the team does not begin performing the task unless/until all required 
spare parts are available. For a complete explanation of how this affects the total time for 
the task, see Corrective Tasks. 

• Task Consequences 

• Does this task bring the system down?: By default, preventive tasks will not bring the 
system down unless having the block down brings the system down based on the 
reliability-wise configuration in the diagram. If you answer Yes, the task will bring the 
system down, even if the task has a zero duration. This forces the task to be included in 
the count of system downing events, regardless of the task's duration. 

• Does this task bring the item down?: It is assumed that a block will always be down 
when a preventive task is performed, even a task with a zero duration; thus, this option 
cannot be changed. 

• If bringing the item down causes the system to go down, do you still perform the 
task?: If you answer Yes, the task will be performed even if doing so brings the system 
down, either because the task itself brings the system down or because the task brings 
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the block down and the block being down causes the system to go down. If you answer 
No and the task brings the system down, the task will never be performed during 
simulation unless the system is already down for another reason. For instance, a 
preventive task that is specified to be performed upon system down will be performed 
even if it brings the system down regardless of your answer here. This is because the 
system is already down, which is what triggered the task in the first place. 
 
A preventive task that does not bring the system down at the preventive maintenance 
time will still be factored into the simulation even if its duration will bring the system 
down at a later time. 
 
For a preventive task that is scheduled to occur based on item age and for which you 
have answered No to this question, if the task is going to bring the system down, then 
it will not take place. If, however, the block reaches the age again (after restoration by 
a corrective action, inspection or another type of preventive maintenance) and this 
time it will not bring the system down, then it will be performed. 

• Perform this task even if the item failed before this task was scheduled to occur?: If 
you answer Yes, the task will be performed even if the item has already failed. This 
option is available only for the following tasks: 

• Preventive tasks and inspection tasks (including the inspection portion of on 
condition tasks) that are scheduled based on item age. In this case, the item's 
"clock" is not stopped upon failure, and the item's "virtual age" is used to trigger 
the task. 

• Inspection tasks (including the inspection portion of on condition tasks) that are 
scheduled upon system down or events in a maintenance group. 

• The inspection portion of on condition tasks scheduled based on calendar age. 

Note that this setting is not relevant when a task is scheduled to be performed as part 
of a maintenance phase in a phase diagram; all such tasks are performed regardless of 
whether the item has failed. 

• RCM properties are text-based properties that are used to keep track of details that may be 
helpful in reliability centered maintenance analysis, but are not used in 
reliability/maintainability simulations. These properties are shown only if they are enabled 
for the project via the interface style settings in RCM++/RBI. 

• Status: The status of the task (choose from a drop-down list). This setting could be used 
if you want to keep track of all tasks that have been considered, regardless of whether 
they end up in the actual maintenance plan (e.g., recommended, rejected, assigned). 
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• Proposed Interval: The interval that was initially proposed for the task. This may be 
different from the interval that is actually assigned to the task. For example, you may 
wish to use this property if the team originally suggests a particular interval for the task 
(perhaps the calculated optimum interval) but then decides to assign a different 
interval (perhaps an interval that is more convenient for packaging a group of tasks). 

• Reference Document: A reference to another document that provides more detailed 
information about the task (e.g., procedure instructions). 

• Condition: A description of the condition that indicates that a failure will occur (e.g., a 
threshold for a measurement of wear, vibration, etc). Typically, this field is used for on 
condition maintenance tasks. 

• Zone: The zone of the system in which the task will be performed. Typically, this field is 
used for aircraft MSG-3 analyses. 

• Access: The access that will be required in order to perform the task. Typically, this field 
is used for aircraft MSG-3 analyses. 

Note: A preventive task with a restoration factor of 0 will generate a new failure with the 
current age. 

INSPECTION TASKS 

Inspections are used in order to uncover hidden failures (also called "dormant failures"); they 
are also used as part of on condition tasks to detect impending failures so that preventive 
maintenance can be performed. 

In general, no maintenance action is performed on the component during an inspection unless 
the component is found failed, in which case a corrective maintenance action is initiated. 
However, there might be cases where a partial restoration of the inspected item would be 
performed during an inspection. For example, when checking the motor oil in a car between 
scheduled oil changes, one might occasionally add some oil in order to keep it at a constant 
level. This sort of restoration is not considered to be preventive maintenance; the deciding 
factor is that inspection tasks do not use spare parts. Note that an inspection task that triggers 
a corrective task will not restore the failed block. Only the corrective task will restore the block. 

Inspection tasks (including the inspection and associated minor work): 

• May bring the block down. 

• May bring the system down; if the task brings the system down, it also brings the block 
down. 
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• Do not use spare parts. 

In addition to the common task properties, the following options are used to configure 
inspection tasks in the Maintenance Task window: 

• Task Class allows you to specify the kind of maintenance that the task performs: 
preventive, inspection or on condition. The options available in the Maintenance Task 
window will vary depending on your choice in this field. 

• Task Scheduling allows you to specify the circumstances under which the task will be 
performed. (See Task Scheduling.) 

• Task Consequences: An inspection task will not bring the block down unless one of the 
following options is selected. 

• Does this task bring the system down?: If you answer Yes, when the task is performed, 
the system will be down, even if the task has a zero duration. If not selected, the task 
will bring the system down only if it brings the block down and having the block down 
brings the system down based on the reliability-wise configuration in the diagram. If 
this option is selected, even tasks with a zero duration will bring the system down. This 
forces the task to be included in the count of system downing events, regardless of the 
task's duration. 

• Does this task bring the item down?: If you answer Yes, when the task is performed, 
the block will be down. Even tasks with a zero duration will bring the block down in this 
case. 

• Perform this task even if the item failed before this task was scheduled to occur?: If 
you answer Yes, the task will be performed even if the item has already failed. This 
option is available only for the following tasks: 

• Preventive tasks and inspection tasks (including the inspection portion of on 
condition tasks) that are scheduled based on item age. In this case, the item's 
"clock" is not stopped upon failure, and the item's "virtual age" is used to trigger 
the task. 

• Inspection tasks (including the inspection portion of on condition tasks) that are 
scheduled upon system down or events in a maintenance group. 

• The inspection portion of on condition tasks scheduled based on calendar age. 

Note that this setting is not relevant when a task is scheduled to be performed as part 
of a maintenance phase in a phase diagram; all such tasks are performed regardless of 
whether the item has failed. 
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• RCM properties are text-based properties that are used to keep track of details that may be 
helpful in reliability centered maintenance analysis, but are not used in 
reliability/maintainability simulations. These properties are shown only if they are enabled 
for the project via the interface style settings in RCM++/RBI. 

• Status: The status of the task (choose from a drop-down list). This setting could be used 
if you want to keep track of all tasks that have been considered, regardless of whether 
they end up in the actual maintenance plan (e.g., recommended, rejected, assigned). 

• Proposed Interval: The interval that was initially proposed for the task. This may be 
different from the interval that is actually assigned to the task. For example, you may 
wish to use this property if the team originally suggests a particular interval for the task 
(perhaps the calculated optimum interval) but then decides to assign a different 
interval (perhaps an interval that is more convenient for packaging a group of tasks). 

• Reference Document: A reference to another document that provides more detailed 
information about the task (e.g., procedure instructions). 

• Condition: A description of the condition that indicates that a failure will occur (e.g., a 
threshold for a measurement of wear, vibration, etc). Typically, this field is used for on 
condition maintenance tasks. 

• Zone: The zone of the system in which the task will be performed. Typically, this field is 
used for aircraft MSG-3 analyses. 

• Access: The access that will be required in order to perform the task. Typically, this field 
is used for aircraft MSG-3 analyses 

To understand how inspections work during simulation, you should be aware of the following: 

• Multiple non-downing inspections cannot occur on the same block at the same time. 

• A non-downing inspection with a restoration factor greater than 0 restores the block based 
on the age of the block at the beginning of the inspection (i.e., the task duration is not 
restored). 

ON CONDITION TASKS 

On condition maintenance relies on the capability to detect failures before they happen so that 
preventive maintenance can be initiated. If, during an inspection, maintenance personnel can 
find evidence that the equipment is approaching the end of its life, then it may be possible to 
delay the failure, prevent it from happening or replace the equipment at the earliest 
convenience rather then allowing the failure to occur and possibly cause severe consequences. 
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In BlockSim, on condition tasks consist of an inspection task that triggers a preventive task 
when an impending failure is detected during inspection. 

For on condition tasks, the Inspection properties allow you to configure the inspection portion 
of the task, and the options are identical to those available for configuring inspection tasks. The 
On Condition Task (Upon Detection) properties allow you to configure the preventive portion of 
the task. The options are the same as those available for configuring preventive tasks, except 
that the Task Scheduling properties are not available. Instead, Failure Detection properties are 
used to specify the "warning period" that spans from the time when a potential failure can first 
be detected to the time when the failure occurs. 

To define the Failure Detection properties, first specify when the task is likely to detect an 
imminent failure. If you choose When a certain percentage of the life of the item has been 
consumed, you must then specify the percentage of the item's life that must have elapsed in 
order for approaching failure to be detected. This is called the failure detection threshold (FDT). 
For example, if the FDT is 0.9 and the item will fail at 1,000 days, the approaching failure can 
begin to be detected at 900 days. If you choose Within a fixed time frame prior to failure, you 
must then specify the amount of time before a failure when the approaching failure can be 
detected by inspection. This is called the P-F interval. For example, if the P-F interval is 200 days 
and the item will fail at 1,000 days, the approaching failure can begin to be detected at 800 
days. 

On condition tasks can be set to perform the preventive portion of the task even if the item 
failed before the approaching failure could be detected. If the inspection portion of the task is 
scheduled based on item age, you can answer Yes to the Perform this task even if the item 
failed before this task was scheduled to occur? option. (For more about this option, see 
Inspection Tasks.) 

Note the following simulation assumptions regarding on condition tasks: 

• An inspection that finds a block at or beyond the failure detection threshold or within the 
range of the P-F interval will trigger the associated preventive task as long as preventive 
maintenance can be performed on that block. 

• If a non-downing inspection triggers a preventive maintenance action because the failure 
detection threshold or P-F interval range was reached, no other maintenance task will be 
performed between the inspection and the triggered preventive task; tasks that would 
otherwise have happened at that time due to system age, system down or group 
maintenance will be ignored. 

• A preventive task that would have been triggered by a non-downing inspection will not 
happen if the block fails during the inspection, as corrective maintenance will take place 
instead. 
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• If a failure will occur within the failure detection threshold or P-F interval set for the 
inspection, but the preventive task is only supposed to be performed when the system is 
down, the simulation waits until the requirements of the preventive task are met to 
perform the preventive maintenance. 

• If the on condition inspection triggers the preventive maintenance part of the task, the 
simulation assumes that the maintenance team will forego any routine servicing associated 
with the inspection part of the task. In other words, the restoration will come from the 
preventive maintenance, so any restoration factor defined for the inspection will be 
ignored in these circumstances. 

TASK SCHEDULING 

The following information applies to the task scheduling properties for preventive tasks, 
inspection tasks and the inspection portion of on condition tasks. 

Click the arrow in the When is this task performed? field to define the criteria for performing 
the task. The remaining fields in the task scheduling properties will depend on your selection in 
this field. The task can be performed: 

• At certain intervals. If you select this option, you must then specify: 

• Whether the interval is fixed or dynamic. 

• Whether the interval is based on the item's age (taking duty cycle into account) or on 
calendar time. 

• Upon certain events. If you select this option, you can choose for the task to be performed: 

• Whenever the system is down for any reason. No further task scheduling properties are 
required for this option. 

• Based on events in a maintenance group. The task will be performed when user-
specified events occur for either some or all blocks in one or more user-specified 
maintenance groups. The item that the task is assigned to does not need to be part of 
the selected maintenance group(s). 

• When a maintenance phase in a phase diagram starts. Please note that if the task is 
selected to be performed only at the start of a maintenance phase and the item that 
the task is associated with is not included in the maintenance phase's associated 
maintenance template, the task will never be performed. No further task scheduling 
properties are required for this option. 
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• Based on events in a flow group (see Flow Groups in the BlockSim documentation). This 
setting is appropriate only for tasks used in process flow simulation diagrams. The task 
will be performed when flow either reaches/exceeds its threshold or drops to or below 
its threshold in one or more user-specified flow groups. The block(s)/item(s) affected 
by the task may or may not belong to any of the flow groups. 

The remaining task scheduling properties for each type of schedule are given next. For any 
interval that you specify, you will be asked to specify the units used. 

• Fixed interval based on either item age or calendar time: Enter the interval when the task 
will be performed (e.g., if you enter 100, the task will be scheduled for 100, 200, 300, etc.). 

• Item age refers to the accumulated age of the block, which gets adjusted each time the 
block is repaired (i.e., restored). If the block is repaired at least once during the 
simulation, this will be different from the elapsed simulation time. For example, if the 
restoration factor is 1 (i.e., "as good as new") and the assigned interval is 100 days 
based on item age, then the task will be scheduled to be performed for the first time at 
100 days of elapsed simulation time. However, if the block fails at 85 days and it takes 5 
days to complete the repair, then the block will be fully restored at 90 days and its 
accumulated age will be reset to 0 at that point. Therefore, if another failure does not 
occur in the meantime, the task will be performed for the first time 100 days later at 
190 days of elapsed simulation time. 

 

• Calendar time refers to the elapsed simulation time. If the assigned interval is 100 days 
based on calendar time, then the task will be performed for the first time at 100 days of 
elapsed simulation time, for the second time at 200 days of elapsed simulation time 
and so on, regardless of whether the block fails and gets repaired correctively between 
those times. 

 

If the task is performed at fixed intervals, you can select the Override task scheduling 
properties with a task package option to assign the task to a task package, which is a group 
of tasks that are performed together at scheduled intervals. (Note that if a task has been 
assigned to a task package, the task scheduling properties will be disabled and displayed in 
italics.) 

http://help.reliasoft.com/blocksim20/index.htm#t=flow_groups.htm


Chapter 19: Resources 

Weibull++ 2020 User's Guide 1273 

 

• Dynamic interval based on either item age or calendar time: The task will be performed at 
variable user-specified intervals. This can be used, for example, to schedule maintenance to 
be performed with increasing frequency as an item gets older. The Dynamic intervals field 
shows the number of intervals specified. Click the button (...) to open the Intervals window, 
which allows you to enter the item age intervals when the task will be performed. The 
intervals are the actual time between maintenance (i.e., they are not cumulative). Note 
that the last value entered in the Intervals window will repeat, if necessary, until the end of 
the simulation time. 

• Based on events in a maintenance group: Specify the events that can trigger the task (i.e., 
a block fails; a corrective, preventive or inspection task starts; a block is restored to 
operation), and choose the maintenance group(s) in which the event(s) must occur in order 
to trigger the task. 

• Based on events in a flow group: Specify the events that can trigger the task (i.e., flow rate 
through any connector exceeds or drops below a certain level), and choose the flow 
group(s) in which the event(s) must occur in order to trigger the task. 

Note: For preventive and inspection tasks that are scheduled based on item age, the Perform 
this task even if the item failed before this task was scheduled to occur? property determines 
whether actual age or "virtual age" is considered. If you answer Yes, the task will be performed 
even if the item has already failed. In other words, the item's "clock" is not stopped upon 
failure, and the item's virtual age is used to trigger the task. (For more about this option, see 
Preventive Tasks.) 

Crews 
Crews are resources that can be shared among analyses and can be managed via the Resource 
Manager. You can assign the crews to maintenance tasks. Starting in Version 2019, crews are 
assigned to maintenance tasks as part of teams. This allows you to require multiple crews to 
complete a task (e.g., if a task requires both a mechanic and an electrician). A team can also 
consist of a single crew. 

The Crew window allows you to create, view and edit crews. It can be accessed by clicking the 
Create New or View/Edit icon in the Crew wizard, which is accessed from Crew fields in 
properties windows (e.g., under Teams for task in the Maintenance Task window). 

   

It can also be accessed from the Crews page of the Resource Manager by choosing Home > Edit 
> Add, by selecting a crew and choosing Home > Edit > View or by double-clicking a crew. 
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For a new resource, a name will be proposed automatically based on the default naming criteria 
established for the current database (see Default Name Formats window). You can replace this 
with your own name, if desired. Remember that the name and identifiers are the primary way 
in which your team will be able to find the resources you need for your analyses. 

The following settings are available to configure the crew: 

• Crew 

• Direct cost allows you to choose or create a model to represent the direct cost per unit 
time to engage the crew (e.g., the hourly charge for the time that the crew spends 
performing the task). This field uses a cost per unit time model. If no model is assigned, 
it is assumed that there is no cost. 

• Cost per incident allows you to choose or create a model to represent the cost per 
incident to engage the crew (e.g., if you have to pay a fixed fee instead of or in addition 
to the hourly rate). This field uses a cost model. If no model is assigned, it is assumed 
that there is no cost. 

• Is there a limit to the number of tasks this crew can perform at the same time?: If you 
answer Yes, you must specify the limit in the Number of tasks field. For example, if the 
crew can only fix 3 components at any given time and 4 components fail at the same 
time, then the crew will not be able to fix the fourth component until one of the other 
components has been restored. 

• Logistic Delay allows you to choose or create a model to describe the delay time before 
the crew can start the task. If no model is assigned, it is assumed that the crew can 
start the task immediately without any delays (i.e., immediate repair). The team with 
the highest priority is always called upon first, regardless of logistic wait times for the 
team's crews. If a team is needed and all teams are engaged, the team with the 
shortest wait time (based on the longest wait time of its constituent crews) is chosen to 
perform the task. 

For a given simulation, a crew's logistic time is constant across that one simulation for 
the task. It is taken randomly from its distribution or from its fixed time. 

For on condition tasks, if the same crew performs the inspection and preventive 
maintenance and there are logistic delays associated with the crew, the logistic delays 
will be factored into the simulation for both parts of the task. 

• If Include logistic delay in cost is selected, then the time spent waiting for the crew 
(including logistic delay and any delay incurred due to limits on the number of tasks the 



Chapter 19: Resources 

Weibull++ 2020 User's Guide 1275 

 

crew can perform simultaneously) will be included when calculating crew costs, based 
on the direct cost specified for the crew. 

• If Include part delay in cost is selected, then the time spent by the crew waiting for 
spare parts will be included when calculating crew costs, based on the direct cost 
specified for the crew. 

• Identifiers contains additional identifying information that can be used to search for 
this resource. 

• History provides information about when the record was created and last updated. If 
the history log has been activated at the project level, you can click the View Item 
History icon to open the Record History Log for the record. 

 

• Watch allows each individual user to subscribe to receive an alert (via e-mail, SMS text 
message or portal message) when the resource is changed. 

• Trace Usage. For existing resources, the link at the bottom of the window indicates 
how many times the resource is currently being used. If you need more information, 
click the link or the icon to open the Dependency Viewer. 

 

Spare Part Pools 
Spare part pools are resources that can be shared among analyses and can be managed via the 
Resource Manager. A spare part pool describes the conditions that determine whether a spare 
part will be available when needed and specifies the time and costs associated with obtaining 
the spare part. You can assign the pools to maintenance tasks. 

What's Changed? Starting in Version 2019, tasks can request multiple spare parts from a pool. 
All requested parts must be delivered before the task can be performed. 
 
In addition, multiple spare part pools can be assigned to tasks. In this case, the task is assumed 
to require all requested parts from all requested pools. 

The Spare Part Pool window allows you to create, view and edit spare part pools. It can be 
accessed by clicking the Create New or View/Edit icon in the Spare Part Pool wizard, which is 
accessed from Spare Part Pool fields in properties windows (e.g., in the Maintenance Task 
window). 
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It can also be accessed from the Spare Part Pools page of the Resource Manager by choosing 
Home > Edit > Add, by selecting a spare part pool and choosing Home > Edit > View or by 
double-clicking a spare part pool. 

For a new resource, a name will be proposed automatically based on the default naming criteria 
established for the current database (see Default Name Formats window). You can replace this 
with your own name, if desired. Remember that the name and identifiers are the primary way 
in which your team will be able to find the resources you need for your analyses. 

The following settings are available to configure the spare part pool: 

Tip: In Version 2019 and later, profile models  can be used to define any acquisition time and 
non-holding costs. This new model type allows you to model changes in cost and duration over 
time. You can also still use all other model types for these fields. 

• Spares 

• Direct cost per dispensed item allows you to specify the direct cost of each spare part 
in the pool. 

• Spare acquisition type: You can select Unlimited spares to indicate that an unlimited 
number of spare parts exist in the pool (i.e., if a spare part is required, it will always be 
available). If you select Limited number of spares, the Pool Restock properties and the 
Emergency Spare Provisions properties will become available. In addition, you will need 
to define the following properties: 

• Initial stock level is the number of spare parts in the pool at the start of simulation. 

• Holding Cost ($/Hour in pool) allows you to choose or create a model to represent 
the cost of holding a spare part in the pool. The unit used is the default unit for the 
database. This field uses a cost per unit time model. If no model is assigned, it is 
assumed that there is no cost. (To determine which unit is defined as the default, 
choose File > Manage Database > Unit Settings. The default unit is the one that is 
selected in the Use as Default column.) 

• If you select the Pool has maximum capacity check box, you will need to specify 
the maximum number of items that can exist in the spare part pool at any given 
time. The restock options will add parts only up to this maximum capacity. For 
example, suppose that the maximum capacity is 20 units and the restock quantity 
is 5 units. If the current stock level is 18 when a restock is triggered (either on a 



Chapter 19: Resources 

Weibull++ 2020 User's Guide 1277 

 

scheduled interval or because the stock fell to a specified level), then only 2 units 
will be added to the spare part pool, even though the restock options call for the 
addition of 5 units at each restock. 

If you select Fixed probability of stockout, the Emergency Spare Provisions properties 
will become available. In addition, you will need to enter the probability of running out 
of stock as a decimal value. 

• Logistic Time for Spare Acquisition allows you to choose or create a model to describe 
the amount of time required to obtain the part when it is required for maintenance, 
assuming that the part is in stock. This field uses a duration model. If no model is 
assigned, it is assumed that the spare part is available for use immediately. 

• The Pool Restock properties allow you to define how the spare part pool will be restocked. 
These properties are available only if you have selected the Limited number of spares 
option in the Spare acquisition type field. You can select either or both of the following 
restock schemes: 

• If the Scheduled restock option is selected, the pool will be restocked at fixed intervals. 
The following properties will be available: 

• Restock every allows you to specify the time interval at which the pool will be 
restocked. 

• Number added per restock allows you to specify the number of parts that are 
added to the pool at every scheduled interval. 

• If the Restock as needed option is selected, the pool will be restocked when the stock 
drops to a specified quantity. This option is available only if the initial stock level 
entered is at least 1. The following properties will be available: 

• Restock when stock drops to allows you to specify the number of parts in the pool 
that will trigger the restock (e.g., when the stock drops to 5, order more parts). 

• Number added per restock allows you to specify the number of parts that are 
added to the pool when the restock condition has been met. 

• Required time for stock arrival allows you to choose or create a model to describe 
the amount of time required for the new parts to arrive after the restock has been 
initiated. This field uses a duration model. If no model is assigned, it is assumed 
that the parts arrive immediately. 

• Off-site spare part pool allows you to assign an off-site spare part pool to the 
current pool. If specified, this pool is considered to be the source for restocking the 
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current pool, which allows you to describe properties for the next level of spare 
parts that can be accessed when needed. If no off-site spares pool is specified, the 
parts are assumed to be ordered and no properties are described for the source. 

Tip: Circular references between spare part pools are not permitted. In other 
words, if Pool 1 calls Pool 2 as its off-site spare part pool, and Pool 2 calls Pool 1 as 
its off-site spare part pool, BlockSim will display a message notifying you of the 
problem upon simulation. 

• The Emergency Spare Provisions properties allow you to define the circumstances when 
the spare part pool is empty but a spare part is required for a task. These properties are 
available only if you have selected either the Limited number of spares option or the Fixed 
probability of stockout option in the Spare acquisition type field. Selecting the Can obtain 
emergency spares if needed option indicates that a spare part can be obtained if required 
and the spare part pool is empty; otherwise, the repair will be delayed until more spare 
parts arrive in the spare part pool. Selecting this option makes the following properties 
available: 

• Number added per emergency allows you to specify the number of parts that are 
added to the pool when an emergency acquisition occurs. 

• Additional costs for emergency spares allows you to choose or create a model to 
represent a per incident cost for emergency acquisition of spares (e.g., there is a $50 
surcharge when emergency spares are required). This field uses a cost model. If no 
model is assigned, it is assumed that there is no cost. 

• Required time for emergency spare allows you to choose or create a model to describe 
the amount of time required for the emergency spare parts to arrive after the 
emergency acquisition has been initiated. This field uses a duration model. If no model 
is assigned, it is assumed that the parts arrive immediately. 

• Off-site spare part pool allows you to assign an emergency off-site spare part pool to 
the current pool. This allows you to create another level of spare parts that can be 
accessed for the emergency acquisition. 

• Identifiers contains additional identifying information that can be used to search for this 
resource. 

• History provides information about when the record was created and last updated. If the 
history log has been activated at the project level, you can click the View Item History icon 
to open the Record History Log for the record. 
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• Watch allows each individual user to subscribe to receive an alert (via e-mail, SMS text 
message or portal message) when the resource is changed. 

• Trace Usage. For existing resources, the link at the bottom of the window indicates how 
many times the resource is currently being used. If you need more information, click the 
link or the icon to open the Dependency Viewer. 

 

Metrics 

A metric is a resource that provides a flexible way to display any numerical value of interest, 
and track how it changes over time. This can be used for tracking and displaying a variety of Key 
Performance Indicators (KPIs) and other values, including: 

• Reliability metrics (e.g., reliability, BX% life, etc.) calculated from a model resource. 

• Any result from a simulated BlockSim diagram. 

• The completion percentage and resource usage for Project Planner gates. 

• The reliability or availability calculated from an FMRA in XFMEA/RCM++/RBI. 

• Any other user-defined value that you wish to display and track. 

Like any other resource, you can create or edit metrics from the Resource Manager, and while 
you’re performing a relevant analysis. (See Showing Metrics in Folios/Diagrams, Using Metrics 
in Project Planner Gates and Pushing Metrics from an FMRA.) 

If your organization chooses to implement an SEP web portal, it's easy to choose specific 
metrics that you want to access quickly from any web-enabled device. 

Note: Metrics are always local resources. They cannot be made global. Metrics in a reference 
project are local to that project and can't be selected for use in other projects. 

METRIC TYPES 

The following pictures demonstrate the four basic options for specifying the value that will be 
displayed and tracked. 
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Calculate from a model resource 

 

Obtain from a BlockSim simulation diagram 

 

Enter any user-defined value 

 

The value is "pushed" from a Project 
Planner gate or FMRA 

 

  

CALCULATED RESULT AND SAVED VALUES 

The Calculated Result field shows the latest calculated value for the metric. This will be 
updated automatically if the associated analysis or model changes, and the latest result will be 
stored in an array of saved values. 

You can then click the View Saved Values icon to view the history of how the metric has 
changed over time. 

 

If you change any of the properties that affect the way the result is calculated, you will be 
prompted to decide whether to clear the array of values that were saved before the change. 
For example: 

• If you change the metric from Reliability to Probability of Failure, or from 1,000 hours to 
500 hours, you will probably want to clear the array so the timeline of saved values is not 
misleading. 
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• Alternatively, if you change the metric’s associated model from prototype1 to prototype2 
to prototype3 at different stages of development, you may wish to keep the saved values 
after each change so the timeline shows the improvement across all three stages. 

In the Metric Results Viewer, you can also choose to clear the entire history or delete only a 
particular saved value. 

The results viewer also allows you to copy the values to the Clipboard so you can paste into 
another application. For example, if the metric stores the calculated reliability at different 
points in time, you may wish to analyze the data with a reliability growth model in a growth 
data folio.    

• Copy > All rows (dates) copies the exact dates shown in the table. 

• Copy > All rows (cumulative days) replaces the dates with the cumulative number of days 
since the date of the last saved value. For example, if the first date is 1/1/2019 and the 
second date is 12/31/2019, the cumulative days would be 0 for the first date and 365 for 
the second date.    

TARGET CONDITIONS AND RESULT INDICATOR 

The Target Conditions feature color-codes the current value of the metric. If all specified 
conditions are met, then the metric's value will be displayed in green. If one or more conditions 
are not met, then it will be in red. For example, in the following pictures, the result is green if 
the estimated system reliability is at least 80%, and red if it is not. 

 

The Result Indicator feature color-codes the indicator that shows whether the value has 
increased or decreased since the prior saved value. If the direction of the change is desirable, 
the indicator will be green; if it is undesirable, the indicator will be red. As an example, the 
following pictures are from the SEP. 
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IDENTIFIERS, HISTORY, WATCH AND TRACE USAGE 

As with most other resources: 

• Identifiers contains additional identifying information that can be used to search for this 
resource. 

• History provides information about when the record was created and last updated. If the 
history log has been activated at the project level, you can click the View Item History icon 
to open the Record History Log for the record. 

 

• Watch allows each individual user to subscribe to receive an alert (via e-mail, SMS text 
message or portal message) when the resource is changed. 

• Trace Usage. For existing resources, the link at the bottom of the window indicates how 
many times the resource is currently being used. If you need more information, click the 
link or the icon to open the Dependency Viewer. 

 

SHOWING METRICS IN FOLIOS/DIAGRAMS 

The Publishing page of the control panel shows all of the metric resources that are associated 
with the current analysis. (The metrics can be created and edited either from the Resource 
Manager or the control panel.) This applies for: 

• Data sheets in Weibull++ that have a published model. 

• Analytical or simulation diagrams in BlockSim that have a published model for the entire 
system (either a fitted model or an analytical model). 

• Simulation diagrams in BlockSim that have simulation results. 

This makes it easy to see the metrics that have been created for each analysis (which may also 
be displayed in relevant Project Planner gates or in the SEP web portal) and to see the history of 
how the analysis results changed over time. It also provides a convenient way to create new 
metrics for the analysis, if desired. 

As an example, the following picture shows a typical scenario for Weibull++. In Weibull++, the 
control panel shows all metrics that are associated with the model published from the current 
data sheet. In BlockSim, it shows all metrics that are associated with a model published from 
the diagram and/or obtained from the diagram’s simulation results. 
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• Double-click a metric to see its properties and history of saved values. 

• A Watch icon will be shown beside any metric for which you have subscribed to receive an 
alert when the resource is changed. 

• Click the Metric Summary icon to see a quick report of all the metrics displayed in the 
current branch. 

• Click the Create New icon to create a new metric. 

 



Chapter 19: Resources 

1284 https://www.reliasoft.com/weibull 

 

Associating Existing Metrics with a Different Data Sheet 

When an analysis changes (e.g., new data, after a design change, etc.), you may choose to 
simply update the existing data sheet and recalculate, or keep the original analysis unchanged 
and perform the updated analysis in a new data sheet. 

If you decided to create a new data sheet, there are two ways to ensure that the metrics will 
reflect the complete history from both analyses: 

Publish to the existing model from the new data sheet 

If you want the published model to reflect the latest analysis results, you can simply transfer 
both the model and the associated metrics to the new data sheet. To do that: 

1. Calculate the new data sheet and then go to the Publishing page of the control panel. 

2. Click Publish to Existing Model and then select the model from the original data sheet. 

 

Change the model for the for the existing metrics 

If you want to keep the original published model associated with the original data sheet, you 
can publish a new model for the new data sheet and then transfer the metrics to the new 
model. To do that: 

1. Publish a new model for the new data sheet. 

2. From either the original data sheet’s control panel or the Resource Manager, open each 
metric that was associated with the original data sheet and change the Associated Model. 
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As a shortcut, you can click the Select Existing icon on the new data sheet's control panel 
and choose one or more existing metrics in the Select Resource window. It is important to 
keep in mind that when you do this, you are changing the associated model for each 
selected metric. 

USING METRICS IN PROJECT PLANNER GATES 

There are two ways to utilize metrics in a Project Planner gate: 

Relevant Metrics 

For any gate in a project plan, you can choose to display up to three metrics that are relevant to 
this stage of the project (e.g., the target reliability, the latest calculated reliability, etc.). 

Use the fields under the Relevant Metrics heading to select an existing metric or create a new 
one. 

 

Push to Metrics 

For any gate in a project plan, you can also choose to push any of the following values to a 
metric resource. This makes it easy to see the history of all saved values, and enables users to 
subscribe to receive alerts when the metric changes. You can also choose to show this 
information in the SEP web portal if it is implemented for the current database. 

• Percent Completed is the percentage of the total duration of dependent actions/gates that 
is complete. For example, if Action 1 (duration = 3 days) is complete and Action 2 (duration 
= 1 day) is incomplete, the progress is 75%. 

• Actual Man Hours % is the percentage of planned hours that have been used to complete 
the gate. 
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• Actual Costs % is the percentage of the budget that has actually been used to complete the 
gate. 

Use the fields under the Push to Metrics heading to create a new metric or select an existing 
metric that is not already assigned to receive a pushed value. (Note that only unused metrics 
are shown in this list.) 

When you first assign a metric in one of these fields, the current value will be automatically 
saved to the metric. Subsequently, the value will be recalculated each time an associated action 
or gate is changed. If the value is found to have changed, it will be saved to the metric. To see 
the current saved value, click inside the field. This will also display a result indicator and the 
View Saved Values icon, which you can click to see a history of all saved values. 

 

PUSHING METRICS FROM AN FMRA 

The Push to Metrics fields on the Properties tab of the Analysis panel in XFMEA/RCM++/RBI 
enable you to "push" the reliability and availability values that were calculated/simulated from 
the Failure Modes and Reliability Analysis (FMRA) to metric resources. 

This makes it easy to see the history of all saved values while you’re working in the FMRA, and 
enables users to subscribe to receive alerts when the metric changes. If desired, you can also 
choose to show this information in a specific Project Planner gate (under the Relevant Metrics 
heading), and in the SEP web portal if it is implemented for the current database. 

1. Go to the FMRA tab in the system panel. (See Enabling and Viewing the FMRA in the 
XFMEA/RCM++/RBI documentation.) 

 

2. Select any item in the FMRA hierarchy and use the fields under the Push to Metrics heading 
to create a new metric or select an existing metric that is not already assigned to receive a 
pushed value. 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=enabling_and_viewing_the_fmra.htm
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3. Calculate and/or simulate the FMRA: 

a. To calculate the reliability, choose FMRA > Calculations > Calculate (Reliability). 

 

b. To simulate the availability, choose FMRA > Calculations > Simulate (Availability). 

 

4. Each time you calculate/simulate the FMRA, the latest value(s) will be automatically saved 
to the metric(s). To see the history of all saved values, click View Saved Values. 

 

Variables 
A variable is a resource that stores a numerical value and allows you to assign a name to that 
value. You can then use the variable name in place of the actual value in the equations that you 
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create. You can also use variables in functions and/or as conditional output values in 
conditional blocks, logic gates and branch gates. 

A variable starts with an assigned initial value, which may be fixed or varied during simulation in 
BlockSim. You can use variables: 

• In event analysis flowcharts, to act as a constant (i.e., maintain a fixed numerical value 
during simulation). 

• In event analysis flowcharts, to temporarily store the output value of a block during 
simulation. See the next section for more information. 

• In event analysis flowcharts, to perform a sensitivity analysis, which involves varying the 
value of one or two variables between runs (i.e., sets of simulations). For example, if you 
are analyzing potential investment strategies, you may wish to vary the number of years 
that you will be investing and/or the percentage of your income that will be invested to see 
how different inputs will affect the final results. 

• As the basis for a dynamic model, which represents a fixed probability, duration or cost. 
The variable can be programmatically varied during simulation, thereby changing the value 
of the model for successive simulation runs. 

• In process flow simulation diagrams, to define a throughput amount. 

• As inputs for certain fields in simulation RBDs via simulation worksheets, allowing 
programmatic variation of the field value during simulation. 

USING VARIABLES TO STORE OUTPUT VALUES IN EVENT ANALYSIS FLOWCHARTS 

You can use variables to hold numerical values passed to them during simulation. In event 
analysis flowcharts, the following blocks are able to store their output values in variables: 

• Standard blocks 

• Result storage blocks 

• Flag markers 

• Counter blocks 

Depending on your choice in the When to Reset field of the variable's properties window, you 
can configure the variable to retain the value passed to it during simulation or reset the variable 
to its initial value at specific times. The options are: 
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• Reset After Each Simulation (i.e., reset after a single pass through the flowchart) 

• Reset After Each Run (i.e., reset after each set of simulations) 

• Reset After Analysis (i.e., reset after each set of runs) 

• Never Reset 

When the simulations end, the variable always returns to its initial starting value unless you 
have selected Never Reset. If you wish to keep the value used during simulation, you can use a 
result storage block to store it. 

Example 

The following example demonstrates two things: a) how a variable may be used to store an 
output value and b) how a variable may be used in an equation. 

In the following configuration, the first block calculates the gross profit from a sale, and then 
stores its output into a variable called "Profit." The conditional block determines whether the 
gross profit exceeds 500. If the output is true, the third block deducts the sale's commission 
from the profit, and overwrites the stored value with the new output. 

 

The following picture shows the properties window of the variable called "Profit." The initial 
value of this variable is set to 0. 
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The following picture shows the Block Properties window of the first block in the example. The 
output of the equation is stored in the variable. 
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The following picture shows the Block Properties window of the third block in the flowchart. 
The equation shows that the commission is deducted from the existing value in the variable, 
and then the variable is overwritten with the new result. At the end of the simulation, the result 
storage block in the flowchart stores the final value of the variable, and then the variable resets 
to 0. 
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Profiles 
A profile is a resource that allows you to represent a value that varies with time. It consists of a 
basic pattern that either repeats as a cycle or occurs once and then continues from its last 
defined setting. 

There are several types of profiles: 

• Stress profiles are used in life-stress data folios. These profiles can be created manually, or 
by importing data from nCode GlyphWorks. For information about how to use stress 
profiles, see Time-Dependent Stress Profiles in the Weibull++ documentation. 

• Throughput profiles are used in process flow simulation (PFS) diagrams (if supported by 
your license). For information about how to use throughput profiles, see Process Flow 
Simulation Diagrams in the BlockSim documentation. 

• Starting in Version 2019, cost profiles and duration profiles are used in profile models, 
which are available for use in spare part pools. 

CREATING PROFILES MANUALLY (ALL TYPES) 

Like any other resource, you can create or edit profiles from the Resource Manager, or while 
you’re performing a relevant analysis. To create a profile: 

http://help.reliasoft.com/weibull20/index.htm#t=time_dependent_stress_profiles.htm
http://help.reliasoft.com/blocksim20/index.htm#t=blocksim_process_flow_simulation_diagrams.htm
http://help.reliasoft.com/blocksim20/index.htm#t=blocksim_process_flow_simulation_diagrams.htm


Chapter 19: Resources 

Weibull++ 2020 User's Guide 1293 

 

1. Specify the type of profile that you are creating. 

2. Define a pattern for how the stress, throughput level, cost or amount of time (i.e., duration) 
will change over a specified period of time. The pattern you will define consists of a series 
of segments, where each segment has a specified duration and a value expressed in one of 
two ways: 

• a constant stress, throughput, cost or duration value, or 

• a function that takes a time value and returns a stress, throughput, cost or duration 
value. 

These segments are defined in the spreadsheet, as shown next. 

 

• Segment Start is calculated automatically by the software and cannot be entered 
manually. The first segment's start time is always 0. For every subsequent segment, the 
start time is identical to the prior segment's end time. 

• Segment End allows you to enter the end time for each segment, which must be 
smaller than the end time of the next segment. 

• Stress S(t), Throughput T(t), Cost C(t) or Duration D(t) is the value or function for the 
segment. If the stress, throughput level, cost or duration will stay constant during a 
segment, enter a constant value (e.g., 30). If the value will change during a segment, 
enter the it as a function of time (e.g., at time = 20, the function t + 20 will return a 
value of 40). When entering a function, you must use t or T as the time variable. 

Tip: Because units are not defined in the profile, it is important to apply stress and 
throughput profiles only to folios or diagrams that are intended to use the same 
stress/throughput and time units. In the Profile window, you may want to use the 
Comments page as a reminder of which units are applicable to that profile. 
 
For cost and duration profiles, the time units are defined within the model where the 
profile is used. This setting applies to the time segments within the profile and, for duration 
profiles, to the duration values. 
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For example, suppose you are creating a stress profile where the stress unit is psi and the 
time unit is seconds. Now suppose you wanted to define the following 120-second pattern: 
a stress value of 30 psi for 60 seconds, followed by a stress value of 50 psi for 30 seconds, 
followed by a stress function that begins at 50 psi and gradually decreases at a rate of 1 psi 
per second for the remainder of the pattern. For this pattern, you could fill out the 
spreadsheet as follows: 

 

Notice that the last segment of this profile uses a function. Since t is the test time (or, if the 
profile is cyclical, the time since the pattern was last restarted), t = 90 when the last 
segment begins. So the last segment’s stress level starts at 50 - (90 - 90) = 50. Then, at 91 
seconds, the stress level will have dropped to 50 - (91 - 90) = 49. After another second it will 
have dropped to 50 - (92 - 90) = 48, and so on. 

Note, too, that the columns have been renamed to reflect the units for the profile. 

3. Next, choose the appropriate option in the After Last Segment area of the control panel. 
Your selection here will determine what happens after the end time of the profile’s last 
segment (in the above example, after time = 120). 

If you select Continue with last value, all times after the last segment will use the 
value/function defined in the last segment. 

If you select Repeat cycle, the entire pattern of segments will be treated as a repeating 
cycle. 

For example, suppose you defined a stress pattern that is made up of five segments, each 
an hour long and increasing stepwise from the segment before. The graphs below illustrate 
the difference between continuing from the last stress (left) and selecting to repeat (right). 
In this example, the test has a duration of 20 hours, and the graphs explain what would 
happen through the entire duration of the test. 
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4. Before you can use the new profile in your analysis, you must save any changes you have 
made and validate the current profile settings. To do this, click the Validate Profile icon. 

 

After you save the changes in your profile, the Profile Summary area will appear. Click the 
Detailed Summary icon  to open the Results window, which shows the current profile in 
a worksheet that you can copy or print. 

To view a stress vs. time or throughput vs. time plot of the profile, click the Plot icon. (See 
Plot Utilities for general information on plots.) 

 

Note: Clicking the Validate Profile icon will not automatically update your plot. To make 
sure your plot reflects the most recent profile information, click the Plot icon. 

If desired, you can use the Comments page of the control panel to enter notes or other text 
that will be saved with the profile. 

5. Click OK to save your changes. 

IMPORTING DATA FROM NCODE GLYPHWORKS TO CREATE STRESS PROFILES 

You can import nCode GlyphWorks time series data from .S3T files for use as stress profiles. The 
stress values in the .S3T file must be greater than zero in order for the data to be imported. 

https://www.ncode.com/products/ncode-glyphworks-signal-processing-and-durability-analysis
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To import data from an nCode .S3T file, first create a new profile from the Resource Manager 
(Home > ReliaSoft > Resource Manager). In the Profile window, click the Import from 
GlyphWorks icon on the control panel. 

 

This launches the import wizard, which guides you through the steps required to import data 
from the file. You can then edit the resulting imported data, if desired. Note that if you update 
the .S3T file in GlyphWorks, the associated profile in Weibull++ will not be updated 
automatically. You must re-import the data to reflect the changes. 

Tip: Because stress units (e.g., volts) and time units (e.g., hours) are not defined in the profile, it 
is important to apply profiles only to folios that are intended to use the same stress and time 
units. In the Profile window, you may want to use the Comments page as a reminder of which 
units are applicable to that profile. 

Maintenance Groups 
Maintenance groups are resources that are available for use throughout the project and can be 
managed via the Resource Manager. A maintenance group is a set of blocks or system hierarchy 
items where some event within the group can trigger either maintenance or state changes for 
one or more blocks or items, either within the group or outside of it. You can use a 
maintenance group: 

• In BlockSim: To turn a block on or off. State change triggers are used to activate or 
deactivate a block when items in one or more specified maintenance groups go down or 
are restored. The block whose state is being changed may or may not belong to any of the 
maintenance groups. This allows you to model a cold standby configuration (i.e., one where 
the component cannot fail when in standby) without using a standby container, which may 
be useful if you are using a parallel or complex configuration, as blocks can be connected 
only in series in standby containers. 

• In BlockSim, RCM++ or RBI: To trigger a scheduled task (i.e., a preventive task, inspection or 
on condition task). You can set the task to be performed based on events in one or more 
maintenance groups. Triggering events within the maintenance group can include 
block/item failure; start of corrective, preventive or inspection tasks; and/or block/items 
restoration. The block(s)/item(s) affected by the task may or may not belong to any of the 
maintenance groups. For example, if you want to perform preventive maintenance on 
Component A every time you perform corrective maintenance on Component B, then you 
can assign Component B to Maintenance Group 1 and then set the preventive task assigned 
to Component A to be performed upon the start of corrective maintenance within 
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Maintenance Group 1. See Task Scheduling for more information on how tasks can be 
scheduled. 

Note: When you specify a maintenance group for a subdiagram block, it applies at the 
subdiagram level rather than to the individual blocks within the subdiagram; for example, the 
subdiagram block is considered "down" only if some event within it causes the entire 
subsystem modeled by the diagram to go down. 

CREATING AND EDITING MAINTENANCE GROUPS 

The Maintenance Group window allows you to create, view and edit maintenance groups. It can 
be accessed by clicking the Create New or View/Edit icon in the Maintenance Group wizard, 
which is accessed from the Maintenance Group field in Block Properties windows in BlockSim, 
and in the FMRA operation properties in RCM++ and RBI . 

   

It can also be accessed from the Maintenance Groups page of the Resource Manager by 
choosing Home > Edit > New, by selecting a maintenance group and choosing Home > Edit > 
View or by double-clicking a maintenance group. 

In BlockSim, it can also be accessed via the icons in the Maintenance Group Manager. 

At the top of the window, you can specify the maintenance group name. You can replace the 
default name with your own name, if desired.  To change the default names, choose File > 
Manage Database > Default Name Formats. (In a secure database, this is available only to 
users with the "Manage other database settings" permission.) 

 

You can also enter comments about the maintenance group in this window. 

For existing resources, the link at the bottom of the window indicates how many times the 
resource is currently being used. If you need more information, click the link or the icon to open 
the Dependency Viewer. 

 

ASSIGNING MAINTENANCE GROUPS 

In RCM++ and RBI, system hierarchy items can belong to maintenance groups. To assign an item 
to a maintenance group, select the item in the FMRA and go to the Operation heading in the 
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Properties tab. See Setting the Operation Properties for an FMRA in the XFMEA/RCM++/RBI 
documentation. 

In BlockSim, certain types of blocks can belong to maintenance groups. You can assign an 
individual block to a maintenance group in the Block Properties window, or you can use the 
Maintenance Group Manager to define the group membership. Blocks that belong to a 
maintenance group have a circle at the upper left corner of the block. You can change the size 
of the indicator via the relevant Block Corner Indicators page of the Diagram Style window. You 
can change the color used for each maintenance group via the Maintenance Group Manager. 

Maintenance Group Manager 

In BlockSim only, the Maintenance Group Manager allows you to add blocks to or remove 
blocks from a maintenance group without having to go into each block's properties individually. 
This window can be accessed by choosing Project > Data Management > Maintenance Group 
Manager or, when you are viewing the Maintenance Groups page of the Resource Manager, by 
choosing Home > Actions > Maintenance Group Manager. 

 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=setting_the_operation_properties_for_an_fmra.htm
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The Maintenance Group area allows you to choose an existing maintenance group from the 
drop-down list. In addition, you can click the Select Existing icon to open the Select Resource 
window. If there is not an existing maintenance group that meets your needs, you can create a 
new one by clicking the Create New icon to open a window that allows you to specify a name 
for the new maintenance group, as well as any comments. Click the View icon to view the 
characteristics of the selected maintenance group. 

 

You can also click the Indicator Style icon to modify the appearance of the corner indicator that 
will appear on each block that belongs to the maintenance group, including: 
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• The indicator's background color, fill color and fill style. The background color is the 
underlying color applied to the indicator; the fill color is applied over the background color 
in the pattern specified by the fill style. 

• The style (e.g., solid, dash, etc.), color and thickness of the indicator border. 

You can change the size of the indicator via the relevant Block Corner Indicators page of the 
Diagram Style window. 

The Blocks area displays all of the blocks in the maintenance group, in the format [Diagram 
Name]\[Block Name]. 

• To add a block to the maintenance group, you can select the diagram and block in the Add 
Block area and click the Add to Maintenance Group button. You also can select the block(s) 
in the diagram, press CTRL+SHIFT and drag the block to the list in the Blocks area of the 
Maintenance Group Manager. 

• To view a block in the maintenance group, select the block in the list and click the Select on 
Diagram button. The diagram will be displayed with the block selected. 

• To remove a block from the maintenance group, select the block in the list and click the 
Remove from List button. 

Mirror Groups 
Mirror groups are resources that are available for use throughout the project and can be 
managed via the Resource Manager. You can use a mirror group: 

• In BlockSim: To place the same block in more than one location (i.e., to represent a single 
component more than once in a diagram or in multiple diagrams within a project). See 
Mirroring (Using Blocks in Multiple Locations) in the BlockSim documentation. 

• In the FMRA in BlockSim, XFMEA, RCM++ or RBI: To place the same cause in more than one 
location in the FMRA hierarchy, in order to consider common cause failures. See Using 
Mirror Groups in an FMRA in the XFMEA/RCM++/RBI documentation. 

Task Packages 
Task packages are resources that can be shared among analyses and can be managed via the 
Resource Manager. They represent groups of tasks that are performed together at scheduled 
intervals, for the most efficient allocation of resources and downtime management. 

http://help.reliasoft.com/blocksim20/index.htm#t=mirroring_using_blocks_in_multiple_locations.htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=using_mirror_groups_in_an_fmra.htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=using_mirror_groups_in_an_fmra.htm


Chapter 19: Resources 

Weibull++ 2020 User's Guide 1301 

 

The Task Package window allows you to create, view and edit task packages. It can be accessed 
by clicking the Create New or View/Edit icon in the Task Package wizard, which is accessed 
from the Task Package field that appears when you select the Override task scheduling 
properties with a task package option for a preventive, inspection or on-condition task that is 
scheduled to be performed at fixed intervals. 

   

It can also be accessed from the Task Packages page of the Resource Manager by choosing 
Home > Edit > Add, by selecting a task package and choosing Home > Edit > View or by double-
clicking a task package. 

For a new resource, a name will be proposed automatically based on the default naming criteria 
established for the current database (see Default Name Formats window). You can replace this 
with your own name, if desired. Remember that the name and identifiers are the primary way 
in which your team will be able to find the resources you need for your analyses. 

The following settings are available to configure the task package: 

• In the Perform every field, enter the length of the interval at which the task package will be 
performed. You must specify units for this value. 

• The Auto-Packaging Intervals fields allow you to specify a range of scheduled intervals that 
will automatically be incorporated into the task package if the user clicks the Auto-Package 
Tasks button at the bottom of the Maintenance Task Packaging window in RCM++/RBI. The 
units for these fields are the same as those specified for the Perform every field. For 
example, if you enter 150 hours in the Start time field and 200 hours in the End time field, 
then tasks that are scheduled to be performed at fixed intervals from 150 to 200 hours can 
automatically be included in the task package to be performed at the scheduled time of the 
task package rather than at their individually scheduled times. 

• Identifiers contains additional identifying information that can be used to search for this 
resource. 

• History provides information about when the record was created and last updated. If the 
history log has been activated at the project level, you can click the View Item History icon 
to open the Record History Log for the record. 

 

• Watch allows each individual user to subscribe to receive an alert (via e-mail, SMS text 
message or portal message) when the resource is changed. 
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• Trace Usage. For existing resources, the link at the bottom of the window indicates how 
many times the resource is currently being used. If you need more information, click the 
link or the icon to open the Dependency Viewer. 

 

Actions 

Throughout the ReliaSoft desktop applications, your team can use actions to track specific 
assignments that need to be performed. These versatile resources can be used multiple times 
in different locations, if appropriate. Specifically, actions can be created, displayed and/or 
managed: 

• via Project Plans or the Resource Manager in all ReliaSoft desktop applications except MPC. 

• via My Portal or Actions Explorer in all ReliaSoft desktop applications. 

• via the SEP web portal (if it is implemented for your database). 

• via FMEAs or test plans in XFMEA/RCM++/RBI. 

For specific instructions regarding how to create or edit an action in each location, please 
consult the documentation for that particular feature. This section focuses on general 
considerations that will be applicable regardless of where/how the action is being used. 

Tip: If an action is used in an FMEA, the properties window will be different depending on the 
current context. If you’re using XFMEA/RCM++/RBI and you open the action from the FMEA or 
My Portal, the window includes additional features that provide quick access to associated 
FMEA records (failures, causes, etc.) and the FMEA change log (if activated). These features are 
not available if you open the action from another location (e.g., Resource Manager, Project 
Planner, Actions Explorer) or in another application, because the associated FMEA can’t be 
opened in those situations. 

ACTIONS AS RESOURCES 

As with any other resource: 

• Any changes to the action properties will be reflected in all locations where the resource is 
used. 
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• If you remove an action from an FMEA, a test plan or a Project Plan, the resource will 
remain in the project unless/until an authorized user deletes it from the database (via My 
Portal, Resource Manager or Actions Explorer). 

Note: Actions are always local resources. They cannot be made global. Actions in a reference 
project are local to that project and can't be selected for use in other projects. 

CONFIGURABLE SETTINGS 

Some properties for action records can be configured via interface style settings. See 
Configurable Settings. 

SHOW/HIDE PROPERTIES FOR INDIVIDUAL RECORDS 

You can also use the following ribbon commands to show/hide certain features for a particular 
action record. 

Generic vs. Detailed: A detailed action contains additional properties for describing 
a specific test that needs to be performed (Specifications, Requirements and Reports). 
These properties are not configurable; they may be of interest in test plans in 
XFMEA/RCM++/RBI. (See Test Plans in the XFMEA/RCM++/RBI documentation.) Most 
actions, unless they are used in test plans, do not need to display these fields. 

Show Resources: The resources fields (Team, Facility, Material and Additional Costs) are 
used for calculating costs and resource utilization. They are always enabled but you can 

toggle this command to hide or display them for any particular action record. The Check 
Utilization command provides a summary of the resources that have already been 
assigned. (See Costs and Man Hours.) 

Show Review/Approval: If the Reviewer property is enabled in the configurable settings 
for the current project, you can toggle this command to hide or display these fields for any 

given action. The Review Action command will be enabled if you are assigned to review 
the action and it is ready to be reviewed. (See Review and Approve Actions.) 

PRIORITY 

The color-coded Priority command provides a consistent scale for prioritizing actions across all 
projects in the database. (The same options are also available for gates in the Project Planner.) 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=test_plans.htm
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This is intended to be used instead of the configurable Action Priority field from prior versions, 
which can be different for different projects. When you convert from a Version 8/9 database, 
the software will attempt to match any priorities that were assigned with the old configurable 
drop-down list. For example, if you were using the default "High," "Medium" and "Low" labels 
that were shipped with Version 8/9 libraries, they will automatically be mapped to the 
corresponding options in the new ribbon command. 

ACTION STATUS AND REVIEW STATUS 

The action’s status bar displays two complementary status indicators. The first one is based on 
the actual and expected start date and completion date. It indicates that the action is not 
started, in progress or complete and whether it is on time or running late. (See Action Timeline 
and Status.) 

The second one is based on whether a reviewer has been assigned in the Review/Approval 
section and, if so, the status of that review. 

  

E-MAIL AND ALERTS 

The E-mail command will be enabled if an authorized user has defined a valid SMTP server. This 
allows you to manually send an e-mail containing the current action details to any valid e-mail 
address. 

 

If a valid SMTP server has been defined within the database, your team can also choose to use 
automated alerts (via e-mail or SMS text message). Each individual user can subscribe to 
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"watch" specific action resources, and the database can also be configured to auto-subscribe 
users assigned to specific roles for the action. (See Watches and Alerts.) 

Click Action Monitors to specify individual users and/or groups of users who will always receive 
alerts for the record, regardless of whether they have personally subscribed to a “watch.” (See 
Action and Gate Monitors.) 

 

ADD TO OUTLOOK CALENDAR 

The Add to Outlook Calendar command will be enabled if Microsoft Outlook is installed on 
your computer. 

 

It launches Outlook’s interface for creating a new calendar event and automatically populates 
the subject and date. You can modify the details as needed before saving the new event to your 
calendar. 

Note that you may need to give focus to the Outlook application in order to see the window.   

PERSON RESPONSIBLE AND RESOURCES 

For each action resource, you can assign both an individual database user who is primarily 
responsible for completing the action and a team of users who are also involved. You also have 
the option to track the percentage of their available time that is planned to be utilized for the 
activity. 

Tip: If a user is assigned as person responsible and also belongs to the team, the costs and 
utilization values will be summed. For example, the application assumes that the utilization is 
X% as person responsible plus an additional Y% as a member of the team. 

Person Responsible 

The Person Responsible field can be enabled or disabled, depending on the configurable 
settings for the current project. If you want to use personalized alerts, track resource utilization 
etc., you must select a database user. Alternatively, you can type a text description that will be 
displayed in the FMEA spreadsheet. 
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Tip: If you want to change the person responsible for multiple actions simultaneously (e.g., if a 
user changes roles and his/her actions need to be reassigned), use the Actions Explorer. 

If the Set action creator as 'Person Responsible' by default check box is selected in the 
Database Settings window, then the person who created the action is automatically shown in 
the Person Responsible field, but that can be changed. 

Resources 

The Resources fields are always enabled but you can toggle the Show Resources command to 
hide or display them for any particular action record. 

 

You can select from the teams, facilities and materials resources that have been predefined 
within the database (or create them on-the-fly if you have the required permissions). In a 
secure database, only users with the "Manage project planning resources and working days" 
permission will be able to create and edit these resources. (See Project Planning Resources.) 

 

Check Utilization 

If you need to view the utilizations of users and facilities for the current action, click Check 
Utilization. 
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ACTION TIMELINE AND STATUS 

For all action resources, the status is determined automatically based on the actual and 
expected start/completion dates. If an action is included in the Project Planner, its expected 
timeline can automatically shift in response to delays in prior activities. If the action is not 
included in the plan, the expected dates are always identical to the originally planned dates. 

The following status indicators are displayed in the status bar of the action properties window 
and in other relevant locations. (Note that the status bar now also displays a separate review 
status to indicate whether a user has been assigned to review/approve the action and, if so, the 
status of the review. See Review and Approve Actions.) 

  Not Started: The action hasn't started, but it can still start on time. 

  Past Start Date: The action hasn't started, and it is too late to start on time. 

  In Progress: The action has started. 

  Past Due: The action hasn't completed, and it is too late to complete on time. 

  Completed - On Time: The action completed on time. 

  Completed - Late: The action completed late. 

COSTS AND MAN HOURS 

For action resources, you can now track the planned vs. actual usage for both costs and man 
hours. 

The Planned Cost and Actual Cost fields can be enabled or disabled, depending on the 
configurable settings for the current project. If the properties are enabled, the planned costs 
will always be calculated automatically based on the action duration, person responsible and 
project planning resources. For the actual costs, you can choose to enter manually or use the 
automatic calculations. 

Enter Manually 

If you prefer to enter the actual costs/hours instead of using the automatically calculated 
values, select Yes in the Manually enter costs/man hours? field. 
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Let the software calculate Enter the values yourself 

Calculate Automatically 

The automatic calculations are based on: 

• The Duration (the number of working days from the start date to the due/completion date). 

• The Person Responsible and/or the Team: 

• The % utilization is set in each action record. 

• The Hours per Day and Cost Category are set in each user account record. 

• The Facility (e.g., test lab or other facility needed to complete the action): 

• The % utilization is set in each action record. 

• The Max Hours per Day and Cost Category are set in each facility properties record. 

• The Materials (e.g., test samples or other material needed to complete the action): 

• The Quantity and Cost Category are set in the material properties record. 

• Any Additional Costs that are defined directly in each action record. 

The following simple examples demonstrate how each type of cost is calculated. 

Personnel Costs 

Action 
Duration: 

5 working days 
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Joe 
Engineer: 

Works 8 hours per day (5 days x 8 hours = 40 hours) 

Time is billed at $100 per hour (no "per instance" cost) 

Assigned as Person Responsible with 5% utilization (40 hours x .05 = 2 hours) 

Also belongs to the assigned Team with 1% utilization (40 hours x .01 = .4 hours) 

The calculated values for Joe’s work on this action are 2.4 man hours and 2.4 x $100 = $240. 

Facilities Costs 

Action 
Duration: 

5 working days 

ABC Test 
Lab: 

Is available up to 8 hours per day (5 days x 8 hours = 40 hours) 

The utilization for this action is 20% (40 hours x .20 = 8 hours) 

Costs $500 "per instance" plus $50 per hour 

The calculated cost for using this facility to complete the action is $500 + (8x$50) = $900. 

Materials Costs 

Gizmo 
Prototype: 

Costs $5000 to produce the batch of test units (the "per instance" cost) 

The test requires 10 samples 

Each unit costs $500 (the "direct cost per hour or unit") 

The calculated cost for the materials required to complete the action is $5000 + (10x$500) = 
$10,000. 

ACTION STATUS UPDATES 

For all action resources, the Progress (Status Updates) area displays any notes that have been 
added to report progress. The software automatically adds these updates under certain 
conditions (e.g., upon review/approval), and you can also create updates manually when 
needed. 

To add a new note, click Add Status Update in the action’s ribbon or click the heading and then 
click the Add icon that becomes visible. 



Chapter 19: Resources 

1310 https://www.reliasoft.com/weibull 

 

 

 

The type that you select in the Add Status Update window can affect the actual start and 
completion dates of the action, and also update the action status. (See Action Timelines and 
Status.) 

 

• Not Started allows you to record comments without entering a start date. If an actual start 
date has already been entered, the update will remove the date and change the action’s 
status back to Not Started. 

• In Progress 

• If an actual start date is not already defined, sets the current date as the Actual Start 
Date and allows you to specify the % Completed. This will change the action’s status to 
In Progress. 

• If the action is already in progress, allows you to add another note and update the 
completion percentage. 

• Completed sets the current date as the Completion Date. This will change the action’s 
status to either Completed-On Time or Completed Late. 

To delete an existing note, click inside the field and then click the Delete icon that becomes 
visible. There is no undo for delete. 

 

REVIEW AND APPROVE ACTIONS 

Action resources can be marked for review and approval. If the Reviewer property is enabled in 
the configurable settings for the current project, you can click Show Review/Approval in the 
action ribbon to hide or display these fields for any given action. 
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(Note that if an action has been assigned for review or is already reviewed, you can no longer 
hide the fields.) 

Assigning a Reviewer 

If an action has not yet been reviewed, any user who is able to edit the record can assign or 
change the reviewer at any time. 

In a secure database, the Reviewer drop-down list contains all of the database users who have 
the "Approve actions" permission. 

• If a user has been assigned to review the action but an actual completion date is not 
entered, the review status will be Reviewer Assigned. 

• When the completion date is entered and the action is ready for review, the status will be 
Pending Approval. 

Tip: If you want to change the assigned reviewer for multiple actions simultaneously (e.g., if a 
user changes roles and his/her actions need to be reassigned), use the Actions Explorer. 

Reviewing and Approving the Action 

When you are assigned to review/approve an action that has been completed, the record will 
be highlighted for you in My Portal (and in the SEP web portal if implemented), and you may 
also receive automated alerts (via e-mail and/or SMS) if applicable. 

To record your decision, open the action record and choose Review Action. 

 

In the Review Action window, you can choose one of the following options: 

• Approve action assigns the review date/time and marks the status Approved. 

• Reject and re-open action removes the completion date and marks the status Rejected and 
in progress. The team can perform any rework that is needed and resubmit the action for 
another review. 

• Reject and close action marks the status Rejected and closed. 
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You can enter your comments directly in this window, or enter/update them later in the 
comments field. 

 

CONFIGURABLE SETTINGS FOR ACTIONS AND CONTROLS 

Some of the properties in action records and in control records are configurable via the 
interface style settings that have been defined for the current project. The interface style is 
used in XFMEA/RCM++/RBI to customize a variety of analysis fields to fit the organization’s 
particular preferences and needs. (See About Configurable Settings in the XFMEA/RCM++/RBI 
documentation.) 

You can view/edit the configurable settings for actions and controls from any ReliaSoft desktop 
application by clicking Configurable Settings of the action properties window or the control 
properties window. (In secure databases, this is available only if the user is the project owner, 
or has the "Edit project properties" permission.) 

 

 Any changes to these settings will apply to all records of that type in the current project. 

Starting in Version 2020, two new configurable drop-down lists are available for actions. These 
fields are intended to allow users to follow the AIAG & VDA FMEA Handbook released in 2019. 

• The options in the Action Type drop-down list depend on the current project's interface 
style. For the "DFMEA: AIAG & VDA-1" and "PFMEA: AIAG & VDA-1" profiles, the default 
values are: 

• Detection actions will help to enhance, optimize or otherwise improve the ability 
detect the failure and/or cause before it reaches the end user. 

• Prevention actions will help to improve the ability to prevent the failure and/or cause 
from occurring. 

• Status Detail is used to manually record the current status of the action. For the "DFMEA: 
AIAG & VDA-1" and "PFMEA: AIAG & VDA-1" profiles, the default values are: 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=about_configurable_settings_xfmea.htm
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• Open 

• Decision Pending 

• Implementation Pending 

• Completed 

• Not Implemented 

ACTIONS EXPLORER 

The Actions Explorer is available in all ReliaSoft desktop applications except MPC. You can use 
this flexible tool to explore all of the action resources that are stored in the current database. 

To access the utility, choose Home > ReliaSoft > Actions Explorer. 

 

To reduce the amount of time required to populate the grid, first use the Project, Status, User 
and/or Date filters to limit your search, then click Load Data. 

 

Add, Edit and Delete Actions 

When actions are loaded in the grid, you can use the following ribbon commands to add, edit 
and delete actions. (In a secure database, the ability to add or edit an action is only available for 
users with the "Create/edit/delete local resources" or "Create/edit/delete local resources" 
permission in the relevant project.) 

To delete or edit multiple actions at the same time, press CTRL or SHIFT while clicking rows in 
the grid. Selected rows will be highlighted. 

  Add Action creates a new action resource in the project that currently has focus. 

  Edit Action allows you to view and edit all of the properties of the action that is currently 
selected. 

  Delete Action deletes all of the actions that are currently selected. There is no undo for 
delete. 
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  Assign Person Responsible and Assign Reviewer allow you to set (or change) the 
person responsible or reviewer for all of the actions that are currently selected. 

Save and Apply Views 

Once you have customized the grid to suit a particular purpose (using the built-in filter, column 
configuration and grouping features described below), you can save the preferences as a view 
that can be used again whenever you need it. A view is saved in the database and available only 
to the user who created it. 

To create a view, first configure the grid to suit your particular needs and then click Save View. 

 

To quickly apply these same preferences again at any time, click Apply View and select one of 
the saved views from the list. 

 

Note: The view does not affect filtering that has been applied from the Project, Status, User 
and/or Date filters, or from the Relevance Panel. 

Project, Status, User and Date Filters 

The Actions Explorer can utilize the same project filter that is available in many other locations 
throughout ReliaSoft desktop applications. 

 

You can also filter by status (e.g., In Progress, Completed, etc.), user (e.g., Person Responsible 
or Reviewer) and date (e.g., Planned Start Date, Actual Start Date, etc.). 

After you clear or change these filters, you must click Load Data again to update the grid. 
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Relevance Panel 

The relevance panel provides a quick way to filter the actions based on how they are relevant 
to you (based on your personal username). 

• I am responsible for  

• You are assigned in the Person Responsible field. 

• I am a team member in  

• You belong to the team assigned in the Team field. 

• I need to review/approve  

• You are assigned in the Reviewer field. 

• I am monitoring  

• You are assigned in the Action Monitors window, or you have personally subscribed to 
“watch” the action.  

• I am the creator  

• You are listed in the Created By field. 

• All actions – displays all actions, regardless of whether they’re relevant to you. 

Tip: If an action is relevant to you in more than one way, it will display if any applicable 
relevance check box is selected. For example, if you are both the person responsible and the 
creator, the action will display if you have selected "I am responsible for", "I am the creator" or 
"All actions." 

Built-in Find/Filter, Configuration and Grouping Tools 

The Actions Explorer offers the same filter, column configuration and grouping tools that are 
built in to other utilities that use a similar grid (e.g., the Resource Manager). For details about 
how to use each feature, see: 

• Finding and Filtering Records 

• Configuring Columns 

• Grouping Panel 
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Controls 
Controls are resources used in FMEAs that are the methods or actions currently planned or 
already in place to reduce or eliminate risk. Controls can be managed via the Resource 
Manager. 

As with any other resource: 

• Any changes to the control properties will be reflected in all locations where the resource is 
used. 

• If you remove a control from an FMEA, it will remain in the project unless/until an 
authorized user deletes it from the database. 

• If a control resource is not currently used in an FMEA, you can delete it via the Resource 
Manager. (In a secure database, this is possible only if the user a) is the project owner, b) is 
the control creator, or c) has the applicable "create/edit/delete resources" permission.) 

For existing resources, the link at the bottom of the window indicates how many times the 
resource is currently being used. If you need more information, click the link or the icon to open 
the Dependency Viewer. 

 

Note: Controls are always local resources. They cannot be made global. Controls in a reference 
project are local to that project and can't be selected for use in other projects. 

For specific instructions on using controls in FMEAs, see the "Controls in FMEAs" topic in the 
XFMEA/RCM++/RBI documentation. 

CONFIGURABLE SETTINGS 

Some properties for controls can be configured via interface style settings. See Configurable 
Settings. 

Resource Manager 

The Resource Manager allows you to create, view, edit and delete resources. It also helps you 
to trace where each resource is used, and to create global resources that are available to all 
projects in the database. 

To open the Resource Manager, choose Home > ReliaSoft > Resource Manager. 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=controls_in_fmeas.htm
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To use the utility, choose the type of resource that you want to work with in the navigation 
panel on the left side of the window. A table that displays the resources of the selected type 
will be shown on the right side of the window. 

Tip: When you need to create or edit a large number of resources, you can also use ReliaSoft 
APIs to import the data from an Excel file or other data source. For example, the 
URDExample.xlsm file at C:\Users\Public\Documents\ReliaSoft\Examples20\API\VBA enables 
you to quickly create/update multiple URDs with some basic properties (models and corrective 
tasks). If you have the necessary software coding experience, you can expand this tool or create 
your own custom applications to meet specific needs. 

RESOURCE FILTER 

The Resource Manager can utilize the same resource filter that is available in many other 
locations throughout ReliaSoft desktop applications. 

 

BUILT-IN FIND/FILTER, CONFIGURATION AND GROUPING TOOLS 

The Resource Manager offers the same filter, column configuration and grouping tools that are 
built in to other utilities that use a similar grid (e.g., the Analysis Explorer, Actions Explorer, 
etc.). For details about how to use each feature, see: 

• Finding and Filtering Records 

• Configuring Columns 

• Grouping Panel 

CREATING, VIEWING, EDITING AND DELETING RESOURCES 

You can: 

http://reliawiki.org/index.php/ReliaSoft_API_Reference
http://reliawiki.org/index.php/ReliaSoft_API_Reference
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• Create a new resource of the selected type by choosing Home > Edit > Add. 

 

To add multiple resources at the same time, specify the quantity in the Home > Edit > 
Number to Add field and then choose Home > Edit > Batch Add. You will specify the 
properties for one of the new resources, and the additional resources will be duplicates of 
that. You can then edit each resource individually, or you can go to the Batch Properties 
Editor to edit them in a spreadsheet format. 

• Duplicate an existing resource by selecting the row in the table and choosing Home > Edit > 
Duplicate. You can choose to duplicate just the selected resource or, for local resources 
only, you can choose Cascade Duplicate to duplicate the resource and all resources 
assigned to it, at all levels (e.g., cascade duplicating a corrective task will also duplicate the 
task's duration model, the assigned crew and all models assigned to the crew, etc.). Note 
that only local resources will be duplicated in a cascade duplication; if the original uses any 
global or reference resources at any level, the copy will also use those original global or 
reference resources rather than creating copies of them. 

 

• View or edit an existing resource by double-clicking the row in the table or by selecting the 
row and choosing Home > Edit > View. 

 

• Delete an existing resource by selecting the row in the table and choosing Home > Edit > 
Delete. 

 

You cannot delete a resource that is currently being used in any other resource or analysis. 

Note: A published model cannot be edited or deleted from the Resource Manager. If changes 
are needed, you must update the original analysis and then republish the model. If you wish to 
delete the model, you must first remove the association with the original analysis and also 
make sure the model is not being used. (See Publishing Models.) 
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TRACING WHERE RESOURCES ARE USED 

With a single resource selected, you can choose Home > Selected Resource > Trace Usage to 
open the Dependency Viewer, which provides information on where the resource is used and 
any additional resources that the currently selected resource itself uses. 

 

If you need to know which resources are not currently being used (e.g., because you want to 
delete obsolete records), choose Home > Display > Show Only Unused. 

 

LOCAL AND GLOBAL AND REFERENCE RESOURCES 

As explained in Local, Global and Reference Resources, the availability of resources for use is 
determined by their scope. Local resources are available only in the current project. Reference 
resources are available for any project within the database, depending on the user's 
permissions within the reference project. Global resources are available for use in any project in 
the database. 

The far left column in the Resource Manager displays an icon that indicates whether each 
resource is local, global or a reference resource. 

   

Local Resource Global Resource Reference Resource 

  

You can use the Home > Display > [Show Local/Show Global/Show References] commands to 
toggle the types of resources shown in the Resource Manager. 

EXPORTING INFORMATION FROM THE RESOURCE MANAGER 

To send the contents of the Resource Manager to Excel, or to a built-in ReliaSoft Workbook or 
spreadsheet if that's available in the current application, choose Administration > Output > 
Transfer Report. 
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You can send either the current item (i.e., the table for the currently displayed page) or the full 
report (i.e., the tables for all pages in the Resource Manager). 

REMOVING UNUSED AND DUPLICATE RESOURCES 

The Resource Manager provides several tools to make it easy to delete unused resources and 
merge duplicate resources. 

Finding and Removing Unused Resources 

To find unused resources of the selected type, choose Home > Display > Show Only Unused. 

 

Once you have found the unused resources, you can decide which ones to delete. 

You can return to viewing all resources of the selected type by choosing the Show All 
command. 

 

Finding Duplicate Resources 

You may sometimes have duplicate resources within a project (i.e., several models that all 
represent the identical distribution, several tasks that are identical, etc.) within a project. For 
example, this might happen if you have imported diagrams that all reference the same model, 
but the imports happened at separate times and therefore the model had to be imported again 
each time. 

To find duplicate resources, choose Home > Display > Show Only Duplicates. 

 

In the window that appears, select the properties that must match in order for the resources to 
be considered duplicates. For example, if you are looking for duplicate URDs, you might select 
to compare the model, corrective task and scheduled tasks, but not the URD name. Once you 
have selected the columns to compare, click OK to show the duplicate resources. 
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You can merge multiple resources of the same type into one resource, either automatically or 
manually. Note that models must be of the same category in order to be merged, and you 
cannot merge published models. When you merge resources, any folios that you may have 
open will be closed prior to the merge in order to prevent data inconsistencies. 

IMPORTANT: Merging cannot be undone, and only the information from the "target" resource 
(i.e., the resource that you merge the others into) will be retained. 

Automatically Merging Duplicates 

To merge resources automatically, choose Administration > Cleanup > Merge All Duplicates. 

 

This will find all sets of duplicates within the selected resource type (e.g., three identical 
Weibull models and 2 identical lognormal models); and for each set, it will merge the duplicates 
into the first instance found. After you confirm that this is what you want to do, you will be 
prompted to select the properties that must match in order for the resources to be considered 
duplicates. The process begins as soon as you select at least one column and click OK. It cannot 
be undone. 

Selecting Resources to Merge 

To merge resources manually, select the resources and choose Administration > Cleanup > 
Merge & Delete.   

 

The window shows a list of the resources you selected to merge and allows you to choose 
which one will be retained (i.e., the one that the other selected resources will be merged into). 
After you click OK, this resource will be used in all places where the other selected resources 
were previously used. 

SELECT RESOURCE WINDOW 

The Select Resource window allows you to choose an existing resource to use at your current 
location. You will see this window in situations like the following: 

• When you click the Select Existing icon in any resource wizard. 
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• When you are adding an existing action in an FMEA or in the Project Planner, or an existing 
control in an FMEA. 

The Select Resource window is similar to the Resource Manager, but it shows only the resource 
type that you are currently working with. The functionality of the window will vary slightly 
depending on where you have opened the window from. 

• If you can select only one resource (e.g., in a resource wizard), each row in the table will 
contain a radio button that allows you to select the resource for use. If you can select 
multiple resources (e.g., adding existing actions or controls in an FMEA), each row will have 
a check box instead. 

• Actions, controls and metrics are always local, so the commands to show global or 
reference resources will not be available in these cases. 

• The ability to apply an item filter is available only for resources that have a full set of 
identifiers. This excludes actions and controls. 

• Some resources may not be available for selection. For example: 

• In an FMEA, you can't select an action or control that is already assigned to the current 
cause. 

• In the project planner, an action cannot be added if it is already in use in the project 
plan or if its start date is either before or more than a year after the gate's start date. 

• A metric can't be selected to have a value pushed to it if it's already in use somewhere 
else, or if it's a type that is not compatible with the current use. 

Starting in Version 2020, the following changes have been made to make the window more 
intuitive to use: 

• When you click OK, only the resources that are selected and currently visible are added to 
the desired location. That is, if you have selected a resource and then applied a filter that 
causes that resource to be hidden from view in the Select Resource window, it will not be 
added. Note that this is true regardless of whether the window is in single selection (radio 
buttons) mode or in multiple selection (check boxes) mode. 

• The selection status of resources is preserved while filters change. If you have selected a 
resource and then applied a filter that hides the resource from view, if you subsequently 
remove the filter, the resource that you had selected continues to be selected. 

• The Select All check box in the column heading selects only visible resources. 
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Taken together, these changes allow you to change your filters multiple times in order to select 
various resources. You can then clear the filters and all selected resources will be added to the 
desired location. 

Trace Usage 

DEPENDENCY VIEWER 

Because resources can be used multiple times, it is important to know where a given resource is 
used before making changes to it. The Dependency Viewer, which is accessed by clicking the 
Trace Usage icon in each resource properties window or in the Resource Manager, provides 
information on where the resource is used and what additional resources, if any, it uses. 

 

The selected resource is shown in the Current Selection area in the middle of the Dependency 
Viewer. 

The items that use the selected resource, if any, will be displayed in the This [resource] is used 
by area on the left. If it uses any resources, those resources will be displayed in the This 
[resource] uses area on the right. For example, in the picture shown next, the selected resource 
is a URD. It is used by Block 1 in a BlockSim diagram and by SubSystem 1 in an FMEA analysis. 
The URD uses an assigned model and two tasks. 
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You can edit any resource shown in the Dependency Viewer by right-clicking it and choosing 
Edit Item on the shortcut menu. The resource's properties window will open. 

You can double-click an item in either area to make it the current selection in the window. For 
example, you could double-click a task used by the URD to see the model(s), crew(s) and/or 
spare part pool(s) that the task uses. 

As you change selected items, each previous item that you selected will be added to the "path" 
of recent selections at the top of the window; click Back to go back through the path to the 
previously selected items. For example, the following picture shows a path in which the user 
started with the URD, then proceeded to its corrective maintenance task, the crew for that task 
and the logistic delay for that crew (not shown in the path because it is the current selection). 
The button now provides a quick way to go back through those same resources in reverse order 
if needed. 

 

You can click the Diagram View button to open the diagram view of the Dependency Viewer. 
The currently selected item will be the main block in the diagram that is created. 
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Choosing What You See 

In the Current Selection area, you can choose what is shown in the This [resource] is used by 
area. You have the option to skip the URD and/or the block that the resource is used by. For 
example, the image below shows the connections among analyses and resources that we have 
been discussing. If you have selected to show all levels, you can trace from Reliability Model to 
URD 1 to Block 1 to RBD1. But if you have selected Skip Blocks and RBDs, it just shows that 
Reliability Model is used by RBD1. 

 

Note that blocks are always skipped in event analysis flowcharts (i.e., only the flowchart will be 
shown as the precedent for a resource used by any block within the flowchart). 

DEPENDENCY VIEWER - DIAGRAM VIEW 

The diagram view of the Dependency Viewer, which is accessed by clicking the Diagram View 
button, offers a diagram-based alternative to help you understand the connections among 
resources in your project. 

To understand how to use this view, consider the same example shown in the Dependency 
Viewer topic. Clicking the Diagram View button for that example will yield a diagram view that 
shows only the main item (in this case, the URD), which is marked with a flag: 
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To view a graphical representation of the information that was shown in the Dependency 
Viewer, choose Add One Level Precedents and Add One Level Dependents. This will show the 
items that use the resource (i.e., its precedents), and the resources that it uses, if any (i.e., its 
dependents). 

 

If you want to see all levels, choose Add All Precedents and Add All Dependents: 
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If you want to add or remove one branch at a time, click the green arrows on the sides of the 
blocks. Alternatively, if you want to remove one branch, select the block and choose Delete 
Precedents or Delete Dependents.   

To set a different item as the main item in the diagram, select it and choose Set Block as Main. 
This serves the same purpose as changing the selected block in the Dependency Viewer. 

Use the commands in the Options group of the ribbon's Home tab to specify how the diagram 
will be constructed: 

• Select Reuse Items to show each item only once in the diagram. For example, if you are 
viewing a URD that is used by two blocks in the same diagram and you choose Add All 
Precedents, the Reuse Items command will affect the display as shown next: 



Chapter 19: Resources 

1328 https://www.reliasoft.com/weibull 

 

 

This command must be selected before the diagram is created, or you must clear the 
current diagram to apply it. 

• Use the Show Blocks in RBDs/FTs and Show URDs commands to determine whether blocks 
and/or URDs are shown as intermediate steps between resources and the analyses in which 
they are used. 

• Select Show Item ID to display the internal ID assigned to each resource, block and/or 
diagram. These IDs can be used to differentiate among items that share the same name. 

The Diagram tab of the ribbon offers zoom options and printing options, as well as the ability to 
copy the diagram or to export it as a graphics file. 

Batch Properties Editor 
The Batch Properties Editor is designed to support batch editing of most types of local 
resources in the current project. In BlockSim, it also allows you to edit the blocks used in the 
diagrams. It enables you to edit the properties in a convenient grid, rather than opening the 
properties window for each individual resource/block. This utility is available for all desktop 
applications except MPC. 

To open the Batch Properties Editor, choose Home > ReliaSoft > Batch Properties Editor. 
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To use the utility, choose the type of resource or diagram that you want to work with in the 
navigation panel on the left side of the window. The right side of the window shows the 
resources or blocks you can edit. For information on configuring the table and limiting the items 
shown, refer to the Configuring Columns and Finding and Filtering Records topics. 

Tip: If you change the information in one column, it may affect the information required in 
another column. For example, if you are editing a model and you change the Model Type 
column from "Weibull-2" to "Weibull-3," then the Parameter 3 column will change from "N/A" 
to requiring a numerical input for the third parameter for the Weibull distribution (i.e., gamma). 

The changes you make in the Batch Properties Editor will be saved when you close the window. 
You can also choose Home > Display > Refresh to commit your changes immediately and 
refresh the Batch Properties Editor to display the most current information, including recent 
changes by other users. 

 

Note the following: 

• Gray Background. If the property does not apply to the corresponding resource or block, 
"N/A" will appear in the column and the cell will have a gray background. Properties that 
cannot be edited via the Batch Properties Editor, such as the model category, will also have 
a gray background. 

• Required Properties. Depending on the type of item you are editing, certain properties may 
be required (e.g., if you are editing a model using a 2-parameter distribution, both 
parameters must be populated). In these cases, you can edit the properties, but you cannot 
delete them. This also means that the Cut command will function as a Copy command for 
these cells. 

• Published Models. Models created by publishing results from an analysis in a ReliaSoft 
application cannot be edited in the Batch Properties Editor. To edit a model that was 
published from an analysis, you must return to the original data source, make the necessary 
changes, recalculate and republish the model. 

• Model Parameters. Since the required parameters for a model will vary depending on the 
model type, the way you use the parameter columns in the Batch Properties Editor will 
vary. The parameter columns in the Batch Properties Editor for each model type are 
presented in the table shown next. 
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SPREADSHEET EDITOR 

You can choose the Spreadsheet Editor command on the ribbon to open the Spreadsheet 
Editor, which displays the resources or blocks in a spreadsheet-based view. This enables you to 
use the capabilities inherent in a spreadsheet (e.g., batch copying, formulas, etc.) to make 
editing multiple items easier. When you are finished editing, choose Close > OK to save your 
changes and close the Spreadsheet Editor or Close > Cancel to close the Spreadsheet Editor 
without saving your changes. 

EXPORTING INFORMATION FROM THE BATCH PROPERTIES EDITOR 

To print the contents of the Batch Properties Editor, choose Administration > Output > Print 
command on the ribbon. 

 

To send the contents of the Batch Properties Editor to Excel, or to a built-in ReliaSoft Workbook 
or spreadsheet if that's available in the current application, choose Administration > Output > 
Transfer Report. 
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You can send either the current item (i.e., the table for the currently displayed page) or the full 
report (i.e., the tables for all pages in the Batch Properties Editor). 

Tip: When you need to create or edit a large number of resources, you can also use ReliaSoft 
APIs to import the data from an Excel file or other data source. For example, the 
URDExample_V10.xlsm file at C:\Users\Public\Documents\ReliaSoft\Examples10\API enables 
you to quickly create/update multiple URDs with some basic properties (models and corrective 
tasks). If you have the necessary software coding experience, you can expand this tool or create 
your own custom applications to meet specific needs. 

http://reliawiki.org/index.php/ReliaSoft_API_Reference
http://reliawiki.org/index.php/ReliaSoft_API_Reference
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Chapter 20: Project Planner 
The Project Planner provides extensive project planning and management capabilities, including 
the ability to create timelines, evaluate progress, track resource usage and estimate costs. Any 
project in a ReliaSoft desktop application  can be associated with a project plan. 

The Project Planner allows you to create, edit or view the plan in any ReliaSoft desktop 
application except MPC. If the SEP web portal has been implemented for an enterprise 
database, you can also access a streamlined view of the plan from any web-enabled device. 

What's Changed? Starting in Version 2020, the Project Planner is disabled by default. You can 
enable it for the current database via the Other Settings page of the Database Settings window. 

Creating a Project Plan 
If the Project Planner is enabled for the database, each project in the database can have a 
project plan. To view the plan from within an open project, choose Project > Management > 
Project Planner. (In a secure database, any user with "read" access to the project will be able to 
view the plan and update any actions that are assigned to them. However, only users with the 
"Create/edit project plans" permission will be able to create or edit the plan.) 

 

A blank plan will be created automatically the first time you open the Project Planner in a given 
project. By default, the project plan shows a sample starting gate, which records the date you 
opened the project plan for the first time. You can edit the sample gate and start building the 
plan from there. 

IMPORTING OR STARTING AGAIN FROM A BLANK PLAN 

Alternatively, you can start again from a blank plan or import an existing project plan from 
another project. In the Project Planner, choose Project Planner > Plan > Create Project Plan. (In 
a secure database, this command is available only to users with the “Create/edit project plans” 
permission.) 

 

Then choose one of the following options. In both cases, you will need to enter the date the 
plan will begin in the Set Start Date field at the bottom of the window. 
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• Choose Blank to start again from a blank plan. This will delete all of the current gates (there 
is no undo for delete). It will also remove any actions that are assigned to the plan. The 
action resources will remain in the database unless/until an authorized user deletes them 
from the database via My Portal, Resource Manager or Actions Explorer. 

OR 

• Choose Import from another project to import an existing plan. You can import from 
another project in the current database or from any other existing standard or enterprise 
database. 

Choose a source database and source project for the import. The Plan Preview area shows 
the gates and actions (if any) in the project that is currently selected. By default, the import 
includes both gates and actions. If you want to import gates only, clear the Include actions 
check box at the bottom of the window. 

Tip: If you want to use any of the Design for Reliability (DFR) project planning "starter" 
templates that were installed with XFMEA/RCM++/RBI Version 9, you can either import directly 
from one of your own projects (converted to Version 2020), or use the 
"Project_Planner_Templates_Rev1" database (choose File > Help > Open Examples Folder then 
open the file in the "Project Planner" folder). To preserve the integrity of this database, a copy 
will be created. 

Project Plan Hierarchy 
In the Project Planner, the plan consists of gates arranged in a tree-based hierarchy to 
represent the different phases of a process. You can also include action resources that 
represent specific assignments that need to be performed. For example, the configuration 
below shows a plan with five top-level gates (Concept Phase, Design Phase, etc.), where each 
gate has its own sub-gates and actions. 
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Certain properties of higher-level gates (e.g., status and dates) are determined by the 
properties of their dependent gates and actions. For example, the "Concept Phase" above has 
two direct dependents. If these are marked as complete, then "Concept Phase" is automatically 
marked complete. (See Gates in the Project Plan for details on how gates inherit their 
properties.) 

In this way, the planner makes it easy for you to monitor how the progress of individual 
activities relates to the completion of the entire process. 

PROJECT PLANNER COLUMNS 

To hide or display Project Planner columns, right-click the column headings then click 
Customize Columns. (You can also change the column order by dragging and dropping column 
headings into the desired positions.) These settings are stored per computer/username. Any 
project that you open on this computer will have the same columns displayed, but other users 
may have different display preferences. 

• General columns display graphics/text to summarize the status, as well as the priority level 
and percent completion. 

• Planned Timeline columns display information about the original plan, including planned 
start/due dates and resource usage. You can also display the percentage of the budget that 
is allocated to different project planning resources (i.e., teams, facilities and materials). 

• Expected Timeline columns display expected start/completion dates given any delays that 
may have occurred for prior activities, as well as estimates of the costs/man hours to date. 
(See Project Planner Timelines.) 

• Actual Timeline columns display actual start/completion dates, as well as the costs/man 
hours that were used for completed gates/actions. 
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• Delta Values columns compare two different values, such as the difference between an 
action's actual and planned costs. 

• Relevant Metrics display values for up to three selected metrics. (See Using Metrics in 
Project Planner Gates.) 

• Notes display other applicable information, including descriptions, completion notes and 
whether an attached file exists. 

Project Planner Timelines 
For gates in the Project Planner, and for any action resource that is included in a project plan, 
three different timelines are used to track progress: 

• The Planned timeline consists of the originally planned start/completion dates. 

• The Actual timeline records when a gate or action has actually started or completed. 

• The Expected timeline shows the start/completion dates that are now expected given the 
current situation. For project plans that use precedents, the expected dates for an activity 
automatically shift in response to delays in prior activities. 

All of these timelines can be shown in gate/action properties and in the Project Planner 
hierarchy columns. The expected dates are used to determine the status (e.g., past start date, 
past due, etc.) and are also shown on the summary panel. 

PLANNED DATES 

For actions and for gates with no specified precedent, the planned start/completion dates are 
entered directly in the Gate Properties window. 

For gates with precedents, the planned start date is automatically set to the working day 
following the precedent's due date (i.e., planned completion date). By using precedents in your 
plan, you guarantee that there will be no gaps between one gate's due date and the next one's 
start date. 

In addition, the software uses the following rules to make sure a gate's planned timeline is 
consistent with that of its dependent gates and actions: 

• If a gate's planned start date is changed (e.g., because of changes to a prior gate's planned 
duration), the planned dates of all dependents will be shifted in the same way. 

• You cannot change a dependent's planned start date to precede that of its parent gate. 
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• If a dependent's due date is changed so that it comes after its parent gate's due date, the 
parent gate's due date will be changed to match it. 

ACTUAL DATES 

Actual start/completion dates are entered directly for actions and for gates with no 
dependents. For gates that have dependents: 

• The parent gate's actual start date is automatically set to match the earliest actual start 
date of its dependents. 

• Once all the dependents have completion dates, the latest of those dates is set as the 
parent gate's actual completion. 

EXPECTED DATES 

By default, expected start/completion dates are equal to the planned dates. However, if the 
gate/action is part of a plan that uses precedents, the two timelines can differ. 

Specifically, when precedents are used, the expected dates will automatically shift in response 
to recorded delays in prior gates (while the planned dates remain unchanged). For example, if 
Gate A is the precedent of Gate B, and Gate A completes two days late, then the expected 
dates for Gate B will be its planned dates + two days. The same will apply to any other gates 
with precedents that trace back to Gate A. 

As an example, consider the following Gantt chart for a plan that has not yet started. The 
planned and expected timelines (shown in gray and black, respectively) are identical at first. 

 

However, if Gate A completes late (shown in red), the expected timeline shifts for the 
remaining gates. (The overall plan bars at the top also indicate that the expected duration for 
the entire plan has now increased by two days.) 



Chapter 20: Project Planner 

1338 https://www.reliasoft.com/weibull 

 

 

Project Planner Gates 
Each gate in the Project Planner has its own properties and a status that is determined based 
on its expected start/completion dates. Additional information about progress and resource 
usage is available in the summary panel. 

To view the properties of a gate, double-click it, or select it and choose Project Planner > Gate > 
Edit Gate. 

 

GATE PROPERTIES 

• The Gate fields provide general information about the gate, including its Name, Description 
and: 

• Deliverables are what will be produced and delivered as a result of completing the 
gate. 

• Priority is a ranking of the gate's importance ("Low," "High," etc.). 

• The Precedent Gate field identifies the gate that must be completed before the current 
gate can start, if any. If you choose to use precedents in a project plan: 

• The precedent gate must be on the same level in the hierarchy as the current gate. (If 
the Use Precedence option is selected, the precedent will be suggested automatically 
for each new gate you create but you can change it manually if desired.) 

• When a gate has a precedent, its planned start date will be automatically set to the 
working day after the precedent's due date. In addition, delays in the precedent will 
automatically shift the expected timeline for future gates. 

• The Planned Timeline consists of the originally planned start/completion dates. 
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• The Expected Timeline shows the start/completion dates that are now expected given the 
current situation. For project plans that use precedents, the expected dates for an activity 
automatically shift in response to delays in prior activities. (See Project Planner Timelines.) 

• The Actual Timeline records when a gate or action has actually started or completed. If the 
gate has dependents, these dates are automatically inherited in the following way: 

• The actual start date is the earliest actual start date from the dependents. 

• The actual completion date is the latest actual completion date from the dependents. 

• The Relevant Metrics fields let you display up to three relevant metrics in the gate. The 
Push to Metrics fields let you "push" the gate's percent completed and actual vs. planned 
resource usage to metrics so they can be tracked and displayed in other locations. (See 
Using Metrics in Project Planner Gates.) 

• The History fields display information about when the gate was created and last modified. 
If the history log has been activated at the project level, you can click the View Item History 
icon to open the Record History Log for the item. 

• Watch allows each individual user to subscribe to receive an alert (via e-mail, SMS text 
message or portal message) when the gate is changed. (See Subscribing to a Watch.) 

• Gate Monitors allows you to specify individual users and/or groups of users who will 
receive alerts for the gate, regardless of whether they have personally subscribed to a 
watch. (See Action and Gate Monitors.) 

GATE STATUS 

The gate status (which is displayed in the summary panel and in the status bar) is determined 
based on the same logic used for action statuses, which takes into account the expected 
start/completion date and any actual dates. For example, a gate's status is "Past Start Date" if it 
hasn't started and it's too late to start by the expected date, while "Past Due" means it is too 
late to complete on time. 

 

Actions in Project Plans 
You can add actions to gates in the Project Planner in order to track specific assignments that 
need to be performed as part of specific phases of the plan. These are the same action 
resources that can be included in My Portal and SEP web portal, as well as FMEAs or Test Plans 
in XFMEA/RCM++/RBI. 
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When you add an action to a gate in the Project Planner, the software will: 

• Use timelines in the action that automatically shift in response to delays in prior activities, 
which will affect how the action's status is determined. 

• Display the action's plan summary in the Action properties window. 

• Use the action's status, percent complete and resources to "roll up" to the gate it is 
assigned to. 

ADDING ACTIONS TO THE PLAN 

With a gate selected in the Project Planner, choose Project Planner > Action > Add Action. (In a 
secure database, this is only available to users with the "Create/edit project plans" permission.) 

 

• Add Action creates a new action resource. 

• Reuse Action Resources allows you to select existing action(s) from the project that a) are 
not already used in the current plan and b) have dates that fit within the current gate. 
Specifically, the action’s start date can’t be before or more than a year after the gate’s start 
date. (See Select Resource window.) 

• Reuse FMEA Actions allows you to select one or more XFMEA/RCM++/RBI system hierarchy 
items from the current project that have FMEAs. You can then select to use existing 
action(s) from those particular FMEAs in the project plan. 

Project Plan Summary Panel 
The project plan summary panel displays information about start/completion dates, status, 
progress and resource usage for an entire project plan, and for individual gates and actions. 

The summary panel is accessible from multiple locations across the ReliaSoft desktop 
application: 
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• From the Project Planner, you can select a gate or action in the hierarchy to view its 
summary, or you can select the project at the top of the hierarchy to view a summary of 
the entire plan. 

• The gate/action properties window shows the summary for that gate/action. 

• The Plan Summary Page in My Portal displays a summary of the entire plan for the project 
that currently has focus. 

• These summaries are also displayed in the SEP web portal, if it is implemented for an 
enterprise database. 

 

In most cases, this shows the current date. If 
you are working in the Project Planner and 
you want to see what the statuses would be 
on a different date, click the green "play" 
arrow ( ) and then select a different date 
from the calendar. When you’re ready to 
return to the current date, click the green 
"pause" bars ( ). 

 

This bar displays the name of the project, 
gate or action that the summary applies to, 
followed by: 

• The EXPECTED start date and 
completion date. (This will be the 
same as the planned dates unless a 
prior delay has caused the expected 
dates to shift.) 

• The ACTUAL start date and 
completion date (if the action is in 
progress or complete). 

• The current status. (See Action 
Timeline and Status.) 
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For actions, the progress bar shows the 
percentage entered by the user. For gates, it 
shows the percentage of the total duration 
of dependent actions/gates that is complete. 
For example, if Action 1 (duration = 3 days) is 
complete and Action 2 (duration = 1 day) is 
incomplete, the progress is 75%. 

 

For resource usage, the black bars show the 
planned man hours and costs. The colored 
bars show either the expected usage to date 
(estimated based on the number of days in 
progress), or the actual usage if complete. 
(See Costs and Man Hours.)   

• Yellow = In progress and usage to 
date is still within plan 

• Orange = In progress and usage to 
date has exceeded plan 

• Green = Complete and actual usage 
was within plan 

• Red = Complete and actual usage 
exceeded plan 

 

The pie chart will be visible only for projects 
or gates that have at least one action 
assigned (either directly or via dependent 
gates). 

• Not Started = Actions that have not 
started and can complete on time 

• In Progress = Actions that are in 
progress and can complete on time 

• Completed = Actions that have a 
completion date 

• Past Due = Actions that can no 
longer complete on time 
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Check Utilization 
The Check Utilization window lets you examine the utilizations for individual users and facilities 
across one or more actions. It displays the total utilization for each resource on each specific 
date, so you can easily identify dates when the resource is over-utilized and make any 
adjustments that may be needed. 

• To view utilizations for a specific action, open the action and choose Tools > Check 
Utilization. 

• To view utilizations across multiple actions, open the Project Planner and choose Project 
Planner > Tools > Check Utilization. 

  

If you open the utility from the Project Planner ribbon, there are two options. By default, it 
shows Only actions in this plan. Alternatively, you can choose to see utilizations from All 
actions in the project (even if they are not used in the plan). 

Regardless of whether you’re checking a single action or the entire project plan, the utility 
shows All resource utilizations by default. Alternatively, you can choose to see Only utilizations 
over 100%. 

Over-utilized resources (i.e., those with a utilization that exceeds 100%) are shown in red. 

Double-click a resource to view its total utilization for each specific date, as well as the action(s) 
that use the resource on each date. For example, according to the window shown next, Joe 
Reliability's highest utilization for a single day exceeds 100%. By double-clicking his name, you 
can see that he is assigned to two actions that overlap on 1/7/2019, and as a result his 
combined utilization for that day is 105%. 
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Project Planner Gantt View 
The Project Planner also includes a Gantt chart that makes it easy to visualize the timelines in 
your project and examine how different planning resources are utilized over time. 

To access this view, click Gantt at the bottom of the Project Planner. 

 

• Use the Gantt Type drop-down list on the control panel to specify what to display: 

• Project Plan shows timelines for gates and actions. 

• Personnel Utilization and Facility Utilization show the utilizations for the person 
responsible, team and/or facilities. (See Project Planning Resources.) 

• In the Gantt Display area, select the part of the plan you want to view in the Filter drop-
down list. For example you could view a specific gate (and its dependents) or a specific user 
(and all their utilizations). If you want to change the widths of columns that contain dates, 
use the Fit Mode. 

• In the Date Selections area: 

• Select to view the entire plan or focus only on a specific date range. 

• Specify whether each column represents a specific number of Days, or Other 
increments such as weeks, months, quarters, etc. 

• In the Date Display area: 
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• If each column represents a single day, select whether to display Non-Working Days. If 
displayed, those columns will have a gray background. (See Working Days/Holidays.) 

• Use Show Planned, Show Expected and Show Actual to specify which timeline bars will 
be displayed. 

• To specify the colors that will be used in both the project plan Gantt chart and the 
timeline plot, choose View > Settings > Set Colors. (See Set Colors for Project 
Planner.) 

• For the planned and actual timeline bars in the project plan chart, you can also choose 
whether to Show Percent Completed. 

• If you are using one of the utilization charts and the date columns each represent more 
than a single day, use the Calculate Utilization As area to specify how to calculate the 
utilization. This can be: 

• The Max (highest) daily utilization among all days in the interval. For example, if the 
interval is 3 days and the utilizations were 15%, 0% and 10%, the max will be 15%. 

• The Average across only the days in the interval that have utilizations. For example, if 
the interval is 5 days but the resource was only utilized on 3 of those days, the average 
will be the total utilization/3 days. 

• The Overall Average across all working days in the interval. For example, if the interval 
is 5 working days, the overall average will be the total utilization/5 days even if the 
resource was not utilized every day. 

Project Planner Plot View 
The Project Planner includes a plot view that makes it easy to visualize the timelines in your 
project. 

To access this view, click Plot at the bottom of the Project Planner. 

 

• Use the Filter Options area to select whether to filter the data by Gate or by using a Date 
range. You can also choose to view data for Top Level Gates only. 

• In the Display Options area: 

• Show Planned, Show Expected and Show Actual determine which timelines will be 
shown in the plot. 
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• To specify the colors that will be used in both the project plan Gantt chart and the 
plot, choose View > Settings > Set Colors. (See Set Colors for Project Planner.) 

• Display Actions shows the dependent actions for each gate. 

• Show Project Item shows the “project” gate at the top of the hierarchy. 

• Show First Gate on Top determines whether the gate with the earliest start date will 
show at the top or bottom of the chart. 

• Auto Refresh refreshes the plot automatically whenever changes have been made. If 
this option is cleared, you can click the Redraw Plot icon ( ) to refresh the display. 

• Keep Aspect Ratio maintains the proportional relationship between the width and 
height of the plot image. 

Set Colors 
To open the Set Colors window for the Project Planner, choose View > Settings > Set Colors. 

 

• The Gate and Action Options apply to the Gantt chart (if viewing the plan), plan hierarchy 
and plot. 

  

• The Date Display options apply only to the Gantt chart and plot. 
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• The Utilization Threshold Colors apply only when using the Gantt chart to view team or 
facility utilization. 

  

Project Planner Dashboards 
You can use the flexible Dashboard utility for presenting data from any Project Planner in the 
database. 

To access this feature, open the planner and choose Project Planner > Tools > Dashboard. 

 

As with any other dashboard, you can use the Dashboard Viewer to select any of the layouts 
that have been predefined for this type of data. In a secure database, only users with the 
"Manage dashboard layouts" permission can use the Dashboard Manager to create or edit 
layouts. 

DATA SOURCE DROP-DOWN LIST 

When you are creating a dashboard layout based on project plan data, the drop-down list at the 
top of the Data Source Panel gives the following options: 
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• Actions returns data only from actions in the current plan. 

• Gates returns data only from gates in the current plan. 

• Gates/Actions returns data from both actions and gates. 

• Facilities returns data from the facilities assigned to actions. 

• Personnel returns data from the person responsible and/or team assigned to actions. 

Each data source allows you to choose relevant fields from the record properties, summary 
panel and/or project plan hierarchy. 

Note that all of the data fields used within a particular dashboard item must come from the 
same source. For example, you can’t combine fields from the “Actions” data source and the 
"Gates" data source in the same chart. If you want to create a chart that includes both actions 
and gates, use the fields from the "Gates/Actions" data source instead. 

EXAMPLES FOR DIFFERENT FIELD TYPES 

The icon for each field indicates the data type:  text,  number or  date. There are many 
possible ways to use these fields in your own customized dashboard layouts. The following 
simple examples demonstrate basic applications for each data type. 

Example Using Counts 

This pie chart uses the Count value for a text field to show the actions in the current project 
plan broken down by status. The argument determines the slices shown in the pie. 
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Tip: If you want to see both the quantity and the percentage, choose Design > Data Labels > 
Argument, Value And Percent. 

Example Using Numbers 

This bar chart uses the Sum values for two number fields to show the top 5 most costly actions 
in the current project plan, with comparison to the planned cost. The arguments determine 
how the bars are labeled, grouped and sorted. 
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Example Using Dates 

This grid uses the Exact Date for two date fields to show a list of all actions in the current plan 
that are due in the current month. (To set the criteria that filters the records shown in the grid, 
right-click inside the chart and choose Edit Filter.) 
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Project Planner Ribbon 

PROJECT PLANNER TAB 

The Project Planner tab in the Project Planner ribbon contains the following commands. 

Project Planner 

  Refresh updates the Project Planner hierarchy, if necessary. For example, if multiple 
users are accessing the same plan simultaneously, this will update the plan to reflect any 
changes made by other users. 
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  Create Project Plan opens the Create Project Plan window so you can start again from 
a blank plan, or import an existing plan from another project. 

  Delete Entire Plan deletes every gate and removes every action from the plan. 

   Item Properties allows you to view or edit the Identifiers defined for the current plan. 
These identifiers can be used in the Analysis Explorer to explore all of the different types of 
analyses (including project plans) in the current database. 

Clipboard 

  Paste pastes the contents of the Clipboard into the level below the selected gate (or 
on the same level of the selected action). If you want to paste gates only (without sub-gates 
and actions), use the Paste Without Actions command. 

  Cut cuts the selected gate/action and any dependents to the Clipboard. You can paste 
this information into another Project Planner within the same database. 

  Copy copies the selected gate/action and any dependents to the Clipboard. To copy 
everything, use the Copy Entire Plan command. You can paste this information into 
another Project Planner within the same database. 

  Delete deletes the selected gate/action and any dependents. 

Gate 

  Add Gate 

• Add Same Level Gate adds a gate on the same level as the selected gate. 

• Add Next Level Gate adds a gate one level below the selected gate. 

• Add Gate adds a top-level gate to the end of the plan. 

• Insert Gate inserts a gate at the selected location. 

  Use Precedence, when selected, automatically sets a new gate's precedent to the prior 
gate, which allows you to take advantage of expected timelines and ensure that there are 
no gaps between gates. If you clear this option, the default precedent will be "None." 
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  Edit Gate opens the Gate Properties window. 

  Promote and  Demote moves the selected gate to the next higher or lower level in 
the plan. An item can be demoted only if there is another item on the same level and above 
the selected item that it can be demoted under. 

Action 

  Add Action 

• Add Action creates a new action resource. 

• Reuse Action Resources allows you to select existing action(s) from the project that a) 
are not already used in the current plan and b) have dates that fit within the current 
gate. Specifically, the action’s start date can’t be before or more than a year after the 
gate’s start date. (See Select Resource window.) 

• Reuse FMEA Actions allows you to select one or more XFMEA/RCM++/RBI system 
hierarchy items from the current project that have FMEAs. You can then select to use 
existing action(s) from those particular FMEAs in the project plan. 

  Edit Action opens action properties window. (See Actions in the Project Planner.) 

Tools 

  Remove Gaps in Dates automatically assigns precedents to every applicable gate. This 
ensures that there will be no gaps in the planned or expected timelines, and it allows the 
expected dates for an activity to automatically shift in response to delays in prior activities. 
(See Project Planner Timelines.) You can choose to remove gaps in the Entire Plan or just 
for the gates that fall under the selected Branch. 

  Check Utilization opens the Check Utilization window so you can examine the 
utilizations for individual users and facilities across multiple actions (e.g., is a particular user 
assigned to too many actions at the same time, or is a particular test facility already booked 
for a particular timeframe). 

  Expand All and Collapse All expands or collapses the gates in the project plan 
hierarchy. 

  Dashboard 
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• Dashboard Viewer opens the Dashboard Viewer so you can view dashboards based on 
predefined layouts. 

• Dashboard Manager opens the Dashboard Layout Manager so you can create, edit and 
delete the predefined layouts that will be available for any user to view for any project 
plan in the database. 

  Excel Import/Export 

• Export View to Excel exports the entire hierarchy and all displayed columns to an Excel 
sheet in a format that's suitable for presentation. 

• Import Hierarchy and Export Hierarchy use an Excel format that's suitable for 
recreating the plan hierarchy in another project plan using information about 
precedents, outline level, etc. 

  Copy Current View copies the currently visible contents of the plan hierarchy or Gantt 
chart to the Clipboard as a graphic that can be pasted to other applications. 

VIEW TAB 

The View tab in the Project Planner ribbon contains the following commands. 

View 

  Color Code Deltas applies highlight colors to any "Delta Values" columns for dates or 
durations that are displayed in the project plan hierarchy (e.g., the difference between the 
planned duration and the actual duration, or between the expected completion date and 
the actual completion date). Highlights are applied on a gradient from blue (ahead of 
schedule) to red (significant delay). 

  Fit All Columns automatically resizes all columns to fit their own data. 

Settings 

  Customize Columns allows you to hide or display specific columns in the plan 
hierarchy. 

  Save View and Apply View create or apply a view that stores your preferences for 
which columns to display in the plan hierarchy and which colors to use for gates, actions, 
timelines and utilizations. Each view is saved per computer/username. 
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  Set Colors allows you to select the colors to use for gates, actions, timelines and 
utilizations. 

Zoom 

  Normal Zoom sets the degree of magnification to 100% 

  Zoom In and Zoom Out increase or decrease the font size by 25% increments. 

  Custom Zoom allows you to specify the zoom percentage. 





Chapter 21: Plot Utilities 

Weibull++ 2020 User's Guide 1357 

 

Chapter 21: Plot Utilities 
Basic Plot Features 
This topic describes some basic features and capabilities that are available in most built-in plot 
utilities in ReliaSoft desktop applications (i.e., utilities where the types of plots available are 
predefined based on the analysis method and type of data you are working with). For 
information about creating your own custom charts in ReliaSoft Workbooks or Dashboards, see 
Custom Charts or Dashboard Layout Designer. 

REDRAW PLOTS 

A plot needs to be refreshed whenever its data source has been recalculated or when its inputs 
or settings have been modified. This ensures that the plot reflects the most current results. In 
most plot sheets, the control panel displays a status light that indicates whether the plot needs 
to be refreshed. A green light indicates that the data and the plot are in sync, while a red light 
indicates that the plot is out of sync with the latest analysis. 

 

You can manually update a plot to reflect any changes by clicking the Redraw Plot icon in the 
plot’s control panel. 

 

Alternatively, a plot can be refreshed automatically whenever changes have been made by 
selecting the Auto Refresh check box on the plot’s control panel. 

IDENTIFY A PLOT’S SOURCE ANALYSIS 

For most plots, the control panel displays a blue link that displays the plot’s source analysis, as 
shown in the following example for a Weibull++ plot. You can click the link to open the folio and 
view the data set. 

 

In some specialty plots (side-by-side plot, life comparison tool, etc.), you can select the source 
analysis for the plot by clicking the icon on the plot’s control panel or ribbon. 
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If the plot contains results from more than one analysis (e.g., overlay plots), the control panel 
includes a button that allows you to add or remove analyses from the plot, as shown in the 
example below for Weibull++ data sheets. In addition, you can click and drag the data sheets to 
the desired order. 

 

SHOW OR HIDE PLOT ITEMS 

When applicable, a plot may provide options for showing or hiding certain plot items such as 
data points, lines, probability scales, etc. The available options depend on the plot type and 
analysis. To view the options for the plot you are working with, choose Plot > Actions > 
Show/Hide Plot Items or right-click the plot and choose Show/Hide Items on the shortcut 
menu. 

 

Select the check box for each item you want to appear in the plot, or clear the item’s check box 
to hide the item from view. 

SCALING 

When applicable, the plot control panel may display X and Y scaling boxes that show the 
minimum and maximum values for the x- and y-axes. You can clear the check boxes and click 
inside the fields to manually edit the values, or select the check boxes to have the application 
choose the appropriate values for the range, based on the data. 
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ZOOM 

The zoom function is available for plots that allow both X and Y scales to be adjusted. To zoom 
in or out of a plot, click inside the plot, point the mouse pointer over the area of interest, and 
then rotate the mouse wheel. Press ESC to return to the original scale.   

For non-3D plots, you can also select a specific area to zoom in by holding the CTRL + SHIFT keys 
while clicking and dragging the mouse over the desired area. You can customize the color and 
line style of the zoom rectangle via the Zoom page of the Plot Setup. 

ASPECT RATIO 

Plots are automatically resized whenever you resize the plot sheets. To maintain the 
proportional relationship between the width and height of the plot image, select the Keep 
Aspect Ratio check box on the plot’s control panel (as shown in the first example below). Clear 
the check box if you wish to stretch the dimensions of the plot graphic to fill the plot sheet (as 
shown in the second example below). 
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SHOW COORDINATES 

To show the coordinates for a location on a plot, press SHIFT and click the plot (no need to hold 
down the mouse button). To stop showing the coordinates and return the pointer to its normal 
mode, click the plot again. 

To track the coordinates on a plot line, click the line. A crosshair shows the current location on 
the line. The crosshair will stay on the line and track the coordinates as you move the pointer. 

When applicable, you can add a label that displays the coordinates of a location by pressing 
CTRL + ALT and then clicking the location you want labeled. 
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ADD CUSTOM LABELS 

When applicable, you can add a custom label to a plot by pressing CTRL and then clicking the 
plot. A label named "Default" will appear in the plot. Select the label to edit the text directly in 
the plot or double-click it to open the Edit Label window, which gives you the option to select a 
font style or format. 

You can then move the label by clicking it and dragging its yellow handle to the desired location 
on the plot. (For more extensive annotations, see ReliaSoft Draw.) 

 

MOVE PLOT ITEMS 

If your plot has lines or points that are obscuring one or the other, you can move an item by 
pressing ALT and clicking the item. The Move Plot Item window will appear, giving you the 
option to move the selected item either to the front or back of the obscuring graphic. 

EXPORT OR COPY PLOT GRAPHICS 

You can save a plot graphic as a *.wmf, *.png, *.gif, or *.jpg file for use in other applications by 
clicking the Export Plot Graphic icon on the plot's control panel, or by choosing [Plot/3D Plot] > 
Actions > Export Plot Graphic if applicable. 
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In addition, you can save a plot graphic to the Clipboard by clicking the Copy Plot Graphic icon 
on the plot's control panel or by choosing [Plot/3D Plot] > Actions > Copy Plot Graphic if 
applicable. 

 

When saving a 3D plot graphic to the Clipboard, the image will be in *.bmp format. For all other 
types of plots there are three choices: If you will be pasting copied plots into any one of the 
spreadsheets built in to ReliaSoft desktop applications (e.g., ReliaSoft Workbooks or General 
Spreadsheets), choose Metafile Optimized for ReliaSoft Spreadsheet. If you will be pasting 
them into external applications, choose Bitmap or Metafile Optimized for External Use. 

EXPORT OR COPY PLOT DATA 

You can export the data from a plot to the Clipboard so that you can paste it into another 
application. The information depends on the plot type and on the application you are using. 

• In Weibull++ or BlockSim, choose Plot > Actions > Copy Plot Data. 

 

• In XFMEA, RCM++, RBI or Lambda Predict, click the Copy Plot Data icon on the plot's 
control panel. 

 

Setting Confidence Bounds 
If your analysis includes calculations for confidence bounds, you can display the bounds in the 
associated plot by clicking the Confidence Bounds link on the plot control panel or by choosing 
Plot > Confidence Bounds > Confidence Bounds. 

 

Depending on the type of data you are working with, you may be presented with different 
options for setting up the confidence bounds on the plot. (The ReliaWiki resource portal 
provides information on the background theory of confidence bounds at: 
http://www.reliawiki.org/index.php/Confidence Bounds.) 

In the Confidence Bounds Setup window, you will need to: 

1. Select which lines to show on the plot (e.g., two-sided, bottom one-sided, etc.) 

http://www.reliawiki.org/index.php/Confidence%20Bounds


Chapter 21: Plot Utilities 

Weibull++ 2020 User's Guide 1363 

 

2. Select which type of bounds to show on the plot. This may be the bounds on the time 
estimate (Type I), bounds on the reliability/unreliability estimate (Type II: Reliability); or 
when applicable, bounds on functions such as number of failures, growth potential, etc. 
(Type II: Function). 

3. Enter the percent confidence level. 

To change the level of detail at which the bounds are plotted, adjust the Resolution slider. You 
can click and drag the slider or, for fine adjustments, click the slider and then use the arrow 
keys. The number of points plotted to create the lines is displayed next to the field name. Note 
that higher resolutions will take longer to plot. 

To hide the confidence bounds, choose Plot > Confidence Bounds > Hide Confidence Bounds. 

 



Chapter 21: Plot Utilities 

1364 https://www.reliasoft.com/weibull 

 

Setting Target Markers 
When applicable, the plot control panel may display a link for Target Reliability, Target 
Unreliability, Target MTBF/FI or Target Availability. These links give you the option to display 
markers for target values on the plot. 

You can select to show a specified target value (displayed as a horizontal line), target time value 
(displayed as a vertical line), and/or insert a marker at the point where the two target values 
intersect. Below is an example for a plot that shows the target reliability. 

Click the Add  or Remove  icon to manage the list of target values to be displayed. You can 
add up to 5 sets of target values/markers to a plot. 

 

Plot Setup 
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The Plot Setup utility provides advanced settings for customizing the look of a plot to meet your 
needs and preferences. It allows you to: a) make changes and apply them to the current plot; b) 
save the changes and use them as default settings for all new plots; c) restore previously saved 
default values; or c) reset all settings to the shipped defaults. 

Tip: You can quickly set some basic default settings for all new plots created in the current 
ReliaSoft desktop application via the Plots page of the Application Setup (File > Application 
Setup). The Application Setup also allows you to set some default analysis settings that may 
affect the appearance of plots (varies depending on the ReliaSoft desktop application). 

To open the Plot Setup, click the Plot Setup icon on the plot’s control panel. 

 

Alternatively, you can double-click the item on the plot you wish to edit (e.g., points, lines, etc.) 
and the Plot Setup will open and display automatically the options associated with that item. 

To apply your changes to the current plot, click OK. To save your changes as the new defaults, 
or restore previously saved defaults, or reset to shipped defaults, click the Defaults button. (See 
Plot Defaults Window for more information.) 

What's Changed? Starting in Version 2019, many plot options that had also been available from 
the Application Setup window are now available only with the Plot Setup utility. 

IMPORTING AND EXPORTING PLOT SETTINGS 

Starting in Version 2019, you have the option to import and export plot settings to an XML file. 
This allows you to define the settings for one plot and then use them in other plots. 

• To export the current settings, click Export. 

 

• To import settings from an XML file, click Import. 

 

PLOT ELEMENTS 

The Plot Setup is divided into pages that contain related settings for particular plot elements. 
The available pages/elements will depend on the type of plot you are working with. 
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As an example, the following picture identifies some of the basic plot elements that can be 
configured via the Plot Setup. 

 

PLOT SETUP: PLOT TITLES PAGE 

The Plot Titles page allows you to define the main, header and footer titles used in the plot and 
to change the text font and color. 

Select or clear the Show check box to determine whether the title will be shown on the plot. 
Click the Set Font button next to the corresponding input box to open the Font window, which 
allows you to set the font type, style, size, color and text orientation. 

Each asterisk (*) represents the default title text. For the main title, this is defined on the Titles 
Text page of the Plot Defaults window. If you type new text in an input box, either alone or in 
addition to the asterisk, the text you type will be displayed on the plot. For example, if you add 
(Helicopter) to the Main Title field, the default main title will be displayed, followed by 
"(Helicopter)." The changes you make will be applied regardless of plot type, so the main title of 
a Failure Rate vs Time plot would then be "Failure Rate vs Time (Helicopter)" and the main title 
of a System Failures plot would be "System Failures (Helicopter)." (This assumes that you have 
not changed the default main titles from the ones shipped with the application.) 

You can use the ENTER key to add additional lines to the header title and the footer title. 
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To add an image file to the header title or footer title, click Set Image then browse for the file 
you want to include. Click Open. (You can select an image that uses one of the following 
formats: *.bmp, *.gif, *.jpg, *.jpeg, or *.ico.) The selected image appears next to the Set Image 
button. The image will also appear at the left side of the header or footer text. To remove the 
image, click Clear Image. 

PLOT SETUP: AXIS TITLES/LABELS PAGE 

The Axis Titles/Labels page allows you to define the information used with the x-axis and y-axis, 
including the titles, axis labels and the numbers displayed in the axis labels. This page is not 
available when you are working with a pie chart. 

The options on this page will vary depending on the plot style you are working with. 

• Axis Titles 

• Select or clear the Show check box to determine whether the title will be shown on the 
plot. Click the Set Font button next to the corresponding input box to open the Font 
window, which allows you to set the font type, style, size, color and orientation of the 
text. 

Each asterisk (*) represents the default title text. If you type new text in an input box, 
either alone or in addition to the asterisk, the text you type will be displayed on the plot. 
For example, if you add (Hours) to the Y-Axis Title field, the default y-Axis title will be 
displayed, followed by "(Hours)." The changes you make will be applied regardless of plot 
type, so the y-axis title of a Static Reliability Importance plot would then be "Static 
Reliability Importance (Hours)" and the y-axis title of a Throughput vs. Time plot would be 
"Throughput(t) (Hours)." (This assumes that you have not changed the default axis titles 
from the ones shipped with the application.) 

• Axis Labels 

• Axis Labels options, when selected, displays the numerical labels for the x-axis and/or 
the y-axis in the plot. 

• If available for the plot type, click the Custom Labels button next to the corresponding 
option to open the Custom Axis Labels window, which allows you to add user-defined 
numerical labels to the x-axis or y-axis of the plot. Note that values outside the plot's 
display range are accepted but will not be shown. 

Click the Set Font button next to the corresponding option to open the Font window, which 
allows you to set the font type, style, size, color and orientation of the text. 

• Numbers in Axis Labels 
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Use the options in this area to configure the display of numerical values shown on the axes. 
The available options depend on the setting of the Use Significant Figure Formatting check 
box. 

If selected: 

Use the significant figures fields to set the maximum number of digits that are 
displayed (e.g., the number 1.23456789 displays as 1 with 1 significant figure while it 
displays as 1.23457 with 6 significant figures). If the value is large and contains more 
significant figures than the set value, then the number is simply rounded to the nearest 
whole number. 

If not selected: 

The mathematical precision sets the number of decimal places that a number will 
display. The scientific tolerance sets the point at which the numbers will be converted 
to normalized scientific notation. For example, setting the scientific tolerance to 3 
means that all numbers with a value greater than 1,000 will be converted to normalized 
scientific notation (e.g., 1.0E +3). 

Note: When you are working with a bar chart, the Numbers in Axis Labels area will 
contain settings for only the axis representing the dependent variable. This is affected 
by the orientation of your bar chart; if you are using vertical bars, this area will contain 
settings for the y-axis, and if you are using horizontal bars, it will contain settings for 
the x-axis. It is important to be aware that the settings for one axis will not transfer to 
the other axis when you change the bar orientation. You will need to return to this 
page and reenter the settings. 

PLOT SETUP: PLOT LABELS PAGE 

The Plot Labels page allows you to customize the labels for items (e.g., bars. slices, points) 
shown in the plot as well as for custom labels used in the plot. 

The options on this page will vary depending on the plot style you are working with. All 
available options are presented below. 

• Bar Labels (available only for bar charts) 

• To display the y-axis value of each bar with the bar, select the Show Bar Labels check 
box. (You can set the bar style using the Bar Orientation field on the Bars page of the 
Plot Setup.) 
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• Show Bar Labels Even if Zero if selected, bars with a y-axis value of 0 will be shown 
with a label of "0." The number of decimal places in the label will conform to the y-axis 
math precision value specified on the Axis Titles/Labels page. 

• Point Labels (available only for line plots) 

• To display the coordinates for each point at the lower right of the point, select the 
Show Point Coordinates check box. If this option is not selected, you can still display 
the coordinates for each point in a pop-up box by pointing to the point. 

• To display the point label in the same color as the border of the point itself, select the 
Use Point Border Color check box. 

• If there are overlapping points, select the Show Point Multiplier check box to display 
the number of points to the right of the point. 

• Slice Labels (available only for pie charts) 

• To label the slices of the pie chart according to the components they represent, select 
the Show Slice Labels check box. 

• To label the slices of the pie chart with the percentage of the whole that they 
represent, select the Show Slice Size check box. 

• Custom Plot Labels allows you to control the appearance of custom plot labels. You can 
add custom labels to your plot by pressing CTRL and clicking the plot. 

• Delete Labels deletes all custom labels on the plot. 

• Reset Labels immediately resets all custom labels on the plot to use the settings 
specified via the Set Font button. This allows you to apply the settings to existing 
custom labels rather than just new labels created after changing the settings. 

• Bar Label Position (available only for bar charts) allows you to specify whether you want 
the bar labels located within the bars or outside of the bars. 

For all labels, you can click the Set Font button in the section to open the Font window, which 
allows you to set the font type, style, size and color for labels of that type. 

PLOT SETUP: LEGEND PAGE 

The Legend page allows you to customize the display of the legend on the current plot. 
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The options on this page will vary depending on the plot style you are working with. All 
available options are presented below. 

• To display the legend on the plot, select the Show Legend check box. 

• To include on the legend a color definition for each point/line/bar/slice shown in the 
plot, select the Show Plot Items check box. 

• To include lines above and below the legend and the user information, select the Show 
Legend Border check box. Use the options to the right to modify the appearance of the 
border. To change the color of the border, click the Color box to the left of the 
Thickness box. Adjust the thickness of the border by entering a positive integer in the 
input box. Change the style of the line (e.g., solid, dashed, etc.) by clicking the Line 
Style box to the right of the Color box. 

• To display the text of the legend in the same color as the lines, points, bars and/or 
slices on the plot, select the Use Item Color check box. If not selected, the text will be 
red. 

• Show Analysis Information if selected, the legend will display information about the 
analysis shown on the plot, including the data source and/or the settings used in the 
calculation, if applicable. 

• To display the plot description (including the plot type) on the plot, select the Show 
Plot Description check box. 

• To show the user display name, company and the date and time the plot was generated 
on the plot, select the Show User Information check box. (You set the display name 
and company using the User Login and Contact Information Window.) 

• The legend area allows you to specify the amount of space used for the legend. 

• Fixed Legend Width if selected, the legend will remain the same size regardless of the 
information it contains. You can set the percentage of the canvas width that the legend 
will occupy. 

• Maximum Legend Width if selected, the legend will automatically recalculate its width 
based on the information it contains. You can set the maximum percentage of the 
canvas area that the legend will occupy. 

Click the Set Font button next to the corresponding option to open the Font window, which 
allows you to set the font type, style, size and color of the text. 
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• For bar and pie charts in BlockSim only, Color Spectrum allows you to set the color limits 
for the plot. 

• You can set both lower and upper color limits by dragging the markers on the scale 
between 0% and 100%. 

• Show all values (0-100%) in legend if selected, the legend will show the full range of 
values; if not selected, the legend will show only the values between the upper and 
lower limits that you have specified. 

The preview shows how the specified settings will appear in the legend. 

PLOT SETUP: CANVAS PAGE 

The Canvas page allows you to customize the color, style and thickness of the plot borders and 
title lines, along with the appearance of the rest of the plot sheet. 

• Plot Canvas and Area 

• Canvas Back Color allows you to choose the color for the area outside the plot (i.e., the 
area containing the titles, labels, legend, etc.). 

• Canvas Border allows you to determine if the border around the plot field will be 
displayed and, if so, to set the color. 

• Plot Area Back Color allows you to choose the color for the plot background. 

• Plot Area Border Lines allows you to hide or show each of the specified lines, as well as to 
choose a color, a thickness and a style for each. The borders referred to in this area are the 
borders of the plot area itself (i.e., the bottom border is the x-axis, etc.). 

• To show or hide a line, select or clear the associated check box. 

• To change the color of any of the lines, click the Color field. The drop-down list that 
appears allows you to choose from custom colors, web-safe colors or the colors used in 
the current Windows system settings. You can add colors to the Custom page by right-
clicking one of the color boxes in the bottom two rows. 

• You can adjust the thickness of a line by entering a positive integer in the input box. A 
value of 1 will draw the thinnest possible line and other values such as 2, 3, etc. will 
draw thicker lines. Note that the size of the thinnest possible line is dependent upon 
your screen resolution. 
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• In addition, you can change the style of each line by clicking the Line Style box to the 
right of the Thickness box. A list providing line style options (e.g., solid, dashed, etc.) 
will appear. Choose the line style you want and it will appear in the Line Style box. 

• To highlight each object (i.e., point, line, bar or slice) on the plot as you point to it, select 
the Highlight Selected Plot Item check box. When an object is active, you can click it to 
open the Plot Setup window and edit the properties specific to that object. The remaining 
options in this area are available only if this option is selected. 

• Fill Color allows you to specify a foreground color to be used on the highlighted active 
object. 

• Back Color allows you to specify a background color to be used on the highlighted 
active object. This color is not used if the selected fill style does not use a background 
color (i.e., solid or transparent fill style). 

• Fill Style allows you to select a style of hatching to be used on the highlighted active 
object. 

PLOT SETUP: GRID PAGE 

The Grid page allows you to customize the color, style and thickness of the grid lines and to set 
the number of axis divisions used. This page is not available when you are working with a pie 
chart. 

The options on this page will vary depending on the plot style you are working with. All 
available options are presented below. 

• Axis Division Lines allows you to hide or show each of the axis division lines, as well as to 
choose a color, a thickness and a style for each. 

• To show or hide a line, select or clear the associated check box. 

• To change the color of any of the grid lines, click the Color box. The drop-down that 
appears allows you to choose from custom colors, web-safe colors or the colors used in 
the current Windows system settings. You can add colors to the Custom page by right-
clicking one of the color boxes in the bottom two rows. 

• You can adjust the thickness of a grid line by entering a positive integer in the input 
box. A value of 1 will draw the thinnest possible line and other values such as 2, 3, etc. 
will draw thicker lines. Note that the size of the thinnest possible line is dependent 
upon your screen resolution. 
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• In addition, you can change the style of each line by clicking the Line Style box to the 
right of the thickness box. A list providing line style options (e.g., solid, dashed, etc.) will 
appear. Choose the line style you want and it will appear in the Line Style box. 

• Number of Axis Divisions allows you to set the number of major and minor divisions for 
each axis. 

Note: When you are working with a bar chart, the Grid page will contain settings for only the 
axis representing the dependent variable. This is affected by the orientation of your bar chart; if 
you are using vertical bars, this area will contain settings for the y-axis, and if you are using 
horizontal bars, it will contain settings for the x-axis. It is important to be aware that the 
settings for one axis will not transfer to the other axis when you change the bar orientation. 
You will need to return to this page and reenter the settings. 

PLOT SETUP: BARS PAGE 

The Bars page allows you to customize the appearance of the bars in the plot. This page is 
available only when you are working with a bar chart. 

• Bar Border Lines allows you to hide or show the border line for the bars, as well as to select 
a color, a thickness and a style for the border. 

• Bar Orientation allows you to select how you want the plot laid out. You can choose to use 
vertical bars or horizontal bars. 

PLOT SETUP: SLICES PAGE 

The Slices page allows you to customize the appearance of the slices in the plot. This page is 
available only when you are working with a pie chart or tableau plot. 

• Pie Settings 

• Rank if selected, you can specify the ranking of the slices that you want to view. For 
example, entering 5 will cause only the five largest slices to be shown in the plot. 

• Threshold if selected, you can specify a minimum size (in percentage of the whole) for 
the slices that you want to view. For example, entering 0.1 will cause only slices 
accounting for ten percent or more of the whole to be shown in the plot. 

• Show Remaining Slices as Other if selected, all remaining slices that do not meet the 
rank or threshold criterion specified will be shown in the plot as "other." This option is 
available only if you have specified a rank, a threshold or both. 
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• Other Slice Color allows you to choose the color used to represent "other" slices. This 
option is available only if you have selected the Show Remaining Slices as Other 
option. 

• Slice Border Lines allows you to hide or show the border line for the slices, as well as to 
select a color, a thickness and a style for the border. 

• Chart Type allows you to select how you want the plot laid out. You can choose to use an 
area chart (blocks), cake chart (layers) or pie chart (wedges). 

PLOT SETUP: PLOT ITEMS PAGE 

The Plot Items page allows you to specify details of the appearance of the points, lines, bars 
and/or slices on the plot. 

The options available on this page will vary depending on the plot style that you are currently 
working with. 

The following options are available for all plot styles: 

• Choose an Item to Configure allows you to choose which plot element the settings on this 
page apply to. 

• Show allows you to select whether or not the plot element you currently chose to configure 
will be shown on the plot. Depending on the plot style that you are currently working with, 
you may select to show the bars, slice, line and/or points. This option is not available for all 
plots. 

For bar charts and pie charts, the following option applies. 

• Area Fill Color and Style allows you to specify the appearance of the bar or slice 
representing the selected item. To change the color of the bar or slice, click the Color box. 
You can select a fill style from the drop-down list. 

For line plots, the following options apply: 

• Line Settings allows you to specify the appearance of the line representing the selected 
item. To change the color of the line, click the Color box. You can adjust the thickness of a 
grid line by entering a positive integer in the input box. Adjust the thickness of the line by 
entering a positive integer in the input box. Change the style of each line such as solid, 
dashed, etc., by clicking the Line Style box. 

• Point Settings 
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• Color, Shape, Size and Fill allows you to specify the appearance of the point body. To 
change the color of the point, click the Color box. You can select a point shape from the 
drop-down list, select the size of the point (with 1 being the smallest point) and select a 
fill style from the drop-down list. 

• Border Color, Thickness and Style allows you to modify the appearance of the border 
of the points. To change the color of the border, click the Color box. Adjust the 
thickness of the border by entering a positive integer in the input box. Change the style 
of each line such as solid, dashed, etc., by clicking the Line Style box. 

Certain point shapes are drawn using only the border color. These include minus, pike, plus 
and x-cross. 

PLOT SETUP: OFFSETS PAGE 

The Offsets page allows you to specify the distance of various components from the edge of the 
plot area. 

Automatically calculate positions from edges of plot sheet if selected, automatically calculates 
the offsets for maximum plot display and readability. If not selected, you can manually specify 
the offsets of the plot's left, right, top and bottom edges; the offset of the legend from the right 
edge of the plot area; and the offset of the main, x-axis, y-axis, header and footer titles. The 
offset values are set as a percentage of the canvas area. 

For your reference, the following picture shows which plot elements are affected by each of the 
offset settings. (Note that the plot is generated from BlockSim, but the settings are the same 
for all ReliaSoft desktop applications.) 
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PLOT SETUP: ZOOM PAGE 

The Zoom page allows you to customize the options used when zooming in on a plot by using 
the mouse wheel. Zooming works only for plots with scales. For more information, see Basic 
Plot Features. 

Allow Zoom if selected, allows the plot zoom feature to be used. 

• Factor use this option to set the amount of the magnification each time you use the mouse 
wheel on the plot. The lower the number, the greater the increase in the magnification. 

• Use the Border Color, Thickness and Style option to set the appearance of the zoom box. 
To change the color of the border, click the Color box to the left of the Thickness box. 
Adjust the thickness of the border by entering a positive integer in the input box. Change 
the style of the line (e.g., solid, dashed, etc.) by clicking the Line Style box to the right of the 
Color box. 

• Fill Style allows you to select a style of hatching to be used on the zoom box. 
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• Fill Color allows you to specify a foreground color to be used on the zoom box. This color is 
not used if the selected fill style does not use a background color (i.e., solid or transparent 
fill style). 

• Background color allows you to specify a background color to be used on the zoom box. 
This color is not used if the selected fill style does not use a background color (i.e., solid or 
transparent fill style). 

PLOT DEFAULTS WINDOW 

Each time you open the Plot Setup window, the changes that you make will apply only to the 
current plot unless you specify otherwise. To specify settings to be used as defaults for all 
subsequent plots or to re-apply default settings to the current plot, click the Defaults button to 
open the Plot Defaults window. 

The Plot Defaults window gives you the flexibility to set the default settings for the three main 
areas of a plot: the plot titles, the plot item settings and the general display areas. You can 
choose to separately save, load or restore the default settings of each main area or you can set 
the default settings for all areas at once. 

The Plot Defaults window consists of nine pages: 

• All Defaults page. This page controls the settings for all the other plot setup pages. When 
you click a button on this page, the effects apply to all pages. This allows you to quickly 
make changes without having to individually change each of the other pages. 

• Titles Text page. This page allows you to customize default plot titles for each plot type 
without having to view a plot of that type. For example, you can display a Failure Rate vs. 
Time plot while changing the titles for a System Failures plot. 

• Plot Items Display page. This page allows you to customize the details of the default 
appearance of the lines, points, bars and/or slices of every plot type without having to 
individually change each plot. 

• General page. This page controls the settings for the five section pages below it. When you 
click a button on this page, the effects apply to the Titles Display, Labels, Legend, Canvas 
and Grid and Offsets pages. 

• The Titles Display, Labels, Legend, Canvas and Grid and Offsets pages control the settings of 
their individual sections. When you click a button on one of these pages, the effects apply 
only to that specific section. 

Three Defaults buttons appear on every page of the Plot Defaults window. The scope of their 
effects differs slightly depending on the page you are working with. 
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• Save Defaults saves settings for use as the default settings for all subsequent plots. This will 
overwrite the previous default settings. 

• Load Defaults enters the saved default values for the settings. You can then click OK in the 
Plot Setup window to apply the default settings to the current plot. This is an easy way to 
undo changes you have made in the Plot Setup window and re-apply default settings. 

• Restore Defaults clears the saved default settings and restores the default values that are 
shipped with the application. 

The scope of the Defaults buttons' effects changes as follows: 

• For the Titles and Plot Item Display pages, these buttons save/load/restore the settings 
specified on the current page. 

• For the Titles Display, Labels, Legend, Canvas and Grid and Offsets pages, these buttons 
save/load/restore all current settings on the corresponding page(s) of the Plot Setup 
window (e.g., clicking Save Defaults on the Canvas and grid page of the Plot Defaults 
window will save the settings from the Canvas, Grid, Bars and Slices pages). 

Note: The settings affected by the Defaults buttons on the Titles Display, Labels, Legend, 
Canvas and Grid and Offsets pages include all settings relevant to the section, regardless of 
whether they are currently available or not. For example, if you have previously specified 
settings for a pie chart and are now specifying settings for a bar chart, the settings that you 
created for the pie chart will be saved as defaults when you click Save Defaults and will be 
applied to subsequent pie charts. 

• For the All Defaults and General pages, clicking these buttons is equivalent to clicking them 
on all of the subordinate pages. 

PLOT DEFAULTS WINDOW: TITLES TEXT PAGE 

The Titles Text page of the Plot Defaults window allows you to customize default plot titles for 
each plot type. 

• Titles allows you to select the plot type that you are changing the default titles for. 

• Main allows you to type the default main title for the plot. 

• X-Axis allows you to type the default title for the x-axis for the plot. 

• Y-Axis allows you to type the default title for the y-axis for the plot. 
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PLOT DEFAULTS WINDOW: PLOT ITEMS DISPLAY PAGE 

Plot Item Type allows you to select the style of plot that you want to specify default settings 
for. The settings you specify are retained in the background when you choose a new item in this 
list, so you can specify settings for each type and save all of them, if desired. 

The options on this page are identical to those on the Plot Items page of the Plot Setup window 
for the corresponding plot style. 

ReliaSoft Draw 
ReliaSoft Draw (RS Draw) is a metafile graphics editor that allows you to annotate and 
customize your plots. With RS Draw, you can insert text, draw an object, mark the coordinates 
of a particular point or paste another picture into your plot. You can also re-arrange the objects 
in your plot by selecting and moving them to the positions you desire. In addition, you can save 
the annotated plot in one of the following formats: *.rdc, *.jpg, *.gif, *.png or *.wmf. 

RS Draw is available by clicking the icon on the plot control panel. 

 

See ReliaSoft Draw Help for information on the features available in ReliaSoft Draw. If you do 
not currently have Internet access, this link will not work, but you can browse to the local copy 
of the help file by opening the Help\RSDraw\index.htm file in your ReliaSoft application 
directory. 

Overlay Plots 
Available in Weibull++ and BlockSim, overlay plots give you the ability to display results from 
multiple analyses in a single plot. This allows you to easily compare different data sets, analysis 
methods or distributions. For example, you may wish to show the reliability plots of two 
product designs in the same plot or compare a simulation-based data set with actual data 
obtained from fielded products. 

CREATING AN OVERLAY PLOT 

Before using an overlay plot, you must first analyze the data sets (or simulate the diagrams) you 
wish to include in the plot. Then to add an overlay plot to the project, choose Home > Insert > 
Overlay Plot. 

 

http://help.reliasoft.com/rsdraw_rh5/index.htm
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In the window that appears, select the data sheets/diagrams you want to include in the plot (up 
to a maximum of 20) and click OK to create the plot sheet. The plot sheet will be saved 
automatically under the Multiplots heading in the current project explorer. 

Tip: In Weibull++, you can add additional plot sheets to a folio by choosing [Life Data/Life-
Stress Data/Growth Data] > Folio Sheets > Insert Additional Plot. The additional sheets can 
function as overlay plots to display results from multiple data sheets in the current folio on a 
single plot. 

ADDING OR REMOVING ANALYSES 

To add or remove analyses from an overlay plot, click the button on the control panel, as shown 
in the example below for data sheets. 

 

If you later delete an analysis that is referenced by the plot, the plot will remain available and 
will continue to show the results of the analysis until you redraw the plot (by clicking the 
Redraw Plot icon on the control panel). 

Note that importing or exporting an overlay plot will automatically import/export the 
associated source analyses. (See Importing/Exporting Project Items or Resources.) 

AVAILABLE PLOT TYPES FOR OVERLAY PLOTS 

The available plots depend on the analysis or type of data you are working with. 

For Weibull++ 

Probability plots, contour plots and life-stress plots are available only if the data sets have 
been calculated with the same distribution. This is because the scales or axes in those types 
of plots vary for different types of distributions. 

In DOE design folios, plots that are intended to be viewed as singular plots will not be 
available for inclusion in overlay plots. These include the comparison chart, Pareto chart, 
interaction matrix, term effect plot, cube plot, residual histogram, residual autocorrelation 
plot, and Box-Cox transformation plot. In addition, only plots that are common to the 
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type(s) of design you have selected will be available in the overlay plot. If a plot type is 
unavailable for any of the included design types, it will be unavailable in the overlay plot. 

For growth data, only plots that are common to the analyses you have selected will be 
available in the overlay plot. If a plot type is unavailable for any of the included analyses, it 
will be unavailable in the overlay plot. It is possible for the selected analyses to not have 
any common plot types. 

For BlockSim 

You can compare data from analytical and simulation diagrams in the same plot, but keep 
in mind that analytical diagrams always show the reliability over time (does not account for 
repairs) while simulation diagrams always show the point reliability over time (may include 
repairs). 

Side-By-Side Plots 
Available in Weibull++, side-by-side plots give you the ability to display different plots for a 
single data set all in a single window for easy comparison. 

To add a side-by-side plot to a project, choose Home > Insert > Side-by-Side Plot. 

 

In the window that appears, select the analysis/data sheet you want to plot and click OK to 
create the plot sheet. 

To view a single plot in greater detail, double-click the plot. You can double-click the plot again 
to return to the side-by-side view. 

CHOOSING PLOTS TO DISPLAY 

The control panel provides options for selecting the type of plots to display. For most analyses, 
the Vary area will be available, which contains two options: 

• The vary Plot Types option allows you to create different plots for the same data set. For 
example, you might wish to display both the Reliability vs. Time plot and the Failure Rate vs. 
Time plot of the data set. 

• The vary Distributions or Models option allows you to compare how different distributions 
or models fit a particular data set. For example, you might wish to display a reliability plot 
for different life distributions, as shown next. 
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3D Plots 

Available in Weibull++ and for two-way sensitivity analysis in event analysis flowcharts in 
BlockSim, 3D plots give you the ability to graph functions with three variables, such as the 
reliability at a given time and stress level. In addition, Weibull++ offera the option to create 3D 
overlay plots, which are similar to regular overlay plots but displayed in 3D space. 

CREATING 3D PLOTS 

Before creating a plot, you must first analyze the data sets (or in event analysis flowcharts, you 
must first run the simulation for the two-way sensitivity analysis). 

To add 3D plots to a project, right-click the Multiplots folder in the current project explorer and 
choose the type of plot: 

 3D Plot 

 3D Overlay Plot (Weibull++ only) 



Chapter 21: Plot Utilities 

Weibull++ 2020 User's Guide 1383 

 

In both cases, the plots are automatically saved and stored in the Multiplots heading in the 
current project explorer. 

DEFINING THE X, Y AND Z AXES 

The control panel in the 3D plot folio contains basic settings for defining the X, Y and Z axes. 
(For advanced customization options, see 3D Plot Setup.) 

The Begin and End fields, as shown next, display the minimum and maximum values for the 
axes. You can click inside these fields to manually edit the values, or select the Autoscale check 
box to have the application automatically choose the appropriate values for the range. 

 

Whenever applicable, the Parameter fields will be displayed, as shown in the example above. 
Click these fields to change which parameter lies on which axis. The name of the parameter 
associated with the axis will be displayed next to that axis’s label. 

ROTATING 3D PLOTS 

The XYZ indicator shown at the lower-left of a 3D plot represents the plot’s horizontal rotation 
(azimuth) and vertical rotation (elevation) in 3D space. Any changes to a plot’s rotation are 
reflected in the XYZ indicator, helping you to visualize the plot’s orientation on the screen. 
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There are several ways to rotate or manipulate a 3D plot, using the mouse, keyboard shortcuts 
or the view cube. 

Using a Mouse and Keyboard Shortcuts 

If you want to Use a mouse Use keyboard shortcuts 

Rotate the plot or change the 
viewing angle 

Click anywhere in the plot 
area, and then press and 
hold the left mouse button 
while moving the pointer. 

Press the Up, Down, Left or 
Right arrow keys. 

Move the plot without 
changing its rotation 

Click anywhere in the plot 
area, and then press and 
hold the right mouse button 
while moving the pointer. 

Hold the SHIFT key while 
pressing the Up, Down, Left, 
or Right arrow keys. 

Zoom in or out Rotate the mouse wheel. 
Alternatively, you can choose 
3D Plot > Display > Zoom In 
or Zoom out. 

or   

Press the W or S keys. 

Automatically center the plot 
on canvas 

Choose 3D Plot > Display > 
Center on Canvas. 

 

N/A 

  

Using the View Cube 

The View Cube helps you to easily orient a 3D plot using predefined viewpoints. The cube is 
located at the lower-right of the 3D plot. 

 

The letters on the cube represent a particular viewpoint. For instance, clicking the "F" side of 
the cube orients the plot such that you are looking directly at the plot’s front side (e.g., Y and Z 
plane). 

• Front 
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• Back 

• Left 

• Right 

• Up 

• Down 

You can rotate the cube in the same way you would rotate any 3D plot (i.e., press and hold the 
left mouse button while moving the pointer anywhere on the screen; or press the Up, Down, 
Left or Right arrow keys on your keyboard). 

3D PLOT SETUP 

The 3D Plot Setup allows you to customize the look of 3D plots to meet your needs. It gives you 
full control over the settings used for individual 3D plots and the default settings for all new 3D 
plots. 

To access the 3D Plot Setup, choose 3D Plot > Actions > Plot Setup. 

 

Alternatively, you can double-click the item on the plot you wish to edit. This will automatically 
open the 3D Plot Setup and display the options associated with that item. The available options 
in the 3D Plot Setup will vary, depending on the plot type. You can move the mouse pointer 
over an option to display its definition. 
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To apply your changes to the current plot only, click OK. 

To save your changes and use them as the default setting for all new 3D plots, click the Save as 
Default button. This will overwrite the previous default settings. 

To restore the previously saved defaults, click the Load Defaults button. This is an easy way to 
undo changes you have made in the 3D Plot Setup and re-apply default settings. 

To reset all settings to the default values that were shipped with the application, click the Reset 
button. 
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Chapter 22: ReliaSoft Workbooks 
The ReliaSoft Workbook is a custom reporting tool that is built directly in to many ReliaSoft 
applications, including Weibull++ and BlockSim. It combines two reporting modules – 
Spreadsheets and Word Processing – into the same flexible interface, thereby replacing the 
Analysis Workbook and Word Report Template functionality from prior versions. 

Tip: If you convert a project from Version 10 or earlier, any Analysis Workbooks and Word 
Report Templates will be automatically converted to ReliaSoft Workbooks. 

If your organization has implemented an SEP web portal for an enterprise database, you can 
choose to publish selected ReliaSoft Workbook reports to be accessed from any web-enabled 
device. See Publishing to SEP. 

ReliaSoft Workbook Wizard 
To add a new ReliaSoft Workbook in an existing project, choose Home > Insert > ReliaSoft 
Workbook. 

 

This launches the wizard, which gives you the opportunity to assign the first associated data 
source and/or select a saved template, if desired. (Note that the examples shown here are from 
Weibull++ but similar functionality is available in BlockSim.) 

IF YOU PREFER TO START WITH A BLANK REPORT: 

Simply click OK and then click Yes when prompted to confirm that you want to create the 
report without associating a data source. (You will be able to associate data source(s) later if 
you wish.) 

IF YOU WANT TO ASSIGN THE FIRST DATA SOURCE: 

Click Select and choose one of the available analyses (i.e., a data sheet in Weibull++ or a 
diagram in BlockSim). When you return to the wizard, click OK to create the report. 

Note that you will be able to associate more data sources after the report is created, and 
change any of those assignments at any time. (See Associated Data Sources.) 
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IF YOU WANT TO USE A SAVED TEMPLATE: 

Click Spreadsheet or Word Processing. Select the Based on Existing Template check box and 
then choose a template from either the Standard tab (templates that are installed with the 
software) or the User tab (templates you have saved). Then click OK to create the report.  (See 
ReliaSoft Workbook Templates.) 

 

 

Associated Data Sources 
In ReliaSoft Workbooks in Weibull++ and BlockSim, you have the option to associate multiple 
data sources that can be used for any function that obtains data or results from an existing 
analysis. (To obtain results from a DOE analysis in Weibull++, see DOE Analysis Report.) 

When you create this type of function, you will have the option to use an index to specify which 
of the currently assigned default data sources will be used. For example, if you want to 
compare the reliability values calculated from two different analyses, you can use 
=RELIABILITY(Default1,1000) to get the result from the first default data source, and 
=RELIABILITY(Default2,1000) to get the result from the second default data source. 

Although you will be prompted to associate the first data source when you create the report, 
you can add or change associated data sources for an existing report at any time. 

ASSOCIATING DATA SOURCES 

For ReliaSoft Workbooks, the Information panel (located on the right side of the window) 
shows which analyses are currently assigned as default data sources. To have the panel always 
display, click the pushpin icon into the vertical position. 
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To add or remove analyses, choose Home > Report > Associate Data Sources or click the icon in 
the Information panel. 

 

The following picture shows the windows for Weibull++. Similar functionality is available in 
BlockSim. 
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Note that: 

• In Weibull++ you can select any data sheet from a folio that contains a life data analysis or 
a growth data analysis: 

• Life data folio 

• Life-stress data folio 

• Non-parametric LDA folio 

• Warranty analysis folio 

• Degradation analysis folios (the results shown in the report will be based on the 
analysis of the extrapolated failure/suspension times) 

• Growth data folio 

• In BlockSim, you can select any analytical diagram, simulation diagram or phase diagram. 
The function results can either be based directly on the analyzed/simulated diagram, or 
based on a model that has been fitted to the diagram. You specify this preference on the 
diagram’s control panel, using the Report folio model drop-down list on the Analysis 
Settings page. 

LINKING MULTIPLE DATA SOURCES WITH DIFFERENT TIME UNITS 

In BlockSim, function results that are time-based (e.g., downtime, time to event, etc.) will be 
returned in terms of the System Base Unit (SBU) for the database. However, in Weibull++, each 
function result is returned in the units used by its data source. If you wish to compare the 
results from multiple data sources that use different time units, there are two possible 
scenarios: 

• Convert the data in the original data source. For example, if one data set is in "hours" and 
another is in "days," you could use the Change Units feature to automatically convert the 
data in the first analysis from "hours" to "days." 

Tip: If you want to keep the original analysis unchanged, you could create a copy of the 
data sheet, then convert the duplicate data sheet to use the new units. 

• Manually adjust the functions so they return results in the same units. For example, if the 
data set is in "days" and you want the results to display the B10 life in "hours," you could 
adjust the function by adding a conversion ratio. For example, if 1 day is equivalent to 24 
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hours, you could edit the function as follows: 
=(TIMEATPF("Weibull!Week!Data1",0.1))*(24). 

ReliaSoft Workbook Templates 
In ReliaSoft Workbooks, saved templates make it easy to reuse the same report multiple times 
— in different analysis projects and with different data sets. 

Note: For DOE analyses, instead of saved templates for the entire workbook, you can use saved 
profiles in the DOE Report Generator. 

In addition to the Standard templates that are installed with the software, you can also create 
your own User templates that are saved from any existing report. Note that the templates are 
module-specific (i.e., compatible with either the spreadsheet module or the word processing 
module). 

SAVING YOUR OWN TEMPLATES 

It is easy to create a template from any ReliaSoft Workbook that is currently open. 

Select either the spreadsheet or the word processing module, then choose Document > 
Document > Save Template. 

 

You can name and store the custom templates however you wish. To share a template with 
other users, you can simply send them a copy of the file, or you can save the file in a shared 
network location that multiple users can access. 

USING A TEMPLATE 

You can select a template when you create a new ReliaSoft Workbook. (See ReliaSoft Workbook 
Wizard.) 

Alternatively, you can use the steps below to apply or change the template for an existing 
workbook at any time. 

IMPORTANT: This will replace any existing content in the current module, and the change can’t 
be undone. 

1. Select either the spreadsheet or word processing module and then choose Document > 
Document > Open Template. 
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2. Select a template from either tab then click OK to apply the template to the new or existing 
report. 

• The Standard tab displays the templates that are installed with the software and stored 
in the applicable sub-folder under C:\Users\Public\Documents\ReliaSoft\Templates. 

• The User tab displays custom templates that were saved from an existing report. These 
can be stored in any location that is convenient for you. If the custom template you 
need is not displayed, click the Open icon to browse for the desired template and add it 
to the list. 

 

Spreadsheet Module 
The spreadsheet module in ReliaSoft Workbooks provides functionality similar to Microsoft 
Excel (with built-in functions and complete in-cell formula support), and it can be used to 
integrate data and/or results from multiple analyses at the same time. 

SEND TO EXCEL 

To export all sheets in the spreadsheet module to a Microsoft Excel file, choose Home > Report 
> Send to Excel. 

 

INSERTING FUNCTIONS 

• To build and insert functions that utilize a referenced analysis (data source), see Function 
Wizard - Data Sources. 
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• To add math, date, logic and other functions, see Function Wizard - Formulas. 

SHOWING FORMULAS 

To display the formulas instead of the calculated results in the worksheet cells, choose 
Formulas > Formula Auditing > Show Formulas. 

  

You can toggle the formula display on and off. 

  

RECALCULATE FORMULAS 

By default, the spreadsheet automatically recalculates all formulas whenever you open the 
workbook or when the cells that a formula depends on have changed. However, if your 
spreadsheet contains a large number of formulas, the recalculation process may take more 
time and every change may require you to wait several seconds or minutes for the application 
to recalculate all values. In this case, you can control when calculation occurs by changing the 
setting to manual calculations. 

To use manual calculations, choose Formulas > Calculation > Calculation Options, and then 
choose the Manual option. To change the settings back to automatic calculations, choose the 
Automatic option. 

 

To recalculate all formulas when in Manual mode, choose Formulas > Calculate > Calculate 
Now. 

  

The Calculate Now command can also be used to refresh the spreadsheet. A spreadsheet needs 
to be refreshed whenever its referenced data source(s) has been recalculated. This ensures that 
the spreadsheet reflects the most current results. 
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ADDING CUSTOM CHARTS 

To create your own custom chart, first select the cells that contain the relevant data, then go to 
Document > Charts and choose a chart type and style. (See Custom Charts in ReliaSoft 
Workbooks.) 

DEFINING NAMES 

To create variable names that reference specific spreadsheet cells, see Defined Names. 

Word Processing Module 
The word processing module in ReliaSoft Workbooks offers custom reporting functionality that 
is similar to a Microsoft Word document. You may prefer to use this tool if you want to have a 
more polished, professional looking report. 

This module has two tabs located at the bottom of the window: Design and Review. Use the 
Design tab to add text, functions and plot holders. Use the Review tab to see the results before 
you generate the final report. 

To export the report to Microsoft Word, choose Send to Word. 

  

USING THE FUNCTION WIZARD 

To use the Function Wizard to build and insert functions that utilize a referenced analysis (data 
source), choose Home > Report > Function Wizard. (See Function Wizard - Data Sources.) 

USING THE PLOT WIZARD 

To use the Plot Wizard to generate a variety of plots based on a referenced analysis, choose 
Home > Report > Plot Wizard. These are the same types of plots that are generated in an 
analysis folio or diagram plot sheets. (See Plot Wizard.) 

USING SPREADSHEET REFERENCES 

To reference cells from the spreadsheet module (within the same workbook), choose Home > 
Report > Spreadsheet Reference and select the desired cells. The link between the word 
processing and spreadsheet modules is dynamic; when data in the spreadsheet is changed, the 
word processing module is automatically updated. (See Spreadsheet References.) 
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Formulas and Functions 

FUNCTION WIZARD - DATA SOURCES 

In both the spreadsheet module and word processing module for ReliaSoft Workbooks in 
Weibull++ and BlockSim, you can build functions that return results based on an analyzed folio 
or diagram.   

Note: To insert math, date, logic and other functions into the spreadsheet module of a ReliaSoft 
Workbook, see Function Wizard - Formulas. 

Using the Function Wizard 

To open the Function Wizard in ReliaSoft Workbooks, choose Home > Report > Function 
Wizard. 

 

Select a function from the navigation panel and enter any required inputs. The following picture 
shows the most complex configuration as an example. After entering the inputs, click Insert to 
place the function into the report at the current cursor location. You can move and/or modify 
the function expression after it has been inserted. 
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For spreadsheet functions: 

• The bracketed parameters indicate that the input is optional. In the example above, the 
Add Time and Confidence Level parameters are optional. 

• You can use cell references as inputs. For example, instead of entering 1000 for a time 
input, you could specify to use whatever time is currently entered into cell A10, using either 
the relative reference (A10) or the absolute reference ($A$10). (See Cell References.) 

• You can use variable names as inputs. (See Defined Names.) 

• You can type the function expressions directly in the cell once you are familiar with the 
syntax. For more information, see Data Entry Tips for Functions. 

For the word processing module: 

• The brackets are part of the function field and are not optional. 

• The functions will not return any results until you either switch to the Review tab or 
generate the report in Microsoft Word. 

Selecting a Data Source (if Applicable) 

There are two ways to specify the data source: 

• Use the Data Source Name (spreadsheets module only): This approach will return results 
based on a specific data sheet or diagram. 

In the Function Wizard, clear the Use Default check box and click the Select button to 
choose the data source, as shown next. In this example, the function will return results 
based on the data sheet called "Data1" in the Weibull++ life data folio called "Folio1." 

 

• Use a Data Source Index (spreadsheet and word processing modules): This approach allows 
you to use the report as a template and return results based on a given data set. 

First, you must add data sources to the ReliaSoft Workbook (see Associated Data Sources). 
Then, in the Function Wizard, click the Data Source Index drop-down list and choose the 
index number of the desired data source. (In spreadsheets, select the Use Default check 
box to access the Data Source Index drop-down list.) 
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FUNCTION WIZARD - FORMULAS 

In the spreadsheet module for ReliaSoft Workbooks in Weibull++ and BlockSim, you can insert 
functions that perform math, date, logic and other operations. 

Using the Function Library 

The quickest way to add a function is to select it from the appropriate function category drop-
down list, then select the cells of interest (hold down the CTRL key to select nonconsecutive 
cells) and press ENTER. You can move and/or modify the function expression after it has been 
inserted. 

For example, to calculate the average reliability for the following units, you would choose 
Formulas > Function Library > AutoSum > Average. Select cells B3 through B9 and press ENTER. 
Note that the cell references can be relative (B3:B9) or absolute ($B$3:$B$9). (See Referencing 
a Cell.) 
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Using the Function Wizard 

To use the Function Wizard, choose Formulas > Function Library > Insert Function. 

 

Select a function from the drop-down list and click OK. Then in the Function Argument window, 
enter the input by either selecting the cells in the sheet or typing them directly into the 
appropriate field. For information relating to entering text as an input, cell references, and 
working with date and time functions, see Data Entry Tips for Functions. 

For example, to exclude the value from unit 4 (failure due to operator error) from the average, 
you would select cells B3 through B5 for Number 1, and B7 through B9 for Number 2. 

 

DATA ENTRY TIPS FOR FUNCTIONS 

This topic provides some data entry tips for using spreadsheet functions in ReliaSoft Workbooks 
and general spreadsheets. If you create the function using the Function Wizard, most of the 
syntax and formatting issues will be handled automatically. However, you have the option to 
create or modify function expressions directly in spreadsheet cells. 

Note: For DOE design folios, you can disregard any tips related to data source functions (i.e., 
functions that obtain data or results from a specific data sheet or diagram). For that type of 
analysis, you can use the DOE Analysis Reports feature to obtain results from a design, multiple 
linear regression or one-way ANOVA folio, or any of the measurement systems analysis folios. 
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Case Sensitivity 

The functions are not case sensitive. 

Entering Text as an Input 

When entering text as an input to a function, you must enclose it in quotation marks. This 
includes situations where you need to specify the data source – 
DISTR("Weibull!Folio1!Data1") – and situations where you need enter a time or 
date value in one of the accepted text formats  – DAY("22-Aug-2020"). 

Regional Settings 

If your regional settings use a comma as the decimal separator, you must use a semicolon to 
separate function arguments (e.g., =RELIABILITY("Weibull!Folio1!Data1";A4)). 

Referencing a Cell in the Same Sheet 

If you want to use another cell in the same sheet, enter the cell reference with a letter to 
identify the column and a number to identify the row. The cell references can be relative (e.g., 
B2) or absolute (e.g., $B$2). 

• A relative reference points to a cell based on its relative position to the current cell (e.g., 
B2). When the cell containing the reference is copied, the reference is adjusted to point to 
a new cell with the same relative offset as the original cell. 

• An absolute reference points to a cell at an exact location. Absolute references are 
designated by placing a dollar sign ($) in front of the row and/or column that is to be 
absolute. For instance, $B$2 is an absolute reference that points to the cell located in 
Column B, Row 2 regardless of the position of the cell containing the reference. 

For example, if you want to obtain the probability of failure for the time that has been entered 
in cell B2, the function could be either =PROBFAIL(B2) or =PROBFAIL($B$2). You can 
type the cell location directly into the field or click the Function Wizard’s Insert Workbook 
Reference icon to insert the reference to the cell currently selected in the sheet. If you want to 
insert an absolute reference, press CTRL while you click the icon. 

 

Another option is to use the Defined Names tool to assign a name to the cell and use the name 
in all of the function expressions that require that input. (See Defined Names.) 
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Referencing a Cell in a Different Sheet 

To reference a cell in a different sheet from the one in which the formula is entered, use an 
exclamation mark (!) after the sheet name. For instance, =Sheet1!$B$2 is a reference to the 
cell located in Column B, Row 2 in Sheet 1. When referencing a cell in a different sheet from the 
one in which the formula is entered, the reference must be absolute. If the reference is not 
absolute, the calculations will not be carried out properly. 

You can only reference sheets in the same workbook. 

Referencing a Cell in a Data Source 

Some functions (e.g., DATAENTRY and FMATRIX) require you to reference a particular cell in a 
data source. This must be defined differently than references to a cell in a spreadsheet. For 
data source cell references, you must identify first the row and then the column, and use a 
number rather than a letter to represent the column (e.g., A=1, B=2, C=3 and so on). For 
example: 

• =DATAENTRY(Default1,2,1) returns the value that was entered into cell A2 in the 
Weibull++ folio that is the data source for this function. 

• =FMATRIX(Default1,2,1) returns the value from the second row in the first column 
of the Fisher variance/covariance matrix that was calculated for that data source. 

Creating Composite Functions 

It is possible to combine different types of data sources and/or functions to create a composite 
function. For example, in the following formula, two different data sources are used to return 
the difference between the reliability at 100 hours calculated from the specific Weibull++ life 
data folio data sheet called "Weibull!Target!Data1" and the reliability at 100 hours calculated 
from any given Weibull++ data sheet that is currently first in the list of associated data sources 
for the workbook or General Spreadsheet. 

=(RELIABILITY("Weibull!Target!Data1",100))-
(RELIABILITY(Default1,100) 

In the next example, nested functions are used to round up the returned reliability result to the 
nearest two decimals. 

=ROUNDUP((RELIABILITY(Default1,1000)),2) 
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Omitting Optional Inputs in the Middle of a Function 

If you do not use an optional input in the middle of the function, the function expression must 
specifically indicate that the input is being omitted. For example, when using the Weibull++ 
reliability function (RELIABILITY(Data_Src,Age,[Add Time],[Confidence 
Level]), if you want to get the confidence bound on the reliability, you must use two commas 
(,,) to indicate that the [Add Time] input is intentionally blank, before entering the [Confidence 
Level] in its usual fourth position (e.g., =RELIABILITY(Default1,1000,,0.95)). 

Note that this is handled automatically if you use the Function Wizard to build and insert the 
function expression. 

Working with Date Functions 

When using one of the spreadsheet date functions (DAY, DAYS360, MONTH, WEEKDAY and 
YEAR) to enter a date, you can use one of the following accepted text formats: 

• Month/Day/Year ("8/22/2019"). For example, =DAY("8/22/2019") returns 22. 

• Day-Month-Year ("22-Aug-2019"). For example, =MONTH("22-Aug-2019") returns 8 
(because August is the 8th month). 

If you do not include the year (e.g., “8/22” or “22-Aug”), the current year is assumed. 

Alternatively, you can use the date’s serial number (which is the number of elapsed days since 
January 1, 1900). For example, =YEAR(43466) returns 2019. 

• You can obtain a date's serial number using either of the following two functions. This may 
be helpful in cases where you want to filter, sort or use the date(s) in calculations. 

• The DATE function uses the inputs of other cells to obtain the serial number. For 
example, if you have dates specified in three cells where A2=Year, B2=Month and 
C2=Day, =DATE(A2,B2,C2) returns the serial number for that date. 

 

• The DATEVALUE function requires you to enter the date in an accepted text format. 
For example, =DATEVALUE("8/22/2019") returns 43699. 
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Finally, you can also use the results of other functions within a date function. For example: 

• To return the month from today’s current date, use: =MONTH(TODAY()) 

• To return the day of the week for a date that is specified in three separate cells (A2=Year, 
B2=Month and C2=Day), use: =WEEKDAY(DATE(A2,B2,C2)) 

 

Working with Time Functions 

When using one of the spreadsheet time functions (HOUR, MINUTE and SECOND) to enter a 
time, you can use one of the following valid text formats: 

• Hour:Minute[:Second] [AM/PM]. For example, =HOUR("4:48:10 PM") returns 16 (the 
hour using the 24 hour system). 

• Month/Day/Year Hour:Minute[:Second] [AM/PM]. For example, =MINUTE("8/22/2019 
4:48:10 PM") returns 48. 

Alternatively, you can use the hour, minute or second’s serial number (which is the fractional 
portion of a 24 hour day). For example, =MINUTE(0.70011574) returns 48 (as the specified 
serial number represents 4:48 PM). 

• You can calculate a time's serial number using either of the following two functions. This 
may be helpful in cases where you want to filter, sort or use the time(s) in calculations 

• The TIME function uses the inputs of other cells to obtain the serial number. For 
example, if you have dates specified in three cells where A2=Hour, B2=Minute and 
C2=Second, =Time(A2,B2,C2) returns the serial number for that time. 
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• The TIMEVALUE function requires you to enter the time as text in one of the accepted 
text formats. For example, =TIMEVALUE("4:48:10 PM") returns 0.70011574. 

Finally, you can also use the results of other functions within a time function. For example: 

• To generate current values, you can use the NOW function. If the current time is 4:48 PM, 
then =HOUR(NOW())returns 16. 

RETURNING CONFIDENCE BOUNDS 

For functions that return confidence bounds, note that the Function Wizard for data sources 
only inserts one-sided bounds. If you want to show two-sided bounds, you can insert the same 
function twice — once at the lower confidence bound and once at the upper confidence bound. 
For example, for a 90% confidence level, you would set the lower confidence bound at 5% and 
the upper confidence bound at 95%. 

 

• In a spreadsheet, you can use the same function (with different input parameters) to obtain 
any of the three values. For example, in Weibull++: 

=RELIABILITY(Default1,1000)returns the estimated value 

=RELIABILITY(Default1,1000,,0.05)returns the lower one-sided bound at 
5% 

=RELIABILITY(Default1,1000,,0.95)returns the upper one-sided bound at 
95% 

Note that the above function expressions for the confidence bounds uses two commas (,,) 
to indicate that another optional input ([Add Time]) was intentionally left blank. For more 
information about the syntax for functions containing multiple optional inputs, see Data 
Entry Tips for Functions. 

• In a word processing module for ReliaSoft Workbooks, the wizard provides separate 
functions for confidence bounds. For example, use the Reliability function to get the 
estimated value and use the Bound on Reliability function to get each one-sided 
confidence bound. 
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Plot Wizard 
In the word processing module for ReliaSoft Workbooks in Weibull++ and BlockSim, you can use 
the Plot Wizard to generate a variety of plots based on a referenced analysis. These are the 
same types of plots that are generated in folio or diagram plot sheets. Although you also have 
the option to copy/paste a static plot graphic from any folio or diagram plot sheet into the 
report, using the Plot Wizard makes it easy to change the associated data source when you 
reuse the template and ensures that the plot in the generated report will always show the 
latest analysis. (For DOE design folios, you can use the DOE Analysis Reports feature to insert 
plots from a design, multiple linear regression or one-way ANOVA folio, or any of the 
measurement systems analysis folios.) 

To open the Plot Wizard, choose Home > Report > Plot Wizard. 

 

The following picture shows the plot wizard in Weibull++. Similar functionality is available for 
BlockSim. 

 

There are three steps to use this tool: 

1. Select the plot type (and enter the inputs, if applicable) 

2. Select the data source 

3. Insert the plot holder 
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SELECT THE PLOT TYPE 

First, select one of the available plot types from the panel on the left side. The right side of the 
wizard displays some information about the plot that is currently selected. 

If applicable, this area also allows you to make relevant inputs (e.g., for life-stress plots that 
require you to select a specific stress column). 

SELECT THE DATA SOURCE 

To specify the data source that the plot will be based on, choose a number from the Data 
Source Index drop-down list, as shown next. Using the index makes it easy to reuse the same 
template with a variety of different data sets. 

 

INSERT THE PLOT HOLDER 

When the plot is fully defined, click Insert to place it at the current cursor location. You can 
move and/or resize the plot holder after it has been inserted. The plot holder shown next will 
return the reliability vs. time plot for whatever data source is currently second in the list of 
associated data sources. 
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Plot holders will not return any results until you view it in the Review tab or generate the report 
(Home > Report > Send to Word). 

 

Custom Charts 
In the spreadsheet module for ReliaSoft Workbooks, you can use the Document > Chart 
commands to insert your own custom charts. The charts can be placed anywhere in the 
spreadsheet, and are dynamic (automatically update when the data used to create the chart is 
changed). 
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ADDING A CHART 

1. Select the cells that contain the data of interest. In the example data below, the headings 
are included in the selection and will be used as the legend labels. 

 

2. Choose Document > Charts. Choose the chart type, and then click a chart subtype that you 
want to use. 

 

3. To move the chart, click and drag the chart to the desired location. 

4. To resize the chart, click the chart and then drag the sizing handles to the desired size. 
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CHANGING THE DATA DISPLAYED ON AN AXIS 

To change the way the data series is displayed on the axes, click the chart, then choose Design 
> Data > Switch Row/Column. 

 

CHANGING THE CHART TYPE AND/OR DATA SET   

You can change the type of chart and/or the data that is used in a chart at any time. To do this, 
click the chart and then: 

• To change the chart type, choose Design > Type > Change Chart Type. Select the desired 
type. 

 

• To change the data set, choose Design > Data > Select Data. Select the cells that contain 
the data of interest. 

 
APPLYING A CHART LAYOUT AND/OR CHART STYLE 

• To apply a predefined chart layout, choose Design > Chart Layouts. As an example, the 
following picture shows some of the options for 2-dimensional bar charts. To see the rest, 
click the arrow in the bottom-right corner. 
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If none of the predefined options are suitable for your chart, choose Layout > Labels, then 
select the option you want to customize. The following picture shows the options for the 
vertical axis. 

 

• To apply a predefined chart style, choose Design > Chart Styles. 

 

RENAMING CHART AND AXES TITLES 

When displaying chart and/or axes titles, you can rename the titles by right-clicking the chart 
and selecting the appropriate title option from the shortcut menu. For example, choosing 
Change Chart Title opens the following window: 
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MODIFYING THE AXES AND GRIDLINES 

To hide or display axes and/or gridlines, choose Layout > Axes > Axes or Gridlines. 

or  

• When displaying axes, you can change direction of the x-axis and/or change the scale of the 
y-axis. 

• When displaying gridlines, you can increase or decrease the number of gridlines for both 
the axes. 

Defined Names 
In the spreadsheet module for ReliaSoft Workbooks and general spreadsheets in Weibull++ 
folios, you can create variable names that reference specific spreadsheet cells. The names can 
then be used in any formula or function within the same workbook. 

For example, say you want to obtain the reliability of a Weibull++ data set. The operating time 
is stored in cell B5 of the spreadsheet: 

=RELIABILITY(“Weibull!Bulb!Data1!”$B$5)) 

You can create a defined name for the operating time to make the formula easier to 
understand and maintain. In this case, the formula might be rewritten as: 

=RELIABILITY(“Weibull!Bulb!Data1!”OpTime) 

You can then use the defined name OpTime in any other formula in the workbook that 
requires the operating time. 

SYNTAX RULES FOR NAMES 

• The first character of a name must be a letter or an underscore. The remaining characters 
can be letters, numbers, periods and underscores.  Names are not case sensitive. 
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• Spaces are not allowed as part of a name. An underscore ( _ ) or period ( . ) can be used as a 
word separator. 

• Symbols, except for underscores ( _ ), periods ( . ) and backslashes ( \ ), aren't allowed. 

MANAGING NAMES 

To view and manage defined names: 

• In ReliaSoft Workbooks, choose Formulas > Defined Names > Name Manager. 

• In general spreadsheets, choose Sheet > Format and View > More Settings > Defined 
Names. 

You can then use the New, Edit, or Delete commands in the window to create or modify the 
names. 

DEFINING NAMES 

There are several ways to define a name. 

Define a Name via the Name Manager 

This method applies to both ReliaSoft Workbooks and general spreadsheets. 

1. Select a cell or range of cells. 

2. Create a new name: 

• In ReliaSoft Workbooks choose Formulas > Defined Names > Define Name (or choose 
Formulas > Defined Names > Name Manager, then click the New button in the 
window). 

• In general spreadsheets, choose Sheet > Format and View > More Settings > Defined 
Names. Then in the window, click the New button. 

3. Type a name into the Name field. In the Scope drop-down list, choose whether this name 
will be used for the entire workbook or a specific sheet. The Comment field is optional. 

The selected cell/range will already be defined in the Refers to field, but you can click into 
the spreadsheet and select different cells, if desired. 
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Define a Name via the Name Box (ReliaSoft Workbook Only) 

This method applies only to the spreadsheet module of ReliaSoft Workbooks. Select the cell or 
range of cells, click the Name box and type a name. Press Enter to create the name. 

 

Define a Name via the Selection Command (ReliaSoft Workbook Only) 

If the fields are already labeled in the spreadsheet, you can use them to create names. 

1. Select the cells of interest (including the row or column labels), then choose Formulas > 
Defined Names >  Create from Selection. 

  

2. In the window, select the location of the labels. Click OK. 
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Spreadsheet References 
In ReliaSoft Workbooks, the spreadsheet reference feature provides integration between the 
spreadsheet and word processing modules in the same workbook. You can insert a reference 
from any cell, or consecutive range of cells, from the spreadsheet into a desired location in the 
word processing document. If the referenced cells in the spreadsheet are changed, the word 
processing module is automatically updated. The changes are visible when you use the Review 
tab to see a preview or generate the Word report. 

To  insert a spreadsheet reference, place the cursor at the desired location in the word 
processing document and choose Home > Report > Spreadsheet Reference. 

 

Note that you can also use the Spreadsheet Reference function in the word processing 
module’s Function Wizard.) 

The Select Cells window shows the contents of the spreadsheet module in the current 
workbook. Select a cell or range of consecutive cells and click OK. 
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For the example data shown above, the entry would look like this: 

  

DOE Analysis Reports 
The DOE Analysis Reports feature allows you to insert selected analysis results and plots into a 
ReliaSoft Workbook. 

This feature is available for any analyzed response in a design, multiple linear regression, one-
way ANOVA or measurement systems analysis folio. The report can display any result that's 
available in the folio's Analysis Summary window for the selected response, as well as any 
applicable plot. 

This topic describes how to build and insert a DOE analysis report, and how to use saved 
profiles for reports that you need to generate frequently. Note that you can insert multiple 
reports into the same spreadsheet or word processing document, if desired. Each additional 
report will be appended to the end. 

INSERTING A DOE ANALYSIS REPORT 

1. Select either the spreadsheet or word processing module in a ReliaSoft Workbook and 
choose Home > Report > DOE Analysis Report. 

  

2. In the Select Response window, choose an analyzed response to copy the results from and 
click OK. 
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3. In the DOE Analysis Report window, the Available Report Items area (left) shows all of the 
available results and plots for the selected response. The Selected Report Items area 
(middle) shows the selected results/plots, in the order in which they will appear. You can: 

a. Choose Profiles > Open Profile to apply all of the relevant selections from a saved 
report profile. (See Using DOE Report Profiles.) 

b. Build/modify the list using double-click, drag and drop or the Add/Remove and 
Up/Down buttons. 

Note that you can include multiple instances of the same report item, if desired. 

4. When you click each selected report item, the Item Properties area (right) allows you to 
view/change the name (heading) that will be used in the report, if desired. 

For plots, you can also click the Preview Plot button to see what the plot will look like in the 
report. Any plot settings you change in the plot preview will be used in the generated 
report but will not affect the folio the report is based on. 

5. Choose Actions > Generate Report. 

 
USING DOE REPORT PROFILES 

When the DOE Analysis Report window is open, you can save the current settings (i.e., report 
item selections), or load settings that were previously saved. 

• To save all your current report settings for use in future reports, choose Profiles > Save 
Profile. 

 

Then specify the name and location of the DOE report file (*.drt) that will store the settings. 

• To overwrite all the settings in the DOE Analysis Report window and use the settings from a 
DOE report file instead, choose Profiles > Open Profile. 

 

Then select the *.drt file that has all the desired settings. 
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Note: When you load report items from a DOE report file, only the items that apply to the 
selected folio/response will be included in the report. 
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Chapter 23: Dashboards 
The dashboard is a flexible tool for graphical presentation of data. This can include bar and pie 
charts, gauges, maps, etc. 

All users can view dashboards based on predefined layouts (see Dashboard Viewer). The viewer 
is available in the following locations in ReliaSoft desktop applications: 

• Project Planner 

• Analysis Explorer 

• Simulation diagram results in BlockSim (see Simulation Diagram Dashboards in the BlockSim 
documentation) 

• FMEA and FMRA data in XFMEA/RCM++ (see FMEA Dashboards in the XFMEA/RCM++/RBI 
documentation) 

• Reliability Data Warehouse (RDW) data in Weibull++ (see Reliability Data Warehouse in the 
in Weibull++ documentation) 

In a secure database, only users with the "Manage dashboard layouts" permission can manage 
and create predefined layouts (see Dashboard Layout Manager and Dashboard Layout 
Designer). 

If your organization chooses to implement an SEP web portal for an enterprise database, you 
can also share selected dashboards to be accessed from any web-enabled device. 

http://help.reliasoft.com/blocksim20/index.htm#t=simulation_diagram_dashboards.htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=fmea_dashboards.htm
http://help.reliasoft.com/weibull20/index.htm#t=reliability_data_warehouse_rdw.htm
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Dashboard Viewer 

Any user can access the Dashboard Viewer in a variety of locations throughout ReliaSoft 
desktop applications for graphical presentation of the latest analysis data. 

When dashboard functionality is available for the data you’re working with (e.g., Project 
Planner, Analysis Explorer, simulation diagrams in BlockSim, etc.), choose Dashboard > 
Dashboard Viewer to open the viewer. 

 

Select any of the predefined dashboard layouts from the drop-down list to see the latest charts 
for the current data set. 

RESIZING PANELS 

To resize the dashboard items vertically and/or horizontally, click between two items and drag 
the resize cursor ( ) to the height and/or width you want. This option is available when a 
dashboard contains multiple items. 
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SHOWING DETAILS IN CHARTS AND PIES 

To see more details about the underlying data, move the mouse pointer over a bar or slice. For 
example, when the pointer is over a bar in a chart, the values for the x and y axes will be 
displayed in the tooltip. 

  

DRILL DOWNS AND MASTER FILTERS 

For information about how to use charts that have been configured for a drill down, see 
Viewing Drill Downs. For information about how to use charts that have been configured with 
master filters, see Using Master Filters. 

SORTING AND FILTERING DATA IN A GRID 

• To sort the data in ascending or descending order, click the column heading. 

• To filter the data, click the Advanced Filter icon to see a drop-down list of filters that you 
can apply. The dashboard uses the same advanced filters functionality that is built in to 
other utilities (e.g., Resource Manager, Analysis Explorer, etc.). (See Finding and Filtering 
Records.) 

 

PRINTING OR EXPORTING THE DASHBOARD 

To print the entire dashboard, or export it as a *.pdf file, an image or an Excel file, click the 
Export To icon. 
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VIEWING DRILL DOWNS 

An easy way to determine if the dashboard was configured for drill down is to look for the 
arrow in the caption bar, if the bar is visible. 

 

To drill down, double-click an area of interest. 

To drill up, click the arrow ( ) until you have reached the desired level or right-click the chart, 
then choose Drill Up. 
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USING MASTER FILTERS 

When a dashboard with master filters is created, it can be configured for single or multiple 
filtering. If you see either of the following, then filtering is enabled: 

• For single filtering, the dashboard title is followed by light gray text. 

 

• For multiple filtering, the Clear Master Filter icon displays in the caption bar, if the bar is 
visible. 
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Note that if you see both the icon and light gray text, this means that multiple filtering is 
enabled, but only one item in the filter is selected. 

Single Filtering 

For single filtering, you can only select one item at a time. You will not be able to clear the view, 
only select a different item. 

Multiple Filtering 

For multiple filtering, you can select as many filter items as you want to view. Hold down SHIFT 
while clicking to select consecutive elements or hold down CTRL while clicking for 
nonconsecutive items. 

In the example shown next, the grid was set up as the master multiple filter. The chart and pie 
charts display the data for the four parts selected in the grid. 

 

 

To reset the view, click the Clear Master Filter icon or right-click, then choose Clear Master 
Filter. 
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Dashboard Layout Manager 
You can use the Dashboard Layout Manager to create, edit and delete the predefined 
dashboard layouts that will be available for any user to view for a particular data set. (In a 
secure database, this is available only for users with the "Manage dashboard layouts" 
permission.) 

To open the Dashboard Layout Manager, choose the command from any interface that 
supports dashboard functionality (e.g., Project Planner, Analysis Explorer, simulation diagrams 
in BlockSim, etc.). It will display only the layouts for that particular data type. 

 

You can also open the Dashboard Layout Manager from the Backstage view (File > Manage 
Database > Dashboard Layout Manager). It will display all of the layouts for any data type. If 
you want to see only the layouts specific to the application you are using, select the check box. 

 

SHOW IN VIEWER 

Use the check boxes in the Show in Viewer column to select which of the predefined layouts 
will be available to all database users via the Dashboard Viewer. If you clear a check box, the 
layout will not show in the viewer’s drop-down list but will remain in the manager’s list. 

  

Use the up/down arrows to change the order of the layouts that are shown in the viewer’s 
drop-down list. 
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LAYOUT PROPERTIES 

For all dashboard layouts that are selected to show in the Dashboard Viewer, the name that will 
be visible in the list is set from the Layout Properties window. To view or change these 
properties, select a row in the table and click the Properties button (or right-click and choose 
Properties). 

 

The description and update history are available to help you manage the layouts; that 
information is not visible to all database users. 

IMPORTING LAYOUTS 

It is easy to reuse dashboard layouts that were created in other databases. Click the Import 
button and then select the database you want to import from. If you are using the Dashboard 
Layout Manager in the Backstage view, you can import layouts of any type. If you’re using a 
manager from one of the locations where dashboards are used, you can only import layouts of 
the current type. 

 

Dashboard Layout Designer 

You can use the Dashboard Layout Designer to create or edit each predefined dashboard 
layout. (In a secure database, this is available only for users with the "Manage dashboard 
layouts" permissions.) 

To access this window, first open the Dashboard Layout Manager and then choose to either 
create a new layout or edit an existing one. 

SEPARATE LAYOUTS FOR EACH DATA TYPE 

Each dashboard layout is designed to be used with a specific data type, which determines which 
fields are available and where the dashboard can be viewed. For information about creating 
dashboards for each particular type of data, see: 

• Project Planner Dashboards 

• Analysis Explorer Dashboards 

• Simulation Diagram Dashboards (in the BlockSim documentation) 

http://help.reliasoft.com/blocksim20/index.htm#t=simulation_diagram_dashboards.htm
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• FMEA Dashboards (in the XFMEA/RCM++/RBI documentation) 

• Reliability Data Warehouse (RDW) Dashboards (in the Weibull++ documentation) 

Tip: For dashboards that are intended to be viewed in both desktop applications and the SEP 
web portal, it is recommended to use the Local Colors option on the Design tab of the 
Dashboard Layout Designer to save your preferred colors with the layout. The global colors 
definition may not be the same in both web and desktop. 

CONFIGURING A DASHBOARD ITEM 

This topic demonstrates some of the basic steps for configuring a dashboard item (bar chart, 
pie chart, gauges, etc.) in the Dashboard Layout Designer. The simple bar chart in this example 
is based on block-level simulation results from a reliability block diagram in BlockSim. The data 
source options will be different for other locations where dashboards are available, see Project 
Planner, Analysis Explorer, Simulation Diagram Dashboards (BlockSim), FMEA Dashboards 
(XFMEA/RCM++/RBI) or RDW Dashboards (Weibull++). 

In a secure database, only users with the "Manage dashboard layouts" permissions can create 
layouts. 

Add the Chart 

Add a chart to the Layout panel by choosing Home > Insert > Chart. 

  

Define the Chart Data 

1. Select a data source from the drop-down list in the Data Source panel, if applicable. 

 

2. Choose the data field (or fields) that will be displayed in the y-axis of the bar chart, then 
drag each field into the Values area in the DATA ITEMS panel. For this example, the chart 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=fmea_dashboards.htm
http://help.reliasoft.com/weibull20/index.htm#t=rdw_dashboards.htm
http://help.reliasoft.com/blocksim20/index.htm#t=simulation_diagram_dashboards.htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=fmea_dashboards.htm
http://help.reliasoft.com/weibull20/index.htm#t=rdw_dashboards.htm
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will display total operating cost, cost from preventive maintenance and cost from corrective 
maintenance. 

Note that when different data sources are available, all of the data fields used within a 
chart must come from the same source. 

 

Tip: To replace a data item, drag a new field on top of the current one. To remove a field, 
drag it anywhere outside of the data item; and to completely clear the DATA ITEMS panel, 
right-click the chart and select Remove Data Items. 

3. Use the drop-down list to see which values are available for this data field (e.g., count, sum, 
average, etc.) and choose one to display in the chart. Note that the same option must be 
selected for all values in the same chart. 

Because we want the total cost from all blocks that meet the given criteria, we use the 
default Sum for this example. 
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4. If appropriate, use the Rename command to change the name that will be displayed in the 
chart legend, tooltip, etc. 

  

5. Choose the data field that will be displayed in the x-axis, then drag it to the Argument bar. 
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Filter the Data 

To filter the data displayed in the chart, choose Data > Filtering > Edit Filter. 

  

Use the Filter Editor to define the criteria. For this example, we’re using the "Not And" operator 
to exclude any blocks with a name that contains "Hub." 

 

 

Tip: You can use hidden data items to filter based on fields that are not displayed in the chart. 

Sort by “Top N” 

To configure the chart to show only the top 5, bottom 10, etc., use the Top N command in the 
Argument data item’s drop-down list. 

For this example, we’re showing only the Top 5 blocks, based on total operating cost. The 
results are displayed from highest to lowest and the order cannot be changed. 
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Tip: Alternatively, you could use the Sort by command to sort by the argument data item — 
which is labeled (Value) in this menu — or by any of the value data items. Click the Argument 
bar to toggle the sort between ascending and descending order. 

Other Design Options 

Click the Design tab on the ribbon to access other configurable options for this type of chart. 
For example: 

1. To hide or display the caption bar above the chart, choose Show Caption. 

  

We will keep it displayed for this example. 

2. To change the title in the caption bar to something more meaningful, choose Edit Names. 

  

For this example, we will set the Dashboard item name to “Top 5 Blocks by Total Operating 
Cost” and clear all of the Series fields to make sure the latest data item name (set via the 
Rename command in the data item’s drop-down list) will always be used in the chart 
legend and tooltip. 
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3. To change the y-axis title to a more meaningful name, choose Y-Axis Settings. 
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AVAILABLE DASHBOARD ITEMS 

The following dashboard items can be added to any layout. You can add the same type of item 
more than once, if desired. To insert an item, choose Home > Insert, then click one of the 
following options. 

 

Pivot 

 

Chart 

 

Gauges 

 

Choropleth 
Map 

 

Range Filter 

 

Scatter Chart 

 

Grid 

 

Pies 

 

Cards 

 

Geo Point 
Map 

 

Text Box 

 

Image 

  

Data Types 

There are two types of data that can be used in a dashboard item: measure or dimension. 

• Measure data is calculated (sum, count, average, etc.). For example, the values on the y-
axis of a chart, the size of a slice in a pie or a target value in a card or gauge. Values and 
targets are forms of measure data. 

• Dimension data can be sorted but is not calculated. For example, the bars in chart, slices in 
a pie or text in a grid column. Arguments and series are forms of dimension data. 

Data Shaping 

You can use the Dimensions and/or Measures bars in the HIDDEN DATA ITEMS panel when you 
want to perform data shaping (filtering, sorting or Top N) but do not want the data to be 
displayed in the dashboard item. Data shaping is available for any dashboard item, except text 
boxes and images. 

• The data fields contained in the Dimensions bar can be used in Filter Editor window to 
create filter conditions based on their values. Dimensions in this area have the same sorting 
functionality that is available in the argument, attribute or series DATA ITEMS area. 



Chapter 23: Dashboards 

1432 https://www.reliasoft.com/weibull 

 

• The data fields contained in the Measures bar can be used in the Sort by submenu and in 
the Top N Values window for data sorting. Measures in this area have the same calculation 
functionality that is available in the values and target DATA ITEMS area. 

CONFIGURING A DRILL DOWN 

Drill down can be enabled for the following dashboard items: 

• Grids: Specify two or more columns 

• Charts and pies: Specify two or more arguments and/or series 

• Gauges: Specify two or more series 

• Cards: Specify two or more series 

Configuring a Drill Down Sequence 

1. In the Dashboard Layout Designer window, select the chart or grid you want to drill down.   

2.  Drag the additional data fields into the Arguments area in the appropriate order for the 
desired drill down sequence. 

For example, you can use the following sequence to configure a pie chart in a Analysis 
Explorer dashboard to first show analyses by application source, then drill down to analysis 
type. 

  

3. Choose Data > Filtering > Drill Down. This command is a toggle; choose the command again 
to disable the drill down. 

When any user views this layout in the Dashboard Viewer, he/she will be able to double-click 
inside the chart to drill down, and use the arrow ( ) to drill back up. (See Viewing Drill Downs.) 

Tip: To make it easy to identify a drill down in the Dashboard Viewer, display the dashboard 
item's caption bar (Design > Common > Show Caption). 
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Filtering 

Using the Filter Editor 

You can use the Filter Editor to incorporate filters into dashboard items that contain dimension 
data. Arguments and series are forms of dimension data. 

This type of filtering only applies to the dashboard item you have selected. To filter the data 
across the entire dashboard, see Configuring a Master Filter. 

Tip: While you cannot use the Filter Editor to sort non-dimension data, users can apply filters to 
such data fields within dashboard grids. See Sorting and Filtering Data in a Grid. 

Dimension Data Locations 

Dimension data can be used in any or all of the following areas: 

• Dimension bar in the HIDDEN DATA ITEMS panel. 

• Dimension, argument and/or series bars in the DATA ITEMS panel. 

An easy way to determine if a data field is a dimension, argument or series, is to look for the 
sort arrow to the left of the data field name. 

 

Configuring a Filter 

1. In the Dashboard Layout Designer widow, select a dashboard item, then choose Data > 
Filtering > Edit Filter. This command is also available in the shortcut menu when you right-
click the dashboard item. 
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2. In the Filter Editor window, define the criteria. The dashboard uses the same Edit Filter 
functionality that is built in to other utilities (e.g., Resource Manager, Analysis Explorer, 
etc.). (See Finding and Filtering Records.) 

In the following example, a chart was created for data that was extracted from XFRACAS into 
the Reliability Data Warehouse (RDW) in Weibull++. 

 

Because we are interested in only the chandelier parts (not the whole unit) and data from 2010 
and later, we can apply the following filter to remove the unwanted data: 
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Configuring a Master Filter 

A master filter can be used to filter data across the entire dashboard. Grids, pies, charts, 
gauges, cards and maps dashboard items can be used as master filters. 

There are two types of master filters that can be configured: 

• A Single filter allows you to select one item at a time. You will not be able to clear the filter, 
only select a different item. 

• A Multiple filter allows you to select one or more items at a time. You can also clear the 
filter to view all items at any time. This is the most flexible option. 

For example, suppose your layout contains a grid, a chart and a pie, and the grid is configured 
as the multiple master filter. When you select items in the grid, only the data for those items 
will display in the chart and pie. 

Configuring a Master Filter 

In the Dashboard Layout Designer window, select the dashboard item, then enable the master 
filtering by choosing Data > Interactivity > [Single Master Filter/Multiple Master Filter]. This 
command is a toggle; choose the command again to disable it. 

  or     

When any user views this layout in the Dashboard Viewer, he/she can use the filter to view only 
the data of interest. (See Using Master Filters.) 

Note that you can prevent a specific dashboard item from being affected by master filters, by 
selecting it in the Layout panel and then choosing Data > Interactivity settings > Ignore Master 
Filters. This command is a toggle; choose the command again to disable it. 

  

Tip: To make it easy to identify that a dashboard item is configured for filtering in the 
Dashboard Viewer, display the item's caption bar (Design > Common > Show Caption). 

 





 29.06.15 Click Wrap License only -Software Maintenance provisions dealt with in separate agreement. 

 
End User Licence Agreement  

Click Wrap Agreement at time of product installation 

BY INSTALLING THIS SOFTWARE OR BY CLICKING THE “I ACCEPT” BUTTON AND ACCEPTING 
THIS LICENCE IN ACCORDANCE WITH RECITAL C (LICENCE ACCEPTANCE PROCEDURE) YOU 
AGREE TO THE TERMS OF THIS LICENCE WHICH WILL BIND YOU, THE COMPANY ON WHOSE 
BEHALF YOU ARE ENTERING INTO THIS LICENCE AGREEMENT, AND ITS EMPLOYEES, AS 
APPLICABLE.   

THIS LICENCE AGREEMENT IS A LEGAL AGREEMENT BETWEEN HBM UNITED 
KINGDOM LTD A COMPANY INCORPORATED IN UNITED KINGDOM WHOSE 
REGISTERED NUMBER IS 1589921 AND WHOSE REGISTERED OFFICE IS AT 
TECHNOLOGY CENTRE, ADVANCED MANUFACTURING PARK, BRUNEL WAY, 
CATCLIFFE, ROTHERHAM S60 5WG (THE ‘LICENSOR’) AND THE END USER LICENSEE 
OR ITS REPRESENTATIVE/AGENT AUTHORISED TO BIND THE END USER LICENSEE 
(‘YOU’). 
PLEASE READ THIS CAREFULLY BEFORE USING THE SOFTWARE PRODUCTS 

A: BACKGROUND 

THIS LICENCE AGREEMENT SHALL BE BETWEEN YOU AND THE LICENSOR 
REGARDLESS OF WHETHER YOU HAVE PURCHASED THE SOFTWARE PRODUCTS 
DIRECTLY FROM THE LICENSOR OR AN AUTHORISED RESELLER AS SET OUT BELOW. 

THE LICENSOR APPOINTS EXPERIENCED PROVIDERS OF SOFTWARE RESALE SERVICES 
WHO DISTRIBUTE THE SOFTWARE PRODUCTS TO END USERS (‘AUTHORISED 
RESELLER’). IF YOU HAVE PURCHASED THE SOFTWARE PRODUCTS AND ANY 
ASSOCIATED SUPPORT AND MAINTENANCE SERVICES FROM AN AUTHORISED 
RESELLER, SUCH PRODUCTS AND SERVICES WILL BE PROVIDED DIRECTLY TO YOU BY 
THE RELEVANT AUTHORISED RESELLER AND ALL PAYMENTS SHALL BE MADE TO THE 
AUTHORISED RESELLER ON THE AUTHORISED RESELLER’S TERMS AND PRICES.  

IF YOU HAVE PURCHASED THE SOFTWARE PRODUCT AND SUPPORT AND 
MAINTENANCE SERVICES DIRECTLY FROM THE LICENSOR, SUCH SUPPORT AND 
MAINTENANCE SERVICES WILL BE DEALT WITH IN A SEPARATE AGREEMENT 
BETWEEN YOU AND THE LICENSOR AND ALL PAYMENTS WILL BE MADE TO THE 
LICENSOR AND GOVERNED BY THE LICENSOR’S TERMS OF SALE. 

B: PROPERTY OF LICENSOR 

THE LICENSOR, OR, WHERE APPLICABLE, THE RELEVANT MEMBER OF THE 
LICENSOR’S CORPORATE GROUP, IS THE ENTIRE LEGAL AND BENEFICIAL OWNER OF 
CERTAIN SOFTWARE PRODUCT(S) (‘THE SOFTWARE PRODUCT’) AS SET OUT IN THE 
QUOTATION OF INFORMATION, WHICH SHALL ALSO INCLUDE YOUR LICENCE KEY, 
SENT TO YOU BY EMAIL EITHER BY THE LICENSOR OR, IF YOU HAVE PURCHASED THE 
SOFTWARE PRODUCTS FROM AN AUTHORISED RESELLER, BY THE AUTHORISED 
RESELLER (‘QUOTATION’).THE LICENSOR IS WILLING TO GRANT YOU A LICENCE TO 
USE THE SOFTWARE PRODUCT ONLY IF YOU ACCEPT ALL THE TERMS AND 
CONDITIONS SET OUT BELOW. 



   

C: LICENCE TO BE GRANTED 

THE LICENSOR IS PROPOSING TO GRANT YOU ONE OF THE FOUR FORMS OF LICENCE 
IN RESPECT OF THE SOFTWARE PRODUCT. DETAILS OF EACH FORM OF LICENCE ARE 
SET OUT IN CLAUSES 2.1 AND 3 BELOW. THE FORM OF LICENCE THAT IS PROPOSED TO 
BE GRANTED TO YOU IS SET OUT IN THE QUOTATION. THE QUOTATION FORMS PART 
OF THE LICENCE AGREEMENT AND BY ACCEPTING THE TERMS OF THE LICENCE YOU 
ARE ACCEPTING THOSE TERMS IN THE QUOTATION. IF YOU HAVE NOT RECEIVED THE 
QUOTATION FROM THE EITHER THE LICENSOR OR FROM THE AUTHORISED RESELLER 
(IF YOU HAVE PURCHASED THE SOFTWARE PRODUCTS FROM AN AUTHORISED 
RESELLER) AT THE DATE HEREOF OR IF ANY DETAILS WITHIN THE QUOTATION ARE 
INCORRECT THEN YOU SHOULD FOLLOW THE ‘LICENCE REJECTION PROCEDURES’ SET 
OUT AT PARAGRAPH D BELOW AND IMMEDIATELY CONTACT THE LICENSOR OR THE 
AUTHORISED RESELLER (AS APPLICABLE). 

C: LICENCE ACCEPTANCE PROCEDURE 

BY CLICKING ON THE ACCEPTANCE BUTTON WHICH FOLLOWS THIS LICENCE 
AGREEMENT (MARKED 'DO YOU ACCEPT THESE TERMS AND CONDITIONS?'), YOU 
INDICATE ACCEPTANCE OF THIS LICENCE AGREEMENT AND THE LIMITED WARRANTY 
AND LIMITATION OF LIABILITY SET OUT IN THIS LICENCE AGREEMENT. SUCH 
ACCEPTANCE IS ON YOUR OWN BEHALF, IF YOU ARE AN INDIVIDUAL AND ON BEHALF 
OF ANY CORPORATE ENTITY WHICH EMPLOYS YOU OR WHICH YOU REPRESENT 
(‘CORPORATE LICENSEE’) IN ENTERING INTO THIS LICENCE AND YOU WARRANT THAT 
YOU HAVE THE NECESSARY AUTHORITY TO BIND THE CORPORATE ENTITY IN THIS 
RESPECT OR THAT THE AUTHORISED REPRESENTATIVES OF THE CORPORATE ENTITY 
ARE AWARE OF YOUR ACCEPTANCE OF THIS AGREEMENT ON ITS BEHALF. IN THIS 
LICENCE AGREEMENT, ‘YOU’ REFERS TO THE LICENSEE, ANY SUCH CORPORATE 
LICENSEE, OR BOTH, AS A COMMON SENSE INTERPRETATION OF THE RELEVANT 
SECTION DICTATES. 

D: LICENCE REJECTION PROCEDURE 

IF YOU DO NOT ACCEPT THESE TERMS AND CONDITIONS, YOU SHOULD CLICK ON THE 
“I DO NOT ACCEPT” BUTTON, DELETE THE SOFTWARE PRODUCTS FROM YOUR 
COMPUTER AND PROMPTLY (AND IN ANY EVENT, WITHIN 14 DAYS OF RECEIPT) 
RETURN TO THE RESELLER (A) ANY MEDIA; AND (B) ANY OTHER ITEMS PROVIDED, 
THAT ARE PART OF THIS PRODUCT. 

E: OTHER AGREEMENTS 

IF THE LICENSOR HAS EXPRESSLY AGREED WITH YOU IN WRITING THAT YOUR USE OF 
THE SOFTWARE PRODUCTS IS GOVERNED BY A PRIOR EXECUTED LICENCE 
AGREEMENT WITH THE LICENSOR, SUCH AGREEMENT SHALL APPLY INSTEAD OF THE 
FOLLOWING TERMS AND CONDITIONS TO THE EXTENT THAT THEY CONFLICT. 

YOU SHOULD PRINT A COPY OF THIS LICENCE AGREEMENT FOR FUTURE REFERENCE. 

LICENCE AGREEMENT  

1. Ownership of Software Products and Copies 

1.1 The Software Products and any printed materials or electronic documentation accompanying the Software 
Products (‘Documentation’) are copyrighted works of authorship, and are also protected under 
applicable database laws. The Licensor, or, where applicable, the relevant member of the Licensor’s 
corporate group, retains ownership of the Software Products and all subsequent copies of the Software 



 
  

Products, regardless of the form in which the copies may exist. This Licence Agreement is not a sale of 
the original Software Products or any copies. 

2. Commercial Licence 

2.1 In consideration of you agreeing to abide by the terms of this Licence Agreement and payment of the 
applicable licence fees either to the Licensor or, if you have purchased the Software Products from an 
Authorised Reseller, to the Authorised Reseller (as specified in the Quotation), the Licensor hereby grants 
to you a personal, non-exclusive, and (unless expressly agreed otherwise by the Licensor in accordance 
with clause 5.1) non-transferable licence to use the Software Products and the Documentation on the 
terms of this Licence Agreement. The licence shall take one of the following forms, (and shall be set out 
in the Quotation): 

(a) Annual Licence: 

(i) Duration – this Licence shall continue for a period of 12 months (‘Initial Period’) from the 
date of delivery of the Quotation (“the Delivery Date”) and, provided that you have paid all 
applicable renewal fees, from year to year thereafter unless terminated in accordance with 
any provision of clause 10 below or any other clause of this Licence Agreement 

(ii) Termination – you must give the Licensor 90 day’s written notice prior to the anniversary 
of the Delivery Date, such notice not to expire before such anniversary date.    

(b) Paid Up Licence: 

(i) Duration – this Licence shall continue for a period of 25 years from the Delivery Date unless 
terminated in accordance with any provision of clause 10 below or any other clause of this 
Licence Agreement. 

(ii) Conversion - this Licence may be converted to a CDS (this may include CRS and CDRS 
which are specific variations of CDS and collectively known as CDS) Licence, upon 
application to either the Licensor or the Authorised Reseller (if you have purchased the 
Software Products from an Authorised Reseller),  and payment of an additional fee  to the 
Licensor or the Authorised Reseller,(as applicable)  which shall be additional to the fees paid 
or payable in respect of any maintenance and support services provided by either by the 
Licensor or the Authorised Reseller (if you have purchased the Software Products from an 
Authorised Reseller), You may reverse this conversion to the same terms as agreed in the 
Paid Up Licence at the anniversary of the conversion by giving the Licensor 90 days written 
notice prior to the anniversary of the Delivery Date, such notice not to expire before the 
anniversary of the Delivery Date. 

(c) CDS/CRS/CDRS Licence: 

(i) Access – subject to the terms and conditions of this Licence Agreement, you may access any 
of the Software Products in the Quotation at any one time and in any combination up to the 
number of subscriptions granting you access to the Software Products for simultaneous use 
by you and purchased by you pursuant to this Agreement  (‘Access Credits’). In the event 
the number of Access Credits reaches the number of Access Credits duly paid for by you 
(‘Access Limit’), you may add additional Access Credits (or, alternatively, at any time 
during the Term) which shall be charged in accordance with either the Licensor’s prices or 
the Authorised Reseller’s prices (if you have purchased the Software Products from an 
Authorised Reseller) Such increase in Access Credits shall apply to the following 12 month 
period, unless you give the Licensor or the Authorised Reseller (as applicable) written notice 
at least 90 days in advance of the expiry of the Initial Period, that you do not wish to sustain 
such increase in Access Credits. You may opt to reduce the number of Access Credits with 



   

90 days written notice in advance of the 12 month period following from the anniversary of 
the Delivery Date, provided that the total number of Access Credits does not fall below the 
minimum threshold set by the Licensor or the Authorised Reseller (as applicable) or below 
the initial number of Access Credits calculated at the time of conversion of any Paid Up 
Licence. 

(ii) Duration - this Licence shall continue for the Initial Period and, provided that you have paid 
for the applicable Access Credits, from year to year thereafter unless terminated in 
accordance with any provision of clause 10 below or any other clause of this Licence 
Agreement; 

(iii) Reporting – in order to serve our customers better, the Licensor needs to be able to 
understand how its customers use the CDS system. As a condition of your continued access 
to the system, you are asked to provide to the Licensor on a quarterly basis, the CDS log file. 
You will be provided with easy-to-follow instructions on how to do this. 

(iv) Termination – you must give the Licensor 90 days written notice in advance of the expiry of 
the Initial Period of your intention to discontinue the CDS Licence, such notice not to expire 
before the anniversary of the Delivery Date, and you must have submitted all reports 
required of you in clause 2.1(c)(iii) above. Failure to provide such notice and reports will 
mean that the license shall automatically continue on the same terms until terminated in 
accordance with this clause.  

2.2 As an end user licensee of the Software Products, you may, subject to the following conditions and any 
conditions specified in the Quotation: 

(a) use and copy the Software Products only for use on any computer system that is detailed in the 
release notes of the respective Software Product and which is licenced, leased and/or controlled by 
you (the Corporate Licensee) or any member of your corporate group, which expression includes 
the Corporate Licensee's majority-owned subsidiaries, any parent company having a majority-
owned interest in the Corporate Licensee, and such parent's majority-owned subsidiaries; 

(b) load the Software Products into and use it only on computers at the locations specified in the 
Quotation and which are under your control; and 

(c) copy the Software Products only for back-up and archival purposes and make up to three copies of 
the Documentation, provided that the original and each copy is kept in your possession and that 
your installation and use of the Software Products does not exceed any restrictions contained in the 
Quotation. 

3. Demonstration Licence 

3.1 If the Licensor has provided you with the Software Products free of charge for evaluation purposes, this 
clause 3 shall apply to your use of the Software Products.  

3.2 You may use the Software Product on a computer solely for the purposes of evaluating the Software 
Product. 

3.3 The Software Product is provided to you free of charge and on an “AS IS” basis, without any technical 
support or warranty of any kind from us including, without limitation, a warranty of satisfactory quality, 
fitness for purpose and non-infringement. 

3.4 This Licence shall continue for a period of 30 days from the Delivery Date unless terminated in 
accordance with any provision of clause 10 below or any other applicable clause of this Licence 
Agreement or until such Licence is converted into an Annual Licence, Paid Up Licence or CDS Licence, 
if earlier. 



 
  

3.5 As part of the Licensor’s testing and evaluation of the Software Products, you shall share with the 
Licensor the input and views received and any reports and analysis produced promptly upon receipt of 
such feedback.  
 

3.6 Clauses 4, 5.1(a), 6.1(b), 6.1(f), 8.1, 8.2, 8.5, 10.1(a) of this Licence Agreement shall not apply to a 
Demonstration Licence. 

4. Delivery and Risk 

4.1 The Software Products shall consist of one copy of the object code of the Software Products on machine-
readable form only, on the disk, dongle or other media on which the Software Product                   is 
delivered as described in the Quotation (the “Media”). Risk in the Media shall pass to you on delivery. If 
any part of the Media shall thereafter be lost, damaged or destroyed, you must contact either the Licensor 
or the Authorised Reseller from whom you have purchased the Software Products who will arrange for a 
repair or replacement of such Media at a cost (if any) determined by the Licensor or the Authorised 
Reseller (as applicable). 

5. Licence Restrictions 

5.1 You may not nor permit others to: 

(a) transfer the Software Products from one location to another, without the express written consent of 
the Licensor and provided such transfers do not exceed two in any twelve month period.  It will be 
a condition of the grant of any such consent that the Software Products held on hard drives at the 
current location must be erased and you must enter into a new licence agreement with the Licensor 
before a Software Products licence key is provided to you.  The administration charge (currently 
US $1,500) will be payable by you in respect of such transfer.; This charge is only applicable to 
end user licensees who do not have a support and maintenance services agreement with the 
Licensor  or Authorised Reseller;  

(b) exceed the number of concurrent users specified in the Quotation, if any;  

(c) sub-licence, sell, assign, rent, pledge, lease, transfer or otherwise dispose of the Software Products, 
on a temporary or permanent basis, without the prior written consent of the Licensor, 

(d) translate, reverse engineer, decompile, disassemble, modify or create derivative works based on 
the Software Products except as permitted by law; 

(e) make copies of the Software Products, in whole or part, except for back-up or archival purposes as 
permitted in this Licence Agreement; 

(f) use any back-up copy of the Software Products for any purpose other than to replace the original 
copy in the event that it is destroyed or becomes defective; 

(g) copy the Documentation (except as provided by this Licence Agreement); 

(h) adapt, modify, delete or translate the Documentation in any way for any purpose whatsoever; 

(i) vary, delete or obscure any notices of proprietary rights or any product identification or restrictions 
on or in the Software Products. 

6. Open Source 

Notwithstanding the foregoing provisions, You acknowledge that certain components of the Software 
Product may be covered by so-called open source software licenses (“Open Source Components”), which 
means any software licenses approved as open source licenses by the Open Source Initiative or any 
substantially similar licenses, including without limitation any license that, as a condition of distribution 
of the software licensed under such license, requires that the distributor make the software available in 



   

source code format. To the extent required by the licenses covering Open Source Components, the terms 
of such licenses will apply to such Open Source Components in lieu of the terms of this Agreement. To 
the extent the terms of the licenses applicable to Open Source Components prohibit any of the restriction 
in this License Agreement with respect to such Open Source Components, such restrictions will not apply 
to such Open Source Components. To the extent the terms of the licenses applicable to Open Source 
Components require Licensor to make an offer to provide source code or related information in connection 
with the Software Product, such offer is hereby made. Any request for source code or related information 
should be directed only to Customer Support, HBM United Kingdom Limited, AMP Technology Centre, 
Brunel Way, Catcliffe, Rotherham, South Yorkshire, S60 5WG, United Kingdom. You acknowledge 
receipt of notices for the Open Source Components for the initial delivery of the Software Product. 

7. Undertakings 

7.1 You undertake: 

(a) to ensure that, prior to use of the Software Products by your employees or agents, all such parties 
are notified of this Licence and the terms of this Licence Agreement and that any such use as 
aforesaid is in accordance with the terms of this Licence Agreement; 

(b) to replace the current version of the Software Product with any updated or upgraded version or 
new release provided by the Licensor or the Authorised Reseller (if applicable) under the terms of 
this Licence Agreement immediately on receipt of such version or release; 

(c) to use the Software Products only as described in the Documentation and subject to the restrictions 
as set out in clause 5 (Licence Restrictions above); 

(d) to reproduce and include the Licensor’s copyright notice (or such other party’s copyright notice as 
specified on the Software Products) on all and any copies of the Software Products, including any 
partial copies of the Software Products as permitted to be made under the terms of this Licence 
Agreement; 

(e) to hold all drawings, specifications, data (including object and source codes), Software Products 
listings and all other information relating to the Software Products confidential and not at any time, 
during this Licence or after its expiry, disclose the same, whether directly or indirectly, to any third 
party without the Licensor’s consent and 

(f) to effect and maintain adequate security measures to safeguard the Software Product from access 
or use by any unauthorised person and indemnify the Licensor for losses flowing from your failure 
to do so. 

8. Intellectual Property Rights  

8.1 You acknowledge that all intellectual property rights in the Software Product and the Documentation 
throughout the world belong to the Licensor, that rights in the Software Product are licensed (not sold) to 
you, and that you have no rights in, or to, the Software Product or the Documentation other than the right 
to use them in accordance with the terms of this Licence Agreement. 

8.2 You acknowledge that you have no right to have access to the Software Product in source code form or 
in unlocked coding or with comments. 

8.3 The integrity of this Software Product is protected by technical protection measures (“TPM”) so that the 
intellectual property rights, including copyright, in the software of the Licensor are not misappropriated. 
You must not attempt in any way to remove or circumvent any such TPM, nor to apply, manufacture for 
sale, hire, import, distribute, sell, nor let, offer, advertise or expose for sale or hire, nor have in your 
possession for private or commercial purposes, any means whose sole intended purpose is to facilitate 
the unauthorised removal or circumvention of such TPM. 



 
  

9. Limited Warranty 

9.1 Subject to the limitations and exclusions of liability below and providing the Software is used in 
accordance with the Documentation and on an operating system or computer for which it was designed, 
the Licensor warrants that (a) the Media on which the Software Products is furnished will be free from 
material defects under normal use for a period of 90 days from the date of delivery (the “Warranty 
Period”); and that (b) during the Warranty Period, the Software Product will, when properly used, perform 
substantially in accordance with the functions described in the Documentation; and (c) that the 
Documentation correctly describes the operation of the Software Product in all material respects. 

9.2 If, within the Warranty Period, you notify the Licensor in writing of any defect or fault in the Software 
Product in consequence of which it fails to perform substantially in accordance with the Documentation, 
and such defect or fault does not result from you having amended the Software Product or used it in 
contravention of the terms of this Licence Agreement, the Licensor will, at its sole option, i) repair or 
replace the Software Product, provided that you make available all information that may be necessary to 
assist the Licensor in resolving the defect or fault, including sufficient information to enable the Licensor 
to recreate the defect or fault, or ii) terminate this Licence Agreement immediately by notice in writing 
to you and the Licensor will refund or if the Software Products have been purchased from an Authorised 
Reseller will procure that the Authorised Reseller shall refund; any of the fees paid as at the date of 
termination (less a reasonable sum in respect of your use of the Software Product to the date of 
termination) on return of the Software Product and all copies thereof. The Licensor’s obligation under 
this clause 8.2 is subject to your compliance with clause 6.1(b). 

9.3 You acknowledge that the Software Product has not been developed to meet your individual requirements 
and that it is therefore your responsibility to ensure that the facilities and functions of the Software 
Product as described in the Documentation meet your requirements. 

9.4 You acknowledge that the Software Product may not be free of bugs or errors and you agree that the 
existence of any minor errors shall not constitute a breach of this Licence Agreement. 

9.5 The Licensor shall not be liable under the said warranty above if the Software Product fails to operate in 
accordance with the said warranty as a result of any modification, variation or addition to the Software 
Products not performed by the Licensor or caused by any abuse, corruption or incorrect use of the 
Software Products, including use of the Software Products with equipment or other software which is 
incompatible. 

9.6 All other conditions, warranties or other terms which might have effect or be implied or incorporated into 
this Licence Agreement or any collateral contract, whether by statute, common law or otherwise, are 
hereby excluded, including, without limitation, the implied conditions, warranties or other terms as to 
satisfactory quality, fitness for purpose or the use of reasonable skill and care. 

10. Exclusion of Liability 

10.1 Nothing in this Licence Agreement shall limit or exclude the liability of either party for death or personal 
injury resulting from negligence, for fraud or for fraudulent misrepresentation. 

10.2 Subject to clause 9.1, the Licensor shall have no liability for any losses or damages which may be suffered 
by you (or any person claiming under or through you), whether the same are suffered directly or indirectly 
or are immediate or consequential, and whether the same arise in contract, tort (including negligence) or 
otherwise howsoever, which fall within any of the following: 

(a) loss of income; 

(b) loss of business profits or contracts; 

(c) business interruption; 



   

(d) loss of the use of money or anticipated savings; 

(e) loss of information; 

(f) loss of opportunity, goodwill or reputation; 

(g) loss of, damage to or corruption of data; or 

(h) any indirect or consequential loss or damage of any kind howsoever arising and whether caused by 
tort (including negligence), breach of contract or otherwise; 

provided that this clause 9.2 shall not prevent claims for loss of or damage to your tangible property that 
fall within the terms of clause 8 or a claim for a refund of the licence fees paid to the Licensor or the 
Authorised Reseller (as applicable) for the licence of the Software Products. 

10.3 Subject to clause 9.1 and clause 9.2, the Licensor's maximum aggregate liability under or in connection 
with this Licence Agreement, or any collateral contract, whether in contract, tort (including negligence) 
or otherwise, shall be limited to a sum equal to the fees paid by you to the Licensor or the Authorised 
Reseller (as applicable) for the licence of the Software Products.  

10.4 Subject to clause 9.1, clause 9.2 and clause 9.3, the Licensor's liability for infringement of third party 
intellectual property rights shall be limited to breaches of third party rights subsisting in the UK and USA. 

10.5 This Licence Agreement sets out the full extent of the Licensor's obligations and liabilities in respect of 
the supply of the Software and Documentation.  In particular, there are no conditions, warranties, 
representations or other terms, express or implied, that are binding on the Licensor except as specifically 
stated in this Licence Agreement.  Any condition, warranty, representation or other term concerning the 
supply of the Software and Documentation which might otherwise be implied into, or incorporated in, 
this Licence Agreement, or any collateral contract, whether by statute, common law or otherwise, is 
hereby excluded to the fullest extent permitted by law. 

11. Term and Termination 

11.1 This Licence Agreement is effective for the period referred to clause 2.1 or until otherwise terminated in 
accordance with that clause. The Licensor may terminate this Licence Agreement immediately by written 
notice to you if: 

(a) save in respect of a Paid Up Licence, if you purchase the Software Products directly from the 
Licensor, you fail to pay any renewal or other fees due by you to the Licensor in respect of this 
Licence Agreement; 

(b) you fail to comply with any provisions of this Licence Agreement; 

(c) you commit a material or persistent breach of this Licence Agreement which you fail to remedy (if 
remediable) within 14 days after the service on you of written notice requiring you to do so; or 

(d) a petition for a bankruptcy order to be made against you has been presented to the court; or 

(e) where you, as the Corporate Licensee, become insolvent or unable to pay its (the company’s) debts, 
enters into liquidation, whether voluntary or compulsory (other than for reasons of bona fide 
amalgamation or reconstruction), passes a resolution for its winding-up, has a receiver or 
administrator manager, trustee, liquidator or similar officer appointed over the whole or any part 
of its assets, makes any composition or arrangement with its creditors or takes or suffers any similar 
action in consequence of its debt, or becomes unable to pay its debts or ceases to trade. 

11.2 In the event of termination in accordance with clause 10.1 you must immediately pay to the Licensor any 
sums due to the Licensor under the Licence Agreement and (at the Licensor’s sole option) you must 
return, destroy or delete all copies of the Software Products from all storage media in your control and, 



 
  

in the case of destruction, certify to us that you have done so. 

12. Export 

12.1 You will comply with all applicable laws, rules, and regulations governing export of goods and 
information, including the laws of the countries in which the Software Products was created. In particular, 
you will not export or re-export, directly or indirectly, separately or as a part of a system, the Software 
Products or other information relating thereto to any country for which an export licence or other approval 
is required, without first obtaining such licence or other approval. 

13. General 

13.1 You agree that the Licensor shall have the right, after supplying undertakings as to confidentiality, to 
audit any computer system on which the Software Products are installed in order to verify compliance 
with this Licence Agreement. 

13.2 You agree that the Licensor may use your company name in Licensor’s customer lists and other 
promotional materials describing your company as a customer or user of Licensor’s software or services, 
as applicable, unless it receives written notice from you objecting to such use. 

13.3 This Licence Agreement, its subject matter or its formation (including non-contractual disputes or claims) 
shall be governed by and construed in accordance with English law and submitted to the non-exclusive 
jurisdiction of the English courts. 

13.4 This Licence Agreement constitutes the complete and exclusive statement of the agreement between the 
Licensor and you with respect to the subject matter of this Licence and supersedes all proposals, 
representations, understandings and prior agreements, whether oral or written, and all other 
communications between us relating to that subject matter except for those expressly referred to in this 
Licence Agreement. 

13.5 Any clause in this Licence Agreement that is found to be invalid or unenforceable shall be deemed deleted 
and the remainder of this Licence Agreement shall not be affected by that deletion. 

13.6 Failure or neglect by either party to exercise any of its rights or remedies under this Licence Agreement 
will not be construed as a waiver of that party’s rights nor in any way affect the validity of the whole or 
part of this Licence Agreement nor prejudice that party’s right to take subsequent action. 

13.7 This Licence Agreement is personal to you and you may not assign, transfer, sub-contract or otherwise 
part with this Licence or any right or obligation under it without the Licensor’s prior written consent. 
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