




Quick Tour of XFMEA and RCM++ 

https://www.reliasoft.com/xfmea 1 
 

Quick Tour of XFMEA and RCM++ 
XFMEA facilitates data management and reporting for all types of FMEA (including Design 
FMEA, Process FMEA, FMECA, etc.). It also supports related analyses such as P-Diagrams, 
DVP&Rs (Test Plans), Design Reviews Based on Failure Mode (DRBFMs), Process Flow 
Diagrams and Process Control Plans. 

RCM++ facilitates the Reliability Centered Maintenance (RCM) approach for creating effective 
scheduled maintenance plans. It supports traditional RCM decision logic diagrams, and also 
offers simulation/calculation engines to compare maintenance strategies based on cost and 
availability. 

Answer a wide variety of questions such as: 

• What is the risk in a product or process? 
• Which components or assemblies pose the greatest risk? 
• What failure modes might occur? What is the effect of failure? 
• What controls are in place to mitigate the risk? 
• What tests need to be performed? 
• How can we improve the design? 
• How should we plan for scheduled inspections and maintenance? 
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Using Databases and Projects 
File Menu 
Use commands on the File menu (New, Recent or Open Database) to create or open a 
database. 

Each database supports simultaneous access by multiple users. If you have admin permissions, 
use File > Manage Database to control user access and manage configurable settings that apply 
throughout the database. 

Use File > Help to access online help and shipped examples. 

 

Project List 
Each database can contain multiple projects. Use the project list to create or open a project. 

If you have a lot of projects: 

• Use the project filter to limit what’s displayed. 
• Use the project category to group projects within the list. 
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System Panel and Analysis Panel 
The System panel shows the items that may be analyzed in the project. 

• It can be a single item or a complex multi-level system configuration. 
• It can be physical components/equipment or steps in a process. 
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The Analysis panel shows properties and analyses for the item that is currently selected.   

 

Common features such as project plans, resources and project attachments are visible in all 
ReliaSoft desktop applications. 
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Project Properties 
FMEA Structure 
Each project has an FMEA structure that will be the same for all FMEAs and RCMs in the 
project. 

• Grouped Effects and Causes (commonly used for FMEA) 
 
The effects will be entered as separate records but displayed together in the FMEA; the 
software calculates RPNs based on the highest severity rating. 

 

• Effects Before Causes (can be used for FMEA or RCM) 

 

• Causes Before Effects (sometimes used for RCM) 
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Configurable Settings 
Each project also has its own configurable settings that enable you to customize: 

• Data fields and names 
• Classifications, categories and other drop-down lists 
• Rating scales and preferences for FMEA risk priority metrics 
• Logic for risk discovery and RCM decision charts 

Use the Select Profile from Library option in the project properties to quickly apply a 
predefined group of settings. 
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Using FMEAs 
Failure Modes and Effects Analysis (FMEA) and Failure Modes, Effects and Criticality Analysis 
(FMECA) are methodologies designed to identify potential failure modes for a product or 
process, to assess the risk associated with those failure modes, to rank the issues in terms of 
importance and to identify and carry out corrective actions to address the most serious 
concerns. 

The basic steps for using an FMEA are: 

1. Create the project and set project properties 

Choose Project > Management > Create Project. 

 

In the Project Properties window, specify the FMEA Structure and the Profile that will 
be used to set the configurable settings. 

 

2. Add items in the system hierarchy 

The first item is added to the system hierarchy when you create the project. Use the 
Properties tab in the Analysis panel to rename it and set other properties. 
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To add items, right-click inside the system hierarchy and choose Add System, Add Next 
Level Item, etc. 

 

3. Add a new FMEA 

To add an FMEA for an item, right-click the item in the system hierarchy and choose 
Analyses > Add FMEA. 

 

4. Add records in the FMEA hierarchy 

The Hierarchy tab for an FMEA displays the analysis records in a hierarchical tree, which 
tends to be good for viewing a lot of information in a small amount of space. In this 
view, you will use properties windows to add or edit FMEA records. 
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When you add a new FMEA, the Function window will automatically open. Enter the 
details and click either Add Function (to add the next function description), Add Failure 
(to add the first failure mode for this function) or OK (to close the window).  

 

5. Use Select Existing Text utilities 

The Select Existing Text window provides a list of existing descriptions that might apply 
to the current text field or analysis. 

If you want to use this utility to replace or append text in an input field, click the icon 
next to the field.  
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The Select Existing Text window can also be used to add multiple records at once. For 
example, right-click a function record and choose Add Multiple Failures > Select Existing 
Text. 

6. View RPNs and related metrics 

You can choose to calculate and display a variety of metrics based on the Severity, 
Occurrence and Detection ratings that have been assigned for effects and causes in the 
FMEA: RPN, SxO, SOD, SD or QCPN. 

To configure the metrics that are enabled for the current project, choose FMEA > Tools 
> Configurable Settings. 

  

On the RPNs page, use the Enabled column to specify which metrics will be available in 
the current project. 
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Use the Highlight Priority Based On area to configure the logic that will be employed 
when a user turns on the priority highlights feature. 

 

To choose which metrics will be displayed in the FMEA hierarchy for your computer, 
right-click a column heading in the FMEA and choose Customize Columns. 

 

To turn on priority highlighting, choose FMEA > Tools > Highlight Priority. 
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7. Use the filtered and worksheet views 
a. Filtered view 

Click the Filtered tab at the bottom of the FMEA to open the filtered view. This 
view presents a sortable list of all records of a particular type, such as causes 
sorted by RPN or actions sorted by due date. 

Use the Filter By drop-down list to select which records are displayed. Then click 
inside the column heading you wish to sort by. 
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b. FMEA worksheet 

Click the Worksheet tab at the bottom of the FMEA to open the worksheet view. 
This view allows you to type directly into the worksheet cells and tab through 
the analysis as you would in a spreadsheet application. 

 

To use the entire workspace for the worksheet view, choose View > Workspace 
Layout > Hide System Panel. 

 

To return to a split workspace, choose View > Workspace Layout > Split Panels. 

 

8. Create plots 

Choose Home > Reporting > Plots. 
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Select the item(s) that you want to include in the plot. Then use the control panel to 
select the plot type and other settings. 

 

9. Run a query 

Choose Home > Reporting > Queries. 
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First use the left panel to specify the data source (selected projects throughout the 
database or selected items within the current project). Then use the right panel to 
specify the query criteria and output preferences. 

 

Click Run Query to view the records that match the criteria. 

10. View a dashboard 

Choose Home > Reporting > Dashboard > Dashboard Viewer. 
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In the Layout drop-down list, select one of the layouts that have been predefined for 
FMEA data and then use the dashboard to view the desired information. For example, in 
the RPN Dashboard you can click an item in the Item Drill Down panel to select which 
item’s data will be displayed in the other 2 panels. 

 

11. Generate a report 

Choose Home > Reporting > Reports. 
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Select the items that you want to create a report for, the report forms you want to 
include in the generated report and the desired output type (Excel or Word). 

 

Click Generate Report to create the report. 
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Using RCMs 
Reliability Centered Maintenance (RCM) analysis provides a structured framework for analyzing 
the functions and potential failures for a physical asset in order to develop a scheduled 
maintenance plan that will provide an acceptable level of operability, with an acceptable level 
of risk, in an efficient and cost effective manner. 

The basic steps for performing RCM analysis are: 

1. Create the project and set project properties 

Choose Project > Management > Create Project. 

 

In the Project Properties window, specify the FMEA Structure and the Profile that will 
be used to set the configurable settings. 

 

2. Add items in the system hierarchy 

The first item is added to the system hierarchy when you create the project. Use the 
Properties tab in the Analysis panel to rename it and set other properties. 

 



Quick Tour of XFMEA and RCM++ 

https://www.reliasoft.com/xfmea 19 
 

To add items, right-click inside the system hierarchy and choose Add System, Add Next 
Level Item, etc. 
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3. Perform equipment selection 

For each system hierarchy item that you want to perform equipment selection for, right-
click the item and choose Analyses > Add Risk Discovery. 
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Depending on the configurable settings for the project, this can be a list of yes/no 
questions or a set of rating scales. 

 

4. Add a new functional failure analysis 

Right-click the system hierarchy item that you want to create a functional failure 
analysis for and choose Analyses > Add FMEA. 
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5. Add functional failure analysis records 

When you add the analysis, the Function window will automatically open. Enter the 
details and click either Add Function (to add the next function description), Add Failure 
(to add the first functional failure for this function) or OK (to close the window). 

 

Continue adding analysis records as needed. Note that RCM failure modes are described 
using the cause record type. 
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6. Perform failure effect categorization 

Right-click an effect in the functional failure analysis and choose Effect Categorization. 

 

The questions and categories depend on the configurable settings for the project. 
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7. Perform maintenance task selection and add a task 

Right-click a failure mode (cause) and choose Task Manager. 
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In the Task Manager, answer the questions by clicking inside the Yes/No column. These 
questions may or may not be dependent on the failure effect categorization, depending 
on the task selection logic defined for the project. 

 

To add a task, click Add Task. 
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• Specify the task name and task type, then indicate when the task is to be 
performed. 
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• Continue to specify task properties as needed. The configurable fields for 
traditional RCM are entered under the RCM node. 
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More Analyses and Tools 
Analysis Plans 
Analysis Plans allow you to keep track of team members, ground rules, estimated completion 
dates, scheduled work sessions and other details that will help you to plan and manage your 
FMEA and RCM projects. 
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Parameter Diagrams (P-Diagrams) 
A Parameter Diagram (P-Diagram) is a structured tool that identifies the inputs from a system 
and relates those inputs to the desired system outputs, while considering the controlled and 
uncontrolled factors. 
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FMEA Block Diagrams 
An FMEA Block Diagram visually depicts the system assembly that will be analyzed in a Design 
FMEA. These diagrams help to define the scope of a particular analysis project and also may 
provide additional information that will be useful to the analysis team when they attempt to 
identify potential failure modes. 
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PFD Worksheets 
A PFD worksheet records detailed information, including process characteristics (inputs) and 
product characteristics (outputs), for each step of the manufacturing or assembly process. The 
complete PFD worksheet provides a structure for preparing process FMEAs (PFMEAs) and 
control plans. 

 

Control Plans 
Control plans are used to track critical characteristics that must be kept in control during a 
manufacturing or assembly process, and record the methods for maintaining control. 
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Test Plans 
A test plan displays a list of actions that describe specific tests that need to be performed. 
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