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Getting Started 
XFRACAS Admin Help 
ReliaSoft XFRACAS by HBM Prenscia is a highly configurable, web-based Failure Reporting, 
Analysis and Corrective Action System (FRACAS). Depending on how your implementation is 
configured, this can include incident/failure reporting, failure analysis on returned parts, part 
tracking for serialized systems, root cause analysis, team-based problem resolution and tracking 
the completion of assigned actions. 

Since XFRACAS is highly configurable, the specific features, field names and behavior will 
depend on the settings for your implementation. 

This guide covers features that are available only to users with administrative permissions, to 
help you configure XFRACAS to meet your organization's specific needs. You may also need to 
consult the following resources: 

• User Guide- covers features that may be available to all XFRACAS users. 

• Implementation Guide (*.pdf) -  guidance for an IT admin to prepare the database and web 
server(s) and install the website, and for an application admin to complete the initial 
configuration. 

XFRACAS can also be integrated with other ReliaSoft applications. This provides intelligent 
integration between reliability program activities and tools while simultaneously facilitating 
effective information sharing and cooperation between engineering teams of any size. Other 
ReliaSoft software by HBM Prenscia includes Weibull++, BlockSim, Lambda Predict, XFMEA, 
RCM++, RBI, MPC, and SEP. 

Tip: Click the Print icon, , to save any help topic as a PDF or to print it to a device from your 
browser. 

 

Technical Support 
The configurable settings for your XFRACAS implementation will be set and maintained by 
user(s) with administrative permissions. If you have questions about these settings, see the 
About page in XFRACAS for the name and e-mail address for the primary admin contact for your 
implementation. 

http://help.reliasoft.com/documents/version2020/IG_XFRACAS20.pdf
https://www.reliasoft.com/products/reliability-analysis/weibull
https://www.reliasoft.com/products/reliability-analysis/blocksim
https://www.reliasoft.com/products/reliability-analysis/lambda-predict
https://www.reliasoft.com/products/reliability-management/xfmea
https://www.reliasoft.com/products/reliability-management/rcm
https://www.reliasoft.com/products/reliability-management/rbi
https://www.reliasoft.com/products/reliability-management/mpc
https://www.reliasoft.com/products/reliability-management/sep
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For organizations with an active maintenance agreement, we provide technical support for 
software-related issues via a network of regional offices and partners/distributors throughout 
the world. To get contact details for technical support worldwide, visit 
http://www.reliasoft.com/about/contact-us. 

WHEN REQUESTING TECH SUPPORT 

When you contact us to request technical support, please be prepared to provide the following 
information: 

• Your phone number and e-mail address. 

• The build version of your implementation (displayed on the About page). 

• The name and version of your web browser. 

• What you were doing when the problem occurred and exactly what happened. Please 
include the specific wording of any message(s) that appeared. 

Note: Technical support representatives are not reliability consultants. Their assistance is 
limited to technical issues that you may encounter with the software tools. 

http://www.reliasoft.com/about/contact-us
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Administrative Ribbon Tabs 
 

System Tab 
In the navigation ribbon, the System tab will be visible if you have either of the following 
permissions: Manage Serialized Systems or Manage Template Systems. 

SYSTEM 

  Template opens the Template page, which allows you to view and manage generic 
system configurations. 

  Serialized opens the Serialized page, which allows you to view and manage the specific 
parts in a particular piece of equipment. 

TEMPLATE 

  Create Template allows you to create a new system template. 

  Find Template allows you to search for an existing system template by template part 
name or template part number. 

  XFMEA Import allows you to import system hierarchy data from XFMEA, RCM++ or RBI 
into XFRACAS. This command appears only if the current database has associated tables 
that you have permission to access and at least one project with a system hierarchy. (See 
Import or Sync from XFMEA.) 

SERIALIZED 

  Create System allows you to create a serialized system based on an existing system 
template. 

  Find System allows you to search for an existing serialized system. 
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PART 

Template Commands 

When you are working with a template, the following commands will appear: 

  Create allows you to create a new system part under the part currently selected in the 
system configuration. 

  Edit allows you to edit the information for the part currently selected in the system 
configuration. 

  Delete removes the currently selected part from the system configuration or retires it 
if it is used in records within the system. 

  Associate allows you to select one or more existing template parts to associate below 
the part currently selected in the system configuration. 

  Disassociate removes the currently selected part from the system configuration and 
makes it a top-level part. 

  Assign Owner allows you to specify the owner who is responsible for the selected part. 

  Remove Owner removes the owner from the selected part and clears the e-mail 
notification list for the part. This command is available only for parts with owners. 

  CC List allows you to specify additional users to be included in the e-mail notification 
list for the selected part. This command is available only for parts with owners. 

  Sync with XFMEA synchronizes the data in XFRACAS to reflect changes made within 
XFMEA, RCM++ or RBI after a part has been imported. This command is available only when 
you are working with a part that was imported from a desktop application. 

  Remove XFMEA Association removes the association of the part with XFMEA. This 
command is available only when you are working with a part that was imported from a 
desktop application. 
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  Export exports the currently selected part and any children to a new *.xml file. 
Depending upon your permissions, this command may have a drop-down list of options. In 
this case, choose Part to export the currently selected part and any children to a new *.xml 
file, or choose Master BOM to export the entire system configuration that the currently 
selected part belongs to, including all details associated with all parts. 

Serialized System Commands 

When you are working with a serialized system, the following commands will appear: 

  Create Serialized allows you to create a new serialized part under the part currently 
selected in the system configuration. 

  Edit Serialized allows you to edit the information for the serialized part currently 
selected in the system configuration. 

  Delete Serialized removes the currently selected serialized part from the system 
configuration or retires it if it is used in records within the system. 

  Add Non-Serialized allows you to select one or more existing non-serialized parts to 
associate below the part currently selected in the system configuration. 

  Add Existing Serialized allows you to select an existing serialized part to associate 
below the part currently selected in the system configuration. 

  Disassociate removes the currently selected part from the serialized system 
configuration and makes it a top-level part. 

  Export exports the currently selected part and any children to a new *.xml file. (See 
Exporting to XML.) 

 

Admin Tab 
In the navigation ribbon, the Admin tab will be visible if you have the following permission: 
Access Admin Tab. 

The available commands will depend on your permissions for individual features. 
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CONFIGURE 

  Security 

  Users opens the Users page, which allows you to add contact and permissions 
information for authorized XFRACAS users and edit the properties of existing user 
accounts. 

  Security Groups opens the Security Groups page, which allows you to create and 
edit groups of users who have the same categories and permissions. 

  User Groups opens the User Groups page, which allows you to create and manage 
predefined groups of users that can quickly be added to the team for an incident, 
problem or project. 

  Applicants opens the Applicants page, which allows you to add users who have 
requested access to XFRACAS and to set their permissions. 

  Active Directory opens the Active Directory page, which allows you to add users 
from Microsoft Active Directory. 

  Manage 

  Contacts opens the Contacts page, which allows you to view and maintain 
contacts. 

  Companies opens the Companies page, which allows you to view and maintain 
companies. 

  Locations opens the Locations page, which allows you to view and maintain 
locations. 

  Preferences opens the Preferences page, which allows you to maintain the 
preferences that control various aspects of XFRACAS. 

  Details opens the Details page, which allows you to manage some of the fields that 
appear in various record types. 
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  Lists opens the Lists page, which allows you to maintain lists of available values for 
user interface fields that require selection from specified values. 

  User Categories opens the User Categories page, which allows you to maintain the 
categories that users can be assigned to. These categories can be used to filter drop-down 
lists of users (e.g., when assigning users to failure review boards). 

  Action Management opens the Action Management page, which allows you to 
maintain the action type categories that users can select from when they create actions. 

  Criticality opens the Criticality page, which allows you to maintain the criticality fields 
that may appear in the Incident and Problem pages. 

TOOLS 

  Diagnostics opens the Diagnostics page, which provides an error log for the current 
entity. 

  Resource Editor opens the Resource Editor page, which allows you to manage the text 
that appears in the XFRACAS interface. 

  Entities opens the Entities page, which allows you to manage the entities that exist in 
XFRACAS. 

  Import opens the Data Import page, which allows you to manage the process of 
importing data from other sources via *.xml files. 

  Report Viewer opens the Report Viewer page, which allows you to control the display 
of the standard reports, chart reports, custom reports and administrator reports. 

USERS/USER GROUPS 

When you are creating a new user or user group, the following commands will appear: 

  Create saves the user/group once you have entered all required information. 

  Delete deletes the applicant from the request list. This command is available only 
when working on the Applicants page. There is no undo for delete. 
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When you are working with an existing record, the following commands will appear: 

  Save saves the current user/group. This command is available on the Users page and 
the User Groups page. 

  New clears the user/group information from the interface so that you can create a 
new one. The existing user/group is unaffected. This command is available on the Users 
page and the User Groups page. 

  Duplicate duplicates the current user so that you can easily create a new user who has 
similar properties. This command is available only on the Users page. 

  Export exports the current user to a new *.xml file. This command is available only on 
the Users page. If you want to export multiple users simultaneously, use the Admin > 
Import > Export command on the Data Import page. 

  Delete deletes the current user/group. This command is available on the Users page 
and the User Groups page. There is no undo for delete. 

CONTACTS/COMPANIES/LOCATIONS 

When you are creating a new contact, company or location, the following command will 
appear: 

  Create saves the new record once you have entered all required information. 

When you are working with an existing record, the following commands will appear: 

  Save saves the current record. 

  New clears the current record information from the interface so that you can create a 
new one. The existing record is unaffected. 

  Export exports the current record to a new *.xml file. Alternatively, if you want to 
export multiple records simultaneously, use the Admin > Import > Export command on the 
Data Import page. 

  Delete deletes the current record. There is no undo for delete. 
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PREFERENCES 

  Save saves your changes to the preferences. 

DIAGNOSTICS 

  Excel exports the Diagnostic error log to a new *.xlsx file. 

  Delete removes the currently selected error(s) from the Diagnostic error log. There is 
no undo for delete. 

RESOURCE EDITOR 

  Find allows you to search for the resources in the current entity that you want to work 
with in the Resource Editor. 

  Replace allows you to replace all occurrences of a text string in the current entity with 
new text. 

  Update Script opens the Update Script utility, which allows you to specify a range of 
changes that you have made in the current database and implement those changes in 
another database. 

  Default All returns all resources in the current entity to the default text. 

ENTITIES 

  Edit opens the Entity utility, which allows you to edit the entity that is currently 
selected in the Entities page. 

  Create opens the Entity utility, which allows you to add a new entity to the XFRACAS 
database. 

IMPORT 

  Add opens the Add Import File utility, which allows you to specify an *.xml file to 
import into XFRACAS. 
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  Process causes scheduled imports to be processed immediately, rather than waiting 
for a scheduled import. This command will appear only if you have certain permissions. 

  Export allows you to specify one or more records to export to an *.xml file. 

REPORT VIEWER 

  Save saves your changes in the Report Viewer page. 
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Managing Users 
 

The Users page allows you to manage accounts for XFRACAS users. To access this page, you'll 
need the "Access Admin Tab and Manage Users" permission. To open it, choose Admin > 
Configure > Security > Users. 

 

Entities and Users 
If your implementation has more than one entity, the login and contact details will be the same 
for all entities that are assigned to the user (System Wide Information); however, the user's 
permissions and other information will be managed separately for each entity (User Account 
Settings). 

The drop-down list at the top of the page determines which entity-specific information is 
currently displayed. 

User/License Counts 
The following information is displayed in the summary area of the Users page: 

• Current Entity Users - number of user accounts assigned to the current entity 

• Current System Users and Remaining User Licenses - number of user accounts across all 
entities and the number of additional user accounts allowed by your license 

• Current Entities and Remaining Entity Licenses - number of entities and the number of 
additional entities allowed by your license 

• Days Remaining - number of days until the license expires 

Creating a New Account 
To create a new account, the Select Name to Edit list must be blank. You can simply enter 
information into the required fields and choose Admin > Users > Create. 
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To clear an existing user's account information before creating a new one, choose Admin > 
Users > New. 

 

To start with the settings from an existing account, select it from the list and then choose 
Admin > Users > Duplicate. 

 

Editing a User Account 
To edit an existing user account, choose the user name from the Select Name to Edit list. Make 
the desired changes and then choose Admin > Users > Save. 

 

Remember that a user can have different permissions in each entity. If you change the 
permission for one entity, it will not change the permissions in the other entities that the user is 
assigned to. 

Deleting a User Account 
To delete an existing user account, choose the user name from the Select Name to Edit list and 
then choose Admin > Users > Delete. 

 

You can delete a user account only if no records are associated with the account. If the user 
account is listed as an owner, author, team member or reviewer for any record or status, 
choosing Delete will instead retire the user account. 

Retiring a User Account 
A user can be retired from a particular entity or from the entire XFRACAS website. In both 
cases, you can configure the account to be retired automatically on a certain date and time, or 
you can manually retire the account. 
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• To retire an account from the website (all entities), use the options in the System Wide 
Information area. 

• To retire an account from a particular entity, make sure the appropriate entity is selected 
and then use the options in the entity-specific area. 

System Wide Information 
The System Wide Information section of the Users page (Admin > Configure > Security > Users) 
allows you to manage permissions that are common to all entities that the user can access. 

• For name and address, only the First Name and Last Name are required. 

• The Time Zone is the offset from Coordinated Universal Time (formerly known as 
Greenwich Mean Time) that is appropriate for this user. The default setting is specified on 
the Preferences page ("Default GMT Offset for New Users"). 

Tip: If you choose the Local Time option, XFRACAS will detect the current time zone offset 
on the client device and apply that (including the effect of daylight savings time). If you 
select a specific time zone, daylight savings will not be considered and you must change the 
setting twice a year. 

• Language sets the user's preferred language for interface text. If this field is blank, the user 
will see the interface text in the default language for the entity, which is specified on the 
Preferences page ("XFRACAS - Language"). 

• E-mail Address is required. The following preferences can be configured on the Preferences 
page to autopopulate the address based on first and last name (e.g., 
firstname.lastname@email_suffix.com). 

• Under Boolean Preferences: "Manage User - E-mail/Login Auto Build" 

• Under E-mail Preferences: "Manage User - E-mail Suffix Used for Auto Build" 

• Login is required. If you are using Active Directory or Windows Authentication, this is 
typically in the format of "domain\username." If you are using SSO for authentication, it 
would be the SSO ID passed to the application. If you are unsure what to use, ask the user 
to try accessing the website. If the account is not recognized, the login that you need to use 
will be displayed in single quotes in the Unknown User page. 
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Note: If the "Manage User - E-mail/Login Auto Build" preference is enabled, the website 
will automatically start building the login based on the user's first and last names. You can 
edit or replace the text that's automatically populated or change the preference at any 
time. 

• The Retired User Account and Account Expiration Date options in this area will retire the 
account for all entities and the user will have no access to the website. Alternatively, if you 
want to retire the account only for the current entity, use the options in the entity-specific 
area. 

• The Default Entity is the entity that will be selected by default when the user visits the site. 
This field is not displayed until the user's account is created. 

• Entities allows you to assign or remove the user's access to the entities for which you have 
the "Manage Users" permission. Click the link to change the assignments. Note that: 

• This utility only shows entities for which you have permission to manage users. If the 
user has access to other entities, they will be visible in the default entity list. 

• You will not be able to remove access for the user's default entity, which is displayed in 
square brackets. 

• If you remove access to an entity, all entity-specific information will be deleted. If you 
later add the entity back to the user’s account, you will need to re-assign groups, 
categories and permissions. 

Entity-specific User Permissions 

USER SETTINGS 

The entity information section of the Users page (Admin > Configure > Security > Users) allows 
you to manage settings and permissions that apply only to the entity that is currently selected. 

• The Retired User Account and Account Expiration Date options in this area will retire the 
account only for the entity that is currently selected. Alternatively, to retire the account for 
the entire website, use the options in the system-wide area. 

• Security Groups are the security group(s) that the user has been assigned to for the current 
entity. Each security group has certain permissions associated that are managed on the 
Security Groups page. 
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Permissions 

• Permissions by Record Type - user permissions for incidents, problems, projects, CSI 
records, failure analyses and actions 

• Administrative Permissions - permissions that allow the user to access or manage various 
features, functions and tools within XFRACAS 

• Other Permissions - permissions related to details, reports and charts, dashboards, the text 
search utility, the portal, ribbon and data syncing and export functions.  

Assigned Categories, Parts and Open Items 

• Categories - specify which categories, if any, the user belongs to. The available categories 
for each entity are managed on the User Categories page. 

• Responsible Parts - shows parts that the user has been assigned as the owner. When a user 
account is retired, all parts that the user is responsible for should be reassigned. 

 Reassign Owner for Selected Parts allows you to assign a different owner for the part(s) 
that are currently selected. 

 Remove Owner for Selected Parts removes the current user's ownership of the part(s). 
This will also clear the e-mail CC list. 

• Responsible Open Items - displays a count of all open incidents, problems and actions that 
have been assigned to the current user. 

• Clicking each count opens a report that lists all records of that type. When a user is 
retired, all items that the user is responsible for should be reassigned. 

• Reassign Owner for Open Items allows you to assign a different owner for all records 
of a particular type. 

PERMISSIONS BY RECORD TYPE 

Incidents 

Creating, Closing and Deleting Records 

Incident - Create Incident Reports - The user can create incidents. If set to No, the Incident 
button will not appear in the ribbon for that user.  
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Incident - Close Incidents - The user can close incidents that they can edit.  

Warning - Allow Incident Delete - The user can delete incidents. Take care when giving these 
permissions; there is no undo for delete. We recommend granting these permissions only when 
users need to delete a record and then setting this to No after that is done. 

Editing and Reopening Records 

Note: The “Incident - Disable Edit of Closed Incidents” Boolean preference determines whether 
closed records will be editable or read-only. 

Incident - Edit All Incidents - The user can edit all incidents and their associated actions. They 
can also reopen all closed incidents.  

Incident - Edit All Open Incidents - The user can edit all open incidents and any open associated 
actions. 

Incident - Team Edit - If the user belongs to the team, they can edit open incidents.  

Incident - Open a Closed Incident - Determines whether a user who does not have 
the “Incident - Edit All Incidents” permission can reopen a closed incident. The behavior of this 
permission depends on the setting for the “Incident - Disable Edit of Closed Incidents” Boolean 
preference: 

• If the preference is True, users who have the "Incident - Open a Closed Incident" permission 
can reopen a closed incident if they also have the "Incident - Edit All Open Incidents" 
permission or if they are also an incident owner, incident creator or team member with the 
"Incident - Team Edit" permission. 

• If the preference is False, the "Incident - Open a Closed Incident" permission has no effect. 
The user can reopen a closed incident if they are an incident owner, an incident creator or a 
team member with the "Incident - Team Edit" permission. 

Field-level Permissions 

Incident - Change Responsible Part - The user can edit the responsible part after the record has 
been created.  

Incident - Change Owner - The user can change the field that identifies the incident owner.  

Incident/Problem - Change Creator Name - The user can change the fields that identify the 
incident or problem creator.  
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Incident - Duplicate Repair/Replace Row - The user can duplicate line items in the 
Repaired/Replaced Parts table on the Incident page.  

Incident/Problem - Allows Incident/Problem Association - The user can associate incidents 
with problems or problems with incidents.  

Warning - Allow Repaired/Replaced Part Row Delete - The user can delete rows in the 
Repaired/Replaced Parts table. Take care when giving these permissions; there is no undo for 
delete. We recommend granting these permissions only when users need to delete a record 
and then setting this back to No after that is done.  

Note: For serialized incidents, deleting a row removes the replacement part from the system 
configuration and restores the original part, unless the replacement part is from a different 
serialized system. In this case, the part will be removed from the system where it was replaced 
but not restored on the system that it came from. 

These permissions apply to serialized incidents only: 

• Incident - Override Automatic Warranty Determination - This permission applies to 
serialized incidents that are associated with a CSI record, assuming the display preference 
(CSI - Display Warranty Section) is enabled. If set to Yes, the user can change the “Under 
Warranty” determination (Yes or No) that is assigned automatically when the incident is 
created based on criteria established for the CSI record (see Integer Preferences).  

• Incident - Update Location Information - The user can change the "Unit Location" that is 
automatically assigned based on the associated CSI record.  

• Incident - Allow Serialized System Modifications - This permission applies when using the 
Repair or Replace Parts utility. For more information, see Repair or Replace Parts Utility in 
the user help.  

• If set to Yes, the user can specify a replacement part from a source other than the 
current template. This modifies the current template (along with its serialized system) 
but does not change any other serialized systems that are based on this template. Once 
the part has been added, it will be available for use in any other systems that are based 
on the current template.  

• If set to No, the user can only save the new part if it already exists in the template that 
the serialized system is based on.   

These permissions apply to serialized and part incidents: 
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• Incident - Edit Serialized Part Information - The user can specify serial / part numbers 
during incident creation.  

• Setting this permission to No disables those fields and allows the user to create the 
incident without this information.  

• Serial / part numbers can be selected later by a user who has this permission; the fields 
remain editable until the record is saved with part / serial numbers.  

• Incident - Edit System Hours - The user can edit time/usage metrics after the record has 
been created.  

• This permission only applies if the time/usage metrics are not auto-calculated or auto-
populated (the Incident - Always Auto-calculate Time Metric [X] and Incident - Auto-
populate Time Metric 1 preferences are set to False).  

• If the Incident - Edit Serialized Part Information permission is disabled, the user will 
not be able to save time/usage metrics even upon incident creation.  

Problems 

Creating, Closing and Deleting Records 

Problem - Create Problems - The user can create problems. If set to No, the Problem icon will 
not appear in the ribbon for that user.  

Problem - Close Problem - The user can close a problem if they can edit the record.  

Warning - Allow Problem Delete - The user can delete problems. Take care when giving these 
permissions; there is no undo for delete. We recommend granting these permissions only when 
users need to delete a record and then changing them back to No after that is done. 

Editing and Reopening Records 

Once a problem is closed, the record becomes read-only and cannot be edited until it is 
reopened (using the Reopen button) by a user who has the required permissions. 

Problem - Edit All Problems - The user can edit open problems and associated actions. In 
addition, they can reopen closed records without having the "Problem - Open a Closed 
Problem" permission. 
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Problem - Edit All Open Problems - The user can edit open problems and associated open 
actions, but they will require the "Problem - Open a Closed Problem" permission to reopen 
records that are closed. 

Problem - Team Edit - If the user belongs to the team, they can edit open problems and 
associated open actions, but they will require the "Problem - Open a Closed Problem" 
permission to reopen records that are closed. 

Problem - Open a Closed Problem - The user can reopen a closed problem that they have 
permission to edit. 

Field-level Permissions 

Incident/Problem - Change Creator Name - The user can change the fields that identify the 
incident or problem creator.  

Problem - Change Problem Owner and Priority - The user can set the owner and priority when 
creating a new problem and change the owner and priority for an existing one. If set to No, the 
user can still specify the problem's priority when creating a new record, but they can’t change it 
for an existing one.  

Incident/Problem - Allows Incident/Problem Association - The user can associate incidents 
with problems or problems with incidents.  

Problem - Edit FRB List - The user can edit the FRB lists for problems. The problem owner can 
always change the FRB lists, even if this permission is No. 

Projects 

Project - Create Projects - The user can create projects. If set to No, the Project icon will not 
appear in the ribbon for that user.  

Project - Edit All Projects - The user can edit all open projects and associated actions, but they 
will require the “Project - Open a Closed Project” permission to  reopen closed records.  

Project - Team Edit - If the user belongs to the team, they can edit open projects and associated 
actions, but they will require the  will require the “Project - Open a Closed Project” permission 
to  reopen closed records. 

Project - Open a Closed Project - The user can reopen a closed project that they have 
permission to edit. If set to Yes, the Reopen button will be available. 
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Warning - Allow Project Delete - The user can delete projects. Take care when giving these 
permissions; there is no undo for delete. We recommend granting these permissions only when 
users need to delete a record and then changing them back to No after that is done.  

Project - Change Creator Name: The user can change the name of the project creator.  

Customer Support (CSI) Records 

CSI - Create CSIs - The user can create CSI records if they also have the CSI - View Customer 
Support permission. If set to No, the Customer Support icon will not appear in the ribbon for 
that user.  

CSI - Update/Edit Customer Support - The user can edit all customer support records and 
associated actions if they also have the CSI - View Customer Support permission.  

CSI - View Customer Support - The user can view Customer Support pages.  

Warning - Allow CSI Delete - The user can delete CSI records. Take care when giving these 
permissions; there is no undo for delete. We recommend granting these permissions only when 
users need to delete a record and then changing them back to No after that is done.  

CSI - Edit Commission Date - The user can change the Commission Date for the serialized 
system. 

CSI - Edit System Hours Report Date - The user can add time metrics reports to the CSI record.  

• If set to Yes, the Add icon, , appears next to the time metrics field (Customer Support 
Summary section).  

• If set to No, the user cannot manually add metrics reports, but they can still delete any 
reports that have been manually added. 

CSI - Update Ship Date - The user can edit the Shipment Date, which appears in the Customer 
Support Summary section after the record is created.  

Failure Analysis Records 

Failure Analysis - Edit/Update Failure Analysis - The user can edit all failure analysis records 
and associated actions.  
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Actions 

Creating and Deleting Actions for Specific Record Types 

Action - Create CSI Action and Action - Delete CSI Action  

Action - Create Failure Analysis Action and Action - Delete Failure Analysis Action  

Action - Create Incident Action and Action - Delete Incident Action  

Action - Create Problem Action and Action - Delete Problem Action  

Action - Create Project Action and Action - Delete Project Action  

Additional Permissions for Actions 

If the user has the required permission(s) to edit the parent record (e.g., an incident), then they can also 
edit any action associated with that parent. 

Action - Open a Closed Action - The user can reopen a closed action if they were able to edit 
the record when it was open. 

Action - Change Action Association - The user can change the record that an action is 
associated with.  

Action - Set/Alter Action Due Dates - The user can set and change the dates within an action. 
The owner of the record that the action is associated with can edit the action properties, even if 
the permission is set to No. In addition, a user who has permission to edit all records of a given 
type can also edit the action properties.  

ADMINISTRATIVE PERMISSIONS 

Only the administrative permissions that the logged in user has will be shown in this list (i.e., 
you can only give other users a permission that you have yourself). 

• Access Data Export: The user can access the Export command in the ribbon for individual 
records (e.g., incidents, problems, etc.), generic templates, serialized systems and in the 
Import page. 

• Access Import Processing: On the Import page, the user can cause scheduled imports to be 
processed immediately, rather than waiting for a scheduled import. The user must have 
this permission to upload and process files either through the Import page, the web service 
or the API. 
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• Access Master BOM Export: On the Template page, the user can export a list of the 
currently selected part and its child items within the template configuration that the part 
belongs to, including all details associated with all parts. This export is intended to allow the 
user to update the details, part names and part numbers for specific parts. 

• Access Admin Tab: The user can access the Admin tab on the XFRACAS ribbon. 

These permissions enable access to parts of the administrative functionality: 

• Manage Action Categories 

• Manage Active Directory 

• Manage Companies 

• Manage Contacts 

• Manage Criticality 

• Manage Details 

• Manage Diagnostics Page 

• Manage Entities 

• Manage Import 

• Manage Lists 

• Manage Locations 

• Manage Part Owners 

• Manage Report Viewer 

• Manage Resource Editor 

• Manage Security Groups 

• Manage Serialized Systems 

• Manage Template Systems 

• Manage User Categories 
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• Manage User Groups 

• Manage Users 

These permissions allow the user to manage the specific preference types on the Preferences 
page. 

• Manage System-Wide Preferences 

• Manage Entity Preferences 

OTHER PERMISSIONS 

Details 

These permissions set what the user can do with certain types of detail fields in any record 
where that type of detail is used. 

• Details - Allow Issue Creation: The user can enter new drop-down values in a "Select List" 
detail field that has the Allow User Creation option selected. 

• Details - Edit All Statuses: The user can edit statuses that have been entered, by any user, 
in a "Status" detail. 

• Details - Overwrite Read-Only: The user can modify detail fields that are set to "Read-Only 
- Always." This option is intended to be used for values that will be imported and should 
not be changed by users via the web interface. This permission enables the user to correct 
the imported values if needed. 

• Details - Allow Failure Mode Creation: The user can create failure modes. 

• Details - Delete Associated File: The user can delete files that have been uploaded/linked in 
an "Attachments Table" detail. There is no undo for delete. 

Reports and Charts 

These permissions enable the user to view reports and charts: 

• Reports - Access Reports Page: The user can run reports. 

• Charts - Access Charts Page: The user can run charts. 
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• Reports - My Queries Enabled: The user can view and use reports saved to the "My 
Reports" and "My Chart Reports" lists. 

• Reports - Public Queries Enabled: The user can view and use reports saved to the "Public 
Reports" and "Public Chart Reports" lists. 

• Report - Show Report SQL: The user can view the SQL statement used with report results, 
using the Show SQL Statement icon on the Reports Toolbar. 

• Allow Sending XFRACAS Data via E-mail: The user can send report results via e-mail, using 
the E-mail Report icon on the Reports Toolbar. 

These permissions enable the user to build reports and charts: 

• Report Builder - Access Report Builder: The user can use the Report Builder to create 
custom reports and charts and to modify their versions of the built-in standard reports for 
their personal use. 

• Report Builder - Set Application Default: The user can use the Report Builder to modify the 
application default for each type of standard report and chart. 

• Reports - Access Custom SQL Reports: The user can use the Report Builder to create 
custom SQL statements. 

• Report Builder - Assign or Remove Public Access: The user can save reports to the "Public 
Reports" and "Public Chart Reports" lists. There is a separate permission for the ability to 
access public reports in the Reports or Charts page ("Reports – Public Queries Enabled"). 

• Reports - Save Report for Another User: The user can save a report to another user's or 
group's "My Reports" or "My Chart Reports" lists. If you save the report for yourself, a 
separate permission is needed to access "my reports" in the Reports or Charts page 
("Reports – My Queries Enabled"). If you save the report for someone else, you will not be 
able to view it again after it is saved. 

Note: This also controls the ability of a user to save dashboard layouts for another user or 
group. 

• Reports - Serialized System Search Enabled and Reports - Template Part Search Enabled: 
The user can see the Serialized Search and Part Search commands in the Report Builder 
ribbon. These enable the user to find specific part numbers and serial numbers without 
giving admin permissions to the part template and serialized system pages. 
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Dashboards 

These permissions enable the user to view and design dashboards: 

• Dashboard - Access Dashboard Page: The user can view existing dashboard layouts. 

• Dashboard Designer - Access Dashboard Designer Page: The user can create custom 
dashboard layouts. 

• Dashboard Designer - Assign or Remove Public Access: The user can make dashboard 
layouts available to all users in the current entity. 

• Dashboard Designer - Set Application Default: The user can use the Dashboard Designer to 
modify the application default dashboard layout. 

Test Search for Select Existing Utility 

The following permissions enable the user to access the Select Existing Utility for description 
and status fields. (See Configuring the Select Existing Utility.) 

• Details - Allow Existing Text Search 

• Action - Allow Existing Text Search 

• CSI - Allow Existing Text Search 

• Project - Allow Existing Text Search 

• Failure Analysis - Allow Existing Text Search 

Portal 

These permissions enable the user to edit his/her portal preferences and information: 

• Portal - Edit User Information: The user can edit their own user information (Options > 
Settings > User Information). 

• Portal - Edit Portal Preferences: The user can change their own portal preferences. 

• Portal - Set Default Portal Preferences: The user can change the Portal preferences that 
are used by default for new accounts (using the "Save as application default" check box). 

• Links and Announcements: These permissions allow the user to create and modify public 
links and announcements. 
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• Portal - Create Public Links and Announcements 

• Portal - Modify Public Links and Announcements 

Ribbon 

Ribbon - Quick Search Enabled enables the user to view and use the Quick Search utility that 
appears at the top of many pages. 

Data Syncing and Export 

• RS Desktop - Read Failure Mode Data: The user can import or sync failure mode data with 
XFMEA/RCM++/RBI.  (See Import or Sync from XFRACAS in the XFMEA/RCM++/RBI 
documentation.) 

• RS Desktop - Read Time to Event Data: The user can export time to event data for use in 
Weibull++. (See Reliability Data Warehouse in the Weibull++ documentation.) 

Adding Users from Active Directory 
Use the Active Directory page to add users from Microsoft Active Directory. Permissions 
required to access this page: Access Admin Tab and Manage Active Directory. 

To open the page, choose Admin > Configure > Security > Active Directory. 

 

Note: This feature uses settings that are specified on the Preferences page. See Entering an ADS 
Path. 

USING THE ACTIVE DIRECTORY PAGE 

First, use the Search Options fields to narrow the Active Directory users that will be shown: 

1. Specify the Domain to search in. 

2. Specify a Group Type. 

3. If desired, enter text to search for in the Group Name field to limit the groups shown. 

4. Click the Load Groups icon, , to populate the Group drop-down list. Select the group of 
interest from the list. 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=import_from_xfracas.htm
http://help.reliasoft.com/weibull20/index.htm#t=reliability_data_warehouse_rdw.htm
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5. If desired, use the Filter By fields to select a criterion for filtering the users and to specify 
the text to match. 

Once you have specified all of your search criteria, click the Load Users link to populate the 
Active Directory Users list. Any Active Directory users that already have XFRACAS accounts will 
be shown in the Current XFRACAS Users list. 

Use the arrows to move some or all user names from the Active Directory Users list to the New 
XFRACAS Users list. You can then set the basic account information, user groups, categories 
and permissions for all of the users in the New XFRACAS Users list. (For more details on these 
settings, see Managing Users.) Choose Admin > Users > Create to create the accounts. 

 

The accounts will be created, and will appear in the Current XFRACAS Users list. 

 

Managing User Categories 
The User Categories page allows you to maintain categories that users can be assigned to. 
These categories determine which users will appear in certain drop-down lists throughout the 
application. Permissions required to access this page: Access Admin Tab and Manage User 
Categories. 

To open the page, choose Admin > Configure > User Categories. 

 

If your implementation has more than one entity, the user categories can be configured 
separately for each. The drop-down list at the top of the page determines which entity's 
categories are currently displayed. 

• To create a new user category, click the Add icon, . 

• To edit an existing user category, select it in the list and click the Edit icon, . Changes will 
apply to all user accounts that have already been associated with that category. 

• User Category Description - the name of the category. 

• Display Order - the order in which categories are displayed in the Users page and, if 
applicable, when assigning Failure Review Boards (FRBs) in the Problem page. 
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• FRB Reviewer - a check box that must be enabled if you want the user category to 
appear in the Available Reviewers List, which allows users to be assigned to an FRB on 
the Problem page. 

• To remove a user category from the current entity, select it in the list and click the Delete 
icon, . If the category is associated with any other entities, it will still be available for 
those entities. 

The following default categories cannot be deleted or renamed: 

• The D2 Approver - D8 Approver categories correspond to the steps in a problem and 
determine which users can be assigned to an FRB to approve those respective steps. (See 
Failure Review Boards in the user help.) 

• Default Problem Reviewer determines which users appear by default in the Selected 
Reviewers List for a problem step. To appear in the list, users must be assigned not only to 
 the "Default Problem Reviewer" category but also to the approver category (D2 - D8) for 
the problem step. 

• FA Engineer sets permission for the user to be assigned as a failure analysis engineer. 

• Legal Expert determines the list of users who can be assigned to the "Legal" role in a team. 
(See Assign Team Members Utility in the user help.) 

• Problem Owner determines the list of users for the Owner field on the Problem page. 

• Project Owner determines the list of users for the Owner and Creator fields on the Project 
page. 

 

Managing Security Groups 
Use the Security Groups page to manage sets of permissions and categories that can be 
assigned to individual user accounts. The categories and permissions on this page are the same 
as those on the Users page. Permissions required to access this page: Access Admin Tab and 
Manage Security Groups. 

To open the page, choose Admin > Configure > Security > Security Groups.   
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If your implementation has more than one entity, user permissions can be managed separately 
for each. 

CREATING A SECURITY GROUP 

To create a new security group, you can: 

• Leave the Select Group to Edit drop-down list blank. Enter the group name and description, 
set the permissions and then choose Admin > Security Groups > Create. 

 

• If you are currently viewing an existing security group and want to clear the information 
and create a new group, choose Admin > Security Groups > New or clear the Select Group 
to Edit field. 

 

You can then enter the group name and description, set the permissions and choose Admin 
> Security Groups > Create. 

EDITING A SECURITY GROUP 

To edit an existing security group, choose the group from the Select Group to Edit drop-down 
list. Make the desired changes and then choose Admin > Security Groups > Save. 

 

DELETING A SECURITY GROUP 

To delete an existing security group, choose the user name from the Select Group to Edit drop-
down list and then choose Admin > Security Groups > Delete. 

 

Note that this will remove any users from the group and delete the group. Any users with 
permissions via the group will lose those permissions. 

GROUP MEMBERSHIP 

Click Manage Group Membership to view or modify the users who are assigned to this security 
group. (Note that you can also change a particular user's security group from the Users page.) 
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If your organization uses Microsoft Active Directory, you can manage the membership of any 
security group based on an associated Active Directory group. For example, any users assigned 
to the "ABC Team" or the "XYZ Team" in Active Directory can be assigned to have specific sets 
of permissions in the entity. If a user needs to be added or removed from a security group, the 
administrator can manually sync the group to the Active Directory group to reflect the changes 
made in Active Directory. 

To associate a security group with an Active Directory group, select the Associate Active 
Directory Group check box and then specify the domain name. Click the Load icon, , beside 
the Security Group field to load available groups, then select the group and click the Load icon 
beside the Active Directory Users field to load the users in the group. Click Associate to finalize 
the association. 

Managing User Groups 
Use the User Groups page to manage predefined groups of users and team roles that can be 
quickly assigned to teams for incidents, problems or projects. Permissions required to access 
this page: Access Admin Tab and Manage User Groups. 

To open the page, choose Admin > Configure > Security > User Groups. 

 

If your implementation has more than one entity, you must create separate user groups for 
each entity. 

CREATING A GROUP 

1. Make sure the Select Group to Edit drop-down list is blank. If you are currently viewing 
another group, you can either choose the blank option from the list, or click Admin > User 
Groups > New. 

 

2. Enter at least a Name for the new group. 

3. Click Admin > User Groups > Create. 
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ASSIGNING MEMBERS TO A GROUP 

1. Select the group from the Select Group to Edit drop-down list. 

2. Click Assign/Remove Members to open the Assign Members utility. 

 

• To add users, select a Team Role, then select the user(s) who will have that role, then 
click Add User(s). Note that only users who have the "Legal Expert" category in the 
Users page can be assigned to the "Legal" role on a team. 

• To remove group members, select the user(s) in the Current Members list and click 
Remove Selected. 

• Click Save to close the window. 

Changes to group members are saved when you close the Assign/Remove Members window. If 
you need to save changes to the group's name or description, choose Admin > User Groups > 
Save. 

 

DELETING A GROUP 

To delete an existing user group, choose the group name from the Select Group to Edit drop-
down list and then choose Admin > User Groups > Delete. 

 

 

Managing Applicants 
Use the Applicants page to process user account requests that have been submitted via the 
"Request Access" process. Permissions required to access this page: Access Admin Tab and 
Manage Users. 

To open the page, choose Admin > Configure > Security > Applicants. 
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Tip: The process also sends an e-mail to the administrator of each entity that the user has 
requested to access (as specified in the "Administrator E-mail" preference). Click the link in the 
e-mail to open the Applicants page. 

If your implementation has more than one entity, the applicants will be managed separately for 
each. The drop-down list at the top of the page determines which entity's applicants are 
currently displayed. 

GRANTING ACCESS 

The Select Name to Edit list shows the applicants who have requested access to the current 
entity. 

To grant access, select a name from the list and review/update the system-wide and entity-
specific information. These are the same options as in the Users page. Then choose Admin > 
Users > Create. 

 

REMOVING AN APPLICANT 

To remove an applicant, select the name from the list and choose Admin > Users > Delete. 
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Managing Parts and Systems 
 

Managing System Templates 
Use the Template page to view and manage generic system configurations that identify the 
types of parts that may be included in a system (e.g., "Bill of Materials") or the steps in a 
process. If applicable, you can use these templates to create separate serialized configurations 
for the specific parts in a particular piece of equipment. Permissions required to access this 
page: Access Admin Tab and Manage Template Systems. 

To open the page, choose System > System > Template. 

 

If your implementation has more than one entity, the system templates are managed 
separately for each. The drop-down list at the top of the page determines which entity's 
templates you are currently managing. 

CREATING A NEW TEMPLATE 

To create a new system template, choose System > Template > Create Template. 

 

In the Create Template utility, enter at least the part number and part name. 

To import a system configuration from XFMEA, RCM++ or RBI, choose System > Template > 
XFMEA Import. 

 

This command appears only if the database has at least one desktop project that has a system 
hierarchy. You must also have  permission to access this project. (See Import or Sync from 
XFMEA.) 

VIEWING AN EXISTING TEMPLATE 

To view or edit an existing system template, choose System > Template > Find Template. 
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In the Find Template utility, you can search by part name or part number. Alternatively, if you 
want to see a list of all system templates in the current entity, leave the value blank and click 
Search. 

VIEWING HIERARCHY AND PART PROPERTIES 

When you are working with an existing system template, the left side of the page shows the 
hierarchical configuration and the right side shows the properties for the part that is currently 
selected.   

If you are working with a large system configuration, the Part Search utility provides a quick 
way to find the part you want to view or edit. Click the Find part on system... link at the top of 
the hierarchy, then search based on part number, name or version. 

EDITING AN EXISTING PART 

To edit an existing part, select the part in the hierarchy and choose System > Part > Edit. 

 

CREATING OR ASSOCIATING PARTS 

When adding parts to a template, you can create a new part (with a new unique Part ID) or add 
an instance of an existing part (with the exact same Part ID used multiple times in the same 
template and/or in multiple templates). 

To add a new part, or to add an existing part when you know the part number and version, 
choose System > Part > Create. 

 

In the Create Template Part utility, enter at least the part number and part name and click 
Save. The behavior depends on whether the Use Existing Part if Found check box is selected 
and whether there are any existing parts with the same part number and version: 

• Not selected - creates a new part with a unique Part ID. 

• Selected and no matching parts - creates a new part with a unique Part ID. 
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• Selected and at least one matching part - opens the Associate Template Parts utility where 
you can select an existing part to add. 

To add an existing part when you don't know the part number and version, or to add multiple 
existing parts at the same time, choose System > Part > Associate. 

 

In the Associate Template Parts utility: 

• When you click a part in the Available Items List, the area at the bottom of the utility 
shows where that part is used, and whether it has subitems (aka "children"). 

• The Selected Items Lists shows the existing part(s) that will be added to the current 
template when you click OK. If the Associate Children check box is selected, any 
subitems/children will also be associated at the same time. Note that the save process may 
take several minutes if you are associating a large number of existing parts. 

DELETING, RETIRING OR DISASSOCIATING A PART 

When removing parts from a template, the behavior depends on the command you choose and 
the location(s) where the part is used. 

To remove a part that you don't want to use again, select the part in the hierarchy and choose 
System > Part > Delete. 

 

• If the part is not used anywhere else, it will be permanently deleted. 

• If the exact same Part ID is used in another location within the current template or in a 
different template, it will be removed from the current location and remain unchanged in 
the other location(s). 

• If this is the only location where the part is used in a template, and the part has been used 
in at least one incident, problem or serialized system, it will be "retired." A retired part 
continues to show in the system hierarchy, identified by an icon and with the retirement 
date shown in brackets. 
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Tip: The application provides a warning when you attempt to delete a part that will have to be 
retired because it is used in at least one incident, problem or serialized system. In addition, if a 
part has already been retired, the Part in Use area will display in the part properties panel. If 
you want to permanently delete the part, you must first remove it from all locations where it is 
used. 
 
Also note that if a part has ever been saved as the Responsible Part for an incident, it will 
remain in the Responsible Part History for that record, and therefore cannot be permanently 
deleted. 

To remove a part that may be used again in another template or in a different location in the 
current template, select the part and choose System > Part > Disassociate. 

 

This will remove the part from the current location and create a new top-level part that you can 
later associate in a different location. 

DEFINING FAILURE MODES 

The potential failure modes and root causes defined for a template part will be available for 
selection in failure mode detail fields (if any) in the incidents, problems or failure analysis 
reports. 

 Add Failure Mode adds a new failure mode for the part. 

 Add Existing Failure Mode copies failure mode(s) and root cause(s) that were defined 
for another part. 

  Add Root Cause adds a new root cause for the selected failure mode. 

To edit or delete an existing failure mode or root cause, select it and click Edit, , or  Delete, 
. 

If you are using ReliaSoft XFMEA, RCM++ or RBI for failure modes and effects analysis, you also 
have the option to import and/or synchronize system templates and failure modes. (See Import 
or Sync from XFMEA.) 
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ASSIGNING AN OWNER 

Each template part can be associated with an owner. Parts that have an owner are indicated in 
the template by . 

When users create new incidents, if they do not specify an incident owner, it will be set 
automatically to the owner of the first responsible part. Depending on the configurable settings 
for the entity, the incident owner may receive e-mail notifications when the incident is created, 
when actions are created for the incident, etc. 

Note: If the incident page is configured to require users to select a single responsible part from 
a drop-down list (i.e., if the "Incident - Use Tree to Select Responsible Part" preference is false), 
users will not be able to create incidents until there is at least one template part with an owner 
assigned. The following warning will be displayed in the incident page: "Incomplete System 
Setup: Responsible Part not configured correctly. Please contact your XFRACAS administrator." 

• To assign an owner, select the part and choose System > Part > Assign Owner. 

 

• To remove the owner, select the part in the template and choose System > Part > Remove 
Owner. 

 

• To add more users to the e-mail notification list for a part that already has an owner, select 
the part and choose System > Part > CC List. 

 

 

Managing Serialized Systems 
Use the Serialized page to view and manage serialized system configurations, which are based 
on generic system templates. For example, the template for Model A identifies all the parts that 
may be included in specific units. The serialized system identifies the parts that actually are 
included in a specific unit, including the unique serial numbers when applicable. Permissions 
required to access this page: Access Admin Tab and Manage Serialized Systems. 

To open the page, choose System > System > Serialized. 
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If your implementation has more than one entity, the serialized systems must be configured 
separately for each. The drop-down list at the top of the page determines which entity's 
systems you are currently managing. 

CREATING A SERIALIZED SYSTEM 

To create a serialized system, choose System > Serialized > Create System. 

 

In the utility that appears, choose the kind of system you want to create from the Template 
Part drop-down list. Then enter the serialized part properties. 

FINDING AN EXISTING SYSTEM 

To work with an existing serialized system, choose System > Serialized > Find System. 

 

In the utility that appears, you can search by system serial number or by subsystem serial 
number. 

SYSTEM CONFIGURATION 

When you are creating or editing a serialized system, the system configuration is displayed on 
the left side of the interface. Click the plus (+) or minus (-) icons to expand or collapse a branch 
of the tree. 

To locate a specific part, click the Find part on system link at the top of the hierarchy to search 
by part number or serial number. 

 

If a part in the system configuration has been replaced, it will appear at the bottom of the 
hierarchy and a replacement date will appear next to it. Replaced parts are indicated by . 
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ADDING OR REMOVING PARTS 

Once you have selected a system to work with, you can add new or existing parts to it and you 
can remove parts from the system. 

• Create Serialized - adds a part based on the generic system template and requires you to 
enter a unique serial number. 

 

• Add Existing Serialized - removes a part from another system and moves it to the current 
system. 

 

• Add Non-Serialized - adds a part based on the generic system template and does not 
require you to enter a unique serial number. 

 

If you select the Associate Children check box, all children of each newly selected part will 
also be added to the list of selected items. Note that this can add a large number of parts 
and that, depending on the size of the tree underneath each selected part, the save process 
may take several minutes. To see a detailed view including child parts, click the View 
Structure link in the item hierarchy to open the full hierarchy in a new window. 

• Disassociate - removes the selected part from the system and makes it available for future 
use. 

 

• Delete Serialized - removes the selected part from the system, unless there are already 
records pertaining to the part, in which case the part is retired instead. 

 

SERIALIZED PART PROPERTIES 

• The Serial Number and Build Date are required for a system while only the Build Date is 
required for parts. 

• These characters are not allowed in serial numbers: @ # % & = { } " < >. 
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• If the part has accumulated age before being added to the system (i.e., the part is "used"), 
specify the Starting Age (e.g., "Run Hours," "Number of Starts" or "kw Run Hours"). If you 
extract the data to Weibull++ for reliability analysis, the starting age may be added to the 
part's time on the system to estimate the part's time/usage. (For example, if the part had a 
starting age of 100 hours when it was added to the system, the system runs for 200 hours 
before the next failure and you have not directly specified the part's time/usage, we 
assume it is 300 hours.) 

If you have configured additional detail fields to meet your organization's specific needs, they 
will be grouped together in a separate Details area. 
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Managing Preferences 
Preferences 
 

Use the Preferences page to manage many of the configurable settings within XFRACAS. 
Permissions required to access this page: Access Admin Tab, and Manage System Wide 
Preferences or Manage Entity Preferences. 

To open the page, choose Admin > Configure > Preferences. 

 

Choose Admin > Preferences > Save to save any changes. 

 

System-Wide Preferences apply to your organization's entire XFRACAS implementation; all 
other preferences must be managed separately for each entity. The drop-down list at the top of 
the Preferences page determines which entity-specific preferences are currently displayed. 

Preferences are grouped by type (e.g., true/false, date, string, etc.) and then listed 
alphabetically on the XFRACAS Preferences page. In the help topics listed below, however, 
related preferences are discussed together when applicable and may not always appear in 
alphabetical order. 

• System-Wide Preferences 

• Boolean Preferences 

• Date Preferences 

• Display Option Preferences 

• Integer Preferences 

• String Preferences 

• Time Zone Preferences 
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• URL Preferences 

• Target and Completed Dates 

Preferences for e-mail alerts are covered in a separate help section. To see which preferences 
apply for a given situation, see Conditions for Triggering E-mail Alerts. 

  

SYSTEM-WIDE PREFERENCES 

To open the Preferences  page, choose Admin > Configure > Preferences. 

Secure Socket Layer Protection 

SSL Server Mode Required: If True, the website will use https (rather than http) when building 
links. Before you enable this option, make sure the IIS web server is configured properly for 
SSL/TLS (as discussed in the Implementation Guide). 

SSO Authentication - XFRACAS uses Windows authentication by default. Alternatively, if your 
web server is set up to support SSO authentication, XFRACAS will check for the "Auth_User" 
variable by default. If your SSO method has been configured to use a different variable, set the 
following preferences: 

• Single Sign-On (SSO) Authentication Enabled: If True, indicates that your web server is set 
up for SSO authentication and uses a variable other than "Auth_User." 

• Single Sign-On (SSO) Server Variable: The alternative variable that XFRACAS needs to check 
for SSO authentication. 

The admin/TESTSSO.aspx page on the website provides additional details to help with 
troubleshooting the configuration. 

Location of the XFRACAS Website 

XFRACAS Server - Filesystem Prefix: The absolute path on the server where the website's IIS 
folder is installed (e.g., C:\inetpub\wwwroot\XFRACAS\). 

XFRACAS Server - IIS Prefix: The path that can be used to build links to pages within the 
XFRACAS website (e.g., servername/XFRACAS or 10.0.0.2/xfracas). 

http://help.reliasoft.com/documents/version2020/IG_XFRACAS20.pdf
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Link to the SEP Web Portal (if Applicable) 

Display SEP Command: If True, the XFRACAS ribbon will include a link to your organization's SEP 
web portal. 

SEP Server - IIS Prefix: The path that can be used to build the link to the SEP web portal (e.g., 
servername/SEP). 

Upload Files for Attachments 

Attachments - Allow Uploaded Files: If True, the Attachments window will include the option 
for users to upload files. The files may be stored in the database or uploaded to a designated 
folder on the web server, depending on how you configure the related preferences. 

Attachments - Store Uploaded Files in Database: If True, files will be stored in the database. If 
False, files will be stored in a designated folder on the web server. 

Attachments - Uploaded Files Filesystem Prefix: If applicable, this is the absolute path to the 
folder on the web server where uploaded attachments will be stored (e.g., 
C:\inetpub\wwwroot\XFRACAS\uploads\ or D:\storage\xfracas) For requirements and 
instructions to prepare this folder, refer to the Implementation Guide. 

Attachments - Uploaded Files IIS Prefix: If applicable, this is the path that will be used to build 
links to download files that were saved on the web server. 

• If you are using an actual file folder within the website, enter a relative path (e.g., uploads). 

• If you are using a virtual directory created in IIS, use an absolute path (e.g., 
http://servername/uploads). 

SMTP Server for E-Mail Notifications 

SMTP Server: The address of the SMTP server that will be used for sending e-mails (e.g., 
mail.servername.com or 10.0.0.2). 

SMTP Port: The port used to connect to the SMTP server. If left blank, the default SMTP port 25 
will be used. 

SMTP Connection Timeout: The amount of time, in seconds, before the connection to the 
SMTP server times out when sending e-mails. 

http://help.reliasoft.com/documents/version2020/IG_XFRACAS20.pdf
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Other 

Use Web-based Help: If True, the help commands always open the most up-to-date help files 
from the Internet when possible. If False, they open the local help files that were installed with 
the software. 

DIU Service - Generate Import Log: If True, an import log will be generated during an import. 
The log will be stored with the import record. 

Terms of Use Agreement Page Required: If True, users will be prompted to accept an 
agreement the first time they access XFRACAS each day. To customize the content of the 
agreement, edit the files directly on the web Server: 

• Agreement.aspx is stored in the website's main folder and will be displayed if the user visits 
any of the regular pages. 

• AdminAgreement.aspx is stored in the website's Admin folder and will be displayed if the 
user visits any of the admin pages. 

Unknown Users - Allow Account Request: If True, users not already in XFRACAS can request 
access to the system, and users not already in an entity can request access to the entity. 

Report Filter Display Max Rows: Indicates the maximum number of rows that a report can 
return and still have filtering and grouping capabilities. 

DB Version and License Number: The database version and license number of the XFRACAS 
system. These are available for technical support purposes and cannot be changed. 

BOOLEAN PREFERENCES 

To open the Preferences  page, choose Admin > Configure > Preferences. 

Incident Preferences 

Display Preferences 

Incident - Display Incident Wizard: If True, the Use Incident Wizard command will be available 
for new Incident records. The wizard prompts users to enter the data one step at a time, 
instead of all in a single form. 

These preferences show/hide some of the fields in the Incidents page. For information about 
how these fields are used, see Incidents. To configure other fields for this record type, use the 
Details page. 
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• Incident - Display Unit Location 

• Incident - Display Title (and Incident - Require Title) 

• Incident - Display Team Members 

• Incident - Display Potential Criticality and Incident - Display Actual Criticality (see 
Managing Criticality Fields) 

• Incident - Display Service Response Time/Date 

• Incident - Display ASP Field Service Tech (and Incident - Require ASP Field Service Tech) 

• Incident - Display Repair Duration 

• Incident - Display Repair/Replace Parts 

Incident - Display System Status: If True, the System Status field will show in part incidents, for 
information purposes only. This field is always hidden for simple incidents and always shown 
for serialized incidents. When applicable, the summary area of the Customer Support page 
displays the current status for a particular system based on all of the serialized incident reports 
for that unit. 

These preferences specify whether to display calculated metrics in the summary for a serialized 
incident. 

• Incident - Display Calculated Response Time 

• Incident - Display Calculated Downtime 

Incident/Problem - Display Audience Restriction and Incident/Problem - Require Legal Team 
Member: If both of these preferences are True, the Audience Restriction field will be displayed 
in the Incident page and Problem page after the record is created, and if the "Attorney/Client 
Privilege" option is selected for a particular incident or problem, then: 

• Only users assigned to the team for that record will be able to view it in any form. Make 
sure the "Incident - Display Team Members" and "Project - Display Team Members" 
preferences are also enabled so users will be able to assign an appropriate team before 
restricting access to the record. 

• The team assigned to the record must have at least one user assigned to the "Legal" team 
role. Only users who have the "Legal Expert" category in the Users page can be assigned to 
this role. 
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Incident - Display Customer Requested Feedback: If True, the "Customer Requested Feedback" 
check box is displayed in the Incident page and the "Report Sent to Customer" check box is 
displayed on the Failure Analysis page. 

E-mail Alert Preferences 

These preferences specify whether e-mails are sent to the incident owner and/or team 
whenever an incident is closed: 

• Incident - E-mail - Incident Closed 

• Incident - E-mail - Incident Closed - Team 

Time Metrics Preferences 

Incident - Auto-populate Time Metric 1: If True, the primary time/usage metric field (e.g., 
hours. miles, kilometers, cycles, etc.) will be populated automatically in a serialized incident 
when the required inputs are available. (See Time Metric Calculations.) 

These preferences specify whether to track additional time or usage metrics (e.g., hours, miles, 
kilometers, cycles, etc.) in the Customer Support page and Incident page for serialized incidents 
and part incidents. By default, these three metrics are labeled "System Hours," "Number of 
Starts" and "kW Run Hours" but you can use the Resource Editor to customize the labels to fit 
your specific needs. 

• Incident - Display Time Metric 2 

• Incident - Display Time Metric 3 

These preferences specify whether to automatically calculate the value of one time/usage 
metric based on the value entered for another. The behavior also depends on the "Display Time 
Metric" and "Time Metric Formula" preferences. (See Time Metric Calculations.) 

• Incident - Always Auto-calculate Time Metric 1 

• Incident - Always Auto-calculate Time Metric 2 

• Incident - Always Auto-calculate Time Metric 3 

Part / Responsible Part Preferences 

Incident - Use Tree to Select Responsible Part: If True, the "Responsible Part" field in the 
Incident page will allow users to select one or multiple parts from a tree view of all system 
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templates. If False, users can select only one part from a drop-down list. When the tree is used, 
you can also specify: 

• Incident - Auto-select Responsible Part for New Incidents: If True, the part number 
specified in the System/Component Information area will be selected by default in the 
Responsible Part tree. 

• Incident - Enable Responsible Part Filter: If True, the Responsible Part tree will only allow 
users to select parts from the system specified in the System/Component Information area. 

Incident - Defaults: These preferences apply when the entity has only one system template 
defined. If True, then XFRACAS will automatically set relevant part fields when creating a new 
incident. 

• Incident - Default Part Number 

• Incident - Default Responsible Part 

These preferences specify whether XFRACAS will automatically set date fields in the incident 
based on today's date. 

• Incident - Default Repair Date 

• Incident - Default Response Date 

Closure Preferences 

Incident - Closure: These preferences specify the conditions that must be met to close an 
incident. Select all that apply. 

• Incident - Closure Restriction Level 1: All actions for the incident are completed. 

• Incident - Closure Restriction Level 2: All failure analysis reports belonging to the incident 
are closed. 

Note: Once an incident is closed, it no longer appears in the XFRACAS Portal under "Unclosed 
Incidents." 

Incident - Disable Edit of Closed Incidents: This preference determines whether closed 
incidents will be read-only or editable for users who have permission to reopen them. (See 
Permissions by Record Type.)  
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• If True, closed incidents will be read-only and can be reopened using the Reopen button.  

• If False, closed incidents will be editable and can be reopened by changing their state. 

Problem / Incident Preferences 

Allow Cross Entity Association: These preferences apply when assigning an incident to a 
problem or assigning a problem to a project. They also apply when creating an attachment to 
an XFRACAS record. If True, records from all entities that the user has access to will be 
available. If False, only records from the current entity will be available. 

• Incident/Problem - Allow Cross Entity Association 

• Project/Problem - Allow Cross Entity Association 

These preferences apply when the user clicks the Create New Problem icon in the Incident 
Summary Area of the Incident page. (See "Assigning an Incident to a Problem" in the user help 
for more information.) 

• Incident - Create Problem Link Transfers Incident Description: If True, the incident's 
description will be used to auto-populate the description field in step 2 of the problem. 
(See Problems.) 

• Incident - Create Problem Link Transfers Incident Title: If True, the incident's title will be 
used to auto-populate the title field in step 2 of the problem. 

• Incident - Create Problem Link Transfers Responsible Part: If True, the incident's 
responsible part will be used to auto-populate the Part Category Code field in step 1 of the 
problem. If the incident has multiple responsible parts, only the first part in the list of 
responsible parts is transferred. 

Other Incident Preferences 

Incident - Assign Creator as Owner: If True, the user who creates the incident will be assigned 
as the owner of the incident. If False, the incident owner depends upon the responsible part or 
the choice in the Owner field. 

Incident - Require Date Field Validation: If True, the date in any date field on the Incident page 
cannot be less than the incident's creation date. 
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Problem Preferences 

Display Preferences 

These preferences show/hide some of the fields in the Problem page. For information about 
how these fields are used, see Problems. To configure other fields for this record type, use the 
Details page. 

• Problem - Display Team Members 

• Problem - Display Requested Closure Date 

• Problem - Display Expected Closure Date 

• Problem - Display Associated Incidents 

• Problem - Display Associated Projects 

These preferences show/hide some of the fields in the Associated Incident Reports section on 
the Problem page. 

• Problem - Display Incidents by Status (open or closed) 

• Problem - Display Incidents by Chargeability (chargeable or non-chargeable) 

Problem - Show Steps: These preferences specify which of the optional steps will be displayed 
on the Problem page in addition to the four steps that are always displayed: Establish the 
Team, Describe the Problem, Choose and Verify Permanent Corrective Actions and Prevent 
Recurrence. 

• Problem - Show Step - Implement and Verify Containment Actions 

• Problem - Show Step - Identify and Verify Root Cause 

• Problem - Show Step - Implement Permanent Corrective Actions 

• Problem - Show Step - Congratulate the Team 

Problem - Always Show All Problem Steps: If True, after a user has entered the first step and 
created a new problem, the page will show all of the subsequent steps that need to be 
performed. If False, each subsequent step will be displayed only after the previous step is 
completed and saved. 
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FRB and Closure Preferences 

Problem - FRB Sign-Off Restriction: This applies only if the "Problem – FRB Sign-Off CC 
Restriction" preference is True. If True, the review request e-mail will be sent only to the next 
FRB reviewer based on priority order. If False, the e-mail will be sent to all reviewers on the 
Failure Review Board (FRB) reviewers list for the current step. 

Problem - FRB Sign-Off CC Restriction: If True, the priority order of FRB reviewers will be 
enforced. Once the first reviewer signs off on the problem step, the second reviewer can then 
review the step. Reviewers cannot sign off out of order. 

These preferences specify the conditions that must be met before a problem step or problem 
can be closed. Select all that apply. 

• Problem - Closure Restriction Level 1: All actions for the problem must be completed. 

• Problem - Closure Restriction Level 2: All incidents associated with the problem must be 
closed. 

• Problem - Closure Restriction Level 3: All actions associated with a problem step must be 
completed before you can close the step. 

When a problem is closed, it no longer appears in the XFRACAS Portal under "Open Problems." 
Only users with the "Problem - Open a Closed Problem" or "Problem - Edit All Problems" 
permissions can reopen a closed problem. 

Other Problem Preferences 

Problem - Completed Date Warning: If True, entering a problem completed date that is in the 
future will show a warning. 

Problem - Enable Created Date Restriction: If True, the problem's creation date must be earlier 
than the completion/sign-off date for any step in the problem. 

Project Preferences 

Display Preferences 

These preferences show/hide some of the fields in the Project page. For information about how 
these fields are used, see Projects. To configure other fields for this record type, use the Details 
page. 

• Project - Display Team Members 
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• Project - Display Target Completion Date 

• Project - Display Revised Completion Date 

• Project - Display Actual Completion Date 

• Project - Display Scope of Project 

• Project - Display End Result 

• Project - Show Associated Problems 

• Project - Show Associated Incident Reports 

• Project - Display Associated Incidents 

• Project - Show Associated FA Reports 

Closure Preferences 

These preferences specify the conditions that must be met before a project can be closed. 
Select all that apply. 

• Project - Closure Restriction Level 1: The actual completion date must be set and all actions 
for the project must be completed. 

• Project - Closure Restriction Level 2: The actual completion date must be set and all 
problems associated with the project must be closed. 

When a project is closed, it no longer appears in the XFRACAS Portal under "My Projects." Only 
users with the "Project - Open a Closed Project" or "Project - Edit All Projects" permissions can 
reopen a closed project. 

Customer Support Preferences 

Display Preferences 

CSI - Display CSI Wizard: If True, the Use CSI Wizard command will be available when users are 
creating new Customer Support records. The wizard prompts users to enter the data one step 
at a time, instead of all in a single form. 

These preferences show/hide some of the fields in the Customer Support page. For information 
about how these fields are used, see Customer Support. To configure other fields for this record 
type, use the Details page. 
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• CSI - Display Shipment Date 

• CSI - Display Delivery Date 

• CSI - Display Distributor 

• CSI - Display MTBF 

• CSI - Display MTBCF 

• CSI - Display MTBNCF 

• CSI - Display MTBI 

• CSI - Display Chargeable Incident Count 

• CSI - Display Non-Chargeable Incident Count 

• CSI - Enable Operational Availability 

• CSI - Display Calculated System Downtime 

• CSI - Display Unit Owner Address Information 

• CSI - Display Contact 

• CSI - Display Warranty Section 

• CSI - Display ASP Information (ASP and ASP Field Service Tech) 

CSI - Display All Authorized Service Technicians: This applies if the "CSI - Display ASP 
Information" preference is enabled. If True, all service technicians will be displayed in the drop-
down list, regardless of the company they are associated with. If False, only service technicians 
associated with the selected company will be displayed. 

CSI - Show All Unit Contact Names: This applies if the "CSI - Display Contact" preference is 
enabled. If True, the Contact field will show all contacts available in the system. If False, the list 
will be filtered by unit owner. 

Other CSI Preferences 

CSI - Commission Date Required: If True, the commission date is required in the Customer 
Support page. If False, the shipment date becomes a required field and will be populated based 
on the system build dateif left blank by the user. 
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CSI - Create Incident Link Transfers Hours from CSI: This applies when the user clicks the 
"Create Incident" link in the Customer Support page. If True, the time metric field(s) in the 
incident (e.g., System Hours) will be populated based on the latest info in the CSI. (See Time 
Metric Calculations.) 

CSI - Extended Warranty Purchase Anytime: This applies if the "CSI - Display Warranty Section" 
preference is enabled. If False, the purchase date for the extended warranty must be within the 
date range of the initial warranty. (See Warranty Information Area). 

Other Entity-specific Preferences 

E-mail Preferences 

For information about e-mail preferences, see Conditions for Triggering E-mail Alerts. 

Report Preferences 

Reports - Allow Send via E-mail: If True, the E-mail button will be available in the Reports page. 

Reports - BCC Administrator on Data Sent via E-mail: If True, the e-mail address specified in 
the "Administrator E-mail" preference will receive a copy when report results are sent via e-
mail. 

Reports - Display Qualifiers: If True, the "Results based on the following qualifiers" area will be 
displayed in report results. 

Reports - Include End Date Matches: If True, the end date set in a report is included in the 
results. For example, with a setting of True, a report of dates between Jan. 1, 2017 and Jan. 2, 
2017 would include results for date matches from the entire days of Jan. 1, 2017 and Jan. 2, 
2017. With a setting of False, the report would only include results from the entire day of Jan. 1, 
2017. This applies if the "XFRACAS - Display Time with Date Fields" preference is set to False. 

Date / Time Preferences 

These preferences apply to all date/time input fields. Note that there are separate preferences 
for dates and times displayed as regular text (the "XFRACAS - Date Format - Long" and 
"XFRACAS - Date Format - Short" string preferences). 

• XFRACAS - Display Day Before Month in Date Input Fields: If True, Date input fields will 
display using the day before month format (e.g., "21 March 2017"). 

• XFRACAS - Display Time with Date Fields: If True, the Time input fields will be displayed 
with applicable Date fields. 
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• XFRACAS - Display Time in 24 Hour Format: If True, the Time field will display using a 24-
hour clock. If False, it will display an A.M./P.M. indicator. 

Application Preferences 

XFRACAS - Autopopulate Associated Record Dialog: This applies to all Assign/Find windows 
(e.g., when assigning an incident to a problem). If True, all records will be displayed when the 
window opens. If False, only currently assigned records will be displayed upon open and users 
can click Filter to see all records. 

XFRACAS - Display Debug IDs: If True, the resource IDs will be shown in square brackets beside 
the name for all fields. You can use this in conjunction with the Resource Editor to customize 
text labels displayed in the website. In addition, the Detail Type IDs will be shown in square 
brackets on the Details page. 

XFRACAS - Display Employee ID With User Name: If True, the employee ID will be displayed 
along with the user name in locations where a user is being selected (e.g., the Assign Team 
Members utility, drop-down lists, etc.). 

XFRACAS - Display Last Updated Timestamp: If True, information on the last update of the 
record will be displayed in the summary area for incidents, problems, projects, failure analysis 
reports, CSIs and actions. 

XFRACAS - Enable Header in Printed Records: If True, the print logo and full entity name will 
appear in the document header when records are printed using the Print Preview command on 
the Home tab. To change the logo, you can replace the logopfv.gif file stored in the Images 
folder on the web server (e.g., C:\inetpub\wwwroot\XFRACAS\Images\logopfv.gif). 

XFRACAS - Sort Statuses by Descending Date: If True, the notes in the Status fields will be 
displayed in descending order based on creation date (i.e., the oldest note is listed first). 

XFRACAS - Testing Mode: If True, a "watermark" that reads "TESTING" will be placed in the 
background of the pages to indicate that the "testing" version of the system is distinguished 
from the actual "live" system. 

Lists - Autosize List Height: If True, the area used to display lists in the Lists page varies in 
height depending on the number of items in the list. If False, a scroll bar will be used to scroll 
through the list. Note that there is a maximum height of 300 pixels for any list, even when this 
preference is set to True. 
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Manage User - E-mail/Login Auto Build: If True, the user login and e-mail address fields will 
automatically be assigned in the Users page based on the user’s first and last names and the 
"Manage User - E-mail Suffix used for Auto Build" e-mail preference. 

These preferences apply to the "data tree" on the Template page and the Serialized page. They 
also apply to the Responsible Part in incidents (when it is used as a tree) and for the Part 
Category Code in problems. 

• System - Data Tree Auto Collapse 

• System - Data Tree Sort by Part Description (rather than part number) 

Reliability Data Warehouse (RDW) Preferences 

These settings apply when using the RDW in Weibull++ to extract data sets for life data analysis: 

• Analysis - Fixed Daily Operating Hours: If True, systems are considered to run constantly 
(i.e., 24x7). System operating time (system up hours) will be calculated based on numerous 
factors, including commission or shipment date, incident occurrence date, the "Incident - 
Max Units/Day" Integer preference and the system down time. If False, the times are those 
reported in either the incidents or in the CSI. 

• Analysis - Weibull++ Export Rollup: If True, failures of child parts will be considered to also 
precipitate failures of parent parts. If the System Down Event incident detail is available in 
the current entity, then for incidents that are marked as system down events, the failure 
will affect all levels above the child part all the way to the top level item. For incidents that 
are not marked as system down events, the failure will affect all but the top level item. If 
False, failures of child parts will not roll up to parent parts.  
 
It is important to note that if this preference is True, the times that are exported are the 
times between failures, not the failure times. If you are unsure if this analysis method is 
appropriate for you, please contact ReliaSoft for further information. 

Actions Preference 

Action - Allow Setting Due Date Before Current Date: If True, users can enter an action date 
that is earlier than the creation date. This allows you to enter historical information that did not 
get entered when the action was actually performed. 
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DATE AND DISPLAY OPTION PREFERENCES 

Date Preferences 

Fiscal Year Begins: The start date of the fiscal year, which is used to determine the current 
quarter when reporting information based on a specified date range. The value entered must 
be a valid date but the current year will always be assumed when calculating the date range. 
For example, if the fiscal year begins on January 1st, you can enter that date with any year 
(01/01/2005, 01/01/2020, 01/01/2015). XFRACAS will only consider the month and day. 

Portal - What's New Modify Date: The date of the most recent modification to the What's New 
page maintained by your company (i.e., the Whatsnew.html page in the main folder on the web 
server where XFRACAS was installed). This page is displayed if the user has not visited the 
website since the page was last modified. 

Display Option Preferences 

These preferences specify which type(s) of incident can be created, and which will be selected 
by default. 

• Incident - Display Part Incident Type 

• Incident - Display Serialized Incident Type 

• Incident - Display Simple Incident Type 

Problem - Display Criticality determines which problem step, if any, displays criticality fields. 
(See Managing Criticality Fields.) 

These preferences specify whether the failure review board (FRB) will be displayed for each 
step in the Problem page, and whether all assigned members are required to sign off before 
users can move to the next step. 

• Problem - Display FRB - Describe the Problem 

• Problem - Display FRB - Implement and Verify Containment Actions 

• Problem - Display FRB - Identify and Verify Root Cause 

• Problem - Display FRB - Choose and Verify Permanent Corrective Actions 

• Problem - Display FRB - Implement Permanent Corrective Actions 
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• Problem - Display FRB - Prevent Recurrence 

• Problem - Display FRB - Congratulate the Team 

XFRACAS - Language: The default language for the interface text. If the Language option in the 
user's account is blank, the interface will display in the default language. However, if the user's 
account specifies a language, the interface will display in the user's preferred language instead. 

XFRACAS - Skin: Sets the appearance of the ribbon and some other elements within the 
XFRACAS interface. 

INTEGER PREFERENCES 

CSI - Hours Decimal Places: The number of decimal places displayed in time figures in the 
Customer Support page. 

CSI - Operational Availability Decimal Places: The number of decimal places that the 
Operational Availability percentage in the Customer Support page will be rounded to. 

CSI - Warranty Months: These preferences set the number of months in the warranty period in 
the Customer Support page, if company-specific values have not been specified on the 
Companies page. 

• CSI - Warranty Months from Commission 

• CSI - Warranty Months from Shipment 

CSI - X Warranty Days for Repaired/Replaced Parts: The number of parts that were repaired or 
replaced in the last X days. This information will display below the associated incidents on the 
Customer Support page. 

Max Units/Day: These preferences set the maximum amount of time/usage (e.g., hours, miles, 
kilometers, cycles, etc.) that a serialized system may accumulate in a single day. The max value 
for Time Metric 1 is used in the Customer Support page to make sure the "Estimated System 
Hours" calculation does not exceed the maximum possible per day. It is also used if you have 
selected to auto-populate Time Metric 1 in the Incident page for serialized systems. (See Time 
Metric Calculations.) 

Note that the max values for Time Metric 2 and 3 are relevant only if you are using a custom 
report that requires these inputs, or a custom method for extracting reliability data for analysis 
in Weibull++. 

• Incident - Max Units/Day - Time Metric 1 
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• Incident - Max Units/Day - Time Metric 2 (only for custom functionality) 

• Incident - Max Units/Day - Time Metric 3 (only for custom functionality) 

Default Due Dates and Closure Dates: These preferences specify the number of days from 
today's date to set as the default due date for a new action or the default closure dates for new 
problems. 

• Action - Default Due Date Offset by X Days 

• Problem - Expected Closure Date Offset 

• Problem - Requested Closure Date Offset 

Preferences that specify the number of business days for e-mails based on calendar date are 
covered in the following topics: 

• "Closure Date for Problem Step is Approaching or Past Due"  

• "Action Due Date is Approaching or Past Due" 

These preferences set the number of days that records will be highlighted in the XFRACAS 
Portal. 

• Portal - Action Due Date Highlight Offset (days prior to the action due date) 

• Portal - Incident Due Date Highlight Offset (days after the incident occurrence date) 

• Portal - Problem Due Date Highlight Offset (days prior to the problem requested closure 
date - if the requested closure date is turned off, then the due date is calculated) 

• Portal - Problem to Review Due Date Highlight Offset (days prior to the problem review 
due date) 

• Portal - Project Due Date Highlight Offset (days prior to the project due date) 

XFRACAS - Description Number of Lines Displayed: The default height for description fields 
(i.e., the maximum number of lines of text that can be visible without scrolling). For 
descriptions that are configurable detail fields, you can override this for a specific field by 
setting the Number of Lines Displayed in the detail properties. 

Reports - Filter Display Max Columns: The maximum number of optional columns that a report 
created in the Report Builder can include. 
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XFRACAS - System Search Timeout: The maximum amount of time, in seconds, that the 
application can spend searching for a part in a system. 

Diagnostics - Number of Exception Items Displayed: The maximum number of items the 
Diagnostics page can display on a single page. 

Active Directory - Maximum Groups to Display: The maximum number of groups that will be 
displayed when loading Active Directory groups. 

STRING PREFERENCES 

To open the Preferences  page, choose Admin > Configure > Preferences. 

About Page 

These preferences specify information that displays on the XFRACAS About page. 

• Administrator Name 

• Administrator Phone 

• Company Name 

• Company Homepage Link: This the anchor text for the link. The URL is specified in the 
"XFRACAS - Company Homepage" URL preference. 

E-mails 

These preferences specify the formats of e-mail alerts.  

• To learn how variables are used in e-mails, see Configuring E-mail Message Formats. 

• To see which formats apply for specific types of e-mails, follow the links in Conditions for 
Triggering E-mail Alerts. 

Criticality Metrics 

These preferences define the formulas used to calculate the criticality metrics for an incident or 
problem. (See Configuring Criticality Metrics.) 

• Criticality - Incident Actual 

• Criticality - Incident Potential 
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• Criticality - Problem Base CIN 

• Criticality - Problem Current CIN 

Time / Usage Metrics 

These preferences specify the formulas used to calculate the value of one time/usage metric 
based on the value entered for another. The behavior also depends on the "Display Time 
Metric" and "Always Auto-calculate Time Metric" preferences, and what the user enters in the 
incident page. (See Time Metric Calculations.) 

• Incident - Time Metric 1 Formula 

• Incident - Time Metric 2 Formula 

• Incident - Time Metric 3 Formula 

Dates 

These preferences specify the formats for dates. Note that this should match the IIS culture 
setting on the web server in order for dates in charts to be displayed correctly. 

• XFRACAS - Date Format - Short: Displays only the date and not the time. The default 
format is MM/dd/yyyy (e.g., 03/01/2017). 

• XFRACAS - Date Format - Long: Displays the time along with the date when applicable. The 
default format is MM/dd/yyyy hh:mm tt (e.g., 03/01/2017 01:00 PM). 

• If the "XFRACAS - Display Time in 24 Hour Format" Boolean preference is True, remove 
the "tt" segment from the long date format (e.g., MM/dd/yyyy hh:mm will display 
03/01/2017 13:00). 

• If you want to display only the date (without the time), set to the same format as the 
short date field (e.g., MM/dd/yyyy) or set the "XFRACAS - Display Time with Date 
Fields" Boolean preference to False. 

Other  

Problem - Default Owner: The user who will be assigned by default as the owner for new 
problems. 

XFRACAS Decimal Separator: The text (usually a period or comma) used to indicate the decimal 
place in both input and output. 
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XFRACAS Thousands Separator: The separator (usually a comma, period or space) used to 
separate groups of thousands in both input and output. 

XFRACAS - Web Page Title Suffix: The text that will be displayed at the end of the title in the 
browser caption bar (e.g., "Proprietary and Confidential Information"). 

Exchange ADS Path: The Active Directory Services Path used for an LDAP connection to the GAL 
(Global Address List). (See Entering an ADS Path.) 

TIME ZONE AND URL PREFERENCES 

Time Zone Preferences 

Default GMT Offset for New Users: The time zone, or offset from Coordinated Universal Time 
(formerly known as Greenwich Mean Time), that will be used when a new user is created if a 
different time zone is not specified for that user. 

URL Preferences 

Tips URLs: For many fields in XFRACAS, a help icon next to the input box opens a separate HTML 
page designed to provide data entry tips for that particular field. You can customize the 
information in these pages to meet the particular needs of your organization. By default, they 
are installed in the "Tips" folder on the web server (e.g., C:\inetpub\wwwroot\XFRACAS\Tips), 
but you can change the URLs if desired. 

URLs for Tips 

These preferences specify the URLs for some of the fields that have tips. For other fields that 
are configured from the Details page (such as the Incident Description or the Problem 
Description), you can specify the "Tips URL" when you edit the settings for the special detail 
field. 

• Action - Description Tips 

• Action - Result Tips 

• Action - Status Tips 

• CSI - Installation Detail Tips 

• FA - Detailed Analysis Tips 

• FA - Fault Description/Troubleshooting/Rework Tips 
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• FA - Initial Repairs/Comments Tips 

• FA - SAP Items 

• FA - Visual Inspection Tips 

• Incident - Actual Criticality Tips 

• Incident - Potential Criticality Tips 

• Problem - Criticality Tips 

• Problem - FRB Rejection Description Tips 

• Project - End Result Tips 

• Project - Scope of Project Tips 

XSLT Style Sheet URLs 

These preferences specify the URLs for the *.xslt style sheets for pages and reports that have a 
Print Preview command in the ribbon. By default, these are installed in the "XSLT" folder on the 
web server (e.g., C:\inetpub\wwwroot\XFRACAS\XSLT), but you can change the URLs if desired. 

• CSI - Print Preview Style Sheet 

• FA - Print Preview Style Sheet 

• Incident - Print Preview Style Sheet 

• Problem - Print Preview Style Sheet 

• Project - Print Preview Style Sheet 

XFRACAS - Company Homepage: The URL of your company's home page link that displays on 
the XFRACAS About page. The anchor text is specified in the "Company Homepage Link" string 
preference. 

TARGET AND COMPLETED DATES 

These preferences specify whether target and/or completed date fields will display in specific 
areas of the Incident page and Problem page. 

• Incident - Description - Show Target Date 
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• Incident - Description - Show Completed Date 

• Incident - Resolution - Show Target Date 

• Incident - Resolution - Show Completed Date 

• Incident - Initial Failure Analysis - Show Target Date 

• Incident - Initial Failure Analysis - Show Completed Date 

• Incident - Additional Comments - Show Target Date 

• Incident - Additional Comments - Show Completed Date 

• Problem - Problem Description - Show Target Date 

• Problem - Containment Description - Show Target Date 

• Problem - Root Cause Verification - Show Target Date 

• Problem - Corrective Action Description - Show Target Date 

• Problem - Implement Corrective Action Description - Show Target Date 

• Problem - Prevent Recurrence Description - Show Target Date 

• Problem - Recognize Team Description - Show Target Date 

Static Pages 
For some features, you can customize the interface to meet your particular needs by editing 
files stored directly on the web server. 

• What's New page (Whatsnew.html) is installed in the website's main folder. The "Portal - 
What's New Modify Date" preference defines the date of the most recent modification to 
the page. 

• General Error page (GeneralError.aspx) is installed in the website's main folder. 

• Terms of Use agreement pages (Agreement.aspx and AdminAgreement.aspx) are installed 
in the website's main folder (displayed when the user visits any of the regular user pages) 
and in the Admin folder (displayed when the user visits any of the admin pages). To enable 
this feature, set the "Terms of Use Agreement Page Required" preference to True. 
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• Description Criteria Link pages are installed in the website's "Tips" folder (e.g., 
C:\inetpub\wwwroot\XFRACAS\Tips). If you want to use a file stored in a different location 
instead, edit the relevant link on the Preferences page under URL Preferences (e.g., 
"Incident - Actual Criticality Tips," etc.). 

• Print Preview XSLT files are installed in the website's "XSLT" folder (e.g., 
C:\inetpub\wwwroot\XFRACAS\XSLT). These configure the "Print Preview" output for an 
incident, failure analysis, problem, project or CSI record or report. If you want to use a file 
stored in a different location instead, edit the relevant link on the Preferences page under 
URL Preferences (e.g., Incident - Print Preview Style Sheet," etc.). 

Tip: If the record has an Attachments Table detail (also called "Associated Files"), the default 
XSLT templates installed with XFRACAS will display any attached image files (e.g.,*. jpg, *.gif, 
*.jpeg or *.png) as images in the print preview. If you need to change the list of file types that 
are treated as images, you can modify the following code in the template: 
 
<xsl:when test="AttachmentType = 'Blob Data' and ('jpg' = 
substring($imageName,string-length($imageName) - string-
length('jpg') +1) or 'gif' = substring($imageName,string-
length($imageName) - string-length('gif') +1) or 'jpeg' = 
substring($imageName,string-length($imageName) - string-
length('jpeg') +1) or 'png' = substring($imageName,string-
length($imageName) - string-length('png') +1))"> 

E-mail Alerts 

STEPS FOR CONFIGURING E-MAIL ALERTS 

About E-mail Alerts in XFRACAS 

In XFRACAS, a variety of settings on the Preferences page (Admin > Configure > Preferences) 
allow admin users to specify not only the conditions for sending e-mail alerts but also the 
contents of these e-mails. In general, XFRACAS can be configured to send e-mails when:  

• An incident, problem, project, action, failure analysis (FA) or customer support (CSI) record 
is created or closed. 

• An incident or problem is assigned a new owner. 

• An action is created or closed. 
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• An action has an approaching or past due date.  

• A status is updated.  

• A user selects a drop-down list option that’s configured to trigger an alert.  

• A problem resolution step requires signoff, or has been signed off, by a failure review board 
(FRB) member.  

• A user wants to notify a specified recipient about certain events related to FAs or the 
processing of failed parts. 

Steps for Configuring E-mails 

To configure e-mail settings, you’ll need to have the “Manage System-Wide Preferences” and 
“Manage Entity Preferences” permissions.  

1. Configure your implementation to send and receive e-mails.  

• In the System-Wide Preferences section of the Preferences page, specify an SMTP 
server, port and connection timeout. (See System-Wide Preferences, Implementation 
Guide.)  

• In Admin > Configure > Security > Users, make sure each user account that will send or 
receive e-mails has a valid e-mail address. (See Managing Users.)  

Tip: You can use the "Manage User - E-mail Suffix Used for Auto Build" preference to define 
the suffix (e.g., @company.com) to be used for e-mail addresses that are automatically 
generated for new users if the "Manage User - E-mail/Login Auto Build" Boolean preference 
is True. 

2. Set the applicable preferences in the Boolean Preferences section of the Preferences page 
to True.  

• To determine which preferences apply, follow the applicable links in Conditions for 
Triggering E-mail Alerts. 

• If you plan to use e-mails in detail lists, follow the instructions in Working with E-mails 
in Detail Lists. 

3. Configure the applicable e-mail “formats” (content) in the String Preferences section using 
the variables defined in the following help topics:  

http://help.reliasoft.com/documents/version2020/IG_XFRACAS20.pdf
http://help.reliasoft.com/documents/version2020/IG_XFRACAS20.pdf
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• E-mail Variables for Incidents, Problems, Projects, FAs and CSIs  

• Action E-mail Variables  

• Status E-mail Variables 

To determine which formats apply for each preference, follow the applicable links in 
Conditions for Triggering E-mail Alerts. 

Note: If you enable a preference but leave its corresponding format blank, your 
organization’s SMTP server may prevent those e-mails from being sent. 

4. Optional: In the E-mail Preferences section of the Preferences page, specify the following:  

• E-mail - Single From Address - defines the default “from” address for all e-mails  

• E-mail - Default New Incident From - defines the default “from” address for new 
incidents  

If you leave these preferences blank, the sender will be the user who initiates the e-mail — 
i.e., the user who creates the new incident, closes an action, etc.  

5. To send copies of e-mails containing data from incident, problem, project, FA or CSI records 
/ reports to an administrator for your organization, do the following:  

• Set E-mail - BCC Administrator on XFRACAS Data Sent to True in the Boolean 
Preferences section.  

• Specify an address for the Administrator E-mail in the E-mail Preferences section.  

These settings apply to e-mails that are triggered whenever a user selects the Printer 
Friendly View option in the Send E-mail utility. (See Send E-mail Utility in the user help). 
They create an audit trail and allow an administrator to monitor outbound e-mails to 
ensure compliance with ITAR and other security requirements.  

6. If you plan to send reminder e-mails based on calendar date, do the following:  

• Configure the appropriate preferences and formats. (See “Action Due Date is 
Approaching or Past Due” and “Closure Date for Problem Step is Approaching or Past 
Due.”)  
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• In the Integer Preferences section of the Preferences page, specify the intervals, in 
days, for any reminder e-mails you wish to send for actions and FRB signoffs.  

• Verify that the DIU service is running by checking its status at the top of the Data 
Import page. If not, follow the instructions in the Implementation Guide to start the 
service. (This may require support from an IT admin.)  

CONDITIONS FOR TRIGGERING E-MAIL ALERTS 

Follow these links to see the required preferences and formats for e-mail alerts. 

See also Working with E-mails in Detail Lists. 

Actions 

These settings apply to incident, problem, project, failure analysis (FA) or customer support 
(CSI) actions.  

• User Creates a New Action 

• User Completes / Closes an Action 

• User Updates an Action 

• Action Due Date is Approaching or Past Due 

Status Updates  

• User Updates the Status of an Existing Action, Incident, Problem, Project or FA 

Incidents  

• User Creates a New Incident 

• User Assigns a New Owner to an Incident 

• User Closes an Incident  

Problems and FRB Signoffs  

• User Creates a New Problem 

• User Assigns a New Owner to a Problem 

http://help.reliasoft.com/documents/version2020/IG_XFRACAS20.pdf
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• User is Assigned to Review a Problem Step 

• FRB Reviewer Signs Off on a Problem Step 

• FRB Reviewer Rejects the Closure of a Problem Step 

• Closure Date for a Problem Step is Approaching or Past Due 

FA Reports 

• User Updates an RMA Received Date for a Failed Part 

• User Wants to Initiate a Request for an SAP Work Order 

• Customer Requests Feedback on an FA Report Associated with an Incident  

E-mail Preferences 

Action E-mail Preferences 

These alerts are sent from the user who initiates the action, unless a different address has been 
specified for E-mail - Single From Address. (See Steps for Configuring E-mail Alerts.) 

Note: The formats required for these preferences are listed in Action E-mail Variables. 

User Creates a New Action  

• Boolean preferences: 

• E-Mail - Incident Action Creation  

• E-Mail - Problem Action Creation  

• E-Mail - Project Action Creation 

• E-Mail - FA Action Creation 

• E-Mail - CSI Action Creation 

• Recipients: 

• Action owner  
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• Action creator, if different from the action owner 

• Owner of the parent record, if E-mail - Action Parent's Owner on Creation is True (e.g., 
the incident owner would be notified upon creation of an action associated with the 
incident) 

• Team members who are assigned to the parent record, if E-mail - Action Parent's Team 
on Creation is True (e.g., the incident's team would be notified upon creation of an 
action associated with the incident) 

• Formats: 

• Action - E-mail Message Format - New - Incident 

• Action - E-mail Message Format - New - Problem 

• Action - E-mail Message Format - New - Project 

• Action - E-mail Message Format - New - FA 

• Action - E-mail Message Format - New - CSI  

User Completes / Closes an Action  

• Boolean preferences: 

• E-Mail - Incident Action Closed 

• E-Mail - Problem Action Closed 

• E-Mail - Project Action Closed 

• E-Mail - FA Action Closed 

• E-Mail - CSI Action Closed 

• Recipients:  

• Action owner 

• Action creator, if different from the action owner 
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• Owner of the parent record, if E-mail - Action Parent's Owner on Close is True (e.g., 
the incident owner would be notified upon when an action associated with the incident 
is closed) 

• Team members who are assigned to the parent record, if E-mail - Action Parent's Team 
on Close is True (e.g., the incident's team would be notified when an action associated 
with the incident is closed) 

• Formats: 

• Action - E-mail Message Format - Complete - Incident 

• Action - E-mail Message Format - Complete - Problem 

• Action - E-mail Message Format - Complete - Project 

• Action - E-mail Message Format - Complete - FA 

• Action - E-mail Message Format - Complete - CSI 

User Updates an Action 

Users update action records whenever they assign a new owner or change a description or due 
date.  

• User assigns a new owner to an action: 

• Boolean preference: E-Mail - Incident Action Creation  

• Recipients: New and former action owners 

• User updates an action's description or due date: 

• Boolean preference: E-mail - Action Owner on Update 

• Recipient: Action owner (if the update was made by someone else) 

• Formats: 

• Action - E-mail Message Format - Updated - Incident 

• Action - E-mail Message Format - Updated - Problem 

• Action - E-mail Message Format - Updated - Project 
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• Action - E-mail Message Format - Updated - FA 

• Action - E-mail Message Format - Updated - CSI 

Action Due Date is Approaching or Past Due 

You can configure XFRACAS to send reminder e-mails for incident, problem, project, FA and CSI 
actions. The following preferences determine when these e-mails are sent: 

• E-mail - Action Due in X Days Offset - the number of days prior to the action due date that 
the e-mail will be sent. 

• E-mail - Send Action Due Notify Once - If True, only the initial e-mail will be sent; if False, 
reminder e-mails will be sent at regular intervals until the action is complete (the number 
of days between reminders is set in E-mail - Remind Action Due Every X Days). 

• E-mail - Group Action Due Date - If True, reminders for all actions that are approaching 
their due dates will be grouped into a single e-mail; if False, individual e-mails will be sent 
for each action. 

Note: The DIU service must be running to send e-mail alerts based on the calendar date. 

• Boolean preferences: 

• E-mail - Incident Action Due Date 

• E-mail - Problem Action Due Date 

• E-mail - Project Action Due Date 

• E-mail - FA Action Due Date 

• E-mail - CSI Action Due Date 

• Recipients: 

• Action owner 

• Incident owner, if E-mail - CC Incident Owner Action Due Date is True 

• Problem owner, if E-mail - CC Problem Owner Action Due Date is True 

• Formats: 
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• Action - E-mail Message Format - Complete - Incident 

• Action - E-mail Message Format - Complete - Problem 

• Action - E-mail Message Format - Complete - Project 

• Action - E-mail Message Format - Complete - FA 

• Action - E-mail Message Format - Complete - CSI 

E-mail Preferences for Status Updates 

These alerts are sent from the user who initiates the update, unless a different address has 
been specified for E-mail - Single From Address. (See Steps for Configuring E-mail Alerts.) 

Note: The formats required for these preferences are listed in Status E-mail Variables. 

User Updates the Status of an Existing Action, Incident, Problem, Project or FA 

• Boolean preferences: 

• E-mail - Incident Status Update 

• E-mail - Problem Status Update 

• E-mail - Project Status Update 

• E-mail - Action Status Update 

• E-mail - FA Status Update 

• Recipients: The user who updated the status, along with the recipients specified in the 
update dialog box. Preferences determine which check boxes are selected by default: 

• E-mail - Incident Status Update Creator Checked 

• E-mail - Incident Status Update Owner Checked 

• E-mail - Incident Status Update Team Checked 

• E-mail - Problem Status Update Creator Checked 

• E-mail - Problem Status Update Owner Checked 
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• E-mail - Problem Status Update Team Checked 

• E-mail - Project Status Update Owner Checked 

• E-mail - Project Status Update Team Checked 

• E-mail - Action Status Update Creator Checked 

• E-mail - Action Status Update Associated Owner Checked 

• E-mail - Action Status Update Team Checked 

• E-mail - FA Status Update Creator Checked 

• E-mail - FA Status Update Associated Owner Checked 

• E-mail - FA Status Update Team Checked 

• Formats: 

• Detail Status - E-mail Message Format - Incident 

• Detail Status - E-mail Message Format - Action 

• Detail Status - E-mail Message Format - Problem 

• Detail Status - E-mail Message Format - Project 

• Detail Status - E-mail Message Format - FA  

Incident E-mail Preferences 

Incident e-mails are sent from the user who initiates the activity (e.g., creates a new incident, 
closes an existing incident, etc.) unless one of the following has been specified:  

• E-mail - Single From Address - sets a default “from” address for all e-mails.  

• E-mail - Default New Incident From - sets a default “from” address for new incidents only. 
If the recipient’s address is invalid, e-mails will bounce back to this address instead of the e-
mail for the user who created the incident.  

Note: The formats required for these preferences are listed in "Incident E-mail Variables." 
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User Creates a New Incident 

• Boolean preference: E-mail - Incident Creation 

• Recipient: Incident owner 

• Format: Incident - E-mail Message Format - New 

User Assigns a New Owner to an Incident 

• Boolean preference: E-mail - Incident Owner Reassigned 

• Recipients: Incident owners (previous and new) 

• Format: Incident - E-mail Message Format - New 

User Closes an Incident 

• Boolean preferences:  

• E-mail - Incident Closed 

• E-mail - Incident Closed - Team 

• Recipients: Incident owner and/or team members 

• Format: Incident - E-mail Message Format - Closed 

E-mail Preferences for Problems and FRB Signoffs 

E-mails for problems and failure review boards (FRBs) are sent from the user who initiates the 
activity (e.g., creates a new problem, closes problem, etc.), unless a different address has been 
specified for E-mail - Single From Address. (See Steps for Configuring E-mail Alerts.) 

Note: The formats required for these preferences are listed in "Problem E-mail Variables." 

User Creates a New Problem 

• Boolean preference: E-mail - Problem Creation 

• Recipient: Problem owner, unless he/she is also the problem creator 

• Format: Problem - E-mail Message Format - New  
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User Assigns a New Owner to a Problem 

• Boolean preference: E-mail - Problem Owner Reassigned 

• Recipient: Problem owner (new and previous), unless he/she is also the problem creator 

• Format: Problem - E-mail Message Format - New  

User is Assigned to Review a Problem Step 

• Boolean preference: E-mail - Reviewer Added to FRB 

• Recipient: The reviewer who was added to the FRB 

• Format: Problem - E-mail Message Format - Closure Requested 

FRB Reviewer Signs Off on a Problem Step 

• Boolean preferences: 

• E-mail - Send Problem Signed Off  

• E-mail - Problem Signed Off by FRB (All) 

• Recipients: 

• Problem owner and reviewer 

• The rest of the FRB, if E-mail - Problem Signed Off by FRB (All) is True 

• Format: Problem - E-mail Message Format - Signed Off  

FRB Reviewer Rejects the Closure of a Problem Step 

• Boolean preference: E-mail - Problem FRB Rejected 

• Recipients: Problem owner and all FRB members 

• Format: Problem - E-mail Message Format - Reject 

Closure Date for Problem Step is Approaching or Past Due 

Note: The DIU Service must be running to send e-mail alerts based on the calendar date. 
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• Boolean preference: E-mail - Problem FRB Not Signed Off 

• Recipients: FRB reviewers 

• Format: Problem - E-mail Message Format - Closure Requested 

• In addition, the following preferences determine how often reminder e-mails are sent to 
FRB reviewers once a Completed Date has been entered for a problem step: 

• E-mail - FRB After Requested Closure in X Days Offset - the number of business days 
after closure when a reminder e-mail is sent to reviewers who have not yet signed off 
on the step. 

• E-mail - Remind FRB After Requested Closure Every X Days - the interval, in days, for 
sending additional e-mail reminders to reviewers (for the final step only). 

If E-mail - Group Problem FRB Not Signed Off is True, only one reminder e-mail will be sent 
to a user for all problem steps for which he/she is an FRB reviewer; otherwise, individual e-
mails will be sent for each step.  

FA E-mail Preferences 

XFRACAS provides options for sending various types of e-mail alerts to support the repair or 
replacement of failed parts.  

User Updates an RMA Received Date for a Failed Part 

For incidents that have been assigned to a problem, these settings notify the problem owner 
that a return materials authorization (RMA) has been received for a failed part so he/she can 
initiate and/or track its repair or replacement. The RMA can be entered on either the Incident 
or Failure Analysis page.  

• Boolean preference: E-mail - RMA Received to Problem Owner 

• Recipient: Problem owner 

• Format: Incident - E-mail Message Format - RMA Received (see "Incident E-mail 
Variables") 
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User Wants to Initiate a Request for an SAP Work Order 

These settings allow users to notify a specified recipient to initiate a request for a 
remanufacturing work order (or similar record) from an enterprise resource planning system 
such as SAP.  

• Boolean preference: E-mail - FA SAP Work Order Request 

• Recipient: Defined by E-mail - SAP Work Order Request To 

• Format: Failure Analysis - E-mail Message Format - Work Order (see "Failure Analysis E-
mail Variables") 

Customer Requests Feedback on an FA Report Associated with an Incident 

These settings send an e-mail to a specified recipient to notify him/her to send a copy of the 
report to the customer. The e-mail is sent when the incident status changes from open to 
closed.  

Note: For these e-mails, the Customer Requested Feedback option must be selected on the 
Incident page and the Report Sent to Customer option must be deselected on the Failure 
Analysis page.  

• Boolean preference: E-mail - Incident Customer Requested Feedback 

• Recipient: Defined by E-mail - Customer Requested Feedback Notify To 

• Format: Incident - E-mail Message Format - Customer Feedback (see "Incident E-mail 
Variables") 

WORKING WITH E-MAILS IN DETAIL LISTS 

E-mail alerts can be triggered from various administratively controlled custom detail lists, 
including select / multiple select (drop-down) lists, trees and multiple check boxes. (See Field 
Types.) 

These types of e-mails are especially useful when you want to notify a specific person about a 
critical situation — e.g., one that might cause a loss of data, work stoppage or safety issue — so 
they can take immediate action. E-mails are sent when the user selects an option from the list 
and saves the record. 

To configure these alerts, you’ll need to do the following: 
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1. Create a detail. (See Managing Details.) 

2. Go to the Lists page (Admin > Configure > Lists) and find the detail you just created. 

3. Populate the detail list with options (issues). (See Managing Lists). You can specify an e-mail 
address for any or all of the options in the list; in the example below, only the level 4 safety 
incident requires an e-mail address. 

 

E-mails will be sent from the user, unless a different address has been specified for the E-mail - 
Single From Address preference. The recipient will be the address specified for the selected list 
option. 

If you want the e-mail to include the list name and selected option that triggered the alert, 
you'll need to use the %DTM variable (see E-mail Variables for Incidents, Problems, Projects, 
FAs and CSIs) and one of the following formats: 

• Detail Drop-down - E-Mail Message Format - Incident 
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• Detail Drop-down - E-mail Message Format - Problem 

• Detail Drop-down - E-mail Message Format - Project 

• Detail Drop-down - E-mail Message Format - FA 

• Detail Drop-down - E-mail Message Format - CSI  

  

  

Configuring E-mail Contents 

 

Configuring E-mail Message Formats 

The "E-mail Message Format" preferences in the String Preferences area of the Preferences 
page (Admin > Configure > Preferences) use variables to specify which information is included 
in each type of e-mail. 

For example, this is the default format for e-mails sent when a new action is assigned from 
within an incident: %1|%2|%3|%4|%5|%6|%8. 

It results in e-mails like the following: 

New Action Assigned 
Action ID: 2268 
Action Creator: JOHN SMITH 
Action Created Date/Time: 07/12/2013 08:37 AM 
Action Type: Incident Action 
Incident Report: E1-16118 
Action Due Date: 07/20/2013 
Action Description: This is a sample description. 

You can replace the default with your own custom format that uses any of the variables that 
are available for incident action e-mails. For example, if you specify a custom format like this: 

%I1 - %1|%2|%10|%6|%8|Acme Industries - Internal Use Only 

It results e-mails like the following: 
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New Action Assigned 
Incident Report: E1-16118 - Action ID: 2268 
Action Creator: JOHN SMITH 
Assigned To: JILL ENGINEER 
Action Due Date: 07/20/2010 
Action Description: This is a sample description. 
Acme Industries - Internal Use Only 

• See E-mail Variables for Incidents, Problems, Projects, FAs and CSIs for a list of variables for 
e-mails that apply to those record types. 

• See Action E-mail Variables for a list of variables for incident, problem, project, CSI, and 
failure analysis action e-mails. 

• See Status E-mail Variables for a list of variables that apply to status updates for incidents, 
actions, failure analysis, problems or projects. 

E-mail Variables for Incidents, Problems, Projects, FAs and CSIs 

Incident E-mail Variables 

These variables related to incident records can be used in any of the following e-mail formats: 

• Detail Drop-down - E-mail Message Format - Incident 

• Incident - E-mail Message Format - New 

• Incident - E-mail Message Format - Closed 

• Incident - E-mail Message Format - Customer Feedback 

• Incident - E-mail Message Format - RMA Received 

Variable Description Example 
%1 Incident Number (with link to 

incident) 
Incident Report: #E1-115 

%2 Incident Title Incident Title: Part Failed 
%3 Incident Created By (with e-mail 

link) 
Incident Creator: John Smith 

%4 Incident Created Date and Time Incident Created Date & Time: 07/12/2013 
07:38 AM 

%5 Incident Owner Incident Owner: Robert Jones 



Managing Preferences 

XFRACAS 2020 Admin Guide 81 

 

%6 Incident Part Number Incident System Part Number: 1001 
%7 Incident Serial Number Incident System Serial Number: 2 
%8 Incident Description Incident Description: Some part failure 

occurred... 
%9 Incident State Incident State: Closed 

%10 Incident Closed Date and Time Incident Closed Date & Time: 11/06/2018 
08:01 AM 

%11 Incident Responsible Part (for all 
selected responsible parts) 

Incident Responsible Part: Fan: 1001; Power 
Supply: 1003; Brass Fitting: 1005 

| New Line Starts a new line in the message 
%DTM Value of the selected option in a 

list detail* 
Detail Name: Selected Value 

%DTX Detail Value* Text Detail: Value 

* See "Using Detail Variables" for more information. 

Problem E-mail Variables 

These variables related to problem records can be used in any of the following e-mail formats: 

• Detail Drop-down - E-mail Message Format - Problem 

• Problem - E-mail Message Format - New 

• Problem - E-mail Message Format - Closure Requested 

• Problem - E-mail Message Format - Reject 

• Problem - E-mail Message Format - Signed Off 

Variable Description Example 
%1 Problem Number (with link to 

problem) 
Problem: #E1-4 

%2 Problem Created By (with e-mail 
link) 

Problem Creator: John Smith 

%3 Problem Created Date and Time Problem Created Date & Time: 07/11/2013 
02:23 PM 

%4 Problem Owner (with e-mail link) Owner: Tom Smith 
%5 Problem Title Problem Title: Parts 
%6 Problem Description Problem Description: Part Reports 
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| New Line Starts a new line in the message 
%DTM Value of the selected option in a list 

detail* 
Detail Name: Selected Value 

%DTX Detail Value* Text Detail: Value 

* See "Using Detail Variables" for more information. 

Project E-mail Variables 

These variables related to project records can be used with this e-mail format: 

• Detail Drop-down - E-mail Message Format - Project 

Variable Description Example 
%1 Project Number (with link to 

project) 
Project: #E1-4 

%2 Project Owner Project Owner: John Smith 
%3 Project Start Date and Time Project Start Date: 07/11/2013 02:23 PM 
%4 Project Title Project Title: Part Redesign 
%5 Project Scope Project Scope: To identify problems with the 

redesign process and implementation 
| New Line Starts a new line in the message 

%DTM Value of the selected option 
in a list detail* 

Detail Name: Selected Value 

%DTX Detail Value* Text Detail: Value 

* See "Using Detail Variables" for more information. 

CSI E-mail Variables 

These variables related to CSI records can be used with the following e-mail format: 

• Detail Drop-down - E-mail Message Format - CSI 

Variable Description Example 
%1 Customer Support Information Number 

(with link to CSI) 
Incident Report: #E1-115 

%2 Customer Support Information Author CSI Author: Tom Smith 
%3 Customer Support Information Shipment 

Date 
Shipment Date: 05/21/2013 03:32 
PM 
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%4 Customer Support Information 
Commission Date 

Commission Date: 05/26/2013 09:01 
AM 

%5 Customer Support Information 
Decommission Date 

Decommission Date: 07/15/2013 
04:44 PM 

%6 Customer Support Information System 
Configuration 

System Configuration: 867978, Part 
1983 ver. 1 

| New Line Starts a new line in the message 
%DTM Value of the selected option in a list 

detail* 
Detail Name: Selected Value 

%DTX Detail Value* Text Detail: Value 

* See "Using Detail Variables" for more information. 

Failure Analysis E-mail Variables 

These variables related to failure analysis records can be used in any of the following e-mail 
formats: 

• Detail Drop-down - E-mail Message Format - FA 

• Failure Analysis - E-mail Message Format - Work Order 

Variable Description Example 
%1 Failure Analysis Number (with link to failure 

analysis report) 
Failure Analysis Report: #E1-9 

%2 Failure Analysis Created By Created By: John Smith 
%3 Failure Analysis Created Date and Time FA Report Open Date: 07/13/2013 

01:23 PM 
%4 Incoming Part Number Incoming Part #: 5309a 
%5 Incoming Part Description Incoming Part Description: Parts 
%6 Incoming Serial Number Incoming Serial #: 867 
%7 System Part Number System Part #: 5309b 
%8 System Part Description System Part Description: Parts 
%9 System Serial Number System Serial #: 1943 
| New Line Starts a new line in the message 

%DTM Value of the selected option in a list detail* Detail Name: Selected Value 
%DTX Detail Value* Text Detail: Value 

* See "Using Detail Variables" for more information. 
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Using Detail Variables 

Two variables — %DTM and %DTX — allow you to include information from details in your e-
mail alerts. (See Managing Details.) They can be used in the formats listed above for each 
record type. 

• Use %DTM for e-mail alerts that are triggered when a user selects an option from a detail 
list in an incident, problem, project, CSI or failure analysis record. (See Working with E-mails 
in Detail Lists.) It adds the name and selected value for the detail that triggered the e-mail 
alert. 

• Use %DTX to include one or more details from the current incident, problem, project, CSI or 
failure analysis record. It adds the detail's text and value to the e-mail alert. For this 
variable, you'll need to specify X, the detail type ID. (See Using Detail Type IDs to find this 
number). 

Action E-mail Variables 

Use the following variables to format action e-mails for incidents, problems, projects, CSIs and 
failure analyses. 

Incident Action E-mail Variables 

These variables related to incident action records can be used in any of the following e-mail 
formats: 

• Action - E-mail Message Format - New - Incident 

• Action - E-mail Message Format - Updated - Incident 

• Action - E-mail Message Format - Complete - Incident 

Variable Description Example 
%1 Action ID (with link to action) Action ID: #128 
%2 Action Created By Name (with e-

mail link) 
Action Creator: John Smith 

%3 Action Created Date and Time Action Created Date/Time: 07/12/2013 
08:38 AM 

%4 Action Type Action Type: Incident Action 
%5 Associated ID (with link to incident) Incident Report: E1-115 
%6 Action Due Date Action Due Date: 08/12/2013 
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%7 Action Complete Date Action Complete Date: 08/02/2013 
%8 Action Description Action Description: Description... 
%9 Action Result Action Result: Result description... 

%10 Action Assigned to Assigned to: John Smith 
%I1 Incident Number (with link to 

incident) 
Incident Report: #E1-115 

%I2 Incident Title Incident Title: Part Failed 
%I3 Incident Created By (with e-mail 

link) 
Incident Creator: John Smith 

%I4 Incident Created Date and Time Incident Created Date & Time: 07/12/2013 
07:38 AM 

%I5 Incident Owner Incident Owner: Robert Jones 
%I6 Incident Part Number Incident System Part Number: 1001 
%I7 Incident Serial Number Incident System Serial Number: 2 
%I8 Incident Description Incident Description: Some part failure 

occurred... 
| New Line Starts a new line in the message 

%DTX Action Detail Value* Detail Text: Value 
%IDTX  Incident Detail Value* Detail Text: Value 

* See "Using Detail Variables" for more information. 

Problem Action E-mail Variables 

These variables related to problem action records can be used in any of the following e-mail 
formats: 

• Action - E-mail Message Format - New - Problem 

• Action - E-mail Message Format - Updated - Problem 

• Action - E-mail Message Format - Complete - Problem 

Variable Description Example 
%1 Action ID (with link to action) Action ID: #132 
%2 Action Created By (with e-mail link) Action Creator: John Smith 
%3 Action Created Date and Time Action Created Time/Date: 07/12/2013 

10:15 AM 
%4 Action Type Action Type: Problem Action 
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%5 Associated ID (with link to problem) Problem: E1-4 
%6 Action Due Date Action Due Date: 08/09/2013 
%7 Action Complete Date Action Complete Date: 08/07/2013 
%8 Action Description Action Description: Description... 
%9 Action Result Action Result: Result description... 

%10 Action Assigned To Assigned To: John Smith 
%R1 Problem Number (with link to 

problem) 
Problem: #E1-4 

%R2 Problem Created By (with e-mail 
link) 

Created By: John Smith 

%R3 Problem Created Date and Time Problem Created Date & Time: 07/11/2013 
02:23 PM 

%R4 Problem Owner (with e-mail link) Owner: Tom Smith 
%R5 Problem Title Problem Title: Parts 
%R6 Problem Description Problem Description: Part Reports 

| New Line Starts a new line in the message 
%DTX Action Detail Value* Detail Text: Value 

%RDTX Problem Detail Value* Detail Text: Value 
%PDTX Problem's Associated Project Detail 

Value* 
Detail Text: Value 

* See "Using Detail Variables" for more information. 

Project Action E-mail Variables 

These variables related to project action records can be used in any of the following e-mail 
formats: 

• Action - E-mail Message Format - New - Project 

• Action - E-mail Message Format - Updated - Project 

• Action - E-mail Message Format - Complete - Project 

Variable Description Example 
%1 Action ID (with link to 

action) 
Action ID: #117 

%2 Action Created By Name 
(with e-mail link) 

Action Creator: John Smith 



Managing Preferences 

XFRACAS 2020 Admin Guide 87 

 

%3 Action Created Date and 
Time 

Action Created Time/Date: 07/12/2013 01:21 PM 

%4 Action Type Action Type: Project Action 
%5 Associated ID (with link to 

project) 
Project: E1-4 

%6 Action Due Date Action Due Date: 08/21/2013 
%7 Action Complete Date Action Complete Date: 08/13/2013 
%8 Action Description Action Description: Description... 
%9 Action Result Action Result: Result description... 

%10 Action Assigned To Assigned To: John Smith 
%P1 Project Number (with link 

to project) 
Project: #E1-4 

%P2 Problem Owner (with e-
mail link) 

Project Owner: John Smith 

%P3 Project Start Date and Time Project Start Date: 07/11/2013 02:23 PM 
%P4 Project Title Project Title: Part Redesign 
%P5 Project Scope Project Scope: To identify problems with the 

redesign process and implementation 
| New Line Starts a new line in the message 

%DTX Action Detail Value* Detail Text: Value 
%PDTX Project Detail Value* Detail Text: Value 

* See "Using Detail Variables" for more information. 

CSI Action E-mail Variables 

These variables related to CSI action records can be used in any of the following e-mail formats: 

• Action - E-mail Message Format - New - CSI 

• Action - E-mail Message Format - Updated - CSI 

• Action - E-mail Message Format - Complete - CSI 

Variable Description Example 
%1 Action ID (with link to action) Action ID: #203 
%2 Action Created By Name (with e-mail 

link) 
Action Creator: John Smith 
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%3 Action Created Date and Time Action Created Time/Date: 
07/16/2013 11:16 PM 

%4 Action Type Action Type: CSI Action 
%5 Associated ID Customer Support: E1-9 
%6 Action Due Date Action Due Date: 08/27/2013 
%7 Action Complete Date Action Complete Date: 08/19/2013 
%8 Action Description Action Description: Description... 
%9 Action Result Action Result: Result description... 

%10 Action Assigned To Assigned To: John Smith 
%C1 Customer Support Information Number CSI: #E1-9 
%C2 Customer Support Information Author CSI Author: Tom Smith 
%C3 Customer Support Information Shipment 

Date 
Shipment Date: 05/21/2013 03:32 PM 

%C4 Customer Support Information 
Commission Date 

Commission Date: 05/26/2013 09:01 
AM 

%C5 Customer Support Information 
Decommission Date 

Decommission Date: 07/15/2013 
04:44 PM 

%C6 Customer Support Information System 
Configuration 

System Configuration: 867978, Part 
1983 ver. 1 

| New Line Starts a new line in the message 
%DTX Action Detail Value* Detail Text: Value 

%CDTX CSI Detail Value* Detail Text: Value 

* See "Using Detail Variables" for more information. 

Failure Analysis Action E-mail Variables 

These variables related to failure analysis action records can be used in any of the following e-
mail formats: 

• Action - E-mail Message Format - New - FA 

• Action - E-mail Message Format - Updated - FA 

• Action - E-mail Message Format - Complete - FA 
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Variable Description Example 
%1 Action ID (with link to action) Action ID: #121 
%2 Action Created By Name (with e-

mail link) 
Action Creator: John Smith 

%3 Action Created Date and Time Action Created Time/Date: 07/12/2013 
09:32 AM 

%4 Action Type Action Type: Failure Analysis Action 
%5 Associated ID Failure Analysis: E1-3 
%6 Action Due Date Action Due Date: 08/21/2013 
%7 Action Complete Date Action Complete Date: 08/13/2013 
%8 Action Description Action Description: Description... 
%9 Action Result Action Result: Result description... 

%10 Action Assigned To Assigned To: John Smith 
%F1 Failure Analysis Number Failure Analysis Report: #E1-3 
%F2 Failure Analysis Created By Created By: John Smith 
%F3 Failure Analysis Created Date and 

Time 
FA Report Open Date: 07/13/2013 01:23 
PM 

%F4 Failure Analysis Incoming Part 
Number 

Incoming Part #: 5309a 

%F5 Failure Analysis Incoming Part Name Incoming Part Description: Parts 
%F6 Failure Analysis Incoming Serial 

Number 
Incoming Serial #: 867 

%F7 Failure Analysis System Part Number System Part #: 5309b 
%F8 Failure Analysis System Part Name System Part Description: Parts 
%F9 Failure Analysis System Serial 

Number 
System Serial #: 1943 

| New Line Starts a new line in the message 
%DTX Action Detail Value* Detail Text: Value 

%FDTX Failure Analysis Detail Value* Detail Text: Value 

* See "Using Detail Variables" for more information. 

Using Detail Variables 

The following variables allow you to include information from details in your action e-mails. 
(See Managing Details.) They can be used in the formats listed in the preceding sections for 
each record type. 



Managing Preferences 

90 http://xfracas.reliasoft.com 

 

• Current action. To include one or more details from the current action, use %DTX. 

• Parent records. To include one or more details from parent records, use %IDTX (incident), 
%RDTX (problem), %PDTX (project), %CDTX (CSI) and %FDTX (failure analysis). 

For each of these variables, you'll need to specify X, the detail type ID. (See Using Detail Type 
IDs to find this number).  

Status E-mail Variables 

These variables (related to the status updates that users can add in incidents, actions, failure 
analysis, problems or projects) can be used in any of the following e-mail formats: 

• Detail Status - E-mail Message Format - Action 

• Detail Status - E-mail Message Format - Incident 

• Detail Status - E-mail Message Format - FA 

• Detail Status - E-mail Message Format - Problem 

• Detail Status - E-mail Message Format - Project 

Variable Description Example 
%1 Status Added By (with link to send e-mail to 

user) 
Status Added By: John Smith 

%2 Date and Time Date & Time: 07/11/2013 02:23 
PM 

%3 Associated Record Associated Incident: E1-103 
%4 Status Text Status Text: Status description... 
| New Line Starts a new line in the message 

%DTX Detail Value* Text Detail: Value 

* Use %DTX to include information for one or more details from the parent incident, problem, 
project, action or failure analysis record. (See Managing Details.) For each detail, you'll need to 
specify X, the detail type ID. (See Using Detail Type IDs to find this number). 

Using Detail Type IDs 
You may need to know a detail type ID (i.e., the ID number for a specific detail) if you are... 

• Building XML files for import into XFRACAS. (See Data Import Page.) 
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• Configuring an e-mail message format and you want to include the name of a detail, along 
with its selected value. (See Configuring E-mail Message Formats and Working with E-mails 
in Detail Lists.) 

To find the detail type ID: 

1. Open the record containing the detail of interest and click the Export icon, . (See 
"Exporting to XML.") 

2. Open the XML file that you just exported in a browser (Firefox is recommended) and then 
scan or search to find the <DetailTypeID> for the detail. 

Note: You'll need to have the "Access Data Export" permission to see the Export command. 

Alternatively, you can also find the ID by setting the "XFRACAS – Display Debug IDs" preference 
to True and then checking the Details page. The ID will appear in brackets preceding the detail 
name. 

 

Time Metric Calculations 
If you configure XFRACAS to track incidents and part repairs/replacements for specific serialized 
systems, you can capture time/usage data for use in reliability data analysis. 

There will always be one primary time/usage metric (Time Metric 1) and you can choose to 
enable up to two additional fields (Time Metric 2 and Time Metric 3). By default, these fields 
are called "System Hours," "Number of Starts" and "kW Run Hours," but you can record any 
metric(s) of interest (hours, miles, kilometers, cycles, etc.) and use the Resource Editor to 
modify the interface labels. 

REPORTED SYSTEM HOURS 

The Customer Support (CSI) page for a serialized system displays the latest reported value(s) for 
the time/usage metric(s) enabled for the entity. This information can be obtained from any or 
all of the following sources: 

• Incidents reported for the serialized system 

• Manual entry via the Customer Support interface 
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• Usage data imported from an external source 

Click the link to see the history of all usage reports for that particular system. Click   to 
manually enter new information. 

 

ESTIMATED SYSTEM HOURS 

For the primary metric only (Metric 1), the Customer Support page also displays the estimated 
usage at today's date. If there are at least two reported values for the system's actual 
time/usage, the estimate is calculated as follows: 

(Commission Date - Today's Date) x Average Usage per Day 

To estimate the average usage per day, XFRACAS fits a slope to the reported time/usage values. 
However, if the estimate exceeds the maximum possible per day (which is specified in the 
"Incident - Max Units/Day - Time Metric 1" preference), the max per day will be used instead. 

This estimate is used for CSI MTBF calculations (discussed below) and may also be incorporated 
into custom reports and charts if applicable. 

AUTO-POPULATE TIME METRIC 1 

By default, users will be prompted to enter the time/usage metric(s) in each incident report for 
a serialized system. Alternatively, you can configure XFRACAS to automatically populate the 
primary metric (Metric 1) when the following preferences and inputs are available: 

Preferences 

• Incident - Auto-populate Time Metric 1 is True 

• Incident - Max Units/Day - Time Metric 1 is a number greater than 0 

Incident 

• Serial Number has been entered 

• Occurrence Date has been entered 
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Customer Support 

The commission date has been entered and it is earlier than the incident's occurrence date. 

• If the System Down Event field (a special Detail field for incidents) is not enabled for the 
entity, the calculation is as follows: 
 
(Commission Date - Occurrence Date) x Max Units/Day 

• If the System Down Event field is enabled, downtime is obtained from any incidents for the 
serialized system where this check box is selected. For each incident, the time down is the 
Repair Date – Occurrence Date (or if a repair has not been entered, it is Today's Date – 
Occurrence Date). The calculation to auto-populate Metric 1 is: 
 
(Commission Date - Occurrence Date - Time Down) x Max 
Units/Day 

AUTO-CALCULATE TIME METRIC 1, 2 OR 3 

You can also configure XFRACAS to automatically calculate a time metric based on the value for 
another metric. For example, if Metric 1 is miles, you can configure Metric 2 as kilometers and 
calculate it automatically based on the value entered for miles (t1 * 1.60934). The behavior 
depends on the following preferences and what the user enters in the incident page. 

• Incident - Display Time Metric [2/3] 

• Incident - Always Auto-calculate Time Metric [1/2/3] 

• Incident Time Metric [1/2/3] Formula 

It is important to be aware that your Preferences settings do not prevent you from saving 
incompatible settings or invalid formulas, which may result in unexpected behavior for the 
metric fields in incidents. Note that: 

• If the formula is blank, the field saves the entered value, regardless of whether "Auto-
calculate" is True. 

• If the formula is not blank and "Always Auto-calculate" is True, the field attempts to 
calculate the value. If the formula is invalid, the calculated value will be 0. 

• If the formula is not blank and "Always Auto-calculate" is False, the field EITHER saves the 
entered value OR attempts to calculate if a value was not entered. For example, this 
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configuration may be appropriate if some incidents have usage reported in Metric 1 and 
other incidents have usage reported in Metric 2. 

Also note that: 

• Operands and operators must be separated by spaces. 

• Valid operators are * / + and –. 

• A valid operand can be a number, a time metric field (t1, t2 or t3) or a list of parameters 
(e.g., [t1,t2]) that will be checked in order until a parameter is found that is not 0. 

• A metric's formula should not refer to itself. For example, the formula for Metric 1 
should not be t1 * 20. 

• A metric's formula should not refer to a metric that is not enabled. 

• A metric's formula should not refer to a metric that is already set to auto-calculate. For 
example, if the formula for Metric 2 is t1 * 30 (e.g., 30 miles for every hour), do not set 
the formula for Metric 3 as t2 * 1.60934 (e.g., 1.60934 km for every mile). Instead, set it 
to t1 * 48.202 (e.g., 48.202 km for every hour). 

MTBF, MTBCF, MTBNCF AND MTBI 

The CSI page provides the option to display some very basic reliability metrics based only on the 
data from a single serialized system. If the preferences are enabled, the MTBF metrics are 
calculated as follows: 

Number of Incidents ÷ Total Time/Usage 

Although we recommend using Weibull++ for more robust reliability analysis whenever 
possible, the CSI MTBF metrics may be used, for example, to monitor a specific machine in a 
manufacturing line to determine whether it is meeting the contracted MTBF. 

The CSI page displays two values for each metric (e.g., MTBF / MTBFE). The first is based on the 
reported usage for Metric 1; the second is based on the estimated usage. 

Since an incident may be a "chargeable failure" or a "non-chargeable failure" depending on the 
Incident Category, there's a choice of four metrics that can be displayed: 

• CSI - Display MTBF (mean time between failures) and CSI - Display MTBCF (mean time 
between chargeable failure incidents) are the same metric 
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• CSI - Display MTBNCF is the mean time between non-chargeable failure incidents 

• CSI - Display MTBI is the mean time between incidents (both chargeable and non-
chargeable) 

EXTRACT DATA FOR RELIABILITY ANALYSIS 

For more robust reliability analysis, you can use the Reliability Data Warehouse (RDW) in the 
ReliaSoft Weibull++ desktop application to extract data from XFRACAS that can be used for 
either life data or reliability growth analysis. 

For information about using the desktop applications to extract the data and transfer to an 
analysis folio, see Extracting Data from XFRACAS in the desktop application's help files. The 
extraction process for life data analysis works as follows: 

1 – Select Part 

The user selects one or multiple parts to be analyzed together in the same data set. 

2 – Get Data from Serialized Incidents 

The RDW identifies all serialized systems that contain the specified part(s). For each serialized 
system, the RDW then finds all "serialized incidents" and orders them by occurrence date to 
build a timeline. 

• The RDW finds all incidents within the timeline in which the specified part(s) were repaired 
or replaced. 

• The RDW checks the "Failure Type" for the repair and the "Incident Category" for the 
incident: 

• If both are chargeable (e.g., repair is "Primary Failure" and incident is "Component 
Failure"), then the incident is treated as a Failure (F). 

• If one or both are non-chargeable (e.g., repair is "Primary Failure" but the incident is 
"ASP Error"), then the incident is treated as a Suspension (S). 

3 – Get Data from Part Incidents 

The RDW finds all "part incidents" in which the specified part(s) were repaired or replaced. 

http://help.reliasoft.com/weibull20/extracting_data_from_xfracas.htm
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The RDW checks the "Failure Type" for the repair and the "Incident Category" for the incident 
(as described above) to determine if the incident will be treated as a Failure (F) or Suspension 
(S). 

 

Configuring Criticality Metrics 
To configure a criticality formula in the String Preferences area of the Preferences page, the 
formula must consist of one of the following: 

• A number (e.g., 7, 12.4, etc.). 

• A criticality field, represented by "c" plus the field’s display order. For example, c2 or c4. 
The field’s display order is set and shown in the Criticality page. 

• A list of numbers or criticality fields separated by commas, surrounded by brackets. For 
example, [c4,c3,c2] or [c7,c5,9]. 

Every number or criticality field (except those in brackets) must be separated by one of the 
following math operators: *, /, + or –. 

The formula requires a space between the numbers and math operators but not between the 
items in brackets. 

The formula is parsed from left to right with numbers or criticality fields alternating with math 
operators. When a bracketed list is encountered, the list is checked for any value that is not a 0. 
The first value that is not a 0 is the value that is used in the formula. 

The default Incident Potential Criticality formula is c1 * c2 * c3. In this formula, criticality field 1, 
criticality field 2 and criticality field 3 are multiplied together. 

The default Problem Current CIN formula is c1 * c2 * c3 * [c6,c5,c4] * c7. In this formula, 
criticality field 1, criticality field 2 and criticality field 3 are multiplied together. Next, criticality 
field 6, then criticality field 5 and then criticality field 4 are checked for 0. The first criticality 
field that does not contain a 0 is multiplied into the formula and the two other criticality fields 
are ignored. Finally, the formula is multiplied by criticality field 7. 
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Entering an ADS Path 
This topic is relevant if you wish to use the Active Directory page to add users from Microsoft 
Active Directory (AD). 

The Active Directory Services (ADS) path uniquely represents each object in the ADS. This can 
be compared to your mailing address. If the path showed "United States, Arizona," then all 
addresses in the state would be displayed. In contrast, "United States, Arizona, Pima County, 
Tucson, Eastside Loop" would display only the addresses on that street. 

To retrieve the network’s Global Address List (GAL), you can enter the correct ADS path for a 
Lightweight Directory Access Protocol (LDAP) connection in the "Exchange ADS Path" 
preference, which is located in the String Preferences area of the Preferences page. LDAP is a 
set of protocols used to access contact information from a server (in this case, a Windows AD 
server). This path is necessary to retrieve e-mail addresses from the network's GAL. 

If you do not plan to implement this functionality, leave the three Exchange preferences blank. 
If your server supports CDO 1.21, the Exchange ADS Path preference can be left blank and the 
Exchange Profile Name and Exchange Server Name preferences can be used to access the 
network's GAL via a CDO connection. 

LDAP CONNECTION STRING EXAMPLES 

Although each ADS path will be unique, it will follow this general format for a 
Windows/Exchange system: 

LDAP://YourDomain.local/OU=Users,DC=YourDomain,DC=local 

If there is a problem resolving the name, try using the IP address instead: 

LDAP://10.0.0.25/OU=Users,DC=YourDomain,DC=local 
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Managing Configurable Fields 
 

Managing Details 
Use the Details page to manage configurable fields in various record types. Permissions 
required to access this page: Access Admin Tab and Manage Details. 

To open the page, choose Admin > Configure > Details. 

 

If your implementation has more than one entity, the detail fields can be configured separately 
for each. The drop-down list at the top of the page determines which entity's detail fields are 
currently displayed. 

TYPES OF DETAIL FIELDS 

• Action Fields appear in the Action page. 

• Company Fields appear in the Companies page. 

• Contact Fields appear in the Contacts page. 

• CSI Fields appear in the Customer Support page. You can specify the sections where the 
fields will appear. 

• FA Fields appear in the Failure Analysis page. You can specify the sections where the fields 
will appear. 

• Incident Fields appear in the Incident page. You can specify the sections where the fields 
will appear. 

• Location Fields appear in the Locations page. 

• Part Fields appear in the parts that are associated with system templates. 

• Problem Fields appear in the Problem page. You can specify the sections where the fields 
will appear. 
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• Project Fields appear in the Project page. You can specify the sections where the fields will 
appear. 

• Serialized Part Fields appear in the parts that are associated with serialized systems. 

The options depend on the type of field (description, date, check box, etc.) and record 
(incident, problem, etc.). Some current settings appear in parentheses under the field name. In 
the following example, the "Custom Text Field" will display in the first detail field position in the 
"Incident Details" area of the Incident page, and it will be read-only after a value is entered. The 
"Custom Date Field" will display in the second portion of that area, and is required (red text). 

 

Fields identified with an asterisk (*) are referred to as "special detail fields" and can be retired 
but not deleted. 

ADDING OR EDITING A FIELD 

To add a new field, click the Add icon, , for the relevant record type. To edit an existing field, 
select it using the radio button to the left of the field and then click Edit, . 

Note that you can use the same detail field in multiple entities, if desired. The Add or Remove 
Entities area shows the entities that you have access to, and allows you to choose which ones 
will include the detail field you're currently editing. If you do not have access to all the entities 
where a field is used, you can add or remove it from the entities that you have access to, but 
you can't edit the other options. 

1. If applicable, select the area that the field will appear in from the Section or Step drop-
down list. 

2. Select a Field Type from the drop-down list. 

3. Enter the Field Name (the label shown in the interface) and Field Description (the tip that 
appears when a user points to the field). 

4. Specify whether user input is Optional/Required. This option is not available for the 
following field types: Accessory; Attachments Table; Check Box; Separator; Status. 
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5. Specify the Display Order, which determines where the field will be displayed in the page. If 
you don't specify a value, XFRACAS will automatically assign one. If the display order 
numbers are not in sequence (e.g., 1, 2, 4), then a blank space will fill that position. 

6. Enable Span width of page, if desired. This forces the detail field to span the entire width of 
the area on the page. If not selected, the field will display at its default width, which varies 
depending on the field type. 

7. Specify the Default Value that will be displayed on new record creation, if applicable. This 
option is not available for the following field types: Accessory; Address; Attachments Table; 
Company; Current System Users; Failure Mode; Separator; Status; System Contacts; Tree. 

8. If applicable, select an Existing Dropdown. For some detail types (e.g., select list, tree, etc.), 
you will need to use the Lists page to configure values that will be available to select. When 
you create the detail, you can choose an Existing Dropdown or leave the option blank so 
XFRACAS will create a new list. 

9. Specify whether the detail is read-only. The Read-only options allow you to make the detail 
unavailable to edit in certain circumstances. The options depend on the field and/or record 
type. 

a. Always - the field is always read-only in the web interface (e.g., because the value is 
intended to be imported). If the value is imported incorrectly, only a user with the 
"Details - Overwrite Read-Only" permission will be able to modify it. 

b. After a value is entered - once a user enters a value in the field, it can't be changed. 

10. Specify the Number of Lines Displayed. This option is available for the Description field 
type only. If not specified, then the number of lines displayed is set by the XFRACAS - 
Description Number of Lines Displayed preference. 

DELETING OR RETIRING A FIELD 

To remove or retire a field, first select it and then click the Delete icon, . 

• If the field is a special detail field (identified with an asterisk) or has already been used in 
any existing records, it will be retired for the current entity and appear grayed out. 

• If the field has never been used in any existing records, it will be completely removed. 

To unretire a detail field, select the field name and click the Edit icon, . You will see a 
message confirming that you want to unretire the detail field. Click OK to proceed. 
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USING SPACES AND SEPARATORS 

To add or remove spaces above a particular detail, select the radio button to the left of the field 
and then click the Add Space or Delete Space links for the relevant record type. 

To add a line within an area of the space, add a "Separator" detail. The Field Description will 
display as a label within the page, and the Field Name will display as a tip when the user points 
to the separator. If you leave both fields blank, only the line will be displayed. 

In the following example, there are 4 extra spaces between a custom description field (in 
position 4) and a separator (in position 9) that identifies a custom sub-section within two list 
fields (positions 10 and 11). 

 

Field Types 
The following types of detail fields can be created: 

• Accessory - a drop-down list where users can select multiple options, each of which 
involves a description, a part number and a serial number. The options in the list will be 
controlled by the users via Add, Edit and Delete icons that appear next to the list. 

• Address - a drop-down list displaying the combinations of company and location that have 
been defined for your implementation. 

• Alphanumeric Input Box - an input box where users can enter letters and numbers. You can 
set a maximum length between 1 and 255 characters; the default maximum is 50 
characters. 

• Attachments Table - a table that allows users to create attachments. 

• Check Box - a check box that users can select or clear. 

• Company - a drop-down list displaying all companies that have been defined for your 
implementation. 
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• Contacts - a drop-down list displaying all contacts that have been defined for your 
implementation. 

• Currency - an input box where users can only enter numbers. The input is interpreted as 
currency. You can specify the number of decimal places to display, the minimum and/or 
maximum acceptable value that can be entered in the field and the world currency type. 

• Date - a date field. 

• Description - an input box in which users can enter letters and numbers. You can set a 
maximum length between 1 and 4,000 characters; the default is 4,000 characters. You can 
select the Allow Existing Text Search check box to allow users to choose text that has 
already been used in the field in other records. 

• Failure Mode - a field controlled by two drop-down lists where users can select options — 
one for failure mode and one for root cause. The options in the lists will be determined by 
the failure modes and root causes of failure modes assigned to the parts on the Templates 
page. It is also possible to allow users to add options to the list by selecting the Allow User 
Creation check box. This field type is available only for the Failure Analysis, Incident and 
Problem pages. 

• Hyperlink - a hyperlink that allows linking to an external site with the ability to pass 
variables. (See Configuring Hyperlink Details). 

• Item Category - a field that allows users to select from the same list of item categories that 
are defined in the data for ReliaSoft desktop applications. This is used when importing or 
synchronizing parts and failure mode data from XFMEA, RCM++ or RBI. (See "Using the Item 
Category Field.") 

• Multiple List - a list where users can select multiple options. The options in the list will be 
controlled by the users via Add, Edit and Delete icons that appear next to the list. 

• Numeric Input Box - an input box where users can only enter numbers. You can specify the 
number of decimal places to display and the minimum and/or maximum acceptable value 
that can be entered in the field. 

• Print Preview - a link that provides a print preview of the page, based on the *.xslt file 
specified for the field. This field type is available only for the CSI, Failure Analysis, Incident, 
Problem and Project pages. 
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Note: If you upload a new *.xslt file after opening a page that includes a "print preview" 
link, you'll need to reload that page to use the new template. 

• Select List, Administrative Controlled - a drop-down list where users can select an option. 
These options will be controlled via the Lists page. It is also possible to allow users to add 
options to the list by enabling the Allow User Creation option. If you want to use the same 
list of values as an existing detail field within the current entity, select the name of that 
field from the Existing Dropdown list. 

• Select List, Administrative Controlled, Multiple - a drop-down list where users can select 
multiple options. The options in the list will be controlled via the Lists page. It is also 
possible to allow users to add options to the list by enabling the Allow User Creation 
option. If you want to use the same list of values as an existing detail field within the 
current entity, select the name of that field from the Existing Dropdown list. 

• Select List, Checkbox Options, Multiple - a list where users can select multiple options 
using check boxes. Note that pointing to a selected option will display a tool tip indicating 
the user who checked the item and the time it was checked. The options in the list will be 
controlled via the Lists page. It is also possible to allow users to add options to the list by 
enabling the Allow User Creation option. If you want to use the same list of values as an 
existing detail field within the current entity, select the name of that field from the Existing 
Dropdown list. 

• Select List, User Controlled, Multiple - a drop-down list where users can select multiple 
options. The options in the list will be controlled by the users via Add, Edit and Delete icons 
that appear next to the list. 

• Separator - a horizontal line. Note that the Field Name will be the tool tip that appears 
when a user points to the field and the Field Description will be shown as a label below the 
separator. 

• Status - a status table with an Add icon that allows users to add status messages. You can 
enable Allow Existing Text Search to allow users to choose text that has already been used 
in the field in other records. 

• Tree - a list of values or issues organized into a tree structure. The options in the tree will 
be controlled via the Lists page. 

• Users - a drop-down list of all current users. You can use the User Category drop-down list 
to specify a single user category that will be used to filter the users list, if desired. Fields of 
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this type will have an icon, , that allows users to select themselves from the list with a 
single click. 

• Yes/No Option Buttons - Yes and No radio buttons. 

Configuring the Select Existing Utility 
The Select Existing utility enables users to reuse text from existing description and status fields 
in action, customer support, failure analysis, project, incident and problem records. This can 
save time on data entry, ensure consistency and facilitate brainstorming. 

When the description or status is a configurable detail field, you can choose whether the 
feature will be available for that particular field. You can also choose which users will be able to 
access the utility when it is available. 

ENABLE THE SEARCH FEATURE FOR SELECTED DETAIL FIELDS 

When you create or modify a description or status field in the Details page (Admin > Configure 
> Details), select Allow Existing Text Search to enable the feature for that field. It will be visible 
only to uses who have the "Details - Allow Existing Text Search" permission. 

 

SET THE USER PERMISSIONS 

When you create or modify a user account in the Users page (Admin > Configure > Security > 
Users), set the following permissions to specify whether the user can access the utility when it 
is available. 
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Permission for Any Record Type 

The Details - Allow Existing Text Search permission applies for detail fields in any record type 
— all of the description and status fields in incidents and problems, as well as any relevant 
configurable details in actions, CSIs, failure analysis reports and projects. 

Permissions for Specific Record Types 

These permissions apply for description and status fields that are built-in for a specific record 
type (e.g., action descriptions, failure analysis visual inspection, etc.). 

• Action - Allow Existing Text Search 

• CSI - Allow Existing Text Search 

• Failure Analysis - Allow Existing Text Search 

• Project - Allow Existing Text Search 

 

Configuring Hyperlink Details 
A hyperlink detail allows linking to an external site with the ability to pass variables. 

Variable Description 
%1 Record number (e.g., "E1-1") 
%2 User ID (ID of the currently logged in XFRACAS user) 
%3 Page ID  (the internal ID of the record) 
%4 User Name (username, with domain, of the currently logged in XFRACAS user, e.g., 

"COMPANY\USERNAME") 
%5 Page title (title of the record) 
%6 User Name Without Domain (username of the currently logged in XFRACAS user, 

but with the Windows domain stripped off. For example, "COMPANY\USERNAME" 
would be included as just "USERNAME.") 

%7 User Language Code 
%DTX Detail Value (X represents the detail type ID) 

For example, the URL field for a hyperlink detail might look like this: 

http://external.site.com/doStuff.cgi?record=[%1]&user=[%2]&title=[%5]&lang=[%7] 
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When incident E1-1, titled "Overflow," is edited by the user with ID 234, the URL generated 
would be: 

http://external.site.com/doStuff.cgi?record=E1-1&user=234&title=Overflow&lang=en 

Clicking the link opens the result in a new browser window. There is no expectation of anything 
being returned. 

 

Managing Criticality Fields 
Use the Criticality page to maintain the criticality fields that may appear in the Incident and/or 
Problem pages. Permissions required to access this page: Access Admin Tab and Manage 
Criticality. 

To open the page, choose Admin > Configure > Criticality. 

 

If your implementation has more than one entity, the criticality fields can be configured 
separately for each. The drop-down list at the top of the page determines which entity's 
criticality fields are currently displayed. 

USING CRITICALITY FIELDS 

To calculate criticality metrics in the Incident and/or Problem page, configure all of the 
following: 

Preferences  

• Incident - Display Actual Criticality 

• Incident - Display Potential Criticality 

• Problem - Display Criticality 

(See Managing Preferences) 

Criticality Fields and Lists 

Customize the fields that are installed with XFRACAS and/or create new fields to meet your 
particular needs. 
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Criticality Formulas  

Customize the formula that calculates the criticality for each record based on the user's 
selections in the criticality fields. (See Configuring Criticality Metrics) 

ADDING, EDITING, DELETING OR RETIRING FIELDS 

The steps to add, edit, delete or retire a criticality field are similar to managing other types of 
fields in the Details page. (See Managing Details.) 

Note that: 

• Criticality fields are automatically set to the "Select List, Administrative Controlled" field 
type. Use the Lists page to manage the options in the drop-down lists. 

• For incident criticality fields, the Section indicates whether the field is used to calculate the 
potential criticality or the actual criticality. This is not relevant for problem criticality fields. 

• The label under each field indicates the code that represents the field in the criticality 
metric formulas. For example, c2 = schedule, c3 = cost, etc. 

 

Managing Lists 
Use the Lists page to maintain the values for fields that require selection from predefined 
options (such as drop-down lists, trees and check box fields). Permissions required to access 
this page: Access Admin Tab and Manage Lists. 

To open the page, choose Admin > Configure > Lists. 

 

If your implementation has more than one entity, the lists can be configured separately for 
each, but the same list may be used in multiple entities. The drop-down list at the top of the 
page determines which entity's lists are currently displayed. 

Some lists are defined in every XFRACAS implementation and you can configure them to meet 
your particular needs (see "Standard Lists" below). You can also create and manage custom lists 
that are used with certain types of configurable detail fields. Custom lists will have names like 
"Incident Detail - Field Name" or "Action Detail - Field Name" by default. 
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EDITING LIST PROPERTIES 

Each list has the following properties. The name will be the same in all entities where the list is 
used; the display and sort-by properties, as well as the list options, may differ in each entity. 

• Name - the label that displays on the bar in the Lists page. This may not correspond to the 
name of the user interface field(s) where the list is used. 

• Display - determines whether the list will display codes, descriptions or a combination of 
both. For example, you could configure the list of currency types to display "USD," "US 
Dollars," "USD: US Dollars" or "US Dollars: USD." 

Note: Reports and charts display only the description, regardless of which setting you 
choose. (See "Editing Option Properties.") 

• Sort By - determines whether the list will be sorted alphabetically or numerically, by code 
or description, in ascending or descending order. If you choose to sort numerically, make 
sure all options have a number in that field. 

To save changes to the list's properties, click Save. To export the list's options to XML, click 
Export. 

ADDING, EDITING OR DELETING LIST OPTIONS 

For each list, the table shows the options for the current entity. A check box in the last column 
indicates that the option will be selected by default for new records. A date in the last column 
indicates that the option is retired and will not be available to select for new records. 

• To add a new option, click Add,  . 

Tip: Some lists can have the options defined in more than one level (i.e., tree details). If an 
existing option is selected when you click Add, the new one will be added to the next level 
under that option. If an existing option is not selected, the new one will be added to the top 
level. After an option is created, you can edit its properties to change the "parent."   

• To edit an option, select it and click Edit,  . 

• To delete or retire one or multiple options, select the option(s) and click Delete,  .  If an 
option has never been used, it will be deleted. If it has been used, it will be retired. 
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To add options that have been defined for this list in another entity, click More Issues. In the 
popup window, select another entity that has the same list. The left panel shows options that 
are not available in the current entity, if any. To add selected options to the current entity, 
move them into the center panel and then click Save. 

EDITING OPTION PROPERTIES 

Each list option has the following properties: 

• Description - a text label that can be up to 200 characters. 

• Code - a number, or a shorter text label (e.g., abbreviation) that can be up to 40 characters. 

• Default - if selected, the option will be selected by default for new records. 

• Entities - shows the entities where the list is used. For the entities that are selected 
(highlighted with a gray background), this option will appear in the list in that entity. 

When applicable, you may also be able to specify: 

• E-mail Address - applies for lists used by certain types of configurable detail fields. If your 
implementation is configured for e-mail notifications, the application can send an e-mail 
when the option is selected in a record. 

• Reciprocal - applies for the "Attachment - Record Association Type" list. It sets the options 
for the Relationship Type field in the Associated Files window. For example, if 
"Superseding" and "Superseded" are configured as reciprocal relationship types, users can 
create links between two XFRACAS records where one record is identified in the 
attachments table as "Superseding" and the other is identified as "Superseded." 

• Parent - applies when options can be defined in more than one level (e.g., tree details). As 
discussed above, the parent is set automatically when you add a new option. You can 
change the parent when editing the properties for an existing option. 

STANDARD LISTS 

These lists are defined in every XFRACAS implementation: 

• Attachment – Record Association Type - sets the options for the Relationship Type field in 
the Associated Files window. (See Attachments.) 

• Audience Restriction - sets the options for the Audience Restriction field, which can be 
displayed in the Incident page and Problem page if the preference is enabled. 



Managing Configurable Fields 

XFRACAS 2020 Admin Guide 111 

 

• Company Sales Region - sets the options for the Sales Region field in the Companies page. 
(See Managing Companies.) 

• CSI Detail - Build Designation, Market Segment, Mode of Operation and Primary 
Application - sets the options for some "special detail fields" in the CSI page. 

• CSI Extended Warranty Terms - sets the options for the Terms field in the CSI page. 

• Currency Type - sets the options for detail fields with type = Currency. 

• FA ATP Test Result - sets the options for the Test Results fields in the ATP / Burn-in section 
of the Failure Analysis page. 

• FA Customer Return Type - sets the options for the Return Type field in the Failure Analysis 
page. 

• FA Status and FA Status Close - sets the options for the FA Status field in the Failure 
Analysis page. The selected option determines whether a record is open or closed. 

• Incident Category Chargeable / Non-Chargeable  and Incident Failure Type Chargeable / 
Non-Chargeable - set the options in the Incident Category field in the Incident page and 
the Failure Type field in the Repair or Replace Parts utility. These determine how data are 
extracted for reliability analysis. (See Repair or Replace Parts Utility.) 

• Incident Criticality - Cost, Criticality and Schedule - sets the options for criticality fields in 
the Incident page and/or the Problem page, if the preferences are enabled. (See Managing 
Criticality Fields.) 

• Incident Parts Disposition - sets the options for the Parts Disposition field in Repair or 
Replace Parts utility. 

• Incident Report Type - sets the options for the Report Type field in the Incident page. 

• Incident State and Incident State Closed - sets the options for the State field in the Incident 
page. The selected option determines whether a record is open or closed. 

• Incident System Status - sets the options for the System Status field in the Incident page 
for serialized incidents (and for part incidents if the preference is enabled). 

• Output Record Count - sets the options for the Records per Page field in the Output section 
of the Report Builder page. This determines the number of records displayed on each page 
of the report results. 
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• Portal Link Groups - sets the options for the Groups field in the Links panel. (See Links 
Panel.) 

• Problem Criticality - Business Decision, Customer Rate, LT Rate and ST Rate - sets the 
options for criticality fields in the Problem page, if the preferences are enabled. (See 
Managing Criticality Fields.) 

• Problem Priority - sets the options for the Priority field in the Problem page. 

• Problem Status Closed - sets the options for the Set Close Status field that appears in the 
Problem page after the required number of steps have been completed. 

• Project Priority - sets the options for the Priority field in the Project page. 

• Reporting Organization - sets the options for the Reporting Organization field in the Users 
page. 

• Team Member Role - sets the options for the Team Role field in the Assign Members 
utility. This may be used in the Incident, Problem and Project pages (if the preferences are 
enabled) and in the User Groups page. (See Assign Team Members Utility.) 

 

Managing Action Fields and Categories 
Use the Action Management page to hide or display actions fields and maintain the categories 
that users can select from when they create actions. Permissions required to access this page: 
Access Admin Tab and Manage Action Categories. 

To open the page, choose Admin > Configure > Action Management. 

 

HIDE OR DISPLAY ACTIONS FIELDS 

Use the Display option under each bar to specify whether an actions field will display in that 
page or section of a page. For incidents, failure analysis reports, CSIs and projects, there can be 
a single actions field in each type of record. For problems, there can be separate actions fields 
for different steps in the problem resolution process (Description, Containment, Root Cause 
Analysis, etc.). 
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MANAGE THE ACTION CATEGORIES 

Each action record has a Category drop-down list. The main category always indicates the 
actions field where the record is displayed (e.g., in an incident, in the Description step for a 
problem, etc.). If desired, use the table under each bar to define your own custom 
subcategories ("action types"). 

• To add a new subcategory, click the Add icon, . 

• To edit an existing subcategory, select it in the list and click the Edit icon, . Changes will 
apply to all records that have already been associated with that subcategory. Alternatively, 
if you do not want the changes to apply to existing records, you can retire the existing 
subcategory and create a new subcategory with the new label.   

• To delete or retire an existing subcategory, select it in the list and click the Delete icon, . 

Note: If you attempt to duplicate an entity that has custom subcategories defined for actions, 
the following error message may appear: "An error occurred while creating <New Entity Name> 
from <Existing Entity Name>. Some data may not have been completely duplicated." 
 
In such cases, the new entity will not show the custom action subcategories that were defined 
in the original entity. To address the issue, go to the Action Management page and select the 
original entity. For each custom subcategory that you want to show in the new duplicated 
entity, click . In the Action Type window, make sure the new duplicated entity is selected 
and click Save. 
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Managing Contacts 
 

Use the Contacts page to manage the list of contacts that are available to select in CSI records, 
Incidents or any record that includes a "Contacts" detail field. Permissions required to access 
this page: Access Admin Tab and Manage Contacts. 

To open the page, choose Admin > Configure > Manage > Contacts. 

 

If your implementation has more than one entity, the same set of contacts will be available in 
all of them. 

Tip: Users can also create and edit contacts that belong to the "Unit Owner" category while 
working in the CSI page. 

Using Contacts in CSIs, Incidents and Other Records 
• In CSI records, contacts are used in the "Unit Owner" and "ASP Field Service Tech" fields. 

• In Incidents, contacts are used in the "ASP Field Service Tech" field if it is enabled for the 
entity. 

• Contacts are also used in any record that has a Detail field with type = Contacts. 

Creating, Editing and Deleting a Contact 
To create a new contact, make sure the Contact drop-down list is blank, enter information into 
the required fields and choose Admin > Contacts > Create. 

 

If you need to clear an existing contact before creating a new one, choose Admin > Contacts > 
New. 
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To edit a contact, choose the name from the Contact list. Make the desired changes and then 
choose Admin > Contacts > Save. 

 

To delete a contact that is not used in any records, choose the name from the Contact list and 
then choose Admin > Contacts > Delete. 

 

Alternatively, if you clear all categories from the contact properties, it will remain assigned to 
any existing records but will not be available to assign to new records. 

Contact Properties 

FIRST NAME AND LAST NAME 

These fields are required; MI (middle initial) is optional. 

COMPANY AND LOCATION 

First select the company and then select one of the locations associated with that 
company. (See Managing Companies and Managing Locations.) 

Tip: In the CSI page, the ASP Field Service Tech field displays contacts that are associated with 
the company that is selected in the ASP field. 

CATEGORY 

• Unit Contact - the contact can be selected in the Contact Name field on the CSI page. Click 
the Associated Systems link to view a report of all CSIs where this contact has been 
selected. 

• ASP Field Tech - the contact can selected in the ASP Field Service Tech field on the CSI page 
or Incident page. 

• External User - please contact ReliaSoft for information about this option. 

If you have configured additional detail fields to meet your organization's specific needs, they 
will be grouped together in a separate Contact Details area at the bottom of the page. 
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Managing Companies 
Use the Companies page to manage the list of companies that are available to select in Contact 
records, CSI records or any record that includes a "Companies" detail field. Permissions 
required to access this page: Access Admin Tab and Manage Companies. 

To open the page, choose Admin > Configure > Manage > Companies. 

 

If your implementation has more than one entity, the same set of companies will be available in 
all of them. 

Tip: Users can also create and edit companies while editing a Contact or CSI record. 

USING COMPANIES IN CSIS AND OTHER RECORDS 

• In CSI records, companies are used in the Distributor, Unit Owner and ASP fields. 

• Each Contact record may be associated with one company and one location. 

• Companies are also used in any record that has a Detail field with type = Company. 

CREATING, EDITING AND DELETING A COMPANY 

To create a new company, make sure the Company drop-down list is blank, enter the required 
fields and choose Admin > Companies > Create. 

 

If you need to clear an existing company before creating a new one, choose Admin > 
Companies > New. 

 

To edit a company, choose the name from the Company list. Make the desired changes and 
then choose Admin > Companies > Save. 
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To delete a company that is not used in any records, choose the name from the Company list 
and then choose Admin > Companies > Delete. 

 

Alternatively, if you clear all categories from the company properties, it will remain assigned to 
any existing records but will not be available to assign to new records. 

COMPANY PROPERTIES 

• Name - a required field. 

• Sales Region - a list of options that are managed under Company Sales Region on the Lists 
page. 

• Location - the locations that are currently associated with this company, shown in a list. 
The table under the list shows the address for the location that is currently selected. Any of 
these locations will be available to select when the company is used in a CSI or Contact 
record. (See Managing Locations.) 

• To add a location to the list, click Add, . In the Location Page window, you can either 
create a new location record or select an existing one. Note that a location cannot be 
associated with more than one company. If you select a location that is already 
associated with another company, it will be removed from the other company. 

• To edit a location, select it in the list and click Edit, . 

• To remove a location, select it in the list and click Remove, . This will remove the 
association with this company, but the location will remain in the database and could 
be associated with another company and/or used in an incident. 

• Category - the fields (Unit Owner, ASP, Distributor) in which the company appears on the 
CSI page. The company can be selected in these fields. 

The following fields will be enabled only if the company record has been saved with the 
Distributor category selected. These are the warranty settings that will be applied when 
you create a new CSI record for this distributor. The default settings for a new distributor 
are based on the CSI - Warranty Months preferences, but you can change them for a 
particular distributor. 

• Warranty From Shipment and Warranty From Commission - the number of months for 
the warranty period. 
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• Initial Warranty Months - whether the warranty period starts on the date of the 
shipment to the distributor or on the date of the delivery to the end-user. 

If you have configured additional detail fields to meet your organization's specific needs, they 
will be grouped together in a separate Company Details area. 

If the company has contacts associated with it, they will be listed in the Associated Contacts 
area at the bottom of the page. 

 

Managing Locations 
Use the Locations page to manage the list of locations that are available to select in Companies, 
Contacts, CSI records, Incidents or any record that includes an "Address" detail field. 
Permissions required to access this page: Access Admin Tab and Manage Locations. 

To open the page, choose Admin > Configure > Manage > Locations. 

 

If your implementation has more than one entity, the same set of locations will be available in 
all of them. 

Tip: Users can also create and edit locations while editing a Company, Contact or CSI record. 

USING LOCATIONS IN COMPANIES AND OTHER RECORDS 

In XFRACAS, a company may be associated with multiple locations. When the company is used 
in a CSI or Contact record, users can select one of the associated locations for that particular 
instance. For example, if ACME Company has sites in Chicago, Dallas and Detroit, the company 
record shows all three locations. When ACME Company is the unit owner for a CSI, users can 
select one of those sites as the location for that particular unit. 

• In Company records, the "Location" field shows all of the locations that are associated with 
that company. 

• In Contact records, the "Locations" field allows users to select one of the locations 
associated with the company that is selected in the "Company" field. 

• In CSI records, the "Location" field allows users to select one of the locations associated 
with the company that is selected in the "Unit Owner" field. 
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• In serialized and part Incidents, the "Unit Location" field allows users to select any of the 
locations defined in the database. If a location is associated with a company, the company 
name will also appear in the list (e.g., "Company - Location"). 

• Locations are also used in any record that has a Detail field with type = Address. 

CREATING, EDITING AND DELETING A LOCATION 

To create a new location, make sure the Location drop-down list is blank, enter information 
into the required fields and choose Admin > Locations > Create. 

 

If you need to clear an existing location before creating a new one, choose Admin > Locations > 
New. 

 

To edit an existing location, choose the name from the list, make the desired changes and then 
choose Admin > Locations > Save. 

 

To delete a location that is not associated with any records, choose the name from the list and 
then choose Admin > Locations > Delete. 

 

You cannot delete a location that is being used other records. 

LOCATION PROPERTIES 

• Description - required; must be unique across all location records in the database. 

• Address, Address 2 and Zip - optional; values are entered/edited separately for each 
location record. For example, if you edit the zip code in one location, any other locations 
with the same zip code value will not be affected. 

• City, State and Country - optional; the same lists will be used for all locations in the 
database. For example, if you edit the name of a city in one location, the change will apply 
in all locations where that city is used. 
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If you have configured additional detail fields to meet your organization's specific needs, they 
will be grouped together in a separate Location Details area at the bottom of the page. 
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Managing Entities 
 

Use the Entities page to manage the entities defined for your implementation. Permissions 
required to access this page: Access Admin Tab and Manage Entities. 

To open the page, choose Admin > Tools > Entities. 

 

XFRACAS can be configured with a single entity (where all users share the same configuration 
settings and data) or with multiple entities (where each entity has its own separate 
permissions, settings and data. The system-wide preferences, companies, contacts and 
locations will be the same for all entities in the database. The user permissions, system 
templates, serialized systems, entity-specific preferences and configurable detail fields can be 
managed separately for each entity. 

Your XFRACAS license determines the maximum number of active entities that can be defined 
for your implementation. 

Adding or Editing an Entity 
To add a new entity, choose Admin > Entities > Create. 

 

In the properties window, enter the required fields (at least a long name and unique record 
prefixes) and click Save. 

IMPORTANT: After you create a new entity, it can be made "inactive" but it cannot be deleted! 
This could affect your ability to manage settings that are shared across multiple entities. We 
recommend that you plan your entity configurations in advance, establish a "template" entity 
that defines common settings for all entities, and implement changes in a staging environment 
before moving to production. 

To edit an existing entity, select the name and then choose Admin > Entities > Edit. 
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Entity Properties 
• Long Name displays in the entity drop-down list at the top of many XFRACAS pages, and in 

other locations where the full entity name is used. 

• Record Prefix allows you to specify an entity-specific prefix for use in record numbers (e.g., 
"ENT-I-" for incidents, "ENT-P-" for problems, etc.). Record prefixes must be unique across 
entities in the same database, and only one entity can be configured without prefixes. 
Users who have the "Manage Entities" permission can change the number (including this 
prefix) for individual records. (See Record Types in the user help.) 

• Parent Entity (optional) allows you to display entities in a tiered structure in the entity 
drop-down list. The name of the parent will be appended to the entity's name in the drop-
down list (e.g., "Parent - Child"). However, there is no implied inheritance for the data or 
settings. For example, if you search for incidents associated with the parent entity, results 
will not be returned for the child entity. Likewise, the configurable settings and permissions 
for the parent entity may not be consistent with the settings for the child entity. 

• Entity Status sets whether the entity is Active (available for use) or Inactive (unavailable for 
use). If there is only one active entity in the system, you cannot make it inactive, so this 
field will be disabled. 

Tip: In addition to using the Inactive status to retire/hide an entity, you can also use it to 
create a tiered structure in the entity drop-down list. For example, if you have an 
Automotive Power Train business unit with an Engine division and a Transmission division, 
you could set "Automotive Power Train" as the inactive parent to the active "Engine" and 
"Transmission" entities. The entity drop-down list would display the active entities as 
"Automotive Power Train - Engine" and "Automotive Power Train - Transmission." 

Duplication Settings 
When you create a new entity (or when you change the status to "active" for an entity that was 
"inactive" upon creation), some basic required settings will always be copied from another 
entity. 

• Text resources 

• Preferences 

• Detail fields that are required (e.g., Incident Description, Problem Description, etc.); if you 
select Copy Detail Fields, the rest of the configurable detail fields will also be copied. 
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• Lists associated with required fields (e.g., Incident State, Problem Priority, etc.); if you select 
Copy Lookup Lists, the rest of the configurable lookup lists will also be copied. 

• Action types 

• Standard reports and charts 

In addition, you can also choose to: 

• Copy Criticality Fields (See Managing Criticality Fields) 

• Copy Users (See Managing Users) 

• Copy Security Groups (See Managing Security Groups) 

For detail fields, lookup lists and action types, duplicated settings will be the same as the entity 
they were copied from unless you later remove the entity from each particular detail, list or 
type and replace it with something else. We recommend establishing a "template" entity that 
defines the settings that are common to all entities and using that template to copy settings for 
each new entity you create. 

Note: Duplicating an entity can consume a large amount of database resources. When you are 
duplicating an entity, other users cannot access the Entities page; they will see a message 
stating that an entity is being duplicated. 
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Reports 
 

Report Viewer 
Use the Report Viewer page to specify which built-in reports will be visible to users and to set 
their display order. This page also determines which options are available in the Quick Search 
utility. Permissions required to access this page: Access Admin Tab and Manage Report Viewer. 

To open the page, choose Admin > Tools > Report Viewer. 

 

For each category of reports in the Report Viewer, specify the display order for the reports. The 
reports will be displayed in the following arrangement: 

 

Note that skipped numbers do not leave a space in the interface. For example, if you do not 
have a report with a display order of 3, the ordered reports will be displayed as follows: 

 

• To hide a report from its list, leave the display order blank. 

• The numbers in parentheses after the report names are the query IDs. 

• To save the changes you have made on the Report Viewer page, choose Admin > Report 
Viewer > Save. 
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Administrator Reports 
Administrator Reports are tabular reports/queries for information managed by application 
admins. These reports provide information about users and their permissions, options in 
configurable lists and owners for template parts. Permissions required to access these reports: 
Access Admin Tab. 

REPORTS PAGE 

1. To use saved admin report templates, choose Home > View > Reports. 

 

2. Click Administrator Reports  . 

REPORTS BUILDER PAGE 

1. To modify or create new admin report templates, choose Options > Designers > Report 
Builder. 

 

2. In the Select Report drop-down lists, select Administrator Reports and then select the 
specific type of report. 
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Imports/Exports 
Importing and Exporting Data 
XFRACAS offers several ways to import and export XFRACAS records (e.g., incidents, system 
configurations, etc.) via *.xml or *.xlsx templates. 

• Use the Data Import page to view and manage the import queue, the log of processed files 
and the log of files that could not be processed. 

• Use the optional XFRACAS Data Import Utility (DIU) Windows service (running on the web 
server) to process the import queue on a scheduled basis. 

• Use the optional XFRACAS Web Service in your own custom application to insert XML files 
into the import queue, along with other related functions. 

Tip: Example files are available for some of the more common import scenarios. You may be 
able to save time by downloading and adapting these files to import your own data. (See XML 
and XLST Templates.) 

If you are using ReliaSoft XFMEA, RCM++ or RBI for failure modes and effects analysis, you also 
have the option to import and/or synchronize system templates and failure modes. (See Import 
or Sync from XFMEA.) 

Note that you can also use the Reliability Data Warehouse (RDW) in Weibull++ to extract data 
from XFRACAS to build data sets for life data analysis or repairable system/reliability growth 
analysis. (See Reliability Data Warehouse in the Weibull++ documentation.) 

 

Data Import Page 
The Data Import page allows you to import and export XFRACAS records (e.g., incidents, system 
configurations, etc.) using *.xml or *.xlsx templates. This page can be used in conjunction with 
the optional XFRACAS DIU (Windows service) and/or the XFRACAS Web Service, if applicable. 
Permissions required to access this page: Access Admin Tab and Manage Import. 

To open the Data Import page, choose Admin > Tools > Import. 

 

http://help.reliasoft.com/weibull20/index.htm#t=reliability_data_warehouse_rdw.htm
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If your implementation has more than one entity, import schedules and logs are managed 
separately for each. The drop-down list at the top of the page determines which entity's import 
details are currently displayed. 

Tip: The XML and XLST Templates topic in the XFRACAS Admin help file provides templates and 
examples for common import scenarios. You may be able to save time by downloading and 
adapting these files to import your own data. 

ADDING FILES TO IMPORT 

1. Choose Admin > Import > Add. 

 

2. In the Add Import File utility, select the import type and browse for the file. 

3. Click Add to add the file to the import queue. 

PROCESSING FILES IN THE INBOX 

The Inbox shows all of the import tasks that are currently in the queue to be imported. Each 
task is an *.xml or *.xlsx file that contains data you wish to import. 

If you have the "Access Import Processing" permission, you can immediately process the import 
queues for all entities. Click Admin > Import > Process. 

 

Alternatively: 

• If the DIU Service is running on the web server, it will attempt to process the file(s) at the 
date/time specified in the Import Schedule for the relevant data type and entity. 

• If you have created your own custom application using the Web Service, it includes a 
function to immediately process the import queues for all entities. 

The Processed area shows the import tasks that have been completed successfully, while the 
Error area shows the files that could not be processed. The DIU Log shows all actions 
performed by the DIU Service (including e-mail notifications that are triggered based on 
calendar date). 
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Note: For most record types, if the relevant ID matches an existing record, it will not be 
imported and it will be logged as a duplicate in the error log. 
 
For incidents, if the EnableUpdate element in the *.xml file is set to "Yes," certain fields can be 
updated in existing records. For details, see XFRACAS XML Import Business Logic (*.pdf). 

EXPORTING TO XML 

If you have the "Access Data Export" permission, the easiest way to export a single record to 
XML is to open the record and click the Export command in the ribbon. 

 

Alternatively, if you know the record ID(s), you can use the utility in the Data Import page. 

Tip: To find IDs for details, see Using Detail Type IDs. 

1. Choose Admin > Import > Export. 

 

2. In the Export File utility, choose the export type and specify the ID(s) to export in the ID 
field. This can be a single ID or a comma-delimited list. 
 
Depending on the record type, you will need to enter either the entity display ID (i.e., the 
record number that is visible in XFRACAS) or the database ID (obtained from the database 
table). 

Export Type ID to Enter 
Address (i.e., location) Database ID 
Company Database ID 
Failure analysis Entity display ID 
Incident Entity display ID 
Issue Database ID of the list issue type 
Master BOM Part ID 
Problem Entity display ID 
Project Entity display ID 
System HID 

http://help.reliasoft.com/documents/version2020/XML_XFRACAS20.pdf
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Unit Commissioning (i.e., CSI) Entity display ID 
User Database ID 

3. Click Export. 

XML and XLST Templates 
XFRACAS provides an XML document type definition (DTD) for each type of record you can 
import or export. These are installed in the "DTD" folder on the web server (e.g., 
C:\inetpub\wwwroot\XFRACAS\ DTD). For descriptions of the XML elements and attributes, see 
XFRACAS XML Import Business Logic (*.pdf). 

You also have the option to import some record types from Excel. 

IMPORTANT: In order to use Excel templates, the web server must be configured to recognize 
the *.xlsx file type. For details, please consult the Implementation Guide (*.pdf). 

DIU Service 
The XFRACAS Data Import Utility (DIU) is a Windows service that must run on the web server in 
order to do the following: 

• Process files in the import queue, based on the schedule specified on the Data Import page. 

• Trigger e-mail notifications based on calendar date (e.g., E-mail - Incident Action Due Date, 
etc.). 

For instructions to start the DIU service, consult the Implementation Guide (*.pdf). 

The current status of the DIU service will be displayed at the top of the Data Import page. This 
page also displays a log of actions performed by the service (DIU Log). 

IMPORTANT: If you have a load balanced environment with multiple web servers, the DIU 
service should run on only one of the servers. 

Web Service 
If you have some basic programming knowledge, you can use the XFRACAS web service in your 
own custom application to insert XML files into the import queue, along with other related 
functions. 

http://help.reliasoft.com/documents/version2020/XML_XFRACAS20.pdf
http://help.reliasoft.com/documents/version2020/IG_XFRACAS20.pdf
http://help.reliasoft.com/documents/version2020/IG_XFRACAS20.pdf
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Tip: The Web Service  topic in the XFRACAS Admin help file enables you to download a sample 
application that demonstrates the basic process for using the web service. 

USING THE SERVICE 

On the web server, IIS must be configured with HTTP Activation enabled for the .NET 
Framework. See the Implementation Guide (*.pdf). 

The following functions are available. For parameters and code examples, see XFRACAS XML 
Import Business Logic (*.pdf) and the sample application. 

• importxml - Inserts an XML file (which may contain data for one or multiple records) into 
the XFRACAS import queue. This is equivalent to clicking Add on the XFRACAS Data Import 
page. It uploads an XML byte array and returns a UUID that identifies the file that was 
added to the queue (the import record id). 

Note: The maximum size for files that can be inserted into the queue by the web service is 
set via the XFRACAS Admin utility on the web server (on the Settings page of the XFRACAS 
Configuration File window). 

• importstatus - Retrieves the status of a previous importxml request. Information about the 
import includes the status. A status of 1 indicates an Error, 2 indicates the import is in the 
Inbox, 3 indicates the data has been Processed. Optionally, the error and import logs can be 
included in the response. 

• processimports - Starts the import process, which attempts to process all files in the import 
queue for all entities. This is equivalent to clicking Process on the Data Import page. To 
view the processing status of the files, check the Processed and Error logs on the website or 
pass the integer result from this method to the importstatus method’s id parameter. 

• importmetrics - Inserts up to 3 time/usage values reported on a particular date for a 
particular serialized system. This is equivalent to clicking Update System Hours in the 
customer support record for a serialized system. (See Time Metric Calculations.) 

• entities - Returns an array of the entities that are accessible to the user the application is 
running as. The entity id (eid) is a required parameter for other functions. 

• issueid - Returns the IssueTypeID for a specific option in a lookup list, given the name of the 
list and either the description or code for the option. This can be used when creating new 
XML files. For example, in incident records, the “Incident State” and “Incident State Closed” 

http://help.reliasoft.com/documents/version2020/IG_XFRACAS20.pdf
http://help.reliasoft.com/documents/version2020/XML_XFRACAS20.pdf
http://help.reliasoft.com/documents/version2020/XML_XFRACAS20.pdf
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lookup lists contain the valid options for the <status> element in the XML file. (See 
Managing Lists.) 

• issues - Returns a list of options for a specific lookup list, given at least the name of the list. 

• parts - Returns a list of parts that contain a specified part name and/or part number. If the sn 
parameter is set, it searches for a serialized part. 

• incident - Returns a limited set of data about a specific Incident. 

• logexc - Writes exception information to the XFRACAS diagnostics log. The body of the request 
must contain a VB Exception object serialized as JSON (see the example application for a 
demonstration). (See Diagnostics Log.) 

• logmsg - Writes a message to the XFRACAS diagnostics log. 

Import or Sync from XFMEA 
If your organization uses ReliaSoft XFMEA, RCM++ or RBI for FMEAs or Reliability Centered 
Maintenance analysis, you can import or synchronize data for parts and failure modes that you 
are tracking in XFRACAS. 

To use this feature, you must have the "Manage Templates" and "RS Desktop - Read Failure 
Mode Data" permissions in XFRACAS. It also requires a user account for ReliaSoft desktop 
applications with the same domain\username as the XFRACAS account and access to at least 
one desktop project that has FMEA/RCM data.     

When a template part in XFRACAS is "associated" with an item in the desktop applications, you 
will be able to synchronize the following: 

• Part Name 

• Part Number and Version (if enabled and populated in the desktop project) 

• Item Category (if the XFRACAS entity uses this type of detail field for template parts) 

• Failure Modes and Root Causes 
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Note: The desktop applications provide similar options for users with the required permissions. 
(See Import or Sync from XFRACAS in the XFMEA/RCM++/RBI documentation.) In both XFRACAS 
and the desktop applications, the import and sync features modify data only in the application 
that you are using. For example, if you want to copy the latest data from XFMEA into XFRACAS, 
use the commands in XFRACAS. Alternatively, to copy recent changes from XFRACAS into 
XFMEA, use the commands in XFMEA. 

XFMEA IMPORT 

To create a new XFRACAS template by importing items from the desktop application, choose 
System > Template > XFMEA Import. 

 

In the XFMEA Import dialog box, select the desktop analysis Project you want to import from 
and a System within that project. (This can be any desktop project you have permission to edit 
that contains a system hierarchy defined in XFMEA, RCM++ or RBI.) 

If you want to create Failure Modes and Root Causes for the new template parts based on 
FMEAs performed in the desktop application, select Import failure modes with template. 

SYNC WITH XFMEA 

When you are editing an XFRACAS template that has parts "associated" with items in the 
desktop applications, you can choose to update the XFRACAS data to reflect changes that have 
been made in the desktop applications. To do this, select the part and choose System > Part > 
Sync with XFMEA. 

 

In the XFMEA Sync window, use the check boxes to specify what you want to update: 

• The properties of the currently selected part 

• The failure modes and root causes associated with the currently selected part 

• The subcomponents of the currently selected part 

• The failure modes and root causes associated with the subcomponents 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=import_from_xfracas.htm
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This will update records that are already "associated" and import new records if applicable. It 
will not affect any template parts and failure modes/causes that exist only in XFRACAS and are 
not "associated" with records in the desktop analysis. 

REMOVE XFMEA ASSOCIATION 

When you are editing an XFRACAS template that has parts "associated" with items in the 
desktop applications, you can choose to remove the association for a single part or for all parts 
in a branch of the hierarchy. To do this, select the part and choose System > Part > Remove 
XFMEA Association. 

 

In the XFMEA Association window, uses the check boxes to specify which part(s) to update: 

• The selected part 

• All subcomponents of the currently selected part 

PART NUMBER NOT REQUIRED IN DESKTOP APPLICATIONS 

In ReliaSoft desktop applications, the part number and version properties can be enabled or 
disabled in each analysis project, and they are not required to be entered for each item. 

In XFRACAS, a part number must be entered for each template part. When users report 
incidents for a serialized system, they must enter a valid combination of serial number and part 
number. 

Therefore, if you will be importing desktop items into XFRACAS, we recommend to make sure 
the Part Number field is enabled for the desktop analysis project(s) and populated for each 
item prior to importing or synchronizing in XFRACAS. 

USING THE ITEM CATEGORY FIELD 

In ReliaSoft desktop applications, the Item Category provides a way to find, filter and group 
analysis data. When an organization defines item categories based on system hierarchies 
defined in XFMEA, RCM++ or RBI, users can apply an appropriate category for the desktop 
analyses, diagrams and resources that are associated with each item. (See Import or Sync from 
XFRACAS in the XFMEA/RCM++/RBI documentation.) 

In XFRACAS, a special type of "Item Category" detail field provides the same list of item 
categories that is available in desktop applications. If this field is enabled in the entity for 

http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=item_categories_in_xfmea_rcm_rbi.htm
http://help.reliasoft.com/xfmea_rcm_rbi20/index.htm#t=item_categories_in_xfmea_rcm_rbi.htm
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template parts, the categories assigned via desktop applications will be imported and 
synchronized for template parts in XFRACAS. Likewise, if you edit or create new template parts 
in XFRACAS that will later be imported or synchronized into the desktop analysis, you can use 
this field to assign the appropriate category. 
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Additional Tools 
 

Diagnostics Log 
Use the Diagnostics page to view warnings and errors that have occurred for your XFRACAS 
implementation. This information may be needed when you contact technical support. 
Permissions required to access this page: Access Admin Tab and Manage Diagnostics Page. 

To open the page, choose Admin > Tools > Diagnostics. 

 

EXPORTING TO EXCEL 

To export the log to an Excel file, choose Admin > Diagnostics > Excel. 

 

DELETING ENTRIES 

To remove one or more entries from the log, select the check box for the row(s) and choose 
Admin > Diagnostics > Delete. 

 

 

Resource Editor 
Use the Resource Editor page to manage text labels that appears throughout the XFRACAS user 
interface. Permissions required to access this page: Access Admin Tab and Manage Resource 
Editor. 

To open the page, choose Admin > Tools > Resource Editor. 
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If your implementation has more than one entity, the text resources can be configured 
separately for each, but the same settings may be used in multiple entities. The drop-down list 
at the top of the page determines which entity's text resources you are currently managing. 

FINDING RESOURCES 

To find specific text resources, choose Admin > Resource Editor > Find. 

 

In the Find utility, you can search by any of the following: 

• Start ID and End ID - specifies a range of resources based on their numerical identifiers. If 
you specify only a Start ID, all resources from that ID on will be displayed. If you specify only 
an End ID, all resources up to and including that ID will be displayed. 

• Default Text - the labels that are shipped with XFRACAS. 

• Display Text - custom labels, if any, that have been configured to meet your particular 
needs. 

Tip: If you type an underscore ( _ ) in this field, the search will return all text resources that 
have custom labels. 

• Location - the user interface page or utility where the resources are used. 

• Language - the translation language. 

Click Find to view all of the text resources that match the specified criteria. 

EDITING RESOURCES 

In the table of resources returned by the Find utility, click Edit   in the row for the text you 
wish to modify. 

In the Edit Resource window, clear the Use Default check box and enter your preferred label in 
the Display Text field. If applicable, select the Entities where the custom label will be used. 

REPLACING RESOURCES 

To find and replace all occurrences of a text string, choose Admin > Resource Editor > Replace. 
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In the Find and Replace Utility, specify the text you want to replace and click Preview to view all 
possible replacements that match the specified criteria. 

In the table of possible replacements, you can clear the check boxes for any text labels you wish 
to leave unchanged. When you are ready to proceed, choose Admin > Resource Editor > Save. 

 

RESTORING DEFAULTS 

To return all resources in the current entity to the default text, choose Admin > Resource 
Editor > Default All. 

 

CREATING AN UPDATE SCRIPT 

If you need to implement the same text changes in another database, choose Admin > 
Resource Editor > Update Script. 

 

In the Update Script utility, use the Begin Date and End Date fields to specify a time period 
(e.g., include only changes made in the past month). Click OK to download a *.txt file that 
contains SQL statements that will implement the same changes in another database. 

 



 29.06.15 Click Wrap License only -Software Maintenance provisions dealt with in separate agreement. 

 
End User Licence Agreement  

Click Wrap Agreement at time of product installation 

BY INSTALLING THIS SOFTWARE OR BY CLICKING THE “I ACCEPT” BUTTON AND ACCEPTING 
THIS LICENCE IN ACCORDANCE WITH RECITAL C (LICENCE ACCEPTANCE PROCEDURE) YOU 
AGREE TO THE TERMS OF THIS LICENCE WHICH WILL BIND YOU, THE COMPANY ON WHOSE 
BEHALF YOU ARE ENTERING INTO THIS LICENCE AGREEMENT, AND ITS EMPLOYEES, AS 
APPLICABLE.   

THIS LICENCE AGREEMENT IS A LEGAL AGREEMENT BETWEEN HBM UNITED 
KINGDOM LTD A COMPANY INCORPORATED IN UNITED KINGDOM WHOSE 
REGISTERED NUMBER IS 1589921 AND WHOSE REGISTERED OFFICE IS AT 
TECHNOLOGY CENTRE, ADVANCED MANUFACTURING PARK, BRUNEL WAY, 
CATCLIFFE, ROTHERHAM S60 5WG (THE ‘LICENSOR’) AND THE END USER LICENSEE 
OR ITS REPRESENTATIVE/AGENT AUTHORISED TO BIND THE END USER LICENSEE 
(‘YOU’). 
PLEASE READ THIS CAREFULLY BEFORE USING THE SOFTWARE PRODUCTS 

A: BACKGROUND 

THIS LICENCE AGREEMENT SHALL BE BETWEEN YOU AND THE LICENSOR 
REGARDLESS OF WHETHER YOU HAVE PURCHASED THE SOFTWARE PRODUCTS 
DIRECTLY FROM THE LICENSOR OR AN AUTHORISED RESELLER AS SET OUT BELOW. 

THE LICENSOR APPOINTS EXPERIENCED PROVIDERS OF SOFTWARE RESALE SERVICES 
WHO DISTRIBUTE THE SOFTWARE PRODUCTS TO END USERS (‘AUTHORISED 
RESELLER’). IF YOU HAVE PURCHASED THE SOFTWARE PRODUCTS AND ANY 
ASSOCIATED SUPPORT AND MAINTENANCE SERVICES FROM AN AUTHORISED 
RESELLER, SUCH PRODUCTS AND SERVICES WILL BE PROVIDED DIRECTLY TO YOU BY 
THE RELEVANT AUTHORISED RESELLER AND ALL PAYMENTS SHALL BE MADE TO THE 
AUTHORISED RESELLER ON THE AUTHORISED RESELLER’S TERMS AND PRICES.  

IF YOU HAVE PURCHASED THE SOFTWARE PRODUCT AND SUPPORT AND 
MAINTENANCE SERVICES DIRECTLY FROM THE LICENSOR, SUCH SUPPORT AND 
MAINTENANCE SERVICES WILL BE DEALT WITH IN A SEPARATE AGREEMENT 
BETWEEN YOU AND THE LICENSOR AND ALL PAYMENTS WILL BE MADE TO THE 
LICENSOR AND GOVERNED BY THE LICENSOR’S TERMS OF SALE. 

B: PROPERTY OF LICENSOR 

THE LICENSOR, OR, WHERE APPLICABLE, THE RELEVANT MEMBER OF THE 
LICENSOR’S CORPORATE GROUP, IS THE ENTIRE LEGAL AND BENEFICIAL OWNER OF 
CERTAIN SOFTWARE PRODUCT(S) (‘THE SOFTWARE PRODUCT’) AS SET OUT IN THE 
QUOTATION OF INFORMATION, WHICH SHALL ALSO INCLUDE YOUR LICENCE KEY, 
SENT TO YOU BY EMAIL EITHER BY THE LICENSOR OR, IF YOU HAVE PURCHASED THE 
SOFTWARE PRODUCTS FROM AN AUTHORISED RESELLER, BY THE AUTHORISED 
RESELLER (‘QUOTATION’).THE LICENSOR IS WILLING TO GRANT YOU A LICENCE TO 
USE THE SOFTWARE PRODUCT ONLY IF YOU ACCEPT ALL THE TERMS AND 
CONDITIONS SET OUT BELOW. 



   

C: LICENCE TO BE GRANTED 

THE LICENSOR IS PROPOSING TO GRANT YOU ONE OF THE FOUR FORMS OF LICENCE 
IN RESPECT OF THE SOFTWARE PRODUCT. DETAILS OF EACH FORM OF LICENCE ARE 
SET OUT IN CLAUSES 2.1 AND 3 BELOW. THE FORM OF LICENCE THAT IS PROPOSED TO 
BE GRANTED TO YOU IS SET OUT IN THE QUOTATION. THE QUOTATION FORMS PART 
OF THE LICENCE AGREEMENT AND BY ACCEPTING THE TERMS OF THE LICENCE YOU 
ARE ACCEPTING THOSE TERMS IN THE QUOTATION. IF YOU HAVE NOT RECEIVED THE 
QUOTATION FROM THE EITHER THE LICENSOR OR FROM THE AUTHORISED RESELLER 
(IF YOU HAVE PURCHASED THE SOFTWARE PRODUCTS FROM AN AUTHORISED 
RESELLER) AT THE DATE HEREOF OR IF ANY DETAILS WITHIN THE QUOTATION ARE 
INCORRECT THEN YOU SHOULD FOLLOW THE ‘LICENCE REJECTION PROCEDURES’ SET 
OUT AT PARAGRAPH D BELOW AND IMMEDIATELY CONTACT THE LICENSOR OR THE 
AUTHORISED RESELLER (AS APPLICABLE). 

C: LICENCE ACCEPTANCE PROCEDURE 

BY CLICKING ON THE ACCEPTANCE BUTTON WHICH FOLLOWS THIS LICENCE 
AGREEMENT (MARKED 'DO YOU ACCEPT THESE TERMS AND CONDITIONS?'), YOU 
INDICATE ACCEPTANCE OF THIS LICENCE AGREEMENT AND THE LIMITED WARRANTY 
AND LIMITATION OF LIABILITY SET OUT IN THIS LICENCE AGREEMENT. SUCH 
ACCEPTANCE IS ON YOUR OWN BEHALF, IF YOU ARE AN INDIVIDUAL AND ON BEHALF 
OF ANY CORPORATE ENTITY WHICH EMPLOYS YOU OR WHICH YOU REPRESENT 
(‘CORPORATE LICENSEE’) IN ENTERING INTO THIS LICENCE AND YOU WARRANT THAT 
YOU HAVE THE NECESSARY AUTHORITY TO BIND THE CORPORATE ENTITY IN THIS 
RESPECT OR THAT THE AUTHORISED REPRESENTATIVES OF THE CORPORATE ENTITY 
ARE AWARE OF YOUR ACCEPTANCE OF THIS AGREEMENT ON ITS BEHALF. IN THIS 
LICENCE AGREEMENT, ‘YOU’ REFERS TO THE LICENSEE, ANY SUCH CORPORATE 
LICENSEE, OR BOTH, AS A COMMON SENSE INTERPRETATION OF THE RELEVANT 
SECTION DICTATES. 

D: LICENCE REJECTION PROCEDURE 

IF YOU DO NOT ACCEPT THESE TERMS AND CONDITIONS, YOU SHOULD CLICK ON THE 
“I DO NOT ACCEPT” BUTTON, DELETE THE SOFTWARE PRODUCTS FROM YOUR 
COMPUTER AND PROMPTLY (AND IN ANY EVENT, WITHIN 14 DAYS OF RECEIPT) 
RETURN TO THE RESELLER (A) ANY MEDIA; AND (B) ANY OTHER ITEMS PROVIDED, 
THAT ARE PART OF THIS PRODUCT. 

E: OTHER AGREEMENTS 

IF THE LICENSOR HAS EXPRESSLY AGREED WITH YOU IN WRITING THAT YOUR USE OF 
THE SOFTWARE PRODUCTS IS GOVERNED BY A PRIOR EXECUTED LICENCE 
AGREEMENT WITH THE LICENSOR, SUCH AGREEMENT SHALL APPLY INSTEAD OF THE 
FOLLOWING TERMS AND CONDITIONS TO THE EXTENT THAT THEY CONFLICT. 

YOU SHOULD PRINT A COPY OF THIS LICENCE AGREEMENT FOR FUTURE REFERENCE. 

LICENCE AGREEMENT  

1. Ownership of Software Products and Copies 

1.1 The Software Products and any printed materials or electronic documentation accompanying the Software 
Products (‘Documentation’) are copyrighted works of authorship, and are also protected under 
applicable database laws. The Licensor, or, where applicable, the relevant member of the Licensor’s 
corporate group, retains ownership of the Software Products and all subsequent copies of the Software 



 
  

Products, regardless of the form in which the copies may exist. This Licence Agreement is not a sale of 
the original Software Products or any copies. 

2. Commercial Licence 

2.1 In consideration of you agreeing to abide by the terms of this Licence Agreement and payment of the 
applicable licence fees either to the Licensor or, if you have purchased the Software Products from an 
Authorised Reseller, to the Authorised Reseller (as specified in the Quotation), the Licensor hereby grants 
to you a personal, non-exclusive, and (unless expressly agreed otherwise by the Licensor in accordance 
with clause 5.1) non-transferable licence to use the Software Products and the Documentation on the 
terms of this Licence Agreement. The licence shall take one of the following forms, (and shall be set out 
in the Quotation): 

(a) Annual Licence: 

(i) Duration – this Licence shall continue for a period of 12 months (‘Initial Period’) from the 
date of delivery of the Quotation (“the Delivery Date”) and, provided that you have paid all 
applicable renewal fees, from year to year thereafter unless terminated in accordance with 
any provision of clause 10 below or any other clause of this Licence Agreement 

(ii) Termination – you must give the Licensor 90 day’s written notice prior to the anniversary 
of the Delivery Date, such notice not to expire before such anniversary date.    

(b) Paid Up Licence: 

(i) Duration – this Licence shall continue for a period of 25 years from the Delivery Date unless 
terminated in accordance with any provision of clause 10 below or any other clause of this 
Licence Agreement. 

(ii) Conversion - this Licence may be converted to a CDS (this may include CRS and CDRS 
which are specific variations of CDS and collectively known as CDS) Licence, upon 
application to either the Licensor or the Authorised Reseller (if you have purchased the 
Software Products from an Authorised Reseller),  and payment of an additional fee  to the 
Licensor or the Authorised Reseller,(as applicable)  which shall be additional to the fees paid 
or payable in respect of any maintenance and support services provided by either by the 
Licensor or the Authorised Reseller (if you have purchased the Software Products from an 
Authorised Reseller), You may reverse this conversion to the same terms as agreed in the 
Paid Up Licence at the anniversary of the conversion by giving the Licensor 90 days written 
notice prior to the anniversary of the Delivery Date, such notice not to expire before the 
anniversary of the Delivery Date. 

(c) CDS/CRS/CDRS Licence: 

(i) Access – subject to the terms and conditions of this Licence Agreement, you may access any 
of the Software Products in the Quotation at any one time and in any combination up to the 
number of subscriptions granting you access to the Software Products for simultaneous use 
by you and purchased by you pursuant to this Agreement  (‘Access Credits’). In the event 
the number of Access Credits reaches the number of Access Credits duly paid for by you 
(‘Access Limit’), you may add additional Access Credits (or, alternatively, at any time 
during the Term) which shall be charged in accordance with either the Licensor’s prices or 
the Authorised Reseller’s prices (if you have purchased the Software Products from an 
Authorised Reseller) Such increase in Access Credits shall apply to the following 12 month 
period, unless you give the Licensor or the Authorised Reseller (as applicable) written notice 
at least 90 days in advance of the expiry of the Initial Period, that you do not wish to sustain 
such increase in Access Credits. You may opt to reduce the number of Access Credits with 



   

90 days written notice in advance of the 12 month period following from the anniversary of 
the Delivery Date, provided that the total number of Access Credits does not fall below the 
minimum threshold set by the Licensor or the Authorised Reseller (as applicable) or below 
the initial number of Access Credits calculated at the time of conversion of any Paid Up 
Licence. 

(ii) Duration - this Licence shall continue for the Initial Period and, provided that you have paid 
for the applicable Access Credits, from year to year thereafter unless terminated in 
accordance with any provision of clause 10 below or any other clause of this Licence 
Agreement; 

(iii) Reporting – in order to serve our customers better, the Licensor needs to be able to 
understand how its customers use the CDS system. As a condition of your continued access 
to the system, you are asked to provide to the Licensor on a quarterly basis, the CDS log file. 
You will be provided with easy-to-follow instructions on how to do this. 

(iv) Termination – you must give the Licensor 90 days written notice in advance of the expiry of 
the Initial Period of your intention to discontinue the CDS Licence, such notice not to expire 
before the anniversary of the Delivery Date, and you must have submitted all reports 
required of you in clause 2.1(c)(iii) above. Failure to provide such notice and reports will 
mean that the license shall automatically continue on the same terms until terminated in 
accordance with this clause.  

2.2 As an end user licensee of the Software Products, you may, subject to the following conditions and any 
conditions specified in the Quotation: 

(a) use and copy the Software Products only for use on any computer system that is detailed in the 
release notes of the respective Software Product and which is licenced, leased and/or controlled by 
you (the Corporate Licensee) or any member of your corporate group, which expression includes 
the Corporate Licensee's majority-owned subsidiaries, any parent company having a majority-
owned interest in the Corporate Licensee, and such parent's majority-owned subsidiaries; 

(b) load the Software Products into and use it only on computers at the locations specified in the 
Quotation and which are under your control; and 

(c) copy the Software Products only for back-up and archival purposes and make up to three copies of 
the Documentation, provided that the original and each copy is kept in your possession and that 
your installation and use of the Software Products does not exceed any restrictions contained in the 
Quotation. 

3. Demonstration Licence 

3.1 If the Licensor has provided you with the Software Products free of charge for evaluation purposes, this 
clause 3 shall apply to your use of the Software Products.  

3.2 You may use the Software Product on a computer solely for the purposes of evaluating the Software 
Product. 

3.3 The Software Product is provided to you free of charge and on an “AS IS” basis, without any technical 
support or warranty of any kind from us including, without limitation, a warranty of satisfactory quality, 
fitness for purpose and non-infringement. 

3.4 This Licence shall continue for a period of 30 days from the Delivery Date unless terminated in 
accordance with any provision of clause 10 below or any other applicable clause of this Licence 
Agreement or until such Licence is converted into an Annual Licence, Paid Up Licence or CDS Licence, 
if earlier. 



 
  

3.5 As part of the Licensor’s testing and evaluation of the Software Products, you shall share with the 
Licensor the input and views received and any reports and analysis produced promptly upon receipt of 
such feedback.  
 

3.6 Clauses 4, 5.1(a), 6.1(b), 6.1(f), 8.1, 8.2, 8.5, 10.1(a) of this Licence Agreement shall not apply to a 
Demonstration Licence. 

4. Delivery and Risk 

4.1 The Software Products shall consist of one copy of the object code of the Software Products on machine-
readable form only, on the disk, dongle or other media on which the Software Product                   is 
delivered as described in the Quotation (the “Media”). Risk in the Media shall pass to you on delivery. If 
any part of the Media shall thereafter be lost, damaged or destroyed, you must contact either the Licensor 
or the Authorised Reseller from whom you have purchased the Software Products who will arrange for a 
repair or replacement of such Media at a cost (if any) determined by the Licensor or the Authorised 
Reseller (as applicable). 

5. Licence Restrictions 

5.1 You may not nor permit others to: 

(a) transfer the Software Products from one location to another, without the express written consent of 
the Licensor and provided such transfers do not exceed two in any twelve month period.  It will be 
a condition of the grant of any such consent that the Software Products held on hard drives at the 
current location must be erased and you must enter into a new licence agreement with the Licensor 
before a Software Products licence key is provided to you.  The administration charge (currently 
US $1,500) will be payable by you in respect of such transfer.; This charge is only applicable to 
end user licensees who do not have a support and maintenance services agreement with the 
Licensor  or Authorised Reseller;  

(b) exceed the number of concurrent users specified in the Quotation, if any;  

(c) sub-licence, sell, assign, rent, pledge, lease, transfer or otherwise dispose of the Software Products, 
on a temporary or permanent basis, without the prior written consent of the Licensor, 

(d) translate, reverse engineer, decompile, disassemble, modify or create derivative works based on 
the Software Products except as permitted by law; 

(e) make copies of the Software Products, in whole or part, except for back-up or archival purposes as 
permitted in this Licence Agreement; 

(f) use any back-up copy of the Software Products for any purpose other than to replace the original 
copy in the event that it is destroyed or becomes defective; 

(g) copy the Documentation (except as provided by this Licence Agreement); 

(h) adapt, modify, delete or translate the Documentation in any way for any purpose whatsoever; 

(i) vary, delete or obscure any notices of proprietary rights or any product identification or restrictions 
on or in the Software Products. 

6. Open Source 

Notwithstanding the foregoing provisions, You acknowledge that certain components of the Software 
Product may be covered by so-called open source software licenses (“Open Source Components”), which 
means any software licenses approved as open source licenses by the Open Source Initiative or any 
substantially similar licenses, including without limitation any license that, as a condition of distribution 
of the software licensed under such license, requires that the distributor make the software available in 



   

source code format. To the extent required by the licenses covering Open Source Components, the terms 
of such licenses will apply to such Open Source Components in lieu of the terms of this Agreement. To 
the extent the terms of the licenses applicable to Open Source Components prohibit any of the restriction 
in this License Agreement with respect to such Open Source Components, such restrictions will not apply 
to such Open Source Components. To the extent the terms of the licenses applicable to Open Source 
Components require Licensor to make an offer to provide source code or related information in connection 
with the Software Product, such offer is hereby made. Any request for source code or related information 
should be directed only to Customer Support, HBM United Kingdom Limited, AMP Technology Centre, 
Brunel Way, Catcliffe, Rotherham, South Yorkshire, S60 5WG, United Kingdom. You acknowledge 
receipt of notices for the Open Source Components for the initial delivery of the Software Product. 

7. Undertakings 

7.1 You undertake: 

(a) to ensure that, prior to use of the Software Products by your employees or agents, all such parties 
are notified of this Licence and the terms of this Licence Agreement and that any such use as 
aforesaid is in accordance with the terms of this Licence Agreement; 

(b) to replace the current version of the Software Product with any updated or upgraded version or 
new release provided by the Licensor or the Authorised Reseller (if applicable) under the terms of 
this Licence Agreement immediately on receipt of such version or release; 

(c) to use the Software Products only as described in the Documentation and subject to the restrictions 
as set out in clause 5 (Licence Restrictions above); 

(d) to reproduce and include the Licensor’s copyright notice (or such other party’s copyright notice as 
specified on the Software Products) on all and any copies of the Software Products, including any 
partial copies of the Software Products as permitted to be made under the terms of this Licence 
Agreement; 

(e) to hold all drawings, specifications, data (including object and source codes), Software Products 
listings and all other information relating to the Software Products confidential and not at any time, 
during this Licence or after its expiry, disclose the same, whether directly or indirectly, to any third 
party without the Licensor’s consent and 

(f) to effect and maintain adequate security measures to safeguard the Software Product from access 
or use by any unauthorised person and indemnify the Licensor for losses flowing from your failure 
to do so. 

8. Intellectual Property Rights  

8.1 You acknowledge that all intellectual property rights in the Software Product and the Documentation 
throughout the world belong to the Licensor, that rights in the Software Product are licensed (not sold) to 
you, and that you have no rights in, or to, the Software Product or the Documentation other than the right 
to use them in accordance with the terms of this Licence Agreement. 

8.2 You acknowledge that you have no right to have access to the Software Product in source code form or 
in unlocked coding or with comments. 

8.3 The integrity of this Software Product is protected by technical protection measures (“TPM”) so that the 
intellectual property rights, including copyright, in the software of the Licensor are not misappropriated. 
You must not attempt in any way to remove or circumvent any such TPM, nor to apply, manufacture for 
sale, hire, import, distribute, sell, nor let, offer, advertise or expose for sale or hire, nor have in your 
possession for private or commercial purposes, any means whose sole intended purpose is to facilitate 
the unauthorised removal or circumvention of such TPM. 



 
  

9. Limited Warranty 

9.1 Subject to the limitations and exclusions of liability below and providing the Software is used in 
accordance with the Documentation and on an operating system or computer for which it was designed, 
the Licensor warrants that (a) the Media on which the Software Products is furnished will be free from 
material defects under normal use for a period of 90 days from the date of delivery (the “Warranty 
Period”); and that (b) during the Warranty Period, the Software Product will, when properly used, perform 
substantially in accordance with the functions described in the Documentation; and (c) that the 
Documentation correctly describes the operation of the Software Product in all material respects. 

9.2 If, within the Warranty Period, you notify the Licensor in writing of any defect or fault in the Software 
Product in consequence of which it fails to perform substantially in accordance with the Documentation, 
and such defect or fault does not result from you having amended the Software Product or used it in 
contravention of the terms of this Licence Agreement, the Licensor will, at its sole option, i) repair or 
replace the Software Product, provided that you make available all information that may be necessary to 
assist the Licensor in resolving the defect or fault, including sufficient information to enable the Licensor 
to recreate the defect or fault, or ii) terminate this Licence Agreement immediately by notice in writing 
to you and the Licensor will refund or if the Software Products have been purchased from an Authorised 
Reseller will procure that the Authorised Reseller shall refund; any of the fees paid as at the date of 
termination (less a reasonable sum in respect of your use of the Software Product to the date of 
termination) on return of the Software Product and all copies thereof. The Licensor’s obligation under 
this clause 8.2 is subject to your compliance with clause 6.1(b). 

9.3 You acknowledge that the Software Product has not been developed to meet your individual requirements 
and that it is therefore your responsibility to ensure that the facilities and functions of the Software 
Product as described in the Documentation meet your requirements. 

9.4 You acknowledge that the Software Product may not be free of bugs or errors and you agree that the 
existence of any minor errors shall not constitute a breach of this Licence Agreement. 

9.5 The Licensor shall not be liable under the said warranty above if the Software Product fails to operate in 
accordance with the said warranty as a result of any modification, variation or addition to the Software 
Products not performed by the Licensor or caused by any abuse, corruption or incorrect use of the 
Software Products, including use of the Software Products with equipment or other software which is 
incompatible. 

9.6 All other conditions, warranties or other terms which might have effect or be implied or incorporated into 
this Licence Agreement or any collateral contract, whether by statute, common law or otherwise, are 
hereby excluded, including, without limitation, the implied conditions, warranties or other terms as to 
satisfactory quality, fitness for purpose or the use of reasonable skill and care. 

10. Exclusion of Liability 

10.1 Nothing in this Licence Agreement shall limit or exclude the liability of either party for death or personal 
injury resulting from negligence, for fraud or for fraudulent misrepresentation. 

10.2 Subject to clause 9.1, the Licensor shall have no liability for any losses or damages which may be suffered 
by you (or any person claiming under or through you), whether the same are suffered directly or indirectly 
or are immediate or consequential, and whether the same arise in contract, tort (including negligence) or 
otherwise howsoever, which fall within any of the following: 

(a) loss of income; 

(b) loss of business profits or contracts; 

(c) business interruption; 



   

(d) loss of the use of money or anticipated savings; 

(e) loss of information; 

(f) loss of opportunity, goodwill or reputation; 

(g) loss of, damage to or corruption of data; or 

(h) any indirect or consequential loss or damage of any kind howsoever arising and whether caused by 
tort (including negligence), breach of contract or otherwise; 

provided that this clause 9.2 shall not prevent claims for loss of or damage to your tangible property that 
fall within the terms of clause 8 or a claim for a refund of the licence fees paid to the Licensor or the 
Authorised Reseller (as applicable) for the licence of the Software Products. 

10.3 Subject to clause 9.1 and clause 9.2, the Licensor's maximum aggregate liability under or in connection 
with this Licence Agreement, or any collateral contract, whether in contract, tort (including negligence) 
or otherwise, shall be limited to a sum equal to the fees paid by you to the Licensor or the Authorised 
Reseller (as applicable) for the licence of the Software Products.  

10.4 Subject to clause 9.1, clause 9.2 and clause 9.3, the Licensor's liability for infringement of third party 
intellectual property rights shall be limited to breaches of third party rights subsisting in the UK and USA. 

10.5 This Licence Agreement sets out the full extent of the Licensor's obligations and liabilities in respect of 
the supply of the Software and Documentation.  In particular, there are no conditions, warranties, 
representations or other terms, express or implied, that are binding on the Licensor except as specifically 
stated in this Licence Agreement.  Any condition, warranty, representation or other term concerning the 
supply of the Software and Documentation which might otherwise be implied into, or incorporated in, 
this Licence Agreement, or any collateral contract, whether by statute, common law or otherwise, is 
hereby excluded to the fullest extent permitted by law. 

11. Term and Termination 

11.1 This Licence Agreement is effective for the period referred to clause 2.1 or until otherwise terminated in 
accordance with that clause. The Licensor may terminate this Licence Agreement immediately by written 
notice to you if: 

(a) save in respect of a Paid Up Licence, if you purchase the Software Products directly from the 
Licensor, you fail to pay any renewal or other fees due by you to the Licensor in respect of this 
Licence Agreement; 

(b) you fail to comply with any provisions of this Licence Agreement; 

(c) you commit a material or persistent breach of this Licence Agreement which you fail to remedy (if 
remediable) within 14 days after the service on you of written notice requiring you to do so; or 

(d) a petition for a bankruptcy order to be made against you has been presented to the court; or 

(e) where you, as the Corporate Licensee, become insolvent or unable to pay its (the company’s) debts, 
enters into liquidation, whether voluntary or compulsory (other than for reasons of bona fide 
amalgamation or reconstruction), passes a resolution for its winding-up, has a receiver or 
administrator manager, trustee, liquidator or similar officer appointed over the whole or any part 
of its assets, makes any composition or arrangement with its creditors or takes or suffers any similar 
action in consequence of its debt, or becomes unable to pay its debts or ceases to trade. 

11.2 In the event of termination in accordance with clause 10.1 you must immediately pay to the Licensor any 
sums due to the Licensor under the Licence Agreement and (at the Licensor’s sole option) you must 
return, destroy or delete all copies of the Software Products from all storage media in your control and, 



 
  

in the case of destruction, certify to us that you have done so. 

12. Export 

12.1 You will comply with all applicable laws, rules, and regulations governing export of goods and 
information, including the laws of the countries in which the Software Products was created. In particular, 
you will not export or re-export, directly or indirectly, separately or as a part of a system, the Software 
Products or other information relating thereto to any country for which an export licence or other approval 
is required, without first obtaining such licence or other approval. 

13. General 

13.1 You agree that the Licensor shall have the right, after supplying undertakings as to confidentiality, to 
audit any computer system on which the Software Products are installed in order to verify compliance 
with this Licence Agreement. 

13.2 You agree that the Licensor may use your company name in Licensor’s customer lists and other 
promotional materials describing your company as a customer or user of Licensor’s software or services, 
as applicable, unless it receives written notice from you objecting to such use. 

13.3 This Licence Agreement, its subject matter or its formation (including non-contractual disputes or claims) 
shall be governed by and construed in accordance with English law and submitted to the non-exclusive 
jurisdiction of the English courts. 

13.4 This Licence Agreement constitutes the complete and exclusive statement of the agreement between the 
Licensor and you with respect to the subject matter of this Licence and supersedes all proposals, 
representations, understandings and prior agreements, whether oral or written, and all other 
communications between us relating to that subject matter except for those expressly referred to in this 
Licence Agreement. 

13.5 Any clause in this Licence Agreement that is found to be invalid or unenforceable shall be deemed deleted 
and the remainder of this Licence Agreement shall not be affected by that deletion. 

13.6 Failure or neglect by either party to exercise any of its rights or remedies under this Licence Agreement 
will not be construed as a waiver of that party’s rights nor in any way affect the validity of the whole or 
part of this Licence Agreement nor prejudice that party’s right to take subsequent action. 

13.7 This Licence Agreement is personal to you and you may not assign, transfer, sub-contract or otherwise 
part with this Licence or any right or obligation under it without the Licensor’s prior written consent. 
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