XFMEA Version 2020
First Steps Example
This example provides a quick introduction to the XFMEA software by allowing you to experiment with the
application’s data management, analysis and reporting features.1 These instructions were prepared with
XFMEA 2020, but you can perform the same steps in previous versions back to Version 9. The appearance of
a few icons and screenshots will vary slightly.

1.1 Open an Existing Database
If you haven’t started XFMEA already, choose Start > All Programs > ReliaSoft and then select the
XFMEA application.
When you launch XFMEA, the Backstage view (File tab) is the first view you will see. This Backstage view
provides a quick way to create and open databases. In ReliaSoft desktop applications, standard databases
are Microsoft Access® databases. These are easy to create and maintain without any special IT
infrastructure or support, but there are limitations to the amount of data they can store and the number of
users who can access the database simultaneously. Enterprise databases require implementation of
Microsoft SQL Server® or Oracle® (which require separate licensing, support and maintenance), but are a
more robust platform that can store much more analysis information in the same database and support access
by many more simultaneous users.
For this example, you will use a standard database that is installed with the software (called
“XFMEA20_Examples.rsgz20”) that contains several sample projects. (If you are using Version 2019, the
file is called “Xfmea19_Examples.rsgz19,” and so on.) To access this file, choose File > Help, click Open
Examples Folder, then browse for the file in the XFMEA sub-folder.
Tip: To preserve the integrity of the shipped example files, the software creates a copy of the file each time you
access a database in the Examples folder. The copy has the same name as the original file and is saved in the
default documents folder for your computer (e.g., My Documents\ReliaSoft\Files). Use the copy to work on the
example projects and save your changes. Any changes you make in the copy will not affect the original file.

1.2 View the Project Properties
In all ReliaSoft desktop applications, projects give you the flexibility to manage your analyses to fit the
particular needs of your organization. You can have one or many projects in the same database.
Every XFMEA analysis within a given project will have the same configurable settings, including the fields
that are enabled/disabled in the interface and reports, the rating scales or questions that are available for risk
assessment and the options that are available for codified information (such as Action Categories,
Classification labels, etc.).
1. For this example, you will work with a project that is based on the design FMEA example that is included in
Appendix G of the 2009 revision of the SAE J1739 Surface Vehicle Standard guidelines.
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To save time and ensure consistency, these configurable settings can be set automatically based on
predefined profiles that are managed by authorized users. They can also be viewed or modified directly in
each individual project.


Select the Design FMEA - Automotive Driveshaft Component (J1739) project in the Project Manager
and choose Project > Management > Edit Project Properties to open the Project Properties window,
as shown next.

As you can see in the Select Profile from Library field, the configurable settings in this project are
based on the DFMEA: J1739 (2009) profile. This predefined profile is shipped with the software and can
be used to quickly configure the project to use the data fields and RPN rating scales specified in the 2009
revision of the SAE J1739 guidelines for Design FMEA (DFMEA).


Now click the Configurable Settings tab. This page provides one way that you can view (and edit) the
configurable settings that have been copied into the current project from the predefined DFMEA profile.
(Note that the settings are also accessible when you are working in the project by choosing Project
> Management > Configurable Settings or by clicking any of the Configurable Settings icons.)



As an example, click the View/Edit Settings icon for Severity Scale.
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1.3 Open a Project

You can see that the project has been configured to use the 10-point ratings from the SAE J1739
guidelines for Design FMEAs.



Click Cancel to close the rating scale window without saving any changes.



If desired, you can click the other View/Edit Settings icons to see the rest of the configurable settings
that have been predefined for this project. When you are finished exploring these settings, click Cancel
to close the Project Properties window without saving any changes.

1.3 Open a Project


With the Design FMEA - Automotive Driveshaft Component (J1739) project still selected in the Project
Manager, open the project either by double-clicking the project name or by choosing Project >
Management > Open Project.
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The Project window is the main window that you will use to perform your analyses. It is divided into two
panels, as shown next.2

The System panel displays the system hierarchy, which includes all items that have been defined in the
project. The Analysis panel displays information and analyses associated with the item that is currently
selected in the hierarchy. Depending on your preferences, these panels can be displayed side-by-side, or with
one panel above the other.

1.4 View the Item Properties
The Properties tab in the Analysis panel displays the item properties fields that are enabled for the current
project, along with some settings that can be used for reliability calculations (if desired) and information
about when the item record was created and last updated.
You can click inside any field with blue text to edit it. Fields shown in italics cannot be edited, either because
they are populated by the application or because they are based on inputs that you make elsewhere in the
software.


If the item properties are not already displayed, click the Properties tab at the top of the Analysis panel.



As an example, click inside the Part Number field and type PN9999, as shown next.

2. If not all of the properties shown in this image are visible on your computer, you can show them by clearing the Hide
reliability nodes on item properties option on the Settings page of the Application Setup window.
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1.5 View the FMEA



If desired, you can edit any of the other item properties. When you are finished exploring these
properties, proceed to the next section.

1.5 View the FMEA
The FMEA tab in the Analysis panel allows you to view/edit the failure modes and effects analysis for the
currently selected item.


Click the FMEA tab to view the FMEA for the steering system. There are now four tabs at the bottom of
the Analysis panel. Each tab displays the analysis information in a different way to facilitate data entry
and decision-making.

1.5.1 The Hierarchy View
The hierarchy view displays the analysis records in a hierarchical tree, which tends to be good for viewing a
lot of information in a small amount of space. It can be especially useful when copying and pasting data or
when scanning the analysis to find a particular section.


If the hierarchy view is not already displayed, click the Hierarchy tab to view it.
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Double-click the “Direct front vehicle wheels...” function record at the top of the tree. The function
properties window will appear, as shown next.



With the properties window still open, click the first failure (“Steering effort too low...”) in the FMEA
hierarchy. You can see that the window updates automatically to display the properties for the record that
is currently selected.



If desired, you can continue clicking different records in the hierarchy to view their properties. When
you are finished exploring, click Cancel to close the properties window without saving any changes.



Now create a new branch in the hierarchy by right-clicking the “Direct front vehicle wheels...” function
and choosing Add Function from the shortcut menu.



In the properties window, type “New Function” in the Function field and then click the Add Failure
icon at the top of the window.



The properties window is now prepared to define a new failure. In the Potential Failure Mode field,
type “New Failure” and then click the Add Effect icon.



Now you can define a new effect. In the first Grouped Effect(s) Properties field, type “New Effect” and
then click the Add Cause icon.
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1.5 View the FMEA



Now you can define a new cause. In the Potential Cause(s) of Failure field, type “New Cause” and then
click OK to close the properties window.
You can see that there is a new branch at the bottom of the hierarchy with the new records you just
created.

1.5.2 The Worksheet View
The worksheet view provides an alternative way to view/edit the same analysis information displayed in the
hierarchy view. This view allows you to type directly into the worksheet cells and tab through the analysis as
you would in a spreadsheet application such as Microsoft Excel®.


To give more space in the Analysis panel before switching to the worksheet view, choose View >
Workspace Layout > Hide System Panel.



Now click the Worksheet tab at the bottom of the Analysis panel.



Double-click inside the first function description. You can see that the cell switches from “select mode”
(with a blue background) to “edit mode” (with a white background and a blinking cursor so you can
modify the text).
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Press ENTER. Note that the blinking cursor now appears in the second function description. Press
ENTER again and the application will automatically create a new row so that you can type a new
function description at the bottom of the worksheet, as shown next.



This time, instead of typing the function description, you can use the Select Existing utility to reuse text
that is already stored in the database. While the cell is in “edit mode,” click the Select Existing icon.



In the Select Existing window, look at the Project Filter, Item Filter, Record Filter and Phrase Sets dropdown lists. These lists allow you to specify the source(s) for the list of existing descriptions that you can
select from.



Look in the list of descriptions and double-click any existing description from the list. This automatically
enters the selected text into the worksheet cell. This convenient feature is available for text fields
throughout the application.



Now scroll all the way to the right side of the worksheet so that you can see the revised ratings columns.
Change the revised occurrence rating (OCCr) for the first cause by double-clicking inside the
corresponding cell. Choose 3 from the drop-down list, as shown next.
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1.6 Priority Highlights



To exit “edit mode” for this field, press ALT or click somewhere else in the worksheet to accept this
change. Notice that the revised RPN (RPNr) has been recalculated automatically and has changed from
28 to 42.



If desired, you can continue to explore the worksheet view by adding and editing records. When you are
finished, proceed to the next section.

1.5.3 The Filtered View
The filtered view allows you to generate sortable lists of different types of records. For example, you can
view a list of all causes in the analysis, all actions sorted by due date, etc.


Click the Filtered tab at the bottom of the Analysis panel.



From the Filter By drop-down list at the upper right corner, choose Causes. The Analysis panel will
change to display all of the causes that have been defined in the current analysis (sorted in alphabetical
order by default).



You can sort the records by clicking any of the column headers. You can also double-click any record to
open its Properties window.



If desired, you can continue to explore the filtered view by changing the filter or sorting by different
columns. When you are finished, proceed to the next section.

1.5.4 Header for Report Output
In addition to the three complementary views of the analysis information, a fourth tab in the Analysis panel
allows you to view and edit the information that will be displayed at the top of FMEA spreadsheet reports.
This includes information such as the document number, the name of the person who created the report, the
revision date, etc.


Click the Header tab to view the details that have been entered for the steering system FMEA.



If desired, you can change any of the properties displayed in blue text. When you are finished, proceed to
the next section.

1.6 Priority Highlights
The optional Priority Highlights feature allows you to apply colored backgrounds to identify each failure
mode as high, medium or low priority based on its RPN, severity, occurrence and/or detection rating. The
priority ranges and colors can be set via the Interface Style option on the Configurable Settings tab in the
Project Properties window.


To see the settings that have been defined for the current project, choose Project > Management >
Configurable Settings > Interface Style. The settings are displayed at the bottom of the FMEA >
RPNs page.
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For this project, the priorities are based simply on RPN and are configured as follows:



To see the highlights in the steering system FMEA, first click the Hierarchy tab again then choose View
> Workspace Layout > Split Panels.

Now the system hierarchy is displayed again on the left, and the FMEA hierarchy is displayed on the
right.


Choose FMEA > Tools > Highlight Priority several times to toggle the background colors on and off
for the RPNi and RPNr columns.



When you are finished exploring this feature, proceed to the next section.

1.7 User-Defined Queries
The Query utility allows you to search the current project or the current database for the analysis records that
meet your specific query criteria. The results of the queries are returned in tabular grids that can then be
exported to Microsoft Excel or incorporated into any of the print-ready reports that you generate from the
software.


To access the Query utility, choose Home > Reporting > Queries.



The left side of the window allows you to specify which analysis data will be considered in the query.
For this example, select Active Project to consider data from the current project only. Then select all of
the items in the current project so the utility will query all three FMEAs in this project.
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1.7 User-Defined Queries



In the Query area on the right side of the window, choose FMEA Cause Actions from the drop-down
list.



You can then specify which columns you want to appear in the query results. For this example, clear the
check box at the top of the Include in Results column, then select the individual check boxes for the
following properties:





Recommended Actions



Responsibility



Planned Completion Date



Actions Taken



Action Status

For Actual Completion Date, specify that only actions that have not yet been completed will be included
in the query results by choosing is empty in the first of the Criterion 1 columns. Even though this field
will not be displayed in the results, it can still be used to filter the analysis records.
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Click Run Query. The query results will appear in the Results tab, as shown next.

You can click any column header to sort the results by that column. You also can double-click any record to
open it. If desired, you can also click the Send to Excel icon to send the query results to a spreadsheet in
Microsoft Excel.

For this example, we will save the query as a template that can be applied to any data set. This saved query
will also be included in the report that you will generate in the next step.


Click the Save Query icon.



Type Incomplete Actions for the query name, then click OK.



Close the Query utility and proceed to the next step.

1.8 Generate a Report of the Analysis
XFMEA provides a complete set of reports for your analysis. Reports can be generated in Microsoft Word®
and/or Excel, which provides maximum flexibility for customization and the ability to create HTML and/or
PDF versions of the reports.


To open the Reports window, choose Home > Reporting > Reports.



The Select Items area (on the left) allows you to specify the item(s) from the system hierarchy that will
be included in the report. Make sure that all three items are selected.



The Available Reports area (in the middle) displays the report forms that are available to be included in
the report document, while the Selected Reports area (on the right) displays the report forms that will be
included in the new report you are generating now. Click the Exclude All icon (<<) to clear the Selected
Reports area so you can start building the new report from scratch.
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1.9 Generate Charts Based on the Analysis





In the Available Reports area, press CTRL and click each of the following report forms so they are all
selected at the same time.


Under the General heading, select Report Summary.



Under the FMEA Spreadsheet heading, select J1739 (2009).



Under the FMEA Records heading, select Incomplete Actions (Queries).

Click the Select (>) icon to move all three of these report forms into the Selected Reports area.
Tip: You can also drag and drop or double-click the report form names to move them back and forth between
“available” and “selected.”



Finally, select to generate the report as a Word Document. The Reports window will look like the one
shown next.



Click Generate Report and specify a name and location for the document. When you click Save, a
progress bar will appear. After the report is complete, it will open automatically in Microsoft Word.



When you have finished viewing the report, leave it open and return to XFMEA, then close the Reports
window.

1.9 Generate Charts Based on the Analysis
XFMEA also provides a complete array of plots and charts for graphical presentation of your analysis.


To create graphical charts, choose Home > Reporting > Plots.
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In the Select Items window that appears, select to include the data associated with all three items in the
project, then click OK.



Choose RPN (Pareto) from the Plot Type drop-down list, then make the following selections:


Display Range = 1 to 5



Automatic Scaling = Selected



Auto Refresh = Selected



Keep Aspect Ratio = Selected



RPN Type = Initial

The Plot Viewer will look like the one shown next. You can hover the mouse pointer over each bar to see the
failure mode it represents.
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Drag the horizontal splitter bar to see the Plot Summary, which shows the details associated with the
current chart.
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1.10 Close the Database



Next, select Initial and Revised from the RPN Type drop-down list. If the Auto Refresh option is
selected, the display will update automatically. If not, click Redraw Plot,

.

1.9.1 Copy Plot Graphic and Summary


To add the plot to your Word document, first click the Copy Plot Graphic icon on the control panel.



Go to the report that you created in Microsoft Word and paste the graphic into the document.



Now return to XFMEA’s Plot Viewer. This time, click the Copy Plot Summary icon.



Return to the Word document, place the cursor below the chart graphic and paste the contents of the
Clipboard into the report.



Save the changes you have made to the report and close Microsoft Word, then close the Plot Viewer.

1.10 Close the Database
Congratulations! You have completed the First Steps Example for XFMEA.


To close the sample database, choose File > Close Database.

Note that if you do not close the database, it will be closed automatically when you create or open a new one.
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